חומר עזר עבור שורת הפקודה

באפשרותך להשתמש בחומר העזר עבור שורת הפקודה כדי להכיר כלים חדשים ומשופרים של שורת הפקודה, כדי לקבוע את תצורת שורת הפקודה שלך, כדי ללמוד אודות מעטפת הפקודות וכדי להפוך משימות של שורת פקודה לאוטומטיות באמצעות קבצי אצווה או כלי Scripting כגון CScript ו- WMIC.

  • לקבלת מידע אודות פונקציונליות שהשתנתה או פונקציונליות שכבר אינה זמינה ב- Windows XP, ראה דרכים חדשות לביצוע משימות מוכרות.
  • לקבלת רשימה של כלים חדשים של שורת פקודה, ראה כלים חדשים של שורת הפקודה.
  • לקבלת רשימה מלאה של כלי שורת פקודה, ראה חומר עזר עבור שורת הפקודה A-Z.
  • לקבלת סיוע במשימות ספציפיות, ראה כיצד לבצע...
  • לקבלת מידע רקע כללי, ראה מושגים.


דרכים חדשות לביצוע משימות מוכרות

Windows XP שומר ומשפר כמעט את כל הפונקציונליות של MS-DOS. הטבלאות הבאות מספקות הסברים:

  • שינויים בפונקציונליות של פקודות MS-DOS.
  • פקודות MS-DOS שאינן זמינות יותר ב- Windows XP.
  • פקודות MS-DOS שאינן זמינות יותר ב- Windows XP 64-Bit Edition.

שינויים בפקודות MS-DOS

הטבלה הבאה מפרטת שינויים שבוצעו בפונקציונליות של פקודות MS-DOS.

פקודה | תכונות שהשתנו
chcp | שינוי הקידוד עבור כל חלונות שורת הפקודה.
diskcomp | אין תמיכה באפשרויות שורת הפקודה ‎/1 ו- ‎/8.
diskperf | הפקודה אינה חייבת לפעול על מחשב שרת. באפשרותך עדיין להשתמש בפקודה diskperf עבור ניהול מרחוק.
diskcopy | אין תמיכה באפשרות שורת הפקודה ‎/1.
doskey | זמינה עבור כל התוכניות מבוססות התווים המקבלות קלט מאוחסן במאגר. הפקודה doskey עברה סידרה של שיפורים.
format | פקודה זו תומכת בכונן תקליטונים 1.44‎ MB בלבד. לא קיימת יותר תמיכה בכונן תקליטונים אופטיים (מגנטי-אופטי) 20.8‎ MB. בנוסף, לא קיימת יותר תמיכה באפשרויות שורת הפקודה ‎/b,‏ ‎/s,‏ ‎/u,‏ ‎/1,‏ ‎/4 ו- ‎/8.
label | ניתן להשתמש בסימנים תו ^ (^) ואמפרסנד (&) בתווית של אמצעי אחסון.
mode | אין תמיכה בתחבירים mode lpt n[:][cols=c][lines=n]‎ ו- mode lpt n[:][c][,[n]]‎.
print | אין תמיכה באפשרויות שורת הפקודה ‎/b,‏ ‎/c,‏ ‎/m,‏ ‎/p,‏ ‎/q,‏ ‎/s,‏ ‎/t ו- ‎/u.
prompt | צירופי תווים חדשים מאפשרים הוספה של סימני אמפרסנד (‎$a‎), סוגריים (‎$c‎ ו- ‎$f‎) ורווחים (‎$s‎) לשורת הפקודה.
recover | שחזור קבצים בלבד.
rmdir | אפשרות שורת פקודה חדשה ‎/s מוחקת ספריות המכילות קבצים וספריות משנה.
sort | אין צורך במשתנה הסביבה TEMP. גודל קובץ אינו מוגבל.
xcopy | אפשרות שורת פקודה חדשה ‎/g יוצרת קבצי יעד מפוענחים.

פקודות MS-DOS שאינן זמינות

פקודות MS-DOS הבאות אינן זמינות בשורת הפקודה.

פקודה | הליך חדש או סיבה להוצאה מכלל שימוש
assign | אינה נתמכת כעת.
backup | אינה נתמכת כעת.
choice | אינה נתמכת כעת.
ctty | אינה נתמכת כעת.
dblspace | אינה נתמכת כעת.
deltree | הפקודה rmdir /s מוחקת ספריות המכילות קבצים וספריות משנה. לקבלת מידע נוסף אודות הפקודה rmdir, ראה Rmdir.
dosshell | הפעולה היא פנימית כעת.
drvspace | אינה נתמכת כעת.
emm386 | הפעולה היא פנימית כעת.
fasthelp | אינה נתמכת כעת. השתמש בפקודה help בשורת הפקודה. לקבלת מידע נוסף אודות הפקודה help, עיין ב- Help. לקבלת רשימה מלאה של כלי שורת הפקודה, עיין בחומר עזר עבור שורת הפקודה A-Z.
fdisk | אינה נתמכת כעת. השתמש בפקודה diskpart, המאפשרת לך לנהל דיסקים, מחיצות או אמצעי אחסון. לקבלת מידע נוסף אודות הפקודה diskpart, ראה Diskpart.
include | XOX
interlnk | אינה נתמכת כעת.
intersrv | אינה נתמכת כעת.
join | הגדלת גודל המחיצות ושיפור מערכת הקבצים מבטלים את הצורך בצירוף כוננים.
memmaker | ניצול זיכרון של מערכת המשנה של MS-DOS משופר באופן אוטומטי.
menucolor | XOX
menudefault | XOX
menuitem | XOX
mirror | אינה נתמכת כעת.
msav | אינה נתמכת כעת.
msbackup | השתמש בפקודה ntbackup במחשבים בהם מותקנים כונני קלטות, או בפקודה xcopy במחשבים בהם לא מותקנים כונני קלטות. לקבלת מידע נוסף אודות הפקודה ntbackup, ראה Ntbackup. לקבלת מידע נוסף אודות הפקודה xcopy, ראה Xcopy.
mscdex | אין צורך להגדיר את מערכת המשנה MS-DOS לשימוש בכונני תקליטורים. Windows XP מספק גישה לכונני תקליטורים עבור מערכת המשנה MS-DOS.
msd | השתמש ביישום ה- Snap-in של מידע המערכת. כדי להפעיל את מידע המערכת, לחץ על התחל, לחץ על הפעלה ולאחר מכן הקלד msinfo32.
numlock | אינה נתמכת כעת.
power | אינה נתמכת כעת.
restore | אינה נתמכת כעת.
scandisk | אינה נתמכת כעת. השתמש בפקודה chkdsk, המאפשרת לך ליצור ולהציג דו"ח מצב עבור דיסק המבוסס על מערכת הקבצים. בנוסף, הפקודה Chkdsk מפרטת ומתקנת שגיאות בדיסק. לקבלת מידע נוסף אודות הפקודה chkdsk, ראה Chkdsk.
smartdrv | אחסון במטמון עבור מערכת המשנה של MS-DOS מתבצע באופן אוטומטי.
submenu | XOX
sys | Windows XP גדול מדי עבור תקליטון 1.2‎ MB או 1.44‎ MB רגיל.
undelete | אינה נתמכת כעת.
unformat | אינה נתמכת כעת.
vsafe | אינה נתמכת כעת.

פקודות MS-DOS שאינן זמינות יותר ב- Windows XP 64-Bit Edition

פקודות 16 סיביות הבאות של מערכת המשנה MS-DOS אינן זמינות ב- Windows XP 64-Bit Edition.

פקודה | פונקציה
append | מתן אפשרות לתוכניות לפתוח קבצי נתונים בתיקיות שצוינו כאילו קבצים אלה נמצאים בתיקיה הנוכחית.
debug | הפעלת Debug.exe, תוכנית בה ניתן להשתמש כדי לבחון קבצי הפעלה של MS-DOS ולאתר בהם באגים.
edit | הפעלת עורך MS-DOS, האחראי על יצירה ושינוי של קבצי טקסט מסוג ASCII.
edlin | הפעלת Edlin.exe, עורך טקסט מונחה שורות באמצעותו באפשרותך ליצור ולשנות קבצי ASCII.
exe2bin | המרה של קבצי ‎.exe (קבצי הפעלה) לתבנית בינארית.
expand | הרחבה של קובץ דחוס אחד או יותר.
fastopen | XOX
forcedos | הפעלת התוכנית המצוינת במערכת המשנה MS-DOS. פקודה זו חיונית רק עבור אותן תוכניות MS-DOS שאינן מזוהות כתוכניות MS-DOS על-ידי Windows XP.
graphics | טעינת תוכנית לזיכרון המאפשרת להדפיס במדפסת את התוכן המוצג על המסך בעת שימוש במתאם צבע או במתאם גרפיקה.
loadfix | פקודה זו מוודאת כי התוכנית נטענת מעל 64 הקילו-בתים הראשונים של הזיכרון הרגיל ולאחר מכן מפעילה את התוכנית.
loadhigh (lh) | טעינה של תוכנית לאזור הזיכרון הגבוה (UMA). טעינת תוכנית ל- UMA מותירה מקום רב יותר בזיכרון הרגיל עבור תוכניות אחרות.
mem | הצגת מידע אודות אזורי זיכרון שהוקצו, אזורי זיכרון פנויים ותוכניות הטעונות כעת בזיכרון במערכת המשנה MS-DOS.
nlsfunc | טעינת מידע ספציפי למדינה/אזור. XOX
setver | קביעת מספר הגירסה של MS-DOS המדווח לתוכנית על-ידי מערכת המשנה MS-DOS.
share | XOX


כלים חדשים של שורת הפקודה

בטבלה הבאה מפורטים כלי שורת הפקודה החדשים של Windows XP Professional.

פקודה | תכונות
bootcfg | קביעה או שינוי של הגדרות הקובץ Boot.ini או ביצוע שאילתה עליהן.
defrag | איתור ואיחוד של קבצי אתחול, קבצי נתונים ותיקיות מפוצלים באמצעי אחסון מקומיים.
diskpart | ניהול דיסקים, מחיצות או אמצעי אחסון.
driverquery | ביצוע שאילתה עבור רשימה של מנהלי התקן ומאפיינים של מנהלי התקן.
eventcreate | מתן אפשרות למנהל ליצור אירוע מותאם אישית ביומן אירועים שצוין.
eventquery | פירוט האירועים ומאפייני האירועים מיומן אירועים אחד או יותר.
eventtriggers | הצגה וקביעת תצורה של גורמים מפעילים (Triggers) של אירועים במחשבים מקומיים או מרוחקים.
fsutil | ניהול של נקודות ניתוח מבנה חוזר, ניהול קבצים דלילים, ביטול טעינה של אמצעי אחסון או הרחבת אמצעי אחסון.
getmac | השגת כתובת בקרת גישה למדיה (MAC) ורשימת פרוטוקולי רשת.
helpctr | הפעלת מרכז העזרה והתמיכה.
ipseccmd | קביעת התצורה של פריטי מדיניות אבטחת פרוטוקול אינטרנט (IPSec) בשירות הספריות או ברישום מקומי או מרוחק. Ipseccmd הוא גירסת שורת פקודה של פריטי מדיניות אבטחת IP, אחד מיישומי ה- Snap-in של Microsoft Management Console ‏(MMC).
logman | ניהול ותזמון אוספים של מוני ביצועים ויומני מעקב אחר אירועים במערכות מקומיות ומרוחקות.
openfiles | ביצוע שאילתה על קבצים פתוחים, הצגה או ניתוק שלהם.
pagefileconfig | הצגה וקביעה של הגדרות הזיכרון הווירטואלי של קובץ ההחלפה של מערכת.
perfmon | מתן אפשרות לפתוח מסוף ביצועים שהוגדר באמצעות קבצי הגדרות מגירסת צג הביצועים של Windows NT 4.0.
prncnfg | קביעת תצורה או הצגה של מידע תצורה אודות מדפסת.
prndrvr | הוספה, מחיקה ופירוט של מנהלי מדפסת משרתי הדפסה מקומיים או מרוחקים.
prnjobs | השהיה, חידוש, ביטול ופירוט של משימות הדפסה.
prnmngr | הוספה, מחיקה ופירוט של מדפסות או חיבורי מדפסות, בנוסף להגדרה והצגה של המדפסת המשמשת כברירת המחדל.
prnport | יצירה, מחיקה ופירוט של יציאות מדפסת TCP/IP רגילות, בנוסף להצגה ושינוי של תצורת יציאה.
prnqctl | הדפסת דף ניסיון, השהיה או חידוש של פעולת מדפסת וניקוי של תור מדפסת.
relog | חילוץ מוני ביצועים מתוך יומני רישום של מונה ביצועים לתוך תבניות אחרות כגון text-TSV (עבור טקסט המופרד באמצעות טאב), text-CSV (עבור טקסט המופרד באמצעות פסיק), binary-BIN או SQL.
sc | אחזור וקביעת מידע אודות שירותים. בדיקה ואיתור באגים בתוכניות שירות.
schtasks | תזמון פקודות ותוכניות לפעולה תקופתית או לפעולה במועד מסוים. הוספה והסרה של משימות מלוח הזמנים, הפעלה והפסקה של משימות לפי דרישה והצגה ושינוי של משימות מתוזמנות.
shutdown | כיבוי או הפעלה מחדש של מחשב מקומי או מרוחק.
systeminfo | ביצוע שאילתה במערכת עבור מידע תצורה בסיסי של המערכת.
taskkill | סיום משימה אחת או יותר או תהליך אחד או יותר.
tasklist | הצגת רשימה של יישומים, שירותים ושל מזהה התהליך (PID) הפועלים כעת במחשב מקומי או מרוחק.
tracerpt | עיבוד של יומני מעקב אחר אירועים או נתוני זמן-אמת מספקי מעקב אירועים מצוידים ומתן אפשרות ליצור דו"חות ניתוח מעקב וקבצי CSV (מופרדים באמצעות פסיקים) עבור האירועים שהופקו.
typeperf | כתיבת נתונים של מונה ביצועים לחלון הפקודה או לתבנית נתמכת של קובץ יומן רישום.
WMIC | הקלה על השימוש ב- Windows Management Insturmentation‏ (WMI) ובמערכות המנוהלות באמצעות WMI.


חומר עזר עבור שורת הפקודה A-Z

לשם חיפוש מידע אודות פקודה, בתפריט הלחצנים A-Z בראש העמוד, לחץ על האות שבה מתחיל שם הפקודה ולאחר מכן לחץ על שם הפקודה.

בנוסף לכלים המותקנים עם Windows XP, קיימים מעל ל- 40 כלי תמיכה הנכללים בתקליטור Windows XP. באפשרותך להשתמש בכלים אלה כדי לאבחן בעיות מחשב ולפתור אותן. לקבלת מידע נוסף אודות כלי אבחון אלה, ראה כלי התמיכה של Windows. לקבלת מידע אודות התקנת כלי תמיכה, ראה התקנת כלי התמיכה של Windows.

לקבלת מידע נוסף אודות שינויים בפונקציונליות של פקודות MS-DOS, כלי שורת פקודה חדשים, פונקציונליות של מעטפת פקודות, קביעת התצורה של שורת הפקודה והפיכת משימות של שורת פקודה לאוטומטיות, ראה חומר עזר עבור שורת הפקודה.

עבור כלים מסוימים של שורת הפקודה, על המשתמש להיות בעל הרשאות ברמת מנהל במחשבי המקור ו/או היעד.

יש להפעיל את כלי שורת הפקודה בשורת הפקודה של מתרגם הפקודות Cmd.exe. כדי לפתוח את שורת הפקודה, לחץ על התחל, לחץ על הפעלה, הקלד cmd ולאחר מכן לחץ על אישור. כדי להציג עזרה בשורת הפקודה, הקלד את הצירוף הבא בשורת הפקודה:

CommandName‎ ‎/?‎

A

Arp

Assoc

At

Atmadm

Attrib

B

Bootcfg

Break

C

Cacls

Call

Change

Chcp

Chdir

Chkdsk

Chkntfs

Cipher

Cls

Cmd

Cmstp

Color

Comp

Compact

Convert

Copy

Cprofile

CScript, מבט כולל על

D

Date

Defrag

Del

Dir

Diskcomp

Diskcopy

DiskPart

Doskey

Driverquery

E

Echo

Endlocal

Eventcreate

Eventquery

Eventtriggers

Evntcmd

Exit

Expand

F

Fc

Find

Findstr

Finger

Flattemp

For

Format

Fsutil

Ftp

Ftp, פקודות משנה

Ftype

G

Getmac

Goto

Gpresult

Gpupdate

Graftabl

H

Help

Helpctr

Hostname

I

If

Ipconfig

Ipseccmd

Ipxroute

Irftp

L

Label

Lodctr

Logman

Lpq

Lpr

M

Macfile

Mkdir‏ (md)

Mmc

Mode

More

Mountvol

Move

MS-DOS, פקודות של מערכת המשנה

Msiexec

Msinfo32

N

Nbtstat

Netsh, מבט כולל על

Netsh, פקודות עבור AAAA

Netsh, פקודות עבור DHCP

Netsh, פקודות אבחון (diag)

Netsh, פקודות עבור IP של ממשק

Netsh, פקודות עבור RAS

Netsh, פקודות עבור ניתוב

Netsh, פקודות עבור WINS

Netstat

Nslookup

Nslookup, פקודות משנה

Ntbackup

Ntcmdprompt

Ntsd

O

Openfiles

P

Pagefileconfig

Path

Pathping

Pause

Pbadmin

Pentnt

Perfmon

Ping

Popd

Print

Prncnfg

Prndrvr

Prnjobs

Prnmngr

Prnport

Prnqctl

Prompt

Pushd

Q

Query

R

Rasdial

Rcp

Recover

Reg

Regsvr32

Relog

Rem

Rename

Replace

Reset session

Rexec

Rmdir

Route

Rsh

Rsm

Runas

S

Sc

Schtasks

Secedit

Set

Setlocal

Shift

Shutdown

Sort

Start

Subst

Systeminfo

Sfc (בודק קבצי המערכת)

T

Taskkill

Tasklist

Tcmsetup

TCP/IP, כלי שירות ושירותים

Telnet, פקודות

Terminal Services, פקודות

Tftp

Time

Title

Tracerpt

Tracert

Tree

Type

Typeperf

U

Unlodctr

V

Ver

Verify

Vol

Vssadmin

W

W32tm

Winnt

Winnt32

WMIC, מבט כולל על

X

Xcopy

א

אצווה, קבצים

מ

מעטפת הפקודות, מבט כולל על

נ

ניתוב מחדש, אופרטורים

ס

סינון, פקודות

ש

שירותי Net, מבט כולל על

שירותי Net, פקודות


כיצד לבצע

גרפיקה של Microsoft Windows

כיצד לבצע...

  • קביעת תצורה של שורת הפקודה


קביעת התצורה של שורת הפקודה

גרפיקה של Microsoft Windows

לשם קביעת התצורה של שורת הפקודה

  1. פתח את שורת הפקודה.
  2. לחץ על הפינה השמאלית העליונה של חלון שורת הפקודה ולאחר מכן לחץ על מאפיינים.
  3. לחץ על הכרטיסיה אפשרויות.
  4. בתיבה היסטוריית פקודות הקלד או בחר את המספר 999 בתיבה גודל מאגר ולאחר מכן הקלד או בחר את המספר 5 בתיבה מספר מאגרים (חוצצים).
  5. בתיבה אפשרויות עריכה בחר את תיבות הסימון מצב עריכה מהירה ומצב הוספה.
  6. לחץ על הכרטיסיה פריסה.
  7. בתיבה גודל מאגר מסך הקלד או בחר את המספר 2500 בתיבה גובה.
  8. בצע אחת מהמשימות האופציונליות הבאות:
    • בתיבה גודל מאגר מסך הגדל את רוחב.
    • בתיבה גודל חלון הגדל את גובה.
    • בתיבה גודל חלון הגדל את רוחב.
    • נקה את תיבת הסימון אפשר למערכת למקם חלון ולאחר מכן שנה בתיבה מיקום חלון את הערכים של לשמאל ולמעלה.
  9. בתיבת הדו-שיח החל מאפיינים לחץ על שמור מאפיינים לחלונות עתידיים בעלי כותרת זהה.

הערות

  • XOX
  • לשם פתיחת מאפייני שורת הפקודה מלוח המקשים הקש ALT+SPACEBAR+P.
  • על-ידי בחירת תיבת הסימון מצב עריכה מהירה הפעולות העתק והדבק הופכות לזמינות מתוך חלון שורת הפקודה. כדי להעתיק, בחר בטקסט המופיע בחלון שורת הפקודה באמצעות לחצן העכבר השמאלי ולאחר מכן לחץ על לחצן העכבר הימני. כדי להדביק, לחץ על לחצן העכבר הימני בשורת הפקודה או בקובץ טקסט.
  • על-ידי הגדלת גודל מאגר המסך ל- 999, האפשרות לגלול בחלון שורת הפקודה הופכת לזמינה.
  • על-ידי הגדלת מספר המאגרים לחמישה, גדל מספר השורות בחלון שורת הפקודה ל- 5000.
  • כדי להפוך את אפשרות השלמת שם הקובץ והספריה לזמינה או לבלתי זמינה במחשב או בהפעלה של כניסת משתמש, הפעל את הקובץ Regedit.exe וקבע את הערך שלהלן עבור REG_DWORD:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor\CompletionChar\REG_DWORD

    כדי לקבוע ערך עבור REG_DWORD השתמש בערך ההקסדצימאלי של תו בקרה עבור פונקציה מסוימת (לדוגמה הערך ‎0×9 הוא TAB והערך ‎0×08 הוא BACKSPACE). הגדרות אישיות של המשתמש מקבלות קדימות על-פני הגדרות המחשב, ואפשרויות שורת פקודה מקבלות קדימות על-פני הגדרות הרישום. לקבלת מידע נוסף אודות השלמת שם קובץ וספריה, ראה נושאים קרובים.

    שים לב

    • עריכה לא נכונה של הרישום עשויה לגרום נזק חמור למערכת. לפני עריכת שינויים ברישום, מומלץ לגבות את כל הנתונים החשובים במחשב.

נושאים קרובים


מושגים

חלק זה מספק מידע אודות הפונקציונליות של מעטפת הפקודה:

  • מבט כולל על מעטפת הפקודות
  • שימוש בכלי Scripting מבוססי פקודה


מבט כולל על מעטפת הפקודות

מעטפת הפקודות (Command Shell) הינה תוכנה נפרדת, המספקת תקשורת ישירה בין המשתמש לבין מערכת ההפעלה. ממשק המשתמש הלא-גרפי של מעטפת הפקודות מספק את הסביבה שניתן להפעיל בה יישומים וכלי שירות מבוססי-תווים. מעטפת הפקודות מפעילה תוכניות ומציגה את הפלט שלהן על המסך באמצעות תווים בודדים הדומים למתרגם הפקודות של ‎MS-DOS‏, Command.com. מעטפת הפקודות של Windows XP משתמשת במתרגם הפקודות Cmd.exe, שטוען יישומים ומכוון את זרימת המידע בין יישומים לשם תרגום קלט של המשתמש לצורה המובנת למערכת ההפעלה.

באפשרותך להשתמש במעטפת הפקודות ליצירת ועריכת קבצי אצווה (המכונים גם בשם קבצי Script) לשם הפיכת הביצוע של משימות שגרתיות לאוטומטית. לדוגמה, באפשרותך להשתמש בקבצי Script כדי להפוך לאוטומטי את הניהול של חשבונות משתמשים או של גיבויים ליליים. באפשרותך גם להשתמש ב- Windows Script Host, ‏CScript.exe, להרצת קבצי Script מתוחכמים יותר במעטפת הפקודות. באפשרותך לבצע פעולות באופן יעיל יותר באמצעות קבצי אצווה יותר מאשר באמצעות ממשק המשתמש. קבצי אצווה מקבלים את כל הפקודות הזמינות בשורת הפקודה. למידע נוסף אודות קבצי אצווה וכתיבת קבצי Script, ראה שימוש בקבצי אצווה.

באפשרותך להתאים אישית את חלון שורת הפקודה לתצוגה נוחה יותר ולהגדיל את השליטה על האופן שבו באפשרותך להריץ תוכניות. למידע נוסף אודות התאמה אישית של חלון שורת הפקודה, ראה לשם קביעת התצורה של שורת הפקודה.

שימוש בתחביר הפקודות

התחביר מופיע בסדר שבו עליך להקליד פקודה ואת כל הפרמטרים הבאים אחריה. הדוגמה הבאה של הפקודה xcopy מדגימה מגוון תבניות תחביריות של טקסט:

xcopy Source [Destination]‎ [‎/w] [‎/p] [‎/c] [‎/v] [‎/q] [‎/f] [‎/l] [‎/g] [‎/d[:mm-dd-yyyy]‎] [‎/u] [‎/i] [‎/s [/e]‎] [‎/t] [‎/k] [‎/r] [‎/h] [{‎/a|/m}] [‎/n] [‎/o] [‎/x] [‎/exclude:file1[+[file2]][+[file3]] [{‎/y|/-y}] [‎/z]

הטבלה הבאה מסבירה כיצד לפרש את תבניות הטקסט השונות.

XOX

השימוש בפקודות מרובות ובסימני עיבוד מותנה

באפשרותך להריץ פקודות מרובות משורת פקודה אחת או מקובץ Script אחד באמצעות סימני עיבוד מותנה. בעת ההרצה של פקודות מרובות בעלות סימני עיבוד מותנה, הפקודות המופיעות לימין סימן העיבוד המותנה פועלות על-פי תוצאות הפקודה המופיעה לשמאל סימן העיבוד המותנה. לדוגמה, ייתכן שתרצה להריץ פקודה רק אם הפקודה הקודמת נכשלת או להריץ פקודה רק אם הפקודה הקודמת מצליחה.

באפשרותך להשתמש בתווים המיוחדים המוצגים בטבלה הבאה לשם העברה של פקודות מרובות.

תו | תחביר | הגדרה
‎&‎[...]‎ | command1 & command2 | משמש להפרדת פקודות מרובות בשורת פקודה אחת. היישום Cmd.exe מריץ את הפקודה הראשונה, ולאחר מכן את הפקודה השניה.
‎&& [...]‎ | command1 && command2 | משמש להרצת הפקודה המופיעה לאחר הסימן && רק אם הפקודה שלפני הסימן מסתיימת בהצלחה. היישום Cmd.exe מריץ את הפקודה הראשונה ולאחר מכן את השנייה, אך רק אם הפקודה הראשונה בוצעה בהצלחה.
‎|| [...]‎ | command1 || command2 | משמש להרצת הפקודה המופיעה לאחר הסימן || רק אם הפקודה המופיעה לפני הסימן || נכשלת. היישום Cmd.exe מריץ את הפקודה הראשונה ולאחר מכן את השנייה, אך רק אם הפקודה הראשונה לא הסתיימה בהצלחה (התקבל קוד שגיאה הגדול מאפס).
‎( ) [...]‎ | (command1 & command2) | משמש לקיבוץ או לקינון של פקודות מרובות.
; או , | command1 parameter1;parameter2 | משמש להפרדה בין פרמטרים של פקודה.

הערות

  • תו האמפרסנד (&), תו ה- Pipe (|) והסוגריים ( ) הינם תווים מיוחדים. אם ברצונך להעבירם כארגומנטים, עליך להוסיף לפניהם תו Escape ‏(^) או מרכאות.
  • אם פקודה מסיימת פעולה בהצלחה, היא מחזירה קוד יציאה של אפס (0) או אינה מחזירה כל קוד יציאה שהוא. למידע נוסף אודות קודי יציאה, ראה Microsoft Windows Resource Kits.

קינון מעטפות של פקודות

באפשרותך לקנן מעטפות של פקודות בתוך היישום Cmd.exe על-ידי פתיחת מופע חדש של היישום Cmd.exe בשורת הפקודה. כברירת המחדל, כל מופע של היישום Cmd.exe יורש את הסביבה של יישום Cmd.exe ששימש כיישום אב שלו. על-ידי קינון מופעים של Cmd.exe, באפשרותך לערוך שינויים בסביבה המקומית מבלי להשפיע על יישום האב של Cmd.exe. דבר זה מאפשר לשמר את הסביבה המקורית של היישום Cmd.exe ולחזור אליה לאחר סיום מעטפת הפקודות המקוננת. השינויים שתבצע במעטפת הפקודות המקוננת לא יישמרו.

כדי לקנן מעטפת פקודות, הקלד בשורת הפקודה:

cmd

ההודעה שתופיע תהיה דומה להודעה הבאה:

Microsoft (R‎) Windows XP (TM‎)‎
‎(C) Copyright 1985-2001 Microsoft Corp.‎

כדי לסגור את מעטפת הפקודות המקוננת, הקלד exit.

באפשרותך לבצע שינויים באופן ממוקד-מקומית עוד יותר במופע של Cmd.exe (או בקובץ Script) באמצעות הפקודות setlocal ו- endlocal. הפקודה Setlocal יוצרת טווח מקומי, והפקודה endlocal מסיימת את הטווח המקומי. כל שינוי שמתבצע בתוך הטווח של הפקודות setlocal ו- endlocal נמחק, ומותיר את הסביבה המקורית ללא כל שינוי. באפשרותך לקנן את שתי הפקודות הללו עד מקסימום של 32 רמות. לקבלת מידע נוסף אודות הפקודות setlocal ו- endlocal, ראה Setlocal ו- Endlocal.

שימוש במשתני סביבה עם היישום Cmd.exe

סביבת מעטפת הפקודות של היישום Cmd.exe מוגדרת באמצעות משתנים הקובעים את אופן הפעולה של מעטפת הפקודות ושל מערכת ההפעלה. באפשרותך להגדיר את אופן הפעולה של סביבת מעטפת הפקודות או של סביבת מערכת ההפעלה כולה באמצעות שני סוגים של משתני סביבה: משתני מערכת ומשתנים מקומיים. משתני סביבה של המערכת מגדירים את אופן הפעולה של הסביבה הכוללת של מערכת ההפעלה. משתני הסביבה המקומיים מגדירים את ההתנהגות של סביבת המופע העכשווי של היישום Cmd.exe.

משתני הסביבה של המערכת מוגדרים מראש במערכת ההפעלה וזמינים עבור כל תהליכי Windows XP. רק למשתמשים בעלי הרשאות של מנהל מערכת יש אפשרות לשנות את משתני המערכת. משתנים אלה נמצאים בשימוש בעיקר בקבצי Script המשמשים עבור כניסה.

משתני מערכת מקומיים זמינים רק כאשר המשתמש שעבורו הם נוצרו נכנס למחשב. משתנים מקומיים המוגדרים בכוורת HKEY_CURRENT_USER תקפים רק עבור המשתמש הנוכחי, אך מגדירים את אופן הפעולה של הסביבה הכוללת של מערכת ההפעלה.

הרשימה הבאה מתארת את הסוגים השונים של המשתנים בסדר יורד של קדימות:

  1. משתני מערכת מוכללים
  2. משתני מערכת הנמצאים בכוורת HKEY_LOCAL_MACHINE
  3. משתנים מקומיים הנמצאים בכוורת HKEY_CURRENT_USER
  4. כל משתני הסביבה והנתיבים המוגדרים בקובץ Autoexec.bat
  5. כל משתני הסביבה והנתיבים המוגדרים בקובץ Script לכניסה (אם קיימים)
  6. המשתנים שנעשה בהם שימוש אינטראקטיבי בקובץ Script או בקובץ אצווה

במעטפת הפקודות, כל מופע של Cmd.exe יורש את הסביבה של יישום האב שלו. לפיכך, באפשרותך לשנות את המשתנים בסביבה של יישום Cmd.exe החדש מבלי להשפיע על הסביבה של יישום האב.

הטבלה הבאה מפרטת את משתני המערכת ואת המשתנים המקומיים עבור Windows XP.

משתנה | סוג | תיאור
‎%ALLUSERSPROFILE%‎ | מקומי | מחזיר את המיקום של הפרופיל עבור כל המשתמשים (All Users Profile).
‎%APPDATA%‎ | מקומי | מחזיר את המיקום שבו מאחסנים היישומים מידע כברירת מחדל.
‎%CD%‎ | מקומי | מחזיר את מחרוזת הספריה הנוכחית.
‎%CMDCMDLINE%‎ | מקומי | מחזיר את שורת הפקודה המדוייקת ששימשה להפעלת יישום Cmd.exe הנוכחי.
‎%CMDEXTVERSION%‎ | מערכת | מחזיר את מספר הגירסה של Command Processor Extensions שבשימוש כעת.
‎%COMPUTERNAME%‎ | מערכת | מחזיר את שם המחשב.
‎%COMSPEC%‎ | מערכת | מחזיר את הנתיב המדויק לקובץ ההפעלה של מעטפת הפקודות.
‎%DATE%‎ | מערכת | מחזיר את התאריך הנוכחי. משתמש באותה תבנית של הפקודה date /t. נוצר באמצעות היישום Cmd.exe. למידע נוסף אודות הפקודה date, ראה Date.
‎%ERRORLEVEL%‎ | מערכת | מחזיר את קוד השגיאה של הפקודה האחרונה שנעשה בה שימוש. ערך השונה מאפס מציין בדרך כלל שגיאה.
‎%HOMEDRIVE%‎ | מערכת | מחזיר את אות הכונן של תחנת העבודה המקומית המקושרת לספריה הראשית של המשתמש. ההגדרה מבוססת על הערך של הספריה הראשית. הספריה הראשית של המשתמש מצוינת ביישום משתמשים וקבוצות מקומיים.
‎%HOMEPATH%‎ | מערכת | מחזיר את הנתיב המלא של הספריה הראשית של המשתמש. ההגדרה מבוססת על הערך של הספריה הראשית. הספריה הראשית של מצוינת ביישום משתמשים וקבוצות מקומיים.
‎%HOMESHARE%‎ | מערכת | מחזיר את נתיב הרשת לספריה הראשית המשותפת של המשתמש. ההגדרה מבוססת על הערך של הספריה הראשית. הספריה הראשית של המשתמש מצוינת ביישום משתמשים וקבוצות מקומיים.
‎%LOGONSEVER%‎ | מקומי | מחזיר את שם בקר קבוצת המחשבים שבדק חוקיותה של הפעלת הכניסה הנוכחית.
‎%NUMBER_OF_PROCESSORS%‎ | מערכת | מציין את מספר המעבדים שהותקנו במחשב.
‎%OS%‎ | מערכת | מחזיר את שם מערכת ההפעלה. מערכת ההפעלה Windows 2000 מציגה את שם מערכת ההפעלה Windows_NT.
‎%PATH%‎ | מערכת | מציין את נתיב החיפוש עבור קבצי הפעלה.
‎%PATHEXT%‎ | מערכת | מחזיר רשימה של סיומות הקבצים, שנחשבים על-ידי מערכת ההפעלה כניתנים להפעלה.
‎%PROCESSOR_ARCHITECTURE%‎ | מערכת | מחזיר את ארכיטקטורת השבב של המעבד. ערכים: x86, ‏IA64.
‎%PROCESSOR_IDENTFIER%‎ | מערכת | מחזיר תיאור של המעבד.
‎%PROCESSOR_LEVEL%‎ | מערכת | מחזיר את מספר הדגם של המעבד המותקן במחשב.
‎%PROCESSOR_REVISION%‎ | מערכת | מחזיר את מספר התיקון של המעבד.
‎%PROMPT%‎ | מקומי | מחזיר את הגדרות שורת הפקודה עבור המתרגם הנוכחי. נוצר באמצעות היישום Cmd.exe.
‎%RANDOM%‎ | מערכת | מחזיר ערך עשרוני אקראי בין 0 ל- 32767. נוצר באמצעות היישום Cmd.exe.
‎%SYSTEMDRIVE%‎ | מערכת | מחזיר את הכונן המכיל את ספריית הבסיס של Windows XP(כלומר, בסיס המערכת).
‎%SYSTEMROOT%‎ | מערכת | מחזיר את המיקום של ספריית הבסיס של Windows XP.
‎%TEMP%‎ ו- ‎%TMP%‎ | מערכת ומשתמש | מחזיר את הספריות הזמניות המהוות ברירת מחדל ומשמשות את היישומים הזמינים למשתמשים המחוברים כעת. חלק מהיישומים מחייבים שימוש ב- TEMP, ואחרים ב- TMP.
‎%TIME% | מערכת | מחזיר את השעה הנוכחית. משתמש באותה תבנית של הפקודה time /t. נוצר באמצעות היישום Cmd.exe. למידע נוסף אודות הפקודה time, ראה Time.
‎%USERDOMAIN%‎ | מקומי | מחזיר את שם קבוצת המחשבים המכילה את החשבון של המשתמש.
‎%USERNAME%‎ | מקומי | מחזיר את שם המשתמש המחובר כעת.
‎%USERPROFILE%‎ | מקומי | מחזיר את מיקום הפרופיל עבור המשתמש הנוכחי.
‎%WINDIR%‎ | מערכת | מחזיר את המיקום של ספריית מערכת ההפעלה.

הגדרת משתני סביבה

משתמש בפקודה set כדי ליצור, לשנות, למחוק או להציג משתני סביבה. הפקודה set משנה את המשתנים בסביבת המעטפת הנוכחית בלבד.

להצגת משתנה, הקלד בשורת הפקודה :

set VariableName

להוספת משתנה, הקלד בשורת הפקודה :

set variablename=value

למחיקת משתנה, הקלד בשורת הפקודה:

set VariableName=‎

באפשרותך להשתמש ברוב התווים כערכי משתנים, כולל רווחים לבנים. בעת השימוש בתווים המיוחדים <, >, |, & או ^, יש להזין לפניהם את התו Escape ‏(^) או מרכאות. בעת שימוש במרכאות, הן ייכללו כחלק מהערך, מאחר שכל מה שמופיע לאחר סימן השוויון (=) נחשב ערך. בחן את הדוגמאות שלהלן:

  • ליצירת ערך המשתנה new&name, הקלד:

    set varname=new^&name

  • ליצירת ערך המשתנה "new&name", הקלד:

    set varname="new&name"‎

  • אם תקליד set varname=new&name בשורת הפקודה, תופיע הודעת שגיאה הדומה להודעה שלהלן:
    ‎"'name' is not recognized as an internal or external command, operable program or batch file."‎

שמות משתנים אינם תלויי רישיות. אולם, הפקודה set מציגה את המשתנה בדיוק כפי שהקלדת אותו. באפשרותך לשלב אותיות גדולות וקטנות בשמות המשתנים כדי להפוך את הקוד שלך לקריא יותר (לדוגמה, המשתנה UserName).

הערות

  • הגודל המקסימלי של משתנה סביבה אחד הוא 8192 בתים.
  • הגודל המקסימלי הכולל של משתנה סביבה עבור כל המשתנים, גודל הכולל את שמות המשתנים ואת סימן השוויון, הוא 65,536 קילו-בתים (KB).

המרת ערכים של משתני סביבה

כדי לאפשר את המרת ערכי המשתנים בשורה הפקודה או בקבצי Script, תחום את שם המשתנה בין סימני אחוזים (כלומר, ‎%variablename%‎). שימוש בסימני האחוזים מבטיח שהיישום Cmd.exe יפנה לערכי המשתנים במקום לבצע השוואה מילולית. לאחר הגדרת ערכי המשתנים עבור שם משתנה, תחום את שם המשתנה בין סימני אחוזים. היישום Cmd.exe יחפש את כל המופעים של שם המשתנה וימיר אותם בערך המשתנה המוגדר. לדוגמה, אם תיצור קובץ Script שיכיל ערכים שונים (לדוגמה, שמות משתמשים) ותרצה להגדיר את משתנה הסביבה USERNAME עבור כל משתמש עם ערכים אלה, תוכל לכתוב קובץ Script אחד שישתמש במשתנה USERNAME התחום בין סימני אחוזים. בעת ההרצה של קובץ Script זה, היישום Cmd.exe ימיר את המשתנה ‎%USERNAME%‎ בערכי משתנים, דבר שיחסוך את הצורך לבצע משימה זו באופן ידני עבור כל משתמש. המרת המשתנים אינה רקורסיבית. היישום Cmd.exe בודק משתנים פעם אחת. למידע נוסף אודות המרת משתנים, ראה For ו- Call.


שימוש בכלי Scripting מבוססי פקודה

גרפיקה של Microsoft Windows

הפיכת משימות שורת פקודה לאוטומטיות

סעיף זה מספק מידע אודות הכלים השונים הזמינים עבור הפיכת משימות שורת פקודה לאוטומטיות:

  • שימוש בקבצי אצווה
  • שימוש במארח קובץ Script מבוסס-פקודה (CScript.exe)
  • שימוש ב- Netsh
  • שימוש בכלי Windows Management Instrumentation Command-line‏ (WMIC)


קבצי אצווה

גרפיקה של Microsoft Windows

שימוש בקבצי אצווה

קבצי אצווה, הנקראים גם תוכניות אצווה או קבצי Script, מאפשרים לך לפשט משימות שגרתיות או משימות החוזרות על עצמן. קובץ אצווה הוא קובץ טקסט לא מעוצב המכיל פקודה אחת או יותר, בעל סיומת ‎.bat או ‎.cmd בעת הקלדת שם הקובץ בשורת הפקודה, הקובץ Cmd.exe מפעיל את הפקודות ברצף לפי הסדר בו הן מופיעות בקובץ.

באפשרותך לכלול כל פקודה בקובץ אצווה. פקודות מסוימות, כגון for‏, goto‏, ו- if מאפשרות עיבוד מותנה של הפקודות בקובץ האצווה. לדוגמה, הפקודה if מבצעת פקודה בהתאם לתוצאות של תנאי. פקודות אחרות מאפשרות שליטה על קלט ופלט וקריאה לקבצי אצווה אחרים.

קודי השגיאה הסטנדרטיים אותם מחזירים רוב היישומים הם 0 במקרה שלא אירעה שגיאה ו- 1 (או ערך גבוה יותר) אם אירעה שגיאה. נא עיין בעזרה של היישום כדי לקבוע את משמעותם של קודי שגיאה ספציפיים.

לקבלת מידע נוסף אודות פעולות קבצי אצווה, ראה את הנושאים הבאים:

  • שימוש בפרמטרי אצווה
  • שימוש במסננים
  • שימוש באופרטורים לניתוב מחדש בפקודה

לקבלת מידע נוסף אודות פקודות שבהן באפשרותך להשתמש בקבצי אצווה, לחץ על פקודה:

  • Call
  • Echo
  • Endlocal
  • For
  • Goto
  • If
  • Pause
  • Rem
  • Setlocal
  • Shift


שימוש בפרמטרי אצווה

באפשרותך להשתמש בפרמטרי אצווה בכל מקום בתוך קובץ אצווה לשם השגת מידע אודות הגדרות הסביבה.

היישום Cmd.exe מספק את משתני ההרחבה ‎%0 עד ‎%9 של פרמטרי האצווה. בעת השימוש בפרמטרי אצווה בקובץ אצווה, %0 מוחלף בשם קובץ האצווה, ו- %1 עד %9 מוחלפים בארגומנטים המקבילים המוקלדים בשורת הפקודה. כדי לגשת לארגומנטים שמעבר ל- %9, עליך להשתמש בפקודה shift. למידע נוסף אודות הפקודה shift, ראה Shift. משתנה האצווה ‎%*‎ הינו הפניה של תו כללי לכל הארגומנטים, להוציא %0, שמועברים לקובץ האצווה.

לדוגמה, להעתקת התוכן מ- Folder1 ל- Folder2, כאשר %1 מוחלף בערך Folder1 ו- %2 מוחלף בערך Folder2, הקלד את הפקודה הבאה בקובץ אצווה בשם Mybatch.bat:

xcopy %1\*.* %2

להפעלת הקובץ, הקלד:

mybatch.bat C:\afolder D:\bfolder.

באותה מידה, ניתן גם להקליד את הפקודה הבאה בקובץ האצווה:

xcopy C:\folder1 \*.* D:\folder2

ניתן גם להשתמש ברכיבי החלפה (Modifiers) עם פרמטרי אצווה. רכיבי החלפה משתמשים במידע של הכונן והספריה הנוכחיים להרחבת פרמטר האצווה כשם חלקי או מלא או של קובץ או של ספריה. לשימוש ברכיב החלפה, הקלד את התו אחוז (%) ולאחריו את התו טילדה (~), ולאחר מכן הקלד את הביטוי רכיב ההחלפה המתאים (כלומר, ‎%~‎modifier).

הטבלה הבאה מציגה את רכיבי ההחלפה שניתן להשתמש בהם עבור הרחבה.

רכיב החלפה | תיאור
‎%~1 | מרחיב את %1 ומסיר את המרכאות המקיפות ("").
‎%~f1 | מרחיב את %1 לשם נתיב מלא.
‎%~d1 | מרחיב את %1 לאות כונן.
‎%~p1 | מרחיב את %1 לנתיב.
‎%~n1 | מרחיב את %1 לשם קובץ.
‎%~x1 | מרחיב את %1 לסיומת קובץ.
‎%~s1 | הנתיב המורחב מכיל שמות קצרים בלבד.
‎%~a1 | מרחיב את %1 לתכונות קובץ.
‎%~t1 | מרחיב את %1 לתאריך ושעה של קובץ.
‎%~z1 | מרחיב את %1 לגודל של קובץ.
‎%~$PATH:1 | מבצע חיפוש בספריות המפורטות במשתנה הסביבה PATH ומרחיב את %1 לשם המלא של הספריה הראשונה שנמצאה. אם שם משתנה הסביבה אינו מוגדר או אם החיפוש אחר הקובץ נכשל, רכיב החלפה זה מורחב למחרוזת ריקה.

הטבלה הבאה מפרטת צירופים אפשריים של רכיבי החלפה ושל צירופים שניתן להשתמש בהם לקבלת תוצאות מורכבות.

רכיב החלפה | תיאור
‎%~dp1 | מרחיב את %1 לאות כונן ולנתיב.
‎%~nx1 | מרחיב את %1 לשם קובץ ולסיומת.
‎%~dp$PATH:1 | מחפש את %1 בספריות המפורטות במשתנה הסביבה PATH ומרחיב לאות הכונן ולנתיב של הספריה הראשונה שנמצאה.
‎%~ftza1 | מרחיב את %1 לשורת פלט מסוג dir.

הערה

  • בדוגמאות הקודמות, ניתן להמיר את %1 ואת PATH בערכי פרמטרי אצווה אחרים.

רכיב ההחלפה ‎%*‎ הוא ייחודי, ומייצג את כל הארגומנטים המועברים בקובץ אצווה. לא ניתן להשתמש ברכיב החלפה זה עם רכיב ההחלפה ‎%~‎. את התחביר ‎%~‎ יש לסיים בערך ארגומנט חוקי.

לא ניתן לטפל בפרמטרי אצווה באותו אופן שבו ניתן לטפל במשתני סביבה. לא ניתן לחפש ולהמיר ערכים או לבדוק מחרוזות משנה. עם זאת, ניתן להקצות את הפרמטר למשתנה סביבה ולטפל במשתנה הסביבה לאחר מכן.


שימוש במסננים

בשימוש עם תו | המשמש לניתוב מחדש של פקודה, מסנן פקודה הוא פקודה בתוך פקודה הקוראת את קלט הפקודה, משנה אותו ולאחר מכן כותבת את הפלט. פקודות סינון מסייעות במיון, בהצגה ובבחירה של חלקים מתוך פלט של פקודה.

פקודות סינון מבצעות חלוקה, ארגון מחדש או חילוץ של חלקים מהמידע העובר דרכן. הטבלה הבאה מפרטת את פקודות הסינון הזמינות ב- Windows XP.

פקודה | תיאור
more | הצגת תוכן הקובץ או פלט הפקודה בחלון אחד של שורת הפקודה בכל פעם.
find | חיפוש בקבצים ובפלט פקודה אחר התווים שתציין.
sort | סידור קבצים ופלט פקודה בסדר אלפביתי.

כדי לשלוח קלט מקובץ לפקודת סינון, השתמש בסימן קטן מ- (‎<‎). אם ברצונך שפקודת הסינון תקבל את הקלט מפקודה אחרת, השתמש בתו |.

שימוש בפקודה more

הפקודה more מציגה את תוכן הקובץ או את פלט הפקודה בחלון אחד של שורת הפקודה בכל פעם. לדוגמה, כדי להציג את תוכן הקובץ List.txt בחלון שורת פקודה אחד בכל פעם, הקלד:

more < list.txt

מופיע חלון אחד של שורת פקודה המכיל מידע ולאחריו מופיעה ההודעה -- More -- בתחתית חלון שורת הפקודה. כדי להמשיך לחלון שורת הפקודה הבא, הקש על מקש כלשהו בלוח המקשים מלבד PAUSE. כדי להפסיק את פעולת הפקודה מבלי להציג מידע נוסף, הקש CTRL+C.

באפשרותך להשתמש בפקודה more כאשר אתה עובד עם פקודה המפיקה יותר מחלון שורת פקודה אחד של פלט. לדוגמה, נניח שברצונך להציג עץ ספריות של הכונן הקשיח. אם קיימות יותר ספריות ממה שניתן להציג בחלון אחד של שורת הפקודה, באפשרותך להשתמש בפקודה tree עם תו | ועם הפקודה more כמתואר להלן:

tree c:\ | more

מופיע מסך שורת הפקודה הראשון של פלט מהפקודה tree ואחריו ההודעה -- More -- . הפלט נעצר עד שתקיש על מקש כלשהו מלבד מקש PAUSE.

שימוש בפקודה find

הפקודה find מחפשת בקבצים אחר המחרוזת או הטקסט שציינת. התוכנית Cmd.exe מציגה כל שורה התואמת למחרוזת או לטקסט שצוין בחלון שורת הפקודה. באפשרותך להשתמש בפקודה find כפקודת מסנן או כפקודה רגילה של Windows XP. לקבלת מידע נוסף אודות השימוש ב- find כפקודה רגילה, ראה Find.

כדי להשתמש ב- find כפקודת מסנן, עליך לכלול סימן קטן מ- (‎<‎) ואת המחרוזת או הטקסט שברצונך לחפש. כברירת מחדל, חיפושים המתבצעים באמצעות הפקודה find הם תלויי רישיות. לדוגמה, הפקודה הבאה מחפשת אחר מופעים של המחרוזת "Pacific Rim" בקובץ Trade.txt:

find "Pacific Rim" < trade.txt

הפלט אינו כולל מופעים של "pacific rim". הוא כולל מופעים של הביטוי המופיע באותיות רישיות בלבד ("Pacific Rim").

כדי לשמור את הפלט של הפקודה find במקום להציג אותו בחלון שורת הפקודה, השתמש בסימן גדול מ- (‎>‎) ובשם הקובץ בו ברצונך לאחסן את הפלט. לדוגמה, הפקודה הבאה מחפשת אחר מופעים של "Pacific Rim" בקובץ Trade.txt ושומרת אותם בקובץ Nwtrade.txt:

find "Pacific Rim" < trade.txt > nwtrade.txt

שימוש בפקודה sort

הפקודה sort מסדרת קובץ טקסט או פלט של פקודה לפי סדר אלפביתי. לדוגמה, הפקודה הבאה ממיינת את התוכן של הקובץ List.txt ומציגה את התוצאות בחלון שורת הפקודה:

sort < list.txt

בדוגמה זו, הפקודה sort ממיינת את השורות בקובץ List.txt ברשימה אלפביתית ומציגה את התוצאות מבלי לשנות את הקובץ. כדי לשמור את הפלט של הפקודה sort במקום להציג את הפלט, כלול סימן גדול מ- (‎>‎) ושם קובץ בפקודה. לדוגמה, הפקודה הבאה מסדרת את השורות בקובץ List.txt לפי סדר אלפביתי ומאחסנת את התוצאות בקובץ Alphlist.txt:

sort < list.txt > alphlist.txt

כדי למיין פלט של פקודה, הקלד את הפקודה, הקלד תו | ולאחר מכן הקלד sort (כלומר, command | sort). לדוגמה, הפקודה הבאה ממיינת את השורות הכוללות את המחרוזת "Jones" (כלומר, פלט הפקודה find) בסדר אלפביתי:

find "Jones" maillst.txt | sort


שימוש באופרטורים עבור ניתוב מחדש של פקודה

באפשרותך להשתמש באופרטורים של ניתוב מחדש כדי לנתב מחדש זרמי פלט וקלט של פקודה ממיקומי ברירת המחדל למיקומים שונים. מיקום זרם הפלט או הקלט נקרא מזהה ייחודי (Handle).

הטבלה הבאה מפרטת אופרטורים שניתן להשתמש בהם כדי לנתב מחדש זרמי קלט ופלט של פקודה.

אופרטור ניתוב מחדש | תיאור
< | כותב את פלט הפקודה לקובץ או להתקן, כגון מדפסת, במקום לחלון שורת הפקודה.
> | קורא את קלט הפקודה מקובץ במקום לקרוא קלט מלוח המקשים.
<< | מצרף את פלט הפקודה לסוף קובץ מבלי למחוק את המידע הקיים בקובץ.
&< | כותב את הפלט ממזהה ייחודי אחד לקלט של מזהה ייחודי אחר.
&> | קורא את הקלט ממזהה ייחודי אחד וכותב אותו לפלט של מזהה ייחודי אחר.
| | קורא את הפלט מפקודה אחת וכותב אותו לקלט של פקודה אחרת. ידוע גם כרכיב Pipe.

כברירת מחדל, קלט הפקודה (כלומר המזהה הייחודי STDIN) נשלח מלוח המקשים אל התוכנית Cmd.exe ולאחר מכן היישום Cmd.exe שולח את פלט הפקודה (כלומר המזהה הייחודי STDOUT) לחלון שורת הפקודה.

הטבלה הבאה מפרטת את המזהים הייחודיים הזמינים.

מזהה ייחודי (Handle) | שווה ערך מספרי של המזהה הייחודי | תיאור
STDIN | 0 | קלט מלוח המקשים
STDOUT | 1 | פלט לחלון שורת הפקודה
STDERR | 2 | פלט שגיאה לחלון שורת הפקודה
UNDEFINED | ‎3-9 | מזהים ייחודיים אלה מוגדרים באופן אינדווידואלי על-ידי היישום והם ספציפיים עבור כל כלי.

המספרים אפס עד תשע (כלומר ‎0-9) מייצגים את 10 המזהים הייחודיים הראשונים. באפשרותך להשתמש ב- Cmd.exe כדי להפעיל תוכנית ולנתב מחדש כל אחד מ- 10 המזהים הייחודיים הראשונים עבור התוכנית. כדי לציין את המזהה הייחודי בו ברצונך להשתמש, הקלד את מספר המזהה הייחודי לפני אופרטור הניתוב מחדש. אם אינך מגדיר מזהה ייחודי, אופרטור הניתוב מחדש עבור קלט המשמש כברירת מחדל > הוא אפס (0) ואופרטור הניתוב מחדש עבור פלט המוגדר כברירת מחדל < הוא אחד (1). לאחר שהקלדת את האופרטור < או >, עליך לציין היכן ברצונך לקרוא או לכתוב את הנתונים. באפשרותך לציין שם קובץ או מזהה ייחודי אחר קיים.

כדי לציין ניתוב מחדש למזהים ייחודיים קיימים, השתמש בתו אמפרסנד (&) ולאחריו מספר המזהה הייחודי שברצונך לנתב מחדש (כלומר ‎&handle#‎). לדוגמה, הפקודה הבאה מנתבת מחדש את המזהה הייחודי 2 (כלומר STDERR) למזהה הייחודי 1 (כלומר STDOUT):

‎1<&2

שכפול מזהים ייחודיים

אופרטור הניתוב מחדש & משכפל פלט או קלט ממזהה ייחודי אחד שצוין למזהה ייחודי אחר שצוין. לדוגמה, כדי לשלוח פלט של הפקודה dir לקובץ File.txt ולשלוח את פלט השגיאה לקובץ File.txt, הקלד:

dir>c:\file.txt 2>&1

בעת שכפול מזהה ייחודי, אתה משכפל את כל מאפייני המופע המקורי של המזהה הייחודי. לדוגמה, אם למזהה ייחודי גישה לכתיבה בלבד, כל ההעתקים של מזהה ייחודי זה יהיו בעלי המאפיין. לא ניתן לשכפל מזהה ייחודי עם גישת קריאה בלבד לתוך מזהה ייחודי עם גישת כתיבה בלבד.

ניתוב מחדש של קלט פקודה (>)

כדי לנתב מחדש קלט פקודה מלוח המקשים לקובץ או להתקן, השתמש באופרטור >. לדוגמה, כדי לקבל את קלט הפקודה עבור הפקודה sort מהקובץ File.txt:

sort<file.txt

תוכן הקובץ File.txt יופיע בחלון שורת הפקודה כרשימה בסדר אלפביתי.

האופרטור > פותח את הקובץ שצוין עם גישה לקריאה בלבד. כתוצאה, אין באפשרותך לכתוב לקובץ כאשר אתה משתמש באופרטור זה. לדוגמה, אם אתה מפעיל תוכנית עם האופרטור ‎<&2, כל הנסיונות לקרוא את המזהה הייחודי 0 ייכשלו שכן המזהה הייחודי 2 נפתח בתחילה עם גישה לכתיבה בלבד.

הערה

  • אפס הוא המזהה הייחודי המוגדר כברירת מחדל עבור אופרטור הקלט > המשמש לניתוב מחדש.

ניתוב מחדש של פלט פקודה (<)

כמעט כל הפקודות שולחות פלט לחלון שורת הפקודה. אפילו פקודות השולחות פלט לכונן או למדפסת מציגות הודעות ושאלות בחלון שורת הפקודה.

כדי לנתב מחדש פלט פקודה מחלון שורת הפקודה לקובץ או להתקן, השתמש באופרטור <. באפשרותך להשתמש באופרטור זה עם רוב הפקודות. לדוגמה, כדי לנתב מחדש פלט של הפקודה dir לקובץ Dirlist.txt:

dir>dirlist.txt

אם הקובץ Dirlist.txt אינו קיים, היישום Cmd.exe יוצר אותו. אם הקובץ Dirlist.txt קיים, היישום Cmd.exe מחליף את המידע הקיים בקובץ בפלט של הפקודה dir.

כדי להפעיל את הפקודה netsh routing dump ולאחר מכן לשלוח את פלט הפקודה לקובץ Route.cfg, הקלד:

netsh routing dump>c:\route.cfg

האופרטור < פותח את הקובץ שצוין עם גישה לכתיבה בלבד. כתוצאה, אין באפשרותך לקרוא את הקובץ בעת שימוש באופרטור זה. לדוגמה, אם תפעיל תוכנית עם ניתוב מחדש באמצעות האופרטור ‎>&0, כל הנסיונות לכתוב את המזהה הייחודי 1 ייכשלו מכיוון שהמזהה הייחודי 0 נפתח בתחילה עם גישה לקריאה בלבד.

הערה

  • אחד הוא המזהה הייחודי המוגדר כברירת מחדל עבור אופרטור הפלט < המשמש לניתוב מחדש.

שימוש באופרטור &> לניתוב מחדש של קלט ולשכפול

כדי להשתמש במזהה הייחודי &> עבור ניתוב מחדש של קלט, על הקובץ שאתה מציין להיות קיים. אם קובץ הקלט קיים, היישום Cmd.exe פותח אותו כקובץ לקריאה בלבד ושולח את התווים המוכלים בקובץ כקלט לפקודה כאילו הגיעו מהמקלדת. אם תציין מזהה ייחודי, היישום Cmd.exe משכפל את המזהה הייחודי שאתה מציין לתוך המזהה הייחודי הקיים במערכת.

לדוגמה, כדי לפתוח את קובץ File.txt כקלט הנקרא במזהה הייחודי 0 (כלומר STDIN), הקלד:

‎<file.txt

כדי לפתוח את הקובץ File.txt, למיין את תוכנו ולשלוח את הפלט לחלון שורת הפקודה (כלומר STDOUT), הקלד:

sort<file.txt

כדי למצוא את הקובץ File.txt ולאחר מכן לנתב מחדש את המזהה הייחודי 1 (כלומר STDOUT) ואת המזהה הייחודי 2 (כלומר STDERR) לקובץ Search.txt, הקלד:

findfile file.txt>search.txt 2<&1

כדי לשכפל את המזהה הייחודי 3 (המוגדר על-ידי המשתמש) כקלט הנקרא על-ידי המזהה הייחודי 0 (כלומר STDIN), הקלד:

‎<&3

שימוש באופרטור &< לניתוב מחדש של פלט ולשכפול

אם אתה מנתב מחדש פלט לקובץ ומציין שם קובץ קיים, היישום Cmd.exe פותח את הקובץ עם גישת כתיבה בלבד, ומחליף את תוכן הקובץ. אם אתה מציין מזהה ייחודי, Cmd.exe משכפל את הקובץ לתוך המזהה הייחודי.

כדי לשכפל את המזהה הייחודי 3 (המוגדר על-ידי המשתמש) לתוך המזהה הייחודי 1, הקלד:

‎>&3

כדי לנתב מחדש את כל הפלט, בכלל זה את המזהה הייחודי 2 (כלומר STDERR), מהפקודה ipconfig למזהה הייחודי 1 (כלומר STDOUT) ולאחר מכן לבצע ניתוב מחדש של הפלט לקובץ Output.log, הקלד:

ipconfig.exe>>output.log 2>&1

שימוש באופרטור הניתוב מחדש << לצירוף פלט

כדי לצרף את הפלט מפקודה לסוף קובץ מבלי לאבד מידע הקיים בקובץ, השתמש בשני סימני גדול מ- (‎>>‎). לדוגמה, הפקודה הבאה מוסיפה את רשימת הספריות המופקת באמצעות הפקודה dir לקובץ Dirlist.txt:

dir>>dirlist.txt

כדי לצרף את הפלט של הפקודה netstat לסוף הקובץ Tcpinfo.txt, הקלד:

netstat>>tcpinfo.txt

שימוש באופרטור Pipe (|)

האופרטור Pipe (|) לוקח את הפלט (כברירת מחדל, STDOUT) של פקודה אחת ומנתב אותו לקלט (כברירת מחדל, STDIN) של פקודה אחרת. לדוגמה, הפקודה הבאה ממיינת ספריה:

dir | sort

בדוגמה זו, שתי הפקודות מתחילות לפעול באופן מקביל, אך לאחר מכן הפקודה sort עוצרת עד שהיא מקבלת את הפלט של הפקודה dir. הפקודה sort משתמשת בפלט של הפקודה dir כקלט שלה, ולאחר מכן שולחת את הפלט שלה למזהה הייחודי 1 (כלומר STDOUT).

שילוב פקודות עם אופרטורים של ניתוב מחדש

באפשרותך לשלב פקודות סינון עם פקודות אחרות ועם שמות קבצים כדי ליצור פקודות מותאמות אישית. לדוגמה, באפשרותך להשתמש בפקודה הבאה כדי לאחסן את שמות הקבצים המכילים את המחרוזת "LOG":

dir /b | find "LOG" > loglist.txt

הפלט של הפקודה dir נשלח דרך פקודת הסינון find. שמות קבצים המכילים את המחרוזת "LOG" מאוחסנים כרשימה של שמות קבצים (לדוגמה, NetshConfig.log‏, Logdat.svd ו- Mylog.bat) בקובץ Loglist.txt.

כדי להשתמש ביותר ממסנן אחד באותה פקודה, הפרד בין המסננים באמצעות Pipe (|). לדוגמה, הפקודה הבאה מבצעת חיפוש בכל הספריות בכונן C:‎, מוצאת את שמות הקבצים הכוללים את המחרוזת "Log" ומציגה אותם במסך אחר מסך של שורת הפקודה:

dir c:\ /s /b | find "LOG" | more

באמצעות Pipe (|) מקבל Cmd.exe הוראה לשליחת הפלט של הפקודה dir דרך פקודת הסינון find. הפקודה find בוחרת רק שמות קבצים המכילים את המחרוזת "LOG". הפקודה more מציגה את שמוות הקבצים שנבחרו על-ידי הפקודה find, במסכים של שורת פקודה, מסך אחד בכל פעם. לקבלת מידע נוסף אודות פקודות סינון, ראה שימוש במסננים.


שימוש במארח קובץ Script מבוסס-פקודה (CScript.exe)

הקובץ Cscript.exe הוא גירסת שורת פקודה של Windows Script Host המספק אפשרויות שורת פקודה להגדרת מאפייני קבצי Script.

באמצעות Cscript.exe באפשרותך להפעיל קבצי Script על-ידי הקלדת שם קובץ Script בשורת הפקודה. כמו הדפדפן Microsoft Internet Explorer, תוכנת Windows Script Host משמשת כבקר של מנגנוני Scripting תואמי Windows Script, אך Windows Script Host הוא בעל דרישות זיכרון נמוכות ביותר. Windows Script Host הוא אידיאלי הן לצורכי Scripting אינטראקטיביים והם לצרכים לא-אינטראקטיביים, כגון Scripting של כניסה ו- Scripting של ניהול.

Windows Script Host תומך בקבצי Script שנכתבו בשפת VBScript או JScript. בעת הפעלת קובץ Script משולחן העבודה או משורת הפקודה, Script Host קורא את קובץ ה- Script שצוין ומעביר את תוכנו למנגנון ה-Script הרשום. מנגנון ה- Script משתמש בסיומות שם קובץ (כלומר ‎.vbs עבור VBScript וסיומת ‎.js עבור JScript) כדי לזהות את קובץ ה- Script. כתוצאה מכך, אין צורך להכיר את המפענח התוכניתי המדויק (כלומר קובץ ה- ProgID) של מנגנון ה- Script. ה- Script Host עצמו מחזיק במיפוי של סיומות קבצי ה- Script למזהים תוכניתיים, ועושה שימוש במודל השיוך של Windows XP לשם הפעלת המנגנון המתאים לקובץ Script נתון. לקבלת מידע נוסף אודות Windows Script Host, ראה Windows Script Host. לקבלת מידע נוסף אודות הקובץ CScript.exe, ראה לשם הפעלה של קבצי Script באמצעות Script Host מבוסס שורת פקודה (cscript.exe).


שימוש ב- Netsh

Netsh הוא כלי שירות Scripting של שורת פקודה המאפשר לך להציג או לשנות, באופן מקומי או מרוחק, תצורת רשת של מחשב הפועל כעת. Netsh מספק גם תכונת Scripting המאפשרת הפעלה של קבוצת פקודות במצב אצווה עבור עבור מחשב שצוין. ל- Netsh יש גם אפשרות לשמור קובץ Script של תצורה בקובץ טקסט עבור מטרות ארכיוניות או כדי לסייע לך לקבוע תצורה של שרתים אחרים.

הקשרים של Netsh

Netsh פועל בהדדיות עם רכיבים אחרים של מערכת הפעלה באמצעות קבצים של ספריית קישור דינאמי (DLL). כל DLL עוזר של Netsh מספק ערכה נרחבת של תכונות הנקראת הקשר, שהוא קבוצה של פקודות ספציפיות לרכיב של עבודה ברשת. הקשרים אלה מרחיבים את הפונקציונליות של netsh על-ידי מתן תמיכה בתצורה ובפיקוח עבור שירות, כלי שירות או פרוטוקול אחד או יותר. לדוגמה, Dhcpmon.dll מספק ל- netsh את ההקשר ואת ערכת הפקודות הנדרשת לשם קביעת תצורה וניהול של שרתי DHCP.

כדי להפעיל פקודת netsh, עליך להפעיל את netsh משורת הפקודה של Cmd.exe ולעבור להקשר המכיל את הפקודה שברצונך להשתמש בה. ההקשרים הזמינים עבורך תלויים ברכיבי הרשת שהתקנת. לדוגמה, אם תקליד dhcp בשורת הפקודה של Netsh, ההקשר ישתנה להקשר DHCP, אך אם הקשר DHCP לא הותקן במחשבך תוצג ההודעה הבאה:

The following command was not found: dhcp.‎

לקבלת מידע נוסף אודות הקשרי Netsh, עיין בנושאים הבאים:

  • פקודות Netsh עבור AAAA
  • פקודות Netsh עבור DHCP
  • פקודות אבחון (diag) של Netsh
  • פקודות Netsh עבור IP של ממשק
  • פקודות Netsh עבור RAS
  • פקודות Netsh עבור Routing
  • פקודות Netsh עבור WINS

שימוש בהקשרים מרובים

להקשר יש אפשרות להתקיים בתוך הקשר. לדוגמה, בתוך ההקשר Routing, ניתן לעבור להקשרי המשנה IP ו- IPX.

לשם הצגת רשימה של פקודות ושל הקשרי משנה הזמינים לשימוש בתוך הקשר, הקלד את שם ההקשר ואחריו ‎/?‎ או help בשורת הפקודה של netsh. לדוגמה, לשם הצגת רשימה של הקשרי משנה ופקודות הזמינים לשימוש בהקשר Routing, הקלד בשורת הפקודה של Netsh ‏(netsh>‎) את הטקסט הבא:

routing /?‎

routing help

כדי לבצע משימות בהקשר אחר מבלי לשנות את ההקשר הנוכחי שלך, הקלד את נתיב ההקשר של הפקודה שברצונך להשתמש בה בשורת הפקודה של netsh. לדוגמה, כדי להוסיף את ממשק ההתקשרות המקומית בהקשר IGMP מבלי לעבור להקשר IGMP, הקלד בשורת הפקודה של netsh:

routing ip igmp add interface "Local Area Connection" startupqueryinterval=21

הפעלת פקודות Netsh משורת הפקודה של Cmd.exe

בעת הפעלת Netsh משורת הפקודה של Cmd.exe,‏ netsh עושה שימוש בתחביר הבא. כדי להפעיל פקודות Netsh אלה ב-Windows 2000 Server מרוחק, ראשית עליך להפעיל התקשרות לשולחן עבודה מרוחק כדי להתחבר ל- Windows 2000 Server שבו פועל שרת מסוף. ייתכן שיהיו הבדלים תפקודיים בין פקודות ההקשר של Netsh ב- Windows 2000 וב- Windows XP.

כדי להציג את תחביר הפקודה, לחץ על הפקודה הבאה:

netsh

Netsh הוא כלי שירות Scripting של שורת פקודה המאפשר לך להציג או לשנות, באופן מקומי או מרוחק, תצורת רשת של מחשב הפועל כעת. כאשר משתמשים ב- netsh ללא פרמטרים, שורת הפקודה Netsh.exe נפתחת (כלומר, netsh>‎).

תחביר

netsh ‎[-a AliasFile]‎ ‎[-c Context]‎ ‎[-r RemoteComputer]‎ ‎[{NetshCommand|-f ScriptFile}]‎

פרמטרים

‎-a
חזרה לשורת הפקודה של netsh לאחר הפעלה של AliasFile.
AliasFile
ציון השם של קובץ הטקסט המכיל פקודת netsh אחת או יותר.
‎-c
מעבר להקשר netsh שצוין.
Context
ציון הקשר של netsh. הטבלה הבאה מציגה הקשרים זמינים של netsh.
הקשר | תיאור
AAAA | הצגה וקביעה של תצורת מסד הנתונים עבור אימות, מתן הרשאות, ניהול חשבונות וביקורת (AAAA), המשמש את שירות אימות באינטרנט (IAS) ואת השירות ניתוב וגישה מרחוק.
DHCP | ניהול שרתי DHCP ומתן חלופה השקולה לניהול מבוסס מסוף.
Diag | ניהול ופתרון בעיות פרמטרים של מערכת הפעלה ושירות רשת.
Interface | קביעת התצורה של פרוטוקול TCP/IP (כולל כתובות, שערי ברירת מחדל, שרתי DNS ושרתי WINS) והצגת מידע אודות התצורה ומידע סטטיסטי.
RAS | ניהול שרתי גישה מרחוק.
Routing | ניהול שרתי ניתוב (Routing).
WINS | ניהול שרתי WINS.
‎-r
קביעת תצורה של מחשב מרוחק.
RemoteComputer
ציון המחשב המרוחק שאת תצורתו יש לקבוע.
NetshCommand
ציון פקודת netsh שברצונך להפעיל.
‎-f
יציאה מ- Netsh.exe לאחר הפעלה של קובץ Script.
ScriptFile
ציון קובץ Script שברצונך להפעיל.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • שימוש ב- ‎-r

    אם תציין ‎-r ולאחריו פקודה נוספת, הפקודה netsh תפעיל את הפקודה במחשב המרוחק ולאחר מכן תחזור לשורת הפקודה של Cmd.exe. אם תציין ‎-r ללא פקודה נוספת, netsh ייפתח במצב מרוחק. התהליך דומה לשימוש ב- set machine בשורת הפקודה של Netsh. בעת השימוש ב- ‎-r, מוגדר מחשב היעד עבור המופע הנוכחי של netsh בלבד. לאחר שתצא ותיכנס מחדש ל- netsh, מחשב היעד חוזר להיות המחשב המקומי. באפשרותך להפעיל פקודות netsh במחשב מרוחק על-ידי ציון שם מחשב המאוחסן ב- WINS, שם UNC, שם אינטרנט שיפוענח על-ידי שרת DNS או כתובת IP מספרית.

הפעלת פקודות Netsh משורת הפקודה של Netsh.exe

Netsh עושה שימוש בפקודות הסטנדרטיות הבאות בכל ההקשרים שבאפשרותך להפעיל משורת פקודה של Netsh.exe (כלומר, netsh>‎). כדי להפעיל פקודות Netsh אלה ב- Windows 2000 Server מרוחק, ראשית הפעל התקשרות לשולחן עבודה מרוחק כדי להתחבר ל- Windows 2000 Server שבו פועל שרת מסוף. ייתכן שיהיו הבדלים תפקודיים בין פקודות הקשר של Netsh ב- Windows 2000 וב- Windows XP.

כדי להציג את תחביר הפקודה, לחץ על פקודה:

..

מעבר להקשר הנמצא רמה אחת מעלה.

תחביר

..

פרמטרים

‎/?‎
הצגת עזרה בשורת הפקודה.

abort

מחיקת כל השינויים שבוצעו במצב לא מקוון. לפקודה Abort אין כל השפעה במצב מקוון.

תחביר

abort

פרמטרים

‎/?‎
הצגת עזרה בשורת הפקודה.

add helper

התקנת קובץ DLL המהווה עוזר ב- Netsh.

תחביר

add helper DLLName

פרמטרים

DLLName
נדרש. ציון שמו של קובץ DLL המהווה עוזר שברצונך להתקין.
‎/?‎
הצגת עזרה בשורת הפקודה.

alias

הוספת כינוי המורכב ממחרוזת תווים המוגדרת על-ידי המשתמש. netsh יתייחס למחרוזת זו כשקולה למחרוזת תווים אחרת. בעת השימוש ב- alias ללא פרמטרים, מוצגים כל הכינויים הזמינים.

תחביר

alias ‎[AliasName]‎ ‎[string1 [string2 ...]]‎

פרמטרים

alias [AliasName]‎
הצגת הכינוי שצוין.
alias ‎[AliasName][string1[string2 ...]]‎
הגדרת AliasName כמחרוזת או כמחרוזות שצוינו.
‎/?‎
הצגת עזרה בשורת הפקודה.

דוגמאות

הדוגמה הבאה לקובץ Script של netsh מגדירה שני כינויי netsh‏, Shaddr ו- Shp, ולאחר מכן משאירה את שורת הפקודה של Netsh בהקשר Interface IP:

alias shaddr show interface ip addr
alias shp show helpers
interface ip

אם תקליד shaddr בשורת הפקודה של Netsh, היישום Netsh.exe יפרש זאת כפקודה show interface ip addr. אם תקליד shp בשורת הפקודה של Netsh, היישום Netsh.exe יפרש זאת כפקודה show helpers.

bye

יציאה מ- Netsh.exe.

תחביר

bye

פרמטרים

‎/?‎
הצגת עזרה בשורת הפקודה.

commit

ביצוע בנתב של כל השינויים שהוגדרו במהלך עבודה במצב לא מקוון. לפקודה commit אין השפעה במצב מקוון.

תחביר

commit

פרמטרים

‎/?‎
הצגת עזרה בשורת הפקודה.

delete helper

הסרת קובץ DLL המהווה עוזר מ- Netsh.

תחביר

delete helper DLLName

פרמטרים

DLLName
נדרש. ציון שם קובץ DLL המהווה עוזר שברצונך להסיר.
‎/?‎
הצגת עזרה בשורת הפקודה.

dump

יצירת מקטע Script המכיל את התצורה הנוכחית. אם תשמור מקטע Script זה לקובץ, תוכל להשתמש בקובץ כדי לשחזר הגדרות תצורה ששונו. כאשר נעשה שימוש ב- dump ללא פרמטרים, מוצגות כל תצורות ההקשר של netsh.

תחביר

dump [FileName]‎

פרמטרים

‎[FileName]‎
ציון שם הקובץ שאליו ברצונך לנתב מחדש את הפלט.
‎/?‎
הצגת עזרה בשורת הפקודה.

exec

טעינת קובץ Script והפעלת פקודות שנשמרו בו.

תחביר

exec ScriptFile

פרמטרים

ScriptFile
נדרש. ציון שם קובץ ה- Script שברצונך לטעון ולהפעיל.

הערות

  • ל- ScriptFile יש אפשרות לפעול במחשב אחד או יותר.

exit

יציאה מ- Netsh.exe.

תחביר

exit

פרמטרים

‎/?‎
הצגת עזרה בשורת הפקודה.

help

הצגת העזרה.

תחביר

‎{/?|?|help|h}‎

פרמטרים

ללא

offline

הגדרת המצב הנוכחי כלא מקוון.

תחביר

offline

פרמטרים

‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • שינויים שביצעת במצב זה נשמרים, אך יהיה עליך להפעיל את הפקודה commit או את הפקודה online כדי ששינויים אלה יבוצעו בנתב.
  • בעת מעבר ממצב לא מקוון למצב מקוון, שינויים שביצעת במצב לא מקוון משתקפים בתצורה הפועלת כעת.
  • שינויים המתבצעים במצב מקוון משתקפים באופן מיידי בתצורה הפועלת כעת.

online

הגדרת המצב הנוכחי כמקוון.

תחביר

online

פרמטרים

‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • שינויים המתבצעים במצב מקוון משתקפים באופן מיידי בתצורה הפועלת כעת.
  • בעת המעבר ממצב לא מקוון למצב מקוון, שינויים שביצעת במצב לא מקוון משתקפים בתצורה הפועלת כעת.

popd

שחזור הקשר מהמחסנית.

תחביר

popd

פרמטרים

‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • כאשר נעשה שימוש בפקודה זו יחד עם pushd, מאפשרת הפקודה popd לשנות את ההקשר, להפעיל את הפקודה בהקשר החדש ולאחר מכן לחדש את ההקשר הקודם.

דוגמאות

בדוגמה הבאה, קובץ Script משנה את ההקשר מהקשר הבסיס להקשר interface ip, מוסיף ניתוב IP סטטי ולאחר מכן חוזר להקשר הבסיס:

netsh>‎pushd
netsh>‎interface ip
netsh interface ip>‎set address local static 10.0.0.9 255.0.0.0 10.0.0.1 1
netsh interface ip>‎popd netsh>‎

pushd

שמירת ההקשר הנוכחי במחסנית מסוג First-In-Last-Out ‏(FILO).

תחביר

pushd

פרמטרים

‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • כאשר נעשה שימוש בפקודה זו עם הפקודה popd, הפקודה pushd מאפשרת לשנות את ההקשר, להפעיל את הפקודה בהקשר החדש ולאחר מכן לחדש את ההקשר הקודם.

quit

יציאה מ- Netsh.exe.

תחביר

quit

פרמטרים

‎/?‎
הצגת עזרה בשורת הפקודה.

set file

העתקת הפלט של חלון שורת הפקודה לקובץ.

תחביר

set file {open FileName|append FileName|close}‎

פרמטרים

open FileName
שליחת הפלט של חלון שורת הפקודה לקובץ שצוין.
append FileName
צירוף הפלט של חלון שורת הפקודה לקובץ הקיים שצוין.
close
הפסקה של שליחת פלט וסגירת קובץ.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • שימוש ב- FileName

    אם שם הקובץ (FileName) שצוין אינו קיים, netsh יוצר קובץ חדש עם שם זה. אם FileName שצוין קיים, netsh מחליף את הנתונים הקיימים בקובץ.

דוגמאות

לשם יצירת קובץ יומן רישום חדש בשם Session.log והעתקת כל הקלט והפלט הבאים של netsh ל- Session.log, הקלד:

set file open c:\session.log

set machine

ציון המחשב הנוכחי שבו יש לבצע את משימות קביעת התצורה. כאשר נעשה שימוש ב- set machine ללא פרמטרים, נעשה שימוש במחשב המקומי.

תחביר

set machine [[ComputerName=]string]‎

פרמטרים

ComputerName
ציון שם המחשב שבו יש לבצע את משימות קביעת התצורה.
string
ציון המיקום של המחשב המרוחק.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • ביצוע משימות תצורה במחשבים מרובים

    באפשרותך להפעיל פקודות בכמה מחשבים מתוך קובץ Script בודד. באפשרותך להשתמש ב- set machine בקובץ Script כדי לציין מחשב יעד (לדוגמה, ComputerA) ולאחר מכן להפעיל את הפקודות שבאות אחרי set machine במחשב זה (כלומר, ComputerA). לאחר מכן, באפשרותך להשתמש ב- set machine כדי לציין מחשב יעד אחר (לדוגמה, ComputerB) ולאחר מכן להפעיל פקודות במחשב זה (כלומר, ComputerB).

set mode

הגדרת המצב הנוכחי כמקוון או כלא מקוון.

תחביר

set mode {online|offline}‎

פרמטרים

online
הגדרת המצב הנוכחי כמקוון.
offline
הגדרת המצב הנוכחי כלא מקוון.
‎/?‎
הצגת עזרה בשורת הפקודה.

show

הצגת כינויים, עוזר ומידע נוסף.

תחביר

show {alias|helper|mode}‎

פרמטרים

alias
פירוט כל הכינויים שהוגדרו.
helper
פירוט כל העוזרים שברמה העליונה.
mode
הצגת המצב הנוכחי.
‎/?‎
הצגת עזרה בשורת הפקודה.

unalias

מחיקת הכינוי שצוין.

תחביר

unalias AliasName

פרמטרים

AliasName
נדרש. ציון שם הכינוי.
‎/?‎
הצגת עזרה בשורת הפקודה.
XOX


שימוש בכלי Windows Management Instrumentation Command-line - WMIC

גרפיקה של Microsoft Windows

שימוש בכלי Windows Management Instrumentation Command-line ‏(WMIC)

Windows Management Instrumentation Command-line ‏(WMIC) הוא ממשק שורת פקודה ו- Scripting המפשט את השימוש ב- Windows Management Instrumentation ‏(WMI) ובמערכות המנוהלות באמצעות WMI.

WMIC מבוסס על כינויים. כינויים הופכים את הנתונים העיקריים שמספק WMI לזמינים גם עבור משתמשים שאינם בקיאים בקונספטים ספציפיים ל- WMI. נתוני WMI ותכונות רבות של WMI זמינים דרך WMI ללא כינויים.

באפשרותך לפרט כינויים זמינים על-ידי שימוש בעזרה WMIC /?‎. ל- WMIC מערכת עזרה מתקדמת. באפשרותך להשתמש בפרמטר ‎/?‎ בכל זמן ובכל עומק כדי לגלות את האפשרויות הנוספות הזמינות בהקשר הנוכחי. הפרמטר ‎/?‎ מפרט את הכינויים, הפקודות והבוררים (כלומר, בוררים החלים על WMIC באופן כללי) הזמינים כרגע. לקבלת פירוט של הפעלים והבוררים הזמינים עבור כינוי, הקלד את שם הכינוי ואחריו ‎/?‎. כדי לפרט את הפרמטרים הזמינים עבור פועל מסוים, הקלד את שם הכינוי, את הפועל ולאחריו ‎/?‎.

לדוגמה, התהליכים הפועלים במערכת הנוכחית זמינים באמצעות הכינוי PROCESS. כדי להציג את כל התהליכים הפועלים כרגע במחשב, הקלד PROCESS בכלי השירות WMIC. כדי לפרט תהליך ספציפי, הקלד פקודה כגון PROCESS WHERE ‎(Description="explorer.exe")‎. כדי לקבל מאפיינים ספציפיים עבור התהליכים, הקלד פקודה כגון PROCESS GET Name, Handle, PageFaults.

ללא שימוש בכינויים, באפשרותך להשתמש באותן אפשרויות באמצעות הפקודה CLASS. לדוגמה, CLASS Win32_Process GET Name, Handle, PageFaults. עם זאת, עליך לקבוע את שם המחלקה מתוך מקורות אחרים. כדי לבצע את הפעולה המקבילה לזו של פסוקית הכינוי Where, עליך להשתמש ב- PATH Win32_Process.Description="explorer.exe"‎.

לקבלת מידע נוסף אודות שימוש והרחבה של WMIC, ראה שורת הפקודה של WMI במערכת העזרה של Windows XP. תיעוד זה כולל מידע אודות שימוש ב- WMIC בקבצי אצווה, עבור דיווח, בפעולה עם מחשבים מרוחקים ומרובים ועבור ניהול מערכת.

פקודה | תוצאה
‎/?‎ | הצגת עזרה.
CLASS | יציאה ממצב הכינוי המוגדר כברירת מחדל של WMIC כדי לבצע גישה למחלקות אחרות בסכימה של WMI באופן ישיר.
PATH | יציאה ממצב הכינוי המוגדר כברירת מחדל של WMIC כדי לבצע גישה למופעים בסכימה של WMI באופן ישיר.
CONTEXT | הצגת הערכים הנוכחיים של כל הבוררים הכלליים.
QUIT | יציאה מ- WMIC.
EXIT | יציאה מ- WMIC.


Append

פקודה זו מאפשרת לתוכניות לפתוח קבצי נתונים בתיקיות שצוינו כאילו קבצים אלה נמצאים בתיקיה הנוכחית. כאשר לא מוזנים פרמטרים, append מציגה את רשימת הספריות המצורפות.

תחביר

append [;] [[Drive:]Path[;...]] [/x:{on|off}][/path:{on|off}] [/e]‎

פרמטרים

;
ביטול רשימת התיקיות המצורפות.
‎[Drive:]Path
ציון הכונן והתיקיה שברצונך לצרף לתיקיה הנוכחית. אם לא צוין כונן, הכונן הנוכחי משמש כברירת המחדל. באפשרותך לציין ערכים מרובים של ‎[Drive:]Path על-ידי הפרדת הערכים באמצעות נקודה-פסיק.
‎/‎x:{on | off‎}‎
קביעה אם מערכת המשנה MS-DOS תחפש תיקיות מצורפות בעת הפעלת תוכניות. ההגדרה ‎/x:on מציינת למערכת לחפש אחר תיקיות מצורפות. ההגדרה ‎/x:off מציינת למערכת שלא לחפש בתיקיות מצורפות.
‎/‎path:{on | off‎}‎
קביעה אם התוכנית תבצע חיפוש בתיקיות מצורפות אחר קובץ נתונים כאשר שם הקובץ שהתוכנית מחפשת כבר כולל נתיב. הגדרת ברירת המחדל היא ‎/‎path:on.
‎/e
הקצאת רשימת התיקיות המצורפות למשתנה סביבה בשם APPEND. אפשרות שורת פקודה זו פועלת בפעם הראשונה בלבד בה נעשה שימוש בפקודה append לאחר הפעלת המערכת.
‎/?‎
הצגת העזרה בשורת הפקודה.

הערות

  • XOX
  • אחסון רשימת התיקיות המצורפות

    באפשרותך להשתמש באפשרות שורת הפקודה ‎/e יחד עם הפקודה append כדי להקצות את רשימת התיקיות המצורפות למשתנה סביבה הקרוי APPEND. לשם ביצוע פעולה זו, השתמש תחילה בפקודה append עם בורר ‎/e בלבד. לאחר מכן השתמש בפקודה append שוב, והפעם כלול את התיקיות שברצונך לצרף. אין באפשרותך לציין את הבורר ‎/e ואת הפרמטרים ‎[Drive:]Path באותה שורת פקודה.

  • קביעת תיקיות מצורפות מרובות

    כדי לצרף יותר מתיקיה אחת, הפרד ערכים מרובים באמצעות נקודה-פסיק. אם תשתמש שוב בפקודה append יחד עם הפרמטרים ‎[Drive:]Path, התיקיה או התיקיות שציינת יחליפו את כל התיקיות שציינת בפקודת append הקודמת.

  • שימוש בפקודה dir

    בעת הקלדת dir לשם צפייה ברשימה של הקבצים וספריות המשנה בספריה הראשית, הפקודה dir אינה כוללת את שמות הקבצים המופיעים בתיקיות מצורפות.

  • פתירת התנגשויות בין שמות קבצים

    אם לקובץ הנמצא בתיקיה מצורפת יש שם זהה לשם של קובץ הנמצא בתיקיה הנוכחית, תוכניות יפתחו את הקובץ הנמצא בתיקיה הנוכחית.

  • שימוש בפקודה append עם תוכניות היוצרות קבצים חדשים

    כאשר תוכנית פותחת קובץ בתיקיה מצורפת, ניתן למצוא את הקובץ כאילו הוא נמצא בתיקיה הנוכחית. אם התוכנית תשמור את הקובץ על-ידי יצירת קובץ חדש בעל אותו שם, הקובץ החדש ייווצר בתיקיה הנוכחית ולא בתיקיה המצורפת. הפקודה append מיועדת לקבצי נתונים שאין לשנותם או שיש לשנותם מבלי ליצור עותקים חדשים של הקבצים. תוכניות מסדי נתונים משנות לעיתים תכופות קבצי נתונים בלי ליצור עותקים חדשים. לעומת זאת, עורכי טקסט ומעבדי תמלילים בדרך כלל מבצעים שמירה של קבצי נתונים ששונו על-ידי יצירת קבצים חדשים. כדי למנוע בלבול, ייתכן שתרצה להימנע משימוש בפקודה append עם תוכניות אלה.

  • שימוש בבורר ‎/x:on בפקודה path

    בעת שימוש בבורר ‎/x:on, באפשרותך להפעיל תוכנית הממוקמת בתיקיה מצורפת על-ידי הקלדת שם התוכנית בשורת הפקודה. בדרך כלל תשתמש בפקודה path כדי לציין תיקיות המכילות תוכניות. עם זאת, אין צורך להשתמש בפקודה path כדי לציין תיקיה מצורפת המכילה תוכניות. מערכת משנה של MS-DOS מחפשת תוכנית בתיקיה מצורפת לפי הסדר הרגיל בו היא מחפשת אחר תוכנית: תחילה בספריה הנוכחית, לאחר מכן בספריות המצורפות ולבסוף בנתיב החיפוש.

  • קיצור הבורר ‎/x:on לבורר ‎/x

    באפשרותך לקצר את הבורר ‎/x:on לבורר ‎/x. כדי לעשות זאת, ציין את הבורר ‎/x:on בפעם הראשונה בה תשתמש בפקודה append לאחר הפעלת המערכת. לאחר מכן באפשרותך לבחור בין הבורר ‎/x:on לבין הבורר ‎/x:off.

  • שימוש בבורר ‎/e יחד עם הפקודה set

    באפשרותך להשתמש בבורר ‎/e עם הפקודה set כדי להציג רשימה של תיקיות מצורפות. לקבלת מידע אודות משתני סביבה והפקודה set, ראה נושאים קרובים.

דוגמאות

כדי לאפשר לתוכניות לפתוח קבצי נתונים בספריות B:\Letters ו- A:\Reports כאילו הקבצים נמצאים בתיקיה הנוכחית, הקלד:

append b:\letters;a:\reports

לשם צירוף אותן תיקיות ושמירת עותק של רשימת התיקיות המצורפות בסביבת Windows XP (עליך לבצע פעולה זו בפעם הראשונה בה תשתמש בפקודה append לאחר הפעלת המערכת), הקלד:

append /e

append b:\letters;a:\reports


Arp

פקודה זו מציגה ומשנה ערכים במטמון Address Resolution Protocol ‏(ARP), המכיל טבלה או טבלאות המשמשות לאחסון כתובות IP וכתובות ה- Ethernet או ה- Token Ring הפיזיות המפוענחות שלהן. טבלה נפרדת קיימת עבור כל מתאם רשת Ethernet או Token Ring המותקן במחשב. כאשר נעשה שימוש בפקודה arp ללא פרמטרים, תוצג העזרה לפקודה זו.

תחביר

arp [-a [InetAddr] [-N IfaceAddr]]‎ [‎-g [InetAddr] [-N IfaceAddr]] [-d InetAddr [IfaceAddr]] [-s InetAddr EtherAddr [IfaceAddr]]‎

פרמטרים

‎-a [InetAddr] [-N IfaceAddr]‎
פקודה זו מציגה טבלאות מטמון ARP עבור כל הממשקים. לשם הצגת ערך מטמון ה- ARP עבור כתובת IP ספציפית, השתמש בפקודה arp -a עם הפרמטרInetAddr כאשר InetAddr הוא כתובת IP. לשם הצגת טבלת מטמון ה- ARP עבור ממשק ספציפי, השתמש בפרמטר ‎-N IfaceAddr כאשר IfaceAddr הוא כתובת ה- IP המוקצית לממשק. הפרמטר ‎-N הוא תלוי רישיות.
‎-g [InetAddr] [-N IfaceAddr]‎
זהה ל- ‎-a.
‎-d InetAddr [IfaceAddr]‎
פקודה זו מוחקת ערך עם כתובת IP ספציפית, כאשר InetAddr הוא כתובת ה- IP. לשם מחיקת ערך בטבלה של ממשק ספציפי, השתמש בפרמטר IfaceAddr כאשר IfaceAddr הוא כתובת ה- IP המוקצית לממשק. לשם מחיקת כל הערכים השתמש בתו הכללי כוכבית (*) במקום הפרמטר InetAddr.
‎-s InetAddr EtherAddr [IfaceAddr]‎
פקודה זו מוסיפה ערך סטטי למטמון ה- ARP המפענח את כתובת ה- IP ‏InetAddr לכתובת הפיזית EtherAddr. לשם הוספת ערך מטמון ARP סטטי לטבלה עבור ממשק ספציפי, השתמש בפרמטר IfaceAddr כאשר IfaceAddr הוא כתובת ה- IP המוקצית לממשק.
‎/?‎
פקודה זו מציגה עזרה בשורת הפקודה.

הערות

  • כתובות ה- IP עבור InetAddr ועבור IfaceAddr מבוטאות בייצוג עשרוני מנוקד.
  • הכתובת הפיזית עבור EtherAddr מורכבת משישה בתים המבוטאים בייצוג הקסדצימאלי ומופרדים באמצעות מקפים (לדוגמה, ‎00-AA-00-4F-2A-9C).
  • ערכים שהוספו בעזרת הפרמטר ‎-s הם ערכים סטטיים ואינם מנותקים מחוץ למטמון ה- ARP. ערכים אלה יוסרו אם פרוטוקול ה- TCP/IP יופסק ויופעל. לשם יצירת ערכי מטמון ARP סטטיים קבועים, הצב את פקודות ה- arp המתאימות בקובץ אצווה והשתמש ביישום משימות מתוזמנות על-מנת להפעיל את קובץ האצווה בעת הפעלת המערכת.
  • פקודה זו זמינה רק אם Internet Protocol (TCP/IP)‎ מותקן כרכיב במאפיינים של מתאם רשת תחת חיבורי רשת.

דוגמאות

לשם הצגת טבלאות מטמון ARP של כל הממשקים, הקלד:

arp -a

לשם הצגת טבלת מטמון ARP של הממשק שהוקצתה לו כתובת ה- IP ‏10.0.0.99, הקלד:

arp -a -N 10.0.0.99

לשם הוספת ערך מטמון ARP סטטי המפענח את כתובת ה- IP ‏10.0.0.80 לכתובת הפיזית ‎00-AA-00-4F-2A-9C, הקלד:

arp -s 10.0.0.80 00-AA-00-4F-2A-9C


Assoc

פקודה זו מציגה או משנה שיוכים של סיומות שם קובץ. כאשר נעשה שימוש בפקודה זו ללא פרמטרים, assoc תציג רשימה של כל שיוכי סיומות שם הקובץ הקיימים.

תחביר

assoc [.ext[=[filetype]]]‎

פרמטרים

‎.ext
פרמטר זה מציין את סיומת שם הקובץ.
filetype
פרמטר זה קובע את סוג הקובץ שאליו ברצונך לשייך את סיומת שם הקובץ שצוינה.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • לשם מחיקת שיוך סוג קובץ לסיומת שם קובץ, השתמש ברווח לבן אחרי סימן השוויון.
  • השתמש בפקודה ftype לשם הצגת סוגי קבצים קיימים שעבורם הוגדרו מחרוזות פקודה פתוחות.
  • השתמש באופרטור הניתוב מחדש ‎>‎ כדי לנתב מחדש את פלט הפקודה assoc לקובץ טקסט.

דוגמאות

לשם הצגת שיוכי סוגי הקבצים הקיימים עבור סיומת שם הקובץ ‎.txt, הקלד:

assoc .txt

לשם מחיקת שיוך סוג קובץ לסיומת שם הקובץ ‎.txt, הקלד:

assoc .txt=‎

לשם הצגת שיוכי סוגי הקבצים הנוכחיים במסך אחד בכל פעם, הקלד:

assoc | more

לשם שליחת פלט הפקודה assoc לקובץ Assoc.cfg, הקלד:

assoc>assoc.cfg


At

פקודה זו מתזמנת פקודות ותוכניות להפעלה במחשב בשעה ובתאריך שצוינו. באפשרותך להשתמש בפקודה at רק בזמן ששירות לוח הזמנים מופעל. כאשר נעשה בפקודה זו שימוש ללא פרמטרים, at מפרטת פקודות מתוזמנות.

תחביר

at [\\ComputerName]‎ [{[ID] [/delete]|/delete [/yes]}]‎

at [[\\ComputerName] hours:minutes [/interactive] [{/every:date[,...]|/next:date[,...]}] command]‎

פרמטרים

‎\\ComputerName
פרמטר זה מציין מחשב מרוחק. אם תשמיט פרמטר זה, הפקודה at תתזמן את הפקודות ואת התוכניות במחשב המקומי.
ID
פרמטר זה מציין את מספר הזיהוי שהוקצה לפקודה מתוזמנת.
‎/delete
פרמטר זה מבטל פקודה מתוזמנת. אם ID יושמט, כל הפקודות המתוזמנות במחשב יבוטלו.
‎/yes
פרמטר זה עונה בחיוב לכל השאילתות מהמערכת בעת מחיקת אירועים מתוזמנים.
hours:minutes
פרמטר זה קובע את השעה בה תופעל הפקודה. השעה מיוצגת כ- שעות:דקות בייצוג של 24 שעות (כלומר, 00:00 [חצות] עד 23:59).
‎/interactive
פרמטר זה מאפשר ל- command לפעול באופן אינטראקטיבי עם שולחן העבודה של המשתמש המחובר למחשב בעת פעולת command.
‎/every:‎
פרמטר זה מפעיל את command בכל יום או ימים שצוינו בשבוע או בחודש (לדוגמה, בכל יום חמישי או ביום השלישי בכל חודש).
date
פרמטר זה מציין את התאריך בו ברצונך להפעיל את הפקודה. באפשרותך לציין יום אחד או יותר בשבוע (כלומר, הקלד M,T,W,Th,F,S,Su) או יום אחד או יותר בחודש (כלומר, הקלד 1 עד 31). הפרד ערכי תאריך מרובים באמצעות פסיקים. אם יושמט הפרמטר date, הפקודה at תשתמש בתאריך הנוכחי.
‎/next:‎
פרמטר זה מפעיל את command בפעם הבאה שהיום מגיע (לדוגמה יום חמישי הבא).
command
פרמטר זה משמש לציון הפקודה, התוכנית (כלומר, קובץ ‎.exe או ‎.com) או תוכנית האצווה (קובץ ‎.bat או ‎.cmd) של Windows שברצונך להפעיל. כאשר הפקודה דורשת נתיב כארגומנט, השתמש בנתיב המוחלט (כלומר, הנתיב המלא המתחיל באות הכונן). אם הפקודה מתבצעת במחשב מרוחק, ציין סימון Universal Naming Convention ‏(UNC) עבור השרת ושם השיתוף, במקום אות כונן מרוחק.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • Schtasks הוא כלי תזמון רב-עוצמה בשורת הפקודה. כלי זה כולל את כל הפונקציונליות שניתן למצוא בכלי השירות בשורת הפקודה at. השתמש ב- schtasks במקום ב- at עבור כל משימות תזמון שורת-הפקודה. לקבלת מידע נוסף אודות schtasks, ראה נושאים קרובים.

  • שימוש ב- at

    לשם שימוש בפקודה at, עליך להיות חבר בקבוצה Administrators המקומית.

  • טעינת Cmd.exe

    הפקודה At אינה טוענת באופן אוטומטי את Cmd.exe, מפענח הפקודות, לפני הפעלת פקודות. אם אינך מפעיל קובץ הפעלה (‎.exe), עליך לטעון את Cmd.exe בתחילת הפקודה במפורש, לדוגמה:

    cmd /c dir > c:\test.out

  • הצגת פקודות מתוזמנות

    כאשר נעשה שימוש בפקודה at ללא אפשרויות שורת פקודה, משימות מתוזמנות מופיעות בטבלה בעלת מבנה דומה לדוגמה הבאה:

    Status  ID   Day       Time        Command Line
    OK      1    Each F    4:30 PM     net send group leads status due
    OK      2    Each M    12:00 AM    chkstor > check.file
    OK      3    Each F    11:59 PM    backup2.bat
  • הוספת מספר זיהוי (ID)

    הוספת מספר זיהוי (ID) לפקודה at בשורת הפקודה תביא להצגתו של מידע לגבי ערך בודד בתבנית דומה לתבנית הבאה:

    Task ID:      1

Status:       OK

Schedule:     Each  F

Time of Day:  4:30 PM

Command:      net send group leads status due

    לאחר תזמון פקודה באמצעות at (במיוחד פקודה בעלת אפשרויות שורת פקודה), בדוק שתחביר הפקודה תקין על-ידי הקלדת at ללא אפשרויות שורת פקודה. אם המידע בעמודה של שורת הפקודה שגוי, מחק את הפקודה והקלד אותה מחדש. אם הוא עדיין שגוי, הקלד את הפקודה מחדש עם אפשרויות שורת פקודה מעטות יותר.

  • הצגת תוצאות

    פקודות שתוזמנו עם הפקודה at פועלות כתהליכי רקע, כך שלא מוצג פלט על-גבי מסך המחשב. כדי לנתב מחדש פלט לקובץ, השתמש בסימן הניתוב מחדש (‎>‎). אם תנתב מחדש פלט לקובץ, עליך להשתמש בסימן Escape (^) לפני סימן ניתוב מחדש, בין אם אתה משתמש בפקודה at בשורת הפקודה או בקובץ אצווה. לדוגמה, לשם ניתוב מחדש של פלט לקובץ Output.text, הקלד:

    at 14:45 c:\test.bat ^>c:\output.txt

    הספריה הנוכחית עבור הפקודה המבוצעת היא התיקיה systemroot.

  • שינוי השעה במערכת

    אם תשנה את השעה במערכת לאחר תזמון פקודה לפעולה באמצעות at, עליך לסנכרן את המתזמן at עם שעון המערכת שהשתנה על-ידי הקלדת הפקודה at ללא אפשרויות שורת פקודה.

  • אחסון פקודות

    פקודות מתוזמנות מאוחסנות ברישום. כתוצאה מכך, אינך מאבד משימות מתוזמנות בעקבות הפעלה מחדש של שירות לוח הזמנים.

  • חיבור לכונני רשת

    הימנע משימוש בכונן שנותב מחדש עבור משימות מתוזמנות המבצעות גישה לרשת. ייתכן שלשירות לוח הזמנים לא תהיה אפשרות לקבל גישה לכונן שנותב מחדש, או שהכונן לא יהיה נוכח אם משתמש אחר מחובר למחשב בעת הפעלת המשימה המתוזמנת. במקום זאת, השתמש בנתיבי UNC למשימות מתוזמנות. לדוגמה:

    at 1:00pm my_backup \\server\share

    הימנע משימוש בתחביר המפורט להלן, שבו x:‎ הוא חיבור שנוצר על-ידי המשתמש:

    at 1:00pm my_backup x‎:‎

    אם תתזמן פקודת at המשתמשת באות כונן כדי להתחבר לספריה משותפת, עליך לכלול פקודת at שתנתק את הכונן כאשר תסיים להשתמש בו. אם הכונן לא ינותק, אות הכונן שהוקצתה לא תהיה זמינה בשורת הפקודה.

דוגמאות

לשם הצגת רשימה של פקודות שתוזמנו בשרת Marketing, הקלד:

at \\marketing

כדי ללמוד יותר אודות פקודה בעלת מספר זיהוי 3 בשרת Corp, הקלד:

at \\corp 3

כדי לתזמן פקודת Net Share להפעלה בשרת Corp בשעה 8:00 לפנה"צ ולנתב מחדש את הפירוט לשרת Maintenance, בספריה המשותפת Reports ובקובץ Corp.txt, הקלד:

at \\corp 08:00 cmd /c "net share reports=d:\marketing\reports >> ‎\\maintenance\reports\corp.txt"‎

כדי לגבות את הכונן הקשיח של שרת Marketing לכונן קלטות בחצות כל חמישה ימים, צור תוכנית אצווה הנקראת Archive.cmd המכילה את פקודות הגיבוי. לאחר מכן קבע את מועד ההפעלה של תוכנית האצווה על-ידי הקלדה של:

at \\marketing 00:00 /every:5,10,15,20,25,30 archive

לשם ביטול כל הפקודות המתוזמנות בשרת הנוכחי, נקה את מידע התזמון של at כמפורט להלן:

at /delete

לשם הפעלת פקודה שאינה קובץ הפעלה (כלומר, קובץ .exe), הקלד cmd /c לפני הפקודה כדי לטעון את Cmd.exe כמפורט להלן:

cmd /c dir > c:\test.out


Atmadm

פקודה זו מפקחת על התקשרויות וכתובות שנרשמו על-ידי ATM Call Manager ברשת של מצב העברה אסינכרוני (ATM). באפשרותך להשתמש בפקודה atmadm כדי להציג סטטיסטיקות עבור שיחות נכנסות ויוצאות במתאמי ATM. כאשר נעשה בפקודה זו שימוש ללא פרמטרים, atmadm מציגה סטטיסטיקות לפיקוח על מצב התקשרויות ה- ATM הפעילות.

תחביר

atmadm [/c][/a] [/s]

פרמטרים

‎/c
הצגת פרטי שיחות עבור כל ההתקשרויות הנוכחיות למתאם הרשת ATM המותקן במחשב זה.
‎/a
הצגת הכתובת הרשומה של נקודת הגישה של שירות הרשת ‎(‎NSAP‎)‎ של ATM עבור כל מתאם המותקן במחשב זה.
‎/s
הצגת סטטיסטיקה לפיקוח על המצב של התקשרויות ATM פעילות.
‎/?‎
הצגת עזרה בשורת הפקודה.

דוגמאות

לשם הצגת מידע אודות שיחה

לשם הצגת פרטי שיחות עבור כל ההתקשרויות הנוכחיות למתאם הרשת ATM המותקן במחשב זה, הקלד:

atmadm /c

הפקודה atmadm /c מייצרת פלט הדומה לזה המוצג להלן:

Windows ATM Call Manager Statistics

ATM Connections on Interface : [009] Olicom ATM PCI 155 Adapter

   Connection   VPI/VCI   Remote Address/
                          Media Parameters (rates in bytes/sec)
   In  PMP SVC    0/193   47000580FFE1000000F21A2E180020481A2E180B
                          Tx:UBR,Peak 0,Avg 0,MaxSdu 1516
                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516
   Out P-P SVC    0/192   47000580FFE1000000F21A2E180020481A2E180B
                          Tx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516
                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516
   In  PMP SVC    0/191   47000580FFE1000000F21A2E180020481A2E180B
                          Tx:UBR,Peak 0,Avg 0,MaxSdu 1516
                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516
   Out P-P SVC    0/190   47000580FFE1000000F21A2E180020481A2E180B
                          Tx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516
                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516
   In  P-P SVC    0/475   47000580FFE1000000F21A2E180000C110081501
                          Tx:UBR,Peak 16953984,Avg 16953984,MaxSdu 9188
                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 9188
   Out PMP SVC    0/194   47000580FFE1000000F21A2E180000C110081501 (0)
                          Tx:UBR,Peak 16953984,Avg 16953984,MaxSdu 9180
                          Rx:UBR,Peak 0,Avg 0,MaxSdu 0
   Out P-P SVC    0/474   4700918100000000613E5BFE010000C110081500
                          Tx:UBR,Peak 16953984,Avg 16953984,MaxSdu 9188
                          Rx:UBR,Peak 16953984,Avg 16953984,MaxSdu 9188
   In  PMP SVC    0/195   47000580FFE1000000F21A2E180000C110081500
                          Tx:UBR,Peak 0,Avg 0,MaxSdu 0
                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 9180

הטבלה שלהלן כוללת תיאורים של כל אחד מהאלמנטים בפלט הדוגמה של הפקודה atmadm /c.

סוג הנתונים | תצוגת מסך | תיאור
מידע אודות התקשרות (Connection) | In/Out | כיוון השיחה. In פירושו למתאם רשת ATM מהתקן אחר. Out פירושו ממתאם רשת ATM להתקן אחר.
PMP | שיחת נקודה לנקודות מרובות.
P-P | שיחת נקודה לנקודה.
SVC | ההתקשרות נמצאת במעגל וירטואלי ממותג.
PVC | ההתקשרות נמצאת במעגל וירטואלי קבוע.
מידע אודות VPI/VCI | VPI/VCI | נתיב וירטואלי וערוץ וירטואלי עבור שיחה נכנסת או יוצאת.
Remote Address/‎Media Parameters | 47000580FFE1000000F21A2E180000C110081500 | כתובת NSAP של התקן ה- ATM המתקשר (In) או שמתקשרים אליו (Out).
Tx הפרמטר Tx כולל את שלושת הרכיבים הבאים:
  • סוג קצב סיביות המהווה ברירת מחדל או הסוג שצוין (UBR, ‏CBR, ‏VBR, או ABR)
  • מהירות קו המהווה ברירת מחדל או המהירות שצוינה
  • גודל יחידת נתוני השירות (SDU) שצוין
Rx הפרמטר Rx כולל את שלושת הרכיבים הבאים:
  • סוג קצב סיביות המהווה ברירת מחדל או הסוג שצוין (UBR, ‏CBR, ‏VBR, או ABR)
  • מהירות קו המהווה ברירת מחדל או המהירות שצוינה
  • גודל SDU שצוין

לשם פירוט כל הכתובות הרשומות

לשם הצגת הכתובת הרשומה של נקודת הגישה של שירות הרשת ‎(‎NSAP‎)‎ של ATM עבור כל מתאם המותקן במחשב זה, הקלד:

atmadm /a

הפקודה atmadm /a מייצרת פלט הדומה לזה שמוצג להלן:

Windows ATM Call Manager Statistics

ATM Addresses for Interface : [009] Olicom ATM PCI 155 Adapter

47000580FFE1000000F21A2E180000C110081500

לשם הצגת סטטיסטיקה

לשם הצגת סטטיסטיקה לפיקוח על המצב של התקשרויות ATM פעילות, הקלד:

atmadm /s

הפקודה atmadm /s מייצרת פלט הדומה לזה המוצג להלן:

Windows ATM Call Manager Statistics

ATM Call Manager statistics for Interface : [009] Olicom ATM PCI 155 Adapter

    Current Active calls                        = 4
    Total successful Incoming calls             = 1332
    Total successful Outgoing calls             = 1297
    Unsuccessful Incoming calls                 = 1
    Unsuccessful Outgoing calls                 = 1
    Calls Closed by Remote                      = 1302
    Calls Closed Locally                        = 1323
    Signalling and ILMI Packets Sent            = 33655
    Signalling and ILMI Packets Received        = 34989

הטבלה שלהלן כוללת תיאורים של כל אחד מהאלמנטים בפלט הדוגמה של הפקודה atmadm /s.

נתון סטטיסטי של מנהל ההתקשרויות | תיאור
Current Active calls | שיחות הפעילות כעת במתאם ATM המותקן במחשב זה.
Total successful Incoming calls | שיחות שהתקבלו בהצלחה מהתקנים אחרים ברשת ATM זו.
Total successful Outgoing calls | שיחות שבוצעו בהצלחה להתקני ATM אחרים ברשת זו ממחשב זה.
Unsuccessful Incoming calls | שיחות נכנסות שנכשלו בהתקשרות למחשב זה.
Unsuccessful Outgoing calls | שיחות יוצאות שנכשלו בהתקשרות להתקן אחר ברשת.
Calls Closed by Remote | שיחות שהסתיימו על-ידי התקן מרוחק ברשת.
Calls Closed Locally | שיחות שהסתיימו על-ידי מחשב זה.
Signaling and ILMI Packets Sent | המספר של מנות ממשק משולב של ניהול מקומי (ILMI) שנשלחו לבורר אליו מחשב זה מנסה להתחבר.
Signaling and ILMI Packets Received | המספר של מנות ILMI שהתקבלו מבורר ATM.


Attrib

פקודה זו מציגה, מגדירה או מסירה את התכונות לקריאה בלבד, ארכיון, מערכת ומוסתר שהוקצו לקבצים או לספריות. בעת שימוש בפקודה זו ללא פרמטרים, attrib מציגה תכונות של כל הקבצים בספריה הנוכחית.

תחביר

attrib [{+r|-r}] [{+a|-a}] [{+s|-s}] [{+h|-h}] [[Drive:][Path] FileName] [/s[/d]]‎

פרמטרים

‎+r
הגדרת תכונת הקובץ לקריאה בלבד.
‎-r
ניקוי תכונת הקובץ לקריאה בלבד.
‎+a
הגדרת תכונת קובץ ארכיון.
‎-a
ניקוי תכונת קובץ ארכיון.
‎+s
הגדרה של תכונת הקובץ מערכת (System).
‎-s
ניקוי תכונת קובץ מערכת.
‎+h
הגדרה של תכונת הקובץ מוסתר (Hidden).
‎-h
ניקוי תכונת קובץ מוסתר.
‎[Drive:][Path] FileName
ציון המיקום והשם של הספריה, הקובץ או סידרת הקבצים שברצונך להציג את תכונותיהם או לשנותן. באפשרותך להשתמש בתו כללי (כלומר ? ו- *) בפרמטר FileName כדי להציג או לשנות את תכונותיה של קבוצת קבצים.
‎/s
פרמטר זה מחיל את הפקודה attrib וכל אפשרויות שורת הפקודה שצוינו על קבצים תואמים בספריה הנוכחית ובכל ספריות המשנה שלה.
‎/d
פרמטר זה מחיל את הפקודה attrib וכל אפשרויות שורת הפקודה שצוינו על ספריות.
‎/?‎‏
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • עבודה עם קבוצות של קבצים

    באפשרותך להשתמש בתווים כלליים (כלומר ? ו- *) עם הפרמטר FileName כדי להציג או לשנות את התכונות עבור קבוצה של קבצים. אם התכונות מערכת או מוסתר מוגדרות עבור קובץ, עליך לנקות תכונות אלה לפני שיהיה באפשרותך לשנות תכונות אחרות עבור קובץ זה.

  • שימוש בתכונה ארכיון

    התכונה ארכיון (כלומר ‎+a) מסמנת קבצים ששונו מאז הפעם האחרונה שקבצים אלה גובו. הפקודה xcopy משתמשת בתכונות ארכיון אלה. לקבלת מידע נוסף אודות תכונות ארכיון והפקודה xcopy, ראה נושאים קרובים.

  • הפקודה attrib, עם פרמטרים שונים, נגישה מה- Recovery Console.

דוגמאות

לשם הצגת התכונות של קובץ בשם News86 הממוקם בכונן הנוכחי, הקלד:

attrib news86

כדי להקצות את התכונה לקריאה בלבד לקובץ בשם Report.txt, הקלד:

attrib +r report.txt

לשם הסרת התכונה לקריאה בלבד מקבצים בספריה ‎\Public\Jones בדיסק בכונן B ומקבצים בספריות המשנה של ‎\‎Public\Jones, הקלד:

attrib -r b:\public\jones\*.* /s

כדוגמה אחרונה, נניח שברצונך לתת לעמית דיסק המכיל את כל הקבצים בספריית ברירת המחדל בדיסק בכונן A פרט לקבצים בעלי סיומת ‎.bak כיוון שבאפשרותך להשתמש בפקודה xcopy כדי להעתיק רק את הקבצים המסומנים עם תכונת הארכיון, עליך להגדיר את התכונה ארכיון עבור הקבצים שברצונך להעתיק. לשם ביצוע פעולה זו, השתמש בשתי הפקודות הבאות כדי להגדיר את התכונה ארכיון עבור כל הקבצים בכונן A ולאחר מכן לנקות את התכונה עבור הקבצים עם סיומת ‎.bak:

attrib +a a:*.* attrib -a a:*.bak

לאחר מכן, השתמש בפקודה xcopy כדי להעתיק את הקבצים מהדיסק בכונן A לדיסק בכונן B. אפשרות שורת הפקודה ‎/a בפקודה הבאה גורמת לפקודה xcopy להעתיק רק את הקבצים המסומנים בתכונה ארכיון. לדוגמה, הקלד:

xcopy a: b: /a

אם ברצונך שהפקודה xcopy תנקה את התכונה ארכיון של כל קובץ לאחר העתקת הקבצים, השתמש באפשרות שורת הפקודה ‎/m במקום באפשרות שורת הפקודה ‎/a. לדוגמה, הקלד:

xcopy a: b: /m


Bootcfg

בעזרת פקודה זו ניתן להגדיר, לבצע שאילתה או לשנות מאפיינים של הקובץ Boot.ini.

להצגת תחביר הפקודה, לחץ על פקודה:

bootcfg addsw

פקודה זו מוסיפה אפשרויות טעינה של מערכת הפעלה עבור ערך ספציפי של מערכת הפעלה.

תחביר

bootcfg ‎/addsw ‎[/s Computer [/u Domain\User /p Password]]‎ ‎[/mm MaximumRAM]‎ ‎[/bv]‎ ‎[/so]‎ ‎[/ng]‎ ‎/id OSEntryLineNum

פרמטרים

‎/s Computer
פרמטר זה מציין שם או כתובת IP של מחשב מרוחק (אין להשתמש בקו נטוי הפוך). ברירת המחדל היא המחשב המקומי.
‎/u Domain\User
פרמטר זה מפעיל את הפקודה עם הרשאות החשבון של המשתמש שצוין ב- User או ב- Domain\User. ברירת המחדל היא ההרשאות של המשתמש הנוכחי במחשב המנפיק את הפקודה.
‎/p Password
פרמטר זה מציין את הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u .
‎/mm MaximumRAM
פרמטר זה מוסיף את הבורר ‎/maxmem לפרמטר OSEntryLineNum שצוין וקובע את כמות ה- RAM המירבית בה יכולה מערכת ההפעלה להשתמש.
‎/bv
פרמטר זה מוסיף את הבורר ‎/basevideo לפרמטר OSEntryLineNum שצוין ובכך מורה למערכת ההפעלה להשתמש במצב VGA סטנדרטי עבור מנהל התקן הווידיאו המותקן.
‎/so
פרמטר זה מוסיף את הבורר ‎/sos לפרמטר OSEntryLineNum שצוין ובכך מורה למערכת ההפעלה להציג את שמות מנהלי ההתקן בזמן טעינתם.
‎/ng
פרמטר זה מוסיף את הבורר ‎/noguiboot לפרמטר OSEntryLineNum שצוין ובכך הופך את מד ההתקדמות של Windows XP Professional המופיע לפני פקודת ההפעלה CTRL+ALT+DEL ללא זמין.
‎/id OSEntryLineNum
פרמטר זה מציין את מספר שורת הערך של מערכת ההפעלה במקטע [operating systems] בקובץ Boot.ini שלתוכו נוספות אפשרויות הטעינה של מערכת ההפעלה. השורה הראשונה אחרי כותרת המקטע [operating systems] היא 1.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

דוגמאות

הדוגמאות שלהלן מדגימות כיצד באפשרותך להשתמש בפקודה bootcfg /addsw:

bootcfg /addsw /mm 64 /id 2
bootcfg /addsw /so /id 3
bootcfg /addsw /so /ng /s srvmain /u hiropln /id 2
bootcfg /addsw /ng /id 2
bootcfg /addsw /mm 96 /ng /s srvmain /u maindom\hiropln /p p@ssW23 /id 2

bootcfg copy

פקודה זו יוצרת העתק של מופע מערכת ההפעלה. ניתן להוסיף בוררים לעותק זה.

תחביר

bootcfg ‎/copy ‎[/s Computer [/u Domain\User /p Password]]‎ ‎[/d Description]‎ ‎[/id OSEntryLineNum]‎

פרמטרים

‎/s Computer
פרמטר זה מציין שם או כתובת IP של מחשב מרוחק (אין להשתמש בקו נטוי הפוך). ברירת המחדל היא המחשב המקומי.
‎/u Domain\User
פרמטר זה מפעיל את הפקודה עם הרשאות החשבון של המשתמש שצוין ב- User או ב- Domain\User. ברירת המחדל היא ההרשאות של המשתמש הנוכחי במחשב המנפיק את הפקודה.
‎/p Password
פרמטר זה מציין את הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u .
‎/d Description
פרמטר זה מציין את התיאור עבור הערך החדש של מערכת ההפעלה.
‎/id OSEntryLineNum
פרמטר זה מציין את מספר שורת הערך של מערכת ההפעלה במקטע [operating systems] בקובץ Boot.ini שאותה יש להעתיק. השורה הראשונה אחרי כותרת המקטע [operating systems] היא 1.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

דוגמאות

הדוגמאות שלהלן מדגימות כיצד באפשרותך להשתמש בפקודה bootcfg /copy:

bootcfg /copy /d "\ABC Server\" /id 1
bootcfg /copy /s srvmain /u maindom\hiropln /p p@ssW23 /d "Windows XP" /id 2
bootcfg /copy /u hiropln /p p@ssW23 /d "AB Ver 1.001" /id 2

bootcfg dbg1394

פקודה זו מגדירה איתור באגים ביציאה 1394 עבור ערך מסוים של מערכת הפעלה.

תחביר

bootcfg ‎/dbg1394 {ON|OFF|EDIT}‎ ‎[/s Computer [/u Domain\User /p Password]]‎ ‎[/ch channel]‎ ‎/id OSEntryLineNum

פרמטרים

ON|OFF|EDIT
פרמטר זה מציין את הערך עבור איתור באגים ביציאה 1394.
ערך | תיאור
ON | פרמטר זה מאפשר תמיכה באיתור באגים מרחוק על-ידי הוספת הבורר ‎/dbg1394 לפרמטר OSEntryLineNum שצוין.
OFF | פרמטר זה הופך את אפשרות התמיכה באיתור באגים מרחוק לבלתי זמינה. זאת על-ידי הסרת הבורר ‎/dbg1394 מהפרמטר OSEntryLineNum שצוין.
EDIT | פרמטר זה מאפשר לבצע שינויים בהגדרות היציאה וקצב השידור על-ידי שינוי ערכי הערוץ המשויכים לבורר ‎/dbg1394 עבור הפרמטר OSEntryLineNum שצוין.
‎/s Computer
פרמטר זה מציין שם או כתובת IP של מחשב מרוחק (אין להשתמש בקו נטוי הפוך). ברירת המחדל היא המחשב המקומי.
‎/u Domain\User
פרמטר זה מפעיל את הפקודה עם הרשאות החשבון של המשתמש שצוין ב- User או ב- Domain\User. ברירת המחדל היא ההרשאות של המשתמש הנוכחי במחשב המנפיק את הפקודה.
‎/p Password
פרמטר זה מציין את הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u .
‎/ch channel
פרמטר זה מציין את הערוץ בו יש להשתמש לשם איתור באגים. ערכים חוקיים הם מספרים שלמים בין 1 ו- 64. אין להשתמש בפרמטר ‎/ch channel אם האפשרות לאיתור באגים ביציאה 1394 הופכת ללא זמינה.
‎/id OSEntryLineNum
פרמטר זה מציין את מספר שורת הערך של מערכת ההפעלה במקטע [operating systems] בקובץ Boot.ini שלתוכו נוספות אפשרויות איתור הבאגים ביציאה 1394. השורה הראשונה אחרי כותרת המקטע [operating systems] היא 1.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

דוגמאות

הדוגמאות שלהלן מדגימות כיצד באפשרותך להשתמש בפקודה bootcfg /dbg1394:

bootcfg /dbg1394 /id 2
bootcfg /dbg1394 on /ch 1 /id 3
bootcfg /dbg1394 edit /ch 8 /id 2
bootcfg /s srvmain /u maindom\hiropln /p p@ssW23 /dbg1394 off /id 2

bootcfg debug

פקודה זו מוסיפה או משנה את הגדרות איתור הבאגים עבור ערך מסוים של מערכת הפעלה.

תחביר

bootcfg ‎/debug {ON|OFF|EDIT}‎ ‎[/s Computer [/u Domain\User /p Password]]‎ ‎[/port {COM1|COM2|COM3|COM4}]‎ ‎[/baud {9600|19200|38400|57600|115200}]‎ ‎[/id OSEntryLineNum]‎

פרמטרים

ON|OFF|EDIT
פרמטר זה מציין את הערך לאיתור באגים.
ערך | תיאור
ON | פרמטר זה מאפשר תמיכה באיתור באגים מרחוק על-ידי הוספת הבורר ‎/debug לפרמטר OSEntryLineNum שצוין.
OFF | פרמטר זה הופך את אפשרות התמיכה מרחוק באיתור באגים לבלתי זמינה. זאת על-ידי הסרת הבורר ‎/debug מהפרמטר OSEntryLineNum שצוין.
EDIT | פרמטר זה מאפשר לבצע שינויים בהגדרות היציאה ומהירות השידור על-ידי שינוי הערכים המשויכים לבורר ‎/debug עבור הפרמטר OSEntryLineNum שצוין.
‎/s Computer
פרמטר זה מציין שם או כתובת IP של מחשב מרוחק (אין להשתמש בקו נטוי הפוך). ברירת המחדל היא המחשב המקומי.
‎/u Domain\User
פרמטר זה מפעיל את הפקודה עם הרשאות החשבון של המשתמש שצוין ב- User או ב- Domain\User. ברירות המחדל הן ההרשאות של המשתמש הנוכחי במחשב המנפיק את הפקודה.
‎/p Password
פרמטר זה מציין את הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u .
‎/port {COM1|COM2|COM3|COM4}‎
פרמטר זה מגדיר את השימוש ביציאת COM לשם איתור באגים. אין להשתמש בפרמטר ‎/port אם האפשרות לאיתור באגים הופכת ללא זמינה.
‎/baud {9600|19200|38400|57600|115200}‎
פרמטר זה מציין את קצב השידור בו יש להשתמש לשם איתור באגים. אין להשתמש בפרמטר ‎/baud אם האפשרות לאיתור באגים הופכת ללא זמינה.
‎/id OSEntryLineNum
פרמטר זה מציין את מספר שורת הערך של מערכת ההפעלה במקטע [operating systems] בקובץ Boot.ini שאליו נוספות אפשרויות איתור הבאגים. השורה הראשונה אחרי כותרת המקטע [operating systems] היא 1.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • אם יש צורך באיתור באגים ביציאה 1394, השתמש בפקודה bootcfg /dbg1394.

דוגמאות

הדוגמאות שלהלן מדגימות כיצד באפשרותך להשתמש בפקודה bootcfg /debug:

bootcfg /debug on /port com1 /id 2
bootcfg /debug edit /port com2 /baud 19200 /id 2
bootcfg /s srvmain /u maindom\hiropln /p p@ssW23 /debug off /id 2

bootcfg default

פקודה זו מציינת את הערך במערכת ההפעלה שאותו יש לייעד כברירת מחדל.

תחביר

bootcfg ‎/default ‎[/s Computer [/u Domain\User /p Password]]‎ ‎[‎/id OSEntryLineNum]‎

פרמטרים

‎/s Computer
פרמטר זה מציין שם או כתובת IP של מחשב מרוחק (אין להשתמש בקו נטוי הפוך). ברירת המחדל היא המחשב המקומי.
‎/u Domain\User
פרמטר זה מפעיל את הפקודה עם הרשאות החשבון של המשתמש שצוין ב- User או ב- Domain\User. ברירת המחדל היא ההרשאות של המשתמש הנוכחי במחשב המנפיק את הפקודה.
‎/p Password
פרמטר זה מציין את הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u .
‎/id OSEntryLineNum
פרמטר זה מציין את מספר שורת הערך של מערכת ההפעלה במקטע [operating systems] בקובץ Boot.ini שיש לייעד כברירת מחדל. השורה הראשונה אחרי כותרת המקטע [operating systems] היא 1.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

דוגמאות

הדוגמאות שלהלן מדגימות כיצד באפשרותך להשתמש בפקודה bootcfg /default :

bootcfg /default /id 2
bootcfg /default /s srvmain /u maindom\hiropln /p p@ssW23 /id 2

bootcfg delete

פקודה זו מוחקת ערך של מערכת הפעלה במקטע [Operating systems] בקובץ Boot.ini.

תחביר

bootcfg ‎/delete ‎[‎/s Computer [/u Domain\User /p Password]]‎ ‎[/id OSEntryLineNum]‎

פרמטרים

‎/s Computer
פרמטר זה מציין שם או כתובת IP של מחשב מרוחק (אין להשתמש בקו נטוי הפוך). ברירת המחדל היא המחשב המקומי.
‎/u Domain\User
פרמטר זה מפעיל את הפקודה עם הרשאות החשבון של המשתמש שצוין ב- User או ב- Domain\User. ברירת המחדל היא ההרשאות של המשתמש הנוכחי במחשב המנפיק את הפקודה.
‎/p Password
פרמטר זה מציין את הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u .
‎/id OSEntryLineNum
פרמטר זה מציין את מספר שורת הערך של מערכת ההפעלה במקטע [operating systems] בקובץ Boot.ini שאותו יש למחוק. השורה הראשונה אחרי כותרת המקטע [operating systems] היא 1.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

דוגמאות

הדוגמאות שלהלן מדגימות כיצד באפשרותך להשתמש בפקודה bootcfg /delete :

bootcfg /delete /id 1
bootcfg /delete /s srvmain /u maindom\hiropln /p p@ssW23 /id 3

bootcfg ems

פקודה זו מאפשרת למשתמש להוסיף או לשנות את ההגדרות לניתוב מחדש של מסוף ה- EMS למחשב מרוחק. על-ידי הפיכת ה- EMS לזמין, מתווספת השורה ‏"redirect=Port‎#‎"‏ למקטע [boot loader] בקובץ Boot.ini ומתווסף בורר ‎/redirect לשורת הערך במערכת ההפעלה שצוינה. התכונה EMS זמינה רק בשרתים.

תחביר

bootcfg ‎/ems {ON|OFF|EDIT}‎ ‎[/s Computer [/u Domain\User /p Password]]‎ ‎[/port {COM1|COM2|COM3|COM4|BIOSSET}]‎ ‎[/baud {9600|19200|38400|57600|115200}]‎ ‎[/id OSEntryLineNum]‎

פרמטרים

ON|OFF|EDIT
פרמטר זה מציין את הערך לניתוב מחדש של EMS.
ערך | תיאור
ON | פרמטר זה הופך לזמין את הפלט המרוחק עבור הפרמטר OSEntryLineNum‏. כמו כן, פרמטר זה מוסיף בורר ‎/redirect לפרמטר OSEntryLineNum שצוין והגדרה redirect=comX למקטע [boot loader]. הערך של comX נקבע על-ידי הפרמטר ‎/port.
OFF | פרמטר זה הופך את הפלט למחשב המרוחק לבלתי זמין. הפרמטר מסיר את הבורר ‎/redirect מהפרמטר OSEntryLineNum שצוין ואת ההגדרה redirect=comX מהמקטע [boot loader].
EDIT | פרמטר זה מתיר שינויים בהגדרות היציאה על-ידי שינוי ההגדרה redirect=comXבמקטע [boot loader]. ערך ההגדרה comX מאופס לערך שצוין על-ידי הפרמטר ‎/port.
‎/s Computer
פרמטר זה מציין שם או כתובת IP של מחשב מרוחק (אין להשתמש בקו נטוי הפוך). ברירת המחדל היא המחשב המקומי.
‎/u Domain\User
פרמטר זה מפעיל את הפקודה עם הרשאות החשבון של המשתמש שצוין בתיבה User או בתיבה Domain\User. ברירת המחדל היא ההרשאות של המשתמש הנוכחי במחשב המנפיק את הפקודה.
‎/p Password
פרמטר זה מציין את הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u .
‎/port {COM1|COM2|COM3|COM4|BIOSSET}‎
פרמטר זה מציין איזו יציאת COM תשמש לניתוב מחדש. הפרמטר BIOSSET מורה ל- EMS להשיג את הגדרות ה- BIOS כדי לקבוע באיזו יציאה יש להשתמש עבור ניתוב מחדש. אין להשתמש בפרמטר ‎/port אם פלט שמנוהל מרחוק הופך ללא זמין.
‎/baud {9600|19200|38400|57600|115200}‎
פרמטר זה מציין את קצב השידור שישמש לשם ניתוב מחדש. אין להשתמש בפרמטר ‎/baud אם פלט שמנוהל מרחוק הופך ללא זמין.
‎/id OSEntryLineNum
פרמטר זה מציין את מספר שורת הערך של מערכת ההפעלה שאליו מתווספת האפשרות EMS במקטע [operating systems] בקובץ Boot.ini. השורה הראשונה אחרי כותרת המקטע [operating systems] היא 1. פרמטר זה דרוש כאשר ערך ה- EMS מוגדר כ- ON או OFF.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • לקבלת מידע נוסף אודות Emergency Management Services‏ (EMS), ראה מרכז העזרה והתמיכה.

דוגמאות

הדוגמאות שלהלן מדגימות כיצד באפשרותך להשתמש בפקודה bootcfg /ems :

bootcfg /ems on /port com1 /baud 19200 /id 2
bootcfg /ems on /port biosset /id 3
bootcfg /s srvmain /ems off /id 2
bootcfg /ems edit /port com2 /baud 115200
bootcfg /s srvmain /u maindom\hiropln /p p@ssW23 /ems off /id 2

bootcfg query

פקודה זו מבצעת שאילתות על ערכי המקטעים [boot loader] ו- [operating systems] מהקובץ Boot.ini ומציגה אותם.

תחביר

bootcfg ‎/query ‎[‎/s Computer [‎/u Domain\User ‎/p Password]]‎

פרמטרים

‎/s Computer
פרמטר זה מציין שם או כתובת IP של מחשב מרוחק (אין להשתמש בקו נטוי הפוך). ברירת המחדל היא המחשב המקומי.
‎/u Domain\User
פרמטר זה מפעיל את הפקודה עם הרשאות החשבון של המשתמש שצוין ב- User או ב- Domain\User. ברירת המחדל היא ההרשאות של המשתמש הנוכחי במחשב המנפיק את הפקודה.
‎/p Password
פרמטר זה מציין את הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u .
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • להלן דוגמה של פלט של הפקודה bootcfg /query:
    Boot Loader Settings
--------------------
timeout: 30
default: multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

Boot Entries
------------
Boot entry ID:   1
Friendly Name:   "Microsoft Windows XP Professional"
Path:            multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
OS Load Options: /fastdetect /debug /debugport=com1:
  • החלק Boot Loader Settings מתוך הפלט של הפקודה bootcfg query מציג כל ערך מתוך המקטע [boot loader] בקובץ Boot.ini.
  • החלק Boot Entries מתוך הפלט של הפקודה bootcfg query מציג את הפירוט שלהלן עבור כל ערך מערכת הפעלה במקטע [operating systems] בקובץ Boot.ini‏: Boot entry ID‏, Friendly Name‏, Path‏ ו- OS Load Options.

דוגמאות

הדוגמאות שלהלן מדגימות כיצד באפשרותך להשתמש בפקודה bootcfg /query :

bootcfg /query
bootcfg /query /s srvmain /u maindom\hiropln /p p@ssW23
bootcfg /query /u hiropln /p p@ssW23

bootcfg raw

פקודה זו מוסיפה אפשרויות טעינה של מערכת הפעלה שצוינו כמחרוזת לערך של מערכת הפעלה המופיע במקטע [operating systems] בקובץ Boot.ini.

תחביר

bootcfg ‎[‎/s Computer [‎/u Domain\User ‎/p Password]]‎ ‎/raw OSLoadOptionsString ‎[/id OSEntryLineNum]‎

פרמטרים

‎/s Computer
פרמטר זה מציין שם או כתובת IP של מחשב מרוחק (אין להשתמש בקו נטוי הפוך). ברירת המחדל היא המחשב המקומי.
‎/u Domain\User
פרמטר זה מפעיל את הפקודה עם הרשאות החשבון של המשתמש שצוין ב- User או ב- Domain\User. ברירת המחדל היא ההרשאות של המשתמש הנוכחי במחשב המנפיק את הפקודה.
‎/p Password
פרמטר זה מציין את הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u .
OSLoadOptionsString
פרמטר זה מציין את אפשרויות הטעינה של מערכת ההפעלה אותן יש להוסיף לערך של מערכת ההפעלה. אפשרויות טעינה אלה יחליפו כל אפשרויות טעינה קיימות המשויכות לערך של מערכת ההפעלה. לא מתבצע כל אימות של הפרמטר OSLoadOptions.
‎/id OSEntryLineNum
פרמטר זה מציין את מספר שורת הערך של מערכת ההפעלה במקטע [operating systems] בקובץ Boot.ini שיעודכן. השורה הראשונה אחרי כותרת המקטע [operating systems] היא 1.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • הפקודה Bootcfg raw משמשת להוספת טקסט לסוף הערך של מערכת ההפעלה, ומחליפה את כל אפשרויות ערך מערכת ההפעלה הקיימות. על טקסט זה להכיל אפשרויות OS Load Options חוקיות כגון ‎/debug‏, ‎/fastdetect‏, ‎/nodebug‏, ‎/baudrate‏, ‎/crashdebug‏ ו- ‎/sos. לדוגמה, הפקודה שלהלן מוסיפה את הפרמטרים ‎"‎/debug /fastdetect"‎ לסוף ערך מערכת ההפעלה הראשון, ומחליפה את כל אפשרויות ערך מערכת ההפעלה הקודמות:

    bootcfg /raw "/debug /fastdetect" /id 1

  • לקבלת מידע נוסף אודות OS Load Options אפשריות ואודות השימוש שעושה Windows בקובץ Boot.ini במהלך האתחול, ראה מאמר Q170756‏, ‎"Available Switch Options for Windows NT Boot.ini File"‎ המצוי ב- Microsoft Knowledge Base‏. (http://www.microsoft.com/‎)

דוגמאות

הדוגמאות שלהלן מדגימות כיצד באפשרותך להשתמש בפקודה bootcfg /raw:

bootcfg /raw "/debug /sos" /id 2
bootcfg /raw /s srvmain /u maindom\hiropln /p p@ssW23 "/crashdebug " /id 2

bootcfg rmsw

פקודה זו מסירה אפשרויות טעינה של מערכת הפעלה עבור ערך מערכת הפעלה שצוין.

תחביר

bootcfg ‎/rmsw ‎[/s Computer [/u Domain\User /p Password]]‎ ‎[/mm]‎ ‎[/bv]‎ ‎[/so]‎ ‎[/ng]‎ ‎/id OSEntryLineNum

פרמטרים

‎/s Computer
פרמטר זה מציין שם או כתובת IP של מחשב מרוחק (אין להשתמש בקו נטוי הפוך). ברירת המחדל היא המחשב המקומי.
‎/u Domain\User
פרמטר זה מפעיל את הפקודה עם הרשאות החשבון של המשתמש שצוין ב- User או ב- Domain\User. ברירת המחדל היא ההרשאות של המשתמש הנוכחי במחשב המנפיק את הפקודה.
‎/p Password
פרמטר זה מציין את הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u .
‎/mm
פרמטר זה מסיר את הבורר ‎/maxmem ואת ערך הזיכרון המירבי המיוחס לו מהפרמטר OSEntryLineNum. הבורר ‎/maxmem מציין את כמות ה- RAM המירבית שבה יכולה מערכת ההפעלה להשתמש.
‎/bv
פרמטר זה מסיר את הבורר ‎/basevideo מהפרמטר OSEntryLineNum. הבורר ‎/basevideo מורה למערכת ההפעלה להשתמש במצב VGA סטנדרטי עבור מנהל התקן הווידיאו המותקן.
‎/so
פרמטר זה מסיר את הבורר ‎/sos מהפרמטר OSEntryLineNum. הבורר ‎/sos מורה למערכת ההפעלה להציג את שמות מנהלי ההתקנים בזמן טעינתם.
‎/ng
פרמטר זה מסיר את הבורר ‎/noguiboot מהפרמטר OSEntryLineNum. הבורר ‎/noguiboot הופך את מד ההתקדמות של Windows XP Professional המופיע לפני בקשת הכניסה של CTRL+ALT+DEL לבלתי זמין.
‎/id OSEntryLineNum
פרמטר זה מציין את מספר שורת הערך של מערכת ההפעלה במקטע [operating systems] בקובץ Boot.ini ממנו מוסרות אפשרויות הטעינה OS Load Options. השורה הראשונה אחרי כותרת המקטע [operating systems] היא 1.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

דוגמאות

הדוגמאות שלהלן מדגימות כיצד באפשרותך להשתמש בפקודה bootcfg /rmsw :

bootcfg /rmsw /mm 64 /id 2
bootcfg /rmsw /so /id 3
bootcfg /rmsw /so /ng /s srvmain /u hiropln /id 2
bootcfg /rmsw /ng /id 2
bootcfg /rmsw /mm 96 /ng /s srvmain /u maindom\hiropln /p p@ssW23 /id 2

bootcfg timeout

פקודה זו משנה את ערך הזמן הקצוב של מערכת ההפעלה.

תחביר

bootcfg ‎/timeout TimeOutValue ‎[/s Computer [‎/u Domain\User ‎/p Password]]‎

פרמטרים

TimeOutValue
פרמטר זה מציין את ערך הזמן הקצוב במקטע [boot loader]. ערך זה הוא מספר השניות העומדות לרשות המשתמש לבחירת מערכת הפעלה ממסך מטעין האתחול לפני ש- NTLDR טוען את ברירת המחדל. אם הערך הוא 0, NTLDR מפעיל מיד את מערכת ההפעלה שהיא ברירת המחדל מבלי להציג את מסך מטעין האתחול.
‎/s Computer
פרמטר זה מציין שם או כתובת IP של מחשב מרוחק (אין להשתמש בקו נטוי הפוך).ברירת המחדל היא המחשב המקומי.
‎/u Domain\User
פרמטר זה מפעיל את הפקודה עם הרשאות החשבון של המשתמש שצוין ב-User או ב- Domain\User. ברירת המחדל היא ההרשאות של המשתמש הנוכחי במחשב המנפיק את הפקודה.
‎/p Password
פרמטר זה מציין את הסיסמה של חשבון המשתמש שצוינה בפרמטר ‎/u .
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

דוגמאות

הדוגמאות שלהלן מדגימות כיצד באפשרותך להשתמש בפקודהbootcfg /timeout :

bootcfg /timeout 30
bootcfg /s srvmain /u maindom\hiropln /p p@ssW23 /timeout 50


גרפיקה של Microsoft Windows

Break

XOX


גרפיקה של Microsoft Windows

Buffers

XOX


Cacls

פקודה זו מציגה או משנה קבצי רשימות בקרת גישה לפי שיקול דעת (DACL).

תחביר

cacls FileName [/t] [/e] [/c] [/g User:permission] [/r User [...]] [/p User:permission [...]] [/d User [...]]

פרמטרים

FileName
פרמטר נדרש. הפרמטר מציג רשימות בקרת גישה לפי שיקול דעת של קבצים שצוינו.
‎/t
פרמטר זה משנה רשימות בקרת גישה לפי שיקול דעת של הקבצים שצוינו בספריה הנוכחית ובכל ספריות המשנה.
‎/e
פרמטר זה מבצע עריכה של רשימת בקרת גישה לפי שיקול דעת במקום להחליף אותה.
‎/c
פרמטר זה מורה על המשך ביצוע שינויים ברשימות בקרת גישה לפי שיקול דעת תוך התעלמות משגיאות.
‎/g User:permission
פרמטר זה מעניק זכויות גישה למשתמש שצוין. הטבלה שלהלן מציגה ערכים חוקיים עבור permission.
ערך | תיאור
n | ללא
r | קריאה
w | כתיבה
c | שינוי (כתיבה)
f | שליטה מלאה
‎/r User
פרמטר זה שולל את זכויות הגישה של המשתמש שצוין.
‎/p User:permission
פרמטר זה מחליף את זכויות הגישה של המשתמש שצוין. הטבלה שלהלן מציגה ערכים חוקיים של permission.
ערך | תיאור
n | ללא
r | קריאה
w | כתיבה
c | שינוי (כתיבה)
f | שליטה מלאה
‎/d User
פרמטר זה דוחה את בקשת הגישה של המשתמש שצוין.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • היעזר בטבלה הבאה כדי לפענח את התוצאות.
    פלט | ערך בקרת הגישה (ACE) מתייחס ל
    OI | תיקיה זו וקבצים אלה
    CI | תיקיה זו ותיקיות משנה
    IO | ערך בקרת הגישה אינו מתייחס לקובץ/לספריה הנוכחיים.
    No output message | תיקיה זו בלבד
    (IO)(CI) | תיקיה זו, תיקיות משנה וקבצים
    (OI)(CI)(IO) | תיקיות משנה וקבצים בלבד
    (CI)(IO) | תיקיות משנה בלבד
    (OI)(IO) | קבצים בלבד
  • באפשרותך להשתמש בתווים כלליים (כלומר * ו- ?) כדי לציין קבצים מרובים.
  • באפשרותך לציין יותר ממשתמש אחד.


Call

פקודה זו קוראת לתוכנית אצווה אחת מתוכנית אחרת מבלי להפסיק את פעולתה של תוכנית האצווה האב. הפקודה call מקבלת תוויות כיעד הקריאה. לפקודה Call אין כל השפעה על שורת הפקודה כאשר משתמשים בה מחוץ לקובץ Script או קובץ אצווה.

תחביר

call [[Drive:][Path] FileName [BatchParameters]]‎ ‎[:label [arguments]]‎

פרמטרים

‎[Drive:][Path] FileName
פרמטר זה קובע את המיקום והשם של תוכנית האצווה לה ברצונך לקרוא. על הפרמטר FileName להיות בעל סיומת ‎.bat או ‎.cmd
BatchParameters
פרמטר זה מציין כל מידע המופיע בשורת הפקודה הנדרש על-ידי תוכנית האצווה, כולל אפשרויות שורת פקודה, שמות קבצים, פרמטרי אצווה (כלומר, %0 עד %9), או משתנים (לדוגמה %baud%).
‎:label
פרמטר זה מציין את התווית שאליה ברצונך להעביר את השליטה בתוכנית האצווה. שימוש בפקודה call עם פרמטר זה ייצור הקשר חדש של קובץ אצווה ויעביר שליטה למשפט הבא לאחר התווית שצוינה. בפעם הראשונה שהמערכת תיתקל בסוף של קובץ האצווה (לאחר המעבר לתווית), השליטה תחזור למשפט שלאחר משפט call. בפעם השנייה שהמערכת תיתקל בסוף של קובץ האצווה, תתבצע יציאה מה- Script של האצווה. לקבלת תיאור של סיומת goto :eof המאפשרת חזרה מ- Script של אצווה, ראה נושאים קרובים.
arguments
פרמטר זה מציין כל מידע המצוי בשורת הפקודה המועבר למופע החדש של תוכנית האצווה המתחיל בפרמטר ‎:label, כולל אפשרויות שורת פקודה, שמות קבצים, פרמטרי אצווה (כלומר, %1 עד %9) או משתנים (לדוגמה, %baud%).
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • שימוש בפרמטרי אצווה

    פרמטרי אצווה יכולים להכיל כל מידע שאותו תעביר לתוכנית אצווה, כולל אפשרויות שורת פקודה, שמות קבצים, פרמטרי אצווה (כלומר, %0 עד %9) ומשתנים (לדוגמה %baud%). לקבלת מידע נוסף אודות פרמטרי אצווה, ראה נושאים קרובים.

  • שימוש ברכיבי Pipe וסמלי ניתוב מחדש

    אין להשתמש ברכיבי Pipe וסמלי ניתוב מחדש עם הפקודה call.

  • ביצוע שיחה רקורסיבית

    באפשרותך ליצור תוכנית אצווה הקוראת לעצמה; עם זאת, עליך לספק תנאי יציאה. אחרת, תוכניות האב והצאצא של האצווה עשויות להמשיך בלולאה אינסופית.

  • עבודה עם הרחבות פקודה

    כאשר האפשרות של הרחבות פקודה היא זמינה (כלומר, ברירת המחדל), הפקודה call מקבלת label כמטרת הקריאה. התחביר הנכון הוא כדלקמן:

    call :label arguments

    למידע נוסף אודות הפיכת הרחבות פקודה לזמינות ולא זמינות, ראה את cmd בנושאים קרובים.

דוגמאות

לשם הפעלת התוכנית Checknew.bat מתוכנית אצווה אחרת, הקלד את הפקודה הבאה בתוכנית האצווה האב:

call checknew

נניח שתוכנית האצווה האב מקבלת שני פרמטרי אצווה וברצונך שהתוכנית תעביר פרמטרים אלה לתוכנית Checknew.bat. באפשרותך להשתמש בפקודה הבאה בתוכנית האצווה האב:

call checknew %1 %2


Chcp

פקודה זו מציגה את המספר של קידוד המסוף הפעיל או משנה את קידוד המסוף הפעיל של המסוף. כאשר נעשה בה שימוש ללא פרמטרים, הפקודה chcp מציגה את המספר של קידוד המסוף הפעיל.

תחביר

chcp [nnn‎]‎

פרמטרים

nnn
פרמטר זה מציין את הקידוד. הטבלה הבאה מציגה כל קידוד נתמך והמדינה/אזור או השפה המשויכים לו:
קידוד | מדינה/אזור או שפה
437 | ארצות הברית
850 | רב-לשוני (לטינית I)
852 | סלאבית (לטינית II)
855 | קירילית (רוסית)
857 | טורקית
860 | פורטוגזית
861 | איסלנדית
863 | קנדית-צרפתית
865 | נורדית
866 | רוסית
869 | יוונית מודרנית
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • רק הקידוד של יצרן הציוד המקורי (OEM) המותקן עם Windows XP מופיע כראוי בחלון שורת פקודה המשתמש בגופני סריקה. קידודים אחרים יופיעו כראוי במצב מסך מלא או בחלונות שורת פקודה המשתמשים בגופני TrueType.
  • אין צורך להכין קידודים כפי שנעשה ב- MS-DOS.
  • תוכניות המופעלות לאחר שהוקצה קידוד חדש משתמשות בקידוד החדש. אך תוכניות (מלבד Cmd.exe) המופעלות לפני הקצאת הקידוד החדש משתמשות בקידוד המקורי.

דוגמאות

כדי להציג את הגדרת הקידוד הפעיל, הקלד:

chcp

ההודעה שתופיע תהיה דומה להודעה הבאה:

Active code page: 437

כדי לשנות את הקידוד הפעיל ל- 850 (רב-לשוני), הקלד:

chcp 850

אם הקידוד שצוין אינו חוקי, תופיע הודעת השגיאה הבאה:

Invalid code page


Chdir

גרפיקה של Microsoft Windows

Chdir (Cd‎)‎

פקודה זו מציגה את שם הספריה הנוכחית או משנה את התיקיה הנוכחית. כאשר נעשה שימוש בפקודה זו עם אות כונן בלבד (לדוגמה chdir C:‎), הפקודה chdir מציגה את שמות הכונן והתיקיה הנוכחיים. כאשר נעשה שימוש בפקודה זו ללא פרמטרים, chdir מציגה את הכונן והספריה הנוכחיים.

תחביר

chdir [[/d] [Drive:][Path] [..]]‎ ‎[[/d] [Drive:][Path] [..]]‎

cd [[/d] [Drive:][Path] [..]]‎ ‎[[/d] [Drive:][Path] [..]]‎

פרמטרים

‎/d
פרמטר זה משנה את הכונן הנוכחי או את הספריה הנוכחית בכונן.
‎[drive:][Path]‎
פרמטר זה מציין את הכונן (אם הוא אינו הכונן הנוכחי) והספריה שברצונך לעבור אליהם.
[..]
פרמטר זה מציין כי ברצונך לעבור אל תיקיית האב.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • עבודה עם הרחבות פקודה

    כאשר הרחבות הפקודה זמינות (זוהי ברירת המחדל) נתיב הספריה הנוכחית תואם לשמות התיקיות בדיוק כפי שאלה מופיעים בכונן הקשיח, תוך שימוש באותה תבנית של אותיות רישיות או אותיות קטנות של שם התיקיה. לדוגמה, אם תיקיה בכונן הקשיח שלך נקראת C:\Temp, הפקודה CD C:\TEMP קובעת את הספריה הנוכחית ל- C:\Temp כך שתתאים לתבנית שם התיקיה של התיקיה בכונן הקשיח.

    כדי להפוך את הרחבות הפקודה לבלתי זמינות עבור תהליך מסוים, הקלד:

    cmd e:off

    בעת הפיכת הרחבות הפקודה לבלתי זמינות, הפקודה chdir אינה מתייחסת לרווחים לבנים כאל מפרידים. כתוצאה מכך, באפשרותך להחליף לשם של ספריית משנה המכיל רווח לבן מבלי להקיף את [Path] במרכאות. לדוגמה, הנתיב שלהלן מחליף לספריית המשנה של תפריט ההתחלה ( ‎\Start):

    cd \winnt\profiles\username\programs\start menu

    לקבלת מידע נוסף אודות הפיכת הרחבות פקודה לזמינות או לבלתי זמינות, ראה cmd בנושאים קרובים.

  • מעבר לספריית הבסיס

    ספריית הבסיס נמצאת בראש הירארכיית הספריות של כונן. כדי לחזור לספריית הבסיס, הקלד:

    cd\‎

  • החלפת ספריית ברירת המחדל בכונן אחד מכונן אחר

    כדי להחליף את ספריית ברירת המחדל בכונן שאינו הכונן הנוכחי בו אתה עובד, הקלד אחת מהפקודות הבאות:

    chdir [Drive:\[directory]]‎

    cd [Drive:\[directory]]‎

    כדי לאמת את שינוי הספריה, הקלד אחת מהפקודות הבאות:

    chdir [Drive:]‎

    cd [Drive:]‎

  • הפקודה chdir זמינה ממסוף השחזור עם פרמטרים אחרים.

דוגמאות

כאשר נעשה שימוש בפקודה זו עם שם כונן, הפקודה chdir מציגה את הספריה הנוכחית באותו כונן. לדוגמה, לאחר הקלדת הפקודה cd c:‎ בשורת הספריה C:\Temp, מופיע הפלט שלהלן:

C:\Temp

כדי לעבור מהספריה הנוכחית לספריה הנקראת Reports, הקלד אחת מהפקודות הבאות:

chdir \reports

cd \reports

כדי לשנות את הספריה הנוכחית לספריית המשנה ‎\Specials\Sponsors, הקלד:

cd \specials\sponsors

לחלופין, אם הספריה הנוכחית בה אתה עובד היא ‎\Specials, הקלד את הפקודה הבאה כדי לעבור לספריית המשנה ‎\Specials\Sponsors:

cd sponsors

כדי לעבור מספריית משנה לספריית האב שלה, הקלד:

cd ..‎

לשם הצגת השם של הספריה הנוכחית, באפשרותך להשתמש בפקודות chdir או cd ללא פרמטר. לדוגמה, אם הספריה הנוכחית היא ‎\Public\Jones בכונן B, הקלד chdir כדי לקבל את הפלט הבא:

B:\Public\Jones

אם אתה עובד בכונן D וברצונך להעתיק את כל הקבצים בספריות ‎\Public\Jones ו- ‎\Public\Lewis בכונן C לספריית הבסיס בכונן D, הקלד את הפקודות הבאות:

chdir c:\public\jones

copy c:*.* d:\‎

chdir c:\public\lewis

copy c:*.* d:\‎

אם ברצונך להעתיק את כל הקבצים בספריות ‎\Public\Jones ו- ‎\Public\Lewis למיקום הנוכחי שלך בכונן D, הקלד:

chdir c:\public\jones

copy c:*.* d:‎

chdir c:\public\lewis

copy c:*.* d:‎


Chkdsk

פקודה זו יוצרת ומציגה דו"ח מצב עבור דיסק, בהתבסס על מערכת הקבצים הנמצאת בשימוש. בנוסף, הפקודה Chkdsk מפרטת ומתקנת שגיאות בדיסק. כאשר נעשה בה שימוש ללא פרמטרים, הפקודה chkdsk מציגה את מצב הדיסק בכונן הנוכחי.

תחביר

chkdsk [volume:][[Path] FileName]‎ [‎/f] [‎/v] [‎/r] [‎/x] [‎/i] [‎/c] ‎[/l[:size]]‎

פרמטרים

volume‎:‎
פרמטר זה מציין את אות הכונן (שאחריה מופיעות נקודתיים), נקודת הטעינה או שם אמצעי האחסון.
‎[Path] FileName
פרמטר זה מציין את המיקום והשם של קובץ או קבוצת קבצים שברצונך שהפקודה chkdsk תבדוק כדי לוודא שאין בהם פיצול. באפשרותך להשתמש בתווים כלליים (כלומר, * ו- ?) כדי לציין קבצים מרובים.
‎/f
פרמטר זה מתקן שגיאות בדיסק. על הדיסק להיות נעול. אם הפקודה chkdsk אינה יכולה לנעול את הכונן, מופיעה הודעה השואלת את המשתמש אם ברצונו לבדוק את הכונן בפעם הבאה בה יאותחל המחשב.
‎/v
הצגת השם של כל קובץ בכל ספריה בעת בדיקת הדיסק.
‎/r
מיקום סקטורים פגומים ושחזור מידע ניתן לקריאה. על הדיסק להיות נעול.
‎/x
לשימוש עם NTFS בלבד. פרמטר זה כופה על אמצעי האחסון להפסיק ראשון את טעינתו, במידת הצורך. מבוטל תוקפם של כל המזהים הייחודיים הפתוחים של כונן. הפרמטר ‎/x כולל גם את הפונקציונליות של הפרמטר ‎/f.
‎/i
לשימוש עם NTFS בלבד. פרמטר זה מבצע בדיקה פחות קפדנית של ערכי אינדקס כדי להפחית את כמות הזמן הדרושה להפעלת הפקודה chkdsk.
‎/c
לשימוש עם NTFS בלבד. פרמטר זה מדלג על בדיקת מעגלים בתוך מבנה התיקיה כדי להפחית את כמות הזמן הדרושה להפעלת הפקודה chkdsk.
‎/l[:size]‎
לשימוש עם NTFS בלבד. פרמטר זה משנה את גודלו של קובץ יומן הרישום לגודל שהוזן. אם פרמטר הגודל מושמט, הפרמטר ‎/l מציג את הגודל הנוכחי.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • הפעלת chkdsk

    לשם הפעלת הפקודה chkdsk בדיסק קבוע עליך להיות חבר בקבוצה Administrators.

  • בדיקה של כונן נעול בעת הפעלה מחדש

    אם ברצונך שהפקודה chkdsk תתקן שגיאות בדיסק, אל תשאיר קבצים פתוחים בכונן. אם יימצאו קבצים פתוחים תופיע הודעת השגיאה הבאה:

    Chkdsk cannot run because the volume is in use by another process. Would you like to schedule this volume to be checked the next time the system restarts? (Y/N)‎

    אם תבחר לבדוק את הכונן בפעם הבאה שתפעיל מחדש את המחשב, הפקודה chkdsk תבדוק את הכונן ותתקן שגיאות אוטומטית כאשר המחשב יופעל מחדש. אם מחיצת הכונן היא מחיצת אתחול, הפקודה chkdsk תפעיל מחדש את המחשב אוטומטית לאחר בדיקת הכונן.

  • דיווח על שגיאות בדיסק

    הפקודה Chkdsk בודקת את שטח הדיסק ואת השימוש בדיסק עבור מערכות הקבצים טבלת מיקומי קבצים (FAT) ו- NTFS. הפקודה Chkdsk מספקת מידע ספציפי לכל מערכת קבצים בדו"ח מצב. דו"ח המצב מציג שגיאות שנמצאו במערכת הקבצים. אם תשתמש בפקודה chkdsk ללא אפשרות שורת הפקודה ‎/f במחיצה פעילה, הפקודה עשויה לדווח על שגיאות מזויפות משום שאין לה אפשרות לנעול את הכונן. מומלץ להשתמש בפקודה chkdsk מדי פעם בכל דיסק כדי לאתר שגיאות.

  • תיקון שגיאות בדיסק

    הפקודה Chkdsk מתקנת שגיאות בדיסק רק אם תצוין אפשרות שורת הפקודה ‎/f. על הפקודה Chkdsk לבצע נעילה של הכונן כדי לתקן שגיאות. משום שתיקוני שגיאות משנים בדרך כלל את טבלת מיקומי הקבצים של הדיסק ולעיתים גורמת לאובדן נתונים, הפקודה chkdsk שולחת הודעת אישור הדומה להודעה הבאה:

    ‎10 lost allocation units found in 3 chains‎.‎

    Convert lost chains to files‎?‎

    אם תקיש Y,‏ Windows ישמור כל שרשרת שאבדה בספריית הבסיס כקובץ Filennnn.chk. לאחר שהפקודה chkdsk תסיים את פעולתה, יהיה באפשרותך לבדוק את הקבצים האלה כדי לראות אם הם מכילים נתונים הדרושים לך. אם תקיש N,‏ Windows יתקן את הדיסק אך לא ישמור את התוכן של יחידות ההקצאה שאבדו.

    אם לא תשתמש באפשרות שורת הפקודה ‎/f, הפקודה chkdsk תשלח הודעה אם יש צורך לתקן קובץ, אך לא תתקן שגיאות.

    אם תשתמש בפקודה chkdsk /f ‎ בדיסק גדול מאוד (לדוגמה, ‎70 ‎GB‎) או דיסק בעל מספר רב מאוד של קבצים (לדוגמה, מיליונים), ייתכן שלפקודה chkdsk יידרש זמן רב (אפילו ימים) כדי להשלים את הפעולה. המחשב לא יהיה זמין במשך זמן זה, מכיוון שהפקודה chkdsk אינה מוותרת על השליטה במחשב עד לסיום הפעולה.

  • בדיקה של דיסק מסוג FAT

    Windows מציג דו"חות מצב של הפקודה chkdsk עבור דיסק מסוג FAT בתבנית הבאה:

    Volume Serial Number is B1AF-AFBF

    72214528 bytes total disk space

    73728 bytes in 3 hidden files

    30720 bytes in 12 directories

    11493376 bytes in 386 user files

    61440 bytes in bad sectors

    60555264 bytes available on disk

    2048 bytes in each allocation unit

    35261 total allocation units on disk

    29568 available allocation units on disk

  • בדיקת דיסק מסוג NTFS

    Windows מציג דו"חות מצב של הפקודה chkdsk עבור דיסק מסוג NTFS בתבנית הבאה:

    The type of the file system is NTFS‎.‎

    CHKDSK is verifying files‎...‎

    File verification completed‎.‎

    CHKDSK is verifying indexes‎...‎

    Index verification completed‎.‎

    CHKDSK is verifying security descriptors‎...‎

    Security descriptor verification completed‎.‎

    12372 kilobytes total disk space‎.‎

    3 kilobytes in 1 user files.‎

    2 kilobytes in 1 indexes.‎

    4217 kilobytes in use by the system.‎

    8150 kilobytes available on disk.‎

    512 bytes in each allocation unit.‎

    24745 total allocation units on disk.‎

    16301 allocation units available on disk.‎

  • שימוש בפקודה chkdsk עם קבצים פתוחים

    אם תציין את אפשרות שורת הפקודה ‎/f, הפקודה chkdsk תציג הודעת שגיאה אם נמצאו קבצים פתוחים בדיסק. אם לא תציין את אפשרות שורת הפקודה ‎/f וקיימים קבצים פתוחים, הפקודה chkdsk עשויה לדווח על יחידות הקצאה שאבדו בדיסק. דבר זה עשוי להתרחש אם קיימים קבצים פתוחים שעדיין לא נרשמו בטבלת מיקומי הקבצים. אם הפקודה chkdsk מדווחת על אובדן מספר גדול של יחידות הקצאה, שקול לתקן את הדיסק.

  • חיפוש שגיאות דיסק פיזיות

    השתמש באפשרות שורת הפקודה ‎/r כדי לחפש שגיאות דיסק פיזיות במערכת הקבצים. לקבלת מידע אודות שחזור של קבצים פגומים פיזית באמצעות הפקודה recover, ראה נושאים קרובים.

  • דיווח על סקטורים פגומים בדיסק

    סקטורים פגומים שדווחו על-ידי הפקודה chkdsk סומנו כפגומים כאשר הדיסק הוכן לראשונה לפעולה. סקטורים אלה אינם מהווים סכנה.

  • הבנת קודי יציאה

    הטבלה שלהלן מציגה את קודי היציאה עליהם מדווחת הפקודה chkdsk לאחר סיום פעולתה.

    קוד יציאה | תיאור
    0 | לא נמצאו שגיאות.
    1 | השגיאות נמצאו ותוקנו.
    2 | בוצע ניקוי הדיסק, כגון אוסף הפסולת, או שלא בוצע ניקוי מכיוון ש- ‎/f לא צוין.
    3 | לא היתה אפשרות לבצע בדיקה של הדיסק, לא היתה אפשרות לתקן שגיאות, או שהשגיאות לא תוקנו מכיוון ש- ‎/f לא צוין.
  • הפקודה chkdsk זמינה ממסוף השחזור עם פרמטרים אחרים.

דוגמאות

אם ברצונך לבדוק את הדיסק בכונן D וש- Windows יתקן את השגיאות, הקלד:

chkdsk d: /f

אם פקודה זו נתקלת בשגיאות, chkdsk עוצרת ומציגה הודעות. הפקודה Chkdsk מסיימת את פעולתה על-ידי הצגת המצב של הדיסק. אין באפשרותך לפתוח קבצים בכונן המצוין עד סיום פעולתה של הפקודה chkdsk.

כדי לבדוק אם קיימים בלוקים לא רציפים בכל הקבצים בספריה הנוכחית בדיסק מסוג FAT, הקלד:

chkdsk ‎*.*‎

הפקודה Chkdsk מציגה דו"ח מצב ולאחר מכן מפרטת את כל הקבצים התואמים למפרט הקובץ הכוללים בלוקים לא רציפים.


Chkntfs

פקודה זו מציגה או מציינת אם בדיקת מערכת אוטומטית מתוזמנת לפעול באמצעי אחסון מסוג FAT‏, FAT32 או NTFS בעת הפעלת המחשב.

תחביר

chkntfs volume: [...]‎

chkntfs [/d]‎

chkntfs [/t[:time]]‎

chkntfs [/x volume: [...]]‎

chkntfs [/c volume: [...]]‎

פרמטרים

volume: [...]‎
פרמטר נדרש. הפרמטר מציין את אות הכונן (ואחריה נקודתיים), נקודת הטעינה או שם אמצעי האחסון. הפרמטר מציג הודעה המזהה את מערכת הקבצים של אמצעי האחסון שצוין. אם מתוזמנת פעולה של בדיקת קובץ אוטומטית, פרמטר זה מציג הודעה המציינת אם אמצעי האחסון נפגם, מה שמצריך את הפעלת הפקודה chkdsk.
‎/d
שחזור כל הגדרות ברירת המחדל של הפקודה chkntfs, מלבד משך הספירה לאחור עבור בדיקת קבצים אוטומטית. התנהגות ברירת המחדל היא לבדוק את כל אמצעי האחסון בעת הפעלת המחשב.
‎/t[:time]‎
פרמטר זה משנה את אורך הזמן הקצוב לאתחול הקובץ Autochk.exe לאורך הזמן שצוין בשניות. אם הפרמטר ‎:time לא צוין, ‎/t מציג את הזמן הקצוב הנוכחי.
‎/x volume:‎ [...]‎
פרמטר זה מונע מאמצעי האחסון להיבדק בעת הפעלת המחשב, אפילו אם אמצעי האחסון מסומן כדורש את הפעלת הפקודה chkdsk.
‎/c volume:‎ [...]‎
תזמון אמצעי האחסון שצוין לבדיקה בעת הפעלת המחשב.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • כדי להפעיל את הפקודה chkntfs עליך להיות חבר בקבוצה Administrators.
  • אף-על-פי שבאפשרותך לכוון את הזמן הקצוב לאתחול הקובץ Autochk.exe לאפס, אין באפשרותך לבטל בדיקה אוטומטית של קובץ העשויה לצרוך זמן, על-ידי כיוונה לאפס.

דוגמאות

כדי להציג את הזמן הקצוב לאתחול הקובץ Autochk.exe הקלד:

chkntfs /t

בעת שינוי הזמן הקצוב לאתחול הקובץ Autochk.exe, הקלד את הזמן בשניות. לדוגמה, כדי לשנות את הזמן הקצוב ל- 30 שניות, הקלד:

chkntfs /t:30

אפשרות שורת הפקודה ‎/x אינה מצטברת. אם תקליד אפשרות זו יותר מפעם אחת, הערך העדכני ביותר ידרוס את הערך הקודם. כדי לא לכלול אמצעי אחסון מרובים בבדיקה, פרט את כולם בפקודה אחת. לדוגמה, כדי לא לכלול גם את אמצעי האחסון E:‎ וגם את אמצעי האחסון F:‎, הקלד:

chkntfs /x e: f:‎

כדי להוציא מהכלל את אמצעי האחסון F:‎ בלבד, הקלד:

chkntfs /x e:‎

chkntfs /x f:‎

אפשרות שורת הפקודה ‎/c מצטברת. אם ברצונך שרק אמצעי האחסון שצוין ייבדק, תחילה בצע איפוס של ברירות המחדל כדי לנקות פקודות קודמות, לאחר מכן הוצא מכלל הבדיקה את כל אמצעי האחסון ולבסוף קבע מועד לבדיקת קבצים אוטומטית באמצעי האחסון הרצוי.

לדוגמה, כדי לקבוע מועד לבדיקת קבצים אוטומטית באמצעי האחסון D:‎ בלבד, הקלד:

chkntfs /d

chkntfs /x c: d: e:‎

chkntfs /c d:‎


Cipher

פקודה זו מציגה או משנה הצפנת תיקיות וקבצים באמצעי אחסון מסוג NTFS. כאשר נעשה שימוש בפקודה זו ללא פרמטרים, cipher מציגה את מצב ההצפנה של התיקיה הנוכחית ושל הקבצים הכלולים בה.

תחביר

cipher [{/e|/d}]‎ ‎[/s:dir]‎ ‎[/a]‎ ‎[/i]‎ ‎[/f]‎ ‎[/q]‎ ‎[/h]‎ ‎[/k]‎ ‎[/u‎[/n]]‎ ‎[PathName [...]] |‎ ‎[/r:PathNameWithoutExtension] |‎ ‎[/w:PathName]‎

פרמטרים

‎/e
פרמטר זה מצפין את התיקיות שצוינו. התיקיות מסומנות כך שהקבצים שיתווספו לתיקיה בשלב מאוחר יותר יוצפנו גם הם.
‎/d
פרמטר זה מפענח את הספריות שצוינו. התיקיות מסומנות כך שהקבצים שיתווספו לתיקיה בשלב מאוחר יותר יוצפנו גם הם.
‎/s: dir
פרמטר זה מבצע את הפעולה שנבחרה בתיקיה שצוינה ובכל תיקיות המשנה שלה.
‎/a
פרמטר זה מבצע את הפעולה בקבצים ובספריות.
‎/i
פרמטר זה ממשיך בביצוע הפעולה שצוינה גם לאחר שאירעו שגיאות. כברירת מחדל, הפקודה cipher מפסיקה את פעולתה כאשר היא נתקלת בשגיאה.
‎/f
פרמטר זה אוכף הצפנה או פענוח של כל האובייקטים שצוינו. כברירת מחדל, הפקודה cipher מדלגת על קבצים שכבר הוצפנו או פוענחו.
‎/q
פרמטר זה מדווח על המידע החיוני ביותר בלבד.
‎/h
הצגת קבצים עם תכונות הסתרה או תכונות מערכת. כברירת מחדל, קבצים אלה אינם מוצפנים או מפוענחים.
‎/k
פרמטר זה יוצר מפתח הצפנה חדש לקובץ עבור המשתמש המפעיל את הפקודה cipher. בעת שימוש באפשרות זו, הפקודה cipher מתעלמת מכל האפשרויות האחרות.
‎/u
פרמטר זה מעדכן את מפתח הצפנת הקובץ של המשתמש או את מפתח סוכן האחזור למפתחות הנוכחיים בכל הקבצים המוצפנים בכוננים המקומיים (אם המפתחות הוחלפו). אפשרות זו פועלת רק עם הפרמטר ‎/n.
‎/n
פרמטר זה מונע את עדכון המפתחות. השתמש באפשרות זו כדי לחפש את כל הקבצים המוצפנים בכוננים המקומיים. אפשרות זו פועלת רק עם הפרמטר ‎/u.
PathName
קביעת תבנית, קובץ או תיקיה.
‎/r:PathNameWithoutExtension
פרמטר זה יוצר אישור ומפתח פרטי חדשים של סוכן אחזור ולאחר מכן כותב אותם לקבצים עם שם הקובץ שצוין ב- PathNameWithoutExtension. בעת שימוש באפשרות זו, הפקודה cipher מתעלמת מכל האפשרויות האחרות.
‎/w:PathName
פרמטר זה מסיר נתונים מחלקים של אמצעי האחסון שאינם נמצאים בשימוש. לפרמטר PathName יש אפשרות לציין כל ספריה באמצעי האחסון הרצוי. בעת שימוש באפשרות זו, הפקודה cipher מתעלמת מכל שאר האפשרויות.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • שימוש בפרמטר ‎/w

    הפרמטר ‎/w מסיר נתונים מאותם חלקים של אמצעי האחסון שאליהם יש לו גישה ושלא הוקצו לקבצים או לספריות. הפרמטר אינו נועל את הכונן, כך שתוכניות אחרות יכולות לקבל מקום בכונן, מקום שאותו לפקודה cipher אין אפשרות למחוק. משום שאפשרות זו כותבת לחלק גדול של אמצעי האחסון הקשיח, השלמתה עשויה לצרוך זמן רב ולכן יש להשתמש באפשרות זו רק במקרה הצורך.

  • הצפנה או פענוח של קבצים

    כדי למנוע את הפענוח של קובץ מוצפן כאשר נעשה בו שינוי, מומלץ להצפין את הקובץ וגם את התיקיה בה הקובץ שוכן.

  • שימוש בקבצים ובתיקיות לקריאה בלבד

    לפקודה Cipher אין אפשרות להצפין קבצים המסומנים לקריאה בלבד.

  • שימוש בשמות תיקיה מרובים

    באפשרותך להשתמש בשמות תיקיה מרובים ובתווים כלליים.

  • שימוש בפרמטרים מרובים

    עליך להפריד פרמטרים מרובים באמצעות רווח אחד לפחות.

דוגמאות

כדי להשתמש בפקודה cipher לשם הצפנת תיקיית משנה הנקראת May בתיקיה הנקראת MonthlyReports הקלד:

cipher /e monthlyreports\may

כדי להצפין את התיקיה MonthlyReports, את תיקיות המשנה January עד December ואת תיקיות המשנה Manufacturing בתוך תיקיות המשנה של החודשים, הקלד:

cipher /e /s:monthlyreports

כדי להצפין רק את הקובץ Marketing.xls בתיקיית המשנה May, הקלד:

cipher /e /a monthlyreports\may\marketing.xls

כדי להצפין את הקובץ Marketing.xls, את הקובץ Maintenance.doc ואת תיקיית המשנה Manufacturing (הממוקמת בתיקיה May), הקלד:

cipher /e /a monthlyreports\may\ma‎*‎

כדי לקבוע אם בוצעה הצפנה של התיקיה May, הקלד:

cipher monthlyreports\may

כדי לקבוע אילו קבצים בתיקיה May מוצפנים, הקלד:

cipher monthlyreports\may\‎*‎


Cls

פקודה זו מנקה את חלון שורת הפקודה.

תחביר

cls

פרמטרים

‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

דוגמאות

כדי לנקות את כל המידע המופיע בחלון שורת הפקודה ולחזור לחלון ריק, הקלד:

cls

XOX

נושאים קרובים


Cmd

פקודה זו מתחילה מופע חדש של מתרגם הפקודה, הקובץ Cmd.exe. אם נעשה שימוש בפקודה זו ללא פרמטרים, cmd מציגה מידע אודות הגירסה וזכויות היוצרים של Windows XP.

תחביר

cmd [[{/c|/k}]‎ ‎[/s]‎ ‎[/q]‎ ‎[/d]‎ ‎[{/a|/u}]‎ ‎[/t:fg]‎ ‎[/e:{on|off}]‎ ‎[‎/f:{on|off}]‎ ‎[/v:{on|off}] string]‎

פרמטרים

‎/c
ביצוע הפקודה שצוינה על-ידי string ולאחר מכן הפסקת הפעולה.
‎/k
ביצוע הפקודה שצוינה על-ידי string והמשך הפעולה.
‎/s
פרמטר זה משנה את הטיפול ב- string אחרי הפרמטרים ‎/c או ‎/k.
‎/q
כיבוי ההד.
‎/d
פרמטר זה מונע את הפעלתן של פקודות AutoRun.
‎/a
פרמטר זה יוצר פלט מסוג American National Standards Institute ‏(ANSI).
‎/u
יצירת פלט Unicode.
‎/t:fg
פרמטר זה קובע את צבעי הקידמה f והרקע g. הטבלאות שלהלן מציגות ספרות הקסדצימאליות חוקיות שבהן באפשרותך להשתמש כערכים עבור f‏ ו- g.
ערך | Color
0 | שחור
1 | כחול
2 | ירוק
3 | תכלת
4 | אדום
5 | סגול
6 | צהוב
7 | לבן
8 | אפור
9 | כחול בהיר
A | ירוק בהיר
B | תכלת בהיר
C | אדום בהיר
D | סגול בהיר
E | צהוב בהיר
F | לבן בוהק
‎/e:on
פרמטר זה הופך הרחבות פקודה לזמינות.
‎/e:off
פרמטר זה הופך את הרחבות הפקודות לבלתי זמינות.
‎/f:on
פרמטר זה הופך לזמינה פעולה של השלמת שם קובץ וספריה.
‎/f:off
פרמטר זה הופך לבלתי זמינה פעולה של השלמת שם קובץ וספריה.
‎/v:on
פרמטר זה הופך הרחבה מושהית של משתנה סביבה לזמינה.
‎/v:off
פרמטר זה הופך הרחבה מושהית של משתנה סביבה לבלתי זמינה.
string
קביעת הפקודה שברצונך לבצע.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • שימוש בפקודות מרובות

    באפשרותך להשתמש בפקודות מרובות המופרדות על-ידי מפריד הפקודות && עבור string, אולם עליך להקיפן במרכאות (לדוגמה "command&&command&&command").

  • עיבוד מרכאות

    אם תציין את הפרמטרים ‎/c או ‎/k, הפקודה cmd תעבד את שאר ה- string והמרכאות יישמרו רק אם יתקיימו כל התנאים הבאים:

    • לא נעשה שימוש בפרמטר ‎/s.
    • נעשה שימוש בזוג מרכאות אחד בלבד.
    • לא נעשה שימוש בכל תו מיוחד שהוא בתוך המרכאות (לדוגמה: &<>( ) @ ^ |).
    • נעשה שימוש בתו רווח לבן אחד או יותר בתוך המרכאות.
    • ה- string בתוך המרכאות הוא שם של קובץ הפעלה.

    אם ימולאו התנאים שלעיל, string יעובד על-ידי בדיקה אם התו הראשון הוא מרכאות פותחות. אם התו הראשון הוא מרכאות פותחות, תו זה יוסר יחד עם המרכאות הסוגרות. כל טקסט המופיע אחרי המרכאות הסוגרות יישמר.

  • הפעלת מפתחות רישום משניים

    אם לא תציין את הפרמטר ‎/d בתוך string, הקובץ Cmd.exe יחפש אחר מפתחות הרישום המשניים הבאים:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor\AutoRun\REG_SZ

    HKEY_CURRENT_USER\Software\Microsoft\Command Processor\AutoRun REG_EXPAND_SZ

    אם יימצא אחד משני מפתחות הרישום המשניים או שניהם, מפתחות אלה יופעלו לפני כל שאר המשתנים.

    שים לב

    • עריכה לא נכונה של הרישום עשויה לגרום נזק חמור למערכת. לפני עריכת שינויים ברישום, מומלץ לגבות את כל הנתונים החשובים במחשב.
  • הפעלה וביטול של הרחבות פקודה

    כברירת מחדל, הרחבות פקודה זמינות ב- Windows XP. באפשרותך להפוך אותן לבלתי זמינות עבור תהליך מסוים באמצעות הפרמטר ‎/e:off. באפשרותך להפוך הרחבות פקודה לזמינות או לבלתי זמינות עבור כל אפשרויות שורת הפקודה cmd במחשב או בהפעלה של המשתמש על-ידי קביעת ערכי REG_DWORD הבאים:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor\EnableExtensions\REG_DWORD

    HKEY_CURRENT_USER\Software\Microsoft\Command Processor\EnableExtensions\REG_DWORD

    קבע את ערך REG_DWORD ברישום כ- ‎0×1 (זמין) או כ- 0×0 (לא זמין) באמצעות Regedit.exe. הגדרות שצוינו על-ידי המשתמש מקבלות קדימות על-פני הגדרות המחשב, ואפשרויות שורת הפקודה מקבלות קדימות על-פני הגדרות הרישום.

    שים לב

    • עריכה לא נכונה של הרישום עשויה לגרום נזק חמור למערכת. לפני עריכת שינויים ברישום, מומלץ לגבות את כל הנתונים החשובים במחשב.

    בעת הפיכת הרחבות הפקודה לזמינות, הדבר משפיע על הפקודות הבאות:

    • assoc
    • call
    • chdir (cd)‎
    • color
    • del (erase)‎
    • endlocal
    • for
    • ftype
    • goto
    • if
    • mkdir (md)‎
    • popd
    • prompt
    • pushd
    • set
    • setlocal
    • shift
    • start (כולל גם שינויים בתהליכי פקודה חיצוניים)

    לקבלת מידע נוסף אודות פקודות אלה, ראה נושאים קרובים.

  • הפיכת הרחבה מושהית של משתנה סביבה לזמינה

    אם הרחבה מושהית של משתנה סביבה הופכת לזמינה, באפשרותך להשתמש בתו סימן קריאה במקום הערך של משתנה סביבה בזמן ריצה.

  • הפיכת פעולה של השלמת שם קובץ וספריה לזמינה

    השלמת שם קובץ וספריה אינה זמינה כברירת מחדל. באפשרותך להפוך השלמת שם קובץ או ספריה לזמינה או לבלתי זמינה עבור תהליך מסוים של הפקודה cmd באמצעות הפרמטר ‎/f:{on|off}‎. באפשרותך להפוך השלמת שם קובץ וספריה לזמינה או לבלתי זמינה עבור כל התהליכים של הפקודה cmd במחשב או בהפעלת כניסה של משתמש על-ידי קביעת ערכי REG_DWORD הבאים:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor\CompletionChar\REG_DWORD

    HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor\PathCompletionChar\REG_DWORD

    HKEY_CURRENT_USER\Software\Microsoft\Command Processor\CompletionChar\REG_DWORD

    HKEY_CURRENT_USER\Software\Microsoft\Command Processor\PathCompletionChar\REG_DWORD

    כדי לקבוע את הערך של REG_DWORD, הפעל את הקובץ Regedit.exe והשתמש בערך ההקסדצימאלי של תו בקרה עבור פונקציה מסוימת (לדוגמה הערך ‎0×9 הוא TAB והערך ‎0×08 הוא BACKSPACE). הגדרות שצוינו על-ידי המשתמש מקבלות קדימות על-פני הגדרות המחשב, ואפשרויות שורת הפקודה מקבלות קדימות על-פני הגדרות הרישום.

    שים לב

    • עריכה לא נכונה של הרישום עשויה לגרום נזק חמור למערכת. לפני עריכת שינויים ברישום, מומלץ לגבות את כל הנתונים החשובים במחשב.

    אם תהפוך את פעולת השלמת שם הקובץ או הספריה לזמינה באמצעות הפרמטר ‎/f:on, השתמש במקשים CTRL+D להשלמת שם ספריה ובמקשים CTRL+F להשלמת שם קובץ. כדי להפוך תו השלמה מסוים ברישום לבלתי זמין, השתמש בערך של רווח לבן [‎0×20] משום שערך זה אינו תו בקרה חוקי.

    בעת לחיצה על CTRL+D או CTRL+F, הפקודה cmd מעבדת את השלמת שם הקובץ או הספריה. פונקציות צירוף מקשים אלו מצרפות תו כללי ל- string (אם לא היה קיים תו כללי קודם לכן), בונות רשימה של נתיבים מתאימים ולאחר מכן מציגות את הנתיב המתאים הראשון. אם אף אחד מבין הנתיבים אינו תואם, הפונקציה של השלמת שם הקובץ והספריה מצפצפת ואינה משנה את התצוגה. כדי עבור ברשימת הנתיבים התואמים, הקש על CTRL+D או CTRL+F שוב ושוב. כדי לנוע אחורנית בתוך הרשימה, הקש על מקש SHIFT ועל המקשים CTRL+D או CTRL+F בו-זמנית. כדי למחוק את הרשימה השמורה של הנתיבים התואמים וליצור רשימה חדשה, ערוך את string והקש CTRL+D או CTRL+F. אם תחליף בין CTRL+D לבין CTRL+F, הרשימה השמורה של הנתיבים התואמים תמחק ורשימה חדשה תיווצר. ההבדל היחיד בין צירוף המקשים CTRL+D לבין צירוף המקשים CTRL+F הוא שצירוף המקשים CTRL+D מוצא התאמות לשמות הספריות בלבד ואילו צירוף המקשים CTRL+F מוצא התאמות הן לשמות הקבצים והן לשמות הספריות. אם תשתמש בהשלמת שם קובץ וספריה בכל אחת מפקודות הספריה המוכללות (כלומר CD‏, MD, או RD), תונח השלמה של שם ספריה.

    השלמת שמות קבצים וספריות מעבדת נכונה שמות קבצים המכילים רווחים לבנים או תווים מיוחדים אם מופיעות מרכאות סביב הנתיב התואם.

    התווים המיוחדים הבאים מצריכים מרכאות: & < > [ ] { } ^ = ; ! ' + , ` ~ [רווח לבן]

    אם המידע שתספק מכיל רווחים, השתמש במרכאות סביב הטקסט (לדוגמה, ‎"Computer Name"‎).

    אם תעבד השלמת שם קובץ וספריה מתוך string, יימחק כל חלק של [Path] מימין הסמן (כלומר, בנקודה בתוך string בה עובדה ההשלמה).


נושאי עזרה להצגת תוכן העניינים.

גרפיקה של Microsoft Windows
לחץ על נושאי עזרה כדי לראות את תוכן העניינים.


Cmstp

פקודה זו מתקינה או מסירה פרופיל שירות של מנהל ההתקשרויות. כאשר נעשה שימוש בפקודה זו ללא פרמטרים אופציונליים, cmstp מתקינה פרופיל שירות עם הגדרות ברירת מחדל המתאימות למערכת ההפעלה ולהרשאות המשתמש.

תחביר

תחביר 1:‎ ServiceProfileFileName.exe /q:a /c:"cmstp.exe ServiceProfileFileName.inf [/nf] [/ni] [/ns] [/s] [/su] [/u]"‎

תחביר 2: cmstp.exe [/nf] [/ni] [/ns] [/s] [/su] [/u] "[Drive:][Path]ServiceProfileFileName.inf"‎

פרמטרים

ServiceProfileFileName.exe
פרמטר זה דרוש עבור תחביר 1 אך אינו חוקי עבור תחביר 2. פרמטר זה מציין את שמה של חבילת ההתקנה המכילה את הפרופיל שברצונך להתקין.
‎/q:a
פרמטר זה דרוש עבור תחביר 1 אולם אינו חוקי עבור תחביר 2. פרמטר זה מציין כי יש להתקין את הפרופיל מבלי לבקש תגובה מהמשתמש. הודעת האימות לפיה ההתקנה הצליחה עדיין תופיע.
‎[Drive:][Path]ServiceProfileFileName.inf
פרמטר נדרש. הפרמטר מציין את שמו של קובץ התצורה הקובע כיצד יש להתקין את הפרופיל. הפרמטר [Drive:][Path] אינו חוקי עבור תחביר 1.
‎/nf
פרמטר זה מציין כי אין להתקין את קבצי התמיכה.
‎/ni
פרמטר זה מציין כי אין ליצור סמל בשולחן העבודה. פרמטר זה חוקי רק במחשבים בהם מותקנת מערכת הפעלה מסוג Windows 95‏, Windows 98‏, Windows NT 4.0, או Windows Millennium Edition.
‎/ns
פרמטר זה מציין כי אין ליצור קיצור דרך בשולחן העבודה. פרמטר זה חוקי רק במחשבים בהם מותקנת מערכת הפעלה מסוג Windows 2000 או Windows XP.
‎/s
פרמטר זה מציין כי יש להתקין או להסיר את פרופיל השירות בשקט (מבלי לבקש תגובה מהמשתמש ומבלי להציג הודעת אימות).
‎/su
פרמטר זה מציין כי יש להתקין את פרופיל השירות עבור משתמש בודד ולא עבור כל המשתמשים. פרמטר זה חוקי רק במחשבים בהם מותקנת מערכת הפעלה מסוג Windows 2000 או Windows XP.
‎/u
פרמטר זה מציין כי יש להסיר את התקנת פרופיל השירות.
‎/?‎
פרופיל זה מציג עזרה בשורת הפקודה.

הערות

  • הפרמטר ‎/s הוא הפרמטר היחיד שבו באפשרותך להשתמש יחד עם הפרמטר ‎/u.
  • תחביר 1 הוא התחביר הטיפוסי הנמצא בשימוש ביישום התקנה מותאמת אישית. כדי להשתמש בתחביר זה, עליך להפעיל את הפקודה cmstp מתוך הספריה המכילה את הקובץ ServiceProfileFileName.exe.

דוגמאות

הדוגמאות הבאות מדגימות שימושים אפשריים של הפקודה cmstp ביחס לפרופיל שירות מדומה הקרוי Fiction וביחס לקבצים המשויכים לו.

  • לשם התקנה של פרופיל השירות Fiction ללא קבצי תמיכה, הקלד:

    • fiction.exe /c:"cmstp.exe fiction.inf /nf"‎

  • לשם התקנה שקטה של פרופיל השירות Fiction עבור משתמש בודד, הקלד:

    • fiction.exe /c:"cmstp.exe fiction.inf /s /su"‎

  • לשם הסרה שקטה של פרופיל השירות Fiction, הקלד:

    • fiction.exe /c:"cmstp.exe fiction.inf /s /u"‎


Color

פקודה זו משנה את צבעי הקידמה והרקע של חלון שורת הפקודה בהפעלה הנוכחית. בעת שימוש בפקודה זו ללא פרמטרים, color משחזרת את צבעי ברירת המחדל של הקידמה והרקע של חלון שורת הפקודה.

תחביר

color [fb]‎

פרמטרים

fb
פרמטר זה קובע את צבעי הקידמה f והרקע g. הטבלה שלהלן מפרטת ספרות הקסדצימאליות חוקיות שבהן באפשרותך להשתמש כערכים עבור f ו- g.
ערך | Color
0 | שחור
1 | כחול
2 | ירוק
3 | תכלת
4 | אדום
5 | סגול
6 | צהוב
7 | לבן
8 | אפור
9 | כחול בהיר
A | ירוק בהיר
B | תכלת בהיר
C | אדום בהיר
D | סגול בהיר
E | צהוב בהיר
F | לבן בוהק
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • כדי לקבוע את צבע ברירת המחדל של חלון שורת הפקודה, לחץ על הפינה השמאלית העליונה של חלון שורת הפקודה, לחץ על ברירות מחדל, לחץ על הכרטיסיה צבעים ולאחר מכן לחץ על הצבעים שבהם ברצונך להשתמש עבור טקסט מסך ועבור רקע מסך.
  • באפשרותך להשתמש בפקודה cmd /t:fb כדי לשנות את צבעי חלון שורת הפקודה עבור ההפעלה הנוכחית.
  • אם צבעי הקידמה והרקע זהים, הפקודה color קובעת את ERRORLEVEL כאחד (1).

דוגמאות

כדי לשנות את צבע קידמת חלון שורת הפקודה לאדום ואת צבע הרקע ללבן, הקלד:

color FC


Comp

פקודה זו משווה את התוכן של שני קבצים או ערכות של קבצים בית אחר בית. לפקודה comp יש אפשרות להשוות קבצים באותו כונן או בכוננים שונים ובאותה ספריה או בספריות שונות. כאשר הפקודה comp משווה בין הקבצים, מוצגים המיקומים והשמות של הקבצים. כאשר נעשה שימוש בפקודה זו ללא פרמטרים, comp מבקשת מהמשתמש להזין את הקבצים שביניהם יש להשוות.

תחביר

comp [data1]‎ [data2] [‎/d] [‎/a] [‎/l] [‎/n=number] [‎/c]‎

פרמטרים

data1
קביעת המיקום והשם של הקובץ הראשון או ערכת הקבצים הראשונה שברצונך להשוות. באפשרותך להשתמש בתווים כלליים (* ו- ?) כדי לציין קבצים מרובים.
data2
קביעת המיקום והשם של הקובץ השני או ערכת הקבצים השניה שברצונך להשוות. באפשרותך להשתמש בתווים כלליים (* ו- ?) כדי לציין קבצים מרובים.
‎/d
הצגת ההבדלים בתבנית עשרונית (תבנית ברירת המחדל היא הקסדצימאלית).
‎/a
הצגת ההבדלים כתווים.
‎/l
הצגת מספר השורה בה קיים הבדל, במקום להציג את היסט הבית.
‎/n=number
השוואת ה- number (מספר) הראשון של השורות בכל קובץ, אפילו אם הקבצים בגדלים שונים.
‎/c
ביצוע השוואה שאינה תלוית רישיות.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • השוואה בין קבצים בעלי שמות זהים

    הקבצים שברצונך להשוות עשויים להיות בעלי שמות קובץ זהים, בתנאי שהם נמצאים בספריות שונות או בכוננים שונים. אם לא תציין שם קובץ עבור data2, שם הקובץ המהווה ברירת מחדל עבור data2 זהה לשם הקובץ ב-data1. באפשרותך להשתמש בתווים כלליים (* ו- ?) כדי לציין שמות קבצים.

  • מקרים מיוחדים עבור data1 ו- data2

    אם תשמיט רכיבים חיוניים של data1 או data2 או אם תשמיט את data2, הפקודה comp תציג בפניך בקשה לספק את המידע החסר. אם data1 מכיל רק אות כונן או שם ספריה ללא שם קובץ, הפקודה comp משווה את כל הקבצים בספריה שצוינה לקובץ שצוין ב- data2. אם data2 מכיל רק אות כונן או שם ספריה, שם הקובץ המהווה ברירת מחדל עבור data2 זהה לשם ב- data1.

  • כיצד הפקודה comp מזהה מידע לא תואם

    במהלך ההשוואה, הפקודה comp מציגה הודעות לזיהוי המיקומים של מידע לא שווה בשני הקבצים. כל הודעה מציינת את כתובת הזיכרון של ההיסט של הבתים הלא שווים ואת התוכן של הבתים עצמם (בייצוג הקסדצימאלי, אלא אם תציין את אפשרויות שורת הפקודה ‎/a או ‎/d). ההודעה מוצגת בתבנית הבאה:

    Compare error at OFFSET xxxxxxxx

    file1 = xx

    file2 = xx

    לאחר ביצוע 10 השוואות בהן נמצאו נתונים שאינם שווים, הפקודה comp מפסיקה את השוואת הקבצים ומציגה את ההודעה הבאה:

    ‎10 Mismatches - ending compare

  • השוואת קבצים בגדלים שונים

    אין באפשרותך להשוות קבצים בגדלים שונים אלא אם תציין את אפשרות שורת הפקודה ‎/n. אם גדלי הקבצים שונים, הפקודה comp תציג את ההודעה הבאה:

    Files are different sizes

    Compare more files ‎(Y/N)?‎

    הקש Y כדי להשוות זוג נוסף של קבצים. הקש N כדי להפסיק את פעולת הפקודה comp.

    אם תקיש Y כתגובה לבקשה, הפקודה comp תכלול את כל הבוררים שציינת בשורת הפקודה בכל השוואה שמתבצעת, עד שתקיש N או תקליד מחדש את הפקודה.

    בעת השוואת קבצים בגדלים שונים, השתמש באפשרות שורת הפקודה ‎/n כדי להשוות רק את החלק הראשון של כל קובץ.

  • השוואת קבצים ברצף

    אם אתה משתמש בתווים כלליים (* ו- ?) כדי לציין קבצים מרובים, הפקודה comp מחפשת אחר הקובץ הראשון התואם ל- data1 ומשווה בינו לבין הקובץ המתאים ב- data2, אם קובץ זה קיים. הפקודה comp מדווחת על תוצאות ההשוואה ולאחר מכן מבצעת את אותה פעולה עבור כל קובץ התואם ל- data1. כאשר הפעולה מסתיימת, הפקודה comp מציגה את ההודעה הבאה:

    Compare more files ‎(Y/N)?‎

    כדי להשוות בין קבצים נוספים, הקש Y. הפקודה comp תציג בפניך בקשה לציין את המיקומים והשמות של הקבצים החדשים. כדי להפסיק את ההשוואות, הקש N. כאשר תקיש Y, הפקודה comp תציג בפניך בקשה לציין את אפשרויות שורת הפקודה בהן יעשה שימוש. אם לא תציין אפשרויות שורת פקודה, הפקודה comp תשתמש באפשרויות שציינת בעבר.

  • אם לפקודה comp אין אפשרות למצוא את הקבצים

    אם לפקודה comp אין אפשרות למצוא את הקבצים שציינת, הפקודה מציגה בפניך הודעה המבקשת ממך לקבוע אם ברצונך להשוות קבצים נוספים.

דוגמאות

כדי להשוות את התוכן של הספריה C:\Reports עם ספריית הגיבוי ‎\\Sales\Backup\April, הקלד:

comp c:\reports \\sales\backup\april

כדי להשוות את עשר השורות הראשונות של קבצי הטקסט בספריה ‎\Invoice ולהציג את התוצאה בתבנית עשרונית, הקלד:

comp \invoice\*.txt \invoice\backup\*.txt /n=10 /d


Compact

פקודה זו מציגה ומשנה את הדחיסה של קבצים או ספריות במחיצות NTFS. כאשר נעשה בה שימוש ללא פרמטרים, הפקודה compact מציגה את מצב הדחיסה של הספריה הנוכחית.

תחביר

compact [{/c|/u}]‎ [‎/s[:dir]‎] [‎/a] [‎/i] [‎/f] [‎/q] ‎[FileName[...]]‎

פרמטרים

‎/c
דחיסת הספריה או הקובץ שצוינו.
‎/u
ביטול הדחיסה של הספריה או הקובץ שצוינו.
‎/s:dir
קביעה כי הפעולה המבוקשת (דחיסה או ביטול דחיסה) תחול על כל ספריות המשנה של הספריה שצוינה או של הספריה הנוכחית אם לא צוינה ספריה.

‎/a
הצגת קבצים מוסתרים או קבצי מערכת.
‎/i
התעלמות משגיאות.
‎/f
כפייה של דחיסה או ביטול דחיסה על הספריה או הקובץ שצוינו. פרמטר זה משמש במקרה של קובץ שנדחס חלקית כאשר פעולת הדחיסה הופסקה על-ידי קריסת המערכת. כדי לכפות על הקובץ להידחס באופן מלא, השתמש בפרמטרים ‎/c ו- ‎/f וציין את הקובץ שנדחס חלקית.
‎/q
דיווח על המידע החיוני ביותר בלבד.
FileName
קביעת הקובץ או הספריה. באפשרותך להשתמש בשמות קבצים מרובים ובתווים כלליים (* ו- ?).
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • הפקודה compact, גירסת שורת הפקודה של תכונת הדחיסה של מערכת הקבצים NTFS, מציגה ומשנה את תכונת הדחיסה של קבצים וספריות במחיצות NTFS. מצב הדחיסה של ספריה מציין אם קבצים שיצורפו לספריה יידחסו באופן אוטומטי. כאשר אתה מגדיר את מצב הדחיסה של ספריה אינך משנה בהכרח את מצב הדחיסה של קבצים שכבר נמצאים בספריה.
  • אין באפשרותך להשתמש בפקודה compact כדי לקרוא, לכתוב או לטעון אמצעי אחסון שנדחסו באמצעות דוחס הדיסק או DoubleSpace.

דוגמאות

כדי לקבוע את מצב הדחיסה של התיקיה הנוכחית, תיקיות המשנה שלה והקבצים הקיימים בתוכה, הקלד את הפקודה הבאה מתוך התיקיה הנוכחית:

compact /c /s

כדי לקבוע את מצב הדחיסה של הקבצים בתיקיה הנוכחית, של תיקיות המשנה בתיקיה הנוכחית ושל הקבצים המצויים בתוך כל ספריות המשנה מבלי לשנות את מצב הדחיסה של התיקיה הנוכחית, הקלד את הפקודה הבאה מתוך התיקיה הנוכחית:

compact /c /s *.*‎

כדי לדחוס אמצעי אחסון, הקלד את הפקודה הבאה מתוך תיקית הבסיס של אמצעי האחסון:

compact /c /i /s:\‎

דוגמה זו קובעת את מצב הדחיסה של תיקיית הבסיס ושל כל התיקיות באמצעי האחסון ודוחסת כל קובץ באמצעי האחסון. על-ידי שימוש בפרמטר ‎/i, באפשרותך להבטיח כי הודעות שגיאה לא יפריעו לתהליך הדחיסה.

כדי לדחוס את כל הקבצים המסתיימים ב- ‎.bmp בספריה ‎\Tmp ובכל ספריות המשנה של ‎\Tmp, אך לא לשנות את תכונת הדחיסה של ספריות אלה, הקלד:

compact /c /s:\tmp *.bmp

כדי לכפות דחיסה מלאה של הקובץ Zebra.bmp, אשר היה דחוס חלקית כאשר אירעה קריסת מערכת, הקלד:

compact /c /f zebra.bmp

כדי להסיר את תכונת הדחיסה מהספריה C:\Tmp, אך לא לשנות את מצב הדחיסה של קבצים בספריה זו, הקלד:

compact /u c:\tmp


Convert

פקודה זו ממירה אמצעי אחסון מסוג FAT ו- FAT32 לאמצעי אחסון מסוג NTFS.

תחביר

convert [volume] /fs:ntfs [/v] [/cvtarea:FileName] [/nosecurity] [/x]‎

פרמטרים

volume
פרמטר זה מציין את אות הכונן (שאחריה מופיעות נקודתיים), נקודת הטעינה או שם אמצעי האחסון שיש להמיר ל- NTFS.
‎/fs:ntfs
פרמטר נדרש. פרמטר זה ממיר את אמצעי האחסון ל- NTFS.
‎/v
מציין מצב מילולי. כל ההודעות יוצגו בעת ההמרה.
‎/cvtarea:FileName
פרמטר זה מיועד למשתמשים מתקדמים בלבד. הפרמטר מציין כי טבלת הקבצים הראשית (MFT) וקבצי מטה-נתונים אחרים מסוג NTFS אחרים נכתבים לקובץ מציין מיקום קיים ורציף. על קובץ זה להיות ממוקם בספריית הבסיס של מערכת הקבצים אותה מעונינים להמיר. שימוש בפרמטר ‎/CVTAREA יכול להביא לפיצול מועט יותר של מערכת הקבצים לאחר ההמרה. לקבלת התוצאות הטובות ביותר, על גודל הקובץ להיות ‎1 KB כפול מספר הקבצים והספריות שבמערכת הקבצים. עם זאת, כלי שירות ההמרה מקבל קבצים מכל הגדלים.

לקבלת מידע נוסף אודות השימוש בפרמטר ‎/cvtarea ראה "File Systems" באתר האינטרנט Microsoft Windows XP Resource Kits.‏(http://www.microsoft.com/‎)

חשוב

  • עליך ליצור את קובץ מציין המיקום באמצעות הפקודה fsutil file createnew לפני הפעלת הפקודה convert. הפקודה convert אינה יוצרת קובץ זה בעצמה. הפקודה convert דורסת קובץ זה עם מטה-נתונים מסוג NTFS. לאחר ההמרה משוחרר כל שטח בקובץ זה שאין לו שימוש. לקבלת מידע נוסף אודות הפקודה fsutil file, ראה נושאים קרובים.
‎/nosecurity
פרמטר זה מציין כי הקבצים שעברו המרה והגדרות האבטחה של הספריה נגישות לכל אחד.
‎/x
ביטול הטעינה של אמצעי האחסון, אם יש צורך בכך, לפני ההמרה. כל המזהים הייחודיים הפתוחים של אמצעי האחסון לא יהיו עוד חוקיים.

הערות

  • עליך לציין כי יש להמיר את הכונן בעת הפעלה מחדש של המחשב. אחרת, אין באפשרותך להמיר את הכונן הנוכחי.
  • אם לפקודה convert אין אפשרות לנעול את הכונן (לדוגמה, אמצעי האחסון של המערכת או הכונן הנוכחי), תציע הפקודה למשתמש להמיר את הכונן בפעם הבאה שהמחשב יופעל מחדש.
  • מיקום הטבלה MFT שונה באמצעי אחסון שהומרו מגירסאות קודמות של NTFS, כך שביצועי אמצעי האחסון עשויים לא להיות טובים באותה מידה באמצעי אחסון שהומרו מ- Windows NT.
  • אמצעי אחסון שהומרו מ- FAT ל- NTFS חסרים מספר יתרונות ביצועים בהשוואה לאמצעי אחסון שאותחלו מלכתחילה עם NTFS. הטבלה MFT עשויה להתפצל באמצעי אחסון שעברו המרה. בנוסף, הרשאות NTFS אינן מיושמות על אמצעי אחסון של אתחול שעברו המרה לאחר שאמצעי האתחול עבר המרה.

דוגמאות

כדי להמיר את אמצעי האחסון בכונן E ולהציג את כל ההודעות, הקלד:

convert e: /fs:ntfs /v


Copy

פקודה זו מעתיקה קובץ אחד או יותר ממיקום אחד לאחר.

תחביר

copy [/d]‎ [‎/v] [‎/n] [{‎/y|‎/-y}] ‎[/z]‎ [{‎/a|‎/b}] Source [{/a|/b}‎]‎ ‎[‎+ Source [{/a|/b}] [+ ...]]‎ [Destination [{/a|/b}]‎]

פרמטרים

‎/d
פרמטר זה מאפשר לשמור את הקבצים המוצפנים המועתקים כקבצים מפוענחים ביעד.
‎/v
אימות כי קבצים חדשים נכתבים כראוי.
‎/n
שימוש בשם קובץ קצר, אם הוא זמין, בעת העתקת קובץ עם שם ארוך משמונה תווים או עם סיומת קובץ ארוכה משלושה תווים.
‎/y
שימוש בפרמטר זה מונע את הצגת הבקשה שמטרתה לוודא אם ברצונך להחליף קובץ יעד קיים.
‎/-y
פרמטר זה מציג בקשה לאישור החלפה של קובץ יעד קיים.
‎/z
העתקת קבצים הנמצאים ברשת במצב הניתן להפעלה מחדש.
‎/a
פרמטר זה מציין קובץ טקסט מסוג ASCII.
‎/b
פרמטר זה מציין קובץ בינארי.
Source
פרמטר נדרש. פרמטר זה מציין את המיקום ממנו ברצונך להעתיק קובץ או ערכת קבצים. הפרמטר Source יכול להיות מורכב מאות כונן ונקודתיים, שם תיקיה, שם קובץ או שילוב של כל אלה.
Destination
פרמטר נדרש. פרמטר זה מציין את המיקום שאליו ברצונך להעתיק קובץ או ערכת קבצים. הפרמטר Destination יכול לכלול אות כונן ונקודתיים, שם תיקיה, שם קובץ או שילוב של כל אלה.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • באפשרותך להעתיק קובץ טקסט מסוג ASCII המשתמש בתו סוף קובץ (כלומר, CTRL+Z) כדי לציין את סוף הקובץ.
  • שימוש בפרמטר ‎/a

    כאשר הפרמטר ‎/a מופיע לפני רשימה של קבצים בשורת הפקודה, הוא מתייחס לכל הקבצים המופיעים ברשימה עד שהפקודה copy נתקלת בפרמטר ‎/b. במקרה זה, הפרמטר ‎/b מתייחס לקובץ המופיע לפני הפרמטר ‎/b.

    כאשר הפרמטר ‎/a מופיע אחרי רשימה של קבצים בשורת הפקודה, הוא מתייחס לכל הקבצים המופיעים ברשימה עד שהפקודה copy נתקלת בפרמטר ‎/b. במקרה זה הפרמטר ‎/b מתייחס לקובץ המופיע לפני הפרמטר ‎/b.

    השפעתו של הפרמטר ‎/a תלויה במיקומו במחרוזת שורת הפקודה. כאשר הפרמטר ‎/a מופיע אחרי Source, הפקודה copy מתייחסת לקובץ כאל קובץ ASCII ומעתיקה נתונים המופיעים לפני תו סוף הקובץ הראשון.

    כאשר הפרמטר ‎/a מופיע אחרי Destination, הפקודה copy מוסיפה תו סוף קובץ בתור התו האחרון של הקובץ.

  • שימוש בפרמטר ‎/b

    הפרמטר ‎/b מורה למתרגם הפקודות לקרוא את מספר הבתים שצוין על-ידי גודל הקובץ בספריה. הפרמטר ‎/b הוא ערך ברירת המחדל עבור הפקודה copy אלא אם הפקודה copy משלבת קבצים.

    כאשר הפרמטר ‎/b מופיע לפני רשימה של קבצים בשורת הפקודה, פרמטר זה מתייחס לכל הקבצים המופיעים ברשימה עד שהפקודה copy נתקלת בפרמטר ‎/a. במקרה זה הפרמטר ‎/a מתייחס לקובץ המופיע לפני הפרמטר ‎/a.

    כאשר הפרמטר ‎/b מופיע אחרי רשימה של קבצים בשורת הפקודה, פרמטר זה מתייחס לכל הקבצים המופיעים ברשימה עד שהפקודה copy נתקלת בפרמטר ‎/a. במקרה זה הפרמטר ‎/a מתייחס לקובץ המופיע לפני הפרמטר ‎/a.

    השפעתו של הפרמטר ‎/b תלויה במיקומו במחרוזת שורת הפקודה. כאשר הפרמטר ‎/b מופיע אחרי Source, הפקודה copy מעתיקה את כל הקובץ, יחד עם כל תווי סוף הקובץ.

    כאשר הפרמטר ‎/b מופיע אחרי Destination, הפקודה copy אינה מוסיפה תו סוף קובץ.

  • שימוש בפרמטר ‎/v

    אם אין אפשרות לאמת פעולת כתיבה, הודעת שגיאה מופיעה. למרות ששגיאות רישום מתרחשות לעיתים נדירות עם הפקודה copy, באפשרותך להשתמש בפרמטר ‎/v כדי לוודא שנתונים קריטיים נרשמו כראוי. בנוסף, אפשרות שורת הפקודה ‎/v מאיטה את פעולת הפקודה copy, כיוון שיש לבדוק כל סקטור שנרשם בדיסק.

  • שימוש בפרמטרים ‎/y ו- ‎/-y

    אם הפרמטר ‎/y נקבע מראש במשתנה הסביבה COPYCMD, באפשרותך לעקוף הגדרה זו על-ידי שימוש בפרמטר ‎/-y בשורת הפקודה. כברירת מחדל, החלפתה של הגדרה זו גורמת להופעתה של הודעה, אלא אם כן הפקודה copy מופעלת ב- Script של אצווה.

  • צירוף קבצים

    כדי לצרף קבצים, ציין קובץ בודד עבור Destination, אך קבצים מרובים עבור Source (באמצעות תווים כלליים או באמצעות התבנית file1+file2+file3).

  • שימוש בפרמטר ‎/z

    אם החיבור מתנתק במהלך שלב ההעתקה (לדוגמה, אם השרת עובר למצב לא מקוון ומנתק את החיבור), פעולתה של הפקודה copy /z מתחדשת לאחר חידוש הקשר. כמו כן, הפרמטר ‎/z מציג את אחוזי פעולת ההעתקה שהושלמה עבור כל קובץ.

  • העתקה אל ומתוך התקנים

    באפשרותך להחליף שם התקן עבור מופע אחד או יותר של Source או של Destination.

  • שימוש בפרמטר ‎/b או השמטתו בעת העתקה להתקן

    כאשר Destination הוא התקן (לדוגמה, Com1 או Lpt1), הפרמטר ‎/b מעתיק נתונים להתקן במצב בינארי. במצב בינארי, הפקודה copy /b מעתיקה את כל התווים (כולל תווים מיוחדים כגון CTRL+C‏, CTRL+S‏, CTRL+Z‏ והחזרת גררה) להתקן בתור נתונים. אם תשמיט את הפרמטר ‎/b‏, הנתונים יועתקו להתקן במצב ASCII. במצב ASCII, תווים מיוחדים עשויים לגרום ל- Windows XP לשלב קבצים במהלך תהליך ההעתקה. לקבלת מידע נוסף, ראה ‎"שילוב קבצים".

  • שימוש בקובץ היעד המהווה ברירת מחדל

    אם לא תציין קובץ יעד, ייווצר עותק בעל אותו שם, תאריך יצירה ושעת יצירה כמו הקובץ המקורי והעותק החדש ימוקם בספריה הנוכחית בכונן הנוכחי. אם קובץ המקור נמצא בכונן הנוכחי ובספריה הנוכחית ולא ציינת כונן אחר או ספריה אחרת עבור קובץ היעד, הפקודה copy תפסיק את פעולתה ותציג את הודעת השגיאה הבאה:

    File cannot be copied onto itself

    0 File(s) copied

  • שילוב קבצים

    אם תציין יותר מקובץ Source אחד ותפריד ערכים באמצעות סימן חיבור (+), הפקודה copy תשלב את הקבצים ותיצור קובץ בודד. אם תשתמש בתווים כלליים (כלומר * או ?) ב- Source אך תציין שם קובץ בודד ב- Destination, הפקודה copy תשלב את כל הקבצים התואמים לשם הקובץ ב- Source ותיצור קובץ בודד בעל שם הקובץ המופיע ב- Destination. בכל מקרה, הפקודה copy פועלת על-פי ההנחה כי הקבצים המשולבים הם קבצי ASCII אלא אם כן תציין את הפרמטר ‎/b.

  • העתקת קבצי בעלי אורך אפס

    הפקודה Copy אינה מעתיקה קבצים בעלי אורך של 0 בתים. השתמש בפקודה xcopy כדי להעתיק קבצים אלה.

  • שינוי השעה והתאריך של קובץ

    אם ברצונך להקצות את השעה והתאריך הנוכחיים לקובץ מבלי לשנות את הקובץ, השתמש בתחביר שלהלן:

    copy /b Source+‎,,‎

    הפסיקים מציינים את ההשמטה של הפרמטר Destination.

  • העתקת קבצים בספריות משנה

    כדי להעתיק את כל הקבצים וספריות המשנה של ספריה, השתמש בפקודה xcopy. לקבלת מידע אודות הפקודה xcopy, ראה נושאים קרובים.

  • הפקודה copy, עם פרמטרים אחרים, זמינה מה- Recovery Console.

דוגמאות

כדי להעתיק קובץ בשם Memo.doc לקובץ Letter.doc בכונן הנוכחי וכדי להבטיח שבסוף הקובץ המועתק יופיע תו סוף קובץ, הקלד:

copy memo.doc letter.doc /a

כדי להעתיק קובץ בשם Robin.typ מהכונן והספריה הנוכחיים לספריה קיימת בשם Birds הממוקמת בכונן C, הקלד:

copy robin.typ c:\birds

אם הספריה Birds אינה קיימת, הקובץ Robin.typ יועתק לתוך קובץ בשם Birds הממוקם בספריית הבסיס בדיסק בכונן C.

כדי להעתיק מספר קבצים לתוך קובץ אחד, פרט מספר קבצי Source, הפרד את שמות הקבצים באמצעות סימן חיבור (+) וציין קובץ Destination שברצונך שיכיל את הקובץ המשולב הסופי. לדוגמה, כדי לשלב את הקבצים Mar89.rpt‏, Apr89.rpt‏ ו- May89.rpt, הממוקמים בכונן ובספריה הנוכחיים ולמקם אותם בקובץ בשם Report בכונן ובספריה הנוכחיים, הקלד:

copy mar89.rpt + apr89.rpt + may89.rpt report

בעת שילוב קבצים, הפקודה copy מסמנת את קובץ היעד עם התאריך והזמן הנוכחיים. אם תשמיט את הפרמטר Destination‏, הקבצים ישולבו ויאוחסנו תחת שמו של הקובץ הראשון שצוין. לדוגמה, כדי לשלב את כל ארבעת הקבצים בקובץ Report כאשר קובץ בשם Report כבר קיים, הקלד:

copy report + mar89.rpt + apr89.rpt + may89.rpt

באפשרותך גם לשלב מספר קבצים לתוך קובץ אחד על-ידי שימוש בתווים כלליים (כלומר * או ?). לדוגמה, כדי לשלב את כל הקבצים בספריה הנוכחית בכונן הנוכחי שהם בעלי סיומת ‎.txt לתוך קובץ בודד בשם Combin.doc, הקלד:

copy *.txt combin.doc

אם ברצונך לשלב מספר קבצים בינאריים לתוך קובץ אחד באמצעות תווים כלליים, עליך לכלול את הפרמטר ‎/b. פרמטר זה מונע מ- Windows XP מלהתייחס ל- CTRL+Z כתו סוף קובץ. לדוגמה, הקלד:

copy /b *.exe combin.exe

שים לב

  • אם תשלב קבצים בינאריים, ייתכן שלא תהיה אפשרות להשתמש בקובץ שנוצר עקב מבנה פנימי.

בדוגמה הבאה, הפקודה copy משלבת כל קובץ בעל סיומת ‎.txt עם קובץ ‎.ref התואם לו. התוצאה היא קובץ בעל אותו שם קובץ אך עם סיומת ‎.doc הפקודה copy משלבת את File1.txt עם File1.ref ליצירת File1.doc. לאחר מכן הפקודה copy משלבת את File2.txt עם File2.ref ליצירת File2.doc וכך הלאה. לדוגמה, הקלד:

copy *.txt + *.ref *.doc

כדי לשלב את כל הקבצים בעלי הסיומת ‎.txt ולאחר מכן לשלב את כל הקבצים בעלי הסיומת ‎.ref לתוך קובץ אחד בשם Combin.doc, הקלד:

copy *.txt + *.ref combin.doc


Country

פקודה זו מאפשרת למערכת המשנה MS-DOS להשתמש במאפייני זמן, תאריך ומטבע בינלאומיים וכן בהמרות בין אותיות רישיות לקטנות ובתווי הפרדה עשרוניים.

תחביר

country=xxx[,[yyy][,[Drive:][Path] FileName‎]]‎

פרמטרים

xxx
קביעת קידומת המדינה/אזור.
yyy
קביעת הקידוד עבור המדינה/אזור.
‎[Drive:][Path] FileName
קביעת המיקום והשם של הקובץ המכיל מידע אודות מדינה/אזור.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • הפקודה country מגדירה את התצורה של מערכת המשנה MS-DOS לזיהוי של ערכת התווים ומוסכמות הפיסוק הקיימות בעת שימוש באחת מן השפות הנתמכות. השתמש בקובץ ‎%systemroot%\System32\Config.nt, או בקובץ ההפעלה המקביל שצוין בקובץ מידע התוכנית (PIF) של התוכנית, כדי לטעון את ההגדרה מדינה/אזור.
  • קביעת שפות נתמכות

    הטבלה שלהלן מציינת כל מדינה/אזור או שפה הנתמכת על-ידי מערכת המשנה MS-DOS . בנוסף, הטבלה מפרטת את כל הקידודים בהם באפשרותך להשתמש עם כל קידומת מדינה/אזור. לדוגמה, אם תשתמש בקידומת המדינה/אזור 003, באפשרותך להשתמש בקודים 437 או 850 בלבד עבור הפרמטר yyy. הראשון משני הקידודים המפורטים עבור כל מדינה/אזור או שפה הוא קידוד ברירת המחדל.

    מדינה/אזור או שפה | קידומת מדינה/אזור | קידודים
    ארצות הברית | 001 | ‎437, 850
    קנדית-צרפתית | 002 | ‎863, 850
    הולנד | 031 | ‎850, 437
    בלגיה | 032 | ‎850, 437
    צרפת | 033 | ‎850, 437
    ספרד | 034 | ‎850, 437
    הונגריה | 036 | ‎852, 850
    איטליה | 039 | ‎850, 437
    שוויץ | 041 | ‎850, 437
    צ'כיה | 042 | ‎852, 850
    סלובקיה | 042 | ‎852, 850
    בריטניה | 044 | 850 ,437
    דנמרק | 045 | ‎850, 865
    שוודיה | 046 | ‎850, 437
    נורווגיה | 047 | ‎850, 865
    פולין | 048 | ‎852, 850
    גרמניה | 049 | ‎850, 437
    ברזיל | 055 | ‎850, 437
    אנגלית בינלאומית | 061 | 850 ,437
    פורטוגל | 351 | ‎850, 860
    פינלנד | 358 | ‎850, 437
  • קביעת תבניות בינלאומיות של שעה ותאריך

    הקוד מדינה/אזור מציין את תבניות השעה והתאריך המשמשות את הפקודות הבאות: backup‏, date ו- time.

    הטבלה הבאה מפרטת את תבניות התאריך והשעה הקשורות לכל קוד מדינה/אזור. עבור כל קוד מדינה/אזור, העמודה תבנית תאריך מראה את התצוגה עבור ה- 3 בינואר, 1994, והעמודה תבנית שעה מראה את התצוגה עבור 5:35 אחה"צ (עם 0 שניות ו- 0 מאיות שניה).

    מדינה/אזור או שפה | קידומת מדינה/אזור | תבנית תאריך | תבנית שעה
    ארצות הברית | 001 | 01/03/1994 | 5:35:00.00p
    קנדית-צרפתית | 002 | ‎1994-01-03 | 17:35:00
    אמריקה הלטינית | 003 | 03/01/1994 | 5:35:00.00p
    הולנד | 031 | ‎03-01-94 | 17:35:00
    בלגיה | 032 | 03/01/94 | 17:35:00
    צרפת | 033 | 03.01.1994 | 17:35:00
    ספרד | 034 | 3/01/94 | 17:35:00
    הונגריה | 036 | 1994.01.03 | 17:35:00
    איטליה | 039 | 03/01/94 | 17.35.00
    שוויץ | 041 | 03.01.94 | ‎17 35.00
    צ'כיה | 042 | 03.01.1994 | 17:35:00
    סלובקיה | 042 | 03.01.1994 | 17:35:00
    בריטניה | 044 | 03/01/94 | 17:35:00.00
    דנמרק | 045 | ‎03-01-94 | 17.35.00
    שוודיה | 046 | ‎1994-01-03 | 17.35.00
    נורווגיה | 047 | 03.01.94 | 17:35:00
    פולין | 048 | ‎1994-01-03 | 17:35:00
    גרמניה | 049 | 03.01.1994 | 17:35:00
    ברזיל | 055 | 03/01/94 | 17:35:00
    אנגלית בינלאומית | 061 | 03/01/1994 | 17:35:00.00
    פורטוגל | 351 | ‎03-01-1994 | 17:35:00
    פינלנד | 358 | 3.1.1994 | 17.35.00

דוגמאות

כדי להמיר שעה, תאריך, אותיות רישיות ומטבע בינלאומיים למוסכמות צרפתיות, הוסף את הפקודה הבאה לקובץ Config.nt:

country=033

כדי לציין קידוד עם קידומת המדינה של צרפת, הקלד:

country=033,850

אם תשמיט את הקידוד אך תכלול את הפרמטר ‎[‎Drive:][Path] FileName‎, עדיין יהיה עליך להקליד את הפסיק שהיה מופיע לפני הקידוד, כפי שמוצג בדוגמה הבאה:

country=033,,c:\winnt\system32\country.sys


Date

פקודה זו מציגה את הגדרות התאריך הנוכחיות של המערכת. כאשר נעשה בה שימוש ללא פרמטרים, הפקודה date מציגה את הגדרות התאריך הנוכחיות של המערכת ומציגה למשתמש הודעה המבקשת ממנו להקליד תאריך חדש.

תחביר

date [mm-dd-yy] [/t]‎

פרמטרים

mm-dd-yy
פרמטר זה קובע את התאריך שהוגדר כאשר mm מייצג את החודש, dd מייצג את היום ו- yy מייצג את השנה.
‎/t
פרמטר זה מציג את התאריך הנוכחי מבלי להציג הודעה המבקשת מהמשתמש להקליד תאריך חדש.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • עליך להפריד ערכים עבור mm‏, dd‏ ו- yy באמצעות נקודות (.), מקפים (-) או קווים נטויים (/).
  • ערכים חוקיים עבור mm נעים בין 1 עד 12.
  • ערכים חוקיים עבור dd נעים בין 1 עד 31.
  • ערכים חוקיים עבור yy נעים בין 80 עד 99 או 1980 עד 2099.
  • מערכת ההפעלה Windows XP משנה את החודש והשנה אוטומטית, לפי מספר הימים של החודש ( 28,‏ 29,‏ 30 או 31 ימים).

דוגמאות

כדי לשנות את התאריך ל- 3 באוגוסט, 2000, הקלד אחת מהמחרוזות הבאות:

08.03.00

‎08-03-00

08/03/00

כדי להציג את תאריך המערכת הנוכחי, הקלד:

date /t


Debug

פקודה זו מפעילה את Debug.exe, תוכנית המשמשת לבדיקה ולאיתור באגים בקבצי הפעלה של MS-DOS . כאשר נעשה בה שימוש ללא פרמטרים הפקודה debug מפעילה את Debug.exe ושורת הפקודה debug מופיעה. שורה זו מיוצגת על-ידי מקף (-).

תחביר

debug [[Drive:][Path] FileName ‎[parameters]]‎

פרמטרים

‎[Drive:][Path] FileName
פרמטר זה מציין את המיקום והשם של קובץ ההפעלה שברצונך לבדוק.
parameters
פרמטר זה מציין כל מידע שורת פקודה הדרוש לקובץ ההפעלה שברצונך לבדוק.
?
פרמטר זה מציג רשימה של פקודות משנה של debug.

הערות

  • XOX
  • שימוש בפקודות מערכת המשנה MS-DOS:

    הפקודה debug היא פקודה של מערכת המשנה MS-DOS הפועלת תחת WOW/NTVDM.

  • הפרדת פרמטרים של פקודה

    באפשרותך להפריד פרמטרים באמצעות פסיק או רווח לבן, אולם תווים מפרידים אלה דרושים רק בין שני ערכים הקסדצימאליים. לדוגמה, הפקודות הבאות הן זהות:

    dcs:100 110

    d cs:100 110

    d,cs:100,110

  • שימוש בפקודות משנה של debug

    קיימות מספר פקודות משנה של debug שבהן ניתן להשתמש. לקבלת מידע נוסף אודות פקודות משנה של debug ראה נושאים קרובים.


Debug: a (assemble)

גרפיקה של Microsoft Windows

Debug: a (assemble)‎

פקודה זו מרכיבה קיצורי 8086/8087/8088 ישירות לזיכרון. כאשר נעשה בה שימוש ללא פרמטרים הפקודה a מתחילה בהרכבה במקום האחרון בו עצרה.

תחביר

a [address‎]‎

פרמטרים

address
פרמטר זה מציין את המיקום בו יוקלדו קיצורי שפת אסמבלי. השתמש בערכים הקסדצימאליים עבור address והקלד כל ערך בלי תו h הנגרר.
?
פרמטר זה מציג רשימת פקודות משנה של Debug.

הערות

  • XOX
  • ציון ערכי address חוקיים

    הפרמטר address הוא רישום בעל שני חלקים, המכיל אוגר יחידה אלפביתי או כתובת יחידה ארבע-ספרתית הכוללת ערך היסט. באפשרותך להשמיט את אוגר היחידה או את כתובת היחידה. CS הוא יחידת ברירת המחדל עבור פקודות המשנה הבאות של Debug‏: a‏, g,‏ l,‏ t,‏ u‏ ו- w. ‏DS הוא יחידת ברירת המחדל עבור כל שאר פקודות המשנה. כל הערכים הנומריים הם בתבנית הקסדצימאלית. עליך לכלול נקודתיים בין שם היחידה לבין ערך ההיסט. להלן כתובות חוקיות:

    CS:0100

    04BA:0100

  • ציון קיצורי תחיליות

    עלייך לציין קיצור תחילית לפני קוד הפעולה (opcode) שאליו היא מפנה. פקודת המשנה a יוצרת ממשפטי שפת אסמבלי קוד מכונה הניתן להפעלה. כל הערכים הנומריים מוצגים בתבנית הקסדצימאלית ועליך להקליד אותם כתו אחד עד ארבעה תווים.

  • שימוש בקיצורים

    הקיצורים לעקיפת יחידות הם cs:‎‏, ds:‎‏, es:‎‏ ו- ss:‎. הקיצור עבור Far Return הוא retf. על קיצורים לטיפול במחרוזות לציין במפורש את גודל המחרוזת. לדוגמה, השתמש בקיצור movsw כדי להעביר מחרוזות מילים (16 סיביות) והשתמש בקיצור movsb כדי להעביר מחרוזות בתים (8 סיביות).

  • הרכבת קפיצות ושיחות

    המרכיב (Assembler) מבצע הרכבה אוטומטית של קפיצות או של קריאות (short, ‏near או far), בהתאם להעברת הבתים, לכתובת היעד. באפשרותך לעקוף קפיצות או קריאות על-ידי שימוש בתחילית near או far. לדוגמה:

    -a0100:0500
    0100:0500 jmp 502 ; a 2-byte short jump
    0100:0502 jmp near 505 ; a 3-byte near jump
    0100:0505 jmp far 50a ; a 5-byte far jump

    באפשרותך לקצר את התחילית near ל- ne.

  • הבחנה בין מיקומי זיכרון של מילים ושל בתים

    כאשר אופרנד מתייחס למיקום זיכרון של מילה או של בית, עליך לציין את סוג הנתונים באמצעות התחילית word ptr או באמצעות התחילית byte ptr. באפשרותך להשתמש בקיצור wo עבור התחילית word ptr ובקיצור by עבור התחילית byte ptr. לדוגמה:

    dec wo [si]‎
    neg byte ptr [128]‎

  • קביעת אופרנדים

    הפקודה Debug.exe משתמשת במוסכמה הנפוצה לפיה אופרנד המוקף בסוגריים מרובעים ([ ]) מתייחס למיקום זיכרון. זוהי הדרך היחידה בה הפקודה Debug.exe יכולה להבדיל בין אופרנד מיידי לבין אופרנד שהוא מיקום זיכרון. לדוגמה:

    mov ax,21 ; load AX with 21h
    mov ax,[21] ; load AX with the
    ; contents of
    ; memory location 21h

  • שימוש בהוראות מדומות

    שתי הוראות מדומות פופולריות זמינות עם פקודת המשנה a: קוד הפעולה (opcode)‏ db, האוסף ערכי בתים ישירות לזיכרון וקוד הפעולה dw האוסף ערכי מילים ישירות לזיכרון. לדוגמה:

    db 1,2,3,4,"THIS IS AN EXAMPLE"
    db 'THIS IS A QUOTATION MARK: "'
    db "THIS IS A QUOTATION MARK: '"
    dw 1000,2000,3000,"BACH"

  • הכנסת נתונים לתוך בתים ספציפיים

    לקבלת מידע נוסף אודות הכנסת נתונים לתוך בתים ספציפיים באמצעות פקודת המשנה e‏ (enter), ראה נושאים קרובים.

  • פירוק בתים

    לקבלת מידע נוסף אודות פירוק בתים באמצעות פקודת המשנה u‏ (unassemble), ראה נושאים קרובים.

דוגמאות

פקודת המשנה a תומכת בכל צורות פקודות האוגר העקיפות. לדוגמה:

add bx,34[bp+2].[si-1]
pop [bp+di]
push [si] )

פקודת המשנה a תומכת כמו כן בכל המילים הנרדפות של קוד פעולה. לדוגמה:

loopz 100
loope 100
ja 200
jnbe 200

עבור קודי פעולה מסוג 8087, עליך לציין את התחילית wait או fwait. לדוגמה:

fwait fadd st,st(3) ; this line assembles
‎; an fwait prefix


Debug: c (compare)

גרפיקה של Microsoft Windows

Debug: c (compare)‎

פקודה זו משווה בין שני חלקי זיכרון.

תחביר

c range address

פרמטרים

range
פרמטר נדרש. פרמטר זה מציין את כתובות ההתחלה והסיום, או את כתובת ההתחלה והאורך של אזור הזיכרון הראשון שברצונך להשוות.
address
פרמטר נדרש. פרמטר זה קובע את כתובת ההתחלה של אזור הזיכרון השני שברצונך להשוות.
?
פרמטר זה מציג רשימה של פקודות משנה של Debug.

הערות

  • XOX
  • ציון ערכי Debug חוקיים

    השתמש בפרמטר range יחד עם פקודת המשנה Debug כדי לציין טווח של זיכרון. באפשרותך לבחור אחת משתי תבניות עבור range: כתובת התחלה וכתובת סיום או כתובת התחלה והאורך (מצוין באמצעות l) של הטווח. לדוגמה, שני התחבירים הבאים מציינים טווח של 16 בתים המתחיל ב- CS:100:

    cs:100 10f

    cs:100 l 10

  • ציון ערכי address חוקיים

    הפרמטר address הוא רישום בעל שני חלקים, המכיל אוגר יחידה אלפביתי או כתובת יחידה ארבע-ספרתית בעלת ערך היסט. באפשרותך להשמיט את אוגר היחידה או את כתובת היחידה. CS הוא יחידת ברירת המחדל עבור פקודות המשנה הבאות של Debug‏: a‏, g‏, l‏, t‏, u‏ ו- w. ‏DS הוא יחידת ברירת המחדל עבור כל שאר פקודות המשנה. כל הערכים הנומריים מוצגים בתבנית הקסדצימאלית. עליך לכלול נקודתיים בין שם היחידה לבין ערך ההיסט. להלן כתובות חוקיות:

    CS:0100

    04BA:0100

  • אם אזורי הזיכרון range ו- address זהים, פקודת המשנה c אינה מציגה דבר וחוזרת לשורת הפקודה Debug. אם קיימים הבדלים, פקודת המשנה c מציגה אותם בתבנית הבאה:

    address1 byte1 byte2 address2

דוגמאות

כדי להשוות את בלוק הזיכרון מ- 100h עד 10Fh עם בלוק הזיכרון מ- 300h עד 30Fh, הקלד:

c100,10f 300

או

c100l10 300

שתי פקודות אלה מייצרות את הפלט הבא (בהנחה ש- DS = 197F):

197F:0100 4D E4 197F:0300
197F:0101 67 99 197F:0301
197F:0102 A3 27 197F:0302
197F:0103 35 F3 197F:0303
197F:0104 97 BD 197F:0304
197F:0105 04 35 197F:0305
197F:0107 76 71 197F:0307
197F:0108 E6 11 197F:0308
197F:0109 19 2C 197F:0309
197F:010A 80 0A 197F:030A
197F:010B 36 7F 197F:030B
197F:010C BE 22 197F:030C
197F:010D 83 93 197F:030D
197F:010E 49 77 197F:030E
197F:010F 4F 8A 197F:030F

הכתובות 197F:0106 ו- 197F:0306 אינן נמצאות ברשימה. פירושו של דבר שהערכים בכתובות אלה זהים.


Debug: d (dump)

גרפיקה של Microsoft Windows

Debug: d (dump)‎

פקודה זו מציגה את התוכן של טווח של כתובות זיכרון. אם נעשה בה שימוש ללא פרמטרים, הפקודה d מציגה את התוכן של 128 בתים, החל מסוף טווח הכתובת שצוין בפקודת המשנה d הקודמת.

תחביר

d [range‎]‎

פרמטרים

range
קביעת כתובות ההתחלה והסיום, או קביעה של כתובת ההתחלה והאורך של אזור הזיכרון שאת תוכנו ברצונך להציג.
?
פרמטר זה מציג רשימה של פקודות משנה של Debug.

הערות

  • XOX
  • ציון ערכי range חוקיים

    השתמש בפרמטר range עם פקודת משנה של Debug כדי לציין טווח של זיכרון. באפשרותך לבחור באחת משתי תבניות עבור range: כתובת התחלה וכתובת סיום או כתובת התחלה והאורך (מצוין על-ידי l) של הטווח. לדוגמה, שני התחבירים הבאים מציינים טווח של 16 בתים המתחיל ב- CS:100:

    cs:100 10f

    cs:100 l 10

  • בעת שימוש בפקודת המשנה d, הקובץ Debug.exe מציג תוכן זיכרון בשני חלקים: חלק הקסדצימאלי (כלומר, כל ערך בית מוצג בתבנית הקסדצימאלית) וחלק של ASCII (כלומר כל ערך בית מוצג כתו ASCII). כל תו שאינו מודפס מצוין על-ידי נקודה (.) בחלק ה- ASCII של התצוגה. כל שורת תצוגה מראה את התוכן של 16 בתים, עם מקף בין הבית השמיני לתשיעי. כל שורת תצוגה מתחילה בתחום של 16 בתים.
  • לקבלת מידע נוסף אודות הצגת התוכן של אוגרים באמצעות פקודת המשנה r (register), ראה נושאים קרובים.

דוגמאות

הקלד:

dcs:100 10f

הקובץ Debug.exe מציג את התוכן של הטווח בתבנית הבאה:

04BA:0100 54 4F 4D 00 53 41 57 59-45 52 00 00 00 00 00 00.....‎

אם תקליד את הפקודה d ללא פרמטרים, הפקודה Debug.exe תעצב את התצוגה כפי שתואר בדוגמה הקודמת. כל שורה בחלון שורת הפקודה מתחילה בכתובת הגדולה ב- 16 בתים מהכתובת בשורה הקודמת (או ב- 8 בתים אם ברשותך מסך של 40 עמודות). עבור כל פקודת משנה d שתקליד לאחר מכן ללא פרמטרים, הפקודה Debug.exe תציג את הבתים הבאים מיד לאחר הבתים שהוצגו בפעם האחרונה.

כדי להציג את התוכן של 20h בתים, החל מ- CS:100, הקלד:

dcs:100 l 20

כדי להציג את התוכן של כל הבתים בטווח השורות מ- 100h עד 115h ביחידה CS, הקלד:

dcs:100 115


Debug: e (enter)

גרפיקה של Microsoft Windows

Debug: e (enter)‎

הזנת נתונים לזיכרון בכתובת שצוינה.

תחביר

e address [list‎]‎

פרמטרים

address
פרמטר נדרש. פרמטר זה מציין את מיקום הזיכרון הראשון בו ברצונך להזין נתונים.
list
קביעת הנתונים שברצונך להזין לבתים רציפים של זיכרון.
?
פרמטר זה מציג רשימה של פקודות משנה של Debug.

הערות

  • XOX
  • ציון ערכי address חוקיים

    הפרמטר Address הוא רישום בעל שני חלקים, המכיל אוגר יחידה אלפביתי או כתובת יחידה ארבע-ספרתית בעלת ערך היסט. באפשרותך להשמיט את אוגר היחידה או את כתובת היחידה. CS הוא יחידת ברירת המחדל של פקודות המשנה הבאות של Debug‏: a‏, g‏, l‏, t‏, u‏ ו- w‏. DS הוא יחידת ברירת המחדל עבור כל שאר פקודות המשנה. כל הערכים הנומריים מוצגים בתבנית הקסדצימאלית. עליך לכלול נקודתיים בין שם היחידה לערך ההיסט. להלן כתובות חוקיות:

    CS:0100

    04BA:0100

  • שימוש בפרמטר address

    אם תציין ערך עבור address מבלי לציין ערך עבור הפרמטר האופציונלי list, הקובץ Debug.exe יציג את הכתובת ואת התוכן שלה, יחזור על הכתובת בשורה הבאה וימתין לקלט מהמשתמש. בנקודה זו, באפשרותך לבצע אחת מהפעולות הבאות:

    • החלפת ערך הבית. כדי לבצע פעולה זו, הקלד ערך חדש לאחר הערך הנוכחי. אם הערך שהקלדת אינו ערך הקסדצימאלי חוקי או אם הוא מכיל יותר משתי ספרות, הקובץ Debug.exe לא יצור הד עבור התו הלא חוקי או התו המיותר.
    • מעבר לבית הבא. כדי לבצע פעולה זו, הקש על SPACEBAR. כדי לשנות את הערך בבית זה, הקלד ערך חדש לאחר הערך הנוכחי. אם תחרוג מתחום של 8 בתים בעת הקשה על SPACEBAR‏, הפקודה Debug.exe תתחיל שורת תצוגה חדשה ותציג את הכתובת החדשה בתחילת השורה.
    • חזרה לבית הקודם. כדי לבצע פעולה זו, הקש על מקש HYPHEN. באפשרותך להקיש על מקש HYPHEN מספר פעמים כדי לחזור יותר מבית אחד לאחור. בעת הקשה על HYPHEN, הפקודה Debug.exe מתחילה שורה חדשה ומציגה את הכתובת ואת ערך הבית הנוכחיים.
    • הפסקה של פעולת פקודה המשנה e. כדי לבצע פעולה זו, הקש ENTER. באפשרותך להקיש ENTER בכל מיקום בית.
  • שימוש בפרמטר list

    אם תציין ערכים עבור הפרמטר list, פקודת המשנה e תחליף ברצף את ערכי הבתים הקיימים בערכים מהרשימה. אם תתרחש שגיאה, לא יתבצעו שינויים בערכי הבתים.

    ערכי List יכולים להיות ערכי בתים הקסדצימאליים או מחרוזות. הפרדת הערכים מתבצעת באמצעות רווח, פסיק או תו טאב. עליך להקיף מחרוזות בגרשיים בודדים (כלומר, 'string') או במרכאות כפולות (כלומר, "string").

  • הרכבת קיצורים

    לקבלת מידע נוסף אודות הרכבת קיצורים באמצעות פקודת המשנה a‏ (assemble) ראה נושאים קרובים.

  • הצגת התוכן של חלק של זיכרון

    לקבלת מידע נוסף אודות הצגת התוכן של חלק של זיכרון באמצעות פקודת המשנה d‏ (dump), ראה נושאים קרובים.

דוגמאות

הקלד:

ecs:100

הפקודה Debug.exe מציגה את התוכן של הבית הראשון בתבנית הבאה:

04BA:0100 EB‎._‎

כדי לשנות ערך זה ל- 41, הקלד 41 בנקודת הכניסה, כמתואר להלן:

04BA:0100 EB.41_‎

באפשרותך להקליד ערכי בית עוקבים עם פקודת משנה e אחת. במקום להקיש ENTER לאחר הקלדת הערך החדש, הקש על SPACEBAR.‏ הפקודה Debug.exe תציג את הערך הבא. בדוגמה זו, אם תקיש SPACEBAR שלוש פעמים, הפקודה Debug.exe תציג את הערכים הבאים:

04BA:0100 EB.41 10. 00. BC‎._‎

כדי לשנות את הערך ההקסדצימאלי BC ל- 42, הקלד 42 בנקודת הכניסה, כמתואר להלן:

04BA:0100 EB.41 10. 00. BC.42_‎

כדי לשנות את הערך 10 ל- 6F, הקש על HYPHEN פעמיים כדי לחזור לכתובת 0101 (ערך 10). הפקודה Debug.exe תציג את הפלט הבא:

04BA:0100 EB.41 10. 00. BC.42-
04BA:0102 00.-
04BA:0101 10._

הקלד 6f בנקודת הכניסה כדי לשנות את הערך, כמתואר להלן:

04BA:0101 10.6F_‎

הקש ENTER כדי להפסיק את פעולת פקודת המשנה e ולחזור לשורת הפקודה Debug.

הערך הבא הוא דוגמה לערך מחרוזת:

eds:100 "This is the text example‎"‎

מחרוזת זו תמלא 24 בתים, החל מ- DS:100.


Debug: f (fill)

גרפיקה של Microsoft Windows

Debug: f (fill)‎

מילוי כתובות באזור הזיכרון שצוין עם הערכים שיצוינו.

תחביר

f range list

פרמטרים

range
פרמטר נדרש. פרמטר זה מציין את כתובות ההתחלה והסיום, או את כתובת ההתחלה והאורך של אזור הזיכרון שברצונך למלא.
list
פרמטר נדרש. פרמטר זה מציין את הנתונים שברצונך להזין.
?
פרמטר זה מציג רשימה של פקודות משנה של Debug.

הערות

  • XOX
  • ציון ערכי range חוקיים

    השתמש בפרמטר range עם פקודת משנה של Debug כדי לציין טווח זיכרון. באפשרותך לבחור אחת משתי תבניות עבור range: כתובת התחלה וכתובת סיום או כתובת התחלה והאורך (מצוין על-ידי l) של הטווח. לדוגמה, שני התחבירים הבאים מציינים טווח של 16 בתים המתחיל ב- CS:100:

    cs:100 10f

    cs:100 l 10

  • ציון נתונים

    באפשרותך לציין נתונים בתבנית הקסדצימאלית או בתבנית ASCII. נתונים שאחסנת בעבר בכתובת שצוינה יאבדו.

  • שימוש בפרמטר list

    הפרמטר list יכול להיות מורכב ממספרים הקסדצימאליים או ממחרוזת המוקפת במרכאות (כלומר "string").

דוגמאות

כדי למלא מיקומי זיכרון 04BA:100 עד 04BA:1FF בחמישה ערכים ספציפיים (לדוגמה 42, 45, 52‏, 54‏, 41) ולחזור על חמשת הערכים עד שהפקודה Debug.exe תמלא את כל 100h הבתים, הקלד:

f04ba:100l100 42 45 52 54 41


Debug: g (go)

גרפיקה של Microsoft Windows

Debug: g (go)‎

פקודה זו מפעילה את התוכנית הנמצאת כעת בזיכרון. כאשר משתמשים בה ללא פרמטרים, הפקודה g מתחילה לפעול בכתובת הנוכחית באוגרים CS:IP.

תחביר

g [=address] [breakpoints‎]‎

פרמטרים

address
פרמטר זה מציין את הכתובת בתוכנית הנמצאת כעת בזיכרון שבה ברצונך להתחיל להפעיל את התוכנית.
breakpoints
פרמטר זה מציין 1 עד 10 נקודות עצירה זמניות שבאפשרותך להגדיר כחלק מפקודת המשנה g.
?
פרמטר זה מציג רשימה של פקודות משנה של Debug.

הערות

  • XOX
  • ציון ערכי address חוקיים

    הפרמטר address הוא רישום בעל שני חלקים, המכיל אוגר יחידה אלפביתי או כתובת יחידה ארבע-ספרתית הכוללת ערך היסט. באפשרותך להשמיט את אוגר היחידה או את כתובת היחידה. CS הוא יחידת ברירת המחדל עבור פקודות המשנה הבאות של Debug‏: a‏, g‏, l‏, t‏, u‏ ו- w‏. DS הוא יחידת ברירת המחדל עבור כל שאר פקודות המשנה. כל הערכים הנומריים הם בתבנית הקסדצימאלית. עליך לכלול נקודתיים בין שם היחידה לבין ערך ההיסט. להלן כתובות חוקיות:

    CS:0100

    04BA:0100

  • שימוש בפרמטר address

    עליך להקליד לפני הפרמטר address סימן שוויון (=) כדי להבדיל בין address לבין כתובות נקודת העצירה (breakpoints).

  • קביעת נקודות עצירה

    התוכנית עוצרת בנקודת העצירה הראשונה בה היא נתקלת, בלי קשר למקום בו הקלדת את נקודת העצירה ברשימה breakpoints.‏ Debug.exe מחליפה את ההוראה המקורית בכל נקודת עצירה בקוד פסיקה.

    כאשר התוכנית מגיעה לנקודת עצירה, Debug.exe משחזרת את כל הכתובות של נקודות העצירה להוראות המקוריות שלהן ומציגה את התוכן של כל הרישומים, את המצב של כל הדגלים ואת הצורה המפוענחת של ההוראה האחרונה שבוצעה. הפקודה Debug.exe מציגה את אותו מידע שהיה מוצג אם היית משתמש בפקודת המשנה r‏ (register) ומציין את הכתובת של נקודת העצירה.

    אם לא תפסיק את פעולתה של התוכנית באחת מנקודות העצירה, Debug.exe לא תחליף את קודי הפסיקה בהוראות המקוריות.

    באפשרותך להגדיר נקודות עצירה רק בכתובות המכילות את הבית הראשון של קוד הפעולה (opcode) ‏8086 . אם תגדיר יותר מ- 10 נקודות עצירה, Debug.exe תציג את ההודעה הבאה:

    bp Error

  • שימוש במצביע המחסנית של המשתמש

    על מצביע המחסנית של המשתמש להיות חוקי ולכלול 6 בתים זמינים עבור פקודת המשנה g. פקודת המשנה g משתמשת בהוראה iret כדי לקפוץ לתוכנית שברצונך לבדוק. Debug.exe מגדירה את מצביע המחסנית של המשתמש ודוחפת את דגלי המשתמש, את אוגר יחידת הקוד ואת מצביע ההוראות למחסנית של המשתמש (אם המחסנית של המשתמש אינה חוקית או קטנה מדי, מערכת ההפעלה עשויה להיכשל). Debug.exe מציבה קוד פסיקה (כלומר, 0CCh) בכתובת או בכתובות של נקודת העצירה שצוינו.

  • הפעלה מחדש של תוכנית

    אל תפעיל מחדש תוכנית לאחר הופעת ההודעה הבאה:

    Program terminated normally

    כדי להפעיל את התוכנית כראוי, טען אותה מחדש באמצעות פקודות המשנה n‏ (Name) ו- l‏ (Load).

  • לקבלת מידע נוסף אודות ביצוע לולאה, הוראת מחרוזת חוזרת, פסיקת תוכנה או רוטינת משנה באמצעות פקודת המשנה P‏ (proceed), ראה נושאים קרובים.
  • לקבלת מידע נוסף הפעלת הוראה אחת באמצעות פקודת המשנה t‏ (trace), ראה נושאים קרובים.

דוגמאות

כדי להפעיל את התוכנית הנמצאת כעת בזיכרון עד לכתובת נקודת העצירה 7550 ביחידה CS, הקלד:

gcs:7550

Debug.exe מציגה את התוכן של האוגרים ואת מצב הדגלים ומפסיקה את פעולת פקודת המשנה g.

כדי לקבוע שתי נקודות עצירה, הקלד:

gcs:7550, cs:8000

אם תקליד את פקודת המשנה g שוב לאחר ש- Debug.exe נתקלה בנקודת עצירה, ההפעלה תתחיל בהוראה שלאחר נקודת העצירה ולא בכתובת ההתחלה.


Debug: h (hexadecimal)

גרפיקה של Microsoft Windows

Debug: h (hexadecimal)‎

פקודה זו מבצעת אריתמטיקה הקסדצימאלית בשני פרמטרים שיצוינו.

תחביר

h value1 value2

פרמטרים

value1
פרמטר נדרש. פרמטר זה מייצג כל מספר הקסדצימאלי בטווח של 0 עד FFFFh.
value2
פרמטר נדרש. פרמטר זה מייצג מספר הקסדצימאלי שני בטווח של 0 עד FFFFh.
?
פרמטר זה מציג רשימה של פקודות משנה של Debug.

הערות

  • XOX
  • Debug.exe מחברת תחילה את שני הפרמטרים שצוינו ולאחר מכן מחסירה את הפרמטר השני מהראשון. התוצאות של חישובים אלה מוצגות בשורה אחת: תחילה הסכום ולאחר מכן ההפרש.

דוגמאות

הקלד:

h19f 10a

Debug.exe מבצעת את החישובים ומציגה את התוצאה הבאה:

02A9 0095


Debug: i (input)

גרפיקה של Microsoft Windows

Debug: i (input)‎

קריאה והצגה של ערך בית אחד מהיציאה שצוינה.

תחביר

i port

פרמטרים

port
פרמטר נדרש. פרמטר זה מציין את יציאת הקלט באמצעות כתובת. הכתובת יכולה להיות ערך של 16 סיביות.
?
פרמטר זה מציג רשימה של פקודות משנה של Debug.

הערות

  • XOX
  • לקבלת מידע נוסף אודות שליחת ערך בית ליציאת פלט באמצעות פקודת המשנה o‏ (output), ראה נושאים קרובים.

דוגמאות

הקלד:

i2f8

אם ערך הבית ביציאה הוא 42h, ‏Debug.exe קוראת את הבית ומציגה את הערך באופן הבא:

42


Debug: l (load)

גרפיקה של Microsoft Windows

Debug: l (load)‎

פקודה זו טוענת קובץ או תוכן של סקטורים ספציפיים בדיסק לתוך הזיכרון. כאשר נעשה בה שימוש ללא פרמטרים, פקודת המשנה l טוענת את הקובץ שצוין בשורת הפקודה של Debug לזיכרון, החל בכתובת CS:100. בנוסף, Debug.exe מגדירה את האוגרים BX ו- CX עם מספר הבתים שנטענו. אם לא ציינת קובץ בשורת הפקודה Debug, הקובץ שייטען הוא הקובץ האחרון שציינת באמצעות פקודת המשנה n‏ (name).

תחביר

l [address]‎

l [address] [Drive] [FirstSector] [number]‎

פרמטרים

address
פרמטר זה קובע את מיקום הזיכרון בו ברצונך לטעון את הקובץ או את תוכן הסקטור. אם לא תציין ערך עבור address, ‏Debug.exe תשתמש בכתובת הנוכחית באוגר CS.
Drive
קביעת הכונן המכיל את הדיסק ממנו יש לקרוא סקטורים ספציפיים. ערך זה מספרי: ‎0 = A‏, ‎1 = B‏, ‎2 = C וכן הלאה.
FirstSector
פרמטר זה מציין את המספר ההקסדצימאלי של הסקטור הראשון שממנו ברצונך לטעון תוכן.
number
פרמטר זה מציין את המספר ההקסדצימאלי של סקטורים עוקבים שמתוכם ברצונך לטעון תוכן. השתמש בפרמטרים Drive‏, FirstSector ו- number רק אם ברצונך לטעון את התוכן של סקטורים ספציפיים במקום לטעון את הקובץ שצוין בשורת הפקודה Debug או בפקודת המשנה n‏ (name) האחרונה.
?
פרמטר זה מציג רשימה של פקודות משנה של Debug.

הערות

  • XOX
  • כדי לטעון את התוכן של מספר הבתים שצוינו ברישומים BX:CX מקובץ דיסק, השתמש בתחביר הבא:

    l [address]‎

  • כדי לעקוף את מערכת הקבצים ולטעון ישירות סקטורים ספציפיים, השתמש בתחביר הבא:

    l [address] [Drive] [FirstSector] [number]‎

  • ציון ערכי address חוקיים

    הפרמטר address הוא רישום בעל שני חלקים, המכיל אוגר יחידה אלפביתי או כתובת יחידה ארבע-ספרתית הכוללת ערך היסט. באפשרותך להשמיט את אוגר היחידה או את כתובת היחידה. CS הוא יחידת ברירת המחדל עבור פקודות המשנה הבאות של Debug‏: a‏, g‏, l‏, t‏, u‏ ו- w‏. DS‏ הוא יחידת ברירת המחדל עבור כל שאר פקודות המשנה. כל הערכים הנומריים הם בתבנית הקסדצימאלית. עליך לכלול נקודתיים בין שם היחידה לבין ערך ההיסט. להלן כתובות חוקיות:

    CS:0100

    04BA:0100

  • שימוש בפרמטר address

    אם תשתמש בפקודת המשנה l עם הפרמטר address‏, Debug.exe תתחיל לטעון את הקובץ או את התוכן של הסקטורים שצוינו במיקום הזיכרון address.

  • שימוש בכל הפרמטרים

    אם תשתמש בפקודת המשנה l עם כל הפרמטרים, Debug.exe תטען את התוכן של סקטורים ספציפיים בדיסק במקום לטעון קובץ.

  • טעינת התוכן של סקטורים ספציפיים

    כל סקטור בטווח שצוין נקרא מתוך Drive. הפקודה Debug.exe מתחילה לטעון עם FirstSector וממשיכה עד שהתוכן של מספר הסקטורים שצוין בפרמטר number נטען.

  • טעינת קובץ ‎.exe

    Debug.exe מתעלמת מהפרמטר address עבור קבצי ‎.exe אם תציין קובץ ‎.exe‏, הפקודה Debug.exe תעביר את הקובץ לכתובת הטעינה שצוינה בכותרת של קובץ ה- ‎.exe הכותרת עצמה תוסר מקובץ ה- ‎.exe לפני שהקובץ ייטען לזיכרון, כך שהגודל של קובץ ‎.exe בדיסק יהיה שונה מגודל הקובץ בזיכרון. אם ברצונך לבדוק קובץ ‎.exe שלם, שנה את שם הקובץ לשם עם סיומת אחרת.

  • פתיחת קובץ ‎.hex

    Debug.exe מניחה כי קבצים עם סיומת ‎.hex הם קבצים בתבנית הקסדצימאלית. באפשרותך להקליד את פקודת המשנה l ללא פרמטרים כדי לטעון קובץ הקסדצימאלי המתחיל בכתובת שצוינה בקובץ ההקסדצימאלי. אם פקודת המשנה l שהקלדת כוללת את הפרמטר address‏, Debug.exe מוסיפה את הכתובת שצוינה לכתובת שנמצאה בקובץ ההקסדצימאלי כדי לקבוע את כתובת ההתחלה.

  • לקבלת מידע נוסף אודות ציון קובץ באמצעות פקודת המשנה n‏ (name), ראה נושאים קרובים.
  • לקבלת מידע נוסף אודות כתיבת קובץ העובר Debug לדיסק באמצעות פקודת המשנה w‏ (write), ראה נושאים קרובים.

דוגמאות

בשורת הפקודה, הקלד:

Debug

הקלד:

nfile.com

כדי לטעון את File.com, הקלד:

l

Debug.exe טוענת את הקובץ ומציגה את שורת הפקודה Debug.

כדי לטעון את התוכן של 109 (6Dh) סקטורים מכונן C, החל בסקטור הלוגי 15 (0Fh), לזיכרון המתחיל בכתובת 04BA:0100, הקלד:

l04ba:100 2 0f 6d


Debug: m (move)

גרפיקה של Microsoft Windows

Debug: m (move)‎

העתקת התוכן של בלוק זיכרון לבלוק זיכרון אחר.

תחביר

m range address

פרמטרים

range
פרמטר נדרש. פרמטר זה מציין את כתובות ההתחלה והסיום או את כתובת ההתחלה והאורך של אזור הזיכרון אשר את תוכנו ברצונך להעתיק.
address
פרמטר זה קובע את כתובת ההתחלה של המיקום אליו ברצונך להעתיק את התוכן של range.
?
פרמטר זה מציג רשימה של פקודות משנה של Debug.

הערות

  • XOX
  • ציון ערכי range חוקיים

    השתמש בפרמטר range עם פקודת משנה של Debug כדי לציין טווח של זיכרון. באפשרותך לבחור אחת משתי תבניות עבור range: כתובת התחלה וכתובת סיום או כתובת התחלה והאורך (מצוין על-ידי l) של הטווח. לדוגמה, שני התחבירים הבאים מציינים טווח של 16 בתים המתחיל ב- CS:100:

    cs:100 10f

    cs:100 l 10

  • ציון ערכי address חוקיים

    הפרמטר address הוא רישום בעל שני חלקים, המכיל אוגר יחידה אלפביתי או כתובת יחידה ארבע-ספרתית הכוללת ערך היסט. באפשרותך להשמיט את אוגר היחידה או את כתובת היחידה. CS הוא יחידת ברירת המחדל עבור פקודות המשנה הבאות של Debug‏: a‏, g‏, l‏, t‏, u‏ ו- w‏. DS‏ הוא יחידת ברירת המחדל עבור כל שאר פקודות המשנה. כל הערכים הנומריים הם בתבנית הקסדצימאלית. עליך לכלול נקודתיים בין שם היחידה לבין ערך ההיסט. להלן כתובות חוקיות:

    CS:0100

    04BA:0100

  • העתקת נתונים

    אם לא נכתבים נתונים חדשים לכתובות בבלוק המועתק, הנתונים המקוריים נשארים שלמים. עם זאת, אם בלוק היעד כבר מכיל נתונים (כפי שעשוי לקרות בפעולת העתקה חופפת), נתונים אלה יוחלפו (פעולות העתקה חופפות הן פעולות שבהן חלק מבלוק היעד חופף לחלק מבלוק המקור).

  • ביצוע פעולות העתקה חופפות

    פקודת המשנה m מבצעת פעולות העתקה חופפות מבלי לאבד נתונים בכתובות היעד. תוכן הכתובות שיוחלף מועתק תחילה. כך, אם הנתונים מועתקים מכתובות גבוהות יותר לכתובות נמוכות יותר, פעולת ההעתקה מתחילה בכתובת הנמוכה ביותר של בלוק המקור ומתקדמת לקראת הכתובת הגבוהה ביותר. מצד שני, אם נתונים מועתקים מכתובות נמוכות לכתובות גבוהות יותר, פעולת ההעתקה מתחילה בכתובת הגבוהה ביותר של בלוק המקור ומתקדמת לקראת הכתובת הנמוכה ביותר.

דוגמאות

כדי להעתיק את התוכן של הכתובת CS:110 לכתובת CS:510 ולאחר מכן להעתיק את התוכן של CS:10F ל- CS:50F וכך הלאה, עד שכל התוכן של CS:100 עד CS:500 יועתק, הקלד:

mcs:100 110 cs:500

להצגת התוצאות, באפשרותך להשתמש בפקודת המשנה d‏ (dump) ולציין את כתובת היעד בה השתמשת בפקודת המשנה m.


Debug: n (name)

גרפיקה של Microsoft Windows

Debug: n (name)‎

פקודה זו מציינת את השם של קובץ הפעלה עבור פקודת המשנה debug l‏ (Load) או w‏ (Write), או מציינת פרמטרים עבור קובץ ההפעלה בו מאותרים הבאגים. כאשר נעשה בה שימוש ללא פרמטרים, הפקודה n מנקה את הפרטים הקיימים.

תחביר

n [Path][executable]‎

n [FileParameters]‎

פרמטרים

[Path][executable]
קביעת המיקום והשם של קובץ ההפעלה שברצונך לבדוק.
[FileParameters]
פרמטר זה מציין את הפרמטרים ואפשרויות שורת הפקודה עבור קובץ ההפעלה שברצונך לבדוק.
?
פרמטר זה מציג רשימה של פקודות משנה של debug.

הערות

  • XOX
  • שימוש בפקודת המשנה n

    באפשרותך להשתמש בפקודת המשנה n בשתי דרכים. ראשית, באפשרותך להשתמש בפקודה זו כדי לציין קובץ בו ייעשה שימוש על-ידי פקודות משנה l‏ (load) או w‏ (write) מאוחר יותר. אם תפעיל את Debug.exe מבלי לתת שם לקובץ בו יבוצע איתור הבאגים, עליך להשתמש בפקודה n FileName לפני שתהיה אפשרות להשתמש בפקודה l לטעינת הקובץ. שם הקובץ מעוצב כראוי עבור בלוק בקרת קבצים (FCB) ב- CS:5C. שנית, באפשרותך להשתמש בפקודה n כדי לציין פרמטרים ואפשרויות שורת פקודה עבור הקובץ בו מתבצע איתור הבאגים.

  • אזורי זיכרון

    הטבלה שלהלן מפרטת את ארבעת אזורי הזיכרון שיכולים להיות מושפעים על-ידי הפקודה n.

    מיקום זיכרון | תוכן
    CS:5C | בלוק בקרת קובץ (FCB) עבור קובץ 1
    CS:6C | בלוק בקרת קובץ (FCB) עבור קובץ 2
    CS:80 | אורך שורת הפקודה n (בתווים)
    CS:81 | תחילת התווים של שורת הפקודה n

    שם הקובץ הראשון שתציין עבור הפקודה n ימוקם ב- FCB ב- CS:5C. אם תציין שם קובץ שני, שם זה ימוקם ב- FCB ב- CS:6C. מספר התווים שהוקלדו בשורת הפקודה n (מלבד התו הראשון, n) מאוחסנים במיקום CS:80. התווים הממשיים בשורת הפקודה n (שוב, מלבד האות n) מאוחסנים החל מהמיקום CS:81. שים לב שתווים אלה עשויים להיות כל אחת מאפשרויות שורת הפקודה והמפרידים שיהיו חוקיים בפקודה המוקלדת בשורת הפקודה.

  • לקבלת מידע אודות טעינת התוכן של קובץ או של סקטורים ספציפיים בדיסק לזיכרון באמצעות פקודת המשנה l‏ (Load), ראה נושאים קרובים.
  • לקבלת מידע נוסף אודות כתיבה לדיסק של הקובץ שברצונך לאתר בו באגים באמצעות פקודת המשנה w‏ (write), ראה נושאים קרובים.

דוגמאות

בדוגמה זו, הפעל את הפקודה debug וטען את התוכנית Prog.com לאיתור באגים. כדי לציין שני פרמטרים עבור Prog.com ולהפעיל את התוכנית, הקלד:

debug prog.com
nparam1 param2
g

במקרה זה, פקודת המשנה g‏ (go) מפעילה את הפקודה כאילו הקלדת את הפקודה הבאה בשורת הפקודה:

prog param1 param2

בדיקה ואיתור באגים משקפים סביבה טיפוסית של זמן ריצה עבור Prog.com.

ברצף הפקודות הבא, פקודת המשנה n הראשונה מציינת את File1.exe כקובץ עבור פקודת המשנה l‏ (load) הבאה לאחר מכן, הטוענת את File1.exe לזיכרון. פקודת המשנה n השנייה מציינת את הפרמטרים שישמשו את File1.exe. לבסוף, פקודת המשנה g‏ (go) מפעילה את File1.exe כאילו הקלדת File1 File2.dat File2.dat בשורת הפקודה.

nfile1.exe
l
nfile2.dat file3.dat
g

אל תשתמש בפקודת המשנה l לאחר המופע השני של פקודת המשנה n. אם תשתמש בפקודת המשנה w‏ (write) לאחר המופע השני של פקודת המשנה n‏, הקובץ File1.exe (כלומר הקובץ העובר איתור באגים) יישמר בשם File2.dat. כדי להימנע מכך, עליך להשתמש תמיד בצורה הראשונה של פקודת המשנה n מיד לפני פקודת המשנה l או w.


Debug: o (output)

גרפיקה של Microsoft Windows

Debug: o (output)‎

שליחת הערך של בית ליציאת פלט.

תחביר

o port byte-value

פרמטרים

port
פרמטר נדרש. פרמטר זה מציין את יציאת הפלט באמצעות כתובת. כתובת היציאה יכולה להיות ערך של 16 סיביות.
byte-value
פרמטר נדרש. פרמטר זה מציין את ערך הבית שברצונך להפנות ל- port.
?
פרמטר זה מציג רשימה של פקודות משנה של debug.

הערות

  • XOX
  • לקבלת מידע נוסף אודות קריאת הערך של בית מיציאת קלט באמצעות פקודת המשנה I‏ (input) ראה נושאים קרובים.

דוגמאות

כדי לשלוח את ערך הבית 4Fh ליציאת הפלט בכתובת 2F8h, הקלד:

o2f8 4f


Debug: p (proceed)

גרפיקה של Microsoft Windows

Debug: p (proceed)‎

פקודה זו מבצעת לולאה, הוראת מחרוזת חוזרת, פסיקת תוכנה או רוטינת משנה. לחלופין, פקודה זו עוקבת אחר כל הוראה אחרת. כאשר נעשה בה שימוש ללא פרמטרים, הפקודה p מציגה את האוגרים ואת ערכיהם הנוכחיים.

תחביר

p [=address] [number]‎

פרמטרים

address
קביעת המיקום של ההוראה הראשונה שיש לבצע. אם לא תציין כתובת, כתובת ברירת המחדל היא הכתובת הנוכחית שצוינה ברישומים CS:IP.
number
פרמטר זה מציין את מספר ההוראות לביצוע לפני החזרת השליטה לפקודה Debug.exe. ערך ברירת המחדל הוא 1.
?
פרמטר זה מציג רשימה של פקודות משנה של debug.

הערות

  • XOX
  • ציון ערכי address חוקיים

    הפרמטר address הוא רישום בעל שני חלקים, המכיל אוגר יחידה אלפביתי או כתובת יחידה ארבע-ספרתית הכוללת ערך היסט. באפשרותך להשמיט את אוגר היחידה או את כתובת היחידה. CS הוא יחידת ברירת המחדל עבור פקודות המשנה הבאות של debug‏: a‏, g‏, l‏, t‏, u‏ ו- w‏. DS‏ הוא יחידת ברירת המחדל עבור כל שאר פקודות המשנה. כל הערכים הנומריים הם בתבנית הקסדצימאלית. עליך לכלול נקודתיים בין שם היחידה לבין ערך ההיסט. להלן כתובות חוקיות:

    CS:0100

    04BA:0100

  • שימוש בפרמטר address

    אם הפרמטר address אינו מציין יחידה, Debug.exe משתמשת באוגר CS של התוכנית הנבדקת. אם תשמיט את הפרמטר address, התוכנית תבוצע החל מהכתובת שצוינה על-ידי אוגרי CS:IP שלה. עליך להקליד סימן שוויון (=) לפני הפרמטר address כדי להבדיל בינו לבין הפרמטר number. אם ההוראה בכתובת שצוינה אינה לולאה, הוראת מחרוזת חוזרת, פסיקת תוכנה או רוטינת משנה, פקודת המשנה p תפעל באותו אופן כמו פקודת המשנה t‏ (trace).

  • העברת השליטה לתוכנית הנבדקת

    כאשר פקודת המשנה p מעבירה את השליטה מ- Debug.exe לתוכנית הנבדקת, תוכנית זו פועלת ללא הפרעות עד להשלמת הלולאה, הוראת המחרוזת החוזרת, פסיקת התוכנה או רוטינת המשנה בכתובת שצוינה או עד שהסתיים הביצוע של מספר הוראות המכונה שצוינו. לאחר מכן השליטה חוזרת ל- Debug.exe.

  • צפייה בהודעות

    לאחר הפעלת הפקודה p, ‏Debug.exe מציגה את התוכן של אוגרי התוכנית, את מצב הדגלים שלה ואת הצורה המפוענחת של ההוראה הבאה שתבוצע.

    אזהרה

    • אין באפשרותך להשתמש בפקודת המשנה p כדי לבצע מעקב בתוך זיכרון לקריאה בלבד (ROM).
  • לקבלת מידע נוסף אודות הפעלת התוכנית הנוכחית הנמצאת בזיכרון באמצעות פקודת המשנה g‏ (go), ראה נושאים קרובים.
  • לקבלת מידע נוסף אודות הפעלת הוראה אחת באמצעות פקודת המשנה t‏ (trace), ראה נושאים קרובים.

דוגמאות

בדוגמה זו, התוכנית הנבדקת מכילה הוראת פקודת call בכתובת CS:143F. כדי להפעיל את רוטינת המשנה המשמשת כיעד של call ולאחר מכן להחזיר את השליטה ל- Debug.exe, הקלד:

p=143f

Debug.exe מציגה את התוצאות בתבנית הבאה:

AX=0000 BX=0000 CX=0000 DX=0000 SP=FFEE BP=0000 SI=0000 DI=0000
DS=2246 ES=2246 SS=2246 CS=2246 IP=1443 NV UP EI PL NZ AC PO NC
2246:1442 7505 JNZ 144A


Debug: q (quit)

גרפיקה של Microsoft Windows

Debug: q (quit)‎

פקודה זו מפסיקה את הפעלת Debug.exe מבלי לשמור את הקובץ הנבדק באותו זמן, וחוזרת לשורת הפקודה.

תחביר

q

פרמטרים

?
פרמטר זה מציג רשימה של פקודות משנה של debug.

הערות

  • XOX


Debug: r (register)

גרפיקה של Microsoft Windows

Debug: r (register)‎

פקודה זו מציגה או משנה את התוכן של אוגר CPU אחד או יותר. כאשר נעשה בה שימוש ללא פרמטרים, הפקודה r מציגה את התוכן של כל האוגרים והדגלים באזור אחסון האוגרים, את מצבם של כל הדגלים ואת הצורה המפוענחת של ההוראה במיקום הנוכחי.

תחביר

r [Register]‎

פרמטרים

Register
פרמטר זה מציין את השם של האוגר שאת תוכנו ברצונך להציג.
?
פרמטר זה מציג רשימה של פקודות משנה של debug.

הערות

  • XOX
  • שימוש בפקודת המשנה r

    אם תציין אוגר, Debug.exe תציג את הערך שגודל 16 סיביות של אוגר זה בייצוג הקסדצימאלי ותציג נקודתיים בתור שורת הפקודה. אם ברצונך לשנות את הערך המוכל באוגר, הקלד ערך חדש והקש ENTER. אחרת, הקש ENTER כדי לחזור לשורת הפקודה של debug.

  • אוגרי x86 חוקיים

    הטבלה שלהלן מציגה אוגרי x86 חוקיים עבור הפרמטר Register.

    ערך
    ax
    bp
    bx
    cs
    cx
    di
    ds
    dx
    es
    f
    ip
    pc
    si
    sp
    ss

    אם תציין שם אוגר שונה מאחד השמות המופיעים ברשימה לעיל, Debug.exe תציג את ההודעה הבאה:

    br error

  • שימוש ב- f במקום אוגר

    אם תקליד f במקום שם אוגר, Debug.exe תציג את ההגדרה הנוכחית של כל דגל כקוד בעל שתי אותיות ולאחר מכן תציג את שורת הפקודה debug. כדי לשנות את ההגדרה של דגל, הקלד את הקוד המתאים בעל שתי האותיות מתוך הטבלה הבאה :

    שם הדגל | הגדרה | ניקוי
    Overflow | ov | nv
    Direction | dn (decrement)‎ | up (increment)‎
    Interrupt | ei (enabled)‎ | di (disabled)‎
    Sign | ng (negative)‎ | pl (positive)‎
    Zero | zr | nz
    Auxiliary Carry | ac | na
    Parity | pe (even)‎ | po (odd)‎
    Carry | cy | nc

    באפשרותך להקליד ערכי דגלים חדשים בכל סדר. אין צורך להשאיר רווחים בין ערכים אלה. כדי להפסיק את פעולת פקודת המשנה r, הקש ENTER. דגלים שעבורם לא צוינו ערכים חדשים יישארו ללא שינוי.

  • הודעות המוצגות עם פקודת המשנה r

    אם תציין יותר מערך אחד עבור דגל, Debug.exe תציג את ההודעה הבאה:

    df error

    אם תציין קוד דגל שאינו מפורט בטבלה לעיל, Debug.exe תציג את ההודעה הבאה:

    bf error

    בשני המקרים, Debug.exe מתעלמת מכל ההגדרות שצוינו לאחר הערך הלא חוקי.

  • הגדרות ברירת המחדל של Debug.exe

    כאשר אתה מפעיל את Debug.exe, אוגרי היחידה מוגדרים לתחתית הזיכרון הפנוי, מצביע ההוראה מוגדר ל- 0100h, מתבצע ניקוי של כל הדגלים ושאר האוגרים מוגדרים לאפס, מלבד sp המוגדר ל- FFEEh.

  • לקבלת מידע נוסף אודות הצגת התוכן של חלק של זיכרון באמצעות פקודת המשנה d, ראה נושאים קרובים.
  • לקבלת מידע נוסף אודות פירוק בתים באמצעות פקודת המשנה u, ראה נושאים קרובים.

דוגמאות

אם המיקום הנוכחי הוא CS:11A, התצוגה תהיה דומה לתצוגה הבאה:

AX=0E00 BX=00FF CX=0007 DX=01FF SP=039D BP=0000 SI=005C DI=0000
DS=04BA ES=04BA SS=04BA CS=O4BA IP=011A NV UP DI NG NZ AC PE NC
04BA:011A CD21 INT 21

כדי לראות את מצבם של הדגלים בלבד, הקלד:

rf

Debug.exe מציגה את המידע באופן הבא:

NV UP DI NG NZ AC PE NC‎ - _‎

הקלד ערך דגל חוקי אחד או יותר בכל סדר, עם או ללא רווחים. לדוגמה:

nv up di ng nz ac pe nc - pleicy

Debug.exe עוצרת את פעולתה של פקודת המשנה r ומציגה את שורת הפקודה debug. כדי לראות את השינויים, הקלד r או rf‏. Debug.exe מציגה את הפלט הבא:

NV UP EI PL NZ AC PE CY - _‎

הקש ENTER כדי לחזור לשורת הפקודה debug.


Debug: s (search)

גרפיקה של Microsoft Windows

Debug: s (search)‎

חיפוש בטווח של כתובות אחר תבנית של ערך בית אחד או יותר.

תחביר

s range list

פרמטרים

range
פרמטר נדרש. פרמטר זה מציין את כתובות ההתחלה והסיום של הטווח בו ברצונך לבצע את החיפוש.
list
פרמטר נדרש. פרמטר זה מציין את התבנית של ערך בית אחד או יותר או של המחרוזת שברצונך לחפש.
?
פרמטר זה מציג רשימה של פקודות משנה של debug.

הערות

  • XOX
  • ציון ערכי range חוקיים

    השתמש בפרמטר range עם פקודת משנה של debug כדי לציין טווח זיכרון. באפשרותך לבחור אחת משתי תבניות עבור range: כתובת התחלה וכתובת סיום או כתובת התחלה והאורך (מצוין על-ידי l) של הטווח. לדוגמה, שני התחבירים הבאים מציינים טווח של 16 בתים המתחיל ב- CS:100:

    cs:100 10f

    cs:100 l 10

  • שימוש בפרמטר list

    בעת השימוש בפרמטר list, הפרד כל ערך בית עם רווח או פסיק והקף את ערכי המחרוזת במרכאות (כלומר "string"). אם הפרמטר list מכיל יותר מערך בית אחד, Debug.exe מציגה רק את הכתובת הראשונה בה מופיע ערך הבית. אם הפרמטר list מכיל ערך בית אחד בלבד, Debug.exe מציגה את כל הכתובות בהן מופיע הערך בטווח שצוין.

דוגמאות

כדי למצוא את כל הכתובות בטווח של CS:100 עד CS:110 המכילות את הערך 41, הקלד:

scs:100 110 41

Debug.exe מציגה את התוצאות באופן הבא:

04BA:0104
04BA:010D
-

כדי לחפש אחר המחרוזת "Ph" בטווח של CS:100 עד CS:1A0, הקלד:

scs:100 1a0 "Ph"‎


פקודות משנה של Debug

לקבלת מידע נוסף, לחץ על פקודה:

  • Debug: a (assemble)‎
  • Debug: c (compare)‎
  • Debug: d (dump)‎
  • Debug: e (enter)‎
  • Debug: f (fill)‎
  • Debug: g (go)‎
  • Debug: h (hexadecimal)‎
  • Debug: i (input)‎
  • Debug: l (load)‎
  • Debug: m (move)‎
  • Debug: n (name)‎
  • Debug: o (output)‎
  • Debug: p (Proceed)‎
  • Debug: q (quit)‎
  • Debug: r (register)‎
  • Debug: s (search)‎
  • Debug: t (trace)‎
  • Debug: u (unassemble)‎
  • Debug: w (write)‎
  • Debug: xa (allocate expanded memory)‎
  • Debug: xd (deallocate expanded memory)‎
  • Debug: xm (map expanded memory pages)‎
  • Debug: xs (display expanded memory status)‎


Debug: t (trace)

גרפיקה של Microsoft Windows

Debug: t (trace)‎

פקודה זו מוציאה לפועל הוראה אחת ומציגה את התוכן של כל האוגרים, את מצבם של כל הדגלים ואת הצורה המפוענחת של ההוראה שבוצעה. כאשר נעשה בה שימוש ללא פרמטרים, הפקודה t מתחילה לעקוב אחר הכתובת שצוינה על-ידי האוגרים CS:IP של התוכנית שלך.

תחביר

t [=address] [number]‎

פרמטרים

address
פרמטר זה מציין את הכתובת בה ברצונך ש- Debug.exe תתחיל לעקוב אחר הוראות.
number
קביעת מספר ההוראות שיש לעקוב אחריהן. על ערך זה להיות מספר הקסדצימאלי. ערך ברירת המחדל הוא 1.
?
פרמטר זה מציג רשימה של פקודות משנה של debug.

הערות

  • XOX
  • ציון ערכי address חוקיים

    הפרמטר address הוא רישום בעל שני חלקים, המכיל אוגר יחידה אלפביתי או כתובת יחידה ארבע-ספרתית הכוללת ערך היסט. באפשרותך להשמיט את אוגר היחידה או את כתובת היחידה. CS הוא יחידת ברירת המחדל עבור פקודות המשנה הבאות של debug‏: a‏, g‏, l‏, t‏, u‏ ו- w‏. DS‏ הוא יחידת ברירת המחדל עבור כל שאר פקודות המשנה. כל הערכים הנומריים הם בתבנית הקסדצימאלית. עליך לכלול נקודתיים בין שם היחידה לבין ערך ההיסט. להלן כתובות חוקיות:

    CS:0100

    04BA:0100

  • מעקב אחר הוראות בזיכרון לקריאה בלבד

    פקודת המשנה t משתמשת במצב המעקב של חומרת מיקרו-מעבד מסוג 8086 או 8088. לפיכך, באפשרותך לבצע מעקב גם אחר הוראות המאוחסנות בזיכרון לקריאה בלבד (ROM).

  • לקבלת מידע נוסף אודות ביצוע לולאה, הוראת מחרוזת חוזרת, פסיקת תוכנה או רוטינת משנה באמצעות פקודת המשנה p‏ (proceed), ראה נושאים קרובים.
  • לקבלת מידע נוסף אודות הפעלת התוכנית הנוכחית הנמצאת בזיכרון באמצעות פקודת המשנה g‏ (go), ראה נושאים קרובים.

דוגמאות

אם המיקום של ההוראה בתוכנית הוא 04BA:011A‏, Debug.exe מציגה את המידע הבא:

AX=0E00 BX=00FF CX=0007 DX=01FF SP=039D BP=0000 SI=005C DI=0000
DS=04BA ES=04BA SS=04BA CS=O4BA IP=011A NV UP DI NG NZ AC PE NC
04BA:011A CD21 INT 21


Debug: u (unassemble)

גרפיקה של Microsoft Windows

Debug: u (unassemble)‎

פקודה זו מפרקת בתים ומציגה את משפטי המקור המתאימים שלהם, כולל כתובות וערכי בתים. הקוד המפורק נראה כמו פירוט עבור קובץ מורכב. כאשר נעשה בה שימוש ללא פרמטרים, הפקודה u מפרקת 20h בתים (מספר ברירת המחדל), החל מהכתובת הראשונה לאחר הכתובת שהוצגה על-ידי פקודת u הקודמת.

תחביר

u [range]‎

פרמטרים

range
קביעת כתובות ההתחלה והסיום או קביעה של כתובת ההתחלה והאורך של הקוד שברצונך לפרק לחלקים.
?
פרמטר זה מציג רשימה של פקודות משנה של debug.

הערות

  • XOX
  • ציון ערכי range חוקיים

    השתמש בפרמטר range עם פקודת משנה של debug כדי לציין טווח זיכרון. באפשרותך לבחור אחת משתי תבניות עבור range: כתובת התחלה וכתובת סיום או כתובת התחלה והאורך (מצוין על-ידי l) של הטווח. לדוגמה, שני התחבירים הבאים מציינים טווח של 16 בתים המתחיל ב- CS:100:

    cs:100 10f

    cs:100 l 10

  • לקבלת מידע נוסף אודות הרכבת קיצורים באמצעות פקודת המשנה a‏ (assemble), ראה נושאים קרובים.
  • לקבלת מידע נוסף אודות הצגת התוכן של חלק זיכרון באמצעות פקודת המשנה d‏ (dump), ראה נושאים קרובים.

דוגמאות

כדי לפרק 16 (10h) בתים, החל מכתובת 04BA:0100, הקלד:

u04ba:100l10

Debug.exe מציגה את התוצאות בתבנית הבאה:

04BA:0100 206472 AND [SI+72],AH
04BA:0103 69 DB 69
04BA:0104 7665 JBE 016B
04BA:0106 207370 AND [BP+DI+70],DH
04BA:0109 65 DB 65
04BA:010A 63 DB 63
04BA:010B 69 DB 69
04BA:010C 66 DB 66
04BA:010D 69 DB 69
04BA:010E 63 DB 63
04BA:010F 61 DB 61

כדי להציג את המידע עבור הכתובות הספציפיות 04BA:0100 עד 04BA:0108 בלבד, הקלד:

u04ba:0100 0108

Debug.exe מציגה את הפלט הבא:

04BA:0100 206472 AND [SI+72],AH
04BA:0103 69 DB 69
04BA:0104 7665 JBE 016B
04BA:0106 207370 AND [BP+DI+70],DH


Debug: w (write)

גרפיקה של Microsoft Windows

Debug: w (write)‎

פקודה זו כותבת קובץ או סקטורים ספציפיים לדיסק. כאשר משתמשים בה ללא פרמטרים, הפקודה w מתחילה מ- CS:100.

תחביר

w [address]‎

w [address] [Drive] [firstsector] [number]‎

פרמטרים

address
קביעת ההתחלה של כתובת הזיכרון של הקובץ, או חלק מהקובץ שברצונך לכתוב לקובץ דיסק.
Drive
קביעת הכונן המכיל את דיסק היעד. ערך זה מספרי: 0 = A,‏ 1 = B‏, 2 = C וכן הלאה.
firstsector
קביעת המספר ההקסדצימאלי של הסקטור הראשון אליו ברצונך לכתוב.
number
קביעת מספר הסקטורים אליהם ברצונך לכתוב.
?
קובץ זה מציג רשימה של פקודות משנה של debug.

הערות

  • XOX
  • כדי לכתוב את התוכן של מספר הבתים שצוינו ברישומים BX:CX לקובץ דיסק, השתמש בתחביר הבא:

    w [address]‎

  • כדי לעקוף את מערכת הקבצים ולכתוב ישירות לסקטורים ספציפיים, השתמש בתחביר הבא:

    w [address] [Drive] [firstsector] [number]‎

  • ציון ערכי address חוקיים

    הפרמטר address הוא רישום בעל שני חלקים, המכיל אוגר יחידה אלפביתי או כתובת יחידה ארבע-ספרתית הכוללת ערך היסט. באפשרותך להשמיט את אוגר היחידה או את כתובת היחידה. CS הוא יחידת ברירת המחדל עבור פקודות המשנה הבאות של debug‏: a‏, g‏, l‏, t‏, u‏ ו- w‏. DS‏ הוא יחידת ברירת המחדל עבור כל שאר פקודות המשנה. כל הערכים הנומריים הם בתבנית הקסדצימאלית. עליך לכלול נקודתיים בין שם היחידה לבין ערך ההיסט. להלן כתובות חוקיות:

    CS:0100

    04BA:0100

  • ציון שם קובץ הדיסק. עליך לציין את שם קובץ הדיסק בעת הפעלת Debug.exe או בפקודת המשנה n ‏ (name) האחרונה. שתי שיטות אלה מעצבות כראוי שם קובץ עבור בלוק בקרת קבצים בכתובת CS:5C.
  • איפוס BX:CX לפני שימוש בפקודה w ללא פרמטרים

    אם השתמשת בפקודות g ‏(go)‏, t ‏(trace)‏, p ‏(proceed) או r ‏(register)‏, עליך לאפס את האוגרים BX:CX לפני שימוש בפקודת המשנה w ללא פרמטרים.

  • כתיבת קובץ ששונה לדיסק

    אם תשנה את הקובץ אך לא תשנה את השם, האורך או כתובת ההתחלה, ל- Debug.exe תהיה אפשרות לכתוב כראוי את הקובץ למיקום המקורי בדיסק.

  • כתיבת קבצי ‎.exe או ‎.hex

    אין באפשרותך לכתוב קובץ מסוג ‎.exe או ‎.hex באמצעות פקודה זו.

    אזהרה

    • כתיבה לסקטורים ספציפיים היא מסוכנת ביותר כיוון שפעולה זו עוקפת את המטפל בקבצים של Windows XP. מבנה הקבצים של הדיסק עשוי להיפגם בקלות אם תקליד את הערכים הלא נכונים.
  • לקבלת מידע נוסף אודות ציון קובץ באמצעות פקודת המשנה n‏ (name), ראה נושאים קרובים.
  • לקבלת מידע נוסף אודות טעינת התוכן של קובץ או סקטורים של קובץ לזיכרון באמצעות פקודת המשנה l‏ (load), ראה נושאים קרובים.

דוגמאות

כדי לכתוב את התוכן של זיכרון, החל מהכתובת CS:100, לדיסק בכונן B, להתחיל באיסוף נתונים מהסקטור הלוגי מספר 37h של הדיסק ולהמשיך לאורך 2Bh סקטורים, הקלד:

wcs:100 1 37 2b

כאשר פעולת הכתיבה הושלמה, Debug.exe מציגה שוב את שורת הפקודה של debug.


Debug: xa (allocate expanded memory)

גרפיקה של Microsoft Windows

Debug: xa (allocate expanded memory)‎

פקודה זו מקצה את מספר עמודי הזיכרון המורחב שצוין. כאשר נעשה בה שימוש ללא פרמטרים, הפקודה xa מחפשת אחר נוכחות או היעדרות של תמיכה בזיכרון מורחב (EMS).

תחביר

xa [count]‎

פרמטרים

count
ציון מספר העמודים בגודל 16 קילו-בתים של זיכרון מורחב שיש להקצות.
?
פרמטר זה מציג רשימה של פקודות משנה של debug.

הערות

  • XOX
  • Windows XP אינו תומך בזיכרון מורחב (EMS). כדי להשתמש בזיכרון מורחב, עליך להתקין מנהל התקן של זיכרון מורחב התואם לגירסה 4.0 של Lotus/Intel/Microsoft Expanded Memory Specification‏ (LIM EMS).
  • אם מספר העמודים שצוין זמין, Debug.exe תציג הודעה המציינת את המספר ההקסדצימאלי של המזהה הייחודי שנוצר; אם לא, Debug.exe תציג הודעת שגיאה.

דוגמאות

כדי להקצות שמונה דפים של זיכרון מורחב, הקלד:

xa8

אם הפקודה בוצעה בהצלחה, Debug.exe תציג הודעה הדומה להודעה הבאה:

Handle created=0003


Debug: xd (deallocate expanded memory)

גרפיקה של Microsoft Windows

Debug: xd (deallocate expanded memory)‎

פקודה זו מבטלת הקצאה של מזהה ייחודי לזיכרון מורחב. כאשר נעשה בה שימוש ללא פרמטרים, הפקודה xd מחפשת אחר נוכחות או היעדרות של תמיכה בזיכרון מורחב (EMS).

תחביר

xd [handle]‎

פרמטרים

handle
קביעת המזהה הייחודי שברצונך לבטל את הקצאתו.
?
פרמטר זה מציג רשימה של פקודות משנה של debug.

הערות

  • XOX
  • Windows XP אינו תומך בזיכרון מורחב (EMS). כדי להשתמש בזיכרון מורחב, עליך להתקין מנהל התקן של זיכרון מורחב התואם לגירסה 4.0 של Lotus/Intel/Microsoft Expanded Memory Specification‏ (LIM EMS).

דוגמאות

כדי לבטל הקצאה של המזהה הייחודי 0003, הקלד:

xd 0003

אם הפקודה הושלמה בהצלחה, Debug.exe תציג את ההודעה הבאה:

Handle 0003 deallocated


Debug: xm (map expanded memory pages)

גרפיקה של Microsoft Windows

Debug: xm (map expanded memory pages)‎

פקודה זו ממפה עמוד לוגי של זיכרון מורחב, השייך למזהה הייחודי שצוין, לעמוד פיזי של זיכרון מורחב. כאשר נעשה בה שימוש ללא פרמטרים, הפקודה xm מחפשת אחר נוכחות או היעדרות של תמיכה בזיכרון מורחב (EMS).

תחביר

xm [lpage] [ppage] [handle]‎

פרמטרים

lpage
קביעת המספר של העמוד הלוגי של זיכרון EMS שברצונך למפות לעמוד הפיזי ppage.
ppage
קביעת המספר של העמוד הפיזי אליו יש למפות את lpage.
handle
קביעת המזהה הייחודי.
?
פרמטר זה מציג רשימה של פקודות משנה של debug.

הערות

  • XOX
  • Windows XP אינו תומך בזיכרון מורחב (EMS). כדי להשתמש בזיכרון מורחב, עליך להתקין מנהל התקן של זיכרון מורחב התואם לגירסה 4.0 של Lotus/Intel/Microsoft Expanded Memory Specification‏ (LIM EMS).

דוגמאות

כדי למפות עמוד לוגי 5 של המזהה הייחודי 0003 לעמוד הפיזי 2, הקלד:

xm 5 2 0003

אם הפקודה הושלמה בהצלחה, Debug.exe תציג את ההודעה הבאה:

Logical page 05 mapped to physical page 02


Debug: xs (display expanded memory status)

גרפיקה של Microsoft Windows

Debug: xs (display expanded memory status)‎

הצגת מידע אודות המצב של זיכרון EMS.

תחביר

xs

פרמטרים

?
פרמטר זה מציג רשימה של פקודות משנה של debug.

הערות

  • XOX
  • כדי להשתמש בזיכרון מורחב, עליך להתקין מנהל התקן של זיכרון מורחב התואם לגירסה 4.0 של Lotus/Intel/Microsoft Expanded Memory Specification‏ (LIM EMS).
  • הפקודה Debug.exe מציגה מידע באופן הבא:

    Handle xx has xx pages allocated
    Physical page xx = Frame segment xx
    xx of a total xx EMS pages have been allocated
    xx of a total xx EMS handles have been allocated

דוגמאות

כדי להציג מידע אודות הזיכרון המורחב, הקלד:

xs

פקודת המשנה xs מציגה מידע בדומה לדוגמה שלהלן:

    Handle 0000 has 0000 pages allocated
    Handle 0001 has 0002 pages allocated

    Physical page 00 = Frame segment C000
    Physical page 01 = Frame segment C400
    Physical page 02 = Frame segment C800
    Physical page 03 = Frame segment CC00
       2 of a total 80 EMS pages have been allocated
       2 of a total FF EMS handles have been allocated


Defrag

פקודה זו מאתרת ומאחה תיקיות, קבצי אתחול וקבצי נתונים מפוצלים באמצעי אחסון.

תחביר

defrag volume

defrag volume [/a]‎

defrag volume [/a] [/v]‎

defrag volume [/v]‎

defrag volume [/f]‎

פרמטרים

volume
אות הכונן או נקודת הטעינה של אמצעי האחסון שיעבור איחוי.
‎/a
פרמטר זה מנתח את אמצעי האחסון ומציג סיכום של דו"ח הניתוח.
‎/v
פרמטר זה מציג את הניתוח השלם ואת דו"חות האיחוי.

כאשר נעשה שימוש בפרמטר זה יחד עם הפרמטר ‎/a, יוצג רק דו"ח הניתוח. כאשר נעשה שימוש בפרמטר זה לבדו, יוצגו הן דו"ח הניתוח והן דו"ח האיחוי.

‎/f
פרמטר זה אוכף את איחוי אמצעי האחסון גם אם אין צורך באיחוי.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • על אמצעי אחסון להיות בעל לפחות 15% של שטח פנוי כדי שהפקודה defrag תאחה את אמצעי האחסון באופן מלא וכראוי. הפקודה defrag משתמשת בשטח זה כאזור מיון עבור חלקי קבצים. אם קיימים באמצעי אחסון פחות מ- 15% של שטח פנוי, הפקודה defrag תאחה אותו באופן חלקי בלבד. להגדלת השטח הפנוי באמצעי אחסון, מחק קבצים שאינם נחוצים או העבר אותם לדיסק אחר.
  • אין באפשרותך לאחות אמצעי אחסון שסומנו על ידי מערכת הקבצים כמלוכלכים, כלומר שעשויים להיות פגומים. עליך להפעיל את הפקודה chkdsk באמצעי אחסון מלוכלך לפני שתוכל לאחות אותו. באפשרותך לקבוע אם אמצעי אחסון הוא מלוכלך באמצעות הפקודה fsutil dirty query. לקבלת מידע נוסף אודות הפקודות chkdsk ו- fsutil dirty, ראה נושאים קרובים.
  • כאשר defrag מנתח ומאחה אמצעי אחסון, הוא מציג סמן מהבהב. לאחר השלמת הניתוח והאיחוי של אמצעי האחסון, מציג defrag את דו"ח הניתוח, את דו"ח האיחוי, או את שני הדו"חות ולאחר מכן מבצע יציאה אל שורת הפקודה.
  • כברירת מחדל, מציג defrag סיכום הן של דו"ח הניתוח והן של דו"ח האיחוי, אם אינך מציין את הפרמטרים ‎/a או ‎/v.
  • באפשרותך לשלוח את הדו"חות לקובץ טקסט על-ידי הקלדת ‎>filename.txt, כאשר filename.txt הוא שם קובץ שאתה מציין. לדוגמה:

    • defrag volume /v >filename.txt

  • כדי להפסיק את תהליך האיחוי, בשורת הפקודה, לחץ על CTRL+C.
  • הפקודה defrag ומאחה הדיסק מבצעים את אותה פעולה ואין אפשרות להפעיל את שניהם במקביל. אם תשתמש במאחה הדיסק כדי לאחות אמצעי אחסון ותפעיל את הפקודה defrag בשורת פקודה, הפקודה defrag תיכשל. ולהפך, אם תפעיל את הפקודה defrag ולאחר מכן תפתח את מאחה הדיסק, אפשרויות האיחוי במאחה הדיסק לא יהיו זמינות.


Del (erase)

גרפיקה של Microsoft Windows

Del (erase)‎

מחיקת הקבצים שצוינו.

תחביר

del [Drive:]‎[Path] FileName [ ...]‎ [‎/p] [‎/f] [‎/s] [‎/q] ‎[/a[:attributes]]‎

erase [Drive:]‎[Path] FileName [ ...]‎ [‎/p] [‎/f] [‎/s] [‎/q] ‎[/a[:attributes]]‎

פרמטרים

‎[Drive:][Path] FileName
פרמטר זה מציין את המיקום והשם של הקובץ או ערכת הקבצים שברצונך למחוק. הפרמטר Filename הוא פרמטר נדרש. באפשרותך להשתמש בשמות קבצים מרובים. הפרד בין שמות הקבצים באמצעות רווחים, פסיקים או תווי נקודה-פסיק.
‎/p
הצגת בקשה לאישור לפני מחיקת הקובץ שצוין.
‎/f
אכיפת מחיקה של קבצים לקריאה בלבד.
‎/s
מחיקת הקבצים שצוינו מהספריה הנוכחית ומכל ספריות המשנה. הצגת השם של כל קובץ בעת מחיקתו.
‎/q
פרמטר זה מציין מצב שקט. אינך נדרש לאשר מחיקות.
‎/a
מחיקת קבצים בהתאם לתכונות שצוינו.
attributes
פרמטר זה מציין אחת או יותר מתכונות הקובץ הבאות:
תכונה | תיאור
r | קריאה בלבד
a | ארכיון
s | מערכת
h | מוסתר
- | תחילית שפירושה "אל תבצע"
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • שימוש בפרמטר ‎/p

    אם תשתמש בפרמטר ‎/p, הפקודה del תציג שם קובץ ותשלח את ההודעה הבאה:

    filename, Delete (Y/N)?‎

    הקש Y לאישור המחיקה, N לביטול המחיקה והצגת שם הקובץ הבא (אם ציינת קבוצה של קבצים) או CTRL+C להפסקת הפעולה של הפקודה del.

  • הפיכת הרחבות פקודה לבלתי זמינות

    בעת הפיכת הרחבות פקודה לבלתי זמינות, אפשרות שורת הפקודה ‎/s תציג את שמותיהם של כל הקבצים שלא נמצאו, במקום להציג את שמות הקבצים העוברים מחיקה (כלומר ההתנהגות הפוכה). לקבלת מידע נוסף אודות הפיכת הרחבות פקודה לבלתי זמינות, ראה cmd בנושאים קרובים.

  • מחיקה של יותר מקובץ אחד בו-זמנית

    באפשרותך למחוק את כל הקבצים בתיקיה על-ידי הקלדת הפקודה del ולאחריה ‎[Drive:]Path. לדוגמה, הפקודה שלהלן מוחקת את כל הקבצים בתיקיה ‎\Work :

    del \work

    בנוסף, באפשרותך להשתמש בתווים כלליים (כלומר, * ו- ?) כדי למחוק יותר מקובץ אחד בו-זמנית. עם זאת, עליך להשתמש בתווים כלליים בזהירות עם הפקודה del כדי למנוע מחיקת קבצים בטעות. לדוגמה, נניח שהקלדת את הפקודה הבאה:

    del *.*‎

    הפקודה del מציגה את הבקשה הבאה:

    All files in directory will be deleted! Are you sure (Y/N)?‎

    הקש Y ולאחר מכן ENTER כדי למחוק את כל הקבצים בספריה הנוכחית או הקש N ולאחר מכן ENTER כדי לבטל את המחיקה.

    לפני שימוש בתווים כלליים עם הפקודה del למחיקת קבוצה של קבצים, באפשרותך להשתמש באותם תווים כלליים עם הפקודה dir כדי לראות רשימה של השמות של כל הקבצים הכלולים בקבוצה.

    אזהרה

    • לאחר מחיקתו של קובץ מהדיסק באמצעות del, לא ניתן לאחזרו.
  • הפקודה del, עם פרמטרים אחרים, זמינה מתוך מסוף השחזור.

דוגמאות

כדי למחוק את כל הקבצים בתיקיה בשם Test בכונן C:‎\‎, הקלד אחת מן הפקודות הבאות:

del c:\test

del c:\test\*.*‎


Device

פקודה זו טוענת את מנהל ההתקן שציינת לזיכרון.

תחביר

device=[Drive:][Path] FileName ‎[dd-parameters]‎

פרמטרים

‎[Drive:][Path] FileName
פרמטר זה מציין את המיקום והשם של מנהל ההתקן שברצונך לטעון. הפרמטר Filename הוא פרמטר נדרש.
[dd-parameters]
פרמטר זה מציין את המידע של שורת הפקודה הדרוש למנהל ההתקן.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • השתמש בקובץ systemroot\System32\Config.nt או בקובץ ההפעלה המקביל המצוין בקובץ המידע של התוכנית (PIF) כדי לטעון מנהלי התקנים עבור מערכת המשנה MS-DOS .

דוגמאות

כדי להשתמש ברצף יציאה ANSI לשליטה במסך ובמקלדת עבור מערכת המשנה MS-DOS, הקלד את הפקודה הבאה בקובץ Config.nt או בקובץ ההפעלה המקביל לו:

device=c:\winnt\system32\ansi.sys


Devicehigh

פקודה זו טוענת מנהלי התקנים לאזור הזיכרון הגבוה. פעולה זו מפנה בתים נוספים של זיכרון רגיל עבור תוכניות אחרות. השתמש בקובץ systemroot\System32‎\Config.nt או בקובץ ההפעלה המקביל המצוין בקובץ המידע של התוכנית (PIF) כדי לטעון מנהלי התקנים עבור מערכת המשנה MS-DOS.

תחביר

devicehigh=[Drive:][Path] FileName ‎[dd-parameters]‎

devicehigh size=hexsize [Drive:][Path] FileName [dd-parameters]‎

פרמטרים

‎[Drive:][Path] FileName
פרמטר זה קובע את המיקום והשם של מנהל ההתקן שברצונך לטעון לאזור הזיכרון הגבוה. Filename הוא פרמטר נדרש.
dd-parameters
פרמטר זה מציין את מידע שורת הפקודה הדרוש למנהל ההתקן.
hexsize
פרמטר זה מציין את כמות הזיכרון המינימלית (כלומר, מספר הבתים, בתבנית הקסדצימאלית) שיש לוודא כי היא זמינה לפני שהפקודה devicehigh תנסה לטעון מנהל התקן לאזור הזיכרון הגבוה. עליך להשתמש ב- size וגם ב- hexsize, כפי שמוצג בשורת התחביר השנייה.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • שימוש בפרמטר dos=umb

    כדי להשתמש בפקודה devicehigh, עליך לכלול גם את הפרמטר dos=umb בקובץ Config.nt או בקובץ ההפעלה המקביל. אם לא תציין את הפרמטר dos=umb, כל מנהלי ההתקנים ייטענו לזיכרון רגיל, כאילו השתמשת בפקודה device. לקבלת מידע נוסף אודות dos=umb, ראה נושאים קרובים.

  • התקנת Himem.sys

    לפני שתהיה אפשרות לטעון מנהל התקן לאזור הזיכרון הגבוה, עליך להשתמש בפקודה device כדי להתקין את מנהל ההתקנים Himem.sys. על הפקודה device להופיע לפני כל פקודת devicehigh בקובץ Config.nt או בקובץ ההפעלה המקביל.

  • קביעה של הגבלת גודל

    אם מנהל ההתקנים שציינת ינסה להקצות כמות גדולה יותר של שטח מאגר מאשר השטח הזמין בבלוק של אזור הזיכרון הגבוה, המערכת עשויה להינעל. השתמש ב- hexsize כדי להימנע מבעיה זו. ב- hexsize, ציין בתבנית הקסדצימאלית את כמות הזיכרון הדרושה למנהל ההתקן. כדי למצוא ערך זה עבור מנהל התקן מסוים, טען את מנהל ההתקן לזיכרון הרגיל והשתמש בפקודה mem /debug.

  • טעינה לזיכרון רגיל

    אם אין מספיק אזור זיכרון גבוה זמין לשם טעינת מנהל ההתקן שציינת ב- devicehigh, מערכת המשנה MS-DOS טוענת אותו לזיכרון הרגיל (כאילו השתמשת בפקודה device).

דוגמאות

כדי לטעון מנהל התקן בשם Mydriv.sys לאזור הזיכרון הגבוה, הקלד את הפקודות הבאות בקובץ Config.nt או בקובץ ההפעלה המקביל:

device=c:\winnt\system32\himem.sys
dos=umb
devicehigh=mydriv.sys


Dir

פקודה זו מציגה רשימה של הקבצים וספריות המשנה בספריה. כאשר נעשה בה שימוש ללא פרמטרים, הפקודה dir מציגה את התווית של אמצעי האחסון ואת המספר הסידורי של הדיסק, ולאחר מכן את רשימת הספריות והקבצים בדיסק, כולל שמותיהם והתאריך והשעה בה בוצע השינוי האחרון בכל אחד. עבור קבצים, הפקודה dir מציגה את סיומת השם ואת הגודל בבתים. כמו כן, הפקודה dir מציגה את המספר הכולל של הקבצים והספריות המפורטים, הגודל הכולל שלהם והשטח הפנוי (בבתים) שנותר בדיסק.

תחביר

dir [Drive:][Path][FileName] [...]‎ [‎/p] [‎/q] [‎/w] [‎/d] [‎/a[[:]attributes]‎][‎/o[[:]SortOrder]‎] [‎/t[[:]TimeField]‎] [‎/s] [‎/b] [‎/l] [‎/n] [‎/x] [‎/c] [‎/4]

פרמטרים

[Drive:][Path]
פרמטר זה מציין את הכונן והספריה שעבורם ברצונך לראות פירוט.
[FileName]
פרמטר זה מציין קובץ מסוים או ערכת קבצים שעבורם ברצונך לראות פירוט.
‎/p
הצגת הפירוט מסך אחר מסך. כדי לצפות במסך הבא, הקש על כל מקש בלוח המקשים.
‎/q
פרמטר זה מציג מידע אודות בעלות הקובץ.
‎/w
הצגת הפירוט בתבנית רחבה, עם חמישה שמות של קבצים או שמות ספריה בכל שורה לכל היותר.
‎/d
כמו ‎/w אך הקבצים ממוינים לפי טורים.
‎/a[[:] attributes]‎
פרמטר זה מציג רק את השמות של אותם קבצים וספריות בעלי התכונות שציינת. אם תשמיט את הפרמטר ‎/a, הפקודה dir תציג את השמות של כל הקבצים מלבד קבצים מוסתרים וקבצי מערכת. אם תשתמש בפרמטר ‎/a מבלי לציין attributes, הפקודה dir תציג את השמות של כל הקבצים, כולל קבצים מוסתרים וקבצי מערכת. הרשימה הבאה מתארת כל אחד מהערכים בהם באפשרותך להשתמש עבור attributes. סימן הנקודתיים (:) אופציונלי. השתמש בכל שילוב של ערכים אלה ואל תפריד בין הערכים באמצעות רווחים.
ערך | תיאור
h | קבצים מוסתרים
s | קבצי מערכת
d | ספריות
a | הקובץ מוכן לשמירה בארכיון
r | קבצים לקריאה בלבד
‎-h | קבצים לא מוסתרים
‎-s | קבצים שאינם קבצי מערכת
‎-d | קבצים בלבד (לא ספריות)
‎-a | קבצים שלא השתנו מאז הגיבוי האחרון
‎-r | קבצים שאינם לקריאה בלבד
‎/o [[:]SortOrder]‎
פרמטר זה שולט על הסדר בו הפקודה dir ממיינת ומציגה שמות ספריה ושמות קבצים. אם תשמיט את הפרמטר ‎/o, הפקודה dir תציג את השמות בסדר בו הם מופיעים בספריה. אם תשתמש בפרמטר ‎/o בלי לציין ערך עבור SortOrder, הפקודה dir תציג את השמות של כל הספריות, ממוינים בסדר אלפביתי ולאחר מכן תציג את שמות כל הקבצים, ממוינים בסדר אלפביתי. סימן הנקודתיים (:) אופציונלי. הרשימה הבאה מתארת כל אחד מהערכים בהם באפשרותך להשתמש עבור SortOrder. השתמש בכל צירוף של הערכים ואל תפריד ערכים אלה באמצעות רווחים לבנים.
ערך | תיאור
n | בסדר אלפביתי לפי שם
e | בסדר אלפביתי לפי סיומת
d | לפי תאריך ושעה, המוקדם ביותר תחילה
s | לפי גודל, הקטן ביותר תחילה
g | עם ספריות מקובצות לפני קבצים
‎-n | בסדר אלפביתי הפוך לפי שם (Z עד A)
‎-e | בסדר אלפביתי הפוך לפי סיומת (‎.ZZZ עד ‎.AAA)
‎-d | לפי תאריך ושעה, המאוחר ביותר תחילה
‎-s | לפי גודל, הגדול ביותר תחילה
‎-g | עם ספריות מקובצות לאחר קבצים
‎/t [[:]TimeField]‎
פרמטר זה קובע איזה שדה שעה יוצג עבור המיון. הרשימה הבאה מתארת כל אחד מהערכים בהם באפשרותך להשתמש עבור TimeField.
ערך | תיאור
c | יצירה
a | גישה אחרונה שבוצעה
w | נכתב לאחרונה
‎/s
פירוט כל מופע, בספריה שצוינה ובכל ספריות המשנה, של שם הקובץ שצוין.
‎/b
פרמטר זה מפרט כל שם ספריה או שם קובץ, אחד בכל שורה, כולל סיומת שם הקובץ. הפרמטר ‎/b אינו מציג מידע כותרת או סיכום. הפרמטר ‎/b עוקף את הפרמטר ‎/w.
‎/l
פרמטר זה מציג שמות ספריות ושמות קבצים לא ממוינים באותיות קטנות. הפרמטר ‎/l אינו ממיר תווים מורחבים לאותיות קטנות.
‎/n
פרמטר זה מציג תבנית רשימה ארוכה עם שמות קבצים בצד הימני העליון של המסך.
‎/x
פרמטר זה מציג את השמות הקצרים שניתנו לקבצים באמצעי אחסון מסוג NTFS ו- FAT. התצוגה זהה לתצוגה עם הפרמטר ‎/n, אך השמות הקצרים מוצגים לאחר השמות הארוכים.
‎/c
הצגת מפריד האלפים בגדלי קבצים.
‎/4
פרמטר זה מציג תבנית שנה בת ארבע ספרות.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • שימוש ב- filenames מרובים

    באפשרותך להשתמש ב- filenames מרובים. הפרד את שמות הקבצים באמצעות רווחים, סימני פסיק או נקודה-פסיק. באפשרותך להשתמש בתווים כלליים (כלומר, ? ו- *) ב- FileName כדי להציג קבוצה של קבצים.

  • שימוש בתווים כלליים

    באפשרותך להשתמש בתווים כלליים (כלומר, ? ו- *) כדי להציג רשימה של קבוצת משנה של קבצים ושל ספריות משנה.

  • קביעת תכונות התצוגה של הקובץ

    אם תציין יותר מערך אחד עבור הפרמטר ‎/a ב- attributes, הפקודה dir תציג רק אותם השמות של הקבצים המכילים את כל התכונות שצוינו. לדוגמה, אם תציין את הפרמטר ‎/a עם הערכים r ו- ‎-h עבור תכונות באמצעות ‎/a:r-h או ‎/ar-h, הפקודה dir תציג רק את השמות של הקבצים לקריאה בלבד שאינם מוסתרים.

  • קביעת מיון של שמות קבצים

    אם תציין יותר מערך אחד של SortOrder‏, הפקודה dir תמיין את שמות הקבצים לפי הקריטריון הראשון תחילה, לאחר מכן לפי הקריטריון השני וכן הלאה. לדוגמה, אם תשתמש בפרמטר ‎/o עם הערכים e ו- ‎-s עבור SortOrder בצורה ‎/o:e-s או ‎/oe-s, הפקודה dir תמיין את שמות הספריות והקבצים לפי סיומת, כאשר הקובץ הגדול ביותר ראשון ותציג את התוצאה הסופית. המיון האלפביתי לפי סיומת גורם לכך ששמות קבצים ללא סיומות יופיעו ראשונים, לאחר מכן שמות ספריות ולאחר מכן שמות קבצים עם סיומות.

  • שימוש בסמלי ניתוב מחדש ובתווי |

    כאשר אתה משתמש בסימן ניתוב מחדש (‎>‎) כדי לשלוח פלט של dir לקובץ, או בתו (|) כדי לשלוח פלט של dir לפקודה אחרת, השתמש בפרמטרים ‎/a:-d ו- ‎/b כדי לפרט את שמות הקבצים בלבד. באפשרותך להשתמש בפרמטר FileName עם הפרמטרים ‎/b ו- ‎/s כדי לציין שעל הפקודה dir לחפש בספריה הנוכחית ובכל ספריות המשנה שלה אחר כל שמות הקבצים התואמים ל- FileName. הפקודה dir מפרטת רק את אות הכונן, שם הספריה, שם הקובץ וסיומת שם הקובץ, נתיב אחד בכל שורה, עבור כל שם קובץ שהפקודה מוצאת. לפני שתשתמש בתו | לשם ניתוב מחדש, עליך להגדיר את משתנה הסביבה TEMP בקובץ Autoexec.nt.

  • קביעה מראש של פרמטרים של dir

    באפשרותך להגדיר מראש פרמטרים של הפקודה dir על-ידי כלילת הפקודה set עם משתנה הסביבה DIRCMD בקובץ Autoexec.nt. באפשרותך להשתמש בכל שילוב חוקי של פרמטרים של dir עם הפקודה set dircmd, כולל המיקום והשם של קובץ.

    לדוגמה, כדי להשתמש במשתנה הסביבה DIRCMD להגדרת תבנית התצוגה הרחבה (‎/w) כתבנית ברירת המחדל, הקלד את הפקודה הבאה בקובץ Autoexec.nt:

    set dircmd=/w

    לשימוש בודד בפקודה dir, באפשרותך לעקוף פרמטר על-ידי שימוש במשתנה הסביבה DIRCMD. לשם כך, הקלד את הפרמטר שאותו ברצונך לעקוף בשורת הפקודה של dir וציין סימן חיסור לפני הפרמטר. לדוגמה:

    dir /-w

    כדי לשנות את הגדרות ברירת המחדל של משתנה הסביבה DIRCMD, הקלד:

    set=NewParameter

    הגדרות ברירת המחדל החדשות יהיו אפקטיביות עבור כל פקודות dir הבאות לאחר מכן עד שתשתמש שוב בפקודה set dircmd או עד שתפעיל מחדש את המחשב.

    לניקוי כל הגדרות ברירת המחדל, הקלד:

    set dircmd=‎

    כדי לצפות בהגדרות הנוכחיות של משתנה הסביבה DIRCMD, הקלד:

    set

    הפקודה set מציגה רשימה של משתני סביבה וההגדרות שלהם. לקבלת מידע נוסף אודות הגדרת משתני סביבה, ראה נושאים קרובים.

  • הפקודה dir, עם פרמטרים שונים, זמינה מתוך ה- Recovery Console.

דוגמאות

כדי להציג את כל הספריות, אחת אחרי השניה, בסדר אלפביתי, בתבנית רחבה ותוך עצירה אחר כל מסך, ודא שספריית הבסיס היא הספריה הנוכחית ולאחר מכן הקלד:

dir /s/w/o/p

הפקודה dir מפרטת את השם של ספריית הבסיס, את שמותיהן של ספריות המשנה בספריית הבסיס ואת שמות הקבצים בספריית הבסיס, כולל סיומות. לאחר מכן הפקודה dir מפרטת את השמות של ספריות המשנה ושמות הקבצים בכל ספריית משנה בעץ.

כדי לשנות את הדוגמה הקודמת כך שהפקודה dir תציג את שמות הקבצים ואת הסיומות אך תשמיט את שמות הספריות, הקלד:

dir /s/w/o/p/a:-d

כדי להדפיס פירוט של ספריה, הקלד:

ir > prn

כאשר אתה מציין prn, פירוט הספריה נשלח למדפסת המחוברת ליציאה LPT1. אם המדפסת שברשותך מחוברת ליציאה אחרת, עליך להחליף את prn בשם היציאה המתאימה.

כמו כן, באפשרותך לנתב מחדש פלט של הפקודה dir לקובץ על-ידי החלפת prn בשם קובץ. באפשרותך גם להקליד נתיב. לדוגמה, כדי לנתב פלט dir לקובץ Dir.doc בספריה Records, הקלד:

dir > \records\dir.doc

אם הקובץ Dir.doc אינו קיים, הפקודה dir יוצרת אותו, אלא אם כן גם הספריה Records אינה קיימת. במקרה כזה, תוצג ההודעה הבאה:

File creation error

כדי להציג רשימה של כל שמות הקבצים בעלי סיומת ‎.txt בכל הספריות בכונן C, הקלד:

dir c:\*.txt /w/o/s/p

הפקודה dir תציג, בתבנית רחבה, רשימה אלפביתית של שמות הקבצים התואמים בכל ספריה ותבצע הפסקה בכל פעם שהמסך יתמלא, עד שתקיש על מקש כלשהו כדי להמשיך.


Diskcomp

פקודה זו משווה את התוכן של שני תקליטונים. כאשר משתמשים בה ללא פרמטרים, הפקודה diskcomp משתמשת בכונן הנוכחי עבור שני התקליטונים שאותם ברצונך להשוות.

תחביר

diskcomp [drive1: [drive2:]]‎

פרמטרים

drive1
קביעת הכונן המכיל את אחד התקליטונים.
drive2
קביעת הכונן המכיל את התקליטון השני.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • שימוש בדיסקים

    הפקודה diskcomp פועלת עם תקליטונים בלבד. אין באפשרותך להשתמש ב- diskcomp עם דיסק קשיח. אם תציין כונן של דיסק קשיח עבור drive1 או drive2, הפקודה diskcomp תציג את הודעת השגיאה הבאה:

    Invalid drive specification
    Specified drive does not exist
    or is nonremovable

  • השוואת דיסקים

    אם כל הרצועות בשני הדיסקים שביניהם מתבצעת ההשוואה זהות, הפקודה diskcomp תציג את ההודעה הבאה:

    Compare OK

    אם הרצועות אינן זהות, הפקודה diskcomp תציג הודעה הדומה להודעה הבאה:

    Compare error on
    side 1, track 2

    כאשר הפקודה diskcomp מסיימת את ההשוואה, מוצגת ההודעה הבאה:

    Compare another diskette (Y/N)?‎

    אם תקיש Y, הפקודה diskcomp תציג בפניך בקשה להכניס תקליטונים עבור ההשוואה הבאה. אם תקיש N, הפקודה diskcomp תפסיק את ההשוואה.

    כאשר הפקודה diskcomp מבצעת את ההשוואה, הפקודה מתעלמת מהמספר של אמצעי האחסון של הדיסק.

  • השמטת פרמטרים של כונן

    אם תשמיט את הפרמטר drive2, הפקודה diskcomp תשתמש בכונן הנוכחי עבור drive2. אם תשמיט את שני הפרמטרים של הכונן, הפקודה diskcomp תשתמש בכונן הנוכחי עבור שניהם. אם הכונן הנוכחי זהה ל- drive1, הפקודה diskcomp תציג בפניך בקשה להחליף דיסקים בהתאם לצורך.

  • שימוש בכונן אחד

    אם תציין את אותו כונן תקליטונים עבור drive1 ו- drive2, הפקודה diskcomp תבצע את ההשוואה באמצעות כונן אחד ותציג בפניך בקשה להכניס את התקליטונים לפי הנדרש. ייתכן שיהיה עליך להחליף את התקליטונים יותר מפעם אחת, בהתאם לקיבולת של התקליטונים ולכמות הזיכרון הזמין.

  • השוואה בין סוגים שונים של תקליטונים

    לפקודה diskcomp אין אפשרות להשוות בין דיסק חד-צידי לדיסק דו-צידי, או בין דיסק קיבולת גבוהה לדיסק קיבולת כפולה. אם התקליטון בכונן drive1 אינו מאותו הסוג כמו התקליטון בכונן drive2, הפקודה diskcomp תציג את ההודעה הבאה:

    Drive types or diskette types not compatible

  • שימוש בפקודה diskcomp עם רשתות וכוננים מנותבים מחדש.

    הפקודה diskcomp אינה פועלת בכונן רשת או בכונן שנוצר על-ידי הפקודה subst. אם תנסה להשתמש בפקודה diskcomp עם כונן מאחד הסוגים האלה, הפקודה diskcomp תציג את הודעת השגיאה הבאה:

    Invalid drive specification

  • השוואה בין תקליטון מקורי לעותק

    בעת שימוש בפקודה diskcomp עם תקליטון שיצרת באמצעות הפקודה copy, הפקודה diskcomp עשויה להציג הודעה הדומה להודעה הבאה:

    Compare error on
    side 0, track 0

    שגיאה מסוג זה עשויה להתרחש גם אם הקבצים בתקליטונים זהים. למרות שהפקודה copy משכפלת מידע, פקודה זו לא בהכרח ממקמת את המידע באותו מיקום בתקליטון היעד. לקבלת מידע נוסף אודות השוואה בין קבצים בודדים בשני תקליטונים שונים באמצעות Fc, ראה נושאים קרובים.

  • הבנת קודי יציאה של הפקודה diskcomp

    הטבלה שלהלן מציגה כל קוד יציאה ותיאור קצר.

    קוד יציאה | תיאור
    0 | התקליטונים זהים
    1 | נמצאו הבדלים
    3 | אירעה טעות חמורה
    4 | אירעה שגיאת אתחול

    כדי לעבד קודי יציאה שהוחזרו על-ידי הפקודה diskcomp, באפשרותך להשתמש בפרמטר errorlevel בשורת הפקודה if בתוכנית אצווה.

דוגמאות

אם במחשב שלך מותקן כונן תקליטונים אחד בלבד (לדוגמה כונן A), וברצונך להשוות בין שני תקליטונים, הקלד:

diskcomp a: a:‎

הפקודה Diskcomp מודיעה למשתמש להכניס כל תקליטון, לפי הצורך.

הדוגמה שלהלן מדגימה כיצד לעבד קוד יציאה של diskcomp בתוכנית אצווה המשתמשת בפרמטר errorlevel בשורת הפקודה if:

rem Checkout.bat compares the disks in drive A and B
echo off
diskcomp a: b:
if errorlevel 4 goto ini_error
if errorlevel 3 goto hard_error
if errorlevel 1 goto no_compare
if errorlevel 0 goto compare_ok
:ini_error
echo ERROR: Insufficient memory or command invalid
goto exit
:hard_error
echo ERROR: An irrecoverable error occurred
goto exit
:break
echo "You just pressed CTRL+C" to stop the comparison
goto exit
:no_compare
echo Disks are not the same
goto exit
:compare_ok
echo The comparison was successful; the disks are the same
goto exit
:exit


Diskcopy

פקודה זו מעתיקה את התוכן של תקליטון בכונן המקור לתקליטון מאותחל או לא מאותחל בכונן היעד. כאשר נעשה בה שימוש ללא פרמטרים, הפקודה diskcopy משתמשת בכונן הנוכחי עבור תקליטון המקור ותקליטון היעד.

תחביר

diskcopy [drive1: [drive2:]] [/v]‎

פרמטרים

drive1
קביעת הכונן המכיל את תקליטון המקור.
drive2
קביעת הכונן המכיל את תקליטון היעד.
‎/v
פרמטר זה מוודא שהמידע הועתק כראוי. שימוש באפשרות שורת פקודה זו מאט את תהליך ההעתקה.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • שימוש בדיסקים

    הפקודה diskcopy פועלת עם דיסקים ניתנים להסרה בלבד, כגון תקליטונים. אין באפשרותך להשתמש בפקודה diskcopy עם כונן קשיח. אם תציין כונן קשיח עבורdrive1 או drive2, הפקודה diskcopy תציג את הודעת השגיאה הבאה:

    Invalid drive specification
    Specified drive does not exist
    or is nonremovable

    הפקודה diskcopy מציגה בפניך בקשה להכניס את הדיסקים של המקור והיעד וממתינה עד שתקיש על מקש כלשהו בלוח המקשים לפני שתימשך הפעולה.

    לאחר סיום ההעתקה, הפקודה diskcopy מציגה את ההודעה הבאה:

    Copy another diskette (Y/N)?‎

    אם תקיש Y, הפקודה diskcopy תציג בפניך בקשה להכניס את הדיסקים של המקור והיעד עבור פעולת ההעתקה הבאה. כדי להפסיק את התהליך של diskcopy, הקש N.

    אם אתה מעתיק לתקליטון לא מאותחל בכונן drive2‏, הפקודה diskcopy מאתחלת את הדיסק עם אותו מספר צדדים וסקטורים לכל רצועה כמו הדיסק שנמצא ב- drive1. הפקודה Diskcopy מציגה את ההודעה הבאה כאשר מתבצע איתחול הדיסק והעתקת הקבצים:

    Formatting while copying

  • מספרים סידוריים של דיסק

    אם לדיסק המקור יש מספר סידורי של אמצעי אחסון, הפקודה diskcopy יוצרת מספרי סידורי חדש של אמצעי אחסון עבור דיסק היעד ומציגה את המספר בסיום פעולת ההעתקה.

  • השמטת פרמטרים של כונן

    אם תשמיט את הפרמטר drive2, הפקודה diskcopy תשתמש בכונן הנוכחי ככונן היעד. אם תשמיט את שני הפרמטרים של הכונן, הפקודה diskcopy תשתמש בכונן הנוכחי עבור שניהם. אם הכונן הנוכחי זהה לכונן drive1, הפקודה diskcopy תציג בפניך בקשה להחליף דיסקים בהתאם לצורך.

  • שימוש בכונן אחד להעתקה

    אם drive1 ו- drive2 זהים, הפקודה diskcopy תציג בפניך בקשה בכל פעם שיהיה עליך להחליף דיסקים. אם תשמיט את שני הפרמטרים של Drive והכונן הנוכחי הוא כונן תקליטונים, הפקודה diskcopy תציג בפניך בקשה בכל פעם שיהיה עליך להכניס דיסק לכונן. אם הדיסקים מכילים כמות גדולה יותר של מידע משניתן להכיל בזיכרון הזמין, לפקודה diskcopy לא תהיה אפשרות לקרוא את כל המידע בבת-אחת. הפקודה diskcopy תקרא מדיסק המקור, תכתוב לדיסק היעד ותציג בפניך בקשה להכניס שוב את דיסק המקור. תהליך זה יימשך עד שהעתקתו של כל הדיסק תושלם.

  • מניעת פיצול של דיסק

    מכיוון שהפקודה diskcopy יוצרת עותק מדויק של דיסק המקור בדיסק היעד, כל פיצול בדיסק המקור עובר לדיסק היעד. פיצול הוא הקיום של אזורים קטנים של שטח לא מנוצל בין קבצים קיימים בדיסק.

    דיסק מקור מפוצל עשוי להאט את תהליך החיפוש, הקריאה והכתיבה של קבצים. כדי למנוע את העברת הפיצול מדיסק אחד לשני, השתמש בפקודה copy או בפקודה xcopy כדי להעתיק את הדיסק. מכיוון שהפקודות copy ו- xcopy מעתיקות קבצים באופן רציף, הדיסק החדש לא יהיה מפוצל.

    אזהרה

    • אין באפשרותך להשתמש בפקודה xcopy כדי להעתיק תקליטון אתחול.
  • הבנת קודי יציאה של הפקודה diskcopy

    הטבלה שלהלן מציגה כל קוד יציאה בצירוף תיאור קצר.

    קוד יציאה | תיאור
    0 | ההעתקה הסתיימה בהצלחה
    1 | אירעה שגיאת קריאה/כתיבה לא חמורה
    3 | אירעה שגיאה חמורה
    4 | אירעה שגיאת אתחול

    כדי לעבד קודי יציאה שהוחזרו על-ידי diskcomp, באפשרותך להשתמש בפרמטר errorlevel בשורת הפקודה if בתוכנית אצווה. לקבלת דוגמה של תוכנית אצווה המבצעת עיבוד של קודי יציאה, ראה את הפקודה diskcomp בנושאים קרובים.

דוגמאות

כדי להעתיק את התקליטון בכונן B לתקליטון בכונן A, הקלד:

diskcopy b: a:‎


DiskPart

הפקודה DiskPart.exe היא מתרגם פקודה במצב טקסט, המאפשר לך לנהל אובייקטים (דיסקים, מחיצות או אמצעי אחסון) באמצעות קבצי Script או קלט ישיר משורת פקודה. לפני שיהיה באפשרותך להשתמש בפקודות DiskPart.exe על דיסק, מחיצה או אמצעי אחסון, עליך לפרט תחילה את האובייקט ולאחר מכן לבחור אותו כדי להתמקד עליו. כאשר האובייקט נמצא במוקד, כל פקודת DiskPart.exe שתקליד תפעל על אותו אובייקט.

באפשרותך לפרט את האובייקטים הזמינים ולקבוע את מספר האובייקט או את אות הכונן שלו באמצעות הפקודות list disk‏, list volume ו- list partition. הפקודות list disk ו- list volume מציגות את כל הדיסקים ואמצעי האחסון במחשב. הפקודה list partition מציגה רק מחיצות בדיסק עם המוקד. בעת השימוש בפקודות list מופיעה כוכבית (*) ליד האובייקט עם המוקד. באפשרותך לבחור אובייקט על-פי מספרו או אות הכונן שלו, כגון דיסק 0, מחיצה 1, אמצעי אחסון 3 או אמצעי אחסון C.

בעת בחירת אובייקט, המוקד נותר על אותו אובייקט עד שתבחר אובייקט אחר. לדוגמה, אם המוקד נקבע על דיסק 0 ותבחר באמצעי אחסון 8 בדיסק 2, המוקד יעבור מדיסק 0 לדיסק 2, אמצעי אחסון 8. פקודות מסוימות משנות אוטומטית את המוקד. לדוגמה, בעת יצירת מחיצה חדשה, המוקד עובר אוטומטית למחיצה החדשה.

באפשרותך להתמקד רק על מחיצה בדיסק שנבחר. כאשר למחיצה יש מוקד, אמצעי האחסון הקשור אליה (אם קיים) מקבל מוקד אף הוא. כאשר לאמצעי אחסון יש מוקד, הדיסק והמחיצה הקשורים אליו מקבלים מוקד אף הם אם אמצעי האחסון ממופה למחיצה ספציפית אחת. אם אין הדבר כך, המוקד בדיסק ובמחיצה אובד.

פקודות DiskPart

כדי לראות את תחביר הפקודות, לחץ על פקודה:

active

פקודה זו מסמנת את המחיצה בעלת המוקד בדיסקים בסיסיים כפעילה. סימון זה מיידע את מערכת הקלט/פלט הבסיסית (BIOS) או את ממשק הקושחה בר-ההרחבה (EFI) שהמחיצה או אמצעי האחסון הם מחיצת מערכת או אמצעי אחסון של מערכת חוקיים.

ניתן לסמן כפעילות מחיצות בלבד.

חשוב

  • הפקודה DiskPart מוודאת שהמחיצה מסוגלת להכין קבצי אתחול של מערכת הפעלה בלבד. הפקודה DiskPart אינה בודקת את תוכן המחיצה. אם תסמן מחיצה בטעות כ"פעילה" והמחיצה אינה מכילה את קבצי האתחול של מערכת ההפעלה, המחשב עשוי שלא לפעול.

תחביר

active

add disk

פקודה זו משקפת את אמצעי האחסון הפשוט עם מוקד לדיסק שצוין.

תחביר

add disk=n [noerr]‎

פרמטרים

n
פרמטר זה מציין את הדיסק שיכיל את השיקוף. באפשרותך לשקף רק אמצעי אחסון פשוטים. הדיסק שצוין חייב להכיל שטח בלתי מוקצה שיהיה גדול לפחות כגודל אמצעי האחסון הפשוט שברצונך לשקף.
noerr
פרמטר זה משמש ל- Scripting בלבד. כאשר הפקודה נתקלת בשגיאה, פרמטר זה מציין שהפקודה DiskPart תמשיך לעבד פקודות כאילו השגיאה לא התרחשה. ללא הפרמטר noerr, הופעת השגיאה תגרום לפקודה DiskPart לצאת עם קוד שגיאה.

assign

פקודה זו מקצה אות כונן או נקודת טעינה לאמצעי האחסון עם המוקד. אם לא מצוינת כל אות כונן או נקודת טעינה, תוקצה לאמצעי האחסון אות הכונן הנגישה הבאה. אם אות הכונן או נקודת הטעינה נמצאות כבר בשימוש, נוצרת שגיאה.

באמצעות שימוש בפקודה assign, באפשרותך לשנות את אות הכונן המשויכת לכונן נשלף.

אין באפשרותך להקצות אותיות כונן לאמצעי אחסון של המערכת, לאמצעי אחסון לאתחול או לאמצעי אחסון המכילים את קובץ ההחלפה. בנוסף, אין באפשרותך להקצות אות כונן למחיצה של יצרן ציוד מקורי (OEM) או למחיצה מסוג טבלת מחיצות של GUID ‏(GPT) מלבד מחיצת MSDATA בסיסית.

תחביר

assign [{letter=d|mount=Path}] [noerr]‎

פרמטרים

letter=d
פרמטר זה מציין את אות הכונן שברצונך להקצות לאמצעי האחסון.
mount=Path
פרמטר זה מציין את נקודת הטעינה שברצונך להקצות לאמצעי האחסון.
noerr
פרמטר זה משמש ל- Scripting בלבד. כאשר הפקודה נתקלת בשגיאה, פרמטר זה מציין כי הפקודה DiskPart תמשיך לעבד את הפקודות כאילו לא אירעה שגיאה. ללא הפרמטר noerr, הופעת שגיאה תגרום לפקודה DiskPart לצאת עם קוד שגיאה.

break disk

פקודה זו מתייחסת לדיסקים דינאמיים בלבד. הפקודה שוברת את אמצעי האחסון שעבר שיקוף בעל המוקד לשני אמצעי אחסון פשוטים. אמצעי אחסון פשוט אחד שומר על אות הכונן ועל כל נקודת טעינה של אמצעי האחסון המשוקף, בעוד אמצעי האחסון הפשוט השני מקבל את המוקד כדי שיהיה באפשרותך להקצות לו אות כונן.

כברירת מחדל, התוכן של שני חצאי אמצעי האחסון שעבר שיקוף נשמר. כל חצי הופך לאמצעי אחסון פשוט. באמצעות השימוש בפרמטר nokeep, באפשרותך לשמור רק על חצי אחד של אמצעי האחסון המשוקף כאמצעי אחסון פשוט, בעוד החצי השני נמחק ועובר המרה לשטח פנוי. במקרה זה אף אחד מבין אמצעי האחסון לא יקבל את המוקד.

תחביר

break disk=n [nokeep] [noerr]‎

פרמטרים

n
פרמטר זה מציין את הדיסק המכיל את אמצעי האחסון שעבר שיקוף.
nokeep
פרמטר זה מציין כי רק אחד מבין אמצעי האחסון שעברו שיקוף נשמר בעוד אמצעי האחסון השני נמחק ועובר המרה לשטח חופשי. אמצעי האחסון והשטח פנוי לא מקבלים את המוקד.
noerr
פרמטר זה מיועד ל- Scripting בלבד. כאשר הפקודה נתקלת בשגיאה, פרמטר זה מציין כי DiskPart תמשיך לעבד את הפקודות כאילו לא אירעה שגיאה. ללא הפרמטר noerr, הופעת שגיאה תגרום לפקודה DiskPart לצאת עם קוד שגיאה.

clean

פקודה זו מנקה את כל המחיצות או אמצעי האחסון המאותחלים מהדיסק בעל המוקד. בדיסקים מסוג רשומת אתחול ראשית (MBR) יוחלף רק מידע מחיצות MBR ומידע סקטורים מוסתרים. בדיסקים מסוג טבלת מחיצות של GUID‏ (GPT) יוחלף מידע מחיצות GPT, כולל Protective MBR. לא קיים מידע של סקטורים מוסתרים.

תחביר

clean [all]‎

פרמטר

הכל
פרמטר זה מציין כי כל הסקטורים בדיסק מאופסים, פעולה המוחקת לחלוטין את כל המידע המוכל בדיסק.

convert basic

פקודה זו ממירה דיסק דינאמי ריק לדיסק בסיסי.

תחביר

convert basic [noerr]‎

פרמטר

noerr
פרמטר זה מיועד ל- Scripting בלבד. כאשר הפקודה נתקלת בשגיאה, פרמטר זה מציין כי DiskPart תמשיך לעבד את הפקודות כאילו לא אירעה שגיאה. ללא הפרמטר noerr הופעת שגיאה תגרום לפקודה DiskPart לצאת עם קוד שגיאה.

convert dynamic

פקודה זו ממירה דיסק בסיסי לדיסק דינאמי.

תחביר

convert dynamic [noerr]‎

פרמטר

noerr
פרמטר זה מיועד ל- Scripting בלבד. כאשר הפקודה נתקלת בשגיאה, פרמטר זה מציין כי DiskPart תמשיך לעבד את הפקודות כאילו לא אירעה שגיאה. ללא הפרמטר noerr הופעת שגיאה תגרום לפקודה DiskPart לצאת עם קוד שגיאה.

convert gpt

במחשבים מבוססי- Itanium, פקודה זו ממירה דיסק בסיסי ריק עם סגנון מחיצת רשומת אתחול ראשית (MBR) לדיסק בסיסי עם סגנון מחיצה טבלת מחיצות של GUID‏ (GPT).

חשוב

  • על הדיסק להיות ריק כדי שניתן יהיה להמירו לדיסק GPT. גבה את הנתונים שלך ולאחר מכן מחק את כל המחיצות או את אמצעי האחסון לפני המרת הדיסק.

תחביר

convert gpt [noerr]‎

פרמטר

noerr
פרמטר זה מיועד ל- Scripting בלבד. כאשר הפקודה נתקלת בשגיאה, פרמטר זה מציין כי DiskPart תמשיך לעבד את הפקודות כאילו לא אירעה שגיאה. ללא הפרמטר noerr הופעת שגיאה תגרום לפקודה DiskPart לצאת עם קוד שגיאה.

convert mbr

במחשבים מבוססי- Itanium, פקודה זו ממירה דיסק בסיסי ריק עם סגנון מחיצה טבלת מחיצות של GUID‏ (GPT) לדיסק בסיסי עם סגנון מחיצה רשומת אתחול ראשית (MBR).

חשוב

  • על הדיסק להיות ריק כדי שניתן יהיה להמירו לדיסק MBR. גבה את הנתונים שלך ולאחר מכן מחק את כל המחיצות או את אמצעי האחסון לפני המרת הדיסק.

תחביר

convert mbr [noerr]‎

פרמטר

noerr
פרמטר זה מיועד ל- Scripting בלבד. כאשר הפקודה נתקלת בשגיאה, פרמטר זה מציין כי DiskPart תמשיך לעבד את הפקודות כאילו לא אירעה שגיאה. ללא הפרמטר noerr הופעת שגיאה תגרום לפקודה DiskPart לצאת עם קוד שגיאה.

create partition efi

במחשבים מבוססי- Itanium, פקודה זו יוצרת מחיצת מערכת EFI בדיסק טבלת מחיצות של GUID‏ (GPT). לאחר יצירת המחיצה, המוקד ניתן למחיצה החדשה.

תחביר

create partition efi [size=n] [offset=n] [noerr]‎

פרמטרים

size=n
פרמטר זה מציין את גודל המחיצה במגה-בתים (MB). אם לא מצוין גודל, המחיצה ממשיכה עד שלא נותר שטח פנוי באזור הנוכחי.
offset=n
פרמטר זה מציין את היסט הבית שבו יש ליצור את המחיצה. אם לא מוגדר היסט, המחיצה ממוקמת באזור הדיסק הראשון הגדול דיו כדי להכיל אותה.
noerr
פרמטר זה מיועד ל- Scripting בלבד. כאשר הפקודה נתקלת בשגיאה, פרמטר זה מציין כי DiskPart תמשיך לעבד את הפקודות כאילו לא אירעה שגיאה. ללא הפרמטר noerr הופעת שגיאה תגרום לפקודה DiskPart לצאת עם קוד שגיאה.

create partition extended

פקודה זו יוצרת מחיצה מורחבת בכונן הנוכחי. לאחר שנוצרה המחיצה, המוקד עובר אוטומטית למחיצה החדשה. ניתן ליצור רק מחיצה מורחבת אחת בדיסק. פקודה זו נכשלת אם תנסה ליצור מחיצה מורחבת בתוך מחיצה מורחבת אחרת. עליך ליצור מחיצה מורחבת לפני שיהיה באפשרותך ליצור כוננים לוגיים.

תחביר

create partition extended [size=n] [offset=n] [noerr]‎

פרמטרים

size=n
פרמטר זה מציין את גודלה של המחיצה המורחבת במגה-בתים (MB). אם לא מצוין גודל, המחיצה תמשיך עד שלא יישאר שטח פנוי באזור. הגודל מותאם לגליל. הגודל מעוגל לגבול הגליל הקרוב ביותר. לדוגמה, אם תציין גודל של ‎500 MB, המחיצה תעוגל לגודל של ‎504 MB.
offset=n
פרמטר זה מתייחס לדיסקים מסוג רשומת אתחול ראשית (MBR) בלבד. פרמטר זה מציין את היסט הבית שבו יש ליצור את המחיצה המורחבת. אם לא מוגדר כל היסט, המחיצה תתחיל בתחילת השטח הפנוי הראשון בדיסק. ההיסט מותאם לגליל. ההיסט מעוגל לגבול הגליל הקרוב ביותר. לדוגמה, אם תציין היסט בגודל ‎27 MB וגודל הגליל הוא ‎8 MB, ההיסט מעוגל לגבול 24‎ MB.
noerr
פרמטר זה מיועד ל- Scripting בלבד. כאשר הפקודה נתקלת בשגיאה, פרמטר זה מציין כי DiskPart תמשיך לעבד את הפקודות כאילו לא אירעה שגיאה. ללא הפרמטר noerr הופעת שגיאה תגרום לפקודה DiskPart לצאת עם קוד שגיאה.

create partition logical

פקודה זו יוצרת כונן לוגי במחיצה המורחבת. לאחר שהמחיצה נוצרה, המוקד עובר אוטומטית לכונן הלוגי החדש.

תחביר

create partition logical [size=n] [offset=n] [noerr]‎

פרמטרים

size=n
פרמטר זה מציין את גודל הכונן הלוגי במגה-בתים (MB). אם לא הוגדר גודל, המחיצה ממשיכה עד שלא נותר שטח פנוי באזור הנוכחי.
offset=n
פרמטר זה מתייחס לדיסקים מסוג רשומת אתחול ראשית (MBR) בלבד. פרמטר זה מציין את היסט הבית שבו יש ליצור את הכונן הלוגי. ההיסט מותאם לגליל (כלומר ההיסט מעוגל כך שימלא לחלוטין כל גודל גליל שנמצא בשימוש). אם לא מוגדר כל גודל, המחיצה ממוקמת באזור הדיסק הראשון הגדול דיו כדי להכיל אותה. אורך המחיצה בבתים יהיה כגודל המספר שצוין באמצעות size=n לפחות. אם תציין גודל עבור הכונן הלוגי, עליו להיות קטן יותר מהמחיצה המורחבת.
noerr
פרמטר זה מיועד ל- Scripting. כאשר הפקודה נתקלת בשגיאה, פרמטר זה מציין כי DiskPart תמשיך לעבד את הפקודות כאילו לא אירעה שגיאה. ללא הפרמטר noerr, הופעת שגיאה תגרום לפקודה DiskPart לצאת עם קוד שגיאה.

create partition msr

במחשבים מבוססי- Itanium, פקודה זו יוצרת מחיצת Microsoft Reserved‏ (MSR) בדיסק טבלת מחיצות של GUID‏ (GPT) .

שים לב

  • עליך להיות זהיר ביותר בעת השימוש בפקודה create partition msr. מאחר שדיסקים מסוג GPT מצריכים פריסת מחיצות ספציפית, יצירת מחיצות Microsoft Reserved עשויה להפוך את הדיסק לבלתי קריא. בדיסקים מסוג GPT המשמשים להפעלת מהדורת 64 סיביות של Windows XP, מחיצת מערכת EFI היא המחיצה הראשונה בדיסק, ואחריה נמצאת מחיצת Microsoft Reserved. דיסקים מסוג GPT משמשים רק לאחסון נתונים ואינם בעלי מחיצת מערכת EFI. כלומר, מחיצת Microsoft Reserved היא המחיצה הראשונה.

    מהדורת 64 סיביות של Windows XP אינה טוענת מחיצות Microsoft Reserved. אין באפשרותך לאחסן נתונים במחיצות אלה ואין באפשרותך למחוק אותן.

תחביר

create partition msr [size=n] [offset=n] [noerr]‎

פרמטרים

size=n
פרמטר זה מציין את גודל המחיצה במגה-בתים (MB). גודל המחיצה בבתים ארוך לפחות כמספר המצוין באמצעות size=n. אם לא מוגדר גודל, המחיצה ממשיכה עד שלא נותר שטח פנוי באזור הנוכחי.
offset=n
פרמטר זה מציין את היסט הבית בו יש ליצור את המחיצה. המחיצה מתחילה בהיסט הבית המוגדר באמצעות offset=n. היסט זה מותאם לגליל, כלומר ההיסט מעוגל כך שימלא לגמרי את גודל סקטור הנמצא בשימוש. אם לא מוגדר כל היסט, המחיצה ממוקמת באזור הדיסק הראשון הגדול דיו כדי להכיל אותה.
noerr
פרמטר זה מיועד ל- Scripting בלבד. כאשר הפקודה נתקלת בשגיאה, פרמטר זה מציין כי DiskPart תמשיך לעבד את הפקודות כאילו לא אירעה שגיאה. ללא הפרמטר noerr הופעת שגיאה תגרום לפקודה DiskPart לצאת עם קוד שגיאה.

create partition primary

פקודה זו יוצרת מחיצה ראשית בדיסק הבסיסי הנוכחי. לאחר יצירת המחיצה, המוקד עובר אוטומטית למחיצה החדשה. המחיצה אינה מקבלת אות כונן. עליך להשתמש בפקודה assign כדי להקצות אות כונן למחיצה.

תחביר

create partition primary [size=n] [offset=n] [ID={byte|GUID}] [noerr]‎

פרמטרים

size=n
פרמטר זה מציין את גודל המחיצה במגה-בתים (MB). אם לא הוגדר גודל, המחיצה ממשיכה עד שלא נותר שטח שאינו מוקצה באזור הנוכחי. הגודל מותאם לגליל. הגודל מעוגל לגבול הגליל הקרוב ביותר. לדוגמה, אם תציין גודל של ‎500 MB, המחיצה תעוגל לגודל של ‎504 MB.
offset=n
פרמטר זה מציין את היסט הבית בו יש ליצור את המחיצה. אם לא הוגדר היסט, המחיצה תתחיל בתחילת השטח הפנוי הראשון בדיסק. בדיסקים מסוג רשומת אתחול ראשית (MBR), ההיסט מותאם לגליל. ההיסט מעוגל לגבול הגליל הקרוב ביותר. לדוגמה, אם תציין היסט בגודל ‎27 MB וגודל הגליל הוא ‎8 MB, ההיסט מעוגל לגבול ‎24 MB.
ID={byte|GUID}‎
פרמטר זה מיועד לשימוש של יצרני ציוד מקורי (OEM) בלבד.

שים לב

  • יצירת מחיצות עם פרמטר זה עשויה לגרום לקריסת המחשב או לכך שהמחשב לא יאותחל. אלא אם כן הנך יצרן ציוד מקורי (OEM) או מומחה לטכנולוגיות מידע המנוסה עם דיסקים מסוג GPT, הימנע מיצירת מחיצות בדיסקים מסוג GPT באמצעות הפרמטר ID=byte | GUID. במקום זאת, השתמש תמיד בפקודה create partition efi כדי ליצור מחיצות מערכת EFI, בפקודה create partition msr כדי ליצור מחיצות Microsoft Reserved ובפקודה create partition primary (ללא הפרמטר ID=byte | GUID) כדי ליצור מחיצות ראשיות בדיסקים מסוג GPT.

עבור דיסקים מסוג MBR, באפשרותך לציין בית של סוג מחיצה, בתבנית הקסדצימאלית, עבור המחיצה. אם לא מצוין בית של סוג מחיצה בדיסק MBR, הפקודה create partition primary יוצרת מחיצה מסוג ‎0x6. ניתן לציין כל בית של סוג מחיצה עם הפרמטר ID=byte | GUID. הפקודה DiskPart אינה בודקת את חוקיות הבית של סוג המחיצה ואינה מבצעת כל בדיקה של הפרמטר ID.

בדיסקים מסוג GPT באפשרותך לציין GUID של סוג מחיצה עבור המחיצה שברצונך ליצור:
  • מחיצת מערכת EFI‏: c12a7328-f81f-11d2-ba4b-00a0c93ec93b
  • מחיצת Microsoft reserved‏: e3c9e316-0b5c-4db8-817d-f92df00215ae
  • MSDATA partition‏: ebd0a0a2-b9e5-4433-87c0-68b6b72699c7
  • LDM Metadata partition on a dynamic disk‏: 5808c8aa-7e8f-42e0-85d2-e1e90434cfb3
  • LDM Data partition on a dynamic disk‏: af9b60a0-1431-4f62-bc68-3311714a69ad

אם לא מצוין GUID של סוג מחיצה, הפקודה create partition primary יוצרת מחיצה מסוג MSDATA. ניתן לציין כל סוג מחיצה עם הפרמטר ID={byte | GUID}. הפקודה DiskPart אינה בודקת את חוקיות GUID המחיצה ואינה מבצעת כל בדיקה אחרת של הפרמטר ID.

noerr
פרמטר זה מיועד ל- Scripting בלבד. כאשר הפקודה נתקלת בשגיאה, פרמטר זה מציין כי DiskPart תמשיך לעבד את הפקודות כאילו לא אירעה שגיאה. ללא הפרמטר noerr הופעת שגיאה תגרום לפקודה DiskPart לצאת עם קוד שגיאה.

create volume raid

פקודה זו יוצרת אמצעי אחסון מסוג RAID-5 בדיסקים דינאמיים שצוינו. לאחר יצירת אמצעי האחסון, המוקד עובר אוטומטית לאמצעי האחסון החדש.

תחביר

create volume raid [size=n] [disk=n[,[n,…]] [noerr]‎

פרמטרים

size=n
פרמטר זה מציין את כמות השטח בדיסק, במגה-בתים (MB), שאותו ימלא אמצעי האחסון בכל דיסק. אם לא מצוין גודל, ייווצר אמצעי האחסון מסוג RAID-5 הגדול ביותר האפשרי. הדיסק בעל השטח הפנוי הרציף הזמין הקטן ביותר קובע את גודל אמצעי האחסון מסוג RAID-5 ואותה כמות של שטח מוקצית לכל דיסק. הכמות המעשית של שטח הדיסק המנוצל באמצעי אחסון מסוג RAID-5 קטנה יותר מאשר הכמות הכוללת של שטח הדיסק משום שחלק משטח הדיסק נחוץ לזוגיות.
disk=n
פרמטר זה מציין את הדיסקים הדינאמיים בהם ייווצר אמצעי האחסון. בכל דיסק מוקצית כמות שטח השווה ל size=n.
noerr
פרמטר זה מיועד ל- Scripting בלבד. כאשר הפקודה נתקלת בשגיאה, פרמטר זה מציין כי DiskPart תמשיך לעבד את הפקודות כאילו לא אירעה שגיאה. ללא הפרמטר noerr הופעת שגיאה תגרום לפקודה DiskPart לצאת עם קוד שגיאה.

create volume simple

פקודה זו יוצרת אמצעי אחסון פשוט. לאחר יצירת אמצעי האחסון, המוקד עובר אוטומטית לאמצעי האחסון החדש.

תחביר

create volume simple [size=n] [disk=n] [noerr]‎

פרמטרים

size=n
פרמטר זה מציין את גודל המחיצה במגה-בתים (MB). אם לא צוין גודל, אמצעי האחסון החדש ממלא את השטח הפנוי שנותר בדיסק.
disk=n
פרמטר זה מציין את הדיסק הדינאמי בו ייווצר אמצעי האחסון. אם לא צוין דיסק, ייעשה שימוש בדיסק הנוכחי.
noerr
פרמטר זה מיועד ל- Scripting בלבד. כאשר הפקודה נתקלת בשגיאה, פרמטר זה מציין כי DiskPart תמשיך לעבד את הפקודות כאילו לא אירעה שגיאה. ללא הפרמטר noerr הופעת שגיאה תגרום לפקודה DiskPart לצאת עם קוד שגיאה.

create volume stripe

פקודה זו יוצרת אמצעי אחסון מפוצל בדיסקים שצוינו. לאחר יצירת אמצעי האחסון, המוקד עובר אוטומטית לאמצעי האחסון החדש.

תחביר

create volume stripe [size=n] [disk=n[,[n,…]] [noerr]‎

פרמטרים

size=n
פרמטר זה מציין את כמות השטח בדיסק, במגה-בתים (MB), שאותה ימלא אמצעי האחסון בכל דיסק. אם לא צוין גודל, אמצעי האחסון החדש ממלא את שאר השטח הפנוי בדיסק הקטן ביותר וכמות זהה של שטח בכל דיסק לאחר מכן.
disk=n
פרמטר זה מציין את הדיסקים הדינאמיים בהם ייווצר אמצעי האחסון. כמות שטח השווה ל- size=n מוקצית בכל דיסק.
noerr
פרמטר זה מיועד ל- Scripting בלבד. כאשר הפקודה נתקלת בשגיאה, פרמטר זה מציין כי DiskPart תמשיך לעבד את הפקודות כאילו לא אירעה שגיאה. ללא הפרמטר noerr הופעת שגיאה תגרום לפקודה DiskPart לצאת עם קוד שגיאה.

delete disk

פקודה זו מוחקת דיסק דינאמי חסר מרשימת הדיסקים.

תחביר

delete disk [noerr] [override]‎

פרמטרים

noerr
פרמטר זה מיועד ל- Scripting בלבד. כאשר הפקודה נתקלת בשגיאה, פרמטר זה מציין כי DiskPart תמשיך לעבד את הפקודות כאילו לא אירעה שגיאה. ללא הפרמטר noerr הופעת שגיאה תגרום לפקודה DiskPart לצאת עם קוד שגיאה.
override
פרמטר זה מאפשר לפקודה DiskPart למחוק את כל אמצעי האחסון הפשוטים בדיסק. אם הדיסק מכיל חצי אמצעי אחסון שעבר שיקוף, חציו של השיקוף נמחק מהדיסק. הפקודה delete disk override נכשלת אם הדיסק הוא חבר באמצעי אחסון מסוג RAID-5.

delete partition

פקודה זו, בדיסק בסיסי, מוחקת מחיצה עם מוקד. לא ניתן למחוק את מחיצת המערכת, מחיצת האתחול או כל מחיצה אחרת המכילה את קובץ ההחלפה הפעיל או קובץ Dump לקריסה (קובץ Dump של זיכרון).

שים לב

  • מחיקת מחיצה בדיסק דינאמי עשויה למחוק את כל אמצעי האחסון הדינאמיים הלא מקוונים בדיסק, ובכך להרוס את הנתונים ולהמיר את הדיסק לדיסק בסיסי. כדי למחוק אמצעי אחסון דינאמי, השתמש תמיד בפקודה delete volume.

ניתן למחוק מחיצות מדיסקים דינאמיים, אולם אין ליצור אותן. לדוגמה, ניתן למחוק מחיצה מסוג טבלת מחיצות של GUID‏ (GPT) בלתי מוכרת מדיסק דינאמי מסוג GPT. מחיקה של מחיצה מסוג זה אינה הופכת את השטח הפנוי שנוצר לזמין. פקודה זו מיועדת במיוחד כדי לאפשר תיקון של השטח בדיסק דינאמי לא-מקוון פגום במצב חירום, בו לא ניתן להשתמש בפקודה clean.

תחביר

delete partition [noerr] [override]‎

פרמטרים

noerr
פרמטר זה מיועד ל- Scripting בלבד. כאשר הפקודה נתקלת בשגיאה, פרמטר זה מציין כי DiskPart תמשיך לעבד את הפקודות כאילו לא אירעה שגיאה. ללא הפרמטר noerr הופעת שגיאה תגרום לפקודה DiskPart לצאת עם קוד שגיאה.
override
פרמטר זה מאפשר לפקודה DiskPart למחוק כל מחיצה מכל סוג. בדרך כלל, הפקודה DiskPart מאפשרת את מחיקתן של מחיצות נתונים מוכרות בלבד.

delete volume

פקודה זו מוחקת את אמצעי האחסון שנבחר. לא ניתן למחוק את אמצעי האחסון של המערכת‏, את אמצעי האחסון לאתחול או כל אמצעי אחסון אחר המכיל את קובץ ההחלפה הפעיל או קובץ Dump לקריסה (קובץ Dump של זיכרון).

תחביר

delete volume [noerr]‎

פרמטר

noerr
פרמטר זה מיועד ל- Scripting בלבד. כאשר הפקודה נתקלת בשגיאה, פרמטר זה מציין כי DiskPart תמשיך לעבד את הפקודות כאילו לא אירעה שגיאה. ללא הפרמטר noerr הופעת שגיאה תגרום לפקודה DiskPart לצאת עם קוד שגיאה.

detail disk

פקודה זו מציגה את התכונות של הדיסק שנבחר ואמצעי האחסון בדיסק.

תחביר

detail disk

detail volume

פקודה זו מציגה את הדיסקים בהם שוכן אמצעי האחסון הנוכחי.

תחביר

detail volume

exit

פקודה זו יוצאת ממפענח הפקודה של DiskPart.

תחביר

exit

extend

פקודה זו מרחיבה את אמצעי האחסון עם המוקד לשטח הרציף הלא מוקצה הבא. עבור אמצעי אחסון בסיסיים, השטח הלא מוקצה חייב להיות באותו דיסק יחד עם המחיצה עם המוקד וחייב להיות הבא אחריה (להיות בהיסט סקטור גבוה יותר). ניתן להרחיב אמצעי אחסון דינאמי פשוט או מורחב לכל שטח ריק בכל דיסק דינאמי. על-ידי שימוש בפקודה זו, באפשרותך להרחיב אמצעי אחסון קיים לשטח שנוצר לאחרונה.

אם המחיצה אותחלה לפני כן באמצעות מערכת הקבצים NTFS, מערכת הקבצים מורחבת אוטומטית כך שתמלא את המחיצה הגדולה יותר. לא נגרם כל אובדן נתונים. אם המחיצה אותחלה לפני כן בתבנית מערכת קבצים אחרת מאשר NTFS, הפקודה נכשלת מבלי לבצע שינוי במחיצה.

אין באפשרותך להרחיב את מחיצת המערכת או האתחול הנוכחית.

תחביר

extend [size=n] [disk=n] [noerr]‎

פרמטרים

size=n
פרמטר זה מציין את כמות השטח, במגה-בתים (MB), שיש להוסיף למחיצה הנוכחית. אם לא הוגדר גודל, הדיסק מורחב כך שימלא את כל השטח הרציף הלא-מוקצה הסמוך.
disk=n
פרמטר זה מציין את הדיסק הדינאמי שבו יש להרחיב את אמצעי האחסון. כמות שטח השווה ל- size=n מוקצית בדיסק. אם לא צוין דיסק, אמצעי האחסון מורחב בדיסק הנוכחי.
noerr
פרמטר זה מיועד ל- Scripting בלבד. כאשר הפקודה נתקלת בשגיאה, פרמטר זה מציין כי DiskPart תמשיך לעבד את הפקודות כאילו לא אירעה שגיאה. ללא הפרמטר noerr הופעת שגיאה תגרום לפקודה DiskPart לצאת עם קוד שגיאה.

help

פקודה זו מציגה רשימה של הפקודות הזמינות.

תחביר

help

import

פקודה זו מייבאת קבוצת דיסק זרה לקבוצת הדיסק במחשב המקומי. הפקודה import מייבאת כל דיסק הנמצא באותה קבוצה של הדיסק בעל המוקד.

תחביר

import [noerr]‎

פרמטר

noerr
פרמטר זה מיועד ל- Scripting בלבד. כאשר הפקודה נתקלת בשגיאה, פרמטר זה מציין כי DiskPart תמשיך לעבד את הפקודות כאילו לא אירעה שגיאה. ללא הפרמטר noerr הופעת שגיאה תגרום לפקודה DiskPart לצאת עם קוד שגיאה.

list disk

פקודה זו מציגה רשימה של דיסקים ומידע אודותיהם, כגון גודלם, כמות השטח הפנוי המצוי בהם, האם הדיסק הוא דיסק בסיסי או דיסק דינאמי והאם הדיסק משתמש בסגנון המחיצה רשומת אתחול ראשית (MBR) או בסגנון המחיצה טבלת מחיצות של GUID‏ (GPT). הדיסק המסומן בכוכבית (*) הוא בעל המוקד.

תחביר

list disk

list partition

פקודה זו מציגה את המחיצות הרשומות בטבלת המחיצות בדיסק הנוכחי. בדיסקים דינאמיים, מחיצות אלה עשויות שלא להתאים לאמצעי האחסון הדינאמיים בדיסק זה. חוסר התאמה זה נובע מכך שדיסקים דינאמיים מכילים ערכים בטבלת המחיצות עבור אמצעי האחסון של המערכת או אמצעי האחסון לאתחול (אם קיים בדיסק) ומחיצה הממלאת את שאר הדיסק כדי לשמור את השטח לשימושם של אמצעי אחסון דינאמיים.

תחביר

list partition

list volume

פקודה זו מציגה רשימה של אמצעי אחסון בסיסיים ודינאמיים בכל הדיסקים.

תחביר

list volume

online

פקודה זו מעלה דיסק או אמצעי אחסון לא מכוון בעל מוקד למצב מקוון.

תחביר

online [noerr]‎

פרמטר

noerr
פרמטר זה מיועד ל- Scripting. כאשר הפקודה נתקלת בשגיאה, פרמטר זה מציין כי DiskPart תמשיך לעבד את הפקודות כאילו לא אירעה שגיאה. ללא הפרמטר noerr הופעת שגיאה תגרום לפקודה DiskPart לצאת עם קוד שגיאה.

rem

פקודה זו מספקת דרך להוספת הערות בקובץ Script.

תחביר

rem

דוגמאות

rem These commands set up 3 drives.‎

create partition primary size=2048

assign d:‎

create partition extend

create partition logical size=2048

assign e:‎

create partition logical

assign f:‎

remove

פקודה זו מסירה אות כונן או נקודת טעינה מאמצעי האחסון בעל המוקד. אם נעשה שימוש בפרמטר all, כל אותיות הכונן ונקודות הטעינה הנוכחיות מוסרות. אם לא מצוינת כל אות כונן או נקודת טעינה, הפקודה DiskPart מסירה את אות הכונן או את נקודת הטעינה הראשונה בה היא נתקלת.

ניתן להשתמש בפקודה remove כדי לשנות את אות הכונן המשויכת לכונן נשלף. אין באפשרותך להסיר את אות הכונן באמצעי אחסון של מערכת, באמצעי אחסון לאתחול או באמצעי אחסון להחלפה. בנוסף, אין באפשרותך להסיר את אות הכונן של מחיצה של יצרן ציוד מקורי (OEM), של כל מחיצת GPT בעלת GUID בלתי מזוהה או של כל המחיצות מסוג GPT המיוחדות, שאינן מחיצות נתונים, כגון מחיצות המערכת EFI.

תחביר

remove [{letter=d|mount=Path [all]}] [noerr]‎

פרמטרים

letter=d
פרמטר זה מציין את אות הכונן שתוסר.
mount=Path
פרמטר זה מציין את נקודת הטעינה שתוסר.
all
פרמטר זה מסיר את כל אותיות הכונן ונקודות הטעינה הנוכחיות.
noerr
פרמטר זה מיועד ל - Scripting בלבד. כאשר הפקודה נתקלת בשגיאה, פרמטר זה מציין כי DiskPart תמשיך לעבד את הפקודות כאילו לא אירעה שגיאה. ללא הפרמטר noerr הופעת שגיאה תגרום לפקודה DiskPart לצאת עם קוד שגיאה.

rescan

פקודה זו מאתרת דיסקים חדשים שאולי נוספו למחשב.

תחביר

rescan

retain

פקודה זו מכינה אמצעי אחסון פשוט דינאמי קיים לשימוש כאמצעי אחסון לאתחול או כאמצעי אחסון של מערכת.

במחשבים מבוססי-x86 פקודה זו יוצרת ערך מחיצה במחיצת רשומת אתחול ראשית (MBR) באמצעי האחסון הדינאמי הפשוט בעל המוקד. כדי ליצור מחיצת MBR, על אמצעי האחסון הפשוט הדינאמי להתחיל בהיסט מיושר גליל ולהתפרס על מספר שלם של גלילים מבחינת גודלו.

במחשב מבוסס Itanium, פקודה זו יוצרת ערך מחיצה בטבלת מחיצות של GUID‏ (GPT) באמצעי אחסון פשוט דינאמי בעל מוקד.

הערה

  • הפקודה retain מיועדת לשימוש רק במהלך התקנה ללא התערבות או על-ידי יצרני ציוד מקוריים (OEM).

תחביר

retain

select disk

פקודה זו בוחרת את הדיסק שצוין ומעבירה אליו את המוקד.

תחביר

select disk=[n]‎

פרמטרים

n
פרמטר זה מציין את מספר הדיסק של הדיסק שיקבל מוקד. אם לא צוין מספר דיסק, הפקודה select מציינת את הדיסק הנוכחי עם המוקד. באפשרותך להציג את המספרים של כל הדיסקים במחשב באמצעות הפקודה list disk.

select partition

פקודה זו מציינת מחיצה ונותנת לה מוקד. אם לא צוינה מחיצה, הפקודה select מציינת את המחיצה הנוכחית עם מוקד. באפשרותך להציג את מספרי כל המחיצות בדיסק הנוכחי באמצעות הפקודה list partition.

תחביר

select partition=[{n|d}]‎

פרמטרים

n
פרמטר זה מציין את מספר המחיצה שתקבל את המוקד.
d
פרמטר זה מציין את אות הכונן או את נתיב נקודת הטעינה של המחיצה שתקבל את המוקד.

select volume

פקודה זו בוחרת את אמצעי האחסון שצוין ומעבירה אליו את המוקד. אם לא צוין אמצעי אחסון, הפקודה select מציינת את אמצעי האחסון הנוכחי בעל המוקד. באפשרותך לציין את אמצעי האחסון לפי מספר, אות כונן או נתיב נקודת טעינה. בדיסק בסיסי, בחירת אמצעי אחסון מעניקה מוקד גם למחיצה המתאימה לו. באפשרותך להציג את מספרי כל אמצעי האחסון במחשב באמצעות הפקודה list volume.

תחביר

select volume=[{n|d}]‎

פרמטרים

n
פרמטר זה מציין את מספר אמצעי האחסון שיקבל את המוקד.
d
פרמטר זה מציין את אות הכונן או נתיב נקודת הטעינה של אמצעי האחסון שיקבל את המוקד.

Scripting של DiskPart

באמצעות DiskPart, באפשרותך ליצור קבצי Script כדי להפוך משימות הקשורות בדיסק לאוטומטיות, כגון יצירת אמצעי אחסון או המרת דיסקים לדיסקים דינאמיים. Scripting של משימות אלה יעיל אם ברצונך לפרוס את Windows באמצעות התקנה ללא התערבות או Sysprep, אשר אינם תומכים ביצירת אמצעי אחסון אחרים מלבד אמצעי אחסון לאתחול.

כדי להפעיל קובץ Script של הפקודה DiskPart, בשורת הפקודה, הקלד:

DiskPart /S scriptname.txt

כאשר scriptname.txt הוא שם קובץ הטקסט המכיל את ה- Script.

כדי לנתב מחדש את הפלט של פעולת ה- Scripting של הפקודה DiskPart לקובץ, הקלד:

DiskPart /S scriptname.txt > logfile.txt

כאשר logfile.txt הוא שם קובץ הטקסט אליו כותבת הפקודה DiskPart את הפלט שלה.

כאשר הפקודה DiskPart מופעלת, הגירסה של DiskPart ושם המחשב מוצגים בשורת הפקודה. כברירת מחדל, אם הפקודה DiskPart נתקלת בשגיאה במהלך הניסיון לבצע משימות של Script, הפקודה DiskPart מפסיקה את עיבודו של ה- Script ומציגה קוד שגיאה (אלא אם כן ציינת את הפרמטר noerr). עם זאת, הפקודה DiskPart תמיד מחזירה שגיאות כאשר היא נתקלת בשגיאות תחביר, גם אם השתמשת בפרמטר noerr. הפרמטר noerr מאפשר לך לבצע משימות יעילות כגון שימוש ב- Script אחד לשם מחיקת כל המחיצות בכל הדיסקים בלי קשר למספר הדיסקים הכולל.

הטבלה שלהלן מציגה את קודי השגיאה של הפקודה DiskPart:

שגיאה | תיאור
0 | לא אירעה כל שגיאה. ה- Script כולו פעל ללא כשל.
1 | אירעה חריגה חמורה. עשויות להיות בעיות רציניות.
2 | הפרמטרים שצוינו עבור פקודה של DiskPart לא היו נכונים.
3 | ל- DiskPart לא היתה אפשרות לפתוח את קובץ ה- Script או קובץ הפלט שצוין.
4 | אחד מהשירותים בהם משתמשת הפקודה DiskPart החזיר כשל.
5 | אירעה שגיאת תחביר פקודה. קובץ ה- Script נכשל משום שאובייקט לא נבחר כהלכה או היה לא חוקי לשימוש עם פקודה זו.


Dos

פקודה זו מציינת כי על מערכת המשנה MS-DOS לשמור על קישור לאזור הזיכרון הגבוה (UMA) או לטעון חלק מעצמה לאזור הזיכרון הגבוה (HMA).

תחביר

dos={high|low}[{,umb|,noumb}]‎

dos={[high,|low,}]{umb|noumb}‎

פרמטרים

{high|low}
פרמטר זה מציין אם על מערכת המשנה MS-DOS לנסות לטעון חלק מעצמה לתוך אזור הזיכרון הגבוה (HMA). השתמש בפרמטר high כדי לאפשר למערכת המשנה MS-DOS לטעון את עצמה לאזור הזיכרון הגבוה (HMA). השתמש בפרמטר low כדי לשמור את כל מערכת המשנה MS-DOS בזיכרון הרגיל. הגדרת ברירת המחדל היא low.
{umb|noumb}
פרמטר זה מציין אם על מערכת המשנה MS-DOS לשמור על קישור בין הזיכרון הרגיל לבין אזור הזיכרון הגבוה (UMA). הפרמטר Umb מספק קישור זה. הפרמטר noumb מנתק קישור זה. הגדרת ברירת המחדל היא noumb.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • התקנת הקובץ Himem.sys עבור dos=umb או dos=high

    עליך להתקין את מנהל ההתקן Himem.sys לפני שתציין את dos=umb או את dos=high.

  • שימוש ב- umb

    עליך לציין את dos=umb לשם טעינת תוכניות ומנהלי התקנים לאזור הזיכרון הגבוה (UMA). שימוש ב- UMA מפנה שטח נוסף בזיכרון הרגיל עבור תוכניות. בנוסף, עליך להתקין ספק של בלוק זיכרון גבוה (UMB).

  • שימוש בפרמטר high

    אם תציין את הפרמטר high, מערכת המשנה MS-DOS תנסה לטעון חלק מעצמה לאזור הזיכרון הגבוה (HMA). טעינת חלק ממערכת המשנה MS-DOS לאזור הזיכרון הגבוה (HMA) תשחרר זיכרון רגיל עבור תוכניות.

  • שילוב פרמטרים

    אם תציין את הפרמטר high, מערכת המשנה MS-DOS תנסה לטעון חלק מעצמה לאזור הזיכרון הגבוה (HMA). על-ידי טעינת חלק ממערכת המשנה MS-DOS ל- HMA, ישוחרר זיכרון רגיל עבור תוכניות.

    באפשרותך לכלול יותר מפרמטר אחד בשורת פקודה בודדת של dos ולהשתמש בפסיקים כדי להפריד בין הפרמטרים. לדוגמה, התחבירים הבאים חוקיים:

    dos=umb,low
    dos=high,umb

    באפשרותך למקם את הפקודה dos בכל מקום בקובץ Config.nt או בקובץ הפעלה שווה ערך.


פקודות של מערכת המשנה MS-DOS

מערכת ההפעלה Windows XP כוללת פקודות 16-סיביות (לא מקוריות) עבור מערכת המשנה MS-DOS ועבור מערכות משנה אחרות. פקודות אלה כוללות פקודות ישנות, כגון edlin או graphics, ופקודות הספציפיות למערכת המשנה MS-DOS, כגון debug או exe2bin. פקודות 16-סיביות אלה כלולות כדי לשמור על תאימות מערכת המשנה MS-DOS ו- MS OS/2 גירסה ‎1.x.

פקודות אחרות של מערכת המשנה MS-DOS , כגון share, מבצעות פונקציות הכלולות כעת במערכת ההפעלה Windows XP או במערכת המשנה MS-DOS. הפקודות מתקבלות במטרה לשמור על תאימות עם קבצים קיימים, אולם אין להן השפעה בשורת הפקודה משום שהפונקציונליות היא אוטומטית.

הערה

  • פקודות 16-הסיביות הבאות של מערכת המשנה MS-DOS אינן זמינות במהדורת 64 סיביות של Windows XP.

לקבלת מידע נוסף, לחץ על פקודה:

  • Append
  • Debug
  • פקודות משנה של Debug
  • Edit
  • Edlin
  • פקודות משנה של Edlin
  • Exe2bin
  • Fastopen
  • Forcedos
  • Graphics
  • Loadfix
  • Loadhigh (lh)‎
  • Mem
  • Nlsfunc
  • Setver
  • Share

כדי לקבוע את תצורת מערכת המשנה MS-DOS השתמש בפקודות תצורה, כגון device או lastdrive. מקם פקודות אלה בקובץ Config.nt בספריה systemroot\System32 או בקובץ Config שצוין על-ידי קובץ מידע התוכנית (PIF) של היישום. פקודות אלה משפיעות על מערכת המשנה MS-DOS בלבד. מערכת המשנה MS-DOS מתעלמת מרבות מפקודות אלה, כגון buffers ו- break, משום שמערכת המשנה MS-DOS פועלת בלעדיהן. פקודות אלה מתקבלות לצורך תאימות בלבד.

לקבלת מידע נוסף אודות פקודות תצורה של מערכת המשנה MS-DOS לחץ על פקודה:

  • Buffers
  • Country
  • Device
  • Devicehigh
  • Dos
  • Dosonly
  • Driveparm
  • Echoconfig
  • Fcbs
  • Files
  • Install
  • Lastdrive
  • Ntcmdprompt
  • Shell
  • Stacks
  • Switches


Doskey

פקודה זו קוראת לתוכנית Doskey.exe, המאחזרת פקודות של Windows XP, עורכת שורות פקודה ויוצרת פקודות מאקרו.

תחביר

doskey {/reinstall |‎ ‎/listsize=size |‎ ‎/macros:[{all | exename}‎]‎ |‎ ‎/history |‎ ‎/insert | /overstrike |‎ ‎/exename=exename |‎ ‎/macrofile=FileName |‎ macroname=[text]‎}‎

פרמטרים

‎/reinstall
פרמטר זה מתקין עותק חדש של Doskey.exe. הפרמטר מנקה את מאגר ההיסטוריה של הפקודות.
‎/listsize=size
קביעת מספר הפקודות המירבי במאגר ההיסטוריה.
‎/macros
פרמטר זה מציג רשימה של כל פקודות המאקרו של doskey. באפשרותך להשתמש בסימן הניתוב מחדש (‎>‎) עם הפרמטר ‎/macros כדי לנתב מחדש את הרשימה לקובץ. באפשרותך לקצר את הפרמטר ‎/macros ל- ‎/m.
all
פרמטר זה מציג את פקודות המאקרו של doskey עבור כל קבצי ההפעלה.
exename
פרמטר זה מציג פקודות מאקרו של doskey עבור קובץ ההפעלה שצוין.
‎/history
פרמטר זה מציג את כל הפקודות שאוחסנו בזיכרון. באפשרותך להשתמש בסימן ניתוב מחדש (‎>‎) עם הפרמטר ‎/history כדי לנתב מחדש את הרשימה לקובץ. באפשרותך לקצר את הפרמטר ‎/history ל- ‎/h.
{‎/insert | /overstrike}
פרמטר זה מציין אם טקסט חדש שהוקלד יחליף טקסט ישן. אם תשתמש בפרמטר ‎/insert, טקסט חדש שתקליד בשורה יצורף לטקסט ישן (כלומר, כאילו הקשת על מקש INSERT). אם תשתמש בפרמטר ‎/overstrike, טקסט חדש יחליף טקסט ישן. הגדרת ברירת המחדל היא ‎/overstrike.
‎/exename=exename
פרמטר זה מציין את התוכנית (כלומר, את קובץ ההפעלה) שבה פועלת פקודת המאקרו doskey.
‎/macrofile=FileName
פרמטר זה מציין קובץ המכיל פקודות מאקרו שברצונך להתקין.
macroname=[text]‎
יצירת מאקרו המבצע את הפקודות שצוינו על-ידי text. הפרמטר macroname מציין את השם שברצונך להקצות למאקרו. הפרמטר Text מציין את הפקודות שברצונך לרשום. אם הפרמטר text נשאר ריק, מתבצע ניקוי של כל הפקודות שהוקצו ל- macroname.
‎/?‎
פרמטר זה מציג עזרה בשורת הפקודה.

הערות

  • שימוש ב- Doskey.exe

    Doskey.exe זמינה תמיד עבור כל התוכניות האינטראקטיביות המבוססות על תווים (כגון תוכניות איתור באגים או תוכניות העברת קבצים) ושומרת מאגר היסטוריה של פקודות ופקודות מאקרו עבור כל תוכנית אותה היא מפעילה. אין באפשרותך להשתמש באפשרויות שורת פקודה של doskey מתוך תוכנית; יש להפעיל אפשרויות שורת פקודה של doskey לפני הפעלת תוכנית. הקצאות מקש של תוכנית עוקפות הקצאות מקש של doskey.

  • אחזור פקודה

    כדי לאחזר פקודה, באפשרותך להשתמש בכל אחד מהמקשים הבאים לאחר הפעלת Doskey.exe. אם נעשה שימוש ב- Doskey.exe בתוך תוכנית, הקצאות המקשים של התוכנית השניה מקבלות קדימות.

    מקש | תיאור
    חץ למעלה | אחזור הפקודה בה השתמשת לפני הפקודה המוצגת.
    חץ למטה | אחזור הפקודה בה השתמשת לאחר הפקודה המוצגת.
    PAGE UP | אחזור הפקודה המוקדמת ביותר בה השתמשת בהפעלה הנוכחית.
    PAGE DOWN | אחזור הפקודה האחרונה בה השתמשת.
  • עריכה של שורת הפקודה

    באמצעות Doskey.exe, באפשרותך לערוך את שורת הפקודה הנוכחית. בעת שימוש ב- Doskey.exe בתוך תוכנית, הקצאות המקשים של תוכנית זו מקבלות קדימות ומקשי עריכה מסוימים של Doskey.exe עשויים שלא לפעול.

    הטבלה שלהלן מציינת את מקשי העריכה של doskey ואת הפונקציות שלהם.

    מקש או צירוף מקשים | תיאור
    חץ שמאלה | העברת נקודת הכניסה בתו אחד אחורה.
    חץ ימינה | העברת נקודת הכניסה בתו אחד קדימה.
    CTRL+חץ שמאלה | העברת נקודת הכניסה במילה אחת אחורה.
    CTRL+חץ ימינה | העברת נקודת הכניסה במילה אחת קדימה.
    HOME | העברת נקודת הכניסה לתחילת השורה.
    END | העברת נקודת הכניסה לסוף השורה.
    ESC | ניקוי הפקודה מהתצוגה.
    F1 | העתקת תו אחד מעמודה בתבנית לאותה עמודה בחלון שורת הפקודה (התבנית היא מאגר זיכרון המכיל את הפקודה האחרונה שהקלדת).
    F2 | ביצוע חיפוש קדימה בתבנית אחר המקש הבא עליו תקיש לאחר הקשת F2. Doskey.exe מוסיפה את הטקסט מהתבנית עד לתו שציינת, לא כולל.
    F3 | העתקת שארית התבנית לשורת הפקודה. Doskey.exe מתחילה להעתיק תווים מהמיקום בתבנית התואם למיקום שצוין על-ידי נקודת הכניסה בשורת הפקודה.
    F4 | מחיקת תווים מהמיקום הנוכחי של נקודת הכניסה עד התו שציינת. כדי להשתמש במקש עריכה זה, הקש F4 והקלד תו. Doskey.exe תמחק את התווים מהמיקום הנוכחי של נקודת הכניסה עד האות הראשונה שצוינה.
    F5 | העתקת התבנית לשורת הפקודה הנוכחית.
    F6 | הצבת תו סוף קובץ (כלומר, CTRL+Z) במיקום הנוכחי של נקודת הכניסה.
    F7 | הצגת כל הפקודות עבור תוכנית זו המאוחסנות בזיכרון בתיבה מוקפצת. השתמש במקש חץ למעלה ובמקש חץ למטה כדי לבחור את הפקודה הרצויה והקש ENTER כדי להפעיל את הפקודה. כמו כן, באפשרותך לציין את המספר הרציף לפני הפקודה ולהשתמש במספר זה בצירוף עם מקש F9.
    ALT+F7 | מחיקת כל הפקודות המאוחסנות בזיכרון עבור מאגר ההיסטוריה הנוכחי.
    F8 | הצגת כל הפקודות במאגר ההיסטוריה המתחילות בתווים בפקודה הנוכחית.
    F9 | הצגת בקשה למספר הפקודה של מאגר היסטוריה ולאחר מכן הצגת הפקודה המשויכת למספר שציינת. הקש ENTER להפעלת הפקודה. לשם הצגת כל המספרים והפקודות המשויכות להם, הקש F7.
    ALT+F10 | מחיקה של כל הגדרות המאקרו.
  • שימוש ב- Doskey בתוך תוכנית

    תוכניות אינטראקטיביות מסוימות המבוססות על תווים, כגון תוכניות איתור באגים או תוכניות העברת קבצים (FTP), משתמשות ב- Doskey.exe באופן אוטומטי. כדי להשתמש ב- Doskey.exe, על התוכנית להיות תהליך מסוף ולהשתמש בקלט מאוחסן במאגר. הקצאות מקשים של תוכנית עוקפות את הקצאות המקשים של doskey. לדוגמה, אם התוכנית משתמשת במקש F7 עבור פונקציה מסוימת, לא תהיה אפשרות לקבל היסטוריית פקודות של doskey בחלון מוקפץ.

    באמצעות Doskey.exe באפשרותך לשמור היסטוריה של פקודות עבור כל תוכנית שתפעיל, לחזור ולערוך פקודות קודמות בשורת הפקודה של התוכנית ולהפעיל פקודות מאקרו של doskey שנוצרו עבור התוכנית. אם תצא מהתוכנית ולאחר מכן תפעיל אותה מחדש מאותו חלון שורת פקודה, היסטוריית הפקודה מההפעלה הקודמת של התוכנית תהיה זמינה.

    עליך להפעיל את Doskey.exe לפני שתפעיל תוכנית. אין באפשרותך להשתמש באפשרויות שורת פקודה של doskey משורת פקודה של תוכנית, גם אם בתוכנית קיימת פקודת מעטפת.

    אם ברצונך להתאים אישית את אופן הפעולה של Doskey.exe עם תוכנית כלשהי וליצור פקודות מאקרו של doskey עבור אותה תוכנית, באפשרותך ליצור תוכנית אצווה המשנה את Doskey.exe ומפעילה את התוכנית.

  • קביעת מצב הוספה המהווה ברירת מחדל

    אם תקיש על מקש INSERT, יהיה באפשרותך להקליד טקסט בשורת הפקודה של doskey באמצע טקסט ישן מבלי להחליף את הטקסט הישן. עם זאת, לאחר שתקיש ENTER, ‏Doskey.exe תחזיר את לוח המקשים למצב החלפה. עליך להקיש INSERT שוב כדי לחזור למצב הוספה.

    השתמש בפרמטר ‎/insert כדי להעביר את לוח המקשים למצב הוספה בכל פעם שתקיש ENTER. לוח המקשים יישאר במצב הוספה עד שתשתמש בפרמטר ‎/overstrike. באפשרותך לחזור למצב החלפה באופן זמני על-ידי הקשה על INSERT אך לאחר שתקיש ENTER, ‏Doskey.exe תחזיר את לוח המקשים למצב הוספה.

    נקודת הכניסה משנה צורה כאשר נעשה שימוש במקש INSERT למעבר ממצב אחד לשני.

  • יצירת מאקרו

    באפשרותך להשתמש ב- Doskey.exe ליצירת פקודות מאקרו המבצעות פקודה אחת או יותר. הטבלה שלהלן מציגה תווים מיוחדים בהם באפשרותך להשתמש כדי לשלוט בפעולות פקודה בעת הגדרת פקודה מאקרו.

    תו | תיאור
    ‎$G או ‎$g | ניתוב מחדש של פלט. השתמש בכל אחד מתווים מיוחדים אלה כדי לשלוח פלט להתקן או לקובץ במקום למסך. תו זה הוא שווה ערך לסימן הניתוב מחדש (‎>‎).
    ‎$G$G‎ או ‎$g$g‎ | תווים אלה מצרפים פלט לסוף קובץ. השתמש באחד מתווים כפולים מיוחדים אלה כדי לצרף פלט לקובץ קיים במקום להחליף את הנתונים בקובץ. תווים כפולים אלה מקבילים לסימן הניתוב מחדש צרף (‎>>‎) עבור פלט.
    ‎$L או ‎$l | ניתוב מחדש של קלט. השתמש באחד מתווים מיוחדים אלה כדי לקרוא קלט מהתקן או מקובץ במקום לקרוא קלט מלוח המקשים. תו זה שווה ערך לסימן הניתוב מחדש עבור קלט (‎<‎).
    ‎$B או ‎$b | שליחת פלט מאקרו לפקודה. השימוש באחד מתווים מיוחדים אלה מקביל לשימוש בתו | בשורת פקודה.
    ‎$T או ‎$t | הפרדת פקודות. השתמש באחד מתווים מיוחדים אלה כדי להפריד בין פקודות בעת יצירת פקודות מאקרו או הקלדת פקודות בשורת הפקודה של doskey. השימוש באחד מתווים מיוחדים אלה מקביל לשימוש בסימן אמפרסנד (&) בשורת פקודה.
    $$ קביעת תו סימן הדולר ($).
    $1 עד $9 | ייצוג מידע אודות שורת הפקודה שברצונך לציין בעת הפעלת המאקרו. התווים המיוחדים $1 עד $9 הם פרמטרי אצווה, דבר המאפשר שימוש בנתונים שונים בשורת הפקודה בכל פעם שאתה מפעיל את המאקרו. התו $1 בפקודה doskey דומה לתו %1 בתוכנית האצווה.
    ‎$*‎ תו זה מייצג את כל מידע שורת הפקודה שברצונך לציין בעת הקלדת שם פקודת המאקרו. התו המיוחד ‎$*‎ הוא פרמטר ניתן להחלפה הדומה לפרמטרי האצווה $1 עד $9, עם הבדל אחד חשוב: במקרה זה, כל מה שתקליד בשורת הפקודה לאחר שם פקודת המאקרו מוחלף בתו ‎$*‎ בפקודת המאקרו.
  • הפעלת פקודת מאקרו של doskey

    כדי להפעיל פקודת מאקרו, הקלד את שם פקודת המאקרו החל מהמיקום הראשון בשורת הפקודה. אם פקודת המאקרו הוגדרה באמצעות הפרמטר ‎$*‎ או אחד מפרמטרי האצווה $1 עד $9, השתמש ברווח לבן כדי להפריד בין פרמטרים. אין באפשרותך להפעיל פקודת מאקרו של doskey מתוכנית אצווה.

  • יצירת פקודת מאקרו עם שם זהה לפקודה של Windows XP

    אם אתה תמיד משתמש בפקודה מסוימת עם אפשרויות שורת פקודת ספציפיות, באפשרותך ליצור פקודת מאקרו בעלת אותו שם כמו הפקודה. כדי לציין אם ברצונך להפעיל את פקודת המאקרו או את הפקודה, עקוב אחר קווים מנחים אלה:

    • כדי להפעיל את המאקרו, התחל את הקלדת שם המאקרו מיד לאחר שורת הפקודה, ללא רווח בין שורת הפקודה ושם הפקודה.
    • כדי להפעיל את הפקודה, הוסף רווח לבן אחד או יותר בין שורת הפקודה לשם הפקודה.
  • מחיקת מאקרו

    כדי למחוק פקודת מאקרו, הקלד:

    doskey macroname=‎

דוגמאות

אפשרויות שורת הפקודה ‎/macros ו- ‎/history משמשות ליצירת תוכניות אצווה לשמירת פקודות מאקרו ופקודות אחרות. לדוגמה, כדי לאחסן את כל פקודות המאקרו הנוכחיות של doskey, הקלד:

doskey /macros > macinit

כדי להשתמש בפקודות המאקרו שאוחסנו ב- Macinit, הקלד:

doskey /macrofile=macinit

כדי ליצור תוכנית אצווה בשם Tmp.bat המכילה פקודות שבהן נעשה שימוש לאחרונה, הקלד:

doskey /history > tmp.bat

כדי להגדיר מאקרו עם פקודות מרובות, השתמש ב- ‎$t‎ כדי להפריד בין פקודות, כפי שמוצג להלן:

doskey tx=cd temp$tdir/w $*‎

בדוגמה הקודמת, פקודת המאקרו TX משנה את הספריה הנוכחית ל- Temp ולאחר מכן מציגה פירוט ספריה בתבנית תצוגה רחבה. באפשרותך להשתמש בפרמטר ‎$*‎ בסוף פקודת המאקרו כדי לצרף אפשרויות שורת פקודה אחרות לפקודה dir בעת הפעלת TX.

פקודת המאקרו הבאה משתמשת בפרמטר אצווה עבור שם חדש של ספריה:

doskey mc=md $1$tcd $1

פקודת המאקרו יוצרת תחילה ספריה חדשה ולאחר מכן עוברת אל ספריה זו מהספריה הנוכחית.

כדי להשתמש בפקודת המאקרו הקודמת לשם יצירת ספריה בשם Books ומעבר אליה, הקלד:

mc books

כדי ליצור פקודת מאקרו של doskey עבור תוכנית הנקראת Ftp.exe, כלול את הפרמטר ‎/exename כמפורט להלן:

doskey /exename:ftp.exe go=open 10.127.1.100$tmget *.TXT c:\reports$bye

כדי להשתמש בפקודת המאקרו הקודמת, הפעל את ftp. בשורת הפקודה של ftp הקלד:

go

התוכנית ftp מפעילה את הפקודות open‏, mget ו- bye.

כדי ליצור פקודת מאקרו המבצעת אתחול מהיר וללא התניה של דיסק, הקלד:

doskey qf=format $1 /q /u

כדי לאתחל דיסק בכונן A במהירות וללא התניה, הקלד:

qf a:‎


Dosonly

פקודה זו מונעת מהמשתמשים להפעיל יישומים מלבד יישומים מבוססי MS-DOS משורת הפקודה Command.com.

תחביר

dosonly

פרמטרים

ללא

הערות

  • בעת יציאה מיישום מבוסס MS-DOS, ‏Windows XP חוזר למפענח הפקודה, Cmd.exe. בעת הפעלת תוכנית שוכנת זיכרון (TSR) או בעת השהיה זמנית של יישום מבוסס MS-DOS כדי לחזור לשורת הפקודה, Windows XP מפעיל את מפענח הפקודה עבור סביבת MS-DOS, ‏Command.com. פעולה זו משמרת את סביבת MS-DOS ומאפשרת לך להשתמש ב- TSR מיידית.

    משום שאתחול והפעלה של יישומים מסוגים אחרים משורת הפקודה Command.com עשויים להפריע לתוכנית שוכנת זיכרון (TSR) או ליישום מבוסס MS-DOS מושעה, Windows XP מספק את הפקודה dosonly. באמצעות dosonly, באפשרותך להפעיל רק יישומים מבוססי MS-DOS משורת הפקודה Command.com. באפשרותך לכלול את הפקודה dosonly בקובץ Config.nt או בקובץ ההפעלה המותאם אישית המקביל בקובץ מידע התוכנית (PIF) של יישום.

  • הקובץ Config.nt משמש לאתחול של סביבת MS-DOS אלא אם כן תציין קובץ אתחול שונה בקובץ PIF של יישום.

דוגמאות

כלול את הפקודה dosonly בקובץ Config.nt או בקובץ ההפעלה Config שצוין בקובץ PIF. הדוגמה שלהלן מדגימה כיצד קובץ Config.nt עשוי להיראות.

dos=high,umb
device=‎%systemroot%‎\system32\himem.sys
files=40
‎@echo off
dosonly

נושאים קרובים


גרפיקה של Microsoft Windows

Driveparm

XOX

נושאים קרובים


Driverquery

הצגת רשימה של כל מנהלי ההתקנים המותקנים והמאפיינים שלהם.

תחביר

driverquery [‎/s Computer] [‎/u Domain\User ‎/p Password] ‎[/fo {TABLE|LIST|CSV}]‎ [‎/nh] [‎/v] ‎[/si]‎

פרמטרים

‎/s Computer
ציון שם או כתובת IP של מחשב מרוחק (אין להשתמש בקו נטוי הפוך). ברירת המחדל היא המחשב המקומי.
‎/u Domain\User
הפעלת הפקודה עם הרשאות החשבון של המשתמש שצוין באמצעות User או באמצעות Domain\User. ברירת המחדל היא ההרשאות של המשתמש הנוכחי במחשב המנפיק את הפקודה.
‎/p Password
ציון הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u .
‎/fo {TABLE|LIST|CSV}‎
ציון התבנית שבה יוצג המידע אודות מנהל ההתקן. הערכים החוקיים הם TABLE‏, LIST‏ ו- CSV. תבנית ברירת המחדל לפלט היא TABLE.
‎/nh
השמטת שורת הכותרת מהמידע המוצג אודות מנהל ההתקן. הפרמטר חוקי כאשר הפרמטר ‎/fo מוגדר כ- TABLE או CSV.
‎/v
פרמטר זה מציין כי יוצג מידע מפורט אודות מנהל ההתקן.
‎/si
הצגת מידע חתימה דיגיטלית עבור מנהלי התקנים חתומים ולא חתומים.
‎/?‎
הצגת עזרה בשורת הפקודה.

דוגמאות

הדוגמאות שלהלן מדגימות כיצד באפשרותך להשתמש בפקודה driverquery:

driverquery
driverquery /fo csv
driverquery /nh
driverquery /s ipaddress
driverquery /s server1 /u hirpln /v driverquery /s server1 /u maindom\hirpln /p p@ssw3d /fo list


Echo

פקודה זו מפעילה או מפסיקה את פעולתה של תכונת הד של פקודה, או מציגה הודעה. כאשר משתמשים בה ללא פרמטרים, הפקודה echo מציגה את הגדרות ההד הנוכחיות.

תחביר

echo [{on|off}] [message]‎

פרמטרים

{on|off}
קביעה אם להפעיל או להפסיק את הפעולה של תכונת ההד של פקודה.
message
ציון טקסט שאותו ברצונך להציג על-גבי המסך.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • הפקודה echo message יעילה כאשר ההד אינו מופעל. כדי להציג הודעה באורך מספר שורות מבלי להציג פקודות אחרות, באפשרותך לכלול מספר פקודות של echo message לאחר הפקודה echo off בקובץ האצווה.
  • אם תשתמש בפקודה echo off, שורת הפקודה לא תופיע על המסך. כדי להציג את שורת הפקודה, הקלד echo on.
  • כדי למנוע הדהוד של שורה, הכנס תו @ לפני פקודה בתוכנית אצווה.
  • כדי להפעיל הד של שורה ריקה במסך, הקלד:

    echo.‎

  • כדי להציג תו (|) או תו ניתוב מחדש (< או >) בעת שימוש בפקודה echo, השתמש בתו ^ מיד לפני תו | או תו הניתוב מחדש (לדוגמה, ‎^>‎‏, ‎^<‎‏, או ‎^|‎ ). אם עליך להשתמש בתו (^) עצמו, השתמש בשני תווים ברצף (^^).

דוגמאות

הדוגמה הבאה מציגה תוכנית אצווה הכוללת הודעה בת שלוש שורות שלפניה ואחריה מופיעה שורה ריקה:

echo off
echo.‎
echo This batch program
echo formats and checks
echo new disks
echo.‎

אם ברצונך להפסיק את פעולת ההד ואין ברצונך לבצע פעולת הד על הפקודה echo עצמה, כלול את הסימן (@) לפני הפקודה, כפי שמוצג להלן:

‎@echo off

באפשרותך להשתמש בפקודות if ו- echo באותה שורת פקודה. לדוגמה:

if exist *.rpt echo The report has arrived.‎


Echoconfig

הצגת הודעות במהלך עיבוד קבצי מידע התוכנית Config.nt ו- Autoexec.nt של מערכת המשנה MS-DOS. אם פקודה זו אינה קיימת, לא יוצגו הודעות.

פרמטרים

ללא

הערות

  • עליך להוסיף פקודה זו לקובץ Config.nt של מערכת המשנה MS-DOS. הדוגמה הבאה מציגה כיצד עשוי להראות קובץ Config.nt:

    dos=high,umb
    device=%systemroot%\system32\himem.sys
    files=40
    echoconfig

XOX

נושאים קרובים


Edit

הפעלת עורך MS-DOS, היוצר ומשנה קבצי טקסט מסוג ASCII. ללא פרמטרים, הפקודה edit מביאה להפעלת עורך MS-DOS.

תחביר

edit [[Drive:][Path] FileName] ‎[/b]‎ [‎/g] [‎/h] ‎[‎/nohi]‎

פרמטרים

‎[Drive:][Path] FileName‎
ציון המיקום והשם של קובץ טקסט מסוג ASCII. אם הקובץ אינו קיים, עורך MS-DOS יוצר אותו. אם הקובץ קיים, עורך MS-DOS פותח אותו ומציג את תוכנו במסך.
‎/b
הצגת עורך MS-DOS בשחור לבן. השתמש באפשרות שורת הפקודה הזו אם צג חד-צבעי אינו מציג את עורך MS-DOS כהלכה.
‎/g
שימוש בעדכון המסך המהיר ביותר האפשרי עבור צג מסוג CGA.
‎/h
הצגת מספר השורות המירבי שניתן להציג בצג הנוכחי.
‎/nohi
מתן אפשרות לשימוש בצגים בעלי שמונה צבעים עם עורך MS-DOS. בדרך כלל, Windows XP עושה שימוש ב- 16 צבעים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • XOX
  • צגים מסוימים עשויים שלא לתמוך בהצגה של מקשי קיצור כברירת מחדל. אם הצג אינו מציג מקשי קיצור, השתמש בבורר ‎/b (עבור צגים מסוג CGA) ובבורר ‎/nohi (עבור מערכות שאינן תומכות בתווים מודגשים).


Edlin

הפעלת Edlin.exe, עורך טקסט מונחה שורות בו באפשרותך להשתמש כדי ליצור ולשנות קבצי ASCII.

תחביר

edlin [Drive:][Path] FileName ‎[/b]‎

פרמטרים

‎[Drive:][Path] FileName
ציון המיקום והשם של קובץ ASCII בדיסק. הפרמטר Filename נדרש. אם הקובץ קיים, הקובץ Edlin.exe פותח אותו. אם הקובץ אינו קיים, הקובץ Edlin.exe יוצר קובץ בזיכרון ועושה שימוש במיקום ובשם הקובץ שצוינו כדי ליצור את הקובץ בדיסק בעת השימוש בפקודת המשנה e.
‎/b
קביעה שעל הקובץ Edlin.exe להתעלם מתו סוף הקובץ (CTRL+Z).
?
הצגת רשימה של פקודות משנה של edlin.

הערות

  • XOX
  • XOX
  • שימוש ב- Edlin.exe

    הקובץ Edlin.exe ממספר כל שורה בקובץ הטקסט הממוקם בזיכרון. באפשרותך להשתמש בקובץ Edlin.exe כדי להוסיף, לשנות, להעתיק, להעביר ולמחוק שורות בקובץ. אם ברצונך להשתמש בעורך של מסך מלא, השתמש בפקודה edit.

  • אורך שורה מירבי

    הקובץ Edlin.exe מקבל 253 תווים לכל היותר בכל שורה.

  • שימוש בפקודות המשנה של edlin

    קיימות מספר פקודות משנה של edlin בהן באפשרותך להשתמש. לקבלת מידע נוסף אודות פקודות משנה של edlin, ראה נושאים קרובים.

  • הכרת תו הכוכבית

    כאשר כוכבית מופיעה כתו היחידי בשורה, זוהי שורת הפקודה edlin *‎, שלאחריה מוקלדות פקודות משנה של edlin. כאשר כוכבית מופיעה לאחר מספר שורה בשורה, הדבר מצביע על כך שזוהי השורה בה ממוקמת נקודת הכניסה.

  • הצגת עמוד של טקסט

    עמוד של טקסט הוא מסך מלא אחד של מידע. במצב של מסך בעל 25 שורות, הקובץ Edlin.exe מציג 24 שורות של טקסט לכל עמוד. מספר השורות לכל עמוד תלוי במצב המסך בו נעשה שימוש.

  • הפעלה והפסקת הפעולה של מצב הוספה

    כדי להוסיף שורות לתוך הקובץ בזיכרון, השתמש בפקודת המשנה i‏ (insert). לאחר שסיימת את הוספת השורות, הקש ENTER ולאחר מכן CTRL+C כדי להפסיק את מצב ההוספה. לקבלת מידע נוסף אודות הוספת שורות באמצעות פקודת המשנה i‏ (insert), ראה נושאים קרובים.

  • מקשי עריכה

    קיימים מספר מפתחות עריכה בהם באפשרותך להשתמש כדי לערוך את הקובץ בזיכרון.


Edlin: a (append)

גרפיקה של Microsoft Windows

Edlin: a (append)‎

טעינת חלק של קובץ לזיכרון כאשר מחסור בזיכרון מונע מהקובץ Edlin.exe לטעון את הקובץ כולו. כאשר נעשה שימוש ב- a ללא פרמטרים, נטענות שורות מקובץ הדיסק עד ש- 75 אחוז מהזיכרון הזמין מתמלאים. אם הזיכרון הזמין כבר הגיע ל- 75 אחוזים מלאים, הקובץ Edlin.exe לא טוען שורות נוספות.

תחביר

‎[n]a

פרמטרים

n
ציון מספר השורות שברצונך לקרוא לתוך הזיכרון מהדיסק.
?
הצגת רשימה של פקודות משנה של edlin.

הערות

  • XOX
  • XOX
  • בעת הפעלת Edlin.exe, הקובץ קורא את מספר השורות המירבי האפשרי מקובץ הדיסק לזיכרון. אם גודל הקובץ חורג מהזיכרון הזמין, עליך לערוך את הקובץ בשלבים. כלומר, עליך לערוך את החלק הראשון של הקובץ, לכתוב חלק זה של הקובץ לדיסק באמצעות פקודת המשנה w‏ (write) ולאחר מכן לטעון שורות לא ערוכות נוספות מהדיסק לזיכרון.
  • לאחר שפקודת המשנה a קוראת את השורה האחרונה של הקובץ לזיכרון, הקובץ Edlin.exe מציג את ההודעה הבאה:

    End of input file

דוגמאות

בדוגמה זו, 100 השורות האחרונות בקובץ הדיסק אינן נכנסות לזיכרון. עליך לערוך את החלק הראשון של הקובץ ולכתוב חלק ממנו בחזרה לדיסק. כדי לטעון את 100 השורות הנותרות לזיכרון, הקלד:

100a


Edlin: c (copy)

גרפיקה של Microsoft Windows

Edlin: c (copy)‎

העתקת בלוק של שורות עוקבות למיקום אחד או יותר בתוך הקובץ בזיכרון. באפשרותך להעתיק בלוק זה מספר פעמים לפי הצורך.

תחביר

[line1],[line2],line3,[count]c

פרמטרים

line1
ציון השורה הראשונה שברצונך להעתיק.
line2
ציון השורה האחרונה שברצונך להעתיק.
line3
נדרש. ציון שורת היעד שלפניה ברצונך להוסיף את בלוק השורות שצוין.
count
ציון מספר הפעמים שברצונך להעתיק את בלוק השורות.

הערות

  • XOX
  • XOX
  • השמטת ערכי פרמטרים

    אם תשמיט את line1 או את line2, הקובץ Edlin.exe יעתיק את השורה הנוכחית בלבד. עליך לכלול את הפסיקים בשורת הפקודה, גם אם תשמיט את אחד הפרמטרים האלה או את שניהם, ועליך לציין את מספר שורת היעד.

    אם תשמיט את הפרמטר count‏, הקובץ Edlin.exe יעתיק את השורות פעם אחת בלבד.

  • מספור מחדש של שורות

    לאחר שהקובץ Edlin.exe מסיים להעתיק שורות, באפשרותך להשתמש בפקודת המשנה l‏ (list) בשורת הפקודה * כדי לראות את השורות שמוספרו מחדש כראוי.

  • חפיפה של מספרי שורות

    לשורה שציינת עבור הפרמטר line3 אין אפשרות להיות חלק מבלוק השורות להעתקה. אם תגרום לחפיפה של מספרי שורות באופן זה, לקובץ Edlin.exe לא תהיה אפשרות להשלים את פעולת ההעתקה ותוצג ההודעה הבאה:

    Entry error

דוגמאות

כדי להעתיק פעם אחת את השורות 1 עד 5, החל משורה 6, הקלד:

1,5,6c

השורות 6 עד 10 הופכות זהות לשורות 1 עד 5.

כדי להעתיק את השורה הנוכחית לשורה 5, הקלד:

‎,,5c

כדי להציג את הודעת השגיאה המופיעה בעת ציון מספרי שורה חופפים, הקלד:

3,20,15c


Edlin: d (delete)

גרפיקה של Microsoft Windows

Edlin: d (delete)‎

מחיקת בלוק השורות העוקבות שציינת. כאשר נעשה שימוש ב- d ללא פרמטרים, נמחקת השורה הנוכחית.

תחביר

[line1][,line2]d

פרמטרים

line1
ציון השורה הראשונה אותה ברצונך שהקובץ Edlin.exe ימחק.
line2
ציון השורה האחרונה אותה ברצונך שהקובץ Edlin.exe ימחק.
?
הצגת רשימה של פקודות משנה של edlin.

הערות

  • XOX
  • XOX
  • השמטת ערכי פרמטרים

    אם תשמיט את שני הפרמטרים או את הפרמטר line2 בלבד, השורה הנוכחית תימחק על-ידי הקובץ Edlin.exe. אך אם תשמיט את הפרמטר line1 בלבד, הקובץ Edlin.exe ימחק את בלוק הטקסט הכולל את השורה הנוכחית עד לשורה שצוינה על-ידי line2. במקרה זה, אין באפשרותך לציין מספר שורה עבור line2 הקודם למספר השורה הנוכחי. למספר שציינת עבור line2 אין אפשרות להיות קטן מהמספר שציינת עבור line1. אם תשמיט את הפרמטר line1 בלבד, יהיה עליך להוסיף פסיק כמציין מיקום לפני line2, כפי שמוצג תחת הסעיף תחביר.

  • מספור שורות מחדש

    לאחר שהקובץ Edlin.exe מסיים למחוק שורות, באפשרותך להשתמש בפקודת המשנה l‏ (list) בשורת הפקודה * כדי להציג כראוי את השורות הממוספרות מחדש שנותרו.

דוגמאות

כדי למחוק את שורה 7, הקלד:

7d

כדי למחוק את בלוק הטקסט בשורות 22 עד 32, הקלד:

22,32d

בדוגמה זו, מספר השורה הנוכחית הוא 7. כדי למחוק את בלוק הטקסט הכולל את השורה הנוכחית עד שורה 11, הקלד:

‎,11d


Edlin: e (end)

גרפיקה של Microsoft Windows

Edlin: e (end)‎

שינוי השם של קובץ הקלט המקורי בדיסק לשם בעל סיומת ‎.bak, כתיבת הקובץ הערוך מהזיכרון לקובץ הקלט המקורי בדיסק ולאחר מכן הפסקת ההפעלה של Edlin.exe.

תחביר

e

פרמטרים

ללא

הערות

  • XOX
  • XOX
  • אם הקובץ בזיכרון הוא קובץ שיצרת במהלך הפעלה זו ולא קובץ שנטען מדיסק על-ידי הקובץ Edlin.exe,‏ Edlin.exe לא ייצור קובץ גיבוי (‎.bak) בדיסק.
  • באמצעות הקובץ Edlin.exe, נכתב הקובץ הערוך מהזיכרון לכונן, לספריה ולשם הקובץ בדיסק שציינת כאשר התחלת את ההפעלה הנוכחית של Edlin.exe. אם השמטת שם של כונן בעת ההפעלה, הקובץ Edlin.exe יכתוב לכונן הנוכחי. אם השמטת שם של ספריה בעת ההפעלה, הקובץ Edlin.exe יכתוב לספריה הנוכחית.
  • לפני השימוש בפקודת המשנה e, ודא שהדיסק מכיל די שטח פנוי עבור כל הקובץ הערוך הנמצא בזיכרון. אם לא קיים די שטח פנוי, הקובץ Edlin.exe מאבד חלק מהקובץ או את כולו.
  • אם תנסה לשמור קובץ ערוך מזיכרון לדיסק כאשר גירסת ה- ‎.bak של הקובץ היא קובץ לקריאה בלבד, הקובץ Edlin.exe יציג הודעה בתבנית הבאה כדי להודיע שלפקודה edlin אין אפשרות להחליף את קובץ ה- ‎.bak:

    Access denied - [Drive:][Path] FileName.bak

    הן הגירסה המקורית והן גירסת הגיבוי של הקובץ בדיסק נותרות ללא שינוי.


Edlin: i (insert)

גרפיקה של Microsoft Windows

Edlin: i (insert)‎

הוספת שורות לפני מספר השורה שציינת בקובץ הערוך השוכן בזיכרון. כאשר נעשה שימוש ב- i ללא פרמטרים, מצב ההוספה מופעל בשורה הנוכחית.

תחביר

i [line]‎

פרמטרים

line
ציון מספר השורה שלפניה ברצונך להוסיף שורות. הערך המשמש כברירת מחדל עבור line הוא מספר השורה הנוכחית.

הערות

  • XOX
  • XOX
  • שימוש בפקודת המשנה i

    בעת יצירת קובץ חדש, עליך להקליד את הפקודה i לפני שיהיה באפשרותך להוסיף שורה חדשה. הקובץ Edlin.exe יציג את מספר השורה הבאה בכל פעם שתקיש ENTER‏. כדי לצאת ממצב הוספה, הקש CTRL+C.

  • מספור שורות מחדש

    בעת היציאה ממצב הוספה, השורה המופיעה מיד לאחר השורות שנוספו הופכת לשורה הנוכחית. באפשרותך להשתמש בפקודת המשנה l ‏(list) בשורת הפקודה * כדי להציג את השורות שמוספרו מחדש כראוי.

  • הוספת תווי בקרה

    כדי להוסיף תו בקרה בטקסט, הקלד:

    ‎^V ASCIIsymbol

    ASCIIsymbol הוא סימן ה- ASCII המייצג את תו הבקרה. לדוגמה, כדי להוסיף תו Escape ‏(‎CTRL+[‎), הקלד:

    ‎^V[‎

    כדי להוסיף תו המפיק צליל (CTRL+G), הקלד:

    ‎^VG‎

  • צירוף טקסט

    אם הערך עבור line חורג ממספר השורות בקובץ שאתה עורך או אם ציינת סימן מספר (#) עבור line‏, הקובץ Edlin.exe מצרף את השורה או השורות המוספות לסוף הקובץ. בשני המקרים, השורה האחרונה שתוסיף תהפוך לשורה הנוכחית. אם רק חלק מהקובץ נמצא בזיכרון, השורה תצורף לסוף החלק שנמצא בזיכרון.

דוגמאות

הטקסט הבא יופיע במסך לאחר שתשתמש בפקודת המשנה l ‏(list):

1: Dear Mr. Muth:
2:
3: Congratulations on your promotion
4: to the position of Senior Chemical
5: Engineer. I continue to be most
6: impressed with your work.
7:
8: Sincerely,
9:
10: Clay Martin, President

כדי להוסיף טקסט לפני שורה 8, הקלד:

8I

הקובץ Edlin.exe מציג את השורה הבאה:

‎8:*_‎

הקלד את השורה הבאה בנקודה הכניסה בשורה 8:

‎8:‎‎*I think you will enjoy working with

הקש ENTER בסיום של כל שורה חדשה והקלד:

‎9:‎ ‎*Mr. Lang on the new project. Please
‎10: *let me know if there is anything I
‎11: *can do to assist you.

הקובץ Edlin.exe מציג את השורה הבאה:

‎12:*_‎

הוסף שורה ריקה על-ידי הקשה על ENTER והשלם את ההוספה על-ידי הקשה על CTRL+C בשורה הבאה. הקלד 1l כדי לראות את השורות הבאות, שמוספרו מחדש כראוי:

1: Dear Mr. Muth:
2:
3: Congratulations on your promotion
4: to the position of Senior Chemical
5: Engineer. I continue to be most
6: impressed with your work.
7:
8: I think you will enjoy working with
9: Mr. Lang on the new project. Please
10: let me know if there is anything I
11: can do to assist you.
12:
13:*Sincerely,
14:
15: Clay Martin, President


Edlin: l (list)

גרפיקה של Microsoft Windows

Edlin: l (list)‎

הצגת בלוק השורות העוקבות שציינת. כאשר נעשה שימוש ב- l ‏(list) ללא פרמטרים, מוצג עד דף אחד המתחיל 11 שורות לפני השורה הנוכחית.

תחביר

l [line1][,line2]

פרמטרים

line1
ציון השורה הראשונה אותה ברצונך שהקובץ Edlin.exe יציג.
line2
ציון השורה האחרונה אותה ברצונך שהקובץ Edlin.exe יציג.
?
הצגת רשימה של פקודות משנה של edlin.

הערות

  • XOX
  • XOX
  • השמטת ערכי פרמטר

    באפשרותך להשמיט את הפרמטר line1, את הפרמטר line2 או את שניהם. הרשימה הבאה מתארת את הערך או את הערכים המשמשים כברירת המחדל עבור כל אחד מהמקרים האלה:

    • אם תשמיט את הפרמטר line1 בלבד, הקובץ Edlin.exe יציג עד עמוד אחד (כלומר, מסך מלא של טקסט) בכל פעם, החל מ- 11 שורות לפני השורה הנוכחית וכלה בשורה אשר מספרה צוין ב- line2. כאשר תשמיט את line1 בלבד, יהיה עליך להוסיף פסיק כמציין מקום.
    • אם תשמיט את הפרמטר line2 בלבד, הקובץ Edlin.exe יציג עד עמוד אחד, החל מן השורה שמספרה צוין ב- line1.
    • אם תשתמש בפקודת המשנה l ‏(list) ללא פרמטרים, הקובץ Edlin.exe יציג עד עמוד אחד, החל מ- 11 שורות לפני השורה הנוכחית. אם תתקין את מנהל ההתקן Ansi.sys, מספר השורות שיוצגו על-ידי Edlin.exe בכל עמוד יהיה תלוי בסוג הצג שברשותך. מספר זה עשוי להיות גדול מ- 24.
  • עבודה עם בלוקים גדולים של שורות

    כאשר בלוק השורות שציינת מכיל יותר מעמוד אחד, הקובץ Edlin.exe יציג את העמוד הראשון ולאחר מכן יציג בפניך את ההודעה הבאה:

    Continue (Y/N)?‎

    הקובץ Edlin.exe יציג עמוד נוסף בכל פעם שתשיב בחיוב להודעה.

דוגמאות

כדי להציג את שורות 5 עד 10, הקלד:

5,10l


Edlin: [line]

גרפיקה של Microsoft Windows

Edlin: [line]‎

הצגת שורת הטקסט שציינת.

תחביר

[line]

פרמטרים

line
ציון מספר השורה אותו ברצונך שהקובץ Edlin.exe יציג. כדי להציג את המספר והטקסט של השורה הנוכחית, הקש ENTER.
?
הצגת רשימה של פקודות משנה של edlin.

הערות

  • XOX
  • XOX
  • כאשר תקליד מספר שורה כפקודה, הקובץ Edlin.exe יציג שתי שורות. השורה הראשונה מכילה את המספר שציינת ואת הטקסט המשויך אליו. השורה השניה מכילה שוב את המספר ואחריו את נקודת הכניסה. הטקסט בשורה הראשונה של התצוגה משמש כתבנית עבור השורה השניה. בשורה השניה של התצוגה, באפשרותך להקיש ENTER כדי לבטל את הפקודה מבלי לשנות את הטקסט, להקליד טקסט חלופי או לערוך את שורת הטקסט. לאחר שתערוך שורה, הקש ENTER כדי להזין את השינויים לזיכרון.

    אזהרה

    • אם תקיש ENTER כאשר נקודת הכניסה ממוקמת באמצע השורה, הקובץ Edlin.exe ימחק את החלק של השורה הנמצא בין נקודת הכניסה לבין סוף השורה.

    לקבלת מידע אודות שמירת הקובץ הערוך מזיכרון לדיסק באמצעות פקודות המשנה e‏ (End) או w‏ (Write), ראה נושאים קרובים.

דוגמאות

בדוגמה זו, הקובץ הבא נמצא בזיכרון ומוכן לעריכה. בעת השימוש בפקודת המשנה l ‏(list) בשורת הפקודה *, הקובץ Edlin.exe מציג את תוכן הקובץ.

1: Dear Mr. Muth:
2:
3: Congratulations on your promotion
4: to the position of Senior Chemical
5: Engineer. I continue to be most
6: impressed with your work.

כדי לערוך את שורה 6, הקלד:

6

הקובץ Edlin.exe מציג את שתי השורות הבאות:

6:*impressed with your work.
6:*_

השורה הראשונה מכילה את מספר השורה שצוין ואת הטקסט המשויך לשורה זו. השורה השניה מכילה את אותו מספר שורה ואת נקודת הכניסה.

כדי להכניס את המילה "fine" לפני המילה "work" בדוגמה הקודמת, ציין שעל Edlin.exe להציג מחדש חלק מהשורה הראשונה, החל מהמיקום של נקודת הכניסה בשורה השניה. ראשית, הקש F2 והקלד w‏. הקובץ Edlin.exe יציג את הטקסט עד האות "w" הראשונה בשורה 6 לא כולל, כפי שמוצג להלן:

‎6:*impressed _ ‎

הקש F2 והקלד w שוב. הקובץ Edlin.exe יציג את הטקסט עד האות "w" הבאה בשורה 6 לא כולל, כפי שמוצג להלן:

‎6:*impressed with your _‎

הקש על מקש INSERT, הקלד fine, הקש על מקש הרווח ולאחר מכן הקש F3. הקובץ Edlin.exe יציג את השורה הערוכה, כפי שמוצג להלן:

‎6:*impressed with your fine work._‎

הקש ENTER לקבלת השינוי.

בשורת הפקודה *, הקלד את פקודת המשנה l ‏(list) כדי להציג את הקובץ הערוך. הקובץ Edlin.exe מציג את השורות הבאות:

1: Dear Mr. Muth:
2:
3: Congratulations on your promotion
4: to the position of Senior Chemical
5: Engineer. I continue to be most
6:*impressed with your fine work.


Edlin: m (move)

גרפיקה של Microsoft Windows

Edlin: m (move)‎

העברת הבלוק של השורות העוקבות שציינת למיקום אחר בקובץ הנמצא בזיכרון.

תחביר

‎[line1],[line2],line3 m

‎[line1],[+n],line3 m

פרמטרים

line1
ציון השורה הראשונה אותה ברצונך שהקובץ Edlin.exe יעביר.
line2
ציון השורה האחרונה אותה ברצונך שהקובץ Edlin.exe יעביר.
line3
נדרש. ציון השורה שלפניה ברצונך שהקובץ Edlin.exe יעביר את בלוק השורות.
‎+n
ציון מספר השורות אותן ברצונך ש- Edlin.exe יעביר, החל מהשורה שצוינה ב- line1 וכולל n השורות הבאות. אם תשמיט את line1, השורה הנוכחית היא נקודת ההתחלה עבור בלוק השורות המועבר על-ידי Edlin.exe.

הערות

  • XOX
  • XOX
  • מספור שורות מחדש

    לאחר שתעביר שורות, השתמש בפקודת המשנה l ‏(list) כדי להציג את השורות שמוספרו מחדש כראוי.

  • חפיפה של מספרי שורות

    לשורה שציינת עבור הפרמטר line3 אין אפשרות להיות חלק מבלוק השורות שברצונך להעביר. לדוגמה, בעקבות הפקודה הבאה תופיע הודעת שגיאה:

    5,10,8m

    אם תבצע חפיפה של מספרי שורות באופן זה, לקובץ Edlin.exe לא תהיה אפשרות להשלים את פעולת ההעברה ותוצג ההודעה הבאה:

    Entry error

דוגמאות

בדוגמה זו, הקובץ הבא נמצא בזיכרון ומוכן לעריכה. בעת השימוש בפקודת המשנה l ‏(list) בשורת הפקודה *, הקובץ Edlin.exe מציג את תוכן הקובץ.

1: Dear Mr. Muth:
2:
3: Congratulations on your promotion
4: to the position of Senior Chemical
5: Engineer. I continue to be most
6: impressed with your fine work.
7:
8: I think you will enjoy working with
9: Mr. Lang on the new project. Please
10: let me know if there is anything I
11: can do to assist you.
12:
13: Sincerely,
14:
15: Clay Martin, President
16: Contoso, Ltd
17: "A World Leader in Technology"

כדי להעביר את המוטו לתחילת התזכיר (כלומר, להעביר את השורות 16 ו- 17 לפני שורה 1), הקלד:

16,17,1m

בשורת הפקודה *, הקלד את פקודת המשנה l ‏(list) כדי להציג את הקובץ הערוך. הקובץ Edlin.exe יציג את השורות הבאות:

1: Contoso, Ltd
2: "A World Leader in Technology"
3: Dear Mr. Muth:
4:
5: Congratulations on your promotion
6: to the position of Senior Chemical
7: Engineer. I continue to be most
8: impressed with your fine work.
9:
10: I think you will enjoy working with
11: Mr. Lang on the new project. Please
12: let me know if there is anything I
13: can do to assist you.
14:
15: Sincerely,
16:
17: Clay Martin, President

כדי להעביר את בלוק השורות, החל מהשורה הנוכחית כולל 25 השורות הבאות לשורה שלפני שורה 100, הקלד:

‎,+25,100m


Edlin: p (page)

גרפיקה של Microsoft Windows

Edlin: p (page)‎

הצגת קובץ או חלק של קובץ, עמוד אחד (כלומר, מסך מלא של טקסט) בכל פעם. כאשר נעשה שימוש ב- p ללא פרמטרים, מוצג עמוד של טקסט המתחיל בשורה שלאחר השורה הנוכחית.

תחביר

[line1][, line2]p

פרמטרים

line1
ציון השורה הראשונה אותה ברצונך שהקובץ Edlin.exe יציג.
line2
ציון השורה האחרונה אותה ברצונך שהקובץ Edlin.exe יציג.
?
הצגת רשימה של פקודות משנה של edlin.

הערות

  • XOX
  • XOX
  • השורה האחרונה שהוצגה במסך הופכת לשורה הנוכחית במסך החדש.
  • השמטת פרמטרים

    כאשר תשמיט את הפרמטר line1‏, הקובץ Edlin.exe יציג עמוד טקסט המתחיל בשורה הנוכחית ומסתיים ב- line2. כאשר תשמיט את line2, הקובץ Edlin.exe יציג עמוד טקסט המתחיל ב- line1. אם תשמיט את line1 ו- line2, הקובץ Edlin.exe יציג עמוד טקסט המתחיל בשורה שלאחר השורה הנוכחית.

דוגמאות

כדי להציג את השורות 100 עד 200, עמוד אחד בכל פעם, הקלד:

100,200p


Edlin: q (quit)

גרפיקה של Microsoft Windows

Edlin: q (quit)‎

הפסקת ההפעלה הנוכחית של Edlin.exe מבלי לכתוב את הקובץ הערוך מהזיכרון לדיסק.

תחביר

q

פרמטרים

ללא

הערות

  • XOX
  • XOX
  • כדי לכתוב את הקובץ הערוך מהזיכרון לדיסק לפני הפסקת ההפעלה הנוכחית, השתמש בפקודת המשנה e ‏(end).


Edlin: r (replace)

גרפיקה של Microsoft Windows

Edlin: r (replace)‎

חיפוש בבלוק של שורות עוקבות אחר מחרוזת של תו אחד או יותר שציינת והחלפת כל מופע של מחרוזת זו במחרוזת אחרת שציינת.

תחביר

[line1][,line2]‎[?]r[string1]‎[CTRL+Z string2]

פרמטרים

line1
ציון השורה הראשונה בה ברצונך להחליף את המחרוזת שצוינה ב- string1.
line2
ציון השורה האחרונה בה ברצונך להחליף את המחרוזת שצוינה ב- string1.
?
שליחת הודעת אישור לפני שהקובץ Edlin.exe מחליף מופע של המחרוזת שצוינה ב- string1.
string1
ציון המחרוזת שברצונך להחליף.
CTRL+Z
הפרדת הערכים של string1 ו- string2. הערך החוקי היחיד עבור פרמטר זה הוא תו סוף הקובץ (CTRL+Z) המופיע כ- ‎^Z.
string2
ציון המחרוזת החדשה שברצונך שתחליף כל מופע של המחרוזת שצוינה ב- string1.

הערות

  • XOX
  • XOX
  • השורה הנוכחית החדשה היא השורה האחרונה בה החליף הקובץ Edlin.exe את string1.
  • רווחים בשורת הפקודה

    אין להוסיף רווח בין r לבין כל פרמטר עוקב בשורת הפקודה.

  • השמטת פרמטרים

    אם תשמיט את הפרמטר line1‏, הקובץ Edlin.exe יתחיל את החיפוש בשורה שלאחר השורה הנוכחית. אם תשמיט את הפרמטר line2, הקובץ Edlin.exe יפסיק את החיפוש בסוף הקובץ או בסוף הטקסט הנמצא בזיכרון כעת.

    אם תשמיט את string1, הקובץ Edlin.exe יעשה שימוש בערך שבו נעשה שימוש לאחרונה מבין הערכים הבאים: הערך שציינת עבור string1 בפעם האחרונה שהשתמשת ב- r או הערך שציינת עבור מחרוזת בפעם האחרונה שהשתמשת ב- s במהלך ההפעלה הנוכחית. אם תשמיט את string1 ולא השתמשת בפקודות המשנה r או s במהלך הפעלת העריכה הנוכחית, פקודת המשנה r מפסיקה את פעולתה באופן מיידי.

    אם תשמיט את הפרמטר string2‏, הקובץ Edlin.exe ישתמש בערך שציינת בפעם האחרונה שהשתמשת בפקודה r במהלך הפעלה זו. אם תשמיט את string2 ולא השתמשת בפקודה r במהלך ההפעלה הנוכחית, הקובץ Edlin.exe ימחק את כל המופעים של המחרוזת שצוינו ב- string1.

  • שימוש ב- CTRL+Z

    עליך להפריד את הערכים של string1 ו- string2 באמצעות CTRL+Z. אם תשמיט את string1, עדיין יהיה עליך להקיש CTRL+Z כדי לסמן את ההתחלה של string2. בעת ההקשה על CTRL+Z, התווים הבאים מופיעים:

    ‎^Z

  • שימוש בפרמטר סימן שאלה (?)

    אם תכלול את הפרמטר ? בפקודה, הקובץ Edlin.exe יציג את השורה המכילה את המופע הראשון של המחרוזת שצוינה עבור string1 ויציג בפניך בקשה באמצעות הודעת האישור הבאה:

    ‎O.K.? _‎

    אם תקיש Y או ENTER, הקובץ Edlin.exe יחליף מופע זה של string1 עם הערך ב- string2 ויחפש אחר המופע הבא. אם תקיש N, הקובץ Edlin.exe לא יחליף מופע זה של הערך עבור string1 ויחפש את המופע הבא.

    אם לא תשתמש בפרמטר ? כדי לאשר החלפות בעת ביצוען, הקובץ Edlin.exe יחליף את כל המופעים של string1 בו-זמנית ולאחר מכן יציג כל שורה המכילה החלפה. אם שורה מכילה שתי החלפות או יותר, הקובץ Edlin יציג את השורה פעם אחת עבור כל החלפה.

דוגמאות

כדי להחליף כל מופע של המילה "mine" במילה "ours" ב- 20 השורות הראשונות של הקובץ הערוך בזיכרון ולקבל הודעת אישור על כך, הקלד אך אל תקיש ENTER:

‎1,20?rmineCTRL+Zours

CTRL+Z מופיע במסך כ- ‎^Z. הפקודה מופיעה במסך כפי שמוצג להלן:

1,20?rmine^Zours

בדוגמה זו, הקובץ שלהלן נמצא בזיכרון ומוכן לעריכה. בעת שימוש בפקודת המשנה l ‏(list) בשורת הפקודה של *, הקובץ Edlin.exe מציג את תוכן הקובץ.

1: Dear Mr. Muth:
2:
3: Congratulations on your promotion
4: to the position of Senior Chemical
5: Engineer. I continue to be most
6: impressed with your fine work.
7:
8: I think you will enjoy working with
9: Mr. Lang on the new project. Please
10: let me know if there is anything I
11: can do to assist you.
12:
13: Sincerely,
14:
15: Clay Martin, President
16: Contoso, Ltd
17: "A World Leader in Technology"

כדי להחליף את כל המופעים של המילה "I" במילים "yours truly" בשורות 5 עד 10 מבלי לקבל הודעת אישור, הקלד:

5,10rICTRL+Zyours truly

CTRL+Z מופיע במסך כ- ‎^Z. הפקודה תופיע במסך כפי שמוצג להלן:

5,10rI^Zyours truly

כיוון שלא כללת את הפרמטר ?, הקובץ Edlin.exe יחליף את שלושת המופעים של "I" מבלי להציג את הודעת האישור. כאשר הקובץ Edlin.exe יסיים לבצע את הפקודה, יוצגו השורות הבאות שהשתנו כתוצאה משלוש ההחלפות:

5: Engineer. yours truly continue to be most
8: yours truly think you will enjoy working with
10: let me know if there is anything yours truly

בדוגמה הקודמת, שתי החלפות לא רצויות אירעו בשורות 5 ו- 8. כדי להימנע משינויים מסוג זה, הוסף את הפרמטר ? לפקודה. הפקודה המלאה אמורה להופיע במסך כפי שמוצג להלן:

5,10?rI^Zyours truly

הקובץ Edlin.exe יציג בפניך בקשה על-ידי הצגת הודעת האישור עבור כל מופע של המחרוזת שצוינה ב- string1 ויבצע החלפות מאושרות בלבד, כפי שמוצג בדוגמה הבאה:

5: Engineer. yours truly continue to be most
O.K.? n
8: yours truly think you will enjoy working with
O.K.? n
10: let me know if there is anything yours truly
O.K.? y

כאשר תשתמש בפרמטר ?, הקובץ Edlin.exe לא יציג באופן אוטומטי את השורות ששונו באמצעות הקובץ Edlin.exe כתוצאה מההחלפות שאישרת. אם תקליד את פקודת המשנה l ‏(list) בשורת הפקודה של *, הקובץ Edlin.exe יציג את הקובץ הערוך שנמצא בזיכרון, כפי שמוצג להלן:

1: Dear Mr. Muth:
2:
3: Congratulations on your promotion
4: to the position of Senior Chemical
5: Engineer. I continue to be most
6: impressed with your hard work.
7:
8: I think you will enjoy working with
9: Mr. Lang on the new project. Please
10: let me know if there is anything yours truly
11: can do to assist you.
12:
13: Sincerely,
14:
15: Clay Martin, President
16: Contoso, Ltd
17: "A World Leader in Technology"


Edlin: s (search)

גרפיקה של Microsoft Windows

Edlin: s (search)‎

חיפוש אחר המחרוזת שציינת.

תחביר

[line1][,line2][?]s[string]

פרמטרים

line1
ציון השורה הראשונה בה ברצונך לחפש.
line2
ציון השורה האחרונה בה ברצונך לחפש.
?
שליחה של הודעת אישור כאשר הקובץ Edlin.exe מוצא את המופע הראשון של המחרוזת שצוינה ב- string1.
string
ציון המחרוזת שברצונך לחפש. אין להוסיף רווח לפני פרמטר זה בשורת הפקודה אלא אם הרווח הוא חלק מהטקסט לחיפוש.

הערות

  • XOX
  • XOX
  • הקובץ Edlin.exe מציג את השורה הראשונה המכילה מופע של המחרוזת. לאחר שנמצא המופע הראשון, החיפוש מפסיק והשורה המכילה את string הופכת לשורה הנוכחית.
  • השמטת פרמטרים

    אם תשמיט את הפרמטר line1‏, הקובץ Edlin.exe יתחיל את החיפוש בשורה שלאחר השורה הנוכחית. אם תשמיט את הפרמטר line2, הקובץ Edlin.exe יפסיק את החיפוש בסוף הקובץ.

    אם תשמיט את string, הקובץ Edlin.exe יעשה שימוש בערך בו נעשה שימוש לאחרונה מבן שני הערכים הבאים: הערך שציינת עבור string בפעם האחרונה שהשתמשת ב- s או הערך שציינת עבור string1 בפעם האחרונה שהשתמשת ב- r במהלך ההפעלה הזו. אם תשמיט את string ולא השתמשת בפקודות המשנה s או r במהלך ההפעלה הנוכחית, פקודת המשנה s מפסיקה את פעולתה באופן מיידי.

  • שימוש בפרמטר ?

    אם תכלול את הפרמטר ? בפקודה, הקובץ Edlin.exe יציג את השורה המכילה את המופע הראשון של מחרוזת התו שצוינה עבור string ויציג בפניך בקשה באמצעות הודעת האישור הבאה:

    ‎O.K.? _‎

    אם תקיש Y או ENTER, השורה שהוצגה לפני ההודעה הופכת לשורה הנוכחית והחיפוש מופסק. אם תקיש N, החיפוש יימשך עד למציאת מופע אחר או עד שהקובץ Edlin.exe יציג את ההודעה הבאה המציינת שבוצע חיפוש בכל השורות על-ידי Edlin.exe:

    Not found

דוגמאות

בדוגמה זו, הקובץ שלהלן נמצא בזיכרון ומוכן לעריכה. בעת השימוש בפקודת המשנה l ‏(list) בשורת הפקודה *, הקובץ Edlin.exe יציג את התוכן של הקובץ.

1: Dear Mr. Muth:
2:
3: Congratulations on your promotion
4: to the position of Senior Chemical
5: Engineer. I continue to be most
6: impressed with your fine work.
7:
8: I think you will enjoy working with
9: Mr. Lang on the new project. Please
10: let me know if there is anything I
11: can do to assist you.
12:
13: Sincerely,
14:
15: Clay Martin, President

כדי לחפש בשורות 2 עד 12 אחר המופע הראשון של המילה "to", הקלד:

2,12sto

הקובץ Edlin.exe מציג את השורה הבאה:

4: to the position of Senior Chemical‎

כדי להציג את השורה המכילה את המופע הראשון של "to" ולקבל הודעת אישור, הקלד:

‎1,?sto

הקובץ Edlin.exe מציג את השורות הבאות:

4: to the position of Senior Chemical
O.K.? _

אם תקיש על כל מקש כלשהו שאינו Y או ENTER, החיפוש יימשך. עבור דוגמה זו, הקש N, כפי שמוצג להלן:

O.K.? n

הקובץ Edlin.exe ימשיך את החיפוש ויציג את השורות הבאות:

5: Engineer. I continue to be most
O.K.? _

הקש Y כדי להפסיק את החיפוש.


פקודות משנה של Edlin

לקבלת מידע נוסף, לחץ על פקודה:

  • Edlin: [line]‎
  • Edlin: a (append)‎
  • Edlin: c (copy)‎
  • Edlin: d (delete)‎
  • Edlin: e (end)‎
  • Edlin: i (insert)‎
  • Edlin: l (list)‎
  • Edlin: m (move)‎
  • Edlin: p (page)‎
  • Edlin: q (quit)‎
  • Edlin: r (replace)‎
  • Edlin: s (search)‎
  • Edlin: t (transfer)‎
  • Edlin: w (write)‎


Edlin: t (transfer)

גרפיקה של Microsoft Windows

Edlin: t (transfer)‎

מיזוג של התוכן של קובץ בדיסק עם התוכן של הקובץ הנמצא בזיכרון.

תחביר

‎[line]t[Drive:][Path] FileName

פרמטרים

line
ציון מספר השורה אשר לפניה ברצונך להוסיף את הקובץ שהועבר מדיסק. ערך ברירת המחדל הוא מספר השורה הנוכחית.
‎[Drive:][Path] FileName
ציון המיקום והשם של הקובץ אותו ברצונך להוסיף לפני השורה שציינת עבור line. הפרמטר Filename נדרש. ערך ברירת המחדל עבור Drive הוא הכונן הנוכחי וערך ברירת המחדל עבור Path הוא הספריה הנוכחית.

הערות

  • XOX
  • XOX
  • לאחר שהקובץ Edlin.exe ממזג קובץ מדיסק, באפשרותך להשתמש בפקודת המשנה l ‏(list) בשורת הפקודה * כדי להציג את השורות שמוספרו מחדש כראוי.

דוגמאות

כדי למזג קובץ בשם Taxes.mem לשורה 12 של הקובץ שעובר עריכה, הקלד:

12t taxes.mem


Edlin: w (write)

גרפיקה של Microsoft Windows

Edlin: w (write)‎

כתיבת החלק הראשון של הקובץ הערוך מהזיכרון לדיסק. כאשר נעשה שימוש ב- w ללא פרמטרים, שורות נכתבות מהקובץ הערוך בזיכרון לדיסק עד ש- 25 אחוז מהזיכרון נמצאים בשימוש.

תחביר

‎[n]w

פרמטרים

n
ציון מספר השורות שברצונך לכתוב לדיסק, החל מהשורה הראשונה של הקובץ הערוך בזיכרון.
?
הצגת רשימה של פקודות משנה של edlin.

הערות

  • XOX
  • XOX
  • בעת ההפעלה של Edlin.exe, הקובץ קורא את מספר השורות המירבי מקובץ הדיסק לתוך הזיכרון. אם גודל הקובץ חורג מכמות הזיכרון הזמינה, עליך לערוך את הקובץ בשלבים. כלומר, עליך לערוך חלק מהקובץ, לכתוב חלק זה לדיסק באמצעות פקודת המשנה w ולאחר מכן לטעון את החלק הבא מהדיסק באמצעות פקודת המשנה a ‏(append).
  • בעת פתיחת קובץ, הקובץ Edlin.exe קורא שורות מהדיסק עד שהזיכרון מתמלא ביותר מ- 75 אחוז. 25 האחוזים הנותרים נשמרים על-ידי Edlin.exe עבור שינויים העשויים להתבצע בטקסט. אם יש די מקום בזיכרון עבור הקובץ כולו, הקובץ Edlin.exe יציג את ההודעה הבאה:

    End of input file

    אם מוצגת הודעה זו, אין צורך להשתמש בפקודות המשנה w ו- a‏ (append).

    אם הקובץ Edlin.exe אינו מציג הודעה זו בעת פתיחת קובץ, גודל הקובץ חורג מכמות הזיכרון הזמינה. עליך לערוך את הקובץ בשלבים באמצעות הפקודות w ו- a כדי לכתוב ולקרוא בהתאמה חלקים של הקובץ.

    פקודת המשנה w אינה כותבת את השינויים שביצעת לדיסק אלא אם כן השימוש ב- w נחוץ. אם תשתמש ב- w למרות שהקובץ כולו מתאים בגודלו לזיכרון ולאחר מכן תשתמש ב- q‏ (quit) כדי לצאת מ- edlin, אף אחד מהשינויים שביצעת לא יישמר.

  • מספור שורות מחדש

    לאחר שהפקודה edlin כותבת את החלק הראשון של הקובץ הערוך מהזיכרון לדיסק, השתמש בפקודת המשנה l ‏(list) בשורת הפקודה * כדי להציג את השורות שנותרו לאחר שמוספרו מחדש כראוי, החל משורה מספר 1.

דוגמאות

בדוגמה זו, לא קיים די מקום בזיכרון עבור 100 השורות האחרונות בקובץ הדיסק. כדי לפנות מספיק מקום לשם טעינת היתרה של קובץ הדיסק אל הזיכרון ולהמשיך בעריכה, הקלד:

125w


Endlocal

סיום תהליך ההתאמה לשינויי סביבה בקובץ אצווה, תוך שחזור של משתני הסביבה לערכיהם לפני פקודת ה- setlocal התואמת.

תחביר

endlocal

פרמטרים

‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • עליך להשתמש ב- endlocal בקובץ Script או בקובץ אצווה. אם תשתמש ב- endlocal מחוץ לקובץ Script או לקובץ אצווה, אין לפקודה כל השפעה.
  • קיימת פקודת endlocal מרומזת בסוף קובץ אצווה.
  • כאשר הרחבות פקודה זמינות (כלומר, ברירת המחדל), הפקודה endlocal משחזרת את המצב של הרחבות הפקודה (כלומר, זמינות או לא זמינות) למצב שהיה קיים לפני ההפעלה של פקודת ה- setlocal התואמת. לקבלת מידע נוסף אודות הפעלה וביטול של הרחבות פקודה, ראה cmd בנושאים קרובים.

דוגמאות

באפשרותך לבצע התאמה מקומית של משתני סביבה בקובץ אצווה. לדוגמה:

@echo off

rem This program starts the superapp batch program on the network,

rem directs the output to a file, and displays the file

rem in Notepad.

setlocal

path=g:\programs\superapp;%path

call superapp>c:\superapp.out

endlocal

start notepad c:\superapp.out


Eventcreate

מתן אפשרות למנהל ליצור אירוע מותאם אישית ביומן אירועים שצוין.

תחביר

eventcreate ‎[/s Computer ‎[/u Domain\User [/p Password]]‎ ‎{[/l {APPLICATION|SYSTEM}]|[/so SrcName]}‎ ‎/t {ERROR|WARNING|INFORMATION|SUCCESSAUDIT|FAILUREAUDIT}‎ ‎/id EventID ‎/d Description

פרמטרים

‎/s Computer
ציון השם או כתובת ה- IP של מחשב מרוחק (אין להשתמש בקו נטוי הפוך). המחשב המקומי משמש כברירת המחדל.
‎/u Domain\User
הפעלת הפקודה עם הרשאות החשבון של המשתמש שצוין על-ידי User או Domain\User. ברירת המחדל היא ההרשאות של המשתמש המחובר כרגע למחשב המנפיק את הפקודה.
‎/p Password
ציון הסיסמה של חשבון המשתמש המצוין בפרמטר ‎/u.
‎/l {APPLICATION|SYSTEM}‎
ציון השם של יומן האירועים בו ייווצר האירוע. השמות החוקיים של יומן הרישום הם APPLICATION ו- SYSTEM.
‎/so SrcName
ציון המקור לשימוש עבור האירוע. מקור חוקי עשוי להיות כל מחרוזת ועליו לייצג את היישום או הרכיב המפיק את האירוע.
‎/t {ERROR|WARNING|INFORMATION|SUCCESSAUDIT|FAILUREAUDIT}‎
ציון סוג האירוע שיש ליצור. הסוגים החוקיים הם ERROR,‏ WARNING,‏ INFORMATION,‏ SUCCESSAUDIT ו- FAILUREAUDIT.
‎/id EventID
ציון של מזהה האירוע עבור האירוע. מזהה חוקי הוא מספר כלשהו בין 1 ל- 65535.
‎/d Description
ציון התיאור בו יש להשתמש עבור האירוע שנוצר לאחרונה.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • לא ניתן לכתוב אירועים מותאמים אישית ליומן האבטחה.

דוגמאות

הדוגמאות הבאות מציגות את האופן בו באפשרותך להשתמש בפקודה eventcreate:

eventcreate /t error /id 100 /l application /d "Create event in application log"‎
eventcreate /t information /id 1000 /so winmgmt /d "Create event in WinMgmt source"‎
eventcreate /t error /id 2001 /so winword /l application /d "new src Winword in application log"‎
eventcreate /s server /t error /id 100 /l application /d "Remote machine without user credentials"‎
eventcreate /s server /u user /p password /id 100 /t error /l application /d "Remote machine with user credentials"‎
eventcreate /s server1 /s server2 /u user /p password /id 100 /t error /so winmgmt /d "Creating events on Multiple remote machines"‎
eventcreate /s server /u user /id 100 /t warning /so winmgmt /d "Remote machine with partial user credentials"‎


Eventquery.vbs

פירוט האירועים ומאפייני האירועים מתוך יומן אירועים אחד או יותר.

תחביר

eventquery[.vbs]‎ ‎[/s Computer [/u Domain\User [/p Password]]]‎ [‎/fi FilterName] ‎[/fo {TABLE|LIST|CSV}]‎ ‎[/r EventRange [‎/nh] [‎/v] ‎[/l [APPLICATION] [SYSTEM] [SECURITY] ["DNS server"] [UserDefinedLog] [DirectoryLogName] [*] ]‎

פרמטרים

‎/s Computer
קביעת השם או כתובת ה- IP של מחשב מרוחק (אין להשתמש בקו נטוי הפוך). ברירת המחדל היא המחשב המקומי.
‎/u Domain\User
הפעלת קובץ ה- Script באמצעות הרשאות החשבון של המשתמש שצוין על-ידי User או Domain\User. ברירת המחדל היא ההרשאות של המשתמש המחובר כעת למחשב ומפעיל את הפקודה.
‎/p Password
קביעת הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u.
‎/fi FilterName
קביעת סוגי האירועים שיש לכלול או לא לכלול בשאילתה. כדי לחפש אירועים עם אחד מהערכים, ניתן להשתמש ב- Type וב- ID בהצהרת תחביר אחת באמצעות האופרטור or. להלן שמות, אופרטורים וערכי מסנן חוקיים.
שם | אופרטור | ערך
תאריך ושעה | eq‏, ne‏, ge‏, le‏, gt‏, lt | ‎mm/dd/yy(yyyy)‎‏, hh:mm:ssAM(/PM)‎
סוג | eq‏, ne‏, or | {ERROR|INFORMATION|WARNING|SUCCESSAUDIT|FAILUREAUDIT}
מזהה | eq‏, ne‏, or‏, ge‏, le‏, gt‏, lt | מספר שלם חיובי וחוקי כלשהו.
משתמש | eq‏, ne | כל מחרוזת חוקית.
מחשב | eq‏, ne | כל מחרוזת חוקית.
מקור | eq‏, ne | כל מחרוזת חוקית.
קטגוריה | eq‏, ne | כל מחרוזת חוקית.
‎/fo {TABLE|LIST|CSV}‎
קביעת התבנית בה יש להשתמש עבור הפלט. הערכים החוקיים הם table,‏ list ו- csv.
‎/r EventRange
קביעת טווח האירועים שיש לפרט.
ערך | תיאור
N | פירוט N האירועים האחרונים.
‎-N | פירוט N האירועים הישנים ביותר.
N1-N2 | פירוט האירועים מ- N1 ל- N2.
‎/nh
העלמה של כותרות עמודה בפלט. חוקי עבור התבניות table ו- csv בלבד.
‎/v
קביעה כי מידע אירוע בעל מלל רב יוצג בפלט.
‎/l [APPLICATION] [SYSTEM] [SECURITY] ["DNS server"] [UserDefinedLog] [DirectoryLogName] [*] ]‎
קביעת יומני הרישום עליהם יש לפקח. הערכים החוקיים הם Application,‏ System,‏ Security,‏ "DNS server", יומן רישום המוגדר על-ידי משתמש ויומן רישום ספריות. ניתן להשתמש ב- "DNS server" רק אם שירות ה- DNS פועל במחשב שצוין על-ידי הפרמטר ‎/s. כדי לציין יותר מיומן רישום אחד עליו יש לפקח, השתמש שוב בפרמטר ‎/l. ניתן להשתמש בתו הכללי (*) והוא ברירת המחדל.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • כדי להפעיל קובץ Script זה, עליך להפעיל את CScript. אם טרם קבעת את Windows Script Host המשמש כברירת מחדל ל- CScript, הקלד:

    cscript //h:cscript //s //nologo

דוגמאות

הדוגמאות הבאות מציגות את האופן בו באפשרותך להשתמש בפקודה eventquery:

eventquery /l system
eventquery /l mylog
eventquery /l application /l system
eventquery /s srvmain /u maindom\hiropln /p p@ssW23 /v /l *‎
eventquery /r 10 /l application /nh
eventquery /r -10 /fo LIST /l security
eventquery /r 5-10 /l "DNS server"‎
eventquery /fi "Type eq Error" /l application
eventquery /fi "Datetime eq 06/25/00,03:15:00AM/06/25/00,03:15:00PM" /l application
eventquery /fi "Datetime gt 08/03/00,06:20:00PM" /fi "id gt 700" /fi "Type eq warning" /l system eventquery /fi "ID eq 1000 OR ID ge 4500"‎ eventquery /fi "Type eq error OR Type eq INFORMATION"‎ eventquery /fi "ID eq 250 OR Type eq ERROR"‎


Eventtriggers

הצגה והגדרה של גורמים מפעילים (Trigger) של אירוע במחשבים מקומיים או מרוחקים.

כדי להציג את תחביר הפקודה, לחץ על פקודה:

eventtriggers create

יצירת גורם מפעיל חדש של אירוע המפקח ופועל בהתאם למופע של אירועי יומן רישום של קריטריונים נתונים.

תחביר

eventtriggers[.exe]‎ ‎/create ‎[/s Computer [/u Domain\User [/p Password]]]‎ ‎/tr TriggerName ‎[/l [APPLICATION] [SYSTEM] [SECURITY] ["DNS Server"] [LOG] [DirectoryLogName] [*] ]‎ ‎{[/eid ID]‎|‎[/t {ERROR|INFORMATION|WARNING|SUCCESSAUDIT|FAILUREAUDIT}]‎|‎[/so Source]}‎ ‎[/d Description]‎ ‎/tk TaskName ‎[/ru {[Domain\]User | "System"} [/rp Password]]‎

פרמטרים

‎/s Computer
קביעת השם או כתובת ה- IP של מחשב מרוחק (אין להשתמש בקו נטוי הפוך). המחשב המקומי משמש כברירת המחדל.
‎/u Domain\User
הפעלת הפקודה באמצעות הרשאות החשבון של המשתמש שצוין באמצעות User או Domain\User. ברירת המחדל היא ההרשאות של המשתמש המחובר כעת למחשב המפעיל את הפקודה.
‎/p Password
קביעת הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u.
‎/tr TriggerName
קביעת שם ידידותי כדי לשייכו לגורם המפעיל של האירוע.
‎/l [APPLICATION] [SYSTEM] [SECURITY] ["DNS Server"] [LOG] [DirectoryLogName] [*] ]‎
קביעת יומני האירועים עליהם יש לפקח. הסוגים החוקיים הם: יישום, מערכת, אבטחה, שרת DNS, יומן רישום ויומן ספריות. ניתן להשתמש בתו הכללי (*) והוא הערך המשמש כברירת מחדל.
‎/eid ID
קביעת מזהה אירוע מסוים שעבורו על הגורם המפעיל של האירוע לפקח. הערכים החוקיים כוללים כל מספר שלם חוקי. לא ניתן להשתמש בפרמטר זה יחד עם הפרמטרים ‎/type או ‎/so.
‎/t {ERROR|INFORMATION|WARNING|SUCCESSAUDIT|FAILUREAUDIT}‎
קביעת סוג אירוע שעבורו על הגורם המפעיל של האירוע לפקח. הערכים החוקיים כוללים את: שגיאה, מידע, אזהרה, ביקורת הצלחה וביקורת כישלון. לא ניתן להשתמש בפרמטר זה יחד עם הפרמטרים ‎/id או ‎/so.
‎/so Source
קביעת מקור אירוע שעבורו על הגורם המפעיל של האירוע לפקח. הערכים החוקיים כוללים כל מחרוזת. לא ניתן להשתמש בפרמטר זה יחד עם הפרמטרים ‎/id או ‎/type.
‎/d Description
קביעת תיאור מפורט של הגורם המפעיל של האירוע. הערכים החוקיים כוללים כל מחרוזת.
‎/tk TaskName
קביעת המשימה/פקודה/שורה שיש להפעיל כאשר מתקיימים תנאי הגורם המפעיל של האירוע.
‎/ru {[Domain\]User | "System"}‎
הפעלת המשימות עם ההרשאה של חשבון המשתמש שצוין. כברירת מחדל, המשימה פועלת עם ההרשאות של המשתמש המחובר למחשב שבו פועל SchTasks.
ערך | תיאור
‎[Domain\]User‎ | קביעת חשבון משתמש.
‎"System"‎ או ""‎ | קביעת חשבון NT Authority\System, המשמש את מערכת ההפעלה.
‎/rp Password
קביעת הסיסמה של חשבון המשתמש המצוין בפרמטר ‎/ru. אם תשמיט פרמטר זה בעת קביעת חשבון משתמש, תתבקש על-ידי SchTasks.exe לציין את הסיסמה ויישום זה יטשטש את הטקסט שתקליד. משימות הפועלות עם ההרשאות של חשבון NT Authority\System אינן מצריכות סיסמה ולא תתבקש על-ידי SchTasks.exe לספק סיסמה.
?/
הצגת עזרה בשורת הפקודה.

דוגמאות

הדוגמאות הבאות מציגות את האופן בו באפשרותך להשתמש בפקודה eventtriggers /create:

eventtriggers /create /tr "Disk Cleanup" /l system /t error /tk c:\windows\system32\cleanmgr.exe
eventtriggers /create /s srvmain /u maindom\hiropln /p p@ssW23 /tr "Low Disk Space" /eid 4133 /t warning /tk \\server\share\diskcleanup.cmd
eventtriggers /create /s srvmain /user maindom\hiropln /p p@ssW23 /tr "Disk Backup" /eid 4133 /l system /t error /tk \\server\share\ntbackup.exe

eventtriggers delete

מחיקת גורם מפעיל של אירוע ממערכת באמצעות מזהה גורם מפעיל של אירוע.

תחביר

eventtriggers[.exe]‎ ‎/delete ‎[/s Computer [/u Domain\User [/p Password]]]‎ ‎/tid {ID|*}‎

פרמטרים

‎/s Computer
קביעת השם או כתובת ה- IP של מחשב מרוחק (אין להשתמש בקו נטוי הפוך). המחשב המקומי משמש כברירת המחדל.
‎/u Domain\User
הפעלת הפקודה עם הרשאות החשבון של המשתמש שצוין על-ידי User או Domain\User. ברירת המחדל היא ההרשאות של המשתמש המחובר כעת למחשב המפעיל את הפקודה.
‎/p Password
קביעת הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u.
‎/tid {ID|*}‎
קביעת הגורם המפעיל או הגורמים המפעילים של האירוע שיש למחוק באמצעות "Event Trigger ID". ניתן להשתמש בתו הכללי (*).
‎/?‎
הצגת עזרה בשורת הפקודה.

דוגמאות

הדוגמאות הבאות מציגות את האופן בו באפשרותך להשתמש בפקודה eventtriggers /delete:

eventtriggers /delete /tid 1 /tid 2 /tid 4 /tid 6
eventtriggers /delete /s srvmain /u maindom\hiropln /p p@ssW23 /tid *‎
eventtriggers /delete /s srvmain /u maindom\hiropln /p p@ssW23 /tid 1‎

eventtriggers query

ביצוע שאילתה והצגת מאפיינים והגדרות של גורם מפעיל של אירוע מערכת.

תחביר

eventtriggers[.exe]‎ ‎/query ‎[/s Computer [/u Domain\User [/p Password]]]‎ ‎[/fo {TABLE|LIST|CSV}]‎ [‎/nh] [‎/v]

פרמטרים

‎/s Computer
קביעת השם או כתובת ה- IP של מחשב מרוחק (אין להשתמש בקו נטוי הפוך). המחשב המקומי משמש כברירת המחדל.
‎/u Domain\User
הפעלת הפקודה עם הרשאות החשבון של המשתמש שצוין על-ידי User או Domain\User. ברירת המחדל היא ההרשאות של המשתמש המחובר כעת למחשב המפעיל את הפקודה.
‎/p Password
קביעת הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u.
‎/fo {TABLE|LIST|CSV}‎
קביעת התבנית בה יש להשתמש עבור פלט השאילתה. הערכים החוקיים הם TABLE,‏ LIST ו- CSV. התבנית המשמשת כברירת מחדל עבור פלט היא TABLE.
‎/nh
העלמה של כותרת עמודה בפלט. הפקודה חוקית כאשר הפרמטר ‎/fo מוגדר כ- TABLE או CSV.
‎/v
קביעה כי מידע מפורט יוצג בפלט.
‎/?‎
הצגת עזרה בשורת הפקודה.

דוגמאות

הדוגמאות הבאות מציגות את האופן בו באפשרותך להשתמש בפקודה eventtriggers /query:

eventtriggers /query
eventtriggers /query /s srvmain
eventtriggers /query /s srvmain /u maindom\hiropln /p p@ssW23 /fo list

הערות

  • כאשר eventtriggers צוין ללא פעולה, מוחזרת רשימה של גורמים מפעילים של אירוע. כדי להציג רשימת גורמים מפעילים של אירוע, הקלד:

    eventtriggers

    מתקבל פלט הדומה לדוגמה הבאה:

Trigger ID Event Trigger Name         Task
========== ========================== ==============================================
         1 Disk Cleanup               c:\windows\system32\cleanmgr.exe
  • במקרה שהפעלת אירוע נכשלת, eventtriggers יוצר קובץ יומן רישום בשם TriggerConsumer.log בספריה ‎\windows\system32\wbem\logs. קובץ יומן הרישום מכיל הודעה שהפעלת האירוע נכשלה.


Evntcmd

קביעת תצורה של תרגום אירועים למלכודות (Trap), יעדי מלכודות או שניהם על בסיס המידע בקובץ תצורה.

תחביר

evntcmd [/s ComputerName] [/v VerbosityLevel] [/n] FileName

פרמטרים

‎/s ComputerName
ציון, לפי שם, של המחשב בו ברצונך לקבוע את התצורה של תרגום אירועים למלכודות, ליעדי מלכודות או שניהם. אם אינך מציין מחשב, התצורה נקבעת במחשב המקומי.
‎/v VerbosityLevel
ציון אילו סוגים של הודעות מצב יופיעו כאשר נקבעת תצורה של מלכודות ושל יעדיהן. על פרמטר זה להיות מספר שלם בין 0 ל- 10. אם אתה מציין 10, יופיעו כל סוגי ההודעות, בכלל זה הודעות מעקב ואזהרות אודות הצלחת ההגדרה של מלכודת. אם תציין 0, לא יופיעו הודעות.
‎/n
ציון שאין להפעיל מחדש את שירות SNMP אם מחשב זה מקבל שינויי תצורה של מלכודות.
FileName
ציון, לפי שם, של קובץ התצורה המכיל מידע אודות תרגום האירועים למלכודות ויעדי מלכודות שאת תצורתם ברצונך לקבוע.
‎/?‎
מציג עזרה בשורת הפקודה.

הערות

  • אם ברצונך לקבוע תצורה של הודעות מלכודות אך לא של יעדיהן, באפשרותך ליצור קובץ תצורה חוקי בעזרת מתרגם אירועים למלכודות, שהוא כלי שירות גרפי. אם מותקן שירות SNMP, באפשרותך להפעיל את מתרגם אירועים למלכודות על-ידי הקלדת evntwin בשורת הפקודה. לאחר שהגדרת את הודעות המלכודות הרצויות, לחץ על ייצוא כדי ליצור קובץ המתאים לשימוש עם הפקודה evntcmd. באפשרותך להשתמש במתרגם האירועים למלכודות כדי ליצור בקלות קובץ תצורה ולאחר מכן להשתמש בקובץ עם הפקודה evntcmd בשורת הפקודה כדי לקבוע בקלות תצורה של הודעות מלכודות במחשבים מרובים.
  • התחביר עבור קביעת תצורה של מלכודת (Trap) הוא כדלהלן:

    ‎#pragma ADD EventLogFile EventSource EventID [Count [Period]]‎

    • על הטקסט ‎#pragma להופיע בתחילת כל רשומה בקובץ.
    • הפרמטר ADD מציין שברצונך להוסיף אירוע לתצורת המלכודת.
    • הפרמטרים EventLogFile‏, EventSource ו- EventID נדרשים. הפרמטר EventLogFile מציין את הקובץ בו נרשם האירוע. הפרמטר EventSource מציין את היישום המפיק את האירוע. הפרמטר EventID מציין את המספר הייחודי המזהה כל אירוע. כדי לגלות את הערך המתאים לכל אירוע, הפעל את מתרגם האירועים למלכודות על-ידי הקלדת evntwin בשורת פקודה. לחץ על מותאם אישית ולאחר מכן לחץ על עריכה. תחת מקורות אירועים, עיין בתיקיות עד שתאתר את האירוע שאת תצורתו ברצונך לקבוע, לחץ עליו ולאחר מכן לחץ על הוספה. מידע אודות מקור האירוע, קובץ יומן רישום האירועים ומזהה האירוע מופיע תחת מקור, יומן אירועים ומזהה אירוע, בהתאמה.
    • הפרמטר Count הוא אופציונלי ומציין כמה פעמים על אירוע להתרחש לפני שנשלחת הודעת Trap. אם לא תעשה שימוש בפרמטר Count, הודעת ה- Trap נשלחת לאחר שהאירוע מתרחש פעם אחת.
    • הפרמטר Period הוא אופציונלי, אך מחייב שימוש בפרמטר Count. הפרמטר Period מציין את משך הזמן (בשניות) במהלכו על האירוע להתרחש מספר פעמים המופיע בפרמטר Count לפני שנשלחת הודעת Trap. אם לא תעשה שימוש בפרמטר Period, הודעת Trap נשלחת לאחר שהאירוע מתרחש מספר פעמים המצוין בפרמטר Count, ללא קשר למשך הזמן שחולף בין המופעים.
  • התחביר להסרת הודעת Trap הוא כדלהלן:

    ‎#pragma DELETE EventLogFile EventSource EventID

    • על הטקסט ‎#pragma להופיע בתחילת כל רשומה בקובץ.
    • הפרמטר DELETE מציין שברצונך להסיר אירוע לתצורת מלכודת.
    • הפרמטרים EventLogFile‏, EventSource ו- EventID נדרשים. הפרמטר EventLogFile מציין את יומן הרישום בו נרשם האירוע. הפרמטר EventSource מציין את היישום המפיק את האירוע. הפרמטר EventID מציין את המספר הייחודי המזהה כל אירוע.
  • התחביר לקביעת תצורה של יעד מלכודת הוא כדלהלן:

    ‎#pragma ADD_TRAP_DEST CommunityName HostID

    • על הטקסט ‎#pragma להופיע בתחילת כל רשומה בקובץ.
    • הפרמטר ADD_TRAP_DEST מציין שברצונך שהודעות Trap יישלחו למחשב מארח שצוין בתוך קהילה.
    • הפרמטר CommunityName מציין, לפי שם, את הקהילה בה נשלחות הודעות Trap.
    • הפרמטר HostID מציין, לפי שם או כתובת IP, את המחשב המארח אליו ברצונך שיישלחו הודעות ה- Trap.
  • התחביר להסרת יעד מלכודת הוא כדלהלן:

    ‎#pragma DELETE_TRAP_DEST CommunityName HostID

    • על הטקסט ‎#pragma להופיע בתחילת כל רשומה בקובץ.
    • הפרמטר DELETE_TRAP_DEST מציין שאין ברצונך שהודעות Trap יישלחו למארח שצוין בתוך קהילה.
    • הפרמטר CommunityName מציין, לפי שם, את הקהילה בה נשלחות הודעות Trap.
    • הפרמטר HostID מציין, לפי שם או כתובת IP, את המחשב המארח אליו אין ברצונך שיישלחו הודעות Trap.

דוגמאות

הדוגמאות הבאות מתארות רשומות בקובץ התצורה עבור הפקודה evntcmd. הן לא נועדו להקלדה בשורת פקודה.

כדי לשלוח הודעת Trap אם שירות יומן האירועים מופעל מחדש, הקלד:

‎#pragma ADD System "Eventlog" 2147489653

כדי לשלוח הודעת Trap אם שירות יומן האירועים מופעל מחדש פעמיים בשלוש דקות, הקלד:

‎#pragma ADD System "Eventlog" 2147489653 2 180

כדי להפסיק לשלוח הודעת Trap בכל פעם ששירות יומן האירועים מופעל מחדש, הקלד:

‎#pragma DELETE System "Eventlog" 2147489653

כדי לשלוח הודעות Trap בתוך קהילה ששמה Public למחשב המארח שכתובת ה- IP שלו היא 192.168.100.100, הקלד:

‎#pragma ADD_TRAP_DEST public 192.168.100.100

כדי לשלוח הודעות Trap בתוך קהילה ששמה Private למחשב המארח ששמו Host1, הקלד:

‎#pragma ADD_TRAP_DEST private Host1

כדי להפסיק לשלוח הודעות בתוך הקהילה ששמה Private לאותו מחשב ממנו אתה קובע תצורת יעד של מלכודות (Trap), הקלד:

‎#pragma DELETE_TRAP_DEST private localhost


Exe2bin

ממיר קבצי הפעלה (‎.exe) לתבנית בינארית.

תחביר

exe2bin [drive1:][path1]InputFile ‎[[drive2:][path2]OutputFile]‎

פרמטרים

‎[drive1:][path1]InputFile
ציון מיקום ושם קובץ הקלט שברצונך להמיר. הפרמטר InputFile נדרש.
‎[drive2:][path2]OutputFile
ציון שם ומיקום קובץ הפלט שברצונך ליצור.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • XOX
  • XOX
  • הפקודה exe2bin כלולה מתוך התחשבות במפתחי תוכנה. פקודה זו אינה שימושית עבור משתמשים רגילים.
  • המגבלות הבאות חלות בעת השימוש בפקודה exe2bin:
    • על קובץ הקלט להיות בתבנית ‎.exe שנוצרה על-ידי המקשר ועליו להיות בלתי דחוס.
    • יש לוודא שהגודל הכולל של חלקי הקוד והנתונים הקבועים או הממשיים של הקובץ קטן מ- 64KB.
    • אין להשתמש ביחידת המחסנית.
  • Exe2bin מבצעת את הפעולות הספציפיות הבאות, בהתאם לערכים בהם השתמשת עבור הפרמטרים InputFile ו- OutputFile:
    • סיומת הקובץ המוגדרת כברירת מחדל עבור הפרמטר InputFile היא ‎.exe הפקודה Exe2bin ממירה את הקובץ בתבנית ‎.exe המצוין בפרמטר InputFile לקובץ בתבנית ‎.bin (כלומר תמונת זיכרון של התוכנית) ומשתמשת במיקום ובשם הקובץ שציינת בפרמטר ‎[drive2:][path2]OutputFile לאחסון קובץ הפלט.
    • אם לא תציין ערך עבור הפרמטר drive2 או path2, הפקודה exe2bin תכתוב את קובץ הפלט לכונן ולספריה הנוכחיים.
    • אם לא תציין שם קובץ עבור הפרמטר OutputFile, הפקודה exe2bin תשתמש בשם הקובץ המופיע בפרמטר InputFile.
    • סיומת ברירת המחדל עבור שם הקובץ שצוין בפרמטר OutputFile היא ‎.bin
  • אפשריים סוגי ההמרה הבאים:
    • אם לא תציין את CS:IP בקובץ ה- ‎.exe, הפקודה exe2bin מבצעת המרה בינארית טהורה. אם התוכנית כוללת הוראות הדורשות מיקום מחדש של יחידות, הפקודה exe2bin מבקשת ממך לציין ערך Fixup. ערך זה הוא היחידה המוחלטת בה יש לטעון את התוכנית. באפשרותך להשתמש בתוכנית המתקבלת רק כאשר אתה טוען אותה לכתובת זיכרון אבסולוטית שצוינה בתוכנית. למתרגם הפקודות אין אפשרות לטעון את התוכנית.
    • אם ה- CS:IP צוין כ- 0000:100H, הקובץ פועל כקובץ ‎.com כאשר מצביע ההוראות מוגדר כ- 100H על-ידי משפט האסמבלר ORG. כלול את הסיומת ‎.com בפרמטר OutputFile‏. אין להשתמש ב- Fixup של יחידות, מכיוון שלקבצי ‎.com חייבת להיות אפשרות לבצע מיקום מחדש של יחידות. כלומר, על הקבצים לקבל את תנאי הערכים המוסברים בספרי הדרכה של Microsoft Macro Assembler. לאחר מכן תהיה למתרגם הפקודות אפשרות לטעון ולהפעיל את התוכנית באותו אופן בו נטענות ומופעלות תוכניות ‎.com הכלולות בדיסק Windows XP שברשותך.


Exit

יציאה מ- Script האצווה הנוכחי או מתוכנית Cmd.exe (כלומר מתרגם הפקודה) וחזרה לתוכנית שהפעילה את Cmd.exe או למנהל היישומים.

תחביר

exit [/b] [ExitCode]‎

פרמטרים

‎/b
יציאה מ- Script האצווה הנוכחי.
ExitCode
ציון מספר נומרי.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • אם תשתמש בפרמטר ‎/b מחוץ ל- Script אצווה, הדבר יגרום ליציאה מ- Cmd.exe.
  • אם תשתמש בפרמטר ‎/b, התוכנית Cmd.exe קובעת את המשתנה ERRORLEVEL לפי הערך שצוין בפרמטר ExitCode. אם תצא מ- Cmd.exe, התוכנית קובעת את קוד היציאה של התהליך לפי הערך שצוין בפרמטר ExitCode.


Expand

הרחבה של קובץ דחוס אחד או יותר. פקודה זו משמשת לאחזור קבצים דחוסים מדיסקי הפצה.

תחביר

expand [-r] Source [Destination]‎

expand -d source.cab [-f:files]‎

expand source.cab -f:files Destination

פרמטרים

‎-r
שינוי שמות של קבצים מורחבים.
‎-d
הצגת רשימה של קבצים במיקום המקור. אין להרחיב או לחלץ את הקבצים.
‎-f:files
ציון הקבצים בקובץ Cabinet ‏(‎.cab) שברצונך להרחיב. ניתן להשתמש בתווים כלליים (* ו- ?).
Source
ציון הקבצים שברצונך להרחיב. לפרמטר Source יש אפשרות להכיל אות כונן ונקודתיים, שם ספריה, שם קובץ או שילוב של כל אלה. ניתן להשתמש בתווים כלליים (* ו- ?).
Destination
ציון המיקום בו יש להרחיב את הקבצים. אם הפרמטר Source מכיל קבצים מרובים והפרמטר ‎-r לא צוין, על הפרמטר Destination להיות ספריה. לפרמטר Destination יש אפשרות להכיל אות כונן ונקודתיים, שם ספריה, שם קובץ או שילוב של כל אלה.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • שימוש ב- expand במסוף השחזור

    הפקודה expand, עם פרמטרים שונים, זמינה ממסוף השחזור.


Fastopen

XOX

הערה

  • XOX


Fc

השוואה בין שני קבצים והצגת ההבדלים בין הקבצים.

תחביר

fc [/a] [/b] [/c] [/l] [/lb n] [/n] [/t] [/u] [/w] [/nnnn] [drive1:][path1]filename1 [drive2:][path2]filename2

פרמטרים

‎/a
קיצור הפלט של השוואת ASCII. במקום להציג את כל השורות השונות, הפקודה fc מציגה רק את השורה הראשונה והאחרונה עבור כל ערכה של הבדלים.
‎/b
ביצוע השוואה בין הקבצים במצב בינארי. הפקודה fc משווה בין שני הקבצים בית אחר בית ללא ניסיון לסנכרן את הקבצים מחדש לאחר שנמצאה אי-התאמה. זהו מצב ברירת המחדל עבור השוואה בין קבצים בעלי סיומות ‎.exe‏, ‎.com‏, ‎.sys‏, ‎.obj‏, ‎.lib או ‎.bin
‎/c
התעלמות מאותיות רישיות וקטנות.
‎/l
ביצוע השוואה בין הקבצים במצב ASCII.‏ הפקודה fc משווה בין שני הקבצים שורה אחר שורה ונעשה ניסיון לסנכרן מחדש את הקבצים לאחר שנמצאת אי-התאמה. זהו מצב ברירת המחדל עבור השוואה בין קבצים שאינם בעלי סיומות ‎.exe‏, ‎.com‏, ‎.sys‏, ‎.obj‏, ‎.lib או ‎.bin
‎/lb n
הגדרת n כמספר השורות עבור מאגר השורות הפנימי. אורך ברירת המחדל עבור מאגר השורות הוא 100 שורות. אם בקבצים שביניהם מתבצעת ההשוואה קיים מספר גדול יותר ממספר זה של שורות רציפות שונות, הפקודה fc תבטל את ההשוואה.
‎/n
הצגת מספרי השורות במהלך השוואה של ASCII.
‎/t
מניעה מהפקודה fc להמיר טאבים לרווחים. אופן הפעולה המשמש כברירת המחדל הוא התייחסות לטאבים כמו לרווחים, עם עצירות בכל מיקום של תו שמיני.
‎/u
השוואה בין קבצים כקבצי טקסט של Unicode.
‎/w
דחיסת רווח לבן (טאבים ורווחים) במהלך ההשוואה. אם שורה מכילה רווחים או טאבים רבים בזה אחר זה, הפרמטר ‎/w מתייחס לתווים אלה כאל רווח בודד. כאשר נעשה בה שימוש עם הפרמטר ‎/w, הפקודה fc מתעלמת מרווחים לבנים (ולא משווה אותם) בתחילתן ובסופן של שורות.
‎/nnnn
ציון מספר השורות העוקבות שצריכות להיות תואמות לפני שהפקודה fc תשקול לבצע סינכרון מחדש של הקבצים. אם מספר השורות התואמות בקבצים קטן מ-nnnn, הפקודה fc תציג את השורות התואמות כהבדלים. ערך ברירת המחדל הוא 2.
‎[drive1:][path1]filename1
ציון המיקום והשם של הקובץ הראשון שברצונך להשוות. הפרמטר Filename1 נדרש.
‎[drive2:][path2]filename2
ציון המיקום והשם של הקובץ השני שברצונך להשוות. הפרמטר Filename2 נדרש.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • דיווח על הבדלים בין קבצים עבור השוואת ASCII

    כאשר אתה משתמש בפקודה fc בהשוואת ASCII, הפקודה fc מציגה הבדלים בין שני הקבצים בסדר הבא:

    • שם הקובץ הראשון
    • שורות מ- filename1 השונות בשני הקבצים
    • השורה הראשונה התואמת בשני הקבצים
    • שם הקובץ השני
    • שורות מ- filename2 השונות בשני הקבצים
    • השורה הראשונה התואמת
  • שימוש בפרמטר ‎/b עבור השוואות בינאריות

    הפרמטר ‎/b מציג הבדלים שנמצאו במהלך השוואה בינארית בצורה הבאה:

    xxxxxxxx: yy zz

    הערך של xxxxxxxx מציין את הכתובת ההקסדצימאלית היחסית עבור זוג הבתים, הנמדדת מתחילת הקובץ. כתובות מתחילות ב- 00000000. הערכים ההקסדצימאליים עבור yy ו- zz מייצגים את הבתים הבלתי תואמים מ- filename1 ו- filename2 בהתאמה.

  • שימוש בתווים כלליים

    באפשרותך להשתמש בתווים כלליים ( * ו- ?) בפרמטרים filename1 ו- filename2. אם אתה משתמש בתו כללי בפרמטר filename1, הפקודה fc משווה את כל הקבצים שצוינו לקובץ שצוין בפרמטר FileName. אם אתה משתמש בתו כללי בפרמטר filename2, הפקודה fc משתמשת בערך המתאים מהפרמטר filename1.

  • עבודה עם זיכרון

    בעת השוואה בין קבצי ASCII, הפקודה fc משתמשת במאגר פנימי (גדול מספיק כדי לכלול 100 שורות) כמקום אחסון. אם הקבצים גדולים מהמאגר, הפקודה fc משווה את מה שיש באפשרותה לטעון למאגר. אם הפקודה fc אינה מוצאת התאמה בחלקים הטעונים של הקבצים, פעולת הפקודה נפסקת ומוצגת ההודעה הבאה:

    Resynch failed. Files are too different.‎

    בעת השוואה בין קבצים בינאריים הגדולים מהזיכרון הזמין, הפקודה fc משווה בין שני הקבצים באופן מלא, על-ידי כיסוי על החלקים הנמצאים בזיכרון בחלקים הבאים מהדיסק. הפלט זהה לפלט של קבצים שנטענו לזיכרון באופן מלא.

דוגמאות

כדי לבצע השוואת ASCII בין שני קבצי טקסט ששמם Monthly.rpt ו- Sales.rpt ולהציג תוצאות בתבנית מקוצרת, הקלד:

fc /a monthly.rpt sales.rpt

כדי לבצע השוואה בינארית בין שני קבצי אצווה בשם Profits.bat ו- Earnings.bat, הקלד:

fc /b profits.bat earnings.bat

מופיעות תוצאות הדומות לדוגמה שלהלן:

00000002: 72 43
00000004: 65 3A
0000000E: 56 92
00000012: 6D 5C
00000013: 0D 7C
00000014: 0D 0A
00000015: 0A 0D
0000001E: 43 7A
0000001F: 09 0A
00000022: 72 44
...
...
...
000005E0: 00 61
000005E1: 00 73
000005E2: 00 73
000005E3: 00 69
000005E4: 00 67
000005E5: 00 6E
000005E6: 00 6D
000005E7: 00 65
000005E8: 00 6E
FC: Earnings.bat longer than Profits.bat

אם הקבצים Profits.bat ו- Earnings.bat זהים, הפקודה fc מציגה את ההודעה הבאה:

FC: no differences encountered

כדי להשוות את כל קבצי ‎.bat בספריה הנוכחית עם הקובץ New.bat, הקלד:

fc *.bat new.bat

כדי להשוות את הקובץ New.bat בכונן C עם הקובץ New.bat בכונן D, הקלד:

fc c:new.bat d:*.bat

כדי להשוות כל קובץ אצווה בספריית הבסיס בכונן C עם הקובץ בעל אותו שם בספריית הבסיס בכונן D, הקלד:

fc c:*.bat d:*.bat


Fcbs

ציון מספר בלוקי בקרת הקבצים ‏(FCB) שבאפשרות מערכת המשנה MS-DOS לפתוח בו-זמנית. השתמש בקובץ systemroot\System32\Config.nt או בקובץ ההפעלה המקביל שצוין בקובץ המידע של התוכנית ‏(PIF) של התוכנית כדי לציין את מספר בלוקי בקרת הקבצים.

תחביר

fcbs=x

פרמטרים

x
נדרש. ציון מספר בלוקי בקרת הקבצים שבאפשרות מערכת המשנה MS-DOS לפתוח בו-זמנית. ערכים חוקיים עבור x נמצאים בטווח שבין 1 ל- 255. ערך ברירת המחדל הוא 4.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • בלוק של בקרת קובץ הוא מבנה נתונים המאחסן מידע אודות קובץ.
  • אם התוכנית מנסה לפתוח יותר קבצים מהמספר המצוין בפרמטר x באמצעות בלוקי בקרת קבצים, מערכת המשנה MS-DOS עשויה לסגור חלק מהקבצים שנפתחו מוקדם יותר.
  • עליך להשתמש בפקודה fcbs רק אם פעולה זו דרושה עבור תוכנית. רוב התוכניות החדשות אינן דורשות בלוקי בקרת קבצים. עם זאת, ייתכן שעבור תוכניות מסוימות ישנות יותר יהיה צורך להשתמש בפקודה fcbs בקובץ Config.nt.

דוגמאות

כדי לציין שלמערכת המשנה MS-DOS תהיה אפשרות לפתוח עד שמונה בלוקי בקרת קבצים בו-זמנית, הקלד את השורה הבאה בקובץ Config.nt:

fcbs=8


Files

קביעת מספר הקבצים אליהם באפשרות מערכת המשנה MS-DOS לגשת בו-זמנית. השתמש בקובץ systemroot\System32\Config.nt או בקובץ ההפעלה המקביל שצוין בקובץ המידע של התוכנית ‏(PIF) כדי לציין את הפרמטר files.

תחביר

files=x

פרמטרים

x
נדרש. מציין את מספר הקבצים אליהם באפשרות מערכת המשנה MS-DOS לגשת בו-זמנית. ערכים חוקיים עבור x נמצאים בטווח שבין 8 ל- 255. ערך ברירת המחדל הוא 8.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • למרות שהגדרת ברירת המחדל של הפרמטר x היא 8, עבור תוכניות מסוימות דרוש ערך גדול יותר. הגדרה אופיינית היא 20.

דוגמאות

כדי לציין שבאפשרות מערכת המשנה MS-DOS לגשת ל- 20 קבצים לכל היותר בו-זמנית, הקלד את השורה הבאה בקובץ Config.nt:

files=20


Find

חיפוש אחר מחרוזת טקסט ספציפית בקובץ או בקבצים. לאחר השלמת החיפוש בקבצים שצוינו, הפקודה find מציגה את כל שורות הטקסט המכילות את המחרוזת שצוינה.

תחביר

find [/v]‎ [‎/c] [‎/n] [‎/i] "string" ‎[[Drive:][Path]FileName[...]]‎

פרמטרים

‎/v
הצגת כל השורות שאינן מכילות את הטקסט שצוין בפרמטר string.
‎/c
ספירת השורות המכילות את הטקסט שצוין בפרמטר string והצגת המספר הכולל שלהן.
‎/n
קביעת מספר השורה של הקובץ בתחילת כל שורה.
‎/i
ציון שהחיפוש אינו תלוי רישיות.
"string"
נדרש. ציון קבוצת התווים שברצונך לחפש. עליך לתחום את הטקסט של הפרמטר string במרכאות (כלומר, "string").
‎[Drive:][Path] FileName
קביעת המיקום והשם של הקובץ בו ברצונך לחפש אחר המחרוזת שצוינה.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • קביעת מחרוזת

    אם אינך משתמש בפרמטר ‎/i, הפקודה find מחפשת בדיוק מה שצוין בפרמטר string. לדוגמה, הפקודה find מתייחסת לתווים "a" ו- "A" כתווים שונים. עם זאת, אם אתה משתמש בפרמטר ‎/i, הפקודה find אינה תלויית רישיות ומתייחסת ל- "a" ול- "A" כאל אותו תו.

    אם המחרוזת אחריה ברצונך לחפש מכילה מרכאות, עליך להשתמש בשני תווי מרכאות עבור כל תו מרכאות המופיע במחרוזת (כלומר, "StringContaining""QuotationMarks").

  • שימוש בפקודה find כמסנן

    אם תשמיט שם של קובץ, הפקודה find תפעל כמסנן על-ידי לקיחת קלט ממקור הקלט הסטנדרטי (בדרך כלל לוח המקשים, Pipe או קובץ מנותב מחדש) ולאחר מכן הצגה של כל השורות המכילות את הטקסט המופיע בפרמטר string.

  • סידור תחביר הפקודה

    באפשרותך להקליד פרמטרים ואפשרויות שורת פקודה עבור הפקודה find בכל סדר.

  • שימוש בתווים כלליים

    אין באפשרותך להשתמש בתווים כלליים (* ו- ?) בשמות קבצים או סיומות שצוינו עם הפקודה find. כדי לחפש מחרוזת בערכת קבצים שצוינה עם תווים כלליים, באפשרותך להשתמש בפקודה find בתוך הפקודה for.

  • שימוש בפרמטר ‎/v או בפרמטר ‎/n עם ‎/c

    אם תציין את הפרמטרים ‎/c ו- ‎/v באותה שורת פקודה, הפקודה find תציג את מספר השורות שאינן מכילות את המחרוזת שצוינה. אם תציין את הפרמטרים ‎/c ו- ‎/n באותה שורת פקודה, הפקודה find תתעלם מהפרמטר ‎/n.

  • שימוש בפקודה find עם החזרות גררה

    הפקודה find אינה מזהה החזרות גררה. כאשר תשתמש בפקודה find לביצוע חיפוש אחר טקסט בקובץ הכולל החזרות גררה, עליך להגביל את מחרוזת החיפוש לטקסט שניתן למצוא בין החזרות גררה (כלומר, מחרוזת שלא סביר שתיקטע על-ידי החזרות גררה). לדוגמה, הפקודה find אינה מדווחת על התאמה עבור המחרוזת "tax file" כאשר החזרת גררה מופיעה בין המילה "tax" והמילה "file".

דוגמאות

כדי להציג את כל השורות בקובץ Pencil.ad המכילות את המחרוזת "Pencil Sharpener", הקלד:

find "Pencil Sharpener" pencil.ad

כדי לחפש מחרוזת המכילה טקסט בין מרכאות, עליך לתחום תחילה את המחרוזת כולה בין מרכאות. שנית, עליך להשתמש בשני גרשיים עבור כל גרש הכלול במחרוזת. כדי לחפש את המחרוזת ‎"The scientists labeled their paper "for discussion only." It is not a final report."‎ בקובץ Report.doc, הקלד:

find "The scientists labeled their paper ""for discussion only."" It is not a final report." report.doc

אם ברצונך לחפש ערכה של קבצים, באפשרותך להשתמש בפקודה find עם הפקודה for. כדי לחפש בספריה הנוכחית אחר קבצים בעלי הסיומת ‎.bat המכילים את המחרוזת "PROMPT", הקלד:

for %f in (*.bat) do find "PROMPT" %f

כדי לחפש בדיסק הקשיח שלך ולהציג שמות קבצים בכונן C המכילים את המחרוזת "CPU," השתמש בתו | כדי לנתב את התוצאות של פקודת dir לפקודה find כדלהלן:

dir c:\ /s /b | find "CPU"‎

מכיוון שהחיפושים של הפקודה find תלויי רישיות והפקודה dir מפיקה פלט באותיות רישיות, עליך להקליד את המחרוזת "CPU" באותיות רישיות או להשתמש באפשרות שורת הפקודה ‎/i עם הפקודה find.


Findstr

חיפוש אחר תבניות טקסט בקבצים באמצעות ביטויים רגילים.

תחביר

findstr [‎/b] [‎/e] [‎/l] [‎/r] [‎/s] [‎/i] [‎/x] [‎/v ] [‎/n] [‎/m] [‎/o] [‎/p] [‎/offline] [‎/g:file] [‎/f:file] [‎/c:string] [‎/d:dirlist] [‎/a:ColorAttribute] strings ‎[[Drive:][Path] FileName [...]]‎

פרמטרים

‎/b
התאמת התבנית אם תבנית זו נמצאת בתחילת שורה.
‎/e
התאמת התבנית אם תבנית זו נמצאת בסוף שורה.
‎/l
שימוש במחרוזות חיפוש באופן מילולי.
‎/r
שימוש במחרוזות חיפוש כביטויים רגילים. הפקודה findstr מפרשת את כל המטה-תווים כביטויים רגילים אלא אם כן תעשה שימוש בפרמטר ‎/l.
‎/s
חיפוש אחר קבצים תואמים בספריה הנוכחית ובכל ספריות המשנה.
‎/i
קובע כי ברצונך שהחיפוש לא יהיה תלוי רישיות.
‎/x
הדפסת שורות התואמות במדויק.
‎/v
הדפסת שורות שאינן מכילות התאמה בלבד.
‎/n
הדפסת מספר השורה לפני כל שורה תואמת.
‎/m
הדפסת שם הקובץ בלבד אם הקובץ מכיל התאמה.
‎/o
הדפסה של היסט חיפוש לפני כל שורה תואמת.
‎/p
דילוג על קבצים בעלי תווים בלתי ניתנים להדפסה.
‎/offline
עיבוד קבצים שנקבעה עבורם התכונה לא מקוון.
‎/f:file
קריאה של רשימת קבצים מהקובץ שצוין.
‎/c:string
שימוש בטקסט שצוין כמחרוזת חיפוש מילולית.
‎/g:file
קבלת מחרוזות חיפוש מהקובץ שצוין.
‎/d:dirlist
ביצוע חיפוש ברשימת ספריות המופרדות באמצעות פסיק.
‎/a:ColorAttribute
קביעה של תכונות צבעים עם שתי ספרות הקסדצימאליות.
strings
הטקסט שצוין שאותו יש לחפש בקובץ המופיע בפרמטר FileName.
‎[Drive:][Path] FileName [...]‎
ציון קובץ או קבצים לחיפוש.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • שימוש בביטויים רגילים עם הפקודה findstr

    לפקודה findstr יש אפשרות למצוא את הטקסט המדויק שאתה מחפש בכל קובץ או קבצים מסוג ASCII. עם זאת, לעיתים נמצא ברשותך רק חלק מהמידע שברצונך להתאים או שברצונך למצוא טווח רחב יותר של מידע. במקרים כאלה, לפקודה findstr יש את היכולת רבת-העוצמה לחפש תבניות של טקסט באמצעות ביטויים רגילים.

    ביטויים רגילים הם סימון לקביעת תבניות של טקסט, בניגוד למחרוזות טקסט מדויקות. הסימון משתמש בתווים מילוליים ובמטה-תווים. כל תו שאין לו משמעות מיוחדת בתחביר הביטוי הרגיל הוא תו מילולי ותואם למופע של תו זה. לדוגמה, אותיות ומספרים הם תווים מילוליים. מטה-תו הוא סימן עם משמעות מיוחדת (אופרטור או מפריד) בתחביר של הביטוי הרגיל.

    הטבלה הבאה מפרטת את המטה-תווים המתקבלים על-ידי הפקודה findstr.

    תו | ערך
    . תווים כלליים: כל תו
    * חזרה: אפס או מופעים נוספים של מחלקה או תו קודם
    ^ מיקום שורה: תחילת שורה
    $ מיקום שורה: סוף שורה
    [class] | מחלקת תווים: כל תו בודד בקבוצה
    ‎[^class]‎ | מחלקה הופכית: כל תו בודד שלא נמצא בקבוצה
    [x-y] | טווח: כל התווים בטווח שצוין
    ‎\x | Escape: שימוש מילולי במטה-תו x
    ‎\<xyz | מיקום מילה: תחילת המילה
    ‎xyz\>‎ | מיקום מילה: סוף המילה

    התווים המיוחדים בתחביר של ביטוי רגיל הם בעלי עוצמה רבה ביותר כאשר נעשה בהם שימוש ביחד. לדוגמה, השילוב הבא של התו הכללי (.) ותו חזרה (*) תואם לכל מחרוזת תווים:

    ‎.*‎

    השתמש בביטוי הבא כחלק מביטוי גדול יותר התואם לכל מחרוזת המתחילה ב- "b" ומסתיימת ב- "ing":

    b.*ing

דוגמאות

השתמש ברווחים כדי להפריד מחרוזות חיפוש מרובות אלא אם מופיע לפני הארגומנט הפרמטר ‎/c. כדי לחפש אחר "hello" או "there" בקובץ x.y, הקלד:

findstr "hello there" x.y

כדי לחפש אחר "hello there" בקובץ x.y, הקלד:

findstr /c:"hello there" x.y

כדי למצוא את כל המופעים של המילה "Windows" (עם אות W ראשונה רישית) בקובץ Proposal.txt, הקלד את הביטוי הבא:

findstr Windows proposal.txt

כדי לבצע חיפוש בכל הקבצים בספריה הנוכחית ובכל ספריות המשנה המכילות את המילה Windows, מבלי להתייחס לרישיות, הקלד את הביטוי הבא:

findstr /s /i Windows *.*‎

כדי למצוא את כל המופעים של שורות המכילות את המילה "FOR", שלפניה מספר כלשהו של רווחים (כמו בלולאה של תוכנית מחשב) ולכלול את מספר השורה בה נמצא כל מופע, הקלד את הביטוי הבא:

findstr /b /n /c:" *FOR" *.bas

אם ברצונך לבצע חיפוש אחר מספר פריטים שונים בתוך אותה ערכה של קבצים, צור קובץ טקסט המכיל כל קריטריון חיפוש בשורה חדשה. בנוסף, באפשרותך לפרט במדויק את הקבצים בהם ברצונך לבצע את החיפוש בקובץ טקסט. כדי להשתמש בקריטריוני חיפוש בקובץ Finddata.txt, לבצע חיפוש בקבצים המפורטים בקובץ Filelist.txt ולאחר מכן לאחסן את התוצאות בקובץ Results.out, הקלד את הביטוי הבא:

findstr /g:finddata.txt /f:filelist.txt > results.out

נניח שברצונך למצוא את כל הקבצים בספריה הנוכחית ובכל ספריות המשנה המכילים את המילה computer, מבלי להתייחס לרישיות. כדי לפרט את כל הקבצים המכילים את המילה computer, הקלד את הביטוי הבא:

findstr /s /i /m "\<computer\>" *.*‎

כעת נניח שברצונך למצוא לא רק את המילה "computer", אלא גם כל מילה אחרת המתחילה באותיות comp, כגון "compliment" ו- "compete". הקלד את הביטוי הבא:

findstr /s /i /m "\<comp.*" *.*‎


Finger

הצגת מידע אודות משתמש או משתמשים במחשב מרוחק שצוין (בדרך כלל מחשב בו פועל UNIX) בו פועל שירות או Daemon של Finger. המחשב המרוחק מציין את התבנית והפלט של תצוגת מידע המשתמש. בעת שימוש ללא פרמטרים, הפקודה finger מציגה עזרה.

תחביר

finger [-l]‎ [User] [@host] ‎[...]‎

פרמטרים

‎-l
הצגת מידע בתבנית של רשימה ארוכה.
User
ציון המשתמש שברצונך לקבל מידע אודותיו. אם תשמיט את הפרמטר User, הפקודה finger תציג מידע אודות כל המשתמשים במחשב שצוין.
‎@host
מציין את המחשב המרוחק בו פועל שירות Finger ובו אתה מחפש מידע אודות משתמשים. באפשרותך לציין שם מחשב או כתובת IP.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • ניתן לציין פרמטרי User@host מרובים.
  • עליך להקדים פרמטרים של הפקודה finger עם מקף (-) ולא עם קו נטוי (/).
  • פקודה זו זמינה רק אם פרוטקול אינטרנט ‏(TCP/IP) מותקן כרכיב במאפייני מתאם רשת בחיבורי רשת.
  • Windows 2000 ו- Windows XP לא מספקים שירותי Finger.

דוגמאות

כדי להציג מידע עבור user1 במחשב users.microsoft.com, הקלד את הפקודה הבאה:

finger user1@users.microsoft.com

כדי להציג מידע עבור כל המשתמשים במחשב users.microsoft.com, הקלד את הפקודה הבאה:

finger @users.microsoft.com


For

הפעלת הפקודה שצוינה עבור כל קובץ בערכת קבצים.

תחביר

for {%variable|%%variable} in (set) do command [ CommandLineOptions]‎

פרמטרים

‎{%variable|%%variable}‎
פרמטר נדרש. פרמטר זה מייצג פרמטר ניתן להחלפה. השתמש ב- ‎%variable כדי לבצע את הפקודה for משורת הפקודה. השתמש ב- ‎%%variable כדי לבצע את הפקודה for מתוך קובץ אצווה. משתנים הם תלויי רישיות ועליהם להיות מיוצגים באמצעות ערך אלפביתי, כגון ‎%A‏, ‎%B או ‎%C.
(set)
פרמטר נדרש. פרמטר זה מציין קובץ, ספריה, טווח ערכים או מחרוזת טקסט אחת או יותר שברצונך לעבד עם הפקודה שצוינה. הסוגריים נדרשים.
command
פרמטר נדרש. פרמטר זה מציין את הפקודה שברצונך לבצע עבור כל קובץ, ספריה, טווח ערכים או מחרוזת טקסט שנכללו בפרמטר (set) שצוין.
CommandLineOptions
ציון אפשרויות שורת פקודה כלשהן בהן ברצונך להשתמש עם הפקודה שצוינה.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • שימוש בפקודה for

    באפשרותך להשתמש בפקודה for מתוך קובץ אצווה או ישירות משורת הפקודה.

  • שימוש בפרמטרי אצווה

    התכונות הבאות חלות על הפקודה for:

    • הפקודה for מחליפה את ‎%variable או את ‎%%variable בכל מחרוזת טקסט שצוינה בפרמטר set עד אשר הפקודה שצוינה בפרמטר command סיימה לעבד את כל הקבצים.
    • יש לזכור כי השמות בפרמטר variable של הפקודה for הם תלויי רישיות, כלליים ולא יותר מ- 52 מהם יכולים להיות פעילים בו-זמנית.
    • כדי למנוע בלבול עם פרמטרי האצווה %0 עד %9, באפשרותך להשתמש בכל תו עבור הפרמטר variable מלבד הספרות 0 עד 9. עבור קבצי אצווה פשוטים, מספיק תו בודד כגון ‎%%f .
    • באפשרותך להשתמש בערכים מרובים עבור variable בקבצי אצווה מורכבים כדי להבחין בין משתנים שונים הניתנים להחלפה.
  • קביעת קבוצה של קבצים

    לפרמטר set יש אפשרות לייצג קבוצה בודדת של קבצים או מספר קבוצות של קבצים. באפשרותך להשתמש בתווים כלליים (* ו- ?) כדי לציין ערכת קבצים. להלן ערכות קבצים חוקיות:

    (‎*.doc)

    (‎*.doc ‎*.txt ‎*.me)

    (jan*.doc jan*.rpt feb*.doc feb*.rpt)

    ‎(ar??1991.* ap??1991.*)‎

    בעת שימוש בפקודה for, הערך הראשון בפרמטר set מחליף את ‎%variable או את ‎%%variable ולאחר מכן הפקודה שצוינה מעבדת את הערך. פעולה זו נמשכת עד סיום עיבוד כל הקבצים (או קבוצות הקבצים) המתאימים לערך שצוין בפרמטר set.

  • שימוש במילות המפתח in ו- do

    In ו- do אינם פרמטרים, אך עליך להשתמש בהם עם הפקודה for. אם תשמיט אחת ממילות מפתח אלה, תוצג הודעת שגיאה.

  • שימוש בצורות נוספות של הפקודה for

    אם הופעלו הרחבות פקודה (ברירת המחדל), נתמכות הצורות הבאות של הפקודה for:

    • ספריות בלבד

      אם הפרמטר set כולל תווים כלליים (* ו- ?), הפקודה המצוינת בפרמטר command פועלת עבור כל ספריה (במקום עבור ערכת קבצים בספריה שצוינה) התואמת לערך שנקבע בפרמטר set. התחביר הוא:

      for /D {%% | %}variable in (set) do command [CommandLineOptions]

    • רקורסיבי

      מעבר בעץ הספריות שבסיסו ב- ‎[Drive:]Path תוך הפעלת המשפט for בכל ספריה הנמצאת בעץ. אם לא צוינה ספריה לאחר ‎/R, המערכת תניח שמדובר בספריה הנוכחית. אם הפרמטר set הוא תו נקודה בודד (.), תבוצע ספירה של עץ הספריות בלבד. התחביר הוא:

      for /R [[Drive :]Path] {%% | %}variable in (set) do command [CommandLineOptions]

    • איטראציה של טווח ערכים

      השתמש במשתנה איטראטיבי לקביעת ערך ההתחלה (start#) ולאחר מכן למעבר דרך טווח של ערכים שנקבע עד שהערך עובר את ערך הסיום שנקבע (end#). הפרמטר ‎/L יבצע את המשתנה האיטראטיבי על-ידי השוואת הערך start# עם הערך end#. אם הערך start# קטן מהערך end# הפקודה תתבצע. כאשר המשתנה האיטראטיבי עובר את הערך end# מעטפת הפקודה יוצאת מהלולאה. כמו כן, באפשרותך להשתמש בערך שלילי בפרמטר step# כדי לבצע מעבר בטווח ערכים הולכים וקטנים. לדוגמה, (1,1,5) מפיק את הרצף 1 2 3 4 5 ו- (‎5, -1, 1) מפיק את הרצף (‎5 4 3 2 1). התחביר הוא:

      for /L {%% | %}variable in (start#,step#,end#) do command [CommandLineOptions]

    • איטראציה וניתוח מבנה טקסט של קבצים

      השתמש בניתוח מבנה טקסט של קבצים לעיבוד פלט פקודה, מחרוזות ותוכן קבצים. השתמש במשתנים איטראטיביים כדי להגדיר את התוכן או את המחרוזות שברצונך לבחון והשתמש באפשרויות השונות של הפרמטר ParsingKeywords כדי לשנות עוד את הניתוח. השתמש באפשרות token של ParsingKeywords כדי לציין אילו Tokens יועברו כמשתני איטראציה. שים לב שאם לא נעשה שימוש באפשרות Token, הפרמטר ‎/F יבחן רק את ה- Token הראשון.

      עיבוד ניתוח מבנה של קובץ כולל קריאת הפלט, פירוק הקובץ לשורות טקסט אינדיבידואליות ולאחר מכן ניתוח מבנה טקסט של כל שורה לאפס או ליותר Tokens. לאחר מכן הלולאה for נקראת עם משתנה האיטראציה הנקבע ל- Token. כברירת מחדל, הפרמטר ‎/F מעביר את ה- Token המופרד הריק הראשון מכל שורה של כל קובץ. המערכת מדלגת על שורות ריקות. אפשרויות התחביר השונות הן:

      for /F ["ParsingKeywords"] {%% | %}variable in (filenameset) do command [CommandLineOptions]‎

      for /F ["ParsingKeywords"] {%% | %}variable in (‎"LiteralString‎") do command [CommandLineOptions]‎

      for /F ["ParsingKeywords"] {%% | %}variable in ('command') do command [CommandLineOptions]‎

      הארגומנט filenameset מציין שם קובץ אחד או יותר. כל קובץ נפתח, נקרא ועובר עיבוד לפני מעבר לקובץ הבא שצוין ב- filenameset. כדי לעקוף את אופן הפעולה של ניתוח מבנה הטקסט שהוגדר כברירת מחדל, ציין את הפרמטר "ParsingKeywords". זוהי מחרוזת מוקפת במרכאות המכילה מילת מפתח אחת או יותר לקביעת אפשרויות שונות לניתוח מבנה טקסט.

      אם אתה עושה שימוש באפשרות usebackq, השתמש באחת מאפשרויות התחביר הבאות:

      for /F ["usebackq ParsingKeywords"] {%% | %}variable in (‎"filenameset") do command [CommandLineOptions]‎

      for /F ["usebackq ParsingKeywords"] {%% | %}variable in (‎'LiteralString') do command [CommandLineOptions]‎

      for /F ["usebackq ParsingKeywords"] {%% | %}variable in (‎`command`) do command [CommandLineOptions]‎

      הטבלה הבאה מפרטת את מילות המפתח עבור ניתוח מבנה טקסט בהן ניתן להשתמש בפרמטר ParsingKeywords.

      מילת מפתח | תיאור
      eol=c | ציון תו סוף שורה (תו אחד בלבד).
      skip=n | ציון מספר השורות עליהן יש לדלג בתחילת הקובץ.
      delims=xxx | ציון ערכת מפרידים. מילת מפתח זו מחליפה את ערכת המפרידים של רווח וטאב המהווה ברירת מחדל.
      tokens=x,y,m-n | ציון ה- Tokens מכל שורה שיועברו לגוף הפקודה for בכל איטראציה. פעולה זו תגרום להקצאה של שמות משתנים נוספים. הצורה m-n היא טווח המציין את ה- Token‏ ה- m עד ה- n. אם התו האחרון במחרוזת tokens=‎ הוא כוכבית (*), תתבצע הקצאה של משתנה נוסף שיקבל את הטקסט שנותר בשורה לאחר שבוצע ניתוח מבנה טקסט של ה- Token האחרון.
      usebackq | מילת מפתח זו מציינת שניתן להשתמש במרכאות לציטוט שמות קבצים במשתנה filenameset, מחרוזת המוקפת בגרשיים הפוכים מתבצעת כפקודה ומחרוזת המוקפת בגרשיים בודדים היא פקודת מחרוזת מילולית.
    • החלפת משתנים

      בנוסף, בוצעו שיפורים בביטויים המגבילים של ההחלפה עבור הפניות משתנים של הפקודה for. הטבלה הבאה מציינת תחביר אופציונלי (עבור כל משתנה I).

      משתנה עם ביטוי מגביל | תיאור
      ‎%~I | הרחבת ‎%I, דבר המביא להסרת מרכאות ("") העשויות להופיע.
      ‎%~fI | הרחבת ‎%I לשם של נתיב מלא.
      ‎%~dI | הרחבת ‎%I לאות כונן בלבד.
      ‎%~pI | הרחבת ‎%I לנתיב בלבד.
      ‎%~nI | הרחבת ‎%I לשם קובץ בלבד.
      ‎%~xI | הרחבת ‎%I לסיומת קובץ בלבד.
      ‎%~sI | הרחבת נתיב כך שיכלול שמות קצרים בלבד.
      ‎%~aI | הרחבת ‎%I לתכונות הקובץ של קובץ.
      ‎%~tI | הרחבת ‎%I לתאריך ושעה של קובץ.
      ‎%~zI | הרחבת ‎%I לגודל של קובץ.
      ‎%~$PATH:I | חיפוש בספריות המפורטות במשתנה הסביבה PATH והרחבת ‎%I לשם מלא של הקובץ הראשון שנמצא. אם השם של משתנה הסביבה אינו מוגדר או שהקובץ אינו נמצא בחיפוש, רכיב שינוי זה מורחב למחרוזת הריקה.

      הטבלה הבאה מפרטת את צירופי רכיבי השינוי השונים בהם באפשרותך להשתמש כדי לקבל תוצאות מורכבות.

      משתנה עם ביטויים מגבילים משולבים | תיאור
      ‎%~dpI | הרחבת ‎%I לאות כונן ונתיב בלבד.
      ‎%~nxI | הרחבת ‎%I לשם קובץ וסיומת בלבד.
      ‎%~fsI | הרחבת ‎%I לשם נתיב מלא עם שמות קצרים בלבד.
      ‎%~dp$PATH:I | חיפוש אחר ‎%I בספריות המפורטות במשתנה הסביבה PATH והרחבה לאות כונן ולנתיב של הקובץ הראשון שנמצא.
      ‎%~ftzaI | הרחבת ‎%I לשורת פלט שהיא כמו dir.

      בדוגמאות שלעיל, באפשרותך להחליף את ‎%I ואת PATH בערכים חוקיים אחרים. שם משתנה חוקי עבור for מסיים את התחביר ‎%~‎.

      שימוש בשמות משתנים שהם אותיות רישיות, כגון ‎%I, עשוי להפוך את הקוד לקריא יותר ולמנוע בלבול עם הביטויים המגבילים, שאינם תלויי רישיות.

  • ניתוח מבנה טקסט של מחרוזת

    באפשרותך להשתמש בלוגיקת ניתוח מבנה הטקסט for /F במחרוזת מיידית, על-ידי הקפת הפרמטר filenameset בין הסוגריים בגרשיים (כלומר 'filenameset'). ההתייחסות לפרמטר filenameset היא כמו לשורה בודדת של קלט מקובץ ולאחר מכן מתבצע ניתוח מבנה הטקסט שלו.

  • ניתוח מבנה טקסט של פלט

    באפשרותך להשתמש בפקודה for /F כדי לנתח מבנה טקסט של פלט של פקודה. באפשרותך לבצע פעולה זו על-ידי הוספת גרשיים הפוכים מסביב לפרמטר filenameset שבין הסוגריים. המערכת תתייחס למחרוזת זו כאל שורת פקודה, שתועבר לצאצא Cmd.exe והפלט יילכד בזיכרון ויבוצע עבורו ניתוח של מבנה טקסט כאילו מדובר בקובץ.

דוגמאות

כדי להשתמש בפקודה for בקובץ אצווה, השתמש בתחביר הבא:

for %%variable in (set) do command [CommandLineOptions]‎

כדי להציג את התוכן של כל הקבצים בספריה הנוכחית בעלי הסיומת ‎.doc או ‎.txt באמצעות המשתנה הניתן להחלפה ‎%f, הקלד:

for %f in (*.doc *.txt) do type %f

בדוגמה שלעיל, כל קובץ בעל סיומת ‎.doc או ‎.txt בספריה הנוכחית מחליף את המשתנה ‎%f עד סיום הצגת התוכן של כל הקבצים. כדי להשתמש בפקודה זו בקובץ אצווה, עליך להחליף כל מופע של ‎%f ב- ‎%%f. אחרת, המערכת תתעלם מהמשתנה ותוצג הודעת שגיאה.

כדי לבצע ניתוח מבנה טקסט לקובץ תוך התעלמות משורות בעלות הערה, הקלד:

for /F "eol=; tokens=2,3* delims=," %i in (myfile.txt) do ‎@echo %i %j %k

פקודה זו מבצעת ניתוח של מבנה טקסט עבור כל שורה בקובץ Myfile.txt, תוך התעלמות משורות המתחילות בנקודה-פסיק והעברה של ה- Token השני והשלישי מכל שורה לגוף הפקודה FOR, כאשר Tokens מופרדים על-ידי פסיקים או רווחים. גוף משפט FOR מפנה את ‎%i ל- Token השני, את ‎%j ל- Token השלישי ואת ‎%k לכל שאר ה- Tokens. אם שמות הקבצים שאתה מספק מכילים רווחים, השתמש במרכאות מסביב לטקסט (לדוגמה, ‎"File Name"‎). כדי להשתמש במרכאות, עליך להשתמש בפרמטר usebackq. אחרת, המערכת מתייחסת למרכאות כאילו הן מגדירות מחרוזת מילולית עבור ניתוח מבנה טקסט .

הפרמטר ‎%i מצוין באופן מפורש במשפט FOR והפרמטרים ‎%j and ‎%k מצוינים באופן משתמע על-ידי שימוש בפרמטר tokens=‎. באפשרותך לציין עד 26 ‏Tokens באמצעות tokens=‎, בתנאי שלא יתבצע כתוצאה מפעולה זו ניסיון להצהיר על משתנה שיהיה גבוה מהאות 'z' או 'Z'.

כדי לבצע ניתוח מבנה טקסט של פקודה על-ידי הצבת הפרמטר filenameset בין הסוגריים, הקלד:

for /F "usebackq delims==" %i IN (`set`) DO @echo %i

דוגמה זו מבצעת ספירה של שמות משתני הסביבה בסביבה הנוכחית.


Forcedos

הפעלת התוכנית שצוינה במערכת המשנה MS-DOS. פקודה זו נחוצה רק עבור תוכניות MS-DOS שלא זוהו ככאלה על-ידי Windows XP.

תחביר

forcedos [/d directory] FileName [parameters]‎

פרמטרים

‎/d directory
קביעת הספריה הנוכחית עבור התוכנית שצוינה לשימוש.
FileName
פרמטר נדרש. ציון התוכנית שיש להפעיל. אם תוכנית זו אינה נמצאת בספריה הנוכחית או בנתיב הנוכחי, עליך לציין את אות הכונן או את הספריות של התוכנית.
parameters
קביעת פרמטרים שיש להעביר לתוכנית.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • XOX
  • XOX
  • תוכניות MS-DOS מסוימות אינן מזוהות על-ידי Windows XP כתוכניות MS-DOS. השתמש בפקודה forcedos כדי להפעיל תוכניות אלה.
  • כל התוכניות שתפעיל באמצעות forcedos נפתחות כיישומי MS-DOS.

דוגמאות

כדי להפעיל את התוכנית Myprog בספריה ‎\Oldapps כך שיהיה באפשרותך להשתמש בספריה ‎\Reports, הקלד:

forcedos /d reports \oldapps\myprog


Format

אתחול הדיסק באמצעי האחסון שצוין לקבלת קבצים של Windows.

תחביר

format volume [‎/fs:file-system] [‎/v:label] [‎/q] [‎/a:UnitSize] [‎/c] ‎[/x]‎

format volume [‎/v:label] [‎/q] ‎[/f:size]‎

format volume [‎/v:label] [‎/q] ‎[/t:tracks /n:sectors]‎

format volume [‎/v:label] ‎[/q]‎

format volume ‎[/q]‎

פרמטרים

volume
ציון נקודת הטעינה, שם אמצעי האחסון או אות הכונן של הכונן שברצונך לאתחל. אם לא תציין אחת מאפשרויות שורת הפקודה שלהלן, הפקודה format תשתמש בסוג של אמצעי האחסון כדי לקבוע את אתחול ברירת המחדל עבור הדיסק.
‎/fs:file-system
ציון מערכת הקבצים בה ברצונך להשתמש, FAT‏, FAT32 או NTFS. לתקליטונים יש אפשרות להשתמש במערכת הקבצים FAT בלבד.
‎/v:label
ציון התווית של אמצעי האחסון. אם תשמיט את אפשרות שורת הפקודה ‎/v או תשתמש באפשרות זו מבלי לציין תווית של אמצעי אחסון, הפקודה format תציג בפניך בקשה לציון התווית של אמצעי האחסון לאחר השלמת האתחול. השתמש בתחביר ‎/v:‎ כדי למנוע את הצגת הבקשה לציון תווית של אמצעי אחסון. אם תאתחל יותר מדיסק אחד באמצעות פקודת format אחת, כל הדיסקים יקבלו את אותה תווית של אמצעי אחסון. לקבלת מידע נוסף אודות תוויות אמצעי אחסון של דיסקים, לחץ על Dir‏, Label ו- Vol ברשימת הנושאים הקרובים.
‎/a:UnitSize
ציון הגודל של יחידת ההקצאה בו יש להשתמש באמצעי אחסון מסוג FAT‏, FAT32 או NTFS. אם לא תציין UnitSize, פרמטר זה ייבחר בהתאם לגודל של אמצעי האחסון. הטבלה שלהלן מפרטת ערכים חוקיים עבור UnitSize.
ערך | תיאור
512 | יצירת 512 בתים לכל אשכול.
1024 | יצירת 1024 בתים לכל אשכול.
2048 | יצירת 2048 בתים לכל אשכול.
4096 | יצירת 4096 בתים לכל אשכול.
8192 | יצירת 8192 בתים לכל אשכול.
16K | יצירת 16 קילו-בתים לכל אשכול.
32K | יצירת 32 קילו-בתים לכל אשכול.
64K | יצירת 64 קילו-בתים לכל אשכול.
‎/q
ביצוע אתחול מהיר. מחיקת טבלת הקבצים וספריית הבסיס של אמצעי אחסון שאותחל בעבר, אך ללא ביצוע סריקה לאיתור אזורים פגומים. עליך להשתמש באפשרות שורת הפקודה ‎/q כדי לאתחל רק אמצעי אחסון שאותחלו בעבר, שידוע לך שמצבם תקין.
‎/f:size
ציון הגודל של התקליטון לאתחול. במידת האפשר, השתמש באפשרות שורת פקודה זו במקום אפשרויות שורת הפקודה ‎/t ו- ‎/n‏. Windows מקבל את הערכים הבאים עבור הגודל:

1440 או 1440k או 1440kb או 1.44 או 1.44m או 1.44mb
דיסק של 1.44‎-MB, דו-צידי, בעל קיבולת גבוהה פי ארבע, בגודל 3.5 אינץ'.

‎/t:tracks
ציון מספר הרצועות בדיסק. כאשר הדבר אפשרי, השתמש באפשרות שורת הפקודה ‎/f במקום אפשרות שורת פקודה זו. אם תשתמש באפשרות שורת הפקודה ‎/t, עליך להשתמש גם באפשרות שורת הפקודה ‎/n. שתי אפשרויות שורת הפקודה האלה מספקות שיטה חלופית לציון גודל הדיסק המאותחל. אין באפשרותך להשתמש באפשרות שורת הפקודה ‎/f ביחד עם אפשרות שורת הפקודה ‎/t.
‎/n:sectors
ציון מספר הסקטורים בכל רצועה. כאשר הדבר אפשרי, השתמש באפשרות שורת הפקודה ‎/f במקום אפשרות שורת פקודה זו. אם תשתמש באפשרות שורת הפקודה ‎/n, עליך להשתמש גם באפשרות שורת הפקודה ‎/t. שתי אפשרויות שורת הפקודה האלה מספקות דרך חלופית לציון גודל הדיסק המאותחל. אין באפשרותך להשתמש באפשרות שורת הפקודה ‎/f ביחד עם אפשרות שורת הפקודה ‎/n.
‎/c
עבור NTFS בלבד. קבצים שנוצרו באמצעי האחסון החדש יידחסו כברירת מחדל.
‎/x
פריקת אמצעי האחסון, אם יש צורך בכך, לפני האתחול של אמצעי האחסון. נקודות אחיזה לפתיחת אמצעי האחסון לא יהיו עוד חוקיות.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • שימוש בפקודה format במסוף השחזור

    הפקודה format, עם פרמטרים שונים, זמינה ממסוף השחזור.

  • הרשאות ניהוליות

    עליך להיות חבר בקבוצת המנהלים כדי לאתחל כונן קשיח.

  • שימוש בפקודה format

    הפקודה format יוצרת ספריית בסיס ומערכת קבצים חדשה עבור הדיסק. בנוסף, לפקודה זו יש אפשרות לבדוק אם קיימים אזורים פגומים בדיסק ולמחוק את כל הנתונים בדיסק. כדי שיהיה באפשרותך להשתמש בדיסק חדש, עליך להשתמש תחילה בפקודה זו כדי לאתחל את הדיסק.

  • הקלדת תווית של אמצעי אחסון

    לאחר אתחול תקליטון, הפקודה format מציגה את ההודעה הבאה:

    Volume label (11 characters, ENTER for none)?‎

    התווית של אמצעי האחסון עשויה לכלול 11 תווים לכל היותר (כולל רווחים). אם אין ברצונך לכלול תווית של אמצעי אחסון בדיסק, הקש ENTER. לקבלת מידע אודות תוויות של אמצעי אחסון, לחץ על label ברשימת הנושאים הקרובים.

  • אתחול דיסק קשיח

    כאשר נעשה שימוש בפקודה format כדי לאתחל דיסק קשיח, הפקודה format מציגה הודעה בצורה הבאה לפני שנעשה ניסיון לאתחל את הדיסק הקשיח:

    WARNING, ALL DATA ON nonremovable DISK
    DRIVE x: WILL BE LOST!‎
    Proceed with Format (Y/N)?_‎

    כדי לאתחל את הדיסק הקשיח, הקש Y; אם אין ברצונך לאתחל את הדיסק, הקש N. יש צורך בהרשאות מנהל כדי לאתחל דיסק קשיח.

  • גודל יחידה

    מערכות קבצים מסוג FAT מגבילות את מספר האשכולות ל- 65526 לכל היותר. מערכות קבצים מסוג FAT32 מגבילות את מספר האשכולות לטווח שבין 65527 ו- 4177917.

    דחיסת NTFS אינה נתמכת עבור גדלים של יחידות הקצאה מעל 4096.

  • הודעות של format

    כאשר האתחול הושלם, הפקודה format מציגה הודעות המציינות את שטח הדיסק הכולל, שטח המסומן כפגום והשטח הזמין עבור הקבצים.

  • אתחול מהיר

    באפשרותך להאיץ את תהליך האתחול באמצעות אפשרות שורת הפקודה ‎/q. השתמש באפשרות שורת פקודה זו רק אם לא קיימים סקטורים פגומים בדיסק הקשיח.

  • שימוש בפקודה format עם כונן שהוקצה מחדש או עם כונן רשת

    אין להשתמש בפקודה format בכונן שהוכן על-ידי הפקודה subst. אין באפשרותך לאתחל דיסקים ברשת.

  • קודי יציאה של format

    הטבלה שלהלן מפרטת כל קוד יציאה ותיאור קצר של משמעות קוד זה:

    קוד יציאה | תיאור
    0 | פעולת האתחול הושלמה בהצלחה.
    1 | סופקו פרמטרים שגויים.
    4 | אירעה שגיאה מכרעת (כל שגיאה מלבד 0, 1 או 5).
    5 | המשתמש הקיש N כתגובה להודעת הבקשה ‎"Proceed with Format (Y/N)‎?"‎ כדי להפסיק את התהליך.

    באפשרותך לבדוק קודי יציאה אלה באמצעות התנאי errorlevel עם פקודת האצווה if.

דוגמאות

כדי לאתחל תקליטון חדש בכונן A תוך שימוש בגודל ברירת המחדל, הקלד:

format a:‎

כדי לבצע פעולת אתחול מהיר בדיסק שאותחל בעבר בכונן A, הקלד:

format a: /q

כדי לאתחל תקליטון בכונן A ולהקצות לתקליטון זה את תווית אמצעי האחסון "DATA", הקלד:

format a: /v:DATA


Fsutil

Fsutil הוא כלי שירות של שורת הפקודה בו באפשרותך להשתמש כדי לבצע משימות הקשורות למערכות הקבצים FAT ו- NTFS, כגון ניהול נקודות ניתוח מבנה חוזר, ניהול קבצים דלילים, ביטול טעינה של אמצעי אחסון, או הרחבת אמצעי אחסון. מכיוון שכלי השירות fsutil הוא רב-עוצמה, השימוש בו מומלץ עבור משתמשים מתקדמים בלבד בעלי ידע מעמיק ב- Windows XP. בנוסף, עליך להיכנס למערכת כמנהל או כחבר בקבוצת המנהלים כדי להשתמש בכלי השירות fsutil.

בטבלה שלהלן מפורטות פקודות המשנה של fsutil.

פקודה | תיאור
behavior | פקודה זו מבצעת שאילתות ושינויים, הופכת הגדרות ליצירת שמות קבצים שאורכם 8.3 תווים לזמינות או ללא זמינות, מקבלת תווים מורחבים בשמות קבצים שאורכם 8.3 תווים הנמצאים באמצעי אחסון מסוג NTFS, מעדכנת את חותמת הזמן של הגישה האחרונה לאמצעי אחסון מסוג NTFS, מעדכנת את התדירות בה אירועי מיכסות נכתבים אל יומן המערכת וכמות שטח הדיסק השמור באזור MFT.
dirty | פקודה זו מבצעת שאילתות כדי לבדוק אם נקבע dirty bit של אמצעי אחסון. היא קובעת dirty bit של אמצעי אחסון. כאשר מוגדר dirty bit של אמצעי אחסון, הפקודה autochk מבצעת בדיקה אוטומטית לאיתור שגיאות באמצעי האחסון בפעם הבאה שהמחשב מופעל מחדש.
file | פקודה זו משמשת בדרך כלל את מומחי התמיכה. הפקודה מחפשת קובץ לפי מזהה האבטחה שלו, מבצעת שאילתות על טווחים שהוקצו עבור קובץ, קובעת שם קצר של קובץ, קובעת את אורך הנתונים החוקי של קובץ, או קובעת נתונים בעלי ערך אפס עבור קובץ.
fsinfo | פקודה זו משמשת בדרך כלל את מומחי התמיכה. הפקודה מפרטת את כל הכוננים, מבצעת שאילתות על סוג הכונן, מבצעת שאילתות על מידע אודות אמצעי אחסון, מבצעת שאילתות על מידע אודות אמצעי אחסון הספציפי ל- NTFS או מבצעת שאילתות על הנתונים הסטטיסטיים של מערכת קבצים.
hardlink | פקודה זו יוצרת קישור קשיח. קישור קשיח הוא ערך ספריה עבור קובץ. ניתן להניח כי לכל קובץ יש לפחות קישור קשיח אחד. באמצעי אחסון מסוג NTFS, לכל קובץ יש אפשרות להכיל קישורים חזקים מרובים ולכן קובץ בודד עשוי להופיע בספריות מרובות (ואף באותה ספריה עם שמות שונים). מכיוון שכל הקישורים מפנים לאותו קובץ, לתוכניות יש אפשרות לפתוח כל אחד מהקישורים ולשנות את הקובץ. מתבצעת מחיקה של קובץ ממערכת הקבצים רק לאחר שכל הקישורים המפנים אליו נמחקו. לאחר יצירת קישור קשיח, לתוכניות יש אפשרות להשתמש בו כבכל שם קובץ אחר.
objectid | פקודה זו משמשת בדרך כלל את מומחי התמיכה. הפקודה מנהלת מזהי אובייקטים הנמצאים בשימוש של Windows XP לשם מעקב אחר אובייקטים כגון קבצים וספריות.
quota | פקודה זו מנהלת מכסות דיסקים באמצעי אחסון מסוג NTFS כדי לספק בקרה מדויקת יותר על מקומות אחסון מבוססי רשת. מיכסות דיסקים מיושמות לפי אמצעי אחסון ומאפשרות יישום של הגבלות מקום אחסון קשיח ומקום אחסון רך לפי משתמש.
reparsepoint | פקודה זו משמשת בדרך כלל את מומחי התמיכה. הפקודה מוחקת או מבצעת שאילתות על נקודות ניתוח מבנה חוזר, שהן אובייקטי מערכת קבצים מסוג NTFS הכוללים תכונה ניתנת להגדרה המכילה נתונים הנשלטים על-ידי המשתמש והמשמשים להרחבת הפונקציונליות במערכת המשנה מסוג קלט/פלט (I/O). נקודות ניתוח מבנה חוזר משמשות עבור נקודות צמתי ספריות ועבור נקודות טעינת אמצעי אחסון. גם מנהלי סינון של מערכות קבצים עושים בהן שימוש לסימון קבצים מסוימים כמיוחדים עבור אותו מנהל התקן.
sparse | פקודה זו מנהלת קבצים דלילים. קובץ דליל הוא קובץ המכיל אזור אחד או יותר של נתונים שלא הוקצו. עבור תוכניות, אזורים אלה שלא הוקצו יוצגו כמכילים בתים בערך של אפס, אך למעשה לא נעשה שימוש בשטח דיסק לייצוג אפסים אלה. כלומר, כל הנתונים בעלי המשמעות או הנתונים שאינם אפסים הוקצו ואילו כל הנתונים חסרי המשמעות (מחרוזות גדולות של נתונים המורכבות מאפסים) לא הוקצו. בעת קריאת קובץ דליל, נתונים שהוקצו מוחזרים כפי שאוחסנו ונתונים שלא הוקצו מוחזרים, כברירת מחדל, כאפסים, בהתאם למפרט דרישות האבטחה של C2. תמיכה בקובץ דליל מאפשרת ביטול הקצאה של נתונים מכל מקום בקובץ.
usn | פקודה זו משמשת בדרך כלל את מומחי התמיכה. הפקודה מנהלת את יומן השינוי של מספרי רצף העדכון (USN), המספק יומן אירועים מתמשך של כל השינויים שבוצעו בקבצים הנמצאים באמצעי האחסון.
volume | פקודה זו מנהלת אמצעי אחסון. הפקודה גורמת לביטול טעינה של אמצעי אחסון או לביצוע שאילתה לשם בדיקת כמות השטח הפנוי הזמין בדיסק.

הערה

  • כדי להציג עזרה עבור פקודות המשנה הזמינות בשורת הפקודה, הקלד fsutil, הקלד את פקודת המשנה ולאחר מכן הקלד help (כלומר, fsutil subcommand help).


Fsutil: behavior

פקודה זו מבצעת שאילתות על ההגדרות הנוכחיות ליצירת שמות קבצים שאורכם 8.3 תווים ומאפשרת תווים מורחבים בשמות קבצים שאורכם 8.3 תווים הנמצאים באמצעי אחסון מסוג NTFS, עדכון חותמת הזמן של הגישה האחרונה לאמצעי האחסון מסוג NTFS, התדירות בה אירועי מיכסות נרשמים ביומן המערכת והגודל של אזור טבלת הקבצים הראשית (MFT). הופכת את השימוש בשמות קבצים שאורכם 8.3 תווים לזמין או ללא זמין, מאפשרת תווים מורחבים בשמות קבצים שאורכם 8.3 תווים הנמצאים באמצעי אחסון מסוג NTFS ומעדכנת את חותמת הזמן של הגישה האחרונה לאמצעי אחסון מסוג NTFS. מאפשרת לשנות את התדירות בה אירועי מיכסות נרשמים ביומן המערכת ולשנות את כמות שטח הדיסק השמור עבור MFT Zone.

תחביר

fsutil behavior query {disable8dot3|allowextchar|disablelastaccess|quotanotify|mftzone}‎

fsutil behavior set [{disable8dot3 {1|0}|allowextchar {1|0}|disablelastaccess {1|0}|quotanotify frequency|mftzone value}]‎

פרמטרים

query
פרמטר זה מבצע שאילתות על הפרמטרים של אופן הפעולה של מערכת הקבצים.
set
פרמטר זה משנה את הפרמטרים של אופן הפעולה של מערכת הקבצים.
disable8dot3 {1|0}‎
פרמטר זה מבטל יצירה של שמות קבצים שאורכם 8.3 תווים באמצעי אחסון שאותחלו באמצעות FAT ו- NTFS.
allowextchar {1|0}‎
פרמטר זה קובע אם תווים מערכת התווים המורחבת, לרבות תווים של סימני ניקוד, ניתנים לשימוש בשמות קבצים קצרים בתבנית 8.3 באמצעי אחסון מסוג NTFS.
disablelastaccess {1|0}‎
פרמטר זה קובע אם NTFS יעדכן את חותמת הזמן של הגישה האחרונה לכל ספריה בעת פירוט הספריות באמצעי אחסון מסוג NTFS.
quotanotify frequency
פרמטר זה מגדיר את התדירות בה הפרות מיכסה של NTFS מדווחות ביומן המערכת. הזן תדירות 0 עד 4294967295 שניות עבור התדירות בה הפרות מיכסה נרשמות ביומן המערכת. ברירת המחדל היא שעה אחת (3600 שניות).
mftzone value
אזור טבלת הקבצים הראשית (MFT) הוא אזור שמור המאפשר ל- MFT להתרחב לפי הצורך, כדי למנוע פיצול MFT. קבע את הערך value ל- 1 (ברירת המחדל) עד 4 (מקסימלי). value מצוין ביחידות של שמיניות הדיסק.

הערות

  • פקודת המשנה behavior רושמת שינויים ביומן הרישום, כך שעליך להפעיל מחדש את המחשב כדי שהשינויים ייכנסו לתוקף.
  • שימוש בפרמטר disable8dot3 {1|0}‎

    כאשר disable8dot3 מוגדר ל- 0, בכל יצירה של קובץ עם שם קובץ ארוך, NTFS יוצר ערך קובץ נוסף בעל שם קובץ שאורכו 8.3 תווים. כאשר NTFS יוצר קבצים בתיקיה, עליו לחפש את שמות הקבצים שאורכם 8.3 תווים המשויכים לשמות הקבצים הארוכים.

    פרמטר זה מעדכן את מפתח הרישום HKLM\SYSTEM\CurrentControlSet\Control\FileSystem\NtfsDisable8dot3NameCreation.

  • שימוש בפרמטר allowextchar {1|0}‎

    פרמטר זה מעדכן את מפתח הרישום HKLM\SYSTEM\CurrentControlSet\Control\FileSystem\NtfsAllowExtendedCharacterIn8dot3Name.

  • שימוש בפרמטר disablelastaccess {1|0}‎

    הפרמטר disablelastaccess נועד לצמצם את השפעת הרישום של עדכון חותמת הזמן של הגישה האחרונה על תיקיות וספריות. ביטול התכונה זמן גישה אחרון משפר את מהירות הגישה לתיקיות ולקבצים.

    כל קובץ ותיקיה באמצעי אחסון מסוג NTFS מכילים תכונה הנקראת זמן גישה אחרון. תכונה זו מגדירה את הפעם האחרונה בה ניגשו לקובץ או לתיקיה, לדוגמה כאשר משתמש מפרט תיקיות, מוסיף קבצים לתיקיה, קורא קובץ, או מבצע שינויים בקובץ. הערך העדכני ביותר של זמן גישה אחרון מאוחסן בזיכרון ובסופו של דבר נרשם בדיסק בשני מיקומים שונים. האחד בתוך תכונת הקובץ, המהווה חלק מרשומת MFT שלו. השני הוא באינדקס של הספריה המכילה את הקובץ.

    ערך זמן גישה אחרון בדיסק אינו תמיד עדכני. פער זה מתרחש מכיוון ש- NTFS מעכב את כתיבת הערך של זמן גישה אחרון בדיסק כאשר משתמשים או תוכניות מבצעים פעולות של קריאה בלבד בקובץ או בתיקיה, כגון פירוט תוכן התיקיה או קריאה (אך לא שינוי) של קובץ בתיקיה. אם הערך של זמן גישה אחרון נשמר עדכני בדיסק המיועד לפעולות קריאה, כל פעולות הקריאה הופכות לפעולות כתיבה, דבר המשפיע על הביצועים של NTFS.

    שים לב כי שאילתות מבוססות קבצים של זמן גישה אחרון מדויקות גם אם כל הערכים בדיסק אינם עדכניים. NTFS מחזיר את הערך הנכון בשאילתות מכיוון שהערך המדויק מאוחסן בזיכרון.

    בדרך כלל NTFS מעדכן תכונה של קובץ בדיסק אם הערך של זמן גישה אחרון בזיכרון שונה בהפרש של יותר משעה מהערך של זמן הגישה האחרון המאוחסן בדיסק, או כאשר כל ההפניות בזיכרון לאותו קובץ אבדו, לפי המקרה שהתרחש אחרון. לדוגמה, אם הערך הנוכחי של זמן הגישה האחרון הוא השעה ‎1:00 P.M.‎, ותקרא את הקובץ בשעה ‎1:30 P.M.‎‏, NTFS לא יעדכן את הערך של זמן הגישה האחרון. אם תקרא את הקובץ שנית בשעה ‎2:00 P.M.‎‏, NTFS יעדכן את הערך של זמן הגישה האחרון בתכונת הקובץ כך שישקף את השעה ‎2:00 P.M.‎ מכיוון שתכונת הקובץ מציגה ‎1:00 P.M.‎ והערך של זמן הגישה האחרון בזיכרון הוא ‎2:00 P.M.‎.

    NTFS מעדכן את האינדקס של הספריה המכילה את הקובץ כאשר NTFS מעדכן את הערך של זמן הגישה האחרון בקובץ ומבחין כי הערך של זמן הגישה האחרון עבור הקובץ שונה בהפרש של יותר משעה מהערך של זמן הגישה האחרון המאוחסן באינדקס של הספריה. עדכון זה מתרחש בדרך-כלל לאחר שתוכנית סוגרת את המזהה הייחודי (handle) המשמש לגישה לקובץ בתוך הספריה. אם משתמש משאיר את המזהה הייחודי פתוח למשך זמן ארוך, יחלוף זמן מה לפני הופעת השינוי בערך האינדקס של הספריה.

    שים לב כי שעה אחת היא הזמן המירבי בו NTFS דוחה את עדכון הערך של זמן הגישה האחרון בדיסק. אם NTFS מעדכן תכונות קובץ אחרות כגון זמן שינוי אחרון ועדכון התכונה זמן הגישה האחרון ממתין, NTFS מעדכן את זמן הגישה האחרון ביחד עם העדכונים האחרים ללא השפעה נוספת על הביצועים.

    שים לב כי שימוש בפרמטר disablelastaccess עשוי להשפיע על תוכניות כגון גיבוי ואחסון מרוחק התלויות בתכונה זו.

    פרמטר זה מעדכן את מפתח הרישום HKLM\SYSTEM\CurrentControlSet\Control\FileSystem\NtfsDisableLastAccessUpdate.

  • שימוש בפרמטר mftzone value

    value הוא הערכה של הגודל ההתחלתי של MFT בתוספת אזור MFT באמצעי אחסון חדש והוא מוגדר בזמן הטעינה עבור כל מערכת קבצים. כאשר נעשה שימוש בשטח באמצעי האחסון, NTFS מתאים את השטח השמור לגדילה עתידית של MFT. אם אזור MFT כבר גדול, הגודל המלא של אזור MFT אינו נשמר שוב. מכיוון שאזור MFT מבוסס על הטווח הרציף שמעבר לסוף MFT, הוא מתכווץ יותר ויותר ככל שנעשה שימוש בשטח.

    מערכת הקבצים אינה קובעת מחדש את מיקום אזור MFT לפני שנעשה שימוש מלא באזור MFT הנוכחי. דבר זה אינו מתרחש לעולם במערכת רגילה.


Fsutil: dirty

פקודה זו מבצעת שאילתות כדי לבדוק אם נקבע dirty bit של אמצעי אחסון. היא קובעת dirty bit של אמצעי אחסון. כאשר מוגדר dirty bit של אמצעי אחסון, הפקודה autochk מבצעת בדיקה אוטומטית לאיתור שגיאות באמצעי האחסון בפעם הבאה שהמחשב מופעל מחדש.

תחביר

fsutil dirty {query|set} PathName

פרמטרים

query
פרמטר זה מבצע שאילתות על dirty bit.
set
פרמטר זה קובע dirty bit של אמצעי אחסון.
PathName
פרמטר זה מציין את אות הכונן (ולאחריו נקודתיים), נקודת הטעינה או שם אמצעי האחסון.

הערות

  • אם נקבע dirty bit של אמצעי אחסון, משמעות הדבר שמערכת הקבצים עשויה להיות במצב לא עקבי. ניתן לקבוע dirty bit מכיוון שאמצעי האחסון מקוון וכולל שינויים שטרם נקלטו, מכיוון שהתבצעו שינויים באמצעי האחסון והמחשב כבה לפני שהשינויים נכנסו לתוקף בדיסק, או מכיוון שנתגלה פגם באמצעי האחסון. אם dirty bit נקבע כאשר המחשב מופעל מחדש, הפקודה chkdsk מופעלת כדי לוודא את עקביות אמצעי האחסון.

    בכל הפעלה של Windows XP, מתבצעת קריאה ל- Autochk.exe על-ידי Kernel לשם סריקת כל אמצעי האחסון ובדיקה אם נקבע dirty bit של אמצעי האחסון. אם הוגדר dirty bit, הפקודה autochk מבצעת מייד chkdsk /f באותו אמצעי אחסון. chkdsk /f מוודאת את תקינות מערכת הקבצים ומנסה לתקן בעיות באמצעי האחסון.

דוגמאות

כדי לבצע שאילתה על dirty bit בכונן C, הקלד:

fsutil dirty query C:‎

פלט לדוגמה:

Volume C: is dirty

או

Volume C: is not dirty

כדי לקבוע את dirty bit בכונן C, הקלד:

fsutil dirty set C:‎


Fsutil: file

פקודה זו בדרך-כלל משמשת את מומחי התמיכה. הפקודה מחפשת קובץ לפי מזהה אבטחה, מבצעת שאילתות על טווחים מוקצים עבור קובץ, קובעת שם קצר של קובץ, קובעת את אורך הנתונים החוקי של קובץ, קובעת נתונים בעלי ערך אפס עבור קובץ או יוצרת קובץ חדש.

תחביר

fsutil file [createnew] PathName length

fsutil file [findbysid] User PathName

fsutil file [queryallocranges] offset=offset length=length PathName

fsutil file [setshortname] PathName shortname

fsutil file [setvaliddata] PathName datalength

fsutil file [setzerodata] offset=offset length=length PathName

פרמטרים

createnew
יצירת קובץ בשם ובגודל שצוינו, שתוכנו מורכב מאפסים.
PathName
ציון אות הכונן (ולאחריה נקודתיים), נקודת הטעינה או שם אמצעי האחסון.
length
ציון אורך הנתונים החוקי של הקובץ.
findbysid
חיפוש קבצים באמצעי אחסון מסוג NTFS השייכים למשתמש שצוין. המשתמש מזוהה לפי מזהה האבטחה (SID) שלו.
User
ציון שם המשתמש או שם הכניסה של המשתמש.
PathName
ציון אות הכונן (ולאחריה נקודתיים), נקודת הטעינה או שם אמצעי האחסון.
queryallocranges
ביצוע שאילתה על הטווחים המוקצים עבור קובץ באמצעי אחסון מסוג NTFS. פרמטר זה יעיל לקביעה אם הקובץ כולל אזורים דלילים.
offset=offset
ציון תחילת הטווח אותו יש להגדיר לאפסים.
length=length
ציון אורך הטווח, בבתים.
PathName
ציון אות הכונן (ולאחריה נקודתיים), נקודת הטעינה או שם אמצעי האחסון.
setshortname
קביעת השם הקצר (שם קובץ שאורכו 8.3 תווים) עבור קובץ באמצעי אחסון מסוג NTFS.
PathName
ציון אות הכונן (ולאחריה נקודתיים), נקודת הטעינה או שם אמצעי האחסון.
shortname
ציון השם הקצר של הקובץ.
setvaliddata
קביעת אורך הנתונים החוקי עבור קובץ באמצעי אחסון מסוג NTFS.
PathName
ציון אות הכונן (ולאחריה נקודתיים), נקודת הטעינה או שם אמצעי האחסון.
datalength
ציון אורך הקובץ בבתים.
setzerodata
קביעת הטווח (אותו מציינים באמצעות offset ו- length) של הקובץ לאפסים, פעולה המרוקנת את הקובץ. אם הקובץ הוא קובץ דליל, מתבטלות יחידות ההקצאה המשמשות כבסיס.
offset=offset
ציון היסט הקובץ, תחילת הטווח אותו יש להגדיר לאפסים.
length=length
ציון אורך הטווח אותו יש להגדיר לאפסים.
PathName
ציון אות הכונן (ולאחריה נקודתיים), נקודת הטעינה או שם אמצעי האחסון.

הערות

  • שימוש בפרמטר setvaliddata

    ב- NTFS, קיימים שני מושגים חשובים של אורך הקובץ: סמן End of File ‏(EOF) ו- Valid Data Length ‏(VDL)‏. EOF מציין את האורך הממשי של הקובץ. VDL מזהה את האורך של נתונים חוקיים בדיסק. כל קריאה בין VDL לבין EOF מחזירה אוטומטית את הערך 0 כדי לשמר את דרישת השימוש החוזר של אובייקט C2.

    הפרמטר setvaliddata זמין עבור מנהלים בלבד מכיוון שנדרשת עבורו ההרשאה Manage Volume. תכונה זו נדרשת רק עבור תרחישים מתקדמים של מולטימדיה ו- System Area Network ‏(SAN).

דוגמאות

כדי לאתר את המשתמש scottb בכונן C לפי מזהה האבטחה (SID) שלו, הקלד:

fsutil file findbysid scottb C:\users

כדי לבצע שאילתה על הטווחים המוקצים עבור קובץ באמצעי אחסון מסוג NTFS, הקלד:

fsutil file queryallocranges offset=1024 length=64 C:\Temp\sample.txt

כדי לקבוע את השם הקצר עבור הקובץ longfilename.txt בכונן C ל- longfile.txt, הקלד:

fsutil file setshortname C:\longfilename.txt longfile.txt

כדי לקבוע את אורך הנתונים החוקי עבור קובץ באמצעי אחסון מסוג NTFS, הקלד:

fsutil file setvaliddata C:\testfile.txt 4096

כדי לקבוע טווח של קובץ באמצעי אחסון מסוג NTFS לאפסים וכך לרוקן אותו, הקלד:

fsutil file setzerodata offset=100 length=150 C:\Temp\sample.txt


Fsutil: fsinfo

פקודה זו משמשת בדרך-כלל את מומחי התמיכה. היא מפרטת את כל מנהלי ההתקנים, מבצעת שאילתות על סוגי מנהלי ההתקנים, מבצעת שאילתות על מידע אודות אמצעי אחסון, מבצעת שאילתות על מידע אודות אמצעי אחסון ספציפיים ל- NTFS, או מבצעת שאילתות על נתונים סטטיסטיים של מערכת קבצים.

תחביר

fsutil fsinfo [drives]‎

fsutil fsinfo [drivetype] PathName

fsutil fsinfo [ntfsinfo] RootPathname

fsutil fsinfo [statistics] VolumePathname

fsutil fsinfo [volumeinfo] RootPathname

פרמטרים

drives
פירוט כל מנהלי ההתקנים במחשב.
drivetype
ביצוע שאילתה על כונן ופירוט סוג הכונן, לדוגמה כונן תקליטורים.
ntfsinfo
פירוט מידע אודות אמצעי אחסון ספציפי ל- NTFS עבור אמצעי האחסון שצוין, כגון מספר הסקטורים, כלל האשכולות, האשכולות הפנויים ותחילתו וסופו של אזור MFT.
statistics
פירוט הנתונים הסטטיסטיים של מערכת הקבצים עבור אמצעי האחסון שצוין, כגון מטה-נתונים, קובץ יומן הרישום והרשאות הקריאה והכתיבה של MFT.
volumeinfo
פירוט מידע עבור אמצעי האחסון שצוין, כגון מערכת הקבצים ומידע המציין אם אמצעי האחסון תומך בשמות קבצים תלויי רישיות, בשימוש ב- Unicode בשמות קבצים, או במיכסות דיסקים.
PathName
ציון אות הכונן (ולאחריה נקודתיים), נקודת הטעינה או שם אמצעי האחסון.
RootPathname
ציון אות הכונן (ולאחריה נקודתיים) של כונן הבסיס.
VolumePathname
ציון אות הכונן (ולאחריה נקודתיים), נקודת הטעינה או שם אמצעי האחסון.

דוגמאות

כדי לבצע שאילתה על סוג הכונן של כונן C, הקלד:

fsutil fsinfo drivetype C:‎

תוצאות אפשריות:

  • Unknown Drive
  • No such Root Directory
  • Removable Drive, for example floppy
  • Fixed Drive
  • Remote/Network Drive
  • CD-ROM Drive
  • Ram Disk

כדי לבצע שאילתה על המידע אודות אמצעי האחסון עבור אמצעי האחסון E, הקלד:

fsinfo volumeinfo E:\‎

פלט לדוגמה:

Volume Name :
Volume Serial Number : 0xd0b634d9
Max Component Length : 255
File System Name : NTFS
Supports Case-sensitive filenames
Preserves Case of filenames
Supports Unicode in filenames
Preserves & Enforces ACL's
Supports file-based Compression
Supports Disk Quotas
Supports Sparse files
Supports Reparse Points
Supports Object Identifiers
Supports Encrypted File System
Supports Named Streams

כדי לבצע שאילתה על כונן F עבור מידע אודות אמצעי אחסון ספציפי ל- NTFS, הקלד:

fsutil fsinfo ntfsinfo F:\‎

פלט לדוגמה:

NTFS Volume Serial Number : 0xe660d46a60d442cb
Number Sectors : 0x00000000010ea04f
Total Clusters : 0x000000000021d409
Free Clusters : 0x00000000000f222a
Total Reserved : 0x0000000000003550
Bytes Per Sector : 512
Bytes Per Cluster : 4096
Bytes Per FileRecord Segment : 1024
Clusters Per FileRecord Segment : 0
Mft Valid Data Length : 0x0000000003eab000
Mft Start Lcn : 0x0000000000000004
Mft2 Start Lcn : 0x000000000010ea04
Mft Zone Start : 0x0000000000003ea0
Mft Zone End : 0x0000000000004700

כדי לבצע שאילתה על הנתונים הסטטיסטיים של מערכת הקבצים עבור כונן E, הקלד:

fsinfo statistics E:‎

פלט לדוגמה:

File System Type : NTFS
Version : 1
UserFileReads : 75021
UserFileReadBytes : 1305244512
UserDiskReads : 71213
UserFileWrites : 8037
UserFileWriteBytes : 207685440
UserDiskWrites : 5278
MetaDataReads : 14377
MetaDataReadBytes : 58888192
MetaDataDiskReads : 14773
MetaDataWrites : 18705
MetaDataWriteBytes : 138108928
MetaDataDiskWrites : 21464

MftReads : 9394
MftReadBytes : 38477824
MftWrites : 17061
MftWriteBytes : 115359744
Mft2Writes : 0
Mft2WriteBytes : 0
RootIndexReads : 0
RootIndexReadBytes : 0
RootIndexWrites : 0
RootIndexWriteBytes : 0
BitmapReads : 136
BitmapReadBytes : 557056
BitmapWrites : 1180
BitmapWriteBytes : 11161600
MftBitmapReads : 4
MftBitmapReadBytes : 16384
MftBitmapWrites : 118
MftBitmapWriteBytes : 491520
UserIndexReads : 2938
UserIndexReadBytes : 12034048
UserIndexWrites : 2738
UserIndexWriteBytes : 20615168
LogFileReads : 4
LogFileReadBytes : 16384
LogFileWrites : 8407
LogFileWriteBytes : 180936704


Fsutil: hardlink

קישור קשיח הוא ערך ספריה עבור קובץ. ניתן להניח כי לכל קובץ יש לפחות קישור קשיח אחד. באמצעי אחסון מסוג NTFS לכל קובץ יש אפשרות לכלול קישורים חזקים מרובים ולכן קובץ בודד עשוי להופיע בספריות מרובות (ואף באותה ספריה עם שמות שונים). מכיוון שכל הקישורים מפנים לאותו קובץ, לתוכניות יש אפשרות לפתוח כל אחד מהקישורים ולשנות את הקובץ. מתבצעת מחיקה של קובץ ממערכת הקבצים רק לאחר שכל הקישורים המפנים אליו נמחקו. לאחר יצירת קישור קשיח, לתוכניות יש אפשרות להשתמש בו כבכל שם קובץ אחר.

תחביר

fsutil hardlink create NewFilename ExistingFilename

פרמטרים

create
יצירת קישור קשיח מסוג NTFS בין קובץ קיים לבין קובץ חדש. קישור קשיח מסוג NTFS דומה לקישור קשיח מסוג POSIX.
NewFilename
ציון הקובץ שאליו ברצונך ליצור קישור קשיח.
ExistingFilename
ציון הקובץ שממנו ברצונך ליצור קישור קשיח.


Fsutil: objectid

משמש בדרך כלל אנשי מקצוע בתחום התמיכה. ניהול מזהי אובייקט (נקראים גם OID), שהם אובייקטים פנימיים בהם נעשה שימוש על-ידי השירות Distributed Link Tracking (DLT) Client ו- File Replication Service ‏(FRS) לשם ניהול מעקב אחר אובייקטים אחרים כגון קבצים, ספריות וקישורים. מזהי אובייקטים אינם גלויים לעין לרוב התוכניות ולעולם אין לשנות אותם.

אזהרה

  • אין למחוק, לקבוע או לשנות מזהה אובייקט. מחיקה או קביעה של מזהה אובייקט עשויה לגרום לאיבוד נתונים בחלקים של קובץ ועד איבוד נתונים באמצעי אחסון שלמים. בנוסף, הדבר עלול לגרום לאופן פעולה לא תקין בשירות Distributed Link Tracking (DLT) Client וב- File Replication Service ‏(FRS).

תחביר

fsutil objectid [create] PathName

fsutil objectid [delete] PathName

fsutil objectid [query] PathName

fsutil objectid [set] ObjectID BirthVolumeID BirthObjectID DomainID PathName

פרמטרים

create
יצירת מזהה אובייקט אם עדיין לא קיים אחד עבור הקובץ. אם כבר קיים מזהה אובייקט, הפרמטר שקול ל- query.
delete
מחיקה של מזהה אובייקט.
query
ביצוע שאילתה על מזהה אובייקט.
set
קביעה של מזהה אובייקט.
ObjectID
מזהה הקסדצימאלי בעל 16 בתים הספציפי לקובץ ומובטח להיות ייחודי בתוך אמצעי אחסון. המזהה משמש את השירות Distributed Link Tracking (DLT) Client ואת File Replication Service ‏(FRS) לשם זיהוי קבצים. לכל קובץ שברשותו ObjectID, קיימים גם BirthVolumeID,‏ BirthObjectID ו- DomainID. בעת העברת קובץ, ה- ObjectID עשוי להשתנות אך BirthVolumeID ו- BirthObjectID אינם משתנים, מה שמאפשר ל- Windows XP למצוא תמיד כל קובץ, ללא קשר למיקום אליו הוא הועבר.
BirthVolumeID
מזהה הקסדצימאלי בעל 16 בתים המציין את אמצעי האחסון בו היה ממוקם הקובץ כאשר קיבל לראשונה ObjectID. ערך זה משמש את השירות DLT Client.
BirthObjectID
מזהה הקסדצימאלי בעל 16 בתים המציין את ה- ObjectID המקורי של הקובץ (שים לב שה- ObjectID עשוי להשתנות בעת העברת קובץ). ערך זה משמש את השירות DLT Client.
DomainID
מזהה קבוצת מחשבים הקסדצימאלי בעל 16 בתים. ערך זה אינו בשימוש כרגע ויש לקבוע אותו לאפסים בלבד.
PathName
ציון אות הכונן (ולאחריה נקודתיים), נקודת טעינה או שם אמצעי האחסון.

דוגמאות

כדי ליצור מזהה אובייקט, הקלד:

fsutil objectid create C:\Temp\sample.txt

כדי למחוק מזהה אובייקט, הקלד:

fsutil objectid delete C:\Temp\sample.txt

כדי לבצע שאילתה על מזהה אובייקט, הקלד:

fsutil objectid get C:\Temp\sample.txt

כדי לקבוע מזהה אובייקט, הקלד:

fsutil objectid set 40dff02fc9b4d4118f120090273fa9fc f86ad6865fe8d21183910008c709d19e 40dff02fc9b4d4118f120090273fa9fc 00000000000000000000000000000000 C:\Temp\sample.txt


Fsutil: quota

ניהול מיכסות דיסק באמצעי אחסון מסוג NTFS כדי לספק שליטה מדויקת יותר באחסון מבוסס רשת.

תחביר

fsutil quota [disable] volumename

fsutil quota [enforce] volumename

fsutil quota [modify] volumename threshold limit [UserName]‎

fsutil quota [query] volumename

fsutil quota [track] volumename

fsutil quota [violations]‎

פרמטרים

disable
ביטול מעקב אחר מיכסה ואכיפה באמצעי האחסון שצוין.
enforce
אכיפה של שימוש במיכסה באמצעי האחסון שצוין.
modify
שינוי מיכסה קיימת של דיסק או יצירה של מיכסה חדשה.
query
פירוט מיכסות קיימות של דיסק.
track
מעקב אחר שימוש בדיסק באמצעי האחסון שצוין.
violations
חיפוש ביומני הרישום של היישום ושל המערכת והצגת הודעה כדי לציין שאותרו הפרות מיכסה או שמשתמש הגיע לגודל סף המיכסה או למגבלת המיכסה שלו.
volumename
ציון אות הכונן עבור אמצעי האחסון (ואחריה נקודתיים).
threshold
המגבלה שבה מונפקות אזהרות.
limit
השימוש המירבי המותר בדיסק.
UserName
ציון שם קבוצת המחשבים או שם המשתמש.

הערות

  • מיכסות דיסק מיושמות על בסיס כל אמצעי אחסון ומאפשרות יישום של מגבלות אחסון רכות וקשות על בסיס כל משתמש.
  • באפשרותך להשתמש בקבצי Script לכתיבה העושים שימוש ב- fsutil quota כדי לקבוע את מגבלות המיכסה בכל פעם שתוסיף משתמש חדש או כדי לנהל מעקב אחר מגבלות מיכסה באופן אוטומטי, לאסוף אותן לתוך דו"ח ולשלוח אותן באופן אוטומטי למנהל המערכת בדואר אלקטרוני.


Fsutil: reparsepoint

פקודה זו בדרך-כלל משמשת את מומחי התמיכה. היא מוחקת או מבצעת שאילתות על נקודות ניתוח מבנה חוזר, שהן אובייקטי מערכת קבצים מסוג NTFS הכוללים תכונה ניתנת להגדרה המכילה נתונים המבוקרים על-ידי המשתמש והמשמשים להרחבת הפונקציונליות במערכת המשנה של הקלט/פלט (I/O). נקודות ניתוח מבנה חוזר משמשות עבור נקודות צמתי ספריות ועבור נקודות טעינת אמצעי אחסון. גם מנהלי סינון של מערכות קבצים עושים בהן שימוש לסימון קבצים מסוימים כמיוחדים עבור אותו מנהל התקן.

תחביר

fsutil reparsepoint [query] PathName

fsutil reparsepoint [delete] PathName

פרמטרים

query
אחזור נתוני נקודת ניתוח המבנה החוזר המשויכים לקובץ או לספריה שזוהו על-ידי המזהה הייחודי (handle) שצוין.
delete
מחיקת נקודת ניתוח מבנה חוזר מהקובץ או מהספריה שזוהו על-ידי המזהה הייחודי שצוין, ללא מחיקת הקובץ או הספריה.

אזהרה

  • הפקודה fsutil reparsepoint delete מבצעת מחיקה של הקובץ בלבד, לא של נקודות ניתוח המבנה החוזר המשויכות לו. פעולה זו עלולה לגרום לכשלים בפתיחת קבצים בתהליכים או בשירותים המנסים לפתוח את הקובץ.
PathName
ציון אות הכונן (ולאחריו נקודתיים), נקודת הטעינה או שם אמצעי האחסון.

הערות

  • באמצעי אחסון מסוג NTFS, קובץ או ספריה עשויים להכיל נקודת ניתוח מבנה חוזר, המהווה אוסף של נתונים המוגדרים על-ידי המשתמש. התבנית של נתונים אלה מובנת על-ידי התוכנית שמאחסנת את הנתונים ועל-ידי מסנן מערכת קבצים, אותו יש להתקין לשם תרגום הנתונים ועיבוד הקובץ. כאשר תוכנית קובעת נקודת ניתוח מבנה חוזר, היא מאחסנת נתונים אלה וכן תג ניתוח מבנה חוזר, המזהה באופן ייחודי את הנתונים שהוא מאחסן. כאשר מערכת הקבצים פותחת קובץ עם נקודת ניתוח מבנה חוזר, מתבצע ניסיון לאתר את מסנן מערכת הקבצים המשויך לתבנית הנתונים שזוהתה על-ידי תג ניתוח המבנה החוזר. אם נמצא מסנן מערכת קבצים זה, המסנן מעבד את הקובץ לפי הוראת נתוני ניתוח המבנה החוזר. אם לא נמצא מסנן מערכת קבצים זה, פעולת פתיחת הקובץ נכשלת.

    לדוגמה, נקודות ניתוח מבנה חוזר משמשות ליישום קישורי NTFS ואחסון מרוחק. באחסון מרוחק נעשה שימוש במערכת כללים המוגדרת על-ידי מנהלים לשם העברת קבצים בהם נעשה שימוש לעיתים רחוקות לאחסון לטווח ארוך, כגון קלטת או תקליטור. נעשה שימוש בנקודות ניתוח מבנה חוזר כדי לאחסן מידע אודות הקובץ במערכת הקבצים. מידע זה מאוחסן בקובץ Stub המכיל נקודת ניתוח מבנה חוזר שנתוניה מצביעים על ההתקן בו הקובץ הממשי ממוקם כעת. למסנן מערכת הקבצים יש אפשרות להשתמש במידע זה כדי לאחזר את הקובץ.

דוגמאות

לשם אחזור נתוני נקודת ניתוח מבנה חוזר המשויכים ל- C:\Server, הקלד:

fsutil reparsepoint query C:\Server

לשם מחיקת נקודת ניתוח מבנה חוזר מקובץ או מספריה שצוינו, השתמש בתבנית שלהלן:

fsutil reparsepoint delete C:\Server


Fsutil: sparse

פקודה זו מנהלת קבצים דלילים. קובץ דליל הוא קובץ המכיל אזור אחד או יותר של נתונים לא מוקצים. עבור תוכניות, אזורים לא מוקצים אלה יוצגו כמכילים בתים בערך של אפס, אך למעשה לא נעשה שימוש בשטח דיסק לייצוג אפסים אלה. כלומר, כל הנתונים בעלי המשמעות או הנתונים שאינם אפסים הוקצו, ואילו כל הנתונים חסרי המשמעות (מחרוזות גדולות של נתונים המורכבות מאפסים) לא הוקצו. בעת קריאת קובץ דליל, נתונים שהוקצו מוחזרים כפי שאוחסנו ונתונים שלא הוקצו מוחזרים, כברירת מחדל, כאפסים, בהתאם למפרט דרישות האבטחה של C2. תמיכה בקובץ דליל מאפשרת ביטול הקצאה של נתונים מכל מקום בקובץ.

תחביר

fsutil sparse [queryflag] PathName

fsutil sparse [queryrange] PathName

fsutil sparse [setflag] PathName

fsutil sparse [setrange] PathName BeginningOffset length

פרמטרים

queryflag
ביצוע שאילתות על קבצים דלילים.
queryrange
ביצוע סריקה של קובץ לשם חיפוש טווחים שעשויים להכיל נתונים שערכם אינו אפס.
setflag
סימון הקובץ שצוין כקובץ דליל.
setrange
מילוי טווח שצוין של קובץ באפסים.
PathName
ציון אות הכונן (ואחריה נקודתיים), נקודת טעינה או שם אמצעי אחסון.
BeginningOffset
היסט בתוך קובץ לסימון כדליל.
length
אורך האזור בקובץ אותו יש לסמן כדליל, בבתים.

הערות

  • בקובץ דליל, ייתכן שעבור טווחים נרחבים של אפסים לא תידרש הקצאה של דיסק. הקצאת שטח עבור נתונים שערכם אינו אפס תתבצע לפי הצורך בעת כתיבת הקובץ.
  • רק לקבצים דחוסים או דלילים יש אפשרות להכיל טווחים של אפסים המוכרים למערכת ההפעלה.
  • אם הקובץ דחוס או דליל, NTFS עשוי לבטל את הקצאת שטח הדיסק בקובץ. פעולה זו קובעת את טווח הבתים לאפסים מבלי להרחיב את גודל הקובץ.

דוגמאות

כדי לסמן קובץ כדליל, הקלד:

fsutil sparse setflag C:\Temp\sample.txt


Fsutil: usn

פקודה זו בדרך כלל משמשת את מומחי התמיכה. היא מנהלת את יומן השינוי של מספרי רצף העדכון (USN), המספק יומן אירועים מתמשך של כל השינויים שבוצעו בקבצים הנמצאים באמצעי האחסון. כאשר קבצים, ספריות ואובייקטי NTFS אחרים מתווספים, נמחקים ומשתנים, NTFS מוסיף רשומות ליומן השינוי של USN, רשומה אחת עבור כל אמצעי אחסון במחשב. כל רשומה מציינת את סוג השינוי ואת האובייקט שהשתנה. רשומות חדשות מצורפות לסוף הזרם.

לתוכניות יש אפשרות להיוועץ ביומן השינוי של USN כדי לקבוע את כל השינויים שבוצעו בערכת קבצים. יומן השינוי של USN יעיל הרבה יותר מבדיקת חותמות זמן או עריכת רישום של דיווחי קבצים. יומן השינוי של USN הופך לזמין ונמצא בשימוש של שירות יצירת אינדקס, שירות שכפול הקבצים (FRS), שירות ההתקנה מרחוק (RIS) ואחסון מרוחק.

תחביר

fsutil usn [createjournal] MaximumSize AllocationDelta VolumePathname

fsutil usn [deletejournal] flags VolumePathname

fsutil usn [enumdata] FileRef LowUsn HighUsn PathName

fsutil usn [queryjournal] VolumePathname

fsutil usn [readdata] PathName

פרמטרים

createjournal
יצירת יומן שינוי של USN.
m=MaximumSize
ציון הגודל המקסימלי, בבתים, ש- NTFS מקצה ליומן השינוי.
a=AllocationDelta
ציון הגודל, בבתים, של הקצאת הזיכרון שנוספה לסוף יומן השינוי והוסרה מתחילתו.
VolumePathname
ציון אות הכונן (ולאחריה נקודתיים), נקודת הטעינה או שם אמצעי האחסון.
deletejournal
מחיקת יומן שינוי פעיל של USN או הפיכתו ללא זמין.
flags
‎/D:‎ הופך יומן שינוי פעיל של USN ללא זמין ומחזיר את בקרת ה- I/O במהלך הפיכת יומן השינוי ללא זמין.
‎/N:‎ הופך יומן שינוי פעיל של USN ללא זמין ומחזיר את בקרת ה- I/O רק לאחר הפיכת יומן השינוי ללא זמין.
VolumePathname
ציון אות הכונן (ולאחריה נקודתיים), נקודת הטעינה או שם אמצעי האחסון.
enumdata
הוספת מספרים לערכי יומן השינוי והצגת פירוט שלהם, בין שני גבולות שצוינו.
FileRef
מיקום סודר בתוך הקבצים הנמצאים באמצעי האחסון בו יש להתחיל בהוספת המספרים.
LowUsn
גבול תחתון של טווח ערכי USN המשמשים לסינון הרשומות שיוחזרו. מוחזרות רק רשומות שה- USN של יומן השינוי האחרון שלהן הוא בין ערכי החבר LowUsn ו- HighUsn או שווה להם.
HighUsn
גבול עליון של טווח ערכי USN המשמשים לסינון הקבצים שיוחזרו.
PathName
ציון שם הכונן (ואחריה נקודתיים), נקודת הטעינה או שם אמצעי האחסון.
queryjournal
ביצוע שאילתה על נתוני USN של אמצעי אחסון לשם איסוף מידע אודות יומן השינוי הנוכחי, הרשומות שלו והקיבולת שלו.
volume pathname
ציון אות הכונן (ואחריה נקודתיים), נקודת הטעינה או שם אמצעי האחסון.
readdata
קריאת נתוני USN עבור קובץ.
PathName
ציון אות הכונן (ואחריה נקודתיים), נקודת הטעינה או שם אמצעי האחסון.

הערות

  • שימוש בפרמטר createjournal

    אם כבר קיים יומן שינוי באמצעי אחסון, הפרמטר createjournal מעדכן את הפרמטרים MaximumSize ו- AllocationDelta של יומן השינוי. פעולה זו מאפשרת הרחבה של מספר הרשומות שיומן פעיל מכיל ללא צורך להפוך אותו ללא זמין. אם ציינת את הערך אפס עבור MaximumSize ו- AllocationDelta, המערכת תבחר ערך ברירת מחדל בהתבסס על גודל אמצעי האחסון.

  • שימוש בפרמטר m=MaximumSize

    ליומן השינוי יש אפשרות להיות גדול מערך יעד זה, אך יומן השינוי נקטע בנקודת הביקורת הבאה של NTFS לערך נמוך מערך זה. NTFS בודק את יומן השינוי ומקצר אותו כאשר גודלו עולה על סכום הערכים של MaximumSize ו- AllocationDelta. בנקודות ביקורת של NTFS, מערכת ההפעלה רושמת רשומות ביומן הרישום של NTFS כדי לאפשר ל- NTFS לקבוע איזה עיבוד נדרש לשחזור מכשל.

  • שימוש בפרמטר a=AllocationDelta

    ליומן השינוי יש אפשרות להיות גדול מסכום הערכים של MaximumSize ו- AllocationDelta לפני קיצורו.

  • שימוש בפרמטר deletejournal

    לשם מחיקת יומן פעיל או הפיכתו ללא זמין נדרש זמן רב, מכיוון שעל המערכת לבצע גישה לכל הרשומות בטבלת הקבצים הראשית (MFT) ולקבוע את תכונת USN האחרונה לאפס. תהליך זה עשוי להימשך מספר דקות וכן הוא עשוי להימשך לאחר הפעלה מחדש של המערכת, במידת הצורך. בתהליך זה, יומן השינוי אינו נחשב לפעיל אך גם אינו הופך ללא זמין. בזמן שהמערכת הופכת את היומן ללא זמין, לא ניתן לגשת אליו וכל פעולות היומן מחזירות שגיאות. עליך לנהוג בזהירות מירבית בעת הפיכת יומן פעיל ללא זמין, מכיוון שפעולה זו משפיעה לרעה על יישומים אחרים העושים שימוש ביומן.

דוגמאות

לשם יצירת יומן שינוי של USN בכונן C, הקלד:

fsutil usn createjournal m=1000 a=100 C:‎

לשם מחיקת יומן שינוי פעיל של USN בכונן C, הקלד:

fsutil usn deletejournal /D C:‎

לשם הוספת מספרים לערכי יומן השינוי והצגת פירוט שלהם בין שני גבולות שצוינו בכונן C, הקלד:

fsutil usn enumdata 1 0 1 C:‎

לשם ביצוע שאילתה על נתוני USN עבור אמצעי אחסון בכונן C, הקלד:

fsutil usn queryjournal C:‎

לשם קריאת נתוני USN עבור קובץ בתיקיה הזמנית בכונן C, הקלד:

fsutil usn readdata C:\Temp\sample.txt


Fsutil: volume

פקודה זו מנהלת אמצעי אחסון. הפקודה גורמת לביצוע ביטול טעינה של אמצעי אחסון או לביצוע שאילתה לשם בדיקת כמות השטח הפנוי הזמין בדיסק.

תחביר

fsutil volume [diskfree] drivename

fsutil volume [dismount] VolumePathname

פרמטרים

diskfree
ביצוע שאילתה על השטח הפנוי באמצעי אחסון.
drivename
קביעת אות הכונן (ואחריה נקודותיים).
dismount
ביטול טעינה של אמצעי אחסון.
VolumePathname
קביעת אות הכונן (ואחריה נקודותיים), נקודת הטעינה, או שם אמצעי האחסון.

דוגמאות

  • כדי לבטל טעינה של אמצעי אחסון בכונן C, הקלד:

    • fsutil volume dismount C:‎

  • כדי לבצע שאילתה על השטח הפנוי של אמצעי אחסון בכונן C, הקלד:

    • fsutil volume diskfree C:‎


Ftp

פקודה המבצעת העברת קבצים אל מחשב וממנו כאשר במחשב פועל שירות של שרת File Transfer Protocol ‏(FTP) כגון Internet Information Services. ניתן להשתמש ב- Ftp באופן אינטראקטיבי או במצב אצווה על-ידי עיבוד קבצי טקסט מסוג ASCII.

תחביר

ftp [-v] [-d] [-i] [-n] [-g] [-s:FileName] [-a] [-w:WindowSize] [-A] [Host]‎

פרמטרים

‎-v
העלמת התצוגה של תגובות שרתי FTP.
‎-d
מתן אפשרות לאיתור באגים, תוך הצגה של כל הפקודות שהועברו בין לקוח ה- FTP לבין שרת ה- FTP.
‎-i
ביטול הצגה של בקשות אינטראקטיביות במהלך העברות של קבצים מרובים.
‎-n
העלמת היכולת לבצע כניסה אוטומטית בעת יצירת ההתקשרות ההתחלתית.
‎-g
ביטול האפשרות לביצוע Globbing של שמות קבצים. באמצעות Glob מתאפשר השימוש בכוכבית (*) ובסימן שאלה (?) כתווים כלליים בשמות של נתיבים וקבצים מקומיים. לקבלת מידע נוסף, ראה Ftp: Glob.
‎-s:FileName
ציון קובץ טקסט המכיל פקודות ftp. פקודות אלה פועלות אוטומטית לאחר הפעלת ftp. פרמטר זה אינו מאפשר רווחים. השתמש בפרמטר זה במקום ניתוב מחדש (>).
‎-a
קביעה כי כל ממשק מקומי ניתן לשימוש בעת איגוד (binding) של חיבורי הנתונים של FTP.
‎-w:WindowSize
ציון גודל מאגר ההעברה. גודל החלון המוגדר כברירת מחדל הוא 4096 בתים.
‎-A
ביצוע כניסה אנונימית לשרת FTP.
Host
ציון שם המחשב, כתובת ה- IP, או כתובת ה- IPv6 של שרת FTP אליו יש להתחבר. על הכתובת או השם של המחשב המארח, אם צוין, להיות הפרמטר האחרון בשורה.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • עליך להוסיף לפרמטרי ftp מקף (-) בתחילתם ולא קו נטוי (/).
  • פרמטרי שורת הפקודה של ftp הם תלויי רישיות.
  • פקודה זו זמינה רק כאשר פרוטוקול האינטרנט (TCP/IP) מותקן כרכיב במאפייני מתאם רשת בחיבורי הרשת.
  • ניתן להשתמש בפקודה ftp באופן אינטראקטיבי. לאחר הפעלתה, הפקודה ftp יוצרת סביבת משנה בה באפשרותך להשתמש בפקודות ftp. באפשרותך לשוב אל שורת הפקודה על-ידי הקלדת הפקודה quit. כאשר סביבת המשנה של ftp פועלת, שורת הפקודה ftp >‎ מציינת זאת.
  • לקבלת מידע נוסף אודות פקודות משנה של ftp, ראה נושאים קרובים.
  • הפקודה ftp תומכת בשימוש ב- IPv6 כאשר פרוטוקול IPv6 מותקן. לקבלת מידע נוסף, ראה IP version 6 וכן יישומי IPv6.

דוגמאות

כדי להיכנס לשרת FTP הנקרא ftp.example.microsoft.com, הקלד את הפקודה הבאה:

ftp ftp.example.microsoft.com

כדי לבצע כניסה אנונימית לשרת FTP הנקרא ftp.example.microsoft.com, הקלד את הפקודה הבאה:

ftp -A ftp.example.microsoft.com

כדי להיכנס לשרת FTP הנקרא ftp.example.microsoft.com ולהפעיל את פקודות ftp המוכלות בקובץ הנקרא Resynch.txt, הקלד את הפקודה הבאה:

ftp -s:resynch.txt ftp.example.microsoft.com


Ftp: append

צירוף של קובץ מקומי לקובץ במחשב המרוחק תוך שימוש בהגדרה הנוכחית של סוג הקובץ.

תחביר

append LocalFile [RemoteFile]‎

פרמטרים

LocalFile
קביעה של קובץ מקומי שיש להוסיף.
RemoteFile
ציון הקובץ במחשב המרוחק אליו נוסף הקובץ בפרמטר LocalFile.
‎? append
הצגת עזרה עבור הפקודה append.

הערות

  • אם הפרמטר RemoteFile מושמט, נעשה שימוש בשם הפרמטר LocalFile במקום שם הקובץ המרוחק.


Ftp: ascii

הגדרת סוג העברת הקבצים כ- ASCII.

תחביר

ascii

פרמטרים

‎? ascii
הצגת עזרה עבור הפקודה ascii.

הערות

  • סוג העברת הקבצים הוא ASCII כברירת מחדל.
  • במצב ASCII, מתבצעות המרות של תווים אל מערכת התווים הסטנדרטית של הרשת וממנה. לדוגמה, תווי סוף שורה עוברים המרה לפי הצורך, בהתאם למערכת ההפעלה הייעודית.
  • FTP תומך בשני סוגי העברה של קבצים, ASCII ותמונה בינארית. עליך להשתמש ב- ASCII בעת העברה של קבצי טקסט. לקבלת מידע נוסף אודות העברת קבצים בינארית, ראה Ftp: binary בנושאים קרובים.


Ftp: !

גרפיקה של Microsoft Windows

Ftp: !‎

יציאה ממערכת המשנה של ftp לשורת פקודה באופן זמני כדי שניתן יהיה להפעיל פקודות של Windows XP. כדי לשוב אל מערכת המשנה של ftp, הקלד exit בשורת הפקודה.

תחביר

!

פרמטרים

‎? !‎
הצגת עזרה עבור הפקודה !.

הערות

  • השתמש בפקודה ! כדי להפעיל פקודות Windows XP מבלי לצאת מ- ftp.


Ftp: bell

החלפת מצב של צליל הניתן לשמיעה כך שיתרחש לאחר השלמת כל פקודה של העברת קבצים.

תחביר

bell

פרמטרים

‎? bell
הצגת עזרה עבור הפקודה bell.

הערות

  • כברירת מחדל, bell אינו פועל.


Ftp: binary

הגדרה של סוג העברת הקבצים כבינארי.

תחביר

binary

פרמטרים

‎? binary
הצגת עזרה עבור הפקודה binary.

הערות

  • מערכת ftp תומכת בשני סוגים של העברת קבצים, ASCII ותמונה בינארית. עליך להשתמש במצב הבינארי בעת העברה של קבצי הפעלה. במצב בינארי, הקבצים מועברים ביחידות של בית אחד. לקבלת מידע נוסף על העברת קבצים מסוג ASCII, ראה Ftp: ascii בנושאים קרובים.


Ftp: bye

סיום ההפעלה של FTP עם המחשב המרוחק וביצוע יציאה מ- ftp.

תחביר

bye

פרמטרים

‎? bye
הצגת עזרה עבור הפקודה bye.


Ftp: cd

שינוי של ספריית העבודה במחשב המרוחק.

תחביר

cd RemoteDirectory

פרמטרים

RemoteDirectory
ציון הספריה אליה ברצונך לעבור במחשב המרוחק.
‎? cd
הצגת עזרה עבור הפקודה cd.


Ftp: close

סיום הפעלת ה- FTP עם השרת המרוחק מבלי לצאת משורת הפקודה ftp>‎.

תחביר

close

פרמטרים

‎? close
הצגת עזרה עבור הפקודה close.


Ftp: debug

החלפת מצב של איתור באגים.

תחביר

debug

פרמטרים

‎? debug
הצגת עזרה עבור הפקודה debug.

הערות

  • כברירת מחדל, איתור באגים אינו מופעל.
  • כאשר איתור באגים מופעל, כל פקודה הנשלחת למחשב המרוחק מוצגת כשלפניה התו גדול מ (‎>‎).


Ftp: delete

מחיקת קבצים במחשבים מרוחקים.

תחביר

delete RemoteFile

פרמטרים

RemoteFile
קביעת הקובץ שברצונך למחוק.
‎? delete
הצגת עזרה עבור הפקודה delete.


Ftp: dir

הצגת רשימה של קבצים וספריות משנה בספריה במחשב מרוחק.

תחביר

dir [RemoteDirectory] [LocalFile]‎

פרמטרים

RemoteDirectory
קביעת הספריה שעבורה ברצונך להציג פירוט. אם לא תציין ספריה, המערכת תשתמש בספריית העבודה הנוכחית במחשב המרוחק.
LocalFile
ציון קובץ מקומי שישמש לאחסון הפירוט. אם לא יצוין קובץ מקומי, התוצאות יוצגו במסך.
‎? dir
הצגת עזרה עבור הפקודה dir.


Ftp: disconnect

התנתקות מהמחשב המרוחק מבלי לצאת משורת הפקודה ftp>‎.

תחביר

disconnect

פרמטרים

‎? disconnect
הצגת עזרה עבור הפקודה disconnect.


Ftp: get

העתקת קובץ מרוחק למחשב המקומי באמצעות הסוג הנוכחי של העברת הקבצים.

תחביר

get RemoteFile [LocalFile]‎

פרמטרים

RemoteFile
קביעת הקובץ המרוחק שיש להעתיק.
LocalFile
ציון שם הקובץ בו ברצונך להשתמש במחשב המקומי.
‎? get
הצגת עזרה עבור הפקודה get.

הערות

  • אם הפרמטר LocalFile אינו מצוין, הקובץ מקבל את השם RemoteFile.
  • הפקודה get זהה לפקודה recv.


Ftp: glob

החלפת מצב של הרחבת תו כללי של שמות קבצים מקומיים.

תחביר

glob

פרמטרים

‎? glob
הצגת עזרה עבור הפקודה glob.

הערות

  • כברירת מחדל, Globbing מופעל.
  • Globbing מאפשר את השימוש בכוכבית (*) ובסימן שאלה (?) כתווים כלליים בשמות קבצים או נתיבים מקומיים.


Ftp: hash

החלפת מצב של הדפסת סימן מספר (#) עבור כל בלוק נתונים שהועבר.

תחביר

hash

פרמטרים

‎? hash
הצגת עזרה עבור הפקודה hash.

הערות

  • הגודל של בלוק הנתונים הוא 2048 בתים.
  • כברירת מחדל, hash אינה מופעלת.


Ftp: help

הצגת תיאורים עבור פקודות משנה של ftp.

תחביר

help [command]‎

‎? [command]‎

פרמטרים

Command
ציון שם הפקודה אודותיה ברצונך להציג תיאור. אם לא תציין את Command, תוצג רשימה של כל הפקודות.


Ftp: lcd

שינוי של ספריית העבודה במחשב המקומי. כברירת מחדל, ספריית העבודה היא הספריה בה הופעלה הפקודה ftp.

תחביר

lcd [Directory]‎

פרמטרים

Directory
ציון הספריה במחשב המקומי אליה ברצונך לעבור. אם לא תציין את Directory, תוצג ספריית העבודה הנוכחית במחשב המקומי.
‎? lcd
הצגת עזרה עבור הפקודה lcd
.


Ftp: literal

שליחת ארגומנטים, מילה במילה, לשרת ה- FTP המרוחק. קוד מענה בודד של FTP מוחזר.

תחביר

literal Argument [ ...]‎

פרמטרים

Argument
קביעת הארגומנט שיש לשלוח לשרת FTP.
‎? literal
הצגת עזרה עבור הפקודה literal.


Ftp: ls

הצגת רשימה מקוצרת של קבצים וספריות משנה בספריה מרוחקת.

תחביר

ls [RemoteDirectory] [LocalFile]‎

פרמטרים

RemoteDirectory
קביעת הספריה שעבורה ברצונך להציג פירוט. אם לא תציין ספריה, המערכת תשתמש בספריית העבודה הנוכחית במחשב המרוחק.
LocalFile
ציון קובץ מקומי שישמש לאחסון הפירוט. אם לא מצוין קובץ מקומי, התוצאות יוצגו במסך.
‎? ls
הצגת עזרה עבור הפקודה ls.


Ftp: mdelete

מחיקת קבצים במחשבים מרוחקים.

תחביר

mdelete RemoteFiles [ ...]‎

פרמטרים

RemoteFiles
קביעת הקבצים המרוחקים שיש למחוק.
‎? mdelete
הצגת עזרה עבור הפקודה mdelete.


Ftp: mdir

הצגת רשימה של קבצים וספריות משנה בספריה מרוחקת.

תחביר

mdir RemoteFiles [ ...] LocalFile

פרמטרים

RemoteFiles
קביעת הספריה שעבורה ברצונך להציג פירוט.
LocalFile
ציון קובץ מקומי שישמש לאחסון הפירוט.
‎? mdir
הצגת עזרה עבור הפקודה mdir.

הערות

  • באפשרותך להשתמש בפקודה mdir כדי לציין קבצים מרובים.
  • ציון RemoteFiles

    הקלד מקף (-) כדי להשתמש בספריית העבודה הנוכחית במחשב המרוחק.

  • ציון LocalFile

    הקלד מקף (-) כדי להציג את הפירוט במסך.


Ftp: mget

העתקת קבצים מרוחקים למחשב המקומי תוך שימוש בסוג הנוכחי של העברת הקבצים.

תחביר

mget RemoteFiles [ ...]‎

פרמטרים

RemoteFiles
קביעת הקבצים המרוחקים שיש להעתיק למחשב המקומי.
‎? mget
הצגת עזרה עבור הפקודה mget.


Ftp: mkdir

יצירת ספריה במחשב המרוחק.

תחביר

mkdir Directory

פרמטרים

Directory
קביעת השם של הספריה המרוחקת החדשה.
‎? mkdir
הצגת עזרה עבור הפקודה mkdir.


Ftp: mls

הצגת רשימה מקוצרת של קבצים וספריות משנה בספריה מרוחקת.

תחביר

mls RemoteFiles [ ...] LocalFile

פרמטרים

RemoteFiles
קביעת הקבצים עבורם ברצונך להציג פירוט.
LocalFile
ציון קובץ מקומי שישמש לאחסון הפירוט.
‎? mls
הצגת עזרה עבור הפקודה mls.

הערות

  • ציון RemoteFiles

    הקלד מקף (-) כדי להשתמש בספריית העבודה הנוכחית במחשב המרוחק.

  • ציון LocalFile

    הקלד מקף (-) כדי להציג את הפירוט במסך.


Ftp: mput

העתקת קבצים מקומיים למחשב המרוחק תוך שימוש בסוג הנוכחי של העברת קבצים.

תחביר

mput LocalFiles [ ...]‎

פרמטרים

LocalFiles
קביעת הקבצים המקומיים שברצונך להעתיק למחשב המרוחק.
‎? mput
הצגת עזרה עבור הפקודה mput.


Ftp: open

התחברות לשרת FTP שצוין.

תחביר

open Computer [Port]‎

פרמטרים

Computer
נדרש. ציון המחשב המרוחק אליו אתה מנסה להתחבר.
Port
ציון מספר יציאת TCP המשמש להתחברות לשרת FTP. כברירת מחדל, נעשה שימוש ביציאת TCP מספר 21.
‎? open
הצגת עזרה עבור הפקודה open.

הערות

  • באפשרותך להשתמש בכתובת IP או בשם מחשב (במקרה זה, על שרת DNS או קובץ Hosts להיות זמינים) כדי לציין Computer. אם התכונה כניסה אוטומטית מופעלת, ftp מנסה להכניס את המשתמש באופן אוטומטי לתוך שרת FTP. לקבלת מידע אודות ביטול של כניסה אוטומטית באמצעות ftp, ראה נושאים קרובים.


Ftp: prompt

החלפת מצב בין prompt במצב פועל או כבוי.

תחביר

prompt

פרמטרים

‎? prompt
הצגת עזרה עבור הפקודה prompt.

הערות

  • כברירת מחדל, הפקודה prompt פועלת.
  • הפקודה ftp מציגה בקשות במהלך העברות מרובות של קבצים כדי לאפשר לך לאחזר או לאחסן קבצים באופן סלקטיבי. הפקודות Mget ו- mput מעבירות את כל הקבצים אם הפקודה prompt אינה פעילה.


Ftp: put

העתקת קובץ מקומי למחשב המרוחק באמצעות הסוג הנוכחי של העברת הקבצים.

תחביר

put LocalFile [RemoteFile]‎

פרמטרים

LocalFile
קביעת הקובץ המקומי שיש להעתיק.
RemoteFile
ציון השם לשימוש במחשב המרוחק.
‎? put
הצגת עזרה עבור הפקודה put.

הערות

  • אם RemoteFile אינו מצוין, השם LocalFile ניתן לקובץ.


Ftp: pwd

הדפסת הספריה הנוכחית במחשב המרוחק.

תחביר

pwd

פרמטרים

‎? pwd
הצגת עזרה עבור הפקודה pwd.


Ftp: quit

סיום ההפעלה של FTP עם המחשב המרוחק ויציאה מ- ftp לשורת הפקודה.

תחביר

quit

פרמטרים

‎? quit
הצגת עזרה עבור הפקודה quit.


Ftp: quote

שליחת ארגומנטים, מילה במילה, לשרת ה- FTP המרוחק. קוד מענה בודד של FTP מוחזר.

תחביר

quote Argument [ ...]‎

פרמטרים

Argument
קביעת הארגומנט שיש לשלוח לשרת FTP.
‎? quote
הצגת עזרה עבור הפקודה quote.

הערות

  • הפקודה quote זהה לפקודה literal.


Ftp: recv

העתקת קובץ מרוחק למחשב המקומי באמצעות הסוג הנוכחי של העברת הקבצים.

תחביר

recv RemoteFile [LocalFile]‎

פרמטרים

RemoteFile
קביעת הקובץ המרוחק שיש להעתיק.
LocalFile
ציון השם לשימוש במחשב המקומי.
‎? recv
הצגת עזרה עבור הפקודה recv.

הערות

  • הפקודה recv זהה לפקודה get.
  • אם LocalFile אינו מצוין, הקובץ מקבל את השם RemoteFile.


Ftp: remotehelp

הצגת עזרה עבור פקודות מרוחקות.

תחביר

remotehelp [Command]‎

פרמטרים

Command
ציון שם הפקודה אשר עבורה ברצונך לקבל עזרה. אם הפקודה command אינה מצוינת, ftp מציג רשימה של כל הפקודות המרוחקות.
‎? remotehelp
הצגת עזרה עבור הפקודה remotehelp.


Ftp: rename

שינוי שמות של קבצים מרוחקים.

תחביר

rename FileName NewFileName

פרמטרים

FileName
ציון הקובץ שאת שמו ברצונך לשנות.
NewFileName
קביעת שם הקובץ החדש.
‎? rename
הצגת עזרה עבור הפקודה rename.


Ftp: rmdir

מחיקת ספריה מרוחקת.

תחביר

rmdir Directory

פרמטרים

Directory
קביעת השם של הספריה המרוחקת שברצונך למחוק.
‎? rmdir
הצגת עזרה עבור הפקודה rmdir.


Ftp: send

העתקת קובץ מקומי למחשב המרוחק באמצעות הסוג הנוכחי של העברת הקבצים.

תחביר

send LocalFile [RemoteFile]‎

פרמטרים

LocalFile
קביעת הקובץ המקומי שיש להעתיק.
RemoteFile
ציון השם לשימוש במחשב המרוחק.
‎? send
הצגת עזרה עבור הפקודה send.

הערות

  • הפקודה send זהה לפקודה put.
  • אם הפרמטר RemoteFile אינו מצוין, הקובץ מקבל את השם LocalFile.


Ftp: status

הצגת המצב הנוכחי של התקשרויות FTP.

תחביר

status

פרמטרים

‎? status
הצגת עזרה עבור הפקודה status.


פקודות משנה של Ftp

לקבלת מידע נוסף, לחץ על פקודה:

  • Ftp: !‎
  • Ftp: ?‎
  • Ftp: append
  • Ftp: ascii
  • Ftp: bell
  • Ftp: binary
  • Ftp: Bye
  • Ftp: cd
  • Ftp: close
  • Ftp: debug
  • Ftp: delete
  • Ftp: dir
  • Ftp: disconnect
  • Ftp: get
  • Ftp: glob
  • Ftp: hash
  • Ftp: help
  • Ftp: lcd
  • Ftp: literal
  • Ftp: ls
  • Ftp: mdelete
  • Ftp: mdir
  • Ftp: mget
  • Ftp: mkdir
  • Ftp: mls
  • Ftp: mput
  • Ftp: open
  • Ftp: prompt
  • Ftp: put
  • Ftp: pwd
  • Ftp: quit
  • Ftp: quote
  • Ftp: recv
  • Ftp: remotehelp
  • Ftp: rename
  • Ftp: rmdir
  • Ftp: send
  • Ftp: status
  • Ftp: trace
  • Ftp: type
  • Ftp: user
  • Ftp: verbose


Ftp: trace

החלפת מצב של מעקב אחר מנות.

תחביר

trace

פרמטרים

‎? trace
הצגת עזרה עבור הפקודה trace.

הערות

  • trace מציגה את סדרת הקריאות של פונקציות פנימיות של FTP בעת הפעלה של פקודת ftp.


Ftp: type

הגדרה או הצגה של סוג העברת הקבצים.

תחביר

type [TypeName]‎

פרמטרים

TypeName
קביעה של סוג העברת הקבצים.
‎? type
הצגת עזרה עבור הפקודה type.

הערות

  • אם לא צוין הפרמטר TypeName, מוצג הסוג הנוכחי.
  • מערכת Ftp תומכת בשני סוגים של העברת קבצים, ASCII ובינארית.

    סוג העברת הקבצים המשמש כברירת מחדל הוא ASCII. יש להשתמש בפקודה ascii בעת העברה של קבצי טקסט. במצב ASCII, מתבצעות המרות של תווים אל מערכת התווים הסטנדרטית של הרשת וממנה. לדוגמה, תווי סוף שורה עוברים המרה לפי הצורך בהתאם למערכת ההפעלה של היעד.

    יש להשתמש בפקודה binary בעת העברה של קבצי הפעלה. במצב בינארי, הקובץ מועבר ביחידות של בית אחד.


Ftp: user

קביעת משתמש למחשב המרוחק.

תחביר

user UserName [Password] [Account]‎

פרמטרים

UserName
קביעת שם משתמש שישמש לביצוע כניסה למחשב המרוחק.
Password
ציון הסיסמה עבור UserName. אם לא מצוינת סיסמה אך היא נדרשת, ftp מציג בקשה לסיסמה.
Account
ציון חשבון שישמש לביצוע כניסה למחשב המרוחק. אם לא מצוין Account אך הדבר נדרש, ftp מציג בקשה להזנת החשבון.
‎? user
הצגת עזרה עבור הפקודה user.


Ftp: verbose

החלפת מצב של הפקודה verbose.

תחביר

verbose

v

פרמטרים

‎? verbose
הצגת עזרה עבור הפקודה verbose.

הערות

  • כברירת מחדל, הפקודה verbose פועלת. כאשר הפקודה verbose פועלת, כל תגובות ה- ftp מוצגות. כאשר מסתיימת העברת קובץ, מוצגת גם סטטיסטיקה אודות יעילות ההעברה.


Ftype

הצגה או שינוי של סוגי קבצים שבהם נעשה שימוש בשיוכי סיומות של שם קובץ. כאשר נעשה שימוש ב- ftype ללא פרמטרים, מוצגים סוגי הקבצים שהוגדרו עבורן מחרוזות פקודות פתוחות.

תחביר

Ftype [FileType[=[OpenCommandString]]]‎

פרמטרים

FileType
קביעת סוג הקובץ שברצונך להציג או לשנות.
OpenCommandString
ציון פקודת הפתיחה שיש להשתמש בה בעת פתיחה של קבצים מסוג זה.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • בתוך הפקודה OpenCommandString,‏ ftype מחליף את המשתנים הבאים:
    • ‎%0‎ או ‎%1‎ מוחלפים בשם הקובץ שברצונך לפתוח.
    • ‎%*‎ מוחלף בכל הפרמטרים.
    • ‎%~n מוחלף בכל הפרמטרים שנותרו, החל בפרמטר שמספרו מיוצג על-ידי n, כאשר n עשוי להיות כל מספר בין 2 ל- 9.
    • %2 מוחלף בפרמטר הראשון, %3 בפרמטר השני וכן הלאה.

דוגמאות

כדי להציג את סוגי הקבצים הנוכחיים שעבורם מוגדרות מחרוזות פקודה פתוחות, הקלד:

ftype

כדי להציג את מחרוזת הפקודה הפתוחה הנוכחית עבור סוג קובץ מסוים, הקלד:

ftype FileType

כדי למחוק את מחרוזת הפקודה הפתוחה עבור סוג קובץ מסוים, הקלד:

ftype FileType=‎

הקלד:

ASSOC .pl=PerlScript FTYPE PerlScript=perl.exe %1 %*‎

כדי להפעיל את קובץ ה- Script מסוג Perl, הקלד:

script.pl 1 2 3

כדי לבטל את הצורך בהקלדת הסיומות, הקלד:

set PATHEXT=.pl;%PATHEXT%‎

כדי להפעיל את קובץ ה- Script מסוג Perl, הקלד:

script 1 2 3 XOX


Getmac

החזרת הכתובת של בקר הגישה למדיה (MAC) ורשימה של פרוטוקולי הרשת המשויכים לכל כתובת עבור כל כרטיסי הרשת בכל מחשב, בין אם באופן מקומי או ברשת.

תחביר

getmac[.exe]‎ ‎[/s Computer [/u Domain\User [/p Password]]]‎ ‎[/fo {TABLE|LIST|CSV}]‎ ‎[/nh]‎ ‎[/v]‎

פרמטרים

‎/s Computer
ציון השם או כתובת ה- IP של מחשב מרוחק (אין להשתמש בקווים נטויים הפוכים). המחשב המקומי משמש כברירת המחדל.
‎/u Domain\User
הפעלת הפקודה באמצעות הרשאות החשבון של המשתמש שצוינו באמצעות User או Domain\User. ברירת המחדל היא ההרשאות של המשתמש המחובר כרגע למחשב המנפיק את הפקודה.
‎/p Password
ציון הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u.
‎/fo {TABLE|LIST|CSV}‎
ציון התבנית שיש להשתמש בה עבור פלט השאילתה. הערכים החוקיים הם TABLE,‏ LIST ו- CSV. התבנית המשמשת כברירת מחדל עבור פלט היא TABLE.
‎/nh
הסתרה של כותרת עמודה בפלט. הפעולה חוקית כאשר הפרמטר ‎/fo נקבע ל- TABLE או ל- CSV.
‎/v
בקשה לקבלת פלט מפורט.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • הפקודה Getmac עשויה להיות שימושית אם ברצונך להזין כתובת MAC לתוך מנתח רשת, או כאשר עליך לדעת מה הם הפרוטוקולים נמצאים כעת בשימוש בכל מתאם רשת במחשב.

דוגמאות

הדוגמאות הבאות מציגות אופני שימוש אפשריים בפקודה getmac:

getmac /fo table /nh /v
getmac /s srvmain
getmac /s srvmain /u maindom\hiropln
getmac /s srvmain /u maindom\hiropln /p p@ssW23
getmac /s srvmain /u maindom\hiropln /p p@ssW23 /fo list /v
getmac /s srvmain /u maindom\hiropln /p p@ssW23 /fo table /nh


Goto

בתוך תוכנית אצווה, ניתוב של Windows XP אל שורה המזוהה באמצעות תווית. לאחר מציאת התווית, עיבוד הפקודות המתחילות בשורה הבאה.

תחביר

goto label

פרמטרים

label
ציון השורה שאליה ברצונך לעבור בתוכנית אצווה.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • עבודה עם הרחבות פקודה

    אם הרחבות פקודה זמינות (כלומר, ברירת המחדל) וברצונך להשתמש בפקודה goto עם תווית היעד ‎:EOF עליך להעביר פקודה לסוף של קובץ Script האצווה הנוכחי ולצאת מקובץ Script האצווה מבלי להגדיר תווית. בעת שימוש ב- goto עם התווית ‎:EOF עליך להוסיף נקודותיים לפני התווית. לדוגמה:

    goto :EOF

    לקבלת תיאור של הרחבות הפקודה call ההופכות תכונה זו לשימושית, ראה cmd בנושאים קרובים.

  • שימוש בערכי label חוקיים

    באפשרותך להשתמש ברווחים בפרמטר label אך אין באפשרותך לכלול מפרידים אחרים (לדוגמה, נקודה-פסיק או סימני שוויון). הפקודה goto עושה שימוש רק בשמונת התווים הראשונים של תווית. לדוגמה, התוויות הבאות שקולות זו לזו, ומפוענחות כ- ‎:hithere0‏

    ‎:hithere0

    ‎:hithere01

    ‎:hithere02

  • התאמת הפרמטר label לתווית בתוכנית האצווה

    על ערך label שציינת להתאים לתווית בתוכנית האצווה. על התווית בתוכנית האצווה להתחיל בנקודותיים (:). Windows XP מזהה שורה של תוכנית אצווה המתחילה בנקודותיים (:) כתווית ואינו מעבד שורה זו כפקודה. אם שורה מתחילה בנקודותיים, אין התייחסות לפקודות הנמצאות בשורה זו. אם תוכנית האצווה אינה כוללת את התווית שציינת, תוכנית האצווה מפסיקה את פעולתה ומציגה את ההודעה הבאה:

    Label not found

  • שימוש בפקודה goto עבור פעולות מותנות

    באפשרותך להשתמש בפקודה goto עם פקודות אחרות לשם ביצוע פעולות מותנות. לקבלת מידע נוסף אודות שימוש בפקודה goto עבור פעולות מותנות, ראה if בנושאים קרובים.

דוגמאות

תוכנית האצווה שלהלן מאתחלת דיסק בכונן A כדיסק מערכת. אם הפעולה מתבצעת בהצלחה, הפקודה goto מנתבת את Windows XP לתווית ‎:end.

echo off
format a: /s
if not errorlevel 1 goto end
echo An error occurred during formatting.
‎:end
echo End of batch program.‎


Gpresult

הצגת הגדרות של מדיניות קבוצתית ושל ערכת מדיניות מונבעת (Resultant Set of Policy, ‏RSOP) עבור משתמש או מחשב.

תחביר

gpresult ‎[/s Computer [/u Domain\User /p Password]]‎ ‎[/user TargetUserName]‎ ‎[/scope {user|computer}]‎ ‎[/v]‎ ‎[/z]‎

פרמטרים

‎/s Computer
ציון השם או כתובת ה- IP של מחשב מרוחק (אין להשתמש בקווים נטויים הפוכים). המחשב המקומי משמש כברירת מחדל.
‎/u Domain\User
הפעלת הפקודה באמצעות הרשאות החשבון של המשתמש שצוין באמצעות User או Domain\User. ברירת המחדל היא ההרשאות של המשתמש המחובר כעת למחשב שהנפיק את הפקודה.
‎/p Password
ציון הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u.
‎/user TargetUserName
ציון שם המשתמש שיש להציג את נתוני RSOP שלו.
‎/scope {user|computer}‎
הצגת תוצאות עבור user (משתמש) או עבור computer (מחשב). ערכים חוקיים עבור הפרמטר ‎/scope הם user או computer. אם תשמיט את הפרמטר ‎/scope, הפקודה gpresult תביא להצגת ההגדרות של user ושל computer גם יחד.
‎/v
בקשה לקבלת פלט עם מידע מדיניות מפורט.
‎/z
קביעה כי הפלט יציג את כל המידע הזמין אודות מדיניות קבוצתית. מכיוון שפרמטר זה מפיק יותר מידע מאשר הפרמטר ‎/v, נתב את הפלט לקובץ טקסט בעת שימוש בפרמטר זה (לדוגמה, gpresult /z >policy.txt).
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • מדיניות קבוצתית היא הכלי הניהולי העיקרי לשם הגדרה ובקרה על האופן שבו תוכניות, משאבי רשת ומערכת ההפעלה פועלים עבור משתמשים ומחשבים בארגון. בסביבת Active Directory, מדיניות קבוצתית חלה על משתמשים או מחשבים בהתאם לחברות שלהם באתרים, בקבוצות מחשבים או ביחידות ארגוניות.
  • מכיוון שבאפשרותך להחיל רמות חופפות של פרטי מדיניות על כל מחשב או משתמש, התכונה מדיניות קבוצתית מפיקה ערכה מונבעת של פרטי מדיניות בעת ההתחברות. הפקודה Gpresult מציגה את הערכה המונבעת של פרטי מדיניות שנכפו על המחשב עבור המשתמש שצוין בכניסה.

דוגמאות

הדוגמאות הבאות מציגות אופנים שבהם באפשרותך להשתמש בפקודה gpresult:

gpresult /user targetusername /scope computer
gpresult /s srvmain /u maindom\hiropln /p p@ssW23 /user targetusername /scope USER
gpresult /s srvmain /u maindom\hiropln /p p@ssW23 /user targetusername /z >policy.txt
gpresult /s srvmain /u maindom\hiropln /p p@ssW23


Graftabl

מתן אפשרות להציג ערכת תווים מורחבת במצב גרפי.

תחביר

graftabl [xxx] [/status]‎

פרמטרים

xxx
קביעת הקידוד שעבורו ברצונך להגדיר את המראה של תווים מורחבים במצב גרפי. הטבלה הבאה מפרטת את כל מספרי הזיהוי של קידוד חוקי ואת המדינה/אזור או השפה שלו.
ערך | מדינה/אזור
437 | ארצות הברית
850 | רב לשוני (לטינית I)
852 | סלבית (לטינית II)
855 | קירילית (רוסית)
857 | טורקית
860 | פורטוגזית
861 | איסלנדית
863 | צרפתית-קנדית
865 | נורדית
866 | רוסית
869 | יוונית מודרנית
‎/status
זיהוי הקידוד המשמש את graftabl.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • לקבלת מידע אודות שימוש בקידודים, ראה chcp או mode (קביעת קידודי התקן) בנושאים קרובים.
  • הפקודה graftabl אינה משנה את הקידוד של קלט המסוף. הפקודה graftabl משפיעה רק על תווים מורחבים של הקידוד שציינת כשהם מוצגים בצג. כדי לשנות את הקידוד שבשימוש, השתמש בפקודות mode או chcp.
  • הכרת קודי היציאה של graftabl

    הטבלה הבאה מפרטת כל קוד יציאה ומספקת תיאור קצר עבורו:

    קוד יציאה | תיאור
    0 | ערכת התווים נטענה בהצלחה; לא נטען קידוד קודם.
    1 | צוין פרמטר שגוי; לא בוצעה כל פעולה.
    2 | אירעה שגיאת קובץ.
  • באפשרותך להשתמש בפרמטר errorlevel בשורת הפקודה if בתוכנית אצווה כדי לעבד קודי יציאה שהוחזרו על-ידי הפקודה graftabl.

דוגמאות

כדי לטעון את ערכת תווי הגרפיקה עבור קידוד 437 (ארצות הברית) לזיכרון, הקלד:

graftabl 437

כדי לטעון את ערכת תווי הגרפיקה עבור קידוד 850 (רב-לשוני) לזיכרון, הקלד:

graftabl 850


גרפיקה של Microsoft Windows

Graphics

XOX


Help

מתן מידע מקוון אודות פקודות מערכת (כלומר, פקודות שאינן פקודות רשת). כאשר משתמשים בפקודה help ללא פרמטרים, כל פקודת רשת מוצגת ומתוארת בקצרה.

תחביר

‎{help [command]|[command]/?}‎

פרמטרים

command
קביעת השם של הפקודה אשר אודותיה ברצונך לקבל מידע.

הערות

  • קיימות שתי דרכים לקבלת עזרה מקוונת עבור פקודה. באפשרותך להקליד help command או command ‎/?‎. השימוש ב- ‎/?‎ הוא מעט מהיר יותר.
  • לקבלת מידע אודות פקודות רשת, לחץ על net help בנושאים קרובים.

דוגמאות

כדי להציג מידע אודות הפקודה xcopy , הקלד אחת מהפקודות הבאות:

help xcopy
xcopy /?‎


Helpctr

הפעלת מרכז העזרה והתמיכה. כאשר נעשה שימוש בפקודה helpctr ללא פרמטרים, מוצג דף הבית של מרכז העזרה והתמיכה.

תחביר

helpctr [/url [URL]]‎ ‎[/mode [URL]]‎ ‎[/hidden]‎ ‎[/fromstarthelp]‎

פרמטרים

‎/url [URL]‎
ציון ה- Uniform Resource Locator ‏(URL) שברצונך להציג במרכז העזרה והתמיכה.
‎/mode [URL]‎
ציון קובץ הגדרה של Extensible Markup Language ‏(XML) המתאים לסכימה Launch_Description.dtd, המפקחת על ההקשר, הפריסה והתוכן של מרכז העזרה והתמיכה.
‎/hidden
הפעלת מרכז העזרה והתמיכה מבלי להציג את ממשק המשתמש. פקודה זו עשויה לטעון נושא. השתמש בפקודה זו עבור הפעלת קובץ Script המנוהל מרחוק.
‎/fromstarthelp
הפעלת מופע חדש של מרכז העזרה והתמיכה.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • שימוש ב- URL

    בעת השימוש ב- ‎/url או ב- ‎/mode, באפשרותך לתחום במרכאות את URL (כלומר, "URL"). אם קיים רווח בתוך URL, החלף אותו על-ידי הקלדת %20 (כלומר, ‎"URL%20 Address"‎).

דוגמאות

לשם הפעלת הפעלה של סיוע מרחוק באמצעות קובץ ‎.msrincident, הקלד:

HelpCtr /mode "hcp://CN=Microsoft%20Corporation,L=Redmond,S=Washington,C=US/Remote%20Assistance/RAClientLayout.xml" /url "hcp://CN=Microsoft%20Corporation,L=Redmond,S=Washington,C=US/Remote%20Assistance/Interaction/Client/rctoolScreen1.htm?IncidentFile=rahelp.msrincident"‎


Hostname

הצגת החלק של שם המחשב המארח מתוך שם המחשב המלא של המחשב.

תחביר

hostname

פרמטרים

‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • לקבלת מידע נוסף אודות ציון שם המחשב המלא, ראה נושאים קרובים.
  • פקודה זו זמינה רק אם הפרוטוקול Internet Protocol ‏(TCP/IP) מותקן כרכיב במאפיינים של מתאם רשת בחיבורי רשת.

דוגמאות

כדי להציג את שם המחשב, הקלד:

hostname

XOX

נושאים קרובים


If

ביצוע עיבוד מותנה בתוכניות אצווה.

תחביר

if [not] errorlevel number command [else expression]‎

if [not] string1==string2 command [else expression]‎

if [not] exist FileName command [else expression]‎

אם הרחבות הפקודה זמינות, השתמש בתחביר הבא:

if [/i] string1 CompareOp string2 command [else expression]‎

if cmdextversion number command [else expression]‎

if defined variable command [else expression]‎

פרמטרים

not
קביעה כי יש לבצע את הפקודה רק אם התנאי שקרי.
errorlevel number
קביעה של תנאי אמת רק אם התוכנית הקודמת שהופעלה על-ידי Cmd.exe החזירה קוד יציאה השווה או גדול מהערך שצוין ב- number.
command
קביעת הפקודה שיש לבצע אם התנאי הקודם התקיים.
string1==string2
קביעה של תנאי אמת רק אם הפרמטרים string1 ו- string2 זהים. ערכים אלה עשויים להיות מחרוזות מילוליות או משתני אצווה (%1, לדוגמה). אין צורך להשתמש במרכאות עבור מחרוזות מילוליות.
exist filename
קביעה של תנאי אמת אם הקובץ שצוין באמצעות הפרמטר FileName קיים.
CompareOp
קביעת אופרטור השוואה בן שלוש אותיות. הטבלה הבאה מציגה ערכים חוקיים עבור CompareOp.
אופרטור | תיאור
EQU | שווה
NEQ | שונה
LSS | קטן
LEQ | קטן או שווה
GTR | גדול
GEQ | גדול או שווה
‎/i
מציין כי יש לכפות על השוואות מחרוזת להתעלם מרישיות. באפשרותך להשתמש בפרמטר ‎/i‎ בצורת string1==string2 של if. השוואות אלה כלליות, במובן זה שאם הפרמטרים string1 ו- string2 כוללים ספרות בלבד, המחרוזות מומרות למספרים ומתבצעת השוואה מספרית.
cmdextversion number
קביעה של תנאי אמת רק אם מספר הגירסה הפנימי המשוייך לתכונה הרחבות פקודה (Command Extensions) של Cmd.exe שווה או גדול מהערך של number. מספר הגירסה הראשונה הוא 1. ערך זה עולה במספר אחד בכל פעם שמתווספים שיפורים משמעותיים להרחבות הפקודה. התנאי של cmdextversion לעולם לא יימצא אמיתי אם הרחבות הפקודה אינן זמינות (כברירת מחדל, הרחבות הפקודה זמינות).
defined variable
קביעה של תנאי אמת אם המשתנה שצוין (variable) הוגדר.
expression
ציון העברה של פקודת שורת פקודה וכל פרמטר לפקודה בפסוקית else.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • אם התנאי שצוין בפקודת if אמיתי, הפקודה שמופיעה לאחר התנאי תבוצע. אם התנאי שקרי, אין התייחסות לפקודה שבפסוקית if ומתבצעת הפעלה של כל פקודה בפסוקית else, אם צוינה.
  • כאשר תוכנית מפסיקה את פעולתה, מוחזר קוד יציאה. באפשרותך להשתמש בקודי יציאה כתנאים באמצעות הפרמטר errorlevel.
  • שימוש ב- defined variable

    אם תשתמש ב- defined variable, נוספים שלושת המשתנים הבאים: ‎%errorlevel%‎,‏ ‎%cmdcmdline%‎ ו- ‎%cmdextversion%‎.

    ‎%errorlevel%‎ מתרחב לכדי ייצוג מחרוזת של הערך הנוכחי של errorlevel, בתנאי שלא קיים כבר משתנה סביבה ששמו ERRORLEVEL. אם קיים משתנה כזה, ערכו יתקבל במקום ערך המחרוזת המבוקש. הדוגמה הבאה ממחישה אופן של אפשרות שימוש ב- errorlevel לאחר הפעלת תוכנית אצווה:

    goto answer%errorlevel%‎
    ‎:answer0
    echo Program had return code 0
    ‎:answer1
    echo Program had return code 1
    goto end
    ‎:end
    echo done!‎

    באפשרותך גם להשתמש באופרטורי ההשוואה CompareOp כמוצג להלן:

    if %errorlevel% LEQ 1 goto okay

    ‎%cmdcmdline%‎ מתרחב לכדי שורת הפקודה המקורית שהועברה ליישום Cmd.exe לפני שיישום זה ביצע עיבוד כלשהו, בתנאי שלא קיים כבר משתנה סביבה בשם cmdcmdline, כיוון שבמקרה זה יתקבל הערך של cmdcmdline במקום הערך הרצוי.

    ‎%cmdextversion%‎ מתרחב לכדי ייצוג מחרוזת של הערך הנוכחי של cmdextversion, בתנאי שלא קיים כבר משתנה סביבה ששמו CMDEXTVERSION. אם קיים משתנה כזה, יתקבל ערכו במקום ערך המחרוזת המבוקש.

  • שימוש בפסוקית else

    עליך להשתמש בפסוקית else באותה שורה של הפקודה שציינת אחרי if. לדוגמה:

    IF EXIST filename. (‎
del filename.
‎) ELSE (‎
echo filename. missing.
)‎

    הקוד הבא אינו פועל מכיוון שעליך לסיים את הפקודה del בשורה חדשה:

    IF EXIST filename. del filename. ELSE echo filename. missing

    הקוד הבא אינו פועל מכיוון שעליך להשתמש בפסוקית else באותה שורה שבה מסתיימת הפקודה if:

    IF EXIST filename. del filename.‎
ELSE echo filename. missing

    אם ברצונך להזין את כל הפקודה בשורה בודדת, השתמש בצורה הבאה של ההצהרה המקורית:

    IF EXIST filename. (del filename.) ELSE echo filename. missing

דוגמאות

אם לא ניתן למצוא את הקובץ Product.dat, תופיע ההודעה הבאה:

if not exist product.dat echo Can't find data file

אם מתרחשת שגיאה במהלך האתחול של הדיסק בכונן A, הדוגמה הבאה מציגה הודעת שגיאה:

‎:begin
‎@echo off
format a: /s
if not errorlevel 1 goto end
echo An error occurred during formatting.‎
‎:end
echo End of batch program.‎

אם לא אירעה שגיאה, לא תוצג הודעת השגיאה.

לא ניתן להשתמש בפקודה if כדי לבדוק ישירות אם קיימת ספריה, אך ההתקן ‎(NUL)‎ Null קיים בכל ספריה. לפיכך, באפשרותך לבדוק אם ההתקן Null קיים כדי לקבוע אם ספריה קיימת. הדוגמה הבאה בודקת את הקיום של ספריה.

if exist c:mydir\nul goto process


Install

טעינת תוכנית שוכנת זיכרון לזיכרון. השתמש בקובץ systemroot\System32\Config.nt או בקובץ ההפעלה השקול לו, כשם שצוין בקובץ מידע של תוכנית (קובץ PIF), כדי לציין את התוכנית שיש להתקין.

תחביר

install=[Drive:][Path] FileName [CommandParameters]‎

פרמטרים

‎[Drive:][Path] FileName
קביעת השם והמיקום של התוכנית שוכנת הזיכרון שברצונך להפעיל.
CommandParameters
ציון פרמטרים עבור התוכנית שציינת באמצעות FileName.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • השתמש בפקודה install כדי לטעון תוכנית שוכנת זיכרון לזיכרון מיד לפני הפעלת היישום שעבורו דרושה התוכנית שוכנת הזיכרון. אם תוכנית שוכנת זיכרון נטענת לזיכרון באמצעות הקובץ Autoexec.nt, התוכנית שוכנת הזיכרון תיטען לזיכרון בכל פעם ששורת הפקודה תופעל, דבר שיגרום לבזבוז זיכרון.
  • אל תשתמש בפקודה install כדי לטעון תוכניות העושות שימוש במשתני סביבה או במקשי קיצור, או תוכניות שעבורן נדרש שימוש ביישום Cmd.exe כדי לטפל בשגיאות קריטיות.

דוגמאות

כדי לטעון תוכנית לזיכרון בקובץ Config.nt, הקלד:

install

XOX

נושאים קרובים


Ipconfig

הצגת ערכי TCP/IP של תצורת רשת ורענון הגדרות Dynamic Host Configuration Protocol ‏(DHCP) ו- Domain Name System ‏(DNS). שימוש בפקודה ipconfig ללא פרמטרים מביא להצגה של כתובת ה- IP, מסיכת רשת משנה, וערכי ברירת המחדל של שער עבור כל המתאמים.

תחביר

ipconfig [/all]‎ ‎[/renew Adapter ‎/release [adapter]‎ ‎[/flushdns]‎ ‎[/displaydns]‎ ‎[/registerdns]‎ ‎[/showclassid Adapter]‎ ‎[/setclassid Adapter [ClassID]]‎

פרמטרים

‎/all
הצגה של תצורת TCP/IP מלאה עבור כל המתאמים. ללא פרמטר זה, הפקודה ipconfig מציגה רק את כתובת ה- IP, מסיכת רשת המשנה וערכי ברירת מחדל של שער עבור כל מתאם. מתאמים עשויים לייצג ממשקים פיזיים, כגון מתאמי רשת מותקנים, או ממשקים לוגיים, כגון התקשרויות חיוג.
‎/renew [Adapter]‎
חידוש תצורת DHCP עבור כל המתאמים (אם לא צוין מתאם) או עבור מתאם מסוים אם צוין ערך עבור הפרמטר Adapter. פרמטר זה זמין רק במחשבים עם מתאמים שהוגדרו להשיג כתובת IP באופן אוטומטי. כדי לציין שם של מתאם, הקלד את שם המתאם המוצג לאחר שימוש בפקודה ipconfig ללא פרמטרים.
‎/release [Adapter]‎
שליחה של הודעת DHCPRELEASE לשרת DHCP כדי לשחרר את תצורת ה- DHCP ולמחוק את תצורת כתובת ה- IP עבור כל המתאמים (אם לא צוין מתאם) או עבור מתאם מסוים אם צוין ערך עבור הפרמטר Adapter. פרמטר זה מונע שימוש ב- TCP/IP עבור מתאמים המוגדרים להשיג כתובת IP באופן אוטומטי. כדי לציין שם של מתאם, הקלד את שם המתאם המוצג לאחר שימוש בפקודה ipconfig ללא פרמטרים.
‎/flushdns
ריקון ואיפוס התוכן של מטמון הפיענוח של לקוח DNS. במהלך פתרון בעיות DNS, באפשרותך להשתמש בהליך זה כדי למחוק ערכי מטמון שליליים מהמטמון, כמו גם ערכים אחרים שהתווספו בצורה דינמית.
‎/displaydns
הצגה של מטמון הפענוח של לקוחות DNS, הכולל ערכים שנטענו מקובץ המארחים (Hosts) המקומי ורשומות משאבים שהתקבלו לאחרונה עבור שאילתות שם שהמחשב פיענח. השירות DNS Client עושה שימוש במידע זה לשם פענוח מהיר של שמות שמתבצעת עליהם שאילתה לעתים קרובות, לפני ביצוע שאילתה על שרתי ה- DNS המוגדרים שלו.
‎/registerdns
אתחול רישום דינמי ידני עבור שמות DNS וכתובות IP שהוגדרו במחשב. באפשרותך להשתמש בפרמטר זה כדי לפתור בעיות ברישום שם DNS שכשל או כדי לזהות בעיית עדכון דינמי בין לקוח לשרת DNS מבלי לאתחל מחדש את מחשב הלקוח. הגדרות DNS, הנקבעות במאפיינים המתקדמים של פרוטוקול TCP/IP, קובעות מה הם השמות שיירשמו ב- DNS.
‎/showclassid Adapter
הצגת מזהה המחלקה של DHCP עבור מתאם שצוין. כדי להציג מזהה מחלקה של DHCP עבור כל המתאמים, השתמש בתו הכללי כוכבית (*) עבור Adapter. פרמטר זה זמין רק במחשבים עם מתאמים שהוגדרו להשיג כתובת IP באופן אוטומטי.
‎/setclassid Adapter [ClassID]‎
הגדרת מזהה המחלקה של DHCP עבור מתאם שצוין. כדי להגדיר את מזהה המחלקה של DHCP עבור כל המתאמים, השתמש בתו הכללי כוכבית (*) במקום Adapter. פרמטר זה זמין רק במחשבים עם מתאמים שהוגדרו להשיג כתובת IP באופן אוטומטי. אם לא צוין מזהה מחלקה של DHCP, יימחק מזהה המחלקה הנוכחי.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • הפקודה ipconfig היא המקבילה של שורת הפקודה לפקודה winipcfg, הזמינה ב- Windows Millennium Edition‏, Windows 98 ו- Windows 95. אף על פי שמערכת ההפעלה Windows XP אינה כוללת מקבילה גרפית לפקודה winipcfg, באפשרותך להשתמש בחיבורי רשת כדי להציג ולחדש כתובת IP. כדי לעשות זאת, פתח את חיבורי רשת, לחץ באמצעות לחצן העכבר הימני על חיבור רשת, לחץ על מצב ולאחר מכן לחץ על הכרטיסיה תמיכה.
  • הפקודה יעילה במיוחד במחשבים שהוגדרו להשיג כתובת IP באופן אוטומטי. הדבר מאפשר למשתמשים לקבוע אילו ערכי תצורה של TCP/IP הוגדרו באמצעות DHCP‏, Automatic Private IP Addressing ‏(APIPA), או תצורה חלופית.
  • אם שם המתאם (Adapter) מכיל רווחים, תחום אותו במרכאות (כלומר, "Adapter Name").
  • עבור שמות מתאמים, ipconfig תומכת בשימוש בתו הכללי כוכבית (*) להגדרת מתאמים ששמותיהם מתחילים במחרוזת מסוימת או כוללים מחרוזת מסוימת. לדוגמה, Local*‎ מתאים לכל המתאמים ששמותיהם מתחילים במחרוזת Local ו- ‎*Con*‎ מתאים לכל המתאמים ששמותיהם מכילים את המחרוזת Con.
  • פקודה זו זמינה רק אם פרוטוקול Internet Protocol ‏(TCP/IP) הותקן כרכיב במאפיינים של מתאם רשת בחיבורי רשת.

דוגמאות

לשם הצגת התצורה הבסיסית של TCP/IP עבור כל המתאמים, הקלד:

ipconfig

לשם הצגת התצורה המלאה של TCP/IP עבור כל המתאמים, הקלד:

ipconfig /all

לשם חידוש תצורה של כתובת IP עם הקצאת DHCP רק עבור המתאם Local Area Connection, הקלד:

ipconfig /renew "Local Area Connection"‎

לשם ריקון של מטמון הפיענוח של DNS בעת פתרון של בעיות זיהוי שמות DNS, הקלד:

ipconfig /flushdns

לשם הצגת מזהה המחלקה של DHCP עבור כל המתאמים בעלי שמות המתחילים ב- Local, הקלד:

ipconfig /showclassid Local*‎

לשם הגדרת מזהה המחלקה של DHCP עבור המתאם Local Area Connection כ- Test, הקלד:

ipconfig /setclassid "Local Area Connection" TEST


Ipseccmd

קביעת מדיניות אבטחת פרוטוקול אינטרנט (IPSec) בשירות ספריות או ברישום מקומי או מרוחק. Ipseccmd היא חלופה של שורת פקודה עבור יישום ה- Snap-in של Microsoft Management Console ‏(MMC), הנקרא פריטי מדיניות אבטחת IP. לפקודה Ipseccmd שלושה מצבים: מצב דינאמי, מצב סטטי ומצב שאילתה.

להצגת תחביר הפקודה, לחץ על פקודה:

ipseccmd במצב דינאמי

באפשרותך להשתמש במצב הדינאמי של Ipseccmd כדי להוסיף כללים אנונימיים למדיניות IPSec הקיימת על-ידי הוספתם למסד הנתונים של פריטי מדיניות אבטחת IPSec. הכללים החדשים יישמרו גם לאחר הפעלה מחדש של שירות IPSEC Services. השימוש במצב דינאמי מאפשר את קיום של הכללים החדשים יחד עם מדיניות IPSec מבוססת קבוצת מחשבים. המצב הדינאמי מוגדר כברירת מחדל עבור Ipseccmd.

תחביר

  • להוספת כלל, השתמש בתחביר הבא:

    • ipseccmd [\\ComputerName] -f FilterList [-n NegotiationPolicyList]‎ ‎[-t TunnelAddr] [-a AuthMethodList] [-1s SecurityMethodList] [-1k MainModeRekeySettings]‎ ‎[-1p] [-1f MMFilterList] [-1e SoftSAExpirationTime] [-soft]‎ ‎[-confirm] [{-dialup | -lan}]‎

  • למחיקת כל פריטי המדיניות הדינאמיים, השתמש בתחביר הבא:

    • ipseccmd -u

פרמטרים

‎\\ComputerName
ציון שם המחשב של מחשב מרוחק שברצונך להוסיף כלל עבורו.
‎-f FilterList
נדרש עבור תחביר ראשוני. ציון מפרט של מסנן אחד, או של כמה מסננים המופרדים באמצעות רווחים, עבור מצב שיוך אבטחה מהיר. כל מפרט מסנן מגדיר מערכת של תנועת רשת שכלל זה חל עליה.
‎-n NegotiationPolicyList
הגדרת שיטת אבטחה אחת, או כמה שיטות אבטחה המופרדות באמצעות רווחים, עבור אבטחת תנועה המוגדרת באמצעות רשימת המסננים.
‎-t TunnelAddr
הגדרת נקודת קצה מסוג Tunnel עבור מצב Tunnel ככתובת IP או כשם DNS של קבוצת מחשבים.
‎-a AuthMethodList
ציון של שיטת אימות אחת, או של כמה שיטות אימות המופרדות באמצעות רווחים.
‎-1s SecurityMethodList
ציון שיטת אבטחה אחת של חילופי מפתחות, או של כמה שיטות אבטחה מסוג זה, המופרדות באמצעות רווחים.
‎-1k MainModeRekeySettings
ציון הגדרות ReKey של שיוך אבטחה במצב ראשי.
‎-1p
מתן אפשרות לסודיות מושלמת של מפתח ראשי עבור העברה קדימה.
‎-1f MMFilterList
ציון מפרט מסנן עבור מצב ראשי של שיוך אבטחה, או של כמה מפרטי מסננים המופרדים באמצעות רווחים.
‎-1e SoftSAExpirationTime
ציון פרק זמן שיוקצב עבור שיוכי אבטחה רכים, בשניות.
‎-soft
הפעלת שיוכי אבטחה רכים.
‎-confirm
ציון של הצגת בקשה לאישור בפני המשתמש לפני הוספת הכלל או המדיניות.
‎{-dialup | -lan}‎
ציון של החלת הכלל על גישה מרחוק או התקשרויות חיוג בלבד, או על חיבורי LAN (רשת תקשורת מקומית) בלבד.
‎-u
נדרש עבור התחביר השני. מציין מחיקה של כל הכללים הדינאמיים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • לא ניתן להשתמש ב- Ipseccmd לשם הגדרת כללים במחשבים שפועל בהם Windows 2000.
  • אם אינך מציין ערך עבור הפרמטר ComputerName, הכלל נוסף למחשב המקומי.
  • אם ברצונך להשתמש בפרמטר ComputerName, עליך להשתמש בו לפני הפרמטרים האחרים. כדי להשתמש בפרמטר זה, עליך להיות בעל הרשאות ניהול במחשב שאליו ברצונך להוסיף את הכלל.
  • עבור הפרמטר ‎-f, מפרט מסנן הוא מסנן אחד או יותר המופרדים באמצעות רווחים, ומוגדרים בתבנית:

    • SourceAddress/SourceMask:SourcePort=DestAddress/DestMask:DestPort:Protocol

    • SourceMask,‏ SourcePort,‏ DestMask ו- DestPort הם אופציונליים. אם לא תעשה שימוש בפרמטרים אלה, נעשה שימוש במסיכה של 255.255.255.255 ובכל היציאות עבור המסנן.
    • Protocol הוא אופציונלי. אם לא תשתמש בפרמטר זה, נעשה שימוש בכל הפרוטוקולים עבור המסנן. אם ברצונך לציין פרוטוקול, עליך לציין את היציאה, או להוסיף שני תווי נקודתיים (::) לפני הפרוטוקול (ראה את הדוגמה הראשונה עבור מצב דינאמי). על הפרוטוקול להיות הפריט האחרון במסנן. באפשרותך להשתמש בסימני הפרוטוקול הבאים: ICMP‏, UDP‏, RAW או TCP.
    • באפשרותך ליצור מסננים משתקפים על-ידי החלפת סימן השוויון (=) בסימן חיבור (+).
    • באפשרותך להחליף את SourceAddress/SourceMask או את DestAddress/DestMask בערכים שבטבלה הבאה.
      • ערך | תיאור
0 | הכתובת או הכתובות שלי
* | כתובת כלשהי
DNSName | שם DNS של קבוצת מחשבים. אם ניתן לפענח שם DNS זה לכמה כתובות שונות, לא ייעשה בו שימוש.
GUID | מזהה ייחודי כללי (GUID) של ממשק רשת מקומי בצורת ‎{12345678-1234-1234-1234-123456789ABC}‎. אין תמיכה בציון מזהה ייחודי כללי כאשר נעשה שימוש בפרמטר ‎-n במצב סטטי.
    • באפשרותך להפעיל את כלל התגובה המוגדר כברירת מחדל על-ידי ציון מפרט המסנן default.
    • באפשרותך לציין מסנן היתר על-ידי תחימת מפרט המסנן בסוגריים. באפשרותך לציין מסנן חוסם על-ידי תחימה של מפרט המסנן בסוגריים מרובעים ([ ]).
    • אם ברצונך להשתמש במסיכות רשת משנה מבוססות מחלקה של כתובת אינטרנט (מסיכות רשת המשנה מוגדרות בגבולות אוקטט), באפשרותך להשתמש בסימון כללי לציון מסיכות רשת משנה. לדוגמה, ‎10.*.*.*‎ שקול ל- ‎10.0.0.0/255.0.0.0‎ ו- ‎10.92.*.*‎ שקול ל- ‎10.92.0.0/255.255.0.0‎.

    דוגמאות מסנן

    ליצירת מסננים משוקפים עבור סינון של תנועת TCP בין Computer1 לבין Computer2, הקלד:

    Computer1+Computer2::TCP

    ליצירת מסנן עבור כל תנועת TCP מרשת המשנה ‎172.31.0.0/255.255.0.0‎, יציאה 80, לרשת המשנה ‎10.0.0.0/255.0.0.0‎, יציאה 80, הקלד:

    ‎172.31.0.0/255.255.0.0:80=10.0.0.0/255.0.0.0:80:TCP‎

    ליצירת מסנן משוקף המאפשר תנועה בין כתובת ה- IP המקומית לכתובת ה- IP ‏‎10.2.1.1‎, הקלד:

    ‎(0+10.2.1.1)‎

  • עבור הפרמטר ‎-n, יש לציין מדיניות משא ומתן אחת או יותר, המופרדות באמצעות רווחים ומוגדרות באחת התבניות הבאות:
    • esp[EncrypAlg,AuthAlg]Rekey PFS[Group]‎
    • ah[HashAlg]‎
    • ah[HashAlg]+esp[EncrypAlg,AuthAlg]‎

    כאשר EncrypAlg עשוי להיות none‏, des או 3des,‏ AuthAlg עשוי להיות none‏, md5 או sha ו- HashAlg עשוי להיות md5 או sha.

    • אין תמיכה עבור התצורה esp[none,none]‎.
    • הפרמטר sha מתייחס לאלגוריתם Hash מסוג SHA1.
    • הפרמטר האופציונלי Rekey מציין את מספר הקילו-בתים (שיש לציין באמצעות K לאחר המספר) או את מספר השניות (שיש לציין באמצעות S לאחר המספר) הקודמים לפעולת ReKeying של שיוך אבטחה במצב מהיר. לציון שני הפרמטרים עבור ReKey, הפרד את שני המספרים באמצעות קו נטוי (/). לדוגמה, כדי לבצע ReKeying של שיוך האבטחה במצב מהיר כל שעה ולאחר כל 5 מגה-בתים של נתונים, הקלד:

      • 3600S/5000K

    • הפרמטר PFS הוא אופציונלי, ומאפשר סודיות מושלמת של מפתח הפעלה (Session Key) בהעברה קדימה. כברירת מחדל, אפשרות זו אינה פועלת אלא אם תבקש להפעילה.
    • הפרמטר Group הוא אופציונלי, ומציין את הקבוצה Diffie-Hellman עבור סודיות מושלמת של מפתח הפעלה בהעברה קדימה. עבור הקבוצה Diffie-Hellman ברמה Low‏(1), ציין PFS1 או P1. עבור הקבוצה Diffie-Hellman ברמה Medium‏(2), ציין PFS2 או P2. כברירת מחדל, ערך הקבוצה עבור סודיות מושלמת של מפתח הפעלה בהעברה קדימה נקבע לפי ההגדרות הנוכחיות של המצב הראשי.
    • אם אינך מגדיר מדיניות משא ומתן, פריטי המדיניות עבור משא ומתן הם אלה:
      • esp[3des,sha]‎
      • esp[3des,md5]‎
      • esp[des,sha]‎
      • esp[des,md5]‎
  • אם לא תציין את הפרמטר ‎-t, נעשה שימוש במצב תעבורה IPSec.
  • עבור הפרמטר ‎-a, נעשה שימוש בשיטת אימות מן התבנית שלהלן, או בכמה שיטות אימות המופרדות באמצעות רווחים:
    • preshare:"PresharedKeyString"‎
    • kerberos
    • cert:"CAInfo"‎

    הפרמטר PresharedKeyString מציין את מחרוזת התווים של המפתח ששיתופו נקבע מראש. הפרמטר CAInfo מציין את השם הייחודי של האישור כפי שהוא מוצג ביישום ה- Snap-in פריטי מדיניות אבטחת IP בעת בחירה באישור שישמש כשיטת אימות עבור כלל. הפרמטרים PresharedKeyString ו- CAInfo תלויי רישיות. באפשרותך להשתמש בקיצורים עבור שמות השיטות על-ידי שימוש באות הראשונה: p‏, k או c. אם לא תציין את הפרמטר ‎-a, שיטת האימות המוגדרת כברירת מחדל היא Kerberos.

  • עבור הפרמטר ‎-1s, יש להשתמש בשיטת אבטחה של חילופי מפתחות מן התבנית הבאה, או בכמה שיטות אבטחה כאלה המופרדות באמצעות רווחים:

    • EncrypAlg-HashAlg-GroupNum

    כאשר EncrypAlg עשוי להיות des או 3des, ‏HashAlg עשוי להיות md5 או sha ו- GroupNum עשוי להיות 1 עבור הקבוצה Diffie-Hellman ברמה Low‏(1), או 2 עבור הקבוצה Diffie-Hellman ברמה Medium‏(2). אם תבחר שלא לציין את הפרמטר ‎-1s, שיטות האבטחה מסוג חילופי מפתחות המוגדרות כברירת מחדל הן 3des-sha-2‏, 3des-md5-2‏, des-sha-1 ו- des-md5-1.

  • עבור הפרמטר ‎-1k, באפשרותך לציין את מספר שיוכי האבטחה של מצב מהיר (שיש לציין באמצעות Q לאחר המספר) או את מספר השניות (שיש לציין באמצעות S לאחר המספר) לשם ביצוע ReKeying לשיוך האבטחה של מצב מהיר. לציון שני הפרמטרים, עליך להפריד את שני המספרים בקו נטוי (/). לדוגמה, כדי לבצע ReKey לשיוך אבטחה של מצב מהיר כל 10 שיוכי אבטחה במצב מהיר וכל שעה, הקלד:

    • 10Q/3600S

    אם לא תציין את הפרמטר ‎-1k, הערכים המוגדרים כברירת מחדל עבור ReKey של מצב ראשי הם מספר בלתי מוגבל של שיוכי אבטחה במצב מהיר ו- 480 דקות.

  • כברירת מחדל, סודיות מושלמת של מפתח ראשי בהעברה קדימה אינה פועלת.
  • עבור הפרמטר ‎-1f, התחביר לציון מפרטי המסנן של מצב ראשי זהה לזה של הפרמטר ‎-f, פרט לכך שאין באפשרותך לציין מסנני היתר, מסנני חסימה, יציאות או פרוטוקולים. אם תבחר שלא לציין את הפרמטר ‎-1f, מסנני המצב הראשי נוצרים באופן אוטומטי, בהתבסס על מסנני המצב המהיר.
  • אם תבחר שלא לציין את הפרמטר ‎-1e, זמן התפוגה עבור שיוכי אבטחה רכים הוא 300 שניות. עם זאת, שיוכי אבטחה רכים פועלים רק אם ציינת את הפרמטר ‎-soft.
  • אישור הוא זמין עבור מצב דינאמי בלבד.
  • אם לא תציין את הפרמטר ‎-dialup או את הפרמטר ‎-lan, הכלל יחול על כל המתאמים.

דוגמאות

ליצירת כלל העושה שימוש בכותרת אימות (Authentication Header, ‏AH) עם Hashing מסוג MD5 עבור כל התנועה מהמחשב המקומי ואליו, הקלד:

ipseccmd -f 0+* -n ah[md5]‎

ליצירת כלל Tunnel עבור תנועה מ- 10.2.1.1 ומ- 10.2.1.13, עם נקודת הקצה 10.2.1.13 עבור Tunnel, עם מצב Tunnel מסוג AH העושה שימוש באלגוריתם Hash מסוג SHA1, בתוספת סודיות מושלמת של מפתח ראשי בהעברה קדימה והצגה של בקשת אישור לפני יצירת הכלל, הקלד:

ipseccmd -f 10.2.1.1=10.2.1.13 -t 10.2.1.13 -n ah[sha] -1p -c

ליצירת כלל במחשב corpsrv1 עבור כל התנועה בין מחשבים הנקראים corpsrv1 ו- corpsrv2, עם צירוף של כותרת אימות (AH) ושל Encapsulating Security Payload ‏(ESP) ועם אימות של מפתח ששיתופו נקבע מראש, הקלד:

ipseccmd \\corpsrv1 -f corpsrv2+corpsrv1 -n ah[md5]+esp[des,sha] -a p:"corpauth"‎

ipseccmd במצב סטטי

באפשרותך להשתמש במצב סטטי של Ipseccmd ליצירת פריטי מדיניות בעלי שם וכללים בעלי שם. באפשרותך להשתמש במצב סטטי גם לשם תיקון של פריטי מדיניות ושל כללים קיימים, אם אלה נוצרו במקור באמצעות Ipseccmd. התחביר עבור מצב סטטי משלב את התחביר עבור מצב דינאמי עם פרמטרים המאפשרים פעולה ברמת המדיניות.

תחביר

ipseccmd DynamicModeParameters -w Type[:Location]‎ ‎-p PolicyName[:PollInterval] -r RuleName [{-x | -y}] [-o]‎

פרמטרים

DynamicModeParameters
נדרש. ציון מערכת של פרמטרים במצב דינאמי עבור כלל IPSec, כפי שתואר לעיל.
‎-w Type[:Location]‎
נדרש. מציין שמתבצע רישום של פריטי המדיניות ושל הכללים ברישום מקומי, ברישום של מחשב מרוחק או בקבוצת מחשבים של Active Directory.
‎-p PolicyName[:PollInterval]‎
נדרש. ציון של שם המדיניות ושל התדירות, בדקות, שבה תיבדק המדיניות לשם חיפוש אחר שינויים. אם PolicyName מכיל רווחים, תחום אותו במרכאות (כלומר, "Policy Name").
‎-r RuleName
נדרש. ציון שם הכלל. אם RuleName מכיל רווחים, תחום אותו במרכאות (כלומר, "Rule Name").
‎[{-x | -y}]‎
מציין האם מתבצעת הקצאה של מדיניות הרישום המקומית. הפרמטר ‎-x מציין שמתבצעת הקצאה של מדיניות הרישום המקומית. הפרמטר ‎-y מציין שהקצאה אינה מתבצעת.
‎-o
מציין שיש למחוק את הכלל או את המדיניות.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • עבור הפרמטר ‎-w, על Type להיות reg כדי לציין את הרישום של מחשב מקומי או מרוחק, או ds כדי לציין Active Directory.
    • בעת ציון reg עבור הפרמטר Type ללא שימוש בפרמטר Location, הכלל נוצר עבור הרישום של המחשב המקומי.
    • בעת ציון reg עבור הפרמטר Type וציון שם של מחשב מרוחק עבור הפרמטר Location, הכלל נוצר עבור רישום המחשב המרוחק שצוין.
    • בעת ציון ds עבור הפרמטר Type ללא שימוש בפרמטר Location, הכלל נוצר עבור קבוצת המחשבים Active Directory שהמחשב המקומי חבר בה.
    • בעת ציון ds עבור הפרמטר Type וציון קבוצת מחשבים של Active Directory עבור הפרמטר Location, הכלל נוצר עבור קבוצת המחשבים שצוינה.
  • עבור הפרמטר ‎-p, אם מדיניות בעלת שם זה כבר קיימת, הכלל שצוין מתווסף למדיניות. אם לא קיימת מדיניות בשם זה, נוצרת מדיניות עם השם שצוין. בעת ציון מספר שלם עבור הפרמטר PollInterval, מרווח התשאולים עבור המדיניות נקבע למספר זה של דקות.
  • עבור הפרמטר ‎-r, אם כלל בעל שם זה כבר קיים, הכלל משתנה כך שישקף את הפרמטרים שצוינו בפקודה. לדוגמה, בעת כלילת הפרמטר ‎-f עבור כלל קיים, יוחלפו רק המסננים של אותו כלל. אם אין כלל קיים ששמו זהה לשם שצוין, נוצר כלל בשם זה.
  • עבור הפרמטר ‎-o, נמחקים כל ההיבטים של המדיניות שצוינה. אין להשתמש בפרמטר זה אם קיימת מדיניות אחרת המבצעת הצבעה אל אובייקטים במדיניות שברצונך למחוק.

  • שימוש במצב סטטי שונה משימוש במצב דינאמי מבחינה אחת. בעבודה במצב דינאמי, המשתמש מציין מסנני היתר ומסנני חסימה באמצעות FilterList, שניתן לזהות באמצעות הפרמטר ‎-f. בעבודה במצב סטטי, המשתמש מציין מסנני היתר ומסנני חסימה באמצעות NegotiationPolicyList, שניתן לזהות באמצעות הפרמטר ‎-n. בנוסף לפרמטרים המתוארים עבור NegotiationPolicyList במצב דינאמי, באפשרותך להשתמש בפרמטרים block‏, pass או inpass במצב סטטי. הטבלה הבאה מציגה את הפרמטרים הללו ואת אופן פעולתם.

    פרמטר | תיאור
    block | התעלמות מכל מדיניות אחרת ב- NegotiationPolicyList, והפיכת כל המסננים למסנני חסימה.
    pass | התעלמות מכל מדיניות אחרת ב- NegotiationPolicyList והפיכת כל המסננים למסנני היתר.
    inpass | מסנני כניסה יאפשרו תקשורת ראשונית שאינה מאובטחת, אך תגובות יאובטחו באמצעות IPSec.

דוגמאות

ליצירת מדיניות בשם Default Domain Policy עם מרווח תשאול של 30 דקות בקבוצת המחשבים של Active Directory שהמחשב המקומי חבר בה, עם כלל בשם Secured Servers עבור תנועה בין המחשב המקומי לבין המחשבים SecuredServer1 ו- SecuredServer2, תוך שימוש ב- Kerberos ובשיטות אימות של מפתחות ששיתופם נקבע מראש, הקלד:

ipseccmd -f 0+SecuredServer1 0+SecuredServer2 -a k p:"corpauth" -w ds -p "Default Domain Policy":30 -r "Secured Servers"‎

ליצירה ולהקצאה של מדיניות מקומית בשם Me to Anyone עם כלל בשם Secure My Traffic, תוך שימוש במסנן משוקף עבור כל תנועה למחשב המקומי ובשיטת אימות של מפתח ששיתופו נקבע מראש, הקלד:

ipseccmd -f 0+* -a p:"localauth" -w reg -p "Me to Anyone" -r "Secure My Traffic" -x

ipseccmd במצב שאילתה

באפשרותך להשתמש במצב שאילתה של Ipseccmd להצגת נתונים ממסד הנתונים עבור פריטי מדיניות אבטחה של IPSec.

תחביר

ipseccmd [\\ComputerName] show {{[filters] | [policies]‎ ‎| [auth] | [stats] | [sas]} | all}‎

פרמטרים

‎\\ComputerName
ציון שמו של המחשב המרוחק שעבורו ברצונך להציג נתונים.
show
נדרש. מציין שיש להפעיל את הפקודה Ipseccmd במצב שאילתה.
filters
הצגת מסנני מצב ראשי ומצב מהיר.
policies
הצגת מדיניות מצב ראשי ומצב מהיר.
auth
הצגת שיטות אימות של מצב ראשי.
stats
הצגת סטטיסטיקה אודות חילופי מפתחות באינטרנט (IKE) ואודות IPSec.
sas
הצגת שיוכי אבטחה של מצב ראשי ומצב מהיר.
all
הצגת כל סוגי הנתונים שצוינו לעיל.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • לא ניתן להשתמש בפקודה Ipseccmd לשם הצגת נתוני IPSec עבור מחשבים שפועל בהם Windows 2000.
  • אם לא נעשה שימוש בפרמטר ComputerName, מוצג מידע אודות המחשב המקומי.
  • אם ברצונך להשתמש בפרמטר ComputerName, ציין אותו לפני פרמטרים אחרים. כמו כן, עליך להיות בעל הרשאות ניהול במחשב שעבורו ברצונך להציג מידע.

דוגמאות

לשם הצגת מסננים ופריטי מדיניות עבור מצב ראשי ומצב מהיר במחשב המקומי, הקלד:

ipseccmd show filters policies

לשם הצגה של כל מידע IPSec עבור המחשב המרוחק Server1, הקלד את הפקודה הבאה:

ipseccmd \\Server1 show all


Ipxroute

הצגה ושינוי של מידע אודות טבלאות הניתוב שפרוטוקול IPX משתמש בהן. בעת שימוש ללא פרמטרים, תציג הפקודה ipxroute את הגדרות ברירת המחדל עבור מנות שנשלחות לכתובות שידור, לכתובות שאינן ידועות ולכתובות של שידור לקבוצה.

תחביר

ipxroute servers [/type=x]‎

ipxroute ripout network

ipxroute resolve {guid | name} {guid | AdapterName}‎

ipxroute board=n [def] [gbr] [mbr] [remove=xxxxxxxxxxxx]‎

ipxroute config

פרמטרים

servers [/type=x]‎
הצגת הטבלה Service Access Point ‏(SAP) עבור סוג השרת שצוין. על x להיות מספר שלם. לדוגמה, ‎/type=4 מציג את כל שרתי הקבצים. אם לא צוין ‎/type, הפקודה ipxroute servers תציג את כל סוגי השרתים, מפורטים לפי שם השרת.
ripout network
בדיקת האפשרות לבצע גישה אל network באמצעות פנייה אל טבלת ניתוב של מחסנית IPX, ושליחת בקשת Rip במקרה הצורך. Network הוא מספר היחידה של רשת IPX
.
resolve {guid | name} {guid | AdapterName}‎
תרגום של שם המזהה הייחודי הכללי (GUID) לשמו הידידותי, או של השם הידידותי למזהה הייחודי הכללי שלו.
board=n
קביעה של מתאם הרשת עבורו ברצונך לבצע שאילתה או להגדיר פרמטרים.
def
שליחת מנות לשידור ALL ROUTES. אם מנה משודרת לכתובת Mac ייחודית שאינה נמצאת בטבלה הניתוב המהווה מקור, הפעולה המהווה ברירת מחדל עבור הפקודה ipxroute היא לשלוח את המנה לשידור SINGLE ROUTES.
gbr
שליחת מנות לשידור ALL ROUTES. אם מנה משודרת לכתובת השידור (FFFFFFFFFFFF)‏, הפעולה המהווה ברירת מחדל עבור הפקודה ipxroute היא לשלוח את המנה לשידור SINGLE ROUTES.
mbr
שליחת מנות לשידור ALL ROUTES. אם מנה משודרת לכתובת של שידור לקבוצה (C000xxxxxxxx)‏, הפעולה המהווה ברירת מחדל עבור הפקודה ipxroute היא לשלוח את המנה לשידור SINGLE ROUTES.
remove=xxxxxxxxxxxx
הסרת הכתובת של הצומת שצוינה מטבלת הניתוב המהווה מקור.
config
הצגת מידע אודות כל האיגודים (Bindings) שתצורת IPX הוגדרה עבורם.
‎/?‎
הצגת עזרה בשורת הפקודה.

דוגמאות

להצגת יחידות הרשת שתחנת העבודה מחוברת אליהן, של כתובת הצומת של תחנת העבודה ושל סוג המסגרת שבשימוש, הקלד את הפקודה הבאה:

ipxroute config


Irftp

שליחת קבצים באמצעות קישור אינפרא-אדום. ללא פרמטרים, או עם הפרמטר ‎/s, הפקודה irftp מביאה לפתיחה של תיבת הדו-שיח קישור אלחוטי, שבה ניתן לבחור את הקבצים שברצונך לשלוח מבלי להשתמש בשורת הפקודה.

תחביר

irftp ‎[Drive:\] [[Path] FileName] [/h]‎

irftp /s

פרמטרים

Drive:\‎
ציון הכונן המכיל את הקבצים שברצונך לשלוח באמצעות קישור אינפרא-אדום.
‎[Path] FileName
ציון המיקום והשם של הקובץ או של ערכת הקבצים שברצונך לשלוח באמצעות קישור אינפרא-אדום. אם ברצונך לציין ערכת קבצים, עליך לציין את הנתיב המלא עבור כל קובץ.
‎/h
ציון מצב מוסתר. בעת שימוש במצב מוסתר, הקבצים נשלחים מבלי שתוצג תיבת הדו-שיח קישור אלחוטי.
‎/s
פתיחה של תיבת הדו-שיח קישור אלחוטי, כך שבאפשרותך לבחור את הקובץ או את ערכת הקבצים שברצונך לשלוח מבלי להשתמש בשורת הפקודה לציון הכונן, הנתיב ושמות הקובץ.

הערות

  • לפני השימוש בפקודה זו, ודא שלהתקנים שברצונך לתקשר איתם באמצעות קישור אינפרא-אדום יש פונקציונליות אינפרא-אדום זמינה ופועלת, ושהקישור האינפרא-אדום בין ההתקנים אכן נוצר.

דוגמאות

לשליחת מסמך Word בשם MyWorkDoc, הממוקם בתיקיה בשם MyWorkFiles (בכונן C של מחשב המקור), למחשב היעד, הקלד:

irftp C:\MyWorkFiles\MyWorkDoc.doc /h

לשליחת שני מסמכי Word, הנקראים MyWorkDoc1 ו- MyWorkDoc2 וממוקמים בתיקיה בשם MyWorkFiles (בכונן C של מחשב המקור), למחשב היעד, הקלד:

irftp C:\MyWorkFiles\MyWordDoc1.doc C:\MyWorkFiles\MyWordDoc2.doc /h

במקרים אלה נעשה שימוש במצב מוסתר, המונע הצגה של תיבת הדו-שיח קישור אלחוטי.


Label

יצירה, שינוי או מחיקה של תווית אמצעי האחסון (שם) של דיסק. הקלד label ללא פרמטרים כדי לשנות את התווית הנוכחית של אמצעי האחסון או כדי למחוק את התווית הקיימת.

תחביר

label [Drive:][label]‎

label [/MP][volume][label]‎

פרמטרים

Drive:‎
ציון אות הכונן (ואחריה נקודתיים) של הדיסק שברצונך לתת לו שם.
label
ציון שם עבור אמצעי האיחסון.
‎/MP
ציון שיש לנהוג באמצעי האחסון כנקודת טעינה או כשם אמצעי אחסון.
volume
ציון אות הכונן (ואחריה נקודתיים), נקודת טעינה, או שם אמצעי אחסון. אם צוין שם אמצעי אחסון, הפרמטר ‎/MP אינו נחוץ.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • Windows מציג את התווית של אמצעי האחסון כחלק מפירוט הספריה. אם קיים מספר סידורי של אמצעי אחסון, Windows יציג גם את מספר זה.
  • הודעות פקודה של Label

    אם לא תציין תווית בעת שימוש בפקודה label, תציג הפקודה label הודעה הדומה לזו:

    Volume in drive A is xxxxxxxxxxx
    Volume Serial Number is xxxx-xxxx
    Volume label (11 characters, ENTER for none)?‎

    החלק "Volume Serial Number" בהודעה אינו מוצג אם לדיסק אין מספר סידורי.

    באפשרותך להקליד את תווית אמצעי האחסון הרצויה או להקיש ENTER כדי למחוק את התווית הנוכחית. אם בדיסק קיימת תווית ואתה מקיש ENTER לביטולה, תציג בפניך הפקודה label את ההודעה הבאה:

    Delete current volume label (Y/N)?

    Press Y to delete the label; press N to keep the label.‎

  • מגבלות על שמות תוויות של אמצעי אחסון

    לתווית של אמצעי אחסון יש אפשרות להכיל עד 32 תווים עבור אמצעי אחסון מסוג NTFS ועד 11 תווים עבור אמצעי אחסון מסוג FAT ובאפשרותה לכלול רווחים אך לא טאבים.

    לתוויות של אמצעי אחסון מסוג FAT אין אפשרות להכיל את התווים הבאים:

    ‎* ? / \ | . , ; : + = [ ] < > "‎

    מגבלה זו אינה חלה על אמצעי אחסון מסוג NTFS.

    עבור אמצעי אחסון מסוג FAT, תוויות אמצעי אחסון מאוחסנות באותיות רישיות גם אם הן מכילות אותיות קטנות. בתוויות של אמצעי אחסון מסוג NTFS, נשמרות ומוצגות הרישיות שנעשה בהן שימוש בעת יצירת התווית.

דוגמאות

כדי לציין תווית עבור תקליטון הנמצא בכונן A ומכיל מידע מכירות עבור חודש יולי, הקלד:

label a:sales-july


גרפיקה של Microsoft Windows

Lastdrive

XOX

נושאים קרובים


Loadfix

פקודה זו מוודאת כי התוכנית נטענה מעל 64 הקילו-בתים הראשונים של הזיכרון הרגיל, ולאחר מכן מפעילה את התוכנית.

תחביר

loadfix [Drive:][Path] FileName

פרמטרים

‎[Drive:][Path]‎
ציון הכונן והספריה של התוכנית.
FileName
ציון השם של התוכנית.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • XOX
  • כדי להשתמש בפקודה loadfix, כלול אותה בתחילת הפקודה המפעילה את התוכנית.
  • כאשר התוכנית נטענת ב- 64 הקילו-בתים הראשונים של הזיכרון הרגיל ואינה פועלת כראוי, יש תוכניות המציגות את ההודעה הבאה (הדבר נכון גם עבור טעינה של חלק מן התוכנית בלבד):
    Packed file corrupt

    לרוב, שגיאה זו מתרחשת בעת טעינה של מנהלי התקנים לאזור הזיכרון הגבוה (UMA), המביאה לפינוי של יותר מ- 64 הקילו-בתים הראשונים של הזיכרון הרגיל. אם מוצגת הודעה זו, השתמש בפקודה loadfix כדי לוודא שטעינת התוכנית מתבצעת מעל ל- 64 הקילו-בתים הראשונים של זיכרון רגיל וירטואלי.

דוגמאות

לטעינת תוכנית בשם Myapp.exe (בספריה Apps של כונן C) תוך שימוש באפשרות שורת הפקודה ‎/c (לדוגמה, לטעינת התוכנית במצב תו), הקלד:

loadfix c:\apps\myapp.exe /c

באפשרותך לכלול פקודה זו גם בתוכנית אצווה.


Loadhigh

טעינה של תוכנית לאזור הזיכרון הגבוה (UMA). טעינת תוכנית ל- UMA מותירה מקום רב יותר בזיכרון הרגיל עבור תוכניות אחרות. השתמש בקובץ systemroot\System32\Config.nt, או בקובץ ההפעלה השקול לו שצוין בקובץ PIF של התוכנית, כדי לציין את התוכניות שברצונך לטעון לאזור הזיכרון הגבוה.

תחביר

loadhigh [Drive:][Path] FileName [parameters]‎

פרמטרים

‎[Drive:][Path] FileName
פרמטר זה מציין את המיקום ואת השם של התוכנית שברצונך לטעון. הפרמטר Filename נדרש.
parameters
ציון מידע של שורת הפקודה הדרוש לתוכנית.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • XOX
  • כדי להשתמש בפקודה loadhigh, יש לכלול את הפקודה dos=umb בקובץ Config.nt או בקובץ הפעלה שקול לו. לקבלת מידע נוסף אודות הפקודה dos=umb, לחץ על dos ברשימה נושאים קרובים.
  • לפני שיהיה באפשרותך לטעון תוכנית לאזור הזיכרון הגבוה, עליך להתקין את מנהל הזיכרון המורחב Himem.sys. השתמש בפקודה device בקובץ Config.nt או בקובץ הפעלה שקול לו כדי להתקין את Himem.sys.
  • בעת שימוש בפקודה loadhigh כדי לטעון תוכנית, Windows XP יבצע ניסיון לטעון אותה לאזור הזיכרון הגבוה (UMA). אם אין די מקום באזור הזיכרון הגבוה, התוכנית נטענת לזיכרון הרגיל; אזור הזיכרון שנעשה בו שימוש לא יצוין.
  • הדרך הנוחה ביותר לשימוש בפקודה loadhigh היא לכלול אותה בקובץ Autoexec.nt או בקובץ הפעלה שקול לו.

דוגמאות

כדי לטעון מנהל התקן לאזור זיכרון גבוה (HMA), כלול את השורה שלהלן בקובץ Autoexec.nt או בקובץ הפעלה שקול לו:

lh ‎%systemroot%‎‎\system32\dosx


Lodctr

רישום של שמות ושל טקסט Explain חדשים של מונה ביצועים (מונה Performance) עבור שירות או מנהל התקן, ושמירה ושחזור של הגדרות ושל טקסט Explain של מונה.

תחביר

lodctr [\\ComputerName] FileName [/s:FileName] [/r:FileName]‎

פרמטרים

‎[\\ComputerName] FileName
רישום הגדרות של שם ושל טקסט Explain של מונה Performance, המסופקים בקובץ האתחול FileName. אם אינך מציין ComputerName, ברירת המחדל עבור lodctr היא שימוש במחשב המקומי.
‎/s:FileName
שמירה של הגדרות רישום ושל טקסט Explain של מונה Performance לקובץ FileName.
‎/r:FileName
שחזור של הגדרות רישום ושל טקסט Explain של מונה Performance מקובץ FileName.

שים לב

  • בעת שימוש בפקודה lodctr /r, כל הגדרות הרישום והגדרות טקסט Explain של מונה Performance יוחלפו בתצורה שהוגדרה בקובץ שצוין.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • אם המידע שברצונך לספק מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Computer Name").

דוגמאות

לשמירה של הגדרות הרישום ושל טקסט Explain של מונה Performance לקובץ perf backup1.txt, הקלד:

lodctr /s:"perf backup1.txt"‎


Lpq

הצגת המצב של תור הדפסה במחשב שפועל בו Line Printer Daemon ‏(LPD). ללא פרמטרים, תציג הפקודה lpq עזרה של שורת פקודה.

תחביר

lpq -S ServerName -P PrinterName [-l]‎

פרמטרים

‎-S ServerName
נדרש. ציון שמו של המחשב המארח את תור ההדפסה שאת מצבו ברצונך להציג.
‎-P PrinterName
נדרש. ציון שמה של המדפסת עבור תור ההדפסה שאת מצבו ברצונך להציג.
‎-l
ציון שברצונך להציג פרטים אודות מצבו של תור ההדפסה.
‎/?‎
הצגת עזרה בשורת הפקודה.


Lpr

שליחת קובץ למחשב שפועל בו Line Printer Daemon ‏(LPD) כהכנה להדפסה. ללא פרמטרים, הפקודה lpr תציג עזרה של שורת פקודה עבור lpr.

תחביר

lpr [-S ServerID] -P PrinterName ‎[-C BannerContent]‎ ‎[-J JobName]‎ ‎[{-o | -o l}]‎ ‎[-d]‎ ‎[-x]‎ FileName

פרמטרים

‎-S ServerID
ציון שם או כתובת IP של המחשב המארח את המדפסת שברצונך להדפיס בה את הקובץ. אם המדפסת מחוברת למחשב המקומי, אין צורך לציין פרמטר זה.
‎-P PrinterName
נדרש. ציון שמה של המדפסת שברצונך להדפיס בה את הקובץ.
‎-C BannerContent
ציון התוכן שברצונך להדפיס בעמוד השער של משימת ההדפסה. אם אינך כולל פרמטר זה, בעמוד השער יוצג שם המחשב שממנו נשלחה משימת ההדפסה.
‎-J JobName
ציון שם משימת ההדפסה עבור הדפסה בעמוד השער. אם אינך כולל פרמטר זה, יוצג בעמוד השער שם הקובץ המודפס.
‎{-o | -o l}‎
ציון סוג הקובץ שברצונך להדפיס. הפרמטר ‎-o מציין שברצונך להדפיס קובץ טקסט. הפרמטר ‎-o l מציין שברצונך להדפיס קובץ בינארי (לדוגמה, קובץ PostScript).
‎-d
ציון שעל קובץ הנתונים להישלח לפני קובץ הבקרה. השתמש בפרמטר זה אם שימוש במדפסת שברשותך מחייב שליחה של קובץ הנתונים תחילה. לקבלת מידע נוסף, עיין בתיעוד המדפסת.
‎-x
ציון שעל הפקודה lpr להיות תואמת למערכת ההפעלה Sun Microsystems, הנקראת SunOS עבור גירסאות שמספרן עד ‎4.1.4_u1‎, כולל.
FileName
נדרש. ציון שמו של הקובץ שיש להדפיס.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • למציאת שם המדפסת, פתח את התיקיה מדפסות ופקסים. XOX


Macfile

השתמש בפקודות macfile בשורת הפקודה כדי לנהל שרתים, אמצעי אחסון, ספריות וקבצים של File Server for Macintosh. באפשרותך להפוך משימות ניהול לאוטומטיות על-ידי הכללה של סדרת פקודות בקבצי אצווה והפעלתן באופן ידני או בזמנים קבועים מראש.

לשם שינוי ספריות באמצעי אחסון המאפשרים גישה עבור Macintosh

תחביר

macfile directory ‎[/server:\\ComputerName]‎ ‎/path:Directory [/owner:OwnerName]‎ ‎[/group:GroupName]‎ ‎[/permissions:Permissions]‎

פרמטרים

‎/server:\\ComputerName
ציון השרת שיש לערוך שינוי בספריה הממוקמת בו. אם אפשרות זו לא תצוין, הפעולה תתבצע במחשב המקומי.
‎/path:Directory
נדרש. ציון הנתיב לספריה שברצונך לשנות. יש לציין נתיב לספריה קיימת. הפקודה Macfile directory אינה יוצרת ספריות.
‎/owner:OwnerName
שינוי הבעלים של הספריה. אם אפשרות זו לא תצוין, הבעלות על הספריה תישאר ללא שינוי.
‎/group:GroupName
ציון או שינוי של קבוצת Macintosh הראשית המשוייכת לספריה. אם אפשרות זו לא תצוין, הקבוצה הראשית תישאר ללא שינוי.
‎/permissions:Permissions
הגדרת הרשאות בספריה עבור הבעלים, הקבוצה הראשית, או כולם (World). מספר בן 11 ספרות משמש להגדרת הרשאות. הספרה 1 מציינת הענקת הרשאה, והספרה 0 מציינת שלילת הרשאה (לדוגמה, 11111011000). מיקום הספרה קובע איזו הרשאה מוגדרת, כפי שמתואר בטבלה הבאה. אם אפשרות זו לא תצוין, ההרשאות יישארו ללא שינוי.
מיקום | הגדרת ההרשאות עבור
ראשון | OwnerSeeFiles
שני | OwnerSeeFolders
שלישי | OwnerMakeChanges
רביעי | GroupSeeFiles
חמישי | GroupSeeFolders
שישי | GroupMakeChanges
שביעי | WorldSeeFiles
שמיני | WorldSeeFolders
תשיעי | WorldMakeChanges
עשירי | לא ניתן לשנות את שם הספריה, להעביר את הספריה או למחוק אותה.
אחד-עשר | השינויים חלים על הספריה הנוכחית ועל כל ספריות המשנה.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • אם המידע שברצונך להזין מכיל רווחים או תווים מיוחדים, תחום אותו במרכאות (לדוגמה, "Computer Name").
  • השתמש בפקודה macfile directory להפוך ספריה קיימת באמצעי אחסון הנגיש עבור Macintosh לזמינה למשתמשי Macintosh. הפקודה macfile directory אינה יוצרת ספריות. השתמש במנהל הקבצים, בשורת הפקודה או בפקודה macintosh new folder ליצירת ספריה באמצעי אחסון הנגיש עבור Macintosh לפני שימוש בפקודה macfile directory.

דוגמאות

הדוגמה הבאה משנה את ההרשאות עבור ספריית המשנה May Sales, הממוקמת באמצעי האחסון Statistics, הנגיש עבור Macintosh וממוקם בכונן E של השרת המקומי. בדוגמה שלהלן מוענקות ההרשאות צפייה בקבצים (See Files), צפייה בתיקיות (See Folders) וביצוע שינויים (Make Changes) לבעלים, וההרשאות צפייה בקבצים וצפייה בתיקיות לכל המשתמשים האחרים. כמו כן, הפקודה שבדוגמה מונעת את שינוי שם הספריה, את העברת הספריה ואת מחיקתה.

macfile directory /path:"e:\statistics\may sales" /permissions:11111011000

לשם צירוף הסתעפויות נתונים והסתעפויות משאבים בקובץ של Macintosh

תחביר

macfile forkize ‎[/server:\\ComputerName]‎ ‎[/creator:CreatorName]‎ ‎[/type:TypeName]‎ ‎[/datafork:FilePath]‎ ‎[/resourcefork:FilePath]‎ ‎/targetfile:FilePath

פרמטרים

‎/server:\\ComputerName
ציון השרת שבו יש לצרף קבצים. אם אפשרות זו לא תצוין, הפעולה תתבצע במחשב המקומי.
‎/creator:CreatorName
ציון היוצר של הקובץ. Macintosh Finder עושה שימוש באפשרות שורת הפקודה ‎/creator כדי לקבוע איזה יישום יצר את הקובץ.
‎/type:TypeName
קביעת סוג הקובץ. Macintosh Finder עושה שימוש באפשרות שורת הפקודה ‎/type כדי לקבוע את סוג הקובץ ביישום שיצר את הקובץ.
‎/datafork:FilePath
ציון מיקומה של הסתעפות הנתונים שיש לצרף. באפשרותך לציין נתיב מרוחק.
‎/resourcefork:FilePath
ציון מיקומה של הסתעפות המשאב שיש לצרף. באפשרותך לציין נתיב מרוחק.
‎/targetfile:FilePath
נדרש. ציון מיקום הקובץ הנוצר על-ידי צירוף של הסתעפות נתונים והסתעפות משאב, או ציון מיקומו של הקובץ שברצונך לשנות את סוגו או את היוצר שלו. על הקובץ להיות ממוקם בשרת שצוין.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • אם המידע שברצונך להזין מכיל רווחים או תווים מיוחדים, תחום אותו במרכאות (לדוגמה, "Computer Name").

דוגמאות

ליצירת הקובץ Treeapp באמצעי האחסון D:\Release הנגיש עבור Macintosh, באמצעות הסתעפות המשאב C:\Cross\Mac\Appcode, וכדי לקבוע שהקובץ החדש יוצג בפני לקוחות Macintosh כיישום (יישומי Macintosh עושים שימוש בסוג APPL) ולקבוע כי היוצר (החתימה) יוגדר כ- MAGNOLIA, הקלד:

macfile forkize /resourcefork:c:\cross\mac\appcode /type:APPL /creator:MAGNOLIA /targetfile:D:\Release\Treeapp

לשינוי יוצר הקובץ ל- Microsoft Word 5.1 עבור הקובץ WORD.txt שבספריה D:\Word documents\Group files בשרת ‎\\SERVERA, הקלד:

macfile forkize /server:\\servera /creator:MSWD /type:TEXT /targetfile:"d:\Word documents\Group files\Word.txt"‎

לשם שינוי הודעת הכניסה ולשם הגבלת הפעלות

תחביר

macfile server ‎[/server:\\ComputerName]‎ ‎[/maxsessions:{Number | unlimited}]‎ ‎[/loginmessage:Message]‎

פרמטרים

‎/server:\\ComputerName
ציון השרת שבו יש לשנות פרמטרים. אם אפשרות זו לא תצוין, הפעולה תתבצע במחשב המקומי.
‎/maxsessions:{Number | unlimited}‎
ציון מספר המשתמשים המירבי שבאפשרותם להשתמש בו-זמנית ב- File and Print Servers for Macintosh. אם אפשרות זו לא תצוין, ההגדרה maxsessions עבור השרת תישאר ללא שינוי.
‎/loginmessage:Message
שינוי ההודעה המוצגת בפני משתמשי Macintosh בעת כניסה אל שרת File Server for Macintosh. מספר התווים המירבי עבור הודעת הכניסה הוא 199. אם אפשרות זו לא תצוין, ההודעה loginmessage עבור השרת תישאר ללא שינוי. להסרה של הודעת כניסה קיימת, כלול את הפרמטר ‎/loginmessage, אך השאר את המשתנה Message ריק.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • אם המידע שברצונך להזין כולל רווחים או תווים מיוחדים, תחום אותו במרכאות (לדוגמה, "Computer Name").

דוגמאות

לשינוי מספרן של הפעלות File and Print Server for Macintosh המורשות בשרת המקומי מההגדרה הנוכחית לחמש הפעלות, ולהוספת הודעת הכניסה "Log off from Server for Macintosh when you are finished.‎", הקלד:

macfile server /maxsessions:5 /loginmessage:"Log off from Server for Macintosh when you are finished."‎

לשם הוספה, שינוי או הסרה של אמצעי אחסון הנגישים עבור Macintosh

תחביר

macfile volume {/add | /set}‎ ‎[/server:\\ComputerName]‎ ‎/name:VolumeName /path:Directory ‎[/readonly:{true | false}]‎ ‎[/guestsallowed:{true | false}]‎ ‎[/password:Password]‎ ‎[/maxusers:{Number | unlimited}]‎

macfile volume /remove ‎[/server:\\ComputerName]‎ ‎/name:VolumeName

פרמטרים

‎{/add | /set}‎
נדרש בעת הוספה או שינוי של אמצעי אחסון הנגיש עבור Macintosh. ביצוע הוספה או שינוי של אמצעי האחסון שצוין.
‎/server:\\ComputerName
ציון השרת שבו יש להוסיף, לשנות או להסיר אמצעי אחסון. אם אפשרות זו לא תצוין, הפעולה תתבצע במחשב המקומי.
‎/name:VolumeName
נדרש. ציון שמו של אמצעי האחסון שיש להוסיף, לשנות או להסיר.
‎/path:Directory
נדרש וחוקי רק בעת הוספה של אמצעי אחסון. ציון הנתיב לספריית הבסיס של אמצעי האחסון שברצונך להוסיף.
‎/readonly:{true | false}‎
ציון האפשרות שניתנת למשתמשים עבור שינוי קבצים באמצעי האחסון. הקלד true כדי לציין שאין למשתמשים אפשרות לשנות קבצים באמצעי האחסון. הקלד false כדי לציין שיש למשתמשים אפשרות לשנות קבצים באמצעי האחסון. אם אפשרות זו לא תצוין בעת הוספת אמצעי אחסון, ניתן יהיה לבצע שינויים בקבצים. אם אפשרות זו לא תצוין בעת שינוי אמצעי אחסון, ההגדרה של האפשרות Read-Only (קריאה בלבד) עבור אמצעי האחסון תישאר ללא שינוי.
‎/guestsallowed:{true | false}‎
ציון האפשרות שתינתן למשתמשים הנכנסים כאורחים להשתמש באמצעי האחסון. הקלד true כדי לציין שיש לאורחים אפשרות להשתמש באמצעי האחסון. הקלד false כדי לציין שאין לאורחים אפשרות להשתמש באמצעי האחסון. אם אפשרות זו לא תצוין בעת הוספת אמצעי אחסון, תהיה לאורחים אפשרות להשתמש באמצעי האחסון. אם אפשרות זו לא תצוין בעת שינוי אמצעי אחסון, ההגדרה guestsallowed עבור אמצעי האחסון תישאר ללא שינוי.
‎/password:Password
ציון הסיסמה שתידרש לשם קבלת גישה לאמצעי האחסון. אם אפשרות זו לא תצוין בעת הוספת אמצעי אחסון, לא תיווצר סיסמה. אם אפשרות זו לא תצוין בעת שינוי אמצעי אחסון, הסיסמה הקיימת תישאר ללא שינוי.
‎/maxusers:{Number | unlimited}‎
ציון מספרם המירבי של משתמשים שיורשו להשתמש בו-זמנית בקבצים שבאמצעי האחסון. אם אפשרות זו לא תצוין בעת הוספת אמצעי אחסון, לא תהיה הגבלה על מספר המשתמשים שיהיה באפשרותם להשתמש באמצעי האחסון. אם אפשרות זו לא תצוין בעת שינוי אמצעי אחסון, הערך maxusers יישאר ללא שינוי.
‎/remove
נדרש בעת הסרת אמצעי אחסון הנגיש עבור Macintosh. הסרת אמצעי האחסון המוגדר.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • אם המידע שברצונך להזין כולל רווחים או תווים מיוחדים, תחום אותו במרכאות (לדוגמה, "Computer Name").

דוגמאות

ליצירת אמצעי אחסון בשם US Marketing Statistics בשרת המקומי, תוך שימוש בספריה Stats שבכונן E, וכמו כן כדי לציין שמשתמשים אורחים לא יורשו לקבל גישה לאמצעי האחסון, הקלד:

macfile volume /add /name:"US Marketing Statistics" /guestsallowed:false /path:e:\Stats

לשינוי אמצעי האחסון שנוצר לעיל כך שישמש עבור קריאה בלבד, שהגישה אליו תותנה בהזנת סיסמה ושמספר המשתמשים המירבי בו יהיה חמישה, הקלד:

macfile volume /set /name:"US Marketing Statistics" /readonly:true /password:saturn /maxusers:5

להוספת אמצעי אחסון בשם Landscape Design בשרת ‎\\Magnolia תוך שימוש בספריה Trees שבכונן E, וכמו כן כדי לציין שמשתמשים אורחים יקבלו גישה לאמצעי האחסון, הקלד:

macfile volume /add /server:\\Magnolia /name:"Landscape Design" /path:e:\Trees

להסרת אמצעי האחסון הנקרא Sales Reports מן השרת המקומי, הקלד:

macfile volume /remove /name:"Sales Reports"‎


Mem

הצגת מידע אודות אזורי זיכרון שהוקצו, אזורי זיכרון פנויים ותוכניות הטעונות כעת בזיכרון במערכת המשנה MS-DOS. ללא פרמטרים, תציג הפקודה mem את מצב הזיכרון שבשימוש ואת מצב הזיכרון הפנוי של מערכת המשנה MS-DOS.

תחביר

mem [{/program | /debug | /classify}]‎

פרמטרים

‎/program
הצגת המצב של תוכניות הטעונות כעת בזיכרון.
‎/debug
הצגת המצב של תוכניות הטעונות כעת ושל של מנהלי התקנים פנימיים, כמו גם מידע תיכנות אחר.
‎/classify
הצגת המצב של תוכניות הטעונות בזיכרון הרגיל ובאזור הזיכרון הגבוה (UMA).
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • XOX
  • XOX
  • השימוש בפרמטר ‎/program

    לא ניתן להשתמש בפרמטר ‎/program עם ‎/debug או עם ‎/classify. עבור ‎/program, באפשרותך להשתמש גם בצורה המקוצרת ‎/p.

  • השימוש בפרמטר ‎/debug

    לא ניתן להשתמש בפרמטר ‎/debug עם ‎/program או עם ‎/classify. עבור ‎/debug, באפשרותך להשתמש גם בצורה המקוצרת ‎/d.

  • השימוש בפרמטר ‎/classify

    הפרמטר ‎/classify מציג פירוט עבור גודלה של כל תוכנית בסימון עשרוני והקסדצימאלי, מספק תקציר של שימוש בזיכרון ומפרט את בלוקי הזיכרון הזמינים הגדולים ביותר. לא ניתן להשתמש בפרמטר ‎/classify עם ‎/program או עם ‎/debug. עבור ‎/classify, באפשרותך להשתמש גם בצורה המקוצרת ‎/c.

  • הצגה של מצב זיכרון

    מערכת המשנה MS-DOS מציגה את מצב הזיכרון המורחב (זיכרון XMS) רק אם בוצעה הקצאת זיכרון של מעל מגה-בית אחד.

דוגמאות

בהנחה שמערכת המשנה MS-DOS מוגדרת עם זיכרון EMS, כדי להציג את המצב של הזיכרון הכולל של המערכת (רגיל, EMS‏, XMS) ולהציג רשימה של תוכניות שנטענו לזיכרון, הקלד את הפקודה שלהלן:

mem /program

התוצאות יתקבלו בתבנית דומה לתבנית שלהלן:

Address     Name          Size       Type

000000                   000400     Interrupt Vector
000400                   000100     ROM Communication Area
000500                   000200     DOS Communication Area

000700      IO           000310     System Data

000A10      MSDOS        0014D0     System Data

001EE0      IO           0018D0     System Data
                KBD      000800      System Program
                HIMEM    000420      DEVICE=
                         000340      FILES=
                         000090      FCBS=
                         000170      LASTDRIVE=
                         000710      STACKS=
0037C0      COMMAND      000A40     Program
004210      MSDOS        000070     - Free -
004290      COMMAND      0001F0     Environment
004490      MEM          0001D0     Environment
004670      MEM          017550     Program
01BBD0      MSDOS        084410     - Free -
09FFF0      SYSTEM       028000     System Program

0C8000      IO           0083D0     System Data
                MOUSE    0083C0      System Program
0D03E0      MSDOS        000050     - Free -
0D0440      REDIR        0009F0     Program
0D0E40      DOSX         007CA0     Program
0D8AF0      DOSX         001030     Data
0D9B30      MSDOS        0164C0     - Free -

    655360 bytes total conventional memory
    655360 bytes available to MS-DOS
    637296 largest executable program size

1048576 bytes total contiguous extended memory
         0 bytes available contiguous extended memory
    405504 bytes available XMS memory
           MS-DOS resident in High Memory Area

  • "Total conventional memory" הוא כמות הזיכרון הווירטואלי שהוקצתה למערכת המשנה MS-DOS עד ל- 640 קילו-בתים ראשונים.
  • "Available to MS-DOS" הוא כמות הזיכרון הרגיל שהוקצתה, כולל הזיכרון הדרוש עבור Cmd.exe.
  • "Largest executable program size" הוא הבלוק הרציף הגדול ביותר של זיכרון רגיל הזמין עבור תוכנית.
  • "Total EMS memory" (אינו מוצג בדוגמה לעיל) הוא הכמות של זיכרון EMS שהוגדרה עבור מערכת המשנה MS-DOS.
  • "Free EMS memory" (אינו מוצג בדוגמה לעיל) הוא כמות של זיכרון EMS הזמינה עבור תוכניות.
  • "Total contiguous extended memory" הוא כמות הזיכרון מעבר למגה-בית אחד.
  • "Available contiguous extended memory" הוא זיכרון XMS הזמין עבור הממשק Interrupt 15h. זיכרון זה אינו מנוהל על-ידי מנהל זיכרון XMS, כגון Himem.sys. מספר תוכניות ישנות יותר עושות שימוש בשיטת זיכרון XMS זו.
  • "Available XMS memory" הוא זיכרון המנוהל על-ידי מנהל זיכרון XMS, כגון Himem.sys, וזמין לתוכניות שיש להן אפשרות להשתמש בו.


Mkdir

יצירה של ספריה או של ספריית משנה.

תחביר

mkdir [Drive:]Path

md [Drive:]Path

פרמטרים

Drive:‎
ציון הכונן שברצונך ליצור בו את הספריה החדשה.
Path
נדרש. פרמטר זה מציין את השם ואת המיקום של הספריה החדשה. האורך המירבי של נתיב בודד נקבע לפי מערכת הקבצים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • כאשר הרחבות הפקודה זמינות (ברירת המחדל), באפשרותך להשתמש בפקודת mkdir יחידה כדי ליצור ספריות ביניים בנתיב שצוין. לקבלת מידע נוסף אודות הפיכת הרחבות פקודה לזמינות או לבלתי זמינות, ראה cmd בנושאים קרובים.

דוגמאות

ליצירת ספריה בשם Taxes עם ספריית משנה בשם Property, המכילה ספריית משנה בשם Current, הקלד:

mkdir \Taxes\Property\Current

שימוש בפקודה זו שקול לשימוש ברצף הפקודות שלהלן כאשר הרחבות פקודה אינן זמינות:

mkdir \Taxes
chdir \Taxes
mkdir Property
chdir Property
mkdir Current ‏XOX


Mmc

פתיחה של Microsoft Management Console ‏(MMC). באמצעות אפשרות שורת הפקודה mmc, באפשרותך לפתוח מסוף MMC מסוים, לפתוח את MMC במצב עריכה, או לציין פתיחה של MMC בגירסת 32 סיביות או 64 סיביות.

תחביר

mmc Path\filename.msc ‎[/a]‎ ‎[/64]‎ ‎[/32]‎

פרמטרים

Path\filename.msc
הפעלת MMC ופתיחת מסוף שנשמר. עליך לציין את הנתיב המלא ואת שם הקובץ עבור קובץ המסוף שנשמר. אם לא תציין קובץ מסוף, MMC יפתח מסוף חדש.
‎/a
פתיחת מסוף שנשמר, במצב עריכה. השתמש באפשרות זו לשם עריכת שינויים במסופים שנשמרו.
‎/64
הפעלה של גירסת 64 סיביות של MMC ‏(MMC64). השתמש באפשרות זו רק אם אתה עובד עם Windows XP 64-Bit Edition.
‎/32
הפעלה של גירסת 32 סיביות של MMC ‏(MMC32). בעת עבודה עם Windows XP 64-Bit Edition, באפשרותך להפעיל יישומי Snap-in של 32 סיביות לאחר הפעלת MMC באמצעות אפשרות שורת פקודה זו.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • שימוש באפשרות שורת הפקודה Path\filename.msc

    באפשרותך להשתמש במשתני סביבה ליצירת שורות פקודה או קיצורי דרך שאינם תלויים במיקום המפורש של קבצי המסוף. לדוגמה, אם הנתיב לקובץ מסוף נמצא בתיקיית המערכת (לדוגמה, mmc c:\winnt\system32\console_name.msc), באפשרותך להשתמש במחרוזת הנתונים הניתנת להרחבה ‎%systemroot%‎ לציון המיקום (mmc ‎%systemroot%‎‎\system32\console_name.msc). ייתכן שיהיה ברצונך להשתמש באפשרותך זו אם עליך להקצות משימות עבור משתמשים העובדים על מחשבים שונים בארגון שלך.

  • שימוש באפשרות שורת הפקודה ‎/a

    כאשר מסופים נפתחים עם אפשרות זו, הם נפתחים במצב עריכה, ללא תלות במצב שהוגדר כברירת מחדל עבורם. שימוש באפשרות זו אינו משנה את הגדרת ברירת המחדל עבור קבצים. אם לא תציין אפשרות זו, MMC פותח קבצי מסוף בהתאם להגדרות המצב המהוות ברירת מחדל עבורם.

  • לאחר פתיחה של MMC או של קובץ מסוף במצב עריכה, באפשרותך לפתוח כל מסוף קיים על-ידי לחיצה על פתיחה בתפריט קובץ.
  • באפשרותך להשתמש בשורת הפקודה כדי ליצור קיצורי דרך עבור פתיחה של MMC ושל מסופים שנשמרו. פקודה זו של שורת הפקודה פועלת עם הפקודה הפעלה בתפריט התחלה בכל חלון של שורת פקודה, בקיצורי דרך ובכל קובץ אצווה או תוכנית המבצעים קריאה לפקודה זו.


Mode

הצגת מצב מערכת, שינוי הגדרות מערכת, או קביעה מחודשת של תצורת יציאות או התקנים. בשימוש ללא פרמטרים, הפקודה mode מציגה את כל התכונות שבאפשרותך לשלוט בהן עבור המסוף ועבור התקני COM זמינים. מאחר שבאפשרותך להשתמש ב- mode לביצוע משימות רבות ושונות, התחביר שיש להשתמש בו לביצוע כל משימה שונה. לחץ על המשימה שברצונך לבצע.

לשם קביעת תצורה של יציאת תקשורת טורית

תחביר

mode com m[:]‎ ‎[baud=b]‎ ‎[parity=p]‎ ‎[data=d]‎ ‎[stop=s]‎ ‎[to={on|off}]‎ ‎[xon={on|off}]‎ ‎[odsr={on|off}]‎ ‎[octs={on|off}]‎ ‎[dtr={on|off|hs}]‎ ‎[rts={on|off|hs|tg}]‎ ‎[idsr={on|off}]‎

פרמטרים

com m[:]‎
ציון המספר של יציאת התקשורת האסינכרונית (COM).
baud=b
ציון קצב השידור, בסיביות לשניה. הרשימה שלהלן מציגה קיצורים חוקיים עבור b ועבור הקצב המשויך לו:
ערך | קצב
11 | 110 באוד
15 | 150 באוד
30 | 300 באוד
60 | 600 באוד
12 | 1200 באוד
24 | 2400 באוד
48 | 4800 באוד
96 | 9600 באוד
19 | 19,200 באוד
parity=p
ציון אופן השימוש שתעשה המערכת בסיבית זוגיות לשם איתור של שגיאות שידור. הרשימה שלהלן מציגה ערכים חוקיים עבור p. ערך ברירת המחדל הוא e. יש מחשבים שאינם תומכים בערכים m ו- s.
ערך | תיאור
n | ללא
e | זוגי (even)
o | אי-זוגי (odd)
m | סימון (mark)
s | רווח (space)
data=d
ציון של מספר סיביות הנתונים בתו. ערכים חוקיים עבור d הם בטווח 5 עד 8. ערך ברירת המחדל הוא 7. יש מחשבים שאינם תומכים בערכים 5 ו- 6.
stop=s
ציון מספר סיביות העצירה המגדירות סוף תו: 1, 1.5 או 2. אם קצב השידור הוא 110, ערך ברירת המחדל הוא 2; אם לא, ערך ברירת המחדל הוא 1. יש מחשבים שאינם תומכים בערך 1.5.
to={on|off}‎
השתמש בפרמטר זה כדי להפעיל או לבטל עיבוד אינסופי עבור זמן קצוב. כברירת מחדל, אפשרות זו אינה פעילה.
xon={on|off}‎
השתמש בפרמטר זה כדי להפעיל או לבטל את הפרוטוקול xon או את הפרוטוקול xoff עבור בקרה של זרימת נתונים.
odsr={on|off}‎
השתמש בפרמטר זה כדי להפעיל או לבטל את פרוטוקול לחיצת היד של הפלט העושה שימוש במעגל Data Set Ready ‏(DSR).
octs={on|off}‎
השתמש בפרמטר זה כדי להפעיל או לבטל את פרוטוקול לחיצת היד של הפלט העושה שימוש במעגל Clear To Send (‏CTS).
dtr={on|off|hs}‎
השתמש בפרמטר זה כדי להפעיל או לבטל את מעגל Data Terminal Ready ‏(DTR), או כדי להגדירו עבור לחיצת יד.
rts={on|off|hs|tg}‎
השתמש בפרמטר זה כדי להפעיל או לבטל את מעגל Request To Send (‏RTS), או כדי להגדירו עבור לחיצת יד או כדו-מצבי.
idsr={on|off}‎
השתמש בפרמטר זה כדי להפעיל או לבטל את הרגישות של מעגל DSR.
‎/?‎
הצגת עזרה בשורת הפקודה.

לשם הצגת המצב של כל ההתקנים או של התקן בודד

תחביר

mode [device] [/status]‎

פרמטרים

device
ציון השם של ההתקן שאת מצבו ברצונך להציג.
‎/status
בקשה של המצב עבור מדפסות מקביליות שעברו ניתוב מחדש. באפשרותך לקצר את אפשרות שורת הפקודה ‎/status ל- ‎/sta.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • ללא פרמטרים, הפקודה mode מציגה את המצב של כל ההתקנים שהותקנו במערכת.

לשם ניתוב מחדש של פלט מיציאה מקבילית ליציאת תקשורת טורית

תחביר

mode lpt n[:]=com m[:]‎

פרמטרים

lpt n
נדרש. ציון היציאה המקבילית. ערכים חוקיים עבור n נמצאים בטווח 1 עד 3.
com m [:]‎
נדרש. ציון היציאה הטורית. ערכים חוקיים עבור m נמצאים בטווח 1 עד 4.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • כדי לבצע ניתוב מחדש של הדפסה, עליך להיות חבר בקבוצה Administrators.

דוגמאות

כדי להגדיר את המערכת כך שתשלח פלט ממדפסת מקבילית למדפסת טורית, עליך להשתמש בפקודה mode פעמיים. בפעם הראשונה, השתמש ב- mode לקביעת תצורתה של היציאה הטורית. בפעם השנייה, השתמש ב- mode לניתוב מחדש של הפלט מהמדפסת המקבילית ליציאה הטורית שהגדרת בפקודה mode הראשונה.

לדוגמה, אם המדפסת הטורית פועלת בקצב של 4800 באוד עם זוגיות במצב זוגי (Even) ומחוברת ליציאה COM1 (החיבור הטורי הראשון במחשב), הקלד:

mode com1 48,e,,,b
mode lpt1=com1

אם ביצעת ניתוב מחדש של פלט מדפסת מקבילית מ- LPT1 ל- COM1 אך לאחר מכן החלטת כי ברצונך להדפיס קובץ באמצעות LPT1, השתמש בפקודה שלהלן לפני הדפסת הקובץ.

mode lpt1

פקודה זו מונעת ניתוב מחדש של הקובץ מ- LPT1 ל- COM1.

לשם בחירה, רענון או הצגה של מספרי הקידודים עבור המסוף

תחביר

mode device codepage select=yyy

mode device codepage [/status]‎

פרמטרים

device
נדרש. ציון ההתקן שברצונך לבחור קידוד עבורו. CON הוא השם החוקי היחיד עבור התקן.
codepage select=‎
נדרש. ציון הקידוד שברצונך להשתמש בו עם ההתקן שצוין. עבור codepage ועבור select באפשרותך להשתמש בצורות המקוצרות cp ו- sel, בהתאמה.
yyy
נדרש. ציון מספר הקידוד שיש לבחור. הרשימה הבאה מציגה כל קידוד הזוכה לתמיכה, ואת המדינה/אזור או השפה המשויכים לקידוד זה:
ערך | מדינה/אזור
437 | ארצות הברית
850 | רב לשוני (לטינית I)
852 | סלבית (לטינית II)
855 | קירילית (רוסית)
857 | תורכית
860 | פורטוגזית
861 | איסלנדית
863 | צרפתית-קנדית
865 | נורדית
866 | רוסית
869 | יוונית מודרנית
codepage
הצגה של מספרי הקידודים, אם קיימים, שנבחרו עבור ההתקן שצוין.
‎/status
הצגת המספרים עבור הקידודים הנוכחיים שנבחרו עבור ההתקן שצוין. באפשרותך להשתמש בקיצור ‎/sta עבור ‎/status. בין אם תציין את ‎/status ובין אם לאו, שימוש בפקודה mode codepage יביא להצגת מספרי הקידודים שנבחרו עבור ההתקן שצוין.
‎/?‎
הצגת עזרה בשורת הפקודה.

לשם שינוי גודל המאגר של חלון שורת הפקודה

תחביר

mode con[:] [cols=c] [lines=n]‎

פרמטרים

con[:]‎
נדרש. שימוש בפרמטר זה מציין כי יש לבצע את השינוי בחלון שורת הפקודה.
cols=c
ציון מספר התווים (טורים) לרוחב במאגר של מסך שורת הפקודה.
lines=n
ציון מספר השורות לעומק במאגר של מסך שורת הפקודה.
‎/?‎
הצגת עזרה בשורת הפקודה.

לשם הגדרת קצב החזרה של המקלדת

תחביר

mode con[:] [rate=r delay=d]‎

פרמטרים

con[:]‎
נדרש. פרמטר זה מתייחס למקלדת.
rate=r
ציון של קצב חזרה על תו בעת לחיצה רציפה על המקש של תו זה.
delay=d
ציון אורכה של לחיצה רציפה על אותו מקש עד שהתו המשויך למקש יתחיל לחזור.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • קצב החזרה הוא הקצב שבו תו חוזר על עצמו כאשר המקש של תו זה נותר לחוץ. קצב החזרה כולל שני מרכיבים: קצב והשהיה. לוחות מקשים מסוימים אינם מזהים פקודה זו.
  • שימוש באפשרות rate=r

    ערכים חוקיים נמצאים בטווח 1 עד 32. ערכים אלה קרובים ל- 2 עד 30 תווים לשניה, בהתאמה. ערך ברירת המחדל הוא 20 עבור לוחות מקשים תואמי IBM AT ו- 21 עבור לוחות מקשים תואמי IBM PS/2. בעת הגדרת הקצב יש להגדיר גם את ההשהיה.

  • delay=d

    ערכים חוקיים עבור d הם 1, 2, 3 ו- 4 (המייצגים רבע שניה, חצי שניה, שלושת רבעי השניה ושניה, בהתאמה). ערך ברירת המחדל הוא 2. בעת הגדרת ההשהיה יש להגדיר גם את הקצב.


More

תצוגה של מסך פלט אחד בכל פעם.

תחביר

command | more [/c] [/p] [/s] [/t n] [+n]‎

more [[/c] [/p] [/s] [/t n] [+n]] < [Drive:] [Path] FileName

more [/c] [/p] [/s] [/t n] [+n] [files]‎

פרמטרים

‎[Drive:] [Path] FileName
ציון הקובץ שיש להציג.
command
ציון הפקודה שאת הפלט שלה שרצונך להציג.
‎/c
ניקוי המסך לפני הצגת עמוד.
‎/p
הרחבה של תווי הזנת דפים.
‎/s
החלפת מספר שורות ריקות בשורה ריקה אחת.
‎/t n
שינוי הטאבים למספר הרווחים שצוין באמצעות n.
‎+n
הצגת הקובץ הראשון הנפתח בשורה שצוינה באמצעות n.
files
ציון רשימת הקבצים שיש להציג. את שמות הקבצים יש להפריד באמצעות רווח.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • שימוש בפקודה more במסוף השחזור

    הפקודה more, עם פרמטרים אחרים, זמינה במסוף השחזור.

  • שימוש בפקודות המשנה של more

    הפקודות שלהלן קבילות בשורת הפקודה של more ‏(-- More --).

    מקש | פעולה
    רווח | הצגת הדף הבא.
    ENTER | הצגת השורה הבאה.
    f | הצגת הקובץ הבא.
    q | יציאה.
    ? הצגת הפקודות הזמינות.
    = הצגת של מספר השורה.
    p n | הצגת n השורות הבאות.
    s n | דילוג על n השורות הבאות.
  • מקורות נתונים

    בעת שימוש בתו הניתוב מחדש (‎<‎) עליך לציין שם קובץ שישמש כמקור. בעת שימוש בתו Pipe (|) באפשרותך להשתמש בפקודות כגון dir,‏ sort ו- type.

דוגמאות

אם ברצונך להציג על המסך קובץ הנקרא Clients.new, הקלד אחת משתי הפקודות שלהלן:

more < clients.new

type clients.new | more

הפקודה more מציגה את מסך המידע הראשון מתוך Clients.new, ולאחר מכן מציגה את השורה הבאה:

-- More --

לאחר מכן באפשרותך להקיש על מקש הרווח כדי להציג את מסך המידע הבא.

כדי לנקות את המסך ולהסיר את כל השורות הריקות המיותרות לפני הצגת הקובץ Clients.new, הקלד אחת משתי הפקודות שלהלן:

more /c /s < clients.new

type clients.new | more /c /s

הפקודה more מציגה את מסך המידע הראשון מתוך Clients.new, ולאחר מכן מציגה את השורה הבאה:

-- More --

כדי להציג את הקובץ שורה אחר שורה, הקש ENTER.

כדי להציג את הדף הבא, הקש על מקש הרווח.

כדי להציג את הקובץ הבא שצוין בפקודה, הקש f.

ליציאה מהתוכנית more, הקש q.

הוסף פקודות לשורה more כפי שמוצג בדוגמה הבאה:

‎-- More [Options: psfq=<space><ret>] --‎

כדי להציג את מספר השורה הנוכחי, הקלד =. מספר השורה הנוכחי נוסף לשורת הפקודה More, כמוצג בדוגמה שלהלן:

‎-- More [Line: 24] --‎

כדי להציג מספר שורות מסוים, הקלד p. התוכנית More תציג בפניך בקשה עבור מספר השורות שיש להציג.

‎-- More -- Lines:‎

הקלד את מספר השורות שיש להציג והקש ENTER. התוכנית More תציג את מספר השורות המבוקש.

כדי לדלג על מספר שורות מסוים, הקלד s. התוכנית More תציג בפניך בקשה עבור מספר השורות שעליהן יש לדלג:

‎-- More -- Lines:‎

הקלד את מספר השורות שיש לדלג עליהן ולאחר מכן הקש ENTER. התוכנית More תדלג על מספר השורות שצוין ותציג את מסך המידע הבא.


Mountvol

יצירה, מחיקה או פירוט של נקודות לטעינת אמצעי אחסון. באמצעות Mountvol ניתן לקשר אמצעי אחסון ללא שימוש באות כונן.

תחביר

mountvol [Drive:]Path VolumeName

mountvol [Drive:]Path /d

mountvol [Drive:]Path /L

mountvol Drive: /s

פרמטרים

‎[Drive:]Path
ציון תיקיה קיימת של ספריית NTFS שיש למקם בה את נקודת הטעינה.
VolumeName
ציון שם אמצעי האחסון המהווה יעד עבור נקודת הטעינה. יש להזין את שם אמצעי האחסון בתבנית ‎\\?\Volume{GUID}\‎, כאשר ‎{GUID}‎ הוא מזהה ייחודי כללי (GUID) (לדוגמה, ‎\\?\Volume\{2eca078d-5cbc-43d3-aff8-7e8511f60d0e}\‎).
‎/d
הסרת נקודת הטעינה של אמצעי אחסון מתיקיה שצוינה.
‎/L
פירוט שם אמצעי האחסון הנטען עבור התיקיה שצוינה.
‎/s
מחשבים מבוססי Itanium בלבד. טעינה של מחיצת מערכת EFI בכונן שצוין.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • אם לא נותרו אותיות כונן לשימוש, טען את אמצעי האחסון המקומיים ללא אותיות כונן.
  • אם עליך להרחיב את שטחו של אמצעי אחסון ללא אתחול מחדש של כונן קשיח וללא החלפתו, באפשרותך להוסיף נתיב טעינה אל אמצעי אחסון אחר.
  • היתרון שבפעולה זו הוא, שאם תשתמש באמצעי אחסון אחד עם מספר נתיבי טעינה יהיה באפשרותך לבצע גישה לכל אמצעי האחסון המקומיים באמצעות אות כונן אחת (כגון C:‎). לא יהיה עליך לזכור איזה אמצעי אחסון תואם לאיזו אות כונן, אף-על-פי שבאפשרותך לטעון אמצעי אחסון מקומיים ועדיין לשמור על הקצאתם לאותיות כונן.


Move

העברה של קובץ או של מספר קבצים מספריה אחת לספריה שצוינה.

תחביר

move [{/y|/-y}] [Source] [target]‎

פרמטרים

‎/y
שימוש בפרמטר זה מונע את הצגת הבקשה שמטרתה לוודא אם ברצונך להחליף קובץ יעד קיים.
‎/-y
שימוש בפרמטר זה מביא להצגת הבקשה שמטרתה לוודא אם ברצונך להחליף קובץ יעד קיים.
Source
ציון שם ונתיב עבור הקובץ או הקבצים שברצונך להעביר. אם ברצונך להעביר ספריה או לשנות את שמה, על הפרמטר Source להכיל את הנתיב ואת השם של הספריה הנוכחית.
target
ציון הנתיב והשם עבור המיקום שאליו יועברו הקבצים. אם ברצונך להעביר ספריה או לשנות את שמה, על הפרמטר target להכיל את הנתיב ואת השם של ספריית היעד.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • שימוש באפשרות שורת הפקודה ‎/y

    אפשרות שורת הפקודה ‎/y עשויה להיקבע מראש במשתנה הסביבה COPYCMD. באפשרותך לעקוף הגדרה זו על-ידי שימוש בבורר ‎/-y בשורת הפקודה. ברירת המחדל היא להציג בפני המשתמש בקשה לאישור ההחלפה, אלא אם הפקודה copy מבוצעת מתוך קובץ Script של אצווה.

  • העברת קבצים מקודדים

    העברת קבצים מקודדים לאמצעי אחסון שאינו תומך במערכת קבצים מוצפנים (EFS) תביא לשגיאה. תחילה פענח את הקבצים או העבר אותם לאמצעי אחסון התומך ב- EFS.

דוגמאות

כדי להעביר את כל הקבצים בעלי סיומת ‎.xls מן הספריה ‎\Data לספריה ‎\Second_Q\Reports, הקלד:

move \data\*.xls \second_q\reports\‎


Msiexec

מתן האמצעים להתקנה, לשינוי ולביצוע פעולות ב- Windows Installer משורת הפקודה.

לשם התקנה או קביעת תצורה של מוצר

תחביר

msiexec /i {package|ProductCode}‎

פרמטרים

‎/i
התקנה או קביעת התצורה של מוצר.
package
ציון שם קובץ החבילה של Windows Installer.
ProductCode
ציון המזהה הייחודי הכללי (GUID) של חבילת Windows Installer.

הערות

  • אפשרויות שורת הפקודה של Windows Installer אינן תלויות רישיות.
  • לקבלת מידע נוסף אודות אפשרויות שורת הפקודה של Windows Installer, ראה נושאים קרובים.

דוגמאות

להתקנת מוצר מתוך A:\Example.msi, הקלד:

msiexec /i A:\Example.msi

לשם שימוש באפשרות ההתקנה הניהולית

תחביר

msiexec /a package

פרמטרים

‎/a
החלה של אפשרות ההתקנה הניהולית.
package
שם קובץ החבילה של Windows Installer.

הערות

  • אפשרויות שורת הפקודה של Windows Installer אינן תלויות רישיות.
  • לקבלת מידע נוסף אודות אפשרויות שורת הפקודה של Windows Installer, ראה נושאים קרובים.

לשם תיקון מוצר

תחביר

msiexec /f [p][o][e][d][c][a][u][m][s][v]{package|ProductCode}‎

פרמטרים

‎/f
הפעלת אחת או יותר מאפשרויות שורת הפקודה המפורטות בטבלה הבאה.
פקודה | תיאור
p | התקנה מחדש רק אם הקובץ חסר.
o | התקנה מחדש אם הקובץ חסר או אם מותקנת גירסה מוקדמת יותר.
e | התקנה מחדש אם הקובץ חסר או אם מותקנת גירסה זהה או מוקדמת יותר.
d | התקנה מחדש אם הקובץ חסר או אם מותקנת גירסה שונה.
c | התקנה מחדש אם הקובץ חסר או אם בדיקת הסיכום שאוחסנה אינה תואמת את הערך המחושב.
a | כפיה של התקנה מחדש עבור כל הקבצים.
u | כתיבה מחדש של כל ערכי הרישום הדרושים והייחודיים למשתמש.
m | כתיבה מחדש של כל ערכי הרישום הדרושים והייחודיים למחשב.
s | החלפת כל קיצורי הדרך הקיימים.
v | הפעלה ממקור ואחסון מחדש במטמון של החבילה המקומית.
package
שם של קובץ החבילה של Windows Installer.
ProductCode
מזהה ייחודי כללי (GUID) של חבילת Windows Installer.

הערות

  • אפשרות זו מתעלמת מכל ערכי המאפיינים שתקליד בשורת הפקודה.
  • הפרמטר המשמש כברירת מחדל עבור אפשרות זו של שורת הפקודה הוא ‎/fpecms.
  • אפשרויות שורת הפקודה של Windows Installer אינן תלויות רישיות.
  • לקבלת מידע נוסף אודות אפשרויות שורת הפקודה של Windows Installer, ראה נושאים קרובים.

דוגמאות

לתיקון חבילת ההתקנה, הקלד:

msiexec /fpecms Example.msi

לשם הסרת מוצר

תחביר

msiexec /x {package|ProductCode}‎

פרמטרים

‎/x
ביטול של התקנת מוצר (הסרה).
package
שם קובץ חבילה של Windows Installer.
ProductCode
מזהה ייחודי כללי (GUID) של חבילת Windows Installer.

הערות

  • אפשרויות שורת הפקודה של Windows Installer אינן תלויות רישיות.
  • לקבלת מידע נוסף אודות אפשרויות שורת הפקודה של Windows Installer, ראה נושאים קרובים.

דוגמאות

להסרה או ביטול התקנה של חבילה, הקלד:

msiexec /x Example.msi

לשם פרסום מוצר

תחביר

msiexec /j [{u|m}] package

msiexec {u|m} package /t TransformList

msiexec {u|m} package /g LanguageID

פרמטרים

‎/j
פרסום מוצר.
u
פרסום למשתמש הנוכחי.
m
פרסום לכל המשתמשים במחשב.
package
ציון קובץ החבילה של Windows Installer.
‎/g LanguageID
זיהוי השפה.
‎/t TransformList
החלת שינוי על חבילה שפורסמה.

הערות

  • אפשרות זו מתעלמת מכל ערכי המאפיינים שתקליד בשורת הפקודה.
  • אם ברצונך להתקין את היישום עם הרשאות מוגברות, השתמש באפשרות ‎/jm.
  • אפשרויות שורת הפקודה של Windows Installer אינן תלויות רישיות.
  • לקבלת מידע נוסף אודות אפשרויות שורת הפקודה של Windows Installer, ראה נושאים קרובים.

דוגמאות

לפרסום חבילה לכל המשתמשים במחשב זה, הקלד:

msiexec /jm Example.msi

לפרסום חבילה לכל המשתמשים במחשב זה, הקלד:

msiexec /jm Example.msi

לשם הגדרה של רמת הרישום ביומן

תחביר

msiexec /L [i][w][e][a][r][u][c][m][p][v][+][!]LogFile.txt

פרמטרים

‎/L
קביעת הנתיב אל קובץ יומן הרישום.
i
רישום הודעות מצב.
w
רישום אזהרות שאינן חמורות.
e
רישום של כל הודעות השגיאות.
a
רישום הפעלה של פעולות.
r
רישום רשומות ייחודיות לפעולה.
u
רישום בקשות משתמש.
c
רישום פרמטרים ראשוניים של ממשק משתמש.
m
רישום הודעות של מחסור בזיכרון.
p
רישום מאפייני מסוף.
v
רישום פלט מפורט. לשימוש ב- v, ציין ‎/L*v.
+
צירוף לקובץ קיים.
!
ריקון כל שורה ליומן הרישום.
*
רישום כל המידע פרט לאפשרות v. זהו תו כללי.
LogFile.txt
שם ונתיב של קובץ טקסט של רישום.

הערות

  • אפשרויות שורת הפקודה של Windows Installer אינן תלויות רישיות.
  • כדי לכלול את האפשרות v בקובץ יומן רישום באמצעות דגל של תו כללי, הקלד ‎/L*v בשורת הפקודה.
  • ניתן להשתמש באפשרויות של קובץ יומן רישום של Windows Installer גם בתהליכים של הסרת התקנה ותיקון.
  • לקבלת מידע נוסף אודות אפשרויות שורת הפקודה של Windows Installer, ראה נושאים קרובים.

דוגמאות

להתקנת חבילה וליצירת קובץ יומן רישום המכיל מידע אודות מצב, זיכרון שאזל והודעות שגיאה, הקלד:

msiexec /i Example.msi /Lime logfile.txt

לשם החלת קובץ תיקון

תחביר

msiexec /p PatchPackage

פרמטרים

‎/p
החלת קובץ תיקון.
PatchPackage
תיקון מסוים.

הערות

  • להחלת תיקון על חבילת התקנה ניהולית, השתמש בתחביר הבא:

    msiexec /p PatchPackage /a Example.msi

  • אפשרויות שורת הפקודה של Windows Installer אינן תלויות רישיות.
  • לקבלת מידע נוסף אודות אפשרויות שורת הפקודה של Windows Installer, ראה נושאים קרובים.

לשם התקנת קבצי שינוי (Transform) באמצעות שורת הפקודה

תחביר

msiexec /i package TRANSFORMS=TransformList

פרמטרים

‎/i
התקנה או קביעת התצורה של מוצר.
package
ציון קובץ החבילה של Windows Installer.
TRANSFORMS=‎
מאפיין המשמש כדי לציין את קבצי השינוי (‎.mst) שיש להחיל על החבילה.
TransformList
רשימת נתיבים המופרדים באמצעות נקודה-פסיק.

הערות

  • אפשרויות שורת הפקודה של Windows Installer אינן תלויות רישיות.
  • לקבלת מידע נוסף אודות אפשרויות שורת הפקודה של Windows Installer, ראה נושאים קרובים.

לשם התקנה ופרסום של מוצר באמצעות קובץ שינוי בשורת הפקודה

תחביר

msiexec /i package /j[u][m] /t TransformList

פרמטרים

‎/i
התקנה או קביעת התצורה של מוצר.
package
שם קובץ החבילה של Windows Installer.
‎/j
פרסום מוצר. אפשרות זו מתעלמת מכל ערכי המאפיינים שהוזנו בשורת הפקודה.
u
פרסום למשתמש הנוכחי.
m
פרסום לכל המשתמשים במחשב זה.
‎/t
החלת שינוי על חבילה שפורסמה.
TransformList
רשימת נתיבים המופרדים באמצעות נקודה-פסיק.

הערות

  • אפשרויות שורת הפקודה של Windows Installer אינן תלויות רישיות.
  • לקבלת מידע נוסף אודות אפשרויות שורת הפקודה של Windows Installer, ראה נושאים קרובים.

לשם הגדרה של רמת ממשק המשתמש

תחביר

msiexec /q{n|b|r|f|n+|b+|b-}‎

פרמטרים

‎/qn
ללא הצגה של ממשק משתמש.
‎/qb
הצגת ממשק משתמש בסיסי.
‎/qr
הצגת ממשק משתמש מצומצם עם תיבת דו-שיח מודאלית המוצגת בסוף ההתקנה.
‎/qf
הצגת ממשק משתמש מלא עם תיבת דו-שיח מודאלית המוצגת בסוף ההתקנה.
‎/qn+‎
ללא הצגה של ממשק משתמש מלבד תיבת דו-שיח מודאלית המוצגת בסוף ההתקנה.
‎/qb+‎
הצגת ממשק משתמש בסיסי עם תיבת דו-שיח מודאלית המוצגת בסוף ההתקנה.
‎/qb-‎
הצגת ממשק משתמש בסיסי ללא תיבות דו-שיח מודאליות.

הערות

  • ‎/qb+-‎ אינו רמה הזוכה לתמיכה עבור ממשק משתמש. התיבה המודאלית אינה מוצגת אם המשתמש מבטל את ההתקנה.
  • אפשרויות שורת הפקודה של Windows Installer אינן תלויות רישיות.
  • לקבלת מידע נוסף אודות אפשרויות שורת הפקודה של Windows Installer, ראה נושאים קרובים.

דוגמאות

להצגת אפשרויות ממשק משתמש בסיסיות במהלך התקנת החבילה של Example.msi, הקלד:

msiexec /qb Example.msi

לשם הצגה של מידע זכויות יוצרים עבור Windows Installer

תחביר

msiexec {/?|/h}‎

פרמטרים

‎{/?|/h}‎
הצגה של גירסת Windows Installer ושל מידע זכויות יוצרים.

הערות

  • אפשרויות שורת הפקודה של Windows Installer אינן תלויות רישיות.
  • לקבלת מידע נוסף אודות אפשרויות שורת הפקודה של Windows Installer, ראה נושאים קרובים.

לשם ביצוע קריאה ל- API הנקרא DllRegisterServer של המערכת עבור רישום עצמאי של מודולים שהועברו בשורת הפקודה

תחביר

msiexec /y module

פרמטרים

‎/y
קריאה לממשק תכנות היישומים (API) הנקרא DllRegisterServer של המערכת לשם ביצוע של רישום עצמאי עבור המודולים שהועברו בשורת הפקודה.
module
ציון שם הקובץ של מודול.

הערות

  • באפשרות זו נעשה שימוש אך ורק עבור מידע רישום שלא ניתן להוסיף באמצעות טבלאות הרישום של קובץ ‎.msi.
  • אפשרויות שורת הפקודה של Windows Installer אינן תלויות רישיות.
  • לקבלת מידע נוסף אודות אפשרויות שורת הפקודה של Windows Installer, ראה נושאים קרובים.

דוגמאות

הדוגמה הבאה מראה את אופן השימוש בפקודה msiexec /y:

msiexec /y my_file.dll

לשם ביצוע קריאה ל- API הנקרא DllUnRegisterServer של המערכת עבור ביטול הרישום של מודולים שהועברו בשורת הפקודה

תחביר

msiexec /z module

פרמטרים

‎/z
קריאה לממשק תכנות היישומים (API) הנקרא DllUnRegisterServer של המערכת לשם ביטול רישום של מודולים שהועברו בשורת הפקודה.
module
שם קובץ של מודול.

הערות

  • באפשרות זו נעשה שימוש אך ורק עבור מידע רישום שלא ניתן להוסיף באמצעות טבלאות הרישום של קובץ ‎.msi.
  • אפשרויות שורת הפקודה של Windows Installer אינן תלויות רישיות.
  • לקבלת מידע נוסף אודות אפשרויות שורת הפקודה של Windows Installer, ראה נושאים קרובים.

דוגמאות

הדוגמה הבאה מראה את אופן השימוש בפקודה msiexec /z:

msiexec /z my_file.dll


Msinfo32

הצגת מציג מבט מקיף על החומרה, על רכיבי המערכת ועל סביבת התוכנה.

תחביר

msinfo32 [/?] [/pch] [/nfo FileName] [/report FileName] [/computer ComputerName] [/showcategories] [/category categoryID]‎ ‎[/categories categoryID]‎

פרמטרים

FileName
ציון הקובץ שיש לפתוח. קובץ זה עשוי להיות קובץ מסוג ‎.nfo‏, ‎.xml‏, ‎.txt או ‎.cab
‎/?‎
הצגת עזרה עבור הפקודה msinfo32.
‎/pch
הצגה של תצוגת היסטוריה.
‎/nfo FileName
שמירת הקובץ המיוצא כקובץ ‎.nfo
‎/report FileName
שמירת הקובץ המיוצא כקובץ ‎.txt
‎/computer ComputerName
הפעלת היישום מידע מערכת עבור המחשב המרוחק שצוין.
‎/showcategories
הפעלת היישום מידע מערכת עם הצגה של כל מזהי הקטגוריות הזמינים.
‎/category categoryID
הפעלת היישום מידע מערכת עם בחירה של הקטגוריה שצוינה. השתמש ב- ‎/showcategories להצגת רשימה של מזהי קטגוריות זמינים.
‎/categories categoryID
הפעלת היישום מידע מערכת עם הצגה של הקטגוריה או הקטגוריות שצוינו בלבד. אפשרות זו גם מגבילה את הפלט לקטגוריה או הקטגוריות שנבחרו. השתמש ב- ‎/showcategories להצגת רשימה של מזהי קטגוריות זמינים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • חלק מן הקטגוריות של היישום מידע מערכת מכילות כמויות נתונים גדולות. באפשרותך להשתמש בפקודה start /wait כדי למטב את ביצועי הדיווח עבור קטגוריות אלה. לקבלת מידע נוסף, ראה נושאים קרובים.

דוגמאות

להצגת פירוט של מזהי הקטגוריות הזמינים, הקלד:

msinfo32 /showcategories

להפעלת היישום מידע מערכת עם הצגה של כל המידע הזמין, פרט למודולים טעונים, הקלד:

msinfo32 /categories +all -loadedmodules

להצגה של מידע System Summary (תקציר מערכת) בלבד וליצירת קובץ ‎.nfo בשם syssum.nfo המכיל את המידע שבקטגוריה זו, הקלד:

msinfo32 /nfo syssum.nfo /categories +systemsummary

להצגת מידע התנגשות משאבים וליצירת קובץ ‎.nfo בשם conflicts.nfo המכיל מידע אודות התנגשויות משאבים, הקלד:

msinfo32 /nfo conflicts.nfo /categories +componentsproblemdevices+resourcesconflicts+resourcesforcedhardware


Nbtstat

הצגת סטטיסטיקה של NetBIOS באמצעות TCP/IP ‏(NetBT), טבלאות שמות NetBIOS עבור המחשב המקומי והמחשבים המרוחקים ומטמון השמות של NetBIOS. הפקודה Nbtstat מאפשרת לבצע רענון של מטמון השמות של NetBIOS ושל השמות הרשומים באמצעות Windows Internet Name Service ‏(WINS). ללא פרמטרים, הפקודה nbtstat מציגה עזרה.

תחביר

nbtstat ‎[-a RemoteName]‎ ‎[-A IPAddress]‎ ‎[-c]‎ ‎[-n]‎ ‎[-r]‎ ‎[-R]‎ ‎[-RR]‎ ‎[-s]‎ ‎[-S]‎ ‎[Interval]‎

פרמטרים

‎-a RemoteName
הצגת טבלת שמות NetBIOS של מחשב מרוחק, כאשר RemoteName הוא שם NetBIOS של המחשב המרוחק. טבלת השמות של NetBIOS היא רשימה של שמות NetBIOS התואמים ליישומי NetBIOS הפועלים במחשב זה.
‎-A IPAddress
הצגת טבלת שמות NetBIOS של מחשב מרוחק, שיש לציין באמצעות כתובת IP (בסימון דצימאלי מנוקד) של המחשב המרוחק.
‎-c
הצגת התוכן של מטמון שמות NetBIOS, של טבלת שמות NetBIOS ושל כתובות ה- IP המשוייכות אליהם.
‎-n
הצגת טבלת שמות NetBIOS של המחשב המקומי. המצב Registered מציין שהשם נרשם באמצעות שידור או באמצעות שרת WINS.
‎-r
הצגת סטטיסטיקה של זיהוי שמות NetBIOS. במחשב Windows XP שתצורתו נקבעה לשימוש ב- WINS, פרמטר זה מחזיר את מספר השמות שזוהו ונרשמו באמצעות שידור ובאמצעות WINS.
‎-R
מחיקת תוכנו של מטמון שמות NetBIOS ולאחר מכן טעינה מחדש של ערכים מתוייגי ‎#PRE מתוך הקובץ Lmhosts.
‎-RR
שחרור ולאחר מכן רענון של שמות NetBIOS עבור המחשב המקומי הרשום עם שרתי WINS.
‎-s
הצגה של הפעלות לקוח ושל הפעלות שרת של NetBIOS, בניסיון להמיר את כתובת ה- IP של היעד לשם.
‎-S
הצגה של הפעלות לקוח ושל הפעלות שרת של NetBIOS, עם פירוט המחשבים המרוחקים לפי כתובות IP בלבד.
Interval
הצגה חוזרת של הסטטיסטיקה שנבחרה, בהשהיה של Interval שניות בין כל תצוגה. הקש CTRL+C להפסקת ההצגה החוזרת של סטטיסטיקה. אם לא תשתמש בפרמטר זה, הפקודה nbtstat תדפיס את מידע התצורה הנוכחי פעם אחת בלבד.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פרמטרים של שורת הפקודה עבור Nbtstat הם תלויי רישיות.
  • הטבלה הבאה מתארת את כותרות העמודות הנוצרות באמצעות nbtstat.
    כותרת | תיאור
    Input | מספר הבתים שהתקבלו.
    Output | מספר הבתים שנשלחו.
    In/Out | האם ההתקשרות מתבצעת מהמחשב (התקשרות יוצאת, Outbound) או ממחשב אחר למחשב המקומי (התקשרות נכנסת, Inbound).
    Life | הזמן שנותר עד להסרת ערך מטמון של טבלת השמות.
    Local Name | שם ה- NetBIOS המקומי המשויך להתקשרות.
    Remote Host | שם או כתובת IP המשויכים למחשב המרוחק.
    <03> | הבית האחרון של שם NetBIOS שהומר לערך הקסדצימאלי. כל שם NetBIOS הוא בן 16 תווים. לבית האחרון חשיבות מיוחדת, מפני ששמות זהים-לכאורה עשויים להופיע במחשב כמה פעמים, כשהם נבדלים זה מזה בבית האחרון בלבד. לדוגמה, <20> הוא רווח בטקסט ASCII.
    Type | סוג השם. שם עשוי להיות שם ייחודי או שם קבוצה.
    Status | האם פועל שירות NetBIOS במחשב המרוחק (Registered) או ששם מחשב זהה ביצע רישום של אותו שירות (Conflict).
    State | מצב של התקשרויות NetBIOS.
  • הטבלה הבאה מתארת מצבי חיבור אפשריים של NetBIOS.
    מצב | תיאור
    Connected | ההפעלה נוצרה.
    Associated | נקודת קצה של התקשרות נוצרה ושויכה לכתובת IP.
    Listening | נקודת קצה זו זמינה עבור התקשרות נכנסת.
    Idle | נקודת קצה זו נפתחה אך אין לה אפשרות לקבל התקשרויות.
    Connecting | ההפעלה נמצאת בשלב ההתחברות, שבו מפוענח המיפוי של שם לכתובת IP עבור היעד.
    Accepting | הפעלה נכנסת מתקבלת כעת ותקושר במהרה.
    Reconnecting | הפעלה מבצעת ניסיון להתקשרות מחדש (נסיון ההתקשרות הראשון נכשל).
    Outbound | הפעלה נמצאת בשלב ההתקשרות, שבו נוצרת כעת התקשרות TCP.
    Inbound | הפעלה נכנסת נמצאת בשלב ההתקשרות.
    Disconnecting | הפעלה נמצאת בתהליך התנתקות.
    Disconnected | המחשב המקומי הנפיק הוראת ניתוק וממתין לאישור מהמערכת המרוחקת.
  • פקודה זו זמינה רק אם פרוטוקול Internet Protocol ‏(TCP/IP) הותקן כרכיב במאפייני מתאם הרשת בחיבורי רשת.

דוגמאות

להצגת טבלת השמות של NetBIOS עבור המחשב המרוחק עם שם מחשב NetBIOS שהוא CORP07, הקלד:

nbtstat -a CORP07

להצגת טבלת שמות NetBIOS עבור המחשב המרוחק שהוקצתה עבורו כתובת ה- IP ‏10.0.0.99, הקלד:

nbtstat -A 10.0.0.99

להצגת טבלת שמות NetBIOS של המחשב המקומי, הקלד:

nbtstat -n

להצגת התוכן של מטמון שמות NetBIOS של המחשב המקומי, הקלד:

nbtstat -c

למחיקה של מטמון שמות NetBIOS וטעינה מחדש של ערכים מתוייגי ‎#PRE בקובץ Lmhosts המקומי, הקלד:

nbtstat -R

לשחרור שמות NetBIOS שנרשמו באמצעות שרת WINS ולרישומם מחדש, הקלד:

nbtstat -RR

להצגת סטטיסטיקה של הפעלת NetBIOS באמצעות כתובת IP כל חמש שניות, הקלד:

nbtstat -S 5


Net accounts

עדכון מסדי הנתונים של חשבונות משתמש ושינוי של סיסמאות ושל דרישות כניסה עבור כל החשבונות.

תחביר

net accounts ‎[/forcelogoff:{minutes | no}]‎ ‎[/minpwlen:length]‎ ‎[/maxpwage:{days | unlimited}]‎ ‎[/minpwage:days]‎ ‎[/uniquepw:number]‎ ‎[/domain]‎

פרמטרים

‎/forcelogoff:{minutes | no}‎
הגדרת מספר הדקות שיש להמתין לפני סיום ההפעלה של משתמש בשרת לאחר שפג תוקף חשבון המשתמש או זמן הכניסה החוקי שלו. הערך ברירת המחדל, no, מונע ניתוק כפוי של משתמשים.
‎/minpwlen:length
הגדרת מספר תווים מזערי עבור סיסמה של חשבון משתמש. הטווח הוא בין 0 ל- 127 תווים וברירת המחדל היא שישה תווים.
‎/maxpwage:{days | unlimited}‎
הגדרת מספר הימים המירבי עבור תוקף הסיסמה של חשבון משתמש. הערך unlimited אינו מגדיר זמן מירבי. על הערך המוזן עבור אפשרות שורת הפקודה ‎/maxpwage להיות גדול מן הערך עבור האפשרות ‎/minpwage. הטווח הוא בין 1 ל- 49,710 יום (כלומר, unlimited שווה ל- 49,710 יום), הערך המוגדר כברירת מחדל הוא 90 יום.
‎/minpwage:days
הגדרת מספר הימים המינימלי לפני שתהיה למשתמש אפשרות לשנות סיסמה חדשה. הערך המוגדר כברירת מחדל הוא אפס ימים, שאינו קובע זמן מינימלי. הטווח הוא 0 עד 49,710.
‎/uniquepw:number
המשתמש נדרש שלא לחזור על אותה סיסמה אלא אם כבר החליף number סיסמאות מאז שעשה שימוש בסיסמה זו. הטווח הוא 0 עד 24 שינויי סיסמה, וברירת המחדל היא חמישה שינויי סיסמה .
‎/domain
ביצוע הפעולה בבקר קבוצת המחשבים הראשי של קבוצת המחשבים הנוכחית. אם אפשרות זו לא תצוין, הפעולה תתבצע במחשב המקומי.
net help command
הצגת עזרה עבור פקודת net שצוינה.

הערות

  • יש להפעיל את שירות כניסה לרשת (Net Logon) במחשב שעבורו ברצונך לשנות פרמטרים של חשבונות. הקלד net accounts ללא פרמטרים לשם הצגת ההגדרות הנוכחיות עבור סיסמה, עבור הגבלות כניסה ועבור מידע אודות קבוצת המחשבים.
  • עליך לבצע את הפעולות הבאות לפני שיהיה באפשרותך להשתמש ב- net accounts:
    • צור חשבונות משתמש. השתמש במנהל המשתמשים או בפקודה net user כדי להגדיר חשבונות משתמש.
    • הפעל את שירות כניסה לרשת בכל השרתים המוודאים כניסה בקבוצת המחשבים. השירות מופעל באופן אוטומטי בעת ההפעלה.
  • בעת שימוש ב- ‎/forcelogoff:minutes, נשלחת אל המשתמשים אזהרה מספר דקות לפני שהם נאלצים להתנתק מהרשת. כמו כן המשתמשים מקבלים דיווח אודות קבצים שנותרו פתוחים. אם ערך minutes קטן משתיים, מועברת למשתמשים אזהרה הקוראת להם להתנתק מהרשת באופן מיידי.

דוגמאות

לשם הצגת ההגדרות הנוכחיות, דרישות הסיסמה ותפקיד השרת עבור שרת, הקלד:

net accounts

כדי להגדיר מינימום של שבעה תווים עבור סיסמאות של חשבון משתמש, הקלד:

net accounts /minpwlen:7

כדי לציין שמשתמשים יכולים להשתמש שוב בסיסמה כלשהי רק לאחר חמש החלפות סיסמה, הקלד:

net accounts /uniquepw:5

כדי למנוע ממשתמשים להחליף סיסמאות בתדירות העולה על פעם בשבעה ימים, לאלץ אותם להחליף סיסמה כל 30 יום ולהגדיר ניתוק כפוי של משתמשים לאחר תום פרק הזמן שהוגדר עבור כניסה עם התראה של 5 דקות, הקלד:

net accounts /minpwage:7 /maxpwage:30 /forcelogoff:5

כדי להבטיח שההגדרות הקודמות ייכנסו לתוקף עבור קבוצת המחשבים שאליה מחובר המחשב, הקלד:

net accounts /minpwage:7 /maxpwage:30 /domain


מבט כולל על שירותי רשת

שירותים רבים עושים שימוש בפקודות עבור עבודה ברשת המתחילות במילה net. לפקודות net אלה כמה מאפיינים משותפים:

  • אם ברצונך להציג רשימה של כל פקודות net הזמינות, הקלד net /?‎ בשורת פקודה.
  • ניתן לקבל עזרה אודות תחביר בשורת הפקודה עבור פקודת net על-ידי הקלדת net help command. לדוגמה, לקבלת עזרה עבור הפקודה net accounts, הקלד:

    net help accounts

  • כל פקודות net מקבלות את אפשרויות שורת הפקודה ‎/y (כן) ו- ‎/n (לא). לדוגמה, הפקודה net stop server תציג בפניך בקשה לאישור של הפסקת כל שירותי Server (שרת) התלויים, בעוד net stop server /y, באמצעות תשובה חיובית אוטומטית, עוקפת את בקשת האישור ומפסיקה את השירות.
  • אם שם של שירות כולל רווחים, תחום אותו במרכאות (כלומר, "Service Name"). לדוגמה, הפקודה הבאה מפעילה את שירות הכניסה לרשת:

    net start "net logon"‎

  • לקבלת מידע נוסף אודות פקודות של שירותי רשת, ראה פקודות של שירותי רשת, Net Services.


Net computer

הוספה או הסרה של מחשבים ממסד נתונים של קבוצת מחשבים.

תחביר

net computer \\ComputerName {/add | /del}‎

פרמטרים

‎\\ComputerName
ציון שם המחשב שיש להוסיף או למחוק מקבוצת המחשבים.
‎{/add | /del}‎
הוספה או הסרה של המחשב שצוין מקבוצת המחשבים.
net help command
הצגת עזרה עבור פקודת net שצוינה.

הערות

  • הפקודה net computer מעבירה כל הוספה או הסרה של מחשב אל בקר קבוצת המחשבים.

דוגמאות

להוספת המחשב Grizzlybear לקבוצת מחשבים, הקלד:

net computer \\grizzlybear /add


Net config

הצגת השירותים הפועלים שאת תצורתם ניתן לקבוע, או הצגה ושינוי של הגדרות עבור שירות Server (שרת) או שירות Workstation (תחנת עבודה). הקלד net config ללא פרמטרים כדי להציג את רשימת השירותים שאת תצורתם ניתן לקבוע.

תחביר

net config [{server|workstation}]‎

פרמטרים

server
הצגה ומתן אפשרות לשינויים בהגדרות עבור שירות Server בעוד השירות פועל.
workstation
הצגה ומתן אפשרות לשינויים בהגדרות עבור שירות Workstation בעוד השירות פועל.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • ניתן להשתמש בפקודה net config server לשם שינוי הגדרות שאת תצורתן ניתן לקבוע עבור שירות Server. השינויים קבועים ומתבצעים מיידית.
  • לא ניתן לשנות את כל הגדרות שירות Server על-ידי שימוש ב- net config server. הפקודה net config server מציגה את המידע הבא, שאין באפשרותך לקבוע את תצורתו:
    • שם מחשב שרת
    • הערת שרת
    • גירסת שרת (כלומר, מספר גירסת התוכנה)
    • שרת פעיל ב- (כלומר, תיאור של הרשת)
    • שרת מוסתר (כלומר, ההגדרה ‎/hidden)
    • מספר מירבי של משתמשים המורשים לבצע כניסה בו-זמנית (כלומר, המספר המירבי של משתמשים שבאפשרותם להשתמש במשאבים משותפים של השרת)
    • מספר מירבי של קבצים פתוחים לכל הפעלה (כלומר, המספר המירבי של קבצי שרת שניתנת למשתמשים אפשרות לפתוח במהלך הפעלה)
    • זמן חוסר פעילות של הפעלה (דקות)
  • השתמש בפקודה net config workstation לשנות הגדרות של שירות Workstation שאת תצורתן ניתן לקבוע.
  • הפקודה net config workstation מציגה את המידע הבא:
    • שם מחשב
    • שם מחשב מלא
    • שם משתמש
    • תחנת עבודה פעילה ב- (כלומר, תיאור של הרשת)
    • גירסת תוכנה (כלומר, מספר גירסת התוכנה)
    • קבוצת מחשבים של תחנת עבודה
    • שם DNS של קבוצת המחשבים של תחנת העבודה
    • קבוצת מחשבים לכניסה
    • זמן קצוב לפתיחת COM (שניות)
    • ספירה של שליחת COM (בתים)
    • זמן קצוב לשליחת COM (מילישניות)


Net continue

החזרה לפעולה של שירות שהושהה באמצעות הפקודה net pause.

תחביר

net continue service

פרמטרים

service
נדרש. ציון השירות שאת פעולתו ברצונך להמשיך. הטבלה הבאה מפרטת חלק מן הערכים האפשריים עבור service.
ערך | תיאור
netlogon | המשך פעולתו של שירות Net Logon (כניסה לרשת).
‎"nt lm security support provider"‎ | המשך פעולתו של שירות NT LM Security Support Provider.
schedule | המשך פעולתו של שירות Task Scheduler (מתזמן המשימות).
server | המשך פעולתו של שירות Server (שרת).
workstation | המשך פעולתו של שירות Workstation (תחנת עבודה).
net help command
הצגת עזרה עבור פקודת net שצוינה.

הערות

  • לעריכת תיקון קל במשאב, השהה את השירות. לאחר מכן, השתמש בפקודה net continue כדי להפעיל מחדש את השירות או את המדפסת מבלי לבטל התקשרויות של משתמשים.
  • ההשפעה שתהיה להשהית שירות ולחידוש פעולתו עשויה להיות שונה בכל שירות.
  • אם שם של שירות מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Service Name").

דוגמאות

הפקודה הבאה ממשיכה את פעולתו של שירות Workstation:

net continue workstation

אם שם השירות כולל שתי מילים או יותר, תחום אותו במרכאות. לדוגמה, כדי להמשיך את פעולתו של שירות NT LM Security Support Provider, הקלד:

net continue "nt lm security support provider"‎


Net file

הצגה של כל הקבצים המשותפים הפתוחים בשרת ושל מספר הנעילות עבור כל קובץ, אם בוצעו. פקודה זו מאפשרת גם סגירה של קבצים משותפים בודדים והסרה של נעילות קובץ. הקלד net file ללא פרמטרים כדי להציג רשימה של קבצים פתוחים בשרת.

תחביר

net file [ID [/close]]‎

פרמטרים

ID
ציון מספר הזיהוי של הקובץ
‎/close
סגירת קובץ פתוח ושחרור רשומות נעולות. הקלד פקודה זו בשורת הפקודה בשרת שבו נעשה בקובץ שימוש משותף.
net help command
הצגת עזרה עבור פקודת net שצוינה.

הערות

  • באפשרותך גם להקליד net files כדי להפעיל פקודה זו.
  • ניתן להשתמש בפקודה net file לשם הצגה ושליטה בקבצים משותפים ברשת. לעתים משאיר משתמש קובץ משותף פתוח ונעול בטעות. במקרה כזה, מחשבים אחרים ברשת אינם יכולים לקבל גישה לחלקים הנעולים של הקובץ. השתמש בפקודה net file /close כדי להסיר את הנעילה וכדי לסגור את הקובץ. להלן דוגמה לפלט של הפקודה net file:

    File      Path             Username    #locks

    ---------------------------------------------

    0         C:\A_FILE.TXT    MARYSL      0

    1         C:\DATABASE      DEBBIET     2

דוגמאות

להצגת מידע אודות קבצים משותפים, הקלד:

net file

לשם סגירת הקובץ שמספר הזיהוי שלו 1, הקלד:

net file 1 /close


Net group

הוספה, הצגה או תיקון של קבוצות כלליות בקבוצת מחשבים.

תחביר

net group [groupname [/comment:"text"]]‎ ‎[/domain]‎

net group [groupname ‎{/add [/comment:"text"] | /delete} [/domain]]‎

net group [groupname username[ ...] {/add | /delete} [/domain]]‎

פרמטרים

groupname
ציון שם הקבוצה שיש להוסיף, להרחיב או למחוק. ציין שם קבוצה בלבד כדי להציג את רשימת המשתמשים בקבוצה.
‎/comment:"text"‎
הוספת הערה לקבוצה חדשה או לקבוצה קיימת. הערה עשויה לכלול עד 48 תווים. את הטקסט יש לתחום במרכאות.
‎/domain
ביצוע הפעולה בבקר קבוצת המחשבים של קבוצת המחשבים הנוכחית. אם לא יצוין פרמטר זה, הפעולה תתבצע במחשב המקומי.
‎/add
הוספת קבוצה או הוספת שם משתמש לקבוצה. יש ליצור חשבון עבור משתמשים שברצונך להוסיף לקבוצה באמצעות פקודה זו.
‎/delete
הסרת קבוצה או הסרת שם משתמש מקבוצה.
UserName[ ...]‎
פירוט שם משתמש אחד או מספר שמות משתמש שיש להוסיף או להסיר מקבוצה. אם תציין מספר ערכים של שם משתמש, הפרד אותם זה מזה באמצעות רווח.
net help command
הצגת עזרה עבור פקודת net שצוינה.

הערות

  • הקלד net group ללא פרמטרים כדי להציג את שם השרת ואת שמות הקבוצות שבשרת.
  • באפשרותך להקליד גם net groups.
  • ניתן להשתמש בפקודה net group לשם קיבוץ משתמשים שאופן השימוש שלהם ברשת זהה או דומה. בעת הקצאה של זכויות לקבוצה, כל חבר בקבוצה מקבל זכויות אלה באופן אוטומטי. בפלט של הפקודה net group, תוצג כוכבית (*) לפני קבוצות הכוללות משתמשים וקבוצות גם יחד.

    להלן פלט לדוגמה עבור הפקודה net group אודות קבוצות בשרת:

    Group Accounts for \\PRODUCTION

    ----------------------------------------------

    ‎*Domain Admins           *Domain Users

דוגמאות

לשם הצגת רשימה של כל הקבוצות בשרת המקומי, הקלד:

net group

לשם הוספת קבוצה הנקראת Exec למסד הנתונים המקומי של חשבונות משתמש, הקלד:

net group exec /add

לשם הוספת קבוצה הנקראת Exec למסד הנתונים של קבוצת המחשבים, הקלד:

net group exec /add /domain

לשם הוספת חשבונות המשתמשים הקיימים stevev‏, ralphr ו- jennyt לקבוצה Exec במחשב המקומי, הקלד:

net group exec stevev ralphr jennyt /add

לשם הוספת חשבונות המשתמש הקיימים stevev‏, ralphr ו- jennyt לקבוצה Exec במסד הנתונים של קבוצת המחשבים, הקלד:

net group exec stevev ralphr jennyt /add /domain

לשם הצגת המשתמשים שבקבוצה Exec, הקלד:

net group exec

לשם הוספת הערה עבור רשומת הקבוצה Exec, הקלד:

net group exec /comment:"The executive staff"‎


Net help

השתמש בפקודה זו לקבלת רשימה של פקודות רשת ונושאים שניתן לקבל מידע עזרה עבורם, או לקבלת מידע אודות פקודה מסוימת. הקלד net help ללא פרמטרים לשם הצגת רשימה של פקודות ושל נושאים שניתן לקבל עזרה אודותיהם.

תחביר

net help [command]‎

פרמטרים

command
‎/help
הצגת של התחביר הנכון ושל מידע העזרה עבור הפקודה.
ציון הפקודה שעבורה ברצונך לקבל עזרה.

דוגמאות

להצגת עזרה עבור הפקודה net use, הקלד:

net help use

לחלופין, הקלד:

net use /help

להצגת תחביר בלבד עבור הפקודה net use, הקלד:

net help /?‎


Net helpmsg

השתמש בפקודה זו כדי לברר מדוע התרחשה שגיאה ולקבל מידע עבור פתרון הבעיה.

תחביר

net helpmsg message#‎

פרמטרים

message#‎
נדרש. ציון המספר בן ארבע הספרות של ההודעה שברצונך לקבל מידע נוסף אודותיה.
net help command
הצגת עזרה עבור פקודת net שצוינה.

הערות

  • כאשר פעולת רשת נכשלת, תוצג הודעה הדומה להודעה הבאה:

    ‎2182: The requested service has already been started.‎

דוגמאות

לקבלת מידע נוסף אודות הודעת השגיאה NET 2182, הקלד:

net helpmsg 2182


Net localgroup

הוספה, הצגה או שינוי של קבוצות מקומיות. הקלד net localgroup ללא פרמטרים כדי להציג את שם השרת ואת שמות הקבוצות המקומיות במחשב.

תחביר

net localgroup [GroupName [/comment:"text"]]‎ ‎[/domain]‎

net localgroup [GroupName ‎{/add [/comment:"text"] | /delete}‎ ‎[/domain]]‎

net localgroup [GroupName name ‎[ ...]‎ ‎{/add | /delete} [/domain]]‎

פרמטרים

GroupName
ציון שם הקבוצה המקומית שיש להוסיף, להרחיב או למחוק. ללא פרמטרים נוספים, תציג הפקודה net localgroup GroupName רשימה של משתמשים או של קבוצות כלליות בקבוצה מקומית.
‎/comment:"text"‎
הוספת הערה עבור קבוצה חדשה או עבור קבוצה קיימת. ניתן לכלול בהערה עד 48 תווים. את הטקסט יש לתחום במרכאות.
‎/domain
ביצוע הפעולה בבקר קבוצת המחשבים הראשי של קבוצת המחשבים הנוכחית. אם אפשרות זו לא תצוין, הפעולה תתבצע במחשב המקומי.
name [ ...]‎
פירוט שם משתמש, שם קבוצה או מספר שמות משתמש או שמות קבוצה שיש להוסיף או להסיר מקבוצה מקומית.
‎/add
הוספה של שם קבוצה כללית או של שם משתמש לקבוצה מקומית. לפני צירוף של משתמשים או של קבוצות כלליות לקבוצה מקומית באמצעות פקודה זו, יש ליצור עבורם חשבון.
‎/delete
הסרה של שם קבוצה או של שם משתמש מקבוצה מקומית.
net help command
הצגת עזרה עבור פקודת net שצוינה.

הערות

  • שימוש בפרמטר ‎/domain

    הפרמטר ‎/domain חל רק על מחשבי Windows XP Professional שהינם חברים בקבוצת המחשבים. כברירת מחדל, מחשבי שרתים מבצעים פעולות בבקר הראשי של קבוצת המחשבים.

  • השימוש בפרמטר name

    ערכים יש להפריד זה מזה באמצעות רווח. השמות עשויים להיות שמות של משתמשים מקומיים, של משתמשים בקבוצות מחשבים אחרות או של קבוצות כלליות, אך לא של קבוצות מקומיות אחרות. אם המשתמש שייך לקבוצת מחשבים אחרת, יש להקדים לשמו את שם קבוצת המחשבים (לדוגמה, Sales\Ralphr).

  • קיבוץ משתמשים

    ניתן להשתמש בפקודה net localgroup לשם קיבוץ משתמשים שאופן פעולתם ברשת או במחשב דומה או זהה. בעת הקצאת זכויות לקבוצה מקומית, כל חבר בקבוצה מקבל באופן אוטומטי את הזכויות שהוקצו.

דוגמאות

לשם הצגת רשימה של כל הקבוצות המקומיות בשרת המקומי, הקלד:

net localgroup

לשם הוספת קבוצה מקומית הנקראת Exec למסד הנתונים המקומי עבור חשבונות משתמש, הקלד:

net localgroup exec /add

לשם הוספת קבוצה מקומית הנקראת Exec למסד הנתונים המקומי עבור חשבונות משתמש, הקלד:

net localgroup exec /add /domain

לשם הוספת חשבונות המשתמש הקיימים stevev‏, ralphr (מקבוצת המחשבים SALES) ו- jennyt לקבוצה המקומית Exec שבמחשב המקומי, הקלד:

net localgroup exec stevev sales\ralphr jennyt /add

לשם הוספה של חשבונות המשתמש הקיימים stevev‏, ralphr ו- jennyt לקבוצה Exec של קבוצת מחשבים, הקלד:

net localgroup exec stevev ralphr jennyt /add /domain

לשם הצגת המשתמשים בקבוצה המקומית Exec, הקלד:

net localgroup exec

לשם הוספת הערה עבור רשומת הקבוצה המקומית Exec, הקלד:

net localgroup exec /comment:"The executive staff."‎


Net name

הוספה או הסרה של שם להעברת הודעות (כלומר, כינוי) או הצגת רשימת השמות שעבורם יקבל המחשב הודעות. הקלד net name ללא פרמטרים לשם הצגת רשימה של השמות הנמצאים בשימוש בעת.

תחביר

net name [name {/add|/delete}]‎

פרמטרים

name
ציון השם לקבלת ההודעות. שם עשוי להכיל עד 15 תווים.
‎/add
הוספת שם למחשב.
‎/delete
הסרת שם ממחשב.

הערות

  • ניתן להשתמש בפקודה net name כדי לציין שם להעברת הודעות. עליך להפעיל את שירות Messenger כדי שיהיה באפשרותך להשתמש בפקודה net name. על כל שם להעברת הודעות להיות ייחודי ברשת. שמות שנוצרו באמצעות net name נמצאים בשימוש עבור הודעות בלבד, לא עבור שמות קבוצה. Windows XP עושה שימוש בשלושת סוגי השמות הבאים:
    • כל שם עבור העברת הודעות (נוסף באמצעות net name)
    • שם מחשב (נוסף בעת הפעלה של שירות Workstation)
    • שם משתמש (המצורף בעת כניסה למחשב, כל עוד שם משתמש זה אינו משמש כשם עבור העברת הודעות במקום אחר ברשת)
  • הפרמטר add הוא אופציונלי. פעולת הפקודה Net name name זהה לפעולת הפקודה net name name add. באפשרותך להשתמש בכל אחת מפקודות אלה כדי להוסיף שם למחשב.
  • אין באפשרותך למחוק את שם המחשב. באפשרותך למחוק את שם המשתמש.

דוגמאות

כדי להציג את רשימת השמות שבמחשב, הקלד:

net name

כדי להוסיף את השם Rsvp למחשב, הקלד:

net name rsvp

כדי להסיר את השם Rsvp מהמחשב, הקלד:

net name rsvp /delete


Net pause

השהיית השירותים הפועלים כעת.

תחביר

net pause service

פרמטרים

service
דרוש. מציין את השירות שברצונך להשהות. הטבלה שלהלן מציינת כמה ערכים אפשריים עבור service.
ערך | תיאור
netlogon | השהיית השירות Net Logon (כניסה לרשת).
‎"nt lm security support provider"‎ | השהיית השירות NT LM Security Support Provider.
schedule | השהיית השירות Task Scheduler (מתזמן המשימות).
server | השהיית השירות Server (שרת).
workstation | השהיית השירות Workstation (תחנת עבודה).
net help command
הצגת עזרה עבור פקודת net שצוינה.

הערות

  • בשרת, ניתן להשתמש בפקודה net pause לפני עצירת שירות כדי לתת למשתמשים אפשרות להשלים את עבודתם או להתנתק ממשאבים. השהיית שירות מעבירה אותו למצב המתנה, אך אינה מסירה את התוכנה מהזיכרון. למשתמשים המקושרים למשאב יש אפשרות להשלים את משימותיהם, אך לא ניתן ליצור התקשרויות חדשות למשאב.

    אם ברצונך לעצור שירות המשפיע על משאבים משותפים, השהה את השירות תחילה. השתמש בפקודה net send כדי להעביר הודעה המציינת כי ברצונך לעצור את השירות. לאחר שקיבלו המשתמשים האחרים די זמן לסיים את השימוש במשאב, השתמש בפקודה net stop כדי לעצור את השירות.

    כדי להפעיל מחדש שירות שהושהה, השתמש בפקודה net continue.

  • אין באפשרותך להשהות את כל השירותים. השהיה משפיעה על שירותים בדרכים הבאות:
    • השהיית שירות כניסה לרשת מונעת מהמחשב לעבד בקשות כניסה. אם קיימים בקבוצת המחשבים שרתי כניסה אחרים, עדיין יש למשתמשים אפשרות כניסה לרשת.
    • השהיית השירות Server מונעת ממשתמשים לבצע התקשרויות חדשות למשאבים המשותפים שבשרת. אם לא קיימים ברשת שרתי כניסה אחרים, תימנע מן המשתמשים גם כניסה לרשת. התקשרויות קיימות אינן מושפעות. לחברים בקבוצה Administrators יש אפשרות להתקשר לשרת גם אם הוא מושהה.
    • לאחר השהיית שירות תחנת עבודה, שם המשתמש, הסיסמה וההתקשרויות יישארו מוגדרים, אך בקשות עבור התקני הדפסה ינותבו למדפסות המחוברות למחשב במקום למדפסות המחוברות לרשת.
  • אם שם שירות מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Service Name").

דוגמאות

לשם השהיה של שירות Server, הקלד:

net pause server

אם שם של שירות כולל שתי מילים או יותר, תחום אותו במרכאות. לדוגמה, כדי להשהות את השירות "NT LM Security Support Provider", הקלד:

net pause "nt lm security support provider"‎


Net print

הצגת מידע אודות תור הדפסה שצוין, הצגת מידע אודות כל תורות ההדפסה שמארח שרת ההדפסה שצוין, הצגת מידע או שליטה במשימת הדפסה שצוינה. ללא פרמטרים, שימוש בפקודה net print מביא להצגת עזרה של שורת פקודה עבור הפקודה net print.

לשם הצגת מידע אודות תור הדפסה שצוין או אודות כל תורות ההדפסה שמארח שרת ההדפסה שצוין

תחביר

net print \\ComputerName[\QueueName]‎

פרמטרים

‎\\ComputerName
דרוש. ציון שמו של המחשב המארח את תור ההדפסה שברצונך להציג מידע אודותיו.
‎\QueueName
ציון שמו של תור ההדפסה שברצונך להציג מידע אודותיו. אם תציין מחשב אך לא תציין תור, יוצג מידע אודות כל תורות ההדפסה במחשב שצוין.
net help net print
הצגת עזרה עבור הפקודה net print.

הערות

  • הפקודה net print מציגה סוגי מידע שונים אודות תורות הדפסה. להלן דוגמה של דו"ח עבור כל תורות ההדפסה שבשרת Production:

    Printer queues at \\PRODUCTION

    Name              Job #      Size      Status

---------------------------------------------------------

LASER Queue       1 jobs               *Queue Active*‎

USER1          84        0      Spooling

דוגמאות

לשם פירוט תוכנו של תור ההדפסה Dotmatrix שבמחשב ‎\\Production, הקלד:

net print \\production\dotmatrix

לשם הצגת מידע או שליטה בתור הדפסה שצוין

תחביר

net print [\\ComputerName]‎ JobNumber [{/hold | /release | /delete}]‎

פרמטרים

‎\\ComputerName
ציון שמו של המחשב המארח את תור ההדפסה שברצונך לשלוט בו. אם לא תציין שם מחשב, תתייחס הפקודה למחשב המקומי.
JobNumber
דרוש. ציון מספרה של משימת ההדפסה שברצונך לשלוט בה. מספר זה הוקצה למשימה בידי המחשב המארח את תור ההדפסה שאליו נשלחה משימת ההדפסה. לאחר שמקצה המחשב מספר למשימת הדפסה, מספר זה אינו מוקצה למשימות הדפסה אחרות בכל תור שמארח מחשב זה.
‎{/hold | /release | /delete}‎
ציון הפעולה שיש לבצע עבור משימת ההדפסה. הפרמטר ‎/hold משהה את המשימה, ומאפשר למשימות הדפסה אחרות להתבצע עד לשחרור המשימה שהושהתה. הפרמטר ‎/release מביא לשחרור משימת הדפסה שהושהתה. הפרמטר ‎/delete מסיר משימת הדפסה מתור הדפסה. אם תציין מספר משימה אך לא תציין פעולה, יוצג מידע אודות משימת ההדפסה.
net help net print
הצגת עזרה עבור הפקודה net print.

הערות

  • להלן דוגמה של דו"ח עבור משימת הדפסה:

    Job #            35

Status           Waiting

Size             3096

Remark

Submitting user  USER2

Notify           USER2

Job data type

Job parameters

Additional info

דוגמאות

לשם קבלת מידע אודות המשימה שמספרה 35 במחשב ‎\\Production, הקלד:

net print \\production 35

לשם השהיית המשימה שמספרה 263 במחשב ‎\\Production, הקלד:

net print \\production 263 /hold

לשם שחרור המשימה שמספרה 263 במחשב ‎\\Production, הקלד:

net print \\production 263 /release


Net send

שליחה ברשת של הודעות למשתמשים, למחשבים או לשמות עבור העברת הודעות.

תחביר

net send ‎{name | * | /domain[:name] | /users}‎ message

פרמטרים

name
ציון של שם משתמש, של שם מחשב או של שם עבור העברת הודעות שאליו תישלח ההודעה. אם המידע שברצונך לציין כולל רווחים, תחום את הטקסט במרכאות (לדוגמה, ‎"Computer Name"‎). שמות משתמש ארוכים עשויים לגרום לבעיות אם תשתמש בהם כשמות NetBIOS. אורכם של שמות NetBIOS מוגבל ל- 16 תווים, והתו ה- 16 שמור.
*
שליחת ההודעה לכל השמות שבקבוצת המחשבים או בקבוצת העבודה.
‎/domain:name
שליחת ההודעה לכל השמות שבקבוצת המחשבים של המחשב. באפשרותך לציין name עבור שליחת ההודעה לכל השמות שבקבוצת המחשבים או בקבוצת העבודה שצוינו.
‎/users
שליחת ההודעה לכל המשתמשים המחוברים לשרת.
message
דרוש. פרמטר זה הוא נוסח ההודעה.
net help command
הצגת עזרה עבור פקודת net שצוינה.

הערות

  • באפשרותך לשלוח הודעה רק אל שם שמצבו ברשת פעיל. אם ההודעה נשלחת לשם משתמש, על מחשבו של הנמען להיות מחובר לרשת, ושירות Messenger אמור לפעול בו כדי שתתאפשר קבלת ההודעה.
  • באפשרותך לשלוח הודעה לכל השמות שבקבוצת המחשבים של המחשב שלך (באמצעות * או באמצעות ‎/domain) או לכל השמות שבקבוצת מחשבים אחרת (באמצעות ‎/domain:domainname). הודעות משודרות עשויות לכלול עד 128 תווים. הפעל שיקול דעת כשברצונך לשלוח הודעות למשתמשים מרובים.
  • האפשרות ‎/users מאפשרת שליחת הודעות לכל המשתמשים המקיימים הפעלות עם השרת. הפעל שיקול דעת כשברצונך לשלוח הודעות למשתמשים מרובים.
  • על שירות Messenger לפעול כדי שתתאפשר קבלת הודעות. לקבל מידע נוסף אודות הפעלת שירות, ראה נושאים קרובים.

דוגמאות

לשם שליחת ההודעה ‎"Meeting changed to 3 P.M. Same place."‎ למשתמש robertf, הקלד:

net send robertf Meeting changed to 3 P.M. Same place.‎

לשם שליחת הודעה לכל המשתמשים המחוברים לשרת, הקלד:

net send /users This server will shut down in 5 minutes.‎

לשם שליחת הודעה הכוללת קו נטוי (/), הקלד:

net send robertf "Format your disk with FORMAT /4"‎


Net session

ניהול התקשרויות של מחשב שרת. ללא פרמטרים, הפקודה net session משתמשת להצגת מידע אודות כל ההפעלות עם המחשב המקומי.

תחביר

net session [\\ComputerName] [/delete]‎

פרמטרים

‎\\ComputerName
זיהוי המחשב שעבורו יש לפרט או לנתק הפעלות.
‎/delete
סיום ההפעלה של המחשב עם ComputerName וסגירת כל הקבצים שנפתחו במחשב עבור הפעלה זו. אם לא תציין את הפרמטר ComputerName, יבוטלו כל ההפעלות במחשב המקומי.
net help command
הצגת עזרה עבור פקודת net שצוינה.

שים לב

  • שימוש בפקודה net session עשוי להביא לאובדן נתונים. ייתכן שיהיה ברצונך ליידע את המשתמשים לפני ניתוק הפעלה.

הערות

  • באפשרותך להשתמש גם בפקודות net sessions או net sess לשם ביצוע הפקודה net session.
  • השתמש בפקודה net session כדי להציג שמות מחשב ושמות משתמש של משתמשים בשרת, כדי לבדוק אם יש למשתמשים קבצים פתוחים וכדי לבדוק כמה זמן היתה הפעלה של משתמש בלתי פעילה.

    המידע מוצג בתבנית הדומה לתבנית הבאה:

    Computer      User name        Client type  Opens   Idle time

------------------------------------------------------------------------
‎\\BASSETT     CHRISDR          Windows 2000   1     00:00:13
‎\\SHARONCA    Administrator    DOS LM 2.1     0     01:05:13

  • לשם הצגת הפעלה של משתמש יחיד יש לכלול בפקודה את הפרמטר ComputerName. תצוגה עבור משתמש יחיד כוללת רשימה של משאבים משותפים שלמשתמש יש התקשרויות אליהם.
  • הפעלה נרשמת כאשר משתמש במחשב לקוח מתחבר לשרת בהצלחה. הפעלה מוצלחת מתקיימת כאשר שני המחשבים נמצאים באותה רשת, וכאשר השם והסיסמה של המשתמש נתקבלו על-ידי השרת. על משתמש במחשב לקוח לקיים הפעלה עם שרת כדי שיהיה באפשרותו להשתמש במשאבי השרת, והפעלה נוצרת רק לאחר שהמשתמש במחשב הלקוח מתחבר למשאב. לא ניתן ליצור יותר מהפעלה אחת עבור לקוח ושרת, אך הפעלה זו עשויה לכלול נקודות כניסה (התקשרויות) רבות למשאבים.
  • כדי לקבוע כמה זמן עשויה הפעלה להיות לא פעילה לפני ניתוק אוטומטי שלה, קבע ערך עבור התכונה autodisconnect באמצעות הפקודה net config server /autodisconnect. לקבלת מידע נוסף אודות הפקודה net config server, ראה נושאים קרובים. הניתוק האוטומטי שקוף למשתמש מכיוון שההפעלה מחוברת מחדש באופן אוטומטי ברגע שחוזר המשתמש לבצע גישה למשאב.
  • כדי לסיים הפעלה עם השרת, השתמש בפקודה net session ‎\\ComputerName /delete.

דוגמאות

לשם פירוט של מידע הפעלה עבור השרת המקומי, הקלד:

net session

לשם הצגה של מידע הפעלה עבור הלקוח ששם המחשב שלו הוא Shepherd, הקלד:

net session \\shepherd

לשם סיום כל ההפעלות בין השרת ללקוחות המחוברים אליו, הקלד:

net session /delete


Net share

ניהול משאבים משותפים. ללא פרמטרים, הפקודה net share מביאה להצגת מידע אודות כל המשאבים המשותפים במחשב המקומי.

תחביר

net share [ShareName]‎ net share [ShareName=Drive:Path [{/users:number|/unlimited}] [/remark:"text"] [/cache: {manual|automatic|no}]]‎ net share [ShareName [{/users:number|unlimited}] [/remark:"text"] [/cache: {manual|automatic|no}]]‎ net share [{ShareName|Drive:Path} /delete]‎

פרמטרים

ShareName
ציון שם הרשת של המשאב המשותף. שימוש בפקודה net share בצירוף ShareName יביא להצגת מידע אודות מיקום משותף זה בלבד.
Drive:Path
ציון הנתיב המוחלט של הספריה שייעשה בה שימוש משותף.
‎/users:number
הגדרת המספר המירבי של משתמשים שבאפשרותם לבצע גישה למשאב המשותף בו-זמנית.
‎/unlimited
מציין כי למספר לא מוגבל של משתמשים תהיה אפשרות לבצע גישה למשאב המשותף בו-זמנית.
‎/remark:"text"‎
הוספת הערה המתארת את המשאב. יש לתחום את הטקסט במרכאות.
‎/cache:automatic
מתן אפשרות לאחסון לא מקוון במטמון עם שילוב מחדש אוטומטי עבור לקוח.
‎/cache:manual
מתן אפשרות לאחסון לא מקוון במטמון עם שילוב מחדש ידני עבור לקוח.
‎/cache:no
התרעה בפני הלקוח כאשר אין לבצע אחסון בלתי מקוון במטמון.
‎/delete
הפסקת שיתוף המשאב.
net help command
הצגת עזרה עבור פקודת net שצוינה.

הערות

  • אם הנתיב של הספריה שברצונך לשתף מכיל רווחים, יש לתחום את הכונן ואת הנתיב של הספריה במרכאות (לדוגמה, "C:\Path Name").
  • בעת הצגת כל המשאבים המשותפים במחשב, מוצגים שם השיתוף של המשאב, שמות ההתקן או הנתיב המקושרים למשאב והערה תיאורית אודות המשאב. הפלט דומה לדוגמה הבאה:

    Sharename  Resource                     Remark
------------------------------------------------------
ADMIN$     C:\WINNT                     Remote Admin
C$         C:\                          Default Share for Internal Use
print$     C:\WINNT\SYSTEM\SPOOL
IPC$                                    Remote IPC
LASER      LPT1               Spooled   Laser printer

  • מיקומים משותפים נשמרים בזמן יצירתם בשרת. כל המיקומים המשותפים מנותקים בעת עצירת שירות Server, אך מחוברים מחדש אוטומטית בעת הפעלת שירות Server או בעת הפעלה מחדש של המחשב. לקבלת מידע נוסף אודות שירותים, ראה שירותים.
  • שמות משאבים משותפים המסתיימים בתו $ אינם מוצגים בעת עיון במחשב המקומי ממחשב מרוחק.

דוגמאות

לשם הצגת מידע אודות משאבים משותפים במחשב, הקלד:

net share

כדי להפוך את הספריה C:\Data למשותפת תחת שם השיתוף DataShare ולהוסיף הערה, הקלד:

net share DataShare=c:\Data /remark:"For department 123."‎

כדי להפסיק את שיתוף התיקיה DataShare שיצרת בדוגמה הקודמת, הקלד:

net share DataShare /delete

כדי להפוך את הספריה C:\Art Lst למשותפת תחת שם השיתוף List, הקלד:

net share list="c:\art lst"‎


Net start

הפעלת שירות. ללא פרמטרים, הפקודה net start מביאה להצגה של רשימת השירותים הפועלים כעת.

תחביר

net start [service]‎

פרמטרים

service
הפעלת שירות שצוין. הטבלה שלהלן מציגה ערכים עבור service.
ערך | תיאור | הערות
alerter הפעלת שירות Alerter.
  • הפעל את שירות Alerter כדי לשלוח הודעות התרעה למשתמשים שצוינו, המחוברים לשרת. הודעות התראה מתריעות על בעיות אבטחה, על בעיות גישה ועל בעיות של הפעלת משתמש.
  • השתמש ב- Server Manager (כלומר, systemroot\System32\Srvmgr.exe) כדי לציין את חברי הקבוצה Administrators שברצונך שיקבלו התראות ניהוליות. Server Manager זמין רק במחשבים שפועל בהם Windows 2000 Server.
  • הודעות התראה נשלחות כהודעות מן השרת אל מחשב המשתמש. כדי שתהיה למשתמש אפשרות לקבל את הודעות ההתראה, יש להפעיל במחשב של המשתמש את שירות Messenger.
browser הפעלת שירות Computer Browser.
  • השירות Computer Browser שומר רשימה מעודכנת של מחשבים ברשת שלך, ומספק את רשימת התוכניות המבקשות רשימה זו.
‎"client service for netware"‎ הפעלת שירות Client Service for NetWare.
  • פקודה זו זמינה רק לאחר התקנת Client Service for NetWare.
clipbook הפעלת שירות ClipBook (ספר-לוח).
  • ClipBook (ספר-לוח) מאפשר גזירה והדבקה של טקסט ושל תמונות ברשת.
  • השירות ClipBook תומך בתצוגת ספר-לוח, שירות המאפשר הצגת דפים בספר-לוח מרוחק.
dhcp client הפעלת שירות DHCP Client.
  • פקודה זו זמינה רק לאחר התקנת הפרוטוקול TCP/IP.
  • השירות DHCP Client מנהל תצורת רשת על-ידי רישום ועדכון של כתובות IP ושל שמות DNS. השירות DHCP Client תומך בהשגת כתובת IP משירות DHCP.
  • לא ניתן לעצור או להשהות את הפעולה של שירות DHCP Client.
eventlog הפעלת שירות Event Log (יומן אירועים).
  • שירות יומן אירועים מבצע רישום של הודעות אירוע שנוצרו בתוכניות וב- Windows XP. דו"חות של יומן אירועים מכילים מידע שעשוי להימצא שימושי עבור אבחון בעיות. הדו"חות מוצגים במציג האירועים. יש להפעיל את יומן האירועים לפני השימוש במציג האירועים לשם הצגת אירועים שנרשמו ביומן.
  • לא ניתן לעצור או להשהות את פעולתו של שירות יומן האירועים.
file replication | הפעלה של שירות File Replication (שכפול קבצים).
messenger הפעלת שירות Messenger.
  • שירות Messenger מאפשר למחשב לקבל הודעות.
  • הודעה נשלחת למחשב תוך שימוש בשמות שהוקצו למחשב לצורך זיהוי.
netlogon הפעלת שירות Net Logon.
  • שירות Net Logon מאמת בקשות כניסה ושולט בשיכפולי מסד נתונים של חשבונות משתמש בכל קבוצת המחשבים.
  • הפעלת שירות Net Logon בכל השרתים בקבוצת מחשבים העושים שימוש בעותק של מסד הנתונים עבור חשבונות משתמש של קבוצת המחשבים.
‎"nt lm security support provider"‎ הפעלת שירות NT LM Security Support Provider.
  • פקודה זו זמינה רק לאחר התקנת NT LM Security Support Provider.
‎"plug and play"‎ | הפעלת שירות Plug and Play (הכנס-הפעל).
‎"remote access connection manager"‎ הפעלת שירות Remote Access Connection Manager.
  • פקודה זו זמינה רק לאחר התקנת Remote Access Service (שירות גישה מרחוק).
‎"routing and remote access"‎ | הפעלת שירות Routing and Remote Access (ניתוב וגישה מרחוק).
rpclocator הפעלת שירות Locator של Remote Procedure Call‏ (RPC).
  • מאפשר ליישומים מבוזרים לעשות שימוש בשירות השמות RPC של Microsoft.
  • השירות Locator של Remote Procedure Call‏ (RPC) הוא שירות שמות RPC עבור Microsoft Windows XP. שירות RPC Locator מנהל את מסד הנתונים של שירות שמות RPC.
  • צד השרת של היישום המבוזר מבצע רישום של זמינותו באמצעות שירות RPC Locator. צד הלקוח של היישום המבוזר מבצע שאילתה על שירות RPC Locator כדי למצוא יישומי שרת תואמים זמינים.
rpcss הפעלת שירות Remote Procedure Call‏ (RPC).
  • שירות Remote Procedure Call‏ (RPC) הוא מערכת המשנה של RPC עבור Windows XP. מערכת המשנה RPC כוללת את ממפה נקודת הקצה ומגוון שירותי RPC אחרים. הפקודה net start rpcss מפעילה את שירות RPC כדי לאפשר ליישומים מבוזרים לעשות שימוש בנקודות קצה דינמיות. שירות RPC מנהל את מסד הנתונים של מפת נקודת הקצה.

    צד השרת של יישומים מבוזרים מבצע רישום של נקודות הקצה שלו באמצעות שירות Remote Procedure Call‏ (RPC). ספריית זמן ריצה של הלקוח מבצעת, עבור צד הלקוח של היישום המבוזר, שאילתה על שירות RPC כדי להשיג את מידע נקודת הקצה. כדי לקבוע אם יישום מבוזר עושה שימוש בשירות של ממפה נקודת הקצה, עיין בתיעוד עבור יישום מבוזר זה.

schedule הפעלת שירות Task Scheduler (מתזמן המשימות).
  • מתזמן המשימות מאפשר לך להפעיל תוכניות במועד שצוין באמצעות הפקודה at. ייתכן שיהיה עליך להפעיל שירותים אחרים לפני שיהיה באפשרותך להפעיל פקודות שתוזמנו.
  • תצורתו של מתזמן המשימות (Scheduler) נקבעת מראש לפעולה בחשבון System של המחשב המקומי. כאשר מתזמן המשימות פועל באמצעות חשבון זה, אין מגבלות על המשימות שבאפשרותך לבצע באמצעות מתזמן המשימות. עם זאת, משימות אלה מקבלות גישה מוגבלת לרשת מכיוון שמחשבים אחרים אינם מזהים את חשבון System של המחשב המקומי.
  • כדי להתגבר על מגבלות הגישה לרשת, קבע את תצורתו של מתזמן המשימות לפעולה תחת חשבון משתמש. אם תעשה זאת, משימות שיבצע מתזמן המשימות יתבצעו באמצעות גישת הרשת של חשבון המשתמש. עם זאת, מכיוון שבמקרה כזה לא ישתמש מתזמן המשימות בחשבון System המקומי, יהיה באפשרותך להפעיל רק משימות שאינן מחייבות נוכחות של חלון.
server הפעלת שירות Server.
  • באפשרותך להשתמש בשירות Server לשם שיתוף של משאבי שרת עם משתמשים ברשת.
spooler הפעלת שירות Print Spooler (הדפסה ברקע).
  • שירות Print Spooler טוען קבצים לזיכרון עבור הדפסה שלהם (הדפסה ברקע).
‎"tcp/ip netbios helper"‎ הפעלת המסייע של NetBIOS בשירות TCP כדי לאפשר שירותי NetBIOS באמצעות TCP/IP ‏(NetBT).
  • שירותי NetBT מספקים יחידות נתונים של NetBIOS, הפעלות NetBIOS וניהול שמות של NetBIOS (כגון רישום ופענוח שמות) עבור יישומי NetBIOS העושים שימוש בפרוטוקול TCP/IP.
  • פקודה זו זמינה רק לאחר התקנת הפרוטוקול Internet Protocol ‏(TCP/IP) כרכיב במאפיינים של מתאם הרשת ביישום חיבורי רשת.
ups הפעלת שירות אל-פסק (Uninterruptible Power Supply, ‏UPS).
  • שירות אל-פסק מנהל יחידה של אספקת כוח למניעת נפילות (UPS) המחוברת למחשב.
  • באפשרותך לקבוע את תצורתו של שירות אל-פסק באמצעות אפשרויות צריכת חשמל שבלוח הבקרה. אם תקבע את תצורתו של שירות אל-פסק לביצוע קובץ פקודה עם הכיבוי, על הקובץ לסיים את פעולתו בתוך 30 שניות. זמן פעולה העולה על 30 שניות עשוי לפגום ביכולתו של Windows XP לסיים כיבוי מערכת תקין.
workstation הפעלת שירות Workstation.
  • שירות Workstation מאפשר למחשב להתחבר למשאבי רשת ולהשתמש בהם.
net help command
הצגת עזרה עבור פקודת net שצוינה.

הערות

  • ערכת השירותים והיישומים שתוצג בפניך עשויה להשתנות בהתאם לאפשרויות שבחרת במהלך ההתקנה או קביעת התצורה.

  • לקבלת מידע נוסף אודות שירותים, ראה "System Essentials Guide" באתר האינטרנט של Microsoft ‏(http://www.microsoft.com/‎).

  • שירותים מסוימים תלויים בשירותים אחרים.
  • באפשרותך גם להשתמש ביישום ה- Snap-In הנקרא Services כדי לקבוע את תצורתם של שירותים להפעלה ולעצירה אוטומטיות. השתמש ביישום Snap-In זה גם כדי לבצע עצירה, הפעלה, השהיה וחידוש ידניים של שירותי רשת.
  • באפשרותך להשתמש בפקודה net start כדי להפעיל שירותים שאינם כלולים ב- Windows XP.
  • אם שם שירות מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Service Name").

דוגמאות

לשם קבלת רשימה של השירותים הפועלים כעת, הקלד:

net start

כדי להפעיל את שירות Client Service for Netware, הקלד:

net start "client service for netware"‎


Net statistics

הצגת יומן סטטיסטיקה עבור תחנת עבודה מקומית, עבור שירות Server מקומי או עבור השירותים הפעילים שקיימים עבורם נתונים סטטיסטיים זמינים. הקלד net statistics ללא פרמטרים כדי להציג רשימה של השירותים הפעילים שקיימים עבורם נתונים סטטיסטיים זמינים.

תחביר

net statistics [{workstation | server}]‎

פרמטרים

workstation
הצגת סטטיסטיקה עבור שירות Workstation המקומי.
server
הצגת סטטיסטיקה עבור שירות Server המקומי.
net help command
הצגת עזרה עבור פקודת net שצוינה.

הערות

  • באפשרותך להקליד גם net stats.
  • עבור שירות Workstation, ‏Windows XP מציג את שם המחשב, את התאריך והשעה שבהם התעדכנו הנתונים הסטטיסטיים בפעם האחרונה, ואת המידע שלהלן:
    • מספר הבתים ומספר בלוקים של הודעות שרת (Server Message Blocks, ‏SMB) שהתקבלו ושודרו.
    • מספר פעולות הקריאה וכתיבה שהתבצעו בהצלחה או נכשלו.
    • מספר שגיאות הרשת.
    • מספר ההפעלות שנכשלו, נותקו או חוברו מחדש.
    • מספר ההתקשרויות למשאבים משותפים שנכשלו או שבוצעו בהצלחה.
  • עבור שירות Server מציג Windows XP את שם המחשב, את התאריך והשעה שבהם עודכנו הנתונים הסטטיסטים בפעם האחרונה, ואת הנתונים שלהלן:
    • מספר ההפעלות שהופעלו, מספר ההפעלות שנותקו אוטומטית ומספר ההפעלות שנותקו בעקבות שגיאה.
    • מספר הקילו-בתים שנשלחו והתקבלו וזמן התגובה הממוצע של השרת.
    • מספר השגיאות וההפרות של מגבלות סיסמה ושל מגבלות הרשאה.
    • מספר הפעמים שבהן נעשה שימוש בקבצים, במדפסות ובהתקני תקשורת משותפים.
    • מספר הפעמים שבהן אירעה חריגה ממאגר הזיכרון.

דוגמאות

להצגת סטטיסטיקה עבור שירות Server ומניעת גלילה של תצוגת הפלט, הקלד:

net statistics server | more


Net stop

עצירת שירות פועל.

תחביר

net stop service

פרמטרים

service
עצירת השירות שצוין. בטבלה שלהלן מוצגים ערכים אפשריים עבור service.
ערך | תיאור | הערות
alerter עצירת שירות Alerter.
  • עצירת שירות Alerter, השולח הודעות התראה למשתמשים שצוינו, המחוברים לשרת. הודעות התראה מתריעות בפני משתמשים על בעיות אבטחה, בעיות גישה ובעיות של הפעלת משתמש.
  • השתמש ב- Server Manager (כלומר, systemroot\System32\Srvmgr.exe) כדי לציין את חברי הקבוצה Administrators שברצונך שיקבלו התראות ניהוליות. Server Manager זמין רק במחשבים שהותקן בהם Windows 2000 Server.
  • הודעות התראה נשלחות כהודעות מן השרת למחשב המשתמש. כדי שתהיה למשתמש אפשרות לקבל את הודעות ההתראה יש להפעיל במחשב של המשתמש את שירות Messenger.
browser עצירת שירות Computer Browser.
  • שירות Computer Browser שומר רשימה מעודכנת של מחשבים ברשת ומספק רשימה זו לתוכניות הזקוקות לה.
‎"client service for netware"‎ עצירת שירות Client Service for NetWare.
  • פקודה זו זמינה רק לאחר התקנת Client Service for NetWare.
clipbook עצירת שירות ClipBook (ספר-לוח).
  • ספר-לוח מאפשר גזירה והדבקה של טקסט ותמונות ברחבי הרשת.
  • שירות ספר-לוח תומך בשירות תצוגת ספר-לוח (ClipBook Viewer), המאפשר הצגת דפים בספרי-לוח מרוחקים.
dhcp client לא ניתן לעצור או להשהות את הפעולה של שירות DHCP Client.
  • שירות DHCP Client מנהל תצורת רשת על-ידי רישום ועדכון של כתובות IP ושמות DNS. שירות DHCP Client תומך בהשגת כתובת IP משירות DHCP.
file replication | עצירה של שירות File Replication (שכפול קבצים).
messenger עצירת שירות Messenger.
  • שירות Messenger מאפשר למחשב לקבל הודעות.
  • הודעה נשלחת למחשב תוך שימוש בשמות שהוקצו למחשב לצורך זיהוי.
netlogon עצירת שירות Net Logon (כניסה לרשת).
  • שירות Net Logon מאמת בקשות כניסה ושולט בשיכפולי מסד נתונים של חשבונות משתמש בכל קבוצת המחשבים.
  • עצור את שירות Net Logon בכל השרתים בקבוצת מחשבים העושים שימוש בעותק של מסד הנתונים עבור חשבונות משתמש של קבוצת המחשבים.
‎"nt lm security support provider"‎ עצירת שירות NT LM Security Support Provider.
  • פקודה זו זמינה רק לאחר התקנת NT LM Security Support Provider.
‎"remote access connection manager"‎ עצירת שירות Remote Access Connection Manager.
  • פקודה זו זמינה רק לאחר התקנת Remote Access Service (שירות גישה מרחוק).
‎"routing and remote access"‎ | עצירת שירות Routing and Remote Access (ניתוב וגישה מרחוק).
rpclocator עצירת שירות Locator של Remote Procedure Call‏ (RPC).
  • מאפשר ליישומים מבוזרים להשתמש בשירות שמות RPC של Microsoft.
  • שירות Locator של Remote Procedure Call‏ (RPC) הוא שירות שמות RPC עבור Windows XP. ‏RPC Locator מנהל את מסד הנתונים של שירות שמות RPC.
  • צד השרת של היישום המבוזר מבצע רישום של זמינותו באמצעות שירות RPC Locator. צד הלקוח של היישום המבוזר מבצע שאילתה על שירות Locator כדי למצוא יישומי שרת תואמים זמינים.
schedule עצירת שירות Task Scheduler (מתזמן המשימות).
  • מתזמן המשימות מאפשר להפעיל תוכניות במועד שצוין באמצעות הפקודה at. ייתכן שיהיה צורך בשירותים פועלים אחרים לשם הפעלה של פקודות מתוזמנות.
  • תצורתו של שירות מתזמן המשימות נקבעת מראש לפעולה בחשבון System שבמחשב המקומי. בעת פעולה באמצעות חשבון זה, אין כל הגבלה על המשימות שניתן להפעיל באמצעות מתזמן המשימות. עם זאת, אפשרות הגישה לרשת של משימות אלה תהיה מוגבלת, משום שמחשבים אחרים אינם מזהים את חשבון System של המחשב המקומי.
  • כדי להתגבר על מגבלות הגישה לרשת, באפשרותך לקבוע את תצורתו של מתזמן המשימות לפעולה תחת חשבון משתמש. אם תעשה זאת, משימות שיתבצעו באמצעות מתזמן המשימות יפעלו באמצעות הגישה לרשת של חשבון המשתמש. עם זאת, מכיוון שבמקרה זה אין מתזמן המשימות משתמש בחשבון System של המחשב המקומי, יהיה באפשרותך להפעיל רק משימות שאינן מחייבות נוכחות של חלון.
server עצירת שירות Server.
  • באפשרותך להשתמש בשירות Server כדי לבצע שיתוף של משאבי שרת עם משתמשים ברשת.
spooler עצירת שירות Print Spooler.
  • שירות Print Spooler טוען קבצים לזיכרון עבור הדפסה שלהם (הדפסה ברקע).
‎"tcp/ip netbios helper"‎ עצירה של שירות NetBIOS Helper Over TCP, המאפשר שירותי NetBIOS באמצעות TCP/IP ‏(NetBT).
  • שירותי NetBT מספקים יחידות נתונים של NetBIOS, הפעלות NetBIOS וניהול של שמות NetBIOS (כגון רישום ופענוח שמות) עבור יישומי NetBIOS העושים שימוש בפרוטוקול TCP/IP.
  • פקודה זו זמינה רק לאחר התקנה של הפרוטוקול Internet Protocol ‏(TCP/IP) כרכיב במאפיינים של מתאם רשת ביישום חיבורי רשת.
ups עצירת שירות אל-פסק (Uninterruptible Power Supply, ‏UPS).
  • שירות אל-פסק מנהל יחידה למניעת נפילות כוח (UPS) המחוברת למחשב.
  • באפשרותך לקבוע את תצורתו של שירות אל-פסק (Uninterruptible Power Supply) באמצעות אפשרויות צריכת חשמל שבלוח הבקרה. אם תקבע את תצורתו של השירות לביצוע קובץ פקודה עם הכיבוי, על קובץ הפקודה לסיים את פעולתו בתוך 30 שניות. זמן פעולה העולה על 30 שניות עשוי לפגום באפשרות לביצוע תקין של כיבוי המחשב.
workstation עצירת שירות Workstation.
  • שירות Workstation מאפשר למחשב להתחבר למשאבי רשת ולהשתמש בהם.
net help command
הצגת עזרה עבור פקודת net שצוינה.

הערות

  • ערכת השירותים והיישומים שתוצג בפניך עשויה להשתנות בהתאם לאפשרויות שבחרת במהלך ההתקנה או קביעת התצורה.

  • לקבלת מידע נוסף אודות שירותים, ראה Microsoft Windows Resource Kits.

  • שירותים מסוימים תלויים בשירותים אחרים.
  • השתמש בפקודה net stop כדי לעצור שירות ולהסיר את התוכנה מן הזיכרון.
  • עצירה של שירות Server מונעת ממשתמשים גישה למשאבים המשותפים של המחשב. אם תעצור את שירות Server כאשר משתמשים עודם עושים שימוש במשאבי שרת, תוצג הודעת אזהרה. אם תשיב y ‏(עבור yes), יבוטלו כל ההתקשרויות למחשב. לפני עצירה של שירות Server, בצע את הפעולות הבאות:
  • השתמש בפקודה net pause כדי להשהות את השירות, פעולה המונעת התקשרויות חדשות.
  • השתמש בפקודה net send כדי לשלוח למשתמשים הודעה המציינת כי עליהם להתנתק ממשאבי השרת.
  • אם שם שירות מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Service Name").
  • ניתן להשתמש בפקודה net stop גם כדי לעצור שירותים שאינם כלולים ב- Windows XP.

דוגמאות

הפקודה שלהלן עוצרת את שירות Server:

net stop server

תחום במרכאות שמות שירותים בני שתי מילים או יותר. לדוגמה, הפקודה שלהלן עוצרת את שירות Client Service for Netware:

net stop "client service for netware"‎


פקודות של שירותי רשת, Net Services

לקבלת מידע נוסף, לחץ על פקודה:

  • Ne Accounts
  • Net Computer
  • Net Config
  • Net Continue
  • Net File
  • Net Group
  • Net Help
  • Net Helpmsg
  • Net Localgroup
  • Net Name
  • Net Pause
  • Net Print
  • Net Send
  • Net Session
  • Net Share
  • Net Start
  • Net Statistics
  • Net Stop
  • Net Time
  • Net Use
  • Net User
  • Net View


Net time

סינכרון שעון המחשב עם שעון של מחשב אחר או של קבוצת מחשבים אחרת. ללא פרמטרים, שימוש בפקודה net time יביא להצגת השעה עבור מחשב אחר או קבוצת מחשבים אחרת.

תחביר

net time [{\\ComputerName | /domain[:DomainName] | /rtsdomain[:DomainName]}] [/set]‎

net time [\\ComputerName] [/querysntp] [/setsntp[:NTPServerList]]‎

פרמטרים

‎\\ComputerName
ציון שם שרת שברצונך לבדוק או שברצונך לבצע סינכרון עמו.
‎/domain[:DomainName]‎
ציון קבוצת המחשבים שברצונך לבצע סינכרון שעונים איתה.
‎/rtsdomain[:DomainName]‎
ציון קבוצת המחשבים של שרת הזמן האמין (Reliable Time Server) שבאמצעותו יבוצע סינכרון זמן.
‎/set
סינכרון שעון המחשב עם השעה במחשב או בקבוצת המחשבים שצוינו.
‎/querysntp
הצגת שם שרת Network Time Protocol‏ (NTP) המוגדר כעת עבור המחשב המקומי או עבור המחשב שצוין בפרמטר ComputerName.
‎/setsntp[:NTPServerList]‎
ציון רשימת שרתי זמן מסוג NTP שהוגדרו לשימוש עבור המחשב המקומי. הרשימה עשויה להכיל כתובות IP או שמות DNS, מופרדים באמצעות רווחים. אם נעשה שימוש בשרתי זמן מרובים, יש לתחום את הרשימה במרכאות.
net help command
הצגת עזרה עבור פקודת net שצוינה.


Net use

חיבור או ניתוק של מחשב ממשאב משותף, או הצגת מידע אודות התקשרויות של המחשב. הפקודה שולטת גם בהתקשרויות רשת מתמשכות. שימוש בפקודה net use ללא פרמטרים יביא לאחזור רשימה של התקשרויות רשת.

תחביר

net use ‎[{DeviceName | *}]‎ ‎[\\ComputerName\ShareName[\volume]] [{Password | *}]]‎ ‎[/user:[DomainName\]UserName]‎ ‎[/user:[DottedDomainName\]UserName]‎ ‎[/user: [UserName@DottedDomainName]‎ ‎[/savecred]‎ ‎[/smartcard]‎ ‎[{/delete | /persistent:{yes | no}}]‎

net use [DeviceName ‎[/home[{Password | *}]‎ ‎[/delete:{yes | no}]]‎

net use ‎[/persistent:{yes | no}]‎

פרמטרים

DeviceName
הקצאת שם עבור חיבור למשאב או ציון ההתקן שינותק. קיימים שני סוגים של שמות התקנים: כונני דיסקים (D:‎ עד Z:‎) ומדפסות (LPT1:‎ עד LPT3:‎). הקלד כוכבית (*) במקום שם התקן מסוים כדי להקצות את שם ההתקן הזמין הבא.
‎\\ComputerName\ShareName
ציון שם השרת ושם המשאב המשותף. אם ComputerName מכיל רווחים, תחום במרכאות את שם המחשב כולו, החל בשני הקווים הנטויים ההפוכים (\\) וכלה בסוף שם המחשב (לדוגמה, "‎\\Computer Name\Share Name"). אורך שם המחשב עשוי להיות בין תו אחד ל- 15 תווים.
‎\volume
ציון אמצעי אחסון מסוג NetWare בשרת. כדי להתחבר לשרתי NetWare, ראשית יש להתקין ולהפעיל את Client Service for NetWare .
Password
ציון הסיסמה הנדרשת עבור גישה למשאב המשותף. הקלד כוכבית (*) כדי שתוצג בקשה להזנת סיסמה. סיסמה אינה מוצגת בעת הקלדתה בשורת סיסמה.
‎/user
ציון שם משתמש אחר שבאמצעותו תבוצע ההתקשרות.
DomainName
ציון קבוצת מחשבים אחרת. אם לא תציין את הפרמטר DomainName, הפקודה net use תעשה שימוש בקבוצת המחשבים שאליה ביצעת כניסה.
UserName
ציון שם המשתמש שישמש עבור כניסה.
DottedDomainName
ציון שם מלא של קבוצת מחשבים עבור קבוצת המחשבים שבה קיים חשבון המשתמש.
‎/savecred
אחסון עבור שימוש חוזר של האישורים שסופקו.
‎/smartcard
מציין כי על התקשרות הרשת לעשות שימוש באישורים שבכרטיס חכם. אם ברשותך כמה כרטיסים חכמים, תתבקש לציין את האישור שברצונך להשתמש בו.
‎/delete
ביטול התקשרות הרשת שצוינה. ציון ההתקשרות בכוכבית (*) יביא לביטול של כל התקשרויות הרשת.
‎/persistent:{yes | no}‎
שליטה באופן השימוש בהתקשרויות רשת מתמשכות. ברירת המחדל היא ההגדרה האחרונה שהיתה בשימוש. התקשרויות ללא התקן אינן מתמשכות. שימוש בפרמטר yes מביא לשמירת כל ההתקשרויות כפי שבוצעו, ולשיחזורן בכניסה הבאה. שימוש בפרמטר no מונע שמירה של ההתקשרות שבוצעה ושל ההתקשרויות שבוצעו אחריה. השתמש בפרמטר ‎/delete כדי למחוק התקשרויות מתמשכות.
‎/home
חיבור משתמש לספריה הראשית.
net help command
הצגת עזרה עבור פקודת net שצוינה.

הערות

  • התחברות והתנתקות ממשאב רשת

    השתמש בפקודה net use כדי להתחבר ולהתנתק ממשאב רשת וכדי להציג את ההתקשרויות הנוכחיות שלך למשאבי רשת. לא ניתן להתנתק מספריה משותפת אם היא משמשת ככונן הנוכחי או אם תהליך פעיל עושה בה שימוש.

  • הצגה של מידע התקשרות

    לקבלת מידע אודות התקשרות, באפשרותך לבצע אחת מהפעולות הבאות:

    • הקלד net use DeviceName כדי להציג מידע אודות התקשרות מסוימת.
    • הקלד net use כדי להציג רשימה של כל התקשרויות המחשב.
  • שימוש בהתקשרויות חסרות התקן

    התקשרויות חסרות התקן אינן מתמשכות.

  • התקשרות לשרתי NetWare

    לאחר התקנה והפעלה של Client Service for NetWare, באפשרותך להתחבר לשרת NetWare ברשת Novell. עליך להשתמש בתחביר זהה לזה שתשתמש בו עבור התקשרות לשרת Windows Networking, אך לכלול גם את אמצעי האחסון שברצונך להתחבר אליו.

  • שימוש במרכאות

    אם שם השרת (ServerName) שתספק כולל רווחים, תחום אותו במרכאות (כלומר, "Server Name"). השמטת המרכאות תביא להצגה של הודעת שגיאה.

דוגמאות

כדי להקצות את שם ההתקן של כונן הדיסקים E:‎ לספריה המשותפת Letters שבשרת ‎\\Financial, הקלד:

net use e: \\financial\letters

כדי להקצות (למפות) את שם ההתקן של כונן הדיסקים M:‎ לספריה Mike באמצעי האיחסון Letters שבשרת NetWare ששמו ‎\\Financial, הקלד:

net use m: \\financial\letters\mike

כדי לקשר את מזהה המשתמש Dan כאילו בוצעה ההתקשרות מקבוצת המחשבים Accounts, הקלד:

net use d:\\server\share /user:Accounts\Dan

כדי להתנתק מהספריה ‎\\Financial\Public, הקלד:

net use f: \\financial\public /delete

כדי להתחבר למשאב Memos המשותף בשרת ‎\\Financial 2, הקלד:

net use k: "\\financial 2" \memos

כדי לשחזר את ההתקשרויות הנוכחיות בכל כניסה, בלי תלות בשינויים עתידיים, הקלד:

net use /persistent:yes


Net user

הוספה, שינוי והצגת מידע אודות חשבונות משתמש.

תחביר

net user [UserName [Password | *] [options]] [/domain]‎

net user [UserName {Password | *} /add [options] [/domain]]‎

net user [UserName [/delete] [/domain]]‎

פרמטרים

UserName
ציון שם חשבון המשתמש שיש להוסיף, למחוק, לשנות או להציג. אורכו המירבי של שם חשבון משתמש הוא 20 תווים.
סיסמה
הקצאה או שינוי של סיסמה עבור חשבון המשתמש. הקלד כוכבית (*) כדי שתתקבל בקשה להזנת סיסמה. הסיסמה אינה מוצגת בעת הקלדתה בשורת הסיסמה.
‎/domain
ביצוע הפעולה בבקר קבוצת המחשבים של קבוצת המחשבים הראשית של המחשב.
options
ציון אפשרות של שורת פקודה. הטבלה הבאה מפרטת אפשרויות חוקיות של שורת פקודה שבאפשרותך להשתמש בהן.
תחביר אפשרות של שורת פקודה | תיאור
‎/active:{no | yes}‎ | הפעלה של חשבון המשתמש או ציון של אי-פעילותו. אם חשבון המשתמש אינו פעיל, אין למשתמש אפשרות לבצע גישה למשאבים במחשב. ברירת המחדל היא yes (כלומר, פעיל).
‎/comment:"text"‎ | מתן הערה תיאורית אודות חשבון משתמש. אורכה המירבי של הערה זו הוא 48 תווים. את הטקסט יש לתחום במרכאות.
‎/countrycode:nnn | שימוש בקודים עבור מדינה/אזור של מערכת ההפעלה כדי ליישם את קבצי השפה שצוינו עבור הודעות עזרה והודעות שגיאה של משתמש. הערך 0 מציין את הקוד המשמש כברירת מחדל עבור מדינה/אזור.
‎/expires:‎{{mm/dd/yyyy | dd/mm/yyyy | mmm,dd ,yyyy} | never}‎ | שימוש באפשרות זו מביא לפקיעת התוקף של חשבון המשתמש אם צוין תאריך (date). תאריכי תפוגה עשויים להופיע בתבנית ‎[mm/dd/yyyy]‎ ,בתבנית ‎[dd/mm/yyyy]‎ או בתבנית ‎[mmm,dd ,yyyy]‎ בהתאם לקוד המדינה/אזור. שים לב כי תוקף החשבון פג בתחילת התאריך שצוין. עבור ערך החודש, באפשרותך להשתמש במספרים, לכתוב את השם בצורה מלאה או להשתמש בקיצור בן שלוש אותיות (כלומר, Jan,‏ Feb,‏ Mar,‏ Apr,‏ May,‏ Jun,‏ Jul,‏ Aug,‏ Sep,‏ Oct,‏ Nov,‏ Dec). באפשרותך להשתמש בשתיים או בארבע ספרות עבור ערך השנה. השתמש בפסיקים או בקווים נטויים כדי להפריד בין מרכיבי התאריך. אין להשתמש ברווחים. אם תשמיט את yyyy, תוקף החשבון יפוג בפעם הבאה שיחול התאריך שצוין (בהתאם לתאריך ולשעה במחשב שלך). לדוגמה, הערכים הבאים שקולים זה לזה אם הוזנו בין העשרה בינואר 1994 לשמונה בינואר 1995: jan,9 1/9/95 january,9,1995 1/9
‎/fullname:"name"‎ | ציון שם מלא של משתמש במקום שם משתמש. את השם המלא יש לתחום במרכאות.
‎/homedir:path | הגדרת הנתיב לספריה הראשית של המשתמש. יש לציין נתיב קיים.
‎/passwordchg:{yes | no}‎ | קביעה אם יש למשתמשים אפשרות לשנות את הסיסמה שלהם. ברירת המחדל היא yes.
‎/passwordreq:{yes | no}‎ | קביעה אם חשבון משתמש מחויב בסיסמה. ברירת המחדל היא yes.
‎/profilepath:[Path]‎ | קביעת נתיב עבור פרופיל הכניסה של משתמש. על נתיב זה להצביע אל פרופיל רישום.
‎/scriptpath:Path | קביעת נתיב לקובץ Script המשמש עבור כניסת משתמש למחשב. אין להגדיר נתיב מוחלט עבור Path. הנתיב שיוגדר עבור Path יחסי ל- ‎%systemroot%\System32\Repl\Import\Scripts.
‎/times:{day[-day][,day[-day]] ,time[-time][,time[-time]] [;…] | all}‎ | ציון השעות שבהן מותר למשתמשים להשתמש במחשב. Time מוגבל לרווחים של שעה אחת. עבור ערכי day, באפשרותך להזין את השם המלא או להשתמש בקיצורים (כלומר, M,‏T,‏W,‏Th,‏F,‏Sa,‏Su). באפשרותך להשתמש בסימון של 12 שעות או 24 שעות. אם תשתמש בסימון של 12 שעות, ציין גם AM ו- PM או A.M.‎ ו- P.M.‎. משמעות הערך all היא שלמשתמש יש אפשרות להיכנס למערכת בכל עת. משמעות של ערך ריק היא שלמשתמש לעולם לא תהיה אפשרות לבצע כניסה. הפרד יום ושעה באמצעות פסיקים ויחידות של יום ושעה באמצעות נקודה-פסיק (לדוגמה, M,4AM-5PM;T,1PM-3PM). אל תשתמש ברווחים בעת ציון שעות.
‎/usercomment:"text"‎ | קביעה כי לחבר בקבוצה Administrators יש אפשרות להוסיף או לשנות את הערת המשתמש עבור החשבון. תחום את טקסט ההערה במרכאות.
‎/workstations:{ComputerName[,...] | *}‎ | פירוט של עד שמונה תחנות עבודה שמהן תהיה למשתמש אפשרות להיכנס לרשת. הפרד ערכים ברשימה באמצעות פסיקים. אם לא נקבעה רשימה עבור ‎/workstations או שהרשימה היא כוכבית (*), יש למשתמש אפשרות להיכנס לרשת מכל מחשב.
net help command
הצגת עזרה עבור פקודת net שצוינה.

הערות

  • שימוש בפקודה net user ללא פרמטרים גורם להצגת רשימה של חשבונות המשתמש במחשב. באפשרותך גם להקליד net users.
  • אורך הסיסמה צריך להתאים לדרישת האורך המינימלי שנקבעה באמצעות הפקודה net accounts /minpwlen. הסיסמה יכולה להכיל עד 127 תווים. עם זאת, אם אתה משתמש ב- Windows 2000 או ב- Windows XP ברשת הכוללת גם מחשבים שפועלים בהם Windows 95 או Windows 98, ייתכן שיהיה שרצונך להשתמש בסיסמאות שאינן מכילות יותר מ- 14 תווים. Windows 95 ו- Windows 98 תומכים בסיסמאות שאורכן עד 14 תווים. אם הסיסמה שלך ארוכה יותר, ייתכן שלא יהיה באפשרותך לבצע כניסה לרשת ממחשבים אלה.

דוגמאות

כדי להציג רשימה של כל חשבונות המשתמש עבור המחשב המקומי, הקלד:

net user

כדי להציג מידע אודות חשבון המשתמש jimmyh, הקלד:

net user jimmyh

כדי להוסיף חשבון משתמש עבור Jay Jamison הכולל זכויות כניסה מ- 8 לפנה"צ עד 5 אחה"צ בימים שני עד שישי (ללא רווחים בציון ערכי הזמן המיועדים), חובת שימוש בסיסמה (jayj) ואת שמו המלא של המשתמש, הקלד:

net user jayj /add /passwordreq:yes /times:monday-friday,8am-5pm/fullname:"Jay Jamison"‎

כדי לקבוע את מועדי הכניסה של johnsw ‏(8 לפנה"צ עד 5 אחה"צ) תוך שימוש בתבנית של 24 שעות, הקלד:

net user johnsw /time:M-F,08:00-17:00

כדי לקבוע את מועדי הכניסה של johnsw ‏(8 לפנה"צ עד 5 אחה"צ) תוך שימוש בתבנית של 12 שעות, הקלד:

net user johnsw /time:M-F,8am-5pm

כדי להגדיר מועדי כניסה בשעות 4 לפנה"צ עד 5 אחה"צ ביום שני, 1 אחה"צ עד 3 אחה"צ ביום שלישי ו- 8 לפנה"צ עד 5 אחה"צ בימים רביעי עד שישי עבור המשתמש marysl, הקלד:

net user marysl /time:M,4am-5pm;T,1pm-3pm;W-F,8:00-17:00


Net view

הצגת רשימה של קבוצות מחשבים, מחשבים או משאבים שמתבצע שיתוף שלהם במחשב שצוין. הפקודה net view ללא פרמטרים מציגה רשימה של מחשבים בקבוצת המחשבים הנוכחית שלך.

תחביר

net view [\\ComputerName] [/domain[:DomainName]]‎

net view /network:nw [\\ComputerName]‎

פרמטרים

‎\\ComputerName
ציון המחשב המכיל את המשאבים המשותפים שברצונך להציג.
‎/domain[:DomainName]‎
ציון קבוצת המחשבים שאת המחשבים הזמינים עבורה ברצונך להציג. אם לא תציין ערך עבור DomainName, שימוש בבורר ‎/domain יביא להצגת כל קבוצות המחשבים ברשת.
‎/network:nw
הצגת כל השרתים הזמינים ברשת NetWare. אם תציין שם מחשב, שימוש בבורר ‎/network:nw יביא להצגת המשאבים הזמינים במחשב זה ברשת NetWare. באפשרותך גם לציין רשתות אחרות המתווספות למערכת.
net help command
הצגת עזרה עבור פקודת net שצוינה.

הערות

  • השתמש בפקודה net view כדי להציג רשימת מחשבים. הפלט דומה לתצוגה הבאה:

    Server Name           Remark

    -------------------------------------------------

    ‎\\Production          Production file server

    ‎\\Print1              Printer room, first floor

    ‎\\Print2              Printer room, second floor

דוגמאות

כדי להציג רשימה של משאבים משותפים במחשב ‎\\Production, הקלד:

net view \\production

כדי להציג משאבים זמינים בשרת ‎\\Marketing של NetWare, הקלד:

net view /network:nw \\marketing

כדי להציג את רשימת המחשבים שבקבוצת המחשבים או קבוצת העבודה sales, הקלד:

net view /domain:sales

כדי להציג את כל השרתים ברשת NetWare, הקלד:

net view /network:nw


פקודות Netsh עבור AAAA

באפשרותך לעשות שימוש בפקודות של הקשר Netsh AAAA להצגה ולקביעת תצורה עבור אימות, מתן הרשאות, חשבונאות, וביצוע ביקורת על מסדי נתונים (Authentication, Authorization, Accounting and Auditing - ‏AAAA) ששירות אימות באינטרנט (IAS) ושירות ניתוב וגישה מרחוק עושים בהם שימוש. מסד הנתונים AAAA מוכר גם כמסד נתוני IAS ‏(Ias.mdb). השימוש העיקרי של פקודות בהקשר AAAA של Netsh הוא ייצוא תצורתו של שרת IAS אחד כקובץ Script של Netsh ולאחר מכן ייבוא של תצורה זו באמצעות הפקודה netsh exec אל שרת IAS אחר.

אין באפשרותך להפעיל פקודות Netsh אלה באופן מקומי ב-Windows XP Professional או ב- Windows XP Home Edition. כדי להפעיל פקודות Netsh אלה ב-Windows 2000 Server מרוחק, עליך להשתמש תחילה בחיבור לשולחן עבודה מרוחק (Remote Desktop Connection) כדי להתחבר לשרת Windows 2000 שבו פועל Terminal Server. באפשרותך להפעיל פקודות אלה משורת הפקודה של Windows 2000 או משורת הפקודה של הקשר AAAA של Netsh. כדי שפקודות אלה יפעלו בשורת הפקודה של Windows 2000, עליך להקליד netsh aaaa לפני הקלדת הפקודות והפרמטרים המוצגים בתחביר שלהלן. ייתכן שיימצאו הבדלים פונקציונליים בין פקודות ההקשר של Netsh ב- Windows 2000 לבין אותן פקודות ב- Windows XP.

לקבלת מידע נוסף אודות Netsh, ראה שימוש ב- Netsh.

להצגת תחביר הפקודה, לחץ על פקודה:

dump

הצגת התצורה של קובץ מסד הנתונים של IAS ‏(Ias.mdb) כמקטע Script הפקודה של Netsh.

תחביר

dump

הערות

  • הפקודה dump מציגה את מקטע Script הפקודה של Netsh שבאפשרותך להשתמש בה לשם שכפול התצורה של שרת שבו מבוצעת פקודה זו ושפועלים בו IAS או שירות ניתוב וגישה מרחוק. מקטע Script הפקודה של Netsh מכיל את התצורה של קובץ מסד הנתונים של IAS ‏(Ias.mdb) בתבנית טקסט דחוסה, כבלוק נתונים גדול. בלוק נתונים זה משמש את הפקודה set config שבמקטע ה- Script כדי לייבא את תצורתו של בלוק נתונים שמור למסד נתונים קיים אחר של IAS, באותו מחשב או במחשב אחר, וזאת באמצעות הפקודה netsh exec. כדי לשמור את מקטע Script הפקודה של Netsh לקובץ, הקלד בשורת הפקודה: netsh aaaa show config > Path\File.txt
  • הפקודה dump אינה זוכה לתמיכה במחשבים שפועל בהם Windows 2000 Server.

show config

הצגת התצורה של קובץ מסד הנתונים של IAS ‏(Ias.mdb) כמקטע Script פקודה של Netsh.

תחביר

show config

הערות

  • הפקודה show config שקולה לפקודה dump.
  • הפקודה show config מציגה את מקטע Script הפקודה של Netsh, שבאפשרותך להשתמש בו לשם שכפול של תצורת השרת שבו מבוצעת הפקודה ושפועל בו IAS או שירות ניתוב וגישה מרחוק. מקטע Script הפקודה של Netsh מכיל את התצורה של קובץ מסד הנתונים של IAS ‏(Ias.mdb) בתבנית טקסט דחוסה כבלוק נתונים גדול. בלוק נתונים זה משמש את הפקודה set config שבמקטע ה- Script כדי לייבא את תצורתו של בלוק נתונים שמור אל מסד נתונים קיים של IAS, באותו מחשב או במחשב אחר, באמצעות הפקודה netsh exec. כדי לשמור את מקטע Script הפקודה של Netsh לקובץ, הקלד בשורת הפקודה: netsh aaaa show config > Path\File.txt
  • הפקודה show config אינה זוכה לתמיכה במחשבים שפועל בהם Windows 2000 Server.

set config

קביעת התצורה של מסד נתוני IAS באמצעות המידע שבבלוק הנתונים שצוין.

תחביר

set config [blob=] DataBlock

פרמטרים

‎[blob=] DataBlock
נדרש. ציון התצורה של מסד נתוני IAS בתבנית טקסט דחוסה כפלט באמצעות הפקודות dump או show config.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • אין סיבה לבצע את הפקודה set config באופן ידני, ויש להשתמש בה רק במקטע Script הפקודה של Netsh, הנוצר באמצעות הפקודות dump או show config.
  • על גירסת מסד הנתונים של IAS שממנה בוצע ייצוא של בלוק הנתונים להתאים לגירסה של מסד הנתונים של IAS שאליו ברצונך לייבא את הבלוק. להצגת הגירסה של מסד נתוני IAS שבו בוצע ייצוא של התצורה, הצג את מקטע Script הפקודה של Netsh. להצגת הגירסה של מסד נתוני IAS שבו יבוצע מקטע ה- Script, השתמש בפקודה show version.

show version

הצגת הגירסה של מסד נתוני IAS.

תחביר

show version

דוגמאות

להצגה של מקטע Script הפקודה של Netsh המשקף את מסד הנתונים IAS במצבו הנוכחי, הקלד:

show config

להצגת הגירסה של מסד נתוני IAS הפועל בשרת, הקלד:

show version


פקודות Netsh עבור DHCP

פקודות Netsh עבור DHCP מציעות כלי שורת פקודה המסייע בניהול שרתי DHCP ומספק חלופה שוות ערך לניהול המבוסס על מסוף. חלופה זו יכולה להועיל במצבים הבאים:

  • בעת ניהול שרתי DHCP ברשתות תקשורת מרחביות (WAN), ניתן להשתמש בפקודות במצב אינטראקטיבי בשורת הפקודה Netsh כדי לשפר את הניהול בקישורי רשת איטיים.
  • בעת ניהול מספר רב של שרתי DHCP, ניתן להשתמש בפקודות במצב אצווה בשורת הפקודה Netsh כדי לסייע בכתיבה ובהפיכה לאוטומטיות של משימות ניהוליות חוזרות ונשנות שיש לבצע עבור כל שרתי DHCP.

הפקודות הבאות זמינות בשורת הפקודה Netsh (להבדיל משורת הפקודה Windows XP). אין באפשרותך להפעיל פקודות Netsh אלה באופן מקומי ב- Windows XP Professional או ב- Windows XP Home Edition. להפעלת פקודות Netsh אלה ב- Windows 2000 Server מרוחק, עליך להשתמש תחילה בחיבור לשולחן עבודה מרוחק כדי להתחבר ל- Windows 2000 Server בו פועל Terminal Server. ייתכנו הבדלים פונקציונליים בין פקודות בהקשר Netsh ב- Windows 2000 לבין Windows XP. לקבלת מידע נוסף אודות אופן השימוש בפקודות Netsh הניתנות עבור DHCP, ראה שימוש בכלי שורת הפקודה של DHCP.

לקבלת דוגמה על אופן השימוש בפקודות Netsh עבור DHCP בקבצי אצווה ובקבצי Script, ראה דוגמת Netsh DHCP.

לקבלת מידע נוסף אודות פקודות Netsh, ראה כלי שורת הפקודה Netsh.

לקבלת מידע נוסף אודות netsh, ראה שימוש ב- Netsh.

Netsh DHCP

הפקודות הבאות זמינות בשורת הפקודה dhcp>‎, שבסיסה נמצא בסביבת netsh.

להצגת תחביר הפקודה, לחץ על פקודה:

add server

הוספת שרת DHCP לרשימת השרתים המורשים ב- Active Directory.

תחביר

add server ServerDNS ServerIP

פרמטרים

ServerDNS
נדרש. קביעת שרת DHCP שיש להוסיף. זיהוי השרת לפי שם קבוצת מחשבים של DNS.
ServerIP
נדרש. קביעת שרת DHCP שיש להוסיף. זיהוי השרת לפי כתובת IP.

דוגמאות

בדוגמה הבאה, פקודה זו מוסיפה שרת בעל שם ה- DNS ‏dhcpsrv1.example.microsoft.com וכתובת ה- IP ‏10.2.2.2 לרשימת השרתים המורשים ב- Active Directory.

add server dhcpsrv1.example.microsoft.com 10.2.2.2

delete server

מחיקת שרת DHCP מרשימת השרתים המורשים ב- Active Directory.

תחביר

delete server ServerDNS ServerIP

פרמטרים

ServerDNS
נדרש. קביעת שרת DHCP שיש למחוק. זיהוי השרת לפי שם קבוצת מחשבים DNS.
ServerIP
נדרש. קביעת שרת DHCP שיש למחוק. זיהוי השרת לפי כתובת IP.

דוגמאות

בדוגמה הבאה, פקודה זו מוחקת את השרת בעל שם ה- DNS ‏dhcpsrv1.example.microsoft.com וכתובת ה- IP ‏10.2.2.2 מרשימת השרתים המורשים ב- Active Directory.

delete server dhcpsrv1.example.microsoft.com 10.2.2.2

dump

יצירת קובץ Dump של תצורה של שרת DHCP לחלון שורת הפקודה או לקובץ טקסט. ללא פרמטרים, פקודה זו יוצרת קובץ Dump של תצורת השרת המקומי לחלון שורת הפקודה.

תחביר

‎[{\\ServerName | IPAddress}]‎ dump >‎ [FileName]

פרמטרים

[{‎\\ServerName | IPAddress}]
קביעת שם שרת DHCP המרוחק (לא מקומי) ממנו ברצונך ליצור קובץ Dump של תצורת פלט. זיהוי השרת לפי שם או כתובת IP. אם לא צוין פרמטר, נוצר קובץ Dump של תצורת השרת המקומי.
FileName
קביעת שם קובץ היעד בו ברצונך ליצור קובץDump של תצורת שרת DHCP. אם לא צוין פרמטר, נוצר קובץ Dumpשל תצורת שרת DHCP לחלון שורת הפקודה.

הערות

  • פקודה זו יוצרת קובץ Dump של תצורת DHCP כפלט טקסט בחלון שורת הפקודה. לחלופין, באפשרותך להעתיק או לנתב מחדש פלט זה לקובץ לשם צפייה במועד מאוחר יותר בעורך טקסט. בעת קבלת פלט קובץ, באפשרותך להשתמש בפקודה exec כדי להפעיל את קובץ הפלט לשם הגדרת שרת DHCP אחר.
  • לפני ביצוע הפקודה Dump בשרת המקור, יש לפשר בין כל הטווחים ולתקן כל אירוע מדווח של חוסר עקביות.
  • הפקודה הבאה יוצרת קובץ Dump של התצורה הנוכחית של שרת DHCP המקומי (המקור) לקובץ טקסט בשם dhcpcfg.dmp. ניתן להעתיק קובץ זה לשרת DHCP חדש (היעד) ולהשתמש בו ליצירה מחדש של תצורת המקור בשרת היעד:

    dump > dhcpcfg.dmp

  • לפני השימוש בפקודה exec כדי להפעיל קובץ dump בשרת היעד, בצע אחת מהפעולות הבאות:
    1. סגור את מסוף ה- DHCP בשרת היעד. אל תפתח מחדש את המסוף אלא לאחר שהשתמשת בפקודה exec.
    2. מחק את כל ההגדרות של אפשרויות ברירת המחדל וכל מחלקה של משתמש וספק בשרת היעד.
  • דוגמאות אלה מציגות את אופן השימוש בפקודות Netsh בשם delete optiondef ו- del class לשם מחיקת כל הגדרות האפשרויות המשמשות כברירת המחדל וכל מחלקות המשתמשים והספקים. באפשרותך להפעיל את הפקודות הבאות בשורת הפקודה dhcp server>‎, אשר מבוססת על סביבת netsh.
    • delete optiondef 01
    • delete optiondef 76
    • del class "Default Routing and Remote Access Class"‎
    • del class "Default BOOTP Class"‎
    • del class "Microsoft Windows 2000 Options"‎
    • del class "Microsoft Windows 98 Options"‎
    • del class "Microsoft Options"‎
  • בשרת היעד, הפקודה exec משמשת לטעינה ולהפעלה של תצורה שנשמרה:

    netsh exec dhcpcfg.dmp

  • לאחר שימוש בפקודה exec לטעינת קובץ Dump, יש לפשר שוב בין כל הטווחים. השתמש ב- net stop dhcpserver להפסקת השירות DHCP Server וב- net start dhcpserver לשם הפעלתו מחדש. לאחר שהשירות מופעל שוב, השינויים במסד הנתונים DHCP נכנסים לתוקף.

דוגמאות

בדוגמה הראשונה, פקודה זו יוצרת קובץ Dump של תצורת שרת DHCP הבאה: ‎\\DHCP-A, לקובץ טקסט בשם dhcpcfg.dmp.

בדוגמה השניה, פקודה זו יוצרת קובץ Dump שלח תצורת שרת DHCP הבאה: 10.0.0.1, לקובץ טקסט בשם dhcpcfg.dmp.

בדוגמה השלישית, פקודה זו יוצרת קובץ Dump של תצורת שרת DHCP המקומי לקובץ טקסט בשם dhcpcfg.dmp.

‎\\DHCP-A dump > dhcpcfg.dmp

‎10.0.0.1 dump > dhcpcfg.dmp

dump > dhcpcfg.dmp

server

העברת הקשר שורת הפקודה Netsh DHCP הנוכחי לשרת DHCP אחר. ללא פרמטרים, server מעביר את הקשר שורת הפקודה הנוכחי למחשב המקומי.

תחביר

server [{\\ServerName | ServerIP}]‎

פרמטרים

‎{\\ServerName | ServerIP}‎
קביעת שרת ה- DHCP אליו ברצונך להעביר את הקשר שורת הפקודה הנוכחי. זיהוי השרת לפי שם NetBIOS או כתובת IP.

דוגמאות

בדוגמה הראשונה, פקודה זו משנה את הקשר שורת הפקודה Netsh DHCP לשרת DHCP בשם ‎\\DHCP-SRV1.

בדוגמה השניה, פקודה זו משנה את הקשר שורת הפקודה Netsh DHCP לשרת ה- DHCP בעל כתובת ה- IP‏ 10.0.0.1.

server \\DHCP-SRV1

server 10.0.0.1

show server

הצגת רשימה של שרתים מורשים ב- Active Directory.

תחביר

show server

פרמטרים

ללא

שרת Netsh DHCP

הפקודות הבאות זמינות בשורת הפקודה dhcp server>‎, שבסיסה נמצא בסביבת netsh.

להצגת תחביר הפקודה, לחץ על פקודה:

add class

הוספת מחלקה לשרת ה- DHCP שצוין.

תחביר

add class ClassName [ClassComment] [Data] [[IsVendor=]{0 | 1}] [[IsBinary=]{B | b}]‎

פרמטרים

ClassName
נדרש. קביעת שם המחלקה שיש ליצור.
ClassComment
קביעת ההערה שיש לשייך למחלקה.
Data
קביעת נתוני המחלקה ב- ASCII או בתבנית בינארית בהתאם לפרמטר IsBinary. אם לא צוין פרמטר, מתקיימת ההנחה כי תבנית הנתונים היא ASCII.
‎[IsVendor=]{0 | 1}‎
קביעה אם המחלקה שיש להוסיף היא מחלקת משתמש או מחלקת ספק: 0-מחלקת משתמש (ברירת מחדל), 1-מחלקת ספק.
‎[IsBinary=]{B | b}‎
קביעה אם מחלקת הנתונים היא בתבנית בינארית. אם לא צוין פרמטר, מתקיימת ההנחה כי תבנית הנתונים היא ASCII.

דוגמאות

בדוגמה הראשונה, פקודה זו יוצרת מחלקת ספק בשם MyClass, עם ההערה TestClass ומחלקת נתונים TestDataForMyClass בתבנית ASCII.

בדוגמה השניה, פקודה זו יוצרת מחלקת משתמש בשם MyUserClass עם נתונים בינאריים של 4345335532 (ASCII-CE3U2).

הדוגמה השלישית היא תחביר פקודה חלופי עבור הדוגמה השניה.

add class MyClass TestClass TestDataForMyClass 1

add class MyUserClass TestClass1 4345335532 B

add class MyUserClass TestClass1 4345335532 0 b

add mscope

הוספת טווח שידור לקבוצה לשרת ה- DHCP שצוין.

תחביר

add mscope MscopeName [MscopeComment] [TTL]‎

פרמטרים

MscopeName
נדרש. קביעת השם של טווח השידור לקבוצה שיש להוסיף.
MscopeComment
קביעת תיאור של טווח השידור לקבוצה הנוכחי.
TTL
קביעת הערך Time-To-Live עבור טווח השידור לקבוצה. הטווח החוקי עבור שדה זה הוא מ- 1 עד 255 וברירת המחדל היא 32.

דוגמאות

בדוגמה הבאה, פקודה זו יוצרת טווח לשידור לקבוצה עם השם My MultiCast Scope, הערת MyTestMulticastScope וערך TTL לשידור לקבוצה של 40.

add mscope "My MultiCast Scope" MyTestMulticastScope 40

add optiondef

הוספת הגדרה לסוג חדש של אפשרות לשרת ה- DHCP שצוין.

תחביר

add optiondef OptCode OptName {BYTE | WORD | DWORD | STRING | IPADDRESS} ‎[[IsArray=]{0 | 1}]‎ [vendor=VendorClass] [comment=OptComment] [DefValue]

פרמטרים

OptCode
נדרש. קביעת סוג האפשרות שיש להגדיר. זיהוי סוג האפשרות באמצעות קוד אפשרות ייחודי. עבור ערך הקוד, בחר מספר בין 0 לבין 255.
OptName
נדרש. קביעת השם של סוג האפשרות.
{BYTE | WORD | DWORD | STRING | IPADDRESS}
נדרש. קביעת סוג הנתונים של האפשרות.
‎[IsArray=]{0 | 1}‎
מציין אם סוג הנתונים מסודר במערך או לא מסודר במערך: 0-Unary או לא מסודר במערך (ברירת מחדל), 1-מסודר במערך.
vendor=VendorClass
קביעת מחלקת הספק עבור האפשרות. אם לא צוינה מחלקת ספק, נעשה שימוש במחלקת הספק המוגדרת כברירת מחדל, מחלקת האפשרויות הרגילה של DHCP.
comment=OptComment
קביעת הערה שיש להוסיף להגדרה של סוג האפשרות החדש. אם לא צוין פרמטר, הערך המוגדר כברירת מחדל הוא NULL.
DefValue
קביעת ערך המוגדר כברירת מחדל לשימוש עבור סוג אפשרות זה, אלא אם כן צוין אחרת.

הערות

  • על IsArray להיות 0 עבור אפשרויות מסוג STRING.

דוגמאות

בדוגמה הראשונה, פקודה זו מגדירה סוג אפשרות חדש בשם ExtensionsPath עם קוד 18 ונתונים מסוג STRING ומצרפת אותו למחלקת האפשרויות הרגילה של DHCP, כשהערך המוגדר כברירת מחדל הוא c:\temp.

בדוגמה השניה ובדוגמה השלישית, פקודה זו מגדירה סוג אפשרות חדש בשם TestOption עם קוד 231 ונתונים מסוג IPADDRESS. בדוגמה השניה, האפשרות מוגדרת כדי לספק רק כתובת IP אחת. IsArray ו- DefValue אינם חיוניים מאחר שנעשה שימוש בברירות המחדל. בדוגמה השלישית, DefValue ו- IsArray נדרשים ליצירת מערך המכיל את ערכי כתובת ה- IP‏ 10.1.1.1, 10.1.1.2, ו- 10.1.1.3.

add optiondef 18 ExtensionsPath STRING 0 c:\temp

add optiondef 231 TestOption IPADDRESS

add optiondef 231 TestOption IPADDRESS 1 vendor=MyVendorClass 10.1.1.1 10.1.1.2 10.1.1.3

add scope

הוספת טווח לשרת ה- DHCP שצוין.

תחביר

add scope ScopeAddress SubnetMask ScopeName [ScopeComment]

פרמטרים

ScopeAddress
נדרש. קביעת הטווח שיש להוסיף. זיהוי הטווח לפי מספר רשת IP.
SubnetMask
נדרש. קביעת מסיכת רשת המשנה עבור הטווח שיש להוסיף.
ScopeName
נדרש. קביעת שם מזהה עבור הטווח.
ScopeComment
קביעת הערה עבור הטווח.

דוגמאות

בדוגמה הבאה, פקודה זו מוסיפה טווח עבור שרת ה- DHCP עם כתובת טווח 10.2.2.0, מסיכת רשת משנה 255.255.255.0, שם טווח MyScope והערה לטווח MyComment.

add scope 10.2.2.0 255.255.255.0 MyScope MyComment

delete class

מחיקת מחלקה משרת ה- DHCP שצוין.

תחביר

delete class Name

פרמטרים

Name
נדרש. קביעת מחלקת המשתמש או מחלקת הספק שיש למחוק.

דוגמאות

בדוגמה הבאה, פקודה זו מוחקת את המחלקה בשם MyClass.

delete class MyClass

delete mscope

מחיקת טווח שידור לקבוצה משרת ה- DHCP שצוין.

תחביר

delete mscope MscopeName

פרמטרים

MscopeName
נדרש. קביעת טווח השידור לקבוצה שיש למחוק. MscopeName הוא תלוי רישיות.

דוגמאות

בדוגמה הבאה, פקודה זו מוחקת את טווח השידור לקבוצה MyMulitcastScope משרת ה- DHCP המצוין כעת.

delete mscope MyMulitcastScope

delete optiondef

מחיקת סוג אפשרות מוגדר משרת ה- DHCP שצוין.

תחביר

delete optiondef OptCode [[vendor=]VendorName]‎

פרמטרים

OptCode
נדרש. קביעת המזהה הייחודי עבור סוג האפשרות שיש למחוק.
vendor=VendorName
קביעת שם מחלקת הספק אליו משויך סוג האפשרות. אם לא צוין פרמטר, ההגדרה של סוג האפשרות נמחקת ממחלקת האפשרויות הרגילה של DHCP מסוים שאינו של ספק.

הערות

  • אפשרות זו ישימה עבור שרתי DHCP בהם פועל Windows 2000 Server בלבד.

דוגמאות

בדוגמה הבאה, פקודה זו מוחקת סוג אפשרות עם קוד 18 ממחלקת האפשרויות הרגילה של DHCP.

delete optiondef 18

delete optionvalue

מחיקת הערך הנוכחי של סוג אפשרות שצוין עבור שרת ה- DHCP שצוין.

תחביר

delete optionvalue OptCode ‎[[vendor=]VendorClass]‎ ‎[[user=]UserClass]‎

פרמטרים

OptCode
נדרש. קביעת המזהה הייחודי של אפשרות השרת הכללי עם ערך למחיקה.
vendor=VendorClass
קביעת שם מחלקת הספק אליו משויכת האפשרות. אם התג אינו כלול, נעשה שימוש ב- VendorName הכללי שנקבע באמצעות set vendorclass. אם נעשה שימוש בתג, אך לא צוין ערך, לא נעשה שימוש במחלקת ספק. פרמטר זה זמין רק במחשבים בהם פועל Windows 2000 Server.
user=UserClass
קביעת שם מחלקת המשתמש אליו משויכת האפשרות. אם התג אינו כלול, נעשה שימוש ב- UserName הכללי שנקבע באמצעות set userclass. אם נעשה שימוש בתג, אך לא צוין ערך, לא נעשה שימוש במחלקת משתמש. פרמטר זה זמין רק במחשבים בהם פועל Windows 2000 Server.

דוגמאות

בדוגמה הבאה, פקודה זו מוחקת את הערך הנוכחי של סוג האפשרות עם קוד 18.

delete optionvalue 18

delete scope

מחיקת טווח משרת ה- DHCP שצוין.

תחביר

delete scope ScopeAddress {DHCPNOFORCE | DHCPFULLFORCE}‎

פרמטרים

ScopeAddress
נדרש. קביעת כתובת הטווח למחיקה.
{DHCPNOFORCE | DHCPFULLFORCE}
נדרש. הצגת העוצמה בה יימחק הטווח: DHCPNOFORCE-מוחק את הטווח אם אין לקוחות פעילים בטווח, DHCPFULLFORCE-מוחק את הטווח אם קיימים לקוחות פעילים בטווח.

דוגמאות

בדוגמה הבאה, פקודה זו כופה את מחיקת הטווח 10.2.2.0 משרת ה- DHCP ומתעלמת מכל האזהרות.

delete scope 10.2.2.0 dhcpfullforce

delete superscope

מחיקת טווח-על משרת ה- DHCP שצוין.

תחביר

delete superscope SuperscopeName

פרמטרים

SuperscopeName
נדרש. קביעת השם של טווח-העל שיש למחוק.

הערות

  • באפשרותך להגדיר את טווח-העל מהקשר הטווח באמצעות הפקודה set superscope.
  • שם טווח-העל תלוי רישיות.

דוגמאות

בדוגמה הבאה, פקודה זו מוחקת את טווח-העל בשם My Superscope משרת ה- DHCP שצוין.

delete superscope "My Superscope"‎

export

ייצוא תצורת שירות DHCP לקובץ.

תחביר

export [Path]FileName {all | ScopeList}‎

פרמטרים

‎[Path]FileName
נדרש. קביעה, לפי שם, של הקובץ בו תאוחסן תצורת DHCP. אם הנתיב, שם הקובץ או שניהם מכילים רווחים, יש להשתמש במרכאות.
{all | ScopeList}
נדרש. קביעת הטווחים שברצונך לייצא. הפרמטר all מביא לייצוא כל הטווחים. הפרמטר ScopeList מביא לייצוא הטווחים התואמים לכתובות ה- IP שציינת. יש להפריד כל כתובת IP ברשימה באמצעות רווחים.

הערות

  • פקודה זו פועלת בשרת המקומי בלבד.
  • בזמן שהפקודה export פועלת, שירות DHCP נפסק ואינו מגיב ללקוחות DHCP המבקשים חכירות חדשות או חידושי חכירה.
  • אם בשירות DHCP קיים מספר רב של טווחים או של חכירות כתובות לקוחות, ייתכן שיידרש זמן רב להפעלת פקודה זו.

דוגמאות

בדוגמה הראשונה, פקודה זו מייצאת את התצורה המלאה של שירות DHCP לקובץ c:\temp\dhcpdb.

בדוגמה השניה, פקודה זו מייצאת את תצורת DHCP עבור הטווחים 10.0.0.0 ו- 192.168.0.0 לקובץ c:\temp\dhcpdb.

בדוגמה השלישית, פקודה זו מייצאת את תצורת שירות DHCP המלאה לקובץ C:\My Folder\Dhcp Configuration. שים לב שהן הנתיב והן שם הקובץ מכילים רווחים ולפיכך נעשה שימוש במרכאות.

export c:\temp\dhcpdb all

export c:\temp\dhcpdb 10.0.0.0 192.168.0.0

export "C:\My Folder\Dhcp Configuration" all

import

ייבוא תצורת שירות DHCP מקובץ לשירות המקומי.

תחביר

import [Path]FileName {all | ScopeList]‎

פרמטרים

‎[Path]FileName‎
נדרש. קביעה, לפי שם, של הקובץ ממנו תיובא תצורת DHCP. אם הנתיב, שם הקובץ או שניהם מכילים רווחים, יש להשתמש במרכאות.
{all | ScopeList}
נדרש. קביעת הטווחים שברצונך לייבא. הפרמטר all מייבא את כל הטווחים המיוצגים בקובץ שתציין. הפרמטר ScopeList מייבא את הטווחים התואמים לכתובות IP שתפרט. יש להפריד כל כתובת IP ברשימה באמצעות רווחים.

הערות

  • פקודה זו פועלת בשרת המקומי בלבד.
  • בזמן שהפקודה import פועלת, שירות DHCP נפסק ואינו מגיב ללקוחות DHCP המבקשים חכירות חדשות או חידושי חכירה.
  • אם בשירות DHCP קיים מספר רב של טווחים או חכירות כתובות לקוחות, ייתכן שיידרש זמן רב להפעלת פקודה זו.

דוגמאות

בדוגמה הראשונה, פקודה זו מייבאת את תצורת שירות DHCP המלאה מהקובץ c:\temp\dhcpdb.

בדוגמה השניה, פקודה זו מייבאת את תצורת DHCP עבור הטווחים 10.0.0.0 ו- 192.168.0.0 מהקובץ c:\temp\dhcpdb.

בדוגמה השלישית, פקודה זו מייבאת את תצורת שירות DHCP המלאה מהקובץ C:\My Folder\Dhcp Configuration. שים לב שהן הנתיב והן שם הקובץ מכילים רווחים ולכן נעשה שימוש במרכאות.

import c:\temp\dhcpdb all

import c:\temp\dhcpdb 10.0.0.0 192.168.0.0

import "C:\My Folder\Dhcp Configuration" all

initiate auth

אתחול מתן הרשאות של שרת ה- DHCP שצוין ב- Active Directory.

תחביר

initiate auth

פרמטרים

ללא

mscope

החלפת הקשר הפקודה לטווח שידור לקבוצה של DHCP.

תחביר

mscope MscopeName

פרמטרים

MscopeName
נדרש. קביעת שם הטווח של שידור לקבוצה אליו יש להעביר את הקשר הפקודה.

הערות

  • פקודה זו מאפשרת לך להשתמש בכל אחת מפקודות רמת הטווח של שידור לקבוצה מסוג DHCP הזמינות בטווח שידור לקבוצה מסוג DHCP שצוין. פעולות עוקבות יתבצעו בטווח שידור לקבוצה זה בשרת שצוין.
  • שם טווח השידור לקבוצה הוא תלוי רישיות.

דוגמאות

בדוגמה הבאה, פקודה זו מעבירה את הקשר הפקודה לטווח שידור לקבוצה בשם My Multicast Scope.

mscope "My Multicast Scope"‎

scope

העברת הקשר הפקודה לטווח DHCP.

תחביר

scope ScopeIPAddress

פרמטרים

ScopeIPAddress
נדרש. קביעת הטווח אליו יש להעביר את הקשר הפקודה. זיהוי הטווח באמצעות רשת או כתובת IP של רשת משנה.

הערות

  • פקודה זו מאפשרת לעשות שימוש בכל אחת מפקודות רמת הטווח של DHCP הזמינות בטווח DHCP שצוין. פעולות עוקבות יתבצעו בטווח זה בשרת שצוין.

דוגמאות

בדוגמה הבאה, פקודה זו מעבירה את הקשר הפקודה לטווח עם כתובת ה- IP‏ 10.0.0.0.

scope 10.0.0.0

set auditlog

קביעת הפרמטרים לנתיב יומן הביקורת עבור שרת ה- DHCP שצוין.

תחביר

set auditlog NewAuditPath

פרמטרים

NewAuditPath
נדרש. קביעת תיקיה מקומית בה ישתמש שרת ה- DHCP בעת אחסון קבצים של יומן ביקורת. נדרש נתיב תיקיה חוקי ועל התיקיה להיות מקומית עבור שרת ה- DHCP בו מוגדר הנתיב.

הערות

  • כדי ששינוי זה ייכנס לתוקף, עליך להפסיק את שירות DHCP ולהפעילו מחדש לאחר הפעלת פקודה זו.

דוגמאות

בדוגמה הבאה, פקודה זו מגדירה ששרת ה- DHCP יאחסן קבצי יומן ביקורת בספריה c:\logpath.

set auditlog c:\logpath

set databasebackupinterval

הגדרת מרווח הגיבוי עבור שרת ה- DHCP שצוין.

תחביר

set databasebackupinterval NewInterval

פרמטרים

NewInterval
נדרש. קביעת מרווח הזמן לגיבוי בדקות.

דוגמאות

בדוגמה הבאה, פקודה זו מגדירה את מרווח הזמן לגיבוי מסד הנתונים עבור שרת ה- DHCP שצוין ל- 1,440 דקות (24 שעות).

set databasebackupinterval 1440

set databasebackuppath

הגדרת נתיב גיבוי מסד הנתונים עבור שרת ה- DHCP שצוין.

תחביר

set databasebackuppath NewBackupPath

פרמטרים

NewBackupPath
נדרש. קביעת תיקיה מקומית בה ישתמש שרת ה- DHCP בעת אחסון קבצי יומן ביקורת. נדרש נתיב תיקיה חוקי ועל התיקיה להיות מקומית לשרת ה- DHCP בו מוגדר הנתיב.

דוגמאות

בדוגמה הבאה, פקודה זו מגדירה את נתיב גיבוי מסד הנתונים כ- c:\winnnt\dhcp\backup.

set databasebackuppath c:\winnt\dhcp\backup

set databasecleanupinterval

הגדרת מרווח הזמן לניקוי מסד הנתונים עבור שרת ה- DHCP שצוין.

תחביר

set databasecleanupinterval NewInterval

פרמטרים

NewInterval
נדרש. קביעת מרווח הזמן לניקוי מסד הנתונים, בדקות.

דוגמאות

בדוגמה הבאה, פקודה זו מגדירה את מרווח הזמן לניקוי מסד הנתונים ל- 10,080 דקות (כל שבעה ימים).

set databasecleanupinterval 10080

set databaseloggingflag

הגדרה או איפוס דגל הרישום של מסד הנתונים עבור שרת ה- DHCP שצוין. ללא פרמטרים, פקודה זו מבצעת איפוס של דגל הרישום של מסד הנתונים.

תחביר

set databaseloggingflag [{0 | 1}]‎

פרמטרים

‎{0 | 1}‎
ציון הגדרת דגל הרישום של מסד הנתונים: 0-איפוס הדגל (ברירת המחדל), 1-הגדרת הדגל.

דוגמאות

בדוגמה הבאה, פקודה זו גורמת לאיפוס דגל הרישום של מסד הנתונים עבור שרת ה- DHCP המצוין כעת.

set databaseloggingflag 0

set databasename

קביעת שם הקובץ של מסד הנתונים של שרת ה- DHCP עבור שרת ה- DHCP שצוין.

תחביר

set databasename NewFileName

פרמטרים

NewFileName
נדרש. קביעת שם חדש עבור קובץ מסד הנתונים של שרת ה- DHCP.

הערות

  • כדי ששינוי זה ייכנס לתוקף, עליך להפסיק את שירות DHCP Server ולהפעילו מחדש.

דוגמאות

בדוגמה הבאה, פקודה זו קובעת ששם הקובץ של מסד הנתונים של שרת ה- DHCP יהיה newdatabase.mdb.

set databasename newdatabase.mdb

set databasepath

הגדרת הנתיב של קובץ מסד הנתונים של שרת ה- DHCP עבור שרת ה- DHCP שצוין.

תחביר

set databasepath NewPath

פרמטרים

NewPath
נדרש. קביעת הנתיב של קובץ מסד הנתונים של DHCP.

הערות

  • כדי ששינוי זה ייכנס לתוקף, עליך להפסיק את שירות DHCP Server ולהפעילו מחדש.

דוגמאות

בדוגמה הבאה, פקודה זו קובעת שהנתיב של קובץ מסד הנתונים של שרת ה- DHCP יהיה c:\winnt\dhcp.

set databasepath c:\winnt\dhcp

set databaserestoreflag

הגדרה או איפוס של דגל שחזור מסד הנתונים עבור שרת ה- DHCP שצוין. ללא פרמטרים, פקודה זו גורמת לאיפוס דגל השחזור של מסד הנתונים.

תחביר

set databaserestoreflag [{0 | 1}]‎

פרמטרים

‎{0 | 1}‎
ציון ההגדרה של דגל השחזור של מסד הנתונים: 0-איפוס הדגל (ברירת המחדל), 1-הגדרת הדגל.

דוגמאות

בדוגמה הבאה, פקודה זו מגדירה את דגל השחזור של מסד הנתונים עבור שרת ה- DHCP המצוין כעת.

set databaserestoreflag 1

set detectconflictretry

קביעה של מספר הניסיונות לאיתור התנגשויות עבור שרת ה- DHCP שצוין.

תחביר

set detectconflictretry RetryNumber

פרמטרים

RetryNumber
נדרש. קביעת מספר הניסיונות לאיתור התנגשויות שיערוך שרת ה- DHCP לפני שיחכיר כתובת IP של טווח ללקוח.

הערות

  • הערך המירבי עבור RetryNumber הוא חמש. כל ערך הגדול מחמש יוקטן כברירת מחדל לחמש.

דוגמאות

בדוגמה הבאה, פקודה זו קובעת ששרת ה- DHCP יבצע ארבעה ניסיונות לאתר אם קיימת התנגשות עבור כתובת IP של טווח לפני ששרת ה- DHCP ישתמש בכתובת זו בחכירת כתובת חדשה.

set detectconflictretry 4

set dnsconfig

קביעה של תצורת העדכון הדינאמי של DNS עבור שרת ה- DHCP שצוין.

תחביר

set dnsconfig [Enable=]{0|1} [[Update=]{0|1}] [[Lookup=]{0|1}] [[NonDyn=]{0|1}]‎

פרמטרים

‎[Enable=]{0|1}‎
נדרש. ציון אם יש להפעיל או לבטל עדכונים דינאמיים של מידע לקוח DNS: ‏0-ביטול עדכונים דינאמיים של מידע לקוח DNS, ‏1-הפעלת עדכונים דינאמיים של מידע לקוח DNS.
‎[Update=]{0|1}‎
ציון הסוג של בדיקות העדכון: ‏0-עדכון על-פי בקשת לקוח, 1-עדכון בדיקות שם קדימה ואחורה.
‎[Lookup=]{0|1}‎
ציון אם יש להפעיל או לבטל בדיקות קדימה עבור לקוחות בעת תפוגת החכירה: 0-ביטול בדיקות קדימה, 1-הפעלת בדיקות קדימה.
‎[NonDyn=]{0|1}‎
ציון אם יש לעדכן מידע DNS עבור לקוחות שאינם תומכים בעדכונים דינאמיים: 0-ביטול עדכונים עבור לקוחות שאינם תומכים בעדכונים דינאמיים, 1-הפעלת עדכונים אלה.

הערות

  • פקודה זו נתמכת רק עבור שרתי DHCP בהם פועל Windows 2000 Server.
  • שרת DNS המועדף שהוגדר, במאפייני TCP/IP של שרת ה- DHCP, יעודכן באמצעות רשומות לקוח DHCP בעת הפעלת עדכונים דינאמיים. אם שרת DNS המועדף אינו זמין ברשת, יעודכן שרת ה- DNS החלופי.

דוגמאות

בדוגמה הבאה, פקודה זו מפעילה עדכון דינאמי של מידע DNS באמצעות שרת ה- DHCP ומגדירה כי תמיד יתבצעו תיקונים עבור בדיקות קדימה ובדיקות אחורה. כמו כן, דוגמה זו מבטלת את האפשרות לבצע בדיקות קדימה בעת תפוגת חכירות ומפעילה עדכונים עבור לקוחות שאינם דינאמיים.

set dnsconfig 1 1 0 1

set optionvalue

קביעת ערך אפשרות של שרת DHCP שיוחל עבור כל הטווחים המוגדרים בשרת ה- DHCP שצוין.

תחביר

set optionvalue OptCode {BYTE | WORD | DWORD | STRING | IPADDRESS} [[user=]UserName] [[vendor=]VendorName] [OptionValue]‎

פרמטרים

OptCode
נדרש. קביעת המזהה הייחודי עבור סוג האפשרות עם הערך שיש לקבוע.
{BYTE | WORD | DWORD | STRING | IPADDRESS}
נדרש. קביעת סוג הנתונים עבור סוג האפשרות עם הערך שיש לקבוע.
‎[user=]UserName
קביעה של שם מחלקת המשתמש הישים עליו תחול פקודה זו. אם לא צוין פרמטר, נעשה שימוש במחלקת המשתמש המוגדרת כברירת מחדל.
‎[vendor=]VendorName
קביעה של שם מחלקת הספק הישים עליו תחול פקודה זו. אם לא צוין, נעשה שימוש במחלקת האפשרויות הרגילות מסוג DHCP.
[OptionValue]
קביעת ערך ברירת המחדל החדש של השרת עבור סוג האפשרות המזוהה באמצעות OptCode. על הערך להיות מסוג הנתונים המשויך.

הערות

  • מחלקות ספק ומשתמש נתמכות רק עבור שרתי DHCP בהם פועל Windows 2000 Server.
  • כדי לשנות את ברירות המחדל הנוכחיות עבור מחלקה שלא צוינה, השתמש בפקודות set userclass או set vendorclass.

דוגמאות

בדוגמה הראשונה, פקודה זו קובעת את ערך קוד האפשרות 003 כך שיפרט שתי כתובות IP של נתב, 10.1.1.1 ו- 10.1.1.2.

בדוגמה השניה, פקודה זו מסייגת את הדוגמה הראשונה וקובעת שהערך המצוין יחול רק עבור לקוחות טווח המזהים עצמם כחברים במחלקת הספק Vendor1. כדי שדוגמה זו תפעל, על מחלקה זו להיות מוגדרת כבר בשרת, כאשר סוג האפשרות שצוין מוגדר לשימוש.

set optionvalue 003 IPADDRESS 10.1.1.1 10.1.1.2

set optionvalue 003 IPADDRESS vendor=Vendor1 10.1.1.1 10.1.1.2

set server

שינוי הקשר שורת הפקודה Netsh לשרת שצוין. ללא פרמטרים, נעשה שימוש בשרת המקומי.

תחביר

set server [{ServerIP | \\ServerDNS}]

פרמטרים

{ServerIP | \\ServerDNS}
קביעת כתובת ה- IP או שם ה- DNS של שרת ה- DHCP שצוין.

הערות

  • בעת שימוש בפקודה זו וכשהקשר שורת הפקודה Netsh משתנה לשרת אחר, כל פעולות הפקודה העוקבות מתבצעות בשרת שצוין. כדי לבצע פעולות פקודה בשרת אחר, יש לבצע פקודה זו שוב, עם כתובת ה- IP או שם ה- DNS של השרת החדש הניתן כפרמטר.

דוגמאות

בדוגמה הבאה, פקודה זו מחליפה את הקשר שורת הפקודה של שרת ה- DHCP לשרת שבכתובת ה- IP‏ 10.1.1.1

set server 10.1.1.1

set userclass

הגדרת השם עבור מחלקת המשתמש הנוכחית. ללא פרמטרים, מחלקת המשתמש הנוכחית תאופס למחלקת המשתמש המוגדרת כברירת מחדל.

תחביר

set userclass [UserClass]‎

פרמטרים

UserClass
קביעת שם מחלקת המשתמש עבור שרת ה- DHCP המצוין כעת.

הערות

  • פקודה זו זמינה לשימוש בשרתי DHCP בהם פועל Windows 2000 Server בלבד.

דוגמאות

בדוגמה הראשונה, פקודה זו מגדירה את שם מחלקת המשתמש ל- MyUserClass.

בדוגמה השניה, פקודה זו גורמת לאיפוס מחלקת המשתמש הנוכחית למחלקת המשתמש המוגדרת כברירת מחדל.

set userclass MyUserClass

set userclass

set vendorclass

הגדרת השם עבור מחלקת הספק הנוכחית. ללא פרמטרים, מחלקת הספק הנוכחית תאופס למחלקה המוגדרת כברירת מחדל, אפשרויות רגילות של DHCP.

תחביר

set vendorclass [VendorClass]‎

פרמטרים

VendorClass
קביעת שם מחלקת הספק עבור השרת הנוכחי.

הערות

  • פקודה זו זמינה לשימוש בשרתי DHCP בהם פועל Windows 2000 Server בלבד.

דוגמאות

בדוגמה הראשונה, פקודה זו מגדירה את שם מחלקת הספק ל- MyVendorClass.

בדוגמה השניה, פקודה זו גורמת לאיפוס מחלקת הספק הנוכחית למחלקה המוגדרת כברירת מחדל, אפשרויות רגילות של DHCP.

set vendorclass MyVendorClass

set vendorclass

show all

הצגת כל המצבים ומידע התצורה עבור שרת ה- DHCP שצוין.

תחביר

show all

פרמטרים

ללא

הערות

  • פקודה זו מפרטת את כל מצבי השרת הנוכחיים ופרטי התצורה, כולל בסיס מידע ניהול (MIB) מאוחסן, עבור שרת ה- DHCP המצוין כעת.

show auditlog

הצגת כל מידע יומן הביקורת עבור שרת ה- DHCP שצוין.

תחביר

show auditlog

פרמטרים

ללא

show bindings

הצגת מידע איגודים (binding) עבור שרת ה- DHCP שצוין.

תחביר

show bindings

פרמטרים

ללא

הערות

  • פקודה זו מציגה מידע איגודים (binding) עבור שרת ה- DHCP הנוכחי ומציינת אילו חיבורי רשת פעילים המוגדרים באמצעות כתובות IP סטטיות מופעלים או אינם זמינים לשימוש בשירות לקוחות DHCP ברשת שלך.
  • השירות DHCP מבטל אוטומטית חיבורי רשת המשיגים תצורת כתובת IP באופן דינאמי מאיגודי שירותים. הדבר מתרחש כברירת מחדל.

show class

ספירה והצגה של כל מידע המחלקה עבור שרת ה- DHCP שצוין. המידע כולל מידע הן של מחלקת משתמש והן של מחלקת ספק.

תחביר

show class

פרמטרים

ללא

show detectconflictretry

הצגת המספר המוגדר לניסיונות איתור התנגשויות עבור שרת ה- DHCP שצוין.

תחביר

show detectconflictretry

פרמטרים

ללא

הערות

  • פקודה זו מציגה את המספר הנוכחי של ניסיונות חוזרים לאיתות (Ping) המשמשים בניסיון לאתר התנגשויות כתובות עבור כתובות IP של טווח המופצות באמצעות השרת.

show dnsconfig

הצגת תצורת העדכון הדינאמי של DNS עבור שרת ה- DHCP שצוין.

תחביר

show dnsconfig

פרמטרים

ללא

הערות

  • אם תצורת DNS לא הופעלה או הוגדרה, באפשרותך להשתמש במסוף DNS או בפקודה set dnsconfig לשם קביעת התצורה של הגדרות אלה.

show mibinfo

הצגת בסיס מידע ניהול (MIB) עבור שרת ה- DHCP שצוין.

תחביר

show mibinfo

פרמטרים

ללא

show mscope

הצגת כל המידע אודות טווחי שידור לקבוצה עבור שרת ה- DHCP שצוין.

תחביר

show mscope

פרמטרים

ללא

show optiondef

הצגת כל סוגי האפשרויות הזמינים והמוגדרים לשימוש בשרת ה- DHCP שצוין. ללא פרמטרים, מוצגות כל האפשרויות.

תחביר

show optiondef [vendor=VendorName]‎

פרמטרים

vendor=VendorName
ציון סוגי האפשרויות הזמינים והמוגדרים שיש להציג. אם לא צוין פרמטר, ברירת המחדל עבור VendorName היא מחלקת הספק המשמשת כברירת מחדל ומוגדרת כעת עבור שרת ה- DHCP.

הערות

  • את מחלקת הספק המוגדרת כברירת מחדל ניתן לאפס באמצעות הפקודה set vendorclass.
  • VendorName ישים רק עבור שרתי DHCP בהם פועל Windows 2000 Server.

דוגמאות

בדוגמה הראשונה, פקודה זו מציגה את כל סוגי האפשרויות המוגדרים עבור מחלקת הספק הנוכחית.

בדוגמה השניה, פקודה זו מציגה את סוגי האפשרויות המוגדרים הזמינים לשימוש עם המחלקה שצוינה Vendor1.

show optiondef

show optiondef vendor=Vendor1

show optionvalue

הצגת כל ערכי האפשרות הזמינים המוגדרים כעת עבור שרת ה- DHCP שצוין. ללא פרמטרים, מוצגים כל ערכי האפשרות, כולל אלה המשמשים הן עבור מחלקות משתמשים והן עבור מחלקות ספקים.

תחביר

show optionvalue [user=UserName | vendor=VendorName]

פרמטרים

user=UserName
קביעת ערכי ברירת המחדל המוגדרים עבור סוגי האפשרויות הזמינים לשימוש עם מחלקת המשתמש המוגדרת כעת.
vendor=VendorName
קביעת ערכי ברירת המחדל המוגדרים עבור סוגי האפשרויות הזמינים לשימוש עם מחלקת הספק המוגדרת כעת.

הערות

  • User=UserName ו- vendor=VendorName זמינים לשימוש רק עם שרתי DHCP בהם פועל Windows 2000 Server.
  • אם תספק ערכים עבור UserName או VendorName, נדרשים התגים המתאימים (user=‎ או vendor=‎). אם התגים אינם כלולים, ברירת המחדל שנעשה בה שימוש היא מחלקת המשתמש הנוכחית, שהוגדרה קודם לכן באמצעות הפקודה set userclass.

דוגמאות

בדוגמה הבאה, פקודה זו מציגה את כל סוגי האפשרויות הזמינים שערכיהם הוגדרו בשרת ה- DHCP המצוין כעת.

show optionvalue

show scope

הצגת מידע אודות הטווחים עבור שרת ה- DHCP שצוין.

תחביר

show scope

פרמטרים

ללא

show server

הצגת מידע אודות שרת ה- DHCP שצוין, כולל שם קבוצת מחשבים מלא (FQDN) וכתובת IP של השרת.

תחביר

show server

פרמטרים

ללא

show dbproperties

הצגת מידע אודות תצורת מסד הנתונים עבור שרת ה- DHCP שצוין.

תחביר

show dbproperties

פרמטרים

ללא

הערות

  • פקודה זו מציגה את המידע הבא אודות תצורת מסד הנתונים:
    • DatabaseName
    • DatabasePath
    • DatabaseBackupPath
    • DatabaseBackupInterval
    • DatabaseLoggingFlag
    • DatabaseRestoreFlag
    • DatabaseCleanupInterval

show serverstatus

הצגת מידע אודות מצב עבור שרת ה- DHCP שצוין.

תחביר

show serverstatus

פרמטרים

ללא

הערות

  • זוהי דוגמה לסוג מידע המצב שפקודה זו מציגה:

    Server Attrib - Server Servicing Clients :TRUE

    Server Attrib - Dynamic BootP Support Enabled :TRUE

    Server Attrib - DHCP Server Part Of DS :TRUE

    Server Attrib - DHCP Server Bindings Aware :TRUE

    Server Attrib - Administrative Rights :TRUE

show userclass

הצגת ההגדרה של מחלקת המשתמש הנוכחית בשרת ה- DHCP שצוין.

תחביר

show userclass

פרמטרים

ללא

הערות

  • זוהי דוגמה של סוג מידע ההגדרה שפקודה זו מציגה:

    Current Class Name set for the Server dhcpsrv1.example.microsoft.com is None.

show vendorclass

הצגת ההגדרה של מחלקת הספק הנוכחית בשרת ה- DHCP שצוין.

תחביר

show vendorclass

פרמטרים

ללא

הערות

  • זוהי דוגמה של סוג מידע ההגדרה שפקודה זו מציגה:

    Current Vendor Name set for the Server dhcpsrv1.example.microsoft.com is None.

show version

הצגה של מידע גירסה נוכחית עבור שרת ה- DHCP שצוין.

תחביר

show version

פרמטרים

ללא

הערות

  • זוהי דוגמה לסוג מידע הגירסה שפקודה זו מציגה:

    The version of the DHCP Server 192.168.0.100 is 5.6.

טווח שרת Netsh DHCP

הפקודות הבאות זמינות בשורת הפקודה dhcp server scope>‎, שבסיסה נמצא בסביבת netsh.

להצגת תחביר הפקודה, לחץ על פקודה:

add excluderange

הוספת טווח כתובות שאין להפיץ בטווח הנוכחי.

תחביר

add excluderange StartIP EndIP

פרמטרים

StartIP
נדרש. קביעת כתובת ה- IP הפותחת את טווח האי-כלילה.
EndIP
נדרש. ציון כתובת ה- IP המסיימת את טווח האי-כלילה.

דוגמאות

בדוגמה הבאה, פקודה זו אינה כוללת את כתובות ה- IP בטווח בין 10.2.2.10 ל- 10.2.2.20 בטווח ההפצה.

add excluderange 10.2.2.10 10.2.2.20

add iprange

הוספת טווח כתובות IP לטווח הנוכחי.

תחביר

add iprange StartIP EndIP [{DHCP | BOOTP | BOTH}] [MaxBootP]‎

פרמטרים

StartIP
נדרש. קביעת כתובת ה- IP הפותחת את הטווח.
EndIP
נדרש. קביעת כתובת ה- IP המסיימת את הטווח.
{DHCP | BOOTP | BOTH}
קביעת סוג הלקוח שיקבל שירות באמצעות טווח זה וטווח ה- IP. ‏DHCP הוא ברירת מחדל.
MaxBootP
קביעת המספר המירבי של לקוחות BOOTP.

הערות

  • MaxBootP יעיל רק אם ClientType הוגדר לתמוך בלקוחות מסוג BOOTP עבור הטווח. אם נעשה שימוש באפשרות שורת פקודה אופציונלית, נדרשות כל אפשרויות שורת הפקודה (הן ההכרחיות והן האופציונליות) המופיעות לפני הפקודה האופציונלית בה נעשה שימוש ועליהן להופיע ברצף הנכון.

דוגמאות

בדוגמה הבאה, פקודה זו מוסיפה לקוחות DHCP אשר קיימים בטווח כתובות ה- IP בין 10.2.2.10 ל- 10.2.2.20 לטווח ההפצה בטווח.

add iprange 10.2.2.10 10.2.2.20

add reservedip

שמירת כתובת IP לשימוש של כתובת בקרת גישה למדיה (MAC) שצוינה בטווח הנוכחי.

תחביר

add reservedip ReservedIP MACAddress [ClientName] [ClientComment] [{DHCP | BOOTP | BOTH}]‎

פרמטרים

ReservedIP
נדרש. קביעת כתובת ה- IP לשמירה.
MACAddress
נדרש. קביעת החומרה הפיזית או הכתובת של בקרת גישת מדיה (MAC) שיש לשייך לכתובת ה- IP השמורה.
ClientName
קביעת שם לקוח שיש לשייך לערך לקוח שמור זה. אם לא צוין פרמטר, שם לקוח אינו משויך לערך לקוח שמור זה.
ClientComment
קביעת הערת לקוח שיש לשייך לערך לקוח שמור זה. אם לא צוין פרמטר, הערת לקוח אינה משויכת לערך לקוח שמור זה.
{DHCP | BOOTP | BOTH}
קביעת סוג הלקוחות שיש לשייך לערך לקוח שמור זה. DHCP הוא ברירת המחדל.

הערות

  • אם נעשה שימוש באפשרות שורת פקודה אופציונלית, נדרשות כל אפשרויות שורת הפקודה (הן ההכרחיות והן האופציונליות) המופיעות לפני אפשרות שורת הפקודה האופציונלית בה נעשה שימוש ועליהן להופיע ברצף הנכון.

דוגמאות

בדוגמה הבאה, פקודה זו שומרת את כתובת ה- IP‏ 10.2.2.32, לשימוש על-ידי לקוח ה- DHCP, אשר בעת קבלת חכירה בטווח הנוכחי מזהה את כתובת ה- MAC שלו כ- 08-00-2b-30-36-9b.

add reservedip 10.2.2.32 08002b30369B

delete excluderange

מחיקת טווח כתובות IP שקודם לכן לא נכללו בטווח הנוכחי.

תחביר

delete excluderange StartIP EndIP

פרמטרים

StartIP
נדרש. קביעת כתובת ה- IP הפותחת את טווח האי-כלילה.
EndIP
נדרש. קביעת כתובת ה- IP המסיימת את טווח האי-כלילה.

דוגמאות

בדוגמה הבאה, פקודה זו מוחקת את טווח האי-כלילה המתחיל בכתובת ה- IP ‏10.2.1.5 ומסתיים בכתובת ה- IP ‏10.2.1.10 בטווח הנוכחי.

delete excluderange 10.2.1.5 10.2.1.10

delete iprange

מחיקת טווח כתובות IP מהטווח הנוכחי.

תחביר

delete iprange StartIP EndIP

פרמטרים

StartIP
נדרש. קביעת כתובת ה- IP הפותחת את הטווח שיש למחוק.
EndIP
נדרש. קביעת כתובת ה- IP המסיימת את הטווח שיש למחוק.

דוגמאות

בדוגמה הבאה, פקודה זו מוחקת כתובות IP בטווח בין 10.2.1.5 ל- 10.2.1.10 מהטווח הנוכחי.

delete iprange 10.2.1.5 10.2.1.10

delete optionvalue

הסרה או ניקוי של ערך אפשרות הטווח המוגדר כעת מהטווח הנוכחי.

תחביר

delete optionvalue OptCode [user=UserName] [vendor=VendorName]

פרמטרים

OptCode
נדרש. קביעת המזהה הייחודי של האפשרות שאת ערכה יש למחוק.
user=UserName
קביעת מחלקת המשתמש ממנה יש למחוק את ערך האפשרות המצוין כעת. אם התג ניתן, אך הערך לא צוין, נעשה שימוש במחלקת המשתמש הנוכחית המוגדרת כברירת מחדל.
vendor=VendorName
קביעת מחלקת הספק ממנה יש למחוק את ערך האפשרות המצוין כעת. אם התג ניתן, אך הערך לא צוין, נעשה שימוש במחלקת הספק הנוכחית המוגדרת כברירת מחדל.

הערות

  • מחלקות ספק ומשתמש נתמכות רק עבור שרתי DHCP בהם פועל Windows 2000 Server.
  • אם תציין מחלקת משתמש, מחלקת ספק או את שתיהן, פקודה זו תמחק את ערך האפשרות שהוגדר רק מלקוחות הטווח המזוהים כחברים במחלקה או במחלקות שצוינו.
  • כדי לשנות את ברירות המחדל הנוכחיות עבור מחלקה שלא צוינה המשמשת עם פקודה זו, השתמש בפקודות set userclass או set vendorclass.

דוגמאות

בדוגמה הראשונה, פקודה זו מוחקת את ערך האפשרות המוגדר כעת עבור קוד אפשרות 18 מהטווח הנוכחי.

בדוגמה השניה, פקודה זו מוחקת את ערך האפשרות המוגדר כעת עבור קוד אפשרות 18 ממחלקת הספק MyVendorClass.

delete optionvalue 18

delete optionvalue 18 vendor="MyVendorClass"‎

delete reservedip

מחיקת שמירה של כתובת IP בטווח הנוכחי.

תחביר

delete reservedip ReservedIP MACAddress

פרמטרים

ReservedIP
נדרש. קביעת שמירת כתובת ה- IP שיש למחוק מהטווח הנוכחי.
MACAddress
נדרש. קביעת בקרת הגישה למדיה (MAC) או מחרוזת כתובת החומרה הפיזית עבורה נשמרה כתובת ה- IP.

דוגמאות

בדוגמה הבאה, פקודה זו מסירה את שמירת כתובת ה- IP‏ 10.2.1.32, עבור כתובת ה- MAC‏ 08002B30369B מהטווח הנוכחי.

delete reservedip 10.2.1.32 08002B30369B

delete reservedoptionvalue

מחיקת ערך אפשרות המוקצה כעת ללקוח שמור בטווח הנוכחי.

תחביר

delete reservedoptionvalue ReservedIP OptCode [User=UserName] [vendor=VendorName]‎

פרמטרים

ReservedIP
נדרש. קביעת כתובת ה- IP של הלקוח השמור.
OptCode
נדרש. קביעת הקוד הייחודי עבור סוג האפשרות המוקצה כעת ללקוח השמור.
User=UserName
קביעת מחלקת המשתמש ממנה יש למחוק את ערך האפשרות. אם התג ניתן, אך לא צוין כל ערך, נעשה שימוש במחלקת המשתמש הנוכחית המוגדרת כברירת מחדל.
vendor=VendorName
קביעת מחלקת הספק ממנה יש למחוק את ערך האפשרות. אם התג ניתן, אך לא צוין כל ערך, נעשה שימוש במחלקת הספק הנוכחית.

הערות

  • מחלקות ספק ומשתמש נתמכות רק עבור שרתי DHCP בהם פועל Windows 2000 Server.
  • כדי לשנות את ברירות המחדל הנוכחיות עבור מחלקה שלא צוינה המשמשת עם פקודה זו, השתמש ב- set userclass או ב- set vendorclass.

דוגמאות

בדוגמה הבאה, פקודה זו מוחקת את ערך האפשרות המוגדר כעת עבור האפשרות המזוהה באמצעות קוד 18 עבור כתובת IP שמורה של 10.2.2.32 בטווח הנוכחי.

delete reservedoptionvalue 10.2.2.32 18

initiate reconcile

בדיקה והשגת פשרה בטווח הנוכחי. ללא פרמטרים, פקודה זו מאמתת את הטווחים ובודקת חוסר עקביות, אך אינה מתקנת חוסר עקביות המתגלה במסד הנתונים.

תחביר

initiate reconcile [fix]‎

פרמטרים

[fix]
קביעה כי הפקודה תתקן, במידת האפשר, כל חוסר עקביות שיתגלה במסד הנתונים.

דוגמאות

בדוגמה הראשונה, פקודה זו מאמתת את הטווחים ובודקת חוסר עקביות.

בדוגמה השניה, פקודה זו מאמתת את הטווחים, בודקת חוסר עקביות ומתקנת כל חוסר עקביות שנמצא.

initiate reconcile

initiate reconcile fix

set comment

הגדרת ההערה עבור הטווח הנוכחי. ללא פרמטרים, set comment מוחקת את ההערה הנוכחית.

תחביר

set comment [NewComment]‎

פרמטרים

[NewComment]
קביעת מחרוזת הערה ששונתה או חדשה עבור הטווח.

דוגמאות

בדוגמה הראשונה, פקודה זו מגדירה מחרוזת הערות ללא רווחים.

בדוגמה השניה, פקודה זו מגדירה מחרוזת הערות הכוללת רווחים.

set comment NewCommentNoSpaces

set comment "New Comment With Spaces"‎

set name

הגדרת השם של הטווח הנוכחי.

תחביר

set name NewName

פרמטרים

NewName
נדרש. פרמטר זה מציין את שם הטווח החדש.

דוגמאות

בדוגמה הראשונה, פקודה זו מגדירה שם שאינו כולל רווחים.

בדוגמה השניה, פקודה זו מגדירה שם הכולל רווחים.

set name NewNameNoSpaces

set name "New Name With Spaces"‎

set optionvalue

הגדרת ערך אפשרות עבור הטווח הנוכחי.

תחביר

set optionvalue OptCode {BYTE | WORD | DWORD | STRING | IPADDRESS} [user=UserName] [vendor=VendorName] OptionValue

פרמטרים

OptCode
נדרש. קביעת הקוד עבור סוג האפשרות שאת ערכה יש להגדיר.
{BYTE | WORD | DWORD | STRING | IPADDRESS}
נדרש. קביעת סוג הנתונים עבור סוג האפשרות שאת ערכה יש להגדיר.
user=UserName
קביעת מחלקת המשתמש. אם התג ניתן, אך הערך לא צוין, נעשה שימוש במחלקת המשתמש הנוכחית המוגדרת כברירת מחדל.
vendor=VendorName
קביעת מחלקת הספק. אם התג ניתן, אך הערך לא צוין, נעשה שימוש במחלקת הספק הנוכחית המוגדרת כברירת מחדל.
OptionValue
נדרש. קביעת הערך שיוקצה עבור סוג האפשרות שצוין ב- OptCode. אם סוג האפשרות תומך במערך המכיל יותר מערך מספרי או ערך כתובת IP אחד, ספק את הערכים הנוספים בסדר המועדף עליך, בסוף הפקודה והפרד כל ערך באמצעות רווח.

הערות

  • מחלקות ספק ומשתמש נתמכות רק עבור שרתי DHCP בהם פועל Windows 2000 Server.
  • כדי לשנות את ברירות המחדל הנוכחיות עבור מחלקה שלא צוינה ואשר משמשת עם פקודה זו, השתמש ב- set userclass או ב- set vendorclass.

דוגמאות

בדוגמה הראשונה, פקודה זו קובעת את ערך קוד האפשרות 003 כך שיתבצע רישום של שתי כתובות IP של נתבים (10.1.1.1, 10.1.1.2).

בדוגמה השניה, פקודה זו קובעת שהערך שצוין בדוגמה הראשונה יחול רק על לקוחות טווח המזהים עצמם כחברים במחלקת הספק Vendor1, מחלקה שקודם לכן הוגדרה בשרת, כאשר סוג אפשרות זה הוגדר לשימושה.

set optionvalue 003 IPADDRESS 10.1.1.1 10.1.1.2

set optionvalue 003 IPADDRESS vendor=Vendor1 10.1.1.1 10.1.1.2

set reservedoptionvalue

הגדרת הערך של אפשרות עבור כתובת IP לשמירה בטווח הנוכחי.

תחביר

set reservedoptionvalue ReservedIP OptCode {BYTE | WORD | DWORD | STRING | IPADDRESS} [user=UserName] [vendor=VendorName] OptValue

פרמטרים

ReservedIP
נדרש. קביעת כתובת ה- IP השמורה עבורה יש להגדיר את ערך האפשרות.
OptCode
נדרש. קביעת הקוד עבור סוג האפשרות שאת ערכו יש להגדיר.
{BYTE | WORD | DWORD | STRING | IPADDRESS}
נדרש. קביעת סוג הנתונים עבור סוג האפשרות שאת ערכה יש להגדיר.
user=UserName
קביעת מחלקת המשתמש הנוכחית המוגדרת כברירת מחדל או המחלקה המוגדרת כ- UserName. אם התג ניתן אך לא הוגדר כל ערך, נעשה שימוש במחלקת המשתמש הנוכחית המוגדרת כברירת מחדל.
vendor=VendorName
קביעת מחלקת הספק הנוכחית המוגדרת כברירת מחדל או המחלקה המוגדרת כ- VendorName. אם התג ניתן, אך לא צוין ערך, נעשה שימוש במחלקת הספק הנוכחית המוגדרת כברירת מחדל.
OptValue
נדרש. קביעת הערך שיוקצה עבור סוג האפשרות שצוין ב- OptCode. אם סוג האפשרות תומך במערך המכיל יותר מערך מספרי או ערך כתובת IP אחד, ספק את הערכים הנוספים בסדר המועדף עליך, בסוף הפקודה והפרד כל ערך באמצעות רווח.

הערות

  • מחלקות ספק ומשתמש נתמכות רק עבור שרתי DHCP בהם פועל Windows 2000 Server.
  • כדי לשנות את ברירות המחדל הנוכחיות עבור מחלקה שלא צוינה המשמשת עם פקודה זו, השתמש ב- set userclass או ב- set vendorclass.

דוגמאות

בדוגמה הבאה, פקודה זו מגדירה את הערך של אפשרות הנתב (קוד 003) עבור כתובת ה- IP השמורה של לקוח, שהיא 10.1.1.50, בטווח הנוכחי כך שתגדיר כתובות IP של 10.1.1.1 ו- 10.1.1.2 עבור הנתבים המוגדרים (שערים המשמשים כברירת מחדל).

set reservedoptionvalue 10.1.1.50 003 IPADDRESS 10.1.1.1 10.1.1.2

set scope

קביעת הטווח עבור שימוש בפעולות עוקבות.

תחביר

set scope ScopeAddress

פרמטרים

ScopeAddress
נדרש. קביעת כתובת ה- IP של הטווח בו יש להשתמש בפעולות פקודה עוקבות.

דוגמאות

בדוגמה הבאה, פקודה זו מגדירה את הטווח הנוכחי ל- 10.2.2.0 עבור פעולות עוקבות.

set scope 10.2.2.0

set state

הגדרה או איפוס של מצב הטווח הנוכחי למצב פעיל או בלתי פעיל. ללא פרמטרים, פקודה זו הופכת את הטווח לפעיל.

תחביר

set state [{0 | 1 | 2 | 3}]‎

פרמטרים

‎{0 | 1 | 2 | 3}‎
ציון מצב הטווח: 0-הפיכת הטווח ללא פעיל, 1-הפיכת הטווח לפעיל (ברירת מחדל), 2-הפיכת הטווח ללא פעיל וסימון הטווח כ- "Switched,"‏ 3-הפיכת הטווח לפעיל וסימון הטווח כ- "Switched".

הערות

  • 2 ו- 3 משמשים בדרך כלל עבור רשתות ממותגות בהן מתארחות רשתות לוגיות מרובות ברשת פיזית אחת.

דוגמאות

בדוגמה הראשונה, פקודה זו הופכת את הטווח לפעיל.

בדוגמה השניה, פקודה זו הופכת את הטווח ללא פעיל.

set state 1

set state 0

set superscope

הגדרת טווח העל בו יש להשתמש בפעולות עוקבות.

תחביר

set superscope SuperscopeName {0 | 1}‎

פרמטרים

SuperscopeName
נדרש. קביעת שם טווח העל שיכלול את הטווח הנוכחי. SuperscopeName הוא תלוי רישיות.
‎{0 | 1}‎
נדרש. ציון אם להגדיר את מצב טווח העל כפעיל או כלא פעיל: 0-הפיכת טווח העל ללא פעיל, 1-הפיכת טווח העל לפעיל.

דוגמאות

בדוגמה הבאה, פקודה זו מוסיפה את הטווח הנוכחי לטווח העל MySuperScope והופכת את טווח העל לפעיל.

set superscope MySuperScope 1

show clients

הצגת כל לקוחות גירסה 4 הזמינים עבור הטווח הנוכחי. ללא פרמטרים, פקודה זו מציגה את המידע הבא עבור כל לקוח: כתובת IP, מסיכת רשת משנה, מזהה ייחודי, תפוגת חכירה וסוג.

תחביר

show clients ‎[{0 | 1}]‎

פרמטרים

‎{0 | 1}‎
ציון רמת פירוט של הפלט: 0-הצגת המידע הבא עבור כל לקוח: כתובת IP, מסיכת רשת משנה, מזהה ייחודי, תפוגת חכירה וסוג נתונים (ברירת מחדל), 1-הצגת כל המידע שמספקת האפשרות 0 ובנוסף, הצגת שם קבוצת מחשבים מלא (FQDN) של כל לקוח.

הערות

  • להצגת הפלט של פקודה זו בצורה יעילה, הגדל את רוחב חלון שורת הפקודה כך שיכיל לפחות 95 תווים.

show clientsv5

הצגת כל לקוחות גירסה 5 הזמינים עבור הטווח הנוכחי. ללא פרמטרים, פקודה זו מציגה את המידע הבא עבור כל לקוח: כתובת IP, מסיכת רשת משנה, מזהה ייחודי, תפוגת חכירה וסוג.

תחביר

show clientsv5 ‎[{0 | 1}]‎

פרמטרים

‎{0 | 1}‎
ציון רמת הפירוט של הפלט: 0-הצגת המידע הבא עבור כל לקוח: כתובת IP, מסיכת רשת משנה, מזהה ייחודי, תפוגת חכירה, סוג (ברירת מחדל), 1-הצגת כל המידע שמספקת האפשרות 0 ובנוסף, הצגת שם קבוצת מחשבים מלא (FQDN) של כל לקוח.

הערות

  • להצגת הפלט של פקודה זו בצורה יעילה, הגדל את רוחב חלון שורת הפקודה כך שיכיל לפחות 95 תווים.

show excluderange

הצגת כל טווחי האי-כלילה של כתובות IP המוגדרים כעת עבור הטווח הנוכחי.

תחביר

show excluderange

פרמטרים

ללא

הערות

  • השתמש בפקודות רמת טווח אחרות כדי להוסיף ולמחוק טווחי אי-כלילה.

show iprange

הצגת כל טווחי הכתובות הזמינים עבור הטווח הנוכחי.

תחביר

show iprange

פרמטרים

ללא

show optionvalue

הצגת כל ערכי האפשרויות שהוגדרו עבור הטווח הנוכחי. ללא פרמטרים, פקודה זו עושה שימוש במחלקות המשתמש והספק הנוכחיות המוגדרות כברירת מחדל.

תחביר

show optionvalue [user=UserName] [vendor=VendorName]

פרמטרים

user=UserName
קביעה שהאפשרויות המוגדרות עבור מחלקת המשתמש שצוינה יוצגו. אם התג ניתן, אך לא צוין כל ערך, נעשה שימוש במחלקת המשתמש הנוכחית המוגדרת כברירת מחדל.
vendor=VendorName
קביעה שהאפשרויות המוגדרות עבור מחלקת הספק שצוינה יוצגו. אם התג ניתן, אך לא צוין כל ערך, נעשה שימוש במחלקת הספק הנוכחית המוגדרת כברירת מחדל.

הערות

  • מחלקות ספק ומשתמש נתמכות רק בשרתי DHCP בהם פועל Windows 2000 Server.
  • כדי לשנות את ברירות המחדל הנוכחיות עבור מחלקה שלא צוינה המשמשת עם פקודה זו, השתמש ב- set userclass או ב- set vendorclass.

דוגמאות

בדוגמה הבאה, פקודה זו מציגה את כל האפשרויות והערכים שהוגדרו בטווח הנוכחי עבור מחלקה המוגדרת על-ידי המשתמש My User Class.

show optionvalue user="My User Class"‎

show reservedip

הצגת כל כתובות ה- IP השמורות כעת עבור הטווח הנוכחי.

תחביר

show reservedip

פרמטרים

ללא

show reservedoptionvalue

הצגת כל ערכי האפשרות המוגדרים כעת עבור כתובת IP של לקוח שמור בטווח הנוכחי.

תחביר

show reservedoptionvalue ReservedIP [user=UserName] [vendor=VendorName]

פרמטרים

ReservedIP
נדרש. קביעת השמירה של כתובת ה- IP עבורה יש להציג אפשרויות המוקצות כעת.
user=UserName
קביעה שהאפשרויות המוגדרות עבור מחלקת המשתמש שצוינה יוצגו. אם התג ניתן, אך לא צוין כל ערך, נעשה שימוש במחלקת המשתמש הנוכחית המוגדרת כברירת מחדל.
vendor=VendorName
קביעה שהאפשרויות המוגדרות עבור מחלקת הספק שצוינה יוצגו. אם התג ניתן, אך לא צוין כל ערך, נעשה שימוש במחלקת הספק הנוכחית המוגדרת כברירת מחדל.

הערות

  • מחלקות ספק ומשתמש נתמכות רק בשרתי DHCP בהם פועל Windows 2000 Server.
  • כדי לשנות את ברירות המחדל הנוכחיות עבור מחלקה שלא צוינה המשמשת עם פקודה זו, השתמש ב- set userclass או ב- set vendorclass.

דוגמאות

בדוגמה הבאה, פקודה זו מציגה את ערכי האפשרות שהוגדרו עבור כתובת ה- IP השמורה 10.2.2.100 בטווח הנוכחי.

show reservedoptionvalue 10.2.2.100

show scope

הצגת מידע עבור הטווח הנוכחי.

תחביר

show scope

פרמטרים

ללא

show state

הצגה של מצב הטווח הנוכחי, המציין אם הוא פעיל או לא פעיל.

תחביר

show state

פרמטרים

ללא

Netsh DHCP server mscope

את הפקודות הבאות ניתן להפעיל משורת הפקודה dhcp server mscope>‎, שבסיסה נמצא בסביבת netsh.

להצגת תחביר הפקודה, לחץ על פקודה:

add excluderange

הוספת טווח כתובות שלא נכללו לטווח השידור לקבוצה הנוכחי.

תחביר

add excluderange StartIP EndIP

פרמטרים

StartIP
נדרש. קביעת כתובת ה- IP הפותחת את טווח האי-כלילה.
EndIP
נדרש. קביעת כתובת ה- IP המסיימת את טווח האי-כלילה.

הערות

  • על טווח האי-כלילה להיות רשת משנה של טווח הכתובות הכולל.

דוגמאות

בדוגמה הבאה, פקודה זו מוסיפה טווח אי-כלילה המתחיל ב- 224.2.2.10 ומסתיים ב- 224.2.2.20 לטווח התפוצה של טווח השידור לקבוצה הנוכחי.

add excluderange 224.2.2.10 224.2.2.20

add iprange

הוספת טווח כתובות IP לטווח השידור לקבוצה הנוכחי.

תחביר

add iprange StartIP EndIP

פרמטרים

StartIP
נדרש. קביעת כתובת ה- IP הפותחת את הטווח.
EndIP
נדרש. קביעת כתובת ה- IP המסיימת את הטווח.

הערות

  • על הטווח להימצא בטווח החוקי של כתובות IP של שידור לקבוצה (מ- 224.0.0.0 עד 239.255.255.255).

דוגמאות

בדוגמה הבאה, פקודה זו מוסיפה את טווח כתובות ה- IP מ- 224.2.2.10 עד 224.2.2.20 לטווח ההפצה בטווח השידור לקבוצה.

add iprange 224.2.2.10 224.2.2.20

delete excluderange

מחיקת טווח אי-כלילה של כתובות IP שלא נכללו בעבר בטווח השידור לקבוצה הנוכחי.

תחביר

delete excluderange StartIP EndIP

פרמטרים

StartIP
נדרש. קביעת כתובת ה- IP הפותחת את טווח האי-כלילה.
EndIP
נדרש. קביעת כתובת ה- IP המסיימת את טווח האי-כלילה.

דוגמאות

בדוגמה הבאה, פקודה זו מסירה אי-כלילה של טווח שידור לקבוצה עם טווח של כתובות IP המתחיל ב- 224.2.2.10 ומסתיים ב- 224.2.2.20 עבור טווח השידור לקבוצה.

delete excluderange 224.2.2.10 224.2.2.20

delete iprange

מחיקת טווח כתובות IP מטווח השידור לקבוצה הנוכחי.

תחביר

delete iprange StartIP EndIP

פרמטרים

StartIP
נדרש. קביעת כתובת ה- IP הפותחת את הטווח שיש למחוק.
EndIP
נדרש. קביעת כתובת ה- IP המסיימת את הטווח שיש למחוק.

דוגמאות

בדוגמה הבאה, פקודה זו מוחקת את טווח כתובות ה- IP מ- 224.2.2.10 עד 224.2.2.20 מהטווח הכולל של טווח השידור לקבוצה המלא.

delete iprange 224.2.2.10 224.2.2.20

initiate reconcile

בדיקה והשגת פשרה בטווח השידור לקבוצה הנוכחי.

תחביר

initiate reconcile

פרמטרים

ללא

הערות

  • פקודה זו בודקת את תקינות טווח השידור לקבוצה הנוכחי על-ידי השוואת התוכן הנוכחי של מסד הנתונים של השרת לעותק שעבר שיקוף של אותו מידע ברישום Windows. אם מאותרים מקרים של חוסר עקביות במסד הנתונים, הם מתוקנים על בסיס המידע המשוכפל ברישום. תמיד נעשה ניסיון לתיקון כל חוסר עקביות שנמצא.

set comment

הגדרת ההערה עבור טווח השידור לקבוצה הנוכחי.

תחביר

set comment NewComment

פרמטרים

NewComment
נדרש. קביעת הערה חדשה או מתוקנת עבור טווח השידור לקבוצה.

דוגמאות

בדוגמה הראשונה, פקודה זו משנה את ההערה של טווח השידור לקבוצה עם הערה חדשה שאינה מכילה רווחים.

בדוגמה השניה, פקודה זו משנה את ההערה של טווח השידור לקבוצה עם הערה חדשה המכילה רווחים.

set comment NewCommentNoSpaces

set comment "New Comment With Spaces"‎

set lease

הגדרת משך החכירה עבור כתובות ה- IP של טווח השידור לקבוצה.

תחביר

set lease Time

פרמטרים

Time
נדרש. ציון משך החכירה עבור לקוחות טווח השידור לקבוצה. קביעת -1 מגדיר את משך חכירת כתובת ה- IP לזמן בלתי מוגבל או אינסופי.

דוגמאות

בדוגמה הבאה, פקודה זו מגדירה את משך החכירה עבור הלקוחות טווח השידור לקבוצה הנוכחי כ- 691200 שניות (שמונה ימים).

set lease 691200

set mscope

הגדרת טווח השידור לקבוצה בו יש להשתמש בפעולות עוקבות.

תחביר

set mscope NewName

פרמטרים

NewName
נדרש. קביעת השם של טווח השידור לקבוצה עבורו משתנה הקשר הפקודה. NewName הוא תלוי רישיות.

הערות

  • פקודה זו משנה את ההקשר של שורת הפקודה netsh dhcp server mscope>‎ מטווח שידור לקבוצה אחד לאחר.
  • פקודה זו אינה משנה את שמו של טווח השידור לקבוצה הנוכחי. כדי לשנות את שמו של טווח השידור לקבוצה הנוכחי, השתמש בפקודה set name.

דוגמאות

בדוגמה הראשונה, פקודה זו משנה את הקשר הפקודה לטווח שידור לקבוצה בשם MyMulticastScope. שים לב ששמו של טווח השידור לקבוצה אינו מכיל רווחים.

בדוגמה השניה, פקודה זו משנה את הקשר הפקודה לטווח שידור לקבוצה בשם My Multicast Scope. שים לב ששמו של טווח השידור לקבוצה מכיל רווחים.

set mscope MyMulticastScope

set mscope "My Multicast Scope"‎

set name

שינוי השם של טווח השידור לקבוצה הנוכחי.

תחביר

set name NewName

פרמטרים

NewName
נדרש. קביעת שם חדש עבור טווח השידור לקבוצה הנוכחי.

דוגמאות

בדוגמה הראשונה, פקודה זו מגדירה שם חדש שאינו מכיל רווחים עבור טווח השידור לקבוצה הנוכחי.

בדוגמה השניה, פקודה זו מגדירה שם חדש המכיל רווחים עבור טווח השידור לקבוצה הנוכחי.

set name NewNameNoSpaces

set name "New Name With Spaces"‎

set state

הגדרה או איפוס של מצב טווח השידור לקבוצה הנוכחי כך שיימצא במצב פעיל או לא פעיל.

תחביר

set state {0 | 1}‎

פרמטרים

‎{0 | 1}‎
נדרש. הגדרת מצב טווח השידור לקבוצה הנוכחי: 0-הפיכת טווח השידור לקבוצה הנוכחי ללא פעיל, 1-הפיכת טווח השידור לקבוצה לפעיל.

דוגמאות

בדוגמה הראשונה, פקודה זו הופכת את טווח השידור לקבוצה הנוכחי לפעיל.

בדוגמה השניה, פקודה זו הופכת את טווח השידור לקבוצה הנוכחי ללא פעיל.

set state 1

set state 0

set ttl

הגדרת ערך אורך החיים (TTL) עבור טווח השידור לקבוצה הנוכחי.

תחביר

set ttl TTL

פרמטרים

TTL
נדרש. קביעת ערך אורך החיים (TTL). הטווח החוקי עבור ערך זה הוא מספר בין 1 ל- 255.

דוגמאות

בדוגמה הבאה, פקודה זו מגדירה את ערך אורך החיים עבור טווח השידור לקבוצה הנוכחי ל- 32.

set ttl 32

show clients

הצגת כל הלקוחות הזמינים עבור טווח השידור לקבוצה הנוכחי.

תחביר

show clients

פרמטרים

ללא

הערות

  • להצגת הפלט של פקודה זו בצורה יעילה, הגדל את רוחב חלון שורת הפקודה כך שיכיל לפחות 95 תווים.

show excluderange

הצגת כל הטווחים הנוכחיים של כתובות IP שאינם נכללים עבור טווח השידור לקבוצה הנוכחי.

תחביר

show excluderange

פרמטרים

ללא

הערות

  • אם לא הוגדרו בעבר טווחי אי-כלילה עבור הטווח, הפלט של פקודה זו יהיה רשימה ריקה.

show iprange

הצגת כל טווחי כתובות ה- IP הזמינים עבור טווח השידור לקבוצה הנוכחי.

תחביר

show iprange

פרמטרים

ללא

show lease

הצגת הגדרות משך החכירה הנוכחיות עבור טווח השידור לקבוצה הנוכחי.

תחביר

show lease

פרמטרים

ללא

show mibinfo

הצגת מידע של בסיס מידע ניהול (MIB) עבור טווח השידור לקבוצה הנוכחי.

תחביר

show mibinfo

פרמטרים

ללא

show mscope

הצגת מידע עבור טווח השידור לקבוצה הנוכחי.

תחביר

show mscope

פרמטרים

ללא

show state

הצגת המצב של טווח השידור לקבוצה הנוכחי.

תחביר

show state

פרמטרים

ללא

show ttl

הצגת ערך אורך החיים (TTL) עבור טווח השידור לקבוצה הנוכחי.

תחביר

show ttl

פרמטרים

ללא


Netsh עבור DHCP - דוגמה

באפשרותך להשתמש בפקודות Netsh עבור Dynamic Host Configuration Protocol ‏(DHCP) בקבצי אצווה ובקבצי Script אחרים כדי להפוך משימות לאוטומטיות. בדוגמה שלהלן מוצג קובץ אצווה המדגים אופן השימוש בפקודות Netsh עבור DHCP לשם ביצוע מגוון של משימות קשורות.

בהליך לדוגמה זה, DHCP-01 הוא שרת DHCP שכתובת ה- IP שלו היא 192.168.0.2. ההליך מוסיף לשרת DHCP-01 תחום חדש עם השם MyScope , כתובת IP של 192.168.10.0, מסיכת רשת משנה של 255.255.255.0 וההערה NewScope. לאחר מכן מוגדר עבור התחום טווח כתובות (192.168.10.1 עד 192.168.10.254), טווח אי-כלילה (192.168.10.1 עד 192.168.10.25) וכתובות IP של נתב (אפשרות 003 של DHCP). לאחר מכן, מוגדר עבור התחום מצב פעיל.

לקבלת מידע נוסף ראה הגדרת טווחים, הגדרת אפשרויות ואפשרויות DHCP.

לקבלת מידע נוסף ורשימה מלאה של פקודות Netsh עבור DHCP, ראה פקודות Netsh עבור DHCP.

בהליך לדוגמה שלהלן, צוינה המחרוזת "rem" לפני שורות הכוללות הערות. Netsh מתעלם מההערות.

rem one DHCP server:‎
rem (DHCP-01) 192.168.0.2

rem 1. Connect to (DHCP-01), and add the scope MyScope with IP address 192.168.10.0,
rem 1.1  subnet mask 255.255.255.0, and the comment NewScope.
netsh dhcp server 192.168.0.2 add scope 192.168.10.0 255.255.255.0 MyScope NewScope

rem 2. Connect to (DHCP-01 MyScope), and add IP address range 192.168.10.1 to 192.168.10.254 for distribution
rem 2.1  and the default ClientType of DHCP.
netsh dhcp server 192.168.0.2 scope 192.168.10.0 add iprange 192.168.10.1 192.168.10.254

rem 3. Connect to (DHCP-01 MyScope), and add IP exclusion range 192.168.10.1 to 192.168.10.25
rem 3.1  and the default ClientType of DHCP.
netsh dhcp server 192.168.0.2 scope 192.168.10.0 add excluderange 192.168.10.1 192.168.10.25

rem 4. Connect to (DHCP-01 MyScope), and set the value of option code 003
rem 4.1   to list two router IP addresses (10.1.1.1, 10.1.1.2).
netsh dhcp server 192.168.0.2 scope 192.168.10.0 set optionvalue 003 IPADDRESS 10.1.1.1 10.1.1.2

rem 5.  Connect to (DHCP-01 MyScope), and set the scope state to active.
netsh dhcp server 192.168.0.2 scope 192.168.10.0 set state 1

rem 6. End example batch file.

הטבלה הבאה מפרטת את פקודות netsh dhcp שנעשה בהן שימוש בהליך לדוגמה שהוצג לעיל.

פקודה | תיאור
server | העברה של הקשר שורת הפקודה הנוכחי של DHCP אל השרת שצוין לפי שם או לפי כתובת IP.
add scope | הוספת תחום חדש לשרת DHCP שצוין.
scope | החלפת הקשר הפקודה אל תחום DHCP שצוין באמצעות כתובת IP.
add iprange | הוספת טווח של כתובות IP לתחום הנוכחי.
add excluderange | הוספת טווח אי-כלילה של כתובות עבור התחום הנוכחי.
set optionvalue | הגדרת ערך אפשרות עבור התחום הנוכחי.
set state | הגדרה או איפוס מצבו של התחום הנוכחי למצב פעיל או למצב בלתי פעיל.


פקודות אבחון (diag) של Netsh

באפשרותך להשתמש בפקודות Netsh Network Diagnostics, או הקשר האבחון (Diag), כדי לנהל ולפתור בעיות של מערכת הפעלה ושל פרמטרים של שירות רשת משורת הפקודה. הקשר האבחון של Netsh בשורת הפקודה הוא netsh diag>‎.

הפקודות שלהלן זמינות בשורת הפקודה עבור הקשר האבחון של Netsh (להבדיל משורת הפקודה של Windows XP). הקשר Diag של Netsh הוא תכונה חדשה של Windows XP. אין באפשרותך להפעיל פקודות Netsh Diag מרחוק ב- Windows 2000 Server.

לקבלת מידע נוסף אודות netsh, ראה שימוש ב- Netsh.

לשם הצגת תחביר פקודה, לחץ על פקודה:

connect ieproxy

קביעה, אימות ושחרור של התקשרות TCP/IP עם שרת Proxy שצוין ב- Internet Explorer.

תחביר

connect ieproxy

פרמטרים

ללא

הערות

  • אם לא צוין שרת Proxy ב- Internet Explorer, הפלט שיתקבל מן הפקודה דומה לזה:
    Internet Explorer Proxy (Not Configured)‎
    Not Configured
  • אם ציינת ב- Internet Explorer שרת Proxy הנקרא corpproxy שמספר היציאה שלו הוא 80, הפלט המתקבל מן הפקודה יהיה דומה לזה:
    Internet Explorer Proxy (corpproxy)‎
    IEProxyPort = 80‎
    IEProxy = corpproxy
    Server appears to be running on port(s) [80]‎

connect iphost

יצירה, אימות ושחרור של התקשרות TCP/IP אל שרת שצוין, באמצעות יציאה שצוינה.

תחביר

connect iphost Host Port

פרמטרים

Host
ציון כתובת IP, שם NetBIOS או שם קבוצת מחשבים מלא של המחשב המארח שברצונך להתקשר אליו.
Port
ציון היציאה שבאמצעותה ברצונך להתקשר.

דוגמאות

כדי להתקשר למחשב מארח ששמו microsoft.com באמצעות יציאה 28, הקלד:

connect iphost microsoft.com 28

connect mail

יצירה, אימות ושחרור של התקשרות TCP/IP עם הצומת שצוין כשרת דואר בפרופיל Outlook Express המהווה ברירת מחדל עבור המשתמש הנוכחי.

תחביר

connect mail

פרמטרים

ללא

connect news

יצירה, אימות ושחרור של התקשרות TCP/IP עם הצומת שצוין כשרת חדשות בפרופיל Outlook Express המהווה ברירת מחדל עבור המשתמש הנוכחי.

תחביר

connect news

פרמטרים

ללא

dump

יצירה של מקטע Script המכיל את התצורה הנוכחית.

תחביר

dump

פרמטרים

ללא

הערות

  • אם תשמור את מקטע ה- Script לקובץ, יהיה באפשרותך להשתמש בו לשם שחזור של הגדרות תצורה ששונו.

gui

הפעלת כלי האבחון עבור הרשת במרכז העזרה והתמיכה.

תחביר

gui

פרמטרים

ללא

ping

בדיקת קישוריות עם המארח המרוחק שצוין.

תחביר

ping Host

פרמטרים

Host
ציון כתובת IP, שם NetBIOS או שם קבוצת מחשבים מלא של המחשב המארח שברצונך לאמת קישוריות איתו.

ping adapter

אימות קישוריות עם מחשבים ועם התקנים אחרים (כגון נתבים) המזוהים במאפייני TCP/IP של מתאם או מתאמי הרשת שצוינו. ללא פרמטרים, הפקודה ping adapter מאמתת קישוריות עבור כל המתאמים שהותקנו.

תחביר

ping adapter [{IndexNumber | FullAdapterName | PartialAdapterName}]‎

פרמטרים

‎{IndexNumber | FullAdapterName | PartialAdapterName}‎
ציון המתאם או המתאמים שברצונך לאמת קישוריות עבורם. הפרמטר IndexNumber מציין את המתאם לפי מספרו האינדקסיאלי. הפרמטר FullAdapterName מציין את המתאם לפי שמו הרשום במערכת ההפעלה. הפרמטר PartialAdapterName מציין את המתאם או המתאמים ששמותיהם כוללים את רצף התווים שצוין בפרמטר. אם על רצף התווים להופיע בתחילת השם, הקלד כוכבית (*) בסוף הפרמטר. אם על רצף התווים להופיע בסוף השם, הקלד כוכבית בתחילת הפרמטר. אם רצף התווים עשוי להופיע בכל מקום שהוא בשם, הקלד כוכבית בתחילת הפרמטר וכוכבית בסופו.

הערות

  • פקודה זו מאמתת קישוריות עם כל המחשבים וההתקנים האחרים שתצורתם נקבעה במאפייני TCP/IP עבור כל מתאם רשת שתציין. לדוגמה, אם ברשותך מתאם רשת שמאפייני TCP/IP שלו נקבעו עם כתובות IP עבור שרת DNS מועדף, שער המהווה ברירת מחדל ושרת DHCP, הפקודה ping adapter תאמת קישוריות עם כל אחד מהתקנים אלה.
  • באפשרותך להשתמש בפקודה show adapter להצגת מספרים אינדקסיאליים ושמות מלאים של כל המתאמים הלוגיים שהוגדרו במחשב.
  • אם ברצונך לציין מתאם לפי מספרו האינדקסיאלי, אין צורך להקליד את האפסים המקדימים.

דוגמאות

כדי לאמת קישוריות לכל המחשבים וההתקנים האחרים שתצורתם נקבעה במאפייני TCP/IP עבור כל מתאם רשת, הקלד:

ping adapter

כדי לאמת קישוריות עם כל המחשבים וההתקנים האחרים שתצורתם נקבעה במאפייני TCP/IP עבור כל מתאם רשת שמספרו האינדקסיאלי 2, הקלד:

ping adapter 2

כדי לאמת קישוריות עם כל המחשבים וההתקנים האחרים שתצורתם נקבעה במאפייני TCP/IP עבור כל מתאם רשת ששמו מתחיל ב- ‎"net"‎, הקלד:

ping adapter net*‎

ping dhcp

אימות קישוריות עם שרתי DHCP ‏(Dynamic Host Configuration Protocol) שתצורתם נקבעה במאפייני TCP/IP עבור מתאם או מתאמי הרשת שצוינו. ללא פרמטרים, הפקודה ping dhcp תאמת קישוריות עם שרתי DHCP עבור כל המתאמים שהותקנו.

תחביר

ping dhcp [{IndexNumber | FullAdapterName | PartialAdapterName}]‎

פרמטרים

‎{IndexNumber | FullAdapterName | PartialAdapterName}‎
ציון המתאם או המתאמים שברצונך לאמת קישוריות עבורם. הפרמטר IndexNumber מציין את המתאם לפי מספרו האינדקסיאלי. הפרמטר FullAdapterName מציין את המתאם לפי שמו כפי שנרשם במערכת ההפעלה. הפרמטר PartialAdapterName מציין את המתאם או המתאמים ששמותיהם מכילים את רצף התווים שצוין בפרמטר. אם על רצף התווים להופיע בתחילת השם, הקלד כוכבית (*) בסוף הפרמטר. אם על רצף התווים להופיע בסוף השם, הקלד כוכבית בתחילת הפרמטר. אם רצף התווים עשוי להופיע בכל מקום שהוא בשם, הקלד כוכבית בתחילת הפרמטר וכוכבית בסופו.

הערות

  • באפשרותך להשתמש בפקודה show adapter להצגת מספריהם האינדקסיאליים ושמותיהם המלאים של כל המתאמים הלוגיים שהוגדרו במחשב.
  • אם ברצונך לציין מתאם באמצעות מספרו האינדקסיאלי, אין צורך להקליד את האפסים המקדימים.

דוגמאות

כדי לאמת קישוריות לשרת DHCP שתצורתו נקבעה במאפייני TCP/IP עבור כל מתאם רשת, הקלד:

ping dhcp

כדי לאמת קישוריות עם שרת DHCP שתצורתו נקבעה במאפייני TCP/IP עבור מתאם רשת שמספרו האינדקסיאלי 2, הקלד:

ping dhcp 2

כדי לאמת קישוריות לשרת DHCP שתצורתו נקבעה במאפייני TCP/IP עבור כל מתאם רשת ששמו מתחיל ב- ‎"net"‎, הקלד:

ping dhcp net*‎

ping dns

אימות קישוריות עם שרתי DNS ‏(Domain Name System) שתצורתם נקבעה במאפייני TCP/IP של המתאם או המתאמים שצוינו. ללא פרמטרים, הפקודה ping dns מאמתת קישוריות עם שרתי DNS עבור כל המתאמים שהותקנו.

תחביר

ping dns [{IndexNumber | FullAdapterName | PartialAdapterName}]‎

פרמטרים

‎{IndexNumber | FullAdapterName | PartialAdapterName}‎
ציון המתאם או המתאמים שברצונך לאמת קישוריות עבורם. הפרמטר IndexNumber מציין את המתאם לפי מספרו האינדקסיאלי. הפרמטר FullAdapterName מציין את המתאם לפי שמו כפי שנרשם במערכת ההפעלה. הפרמטר PartialAdapterName מציין את המתאם או המתאמים ששמותיהם כוללים את רצף התווים שצוין בפרמטר. אם על רצף התווים להופיע בתחילת השם, הקלד כוכבית (*) בסוף הפרמטר. אם על רצף התווים להופיע בסוף השם, הקלד כוכבית בתחילת הפרמטר. אם רצף התווים עשוי להופיע בכל מקום שהוא בשם, הקלד כוכבית בתחילת הפרמטר וכוכבית בסופו.

הערות

  • באפשרותך להשתמש בפקודה show adapter כדי להציג את מספריהם האינדקסיאליים ואת שמותיהם המלאים של כל המתאמים הלוגיים שהוגדרו במחשב.
  • אם ברצונך לציין מתאם לפי מספרו האינדקסיאלי, אין צורך להקליד את האפסים המקדימים.

דוגמאות

כדי לאמת קישוריות עם שרת DNS שתצורתו נקבעה במאפייני TCP/IP עבור כל מתאם רשת, הקלד:

ping dns

כדי לאמת קישוריות עם שרת DNS שתצורתו נקבעה במאפייני TCP/IP עבור מתאם רשת שמספרו האינדקסיאלי 2, הקלד:

ping dns 2

כדי לאמת קישוריות עם שרת DNS שתצורתו נקבעה במאפייני TCP/IP עבור על מתאם רשת ששמו מתחיל ב- ‎"net"‎, הקלד:

ping dns net*‎

ping gateway

אימות קישוריות עם שרתי שער המהווים ברירת מחדל, שהוגדרו במאפייני TCP/IP של המתאם או המתאמים שצוינו. ללא פרמטרים, הפקודה ping gateway מאמתת קישוריות עבור כל המתאמים שהותקנו.

תחביר

ping gateway [{IndexNumber | FullAdapterName | PartialAdapterName}]‎

פרמטרים

‎{IndexNumber | FullAdapterName | PartialAdapterName}‎
ציון המתאם או המתאמים שברצונך לאמת קישוריות עבורם. הפרמטר IndexNumber מציין את המתאם לפי מספרו האינדקסיאלי. הפרמטר FullAdapterName מציין את המתאם לפי שמו כפי שנרשם במערכת ההפעלה. הפרמטר PartialAdapterName מציין את המתאם או המתאמים ששמותיהם כוללים את רצף התווים שצוין בפרמטר. אם על רצף התווים להופיע בתחילת השם, הקלד כוכבית (*) בסוף הפרמטר. אם על רצף התווים להופיע בסוף השם, הקלד כוכבית בתחילת הפרמטר. אם רצף התווים עשוי להופיע בכל מקום שהוא בשם, הקלד כוכבית בתחילת הפרמטר וכוכבית בסופו.

הערות

  • באפשרותך להשתמש בפקודה show adapter כדי להציג את מספריהם האינדקסיאליים ואת שמותיהם המלאים של כל המתאמים הלוגיים שהוגדרו במחשב.
  • אם ברצונך לציין מתאם לפי מספרו האינדקסיאלי, אין צורך להקליד את האפסים המקדימים.

דוגמאות

כדי לאמת קישוריות עם שרת השער שהוגדר במאפייני TCP/IP עבור כל מתאם רשת, הקלד:

ping gateway

כדי לאמת קישוריות עם שרת שער שהוגדר במאפייני TCP/IP עבור מתאם רשת שמספרו האינדקסיאלי 2, הקלד:

ping gateway 2

כדי לאמת קישוריות עם שרת שער שהוגדר במאפייני TCP/IP עבור כל מתאם רשת ששמו מתחיל ב- ‎"net"‎, הקלד:

ping gateway net*‎

ping ieproxy

אימות קישוריות עם שרת Proxy של אינטרנט עבור Internet Explorer.

תחביר

ping ieproxy

פרמטרים

ללא

ping ip

אימות קישוריות עם כל כתובות ה- IP עבור המתאם או המתאמים שצוינו. ללא פרמטרים, הפקודה ping ip מאמתת קישוריות עבור כל המתאמים שהותקנו.

תחביר

ping ip [{IndexNumber | FullAdapterName | PartialAdapterName}]‎

פרמטרים

‎{IndexNumber | FullAdapterName | PartialAdapterName}‎
ציון המתאם או המתאמים שברצונך לאמת קישוריות עבורם. הפרמטר IndexNumber מציין את המתאם לפי מספרו האינדקסיאלי. הפרמטר FullAdapterName מציין את המתאם לפי שמו כפי שנרשם במערכת ההפעלה. הפרמטר PartialAdapterName מציין את המתאם או המתאמים ששמותיהם כוללים את רצף התווים שצוין בפרמטר. אם על רצף התווים להופיע בתחילת השם, הקלד כוכבית (*) בסוף הפרמטר. אם על רצף התווים להופיע בסוף השם, הקלד כוכבית בתחילת הפרמטר. אם רצף התווים עשוי להופיע בכל מקום שהוא בשם, הקלד כוכבית בתחילת הפרמטר וכוכבית בסופו.

הערות

  • באפשרותך להשתמש בפקודה show adapter כדי להציג את מספריהם האינדקסיאליים ואת שמותיהם המלאים של כל המתאמים הלוגיים שהוגדרו במחשב.
  • אם ברצונך לציין מתאם לפי מספרו האינדקסיאלי, אין צורך להקליד את האפסים המקדימים.

דוגמאות

כדי לאמת קישוריות עם כל מתאם רשת, הקלד:

ping ip

כדי לאמת קישוריות עם מתאם הרשת שמספרו האינדקסיאלי 2, הקלד:

ping ip 2

כדי לאמת קישוריות עם כל מתאם רשת ששמו מתחיל ב- ‎"net"‎, הקלד:

ping ip net*‎

ping iphost

אימות קישוריות עם מחשב מארח מקומי או מרוחק.

תחביר

ping iphost Node

פרמטרים

Node
ציון מארח לפי כתובת IP, שם NetBIOS או שם קבוצת המחשבים המלא שלו.

דוגמאות

כדי לאמת קישוריות עם המחשב המארח המקומי (בכתובת הלולאה החוזרת 127.0.0.1), הקלד:

ping iphost 127.0.0.1

כדי לאמת קישוריות עם המחשב המארח microsoft.com, הקלד:

ping iphost microsoft.com

ping loopback

אימות קישוריות עם כתובת הלולאה החוזרת של המחשב המארח המקומי (127.0.0.1).

תחביר

ping loopback

פרמטרים

ללא

ping mail

אימות קישוריות עם שרת הדואר שהוגדר בפרופיל Outlook Express המהווה ברירת מחדל עבור המשתמש הנוכחי.

תחביר

ping mail

פרמטרים

ללא

ping news

אימות קישוריות עם שרת החדשות שהוגדר בפרופיל Outlook Express המהווה ברירת מחדל עבור המשתמש הנוכחי.

תחביר

ping news

פרמטרים

ללא

ping wins

אימות קישוריות עם שרת WINS ‏(Windows Internet Name Service) המועדף ועם שרת WINS החלופי עבור מתאם או מתאמי הרשת שצוינו. ללא פרמטרים, הפקודה ping wins מאמתת קישוריות עבור כל המתאמים שהותקנו.

תחביר

ping wins [{IndexNumber | FullAdapterName | PartialAdapterName}]‎

פרמטרים

‎{IndexNumber | FullAdapterName | PartialAdapterName}‎
ציון המתאם או המתאמים שברצונך לאמת קישוריות עבורם. הפרמטר IndexNumber מציין את המתאם לפי מספרו האינדקסיאלי. הפרמטר FullAdapterName מציין את המתאם לפי שמו כפי שנרשם במערכת ההפעלה. הפרמטר PartialAdapterName מציין את המתאם או המתאמים ששמותיהם כוללים את רצף התווים שצוין בפרמטר. אם על רצף התווים להופיע בתחילת השם, הקלד כוכבית (*) בסוף הפרמטר. אם על רצף התווים להופיע בסוף השם, הקלד כוכבית בתחילת הפרמטר. אם רצף התווים עשוי להופיע בכל מקום שהוא בשם, הקלד כוכבית בתחילת הפרמטר וכוכבית בסופו.

הערות

  • באפשרותך להשתמש בפקודה show adapter כדי להציג את מספריהם האינדקסיאליים ואת שמותיהם המלאים של כל המתאמים הלוגיים שהוגדרו במחשב.
  • אם ברצונך לציין מתאם לפי מספרו האינדקסיאלי, אין צורך להקליד את האפסים המקדימים.

דוגמאות

כדי לאמת קישוריות עם שרתי WINS שכתובות ה- IP שלהם הוגדרו במאפייני TCP/IP של כל מתאם שהותקן, הקלד:

ping wins

כדי לאמת קישוריות עם שרתי WINS שכתובות ה- IP שלהם הוגדרו במאפייני TCP/IP של כל מתאם שהותקן ושמספרו האינדקסיאלי 2, הקלד:

ping wins 2

show adapter

הצגת מידע אודות המתאם או המתאמים הלוגיים שצוינו. ללא פרמטרים, תביא הפקודה show adapter להצגת מידע אודות כל המתאמים שהוגדרו עבור שרת זה.

תחביר

show adapter [{IndexNumber | FullAdapterName | PartialAdapterName}] [{/v | /p}]‎

פרמטרים

‎{IndexNumber | FullAdapterName | PartialAdapterName}‎
ציון המתאם או המתאמים שעבורם ברצונך להציג מידע. הפרמטר IndexNumber מציין את המתאם לפי מספרו האינדקסיאלי. הפרמטר FullAdapterName מציין את המתאם לפי שמו כפי שנרשם במערכת ההפעלה. הפרמטר PartialAdapterName מציין את המתאם או המתאמים ששמותיהם כוללים את רצף התווים שצוין בפרמטר. אם על רצף התווים להופיע בתחילת השם, הקלד כוכבית (*) בסוף הפרמטר. אם על רצף התווים להופיע בסוף השם, הקלד כוכבית בתחילת הפרמטר. אם רצף התווים עשוי להופיע בכל מקום שהוא בשם, הקלד כוכבית בתחילת הפרמטר וכוכבית בסופו.
‎{/v | /p}‎
מציין אם יש להציג שדות שערכיהם ריקים. הפרמטר ‎/v מציין כי יש להציג את השדות. הפרמטר ‎/p מציין כי אין להציג את השדות.

הערות

  • פקודה זו מציינת כל מתאם לפי מספרו האינדקסיאלי, המוצג בסוגריים מרובעים ואחריו שם המתאם שנרשם. פלט לדוגמה עשוי להיראות כך:

    • Network Adapters

    1. ‎[00000001] 3Com 3C920 Integrated Fast Ethernet Controller (3C905C-TX Compatible)‎
    2. ‎[00000002] RAS Async Adapter
    3. ‎[00000003] WAN Miniport (L2TP)‎
    4. ‎[00000004] WAN Miniport (PPTP)‎
    5. ‎[00000005] WAN Miniport (PPPOE)‎
    6. ‎[00000006] Direct Parallel
    7. ‎[00000007] WAN Miniport (IP)‎
    8. ‎[00000008] WAN Miniport (Network Monitor)‎

דוגמאות

לשם הצגת המתאמים הלוגיים שהוגדרו במחשב, הקלד:

show adapter

show all

פירוט של כל פריטי הרשת שהוגדרו עבור השרת המקומי. ללא פרמטרים, תביא הפקודה show all להצגת מבט כולל של מידע התצורה עבור רכיבי התוכנה והחומרה הבאים: Default Outlook Express Mail, ‏Default Outlook Express News, שרת Proxy עבור אינטרנט של Internet Explorer, לולאה חוזרת, מערכת מחשב, מערכת הפעלה, גירסה, מודמים, מתאמי רשת ולקוחות רשת.

תחביר

show all [{/v | /p}]‎

פרמטרים

‎{/v | /p}‎
מציין האם יש להציג שדות עם ערכים ריקים. הפרמטר ‎/v מציין כי יש להציג את השדות. הפרמטר ‎/p מציין כי אין להציג את השדות.

הערות

  • הפלט של פקודה זו עשוי להיות ארוך מאוד, וכולל מידע תצורה אודות דואר, חדשות ושרתי Proxy. הפקודה מציגה גם מידע אודות כתובת לולאה חוזרת של TCP/IP ופרטים אודות המחשב, מערכת ההפעלה, וכל מתאמי הרשת ולקוחות הרשת.

show client

הצגת כל לקוחות הרשת שהוגדרו עבור המתאם או המתאמים שצוינו. ללא פרמטרים, תציג הפקודה show client את הלקוחות עבור כל המתאמים שהותקנו.

תחביר

show client [{IndexNumber | FullAdapterName | PartialAdapterName}] [{/v | /p}]‎

פרמטרים

‎{IndexNumber | FullAdapterName | PartialAdapterName}‎
ציון המתאם או המתאמים שעבורם יש להציג פירוט לקוחות. הפרמטר IndexNumber מציין את המתאם לפי מספרו האינדקסיאלי. הפרמטר FullAdapterName מציין את המתאם לפי שמו כפי שנרשם במערכת ההפעלה. הפרמטר PartialAdapterName מציין את המתאם או המתאמים ששמותיהם כוללים את רצף התווים שצוין בפרמטר. אם על רצף התווים להופיע בתחילת השם, הקלד כוכבית (*) בסוף הפרמטר. אם על רצף התווים להופיע בסוף השם, הקלד כוכבית בתחילת הפרמטר. אם רצף התווים עשוי להופיע בכל מקום שהוא בשם, הקלד כוכבית בתחילת הפרמטר וכוכבית בסופו.
‎{/v | /p}‎
מציין האם יש להציג שדות שערכיהם ריקים. הפרמטר ‎/v מציין שיש להציג את השדות. הפרמטר ‎/p מציין שאין להציג את השדות.

הערות

  • באפשרותך להשתמש בפקודה show adapter כדי להציג את מספריהם האינדקסיאליים ואת שמותיהם המלאים של כל המתאמים הלוגיים שהוגדרו במחשב.
  • אם ברצונך לציין מתאם לפי מספרו האינדקסיאלי, אין צורך להקליד את האפסים המקדימים.

דוגמאות

להצגת פירוט של כל לקוחות הרשת שהוגדרו עבור כל מתאמי הרשת במחשב המארח, הקלד:

show client

להצגת כל השדות שערכיהם אינם ריקים עבור כל לקוחות הרשת שהוגדרו עבור מתאם הרשת שמספרו 2, הקלד:

show client 2 /p

show computer

הצגת פרטי WMI ‏(Windows Management Interface) עבור השרת. ללא פרמטרים, תציג הפקודה show computer את שם NetBIOS של המחשב המקומי.

תחביר

show computer [{/v | /p}]‎

פרמטרים

‎{/v | /p}‎
מציין האם יש להציג שדות שערכיהם ריקים. הפרמטר ‎/v מציין כי יש להציג את השדות. הפרמטר ‎/p מציין כי אין להציג את השדות.

דוגמאות

כדי להציג פירוט של כל פרמטרי הממשק של WMI שאינם ריקים עבור השרת, הקלד:

show computer /p

show dhcp

פירוט של כל שרתי DHCP שהוגדרו עבור המתאם שצוין. ללא פרמטרים, תביא הפקודה show dhcp להצגה של רשימת השרתים שהוגדרו עבור כל המתאמים שהותקנו.

תחביר

show dhcp {IndexNumber | FullAdapterName | PartialAdapterName} [{/v | /p}]‎

פרמטרים

‎{IndexNumber | FullAdapterName | PartialAdapterName}‎
ציון המתאם או המתאמים שברצונך להציג פירוט שרתים עבורם. הפרמטר IndexNumber מציין את המתאם לפי מספרו האינדקסיאלי. הפרמטר FullAdapterName מציין את המתאם לפי שמו כפי שנרשם במערכת ההפעלה. הפרמטר PartialAdapterName מציין את המתאם או המתאמים ששמותיהם כוללים את רצף התווים שצוין בפרמטר. אם על רצף התווים להופיע בתחילת השם, הקלד כוכבית (*) בסוף הפרמטר. אם על רצף התווים להופיע בסוף השם, הקלד כוכבית בתחילת הפרמטר. אם רצף התווים עשוי להופיע בכל מקום שהוא בשם, הקלד כוכבית בתחילת הפרמטר וכוכבית בסופו.
‎{/v | /p}‎
מציין האם יש להציג שדות שערכיהם ריקים. הפרמטר ‎/v מציין כי יש להציג את השדות. הפרמטר ‎/p מציין כי אין להציג את השדות.

הערות

  • באפשרותך להשתמש בפקודה show adapter כדי להציג את מספריהם האינדקסיאליים ואת שמותיהם המלאים של כל המתאמים הלוגיים שהוגדרו במחשב.
  • אם ברצונך לציין מתאם לפי מספרו האינדקסיאלי, אין צורך להקליד את האפסים המקדימים.

דוגמאות

כדי להציג פירוט של כל שרתי DHCP שהוגדרו עבור כל מתאמי הרשת, הקלד:

show dhcp /v

כדי להציג פירוט של כל שרתי DHCP שהוגדרו עבור מתאם הרשת שמספרו 2, הקלד:

show dhcp 2

show dns

פירוט של כל שרתי DNS שהוגדרו עבור המתאם שצוין. ללא פרמטרים, תביא הפקודה show dns להצגה של רשימת כל השרתים שהוגדרו עבור כל המתאמים שהותקנו.

תחביר

show dns [{IndexNumber | FullAdapterName | PartialAdapterName}] [{/v | /p}]‎

פרמטרים

‎{IndexNumber | FullAdapterName | PartialAdapterName}‎
ציון המתאם או המתאמים שברצונך להציג פירוט שרתים עבורם. הפרמטר IndexNumber מציין את המתאם לפי מספרו האינדקסיאלי. הפרמטר FullAdapterName מציין את המתאם לפי שמו כפי שנרשם במערכת ההפעלה. הפרמטר PartialAdapterName מציין את המתאם או המתאמים ששמותיהם כוללים את רצף התווים שצוין בפרמטר. אם על רצף התווים להופיע בתחילת השם, הקלד כוכבית (*) בסוף הפרמטר. אם על רצף התווים להופיע בסוף השם, הקלד כוכבית בתחילת הפרמטר. אם רצף התווים עשוי להופיע בכל מקום שהוא בשם, הקלד כוכבית בתחילת הפרמטר וכוכבית בסופו.
‎{/v | /p}‎
מציין האם יש להציג שדות שערכיהם ריקים. הפרמטר ‎/v מציין שיש להציג את השדות. הפרמטר ‎/p מציין שאין להציג את השדות.

הערות

  • באפשרותך להשתמש בפקודה show adapter כדי להציג את מספריהם האינדקסיאליים ואת שמותיהם המלאים של כל המתאמים הלוגיים שהוגדרו במחשב.
  • אם ברצונך לציין מתאם לפי מספרו האינדקסיאלי, אין צורך להקליד את האפסים המקדימים.

דוגמאות

כדי להציג פירוט של כל הפרטים שאינם ריקים אודות כל שרתי DNS שהוגדרו עבור כל מתאמי הרשת, הקלד:

show dns /p

כדי להציג פירוט עבור כל שרתי DNS שהוגדרו עבור מתאם הרשת שמספרו 2, הקלד:

show dns 2

show gateway

פירוט של כל שערי האינטרנט שהוגדרו עבור מתאם או מתאמים שצוינו. ללא פרמטרים, תביא הפקודה show gateway להצגה של רשימת כל השערים שהוגדרו עבור כל המתאמים שהותקנו.

תחביר

show gateway [{IndexNumber | FullAdapterName | PartialAdapterName}] [{/v | /p}]‎

פרמטרים

‎{IndexNumber | FullAdapterName | PartialAdapterName}‎
ציון המתאמים או המתאמים שברצונך בפירוט שערים עבורם. הפרמטר IndexNumber מציין את המתאם לפי מספרו האינדקסיאלי. הפרמטר FullAdapterName מציין את המתאם לפי שמו כפי שנרשם במערכת ההפעלה. הפרמטר PartialAdapterName מציין את המתאם או המתאמים ששמותיהם כוללים את רצף התווים שצוין בפרמטר. אם על רצף התווים להופיע בתחילת השם, הקלד כוכבית (*) בסוף הפרמטר. אם על רצף התווים להופיע בסוף השם, הקלד כוכבית בתחילת הפרמטר. אם רצף התווים עשוי להופיע בכל מקום שהוא בשם, הקלד כוכבית בתחילת הפרמטר וכוכבית בסופו.
‎{/v | /p}‎
מציין האם יש להציג שדות שערכיהם ריקים. הפרמטר ‎/v מציין שיש להציג את השדות. הפרמטר ‎/p מציין שאין להציג את השדות.

הערות

  • באפשרותך להשתמש בפקודה show adapter כדי להציג את מספריהם האינדקסיאליים ואת שמותיהם המלאים של כל המתאמים הלוגיים שהוגדרו במחשב.
  • אם ברצונך לציין מתאם לפי מספרו האינדקסיאלי, אין צורך להקליד את האפסים המקדימים.

דוגמאות

כדי להציג פירוט של כל הפרטים זמינים אודות כל שערי האינטרנט שהוגדרו עבור כל המתאמים, הקלד:

show gateway /v

כדי להציג פירוט של כל הערכים שאינם ריקים עבור כל השערים שהוגדרו עבור מתאם הרשת שמספרו 3, הקלד:

show gateway 3 /p

show ieproxy

הצגת פירוט של שרתי Proxy של Internet Explorer שהוגדרו עבור המתאם או המתאמים שצוינו. ללא פרמטרים, תביא הפקודה show ieproxy להצגה של רשימת כל השרתים עבור כל המתאמים שהותקנו.

תחביר

show ieproxy [{IndexNumber | FullAdapterName | PartialAdapterName}] [{/v | /p}]‎

פרמטרים

‎{IndexNumber | FullAdapterName | PartialAdapterName}‎
ציון המתאם או המתאמים שברצונך בפירוט שרתים עבורם. הפרמטר IndexNumber מציין את המתאם לפי מספרו האינדקסיאלי. הפרמטר FullAdapterName מציין את המתאם לפי שמו כפי שנרשם במערכת ההפעלה. הפרמטר PartialAdapterName מציין את המתאם או המתאמים ששמותיהם כוללים את רצף התווים שצוין בפרמטר. אם על רצף התווים להופיע בתחילת השם, הקלד כוכבית (*) בסוף הפרמטר. אם על רצף התווים להופיע בסוף השם, הקלד כוכבית בתחילת הפרמטר. אם על רצף התווים להופיע בכל מקום שהוא בשם, הקלד כוכבית בתחילת הפרמטר וכוכבית בסופו.
‎{/v | /p}‎
מציין האם יש להציג שדות שערכיהם ריקים. הפרמטר ‎/v מציין שיש להציג את השדות. הפרמטר ‎/p מציין שאין להציג את השדות.

הערות

  • באפשרותך להשתמש בפקודה show adapter כדי להציג את מספריהם האינדקסיאליים ואת שמותיהם המלאים של כל המתאמים הלוגיים שהוגדרו במחשב.
  • אם ברצונך לציין מתאם לפי מספרו האינדקסיאלי, אין צורך להקליד את האפסים המקדימים.

דוגמאות

להצגת פירוט של כל שרתי Proxy של Internet Explorer שהוגדרו עבור כל מתאמי הרשת שבשרת, הקלד:

show ieproxy

show ip

הצגת מידע אודות מתאם או מתאמים שצוינו ושהשימוש ב- TCP/IP זמין עבורם. ללא פרמטרים, הפקודה show ip מציגה מידע אודות כל המתאמים שהותקנו.

תחביר

show ip [{IndexNumber | FullAdapterName | PartialAdapterName}] [{/v | /p}]‎

פרמטרים

‎{IndexNumber | FullAdapterName | PartialAdapterName}‎
ציון המתאם או המתאמים שברצונך להציג מידע עבורם. הפרמטר IndexNumber מציין את המתאם לפי מספרו האינדקסיאלי. הפרמטר FullAdapterName מציין את המתאם לפי שמו כפי שנרשם במערכת ההפעלה. הפרמטר PartialAdapterName מציין את המתאם או המתאמים ששמותיהם כוללים את רצף התווים שצוין בפרמטר. אם על רצף התווים להופיע בתחילת השם, הקלד כוכבית (*) בסוף הפרמטר. אם על רצף התווים להופיע בסוף השם, הקלד כוכבית בתחילת הפרמטר. אם רצף התווים עשוי להופיע בכל מקום שהוא בשם, הקלד כוכבית בתחילת הפרמטר וכוכבית בסופו.
‎{/v | /p}‎
מציין האם יש להציג שדות שערכיהם ריקים. הפרמטר ‎/v מציין שיש להציג את השדות. הפרמטר ‎/p מציין שאין להציג את השדות.

הערות

  • באפשרותך להשתמש בפקודה show adapter כדי להציג את מספריהם האינדקסיאליים ואת שמותיהם המלאים של כל המתאמים הלוגיים שהוגדרו במחשב.
  • אם ברצונך לציין מתאם לפי מספרו האינדקסיאלי, אין צורך להקליד את האפסים המקדימים.

דוגמאות

כדי להציג רשימה הכוללת מספר אינדקסיאלי, שם וכתובת TCP/IP של כל מתאם שפעולת TCP/IP זמינה עבורו, הקלד:

show ip

show mail

הצגת שרת הדואר של Outlook Express שצוין עבור המחשב המקומי. ללא פרמטרים, הפקודה show mail תביא להצגת מידע תצורה כולל אודות שרת הדואר המהווה ברירת מחדל עבור Outlook Express.

תחביר

show mail [{/v | /p}]‎

פרמטרים

‎{/v | /p}‎
מציין האם יש להציג שדות שערכיהם ריקים. הפרמטר ‎/v מציין שיש להציג את השדות. הפרמטר ‎/p מציין שאין להציג את השדות.

דוגמאות

לשם הצגת שרת הדואר שהוגדר עבור המחשב המקומי, הקלד:

show mail

show modem

הצגת פירוט אודות התקן או התקני המודם שצוינו ושתצורתם נקבעה במחשב המקומי. ללא פרמטרים, תביא הפקודה show modem להצגת פרטים אודות כל התקני המודם.

תחביר

show modem [{IndexNumber | FullModemName | PartialModemName}] [{/v | /p}]‎

פרמטרים

‎{IndexNumber | FullModemName | PartialModemName}‎
ציון התקן או התקני המודם שברצונך להציג פירוט עבורם. הפרמטר IndexNumber מציין את ההתקן לפי מספרו האינדקסיאלי. הפרמטר FullModemName מציין את ההתקן לפי שמו כפי שנרשם במערכת ההפעלה. הפרמטר PartialModemName מציין את ההתקן או ההתקנים ששמם מכיל את רצף התווים שצוין בפרמטר. אם על רצף התווים להופיע בתחילת השם, הקלד כוכבית (*) בסוף הפרמטר. אם על רצף התווים להופיע בסוף השם, הקלד כוכבית בתחילת הפרמטר. אם רצף התווים עשוי להופיע בכל מקום שהוא בשם, הקלד כוכבית בתחילת הפרמטר וכוכבית בסופו.
‎{/v | /p}‎
מציין האם יש להציג שדות שערכיהם ריקים. הפרמטר ‎/v מציין שיש להציג את השדות. הפרמטר ‎/p מציין שאין להציג את השדות.

דוגמאות

להצגת כל הפרטים, כולל אלה שערכיהם ריקים, אודות כל התקני המודם שתצורתם נקבעה במחשב המקומי, הקלד:

show modem /v

להצגת שמם ומספרם האינדקסיאלי של כל התקני המודם שתצורתם נקבעה במחשב המקומי וששמם מתחיל ב- "dialup", הקלד:

show modem dialup*‎

show news

הצגת מידע תצורה אודות שרת החדשות שהוגדר עבור המחשב המקומי. ללא פרמטרים, תביא הפקודה show news להצגת מידע תצורה כולל עבור שרת החדשות המהווה ברירת מחדל עבור Outlook Express.

תחביר

show news [{/v | /p}]‎

פרמטרים

‎{/v | /p}‎
מציין האם יש להציג שדות שערכיהם ריקים. הפרמטר ‎/v מציין שיש להציג את השדות. הפרמטר ‎/p מציין שאין להציג את השדות.

דוגמאות

להצגת שם וכתובת TCP/IP של שרת החדשות, הקלד:

show news

show os

הצגת מידע אודות מערכת ההפעלה הפועלת במחשב המקומי.

תחביר

show os [/v]‎

פרמטרים

‎/v
מציין שיש להציג שדות שערכיהם ריקים.

הערות

  • המידע המוצג באמצעות פקודה זו נאסף על-ידי ספק WMI ששמו win32_operatingsystem.

show test

הצגת כל אובייקטי הרשת שהוגדרו עבור המחשב המקומי ואימות קישוריות עם כל אובייקט באמצעות הפקודה ping. ללא פרמטרים, תביא הפקודה show test להצגת מידע תצורה כולל עבור רכיבי החומרה והתוכנה הבאים: Default Outlook Express Mail, ‏Default Outlook Express News, שרת Proxy עבור אינטרנט של Internet Explorer, לולאה חוזרת, מערכת מחשב, מערכת הפעלה, גירסה, מודמים, מתאמי רשת ולקוחות רשת. בנוסף מתבצע גם אימות קישוריות עם מתאם הלולאה החוזרת ועם כל כתובות ה- IP שהוגדרו כאפשרות לקוח במאפייני TCP/IP של כל מתאם רשת.

תחביר

show test [{/v | /p}]‎

פרמטרים

‎{/v | /p}‎
מציין האם יש להציג שדות שערכיהם ריקים. הפרמטר ‎/v מציין שיש להציג את השדות. הפרמטר ‎/p מציין שאין להציג את השדות.

הערות

  • הפלט של פקודה זו עשוי להיות ארוך וייתכן שיידרשו כמה דקות להשלמתו. הפלט כולל מידע תצורה אודות שרתי דואר, שרתי חדשות ושרתי Proxy, כמו גם את תוצאותיהם של הניסיונות לאמת קישוריות עם שרתים אלה באמצעות הפקודה ping. פקודה זו מביאה להצגת מידע ולאימות קישוריות עם כתובת הלולאה החוזרת מסוג TCP/IP. פקודה זו מספקת פרטים אודות המחשב ומערכת ההפעלה, כמו גם אודות כל מתאמי הרשת ולקוחות הרשת. אימות קישוריות עם מתאמי רשת ולקוחות רשת מתבצע באמצעות הפקודה ping, ותוצאות הבדיקה מוצגות.

דוגמאות

להצגת כל המידע הזמין בהקשר האבחוני של Netsh, הקלד:

show test /v

show version

הצגת הגירסה של מערכת ההפעלה, ואפשרות להצגת הגירסה של WMI ‏(Windows Management Infrastructure). ללא פרמטרים, תביא הפקודה show version להצגת מספר הגירסה של מערכת ההפעלה שהותקנה במחשב המקומי.

תחביר

show version [{/v | /p}]‎

פרמטרים

‎{/v | /p}‎
מציין האם יש להציג שדות שערכיהם ריקים. הפרמטר ‎/v מציין שיש להציג את השדות. הפרמטר ‎/p מציין שאין להציג את השדות.

הערות

  • שורת הפלט הראשונה של הפקודה מציגה את מספר הגירסה של מערכת ההפעלה. השורה השניה מציגה את מספר הגירסה של WMI. פלט לדוגמה:
    • Version (5.1.2416)‎
    Version = 5.1.2416
    BuildVersion = 2416.0000

דוגמאות

להצגת הגירסאות של מערכת ההפעלה ושל WMI, כולל שדות שערכיהם ריקים, הקלד:

show version /v

show wins

הצגת פירוט של שרתי WINS עבור המתאם או המתאמים שצוינו. ללא פרמטרים, תביא הפקודה show wins להצגה של רשימת שרתים עבור כל המתאמים שהותקנו.

תחביר

show wins [{IndexNumber | FullAdapterName | PartialAdapterName}] [{/v | /p}]‎

פרמטרים

‎{IndexNumber | FullAdapterName | PartialAdapterName}‎
ציון המתאם או המתאמים שברצונך בפירוט שרתים עבורם. הפרמטר IndexNumber מציין את המתאם לפי מספרו האינדקסיאלי. הפרמטר FullAdapterName מציין את המתאם לפי שמו כפי שנרשם במערכת ההפעלה. הפרמטר PartialAdapterName מציין את המתאם או המתאמים ששמותיהם כוללים את רצף התווים שצוין בפרמטר. אם על רצף התווים להופיע בתחילת השם, הקלד כוכבית (*) בסוף הפרמטר. אם על רצף התווים להופיע בסוף השם, הקלד כוכבית בתחילת הפרמטר. אם רצף התווים עשוי להופיע בכל מקום שהוא בשם, הקלד כוכבית בתחילת הפרמטר וכוכבית בסופו.
‎{/v | /p}‎
מציין האם יש להציג שדות שערכיהם ריקים. הפרמטר ‎/v מציין שיש להציג את השדות. הפרמטר ‎/p מציין שאין להציג את השדות.

הערות

  • באפשרותך להשתמש בפקודה show adapter כדי להציג את מספריהם האינדקסיאליים ואת שמותיהם המלאים של כל המתאמים הלוגיים שהוגדרו במחשב.
  • אם ברצונך לציין מתאם לפי מספרו האינדקסיאלי, אין צורך להקליד את האפסים המקדימים.
  • להלן פלט לדוגמה עבור פקודה זו:
    • WINS Servers
    ‎2. [00000002] 3Com 3C920 Integrated Fast Ethernet Controller (3C905C-TX Compatible)‎
    WINSPrimaryServer = 172.16.44.17
    WINSSecondaryServer = 172.16.32.22

דוגמאות

להצגת פירוט של שרתי WINS שהוגדרו עבור כל המתאמים בשרת, הקלד:

show wins

להצגת פירוט של שרתי WINS שצוינו עבור המתאם שמספרו האינדקסיאלי 2, הקלד:

show wins 2


פקודות Netsh עבור Interface IP

באפשרותך להשתמש בפקודות Netsh של הקשר Interface IP כדי לקבוע את תצורתו של פרוטוקול TCP/IP (כולל כתובות, שערים המהווים ברירת מחדל, שרתי DNS ושרתי WINS) וכדי להציג מידע תצורה ומידע סטטיסטי.

באפשרותך להפעיל פקודות אלה משורת הפקודה של Windows XP או משורת הפקודה של הקשר Interface IP של Netsh. כדי להפעיל פקודות אלה בשורת הפקודה של Windows XP, הקלד netsh interface ip לפני הקלדת הפקודות והפרמטרים המוצגים בתחביר שלהלן. כדי להפעיל פקודות Netsh אלה בשרת מרוחק שפועל בו Windows 2000 Server, ראשית עליך להשתמש בהתקשרות של שולחן עבודה מרוחק כדי להתחבר לשרת Windows 2000 Server שפועל בו שרת מסוף. עשויים להיות הבדלים תפקודיים בין פקודות ההקשר של Netsh המבוצעות ב- Windows 2000 לבין פקודות אלה כאשר הן מבוצעות ב- Windows XP.

לקבלת מידע נוסף אודות Netsh, ראה שימוש ב- Netsh.

להצגת תחביר של פקודה, לחץ על פקודה:

set address

קביעת תצורה של כתובת IP ושל שער המהווה ברירת מחדל בממשק שצוין.

תחביר

set address [name=]InterfaceName ‎[source=]{dhcp | static [addr=]IPAddress ‎[mask=]SubnetMask [gateway=]{none | DefaultGateway ‎[[gwmetric=]GatewayMetric]}}‎

פרמטרים

‎[name =] InterfaceName
נדרש. ציון שם הממשק שברצונך להגדיר כתובת ומידע שער עבורו. על הפרמטר InterfaceName להתאים לשם הממשק כפי שצוין בחיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום טקסט זה במרכאות (לדוגמה, ‎"Interface Name"‎).
‎[source=]{dhcp | static [addr=]IPAddress [mask=]SubnetMask [gateway=]{none | DefaultGateway [[gwmetric=]GatewayMetric]}}‎
נדרש. מציין האם מקורה של כתובת ה- IP שיש להגדיר הוא בשרת Dynamic Host Configuration Protocol ‏(DHCP), או שכתובת זו סטטית. אם הכתובת סטטית, הפרמטר IPAddress מציין את הכתובת שיש להגדיר והפרמטר SubnetMask מציין את מסיכת רשת המשנה עבור כתובת IP זו. אם הכתובת סטטית, עליך לציין גם אם ברצונך להותיר את השער הנוכחי המהווה ברירת מחדל (אם קיים), או להגדיר שער חדש. אם תגדיר שער חדש שיהווה ברירת מחדל, הפרמטר DefaultGateway מציין את כתובת ה- IP עבור שער ברירת המחדל שיש להגדיר והפרמטר GatewayMetric מציין את מאפייניו.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • באפשרותך להשתמש בפקודה זו כדי לעבור ממשק בין תצורת DHCP ותצורה סטטית. אם תצורת הממשק נקבעה סטטית, יש לקבוע תצורה סטטית גם עבור הכתובות של שרתי DNS ושרתי WINS של ממשק זה.
  • השמטת הפרמטר DefaultGateway אינה מנקה את הגדרת השער הקיים, אלא משמרת את התצורה הקיימת.

add address

הוספת כתובת IP ושער המהווה ברירת מחדל בממשק שצוין והוגדר עם כתובת IP סטטית.

תחביר

add address [name=]InterfaceName ‎[addr=]IPAddress [mask=]SubnetMask ‎[[gateway=] DefaultGateway [gwmetric=]GatewayMetric]‎

פרמטרים

‎[name=]InterfaceName
נדרש. ציון שם הממשק שעבורו ברצונך להוסיף מידע כתובת ומידע שער. על הפרמטר InterfaceName להתאים לשם הממשק כפי שצוין בחיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום טקסט זה במרכאות (לדוגמה, ‎"Interface Name"‎).
‎[addr=]IPAddress [mask=]SubnetMask
נדרש. ציון של כתובת IP שיש להוסיף ושל מסיכת רשת המשנה עבור כתובת IP זו.
‎[gateway=]DefaultGateway [gwmetric=]GatewayMetric
ציון כתובת IP עבור שער ברירת המחדל שיש להוסיף, ואת המאפיינים של שער ברירת מחדל זה.
‎/?‎
הצגת עזרה בשורת הפקודה.

delete address

מחיקה של כתובת IP או של שער ברירת מחדל בממשק שתצורתו נקבעה סטטית.

תחביר

delete address [name=]InterfaceName ‎[addr=] IPAddress [[gateway=]{DefaultGateway | all}]‎

פרמטרים

‎[name=]InterfaceName
נדרש. ציון שם הממשק שעבורו ברצונך למחוק מידע של כתובת ושל שער. על הפרמטר InterfaceName להתאים לשם הממשק כפי שצוין בחיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום טקסט זה במרכאות (לדוגמה, ‎"Interface Name"‎).
‎[addr=]IPAddress
נדרש. ציון כתובת IP שיש למחוק.
‎[gateway=]{DefaultGateway | all}‎
מציין האם למחוק שער אחד המהווה ברירת מחדל או את כל השערים המהווים ברירת מחדל. בעת מחיקה של שער ברירת מחדל אחד בלבד, הפרמטר DefaultGateway מציין את כתובת ה- IP של שער ברירת המחדל שיש למחוק.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו לא תביא למחיקת כתובת ה- IP האחרונה בממשק.

show address

הצגת מידע אודות כתובות IP סטטיות ואודות שערים המהווים ברירת מחדל בממשק שצוין. ללא פרמטרים, הפקודה show address מביאה להצגת מידע כתובת עבור כל הממשקים.

תחביר

show address [[name=]InterfaceName]‎

פרמטרים

‎[name=]InterfaceName
ציון השם של ההתקן שברצונך להציג מידע כתובת עבורו. על הפרמטר InterfaceName להתאים לשם הממשק שצוין בחיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום טקסט זה במרכאות (לדוגמה, ‎"Interface Name"‎).
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • עבור ממשקים שתצורתם נקבעה באמצעות DHCP, השתמש בפקודה ipconfig כדי להציג כתובות IP שהוקצו, פרמטרים של חכירה ומידע DHCP אחר.

set dns

הגדרת כתובת של שרת DNS עבור ממשק שצוין.

תחביר

set dns [name=]InterfaceName ‎[source=]{dhcp | static ‎[addr=]{DNSAddress | none}}‎ ‎[[ddns=]{disabled | enabled}] [[suffix=]{interface | primary}]‎

פרמטרים

‎[name=]InterfaceName
נדרש. ציון שם הממשק שעבורו ברצונך להגדיר מידע DNS. על הפרמטר InterfaceName להתאים לשם הממשק כפי שצוין בחיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום טקסט זה במרכאות (לדוגמה, ‎"Interface Name"‎).
‎[source=]{dhcp | static [addr =]{DNSAddress | none}}‎
נדרש. מציין האם כתובת ה- IP של שרת DNS שצוין סטטית, או שנקבעה באמצעות DHCP. אם כתובת IP היא סטטית, הפרמטר DNSAddress מציין את כתובת ה- IP של שרת DNS שיש לקבוע את תצורתו, בעוד none מציין כי יש להסיר את תצורת DNS.
‎[ddns=]{disabled | enabled}‎
מציין האם על המחשב לנסות לבצע רישום עדכון דינאמי של DNS עבור כתובות ה- IP של התקשרות זו ועבור שם המחשב המלא. את שם המחשב המלא ניתן למצוא בכרטיסיה שם מחשב של הפריט מערכת בלוח הבקרה. הפרמטר enabled מציין כי על המחשב לבצע ניסיון זה. הפרמטר disabled מציין כי אל למחשב לבצע ניסיון זה.
‎[suffix=]{interface | primary}‎
מציין האם על המחשב לנסות לבצע עדכון דינאמי של DNS עבור רישום של כתובות IP ושל שם קבוצת המחשבים הייחודי להתקשרות שצוינה, וזאת בנוסף לשם המחשב המלא. שם DNS הייחודי להתקשרות זו הוא צירוף של שם המחשב (שהוא התג הראשון בשם המחשב המלא) ושל סיומת DNS של התקשרות זו. הפרמטר interface מציין כי יש לבצע רישום של שם המחשב המלא וגם של שם המחשב הייחודי להתקשרות. הפרמטר primary מציין כי יש לבצע רישום של שם המחשב המלא בלבד.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • אם תצורתו של הממשק כבר נקבעה סטטית, הפרמטר static מחליף את הרשימה הקיימת של כתובות שרתי DNS ברשימה שצוינה בפקודה.
  • הגדרת ברירת המחדל עבור ddns=‎ היא enabled (פועל).
  • הגדרת ברירת המחדל עבור suffix=‎ היא primary (עיקרי).

add dns

הוספה של שרת DNS לרשימה של שרתי DNS עבור הממשק שצוין.

תחביר

add dns [name=]InterfaceName ‎[addr=] DNSAddress [[index=]DNSIndex]‎

פרמטרים

‎[name=]InterfaceName
נדרש. ציון שם הממשק שעבורו ברצונך להוסיף מידע DNS. על הפרמטר InterfaceName להתאים לשם הממשק כפי שצוין בחיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום טקסט זה במרכאות (לדוגמה, ‎"Interface Name"‎).
‎[addr= ]DNSAddress
נדרש. ציון כתובת ה- IP של שרת DNS שיש להוסיף.
‎[index=]DNSIndex
ציון מיקומו של שרת DNS שהתווסף ברשימה של שרתי DNS עבור הממשק.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • מספר נמוך עבור הפרמטר DNSIndex מציין קדימות גבוהה יותר. אם לא צוין מספר אינדקסיאלי, יתווסף השרת עם קדימות מזערית.

delete dns

מחיקה של שרת DNS או של כל שרתי DNS מן הרשימה של שרתי DNS עבור הממשק שצוין, או עבור כל הממשקים.

תחביר

delete dns [name=]InterfaceName ‎[addr=]{DNSAddress | all}‎

פרמטרים

‎[name=]InterfaceName
נדרש. ציון שם הממשק שעבורו ברצונך למחוק מידע DNS. על הפרמטר InterfaceName להתאים לשם הממשק כפי שצוין בחיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום טקסט זה במרכאות (לדוגמה, ‎"Interface Name"‎).
‎[addr=]{DNSAddress | all}‎
נדרש. מציין האם למחוק את כתובתו של שרת DNS אחד, או את כתובות כל השרתים עבור כל הממשקים. אם יש למחוק שרת DNS אחד בלבד, הפרמטר DNSAddress מציין את כתובת ה- IP של שרת DNS שיש למחוק.
‎/?‎
הצגת עזרה בשורת הפקודה.

show dns

תצוגה של תצורת DNS של הממשק שצוין. ללא פרמטרים, הפקודה show dns מביאה להצגת תצורות DNS של כל הממשקים.

תחביר

show dns [[name=]InterfaceName]‎

פרמטרים

‎[name=]InterfaceName
ציון שם הממשק שברצונך להציג את תצורת DNS עבורו. על הפרמטר InterfaceName להתאים לשם הממשק כפי שצוין בחיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום טקסט זה במרכאות (לדוגמה, ‎"Interface Name"‎).
‎/?‎
הצגת עזרה בשורת הפקודה.

set wins

קביעת תצורתם של שרתי WINS למצב סטטי או למצב DHCP עבור ממשק שצוין.

תחביר

set wins [name=]InterfaceName ‎[source=]{dhcp | static [addr=]‎‎{WINSAddress | none }}‎

פרמטרים

‎[name=]InterfaceName
נדרש. ציון שם הממשק שעבורו ברצונך להגדיר מידע WINS. על הפרמטר InterfaceName להתאים לשם הממשק כפי שצוין בחיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום טקסט זה במרכאות (לדוגמה, ‎"Interface Name"‎).
‎[source=]{dhcp | static [addr=]{WINSAddress | none }}‎
נדרש. מציין האם להקצות באמצעות DHCP את כתובת ה- IP של שרת WINS שיש להגדיר, או שכתובת זו היא סטטית. אם כתובת IP היא סטטית, הפרמטר WINSAddress מציין את כתובת ה- IP של שרת WINS שאת תצורתו יש לקבוע, ואילו none מציין שיש להסיר את תצורת WINS.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • אם תצורתו של הממשק כבר נקבעה סטטית, הפרמטר static מחליף את הרשימה הקיימת של כתובות שרתי WINS בזו שצוינה בפקודה set wins.

add wins

הוספה של שרת WINS לרשימה של שרתי WINS עבור ממשק שצוין.

תחביר

add wins [name=]InterfaceName ‎[addr=] WINSAddress [[index=]WINSIndex]‎

פרמטרים

‎[name=]InterfaceName
נדרש. ציון שם הממשק שעבורו ברצונך להוסיף מידע WINS. על הפרמטר InterfaceName להתאים לשם הממשק כפי שצוין בחיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום טקסט זה במרכאות (לדוגמה, ‎"Interface Name"‎).
‎[addr=]WINSAddress
נדרש. ציון כתובת IP של שרת WINS שיש להוסיף.
‎[index=]WINSIndex
ציון מיקומו של שרת WINS שהתווסף ברשימה של שרתי WINS עבור ממשק זה.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • מספר נמוך עבור הפרמטר WINSIndex מציין קדימות גבוהה. אם לא צוין מספר אינדקסיאלי, השרת יתווסף בקדימות הנמוכה ביותר.

delete wins

מחיקה של שרת WINS או של כמה שרתי WINS מן הרשימה של שרתי WINS עבור הממשק שצוין או עבור כל הממשקים.

תחביר

delete wins [name=]InterfaceName ‎[addr=]{WINSAddress | all}‎

פרמטרים

‎[name=]InterfaceName
נדרש. ציון שם הממשק שעבורו ברצונך למחוק שרת WINS או כמה שרתי WINS. על הפרמטר InterfaceName להתאים לשם הממשק כפי שצוין בחיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום טקסט זה במרכאות (לדוגמה, ‎"Interface Name"‎).
‎[addr=]{WINSAddress | all}‎
נדרש. מציין האם למחוק שרת אחד בלבד עבור ממשק, או את כל השרתים עבור כל הממשקים. אם יש למחוק שרת אחד בלבד, הפרמטר WINSAddress מציין את כתובת ה- IP של שרת WINS שיש למחוק.
‎/?‎
הצגת עזרה בשורת הפקודה.

show wins

הצגה של תצורת WINS עבור ממשק שצוין. ללא פרמטרים, תביא הפקודה show wins להצגת של תצורת WINS עבור כל הממשקים.

תחביר

show wins [[name=]InterfaceName]‎

פרמטרים

‎[name=]InterfaceName
ציון שם הממשק שברצונך להציג מידע WINS עבורו. על הפרמטר InterfaceName להתאים לשם הממשק כפי שצוין בחיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום טקסט זה במרכאות (לדוגמה, ‎"Interface Name"‎).
‎/?‎
הצגת עזרה בשורת הפקודה.

show icmp

הצגה של סטטיסטיקת ICMP. ללא פרמטרים, תביא הפקודה show icmp להצגת נתונים סטטיסטיים פעם אחת בלבד.

תחביר

show icmp [[rr=]RefreshRate]‎

פרמטרים

‎[rr=]RefreshRate
ציון קצב הרענון (מספר השניות שיעברו בין רענונים של תצוגת הנתונים הסטטיסטיים).
‎/?‎
הצגת עזרה בשורת הפקודה.

show interface

הצגת סטטיסטיקה עבור ממשק שצוין. ללא פרמטרים, תביא הפקודה show interface להצגת נתונים סטטיסטיים פעם אחת בלבד.

תחביר

show interface [[index=]InterfaceIndex] [[rr=]RefreshRate]‎

פרמטרים

‎[index=]InterfaceIndex
ציון מספרו האינדקסיאלי של הממשק, שהוא מספר שלם המשמש לזיהוי הממשק.
‎[rr=]RefreshRate
ציון קצב הרענון (מספר השניות שיעברו בין רענונים של תצוגת הנתונים הסטטיסטיים).
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • כדי לקבל את מספרו האינדקסיאלי של ממשק, עיין בפלט של הפקודה show interface לאחר ביצועה ללא פרמטרים.

show ipaddress

הצגת מידע עבור כתובת IP שצוינה. ללא פרמטרים, תביא הפקודה show ipaddress להצגת מידע עבור כל כתובות ה- IP בכל הממשקים, פעם אחת בלבד.

תחביר

show ipaddress [[index=]IPAddress] [[rr=]RefreshRate]‎

פרמטרים

‎[index=]IPAddress
ציון כתובת IP של ממשק.
‎[rr=]RefreshRate
ציון קצב הרענון (מספר השניות שיעברו בין רענונים של תצוגת הנתונים הסטטיסטיים).
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • כדי לקבל את כתובות ה- IP של כל הממשקים, עיין בפלט של הפקודה show ipaddress לאחר ביצועה ללא פרמטרים.

show ipnet

הצגת התוכן של מטמון Address Resolution Protocol ‏(ARP), המכיל את כתובות החומרה עבור כתובות ה- IP המפוענחות המהוות את נקודות החיבור הבאות ברשת. ללא פרמטרים, תביא הפקודה show ipnet להצגת המידע פעם אחת בלבד.

תחביר

show ipnet [[rr=]RefreshRate]‎

פרמטרים

‎[rr=]RefreshRate
ציון קצב הרענון (מספר השניות שיעברו בין רענונים של תצוגת הנתונים הסטטיסטיים).
‎/?‎
הצגת עזרה בשורת הפקודה.

show ipstats

הצגה של סטטיסטיקת IP. ללא פרמטרים, תביא הפקודה show ipstats להצגת הנתונים הסטטיסטיים פעם אחת בלבד.

תחביר

show ipstats [[rr=]RefreshRate]‎

פרמטרים

‎[rr=]RefreshRate
ציון קצב הרענון (מספר השניות שיעברו בין רענונים של תצוגת הנתונים הסטטיסטיים).
‎/?‎
הצגת עזרה בשורת הפקודה.

show joins

הצגת קבוצות שידור לקבוצה מסוג IP שקובצו עבור כתובת IP שצוינה. ללא פרמטרים, תביא הפקודה show joins להצגת מידע עבור כל כתובות ה- IP.

תחביר

show joins [[index=]IPAddress]‎

פרמטרים

‎[index=]IPAddress
ציון כתובת IP של ממשק.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • כדי לקבל את כתובות ה- IP עבור כל הממשקים, עיין בפלט של הפקודה show ipaddress לאחר ביצועה ללא פרמטרים.

show tcpconn

הצגת מידע אודות חיבור TCP שצוין. ללא פרמטרים, תביא הפקודה show tcpconn להצגת מידע עבור כל חיבורי TCP פעם אחת בלבד.

תחביר

show tcpconn [[index=]{LocalIPAddress | LocalPort | RemoteIPAddress | RemotePort}]‎ ‎[[rr=]RefreshRate]‎

פרמטרים

‎[index=]{LocalIPAddress | LocalPort | RemoteIPAddress | RemotePort}‎
ציון החיבור שיש להציג מידע אודותיו. הפרמטר LocalIPAddress מציין כתובת IP של ממשק. הפרמטר LocalPort מציין יציאת TCP עבור תהליך מקומי. הפרמטר RemoteIPAddress מציין כתובת IP של מארח מרוחק. הפרמטר RemotePort מציין יציאת TCP עבור תהליך מרוחק.
‎[rr=]RefreshRate
ציון קצב הרענון (מספר השניות שיעברו בין רענונים של תצוגת המידע).
‎/?‎
הצגת עזרה בשורת הפקודה.

show tcpstats

הצגה של סטטיסטיקת TCP. ללא פרמטרים, תביא הפקודה show tcpstats להצגת הנתונים הסטטיסטיים פעם אחת בלבד.

תחביר

show tcpstats [[rr=]RefreshRate]‎

פרמטרים

‎[rr=]RefreshRate
ציון קצב הרענון (מספר השניות שיעברו בין רענונים של תצוגת הנתונים הסטטיסטיים).
‎/?‎
הצגת עזרה בשורת הפקודה.

show udpconn

הצגת מידע אודות יציאות UDP המשמשות עבור כל כתובת IP. ללא פרמטרים, תביא הפקודה show udpconn להצגה של מידע אודות יציאות UDP עבור כל כתובות ה- IP פעם אחת בלבד.

תחביר

show udpconn [[index=]{LocalIPAddress | LocalPort}]‎ ‎[[rr=]RefreshRate]‎

פרמטרים

‎[index=]{LocalIPAddress | LocalPort}‎
ציון החיבור שיש להציג מידע אודותיו. הפרמטר LocalIPAddress מציין כתובת IP של ממשק. הפרמטר LocalPort מציין יציאת UDP עבור תהליך מקומי.
‎[rr=]RefreshRate
ציון קצב הרענון (מספר השניות שיעברו בין רענונים של תצוגת הנתונים הסטטיסטיים).
‎/?‎
הצגת עזרה בשורת הפקודה.

show udpstats

הצגה של סטטיסטיקת UDP. ללא פרמטרים, תביא הפקודה show udpstats להצגת הנתונים הסטטיסטיים פעם אחת בלבד.

תחביר

show udpstats [[rr=]RefreshRate]‎

פרמטרים

‎[rr=]RefreshRate
ציון קצב הרענון (מספר השניות שיעברו בין רענונים של תצוגת הנתונים הסטטיסטיים).
‎/?‎
הצגת עזרה בשורת הפקודה.

show config

הצגה של כתובת IP ושל מידע תצורה אחר עבור ממשק שצוין. ללא פרמטרים, תביא הפקודה show config להצגת מידע תצורה עבור כל הממשקים.

תחביר

show config [[name=]InterfaceName]‎

פרמטרים

‎[name=]InterfaceName
ציון שמו של ההתקן שאת מידע התצורה שלו ברצונך להציג. על הפרמטר InterfaceName להתאים לשם הממשק כפי שצוין בחיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום טקסט זה במרכאות (לדוגמה, ‎"Interface Name"‎).
‎/?‎
הצגת עזרה בשורת הפקודה.

show offload

הצגת המשימות שניתן לבצע באמצעות מתאם הרשת עבור הממשק שצוין, בתאימות לחומרת רשת שהותקנה. ללא פרמטרים, תביא הפקודה show offload להצגה של מידע העברה עבור כל הממשקים התואמים לחומרת רשת שהותקנה.

תחביר

show offload [[name=]InterfaceName ]‎

פרמטרים

‎[name=]InterfaceName
ציון השם של ההתקן שברצונך להציג מידע העברה עבורו. על הפרמטר InterfaceName להתאים לשם הממשק כפי שצוין בחיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום טקסט זה במרכאות (לדוגמה, ‎"Interface Name"‎).
‎/?‎
הצגת עזרה בשורת הפקודה.

delete arpcache

הסרת ערכים ממטמון Address Resolution Protocol ‏(ARP) עבור ממשק שצוין. ללא פרמטרים, תביא הפקודה delete arpcache להסרת הערכים ממטמוני ARP של כל הממשקים.

תחביר

delete arpcache [[name=]InterfaceName]‎

פרמטרים

‎[name=]InterfaceName
ציון שם הממשק שעבורו ברצונך להסיר ערכים של מטמון ARP. על הפרמטר InterfaceName להתאים לשם הממשק כפי שצוין בחיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום טקסט זה במרכאות (לדוגמה, ‎"Interface Name"‎).
‎/?‎
הצגת עזרה בשורת הפקודה.

dump

הצגת התצורה הנוכחית כסדרה של פקודות Interface IP של Netsh.

תחביר

dump

פרמטרים

ללא

הערות

  • לשם יצירת קובץ Script של התצורה, נתב את פלט הפקודה לקובץ.

דוגמה של Netsh Interface IP

הפקודה מגדירה עבור הממשק ששמו Local Area Connection את כתובת ה- IP הסטטית 10.0.5.99, את מסיכת רשת המשנה 255.255.255.0 ואת שער ברירת המחדל 10.0.5.1:

set address name="Local Area Connection" source=static addr=10.0.5.99 mask=255.255.255.0 gateway=10.0.5.1


פקודות Netsh עבור RAS

באפשרותך לנהל שרתים של גישה מרחוק על-ידי הקלדת פקודות בשורת הפקודה של הקשר Netsh RAS. שורת הפקודה Netsh RAS מאפשרת לנהל שרתים במהירות גבוהה יותר בחיבורי רשת איטיים, כמו גם ליצור קבצי Script המאפשרים ניהול אוטומטי של שרתים רבים.

כדי להפעיל פקודות Netsh אלה ב- Windows 2000 Server מרוחק, ראשית עליך להשתמש בהתקשרות לשולחן עבודה מרוחק כדי להתחבר ל- Windows 2000 Server שפועל בו שרת מסוף. ייתכן שיימצאו הבדלים פונקציונליים בין פקודות הקשר Netsh ב- Windows 2000 וב- Windows XP.

לקבלת מידע נוסף אודות Netsh, ראה שימוש ב- Netsh.

כדי להציג את תחביר הפקודה, לחץ על פקודה:

help

הצגת עזרה של שורת פקודה עבור פקודות שבאפשרותך להשתמש בהן בהקשר RAS של Netsh.

תחביר

help

פרמטרים

ללא

הערות

  • באפשרותך להציג עזרה של שורת פקודה גם על-ידי הקלדת אחד מהצירופים הבאים בשורת הפקודה של הקשר RAS של Netsh:‏ ?, ‎/?‎ או ‎-?‎.

show activeservers

הצגת רשימה של פרסומים עבור שרת של גישה מרחוק.

תחביר

show activeservers

פרמטרים

ללא

show client

פירוט של לקוחות גישה מרחוק המחוברים לשרת זה.

תחביר

show client

פרמטרים

ללא

dump

הצגת התצורה של שרת הגישה מרחוק בתבנית Script.

תחביר

dump

פרמטרים

ללא

show tracing

בדיקה של הפעלת מעקב עבור הרכיב שצוין. כאשר נעשה שימוש בפקודה show tracing ללא פרמטרים, מוצגים כל הרכיבים המותקנים ומצב המעקב עבור כל אחד מהם.

תחביר

show tracing [Component]‎

פרמטרים

Component
ציון הרכיב שעבורו יש להציג מידע.

set tracing

הפעלה או ביטול של מעקב עבור הרכיב שצוין.

תחביר

set tracing Component {enabled | disabled}‎

פרמטרים

Component
נדרש. ציון הרכיב שעבורו ברצונך להפעיל או לבטל מעקב. השתמש ב- * כדי לציין הפעלה או ביטול של מעקב עבור כל הרכיבים.
‎{enabled | disabled}‎
נדרש. ציון של הפעלת או ביטול מעקב עבור הרכיב שצוין.

הערות

  • כדי להציג רשימה של כל הרכיבים המותקנים, השתמש בפקודה show tracing ללא פרמטרים.

דוגמאות

כדי להפעיל מעקב עבור הרכיב PPP, הקלד:

set tracing ppp enabled

show authmode

הצגת מידע אודות הצורך באימות עבור לקוחות חיוג המשתמשים בסוגי התקנים מסוימים.

תחביר

show authmode

פרמטרים

ללא

set authmode

ציון צורך באימות עבור לקוחות חיוג המשתמשים בסוגי התקנים מסוימים.

תחביר

set authmode {standard | nodcc | bypass}‎

פרמטרים

‎{standard | nodcc | bypass}‎
נדרש. מציין אם יש לבצע אימות עבור לקוחות חיוג המשתמשים בסוגי התקנים מסוימים. הפרמטר standard מציין שיש לבצע אימות עבור לקוחות המשתמשים בכל סוג של התקן. הפרמטר nodcc מציין שיש לבצע אימות עבור לקוחות המשתמשים בכל סוג של התקן, למעט התקן של חיבור ישיר. הפרמטר bypass מציין שאין צורך באימות עבור אף לקוח.

add authtype

הוספת סוג אימות לרשימת הסוגים שבאמצעותם יהיה על שרת הגישה מרחוק לנסות לנהל משא ומתן על אימות.

תחביר

add authtype ‎{pap|spap|md5chap|mschap|mschapv2|eap}‎

פרמטרים

‎{pap|spap|md5chap|mschap|mschapv2|eap}‎
נדרש. ציון סוג האימות שיש להוסיף לרשימת הסוגים שבאמצעותם על שרת הגישה מרחוק לנסות לנהל משא ומתן על אימות. הפרמטר pap מציין שעל שרת הגישה מרחוק להשתמש בפרוטוקול Password Authentication Protocol (טקסט נקי). הפרמטר spap מציין שעל שרת הגישה מרחוק להשתמש בפרוטוקול Shiva Password Authentication Protocol. הפרמטר md5chap מציין שעל שרת הגישה מרחוק להשתמש בפרוטוקול Challenge Handshake Authentication Protocol (תוך שימוש בתבנית ה- Hashing של Message Digest 5 כדי להצפין את התגובה). הפרמטר mschap מציין שעל שרת הגישה מרחוק להשתמש בפרוטוקול Microsoft Challenge-Handshake Authentication Protocol. הפרמטר mschapv2 מציין שעל שרת הגישה מרחוק להשתמש בגירסה 2 של MSCHAP. הפרמטר eap מציין שעל שרת הגישה מרחוק להשתמש בפרוטוקול Extensible Authentication Protocol.

הערות

  • שרת הגישה מרחוק ינסה לנהל משא ומתן על אימות באמצעות הפרוטוקולים שצוינו, החל במאובטח ביותר וכלה במאובטח פחות מן היתר. לאחר שמתקיימת הסכמה לגבי סוג האימות בין הלקוח והשרת, המשא ומתן על PPP ממשיך לפי מסמכי RFC המתאימים.

delete authtype

מחיקת סוג אימות מרשימת הסוגים שבאמצעותם ינסה שרת הגישה מרחוק לנהל משא ומתן על אימות.

תחביר

delete authtype ‎{pap|spap|md5chap|mschap|mschapv2|eap}‎

פרמטרים

‎{pap|spap|md5chap|mschap|mschapv2|eap}‎
נדרש. ציון סוג האימות שיש למחוק מרשימת הסוגים שבאמצעותם על שרת הגישה מרחוק לנסות לנהל משא ומתן על אימות. הפרמטר pap מציין שעל שרת הגישה מרחוק להימנע משימוש בפרוטוקול Password Authentication Protocol (טקסט נקי). הפרמטר spap מציין שעל שרת הגישה מרחוק להימנע משימוש בפרוטוקול Shiva Password Authentication Protocol. הפרמטר md5chap מציין שעל שרת הגישה מרחוק להימנע משימוש בפרוטוקול Challenge Handshake Authentication Protocol (העושה שימוש בתבנית ה- Hashing של Message Digest 5 כדי להצפין את התגובה). הפרמטר mschap מציין שעל שרת הגישה מרחוק להימנע משימוש בפרוטוקול Microsoft Challenge-Handshake Authentication Protocol. הפרמטר mschapv2 מציין שעל שרת הגישה מרחוק להימנע משימוש בגירסה 2 של MSCHAP. הפרמטר eap מציין שעל שרת הגישה מרחוק להימנע משימוש בפרוטוקול Extensible Authentication Protocol.

show authtype

פירוט סוג האימות (או סוגי האימות) ששרת הגישה מרחוק משתמש בהם כדי לנסות לנהל משא ומתן על אימות.

תחביר

show authtype

פרמטרים

ללא

add link

הוספת מאפיין קישור לרשימת מאפייני הקישור שעל PPP לנהל משא ומתן עליהם.

תחביר

add link {swc | lcp}‎

פרמטרים

‎{swc | lcp}‎
נדרש. ציון מאפיין הקישור שיש להוסיף לרשימה של מאפייני קישור שעל PPP לנהל משא ומתן עליהם. הפרמטר swc מציין שיש להוסיף דחיסת תוכנה (MPPC). הפרמטר lcp מציין שיש להוסיף סיומות של Link Control Protocol מחבילת הפרוטוקולים של PPP.

delete link

מחיקת מאפיין קישור מרשימת מאפייני הקישור שעל PPP לנהל משא ומתן עליהם.

תחביר

delete link {swc | lcp}‎

פרמטרים

‎{swc | lcp}‎
נדרש. ציון מאפיין הקישור שיש למחוק מרשימת מאפייני הקישור שעל PPP לנהל משא ומתן עליהם. הפרמטר swc מציין שיש למחוק דחיסת תוכנה (MPPC). הפרמטר lcp מציין שיש למחוק סיומות Link Control Protocol מחבילת הפרוטוקולים של PPP.

show link

הצגת מאפייני הקישור שעל PPP לנהל משא ומתן עליהם.

תחביר

show link

פרמטרים

ללא

add multilink

הוספת סוג Multilink לרשימה של סוגי Multilink שעל PPP לנהל משא ומתן עליהם.

תחביר

add multilink {multi | bacp}‎

פרמטרים

‎{multi | bacp}‎
נדרש. ציון סוג ה- Multilink שיש להוסיף לרשימת סוגי ה- Multilink שעל PPP לנהל משא ומתן עליהם. הפרמטר multi מציין שיש להוסיף הפעלות PPP מסוג Multilink. הפרמטר bacp מציין שיש להוסיף Bandwidth Allocation Control Protocol.

delete multilink

מחיקה של סוג Multilink מהרשימה של סוגי Multilink שעל PPP לנהל משא ומתן עליהם.

תחביר

delete multilink {multi | bacp}‎

פרמטרים

‎{multi | bacp}‎
נדרש. ציון סוג Multilink שיש למחוק מהרשימה של סוגי Multilink שעל PPP לנהל משא ומתן עליהם. הפרמטר multi מציין שיש למחוק הפעלות PPP מסוג Multilink. הפרמטר bacp מציין שיש למחוק את Bandwidth Allocation Control Protocol.

show multilink

הצגת סוגי ה- Multilink שעל PPP לנהל משא ומתן עליהם.

תחביר

show multilink

פרמטרים

ללא

add registeredserver

רישום השרת שצוין כשרת הגישה מרחוק בקבוצת המחשבים של Active Directory שצוינה. כאשר נעשה שימוש בפקודה add registeredserver ללא פרמטרים, המחשב שבו הוקלדה הפקודה נרשם בקבוצת המחשבים הראשית שלו.

תחביר

add registeredserver [[domain=]DomainName] [[server=]ServerName]‎

פרמטרים

‎[domain=]DomainName
ציון שמה של קבוצת המחשבים שיש לרשום בה את השרת. אם לא תציין קבוצת מחשבים, השרת יירשם בקבוצת המחשבים הראשית שלו.
‎[server=]ServerName
ציון השרת, לפי שם DNS או כתובת IP, שיש לרשום. אם לא תציין שרת, יירשם המחשב שבו הוקלדה הפקודה.

delete registeredserver

מחיקת הרישום של השרת שצוין כשרת גישה מרחוק מקבוצת המחשבים של Active Directory שצוינה. כאשר נעשה שימוש בפקודה delete registeredserver ללא פרמטרים, הרישום עבור המחשב שבו הוקלדה הפקודה נמחק מקבוצת המחשבים הראשית שלו.

תחביר

delete registeredserver [[domain=]DomainName] [[server=]ServerName]‎

פרמטרים

‎[domain=]DomainName
ציון שמה של קבוצת המחשבים שממנה יש להסיר את הרישום. אם לא תציין קבוצת מחשבים, הרישום יוסר מקבוצת המחשבים הראשית של המחשב שבו הוקלדה הפקודה.
‎[server=]ServerName
ציון השרת, לפי כתובת IP או שם DNS, שאת הרישום שלו ברצונך להסיר. אם לא תציין שרת, יוסר הרישום עבור המחשב שבו הוקלדה הפקודה.

show registeredserver

הצגת מידע מצב אודות השרת שצוין, הרשום כשרת גישה מרחוק בקבוצת המחשבים של Active Directory שצוינה. כאשר נעשה שימוש בפקודה show registeredserver ללא פרמטרים, מוצג מידע אודות המחשב שבו הוקלדה הפקודה בקבוצת המחשבים הראשית שלו.

תחביר

show registeredserver [[domain=]DomainName] [[server=]ServerName]‎

פרמטרים

‎[domain=]DomainName
ציון שמה של קבוצת המחשבים שבה רשום השרת שברצונך להציג מידע עבורו. אם לא תציין קבוצת מחשבים, יוצג מידע אודות השרת כפי שנרשם בקבוצת המחשבים הראשית של המחשב שבו הוקלדה הפקודה.
‎[server=]ServerName
ציון השרת, לפי כתובת IP או שם DNS, שאודותיו ברצונך להציג מידע. אם לא תציין שרת, יוצג מידע אודות המחשב שבו הוקלדה הפקודה.

show user

הצגת המאפיינים של משתמש או משתמשים מרוחקים שצוינו. כאשר נעשה שימוש בפקודה show user ללא פרמטרים, מוצגים המאפיינים של כל משתמשי הגישה מרחוק.

תחביר

show user [name=UserName]‎ ‎[[mode=] {permit | report}]‎

פרמטרים

name=UserName
ציון שם הכניסה של המשתמש שאת מאפייניו ברצונך להציג. אם לא תציין משתמש, יוצגו המאפיינים של כל המשתמשים.
mode= {permit | report}‎
קביעה אם להציג מאפיינים עבור כל המשתמשים או רק עבור אלה שהרשאות החיוג שלהם נקבעו ל- Permit. הפרמטר permit מציין שיש להציג מאפיינים רק עבור משתמשים שהרשאת החיוג שלהם היא Permit. הפרמטר report מציין שיש להציג מאפיינים עבור כל המשתמשים.

set user

קביעת המאפיינים של משתמש הגישה מרחוק שצוין.

תחביר

set user [name=]UserName ‎[dialin] {permit | deny | policy}‎ ‎[cbpolicy] {none | caller | admin [cbnumber=]CallbackNumber}‎

פרמטרים

name=UserName
נדרש. ציון שם הכניסה של המשתמש שברצונך לקבוע את מאפייניו.
‎[dialin] {permit | deny | policy}‎
נדרש. ציון הנסיבות שבעת התקיימותן יש לאפשר למשתמש להתחבר. הפרמטר permit מציין כי יש לאפשר למשתמש להתחבר בכל עת. הפרמטר deny מציין שלעולם אין לאפשר למשתמש להתחבר. הפרמטר policy מציין שעל פריטי מדיניות של גישה מרחוק לקבוע אם לאפשר למשתמש להתחבר.
‎[cbpolicy] {none | caller | admin [cbnumber=]CallbackNumber}‎
נדרש. ציון מדיניות ההתקשרות חזרה עבור המשתמש. תכונת ההתקשרות חזרה חוסכת למשתמש את העלות של שיחת הטלפון המשמשת לחיבור לשרת גישה מרחוק. הפרמטר none מציין שאין להתקשר בחזרה אל המשתמש. הפרמטר caller מציין שיש להתקשר בחזרה אל המשתמש באמצעות המספר שצוין על-ידו בשעת ההתחברות. הפרמטר admin מציין שיש להתקשר בחזרה אל המשתמש למספר שצוין בפרמטר CallbackNumber.

הערות

  • עבור משתמשים בקבוצת מחשבים במצב מעורב, הפרמטר policy והפרמטר deny הם שווי ערך.

דוגמאות

כדי לאפשר ל- GuestUser להתחבר ולקבל התקשרות חזרה למספר 4255551212, הקלד:

set user guestuser permit admin 4255551212

פקודות הקשר RAS IP של Netsh

הפקודות הבאות ייחודיות להקשר RAS IP של סביבת Netsh.

כדי להציג את תחביר הפקודה, לחץ על פקודה:

dump

יצירת מקטע Script המכיל את תצורת ה- IP של שרת גישה מרחוק. אם תשמור מקטע Script זה לקובץ, יהיה באפשרותך להשתמש בו לשם שחזור הגדרות של תצורת IP.

תחביר

dump

פרמטרים

ללא

show config

הצגה של תצורת ה- IP הנוכחית של שרת הגישה מרחוק.

תחביר

show config

פרמטרים

ללא

set negotiation

קביעה אם על שרת הגישה מרחוק לאפשר קביעה של תצורת IP עבור כל התקשרויות הלקוח שמקבל השרת.

תחביר

set negotiation {allow | deny}‎

פרמטרים

{allow | deny}
נדרש. קביעה אם לאפשר IP על-גבי התקשרויות לקוח. הפרמטר allow מאפשר IP בהתקשרויות לקוח. הפרמטר deny מונע IP בהתקשרויות לקוח.

set access

קביעה אם יש להעביר תעבורת רשת IP מלקוח כלשהו לרשת או לרשתות שאליהן מחובר שרת הגישה מרחוק.

תחביר

set access {all | serveronly}‎

פרמטרים

{all | serveronly}
נדרש. קביעה אם ללקוחות תהיה אפשרות להגיע לשרת הגישה מרחוק ולכל רשת המחוברת אליו. הפרמטר all מאפשר ללקוחות לבצע גישה לרשתות באמצעות השרת. הפרמטר serveronly מאפשר ללקוחות לבצע גישה אל השרת בלבד.

set addrassign

קביעת השיטה שלפיה יקצה שרת הגישה מרחוק כתובות IP ללקוחותיו.

תחביר

set addrassign {auto | pool}‎

פרמטרים

{auto | pool}
נדרש. קביעה אם יש להקצות כתובות IP באמצעות DHCP או מתוך מאגר של כתובות המאוחסן בשרת הגישה מרחוק. הפרמטר auto מציין שיש להקצות כתובות באמצעות DHCP. אם שרת DHCP אינו זמין, מוקצית כתובת פרטית ואקראית. הפרמטר pool מציין שיש להקצות כתובות מתוך מאגר.

set addrreq

קביעה אם ללקוחות חיוג תהיה אפשרות לבקש כתובות IP משל עצמם.

תחביר

set addrreq {allow | deny}‎

פרמטרים

{allow | deny}
נדרש. קביעה אם ללקוחות חיוג תהיה אפשרות לבקש כתובות IP משל עצמם. הפרמטר allow מאפשר ללקוחות לבקש כתובות. הפרמטר deny מונע מלקוחות לבקש כתובות.

set broadcastnameresolution

מאפשר או מבטל פענוח של שמות שידור באמצעות NetBIOS ב- TCP/IP.

תחביר

set broadcastnameresolution {enabled | disabled}‎

פרמטרים

{enabled | disabled}
נדרש. קביעה אם לאפשר או לבטל פענוח של שמות שידור באמצעות NetBIOS ב- TCP/IP.

add range

הוספת טווח של כתובות למאגר של כתובות IP סטטיות ששרת הגישה מרחוק עשוי להקצות ללקוחות.

תחביר

add range [from=]StartingIPAddress [to=]EndingIPAddress

פרמטרים

‎[from=]StartingIPAddress [to=]EndingIPAddress
נדרש. ציון הטווח של כתובות IP שיש להוסיף. הפרמטר StartingIPAddress מציין את כתובת ה- IP הראשונה בטווח. הפרמטר EndingIPAddress מציין את כתובת ה- IP האחרונה בטווח.

דוגמאות

כדי להוסיף את טווח כתובות ה- IP ‏10.2.2.10 עד 10.2.2.20 למאגר הסטטי של כתובות IP שבאפשרות שרת הגישה מרחוק להקצות, הקלד:

add range from=10.2.2.10 to=10.2.2.20

delete range

מחיקת טווח כתובות מהמאגר של כתובות IP סטטיות שבאפשרות שרת הגישה מרחוק להקצות ללקוחות.

תחביר

delete range [from=]StartingIPAddress [to=]EndingIPAddress

פרמטרים

‎[from=]StartingIPAddress [to=]EndingIPAddress
נדרש. ציון טווח כתובות ה- IP שיש למחוק. הפרמטר StartingIPAddress מציין את כתובת ה- IP הראשונה בטווח. הפרמטר EndingIPAddress מציין את כתובת ה- IP האחרונה בטווח.

דוגמאות

כדי למחוק את טווח כתובות ה- IP ‏10.2.2.10 עד 10.2.2.20 מהמאגר של כתובות IP סטטיות שבאפשרות שרת הגישה מרחוק להקצות, הקלד:

delete range from=10.2.2.10 to=10.2.2.20

delete pool

מחיקת כל הכתובות מהמאגר של כתובות IP סטטיות שבאפשרות שרת הגישה מרחוק להקצות ללקוחות.

תחביר

delete pool

פרמטרים

ללא

פקודות הקשר RAS IPX של Netsh

הפקודות הבאות ייחודיות להקשר RAS IPX של סביבת Netsh.‏ XOX

כדי להציג את תחביר הפקודה, לחץ על פקודה:

dump

יצירת מקטע Script המכיל את תצורת ה- IPX של שרת הגישה מרחוק. אם תשמור מקטע Script זה לקובץ, יהיה באפשרותך להשתמש בו כדי לשחזר הגדרות של תצורת IPX.

תחביר

dump

פרמטרים

ללא

show config

הצגה של תצורת ה- IPX הנוכחית של שרת הגישה מרחוק.

תחביר

show config

פרמטרים

ללא

set negotiation

קביעה אם על שרת הגישה מרחוק לאפשר קביעת תצורה של IPX עבור כל התקשרות לקוח שהוא מקבל.

תחביר

set negotiation {allow | deny}‎

פרמטרים

{allow | deny}
נדרש. קביעה אם לאפשר קביעת תצורה של IPX. הפרמטר allow מאפשר קביעת תצורה של IPX. הפרמטר deny מונע קביעת תצורה של IPX.

set access

קביעה אם יש להעביר תעבורת רשת של IPX מלקוח כלשהו לרשת או לרשתות שאליהן מחובר שרת הגישה מרחוק.

תחביר

set access {all | serveronly}‎

פרמטרים

{all | serveronly}
נדרש. קביעה אם יש להעביר תעבורת IPX. הפרמטר all מאפשר העברה של תעבורת IPX. הפרמטר serveronly מונע העברה של תעבורה.

set netassign

ציון השיטה שבאמצעותה מקצה שרת הגישה מרחוק כתובות IPX ללקוחותיו.

תחביר

set netassign ‎[method] {auto | pool | autosame | poolsame}‎

פרמטרים

‎[method] {auto | pool | autosame | poolsame}‎
נדרש. ציון השיטה שבאמצעותה מקצה שרת הגישה מרחוק כתובות IPX ללקוחות. הפרמטר auto מציין שעל שרת הגישה מרחוק להקצות מספר רשת IPX שונה ואקראי לכל לקוח. הפרמטר pool מציין שעל שרת הגישה מרחוק להקצות כתובת IPX שונה מתוך מאגר של כתובות לכל לקוח. הפרמטר autosame מציין שעל שרת הגישה מרחוק להפיק מספר רשת IPX אקראי ולהקצות אותו לכל הלקוחות. הפרמטר poolsame מציין שעל שרת הגישה מרחוק להקצות כתובת מתוך מאגר לכל הלקוחות.

הערות

  • עבור רוב התצורות, מומלץ להשתמש בפרמטרים autosame או poolsame מכיוון שהם משמרים מספרי רשת ומפחיתים תעבורת רשת.
  • בטרם יקצה שרת הגישה מרחוק מספר רשת ללקוח, על השרת לוודא אם המספר כבר נמצא בשימוש ברשת האינטרא-נט שאליה שרת הגישה מרחוק מחובר. כתוצאה מכך, ייתכן שמספר כתובות במאגר לא יוקצו.

set pool

ציון המאגר של כתובות IPX שממנו עשוי שרת הגישה מרחוק להקצות כתובות ללקוחות.

תחביר

set pool [firstnet=]IPXAddress ‎[size=]{PoolSize | 0}‎

פרמטרים

‎[firstnet=]IPXAddress
נדרש. ציון כתובת ה- IPX הראשונה במאגר, בסימון הקסדצימאלי.
‎[size=]{PoolSize | 0}‎
נדרש. מציין את גודל המאגר, או מציין כי על המאגר לגדול כנדרש. הפרמטר PoolSize מציין, בסימון דצימאלי, את מספר כתובות ה- IPX שבמאגר. הפרמטר 0 מציין שעל המאגר לגדול כנדרש.

דוגמאות

כדי לציין שעל מאגר כתובות ה- IPX להתחיל ב- AAAAAAA ולגדול כנדרש, הקלד:

set pool AAAAAAA 0

set nodereq

קביעה אם יש לאפשר ללקוחות חיוג לבקש מספרי צומת IPX משלהם.

תחביר

set nodereq {allow | deny}‎

פרמטרים

{allow | deny}
נדרש. קביעה אם יש לאפשר ללקוחות לבקש מספרי צומת IPX משלהם. הפרמטר allow מאפשר בקשות אלה. הפרמטר deny מתעלם מהבקשות.

פקודות הקשר RAS AppleTalk של Netsh

הפקודות הבאות ייחודיות להקשר RAS AppleTalk של סביבת Netsh. פרוטוקול AppleTalk אינו זמין ב- Windows XP Home Edition או ב- Windows XP Professional.

כדי להציג את תחביר הפקודה, לחץ על פקודה:

dump

יצירת מקטע Script המכיל את תצורת AppleTalk של שרת הגישה מרחוק. אם תשמור מקטע Script זה לקובץ, יהיה באפשרותך להשתמש בו כדי לשחזר הגדרות של תצורת AppleTalk.

תחביר

dump

פרמטרים

ללא

show config

הצגה של תצורת AppleTalk הנוכחית עבור שרת הגישה מרחוק.

תחביר

show config

פרמטרים

ללא

set negotiation

קביעה אם על שרת הגישה מרחוק לאפשר קביעת תצורה של AppleTalk עבור כל התקשרות לקוח שמקבל השרת.

תחביר

set negotiation {allow | deny}‎

פרמטרים

{allow | deny}
נדרש. קביעה אם יש לאפשר קביעה של תצורת AppleTalk. הפרמטר allow מאפשר קביעת תצורה. הפרמטר deny מונע קביעת תצורה.

set access

קביעה אם יש להעביר תעבורת רשת של AppleTalk מלקוח כלשהו לרשת או לרשתות שאליהן מחובר שרת הגישה מרחוק.

תחביר

set access {all | serveronly}‎

פרמטרים

{all | serveronly}
נדרש. קביעה אם יש להעביר תעבורת רשת של AppleTalk. הפרמטר all מאפשר העברה של תעבורה. הפרמטר serveronly מונע העברה של תעבורה.

פקודות הקשר RAS AAAA של Netsh

הפקודות הבאות ייחודיות להקשר RAS AAAA של סביבת Netsh.

כדי להציג את תחביר הפקודה, לחץ על פקודה:

dump

הצגה של תצורת AAAA של שרת גישה מרחוק בתבנית Script.

תחביר

dump

פרמטרים

ללא

add acctserv

ציון כתובת IP או שם DNS של שרת RADIUS שיש להשתמש בו עבור ניהול חשבונות וציון של אפשרויות ניהול חשבונות.

תחביר

add acctserv [name=]ServerID ‎[[secret=]SharedSecret]‎ ‎[[init-score=]ServerPriority]‎ ‎[[port=]Port]‎ ‎[[timeout=]Seconds]‎ ‎[[messages] {enabled | disabled}]‎

פרמטרים

‎[name=]ServerID
נדרש. ציון של שרת RADIUS לפי כתובת IP או שם DNS.
‎[secret=]SharedSecret
ציון פריט המידע המוצפן המשותף.
‎[init-score=]ServerPriority
ציון התוצאה הראשונית (עדיפות שרת).
‎[port=]Port
ציון היציאה שאליה יש לשלוח בקשות ניהול חשבונות.
‎[timeout=]Seconds
ציון פרק הזמן הקצוב, בשניות, שבמהלכו שרת RADIUS עשוי להיות בלתי פעיל לפני שיסומן כבלתי זמין.
‎[messages] {enabled | disabled}‎
קביעה אם יש לשלוח הודעות הפעלה/כיבוי של ניהול חשבונות. הפרמטר enabled מציין שיש לשלוח הודעות. הפרמטר disabled מציין שאין לשלוח הודעות.

delete acctserv

מחיקת שרת ניהול חשבונות של RADIUS.

תחביר

delete acctserv [name=]ServerID

פרמטרים

‎[name=]ServerID
נדרש. ציון השרת שיש למחוק, לפי שם DNS או כתובת IP.

set acctserv

ציון כתובת IP או שם DNS של שרת RADIUS שיש להשתמש בו עבור ניהול חשבונות.

תחביר

add acctserv [name=]ServerID ‎[[secret=]SharedSecret]‎ ‎[[init-score=]ServerPriority]‎ ‎[[port=]Port]‎ ‎[[timeout=]Seconds]‎ ‎[[messages] {enabled | disabled}]‎

פרמטרים

‎[name=]ServerID
נדרש. ציון שרת RADIUS לפי כתובת IP או שם DNS.
‎[secret=]SharedSecret
ציון פריט המידע המוצפן המשותף.
‎[init-score=]ServerPriority
ציון התוצאה הראשונית (עדיפות שרת).
‎[port=]Port
ציון היציאה שיש לשלוח באמצעותה בקשות אימות.
‎[timeout=]Seconds
ציון פרק הזמן הקצוב, בשניות, שיחלוף בטרם יסומן השרת RADIUS כבלתי זמין.
‎[messages=] {enabled | disabled}‎
קביעה אם יש לשלוח הודעות הפעלה/כיבוי של ניהול חשבונות.

show acctserv

הצגת מידע מפורט אודות שרת ניהול חשבונות. כאשר נעשה שימוש בפקודה show acctserv ללא פרמטרים, מוצג מידע אודות כל שרתי ניהול החשבונות שהוגדרו.

תחביר

show acctserv [[name=]ServerID]‎

פרמטרים

‎[name=]ServerID
ציון שרת RADIUS שאודותיו יש להציג מידע, לפי שם DNS או כתובת IP.

add authserv

ציון כתובת IP או שם DNS של שרת RADIUS שאליו יש להעביר בקשות אימות.

תחביר

add authserv ‎[name=]ServerID ‎[[secret=]SharedSecret]‎ ‎[[init-score=]ServerPriority]‎ ‎[[port=]Port]‎ ‎[[timeout=]Seconds]‎ ‎[[signature] {enabled | disabled}]‎

פרמטרים

‎[name=]ServerID
נדרש. ציון שרת RADIUS לפי כתובת IP או שם DNS.
‎[secret=]SharedSecret
ציון פריט המידע המוצפן המשותף.
‎[init-score=]ServerPriority
ציון התוצאה הראשונית (עדיפות שרת).
‎[port=]Port
ציון היציאה שיש לשלוח אליה בקשות אימות.
‎[timeout=]Seconds
ציון פרק הזמן הקצוב, בשניות, שבמהלכו שרת RADIUS עשוי להיות בלתי פעיל לפני שיסומן כבלתי זמין.
‎[signature] {enabled | disabled}‎
קביעה אם יש להשתמש בחתימות דיגיטליות. הפרמטר enabled מציין שיש להשתמש בחתימות דיגיטליות. הפרמטר disabled מציין שאין להשתמש בחתימות דיגיטליות.

delete authserv

מחיקה של שרת אימות מסוג RADIUS.

תחביר

delete authserv [name=]ServerID

פרמטרים

‎[name=]ServerID
נדרש. ציון השרת שיש למחוק, לפי שם DNS או כתובת IP.

set authserv

ציון כתובת IP או שם DNS של שרת RADIUS שיש להעביר אליו בקשות אימות.

תחביר

set authserv [name=]ServerID ‎[[secret=]SharedSecret]‎ ‎[[init-score=]ServerPriority]‎ ‎[[port=]Port]‎ ‎[[timeout=]Seconds]‎ ‎[[signature] {enabled | disabled}]‎

פרמטרים

‎[name=]ServerID
נדרש. ציון שרת RADIUS לפי כתובת IP או שם DNS.
‎[secret=]SharedSecret
ציון פריט המידע המוצפן המשותף.
‎[init-score=]ServerPriority
ציון התוצאה הראשונית (עדיפות שרת).
‎[port=]Port
ציון היציאה שבאמצעותה יש לשלוח את בקשות האימות.
‎[timeout=]Seconds
ציון פרק הזמן הקצוב, בשניות, שעליו לחלוף בטרם יסומן שרת RADIUS כבלתי זמין.
‎[signature=] {enabled | disabled}‎
קביעה אם יש להשתמש בחתימות דיגיטליות.

show authserv

הצגת מידע מפורט אודות שרת אימות. כאשר נעשה שימוש בפקודה show authserv ללא פרמטרים, מוצג מידע אודות כל שרתי האימות שהוגדרו.

תחביר

show authserv [[name=]ServerID]‎

פרמטרים

‎[name=]ServerID
ציון שרת RADIUS שיש להציג מידע אודותיו, לפי שם DNS או כתובת IP.

set acco

ציון של ספק ניהול החשבונות.

תחביר

set acco provider {windows | radius | none}‎

פרמטרים

provider {windows | radius | none}‎
נדרש. קביעה אם תבוצע ניהול חשבונות, ובאמצעות איזה שרת. הפרמטר windows מציין שעל אבטחת Windows לבצע ניהול חשבונות. הפרמטר radius מציין שעל שרת RADIUS לבצע ניהול חשבונות. הפרמטר none מציין שאין לבצע ניהול חשבונות כלשהו.

show acco

הצגת ספק ניהול החשבונות.

תחביר

show acco

פרמטרים

ללא

set authe

ציון ספק האימות.

תחביר

set authe provider {windows | radius}‎

פרמטרים

provider {windows | radius}‎
נדרש. קביעת הטכנולוגיה שתבצע אימות. הפרמטר windows מציין שעל אבטחת Windows לבצע אימות. הפרמטר radius מציין שעל שרת RADIUS לבצע אימות.

show authe

הצגה של ספק האימות.

תחביר

show authe

פרמטרים

ללא


פקודות Netsh עבור ניתוב

באפשרותך להשתמש בפקודות Netsh עבור ניתוב כדי לנהל שרתי ניתוב משורת הפקודה במקום ממסוף הניתוב והגישה מרחוק. ניהול שרתים משורת הפקודה הוא שימושי ביותר במצבים הבאים:

  • ניהול שרתי ניתוב הוא מהיר יותר בשורת הפקודה מאשר במסוף. יכולת זה חשובה במיוחד, אם נעשה שימוש בחיבור רשת איטי. לדוגמה, בחיבור באמצעות רשת תקשורת מרחבית (WAN).
  • ניתן לנהל שרתי ניתוב באופן עקבי יותר על-ידי הכללת פקודות אלה בקובץ Script שניתן להפעיל בשרתים מרובים.

ניתן להשתמש בפקודות הבאות בשורת הפקודה של הקשר Netsh המתאים (להבדיל משורת הפקודה של Windows XP) לניהול שרתי ניתוב. להפעלת פקודות Netsh אלה בשרת Windows 2000 מרוחק, עליך להשתמש תחילה בהתקשרות לשולחן עבודה מרוחק כדי להתחבר אל שרת Windows 2000 שפועל בו שרת מסוף. ייתכן שיהיו הבדלים פונקציונליים בין פקודות הקשר של Netsh ב- Windows 2000 וב- Windows XP.

לקבלת מידע נוסף אודות Netsh, ראה שימוש ב- Netsh.

פקודות IP IGMP של ניתוב Netsh

הפקודות הבאות זמינות לשימוש בהקשר IP IGMP של ניתוב Netsh.

להצגת תחביר הפקודה, לחץ על פקודה:

add interface

קובעת את התצורה של IGMP בממשק שצוין.

תחביר

add interface [InterfaceName=]InterfaceName ‎[[IgmpPrototype=]{igmprtrv1 | igmprtrv2 | igmprtrv3 | igmpproxy}]‎ ‏[[IfEnabled=]{enable | disable}] [[RobustVar=]Integer]‎ [‎[GenQueryInterval=]Integer] [[GenQueryRespTime=]Integer] [[StartUpQueryCount=]Integer]‎ ‎[[StartUpQueryInterval=]Integer] [[LastMemQueryCount=]Integer]‎ ‎[[LastMemQueryInterval=Integer] [[AccNonRtrAlertPkts=]{yes | no}]‎

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. מציין את שם הממשק שבו ברצונך לקבוע את תצורת IGMP. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שצוין בחיבורי הרשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[IgmpPrototype=]{igmprtrv1 | igmprtrv2 | igmprtrv3 | igmpproxy}‎
מציין את סוג הפרוטוקול שיש לקבוע את תצורתו בממשק. סוג הפרוטוקול המשמש כברירת מחדל הוא igmprtrv2.
‎[IfEnabled=]{enable | disable}‎
מציין האם הפרוטוקול שתצורתו נקבעת יהיה זמין או בלתי זמין. ברירת המחדל היא זמין.
‎[RobustVar=]=Integer
מציין את משתנה החוסן. ערכו של משתנה זה צריך להיות גדול מאפס (0). ערך ברירת המחדל הוא 2.
‎[GenQueryInterval=]Integer
מציין את מרווח הזמן, בשניות, שבו על שאילתות כלליות להישלח בממשק. ערך ברירת המחדל הוא 125 שניות.
‎[GenQueryRespTime=]Integer
מציין את זמן התגובה המירבי, בשניות, לתגובה של מחשבים מארחים לשאילתה כללית. ערך ברירת המחדל הוא 10 שניות.
‎[StartUpQueryCount=]Integer
מציין את מספר השאילתות הכלליות שיישלחו בעת האתחול. ערך ברירת המחדל הוא 2.
‎[StartUpQueryInterval=]Integer
מציין את מרווח הזמן, בשניות, בין שאילתות כלליות הנשלחות בעת האתחול. ערך ברירת המחדל הוא 31 שניות.
‎[LastMemQueryCount=]Integer
מציין את מספר השאילתות הייחודיות לקבוצה הנשלחות כאשר מתקבלת הודעה על מחשב מארח העוזב את הקבוצה. ערך ברירת המחדל הוא 2.
‎[LastMemQueryInterval=]Integer
מציין את מרווח הזמן, באלפיות השניה, בין שאילתות ייחודיות לקבוצה. ערך ברירת המחדל הוא 1000 אלפיות השניה.
‎[AccNonRtrAlertPkts=]{yes | no}‎
מציין האם לקבל מנות IGMP, שייתכן שאפשרות ההתראה עבור נתב לא הוגדרה עבורן. ברירת המחדל היא yes.

דוגמאות

לשינוי מרווח הזמן המשמש כברירת מחדל של שאילתת האתחול ל- 21 שניות עבור תצורת IGMP של הממשק ששמו Local Area Connection, הקלד:

add interface "Local Area Connection" startupqueryinterval=21

install

התקנת נתב או Proxy של IGMP והגדרת רישום כללי ביומן. הפקודה install ללא פרמטרים מתקינה את הנתב או את ה- Proxy ומציינת ששגיאות השייכות ל- IGMP יירשמו ביומן, אולם אירועים אחרים הקשורים ל- IGMP לא יירשמו.

תחביר

‎install [[LogLevel=]{none | error | warn | info}]‎

פרמטרים

‎[LogLevel=]{none | error | warn | info}‎
מציין מה הם האירועים שיירשמו ביומן. הפרמטר none מציין שלא יירשמו ביומן אירועים הקשורים ל- IGMP. הפרמטר error מציין שרק שגיאות הקשורות ל- IGMP יירשמו ביומן. הפרמטר warn מציין שרק אזהרות הקשורות ל- IGMP יירשמו ביומן. הפרמטר info מציין שכל האירועים הקשורים ל- IGMP יירשמו ביומן.

delete interface

מחיקה של נתב או של Proxy של IGMP מהממשק שצוין.

תחביר

delete interface [InterfaceName=]InterfaceName

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון שמו של הממשק שממנו ברצונך להסיר נתב או Proxy של IGMP. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").

דוגמאות

delete interface "Local Area Connection"‎

uninstall

הסרה של נתב או של Proxy של IGMP מכל הממשקים.

תחביר

uninstall

פרמטרים

ללא

set interface

שינוי הפרמטרים של תצורת הממשק.

תחביר

set interface [InterfaceName=]InterfaceName ‎[[IgmpPrototype=]{igmprtrv1 | igmprtrv2 | igmprtrv3 | igmpproxy}]‎ [‎[IfEnabled=]{enable | disable}] [[RobustVar=]Integer]‎ [‎[GenQueryInterval=]Integer] [[GenQueryRespTime=]Integer] [[StartUpQueryCount=]Integer]‎ [‎[StartUpQueryInterval=]Integer] [[LastMemQueryCount=]Integer] [[LastMemQueryInterval=]Integer]‎ ‎[[AccNonRtrAlertPkts=]{yes | no}]‎

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. מציין את שם הממשק שבו ברצונך לקבוע את תצורת IGMP. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[IgmpPrototype=]{igmprtrv1 | igmprtrv2 | igmprtrv3 | igmpproxy}‎
מציין את סוג הפרוטוקול שתצורתו נקבעת בממשק. סוג הפרוטוקול המשמש כברירת מחדל הוא igmprtrv2.
‎[IfEnabled=]{enable | disable}‎
מציין האם על הפרוטוקול המוגדר שתצורתו נקבעת להיות זמין או לא זמין. ברירת המחדל היא זמין.
‎[RobustVar=]Integer
מציין את משתנה החוסן. על ערך משתנה זה להיות גדול מאפס (0). ערך ברירת המחדל הוא 2.
‎[GenQueryInterval=]Integer
מציין את מרווח הזמן, בשניות, שבו על שאילתות כלליות להישלח בממשק. ערך ברירת המחדל הוא 125 שניות.
‎[GenQueryRespTime=]Integer
מציין את זמן התגובה המירבי, בשניות, לתגובה מצד מחשבים מארחים לשאילתה כללית. ערך ברירת המחדל הוא 10 שניות.
‎[StartUpQueryCount=]Integer
מציין את מספר השאילתות הכלליות שיישלחו בעת האתחול. ערך ברירת המחדל הוא 2.
‎[StartUpQueryInterval=]Integer
מציין את מרווח הזמן, בשניות, בין שאילתות כלליות הנשלחות בעת האתחול. ערך ברירת המחדל הוא 31 שניות.
‎[LastMemQueryCount=]Integer
מציין את מספר השאילתות המיועדות לקבוצות הנשלחות כאשר מתקבלת הודעה על מחשב מארח העוזב את הקבוצה. ערך ברירת המחדל הוא 2.
‎[LastMemQueryInterval=]Integer
מציין את מרווח הזמן, באלפיות השניה, בין שאילתות ייחודיות לקבוצה. ערך ברירת המחדל הוא 1000 אלפיות השניה.
‎[AccNonRtrAlertPkts=]{yes | no}‎
מציין האם לקבל מנות IGMP שאפשרות האזהרה עבור נתב אינה מוגדרת עבורן. ברירת המחדל היא לקבל מנות אלה.

דוגמאות

לשינוי מרווח הזמן המשמש כברירת מחדל של שאילתת האתחול ל- 21 שניות עבור תצורת IGMP של הממשק ששמו Local Area Connection, הקלד:

set interface "Local Area Connection" startupqueryinterval=21

set global

הגדרת הפרמטרים הכלליים של IGMP. הפקודה set global ללא פרמטרים מציינת שהאזהרות נרשמות ביומן, אולם אירועים אחרים הקשורים ל- IGMP אינם נרשמים ביומן.

תחביר

set global [LogLevel=]{none | error | warn | info}‎

פרמטרים

‎[LogLevel=]{none | error | warn | info}‎
נדרש. מציין אלו אירועים יירשמו ביומן. הפרמטר none מציין שלא יירשמו ביומן אירועים הקשורים ל- IGMP. הפרמטר error מציין שרק שגיאות הקשורות ל- IGMP יירשמו ביומן. הפרמטר warn מצין שרק אזהרות הקשורות ל- IGMP יירשמו ביומן. הפרמטר info מציין שכל האירועים הקשורים ל- IGMP יירשמו ביומן.

show interface

הצגה של תצורת IGMP של הממשק שצוין. הפקודה show interface ללא פרמטרים מציגה מידע תצורה של IGMP עבור כל הממשקים.

תחביר

show interface [InterfaceName=]InterfaceName

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. מציין את שם הממשק שעבורו ברצונך להציג מידע. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").

show global

הצגת הפרמטרים הכלליים של IGMP.

תחביר

show global

פרמטרים

ללא

show ifstats

הצגת סטסיסטיקה של IGMP עבור הממשק שצוין. הפקודה show ifstats ללא פרמטרים מציגה את הסטטיסטיקה של IGMP פעם אחת עבור כל הממשקים.

תחביר

show ifstats [[Index=]Integer] [[Rr=]Integer]‎

פרמטרים

‎[Index=]Integer
מציין מספר המזהה את הממשק שעבורו ברצונך להציג מידע.
‎[Rr=]Integer
מציין, בשניות, באיזו תדירות ברצונך לבצע רענון של המידע.

דוגמאות

להצגת סטטיסטיקה על IGMP כל 5 שניות עבור ממשק שערך האינדקס שלו הוא 1001, הקלד:

show ifstats index=1001 rr=5

show iftable

הצגת קבוצות אירוח של IGMP עבור ממשק מסוים. הפקודה show iftable ללא פרמטרים מציגה קבוצות אירוח של IGMP עבור כל הממשקים, פעם אחת בלבד.

תחביר

show iftable [[Index=]Integer] [[Rr=]Integer]‎

פרמטרים

‎[Index=]Integer
מציין, באמצעות מספר אינדקס, את הממשק שעבורו ברצונך להציג מידע.
‎[Rr=]Integer
מציין, בשניות, באיזו תדירות ברצונך לרענן את המידע.

דוגמאות

להצגת קבוצות אירוח של IGMP כל 5 שניות עבור ממשק שערך האינדקס שלו הוא 1001, הקלד:

show iftable index=1001 rr=5

show grouptable

הצגה של טבלת קבוצות האירוח של IGMP עבור קבוצת שידור למחשבים מרובים. הפקודה show grouptable ללא פרמטרים מציגה את טבלאות קבוצות האירוח של IGMP עבור כל קבוצות השידור בכל הממשקים המשויכים לנתב, פעם אחת בלבד.

תחביר

show grouptable [[Index=]Integer] [[Rr=]Integer]‎

פרמטרים

‎[Index=]Integer
מציין, באמצעות כתובת IP, את קבוצת השידור למחשבים מרובים שעליה ברצונך להציג מידע.
‎[Rr=]Integer
מציין, בשניות, באיזו תדירות ברצונך לרענן את המידע.

דוגמאות

להצגת טבלת קבוצות האירוח של IGMP כל 5 שניות עבור קבוצת שידור למחשבים מרובים של IGMP , המזוהה באמצעות כתובת ה- IP ‏192.168.100.239, הקלד:

show grouptable index=192.168.100.239 rr=5

show rasgrouptable

מציגה את טבלת קבוצות האירוח עבור ממשק של לקוח גישה מרחוק. הפקודה show rasgrouptable ללא פרמטרים מציגה את טבלאות קבוצות האירוח פעם אחת בלבד עבור כל הממשקים של לקוחות גישה מרחוק.

תחביר

show rasgrouptable [[Index=]IPAddress] [[Rr=]Integer]‎

פרמטרים

‎[Index=]IPAddress
מציין, באמצעות כתובת IP, את הממשק של לקוח הגישה מרחוק שעבורו ברצונך להציג מידע.
‎[Rr=]Integer
מציין, בשניות, באיזו תדירות ברצונך לרענן את המידע.

דוגמאות

להצגת טבלת קבוצות האירוח עבור ממשק של לקוח גישה מרחוק עם כתובת IP של 10.10.1.100 ולרענון המידע כל 5 שניות, הקלד:

show rasgrouptable index=10.10.1.100 rr=5

show proxygrouptable

מציגה את טבלת קבוצות האירוח של IGMP עבור ממשק Proxy של IGMP. הפקודה show proxygrouptable ללא פרמטרים מציגה מידע פעם אחת עבור כל הממשקים.

תחביר

show proxygrouptable [[InterfaceName=]InterfaceName] [[Rr=]Integer]‎

פרמטרים

‎[InterfaceName=]InterfaceName
מציינת, ששמו, את הממשק שעבורו ברצונך להציג מידע. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[Rr=]Integer
מציין, בשניות, באיזו תדירות ברצונך לרענן את המידע.

דוגמאות

להצגת טבלאות קבוצות האירוח של IGMP עבור כל ממשקי Proxy של IGMP ולרענון המידע כל 5 שניות, הקלד:

show proxygrouptable rr=5

פקודות IP Routerdiscovery של ניתוב Netsh

הפקודות הבאות זמינות לשימוש בהקשר IP Routerdiscovery של ניתוב Netsh.

להצגת תחביר הפקודה, לחץ על פקודה:

add interface

הגדרה של גילוי נתב עבור הממשק שצוין.

תחביר

‎add interface [InterfaceName=]InterfaceName [[Disc=]{enable | disable}]‎ [‎[MinInt=]Integer] [[MaxInt=]Integer] [[Life=]Integer] [[Level=]Integer]‎

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון שמו של הממשק שעבורו ברצונך להגדיר גילוי נתב. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[Disc=]{enable | disable}‎
מציין אם יש לבצע את גילוי הנתב בממשק זה. הפרמטר enable מציין שיש לבצע גילוי נתב. הפרמטר disable מציין שאין לבצע גילוי נתב.
‎[MinInt=]Integer
מציין מרווח זמן מזערי, בדקות, בין מועדי השליחה של מנות גילוי נתב.
‎[MaxInt=]Integer
מציין מרווח זמן מירבי, בדקות, בין מועדי השליחה של מנות גילוי נתב.
‎[Life=]Integer
מציין את מספר הדקות שמנת גילוי נתב שנשלחה מנתב או משרת זה תיחשב לחוקית עבורן.
‎[Level=]Integer
מציין ערך מספרי עבור העדיפות לשימוש בממשק זה כשער המשמש כברירת מחדל. במקרים שבהם קיימים כמה ממשקים הזמינים עבור גילוי נתב, מספר גבוה יותר מצביע על עדיפות גבוהה יותר.

הערות

  • כאשר נוספים פרסומים של גילוי נתב, הם נשלחים בזמנים אקראים שהמשותף להם הוא מרווחי הזמן (מזערי ומירבי) שהוגדרו.

דוגמאות

כדי להפעיל את גילוי הנתב עבור הממשק Local Area Connection, תוך ציון מרווח זמן מזערי של 7 דקות, מרווח זמן מירבי של 10 דקות, אורך חיים של 30 דקות עבור מנות של גילוי נתב ורמת עדיפות של אפס (0), כלומר ללא רמת עדיפות, הקלד:

add interface "Local Area Connection" enable 7 10 30 0

set interface

קביעת התצורה של גילוי נתב עבור ממשק.

תחביר

‎set interface [InterfaceName=]InterfaceName [[Disc=]{enable | disable}]‎ ‎[[MinInt=]Integer] [[MaxInt=]Integer] [[Life=]Integer] [[Level=]Integer]‎

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון שמו של הממשק שעבורו ברצונך לקבוע את תצורת הנתב. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[Disc=]{enable | disable}‎
מציין האם יש לבצע גילוי נתב בממשק זה. הפרמטר enable מציין שיש לבצע גילוי נתב. הפרמטר disable מציין שאין לבצע גילוי נתב.
‎[MinInt=]Integer
מציין מרווח זמן מזערי, בדקות, בין הזמנים שבהם נשלחות מנות של גילוי נתב.
‎[MaxInt=]Integer
מציין מרווח זמן מירבי, בדקות, בין הזמנים שבהם נשלחות מנות של גילוי נתב.
‎[Life=]Integer
מציין, בדקות, את פרק הזמן שבמהלכו תהיה מנה של גילוי נתב, הנשלחת מנתב או משרת זה, חוקית.
‎[Level=]Integer
מציין עדיפות לשימוש בממשק זה כשער המשמש כברירת מחדל. מספר גבוה יותר מצביע על עדיפות גבוהה יותר.

דוגמאות

כדי להפעיל את גילוי הנתב עבור הממשק Local Area Connection תוך ציון מרווח זמן מזערי של 7 דקות, מרווח זמן מירבי של 10 דקות, אורך חיים של 30 דקות עבור מנות של גילוי נתב ועדיפות של אפס (0), כלומר ללא רמת עדיפות, הקלד:

set interface "Local Area Connection" enable 7 10 30 0

delete interface

מחיקת תצורה של גילוי נתב.

תחביר

delete interface [InterfaceName=]InterfaceName

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון שמו של הממשק שעבורו ברצונך למחוק תצורה של גילוי נתב. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").

דוגמאות

למחיקה של תצורת גילוי נתב עבור ממשק ששמו Local Area Connection, הקלד:

delete interface name="Local Area Connection"‎

show interface

הצגת מידע אודות גילוי נתב. ללא פרמטרים, הפקודה show interface מציגה מידע עבור כל הממשקים.

תחביר

show interface [[InterfaceName=]InterfaceName]‎

פרמטרים

‎[InterfaceName=]InterfaceName
ציון שמו של הממשק שעבורו ברצונך להציג מידע. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").

דוגמאות

להצגת מידע של גילוי נתב עבור ממשק ששמו Local Area Connection, הקלד:

show interface "Local Area Connection"‎

פקודות IP RIP של ניתוב Netsh

הפקודות הבאות זמינות לשימוש בהקשר IP RIP של ניתוב Netsh.

להצגת תחביר הפקודה, לחץ על פקודה:

add peerfilter

הוספת מסנן לשרתים שניתן לקבל כמחשבים עמיתים.

תחביר

add peerfilter [Server=]IPAddress

פרמטרים

‎[Server=]IPAddress
נדרש. ציון כתובת IP של השרת העמית שאת תעבורתו ברצונך לסנן.

add acceptfilter

ציון מסנן קבלה עבור ניתובים המתקבלים בממשק.

תחביר

add acceptfilter [InterfaceName=]InterfaceName [Addr=]IPAddress1 IPAddress2

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון שמו של ממשק ש- RIP זמין לשימוש בו. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[Addr=]IPAddress1 IPAddress2
נדרש. מציין זוג של כתובות IP. הכתובת הראשונה היא עבור כתובת ה- IP הנמוכה והכתובת השניה היא עבור כתובת ה- IP הגבוהה שיש להשתמש בהן בבניית המסנן.

דוגמאות

להוספת מסנן קבלה עבור ממשק ששמו Local Area Connection לטווח כתובות IP שבין 10.0.0.2 לבין 10.11.21.154, הקלד:

add acceptfilter "Local Area Connection" 10.0.0.2 10.11.21.154

add announcefilter

הוספת מסנן לניתובים המוכרזים בממשק.

תחביר

add announcefilter [InterfaceName=]InterfaceName [Addr=]IPAddress1 IPAddress2

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. מציין את שם הממשק שבו יהיה RIP זמין לשימוש. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[Addr=]IPAddress1 IPAddress2
נדרש. מציין זוג של כתובות IP. הכתובת הראשונה היא עבור כתובת ה- IP הנמוכה, ואילו הכתובת השניה היא עבור כתובת ה- IP הגבוהה. שתי הכתובות משמשות לבניית המסנן.

דוגמאות

להוספת מסנן לניתובים המוכרזים בממשק ששמו Local Area Connection עבור טווח כתובות IP שבין 10.0.0.2 לבין 10.11.21.154, הקלד:

add announcefilter Local Area Connection 10.0.0.2 10.11.21.154

add neighbor

הוספת RIP שכן על ממשק.

תחביר

add neighbor [InterfaceName=]InterfaceName [addr=]IPAddress

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון שמו של ממשק שבו יהיה RIP זמין לשימוש. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[addr=]IPAddress
נדרש. מציין את כתובת ה- IP של ה- RIP השכן שברצונך להוסיף.

דוגמאות

להוספת RIP שכן הממוקם בכתובת IP של 10.0.0.2 לממשק ששמו Local Area Connection, הקלד:

add neighbor "Local Area Connection" 10.0.0.2

add interface

הוספת RIP לממשק שצוין.

תחביר

add interface [InterfaceName=]InterfaceName [[Metric=]Integer]‎ ‎[[UpdateMode=]{demand | periodic}] [[Announce=]{none | rip1 | rip1compat | rip2}]‎ ‎[[Accept=]{none | rip1 | rip1compat | rip2}]‎ ‎[[Expire=]Integer] [[Remove=]Integer] [[Update=]Integer]‎ ‎[[AuthMode=]{authnone | authsimplepassword}] [[Tag=]Integer] [[Unicast=]{also | only | disable}]‎ ‎[[AccFiltMode=]{include | exclude | disable}]‎ ‎[[AnnFiltMode=]{include | exclude | disable}] [[Password=]String]‎

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון שמו של הממשק שאליו ברצונך להוסיף RIP. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[Metric=]Integer
מציין ערך עשרוני עבור ניתובים המבוססים על ממשק זה.
‎[UpdateMode=]{demand | periodic}‎
מציין מתי יתבצעו עדכונים. הפרמטר demand מציין שעדכונים יתבצע על-פי דרישה. הפרמטר periodic מציין שעדכונים יתבצעו במרווחי זמן קבועים.
‎[Announce=]{none | rip1 | rip1compat | rip2}‎
מציין את הניתובים שיש להכריז עליהם. הפרמטר none מציין שיש להכריז על כל הניתובים. הפרמטר rip1 מציין שיש להכריז רק על ניתובי RIP מגירסה 1. הפרמטר rip1compat מציין שיש לבצע הכרזות במצב של תאימות לגירסת RIP. הפרמטר rip2 מציין שיש להכריז רק על ניתובים של RIP מגירסה 2.
‎[Accept=]{none | rip1 | rip1compat | rip2}‎
מציין מה הם הניתובים שיש לקבל. הפרמטר none מציין שיש לקבל את כל הניתובים. הפרמטר rip1 מציין שיש לקבל רק ניתובי RIP מגירסה 1. הפרמטר rip1compat מציין שיש לקבל את הניתובים במצב של תאימות לגירסת ה- RIP. הפרמטר rip2 מציין שיש לקבל רק ניתובי RIP מגירסה 2.
‎[Expire=]Integer
מציין, בשניות, את מרווח הזמן של תפוגת הניתוב.
‎[Remove=]Integer
מציין, בשניות, את מרווח הזמן להסרת הניתוב.
‎[Update=]Integer
מציין, בשניות, את מרווח הזמן לעדכון מלא.
‎[AuthMode=]{authnone | authsimplepassword}‎
מציין האם יהיה צורך במתן הרשאות. הפרמטר authnone מציין שלא יידרש מתן הרשאות. הפרמטר authsimplepassword שיידרש מתן הרשאות באמצעות סיסמה.
‎[Tag=]Integer
מציין את תג הניתוב.
‎[Unicast=]{also | only | disable}‎
מציין את מצב השידור ליעד בודד. הפרמטר also מציין שימוש גם במצב השידור ליעד בודד. הפרמטר only מציין שימוש במצב השידור ליעד בודד בלבד. הפרמטר disable מציין שאין להפעיל את מצב השידור ליעד בודד.
‎[AccFiltMode=]{include | exclude | disable}‎
מציין אם על מסנני קבלה להיכלל, או אם יש לבטלם. הפרמטר include מציין שיש לכלול מסנני קבלה. הפרמטר exclude מציין שאין לכלול מסנני קבלה. הפרמטר disable מציין שיש לבטל את מסנני הקבלה.
‎[AnnFiltMode=]{include | exclude | disable}‎
מציין האם יש לכלול מסנני הכרזה, או שיש לבטלם. הפרמטר include מציין שיש לכלול מסנני הכרזה. הפרמטר exclude מציין שאין לכלול פרמטרי הכרזה. הפרמטר disable מציין שיש לבטל את מסנני ההכרזה.
‎[Password=]String
מציין סיסמה מסוג טקסט רגיל שאורכה אינו עולה על 16 תווים.

add helper

התקנת עוזר DLL תחת RIP.

תחביר

add helper DLLName

פרמטרים

DLLName
נדרש. מציין DLL התומך בהקשר זה.

delete peerfilter

מחיקת מסנן עבור שרת עמית שהתקבל.

תחביר

delete peerfilter [Server=]IPAddress

פרמטרים

‎[Server=]IPAddress
נדרש. מציין, באמצעות כתובת IP, את השרת העמית שאת תעבורתו אין ברצונך לסנן.

delete acceptfilter

מחיקה של מסנן קבלה עבור ניתובים שהתקבלו בממשק שצוין.

תחביר

delete acceptfilter [InterfaceName=]InterfaceName [Addr=]IPAddress1 IPAddress2

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון שמו של ממשק שבו RIP זמין לשימוש. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[Addr=]IPAddress1 IPAddress2
נדרש. מציין זוג של כתובות IP. הכתובת הראשונה היא עבור כתובת ה- IP הנמוכה, ואילו הכתובת השניה היא עבור כתובת ה- IP הגבוהה. כתובות אלה משמשות עבור בניית המסנן.

דוגמאות

למחיקת מסנן קבלה עבור טווח כתובות ה- IP שבין 10.0.0.2 לבין 10.11.21.154 בממשק ששמו Local Area Connection, הקלד:

delete acceptfilter "Local Area Connection" 10.0.0.2 10.11.21.154

delete announcefilter

מחיקה של מסנן הכרזה שהוגדר עבור ממשק.

תחביר

delete announcefilter [InterfaceName=]InterfaceName [Addr=]IPAddress1 IPAddress2

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. מציין את שם הממשק שבו RIP זמין לשימוש. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[Addr=]IPAddress1 IPAddress2
נדרש. מציין זוג של כתובות IP. הכתובת הראשונה היא עבור כתובת ה- IP הנמוכה, ואילו הכתובת השניה היא עבור כתובת ה- IP הגבוהה. כתובות אלה משמשות עבור בניית המסנן.

דוגמאות

למחיקת מסנן הכרזה עבור טווח כתובות ה- IP שבין 10.0.0.2 לבין 10.11.21.154 עבור ממשק ששמו Local Area Connection, הקלד:

delete announcefilter "Local Area Connection" 10.0.0.2 10.11.21.154

delete neighbor

מחיקה של RIP שכן מממשק.

תחביר

delete neighbor [InterfaceName=]InterfaceName IPAddress

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון שמו של הממשק שבו RIP זמין לשימוש. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות לדוגמה, "Interface Name").
IPAddress
נדרש. מציין, באמצעות כתובת IP, את ה- RIP השכן המיועד למחיקה.

דוגמאות

למחיקת RIP שכן, הממוקם בכתובת 10.0.0.2, עבור ממשק ששמו Local Area Connection, הקלד:

delete neighbor "Local Area Connection" 10.0.0.2

delete interface

הסרת RIP מן הממשק שצוין.

תחביר

delete interface [InterfaceName=]InterfaceName

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון שמו של הממשק שממנו ברצונך להסיר RIP. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").

delete helper

הסרת עוזר DLL שצוין מ- Netsh.

תחביר

delete helper HelperName

פרמטרים

HelperName
נדרש. ציון שם הקובץ של את עוזר DLL שברצונך להסיר.

set interface

קביעה של תצורת RIP בממשק שצוין.

תחביר

set interface [InterfaceName=]InterfaceName [[Metric=]Integer]‎ ‎[[UpdateMode=]{demand | periodic}]‎ ‎[[Announce=]{none | rip1 | rip1compat | rip2}] [[Accept=]{none | rip1 | rip1compat | rip2}]‎ [‎[Expire=]Integer] [[Remove=]Integer] [[Update=]Integer]‎ ‎[[AuthMode=]{authnone | authsimplepassword}]‎ ‎[[Tag=]Integer] [[Unicast=]{also | only | disable}]‎ ‎[[AccFiltMode=]{include | exclude | disable}]‎ ‎[[AnnFiltMode=]{include | exclude | disable}] [[Password=]String]‎

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון שמו של הממשק שבו יש לקבוע את תצורת RIP. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[Metric=]Integer
מציין ערך עשרוני עבור ניתובים בהתבסס על ממשק זה.
‎[UpdateMode=]{demand | periodic}‎
מציין מתי על עדכונים להתבצע. הפרמטר demand מציין שעל עדכונים להתבצע על-פי דרישה. הפרמטר periodic מציין שעל עדכונים להתבצע במרווחי זמן קבועים.
‎[Announce=]{none | rip1 | rip1compat | rip2}‎
מציין את הניתובים שעליהם יש להכריז. הפרמטר none מציין שיש להכריז על כל הניתובים. הפרמטר rip1 מציין שיש להכריז רק על ניתובי RIP מגירסה 1. הפרמטר rip1compat מציין שיש לבצע את ההכרזות במצב תואם לגירסת RIP. הפרמטר rip2 מציין שיש להכריז רק על ניתובי RIP מגירסה 2.
‎[Accept=]{none | rip1 | rip1compat | rip2}‎
מציין את הניתובים שיש לקבל. הפרמטר none מציין שיש לקבל את כל הניתובים. הפרמטר rip1 מציין שיש לקבל רק ניתובי RIP מגירסה 1. הפרמטר rip1compat מציין שיש לקבל את הניתובים במצב תואם לגירסת RIP. הפרמטר rip2 מציין שיש לקבל רק ניתובי RIP מגירסה 2.
‎[Expire=]Integer
מציין, בשניות, את פרק הזמן שיחלוף עד שיפוג תוקפו של הניתוב.
‎[Remove=]Integer
מציין, בשניות, את פרק הזמן שיחלוף עד להסרת הניתוב.
‎[Update=]Integer
מציין, בשניות, באיזו תדירות מתבצעים עדכונים מלאים.
‎[AuthMode=]{authnone | authsimplepassword}‎
מציין האם נדרש מתן הרשאות. הפרמטר authnone מציין שלא נדרש כל מתן הרשאות. הפרמטר authsimplepassword מציין שנדרש מתן הרשאות באמצעות סיסמה.
‎[Tag=]Integer
מציין את תג הניתוב.
‎[Unicast=]{also | only | disable}‎
מציין את מצב השידור ליעד בודד. הפרמטר also מציין שניתן להשתמש גם במצב של שידור ליעד בודד. הפרמטר only מציין שימוש רק במצב של שידור ליעד בודד. הפרמטר disable מציין כי אין לעשות שימוש במצב השידור ליעד בודד.
‎[AccFiltMode=]{include | exclude | disable}‎
מציין אם יש לכלול מסנני קבלה. הפרמטר include מציין שיש לכלול מסנני קבלה. הפרמטר exclude מציין שאין לכלול מסנני קבלה. הפרמטר disable מציין שיש לבטל שימוש במסנני קבלה.
‎[AnnFiltMode=]{include | exclude | disable}‎
מציין האם על מסנני קבלה להיכלל או אם יש לבטלם. הפרמטר include מציין שיש לכלול מסנני קבלה. הפרמטר exclude מציין שאין לכלול מסנני קבלה. הפרמטר disable מציין שיש לבטל שימוש במסנני קבלה.
‎[Password=]String
מציין סיסמה מסוג טקסט רגיל שאורכה אינו עולה על 16 תווים.

דוגמאות

לשם שינוי של תצורת RIP בממשק ששמו Local Area Connection, תוך כדי ציון ערך מטרי של 2 וציון העובדה שעל עדכונים להתבצע על-פי דרישה, הקלד:

set interface "Local Area Connection" metric=2 updatemode=periodic

set flags

הגדרת דגלים הקשורים ל- RIP בממשק שצוין .

תחביר

set flags [InterfaceName=]InterfaceName [clear,][splithorizon,][poisonreverse,][triggeredupdates,][cleanupupdates]‎‎[accepthostroutes,][acceptdefaultroutes,][senddefaultroutes,][nosubnetsummary]‎

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון שמו של הממשק שבו יש להגדיר דגלים. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[clear,][splithorizon,][poisonreverse,][triggeredupdates,][cleanupupdates,][accepthostroutes,][acceptdefaultroutes,][senddefaultroutes,][nosubnetsummary]‎
מציין מדיניות עבור דגלים הקשורים ל- RIP. הפרמטר clear מציין שיש לנקות את כל הדגלים המוגדרים של RIP. הפרמטר splithorizon מציין שיש לאפשר פעולה של RIP עבור Split Horizon. הפרמטר poisonreverse מציין שיש לאפשר פעולה של RIP עבור Poison Reverse. הפרמטר triggeredupdates מציין שיש לבצע עדכונים המופעלים על-ידי RIP. הפרמטר cleanupupdates מציין שיש לבצע עדכוני ניקוי עבור RIP. הפרמטר accepthostroutes מציין שיש לקבל ניתובי אירוח. הפרמטר acceptdefaultroutes מציין שיש לשלוח ניתובים המשמשים ברירת מחדל. הפרמטר senddefaultroutes מציין שיש לשלוח ניתובים המשמשים כברירת מחדל. הפרמטר nosubnetsummary מציין שאין לבצע סיכום של רשת משנה.

הערות

  • אין לציין פסיק לאחר פרמטר המדיניות האחרון.

set global

הגדרת פרמטרים כלליים של RIP.

תחביר

set global {[[loglevel=]{none | error | warn | info}] |‎ ‎[[mintrig=]Integer] | [[peermode=]{include | exclude | disable}]}‎

פרמטרים

‎[loglevel=]{none | error | warn | info}‎
מציין אירועי RIP שיירשמו ביומן הרישום. הפרמטר none מציין שלא יירשמו ביומן אף אירועי RIP. הפרמטר error מציין שיירשמו ביומן רק שגיאות הקשרות ל- RIP. הפרמטר warn מציין שיירשמו ביומן רק אזהרות הקשורות ל- RIP. הפרמטר info מציין שיירשמו ביומן כל האירועים הקשורים ל- RIP.
‎[mintrig=]Integer
מציין, בדקות, את פרק הזמן המזערי האמור לחלוף בין גורמים מפעילים (Triggers).
‎[peermode=]{include | exclude | disable}‎
מציין האם יש לכלול מחשבים עמיתים והאם יש לבטל מצב עמית. הפרמטר include מציין שיש לכלול מחשבים עמיתים. הפרמטר exclude מציין שאין לכלול מחשבים עמיתים. הפרמטר disable מציין שאין להפעיל מצב עמית.

show interface

הצגה של תצורת RIP עבור הממשק שצוין. הפקודה show interface ללא פרמטרים מציגה מידע תצורה עבור כל הממשקים.

תחביר

show interface [[InterfaceName=]InterfaceName]‎

פרמטרים

‎[InterfaceName=]InterfaceName
ציון שמו של הממשק שאת המידע עליו ברצונך להציג. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שהוא מופיע ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").

show flags

הצגה של דגלי RIP שהוגדרו עבור הממשק שצוין. הפקודה show flags ללא פרמטרים מציגה מידע עבור כל הממשקים.

תחביר

show flags [[InterfaceName=]InterfaceName]‎

פרמטרים

‎[InterfaceName=]InterfaceName
ציון שמו של הממשק שברצונך להציג מידע אודותיו. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").

show global

הצגת הפרמטרים הכלליים של RIP.

תחביר

show global

פרמטרים

ללא

show ifstats

הצגה של סטטיסטיקת RIP עבור הממשק שצוין. הפקודה show ifstats ללא פרמטרים מציגה מידע פעם אחת בלבד, עבור כל הממשקים.

תחביר

show ifstats [[Index=]Integer] [[Rr=]Integer]‎

פרמטרים

‎[Index=]Integer
מציין את מספרו האינדקסיאלי של הממשק שברצונך להציג מידע אודותיו.
‎[Rr=]Integer
מציין, בשניות, באיזו תדירות ברצונך לרענן את המידע.

הערות

  • להצגת ערכו האינדקסיאלי של כל ממשק, השתמש בפקודה show interface בהקשר Interface IP של Netsh.

דוגמאות

להצגה של סטטיסטיקת RIP כל 5 שניות עבור ממשק שערכו האינדקסיאלי 1, הקלד:

show ifstats index=1 rr=5

show ifbinding

הצגת איגוד כתובת IP של ממשק RIP. הפקודה show ifbinding ללא פרמטרים מציגה מידע פעם אחת בלבד, עבור כל הממשקים.

תחביר

show ifbinding [[Index=]Integer] [[Rr=]Integer]‎

פרמטרים

‎[Index=]Integer
ציון מספרו האינדקסיאלי של הממשק שברצונך להציג מידע אודותיו.
‎[Rr=]Integer
מציין, בשניות, באיזו תדירות ברצונך לרענן את המידע.

הערות

  • להצגת הערך האינדקסיאלי של כל ממשק, השתמש בפקודה show interface בהקשר Interface IP של Netsh.

דוגמאות

להצגת איגודים כל 5 שניות עבור ממשק שערכו האינדקסיאלי 1, הקלד:

show ifbinding index=1 rr=5

פקודות IP Relay של ניתוב Netsh

הפקודות הבאות זמינות לשימוש בהקשר IP Relay של ניתוב Netsh.

להצגת תחביר הפקודה, לחץ על פקודה:

add dhcpserver

הוספה של שרת DHCP לרשימה של שרתי DHCP שהודעותיהם יועברו באמצעות DHCP Relay Agent.

תחביר

add dhcpserver IPAddress

פרמטרים

IPAddress
נדרש. ציון כתובת IP של שרת DHCP שברצונך להוסיף.

add interface

הפעלת DHCP Relay Agent בממשק שצוין.

תחביר

add interface [InterfaceName=]InterfaceName

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון שמו של הממשק שברצונך להפעיל בו את DHCP Relay Agent. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").

delete interface

ביטול DHCP Relay Agent בממשק שצוין.

תחביר

delete interface [InterfaceName=]InterfaceName

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון שמו של הממשק שברצונך לבטל בו את DHCP Relay Agent. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").

delete dhcpserver

הסרה של שרת DHCP מן הרשימה של שרתי DHCP שהודעותיהם יועברו באמצעות DHCP Relay Agent.

תחביר

delete dhcpserver IPAddress

פרמטרים

IPAddress
נדרש. ציון כתובת IP של שרת DHCP שיש למחוק.

set global

קביעת פרמטרים כלליים של רישום עבור תצורת DHCP Relay Agent.

תחביר

set global [LogLevel=]{none | error | warn | info}‎

פרמטרים

‎[LogLevel=]{none | error | warn | info}‎
נדרש. ציון של אירועי DHCP Relay Agent שיירשמו ביומן. הפרמטר none מציין שלא יירשמו ביומן אף אירועים הקשורים ל- DHCP Relay Agent. הפרמטר error מציין שרק שגיאות הקשורות ל- DHCP Relay Agent יירשמו ביומן. הפרמטר warn מציין שרק אזהרות הקשורות ל- DHCP Relay Agent יירשמו ביומן. הפרמטר info מציין שכל האירועים הקשורים ל- DHCP Relay Agent יירשמו ביומן.

set interface

עדכון של תצורת DHCP Relay Agent בממשק.

תחביר

set interface [InterfaceName=]InterfaceName [relaymode=]{enable | disable}‎ ‎[[maxhop=]Integer] [[minsecs=]Integer]‎

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון שמו של הממשק שבו ברצונך לעדכן את תצורת DHCP Relay Agent. על הפרמטר InterfaceNameלהיות תואם לשם הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[relaymode=]{enable | disable}‎
נדרש. ציון הפעלה או ביטול של DHCP Relay Agent. הפרמטר enable מציין שיש להפעיל את DHCP Relay Agent זמין עבור ממשק זה. הפרמטר disable שיש לבטל את פעולת DHCP Relay Agent עבור ממשק זה.
‎[maxhop=]Integer
מציין את מספר הדילוגים שמנת DHCP עשויה לבצע לפני שתשוחרר ולא תשודר יותר.
‎[minsecs=]Integer
מציין את המספר המזערי של שניות החל מזמן האתחול שחייב להופיע במנת DHCP לפני שתישלח לשרת DHCP המופיע ברשימת השרתים שהודעותיהם מועברות באמצעות DHCP Relay Agent.

דוגמאות

לעדכון תצורת DHCP Relay Agent בממשק ששמו Local Area Connection עם ספירת דילוגים מירבית של 16 ועם ערך של 4 שניות עבור מספר השניות המזערי מזמן האתחול, הקלד:

set interface "Local Area Connection" enable 16 4

show interface

הצגה של מידע תצורה אודות DHCP Relay Agent בממשק שצוין.

תחביר

show interface [InterfaceName=]InterfaceName

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון שמו של הממשק שברצונך להציג מידע אודותיו. על הפרמטר InterfaceName להיות תואם לשם הממשק כפי שהוא מופיע ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").

show global

הצגת התצורה הגלובלית של DHCP Relay Agent.

תחביר

show global [[Rr=]Integer]‎

פרמטרים

‎[Rr=]Integer
מציין, בשניות, באיזו תדירות ברצונך לרענן את המידע.

show ifconfig

הצגה של מידע תצורה אודות DHCP Relay Agent בממשק שצוין. הפקודה show ifconfig ללא פרמטרים מציגה מידע פעם אחת בלבד, עבור כל הממשקים ש- DHCP Relay Agent הופעל בהם.

תחביר

show ifconfig [[Index=]Integer] [[Rr=]Integer]‎

פרמטרים

‎[Index=]Integer
מציין את ערכו האינדקסיאלי של הממשק שעבורו ברצונך להציג מידע.
‎[Rr=]Integer
מציין, בשניות, באיזו תדירות ברצונך לרענן את המידע.

show ifbinding

הצגה של איגודי כתובות IP עבור הממשק שצוין. הפקודה show ifbinding ללא פרמטרים מציגה מידע פעם אחת בלבד, עבור כל הממשקים ש- DHCP Relay הופעל בהם.

תחביר

show ifbinding [[Index=]Integer] [[Rr=]Integer]‎

פרמטרים

‎[Index=]Integer
מציין את ערכו האינדקסיאלי של הממשק שעבורו ברצונך להציג מידע.
‎[Rr=]Integer
מציין, בשניות, באיזו תדירות ברצונך לרענן את המידע.

show ifstats

הצגת סטטיסטיקה של DHCP Relay Agent עבור הממשק שצוין. הפקודה show ifstats ללא פרמטרים מציגה מידע פעם אחת בלבד, עבור כל הממשקים ש- DHCP Relay הופעל בהם.

תחביר

show ifstats [[Index=]Integer] [[Rr=]Integer]‎

פרמטרים

‎[Index=]Integer
מציין את ערכו האינדקסיאלי של הממשק שעבורו ברצונך להציג מידע.
‎[Rr=]Integer
מציין, בשניות, באיזו תדירות ברצונך לרענן את המידע.

פקודות IP OSPF של ניתוב Netsh

הפקודות הבאות זמינות לשימוש בהקשר IP OSPF של ניתוב Netsh.

להצגת תחביר הפקודה, לחץ על פקודה:

הערה

  • הפרוטוקול OSPF אינו זמין ב- Windows XP 64-Bit Edition.

add range

הוספה של זוג המכיל כתובת IP ומסיכה, ומגדיר טווח כתובות השייכות לאזור זה.

תחביר

add range [Areaid=]IPAddress [Range=]IPAddress SubnetMask

פרמטרים

‎[Areaid=]IPAddress
נדרש. מציין כתובת IP של האזור שאליו נוסף הטווח.
‎[Range=]IPAddress SubnetMask
נדרש. מציין כתובת IP ומסיכה עבור הטווח שיש להוסיף.

הערות

  • טווחי OSPF משמשים לסיכום הניתובים באזור OSPF.

add area

הוספת מזהה עבור האזור.

תחביר

add area [Areaid=]IPAddress

פרמטרים

‎[Areaid=]IPAddress
נדרש. מציין כתובת IP של האזור שאליו ברצונך להוסיף את הטווח.

הערות

  • הפרמטר Areaid הוא מספר של 32 סיביות המבוטא באמצעות סימון נקודה עשרונית, ומזהה את אזור OSPF. מזהה האזור אינו צריך להיות זהה לכתובת ה- IP או למזהה רשת של IP. מזהה האזור 0.0.0.0 שמור עבור האזור המרכזי. אם האזור מייצג רשת משנה מקוננת, באפשרותך לציין עבור מזהה האזור את המספר עבור מזהה רשת של IP ברשת המשנה המקוננת.

add virtif

הוספת הממשק הווירטואלי עבור נתב.

תחביר

add virtif [transareaid=]TransitAreaID [virtnbrid=]VirtualNeighborID

פרמטרים

‎[transareaid=]TransitAreaID
נדרש. מציין את כתובת ה- IP של אזור המעבר המשמש להחלפת מידע ניתוב בין הנתב הגבול של האזור המרכזי לבין נתב הגבול של האזור הבלתי רציף.
‎[virtnbrid=]VirtualNeighborID
נדרש. מציין את כתובת ה- IP של מזהה הנתב של השכן הווירטואלי שיש להוסיף.

add neighbor

הוספת שכן OSPF לממשק שצוין.

תחביר

add neighbor [InterfaceName=]InterfaceName [addr=]IPAddress ‎[nbraddr=]IPAddress [nbrprio=]Priority

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון שמו של הממשק שברצונך להוסיף לו שכן. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[addr=]IPAddress
נדרש. ציון כתובת IP של ממשק ה- OSPF.
‎[nbraddr=]IPAddress
נדרש. ציון כתובת IP של השכן שברצונך להוסיף.
‎[nbrprio=]Priority
נדרש. ציון עדיפות של נתב OSPF עבור השכן שברצונך להוסיף.

add interface

הגדרת OSPF בממשק שצוין.

תחביר

add interface [InterfaceName=]InterfaceName [areaid=]IPAddress ‎[addr=]IPAddress [mask=]SubnetMask

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון שמו של הממשק שברצונך להוסיף אליו OSPF. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[areaid=]IPAddress
נדרש. ציון כתובת IP של האזור שאליו שייך הממשק.
‎[addr=]IPAddress
נדרש. ציון כתובת IP של הממשק שיש להוסיף.
‎[mask=]SubnetMask
נדרש. ציון מסיכת רשת המשנה של הממשק שיש להוסיף.

add routefilter

הוספה של מסנן עבור ניתוב OSPF.

תחביר

add routefilter [Filter=]IPAddress SubnetMask

פרמטרים

‎[Filter=]IPAddress SubnetMask
נדרש. ציון כתובת IP ומסיכת רשת משנה עבור הניתוב שברצונך לסנן.

add protofilter

הוספה של מסנן פרוטוקול OSPF.

תחביר

add protofilter [filter=]‎‎{autostatic | local | rip | snmp | nondod | static}‎

פרמטרים

‎[filter=]{autostatic | local | rip | snmp | nondod | static}‎
נדרש. ציון מסנן הפרוטוקול שברצונך להוסיף. הפרמטר autostatic מציין ניתוב אוטו-סטטי מסוג RIP. הפרמטר local מציין ניתוב שמוסיפה הרשת שאליה מחובר המחשב. הפרמטר rip מציין שהוספת המסנן מתבצעת באמצעות RIP. הפרמטר snmp מציין שהוספת הניתוב מתבצעת באמצעות SNMP. הפרמטר nondod מציין ניתוב RTM הנוכח רק כאשר ממשק DOD מחובר. הפרמטר static מציין ניתוב RTM.

הערות

  • בפקודה add protofilter נעשה שימוש בניתוב OSPF הפועל כנתב גבול של מערכת אוטונומית. המסננים שתוסיף יסננו מקורות ניתוב אחרים לפי מקור פרוטוקול, כגון ניתובים סטטיים ו- RIP, כך שלא תבוצע הפצה מחדש שלהם אל מערכת אוטונומית של OSPF.

install

התקנת OSPF.

תחביר

install

פרמטרים

ללא

delete range

מחיקת הטווח שצוין עבור מזהה האזור.

תחביר

delete range [Areaid=]IPAddress [Range=]IPAddress SubnetMask

פרמטרים

‎[Areaid=]IPAddress
נדרש. ציון כתובת ה- IP של האזור שברצונך למחוק.
‎[Range=]IPAddress SubnetMask
נדרש. ציון כתובת IP ומסיכת רשת משנה של טווח האזור שברצונך למחוק.

delete area

מחיקת האזור שצוין.

תחביר

delete area [Areaid=]IPAddress

פרמטרים

‎[Areaid=]IPAddress
נדרש. ציון כתובת ה- IP של האזור שברצונך למחוק.

הערות

מזהה האזור הוא מספר של 32 סיביות בסימון דצימלי מנוקד המזהה את אזור OSPF. מזהה האזור אינו חייב להיות זהה לכתובת ה- IP או למזהה רשת של IP. מזהה האזור 0.0.0.0 שמור עבור האזור המרכזי. אם האזור מייצג רשת משנה מקוננת, באפשרותך להשתמש עבור מזהה האזור במספר רשת של IP של רשת המשנה המקוננת.

delete virtif

מחיקת ממשק וירטואלי שצוין.

תחביר

delete virtif [transareaid=]TransitAreaID [virtnbrid=]VirtualNeighborID

פרמטרים

‎[transareaid=]TransitAreaID
נדרש. ציון כתובת ה- IP של אזור המעבר המשמש עבור החלפה של מידע ניתוב בין נתב הגבול של האזור המרכזי לבין נתב הגבול של האזור הבלתי רציף.
‎[virtnbrid=]VirtualNeighborID
נדרש. ציון מזהה הנתב של השכן הווירטואלי שיש למחוק.

delete neighbor

מחיקה של שכן OSPF שצוין.

תחביר

delete neighbor [InterfaceName=]InterfaceName [addr=]IPAddress ‎[nbraddr=]IPAddress [nbrprio=]Priority

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון שמו של הממשק שממנו ברצונך למחוק שכן. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[addr=]IPAddress
נדרש. ציון כתובת ה- IP של הממשק שממנו ברצונך למחוק שכן.
‎[nbraddr=]IPAddress
נדרש. ציון כתובת ה- IP של השכן שיש למחוק.
‎[nbrprio=]Priority
נדרש. ציון עדיפות נתב OSPF של השכן שיש למחוק.

delete interface

מחיקת OSPF מן הממשק שצוין.

תחביר

delete interface [InterfaceName=]InterfaceName [addr=]IPAddress [mask=]SubnetMask

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון שמו של הממשק שממנו ברצונך למחוק OSPF. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[addr=]IPAddress
נדרש. ציון כתובת ה- IP של הממשק שיש למחוק.
‎[mask=]SubnetMask
נדרש. ציון מסיכת רשת המשנה של הממשק שיש למחוק.

delete routefilter

מחיקה של מסנן ניתוב OSPF שצוין.

תחביר

delete routefilter [Filter=]IPAddress SubnetMask

פרמטרים

‎[Filter=]IPAddress SubnetMask
נדרש. ציון כתובת IP ומסיכת רשת משנה של מסנן הניתוב שברצונך למחוק.

delete protofilter

מחיקה של מסנן פרוטוקול OSPF שצוין.

תחביר

delete protofilter [filter=]‎‎{autostatic | local | rip | snmp | nondod | static}‎

פרמטרים

‎[filter=]{autostatic | local | rip | snmp | nondod | static}‎
נדרש. ציון מסנן הפרוטוקול שברצונך למחוק. הפרמטר autostatic מציין ניתוב RIP אוטו-סטטי. הפרמטר local מציין ניתוב שהוספתו מתבצעת באמצעות הרשת שאליה מחובר המחשב. הפרמטר rip מציין שהוספת המסנן מתבצעת באמצעות RIP. הפרמטר snmp מציין שהוספת הניתוב מתבצעת באמצעות SNMP. הפרמטר nondod מציין ניתוב RTM הנוכח רק כאשר ממשק DOD מחובר. הפרמטר static מציין ניתוב RTM.

הערות

  • בפקודה delete protofilter נעשה שימוש בנתב OSPF הפועל כנתב גבול של מערכת אוטונומית. המסננים שתוסיף מסננים מקורות ניתוב אחרים לפי מקור הפרוטוקול, כגון ניתובים סטטיים ו- RIP, כך שלא מתבצעת עבורם הפצה מחדש אל מערכת אוטונומית של OSPF.

uninstall

מחיקת OSPF.

פרמטרים

ללא

set area

שינוי פרמטרים עבור אזור שצוין.

תחביר

set area [areaid=]AreaID [[auth=]{none | password}]‎ ‎[[stubarea=]{yes | no}] [[metric=]StubMetric] [[sumadv=]{yes | no}]‎

פרמטרים

‎[areaid=]AreaID
נדרש. ציון כתובת ה- IP של אזור OSPF שעבורו ברצונך לשנות פרמטרים.
‎[auth=]{none | password}‎
מציין האם נדרש שימוש בסיסמאות עבור האזור. אם נדרש שימוש בסיסמאות עבור אזור, אותה סיסמה נדרשת עבור כל הממשקים שבאותו אזור ובאותו מקטע רשת, אך ניתן להשתמש בסיסמאות שונות עבור ממשקים הנמצאים באותו אזור אך במקטעי רשת שונים. כברירת מחדל נדרשת סיסמה, וסיסמה זו היא 12345678. הסיסמאות משודרות בתבנית טקסט רגיל, כך שאפשרות זו משמשת עבור זיהוי, לא למטרות אבטחה.
‎[stubarea=]{yes | no}‎
מציין האם אזור זה הוגדר כאזור שארית, שהוא אזור OSPF שאינו מבצע מניה של ניתובים חיצוניים. ניתובים שמקורם חיצוני למערכת אוטונומית (AS) של OSPF אינם מוצפים אל אזורי שארית, או דרכם. ניתוב ליעדי AS חיצוניים באזורים ממין זה מתבסס על ניתובי ברירת מחדל של סיכום. אפשרות זו מסייעת להקטין את התקורה עבור נתבים הממוקמים באזור שארית.
‎[metric=]StubMetric
ציון העלות של ניתוב סיכום המהווה ברירת מחדל שהנתב מפרסם אל אזור השארית.
‎[sumadv=]{yes | no}‎
מציין האם לייבא פרסומי סיכום.

set virtif

קביעת פרמטרים עבור הממשק הווירטואלי שצוין.

תחביר

set virtif [transareaid=]TransitAreaID [virtnbrid=]VirtualNeighborID ‎[[transdelay=]TransitDelay] [[retrans=]ReTransmitInterval]‎ ‎[[hello=]HelloInterval] [[dead=]DeadInterval] [[password=]Password]‎

פרמטרים

‎[transareaid=]TransitAreaID
נדרש. ציון כתובת ה- IP של אזור ההעברה.
‎[virtnbrid=]VirtualNeighborID
נדרש. ציון מזהה הנתב של השכן הווירטואלי.
‎[transdelay=]TransitDelay
ציון מספר השניות שיידרש, להערכתך, לשידור מנת עדכון של מצב קישור בממשק זה. אם לא נעשה שימוש בפרמטר זה, זמן העיכוב נקבע לשניה אחת.
‎[retrans=]ReTransmitInterval
ציון מספר השניות שיחלוף בין שידורים מחדש של פרסומי מצב קישור עבור שכנויות השייכות לממשק זה. ערך אופייני עבור רשת תקשורת מקומית הוא 5 שניות.
‎[hello=]HelloInterval
מציין, בשניות, את מרווח הזמן בין שידור של מנות Hello על-ידי נתב בממשק זה. על ערך זה להיות זהה עבור כל הנתבים המחוברים לאותה רשת. ערך אופייני עבור רשת תקשורת מקומית הוא 10 שניות.
‎[dead=]DeadInterval
מציין, בשניות, את פרק הזמן שבמהלכו עשוי נתב שלא להגיב לפני שנתב שכן יחשיב אותו לפגום. על הערך להיות מכפלה של מרווח הזמן שהוגדר עבור מנות Hello במספר שלם (לרוב 4). על ערך זה להיות זהה עבור כל הממשקים של נתב OSPF המחוברים לאותו מקטע רשת.
‎[password=]Password
ציון הסיסמה עבור ממשק זה אם נדרשות סיסמאות עבור האזור. יש להגדיר סיסמה זהה עבור כל הממשקים הממוקמים באותה רשת. כברירת מחדל, יש לעשות שימוש בסיסמאות, והסיסמה המהווה ברירת מחדל היא 12345678.

set interface

קביעה של פרמטרי OSPF עבור ממשק.

תחביר

set interface [interfacename=]InterfaceName [addr=]IPAddress [mask=]SubnetMask ‎[[state=]{enable | disable}] [[areaid=]AreaID] [[type=]{nbma | p2p | broadcast}]‎ ‎[[prio=]Priority] [[transdelay=]TransitDelay] [[retrans=]ReTransmitInterval]‎ ‎[[hello=]HelloInterval] [[dead=]DeadInterval] [[poll=]PollInterval]‎ ‎[[metric=]Metric] [[password=]Password] [[mtu=]MTUSize]‎

פרמטרים

‎[interfacename=]InterfaceName
נדרש. ציון שמו של הממשק שאת הפרמטרים עבורו ברצונך לקבוע. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[addr=]IPAddress
נדרש. ציון כתובת ה- IP של הממשק.
‎[mask=]SubnetMask
נדרש. ציון מסיכת רשת המשנה של הממשק.
‎[state=]{enable | disable}‎
ציון מצב הזמינות של הממשק. הפרמטר enable מפעיל את הממשק. הפרמטר disable הופך אותו לבלתי זמין.
‎[areaid=]AreaID
ציון כתובת ה- IP של אזור הממשק.
‎[type=]{nbma | p2p | broadcast}‎
ציון הסוג של ממשק OSPF שבעבורו ברצונך להגדיר פרמטרים. הפרמטר nbma מציין ממשק OSPF של גישה מרובה ללא שידור (NBMA). הפרמטר p2p מציין ממשק OSPF מסוג point-to-point. הפרמטר broadcast מציין ממשק OSPF של שידור.
‎[prio=]Priority
ציון עדיפות הממשק.
‎[transdelay=]TransitDelay
ציון המספר המשוער של שניות הדרוש לשידור מנת עדכון של מצב קישור בממשק זה. אם לא תציין פרמטר זה, העיכוב המשוער נקבע לשניה אחת.
‎[retrans=]ReTransmitInterval
ציון מספר השניות בין שידורים מחדש של פרסומי מצבי קישורים עבור שכנויות המשתייכות לממשק זה. ערך טיפוסי עבור רשת תקשורת מקומית הוא 5 שניות.
‎[hello=]HelloInterval
ציון, בשניות, של מרווח הזמן בין שידורים של מנות Hello על-ידי הנתב בממשק. על הגדרה זו להיות זהה עבור כל הנתבים המחוברים לאותה רשת. ערך טיפוסי עבור רשת תקשורת מקומית הוא 10 שניות.
‎[dead=]DeadInterval
ציון, בשניות, כמה זמן עשוי נתב שלא להגיב לפני שנתב שכן יתייחס אליו כפגום. על הגדרה זו להיות מכפלה של מרווח הזמן שהוגדר עבור מנות Hello במספר שלם (לרוב 4). על ערך זה להיות זהה עבור כל הממשקים של נתב OSPF המחוברים לאותו מקטע רשת.
‎[poll=]PollInterval
ציון מספר השניות בין תשאולי רשת מסוג OSPF עבור ממשקים מסוג גישה מרובה ללא שידור (NBMA) בלבד. עליך לקבוע את מרווח התשאול כך שיהיה ארוך פי שתיים מהמרווח הבלתי פעיל. ערך טיפוסי עבור רשת מסוג X.25 הוא שתי דקות.
‎[metric=]Metric
ציון העלות של משלוח מנה מחוץ לממשק זה. הערך שנקבע כאן מפורסם כעלות הקישור עבור ממשק זה בפרסום מצב הקישור של הנתב. ממשקים מהירים יותר לרוב כוללים עלויות נמוכות יותר. ההגדרה המירבית היא 32,767.
‎[password=]Password
ציון הסיסמה עבור הממשק אם סיסמאות נדרשות עבור האזור. יש לוודא שבכל הממשקים השייכים לאותו אזור ולאותה רשת נעשה שימוש באותה סיסמה. כברירת מחדל, נדרשת סיסמה והיא 12345678.
‎[mtu=]MTUSize
ציון, בבתים, של הגודל המירבי של מנות IP הנושאות מידע OSPF הניתן לשליחה ללא פיצול. ברירת המחדל של IP MTU עבור רשת Ethernet היא 1,500 בתים.

set global

קביעת תצורה של פרמטרי OSPF כלליים.

תחביר

set global [routerid=]IPAddress [asborder=]{yes | no} ‎[[loglevel=]{none | error | warn | info}]

פרמטרים

‎[routerid=]IPAddress
נדרש. ציון כתובת ה- IP של נתב שעבורו ברצונך להגדיר פרמטרים.
‎[asborder=]{yes | no}‎
נדרש. ציון אם הנתב מתנהג כנתב גבול מערכת אוטונומית (AS).
‎[loglevel=]{none | error | warn | info}‎
ציון אילו אירועים יש לכלול ביומן הרישום. הפרמטר none מציין שאין לכלול ביומן הרישום אירועים הקשורים ל- OSPF. הפרמטר error מציין שיש לכלול ביומן הרישום רק שגיאות הקשורות ל- OSPF. הפרמטר warn מציין שיש לכלול ביומן האירועים רק אזהרות הקשורות ל- OSPF. הפרמטר info מציין שיש לכלול ביומן הרישום את כל האירועים הקשורים ל- OSPF.

set routefilter

קביעת התצורה של פעולת המסנן של ניתוב OSPF.

תחביר

set routefilter [action=]{drop | accept}

פרמטרים

‎[action=]{drop | accept}‎
נדרש. מציין אם מסנן הניתוב משחרר או מקבל מנות. הפרמטר drop מציין שיש לדחות מנות. הפרמטר accept מציין שיש לקבל מנות.

set protofilter

קביעת התצורה של פעולות מסנן פרוטוקול OSPF.

תחביר

set protofilter [action=]{drop | accept}

פרמטרים

‎[action=]{drop | accept}‎
נדרש. מציין אם מסנן הפרוטוקול מקבל או משחרר מנות. הפרמטר drop מציין שיש לשחרר מנות. הפרמטר accept מציין שיש לקבל מנות.

show global

הצגת פרמטרי OSPF כלליים.

תחביר

show global

פרמטרים

ללא

show area

הצגת פרמטרי אזור.

תחביר

show area

פרמטרים

ללא

show virtif

הצגת פרמטרים עבור כל הממשקים הווירטואליים.

תחביר

show virtif

פרמטרים

ללא

show interface

הצגת מידע תצורת OSPF עבור הממשק שצוין.

תחביר

show interface [InterfaceName=]InterfaceName

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שעבורו ברצונך להציג מידע. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").

show routefilter

הצגת מידע אודות מסנן ניתוב OSPF.

תחביר

show routefilter

פרמטרים

ללא

show protofilter

הצגת מידע אודות מסנן פרוטוקול OSPF.

תחביר

show protofilter

פרמטרים

ללא

show area

הצגת מידע אודות אזורי OSPF.

תחביר

show area

פרמטרים

ללא

show virtif

הצגת מידע אודות ממשקים וירטואליים של OSPF.

תחביר

show virtif

פרמטרים

ללא

פקודות IP Autodhcp של ניתוב Netsh

להלן פקודות הזמינות לשימוש בהקשר של IP Autodhcp של ניתוב Netsh.

להצגת התחביר של פקודה, לחץ על פקודה:

add exclusion

הוספת הוצאה מהכלל לטווח כלי ההקצאה של DHCP.

תחביר

add exclusion IPAddress

פרמטרים

IPAddress
נדרש. ציון כתובת IP שאין לכלול בטווח כלי ההקצאה של DHCP.

delete exclusion

מחיקת הוצאה מהכלל מטווח כלי הקצאה של DHCP.

תחביר

delete exclusion IPAddress

פרמטרים

IPAddress
נדרש. ציון כתובת IP שכבר הוצאה מטווח כלי ההקצאה של DHCP.

install

התקנת פרוטוקול הניתוב תחת IP.

תחביר

install

פרמטרים

ללא

set global

קביעת התצורה של פרמטרים כלליים עבור הקצאה של DHCP.

תחביר

set global {[[scopenetwork=]IPAddress] | [[scopemask=]SubnetMask] | ‎[[leasetime=]Minutes] | [[loglevel=]{none | error | warn | info}]}

פרמטרים

‎[scopenetwork=]IPAddress
ציון כתובת ה- IP עבור טווח כלי ההקצאה של DHCP.
‎[scopemask=]SubnetMask
ציון מסיכת רשת המשנה המשויכת לכתובת ה- IP עבור הטווח.
‎[leasetime=]Minutes
ציון, בדקות, של משך ההחכרה.
‎[LogLevel=]{none | error | warn | info}‎
ציון אילו אירועים יש לכלול ביומן הרישום. הפרמטר none מציין שאין לכלול אירועים הקשורים ל- DHCP. הפרמטר error מציין שיש לכלול ביומן הרישום רק שגיאות הקשורות ל- DHCP. הפרמטר warn מציין שיש לכלול ביומן הרישום רק אזהרות הקשורות ל- DHCP. הפרמטר info מציין שיש לכלול ביומן הרישום את כל האירועים הקשורים ל- DHCP.

דוגמאות

כדי לקבוע רשת IP עבור כלי הקצאה של DHCP ל- 10.10.10.0, עם מסיכת רשת משנה של טווח משויך של 255.255.255.0, משך החכרה של 11520 דקות (8 ימים) ורישום מידע עבור כל האירועים הקשורים, הקלד:

set global 10.10.10.0 255.255.255.0 11520 info

כדי להתאים רק את משך ההחכרה באופן כללי עבור כל הטווחים בכל הממשקים לערך של 4320 דקות (3 ימים), הקלד:

set global leasetime=4320

set interface

הגדרת הפרמטרים של כלי ההקצאה של DHCP עבור הממשק שצוין.

תחביר

set interface [InterfaceName=]InterfaceName [mode=]{enable | disable}

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שבו יש להגדיר פרמטרים. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[mode=]{enable | disable}‎
נדרש. ציון אם כלי ההקצאה של DHCP מופעל או מבוטל עבור הממשק.

show global

הצגת התצורה הכללית של כלי ההקצאה של DHCP.

תחביר

show global

פרמטרים

ללא

show interface

הצגת התצורה של כלי ההקצאה של DHCP עבור הממשק שצוין.

תחביר

show interface [InterfaceName=]InterfaceName

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שעבורו ברצונך להציג מידע. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").

uninstall

הסרת פרוטוקול הניתוב תחת IP.

תחביר

uninstall

פרמטרים

ללא

פקודות IP Dnsproxy של ניתוב Netsh

הפקודות שלהלן זמינות לשימוש בהקשר של IP Dnsproxy של ניתוב Netsh.

להצגת תחביר הפקודה, לחץ על פקודה:

set global

קביעת פרמטרים כלליים של DNS Proxy.

תחביר

set global [querytimeout=]Integer [[dnsmode=]{enable | disable}] ‎[[winsmode=]{enable | disable}] [[loglevel=]{none | error | warn | info}]

פרמטרים

‎[querytimeout=]Integer
נדרש. ציון זמן קצוב, בשניות, עבור שאילתות DNS שעברו תהליך Proxy.
‎[dnsmode=]{enable | disable}‎
ציון אם פעולת DNS Proxy מופעלת או מבוטלת.
‎[winsmode=]{enable | disable}‎
ציון אם פעולת WINS Proxy מופעלת או מבוטלת.
‎[loglevel=]{none | error | warn | info}‎
ציון אילו אירועים יש לכלול ביומן הרישום. הפרמטר none מציין שאין לכלול אירועים הקשורים ל- DNS Proxy. הפרמטר error מציין שיש לכלול רק שגיאות הקשורות ל- DNS Proxy. הפרמטר warn מציין שיש לכלול ביומן הרישום רק אזהרות הקשורות ל- DNS Proxy. הפרמטר info מציין שיש לכלול ביומן הרישום את כל האירועים הקשורים ל- DNS Proxy.

דוגמאות

כדי לציין ששאילתות יפוגו לאחר 10 שניות, כדי לאפשר פעולות DNS Proxy ו- WINS Proxy וכדי למנוע רישום של אירועי DNS Proxy, הקלד:

set global 10 enable enable none

install

התקנת פרוטוקול הניתוב תחת IP.

תחביר

install

פרמטרים

ללא

set interface

קביעת התצורה של פרמטרי DNS Proxy עבור ממשק.

תחביר

set interface [InterfaceName=]InterfaceName [[mode=]{enable | disable | default}]

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שעבורו יש להגדיר פרמטרים. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[mode=]{enable | disable | default}‎
ציון אם DNS Proxy מופעל, מבוטל או מוגדר לשימוש בברירת המחדל עבור הממשק שצוין. הפרמטר enable מציין ש- DNS Proxy מופעל. הפרמטר disable מציין ש- DNS Proxy מבוטל. הפרמטר default מציין ש- DNS Proxy נקבע בהתאם לברירת המחדל עבור הממשק.

show global

הצגת התצורה הכללית של DNS Proxy.

תחביר

show global

פרמטרים

ללא

show interface

הצגת התצורה של DNS Proxy עבור הממשק שצוין.

תחביר

show interface [InterfaceName=]InterfaceName

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שעבורו ברצונך להציג מידע. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").

uninstall

הסרת פרוטוקול הניתוב תחת IP.

תחביר

uninstall

פרמטרים

ללא

פקודות IP NAT של ניתוב Netsh

הפקודות שלהלן זמינות לשימוש בהקשר של IP NAT של ניתוב Netsh.

להצגת תחביר הפקודה, לחץ על פקודה:

add addressmapping

הוספת מיפוי כתובת IP למאגר הכתובות של תרגום כתובות רשת (NAT) עבור הממשק שצוין.

תחביר

add addressmapping [InterfaceName=]InterfaceName [public=]IPAddress ‎[private=]IPAddress [inboundsessions=]{enable | disable}

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שבו ברצונך להשתמש בתרגום כתובות רשת. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[public=]IPAddress
נדרש. ציון כתובת ה- IP המשמשת ברשת ציבורית.
‎[private=]IPAddress
נדרש. ציון כתובת ה- IP בטווח המאגר של כתובות הזמינות לשימוש ברשת הפרטית.
‎[inboundsessions=]{enable | disable}‎
נדרש. ציון אם הפעלות נכנסות מופעלות או מבוטלות. הפרמטר enable מציין שהפעלות נכנסות מופעלות. הפרמטר disable מציין שהפעלות נכנסות מבוטלות.

דוגמאות

לשם מיפוי כתובת ה- IP הציבורית 10.11.11.1 לכתובת ה- IP הפרטית 10.10.10.1 ולשם ביטול של הפעלות נכנסות עבור מיפוי טבלת NAT זה, הקלד:

add addressmapping "Local Area Connection" 10.11.11.1 10.10.10.1 disable

add addressrange

הוספת טווח כתובות למאגר כתובות NAT עבור הממשק שצוין.

תחביר

add addressrange [InterfaceName=]InterfaceName [start=]IPAddress [end=]IPAddress ‎[mask=]SubnetMask

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שאת מאגר הכתובות שלו ברצונך להוסיף לטווח כתובות.
‎[start=]IPAddress
נדרש. ציון כתובת ה- IP ההתחלתית עבור טווח הכתובות.
‎[end=]IPAddress
נדרש. ציון כתובת ה- IP המסיימת עבור טווח הכתובות.
‎[mask=]SubnetMask
נדרש. ציון מסיכת רשת המשנה של ה- IP המשויכת לטווח הרשת, שהינו תחום בכתובות ה- IP של ההתחלה והסיום.

add interface

קביעת תצורת NAT בממשק שצוין.

תחביר

add interface [InterfaceName=]InterfaceName [[mode=]{full | addressonly | private}]

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שבו ברצונך להגדיר את NAT. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[mode=]{full | addressonly | private}‎
ציון אם בממשק נעשה שימוש במצב מלא, כתובת בלבד או פרטי.

add portmapping

הוספת מיפוי יציאת פרוטוקול בממשק NAT.

תחביר

add portmapping [InterfaceName=]InterfaceName [proto=]{tcp | udp} [publicip=]{IPAddress | 0.0.0.0} ‎[publicport=]Integer [privateip=]IPAddress [privateport=]Integer

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שעבורו ברצונך להוסיף מיפוי יציאה. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[proto=]{tcp | udp}‎
נדרש. ציון אם סוג הפרוטוקול נקבע ל- TCP או ל- UDP.
‎[publicip=]{IPAddress | 0.0.0.0}‎
נדרש. ציון כתובת IP חיצונית ברשת הציבורית או 0.0.0.0 כדי לציין כל כתובת IP שלא צוינה בתוך טווח כתובות הרשת הפרטית.
‎[publicport=]Integer
נדרש. ציון יציאת הפרוטוקול הציבורית באמצעות מספר בין 0 ל- 9999.
‎[privateip=]IPAddress
נדרש. ציון כתובת IP בתוך טווח הרשת הפרטית.
‎[privateport=]Integer
נדרש. ציון יציאת הפרוטוקול הפרטית באמצעות מספר בין 0 ל- 9999.

delete addressmapping

מחיקת מיפוי כתובת ממאגר כתובות ה- NAT עבור הממשק שצוין.

תחביר

delete addressmapping [InterfaceName=]InterfaceName [[public=]IPAddress]

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שעבורו ברצונך למחוק מיפוי כתובת. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[public=]IPAddress
ציון כתובת ה- IP שיש למחוק. אם לא תציין כתובת, כל מיפויי הכתובות ממאגר כתובות ה- NAT יימחקו מהממשק.

delete addressrange

מחיקת טווח כתובות ממאגר כתובות ה- NAT עבור הממשק שצוין.

תחביר

delete addressrange [InterfaceName=]InterfaceName [start=]IPAddress

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שממנו ברצונך למחוק טווח כתובות. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[start=]IPAddress
נדרש. ציון כתובת ה- IP ההתחלתית של הטווח שברצונך למחוק.

delete interface

הסרת תרגום כתובות רשת (NAT) מהממשק שצוין.

תחביר

delete interface [InterfaceName=]InterfaceName

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שעבורו ברצונך להסיר את השימוש ב- NAT. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").

delete portmapping

מחיקת מיפוי יציאת פרוטוקול מהממשק שצוין בו פועל NAT.

תחביר

delete portmapping [InterfaceName=]InterfaceName [[proto=]{tcp | udp}] ‎[publicip=]{IPAddress | 0.0.0.0}] [[publicport=]Integer] [[privateip=]IPAddress] [privateport=]Integer]

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שעבורו ברצונך למחוק מיפוי יציאה. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[proto=]{tcp | udp}‎
ציון סוג הפרוטוקול. הפרמטר tcp מציין שסוג הפרוטוקול הוא Transmission Control Protocol. הפרמטר udp מציין שסוג הפרוטוקול הוא User Datagram Protocol.
‎[publicip=]{IPAddress | 0.0.0.0}‎
ציון כתובת IP חיצונית ברשת הציבורית או 0.0.0.0 כדי לציין כל כתובת IP שלא צוינה בתוך טווח הכתובות של הרשת הפרטית.
‎[publicport=]Integer
ציון יציאת הפרוטוקול הציבורית באמצעות מספר בין 0 ל- 9999.
‎[privateip=]IPAddress
ציון כתובת IP בתוך טווח הרשת הפרטית.
‎[privateport=]Integer
ציון יציאת הפרוטוקול הפרטית באמצעות מספר בין 0 ל- 9999.

set global

קביעת פרמטרים כלליים עבור NAT.

תחביר

set global {[[tcptimeoutmins=]Integer] | [[udptimeoutmins=]Integer] | ‎[[LogLevel=]{none | error | warn | info}]}

פרמטרים

‎[tcptimeoutmins=]Integer
ציון בדקות של ערך הזמן הקצוב עבור מיפויי TCP.
‎[udptimeoutmins=]Integer
ציון בדקות של ערך הזמן הקצוב עבור מיפויי UDP.
‎[LogLevel=]{none | error | warn | info}‎
ציון אילו אירועים יש לכלול ביומן הרישום. הפרמטר none מציין שאין לכלול ביומן הרישום אירועים הקשורים ל- NAT. הפרמטר error מציין שיש לכלול ביומן הרישום רק שגיאות הקשורות ל- NAT. הפרמטר warn מציין שיש לכלול ביומן הרישום רק אזהרות הקשורות ל- NAT. הפרמטר info מציין שיש לכלול ביומן הרישום את כל האירועים הקשורים ל- NAT.

set interface

קביעת תצורה של פרמטרי NAT עבור הממשק שצוין.

תחביר

set interface [InterfaceName=]InterfaceName [mode=]{Full | AddressOnly | Private}

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שעבורו ברצונך להגדיר פרמטרים. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[mode=]{Full | AddressOnly | Private}‎
נדרש. ציון אם יש להפעיל את הממשק עבור מצב מלא, כתובת בלבד או פרטי.

show global

הצגת תצורה כללית של תרגום כתובות רשת (NAT).

תחביר

show global

פרמטרים

ללא

show interface

הצגת תצורה של תרגום כתובות רשת (NAT) עבור הממשק שצוין.

תחביר

show interface [InterfaceName=]InterfaceName

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שעבורו ברצונך להציג מידע. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").

פקודות IPX של ניתוב Netsh

להלן פקודות הזמינות לשימוש בהקשר של IPX של ניתוב Netsh.

להצגת תחביר הפקודה, לחץ על פקודה:

show interface

הצגת מידע תצורה עבור הממשק שצוין.

תחביר

show interface [InterfaceName=]InterfaceName

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שעבורו ברצונך להציג מידע. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").

add interface

הוספת ערכי ממשק לתצורת IPX.

תחביר

add interface [InterfaceName=]InterfaceName

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שאת ערכיו ברצונך להוסיף. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").

delete interface

מחיקת ערכי ממשק מתצורת IPX.

תחביר

delete interface [InterfaceName=]InterfaceName

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שאת ערכיו ברצונך למחוק. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").

set interface

עדכון תצורת IPX בממשק שצוין.

תחביר

set interface [InterfaceName=]InterfaceName {[[admstate=]{enabled | disabled}] | ‎[[wanprotocol=]{ppp | ipxwan}]}

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שעבורו ברצונך לעדכן את תצורת IPX. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[admstate=]{enabled | disabled}‎
ציון אם admstate מופעל או מבוטל בממשק.
‎[wanprotocol=]{ppp | ipxwan}‎
ציון פרוטוקול הממשק, PPP או ipxwan.

show route

הצגת מידע ניתוב עבור כתובת רשת שצוינה.

תחביר

show route NetworkAddress

פרמטרים

NetworkAddress
נדרש. ציון כתובת רשת של 4 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.

show staticroute

הצגת מידע תצורה.

תחביר

show staticroute [InterfaceName=]InterfaceName NetworkAddress

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שעבורו ברצונך להציג מידע. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
NetworkAddress
נדרש. ציון כתובת רשת של 4 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.

add staticroute

הוספת ערכים לתצורת IPX של הממשק שצוין.

תחביר

add staticroute [InterfaceName=]InterfaceName {[NetworkAddress] | ‎[[nexthopmacaddress=]MacAddress] | [[ticks=]Integer] | [[hops=]Integer]}

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שלתצורת IPX שלו ברצונך להוסיף ערכים. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
NetworkAddress
ציון כתובת רשת של 4 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[nexthopmacaddress=]MacAddress
ציון כתובת mac של הדילוג הבא, בת 6 בתים שאינה עולה על 12 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[ticks=]Integer
ציון ספירת השנתות כמספר שלם דצימאלי.
‎[hops=]Integer
ציון ספירת הדילוגים כמספר שלם דצימאלי.

delete staticroute

מחיקת ערך מתצורת IPX של הממשק שצוין.

תחביר

delete staticroute [InterfaceName=]InterfaceName {[NetworkAddress] | ‎[[nexthopmacaddress=]MacAddress] | [[ticks=]Integer] | [[hops=]Integer]}

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק ממנו ברצונך להסיר ערך. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
NetworkAddress
ציון כתובת רשת של 4 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[nexthopmacaddress=]MacAddress
ציון כתובת mac של הדילוג הבא, בת 6 בתים שאינה עולה על 12 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים
‎[ticks=]Integer
ציון ספירת השנתות כמספר שלם דצימאלי.
‎[hops=]Integer
ציון ספירת הדילוגים כמספר שלם דצימאלי.

set staticroute

עדכון תצורת IPX של הממשק שצוין.

תחביר

set staticroute [InterfaceName=]InterfaceName {[NetworkAddress] | ‎[[nexthopmacaddress=]MacAddress] | [[ticks=]Integer] | [[hops=]Integer]}

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שאת תצורת ה- IPX שלו ברצונך לעדכן. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
NetworkAddress
ציון כתובת רשת של 4 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[nexthopmacaddress=]MacAddress
ציון כתובת mac של הדילוג הבא, בת 6 בתים שאינה עולה על 12 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[ticks=]Integer
ציון ספירת השנתות כמספר שלם דצימאלי.
‎[hops=]Integer
ציון ספירת הדילוגים כמספר שלם דצימאלי.

show service

הצגת מידע אודות תצורת שם שירות. ללא פרמטרים, הפקודה show service מציגה את כל סוגי השירותים ושמותיהם.

תחביר

show service [ServiceType] [ServiceName]

פרמטרים

ServiceType
ציון סוג שירות בן 2 בתים שאינו עולה על 4 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
ServiceName
ציון בשם של השירות שעבורו ברצונך להציג מידע.

show staticservice

הצגת מידע תצורה אודות שירות ניתוב סטטי.

תחביר

show staticservice [InterfaceName=]InterfaceName [ServiceType] [ServiceName]

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שעבורו ברצונך להציג מידע. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
ServiceType
ציון סוג שירות בן 2 בתים שאינו עולה על 4 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
ServiceName
ציון שם שירות.

add staticservice

הוספת ערכים לתצורת IPX של ממשק שצוין.

תחביר

add staticservice [InterfaceName=]InterfaceName {[ServiceType] | [ServiceName] | [NetworkAddress] | ‎[[node=]NodeAddress] | [[socket=]SocketAddress] | [[hops=]Integer]}

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שלתצורתו ברצונך להוסיף ערכים. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
ServiceType
ציון סוג שירות בן 2 בתים שאינו עולה על 4 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
ServiceName
ציון שם שירות.
NetworkAddress
ציון כתובת רשת בת 4 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[node=]NodeAddress
ציון כתובת צומת בת 6 בתים שאינה עולה על 12 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[socket=]SocketAddress
ציון כתובת Socket בת 2 בתים שאינה עולה על 4 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[hops=]Integer
ציון ספירת הדילוגים כמספר שלם דצימאלי.

delete staticservice

מחיקת ערך מתצורת ה- IPX של ממשק שצוין.

תחביר

delete staticservice [InterfaceName=]InterfaceName {[ServiceType] | [ServiceName] | [NetworkAddress] | ‎[[node=]NodeAddress] | [[socket=]SocketAddress] | [[hops=]Integer]}

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שמתצורת ה- IPX שלו ברצונך להסיר ערך. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
ServiceType
ציון סוג שירות בן 2 בתים שאינו עולה על 4 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
ServiceName
ציון שם שירות.
NetworkAddress
ציון כתובת רשת בת 4 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[node=]NodeAddress
ציון כתובת צומת בת 6 בתים שאינה עולה על 12 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[socket=]SocketAddress
ציון כתובת Socket בת 2 בתים שאינה עולה על 4 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[hops=]Integer
ציון ספירת הדילוגים כמספר שלם דצימאלי.

set staticservice

עדכון תצורת הניתוב הסטטי של IPX.

תחביר

set staticservice [InterfaceName=]InterfaceName {[ServiceType] | [ServiceName] | [NetworkAddress] | ‎[[node=]NodeAddress] | [[socket=]SocketAddress] | [[hops=]Integer]}

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שאת תצורתו ברצונך לעדכן. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
ServiceType
ציון סוג שירות בן 2 בתים שאינו עולה על 4 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
ServiceName
ציון שם שירות.
NetworkAddress
ציון כתובת רשת בת 4 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[node=]NodeAddress
ציון כתובת צומת בת 6 בתים שאינה עולה על 12 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[socket=]SocketAddress
ציון כתובת Socket בת 2 בתים שאינה עולה על 4 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[hops=]Integer
ציון ספירת הדילוגים כמספר שלם דצימאלי.

set filter

עדכון תצורת המסנן של נתב IPX.

תחביר

set filter [InterfaceName=]InterfaceName [[mode=]{input | output}] ‎[[action=]{permit | deny}]

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שאת תצורתו ברצונך לעדכן. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[mode=]{input | output}‎
ציון המצב, קלט או פלט.
‎[action=]{permit | deny}‎
ציון הפעולה, הרשאה או דחיה.

show filter

הצגת המידע אודות תצורת מסנן IPX עבור הממשק שצוין.

תחביר

show filter [InterfaceName=]InterfaceName

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שעבורו ברצונך להציג מידע. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").

add filter

הוספת ערכי מסנן של נתב לתצורת IPX.

תחביר

add filter [InterfaceName=]InterfaceName [mode=]{input | output} ‎[[srcnet=]SourceSubnet] [[srcnode=]SourceNode] [[srcsocket=]SourceSocket] ‎[[dstnet=]DestinationSubnet] [[dstnode=]DestinationNode] [[dstsocket=]DestinationSocket] ‎[[pkttype=]PacketType]

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שאליו ברצונך להוסיף ערכי מסנן. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[mode=]{input | output}‎
נדרש. קביעת המצב.
‎[srcnet=]SourceSubnet
ציון מסיכת רשת בת 4 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[srcnode=]SourceNode
ציון כתובת צומת בת 6 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[srcsocket=]SourceSocket
ציון כתובת Socket בת 2 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[dstnet=]DestinationSubnet
ציון מסיכת רשת בת 4 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[dstnode=]DestinationNode
ציון כתובת צומת בת 6 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[dstsocket=]DestinationSocket
ציון כתובת Socket בת 2 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[pkttype=]PacketType
ציון סוג מנה בן בית אחד שאינו עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.

delete filter

מחיקת ערכים של מסנני נתבים מתצורת IPX.

תחביר

delete filter [InterfaceName=]InterfaceName [mode=]{input | output} ‎[[srcnet=]SourceSubnet] [[srcnode=]SourceNode] [[srcsocket=]SourceSocket] ‎[[dstnet=]DestinationSubnet] [[dstnode=]DestinationNode] [[dstsocket=]DestinationSocket] ‎[[pkttype=]PacketType]

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק ממנו ברצונך למחוק ערך מסנן. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[mode=]{input | output}‎
נדרש. קביעת המצב.
‎[srcnet=]SourceSubnet
ציון מסיכת רשת בת 4 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[srcnode=]SourceNode
ציון כתובת צומת בת 6 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[srcsocket=]SourceSocket
ציון כתובת Socket בת 2 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[dstnet=]DestinationSubnet
ציון מסיכת רשת בת 4 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[dstnode=]DestinationNode
ציון כתובת צומת בת 6 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[dstsocket=]DestinationSocket
ציון כתובת Socket בת 2 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[pkttype=]PacketType
ציון סוג מנה בן בית אחד שאינו עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.

show global

הצגת מידע אודות תצורת IPX כללית.

תחביר

show global

פרמטרים

ללא

set global

קביעת הגדרות IPX כלליות.

תחביר

set global [LogLevel=]{none | error | warn | info}

פרמטרים

‎[LogLevel=]{none | error | warn | info}‎
נדרש. ציון אילו אירועים יש לכלול ביומן הרישום. הפרמטר none מציין שאין לכלול ביומן הרישום אירועים הקשורים ל- IPX. הפרמטר error מציין שיש לכלול ביומן הרישום רק שגיאות הקשורות ל- IPX. הפרמטר warn מציין שיש לכלול ביומן הרישום רק אזהרות הקשורות ל- IPX. הפרמטר info מציין שיש לכלול ביומן הרישום את כל האירועים הקשורים ל- IPX.

פקודות IPX NetBIOS של ניתוב Netsh

הפקודות שלהלן זמינות לשימוש בהקשר של IPX NetBIOS של ניתוב Netsh.

להצגת תחביר הפקודה, לחץ על פקודה:

show interface

הצגה של הורשת שידורים ותעבורה מסוג IPX NetBIOS בממשקי נתב.

תחביר

show interface [InterfaceName=]InterfaceName

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שעבורו ברצונך להציג מידע. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").

set interface

הגדרת הורשה של שידורים ותעבורה מסוג IPX NetBIOS בממשקי נתב.

תחביר

set interface [InterfaceName=]InterfaceName [[bcastaccept=]{enabled | disabled}] ‎[[bcastdeliver=]{enabled | disabled | staticonly | onlywhenup}]

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק בו ברצונך להגדיר הורשה. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[bcastaccept=]{enabled | disabled}‎
ציון אם על ממשק הנתב לקבל שידורים ותעבורה מסוג NetBIOS.
‎[bcastdeliver=]{enabled | disabled | staticonly | onlywhenup}‎
ציון אם וכיצד על ממשק הנתב להעביר שידורים ותעבורה מסוג NetBIOS. כאשר מופעל bcastdeliver, כל השידורים והתעבורה מועברים. כאשר bcastdeliver מבוטל, לא מועברים כל שידורים או תעבורה. הפרמטר onlywhenup מציין ששידורים ותעבורה מועברים רק כאשר הממשק למעלה. הפרמטר staticonly מציין ששידורים ותעבורה מועברים רק עבור ניתובים סטטיים.

show nbname

הצגת שמות NetBIOS סטטיים בממשק הנתב שצוין.

תחביר

show nbname [InterfaceName=]InterfaceName

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק עבורו ברצונך להציג מידע. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").

add nbname

הוספת שם NetBIOS סטטי לממשק הנתב שצוין.

תחביר

add nbname [InterfaceName=]InterfaceName NetBIOSName [[nbtype=]Type]

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שאליו ברצונך להוסיף שם. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
NetBIOSName
נדרש. ציון שם ה- NetBIOS שברצונך להוסיף.
‎[nbtype=]Type
ציון סוג שם של NetBIOS בן בית אחד שאינו עולה על 2 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.

delete nbname

הסרת שם NetBIOS סטטי מממשק הנתב שצוין.

תחביר

delete nbname [InterfaceName=]InterfaceName NetBIOSName [nbtype=]Type

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק ממנו ברצונך למחוק שם. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
NetBIOSName
נדרש. ציון שם ה- NetBIOS שברצונך למחוק.
‎[nbtype=]Type
ציון סוג שם של NetBIOS בן בית אחד שאינו עולה על 2 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים

פקודות IPX RIP של ניתוב Netsh

הפקודות שלהלן זמינות לשימוש בהקשר של IPX RIP של ניתוב Netsh.

להצגת תחביר הפקודה, לחץ על פקודה:

show interface

הצגת הסטטוס של IPX RIP עבור הממשק שצוין. ללא פרמטרים, הפקודה show interface מציגה מידע עבור כל הממשקים.

תחביר

show interface [[InterfaceName=]InterfaceName]

פרמטרים

‎[InterfaceName=]InterfaceName
ציון בשם של הממשק שעבורו ברצונך להציג מידע. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").

set interface

קביעת תצורה של ממשקי IPX RIP.

תחביר

set interface [InterfaceName=]InterfaceName [[admstate=]{enabled | disabled}] ‎[[advertise=]{enabled | disabled}] [[listen=]{enabled | disabled}] [[gnsreply=]{enabled | disabled}] ‎[[updatemode=]{standard | none | autostatic}] [[interval=]Integer] [[agemultiplier=]Integer]

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שברצונך לקבוע את תצורתו. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[admstate=]{enabled | disabled}‎
ציון אם admstate מופעל או מבוטל.
‎[advertise=]{enabled | disabled}‎
ציון אם advertising מופעל או מבוטל.
‎[listen=]{enabled | disabled}‎
ציון אם listening מופעל או מבוטל.
‎[gnsreply=]{enabled | disabled}‎
ציון אם gnsreply מופעל או מבוטל.
‎[updatemode=]{standard | none | autostatic}‎
ציון מתי וכיצד מתרחשים עדכונים.
‎[interval=]Integer
ציון בשניות של מרווח הזמן לעדכון.
‎[agemultiplier=]Integer
ציון מכפיל ההזדקנות של השירות.

show global

הצגת ההגדרות הכלליות של IPX RIP.

תחביר

show global

פרמטרים

ללא

set global

קביעת התצורה של הגדרות IPX RIP כלליות.

תחביר

set global [LogLevel=]{none | error | warn | info}

פרמטרים

‎[LogLevel=]{none | error | warn | info}‎
נדרש. ציון אילו אירועים יש לכלול ביומן הרישום. הפרמטר none מציין שאין לכלול ביומן הרישום אירועים הקשורים ל- IPX RIP. הפרמטר error מציין שיש לכלול ביומן הרישום רק שגיאות הקשורות ל- IPX RIP. הפרמטר warn מציין שיש לכלול ביומן הרישום רק אזהרות הקשורות ל- IPX RIP. הפרמטר info מציין שיש לכלול ביומן הרישום את כל האירועים הקשורים ל- IPX RIP.

set filter

קביעת תצורה של IPX RIP בממשק שצוין.

תחביר

set filter [InterfaceName=]InterfaceName [mode=]{input | output} ‎[action=]{permit | deny}

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שאת תצורתו ברצונך לעדכן. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[mode=]{input | output}‎
נדרש. ציון המצב, קלט או פלט.
‎[action=]{permit | deny}‎
נדרש. ציון הפעולה, אישור או דחיה.

show filter

הצגת מידע אודות תצורת IPX RIP.

תחביר

show filter [InterfaceName=]InterfaceName [[mode=]{input | output}]

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שעבורו ברצונך להציג מידע. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[mode=]{input | output}‎
ציון המצב, קלט או פלט.

add filter

הוספת ערך מסנן ניתוב לתצורת IPX RIP של הממשק שצוין.

תחביר

add filter [InterfaceName=]InterfaceName [mode=]{input | output} ‎[net=]NetworkAddress [mask=]SubnetMask

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שלתצורת IPX RIP שלו ברצונך להוסיף ערכים. על הפרמטרInterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[mode=]{input | output}‎
נדרש. ציון המצב, קלט או פלט.
‎[net=]NetworkAddress
נדרש. ציון כתובת רשת בת 4 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[mask=]SubnetMask
נדרש. ציון מסיכת רשת בת 4 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.

delete filter

מחיקת ערך של מסנן ניתוב מתצורת IPX RIP של הממשק שצוין.

תחביר

delete filter [InterfaceName=]InterfaceName [mode=]{input | output} ‎[net=]NetworkAddress [mask=]SubnetMask

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שמתצורת ה- IPX RIP שלו ברצונך למחוק ערך. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[mode=]{input | output}‎
נדרש. ציון המצב, קלט או פלט.
‎[net=]NetworkAddress
נדרש. ציון כתובת רשת בת 4 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[mask=]SubnetMask
נדרש. ציון מסיכת רשת בת 4 בתים שאינה עולה על 8 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.

פקודות IPX SAP של ניתוב Netsh

הפקודות שלהלן זמינות לשימוש בהקשר של IPX SAP של ניתוב Netsh.

להצגת תחביר הפקודה, לחץ על פקודה:

show interface

הצגת הסטטוס של IPX SAP עבור הממשק שצוין. ללא פרמטרים, הפקודה show interface מציגה מידע עבור כל הממשקים.

תחביר

show interface [[InterfaceName=]InterfaceName]

פרמטרים

‎[InterfaceName=]InterfaceName
ציון בשם של הממשק שעבורו ברצונך להציג מידע. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").

set interface

קביעת תצורה של ממשקי IPX SAP.

תחביר

set interface [InterfaceName=]InterfaceName [[admstate=]{enabled | disabled}] ‎[[advertise=]{enabled | disabled}] [[listen=]{enabled | disabled}] [[gnsreply=]{enabled | disabled}] ‎[[updatemode=]{standard | none | autostatic}] [[interval=]Integer] [[agemultiplier=]Integer]

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שעבורו ברצונך לקבוע את תצורת IPX SAP. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[admstate=]{enabled | disabled}‎
ציון אם admstate מופעל או מבוטל.
‎[advertise=]{enabled | disabled}‎
ציון אם advertising מופעל או מבוטל.
‎[listen=]{enabled | disabled}‎
ציון אם listening מופעל או מבוטל.
‎[gnsreply=]{enabled | disabled}‎
ציון אם gnsreply מופעל או מבוטל.
‎[updatemode=]{standard | none | autostatic}‎
ציון מתי וכיצד מתרחשים עדכונים.
‎[interval=]Integer
ציון מרווח הזמן לעדכון בשניות.
‎[agemultiplier=]Integer
ציון מכפיל ההזדקנות של השירות.

show global

הצגת הגדרות כלליות עבור IPX SAP.

תחביר

show global

פרמטרים

ללא

set global

קביעת הגדרות כלליות עבור IPX SAP.

תחביר

set global [LogLevel=]{none | error | warn | info}

פרמטרים

‎[LogLevel=]{none | error | warn | info}‎
נדרש. ציון אילו אירועים יש לכלול ביומן הרישום. הפרמטר none מציין שאין לכלול ביומן הרישום אירועים הקשורים ל- IPX SAP. הפרמטר error מציין שיש לכלול ביומן הרישום רק שגיאות הקשורות ל- IPX SAP. הפרמטר warn מציין שיש לכלול ביומן הרישום רק אזהרות הקשורות ל- IPX SAP. הפרמטר info מציין שיש לכלול ביומן הרישום את כל האירועים הקשורים ל- IPX SAP.

set filter

עדכון תצורת IPX SAP.

תחביר

set filter [InterfaceName=]InterfaceName [mode=]{input | output} ‎[action=]{permit | deny}

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שאת תצורתו ברצונך לעדכן. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[mode=]{input | output}‎
נדרש. ציון המצב, קלט או פלט.
‎[action=]{permit | deny}‎
נדרש. ציון הפעולה, אישור או דחיה.

show filter

הצגת מידע אודות תצורת IPX SAP עבור הממשק שצוין.

תחביר

show filter [InterfaceName=]InterfaceName [[mode=]{input | output}]

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שעבורו ברצונך להציג מידע. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[mode=]{input | output}‎
ציון המצב, קלט או פלט.

add filter

הוספת ערכים לתצורת IPX SAP של הממשק שצוין.

תחביר

add filter [InterfaceName=]InterfaceName [mode=]{input | output} ‎[svtype=]ServiceType [svname=]ServiceName

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שלתצורתו ברצונך להוסיף ערכים. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[mode=]{input | output}‎
נדרש. ציון המצב, קלט או פלט.
‎[svtype=]ServiceType
נדרש. ציון סוג שירות בן 2 בתים שאינו עולה על 4 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[svname=]ServiceName
נדרש. ציון שם שירות.

delete filter

מחיקת ערכי תצורה של מסנן מתצורת IPX SAP של הממשק שצוין.

תחביר

delete filter [InterfaceName=]InterfaceName [mode=]{input | output} ‎[svtype=]ServiceType [svname=]ServiceName

פרמטרים

‎[InterfaceName=]InterfaceName
נדרש. ציון בשם של הממשק שמתצורתו ברצונך להסיר ערכים. על הפרמטר InterfaceName להתאים לשמו של הממשק כפי שצוין ביישום חיבורי רשת. אם הפרמטר InterfaceName מכיל רווחים, תחום אותו במרכאות (לדוגמה, "Interface Name").
‎[mode=]{input | output}‎
נדרש. ציון המצב, קלט או פלט.
‎[svtype=]ServiceType
נדרש. ציון סוג שירות בן 2 בתים שאינו עולה על 4 ספרות הקסדצימאליות. אפסים מובילים הם אופציונליים.
‎[svname=]ServiceName
נדרש. ציון שם שירות.

דוגמה לניתוב Netsh

לשם הפעלה של גילוי נתב עבור הממשק המכונה Local Area Connection, תוך ציון מרווח זמן מינימלי של 7 דקות, מרווח זמן מירבי של 10 דקות, אורך חיים של 30 דקות עבור מנות גילוי נתב, ורמת העדפה אפס (0) או ללא רמת העדפה, הקלד:

add interface "Local Area Connection" enable 7 10 30 0


פקודות Netsh עבור WINS

פקודות Netsh עבור WINS מספקות כלי של שורת פקודה לשם ניהול של שרתי WINS. באפשרותך להשתמש בכלי זה כחלופה לניהול מבוסס מסוף. תכונה זו שימושית במצבים הבאים:

  • בעת ניהול שרתי WINS ברשתות תקשורת מרחבית ‏(WAN), ניתן להשתמש בפקודות במצב אינטראקטיבי בשורת הפקודה של Netsh כדי לשפר את הניהול של קישורי רשת במהירות נמוכה.
  • בעת ניהול מספר רב של שרתי WINS, ניתן להשתמש בפקודות במצב אצווה כדי להפעיל קובץ Script עבור משימות ניהוליות חוזרות שיש לבצע עבור כל שרתי WINS ולהפוך משימות אלה לאוטומטיות.

הפקודות שלהלן זמינות בשורת הפקודה של Netsh (להבדיל משורת הפקודה של Windows XP). לקבלת מידע נוסף אודות אופן השימוש בפקודות Netsh עבור WINS, ראה שימוש בכלי שורת הפקודה של WINS.

הערות

  • אלא אם צוין אחרת, תגי שדות (כגון Name=‎ ו- EndChar=‎) הם אופציונליים. אם נעשה שימוש בתגים, עליך להחילם על כל הפרמטרים בפקודה. אם לא נעשה שימוש בתגים, עליך לספק ערך עבור כל אחד מהשדות הזוכים לתמיכה בפקודה זו.
  • המונח Persona Non Grata מתייחס לתכונות Block records for these owners של שרת Windows 2000 WINS.
  • לקבלת מידע נוסף אודות netsh, ראה שימוש ב- Netsh.
  • לקבלת דוגמה לאופן השימוש בפקודות Netsh עבור WINS בקבצי אצווה ובקבצי Script, ראה Netsh עבור WINS - דוגמה.
  • אין באפשרותך להפעיל פקודות Netsh אלה באופן מקומי ב- Windows XP Professional או ב- Windows XP Home Edition. כדי להפעיל פקודות Netsh אלה בשרת Windows 2000 Server מרוחק, ראשית עליך להשתמש בהתקשרות לשולחן עבודה מרוחק (Remote Desktop Connection) כדי להתחבר לשרת Windows 2000 Server שפועל בו Terminal Server. באפשרותך להפעיל פקודות אלה מתוך שורת הפקודה של Windows 2000 או מתוך שורת הפקודה של הקשר WINS של Netsh. כדי שפקודות אלה יפעלו בשורת הפקודה של Windows 2000, עליך להקליד netsh dhcp לפני הקלדת הפקודות והפרמטרים כפי שהם מופיעים בתחביר שלהלן. ייתכן שיימצאו הבדלים תפקודיים בין פקודות של הקשר Netsh המבוצעות ב- Windows 2000 לבין פקודות אלה כשהן מבוצעות ב- Windows XP.

Netsh WINS

הפקודות שלהלן זמינות בשורת הפקודה wins>‎ של סביבת Netsh.

כדי להציג את תחביר הפקודה, לחץ על פקודה:

server

מעבר להקשר השרת שצוין. ללא פרמטרים, ברירת המחדל היא שימוש בשרת WINS המקומי.

תחביר

server [{\\ServerName | IPAddress}]‎

פרמטרים

{‎\\ServerName | IPAddress}
ציון שרת WINS המרוחק (לא מקומי) שאליו יש להעביר את הקשר שורת הפקודה Netsh WINS. השרת מזוהה לפי שם שרת או כתובת IP.

דוגמאות

בדוגמה הראשונה, פקודה זו מעבירה את הקשר Netsh לשרת WINS המקומי.

בדוגמה השניה, פקודה זו מעבירה את הקשר Netsh לשרת מרוחק ששמו ‎\\WINS-SRV1.

בדוגמה השלישית, פקודה זו מעבירה את הקשר Netsh לשרת מרוחק שכתובת ה- IP שלו היא 10.0.0.1.

server

server \\WINS-SRV1

server 10.0.0.1

Netsh WINS server

הפקודות הבאות זמינות בשורת הפקודה wins server>‎ של סביבת Netsh.

כדי להציג את תחביר הפקודה, לחץ על פקודה:

add

add filter

הוספת מסנן המוגדר על-ידי משתמש לשרת WINS שצוין.

תחביר

add filter [ID=]ID [Desc=]FilterDescription

פרמטרים

‎[ID=]ID
נדרש. ציון המזהה של המסנן שברצונך להוסיף, בסימון הקסדצימאלי.
‎[Desc=]FilterDescription
נדרש. ציון תיאורו של המסנן שברצונך להוסיף.

add name

הוספה של רשומת שם למסד הנתונים בשרת WINS שצוין.

תחביר

add name [Name=]ComputerName [[EndChar=]16thCharInHex]‎ ‎[[Scope=]ScopeName] [[RecType=]{0 | 1}]‎ ‎[[Group=]{0 | 1 | 2 | 3 | 4}] [[Node=]{0 | 1 | 3}]‎ ‎[IP=]{IPAddress1[,IPAddress2,IPAddress3… ]}‎

פרמטרים

‎[Name=]ComputerName
נדרש. ציון השם שיש להוסיף ולרשום במסד הנתונים של שרת WINS.
‎[EndChar=]16thCharInHex
ציון התו ה- 16 של השם, בסימון הקסדצימאלי. אם פרמטר זה לא צוין, סוגי הרשימות יתווספו בהתאם לערך של Group=‎. לקבלת מידע נוסף, עיין בהערות.
‎[Scope=]ScopeName
ציון השם של טווח NetBIOS.
‎[RecType=]{0 | 1}‎
ציון סוג הרשומה: ‎0 מציין Static (מצב סטטי, שהוא ברירת המחדל), ‎1 מציין Dynamic (דינמי).
‎[Group=]{0 | 1 | 2 | 3 | 4}‎
ציון סוג הקבוצה: ‎0 עבור Unique (ייחודי, שהוא ברירת המחדל), ‎1 עבור Group (קבוצה), ‎2 עבור Internet (אינטרנט), ‎3 עבור Multihomed (מרובה בתים), ‎4 עבור Domain Name (שם קבוצת מחשבים).
‎[Node=]{0 | 1 | 3}‎
ציון הסוג של צומת NetBIOS‏: 0 עבור B Node‏, 1 עבור P Node (ברירת המחדל), 3 עבור H Node.
‎[IP=]{IPAddress1[,IPAddress2,IPAddress3…]}‎
נדרש. ציון כתובת ה- IP של רשומת השם שיש להוסיף. אם המחשב מרובה חיבורים, ניתן לציין יותר מכתובת IP אחת. תחום כתובת IP אחת או יותר בסוגריים מסולסלים ({}) והפרד בין כתובות IP באמצעות פסיקים.

הערות

  • אם נעשה שימוש בפרמטר EndChar=‎ ובפרמטר Group=‎ ביחד, EndChar=‎ גובר על Group=‎.
  • כאשר לא צוין EndChar=‎, סוגי הרשומות הבאים נוספים למסד הנתונים של WINS בהתאם לערך של Group=‎:
    ערך הפרמטר Group | סוג הרשומה שנוסף
    קבוצה ייחודית (0) | 03h, 20h, 00h
    קבוצה רגילה (1) | 1eh
    קבוצה מיוחדת/אינטרנט (2) | 20h
    קבוצה מרובת חיבורים (3) | 03h, 20h, 00h
    קבוצה/קבוצת מחשבים מיוחדת (4) | 1ch

דוגמאות

בדוגמה הראשונה, פקודה זו מוסיפה קבוצת רשומות NetBIOS המוגדרות כברירת מחדל של הרשומות 00h,‏ 03h ו- 20h עבור מחשב הנקרא HOSTA עם כתובת IP ממופה של 10.0.0.1.

בדוגמה השניה, פקודה זו מוסיפה רשומת 20h עבור HOSTB, מחשב מרובה חיבורים שכתובות ה- IP שלו הן 10.0.0.2 ו- 10.0.0.3, ב- SUBNETA, עם רשומה מסוג סטטי ותצורת P-Node.

add name Name=HOSTA IP={10.0.0.1}‎

add name HOSTB 20 SUBNETA 0 3 1{10.0.0.2,10.0.0.3}‎

add partner

הוספה של שותף שכפול לרשימה של שותפי השכפול בשרת WINS שצוין.

תחביר

add partner [Server=]IPAddress [[NetBIOS=]ServerNetBIOSName] [[Type=]{0 | 1 | 2}]‎

פרמטרים

‎[Server=]IPAddress
נדרש. ציון שותף השכפול שיש להוסיף לשרת WINS. השרת השותף מזוהה לפי כתובת IP.
‎[NetBIOS=]ServerNetBIOSName
ציון שותף השכפול שיש להוסיף לשרת WINS. השרת השותף מזוהה לפי שם NetBIOS.
‎[Type=]{0 | 1 | 2}‎
ציון סוג השותף שיש להוסיף: ‎0-Pull‏, ‎1-Push‏, ‎2-Both (ברירת המחדל).

הערות

  • אם כתובת ה- IP אינה מפוענחת, הפרמטר של שם NetBIOS משמש ליצירת רשומת השותף. בכל מקרה אחר לא נעשה שימוש בפרמטר של NetBIOS.

דוגמאות

בדוגמה הבאה, פקודה זו מוסיפה שותף שכפול מסוג Push/Pull עם כתובת IP של 10.2.2.2 לשרת WINS הנוכחי.

add partner 10.2.2.2

add pngserver

פקודה זו מוסיפה רשימה של שרתי Persona Non Grata בשרת WINS שצוין.

תחביר

add pngserver [Servers=]{ListOfServerIPAddresses}‎

פרמטרים

‎[Servers=]{ListOfServerIPAddresses}‎
נדרש. ציון שרת או שרתי Persona Non Grata שיש להוסיף. כל שרת מזוהה לפי כתובת ה- IP שלו, התחומה בסוגריים מסולסלים ({}). אם סיפקת רשימה, עליך להפריד כתובות IP באמצעות פסיקים ולתחום אותן בסוגריים מסולסלים ({}).

הערות

  • פקודה זו מוסיפה את השרת החדש או השרתים החדשים לאחר ביצוע בדיקה לאיתור שכפולים. רשימת Persona Non Grata ‏(PNG) משמשת לציון בעלים ‎(שרתי WINS אחרים) שאת רשומותיהם יש לחסום במהלך השכפול.

דוגמאות

בדוגמה הבאה, פקודה זו מוסיפה את שרתי WINS ‏10.2.2.2 ו- 10.2.2.3 לרשימת Persona Non Grata עבור שרת WINS הנוכחי.

add pngserver {10.2.2.2,10.2.2.3}‎

add server

הוספה של שרת WINS למסוף WINS.

תחביר

add server [Server=]{\\ServerName | ServerIPAddress}‎

פרמטרים

‎[Server=]{\\ServerName | ServerIPAddress}‎
נדרש. ציון שרת WINS שיש להוסיף. השרת מזוהה לפי שם NetBIOS או כתובת IP.

דוגמאות

בדוגמה הבאה, פקודה זו מוסיפה שרת עם כתובת ה- IP ‏172.17.32.28 למסוף WINS.

add server Server=172.17.32.28

check

check database

בדיקת עקביות במסד הנתונים של WINS. ללא פרמטרים, מתבצעת בדיקת עקביות בכל השכפולים שחלף מרווח הזמן שלהם עבור אימות. בדיקת העקביות אינה מתבצעת באופן מיידי אם קיימים מצבים של עומס יתר, אלא לאחר שתם מרווח הזמן שהוגדר עבור אימות.

תחביר

check database [[All=]{1 | 0}] [[Force=]{1 | 0}]‎

פרמטרים

‎[All=]{1 | 0}‎
קביעה אם יש לבצע בדיקת עקביות בכל השכפולים, או רק בשכפולים שתם מרווח הזמן שלהם לאימות: ‎1 מציין All (כל השרתים) , ‎0 מציין Otherwise (ברירת המחדל).
‎[Force=]{1 | 0}‎
קביעה אם יש לעקוף את בדיקת העקביות של WINS במצבי עומס יתר: ‎1מציין Override (עקיפה), ‎0 מציין Otherwise (ברירת המחדל).

הערות

  • בדיקת עקביות בכל השכפולים מהווה פעולת אינטנסיבית של המשאב ושל הרשת.
  • מצב עומס יתר מתרחש כאשר הפקודה לבדיקת עקביות מתבצעת יותר מפעם בשעה.

דוגמאות

בדוגמה הבאה, פקודה זו מבצעת בדיקת עקביות עבור כל השכפולים. אם קיימים מצבי עומס יתר, בדיקת העקביות מתבצעת לאחר שחלף מרווח הזמן שהוגדר עבור אימות.

check database 1

check name

בדיקת רשימה של רשומות שם כנגד קבוצת שרתי WINS שצוינה.

תחביר

check name {NameFile=FileName | NameList={NamesList}}‎ ‎{ServerFile=FileName | ServerList={ListOfServerIPAddresses}}‎‎[InclPartner={Y | y}]‎

פרמטרים

‎{NameFile=FileName | NameList={NamesList}}‎
נדרש. ציון הקובץ שמכיל את רשימת השמות שיש לבדוק או ציון רשימת שמות שיש לבדוק. אם סיפקת רשימה, עליך להפריד שמות באמצעות פסיקים ולתחום אותם בסוגריים מסולסלים ({}).
‎{ServerFile=FileName | ServerList={ListOfServerIPAddresses}}‎
נדרש. ציון הקובץ שמכיל רשימת כתובות IP של שרתים או ציון רשימה של כתובות IP שיש לבדוק. אם סיפקת רשימה, עליך להפריד כתובות IP באמצעות פסיקים ולתחום אותן בסוגריים מסולסלים ({}).
InclPartner={Y | y}‎
ציון כי כל השותפים ייכללו ברשימת השרתים. כברירת מחדל, שותפים אינם נכללים.

הערות

  • נדרשים תגים עבור פקודה זו. כאשר מאותר חוסר עקביות, מתבצע ניסיון לתקן אותו.
  • התבנית עבור Name בפרמטר NameFile ובפרמטר NameList היא Name*16thchar, כאשר Name הוא שם הרשומה ו- 16thchar הוא התו ה- 16 של הרשומה.
  • בקובץ, ערכי שמות מופרדים באמצעות פסיקים או החזרות גררה/הזנות שורה.

דוגמאות

בדוגמה הראשונה, פקודה זו בודקת נתוני WINS מול הקבצים Names.txt ו- Servers.txt, בהנחה שקבצים אלה ממוקמים במיקום הנתיב שצוין (הבסיס של כונן D).

בדוגמה השניה, פקודה זו בודקת את השמות Name1 עם התו ה- 16 שהוא 03‏, 00 ו- 20h בהתאמה מול השרתים עם כתובות ה- IP ‏10.2.2.2 ו- 10.2.2.3.

check name NameFile=D:\Names.txt ServerFile=D:\Servers.txt

check name NameList={Name1*03,Name1*00,Name1*20} ServerList={10.2.2.2,10.2.2.3}‎

check version

בדיקת עקביות עבור המספרים של מזהי הגירסה עבור בעלי רשומות של WINS במסד הנתונים של WINS.

תחביר

check version [Server=]IPAddress [[File=]FileName]‎

פרמטרים

‎[Server=]IPAddress
נדרש. ציון כתובת ה- IP של שרת WINS הראשוני.
‎[File=]FileName
ציון הקובץ שבו יש לאחסן את האינדקס עבור טבלת כתובות IP. ללא פרמטר זה, הפקודה check version יוצרת את הקובץ Wins.rec בספריה הנוכחית ומאחסנת בו את האינדקס עבור טבלת כתובות IP.

הערות

  • אם תספק שם קובץ לא חוקי, FileName יוגדר כ- Wins.rec בספריה הנוכחית.
  • ייתכן שיהיה עליך להגדיל את רוחב חלון הפקודה כדי שיהיה באפשרותך להציג את הטבלה כראוי.

דוגמאות

בדוגמה הבאה, פקודה זו מאמתת את עקביות מספר הגירסה של הרשומות עבור שרת WINS עם כתובת ה- IP ‏ 10.2.2.2 בשותפי השכפול שלו.

check version 10.2.2.2

delete

delete name

מחיקת שם רשום ממסד הנתונים של שרת WINS.

תחביר

delete name [Name=]RegisteredName [EndChar=]16thCharInHex [[Scope=]ScopeName]‎

פרמטרים

‎[Name=]RegisteredName
נדרש. ציון השם הרשום שיש למחוק.
‎[EndChar=]16thCharInHex
נדרש. ציון התו ה- 16 של שם הרשומה שיש למחוק, בסימון הקסדצימאלי.
‎[Scope=]ScopeName
ציון מזהה טווח NetBIOS עבור הרשומה שיש למחוק.

דוגמאות

בדוגמה הבאה, פקודה זו מוחקת את רשומות Messenger ‏(03h) עם שם הרשומה HOSTA ממסד הנתונים של WINS.

delete name Name=HOSTA EndChar=03

delete owners

ביצוע של מחיקה או של פעולת Tombstone של רשימת בעלים והרשומות שלהם ממסד הנתונים בשרת WINS שצוין.

תחביר

delete owners [Servers=]{ListOfServerIPAddresses}‎ ‎[[Op=]{0 | 1}]‎

פרמטרים

‎[Servers=]{ListOfServerIPAddresses}‎
נדרש. ציון רשימה של השרתים הבעלים המכילים רשומות שיש למחוק. זיהוי השרתים לפי כתובות IP שיש להפריד באמצעות פסיקים ולתחום בסוגריים מסולסלים ({}).
‎[Op=]{0 | 1}‎
ציון האפשרות לבחירתך: ‎0 עבור פעולת Tombstone (ברירת המחדל), ‎1 עבור מחיקה.

דוגמאות

בדוגמה הבאה, פקודה זו מוחקת את כל הרשומות שבעליהן הוא שרת WINS שכתובת ה- IP שלו היא 10.0.0.1.

delete owners Servers={10.0.0.1} Op=1

delete partner

פקודה זו מוחקת את כל שותפי השכפול או את שותף השכפול שצוין מהרשימה של שותפי שכפול בשרת WINS שצוין. ללא פרמטרים, כל שותפי השכפול נמחקים הן מרשימות שותפי המשיכה (Pull) והן מרשימות שותפי הדחיפה (Push) ללא הצגת בקשה לאישור.

תחביר

delete partner [[Server=]IPAddress] [[Type=]{0 | 1 | 2}] [[Confirm=]{Y|y}]‎

פרמטרים

‎[Server=]IPAddress
ציון השותף שיש למחוק. זיהוי השותף לפי כתובת IP.
‎[Type=]{0 | 1 | 2}‎
ציון סוג רשימת השותפים שיש למחוק: 0 עבור Pull‏, 1 עבור Push‏, 2 עבור Both (שניהם. זוהי ברירת המחדל).
‎[Confirm=]{Y|y}‎
הפעלת הפעולה והשלמתה ללא הצגת בקשה לאישור.

דוגמאות

בדוגמה הבאה, פקודה זו מוחקת שותף מסוג Push/Pull שכתובת ה- IP שלו היא 10.0.0.1 משרת WINS הנוכחי, ללא הצגת בקשה לאישור.

delete partner Server=10.0.0.1 Type=2 Confirm=Y

delete pngserver

פקודה זו מוחקת את כל שרתי Persona Non Grata או שרתי Persona Non Grata מסוימים מהרשימה של שרתי Persona Non Grata בשרת WINS שצוין.

תחביר

delete pngserver [Servers=]{ListOfServerIPAddresses}‎

פרמטרים

‎[Servers=]{ListOfServerIPAddresses}‎
נדרש. ציון רשימה של שרתי Persona Non Grata שיש למחוק. זיהוי שרתי Persona Non Grata לפי כתובות IP שהופרדו באמצעות פסיקים ונתחמו בסוגריים מסולסלים ({}).

הערות

  • רשימת Persona Non Grata ‏(PNG) מציינת בעלים (שרתי WINS אחרים) שאת רשומותיהם יש לנעול במהלך השכפול. אם השתמשת בסוגריים מסולסלים ({}) ריקים, הפקודה delete pngserver מוחקת את כל השרתים שברשימת שרתי PNG.

דוגמאות

בדוגמה הבאה, פקודה זו מוחקת את שרתי WINS‏ 10.2.2.2 ו- 10.2.2.3 מרשימת Persona Non Grata עבור שרת WINS זה.

delete pngserver Servers={10.2.2.2,10.2.2.3}‎

delete records

פקודה זו מוחקת את כל הרשומות או קבוצת רשומות משרת WINS הנוכחי, או מסמנת רשומות כרשומות שבוצעה בהן פעולת Tombstone.

תחביר

delete records [MinVer=]{High,Low} [MaxVer=]{High,Low}‎ ‎[[Op=]{0 | 1}]‎

פרמטרים

‎[MinVer=]{High,Low}‎
נדרש. ציון הערך המינימלי הגבוה והערך המינימלי הנמוך של גירסאות הרשומות שבהן יש להתחיל את המחיקה. ערכים גבוהים ונמוכים יש להפריד באמצעות פסיק ולתחום בסוגריים מסולסלים ({}).
‎[MaxVer=]{High,Low}‎
נדרש. ציון הערך המקסימלי הגבוה והערך המקסימלי הנמוך של גירסאות הרשומות שבהן יש להפסיק את המחיקה. ערכים גבוהים ונמוכים יש להפריד באמצעות פסיק ולתחום בסוגריים מסולסלים ({}).
‎[Op=]{0 | 1}‎
ציון האפשרות לבחירתך: 0 עבור מחיקה (ברירת המחדל), 1 עבור פעולת Tombstone.

הערות

  • אם תגדיר את MinVer=‎ ואת MaxVer=‎ ל- {0,0}, הפקודה delete records תמחק את כל הרשומות.

דוגמאות

בדוגמה הראשונה, פקודה זו מסמנת את כל הרשומות בשרת WINS כרשומות שבוצעה בהן פעולת Tombstone.

בדוגמה השניה, פקודה זו מוחקת את כל הרשומות בין 2de2d לבין 2de3f כולל.

delete records MinVer={0,0} MaxVer={0,0} Op=1

delete records MinVer={0,2de2d} MaxVer={0,2de3f}‎

delete server

מחיקה של שרת WINS ממסוף WINS.

תחביר

delete server [Server=]{\\ServerName | ServerIPAddress}‎

פרמטרים

‎[Server=]{\\ServerName | ServerIPAddress}‎
נדרש. ציון שרת WINS שיש למחוק. זיהוי השרת לפי שם NetBIOS או כתובת IP.

דוגמאות

בדוגמה הבאה, פקודה זו מוחקת את השרת שכתובת ה- IP שלו היא 172.31.255.254 ממסוף WINS.

delete server Server=172.31.255.254

init

init backup

פקודה זו מפעילה גיבוי למסד הנתונים של WINS אל הספריה שצוינה. ללא פרמטרים, פקודה זו מספקת גיבוי מלא לנתיב הגיבוי שהוגדר כברירת מחדל.

תחביר

init backup [[Dir=]BackupDir] [[Type=]{0 | 1}]‎

פרמטרים

‎[Dir=]BackupDir
ציון הספריה שבה מאוחסנים קבצי הגיבוי. אם לא צוינה ספריה, נעשה שימוש בנתיב הגיבוי שהוגדר כברירת מחדל.
‎[Type=]{0 | 1}‎
ציון סוג הגיבוי: 0 עבור גיבוי מלא (ברירת המחדל), 1 עבור גיבוי מצטבר.

הערות

  • ניתן להשתמש בגיבוי של WINS לשם גיבוי מקומי באותו שרת בלבד. אין תמיכה בגיבוי של שרתי WINS מרוחקים.
  • קבצי גיבוי יווצרו באופן אוטומטי תחת ספריית המשנה wins_bak של הספריה Dir=‎.

דוגמאות

בדוגמה הבאה, פקודה זו מפעילה גיבוי מלא למסד הנתונים של WINS בשרת WINS המקומי אל התיקיה C:\WINSfiles\wins_bak‏. WINS ייצור את ספריית המשנה wins_bak.

init backup Dir=C:\WINSfiles Type=0

init compact

דחיסת מסד הנתונים של שרת WINS.

תחביר

init compact

פרמטרים

ללא

init export

ייצוא מסד הנתונים של שרת WINS לקובץ.

תחביר

init export

פרמטרים

ללא

init import

ייבוא מיפויים סטטיים מקובץ Lmhosts.

תחביר

init import [File=]ImportFile

פרמטרים

‎[File=]ImportFile
נדרש. ציון קובץ Lmhosts בתבנית טקסט, שישמש לייבוא של מיפויים סטטיים אל מסד הנתונים של WINS.

דוגמאות

בדוגמה הבאה, פקודה זו מייבאת את המיפויים הסטטיים של הקובץ Fixedip.sam, הממוקם בנתיב C:\WINSfiles, כמיפויים סטטיים חדשים במסד הנתונים של שרת WINS המקומי.

init import File=C:\WINSfiles\Fixedip.sam

init pull

אתחול של גורם מפעיל עבור משיכה (Pull) ושליחתו אל שרת WINS אחר.

תחביר

init pull [Server=]{PullServerName | IPAddress}‎

פרמטרים

‎[Server=]{\\PullServerName | IPAddress}‎
נדרש. ציון שרת WINS שאליו יש לשלוח גורם מפעיל עבור משיכה. זיהוי השרת לפי שם שרת או כתובת IP.

הערות

  • אם תספק שם שרת שאינו ניתן לפענוח לכתובת IP, הפעולה תיכשל.

דוגמאות

בדוגמה הבאה, פקודה זו מאתחלת גורם מפעיל עבור משיכה ושולחת אותו אל שרת WINS‏ 10.2.2.2.

init pull Server=10.2.2.2

init pullrange

אתחול ומשיכה של טווח רשומות משרת WINS אחר.

תחביר

init pullrange [Owner=]OwnerServerIP [Server=]PullServerIP ‎[MaxVer=]{High,Low} [MinVer=]{High,Low}‎

פרמטרים

‎[Owner=]OwnerServerIP
נדרש. ציון שרת WINS שממנו יש למשוך רשומות. זיהוי השרת לפי כתובת IP.
‎[Server=]PullServerIP
נדרש. ציון שרת WINS המבצע משיכה של טווח הרשומות. זיהוי השרת לפי כתובת IP.
‎[MaxVer=]{High,Low}‎
נדרש. ציון המספר המקסימלי הגבוה והמספר המקסימלי הנמוך של גירסת הרשומות שיש למשוך. ערכים גבוהים ונמוכים יש להפריד באמצעות פסיק ולתחום בסוגריים מסולסלים ({}).
‎[MinVer=]{High,Low}‎
נדרש. ציון המספר המינימלי הגבוה והמספר המינימלי הנמוך של גירסת הרשומות שיש למשוך. ערכים גבוהים ונמוכים יש להפריד באמצעות פסיק ולתחום בסוגריים מסולסלים ({}).

הערות

  • אם תגדיר את MaxVer=‎ ואת MinVer=‎ ל- {0,0}, הפקודה init pullrange תמשוך את טווח הרשומות כולו.

דוגמאות

בדוגמה הבאה, פקודה זו מאתחלת גורם מפעיל עבור משיכה ושולחת אותו אל שרת WINS‏ 10.2.2.3 עבור כל הרשומות שבעליהן הוא שרת WINS‏ 10.2.2.2.

init pullrange Owner=10.2.2.2 Server=10.2.2.3 MaxVer={0,0}‎ MinVer={0,0}‎

init push

פקודה זו מאתחלת גורם מפעיל עבור דחיפה (Push) ושולחת אותו אל שרת WINS אחר.

תחביר

init push [Server=]{\\PushServerName | IPAddress}‎ ‎[[PropReq=]{0 | 1}]‎

פרמטרים

‎ [Server=]{\\PushServerName | IPAddress}‎
נדרש. ציון שרת WINS שאליו יש לשלוח גורם מפעיל עבור דחיפה. זיהוי השרת לפי שם או כתובת IP.
‎[PropReq=]{0 | 1}‎
ציון בקשת ההפצה שלך: 0 לציון דחיפה לשרת שצוין בלבד (ברירת המחדל), 1 לציון הפצה של הגורם המפעיל עבור דחיפה לכל שותפיו של השרת.

הערות

  • אם תספק שם שרת שאינו ניתן לפענוח לכתובת IP, הפעולה תיכשל.

דוגמאות

בדוגמה הבאה, פקודה זו מאתחלת גורם מפעיל עבור דחיפה, שולחת אותו אל שרת WINS‏ 10.2.2.2 וגורמת לו להפיץ את הגורם המפעיל לכל שותפי השכפול שלו.

init push Server=10.2.2.2 PropReq=1

init replicate

כפיית שכפול מיידי של מסד נתונים עם שותפי שכפול.

תחביר

init replicate

פרמטרים

ללא

הערות

  • פקודה זו מפעילה שכפול מסוג דחיפה/משיכה (Push/Pull) עם כל שותפי השכפול עבור שרת זה.

init restore

שחזור מסד הנתונים של WINS מספריה וקובץ בשרת WINS שצוין.

תחביר

init restore [Dir=]RestoreDir

פרמטרים

‎[Dir=]RestoreDir
נדרש. ציון הספריה שממנה יש לשחזר קבצים.

הערות

  • ניתן לשחזר גיבויי WINS רק באופן מקומי, באותו שרת. אין אפשרות לשחזר את מסד הנתונים של WINS ממחשב מרוחק.
  • על הספריה שצוינה בפרמטר Dir=‎ להכיל את ספריית המשנה wins_bak שתכיל את קובץ מסד הנתונים, אך אין לכלול ספריית משנה זו בפרמטר Dir=‎.

דוגמאות

בדוגמה הבאה, פקודה זו משחזרת את מסד הנתונים של WINS ממיקום קובץ הגיבוי של מסד הנתונים C:\WINSfiles.

init restore Dir=C:\WINSfiles

init scavenge

ניקוי מסד הנתונים של WINS עבור שרת WINS שצוין.

תחביר

init scavenge

פרמטרים

ללא

הערות

  • הסרת מידע מיושן ממסד הנתונים של WINS.

init search

חיפוש אחר שם הרשומה שצוין במסד הנתונים של WINS.

תחביר

init search [Name=]RecordName [[EndChar=]EndCharacter]‎ ‎[[Case=]{0 | 1}] [[File=]FileName]‎

פרמטרים

‎[Name=]RecordName
נדרש. ציון שם הרשומה שיש לחפש.
‎[EndChar=]EndCharacter
ציון התו ה- 16 של רשומת שם NetBIOS. אם תו זה לא צוין, החיפוש מחזיר את כל הרשומות המתאימות למחרוזת שהזנת כערך עבור Name=‎. לקבלת מידע נוסף, עיין בהערות.
‎[Case=]{0 | 1}‎
ציון העדפה לגבי אותיות רישיות בשם: 0 עבור התעלמות מרישיות (ברירת המחדל), 1 עבור שימוש ברישיות.
‎[File=]FileName
ציון הקובץ שבו יש לאחסן פלט של טקסט רגיל מסוג ASCII. אם לא צוין קובץ, הפלט מוצג בחלון שורת הפקודה.

הערות

  • אם לא תספק ערך עבור EndChar=‎, החיפוש יחזיר את כל הרשומות המתאימות למחרוזת שהוזנה כערך עבור Name=‎. לדוגמה, אם מסד הנתונים מכיל רשומה שנקראת MYPC-1, חיפוש העושה שימוש ב- MYPC כערך הפרמטר של השם מחזיר את כל הרשומות המתחילות בתבנית זו של השם, ללא התייחסות לסוג הרשומה:

    • שם הרשומה | סוג הרשומה
MYPC-1 | [00h]‏Workstation (תחנת עבודה)
MYPC-1 | [01h]‏Other (אחר)
MYPC-1 | [03h]‏Messenger (שליחים)

    אם תציין ערך עבור EndChar=‎, מוחזרות רק רשומות המתאימות לשם הרשומה ולסוג הרשומה. לדוגמה, אם הערך עבור Name=‎ הוא MYPC והערך עבור EndChar הוא 00, יוחזרו תוצאות החיפוש הבאות:

    שם הרשומה | סוג הרשומה
MYPC-1 | ‎[00h]Workstation

דוגמאות

בדוגמה הבאה, פקודה זו מחפשת אחר רשומות הנקראות dc1 והתו האחרון שלהן הוא 1c, מתעלמת מאותיות רישיות ושולחת את פלט המידע אל הקובץ names.txt שמיקומו C:\WINSfiles.

init search Name=dc1 EndChar=1c Case=0 File=C:\WINSfiles \names.txt

reset

reset counter

איפוס הסטטיסטיקה עבור שרת WINS המקומי.

תחביר

reset counter

פרמטרים

ללא

set

set autopartnerconfig

קביעת המידע אודות התצורה של שותף השכפול האוטומטי עבור השרת. ללא פרמטרים, מתבצע איפוס של תצורת שותף אוטומטית (הפיכתה ללא זמינה).

תחביר

set autopartnerconfig [[State=]{0 | 1}]‎ ‎[[Interval=]Value] [[TTL=]Value]‎

פרמטרים

‎[State=]{0 | 1}‎
ציון הגדרת המידע של תצורת שותף השכפול האוטומטי: 0 עבור איפוס (ברירת המחדל), 1 עבור הפעלה.
‎[Interval=]Value
ציון הערך של מרווח הזמן לשידור לקבוצה, בשניות.
‎[TTL=]Value
ציון אורך החיים (ערך TTL) עבור יחידות נתונים של שידור לקבוצה בין שרתי WINS שותפים. על ערך זה להיות בטווח שבין 1 ל- 32.

דוגמאות

בדוגמה הבאה, פקודה זו קובעת את מידע התצורה האוטומטי עבור שרת WINS זה למרווח זמן של 3,600 שניות עבור שידור לקבוצה, וערך של 20 עבור אורך חיים (TTL).

set autopartnerconfig State=0 Interval=3600 TTL=20

set backuppath

קביעת פרמטרי הגיבוי עבור שרת WINS שצוין.

תחביר

set backuppath [Dir=]NewPath ‎[[Shutdown=]{0 | 1}]‎

פרמטרים

‎[Dir=]NewPath
נדרש. ציון נתיב הגיבוי עבור מסד הנתונים של השרת. אם לא צוין נתיב, נתיב ברירת המחדל הוא C:\‎.
‎[Shutdown=]{0 | 1}‎
ציון ההגדרה לגיבוי במהלך כיבוי: 0 עבור ביטול גיבוי של שרתי WINS במהלך כיבוי (ברירת המחדל), 1 עבור הפעלת גיבוי של מסד הנתונים של WINS במהלך כיבוי.

דוגמאות

בדוגמה הבאה, פקודה זו מגדירה את שרת WINS לגבות אוטומטית את מסד הנתונים של WINS ב- C:\WINSfiles בכל כיבוי של השרת.

set backuppath Dir=C:\WINSfiles Shutdown=1

set burstparam

קביעה של פרמטרים של טיפול בפרץ עבור שרת WINS שצוין.

תחביר

set burstparam [State=]{0 | 1}‎ ‎[[Value=]QueueSize]‎

פרמטרים

‎[State=]{0 | 1}‎
נדרש. ציון ההגדרה עבור טיפול בפרץ: 0 עבור איפוס או ביטול של טיפול בפרץ עבור שרת WINS, 1 עבור הפעלה של טיפול בפרץ עבור שרת WINS.
‎[Value=]QueueSize
ציון הערך של גודל תור הפרץ. על גודל התור להיות בטווח שבין 50 ל- 5,000.

דוגמאות

בדוגמה שלהלן, פקודה זו מגדירה את גודל תור הפרץ כך שיאפשר 1,000 בקשות הרשמה וחידוש של לקוחות לפני ששרת WINS זה יפעיל טיפול בפרץ.

set burstparam State=1 Value=1000

set defaultparam

החזרת הפרמטרים המהווים ברירת מחדל עבור התצורה של שרת WINS.

תחביר

set defaultparam

פרמטרים

ללא

הערות

  • פקודה זו מחזירה את כל פרמטרי התצורה של שרת WINS לערכי ברירת המחדל שלהם. מומלץ להפעיל פקודה זו לאחר התקנת שירות WINS כדי לקבוע את התצורה של השרת לפי הגדרות ברירת המחדל של הפרמטרים.

set logparam

קביעה או איפוש של הפרמטרים עבור רישום אירועים מפורט ועבור רישום של מסד הנתונים. ללא פרמטרים, הערכים הנוכחיים נשמרים.

תחביר

set logparam [[DBChange=]{0 | 1}] [[Event=]{0 | 1}]‎

פרמטרים

‎[DBChange=]{0 | 1}‎
ציון אם ברצונך לבצע רישום של שינויים המתבצעים במסד הנתונים: 1 מציין רישום של שינויים במסד הנתונים לקבצי יומן מסוג JET (ברירת המחדל), 0 מציין איפוס של אפשרות זו.
‎[Event=]{0 | 1}‎
ציון פירוט עבור האירועים: 1 מציין רישום של אירועים מפורטים ביומן הרישום של המערכת, 0 מציין איפוס של אפשרות זו (ברירת המחדל).

הערות

  • למנגנון מסד הנתונים של WINS יש אפשרות לרשום את השינויים במסד הנתונים בקבצים נפרדים. מכיוון שאפשרות זו משפרת את הביצועים של פעולות מסד הנתונים, פעולתה היא ברירת המחדל.
  • לשרת WINS יש אפשרות לרשום מידע מפורט אודות אירועים ביומן האירועים של המערכת. מכיוון שאפשרות זו צורכת משאבים מרובים, כברירת מחדל היא אינה מופעלת.

דוגמאות

בדוגמה הבאה, פקודה זו קובעת פרמטרים של רישום עבור שרת WINS זה כדי לאפשר רישום של שינויים במסד הנתונים בקבצי JET וכדי לרשום אירועים מפורטים ביומן האירועים של המערכת.

set logparam Event=1

set migrateflag

פקודה זו מגדירה את דגל ההעברה עבור שרת WINS שצוין.

תחביר

set migrateflag [State=]{0 | 1}‎

פרמטרים

‎[State=]{0 | 1}‎
נדרש. ציון ההגדרה של דגל ההעברה: ‎0 מציין ביטול (ללא העברה), 1 מציין אפשרות להעברה.

הערות

  • דגל ההעברה קובע אם ניתן להחליף מיפויים סטטיים יחודיים ברשומות דינמיות.

דוגמאות

בדוגמה הבאה, פקודה זו קובעת את דגל ההעברה כך שתתאפשר החלפה של מיפויים סטטיים יחודיים ברשומות דינמיות עבור שרת WINS שצוין.

set migrateflag State=1

set namerecord

הגדרת מרווחי הזמן המשמשים לקביעת המועד שבו רשומות שם של WINS מחודשות, נמחקות ומאומתות בשרת WINS שצוין. ללא פרמטרים, הערכים הנוכחיים נשמרים.

תחביר

set namerecord [[Renew=]Value] [[Extinction=]Value]‎ ‎[[ExTimeout=]Value] [[Verification=]Value]‎

פרמטרים

‎[Renew=]Value
ציון מרווח הזמן עבור התחדשות, בשניות.
‎[Extinction=]Value
ציון מרווח הזמן עבור מחיקה, בשניות.
‎[ExTimeout=]Value
ציון פסק הזמן עבור מחיקה, בשניות.
‎[Verification=]Value
ציון מרווח הזמן עבור אימות, בשניות.

הערות

  • כל הפרמטרים אופציונליים. עבור פרמטרים שלא נעשה בהם שימוש, נשמרים הערכים הקיימים (ערכים שהוגדרו בעבר או ערכי ברירת המחדל).

דוגמאות

בדוגמה הבאה, פקודה זו מגדירה כל אחד מהערכים עבור רשומות שם בשרת WINS זה.

set namerecord Renew=3600 Extinction=7200 ExTimeout=86400 Verification=2073600

set periodicdbchecking

הגדרת פרמטרים עבור בדיקת עקביות תקופתית במסד הנתונים של שרת WINS שצוין. ללא פרמטרים, הערכים הנוכחיים נשמרים.

תחביר

set periodicdbchecking [[State=]{0 | 1}] [[MaxRec=]Value]‎ ‎[[CheckAgainst=]{0 | 1}] [[CheckEvery=]Value] [[Start=]Value]‎

פרמטרים

‎[State=]{0 | 1}‎
נדרש. ציון אם יש לבדוק את מצב מסד הנתונים של WINS: 0 מציין ביטול, 1 מציין הפעלה (ברירת המחדל). אם תקבע את הערך של פרמטר זה ל- 0, כל הבדיקות יבוטלו ללא התייחסות לערכים של פרמטרים אחרים.
‎[MaxRec=]Value
ציון המספר המירבי של רשומות שנבדקות בכל תקופה. אם לא צוין מספר, ברירת המחדל היא 30,000.
‎[CheckAgainst=]{0 | 1}‎
ציון השרת שמולו יש לבצע את הבדיקה : 0 מציין את השרת הבעלים (ברירת המחדל), 1 מציין שרת שנבחר אקראית.
‎[CheckEvery=]Value
ציון התדירות שבה יש לבדוק עקביות במסד הנתונים של WINS, בשעות. אם לא צוינה תדירות, ברירת המחדל היא 24 שעות.
‎[Start=]Value
ציון הזמן, בשניות, שבו יש להתחיל את בדיקת העקביות.

הערות

  • כדי להגדיר מרווחי זמן לבדיקת עקביות תקופתית, מומלץ לציין ערכים עבור הפרמטרים CheckEvery ו- Start. כדי להתאים את ההגדרות הקיימות עבור בדיקת עקביות תקופתית, ציין ערכים עבור State ועבור הפרמטר או הפרמטרים שברצונך לשנות בלבד. פרמטרים שלא תספק עבורם ערכים לא ישתנו.

דוגמאות

בדוגמה הבאה, פקודה זו בודקת את מסד הנתונים של WINS מול שותף שכפול אקראי פעם שעה, החל ב- 3,600 שניות.

set periodicdbchecking State=1 MaxRec=1000 CheckAgainst=1 CheckEvery=1 Start=3600

set pullparam

הגדרת הפרמטרים המהווים ברירת מחדל עבור שותף המשיכה (Pull) של שרת WINS שצוין. ללא פרמטרים, נשמרים ערכים שהוגדרו בעבר או ערכי ברירת המחדל.

תחביר

set pullparam ‎[[State=]{0 | 1}] [[Strtup=]{0 | 1}]‎ ‎[[Start=]Value] [[Interval=]Value] [[Retry=]Value]‎

פרמטרים

‎[State=]{0 | 1}‎
נדרש. ציון אם ברצונך שיעשה שימוש בהתקשרויות מתמשכות עם שותפי משיכה: 0 מציין כי אין לעשות שימוש בהתקשרויות מתמשכות עם שותפי משיכה, 1 מציין כי יש לעשות שימוש בהתקשרויות מתמשכות עם שותפי משיכה.
‎[Strtup=]{0 | 1}‎
ציון אם שכפול משיכה יופעל בעת האתחול: 0 מציין כי אין להפעיל שכפול משיכה עם האתחול (ברירת המחדל), 1 מציין כי יש להתחיל שכפול משיכה עם האתחול.
‎[Start=]Value
ציון זמן ההפעלה של גורם מפעיל עבור משיכה, בשניות.
‎[Interval=]Value
ציון מרווח הזמן לשכפול, בשניות.
‎[Retry=]Value
ציון מספר הפעמים שבהן יש לבצע ניסיון חוזר לשכפול.

הערות

  • אם לא תציין ערך עבור Interval=‎, יתרחש שכפול אחד בלבד.
  • אם לא תציין ערך עבור Start=‎, הפעלת הפקודה תגרום להפעלת הגורם המפעיל עבור משיכה.

דוגמאות

בדוגמה הבאה, פקודה זו מגדירה את הפרמטרים המהווים ברירת מחדל עבור שותף משיכה של שרת WINS זה לשם שימוש בהתקשרות מתמשכת עם שותפי משיכה, הפעלת שכפול בעת האתחול, הפעלת גורם מפעיל עבור משיכה תוך 23,600 שניות במרווח זמן של 259,200 שניות, וביצוע שבעה ניסיונות חוזרים לשכפל.

set pullparam State=1 Strtup=1 Start=23600 Interval=259200 Retry=7

set pullpartnerconfig

פקודה זו מגדירה את פרמטרי התצורה עבור שותף המשיכה שצוין.

תחביר

set pullpartnerconfig [[State=]{0 | 1}] [Server=]ServerName ‎[[Start=]Value] [[Interval=]Value]‎

פרמטרים

‎[State=]{0 | 1}‎
ציון המצב של דגל ההתקשרות המתמשכת: 0 עבור ביטול, 1 עבור הפעלה (ברירת המחדל).
‎[Server=]ServerName
נדרש. ציון שותף המשיכה עבור שכפול, לפי שם שרת או כתובת IP.
‎[Start=]Value
ציון זמן ההפעלה עבור השכפול, בשניות.
‎[Interval=]Value
ציון מרווח הזמן בין שכפולי משיכה, בשניות.

הערות

  • אם תספק בפרמטר Server=‎ שם שרת שאינו ניתן לפענוח לכתובת IP, הפעולה תיכשל.

דוגמאות

בדוגמה הבאה, פקודה זו מגדירה את תצורת שותף המשיכה של שרת WINS הנוכחי לשרת WINS השותף 10.2.2.2. שכפול משיכה מופעל תוך 3,600 שניות, ומופעל שוב כל 4,320 שניות.

set pullpartnerconfig State=1 Server=10.2.2.2 Start=3600 Interval=4320

set pushparam

פקודה זו מגדירה את הפרמטרים המהווים ברירת מחדל עבור שותפי דחיפה (Push) של שרת WINS שצוין.

תחביר

set pushparam [State=]{0 | 1} [[Strtup=]{0 | 1}]‎ ‎[[AddChange=]{0 | 1}] [[Update=]Value]‎

פרמטרים

‎[State=]{0 | 1}‎
נדרש. ציון אם ברצונך שיעשה שימוש בהתקשרויות מתמשכות עם שותפי דחיפה: 0 מציין כי אין לעשות שימוש בהתקשרויות מתמשכות עם שותפי דחיפה, 1 מציין כי יש לעשות שימוש בהתקשרויות מתמשכות עם שותפי דחיפה.
‎[Strtup=]{0 | 1}‎
ציון אם ברצונך ששכפול דחיפה יופעל בעת האתחול: 0 מציין כי אין להפעיל שכפול דחיפה עם האתחול (ברירת המחדל), 1 מציין כי יש להפעיל שכפול דחיפה עם האתחול.
‎[AddChange=]{0 | 1}‎
ציון אם ברצונך שהשכפול יופעל בעת שינוי כתובת: 0 מציין כי אין להפעיל שכפול לאחר שינוי כתובת (ברירת המחדל), 1 מציין כי יש להפעיל שכפול לאחר שינוי כתובת.
‎[Update=]Value
ציון מספר השינויים שיתרחשו במזהה הגירסה לפני שכפול.

דוגמאות

בדוגמה הבאה, פקודה זו מגדירה את הפרמטרים המהווים ברירת מחדל עבור שותפי דחיפה של שרת WINS זה כך שהשרת יעשה שימוש בהתקשרויות מתמשכות עם שותפי הדחיפה שלו, יפעיל שכפול דחיפה בעת האתחול ובעת שינוי כתובות ויבצע דחיפה אל שותפים לאחר שני עדכונים של מזהה הגירסה עבור רשומות שהוא בעליהן.

set pushparam State=1 Strtup=1 AddChange=1 Update=2

set pushpartnerconfig

פקודה זו מגדירה את פרמטרי התצורה עבור שותף הדחיפה שצוין.

תחביר

set pushpartnerconfig [[State=]{0 | 1}]‎ ‎[Server=]\\ServerName [Update=]Value

פרמטרים

‎[State=]{0 | 1}‎
ציון המצב של דגל ההתקשרות המתמשכת: 0 עבור ביטול, 1 עבור הפעלה (ברירת המחדל).
‎[Server=]\\ServerName
נדרש. ציון שרת שותף הדחיפה שעבורו ברצונך להגדיר את פרמטרי התצורה. זיהוי השרת לפי שם שרת או כתובת IP.
‎[Update=]Value
נדרש. ציון גודל הסף עבור עדכונים.

הערות

  • אם תספק שם בפרמטר השרת שאינו ניתן לפענוח לכתובת IP, הפעולה תיכשל.

דוגמאות

בדוגמה הבאה, פקודה זו קובעת את תצורת שותף הדחיפה של שרת WINS הנוכחי עבור שרת WINS שותף שכתובת ה- IP שלו היא 10.2.2.2ף ומגדירה ערך של שתיים כמגבלה על כמות השינויים במזהה הגירסה שניתן לבצע לפני ששותפי הדחיפה מקבלים דיווח לגביהם.

set pushpartnerconfig State=1 Server=10.2.2.2 Update=2

set replicateflag

פקודה זו קובעת את דגל השכפול עבור שרת WINS שצוין.

תחביר

set replicateflag [State=]{0 | 1}‎

פרמטרים

‎[State=]{0 | 1}‎
נדרש. ציון ההגדרה של דגל השכפול: 0 מציין ביטול (דגל Off עבור שכפול), 1 מציין הפעלה (דגל On עבור שכפול).

דוגמאות

בדוגמה הבאה, פקודה זו מפעילה את דגל השכפול עבור שרת זה.

set replicateflag State=1

set startversion

פקודה זו קובעת את מספר המזהה של גירסת ההתחלה עבור מסד הנתונים.

תחביר

set startversion [Version=]{High,Low}‎

פרמטרים

‎[Version=]{High,Low}‎
נדרש. ציון מספר המזהה של גירסת ההתחלה עבור מסד הנתונים של WINS. ערכים גבוהים ונמוכים יש להפריד באמצעות פסיק ולתחום בסוגריים מסולסלים ({}).

דוגמאות

בדוגמה הבאה, פקודה זו מגדירה את מספר המזהה של גירסת ההתחלה עבור מסד הנתונים של WINS ל- 0.

set startversion Version={0,0}‎

show

show browser

הצגה של כל רשומות הדפדפנים הראשיים והפעילים של קבוצת מחשבים [1Bh] עבור שרת WINS שצוין.

תחביר

show browser

פרמטרים

ללא

show database

הצגה של מסד הנתונים ושל הרשומות עבור רשימה חלקית או מלאה של שרתים בעלים שצוינו.

תחביר

show database [Servers=]{IPAddresses} [[RecType=]{0 | 1 | 2}]‎ ‎[[Count=]Count] [[Start=]{0 | 1}] [[EndChar=]16thCharInHex]‎ ‎[[File=]FileName]‎

פרמטרים

‎[Servers=]{IPAddresses}‎
נדרש. ציון רשימה של שרתים בעלים שיש להציג את רשומותיהם. השרתים הבעלים מזוהים לפי כתובות IP שיש להפריד באמצעות פסיקים ולתחום בסוגריים מסולסלים ({}).
‎[RecType=]{0 | 1 | 2}‎
ציון סוג הרשומה: 1 עבור סטטי, 2 עבור דינמי, 0 עבור שניהם.
‎[Count=]Count
ציון מספר הרשומות שברצונך להציג. אם לא צוין מספר, יוחזרו כל הרשומות המתאימות לפרמטרי השאילתה.
‎[Start=]{0 | 1}‎
ציון המיקום שבו יש להתחיל במיון התצוגה: 0 מציין התחלה בראשית מסד הנתונים (ברירת המחדל), 1 מציין התחלה בסוף מסד הנתונים.
‎[EndChar=]16thCharInHex
ציון התו ה- 16 של הרשומות, בסימון הקסדצימאלי. מספר זה מסנן את הרשומות המאוחזרות ממסד הנתונים. אם לא צוין מספר, יוחזרו כל סוגי הרשומות.
‎[File=]FileName
ציון הקובץ שבו יש לאחסן פלט מעוצב. אם לא צוין קובץ, הפלט מוצג בחלון שורת הפקודה.

הערות

  • אם תציין סוגריים מסולסלים ({}) ריקים עבור Servers=‎, רשומות מסוג show database יוצגו עבור כל השרתים הבעלים.

דוגמאות

בדוגמה הבאה, פקודה זו שולחת פלט של 1000 הרשומות הדינמיות הראשונות במסד הנתונים של WINS עבור השרת 10.2.2.2 אל קובץ הטקסט output.txt.

show database Servers={10.2.2.2} RecType=2 Count=1000 Start=0 Endchar=0 File=C:\WINSfiles\output.txt

show info

הצגה של מידע תצורה עבור שרת WINS שצוין.

תחביר

show info

פרמטרים

ללא

הערות

  • לאחר הפעלתה, מציגה הפקודה את מידע התצורה הבא עבור WINS עבור השרת הנוכחי:
    • נתיב גיבוי
    • הגדרה של רשומת שם
    • בדיקת עקביות תקופתית במסד הנתונים
    • טיפול בפרץ
    • פרמטרי כניסה
    • ספירה של גירסת ההתחלה

show name

ביצוע שאילתה עבור מידע מפורט של רשומה מסוימת במסד הנתונים של שרת WINS הנוכחי, והצגה של מידע זה.

תחביר

show name [Name=]RecordName [EndChar=]16thCharInHex [[Scope=]ScopeName]‎

פרמטרים

‎[Name=]RecordName
נדרש. ציון הרשומה שעליה יש לבצע את השאילתה.
‎[EndChar=]16thCharInHex
נדרש עבור כל השאילתות למעט עבור רשומות מסוג ייחודי. ציון התו ה- 16, בסימון הקסדצימאלי.
‎[Scope=]ScopeName]‎
ציון טווח NetBIOS, אם נעשה בו שימוש.

דוגמאות

בדוגמה הבאה, פקודה זו מציגה מידע המאוחסן כעת עבור רשומת השם HOSTA, מסוג File Server‏ [20h] שקיימת במסד הנתונים של WINS בשרת WINS שצוין.

show name Name=HOSTA EndChar=20

show partner

פקודה זו מציגה את כל שותפי המשיכה (Pull), שותפי הדחיפה (Push), או שותפי המשיכה והדחיפה עבור שרת WINS שצוין. ללא פרמטרים, פקודה זו מציגה את כל שותפי הדחיפה, שותפי המשיכה, ושותפי הדחיפה/משיכה עבור שרת WINS שצוין.

תחביר

show partner [[Type=]{0 | 1 | 2 | 3}]‎

פרמטרים

‎[Type=]{0 | 1 | 2 | 3}‎
ציון סוג השותף שיש להציג: 0 מציין שותפים מכל הסוגים (ברירת המחדל), 1 מציין שותפי משיכה, 2 מציין שותפי דחיפה, 3 מציין שותפי דחיפה ושותפי משיכה גם יחד.

דוגמאות

בדוגמה הבאה, פקודה זו מציגה את שם השרת, את כתובת ה- IP ואת סוג השכפול של כל שותף שכפול עבור שרת WINS זה.

show partner

show partnerproperties

הצגת מידע אודות תצורת השותף המשמש כברירת מחדל עבור שרת WINS שצוין.

תחביר

show partnerproperties

פרמטרים

ללא

הערות

  • פקודה זו מציגה את תצורת השותף האוטומטית ואת פרמטרי הדחיפה/משיכה המשמשים כברירת מחדל עבור שרת WINS הנוכחי.

show pullpartnerconfig

הצגת מידע תצורה עבור שותף משיכה.

תחביר

show pullpartnerconfig [Server=]{Name | IPAddress}‎

פרמטרים

‎[Server=]{Name | IPAddress}‎
נדרש. ציון שותף המשיכה שעבורו ברצונך להציג מידע תצורה. זיהוי השותף לפי שם או לפי כתובת IP.

הערות

  • אם תספק שם שאינו ניתן לפענוח לכתובת IP, הפעולה תיכשל.

דוגמאות

בדוגמה הבאה, פקודה זו מציגה את מידע התצור של שותף המשיכה עבור שרת WINS ‏10.2.2.2.

show pullpartnerconfig Server=10.2.2.2

show pushpartnerconfig

הצגה של מידע תצורה עבור שותף דחיפה.

תחביר

show pushpartnerconfig [Server=]{Name | IPAddress}‎

פרמטרים

‎[Server=]{Name | IPAddress}‎
נדרש. ציון שותף הדחיפה עבורו ברצונך להציג מידע תצורה. זיהוי שותף הדחיפה לפי שם או לפי כתובת IP.

הערות

  • אם תספק שם שאינו ניתן לפענוח לכתובת IP, הפעולה תיכשל.

דוגמאות

בדוגמה הבאה, פקודה זו מציגה מידע תצורה אודות שותף הדחיפה עבור שרת WINS ‏10.2.2.2.

show pushpartnerconfig Server= 10.2.2.2

show recbyversion

הצגה של קבוצת רשומות עבור בעלים, שצוינה כטווח של מזהי גירסאות. מיון הרשימות מתבצע לפי גירסה.

תחביר

show recbyversion [Server=]IPAddress [MaxVer=]{High,Low}‎ ‎[MinVer=]{High,Low} [[Name=]RecordName] [[EndChar=]16thChar] [Case=]{0 | 1}‎

פרמטרים

‎[Server=]IPAddress
נדרש. ציון השרת הבעלים שעבורו ברצונך להציג קבוצת רשומות. זיהוי השרת לפי כתובת IP.
‎[MaxVer=]{High,Low}‎
נדרש. ציון טווח הרשומות שיש להחזיר לפי מספר הגירסה המקסימלי הגבוה ומספר הגירסה המקסימלי הנמוך. ערכים גבוהים ונמוכים יש להפריד באמצעות פסיק ולתחום בסוגריים מסולסלים ({}).
‎[MinVer=]{High,Low}‎
נדרש. ציון טווח הרשומות שיש להחזיר לפי מספר הגירסה המינימלי הגבוה ומספר הגירסה המינימלי הנמוך. ערכים גבוהים ונמוכים יש להפריד באמצעות פסיק ולתחום בסוגריים מסולסלים ({}).
‎[Name=]RecordName
ציון הרשומות שיש לחפש.
‎[EndChar=]16thChar
ציון התו שיש לחפש, בסימון הקסדצימאלי.
‎[Case=]{0 | 1}‎
ציון אם יש ליצור השוואה תלויית רישיות: 0 מציין התעלמות מרישיות (ברירת המחדל), 1 מציין השוואה תלוית רישיות.

הערות

  • אם לא צוין Name=‎, המערכת תתעלם מהערכים שהוזנו עבור EndChar=‎ ו- Case=‎.
  • אם תגדיר הן את MinVer=‎ והן את MaxVer=‎ ל- {0,0}, הפקודה show recbyversion תציג את טווח הרשומות כולו.

דוגמאות

בדוגמה הבאה, פקודה זו מציגה את מספר הרשומות הכולל (לפי גירסת הרשומה) שבעליהן הוא שרת WINS ‏10.2.2.2.

show recbyversion Server=10.2.2.2 MaxVer={0,0} MinVer={0,0}Name=dc1 EndChar=1c Case=0

show reccount

הצגה של מספר הרשומות שבעליהן הוא שרת WINS מסוים.

תחביר

show reccount [Server=]IPAddress [MaxVer=]{High,Low}‎ ‎[MinVer=]{High,Low}‎

פרמטרים

‎[Server=]IPAddress
נדרש. ציון השרת הבעלים שעבורו ברצונך להציג את מספר הרשומות. זיהוי השרת לפי כתובת IP.
‎[MaxVer=]{High,Low}‎
נדרש. ציון הערך המקסימלי הגבוה והערך המקסימלי הנמוך של גירסת הרשומות שיש להציג. ערכים גבוהים ונמוכים יש להפריד באמצעות פסיק ולתחום בסוגריים מסולסלים ({}).
‎[MinVer=]{High,Low}‎
נדרש. ציון הערך המינימלי הגבוה והערך המינימלי הנמוך של גירסת הרשומות שיש להציג. ערכים גבוהים ונמוכים יש להפריד באמצעות פסיק ולתחום בסוגריים מסולסלים ({}).

הערות

  • אם תגדיר הן את MinVer=‎ והן את MaxVer=‎ ל- {0,0}, הפקודה show reccount תספור את טווח הרשומות כולו.

דוגמאות

בדוגמה הבאה, פקודה זו מציגה את ספירת הרשומות הכוללת עבור שרת WINS ‏10.2.2.2.

show reccount Server=10.2.2.2 MaxVer={0,0} MinVer={0,0}‎

show server

הצגת מידע אודות שרת WINS שצוין.

תחביר

show server

פרמטרים

ללא

הערות

  • פקודה זו מציגה את השם ואת כתובת ה- IP של שרת WINS שצוין.

show serverstatistics

הצגת סטטיסטיקה עבור שרת WINS שצוין.

תחביר

show statistics

פרמטרים

ללא

show version

הצגת הערך המקסימלי הנוכחי של מונה הגירסאות עבור שרת WINS שצוין.

תחביר

show version

פרמטרים

ללא

show versionmap

הצגה של מזהה הבעלים עבור טבלת המיפויים של מספר הגירסה המקסימלי של שרת WINS שצוין.

תחביר

show versionmap

פרמטרים

ללא


Netsh עבור WINS - דוגמה

באפשרותך להשתמש בפקודות Netsh עבור Windows Internet Name Service ‏(WINS) בקבצי אצווה ובקבצי Script אחרים כדי להפוך משימות לאוטומטיות. קובץ האצווה שלהלן מדגים כיצד יש להשתמש בפקודות Netsh עבור WINS כדי לבצע מגוון משימות קשורות.

בהליך דוגמה זה, WINS-A הוא שרת WINS עם כתובת IP של 192.168.125.30 ו- WINS-B הוא שרת WINS עם כתובת IP של 192.168.0.189. ההליך מוסיף רשומת שם דינמי הנקראת MY_RECORD ‏[04h] עם כתובת IP של 192.168.0.205 ל- WINS-A, מגדיר את WINS-B כשותף שכפול מסוג דחיפה/משיכה (Push/Pull) של WINS-A, מתחבר ל- WINS-B ולאחר מכן מגדיר את WINS-A כשותף שכפול מסוג משיכה/דחיפה של WINS-B. בשלב הבא ההליך יוצר שכפול דחיפה מ- WINS-A אל WINS-B ולאחר מכן מתחבר אל WINS-B כדי לוודא כי הרשומה החדשה, MY_RECORD, שוכפלה בהצלחה.

לקבלת מידע נוסף, ראה שכפול WINS, הפניה לשמות NetBIOS, וכן קביעת תצורת שכפול.

לקבלת רשימה מלאה של פקודות Netsh עבור WINS, ראה פקודות Netsh עבור WINS.

בהליך לדוגמה שלהלן, לפני שורות המכילות הערות יופיע "rem", המציין הערה (Remark). היישום Netsh מתעלם מהערות.

rem two WINS servers:
rem (WINS-A) 192.168.125.30
rem (WINS-B) 192.168.0.189

rem 1. Connect to (WINS-A), and add the dynamic name MY_RECORD [04h] to the (WINS-A) database.
netsh wins server 192.168.125.30 add name Name=MY_RECORD EndChar=04 IP={192.168.0.205}

rem 2. Connect to (WINS-A), and set (WINS-B) as a push/pull replication partner of (WINS-A).
netsh wins server 192.168.125.30 add partner Server=192.168.0.189 Type=2

rem 3. Connect to (WINS-B), and set (WINS-A) as a push/pull replication partner of (WINS-B).
netsh wins server 192.168.0.189 add partner Server=192.168.125.30 Type=2

rem 4. Connect back to (WINS-A), and initiate a push replication to (WINS-B).
netsh wins server 192.168.125.30 init push Server=192.168.0.189 PropReq=0

rem 5. Connect to (WINS-B), and check that the record MY_RECORD [04h] was replicated successfully.
netsh wins server 192.168.0.189 show name Name=MY_RECORD EndChar=04

rem 6. End example batch file.

הטבלה שלהלן מציגה פירוט עבור פקודות netsh wins שנעשה בהן שימוש בהליך לדוגמה זה.

פקודה | תיאור
server | העברת ההקשר של שורת הפקודה הנוכחית של WINS אל השרת שצוינו שמו או כתובת ה- IP שלו.
add name | רישום שם בשרת.
add partner | הוספת שותף שכפול לשרת.
init push | יצירה של גורם מפעיל עבור דחיפה ושליחתו אל שרת WINS.
show name | הצגת מידע מפורט עבור רשומה מסוימת במסד הנתונים של שרת WINS.


Netstat

פקודה זו מציגה חיבורי TCP פעילים, יציאות שבאמצעותן מבצע המחשב האזנה, נתונים סטטיסטיים של Ethernet, טבלת ניתוב IP, נתונים סטטיסטיים של IPv4 (עבור הפרוטוקולים IP‏, ICMP‏, TCP ו- UDP) ונתונים סטטיסטיים של IPv6 (עבור הפרוטוקולים IPv6‏, ICMPv6‏, TCP over IPv6 ו- UDP over IPv6). ללא פרמטרים, תציג הפקודה netstat חיבורי TCP פעילים.

תחביר

netstat ‎[-a]‎ ‎[-e]‎ ‎[-n]‎ ‎[-o]‎ ‎[-p Protocol]‎ ‎[-r]‎ ‎[-s]‎ ‎[Interval]‎

פרמטרים

‎-a
הצגה של כל חיבורי TCP הפעילים ושל יציאות TCP ו- UDP שבאמצעותן מבצע המחשב האזנה.
‎-e
הצגת נתונים סטטיסטיים של Ethernet, כגון מספר הבתים והמנות שנשלחו והתקבלו. ניתן לשלב פרמטר זה עם הפרמטר ‎-s.
‎-n
הצגה של חיבורי TCP פעילים. עם זאת, כתובות ומספרי יציאות מבוטאים בצורה מספרית ולא מתבצע ניסיון לקביעת שמות.
‎-o
הצגה של חיבורי TCP פעילים וכלילת מזהה התהליך (PID) עבור כל חיבור. באפשרותך לאתר את היישום לפי ה- PID בכרטיסיה Processes במנהל המשימות של Windows. ניתן לשלב פרמטר זה עם הפרמטרים ‎-a‏, ‎-n וכן ‎-p.
‎-p Protocol
הצגת החיבורים עבור הפרוטוקול שצוין באמצעות הפרמטר Protocol. במקרה זה, Protocol עשוי להיות tcp‏, udp‏, tcpv6 או udpv6. אם נעשה שימוש בפרמטר זה עם ‎-s כדי להציג נתונים סטטיסטיים לפי פרוטוקול, Protocol עשוי להיות tcp‏, udp‏, icmp‏, ip‏, tcpv6‏, udpv6‏, icmpv6 או ipv6.
‎-s
הצגת נתונים סטטיסטיים לפי פרוטוקול. כברירת מחדל, נתונים סטטיסטיים מוצגים עבור הפרוטוקולים TCP‏, UDP‏, ICMP ו- IP. אם הפרוטוקול IPv6 for Windows XP מותקן במחשב, מוצגים נתונים סטטיסטיים עבור הפרוטוקולים TCP over IPv6‏, UDP over IPv6‏, ICMPv6 ו- IPv6. ניתן להשתמש בפרמטר ‎-p כדי לציין קבוצת פרוטוקולים.
‎-r
הצגת התוכן של טבלת ניתוב IP. פקודה זו שקולה לפקודה route print.
Interval
הצגה חוזרת של המידע הנבחר כל Interval שניות. הקש CTRL+C כדי להפסיק את ההצגה החוזרת. אם תשמיט פרמטר זה, הפקודה netstat תציג את המידע פעם אחת בלבד.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • לפני פרמטרים שנעשה בהם שימוש עבור פקודה זו יש לציין מקף (-) ולא קו נטוי (/).
  • הפקודה Netstat מספקת נתונים סטטיסטיים עבור הפריטים שלהלן:
    • Proto

      שם הפרוטוקול (TCP או UDP).

    • Local Address

      כתובת ה- IP של המחשב המקומי ומספר היציאה שנעשה בהם שימוש. שם המחשב המקומי המתאים לכתובת ה- IP ושם היציאה יוצגו אלא אם צוין הפרמטר ‎-n. אם טרם נוצרה יציאה, מספר היציאה מוצג ככוכבית (*).

    • Foreign Address

      כתובת ה- IP ומספר היציאה של המחשב המרוחק שחובר אליו ה- Socket. השמות המתאימים לכתובת ה- IP וליציאה יוצגו אלא אם צוין הפרמטר ‎-n. אם טרם נוצרה יציאה, מספר היציאה מוצג ככוכבית (*).

    • (state)

      ציון המצב של חיבור TCP. המצבים האפשריים הם:

      CLOSE_WAIT

      CLOSED

      ESTABLISHED

      FIN_WAIT_1

      FIN_WAIT_2

      LAST_ACK

      LISTEN

      SYN_RECEIVED

      SYN_SEND

      TIMED_WAIT

      • לקבלת מידע נוסף אודות מצבים של חיבור TCP, ראה RFC 793.

  • פקודה זו זמינה רק אם הפרוטוקול Internet Protocol ‏(TCP/IP) הותקן כרכיב במאפיינים של מתאם רשת בחיבורי רשת.

דוגמאות

כדי להציג את הנתונים הסטטיסטיים עבור Ethernet וגם את הנתונים הסטטיסטיים עבור כל הפרוטוקולים, הקלד את הפקודה הבאה:

netstat -e -s

כדי להציג את הנתונים הסטטיסטיים עבור הפרוטוקולים TCP ו- UDP בלבד, הקלד את הפקודה הבאה:

netstat -s -p tcp udp

כדי להציג חיבורי TCP פעילים ואת מזהי התהליך כל 5 שניות, הקלד את הפקודה הבאה:

nbtstat -o 5

כדי להציג חיבורי TCP פעילים ואת מזהי התהליך בצורה מספרית, הקלד את הפקודה הבאה:

nbtstat -n -o


Nlsfunc

טעינת מידע ייחודי עבור מדינה/אזור. XOX

תחביר

nlsfunc [[Drive:][Path][FileName]]‎

פרמטרים

‎[[Drive:][Path][FileName]]‎
ציון הקובץ המכיל את המידע הייחודי עבור מדינה/אזור.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • XOX
  • XOX


Nslookup

הצגת מידע שבאפשרותך להשתמש בו כדי לאבחן את התשתית של Domain Name System ‏(DNS). לפני השימוש בכלי זה, עליך להכיר את אופן הפעולה של DNS. כלי שורת הפקודה Nslookup זמין רק אם התקנת את הפרוטוקול TCP/IP.

תחביר

nslookup [-SubCommand ...]‎ ‎[{ComputerToFind|‎ ‎[-Server]}]‎

פרמטרים

‎-SubCommand ...‎
ציון פקודת משנה אחת או יותר של nslookup כאפשרות של שורת פקודה. לקבלת רשימה של פקודות משנה, ראה נושאים קרובים.
ComputerToFind
חיפוש מידע עבור ComputerToFind באמצעות שרת שמות DNS המהווה את ברירת המחדל הנוכחית, אם לא צוין כל שרת אחר. כדי לחפש מחשב שאינו בקבוצת המחשבים הנוכחית של DNS, צרף נקודה לשם.
‎-Server
קביעה כי יש להשתמש בשרת זה כשרת שמות DNS. אם תשמיט את ‎-Server, ייעשה שימוש בשרת שמות DNS המהווה ברירת מחדל.
‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.

הערות

  • אם ComputerToFind הוא כתובת IP והשאילתה היא עבור סוג רשומה מסוג A או PTR של משאב, שם המחשב מוחזר. אם ComputerToFind הוא שם שאינו מסתיים בנקודה, מצורף לשם זה שם ברירת המחדל עבור קבוצת מחשבים מסוג DNS. אופן פעולה זה תלוי במצב של פקודות המשנה הבאות של set:‏ domain,‏ srchlist,‏ defname ו- search.
  • אם תקליד מקף (-) במקום ComputerToFind, שורת הפקודה עוברת למצב nslookup אינטראקטיבי.
  • האורך המירבי של שורת הפקודה הוא 256 תווים.
  • ב- Nslookup קיימים שני מצבים: אינטראקטיבי ולא אינטראקטיבי.

    אם עליך לחפש פריט נתונים יחיד, השתמש במצב לא אינטראקטיבי. עבור הפרמטר הראשון, הקלד את השם או את כתובת ה- IP של המחשב שברצונך לחפש. עבור הפרמטר השני, הקלד את השם או את כתובת ה- IP של שרת שמות DNS. אם תשמיט את הארגומנט השני, הכלי nslookup יעשה שימוש בשרת שמות DNS המשמש כברירת מחדל.

    אם עליך לחפש מספר פריטי נתונים, באפשרותך להשתמש במצב אינטראקטיבי. הקלד מקף (-) עבור הפרמטר הראשון ושם או כתובת IP של שרת שמות DNS עבור הפרמטר השני. לחלופין, השמט את שני הפרמטרים והכלי nslookup יעשה שימוש בשרת שמות DNS המשמש כברירת מחדל. להלן מספר עצות לגבי עבודה במצב אינטראקטיבי:

    • כדי להפסיק פקודות אינטראקטיביות בכל עת, הקש CTRL+B.
    • לשם יציאה, הקלד exit.
    • כדי להתייחס לפקודה מוכללת כאל שם מחשב, הקלד תו Escape ‏(\) לפני הפקודה.
    • ההתייחסות לפקודה לא מזוהה היא כאל שם מחשב.
  • אם בקשת החיפוש כושלת, הכלי nslookup מפיק הודעת שגיאה. הטבלה הבאה מציגה הודעות שגיאה אפשריות.
    הודעת שגיאה | תיאור
    Timed out | השרת לא הגיב לבקשה לאחר פרק זמן מסוים ומספר נסיונות מסוים. באפשרותך לקבוע את משך הזמן באמצעות פקודת המשנה set timeout. באפשרותך לקבוע את מספר הנסיונות החוזרים באמצעות פקודת המשנה set retry.
    No response from server | במחשב השרת לא פועל שרת שמות DNS.
    No records | לשרת שמות DNS אין רשומות משאבים של סוג השאילתה הנוכחי עבור המחשב, למרות ששם המחשב חוקי. סוג השאילתה מצוין באמצעות הפקודה set querytype.
    Nonexistent domain | שם המחשב או שם קבוצת המחשבים של DNS אינו קיים.
    Connection refused

    -או-

    Network is unreachable

             לא ניתן ליצור התקשרות לשרת שמות DNS או לשרת Finger. שגיאה זו מתרחשת בדרך כלל עם בקשות ls ובקשות finger.
    Server failure | שרת שמות DNS זה נתקל בחוסר עקביות פנימי במסד הנתונים שלו ולא היתה אפשרות להחזיר תשובה חוקית.
    Refused | לשרת שמות DNS זה לא היתה אפשרות לבצע שירות עבור הבקשה.
    Format error | שרת שמות DNS מצא כי מנת הבקשה לא היתה בתבנית המתאימה. הודעה זו עשויה להצביע על שגיאה ב- nslookup.
  • לקבלת מידע נוסף אודות הפקודה nslookup ו- DNS, עיין במקורות הבאים:

    • אתר האינטרנט של Microsoft Windows Resource Kits ‏(http://www.microsoft.com/‎)

    • Lee, T., Davies, J. 2000. Microsoft Windows 2000 TCP/IP Protocols and Services Technical Reference. Redmond, Washington: Microsoft Press.‎
    • Albitz, P., Loukides, M. and C. Liu. 1998. DNS and BIND, Third Edition. Sebastopol, California: O'Reilly and Associates, Inc.‎

דוגמאות

כל אפשרות של שורת פקודה מורכבת ממקף (-) שמייד אחריו מופיע שם הפקודה, ובמקרים מסוימים סימן שוויון (=) ולאחריו ערך. לדוגמה, כדי לשנות את סוג השאילתה המשמש כברירת מחדל לשאילתת מידע של מחשב מארח ולשנות את פרק הזמן הקצוב ההתחלתי ל- 10 שניות, הקלד:

nslookup -querytype=hinfo -timeout=10


פקודות משנה של Nslookup

לקבלת מידע נוסף, לחץ על פקודה:

  • Nslookup: exit
  • Nslookup: finger
  • Nslookup: help
  • Nslookup: ls
  • Nslookup: lserver
  • Nslookup: root
  • Nslookup: server
  • Nslookup: set
  • Nslookup: set all
  • Nslookup: set class
  • Nslookup: set d2
  • Nslookup: set debug
  • Nslookup: set defname
  • Nslookup: set domain
  • Nslookup: set ignore
  • Nslookup: set port
  • Nslookup: set querytype
  • Nslookup: set recurse
  • Nslookup: set retry
  • Nslookup: set root
  • Nslookup: set search
  • Nslookup: set srchlist
  • Nslookup: set timeout
  • Nslookup: set type
  • Nslookup: set vc
  • Nslookup: view


Nslookup: exit

יציאה מ- nslookup.

תחביר

exit

פרמטרים

‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.


Nslookup: finger

קישור עם שרת Finger במחשב הנוכחי.

תחביר

finger [UserName] [{[>] FileName|[>>] FileName}]‎

פרמטרים

UserName
ציון שם המשתמש שיש לחפש.
FileName
ציון שם הקובץ שבו יישמר הפלט. באפשרותך להשתמש בסימן גדול מ- (<) או בסימן גדול מ- כפול (<<) כדי לבצע ניתוב מחדש של פלט באופן הרגיל.
‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.

הערות

  • המחשב הנוכחי מוגדר כשבדיקה קודמת עבור מחשב בוצעה בהצלחה והחזירה מידע כתובת. לקבלת מידע נוסף אודות פקודת המשנה set querytype, ראה נושאים קרובים.


Nslookup: help

הצגת סיכום קצר של פקודות משנה של nslookup.

תחביר

‎{help|?}‎

פרמטרים

‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.


Nslookup: ls

פירוט מידע עבור קבוצת מחשבים של Domain Name System ‏(DNS).

תחביר

ls ‎[Option] DNSDomain [{[>] FileName|[>>] FileName}]‎

פרמטרים

Option
הטבלה הבאה מפרטת אפשרויות חוקיות.
אפשרות | תיאור
‎-t QueryType | פירוט כל הרשומות מהסוג שצוין. לקבלת תיאור של QueryType, ראה set querytype בנושאים קרובים.
‎-a | פירוט כינויים של מחשבים בקבוצת המחשבים של DNS. פרמטר זה שקול ל- ‎-t CNAME.
‎-d | פירוט כל הרשומות עבור קבוצת המחשבים של DNS. פרמטר זה שקול ל- ‎-t ANY.
‎-h | פירוט של מידע CPU ושל מידע מערכת הפעלה עבור קבוצת המחשבים של DNS. פרמטר זה שקול ל- ‎-t HINFO.
‎-s | פירוט שירותים מוכרים של מחשבים בקבוצת המחשבים של DNS. פרמטר זה שקול ל- ‎-t WKS.
DNSDomain
ציון קבוצת המחשבים של DNS שרצונך במידע עבורה.
FileName
ציון שם הקובץ שבו יישמר הפלט. באפשרותך להשתמש בסימן גדול מ- (<) או בסימן גדול מ- כפול (<<) כדי לבצע ניתוב מחדש של פלט באופן הרגיל.
‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.

הערות

  • הפלט המשמש כברירת מחדל מכיל שמות מחשבים ואת כתובות ה- IP שלהם. כאשר מתבצע ניתוב של פלט לקובץ, מודפסים סימני סולמית (#) עבור כל 50 רשומות המתקבלות מהשרת.
XOX נושאים קרובים


Nslookup: lserver

שינוי השרת המשמש כברירת מחדל לקבוצת המחשבים של ה- DNS שצוין.

תחביר

lserver DNSDomain

פרמטרים

DNSDomain
ציון קבוצת המחשבים החדשה של DNS עבור השרת המשמש כברירת מחדל.
‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.

הערות

  • הפקודה lserver עושה שימוש בשרת ההתחלתי כדי לחפש מידע אודות קבוצת המחשבים של DNS שצוינה. פקודה זו מנוגדת לפקודה server, העושה שימוש בשרת המשמש כברירת המחדל הנוכחית.


Nslookup: root

שינוי השרת המשמש כברירת מחדל לשרת עבור בסיס טווח השמות של קבוצת המחשבים של Domain Name System ‏(DNS).

תחביר

root

פרמטרים

‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.

הערות

  • נכון לעכשיו, שרת השמות ns.nic.ddn.mil נמצא בשימוש. פקודה זו שקולה ל- lserver ns.nic.ddn.mil. באפשרותך לשנות את השם של שרת הבסיס באמצעות הפקודה set root.


Nslookup: server

שינוי השרת המשמש כברירת מחדל לקבוצת המחשבים של Domain Name System ‏(DNS) שצוינה.

תחביר

server DNSDomain

פרמטרים

DNSDomain
נדרש. ציון קבוצת המחשבים החדשה של DNS עבור השרת המשמש כברירת מחדל.
‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.

הערות

  • הפקודה server עושה שימוש בשרת המשמש כברירת המחדל הנוכחית כדי לחפש את המידע אודות קבוצת המחשבים של DNS שצוינה. פקודה זו מנוגדת לפקודה lserver, העושה שימוש בשרת ההתחלתי.


Nslookup: set

שינוי הגדרות התצורה המשפיעות על אופן הפעולה של חיפושים.

תחביר

set KeyWord[=Value]‎

פרמטרים

KeyWord
זיהוי פקודות משנה הנגזרות מפקודת המשנה set. לדוגמה, בפקודת המשנה set d2 קיימת מילת המפתח ‎[no]d2. לקבלת רשימה של פקודות משנה הנגזרות מפקודת המשנה set, ראה נושאים קרובים.
Value
ציון ערך הגדרת התצורה של Nslookup עבור כל פקודת משנה.
‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.

הערות

  • השתמש בפקודה set all כדי להציג פירוט של ההגדרות הנוכחיות.


Nslookup: set all

הדפסת הערכים הנוכחיים של הגדרות התצורה.

תחביר

set all

פרמטרים

‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.

הערות

  • באמצעות Set all ניתן גם להדפיס מידע אודות השרת והמחשב המשמשים כברירת מחדל (כלומר, המארח).


Nslookup: set class

שינוי מחלקת השאילתה. המחלקה מציינת את קבוצת הפרוטוקול של המידע.

תחביר

set cl[ass]=Class

פרמטרים

Class
המחלקה המשמשת כברירת מחדל היא IN. הטבלה הבאה מפרטת את הערכים החוקיים עבור פקודה זו.
ערך | תיאור
IN | ציון מחלקת האינטרנט.
CHAOS | ציון מחלקת ה- Chaos.
HESIOD | ציון המחלקה של MIT Athena Hesiod.
ANY | ציון כל אחד מהתווים הכלליים שפורטו לעיל.
‎{help | ?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.


Nslookup: set d2

הפעלה או ביטול של מצב איתור הבגים המקיף. כל השדות של כל מנה מודפסים.

תחביר

set [no]d2

פרמטרים

nod2
ביטול של מצב איתור באגים מקיף. התחביר המשמש כברירת מחדל הוא nod2.
d2
הפעלה של מצב איתור באגים מקיף.
‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.


Nslookup: set debug

הפעלה או ביטול של מצב איתור הבגים.

תחביר

set [no]deb[ug]‎

פרמטרים

nodeb[ug]‎
ביטול של מצב איתור באגים. התחביר המשמש כברירת מחדל הוא nodebug.
deb[ug]‎
הפעלה של מצב איתור באגים.
‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.

הערות

  • כשמצב איתור הבאגים מופעל, מידע רב יותר מודפס אודות המנה הנשלחת אל השרת ואודות התשובה המתקבלת.


Nslookup: set defname

צירוף שם קבוצת המחשבים של Domain Name System ‏(DNS) המשמשת כברירת מחדל לבקשת חיפוש של רכיב יחיד. רכיב יחיד הוא רכיב שאינו מכיל נקודות.

תחביר

set [no]def[name]‎

פרמטרים

nodef[name]‎
הפסקת צירוף שם קבוצת המחשבים של Domain Name System‏ (DNS) לבקשת חיפוש של רכיב יחיד.
def[name]‎
צירוף שם קבוצת המחשבים של Domain Name System ‏(DNS) המשמשת כברירת מחדל לבקשת חיפוש של רכיב יחיד. התחביר המשמש כברירת מחדל הוא defname.
‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.


Nslookup: set domain

שינוי שם קבוצת המחשבים של Domain Name System ‏(DNS) המשמשת כברירת מחדל לשם שצוין.

תחביר

set do[main]=DomainName

פרמטרים

DomainName
ציון שם חדש עבור שם קבוצת המחשבים של DNS המשמשת כברירת מחדל. שם קבוצת המחשבים המשמשת כברירת מחדל הוא שם המארח.
‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.

הערות

  • שם קבוצת המחשבים של DNS המשמשת כברירת מחדל מצורף לבקשת חיפוש בהתאם למצב של האפשרויות defname ו- search. רשימת החיפוש של קבוצת המחשבים של DNS מכילה את האבות של קבוצת המחשבים של DNS המשמשת כברירת מחדל, אם קיימים בשמה שני רכיבים לפחות. לדוגמה, אם קבוצת המחשבים של DNS המשמשת כברירת מחדל היא mfg.widgets.com, השם של רשימת החיפוש יהיה mfg.widgets.com וגם widgets.com. השתמש בפקודה set srchlist כדי לציין רשימה אחרת ובפקודה set all כדי להציג את הרשימה.


Nslookup: set ignore

התעלמות משגיאות חיתוך של מנה.

תחביר

set [no]ig[nore]‎

פרמטרים

noig[nore]‎
אין להתעלם משגיאות חיתוך של מנה. ההגדרה המשמשת כברירת מחדל היא noignore.
ig[nore]‎
התעלמות משגיאות חיתוך של מנה.
‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.


Nslookup: set port

שינוי יציאת TCP/UDP המהווה ברירת מחדל עבור שרת שמות DNS לערך שצוין.

תחביר

set po[rt]=Port

פרמטרים

Port
ציון הערך החדש עבור יציאת TCP/UDP המהווה ברירת מחדל של שרת שמות DNS. היציאה המהווה ברירת המחדל היא 53.
‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.


Nslookup: set querytype

שינוי הסוג של רשומת המשאב עבור השאילתה.

תחביר

set q[uerytype]=ResourceRecordType

פרמטרים

ResourceRecordType
ציון סוג רשומה של משאב DNS. סוג רשומת המשאב המהווה ברירת מחדל הוא A. הטבלה הבאה מפרטת את הערכים החוקיים עבור פקודה זו.
ערך | תיאור
A | ציון כתובת IP של מחשב.
ANY | ציון כל סוגי הנתונים.
CNAME | ציון של שם קאנוני עבור כינוי.
GID | ציון מזהה קבוצתי של שם קבוצה.
HINFO | ציון CPU וסוג מערכת הפעלה של מחשב.
MB | ציון שם קבוצת מחשבים של תיבת דואר.
MG | ציון חבר בקבוצת דואר.
MINFO | ציון מידע של תיבת דואר או של רשימת דואר.
MR | ציון שם קבוצת המחשבים של שינוי שם דואר.
MX | ציון מחליף הדואר.
NS | ציון שרת שמות DNS עבור האזור הנקוב.
PTR | ציון שם מחשב אם השאילתה היא כתובת IP; אם לא, ציון המצביע למידע אחר.
SOA | ציון תחילת ההרשאה עבור אזור DNS.
TXT | ציון מידע הטקסט.
UID | ציון מזהה המשתמש.
UINFO | ציון מידע המשתמש.
WKS | תיאור של שירות מוכר.
‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.

הערות

  • הפקודה set type מבצעת פעולה זהה לזו של הפקודה set querytype.
  • לקבלת מידע נוסף אודות סוגים של רשומות משאב, עיין במסמך RFC מספר 1035.


Nslookup: set recurse

פקודה זו מורה לשרת שמות Domain Name System ‏(DNS) לבצע שאילתה על שרתים אחרים אם המידע אינו קיים בו.

תחביר

set [no]rec[urse]‎

פרמטרים

norec[urse]‎
שימוש בפרמטר זה מונע משרת שמות DNS לבצע שאילתות על שרתים אחרים במקרה שהמידע המבוקש אינו קיים בו.
rec[urse]‎
שימוש בפרמטר זה מורה לשרת שמות DNS לבצע שאילתה על שרתים אחרים אם המידע אינו קיים בו. התחביר המשמש כברירת המחדל הוא recurse.
‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.


Nslookup: set retry

הגדרת מספר הנסיונות החוזרים.

תחביר

set ret[ry]=number

פרמטרים

number
ציון הערך החדש עבור מספר הנסיונות החוזרים. כברירת מחדל, מספר הנסיונות החוזרים הוא 4.
‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.

הערות

  • כאשר מענה לבקשה אינו מתקבל בתוך פרק זמן מסוים, פרק הזמן הקצוב מוכפל והבקשה נשלחת מחדש. ערך הניסיון החוזר קובע כמה פעמים תישלח הבקשה מחדש. באפשרותך לשנות את ערכו של פרק הזמן הקצוב באמצעות פקודת המשנה set timeout.


Nslookup: set root

שינוי השם של שרת הבסיס המשמש עבור שאילתות.

תחביר

set ro[ot]=RootServer

פרמטרים

RootServer
ציון השם החדש עבור שרת הבסיס. ערך ברירת המחדל הוא ns.nic.ddn.mil.
‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.

הערות

  • פקודת המשנה set root משפיעה על פקודת המשנה root.


Nslookup: set search

צירוף שמות קבוצת המחשבים של Domain Name System ‏(DNS) שברשימת החיפוש של קבוצת המחשבים של DNS לבקשה עד לקבלת תשובה. אפשרות זו תחול כאשר הערכה ובקשת החיפוש מכילות לפחות נקודה אחת, אך אינן מסתיימות בנקודה.

תחביר

set [no]sea[rch]‎

פרמטרים

nosea[rch]‎
הפסקת צירוף לבקשה של שמות קבוצות המחשבים של DNS שברשימת החיפוש של קבוצת המחשבים של DNS.
sea[rch]‎
צירוף לבקשה של שמות קבוצת המחשבים של DNS שברשימת החיפוש של קבוצת המחשבים של DNS עד לקבלת תשובה. התחביר המשמש כברירת מחדל הוא search.
‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.


Nslookup: set srchlist

שינוי שם ורשימת חיפוש של קבוצת המחשבים של Domain Name System‏ (DNS) המשמשת כברירת מחדל.

תחביר

Set srchl[ist]=DomainName[/...]‎

פרמטרים

DomainName
ציון שמות חדשים עבור קבוצת המחשבים של DNS המשמשת כברירת מחדל ועבור רשימת החיפוש המשמשת כברירת מחדל. הערך של שם קבוצת המחשבים המשמשת כברירת מחדל מבוסס על שם המחשב המארח. באפשרותך לציין עד שישה שמות מופרדים באמצעות קוים נטויים (/).
‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.

הערות

  • הפקודה set srchl גוברת על שם קבוצת המחשבים של DNS ועל רשימת החיפוש המשמשות כברירת המחדל של הפקודה set domain. השתמש בפקודה set all כדי להציג את הרשימה.

דוגמאות

כדי לקבוע את קבוצת המחשבים של DNS ל- mfg.widgets.com ואת רשימת החיפוש לשלושת השמות, הקלד:

set srchlist=mfg.widgets.com/mrp2.widgets.com/widgets.com


Nslookup: set timeout

שינוי הערך ההתחלתי של מספר השניות עבור המתנה למענה על בקשה.

תחביר

set ti[meout]=Number

פרמטרים

Number
ציון מספר השניות שבמהלכן יש להמתין לתגובה. מספר השניות המשמש כברירת מחדל להמתנה הוא 5.
‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.

הערות

  • כאשר תגובה לבקשה אינה מתקבלת בתוך פרק הזמן שצוין, פרק הזמן הקצוב מוכפל והבקשה נשלחת שוב. באפשרותך להשתמש בפקודה set retry כדי לקבוע את מספר הנסיונות החוזרים.


Nslookup: set type

שינוי הסוג של רשומת המשאב עבור השאילתה.

תחביר

set ty[pe]=ResourceRecordType

פרמטרים

ResourceRecordType
ציון סוג הרשומה של משאב DNS. סוג רשומת המשאב המשמש כברירת מחדל הוא A. הטבלה הבאה מפרטת את הערכים החוקיים עבור פקודה זו.
ערך | תיאור
A | ציון כתובת IP של מחשב.
ANY | ציון כל סוגי הנתונים.
CNAME | ציון של שם קאנוני עבור כינוי.
GID | ציון מזהה קבוצתי של שם קבוצה.
HINFO | ציון CPU וסוג מערכת הפעלה של מחשב.
MB | ציון שם קבוצת מחשבים של תיבת דואר.
MG | ציון חבר בקבוצת דואר.
MINFO | ציון מידע של תיבת דואר או של רשימת דואר.
MR | ציון שם קבוצת המחשבים של שינוי שם דואר.
MX | ציון מחליף הדואר.
NS | ציון שרת שמות DNS עבור האזור הנקוב.
PTR | ציון שם מחשב אם השאילתה היא כתובת IP; אם לא, ציון המצביע למידע אחר.
SOA | ציון תחילת ההרשאה עבור אזור DNS.
TXT | ציון מידע הטקסט.
UID | ציון מזהה המשתמש.
UINFO | ציון מידע המשתמש.
WKS | תיאור של שירות מוכר.
‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.

הערות

  • הפקודה set type מבצעת פעולה זהה לזו של הפקודה set querytype.
  • לקבלת מידע נוסף אודות סוגים של רשומת משאב, עיין במסמך RFC שמספרו 1035.


Nslookup: set vc

פקודה זו מציינת אם יש לעשות שימוש במעגל וירטואלי בעת שליחת בקשות לשרת.

תחביר

set [no]v[c]‎

פרמטרים

nov[c]‎
ציון כי לעולם אין לעשות שימוש במעגל וירטואלי בעת שליחת בקשות לשרת. ברירת המחדל היא novc.
v[c]‎
ציון כי תמיד יש לעשות שימוש במעגל וירטואלי בעת שליחת בקשות לשרת.
‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.


Nslookup: view

מיון ופירוט הפלט של פקודות או פקודות משנה קודמות מסוג ls.

תחביר

view FileName

פרמטרים

FileName
ציון שם הקובץ המכיל פלט מפקודות או פקודות משנה קודמות מסוג ls.
‎{help|?}‎
הצגת סיכום קצר של פקודות משנה של nslookup.


Logman
גרפיקה של Microsoft Windows

Logman

מנהלת ומתזמנת את מונה הביצועים ואת האוספים של יומני מעקב האירועים במחשב המקומי ובמחשבים מרוחקים.

פעלים תחביריים

Logman [create {counter | trace} collection_name ‎] [start collection_name] [stop collection_name] [delete collection_name] [query {collection_name|providers}] [update collection_name]‎

פרמטרים

create {counter | trace} collection_name
יצירת שאילתות אוסף עבור אוספי מונים או אוספי מעקב. באפשרותך להשתמש באפשרויות של שורת הפקודה כדי לציין את ההגדרות.
start collection_name
הפעלה של שאילתת אוסף הנתונים collection_name. השתמש באפשרות זו כדי לעבור מאוספים מתוזמנים לאוספים ידניים. השתמש בפרמטר update בשורת הפקודה עם זמן התחלה (‎-b), זמן סיום (‎-e) או זמן חזרה (‎-rt) כדי לתזמן אוספים מחדש.
stop collection_name
עצירה של שאילתת אוסף הנתונים collection_name. השתמש באפשרות זו כדי לעבור מאוספים מתוזמנים לאוספים ידניים. השתמש בפרמטר update בשורת הפקודה עם זמן התחלה (‎-b), זמן סיום (‎-e) או זמן חזרה (‎-rt) כדי לתזמן אוספים מחדש.
delete collection_name
מחיקה של שאילתת אוסף הנתונים collection_name. אם אין בנמצא collection_name, תתקבל שגיאה.
query {collection_name|providers}‎
אם לא צוין הפרמטר collection_name או הפרמטר providers (ספקים), יוצג הססטוס של כל שאילתות האוסף הקיימות. השתמש ב- collection_name כדי להציג את המאפיינים של אוסף מסוים. להצגת המאפיינים של מחשבים מרוחקים, השתמש באפשרות ‎-s‎ remote computer בשורת הפקודה. השתמש ב- providers כמילת המפתח במקום collection_name כדי להציג את הספקים הרשומים המותקנים במחשב המקומי. כדי להציג את הספקים הרשומים המותקנים במחשב המרוחק, השתמש באפשרות ‎-s‎ בשורת הפקודה.
update collection_name
עדכון של שאילתות אוסף עבור אוספי מונים ואוספי מעקב. עבור אוספי מונים, שינויים הנערכים בשאילתה ייפסקו, ולאחר מכן יופעלו האוספים מחדש. עבור אוספי מעקב, השתמש בפרמטרים הבאים בשורת הפקודה כדי לבצע שאילתה מבלי לעצור את האוסף: ‎-p‎ provider [(flags[,flags ...])] Level,‏ ‎- max n, ‏‎- o PathName, ‏‎-ft mm:ss או ‏‎-fd.

אפשרויות תחביר

‎[‎-s‎ computer_name] [-config FileName] [-b M/d/yyyy h:mm:ss[AM | PM]]‎ ‎[‎-e M/d/yyyy h:mm:ss[AM | PM]] [‎-m [start] [stop]] ‎[-[-]r] [‎‎-o {Path | DSN!counter_log}] [-f {bin | bincirc | csv | tsv | SQL}] [-[-]a] [-[-]v [{nnnnn | mmddhhmm}]] ‎[-[-] rc [FileName]] ‎[-[-] max {value}] ‎[-[-]cnf [[[hh:]]mm:]ss] [‎-c {Path [path ...] | ‎-cf FileName}] [‎-si [[hh:]mm:]ss] [‎-ln logger_name] [-ets] [-[-] rt] [-p {GUID | provider [(flags [,flags...]}] Level | -pf FileName}] [-[-] ul] [-bs value] [-ft [[hh:]mm:]ss] [-nb min max] [-fd logger name] [-[-]u user password] [-rf [[hh:]mm:]ss] [-y] [-mode ‎{trace_mode [trace_mode]}]‎

פרמטרים

‎-s computer_name
הוראה לבצע את הפקודות create‏, start‏, stop‏, delete‏, query או update במחשב המרוחק. ברירת מחדל היא לעשות שימוש במחשב המקומי עבור פקודות.
‎-config FileName
ציון שם הנתיב של קובץ ההגדרות המכיל פרמטרים של שורת פקודה.
‎-b M/d/yyyy h:mm:ss[AM | PM]‎
ציון זמן ההתחלה עבור אוספים בתבנית של 24 שעות. ניתן לציין את זמן ההתחלה עבור אוספים גם בתבנית של 12 שעות על-ידי הוספת AM או PM בשורת הפקודה. כברירת מחדל, נעשה שימוש בתאריך ובשעה הנוכחיים, אלא אם צוין אחרת. השתמש באפשרות ההפעלה הידנית להפעלת האוסף באופן מיידי.
‎-e M/d/yyyy h:mm:ss[AM | PM]‎
ציון זמן הסיום עבור אוספים בתבנית של 24 שעות. ניתן לציין את זמן הסיום גם בתבנית של 12 שעות על-ידי הוספת AM או PM בשורת הפקודה. כברירת מחדל, נעשה שימוש בתאריך ובשעה הנוכחיים, אלא אם צוין אחרת. השתמש באפשרות העצירה הידנית ולאחר מכן באפשרות החזרה אם ברצונך לציין זמן עצירה הקודם לשעה הממשית הנוכחית, או שתתקבל הודעת שגיאה.
‎-m start stop
הוראה להתחיל ולעצור אוספים באמצעות הפרמטרים start ו- stop בשורת הפקודה. לא ניתן להשתמש יחד בפרמטרים ‎-m start ו- ‎-b או בפרמטרים ‎-m stop ו- ‎-e או ‎-rf בשורת הפקודה באותה שאילתה.
‎-r
חזרה על פעולת האיסוף כל יום, בפרקי הזמן שצוינו באמצעות האפשרויות ‎-b ו-‎-rf או האפשרויות ‎-b ו-‎-e. פקודה זו חוקית רק עבור זמני התחלה וסיום החלים באותם יום, חודש ושנה.
‎--r
ביטול אפשרות החזרה.
‎-o {Path | DSN!counter_log}‎
ציון שם הנתיב של קובץ הפלט שאוסף את נתוני מוני הביצועים ואת נתוני המעקב, או את המיקום של מסד הנתונים וקבוצת הנתונים של SQL. כדי לציין SQL בתבנית DSN!counter_log, השתמש באפשרות ‎-f בשורת הפקודה. כברירת מחדל, שם הקובץ של יומן האוסף הוא שם שאילתת האוסף עם הסיומת ‎.blg עבור מוני ביצועים או ‎.etl עבור נתוני מעקב.
‎-f {bin | bincirc | csv | tsv | SQL}‎
ציון תבנית הקובץ המשמשת לאיסוף נתוני מוני ביצועים ונתוני מעקב. בעת איסוף של מוני ביצועים, באפשרותך להשתמש בתבניות בינאריות, בינאריות מעגליות, בתבניות המופרדות באמצעות פסיק או באמצעות טאב, או בתבניות של מסד הנתונים של SQL. השתמש באפשרות ‎-o בשורת הפקודה בצירוף עם האפשרות DNS!counter_log. עבור תבניות של מסד הנתונים של SQL, יש להגדיר מראש DSN ‏(Database System Name) וכן את ההרשאות עבור כתיבה למסד הנתונים. קבוצת הנתונים counter_log נוצרת במסד הנתונים ומצוינת על-ידי ה- DSN. ברירת המחדל היא תבנית בינארית.
‎-a
השתמש באפשרות זו כדי לצרף את הקובץ.
‎--a
ביטול של האפשרות לצירוף קובץ וחזרה למצב של החלפת הטקסט הקיים.
‎-v {nnnnn | mmddhhmm}‎
הוספת המידע אודות בקרת גירסה לסוף קובץ הפלט ושם הנתיב. עבור בקרת גירסה, השתמש בתבנית מספרית nnnnn, או בתבנית תאריך mmddhhmm (חודש, יום, שעה בשעון של 24 שעות, דקה).
‎--v
ביטול של אפשרות הגירסה.
‎-rc FileName
הוראה להפעיל פקודה זו לאחר סגירת הקובץ, בין אם בסוף או במהלך זמן האיסוף. השתמש באפשרות ‎-rf בצירוף עם האפשרות ‎-cnf כדי לסגור את הקבצים במהלך זמני האיסוף. שימוש באפשרות ‎-stop לא יבטל פקודה זו. הפקודות רצות תמיד ברקע.
‎--rc
ביטול של האפשרות הפעל פקודה זו.
‎-max value
ציון הגודל המירבי של קובץ יומן הרישום הנאסף, ביחידות בנות מגה-בית (MB). אם גודל קובץ היומן עובר את הגודל המירבי, פעולת האוסף תיפסק. עבור מסד נתונים של SQL, הגודל המירבי הוא מספר הרשומות שיש לכתוב.
‎--max
ביטול האפשרות של הגבלת גודל מירבי. אפשרות זו היא ברירת המחדל.
‎-cnf [[hh:]mm:]ss
יצירת קובץ חדש כאשר קבצי הפלט עוברים את הגודל המירבי, או כאשר עובר הזמן שצוין. עליך להוסיף את האפשרות ‎-v בעת ההפעלה של פקודה זו. כברירת מחדל, נוצר קובץ יומן רישום אחד בלבד עבור כל אוסף.
‎--cnf
ביטול של האפשרות ליצירת קובץ חדש.
‎-c {Path [path ...] | -cf FileName}‎
ציון הנתיב שיש לרשום עבור מונה הביצועים, או ציון שם הנתיב של קובץ הרישום המפרט מונים אלה. להצגת נתיבים של מספר מונים, הפרד את שורת הפקודה באמצעות רווח, או השתמש באפשרות ‎-cf להצגת נתיבי מונים בקובץ קלט, נתיב אחד לשורה.

התבנית הכללית לנתיבי מונים היא זו: [‎\\Computer]\object[parent/instance#index]\counter]‏, כאשר:

רכיבי התבנית parent‏, instance‏, index ו- counter מכילים שם חוקי או תו כללי. הרכיבים computer‏, parent‏, instance‏ ו- index אינם הכרחיים עבור כל המונים.

באפשרותך לקבוע את נתיבי המונים שייעשה בהם שימוש, בהתבסס על המונה עצמו. לדוגמה, לאובייקט LogicalDisk יש מופע index, כך שיש לספק ‎#index או תו כללי. לכן, ניתן להשתמש בתבנית הבאה:

‎\LogicalDisk‎(*/*#*)\*‎

לעומת זאת, האובייקט Process אינו מחייב מופע index. לכן, ניתן להשתמש בתבנית הבאה:

‎\Process(*)\ID Process

להלן רשימת התבניות האפשריות:

  • ‎\\machine\object(parent/instance#index)\counter
  • ‎\\machine\object(parent/instance)\counter
  • ‎\\machine\object(instance#index)\counter
  • ‎\\machine\object(instance)\counter
  • ‎\\machine\object\counter
  • ‎\object(parent/instance#index)\counter
  • ‎\object(parent/instance)\counter
  • ‎\object(instance#index)\counter
  • ‎\object(instance)\counter
  • ‎\object\counter

אם שם האב כולל תו כללי, יוחזרו כל מופעי האובייקט שצוין המתאימים לשדה המופע (instance) ולשדה המונה (counter).

אם שם המופע כולל תו כללי, יוחזרו כל המופעים של האובייקט שצוין ושל אובייקט האב, אם כל שמות המופעים מתאימים לאינדקס (index) שצוין לתו הכללי.

אם שם המונה כולל תו כללי, יוחזרו כל המונים של האובייקט שצוין.

לא ניתן להשתמש בהתאמות חלקיות של מחרוזות נתיבי מונים (לדוגמה, pro*‎).

‎-si [[hh:]mm:]ss
ציון מרווחי זמן מדגמיים עבור אוסף של מוני ביצועים בשעות, דקות ושניות. ברירת המחדל היא 15 שניות.
‎-ln logger_name
ציון שם עבור ההפעלה (Session) של רישום מעקב האירועים. כברירת מחדל, שם זה זהה לשם האוסף.
‎-ets
יצירה ופתיחת הפעלה של מעקב אחר אירועים, עם האפשרויות שצוינו בשורת הפקודה. ניתן להשתמש בפרמטר אופציונלי זה בצירוף עם הפרמטרים create trace‏, update‏, query ו- delete.
‎-rt
הוראה לבצע את ההפעלה של מעקב אחר אירועים במצב זמן אמת, ללא כתיבה לקובץ. כברירת מחדל, הנתונים נרשמים בקובץ.
‎--rt
ביטול האפשרות של רישום זמן אמת.
‎-p {GUID | provider [(flags[,flags ...])] Level] | -pf {FileName}‎
ציון הספקים (הרכיבים האוספים את נתוני המעקב) שיש להשתמש בהם עבור מעקב אחר אוסף נתונים. השתמש בספקים של השאילתה Logman לאיתור ה- pname (ספקים מזוהים, named providers) מתוך רשימת הספקים הרשומים. השתמש באפשרות ‎-pf להצגת מספר ספקים. האפשרות ‎-pf מזהה את קובץ הקלט המכיל את שמות הספקים. את שמות הספקים יש לתחום במרכאות ("") או לספק מזהים ייחודיים כלליים (GUID) התחומים בסוגריים מסולסלים, מסכות דגלים ומספרים שלמים (רמת זמינות). הדגלים מוצגים בתבנית הקסדצימאלית (OXFFFF) או בתבנית (flag, flag).
‎-ul
הוראה לביצוע ההפעלה של מעקב אחר אירועים במצב משתמש. אם נעשה שימוש באפשרות ‎-ul, ניתן להפעיל ספק אחד בלבד עבור ההפעלה של מעקב אחר אירועים.
‎--ul
ציון של ביטול מצב המשתמש, והוראה לבצע את ההפעלה של מעקב אחר אירועים במצב ליבה.
‎-bs value
ציון גודל המאגר עבור אוספי המעקב אחר נתונים, ב- n קילו-בתים.
‎–ft [[hh:]mm:]ss
ציון מרווח הזמן עבור ריקון בדקות ובשניות עבור אוספי מעקב אחר נתונים.
‎-nb min max
ציון המספר המזערי והמספר המירבי של מאגרים עבור אוסף מעקב אחר נתונים. המספר המזערי המהווה ברירת מחדל הוא מספר המעבדים על המחשב ועוד שתיים. המספר המירבי המהווה ברירת מחדל הוא 25.
‎-fd logger_name
ריקון לדיסק של כל המאגרים הפעילים עבור הפעלה קיימת של מעקב אחר אירועים. השתמש בפקודה זו בצירוף עם האפשרות ‎-ln.
‎-u user password
ציון של שם החשבון ושל הסיסמה שעל שאילתת האוסף לעשות בהם שימוש במחשבים מקומיים או מרוחקים. להתחלת איסוף מידע עבור שאילתות אוסף, בצע כניסה למחשב מרוחק עבור כלי השירות יומני רישום ביצועים והתראות. באפשרותך להשתמש בתו הכללי כוכבית (*) כסיסמה בשורת הפקודה כדי שתוצג בקשה להזנת סיסמה.
‎--u
איפוס שם החשבון לחשבון השירות של כלי השירות יומני רישום ביצועים והתראות.
‎–rf [[hh:]mm:]ss
הוראה להפעלת האוספים במשך פרק זמן קבוע.
‎-y
החלפת ההגדרות עבור שם האוסף ולאחר מכן החלה של הגדרות חדשות, כל זאת מבלי לבצע שאילתה אצל משתמש הקצה.
‎-mode {trace_mode [trace_mode ‎...]}‎
ציון אפשרויות מתקדמות עבור הפעלות מעקב רק כאשר trace_mode עשוי להיות globalsequence, ‏localsequence או pagedmemory‏. האפשרות globalsequence מציינת שהעוקב אחר האירועים מוסיף מספר רצף לכל אירוע המתקבל על-ידו ללא תלות בהפעלת המעקב שקיבלה את האירוע. האפשרות localsequence מציינת שהעוקב אחר האירועים מוסיף מספרי רצף לאירועים המתקבלים בהפעלת מעקב מסוימת. כאשר נעשה שימוש באפשרות localsequence, ייתכן שיימצאו מספרי רצף זהים בהפעלות שונות, אך מספרים אלה יהיו ייחודיים בתוך כל הפעלה כשלעצמה. האפשרות pagedmemory מורה לעוקב אחר האירועים לעשות שימוש בזיכרון קובץ ההחלפה עבור הקצאות המאגר הפנימיות שלו במקום באפשרות ברירת המחדל, שהיא שימוש במאגר הזיכרון שאינו בקובץ ההחלפה.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • אפשרויות חוקיות עבור פעלי שורת הפקודה create‏, update‏, start‏, stop‏, delete ו- query הן:

    ‎-s remote machine name

    ‎-[-]u Domain/username password

  • אפשרויות חוקיות עבור create ו- update ואפשרויות נפוצות עבור counter ו- trace הן:

    ‎-y

    ‎-b M/d/yyyy h:mm:ss [AM|PM]‎

    ‎-e M/d/yyyy h:mm:ss [AM|PM]‎

    ‎-rf hh:mm:ss

    ‎-m start stop

    ‎-f bin|bincirc

    ‎-[-]r

    ‎-o PathName

    ‎-[-]a

    ‎-[-]v nnnnn|mmddhhmm

    ‎-[-]rc command pathname

    ‎-[-]max n

    ‎-[-]cnf hh:mm:ss

  • אפשרויות נפוצות עבור counters בלבד הן:

    ‎-f bin|bincirc|csv|tsv|SQL

    ‎-o PathName | DSN!counter_log

  • אפשרויות נפוצות עבור create counter הן:

    ‎-c counterpath | -cf input file

    ‎-si [[hh:]mm:]ss

    אפשרויות אלה גורמות לעדכון המונה, ויביאו לעצירה ולהפעלה של פעולת האוספים.

  • אפשרויות עבור update לאוספי מעקב הן:

    ‎- max n

    ‎- o PathName

    ‎-ft mm:ss

    ‎-fd

    אפשרויות אלה גורמות לביצוע שאילתה על אוספי מעקב מבלי לעצור את האוספים.

  • אפשרויות חוקיות עם counters בלבד הן:

    ‎-f bin|bincirc|csv|tsv|SQL

    ‎-o PathName | DSN!counter_log

  • אפשרויות חוקיות עם פקודות create counter הן:

    counterpath | -cf input file

    ‎-si hh:mm:ss

  • אפשרויות חוקיות עבור פקודות create trace הן:

    ‎-ln logger name

    ‎-[-]rt

    ‎-p Guid | provider (flags[,flags ...]) level | -pf FileName

    ‎-[-]ul

    ‎-bs n

    ‎-ft mm:ss

    ‎-nb min max

    ‎-fd logger name

    ‎-ets

  • שימוש באפשרות ‎-config

    על תוכן קובץ ההגדרות, שנעשה בו שימוש עם האפשרות ‎-config, להיות בתבנית הבאה:

    ‎[command_option]‎

    value

    כאשר האפשרות command_option היא אפשרות של שורת הפקודה, ו- value מציין את הערך שלה. לדוגמה:

    ‎[create]‎

    counter logx

    ‎[-s]‎

    mysystem

    ‎[-u]‎

    mypassword

  • שימוש באפשרות ‎-mode

    אפשרות זו מיועדת למשתמשים מתקדמים בלבד.

  • ניהול צג הביצועים

    באפשרותך להשתמש בפקודה Logman לניהול מחשבים שפועלת בהם מערכת ההפעלה Windows 2000 או Windows XP בלבד.

  • למידע נוסף אודות הכללת הפקודה Logman בקבצי ה- Script של Windows Management Instrumentation ‏(WMI), ראה Scripting Logs and Monitoring באתר האינטרנט של Microsoft Windows Resource Kits ‏(http://www.microsoft.com/‎).

דוגמאות

תבניות הזמן בדוגמאות הבאות מיועדות לזמן המקומי בארה"ב בלבד.

ליצירת שאילתות יומיומיות של אוספי מונים עם זמני התחלה וזמני סיום, אוספים חוזרים, מספרי בקרת גירסה, נתיבי מונים ומרווחי זמן מדגמיים, הקלד:

Logman create counter daily_perf_log -b 7/27/2000 ‎13:00:00 ‎-e 7/27/2000 15:00:00 -r -v mmddhhmm -c ‎"\Processor(_Total)\% Processor Time" ‎"\Memory\Available bytes"‎ -si 00:15 -o ‎"c:\perflogs\daily_log"‎

ליצירת שאילתות אוספים יומיומיות עם זמני התחלה וסיום, אוספים חוזרים, אוספים של קבצי פלט, מספרי בקרת גירסה, נתיבי מונים ומרווחי זמן מדגמיים, הקלד:

Logman create counter daily_perf_log -b 7/27/2000 ‎13:00:00 -e 7/27/2000 15:00:00 -r -o ‎"c:\perflogs\daily_log" -v mmddhhmm -c "\Processor (_Total)\% Processor Time" ‎"\Memory\Available bytes" -si 00:15

ליצירת שאילתות אוסף יומיומיות באמצעות קובץ config במקום באמצעות קובץ שורת הפקודה, הקלד:

Logman -config file daily_perf.txt

ליצירת שאילתות יומיומיות של אוספי מעקב עם זמני התחלה וסיום, אוספים חוזרים, מספרי בקרת גירסה, שמות ספקים ואוספים של קבצי קלט ופלט, הקלד:

Logman create trace daily_kernel_trace_log -b ‎7/27/2000 13:00:00 -e 7/27/2000 15:00:00 -r -v mmddhhmm -p "Windows Kernel Trace" 0xFFFFFFFF -rf 100 -o "c:\perflogs\daily_nt_trace"‎

ליצירת שאילתות יומיומיות של אוספי מעקב עם זמני התחלה וסיום, אוספים חוזרים, מספרי בקרת גירסה, מזהה ייחודי כללי (GUID), שמות מבצעי כניסה ואוספים של קבצי קלט ופלט, הקלד:

Logman create trace daily_lsass_trace_log -b 7/27/2000 ‎13:00:00 -e 7/27/2000 15:00:00 -r -v mmddhhmm -p "Local Security Authority(LSA) " 0x00000001 -rf 30:00 -o " c:\perflogs\daily_lsass_trace"‎

ליצירת שאילתות יומיומיות של אוספי מונים עם זמני התחלה וסיום, אוספים חוזרים, מספרי בקרת גירסה, נתיבי מונים, מרווחי זמן מדגמיים, תבניות SQL ואוספים של קבצי פלט, הקלד:

Logman create counter daily_perf_log -b 7/27/2000 ‎13:00:00 -e 7/27/2000 15:00:00 -r -v mmddhhmm -c ‎"\Processor(_Total)\% Processor Time" ‎"\Memory\Available bytes" -si 00:15 -f sql -o perfdb!daily_log

להפעלת אוספים יומיומיים עם מרווחי זמן מדגמיים, שמות חשבונות וסיסמאות, הקלד:

Logman start daily_perf_log -s \\%computer_name% -u admin "adminpassword"‎

להפעלת אוספי מידע ידניים, הקלד:

Logman start daily_perf_log

להפסקת הפעולה של אוספי מידע, הקלד:

Logman stop daily_perf_log

למחיקת אוספי מידע, הקלד:

Logman delete daily_perf_log

להצגת המצב של שאילתות אוסף, הקלד את הפקודות הבאות:

Logman query

Logman query daily_perf_log


Perfmon

מאפשרת פתיחה של מסוף ביצועים של Windows XP, שתצורתו נקבעת באמצעות קבצי הגדרות של גירסת Windows NT 4.0 לצג הביצועים (Performance Monitor).

תחביר

perfmon.exe [file_name] [/HTMLFILE:converted_file settings_file]‎

פרמטרים

‎.exe
מציין את שם סיומת הקובץ.
file_name
מציין את שם קובץ ההגדרות.
‎/HTMLFILE:converted_file settings_file
מציין את שם הקבצים שהומרו ואת שם קובץ ההגדרות המקורי של Windows NT 4.0.

הערות

  • הליך זה ניתן ליישום עבור הסוגים הבאים של קבצי הגדרות עבור צג הביצועים של Windows NT 4.0: תרשים (‎.pmc)‏, דו"ח (‎.pmr)‏, התראה (‎.pma) ויומן רישום (‎.pml).
  • כדי להציג את קובץ ההגדרות של Windows NT 4.0 בצג המערכת, המערכת ממירה את הקובץ באופן זמני לצורך שימוש עם צג המערכת של Windows XP, ומוחקת את הגירסה המומרת עם תום הפעלת המסוף. אם ברצונך לשמור את קובץ ההגדרות לשימוש קבוע עם צג המערכת, הקלד את הפקודה הבאה:

    Perfmon [file_name] [/HTMLFILE:converted_file settings_file]‎

    כאשר ‎/HTMLFILE:converted_file מייצג את השם שניתן לקובץ שעבר המרה ו- settings_file מייצג את שם קובץ ההגדרות המקורי של Windows NT 4.0.

  • למידע נוסף אודות הכללת הפקודה Perfmon בקבצי Script של Windows Management Instrumentation ‏(WMI), ראה Scripting Logs and Monitoring באתר האינטרנט של Microsoft Windows Resource Kits ‏(http://www.microsoft.com/‎).

דוגמאות

להצגה של קובץ ההגדרות, הקלד:

Perfmon myfile_overview

לפירוט שמות קבצים מקוריים ושמות קבצים שהומרו, הקלד:

Perfmon myfile_overview /Commands:newfile_review oldfile_sample.pml


Relog

חילוץ מוני ביצועים מתוך יומנים של מוני ביצועים ושמירתם בתבניות אחרות, כגון text-TSV (טקסט המופרד באמצעות טאבים), text-CSV (טקסט המופרד באמצעות פסיקים), binary-BIN או SQL.

תחביר

relog [FileName [filename ...]] [-a] [-c Path [path ...]]‎ ‎[‎-cf FileName] [-f {bin|csv|tsv|SQL}] [-t value] [-o {output file | DSN!counter_log}] [-b M/d/yyyy [[hh:]mm:]ss] [-e M/d/yyyy [[hh:]mm:]ss] [-config FileName] [-q]‎

פרמטרים

FileName [filename ...]‎
מציין את שם הנתיב של יומן מוני ביצועים קיים. באפשרותך לציין כמה קבצי קלט.
‎-a
מצרף קובץ פלט במקום לבצע החלפה. אפשרות זו אינה חלה על תבנית SQL, שבה צירוף במקום החלפה היא האפשרות המהווה ברירת מחדל.
‎-c Path [path ...]‎
מציין את נתיב מונה הביצועים שיש לרשום. לציון מספר נתיבי מונים, הפרד את הנתיבים באמצעות רווח ותחום אותם במרכאות (לדוגמה, "CounterPath1 CounterPath2").
‎-cf FileName
מציין את שם הנתיב של קובץ הטקסט המפרט את מוני הביצועים הכלולים בקובץ יומן הרישום המחודש. השתמש באפשרות זו להצגת נתיבי מונים בקובץ קלט, נתיב אחד לשורה. ההגדרה המשמשת כברירת מחדל היא רישום מחדש ביומן של כל המונים מקובץ יומן הרישום המקורי.
‎-f {bin|csv|tsv|SQL}‎
מציין את שם הנתיב של תבנית קובץ הפלט. התבנית המשמשת כברירת מחדל היא bin. עבור מסד נתונים של SQL, קובץ הפלט מציין את DSN!counter_log. באפשרותך לציין את מיקום מסד הנתונים באמצעות מנהל ODBC לשם קביעת התצורה של DSN‏ (Database System Name).
‎-t value
מציין מרווחים מדגמיים ב- "n" רשומות. כולל כל נקודת נתונים n-ית בקובץ יומן הרישום המחודש. ברירת המחדל היא כל נקודת נתונים.
‎-o {output file | DSN!counter_log}‎
מציין את שם הנתיב של קובץ הפלט או של מסד הנתונים של SQL, שלתוכו מתבצע רישום של המונים.
‎-b M/d/yyyy hh[:mm[:ss]]‎
מציין את זמן ההתחלה להעתקת הרשומה הראשונה מקובץ הקלט. על התאריך והשעה להיות בדיוק בתבנית זו: M/d/yyyy hh:mm:ss.
‎ -e M/d/yyyy hh[:mm[:ss]]‎
מציין את זמן הסיום להעתקת הרשומה האחרונה מקובץ הקלט. על התאריך והשעה להיות בדיוק בתבנית זו: M/d/yyyy hh:mm:ss.
‎-config FileName
מציין את שם הנתיב של קובץ ההגדרות המכיל פרמטרים של שורת פקודה.
‎-q
מציג את מוני הביצועים ואת טווחי הזמן של קבצי יומן הרישום שצוינו בקובץ הקלט.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • התבנית של נתיבי מונים

    התבנית הכללית לנתיבי מונים היא ‎[\\Computer]\object[parent/instance#index]\counter]‎, כאשר:

    הרכיבים parent‏, instance‏, index ו- counter של התבנית יכולים להכיל או שם חוקי או תו כללי. הרכיבים computer‏, parent‏, instance ו- index אינם הכרחיים עבור כל המונים.

    קבע את נתיבי המונים שנעשה בהם שימוש על סמך המונה עצמו. לדוגמה, לאובייקט LogicalDisk יש מופע index, כך שיש לספק את ‎#index או תו כללי כלשהו. לכן, ניתן להשתמש בתבנית הבאה:

    ‎\LogicalDisk;(*/*#*)\*‎

    לעומת זאת, לאובייקט Process לא דרוש מופע index. לכן, ניתן להשתמש בתבנית הבאה.

    ‎\Process(*)\ID Process

    להלן רשימה של התבניות האפשריות:

    • ‎\\machine\object(parent/instance#index)\counter
    • ‎\\machine\object(parent/instance)\counter
    • ‎\\machine\object(instance#index)\counter
    • ‎\\machine\object(instance)\counter
    • ‎\\machine\object\counter
    • ‎\object(parent/instance#index)\counter
    • ‎\object(parent/instance)\counter
    • ‎\object(instance#index)\counter
    • ‎\object(instance)\counter
    • ‎\object\counter

    אם מצוין תו כללי בשם האב, יוחזרו כל המופעים של האובייקט שצוין המתאימים למופע ולשדות המונה שצוינו.

    אם מצוין תו כללי בשם המופע, יוחזרו כל המופעים של האובייקט שצוין ושל אובייקט האב אם כל שמות המופעים המתאימים לאינדקס שצוין מתאימים לתו הכללי.

    אם צוין תו כללי בשם המונה, יוחזרו כל המונים של האובייקט שצוין.

    אין תמיכה בהתאמות לפי מחרוזות של נתיבי מונים חלקיים (לדוגמה, pro*‎).

  • קבצי מונים

    קבצי מונים הם קבצי טקסט המציגים מונה אחד או יותר ממוני הביצועים ביומן הרישום הקיים. העתק את השם המלא של המונה מיומן הרישום או מפלט ‎-q בתבנית ‎[\\Computer \ object [instance] \ counter]‎. ציין נתיב מונה אחד בכל שורה.

  • העתקת מונים

    בעת הפעלתה, מעתיקה הפקודה Relog מונים שצוינו מכל רשומה בקובץ הקלט, תוך כדי המרת התבנית במידת הצורך. בקובץ המונים, מותר השימוש בנתיבים עם תווים כלליים.

  • שמירת קבוצות משנה של קבצי קלט

    השתמש בפרמטר ‎-t כדי לציין שקבצי קלט מוכנסים לתוך קבצי פלט במרווחים של כל רשומה n-ית. כברירת מחדל, הנתונים נרשמים מחדש מכל רשומה.

  • שימוש בפרמטרים ‎-b ו- ‎-e עם קבצי יומן רישום

    באפשרותך לציין שיומני הרישום של הפלט יכללו רשומות מלפני זמן ההתחלה (‎-b) כדי לספק נתונים עבור מונים הדורשים ערכי חישוב של הערך המאותחל. קובץ הפלט יכלול את הרשומות האחרונות מקבצי קלט עם חותמות זמן הקטנות מהפרמטר המציין את זמן הסיום (‎-e).

  • שימוש באפשרות ‎-config

    על תוכן קובץ ההגדרות הנמצא בשימוש עם האפשרות ‎-config להיות בתבנית הבאה:

    ‎[command_option]‎

    value

    כאשר command_option היא אפשרות של שורת הפקודה, ו- value מציין את הערך שלה. לדוגמה:

    ‎[o]‎

    output.txt

    ‎[f]‎

    csv

    ‎[t]‎

    5

  • לקבלת מידע נוסף אודות הכללת הפקודה Relog בקבצי Script של Windows Management Instrumentation ‏(WMI), ראה Scripting Logs and Monitoring באתר האינטרנט של Microsoft Windows Resource Kits.‏‎(http://www.microsoft.com/)‎

דוגמאות

לדגימה מחודשת של יומני מעקב קיימים במרווחים קבועים של 30, עם פירוט של נתיבי המונים, קבצי הפלט והתבניות, הקלד את הפקודה הבאה:

Relog c:\perflogs\daily_trace_log.blg -cf counter_file.txt ‎-o c:\perflogs\reduced_log.csv -t 30 -f csv

לדגימה מחודשת של יומני מעקב קיימים במרווחים קבועים של 30, עם פירוט של נתיבי המונים וקבצי הפלט, הקלד את הפקודה הבאה:

Relog c:\perflogs\daily_trace_log.blg -cf counter_file.txt ‎-o c:\perflogs\reduced_log.blg -t 30


Tracerpt

מעבדת יומנים של מעקב אחר אירועים או נתוני זמן אמת שהתקבלו מספקים מאושרים של מעקב אחר אירועים ומאפשרת יצירה של דו"חות ניתוח מעקב ושל קבצי CSV (המופרדים באמצעות פסיקים) עבור האירועים המתרחשים.

תחביר

tracerpt [FileName [filename ...]] [-o [FileName]]‎ ‎[-report [FileName]] [-rt session_name [session_name ...]] [‎-summary [FileName]] [-config [FileName]‎

פרמטרים

FileName [filename ...]‎
מציין את שם הקובץ עבור ההפעלה (Session) של מעקב אחר אירועים. באפשרותך לציין כמה קבצים.
‎-o [FileName]‎
מציין את שם קובץ ה- CSV (המופרד באמצעות פסיקים). אם לא צוין אף קובץ, ברירת המחדל היא dumpfile.csv ולא summary.txt.
‎-report [FileName]‎
מציין את שם קובץ הפלט של הדו"ח. ברירת המחדל היא workload.txt.
‎-rt session_name [session_name ...]‎
מקבל נתונים ממקור של נתונים בזמן אמת. לשימוש באפשרות זו, כלול את ההפעלה של מעקב אחר אירועים.
‎-summary [FileName]‎
מציין את שם קובץ הפלט של הסיכום. ברירת המחדל היא summary.txt.
‎-config FileName
מציין את שם הנתיב של קובץ ההגדרות המכיל פרמטרים של שורת פקודה. השתמש באפשרות זו לרישום אפשרויות שורת הפקודה בקובץ.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • הצגת קבצי dumpfile.csv ביישום Microsoft Excel

    פתיחת התבנית dumpfile.csv ביישום Microsoft Excel מאפשרת הצגה של האירועים בסדר כרונולוגי. הקבצים כוללים רשומות כותרת, שאחריהן מופיע טקסט המופרד באמצעות פסיקים. שדות הכותרת מפורטים להלן:

    שדה | תיאור
    TID | מזהה של הליך משנה (Thread)
    Clock time | חותמת זמן של האירוע
    Kernel (ms)‎ | זמן מעבד במצב ליבה
    User (ms)‎ | זמן מעבד במצב משתמש
    User data | חלק המשתנה של נתוני כותרת, המבוסס על המבנה Managed Object Format ‏(MOF).
    IID | מזהה המופע
    PIID | מזהה מופע האב
  • שימוש באפשרות ‎-report

    לשימוש באפשרות הדו"ח, יש לכלול בשורת הפקודה קובץ של מעקב אחר ליבה של Windows ‏("Windows Kernel Trace") וכן כל קובץ אחר של מעקב אחר אירועים. אם לא תוסיף נתונים אלה בשורת הפקודה, תתקבל הודעת שגיאה.

  • שימוש באפשרות ‎-summary

    בעת השימוש באפשרות ‎-summary, נוצר הקובץ הבא:

    Files processed | list of files
    Total buffers processed | N
    Total events processed | N
    Total events lost | N
    Start time | dd MMM yyyy hh:mm:ss.ttt
    End time | dd MMM yyyy hh:mm:ss.ttt
    Elapsed time | N sec
  • שימוש באפשרות ‎-config

    על תוכן קובץ ההגדרות, המשמש יחד עם האפשרות ‎-config, להיות בתבנית הבאה:

    ‎[command_option]‎

    value

    כאשר command_option היא אפשרות של שורת הפקודה ו- value מציין את הערך שלה. לדוגמה:

    ‎[o]‎

    output.txt

    ‎[report]‎

    report.txt

    ‎[summary]‎

    summary.txt

  • למידע נוסף אודות הכללת הפקודה Tracerpt בקבצי Script של Windows Management Instrumentation ‏(WMI), ראה Scripting Logs and Monitoring באתר האינטרנט של Microsoft Windows Resource Kits. ‏(http://www.microsoft.com/‎)


Typeperf

כתיבת הנתונים של מונה הביצועים לתוך חלון הפקודה או לתוך תבנית נתמכת של קובץ יומן רישום. להפסקת פעולת הפקודה Typeperf, הקש CTRL+C.

תחביר

Typeperf [Path [path ...]] [-cf FileName]‎ ‎[-f {csv|tsv|bin}] [-si interval] [-o FileName] [-q [object]] ‎[-qx [object]] [-sc samples] [-config FileName] [-s computer_name]‎

פרמטרים

‎-c {Path [path ...] | -cf FileName}‎
מציין את נתיב מונה הביצועים שיש לרשום. להצגת מספר נתיבי מונים, הפרד כל נתיב פקודה באמצעות רווח.
‎-cf FileName
מציין את שם הקובץ המכיל את נתיבי המונים שעליהם ברצונך לפקח, נתיב אחד לשורה.
‎-f {csv|tsv|bin}‎
מציין את תבנית קובץ הפלט. תבניות הקבצים הן csv (קבצים המופרדים באמצעות פסיקים), tsv (קבצים המופרדים באמצעות טאבים) ו- bin (בינאריים). התבנית המשמשת כברירת המחדל היא csv.
‎-si interval [mm:] ss
מציין את מרווח הזמן בין מדגמים בתבנית ‎[mm:] ss. ברירת המחדל היא שנייה אחת.
‎-o FileName
מציין את שם הנתיב של קובץ הפלט. ברירת המחדל היא stdout.
‎-q [object]‎
מציין את המונים הזמינים שאין להם מופעים ומבצע עליהם שאילתה. להצגת מונים עבור אובייקט אחד, כלול את שם האובייקט.
‎-qx [object]‎
מציין את כל המונים הזמינים שיש להם מופעים ומבצע עליהם שאילתה. להצגת המונים עבור אובייקט אחד, כלול את שם האובייקט.
‎-sc samples
מציין את מספר הדגימות שיש לאסוף. ברירת המחדל היא דגימה עד שמקיש המשתמש CTRL+C.
‎-config FileName
מציין את שם הנתיב של קובץ ההגדרות, המכיל פרמטרים של שורת פקודה.
‎-s computer_name
מציין את המחשב שיש לפקח עליו, אם לא מצוין אף שרת בנתיב המונה.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • תבנית נתיב המונה

    התבנית הכללית עבור נתיבי מונים היא ‎[\\Computer]\object[parent/instance#index]\counter]‎, כאשר:

    הרכיבים parent‏, instance‏, index ו- counter של התבנית יכולים להכיל או שם חוקי או תו כללי. הרכיבים computer‏, parent‏, instance ו- index אינם הכרחיים עבור כל המונים.

    באפשרותך לקבוע את נתיבי המונים שיש להשתמש בהם בהתבסס על המונה עצמו. לדוגמה, לאובייקט LogicalDisk יש מופע index, כך שיש לספק ‎#index או תו כללי. לכן, ניתן להשתמש בתבנית הבאה:

    ‎\LogicalDisk(*/*#*)\*‎

    לעומת זאת, האובייקט Process אינו דורש מופע index. לכן, ניתן להשתמש בתבנית הבאה:

    ‎\Process(*)\ID Process

    להלן רשימה של התבניות האפשריות

    • ‎\\machine\object(parent/instance#index)\counter
    • ‎\\machine\object(parent/instance)\counter
    • ‎\\machine\object(instance#index)\counter
    • ‎\\machine\object(instance)\counter
    • ‎\\machine\object\counter
    • ‎\object(parent/instance#index)\counter
    • ‎\object(parent/instance)\counter
    • ‎\object(instance#index)\counter
    • ‎\object(instance)\counter
    • ‎\object\counter

    אם הוזן תו כללי בשם האב, יוחזרו כל מופעי האובייקט שצוין המתאימים למופע ולשדות המונה שצוינו.

    אם צוין תו כללי בשם המופע, יוחזרו כל המופעים של האובייקט המצוין ושל אובייקט האב אם כל שמות המופעים המתאימים לאינדקס שצוין מתאימים לתו הכללי.

    אם צוין תו כללי בשם המונה, מוחזרים כל המונים של האובייקט שצוין.

    אין תמיכה בהתאמות לפי מחרוזות חלקיות של נתיבי מונים (לדוגמה, pro*‎).

  • תבניות של שאילתות

    עבור שאילתות של נתיבי מונים, השתמש בתבנית הבאה: Typeperf [{-q | -qx [\\Computer\] [object] [-o outputfile‎}]‎.

    השתמש בשורות הפקודה הבאות עבור שאילתות מלאות:

    Typeperf [\\Computer]\object[instance]\counter]‎

    Typeperf -cf input file

  • שימוש באפשרות ‎-config

    על תוכן קובץ ההגדרות הנמצא בשימוש עם האפשרות ‎-config להיות בתבנית הבאה:

    ‎[command_option]‎

    value

    כאשר command_option היא אפשרות של שורת הפקודה, ו- value מציין את הערך שלה. לדוגמה:

    ‎[-c]‎

    ‎\Windows\mypath

    ‎[-o]‎

    report.csv

    ‎[-s]‎

    mysystem

  • למידע נוסף אודות הכללת הפקודה Typeperf בקבצי Script של Windows Management Instrumentation ‏(WMI), ראה Scripting Logs and Monitoring באתר האינטרנט של Microsoft Windows Resource Kits. ‏(http://www.microsoft.com/‎)

דוגמאות

להצגת מוני המעבד והזיכרון, הקלד:

typeperf "\Memory\Available bytes" "\processor(_total)\% processor time‎"‎

להצגת מוני התהליכים של הסייר (Explorer) כל 3 שניות בתבנית קובץ הפלט CSV, הקלד:

typeperf "\Process(Explorer)\Thread Count" -si 3 -o typeperf.csv

להצגת 50 דגימות של מוני RAS במחשב Server_name, הקלד:

typeperf "\RAS port(LPT1)\Bytes Transmitted" -sc 50 -s Server_name

להצגת ערכי מונים עבור 50 דגימות של המונים המפורטים בקובץ input.txt, במרווחי זמן מדגמיים של 120 שניות, הקלד:

typeperf -cf input.txt -si 120 -sc 50 -f TSV -o domain2.tsv

לביצוע שאילתה על מונים מותקנים עם מופעים, הקלד את הפקודה הבאה. שים לב לכך שהפרמטר ‎-qx יחזיר מספר גדול הרבה יותר של מוני ביצועים יותר מאשר הפרמטר ‎-q.

typeperf -qx

לביצוע שאילתה על מוני דיסק פיזי ללא מופעים במחשב Server5 ולרישום שלהם בקובץ ששמו diskctrs.txt, הקלד:

typeperf -q \\Server5\PhysicalDisk -o diskctrs.txt


Ntbackup

בצע פעולות גיבוי בשורת פקודה או מקובץ אצווה באמצעות הפקודה ntbackup כשאחריה פרמטרים שונים.

תחביר

ntbackup backup ‎[systemstate] "@bks file name" /J {"job name"} ‎[/P {"pool name"}]‎ ‎[/G {"guid name"}]‎ ‎[/T { "tape name"}]‎ ‎[/N {"media name"}]‎ ‎[/F {"file name"}]‎ ‎[/D {"set description"}]‎ ‎[/DS {"server name"}]‎ ‎[/IS {"server name"}]‎ ‎[/A]‎ ‎[/V:{yes|no}]‎ ‎[/R:{yes|no}]‎ ‎[/L:{f|s|n}]‎ ‎[/M {backup type}]‎ ‎[/RS:{yes|no}]‎ ‎[/HC:{on|off}]‎ ‎[/SNAP:{on|off}]‎

פרמטרים

systemstate
קביעה שברצונך לגבות את נתוני מצב המערכת. בעת הבחירה באפשרות זו, ייכפה על סוג הגיבוי להפוך לרגיל או לעותק.
‎@bks file name
ציון השם של קובץ בחירת הגיבוי (קובץ ‎.bks) המשמש לפעולת גיבוי זו. על התו @ להקדים את השם של קובץ בחירת הגיבוי. קובץ בחירת גיבוי מכיל מידע אודות הקבצים והתיקיות שבחרת לגיבוי. עליך ליצור את הקובץ באמצעות גירסת מימשק המשתמש הגרפי (GUI) של תוכנית הגיבוי.
‎/J {"job name"}‎
ציון שם המשימה שישמש בקובץ יומן הרישום. שם המשימה מתאר בדרך כלל את הקבצים והתיקיות המגובים במשימת הגיבוי הנוכחית כמו גם את התאריך והשעה של גיבוי הקבצים.
‎/P {"pool name"}‎
ציון מאגר המדיות ממנו ברצונך להשתמש במדיה. זהו בדרך כלל מאגר משנה של מאגר מדיות הגיבוי, כגון 4mm DDS. בעת בחירה באפשרות זו, לא ניתן להשתמש באפשרויות שורת הפקודה ‎/A,‏ ‎/G,‏ ‎/F או ‎/T.
‎/G {"guid name"}‎
מחיקה של קלטת זו או הוספה אליה. אין להשתמש בבורר זה יחד עם ‎/P.
‎/T {"tape name"}‎
מחיקה של קלטת זו או הוספה אליה. אין להשתמש בבורר זה יחד עם ‎/P.
‎/N {"media name"}‎
ציון שם הקובץ החדש. אין להשתמש בבורר ‎/A עם בורר זה.
‎/F {"file name"}‎
נתיב ושם קובץ של דיסק לוגי. אין להשתמש בבוררים הבאים עם בורר זה: ‎/P /G /T.
‎/D {"set description"}‎
ציון תווית עבור כל ערכת גיבוי.
‎/DS {"server name"}‎
גיבוי קובץ שירותי ספריה עבור Microsoft Exchange Server.
‎/IS {"server name"}‎
גיבוי קובץ אחסון מידע עבור Microsoft Exchange Server שצוין.
‎/A
ביצוע פעולת הוספה. יש להשתמש ב- ‎/G או ב- ‎/T יחד עם בורר זה. אין להשתמש בבורר זה ביחד עם ‎/P.
‎/V:{yes|no}‎
אימות הנתונים לאחר השלמת הגיבוי.
‎/R:{yes|no}‎
הגבלת גישה לקלטת זו לבעלים או לחבר בקבוצה של מנהלים.
‎/L:{f|s|n}‎
ציון סוג קובץ יומן הרישום: f=full‏, s=summary‏, n=none (לא נוצר קובץ יומן רישום).
‎/M {backup type}‎
ציון סוג הגיבוי. עליו להיות אחד מהבאים: רגיל, עותק, משלים‏, מצטבר או יומי.
‎/RS:{yes|no}‎
גיבוי קבצי הנתונים שהועברו, הממוקמים באחסון מרוחק. אפשרות שורת הפקודה ‎/RS אינה נדרשת כדי לגבות את מסד הנתונים המקומי של אחסון נשלף (המכיל את קבצי מציין המיקום של האחסון המרוחק). בעת גיבוי של תיקיית %systemroot%, נעשה גם גיבוי אוטומטי של מסד הנתונים של האחסון הנשלף.
‎/HC:{on|off}‎
שימוש בדחיסה באמצעות חומרה, אם אפשרות זו זמינה בכונן הקלטת.
‎/SNAP:{on|off}‎
קביעה אם הגיבוי הוא עותק צל של אמצעי אחסון.
‎/M {backup type}‎
ציון סוג הגיבוי. עליו להיות אחד מהבאים: רגיל, עותק, משלים‏, מצטבר או יומי.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • אין באפשרותך לשחזר נתונים משורת הפקודה בעזרת הפקודה ntbackup.
  • האפשרויות הבאות של שורת הפקודה ייקבעו כברירת המחדל עבור מה שכבר קבעת באמצעות גירסת מימשק המשתמש הגרפי (GUI) של הגיבוי אלא אם כן הן ישונו באמצעות אפשרויות שורת הפקודה: ‎/V /R /L /M /RS /HC. לדוגמה, אם מופעלת דחיסה באמצעות חומרה בתיבת הדו-שיח אפשרויות בתוכנית הגיבוי, ייעשה בה שימוש אם לא צויינה האפשרות ‎/HC בשורת הפקודה. עם זאת, אם האפשרות ‎/HC:off צויינה בשורת הפקודה, היא תחליף את הגדרת תיבת הדו-שיח אפשרויות ולא ייעשה שימוש בדחיסה.
  • אם Windows Media Services פועל במחשב, וברצונך לגבות את הקבצים המשויכים לשירותים אלה, ראה "Running Backup with Windows Media Services" בתיעוד המקוון של Windows Media Services. עליך לעקוב אחר ההליכים המתוארים בתיעוד המקוון של Windows Media Services כדי שיהיה באפשרותך לגבות או לשחזר קבצים המשויכים ל- Windows Media Services.
  • באפשרותך לגבות את נתוני מצב המערכת במחשב מקומי בלבד. אין באפשרותך לגבות את נתוני מצב המערכת במחשב מרוחק.
  • אם תשתמש באחסון נשלף לשם ניהול מדיה או באחסון מרוחק לשם אחסון נתונים, עליך לגבות בקביעות את הקבצים הנמצאים בתיקיות הבאות:

    Systemroot‎\System32\Ntmsdata

    Systemroot‎\System32\Remotestorage

    פעולה זו תבטיח שניתן יהיה לשחזר את כל הנתונים של אחסון נשלף ושל אחסון מרוחק.

דוגמאות

דוגמה 1

הדוגמה הבאה מבצעת גיבוי רגיל בשם "My Job 1" של המיקום המשותף והמרוחק ‎\\iggy-multi\c$‎. דוגמה זו מוציאה קלטת ממאגר המדיות של הגיבוי וקוראת לקלטת "Command Line Backup 1". התיאור של משימת הגיבוי הוא "Command Line Functionality". לאחר השלמת משימת הגיבוי, מתבצע אימות של הגיבוי, הגישה אינה מוגבלת לבעלים/מנהל, רמת הרישום נקבעת לסיכום בלבד, נתוני אחסון מרוחק אינם מגובים והאפשרות דחיסה באמצעות חומרה הופכת לזמינה.

ntbackup backup \\iggy-multi\c$ /m normal /j "My Job 1" /p "Backup" /n "Command Line Backup 1" /d "Command Line Functionality" /v:yes /r:no /l:s /rs:no /hc:on

דוגמה 2

דוגמה זו מבצעת גיבוי עותק בשם "My Job 2" של הכונן המקומי D:\‎. הקבצים והתיקיות המגובים מצורפים לקלטת בשם "Command Line Backup 1". כל האפשרויות האחרות נקבעות כברירת מחדל לאלה שצוינו בתוכנית הגיבוי.

ntbackup backup d:\ /j "My Job 2" /a /t "Command Line Backup 1" /m copy

דוגמה 3

הדוגמה הבאה מבצעת גיבוי באמצעות סוג הגיבוי שצוין בתוכנית הגיבוי. הדוגמה עושה שימוש בקובץ בחירת הגיבוי בשם Commandline.bks, הממוקם בספריה C:\Program Files\Windows NT\ntbackup\data\‎ לשם בחירת הקבצים לגיבוי. משימת הגיבוי נקראת "My Job 3" והיא מחליפה את הקלטת הנקראת "Command Line Backup 1" בשם החדש "Command Line Backup 2".

ntbackup backup "@C:\Program Files\Windows NT\ntbackup\data\commandline.bks" /j "My Job 3" /t "Command Line Backup 1" /n "Command Line Backup 2"

דוגמה 4

הדוגמאות הבאות מציגות את אופן הביצוע של גיבוי לקובץ מתוך שורת הפקודה. שלוש הדוגמאות עושות שימוש בערכי ברירת המחדל של תוכנית הגיבוי עבור סוג הגיבוי, הגדרות האימות, רמת הרישום, דחיסה באמצעות חומרה וכל הגבלה אחרת. הדוגמה הראשונה מציגה את אופן הגיבוי של ‎\\iggy-multi\d$‎ לקובץ D:\Backup.bkf. הדוגמה השנייה מציגה את אופן הצירוף של אותו גיבוי לאותו הקובץ. הדוגמה השלישית מציגה את אופן החלפת הקובץ באותו גיבוי. בכל שלוש הדוגמאות ניתן להחליף את אות הכונן בשם UNC מלא (כלומר, במקום d:\backup.bkf, באפשרות המשתמש לציין את ‎\\iggy-multi\d$\backup.bkf כיעד הגיבוי).

ntbackup backup \\iggy-multi\d$ /j "Command Line Backup 4" /f "D:\backup.bkf"

ntbackup backup \\iggy-multi\d$ /j "Command Line Backup 5" /f "D:\backup.bkf" /a

ntbackup backup \\iggy-multi\d$ /j "Command Line Backup 6" /f "D:\backup.bkf"


Ntcmdprompt

הפעלת מתרגם הפקודות Cmd.exe במקום Command.com, לאחר הפעלת TSR או לאחר הפעלת שורת הפקודה מתוך יישום MS-DOS.

תחביר

ntcmdprompt

פרמטרים

‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • כאשר Command.com פועל, תכונות מסוימות של Cmd.exe אינן זמינות; לדוגמה, תצוגת Doskey של היסטוריית פקודה. אם תעדיף להפעיל את מתרגם הפקודה Cmd.exe לאחר שהפעלת TSR או שהפעלת את שורת הפקודה מתוך יישום המבוסס על MS-DOS, באפשרותך להשתמש בפקודה ntcmdprompt. עם זאת, זכור כי TSR עשוי שלא להיות זמין לשימוש בעת הפעלת Cmd.exe. באפשרותך לכלול את הפקודה ntcmdprompt בקובץ Config.nt או בקובץ ההפעלה המותאם אישית המקביל, בקובץ מידע תוכנית (PIF) של יישום.

דוגמאות

כדי לכלול את ntcmdprompt בקובץ Config.nt או בקובץ הפעלת התצורה שצוין בקובץ PIF, הקלד:

ntcmdprompt

XOX

נושאים קרובים


Ntsd

הפקודה Ntsd מצורפת לנוחותם של מפתחי תוכנה. רק מפתחי מערכות אמורים להשתמש בפקודה זו. למידע נוסף, ראה קובץ העזרה המצורף ל- NTSD.


Openfiles

ביצוע שאילתות על קבצים פתוחים או הצגתם. כמו כן, ביצוע שאילתות על קבצים שנפתחו על-ידי משתמשי הרשת, הצגתם או ניתוקם.

להצגת תחביר של פקודה, לחץ על פקודה:

openfiles disconnect

ניתוק משתמש מרוחק אחד או יותר המחובר לקבצים משותפים פתוחים.

תחביר

openfiles.exe ‎/disconnect [‎/s Computer [/u Domain\User [/p Password]‎]‎] {[‎/id OpenFileID]|[/a  UserName]|[/o OpenMode]}
[‎/se SessionName]
[‎/op OpenFileName]

פרמטרים

‎/s Computer
ציון השם או כתובת ה- IP של מחשב מרוחק (אל תשתמש בקווים נטויים הפוכים). ברירת המחדל היא המחשב המקומי.
‎/u Domain\User
הפעלת הפקודה עם הרשאות החשבון של המשתמש שצוין בפרמטר User או Domain\User. ברירת המחדל היא ההרשאות של המשתמש הנוכחי המחובר למחשב שממנו נשלחה הפקודה.
‎/p Password
ציון את הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u .
‎/id OpenFileID
ניתוק הקובץ שנפתח עם הפרמטר OpenFileID המספרי שצוין, וזאת במחשב שצוין באמצעות הפרמטר ‎/s השתמש ב- openfiles.exe /query להכרת מזהה הקובץ. ניתן להשתמש בתו הכללי כוכבית (*) לניתוק כל הקבצים הפתוחים במחשב שצוין.
‎/a UserName
ניתוק את כל הקבצים הפתוחים, שהמשתמש שצוין ביצע גישה אליהם במחשב שצוין בפרמטר ‎/s . ניתן להשתמש בתו הכללי כוכבית (*) לניתוק כל הקבצים הפתוחים במחשב שצוין.
‎/o OpenMode
ניתוק את כל הקבצים הפתוחים עם הפרמטר OpenMode שצוין, וזאת במחשב שצוין באמצעות הפרמטר ‎/s. הפרמטר OpenMode כולל את מצב קריאה/כתיבה (Read/Write) ואת מצב הקריאה (Read). ניתן להשתמש בתו הכללי (*) לניתוק כל הקבצים הפתוחים במחשב שצוין.
‎/se SessionName
ניתוק כל הקבצים הפתוחים שנוצרו באמצעות ההפעלה שצוינה במחשב שצוין בפרמטר ‎/s . ניתן להשתמש בתו הכללי כוכבית (*) לניתוק כל הקבצים הפתוחים במחשב שצוין.
‎/op OpenFileName
ניתוק הקובץ הפתוח שנוצר באמצעות הפרמטר OpenFileName שצוין, במחשב שצוין באמצעות הפרמטר ‎/s . ניתן להשתמש בתו הכללי כוכבית (*) לניתוק כל הקבצים הפתוחים במחשב שצוין.
‎/?‎
הצגת עזרה בשורת הפקודה.

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה openfiles /disconnect:

openfiles.exe /disconnect /id 1
openfiles.exe /disconnect /a hiropln
openfiles.exe /disconnect /o read/write
openfiles.exe /disconnect /op "c:\my documents\somedoc.doc"‎
openfiles /disconnect /session machine /id 5
openfiles.exe /disconnect /s srvmain /u maindom\hiropln /id 5
openfiles /disconnect /s srvmain /u maindom\hiropln /p p@ssW23 /id *‎

openfiles query

ביצוע שאילתות על כל הקבצים הפתוחים והצגתם.

תחביר

openfiles.exe /query ‎[‎/s Computer [/u Domain\User [/p Password‎]]‎] [‎/fo {TABLE|LIST|CSV}‎] ‎[/nh]‎ [‎/v]‎

פרמטרים

‎/s Computer
ציון השם או כתובת ה- IP של מחשב מרוחק (אל תשתמש בקווים נטויים הפוכים). ברירת המחדל היא המחשב המקומי.
‎/u Domain\User
הפעלת את הפקודה עם הרשאות החשבון של המשתמש שצוין באמצעות הפרמטר User או Domain\User. ברירת המחדל היא ההרשאות של המשתמש הנוכחי המחובר למחשב שממנו נשלחת הפקודה.
‎/p Password
ציון הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u .
‎/fo {TABLE|LIST|CSV}‎
ציון התבנית לשימוש עבור פלט השאילתה. ערכים חוקיים הם TABLE‏, LIST ו- CSV. ערך ברירת המחדל עבור פלט הוא TABLE.
‎/nh
העלמה של כותרת הטור בפלט. חוקי רק כאשר הפרמטר ‎/fo מוגדר כ- TABLE או כ- CSV.
‎/v
הוראה להצגת מידע מפורט על משימה בפלט.
‎/?‎
הצגת עזרה בשורת הפקודה.

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה openfiles /query:

openfiles.exe /query
openfiles.exe /query /fo table /nh
openfiles.exe /query /fo list /v
openfiles.exe /query /s srvmain /u maindom\hiropln /p p@ssW23


Pagefileconfig.vbs

מאפשרת למנהל להציג ולקבוע את התצורה של הגדרות הזיכרון הווירטואלי של קובץ ההחלפה של המחשב.

להצגת תחביר של פקודה, לחץ על פקודה:

pagefileconfig change

משנה את ההגדרות הנוכחיות של הזיכרון הווירטואלי עבור קובץ ההחלפה של מחשב.

תחביר

pagefileconfig[.vbs]‎ ‎/change ‎[/s Computer [/u Domain\User [/p Password]]]‎ ‎{[/i InitialPageFileSize]|[/m MaximumPageFileSize]}‎ ‎/vo {VolumeLetter|*}‎ ‎[/vo {VolumeLetter2|*} [...]]‎

פרמטרים

‎/s Computer
מציין את השם או את כתובת ה- IP של מחשב מרוחק (אל תשתמש בקווים נטויים הפוכים). ברירת המחדל היא המחשב המקומי.
‎/u Domain\User
מפעיל את קובץ ה- Script עם הרשאות החשבון של המשתמש שצוין בפרמטר User או Domain\User. ברירת המחדל היא ההרשאות של המשתמש הנוכחי שביצע כניסה למחשב שממנו נשלחת הפקודה.
‎/p Password
מציין את הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u .
‎/i InitialPageFileSize
מציין את הגודל ההתחלתי החדש (ביחידות של מגה-בית, MB) לשימוש עבור קובץ ההחלפה שצוין.
‎/m MaximumPageFileSize
מציין את הגודל המירבי החדש (ביחידות של מגה-בית) לשימוש עבור קובץ ההחלפה שצוין.
‎/vo {VolumeLetter|*}‎
מציין אמצעי אחסון אחד או יותר של הגדרות קובץ ההחלפה שיש לשנות. ציין את אמצעי האחסון באמצעות אות ולאחריה נקודתיים (לדוגמה, "C:‎").
‎/?‎
הצגת עזרה בשורת הפקודה.

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה pagefileconfig /change:

pagefileconfig.vbs /change /m 400 /vo c:‎
pagefileconfig.vbs /change /s srvmain /u maindom\hiropln /m 400 /vo c:‎
pagefileconfig.vbs /change /s srvmain /u maindom\hiropln /i 20 /vo *‎
pagefileconfig.vbs /change /s srvmain /u maindom\hiropln /p p@ssW23 /i 200 /m 500 /vo c: /vo d:‎

pagefileconfig create

יוצרת או מוסיפה קובץ החלפה נוסף למחשב.

תחביר

pagefileconfig.vbs ‎/create ‎[/s Computer [/u Domain\User [/p Password]]]‎ ‎/i InitialPageFileSize ‎/m MaximumPageFileSize ‎/vo {VolumeLetter|*}‎ ‎[/vo {VolumeLetter2|*} [...]]‎

פרמטרים

‎/s Computer
מציין את השם או את כתובת ה- IP של מחשב מרוחק (אל תשתמש בקווים נטויים הפוכים). ברירת המחדל היא המחשב המקומי.
‎/u Domain\User
מפעיל את קובץ ה- Script עם הרשאות החשבון של המשתמש שצוין בפרמטר User או Domain\User. ברירת המחדל היא ההרשאות של המשתמש הנוכחי שביצע כניסה למחשב שממנו נשלחת הפקודה.
‎/p Password
מציין את הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u .
‎/i InitialPageFileSize
מציין את הגודל ההתחלתי החדש (ביחידות של מגה-בית, MB) לשימוש עבור קובץ ההחלפה שצוין.
‎/m MaximumPageFileSize
מציין את הגודל המירבי החדש (ביחידות של מגה-בית) לשימוש עבור קובץ ההחלפה שצוין.
‎/vo {VolumeLetter|*}‎
מציין אמצעי אחסון אחד או יותר עבור הגדרות קובץ ההחלפה שיש ליצור. ציין את אמצעי האחסון באמצעות אות ולאחריה נקודתיים (לדוגמה, "C:‎").
‎/?‎
הצגת עזרה בשורת הפקודה.

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה pagefileconfig /create:

pagefileconfig.vbs /create /i 140 /m 300 /vo d:‎
pagefileconfig.vbs /create /s srvmain /u maindom\hiropln /i 150 /m 300 /vo d:‎
pagefileconfig.vbs /create /s srvmain /u maindom\hiropln /i 50 /m 200 /vo *‎
pagefileconfig.vbs /create /s srvmain /u maindom\hiropln /p p@ssW23 /i 100 /m 600 /vo d: /vo e: /vo f:‎

pagefileconfig delete

מוחקת קובץ החלפה מהמחשב.

תחביר

pagefileconfig.vbs ‎/delete ‎[/s Computer [/u Domain\User [/p Password]]]‎ ‎/vo {VolumeLetter|*}‎ ‎[/vo {VolumeLetter2|*} [...]]‎

פרמטרים

‎/s Computer
מציין את השם או את כתובת ה- IP של מחשב מרוחק (אל תשתמש בקווים נטויים הפוכים). ברירת המחדל היא המחשב המקומי.
‎/u Domain\User
מפעיל את קובץ ה- Script עם הרשאות החשבון של המשתמש שצוין בפרמטר User או Domain\User. ברירת המחדל היא ההרשאות של המשתמש הנוכחי שביצע כניסה למחשב שממנו נשלחת הפקודה.
‎/p Password
מציין את הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u .
‎/vo {VolumeLetter|*}‎
מציין אמצעי אחסון אחד או יותר עבור הגדרות קובץ ההחלפה שיש ליצור. ציין אמצעי אחסון באמצעות אות ולאחריה נקודתיים (לדוגמה, "C:‎").
‎/?‎
הצגת עזרה בשורת הפקודה.

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה pagefileconfig /delete:

pagefileconfig.vbs /delete /vo d:‎
pagefileconfig.vbs /delete /s srvmain /u maindom\hiropln /vo d:‎
pagefileconfig.vbs /delete /s srvmain /u maindom\hiropln /p p@ssW23 /vo d: /vo e: /vo f:‎

pagefileconfig query

מבצעת שאילתה על הגדרות הזיכרון הווירטואלי של קובץ החלפה של מחשב ומציגה אותן.

pagefileconfig.vbs ‎/query ‎[/s Computer [/u Domain\User [/p Password]]]‎ ‎[/fo {TABLE|LIST|CSV}]‎

פרמטרים

‎/s Computer
מציין את השם או את כתובת ה- IP של מחשב מרוחק (אל תשתמש בקווים נטויים הפוכים). ברירת המחדל היא המחשב המקומי.
‎/u Domain\User
מפעיל את קובץ ה- Script עם הרשאות החשבון של המשתמש שצוין בפרמטר User או Domain\User. ברירת המחדל היא ההרשאות של המשתמש הנוכחי שביצע כניסה למחשב שממנו נשלחת הפקודה.
‎/p Password
מציין את הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u .
‎/fo {TABLE|LIST|CSV}‎
מציין את התבנית שיש להשתמש בה עבור פלט השאילתה. ערכים חוקיים הם TABLE‏, LIST ו- CSV. ערך ברירת המחדל הוא LIST.
‎/?‎
הצגת עזרה בשורת הפקודה.

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה pagefileconfig /query:

pagefileconfig.vbs /query
pagefileconfig.vbs /query /fo table
pagefileconfig.vbs /query /s srvmain /u maindom\hiropln
pagefileconfig.vbs /query /s srvmain /u maindom\hiropln /p p@ssW23 /fo list

הערות

  • גודלו המירבי של קובץ החלפה מוגבל למרחב הדיסק הפנוי הזמין, פחות השטח שהוגדר עבור שחזור שלאחר crashdump עבור כונן האתחול.


Path

מגדירה את נתיב הפקודה במשתנה הסביבה PATH, קבוצת הספריות המשמשות עבור חיפוש קבצים הניתנים להפעלה. הפקודה path ללא פרמטרים מציגה את נתיב הפקודה הנוכחי.

תחביר

path ‎[[%path%]‎ ‎[Drive:]Path ‎[;...]]‎

פרמטרים

‎[Drive:]Path
מציין את הכונן והספריה להגדרה בנתיב הפקודה.
;
מפריד ספריות בנתיב הפקודה.
%path%
מציין כי על Windows XP להוסיף את נתיב הפקודה לקבוצה הקיימת של ספריות המפורטות במשתנה הסביבה PATH.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • שימוש בפרמטר ;

    כאשר הפרמטר ; משמש כפרמטר היחיד, הוא מוחק את ערך נתיב הפקודה הנוכחי של המשתנה PATH.

  • שימוש בפרמטר %path%

    כאשר מוסיפים את הפרמטר %path% לתחביר, היישום Cmd.exe ממיר אותו בערך נתיב הפקודה הנמצא במשתנה PATH, וחוסך ממך את הצורך להזין ערכים אלה ידנית בשורת הפקודה. למידע נוסף אודות המרה של ערכי משתני סביבה, ראה מבט כולל על מעטפת הפקודות בנושאים קרובים.

  • ספריה נוכחית

    Windows XP תמיד מבצע חיפוש בספריה הנוכחית תחילה, לפני חיפוש בספריות שבנתיב הפקודה.

  • קבצים בעלי שמות זהים וסיומות שונות

    ייתכן שיהיו באותה ספריה מספר קבצים בעלי שם קובץ זהה אך סיומות שונות. לדוגמה, ייתכן שיימצא קובץ הנקרא Accnt.com המפעיל תוכנית ניהול חשבונות וקובץ נוסף הנקרא Accnt.bat, המקשר את המערכת לרשת של מערכת ניהול החשבונות.

    Windows XP מבצע חיפוש של קובץ באמצעות סיומות שם קובץ המשמשות כברירת מחדל, וזאת לפי סדר הקדימויות הבא: ‎.exe‏, ‎.com‏, ‎.bat ו- ‎.cmd כדי להפעיל קובץ הנקרא Accnt.bat אם באותה ספריה קיים גם קובץ הנקרא Accnt.com, יש לכלול את הסיומת ‎.bat בשורת הפקודה.

  • שני שמות זהים בנתיב, או יותר

    ייתכן שיהיו בנתיב החיפוש שני קבצים בעלי שם קובץ וסיומת זהים, או יותר. Windows XP יחפש תחילה בספריה הנוכחית את שם הקובץ שצוין, ולאחר מכן בספריות בשורת הפקודה בסדר שבו צוינו במשתנה PATH.

  • ביצוע חיפוש במערכת המשנה של MS-DOS

    אם הפקודה path נמצאת בקובץ Autoexec.nt, היא מצרפת באופן אוטומטי את נתיב החיפוש שצוין עבור מערכת המשנה של MS-DOS לנתיב החיפוש של Windows XP בכל ביצוע כניסה למחשב. היישום Cmd.exe אינו משתמש בקובץ Autoexec.nt. כאשר היישום Cmd.exe מופעל מקיצור דרך, הוא יורש את משתני הסביבה המוגדרים בספריה My Computer/Properties/Advanced/Environment.

דוגמאות

הפקודה שלהלן מציינת כי על Windows XP לבצע חיפוש בשלוש ספריות כדי למצוא פקודות חיצוניות. שלושת הנתיבים עבור ספריות אלה הם C:\User\Taxes,‏ B:\User\Invest ו- B:\Bin:‎.

path c:\user\taxes;b:\user\invest;b:\bin


Pathping

מספקת מידע אודות השהיית הרשת ואיבוד הרשת בדילוגי ביניים בין המקור והיעד. הפקודה Pathping שולחת מספר הודעות Echo Request לכל נתב בין המקור והיעד במשך פרק זמן מסוים, ולאחר מכן מחשבת את התוצאות בהסתמך על המנות המוחזרות מכל נתב. מאחר שהפקודה pathping מציגה את רמת איבוד המנות עבור כל נתב או חיבור, באפשרותך לקבוע לאלו רשתות משנה או נתבים יש בעיות רשת. הפקודה Pathping מבצעת פעולה הדומה לזו של הפקודה tracert על-ידי זיהוי הנתבים הנמצאים בנתיב. לאחר מכן, היא שולחת מפעם לפעם איתותים (Pings) לכל הנתבים במשך פרק זמן נתון ומבצעת חישוב סטטיסטי בהתבסס על המספר שהוחזר מכל נתב. הפקודה pathping ללא פרמטרים מציגה עזרה.

תחביר

pathping [-n]‎ ‎[-h MaximumHops]‎ ‎[-g HostList]‎ ‎[-p Period]‎ ‎[-q NumQueries ‎[-w Timeout]‎ ‎[-T]‎ ‎[-R]‎ ‎[TargetName]‎

פרמטרים

‎-n
מונע מן הפקודה pathping את הניסיון לשייך את כתובות ה- IP של נתבי ביניים לשמותיהם. פעולה זו עשויה לזרז את הצגת תוצאות הפקודה pathping.
‎-h MaximumHops
מציין את המספר המירבי של דילוגים בנתיב לחיפוש היעד (Destination). ברירת המחדל היא 30 דילוגים.
‎-g HostList
מציין שהודעות Echo Request יעשו שימוש באפשרות Loose Source Route בכותרת ה- IP יחד עם קבוצת יעדי הביניים המצוינים ב- HostList. עם האפשרות Loose Source Routing, ניתן להפריד יעדי ביניים עוקבים באמצעות נתב אחד או יותר. המספר המירבי של כתובות או שמות ברשימת האירוח הוא 9. HostList הוא קבוצה של כתובות IP (עם סימני נקודה עשרונית) המופרדות באמצעות רווחים.
‎-p Period
מציין את מספר אלפיות השניה להמתנה בין איתותים (Pings) עוקבים. ברירת המחדל היא 250 אלפיות השניה (1/4 שניה).
‎-q NumQueries
מציין את מספר הודעות Echo Request הנשלחות לכל נתב בנתיב. ברירת המחדל היא 100 שאילתות.
‎-w Timeout
מציין את מספר אלפיות השניה להמתנה עבור כל תשובה. ברירת המחדל היא 3000 אלפיות השניה (3 שניות).
‎-T
מצרף תג עדיפות של שכבה 2 (לדוגמה, 802.1p) להודעות Echo Request הנשלחות לכל אחד מהתקני הרשת לאורך הנתיב. הדבר מסייע לזהות התקני רשת שאין להם יכולת עדיפות של שכבה 2. בורר זה משמש לבדיקת יכולת הקישוריות Quality of Service ‏(QoS).
‎-R
קובע האם כל התקן רשת לאורך הנתיב תומך ב- Resource Reservation Setup Protocol‏ (RSVP), המאפשר למחשב המארח לשמור כמות מסוימת של רוחב פס עבור זרם נתונים. פרמטר זה משמש לבדיקת יכולת הקישוריות Quality of Service ‏(QoS).
TargetName
מציין את היעד, הניתן לזיהוי או באמצעות כתובת IP או באמצעות שם המחשב המארח.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • הפרמטרים של הפקודה Pathping הם תלויי רישיות.
  • כדי למנוע עומס ברשת, יש לשלוח איתותים (Pings) במרווחי זמן ארוכים מספיק.
  • כדי למזער את ההשפעה של אבידות פרץ, אין לשלוח איתותים (Pings) בסמיכות רבה מדי זה לזה.
  • בעת השימוש בפרמטר ‎-p, נשלחים איתותים (Pings) לכל דילוג ביניים. לכן, מרווח הזמן בין שני איתותים הנשלחים לאותו דילוג מחושב לפי מכפלה של (period) ב- (מספר דילוגים).
  • בעת השימוש בפרמטר ‎-w, יכולים להישלח מספר איתותים (Pings) במקביל. לכן, הזמן המצוין בפרמטר Timeout אינו מוגבל על-ידי הזמן המצוין בפרמטר Period להמתנה בין איתותים.
  • שימוש בפרמטר ‎-T

    • הפעלת עדיפות של שכבה 2 במחשב המארח מאפשרת שליחת מנות עם תג עדיפות של שכבה 2, היכול לשמש התקני שכבה 2 לצורך הקצאת עדיפות למנה. התקני דור קודם אינם מזהים עדיפות מסוג שכבה 2, ולכן יתעלמו ממנות אלה ויתייחסו אליהן כמנות פגומות. פרמטר זה מסייע בזיהוי מחשבי רשת המתעלמים ממנות אלה.

  • שימוש בפרמטר ‎-R

    • הודעה של שמירת RSVP עבור הפעלה שאינה קיימת נשלחת לכל התקן רשת לאורך הנתיב. אם ההתקן אינו תומך ב- RSVP, הוא מחזיר הודעת Destination Unreachable-Protocol Unreachable (יעד אינו נגיש- פרוטוקול אינו נגיש) של Internet Control Message Protocol ‏(ICMP). אם ההתקן תומך ב- RSVP, הוא מחזיר הודעת שגיאת שמירה של RSVP. ייתכן שהתקנים מסוימים לא יחזירו אף אחת מהודעות אלה. במקרה זה, מוצגת הודעה המציינת שתם פרק הזמן שהוקצב למשימה זו.

  • פקודה זו זמינה רק אם הפרוטוקול Internet Protocol ‏(TCP/IP) מותקן כרכיב במאפיינים של מתאם הרשת בחיבורי רשת.

דוגמאות

הדוגמה הבאה מציגה את פלט הפקודה pathping:

D:\>pathping -n corp1

Tracing route to corp1 [10.54.1.196]
over a maximum of 30 hops:
  0  172.16.87.35
  1  172.16.87.218
  2  192.168.52.1
  3  192.168.80.1
  4  10.54.247.14
  5  10.54.1.196

Computing statistics for 125 seconds...
            Source to Here   This Node/Link
Hop  RTT    Lost/Sent = Pct  Lost/Sent = Pct  Address
  0                                           172.16.87.35
                                0/ 100 =  0%   |
  1   41ms     0/ 100 =  0%     0/ 100 =  0%  172.16.87.218
                               13/ 100 = 13%   |
  2   22ms    16/ 100 = 16%     3/ 100 =  3%  192.168.52.1
                                0/ 100 =  0%   |
  3   24ms    13/ 100 = 13%     0/ 100 =  0%  192.168.80.1
                                0/ 100 =  0%   |
  4   21ms    14/ 100 = 14%     1/ 100 =  1%  10.54.247.14
                                0/ 100 =  0%   |
  5   24ms    13/ 100 = 13%     0/ 100 =  0%  10.54.1.196

Trace complete.

כשהפקודה pathping מופעלת, התוצאות הראשונות המוצגות הן פירוט של הנתיב. נתיב זה הוא אותו נתיב המוצג גם באמצעות הפקודה tracert. לאחר מכן, מוצגת הודעה המציינת שימוש ברשת (הודעת Busy) במשך כ-90 שניות (פרק זמן זה משתנה על-פי מספר הדילוגים). במשך פרק זמן זה, מתבצע איסוף מידע מכל הנתבים שפורטו קודם לכן ומהחיבורים שביניהם. בסוף פרק זמן זה, מוצגות תוצאות הבדיקה.

בדו"ח לדוגמה שהוצג לעיל, הטור This Node/Link, ‏Lost/Sent = Pct והטור Address מציינים כי החיבור בין 172.16.87.218 ו- 192.68.52.1 מאבד 13% מהמנות. גם הנתבים בדילוג מספר 2 ובדילוג מספר 4 מאבדים מנות שנשלחו אליהם, אך איבוד זה אינו משפיע על יכולתם להעביר הלאה תעבורה שהם אינם נמעניה.

שיעורי האיבוד המוצגים עבור החיבורים, הניתנים לזיהוי כפס אנכי (|) בטור Address, מצביעים על כך שהעומס על חיבורים גורם לאיבוד המנות הנשלחות לאורך הנתיב. שיעורי האיבוד המוצגים עבור נתבים (הניתנים לזיהוי באמצעות כתובות ה- IP שלהם) מצביעים על כך שייתכן שנתבים אלו עמוסים מדי.


Pause

משהה עיבוד של תוכניות אצווה ומציגה הודעה המבקשת מהמשתמש להקיש על מקש כלשהו כדי להמשיך.

תחביר

pause

פרמטרים

‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • בעת הפעלת הפקודה prompt, מוצגת ההודעה הבאה:

    Press any key to continue . . .‎

  • אם תקיש CTRL+C כדי להפסיק את פעולתה של תוכנית אצווה, תוצג ההודעה הבאה:

    Terminate batch job (Y/N)?‎

    אם תקיש Y (קיצור ל- Yes) בתגובה להודעה זו, תוכנית האצווה מסתיימת והשליטה חוזרת למערכת הפעלה. כך באפשרותך להוסיף את הפקודה pause לפני מקטע של קובץ אצווה שאין ברצונך לעבד. כאשר הפקודה pause משהה את עיבוד תוכנית האצווה, באפשרותך להקיש CTRL+C ולאחר מכן Y כדי להפסיק את פעולתה של תוכנית האצווה.

דוגמאות

ליצירת תוכנית אצווה המבקשת מהמשתמש להחליף את התקליטונים באחד הכוננים, הקלד:

‎@echo off
‎:begin
copy ‎a:*.*‎
echo Please put a new disk into drive A
pause
goto begin

בדוגמה זו, כל הקבצים בתקליטון שבכונן A מועתקים לספריה הנוכחית. לאחר שמוצגת בקשה להחלפת תקליטון בכונן A, הפקודה pause משהה את העיבוד כדי שיהיה באפשרותך להחליף תקליטונים ולאחר מכן ללחוץ על מקש כלשהו כדי להמשיך בעיבוד. פעולתה של תוכנית אצווה זו מתבצעת בלולאה אינסופית. הפקודה goto BEGIN שולחת את מפענח הפקודות לתווית begin של קובץ האצווה. כדי לעצור את פעולתה של תוכנית אצווה זו, הקש CTRL+C ולאחר מכן Y.


Pbadmin

מנהלת פנקסי טלפונים. הפקודה pbadmin ללא פרמטרים מפעילה את מנהל פנקס הטלפונים.

תחביר

pbadmin.exe /N PhoneBookName ‎[/R RegionFilePath\RegionFileName]‎ ‎[/P DataFilePath\DataFileName]‎

pbadmin.exe /I PhoneBookName /R RegionFilePath\RegionFileName

pbadmin.exe /I PhoneBookName /P DataFilePath\DataFileName

pbadmin.exe /O PhoneBookName ServerName UserName Password

pbadmin.exe /B PhoneBookName

פרמטרים

‎/N PhoneBookName
יוצר פנקס טלפונים (‎.mdb). הפרמטר PhoneBookName מציין את שם הקובץ שיש ליצור.
‎/I PhoneBookName
מייבא נתונים לתוך פנקס טלפונים (‎.mdb) מקובץ אזורי (‎.txt) או מקובץ פנקס טלפונים (‎.pbk או ‎.txt). הפרמטר PhoneBookName מציין את פנקס הטלפונים שלתוכו ברצונך לייבא נתונים. עליך להשתמש בפרמטר ‎/R או ‎/P בצירוף עם הפרמטר ‎/I.
‎/R RegionFilePath\RegionFileName
מציין את המיקום ואת השם של הקובץ האזורי, שברצונך לייבא לתוך פנקס טלפונים.
‎/P DataFilePath\DataFileName
מציין את המיקום ואת השם של קובץ פנקס הטלפונים (‎.pbk או ‎.txt), שברצונך לייבא לתוך פנקס טלפונים.
‎/O PhoneBookName ServerName UserName Password
מגדיר אפשרויות עבור פנקס טלפונים. הפרמטר PhoneBookName מציין את שם פנקס הטלפונים, שברצונך להגדיר אפשרויות עבורו. הפרמטר ServerName מציין את שם השרת, שפנקס הטלפונים מתפרסם לתוכו. הפרמטר UserName מציין חשבון משתמש עם הרשאות FTP על שרת Phone Book Service ‏(PBS)‏. הפרמטר Password מציין את הסיסמה עבור חשבון המשתמש בשרת ה- PBS.
‎/B PhoneBookName
מפרסם פנקס טלפונים. הפרמטר PhoneBookName מציין את שם פנקס הטלפונים המיועד לפרסום. לפני השימוש בפרמטר ‎/B, עליך לקבוע את התצורה של פנקס הטלפונים עם הפרמטר ‎/O.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • ליצירת פנקס טלפונים (‎.mdb), השתמש בתחביר הבא:

    • pbadmin.exe /N PhoneBookName ‎[/R RegionFilePath\RegionFileName]‎ ‎[/P DataFilePath\DataFileName]‎

  • לייבוא נתונים לתוך פנקס טלפונים מקובץ אזורי, השתמש בתחביר הבא:

    • pbadmin.exe /I PhoneBookName /R RegionFilePath\RegionFileName

  • לייבוא נתונים לתוך פנקס טלפונים מקובץ פנקס טלפונים (‎.pbk) או מקובץ טקסט המעוצב בהתאם (‎.txt), השתמש בתחביר הבא:

    • pbadmin.exe /I PhoneBookName /P DataFilePath\DataFileName

  • להגדרת אפשרויות הפרסום עבור פנקס טלפונים, השתמש בתחביר הבא:

    • pbadmin.exe /O PhoneBookName ServerName UserName Password

  • לפרסום פנקס טלפונים, השתמש בתחביר הבא:

    • pbadmin.exe /B PhoneBookName

  • עבור הפקודה pbadmin, המונח "פנקס טלפונים" מתייחס לפנקס טלפונים (‎.mdb), והמונח "קובץ פנקס טלפונים" מתייחס לקובץ פנקס טלפונים (‎.pbk).
  • הפרמטרים של שורת הפקודה הינם תלויי רישיות.
  • שם של פנקס טלפונים אינו יכול להכיל יותר משמונה תווים ואינו יכול להכיל ספרות בלבד, וכמו כן אינו יכול להכיל רווח או אחד מהסימנים הבאים: ! , ; * = / \ : ? ' " < > | . & % {} [] @ ( ) ´ ` ~
  • בעת ציון נתיב, יש לציין את הנתיב המלא. לא ניתן להשתמש ברווחים בנתיב לפנקס הטלפונים, לקובץ פנקס טלפונים או לקובץ אזורי.
  • כדי להשתמש בפקודה pbadmin, יש להתקין מנהל פנקס טלפונים ולאחר מכן להקליד את הפקודה מתוך הספריה PBA. להתקנת מנהל פנקס טלפונים, הכנס את דיסק ההתקנה של Windows XP Professional או של Windows 2000 לכונן התקליטורים ולחץ על עיון בתקליטור זה. פתח את התיקיה VALUEADD, פתח את התיקיה MSFT, פתח את התיקיה MGMT ופתח את התיקיה PBA. לחץ לחיצה כפולה על PBAINST, ומלא אחר ההוראות המופיעות על המסך.

דוגמאות

בדוגמאות שלהלן נעשה שימוש בנתונים בדויים.

ליצירת פנקס טלפונים בשם Awesome, הקלד:

pbadmin.exe /N Awesome

לייבוא נתונים לתוך פנקס טלפונים בשם Awesome מקובץ אזורי בשם Region1.txt הממוקם בספריה C:\Temp, הקלד:

pbadmin.exe /I Awesome /R C:\Temp\Region1.txt

לקביעת התצורה של קובץ פנקס טלפונים בשם Awesome עם שרת בשם Rainier, משתמש בשם jobrown והסיסמה mypassword, הקלד:

pbadmin.exe /O Awesome Rainier jobrown mypassword

לפרסום פנקס טלפונים בשם Awesome, הקלד:

pbadmin.exe /B Awesome


Pentnt

מאתרת שגיאת חלוקה של נקודה צפה (אם קיימת) בשבב ה- Pentium, מבטלת אפשרות לשימוש בחומרת נקודה צפה ומפעילה הדמיה של נקודה צפה.

תחביר

pentnt [-c] [-f] [-o]‎

פרמטרים

‎-c
מאפשר הדמיה מותנית.
‎-f
מאפשר הדמיה כפויה.
‎-o
מבטל הדמיה כפויה ומפעיל מחדש חומרת נקודה צפה, אם קיימת.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • לפני הפרמטרים שנעשה בהם שימוש בפקודה זו, יש למקם מקף (-) ולא קו נטוי (/).
  • שימוש באפשרות שורת הפקודה ‎-c

    הדמיה של נקודה צפה נכפית רק אם המערכת מאתרת שגיאת חלוקה של נקודה צפה במעבד ה- Pentium בעת ההפעלה. לאחר שימוש בפרמטר זה, יש להפעיל מחדש את המחשב כדי שהשינויים ייכנסו לתוקף.

  • לאחר שימוש באפשרות שורת הפקודה ‎-f, חומרת הנקודה הצפה אינה זמינה והדמיית הנקודה הצפה נכפית תמיד, מבלי להתחשב בהתגלות שגיאת החלוקה של הנקודה הצפה של מעבד ה- Pentium במחשב. פרמטר זה שמושי לבדיקת מדמי תוכנה ולעקיפת ליקויי חומרה של הנקודה הצפה הידועים למערכת ההפעלה. לאחר בחירה בפרמטר זה, יש להפעיל את המחשב מחדש כדי שהשינויים ייכנסו לתוקף.
  • שימוש באפשרות שורת הפקודה ‎-o מחייב הפעלה מחדש את המחשב כדי שהשינויים ייכנסו לתוקף.


Ping

בודקת קישוריות ברמת IP למחשב TCP/IP אחר על-ידי שליחת הודעות Echo Request של Internet Control Message Protocol ‏(ICMP)‏. מוצגות הודעות Echo Reply תואמות, יחד עם זמני ההעברה הלוך ושוב. הפקודה Ping היא פקודת ה- TCP/IP העיקרית שנעשה בה שימוש לפתרון בעיות של התקשרות, יכולת גישה וזיהוי שמות. הפקודה ping בלא פרמטרים מציגה עזרה.

תחביר

ping ‎[-t]‎ ‎[-a]‎ [‎-n Count] [‎`-l Size] [‎-f] [‎-i TTL] [‎-v TOS] [‎-r Count] [‎-s Count] [{‎-j HostList | -k HostList}] [‎-w Timeout] [TargetName]

פרמטרים

‎-t
מציין שהפקודה Ping תמשיך לשלוח ליעד הודעות Echo Request עד שתופסק. להפסקת הפקודה ולהצגת סטטיסטיקה, הקש CTRL-BREAK. להפסקת הפקודה וליציאה ממנה, הקש CTRL-C.
‎-a
מציין שזיהוי שמות הפוך מתבצע על כתובת ה- IP של היעד. אם פעולה זו מצליחה, מציגה הפקודה Ping את שם המחשב המארח המתאים.
‎-n Count
מציין את מספר הודעות ה- Echo Request הנשלחות. ברירת המחדל היא 4.
‎-l Size
מציין את האורך, בבתים, של השדה Data (שדה הנתונים) בהודעות Echo Request שיש לשלוח. ברירת המחדל היא 32. הגודל המירבי הוא 65,527.
‎-f
מציין שהודעות ה- Echo Request נשלחות כשדגל אי-הפיצול (דגל Don't Fragment) הממוקם בכותרת ה- IP שלהן מוגדר ל- 1. הודעת ה- Echo Request אינה ניתנת לפיצול על-ידי נתבים בנתיב היעד. פרמטר זה יעיל בפתרון בעיות Maximum Transmission Unit ‏(PMTU)‏ של נתיב.
‎-i TTL
מציין את הערך של השדה TTL בכותרת ה- IP עבור הודעות Echo Request שנשלחות. ברירת המחדל היא ערך ברירת המחדל של TTL עבור המחשב המארח. עבור מחשבים מארחים של Windows XP, ערך זה הוא בדרך כלל 128. הערך המירבי של TTL הוא 255.
‎-v TOS
מציין את הערך של השדה Type of Service ‏(TOS)‏ בכותרת ה- IP של הודעות Echo Request שנשלחות. ברירת המחדל היא 0. ‏TOS מצוין כערך עשרוני בין 0 ל- 255.
‎-r Count
מציין שנעשה שימוש באפשרות Record Route שבכותרת ה- IP לשם רישום הנתיב של הודעת ה- Echo Request ושל הודעת ה- Echo Reply המקבילה. כל דילוג בנתיב משתמש בערך שבאפשרות Record Route. במידת האפשר, ציין ערך Count השווה למספר הדילוגים שבין המקור ליעד, או גדול ממנו. הערך המינימלי של Count הוא 1, והערך המקסימלי הוא 9.
‎-s Count
מציין שהאפשרות חותמת זמן אינטרנט (Internet Timestamp) שבכותרת ה- IP משמשת לרישום זמן ההגעה של הודעת ה- Echo Request ושל הודעת ה- Echo Reply המקבילה עבור כל דילוג. הערך המינימלי עבור Count הוא 1, והערך המקסימלי הוא 4.
‎-j HostList
מציין שהודעות Echo Request משתמשות באפשרות Loose Source Route בכותרת ה- IP יחד עם קבוצה של יעדי ביניים שצוינו ב- HostList. עם האפשרות Loose Source Routing, ניתן להפריד יעדי ביניים רצופים באמצעות נתב אחד או יותר. המספר המירבי של כתובות או שמות ברשימת המארחים (Host List) הוא 9. רשימת האירוח היא סדרה של כתובות IP (עם סימון של נקודה עשרונית) המופרדות באמצעות רווחים.
‎-k HostList
מציין שהודעות Echo Request משתמשות באפשרות Strict Source Route בכותרת ה- IP יחד עם קבוצה של יעדי ביניים המצוינים ב- HostList. עם האפשרות Strict Source Routing, יעד הביניים הבא ניתן לגישה באופן ישיר (עליו להיות סמוך על ממשק של הנתב). המספר המירבי של כתובות או שמות ברשימת האירוח הוא 9. רשימת האירוח היא סדרה של כתובות IP (עם סימון של נקודה עשרונית) המופרדות באמצעות רווחים.
‎-w Timeout
מציין את הזמן, באלפיות שניה, להמתנה להודעת ה- Echo Reply המקבילה להודעת Echo Request מסוימת שאמורה להתקבל. אם הודעת Echo Reply אינה מתקבלת בתוך הזמן הקצוב, מוצגת הודעת השגיאה "Request timed out". פרק הזמן המשמש כברירת מחדל הוא 4000 (4 שניות).
TargetName
מציין את היעד, המזוהה באמצעות כתובת IP או באמצעות שם מחשב מארח.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • באפשרותך להשתמש בפקודה ping כדי לבדוק את שם המחשב ואת כתובת ה- IP שלו. אם כתובת ה- IP אומתה באמצעות הפקודה Ping אך שם המחשב לא אומת, ייתכן כי קיימת בעיה של זיהוי שמות. במקרה זה, וודא ששם המחשב שצוין ניתן לזיהוי באמצעות קובץ המארחים (קובץ Hosts) המקומי על-ידי שימוש בשאילתות של Domain Name System ‏(DNS)‏, או באמצעות שיטות זיהוי שמות של NetBIOS.
  • פקודה זו זמינה רק אם הפרוטוקול Internet Protocol ‏(TCP/IP) מותקן כרכיב במאפיינים של מתאם רשת בחיבורי רשת.

דוגמאות

הדוגמאות שלהלן מציגות פלט של הפקודה ping:

C:\>ping example.microsoft.com

Pinging example.microsoft.com [192.168.239.132] with 32 bytes of data:‎

Reply from 192.168.239.132: bytes=32 time=101ms TTL=124

Reply from 192.168.239.132: bytes=32 time=100ms TTL=124

Reply from 192.168.239.132: bytes=32 time=120ms TTL=124

Reply from 192.168.239.132: bytes=32 time=120ms TTL=124

לאימות היעד 10.0.99.221 ולשיוך 10.0.99.221 לשם המחשב המארח שלו, הקלד:

ping -a 10.0.99.221

לאימות היעד 10.0.99.221 עם 10 הודעות Echo Request, שלכל אחת מהן שדה Data עם 1000 בתים, הקלד:

ping -n 10 -l 1000 10.0.99.221

לאימות היעד 10.0.99.221 ולרישום הנתיב עבור 4 דילוגים, הקלד:

ping -r 4 10.0.99.221

לאימות היעד 10.0.99.221 ולציון נתיב המקור החופשי (Loose Source Route) של ‎10.12.0.1-10.29.3.1-10.1.44.1‎, הקלד:

ping -j 10.12.0.1 10.29.3.1 10.1.44.1 10.0.99.221


Popd

מחליפה את הספריה הנוכחית בספריה המאוחסנת באמצעות הפקודה pushd.

תחביר

popd

פרמטרים

‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • בכל פעם שנעשה שימוש בפקודה pushd, מאוחסנת ספריה אחת לשימושך. עם זאת, ניתן לאחסן כמה ספריות על-ידי שימוש בפקודה pushd כמה פעמים.

    הספריות מאוחסנות ברצף במחסנית וירטואלית. אם נעשה שימוש בפקודה pushd פעם אחת, הספריה שבה נעשה שימוש בפקודה תמוקם בתחתית המחסנית. אם נעשה שימוש בפקודה פעם נוספת, הספריה השניה תמוקם מעל הספריה הראשונה. הליך זה מתבצע בכל פעם שנעשה שימוש בפקודה pushd.

    ניתן להשתמש בפקודה popd להחלפת הספריה הנוכחית בספריה שאוחסנה לאחרונה באמצעות הפקודה pushd. אם נעשה שימוש בפקודה popd, הספריה שבראש המחסנית מוסרת ממנה עם החלפת הספריה הנוכחית בספריה זו. אם נעשה שימוש בפקודה popd פעם נוספת, הספריה הבאה במחסנית מוסרת.
  • כאשר הרחבות הפקודה זמינות, מסירה הפקודה popd את כל שיוכי האותיות לכוננים שנוצרו באמצעות הפקודה pushd.

דוגמאות

ניתן להשתמש בפקודות pushd ו- popd בתוכנית אצווה להחלפת הספריה הנוכחית בספריה שבה מופעלת תוכנית האצווה ובחזרה. הדוגמה הבאה של תוכנית אצווה מראה כיצד לעשות זאת:

‎@echo off
rem This batch file deletes all .txt files in a specified directory
pushd %1
del *.txt
popd
cls
echo All text files deleted in the %1 directory


Print

שולחת קובץ טקסט למדפסת.

תחביר

print [/d:Printer] [Drive:][Path] FileName ‎[ ...]‎

פרמטרים

‎/d:Printer
מציין את המדפסת שברצונך להשתמש בה לשם הדפסת המשימה. באפשרותך לציין מדפסת מקומית על-ידי ציון היציאה במחשב שאליה מחוברת המדפסת. ערכים חוקיים ליציאות מקביליות הם: LPT1‏, LPT2 ו- LPT3. ערכים חוקיים ליציאות טוריות הם: COM1‏, COM2‏, COM3 ו- COM4. באפשרותך גם לציין מדפסת רשת באמצעות שם התור שלה (‎\\ServerName\ShareName). אם לא תציין מדפסת, משימת ההדפסה נשלחת אל LPT1.
Drive:‎
מציין את הכונן הלוגי או הפיזי שבו ממוקם הקובץ המיועד להדפסה. פרמטר זה אינו הכרחי אם הקובץ שברצונך להדפיס ממוקם בכונן הנוכחי.
Path
מציין את המקום בכונן שבו ממוקם הקובץ שברצונך להדפיס. פרמטר זה אינו הכרחי אם הקובץ שברצונך להדפיס ממוקם בספריה הנוכחית.
FileName ‎[...]‎
הכרחי. מציין, לפי שם, את הקובץ שברצונך להדפיס. באפשרותך לכלול מספר קבצים בפקודה אחת.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • ניתן להדפיס קובץ ברקע אם הוא נשלח למדפסת המחוברת ליציאה טורית או מקבילית במחשב מקומי.
  • תוכניות רבות כוללות פקודות ההדפסה משלהן. כדי להדפיס קבצים שיצרת באמצעות תוכנית, השתמש בפקודה print של תוכנית זו.
  • באפשרותך לבצע משימות רבות של קביעת תצורה משורת הפקודה באמצעות הפקודה mode. למידע נוסף אודות קביעת התצורה של מדפסת המחוברת ליציאה מקבילית, לקביעת התצורה של מדפסת המחוברת ליציאה טורית, להצגה של מצב המדפסת או להכנת מדפסת להחלפת קידוד, ראה mode בנושאים קרובים.

דוגמאות

לשליחת הקובץ Report.txt שבספריה הנוכחית למדפסת המחוברת ל- LPT2 במחשב המקומי, הקלד:

print /d:LPT2 report.txt

לשליחת הקובץ Report.txt שבספריה c:\Accounting לתור ההדפסה Printer1 בשרת ‎\\CopyRoom, הקלד:

print /d:\\copyroom\printer1 c:\accounting\report.txt


Prncnfg.vbs

קובעת את תצורת המדפסת או מציגה את מידע התצורה עבורה. הפקודה prncnfg.vbs ללא פרמטרים מציגה עזרה של שורת הפקודה עבור הפקודה prncnfg.vbs.

לשם הצגת מידע תצורה של מדפסת

תחביר

cscript prncnfg.vbs -g [-s RemoteComputer]‎ ‎-p PrinterName ‎[-u UserName -w Password]‎

פרמטרים

‎-g
הכרחי. מציין שברצונך להציג מידע תצורה של מדפסת.
‎-s RemoteComputer
מציין, לפי שם, את המחשב המרוחק המנהל את המדפסת שברצונך להציג מידע אודותיה. אם לא יצוין מחשב, נעשה שימוש במחשב המקומי.
‎-p PrinterName
הכרחי. מציין, לפי שם, את המדפסת שברצונך להציג מידע אודותיה.
‎-u UserName -w Password
מציין חשבון עם הרשאות להתחברות באמצעות שירותי Windows Management Instrumentation ‏(WMI) למחשב המארח את המדפסת שברצונך להציג מידע אודותיה. הרשאות אלה מוענקות לכל החברים בקבוצה Administrators של מחשב זה, אך ניתן להעניק אותן גם למשתמשים אחרים. אם לא תציין חשבון, עליך לבצע כניסה למחשב באמצעות חשבון עם הרשאות אלה. אם לא תעשה כן, לא יהיה באפשרותך להשתמש בפקודה זו. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כשספריה זו היא הספריה הנוכחית. לחלופין, הקלד בתחילת הפקודה cscript את הנתיב המלא לספריה זו.
  • אם המידע שסיפקת מכיל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").

דוגמה

להצגת מידע תצורה עבור מדפסת בשם ColorPrinter_2, שתור ההדפסה שלה נמצא במחשב מרוחק בשם HRServer, הקלד:

cscript prncnfg.vbs -g -s HRServer -p ColorPrinter_2

לשם קביעת תצורה של מדפסת

תחביר

cscript prncnfg.vbs -t [-s RemoteComputer] -p PrinterName [‎-u UserName -w Password] [-r PortName] ‎[‎‎-l Location] [-m Comment] [‎-h ShareName] [-f SeparatorText] [-y DataType] ‎[‎‎-st StartTime] [-ut EndTime] [-o Priority] [-i DefaultPriority] ‎[{+ | -}‎shared] [{+ | -}direct] [{+ | -}published] [{+ | -}hidden] [{+ | -}rawonly] [{+ | -}queued] [‎{+ | -}‎keepprintedjobs] [{+ | -}workoffline] [{+ | -}enabledevq] [{+ | -}docompletefirst][‎{+ | -}‎enablebidi]

פרמטרים

‎-t
הכרחי. מציין שברצונך לקבוע תצורה של מדפסת.
‎-s RemoteComputer
מציין, לפי שם, את המחשב המרוחק המנהל את המדפסת שברצונך לקבוע את תצורתה. אם לא צוין מחשב, תצורת המדפסת נקבעת במחשב המקומי.
‎-p PrinterName
הכרחי. מציין, לפי שם, את המדפסת שברצונך לקבוע את תצורתה.
‎-u UserName -w Password
מציין חשבון עם הרשאות להתחברות באמצעות שירותי Windows Management Instrumentation ‏(WMI)‏ למחשב שבו ברצונך לקבוע תצורת מדפסת. לכל החברים בקבוצה Administrators של מחשב זה יש הרשאות אלה, אך ניתן גם להעניק אותן למשתמשים אחרים. אם אינך מציין חשבון מסוים, עליך לבצע כניסה למחשב באמצעות חשבון עם הרשאות אלה, אחרת לא יהיה באפשרותך להשתמש בפקודה. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎-r PortName
מציין את היציאה שאליה מחוברת המדפסת. אם יציאה זו היא מקבילית או טורית, השתמש במזהה של היציאה (לדוגמה, LPT1 או COM1). אם זוהי יציאת TCP/IP, השתמש בשם היציאה שצוין בעת הוספת היציאה. לקבלת מידע נוסף, ראה נושאים קרובים.
‎-l Location
מציין את מיקום המדפסת, כגון "Copier Room".
‎-m Comment
מציין את מחרוזת ההערה.
‎-h ShareName
מציין את שם השיתוף.
‎-f SeparatorText
מציין קובץ המכיל את הטקסט המופיע בעמוד המפריד.
‎-y DataType
מציין את סוגי הנתונים שהמדפסת עשויה לקבל. לקבלת מידע נוסף אודות סוגי נתונים, ראה נושאים קרובים.
‎-st StartTime
קובע את תצורת המדפסת לזמינות מוגבלת. מציין את השעה שאחריה תהיה המדפסת זמינה. אם נשלח מסמך למדפסת בעת שהיא אינה זמינה, המסמך נשמר (מודפס ברקע) עד הפיכתה של המדפסת לזמינה. עליך לציין את הזמן ביחידות של שעון בעל 24 שעות. לדוגמה, לציון השעה ‎11 P.M.‎, הקלד 2300.
‎-ut EndTime
קובע את תצורת המדפסת לזמינות מוגבלת. מציין את השעה שאחריה לא תהיה המדפסת זמינה. אם נשלח מסמך למדפסת בעת שהיא אינה זמינה, הוא נשמר (מודפס ברקע) עד הפיכתה של המדפסת לזמינה. עליך לציין את הזמן ביחידות של שעון בעל 24 שעות. לדוגמה, לציון השעה ‎11 P.M.‎, הקלד 2300.
‎-o Priority
מציין עדיפות שמנגנון ההדפסה ברקע משתמש בה לניתוב משימות ההדפסה. תור הדפסה בעל עדיפות גבוהה מקבל את כל המשימות שלו לפני כל תור אחר בעל עדיפות נמוכה יותר.
‎-i DefaultPriority
מציין את עדיפות ברירת המחדל המוקצית לכל משימת הדפסה.
‎{+ | -}‎shared
מציין האם מדפסת זו משותפת ברשת.
‎{+ | -}‎direct
מציין האם על המסמך להישלח ישירות למדפסת מבלי להיות מודפס ברקע.
‎{+ | -}‎published
מציין האם על מדפסת זו להתפרסם ב- Active Directory. אם המדפסת פורסמה, משתמשים אחרים יכולים לנסות לאתרה בהתבסס על מיקומה ויכולותיה, כגון הדפסת צבע והידוק.
‎{+ | -}‎hidden
פונקציה שמורה.
‎{+ | -}‎rawonly
מציין האם רק משימות הדפסה של נתוני גלם ניתנות להדפסה ברקע בתור זה.
‎{+ | -}‎queued
מציין כי על המדפסת להתחיל בהדפסה רק לאחר שהעמוד האחרון של המסמך הודפס ברקע. תוכנית ההדפסה תהיה בלתי זמינה כל עוד לא הסתיימה הדפסת המסמך. עם זאת, השימוש באפשרות זו מבטיח שכל המסמך יהיה זמין עבור המדפסת.
‎{+ | -}‎keepprintedjobs
מציין האם מנגנון ההדפסה ברקע שומר מסמכים לאחר הדפסתם. הפיכת אפשרות זו לזמינה מאפשרת למשתמש לשלוח מחדש להדפסה מסמך מתור ההדפסה במקום מהתוכנית המדפיסה.
‎{+ | -}‎workoffline
מציין האם יהיה באפשרותך לשלוח משימות הדפסה לתור ההדפסה אפילו אם המחשב שלך אינו מחובר לרשת.
‎{+ | -}‎enabledevq
מציין האם משימות הדפסה שאינן תואמות את הגדרת המדפסת (לדוגמה, קבצי PostScript המודפסים ברקע במדפסות שאינן מסוג PostScript) יישמרו בתור ולא יודפסו.
‎{+ | -}‎docompletefirst
מציין האם על מנגנון ההדפסה ברקע לשלוח לתור המתאים משימות הדפסה בעלות עדיפות נמוכה שההדפסה ברקע שלהן הסתיימה לפני השליחה לאותו תור של משימות הדפסה בעלות עדיפות גבוהה יותר שההדפסה ברקע שלהן לא הסתיימה. אם אפשרות זו זמינה ועדיין לא הסתיימה ההדפסה ברקע של אף מסמך, מנגנון ההדפסה ברקע ישלח מסמכים גדולים יותר לפני מסמכים קטנים יותר. עליך להפוך אפשרות זו לזמינה אם ברצונך למטב את יעילות המדפסת על חשבון עדיפות המשימות. אם אפשרות זו אינה זמינה, מנגנון ההדפסה ברקע תמיד ישלח תחילה משימות בעלות חשיבות גבוהה יותר לתורים המתאימים להן.
‎{+ | -}‎enablebidi
מציין האם המדפסת שולחת מידע מצב למנגנון ההדפסה ברקע.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה עם ספריה זו כספריה הנוכחית, או להקליד את הנתיב המלא לספריה זו בתחילת הפקודה cscript.
  • אם המידע שברצונך לספק מכיל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").

דוגמה

לקביעת התצורה של מדפסת בשם ColorPrinter_2 באופן שבו מנגנון ההדפסה ברקע במחשב מרוחק ששמו HRServer ישמור משימות הדפסה לאחר הדפסתן, הקלד:

cscript prncnfg.vbs -t -s HRServer -p ColorPrinter_2 +keepprintedjobs

לשם שינוי שמה של מדפסת

תחביר

cscript prncnfg.vbs -x ‎[-s RemoteComputer] -p PrinterName -z NewPrinterName ‎[-u UserName -w Password]‎

פרמטרים

‎-x
הכרחי. מציין שברצונך לשנות שם מדפסת.
‎-s RemoteComputer
מציין, לפי שם, את המחשב המרוחק המנהל את המדפסת שברצונך לשנות את שמה. אם אינך מציין מחשב, נעשה שימוש במחשב המקומי.
‎-p PrinterName
הכרחי. מציין את שם המדפסת הנוכחי.
‎-z NewPrinterName
הכרחי. מציין את השם החדש של המדפסת.
‎-u UserName -w Password
מציין חשבון עם הרשאות להתחברות באמצעות שירותי Windows Management Instrumentation ‏(WMI)‏ למחשב המארח את המדפסת שאת שמה ברצונך לשנות. לכל החברים בקבוצה Administrators באותו מחשב הוענקו הרשאות אלה, אך ניתן להעניק אותן גם למשתמשים אחרים. אם לא תציין חשבון, עליך לבצע כניסה למחשב באמצעות חשבון עם הרשאות אלה. אם לא תעשה כן, לא יהיה באפשרותך להשתמש בפקודה זו. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה עם ספריה זו כספריה הנוכחית, או להקליד את הנתיב המלא לספריה בתחילת הפקודה cscript.
  • אם המידע שברצונך לספק מכיל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").

דוגמה

לשינוי שם של מדפסת במחשב מרוחק בשם HRServer מ- ColorPrinter_2 ל- ColorPrinter_3, הקלד:

cscript prncnfg.vbs -x -s HRServer -p ColorPrinter_2 -z ColorPrinter_3


Prndrvr.vbs

הוספה, מחיקה ופירוט של מנהלי מדפסות. שימוש בפקודה prndrvr.vbs מביא להצגת עזרה של שורת פקודה עבור הפקודה prndrvr.vbs.

לשם התקנת מנהל מדפסת

תחביר

cscript prndrvr.vbs -a ‎[-m DriverName] [-v {0 | 1 | 2 | 3}]‎ ‎[-e Environment] [-s RemoteComputer]‎ ‎[-h Path] [-i FileName.inf]‎ ‎[-u UserName -w Password]‎

פרמטרים

‎-a
נדרש. קביעה כי ברצונך להתקין מנהל מדפסת.
‎-m DriverName
ציון מנהל המדפסת שברצונך להתקין, לפי שם. מנהלי מדפסות מכונים לעיתים קרובות לפי דגם המדפסת שהם תומכים בו. עיין בתיעוד המדפסת לקבלת מידע נוסף.
‎-v {0 | 1 | 2 | 3}‎
ציון הגירסה של מנהל המדפסת שברצונך להתקין. ראה את התיאור של הפרמטר ‎-e Environment לקבלת מידע אודות הגירסאות הזמינות עבור כל סביבה. אם לא תציין גירסה, תותקן גירסת מנהל המדפסת המתאימה לגירסה של Windows הפועלת במחשב שבו ברצונך לבצע את ההתקנה.
  • גירסה 0 תומכת ב- Windows 95,‏ Windows 98 ו- Windows Millennium Edition.
  • גירסה 1 תומכת ב- Windows NT 3.51.
  • גירסה 2 תומכת ב- Windows NT 4.0.
  • גירסה 3 תומכת ב- Windows XP ו- Windows 2000.
‎-e Environment
ציון הסביבה עבור מנהל ההתקן שברצונך להתקין. אם לא תציין סביבה, ייעשה שימוש בסביבה של המחשב שבו אתה מתקין את מנהל המדפסת. הטבלה הבאה מפרטת את הסביבות הזמינות של מנהלי המדפסת, ואת הגירסאות הזמינות עבור כל אחת מהן.
סביבה | גירסאות זמינות
"Windows NT x86" | 1, 2 ו- 3
"Windows NT Alpha_AXP" | 1 ו- 2
"Windows IA64" | 3
"Windows NT R4000" | 1
"Windows NT PowerPC" | 1
"Windows 4.0" | 0
‎-s RemoteComputer
ציון המחשב המרוחק שבו ברצונך להתקין את מנהל המדפסת. אם לא תציין מחשב, מנהל המדפסת יותקן במחשב המקומי.
‎-h Path
קביעת הנתיב לקובץ של מנהל המדפסת. אם לא תציין נתיב, ייעשה שימוש בנתיב למיקום שממנו הותקן Windows.
‎-i FileName.inf
ציון שם הקובץ עבור מנהל המדפסת שברצונך להתקין. אם לא תציין שם קובץ, ייעשה שימוש ב- ntprint.inf.
‎-u UserName -w Password
ציון חשבון עם הרשאות לחיבור באמצעות שירותי Windows Management Instrumentation ‏(WMI) למחשב שברצונך להתקין בו את מנהל המדפסת. לכל החברים בקבוצה Administrators של מחשב זה הוענקו הרשאות אלה, אך ניתן להעניק את ההרשאות גם למשתמשים אחרים. אם לא תציין חשבון, עליך לבצע כניסה למחשב תחת חשבון עם הרשאות אלה כדי שהפקודה תפעל. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא לספריה זו בתחילת הפקודה cscript.
  • אם המידע שסיפקת כולל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").

דוגמה

כדי להוסיף את גירסה 3 של מנהל ההתקן של המדפסת הנקרא "Color Printer Driver 1" למחשב המקומי, המציע סביבה מבוססת על Windows NT x86, הקלד:

cscript prndrvr.vbs -a -m "Color Printer Driver 1" -v 3 -e "Windows NT x86"‎

לשם מחיקת מנהל מדפסת

תחביר

cscript prndrvr.vbs -d ‎[-s RemoteComputer]‎ -m DriverName -v {0 | 1 | 2 | 3}‎ ‎-e Environment

‎[-u UserName -w Password]‎

פרמטרים

‎-d
נדרש. קביעה כי ברצונך למחוק מנהל התקן.
‎-s RemoteComputer
ציון המחשב המרוחק שממנו ברצונך למחוק את מנהל המדפסת. אם לא תציין מחשב, מנהל המדפסת יימחק מהמחשב המקומי.
‎-m DriverName
נדרש. ציון מנהל המדפסת שברצונך למחוק, לפי שם. מנהלי מדפסת נקראים לעיתים קרובות לפי דגם המדפסת שהם תומכים בו. עיין בתיעוד המדפסת לקבלת מידע נוסף.
‎-v {0 | 1 | 2 | 3}‎
נדרש. ציון הגירסה של מנהל המדפסת שיש למחוק. ראה את התיאור של הפרמטר ‎-e Environment לקבלת מידע אודות הגירסאות הזמינות בכל סביבה.
  • גירסה 0 תומכת ב- Windows 95,‏ Windows 98 ו- Windows Millennium Edition.
  • גירסה 1 תומכת - Windows NT 3.51.
  • גירסה 2 תומכת ב- Windows NT 4.0.
  • גירסה 3 תומכת ב- Windows XP ו- Windows 2000.
‎-e Environment
נדרש. ציון הסביבה עבור מנהל המדפסת שברצונך למחוק. הטבלה הבאה מפרטת את סביבות מנהלי המדפסת הזמינות ואת הגירסאות הזמינות לכל אחת מהן.
סביבה | גירסאות זמינות
"Windows NT x86" | 1, 2 ו- 3
"Windows NT Alpha_AXP" | 1 ו- 2
"Windows IA64" | 3
"Windows NT R4000" | 1
"Windows NT PowerPC" | 1
"Windows 4.0" | 0
‎-u UserName -w Password
ציון חשבון עם הרשאות לחיבור באמצעות שירותי Management Instrumentation ‏(WMI) למחשב שממנו ברצונך למחוק את מנהל ההתקן. לכל החברים בקבוצה Administrators של מחשב זה הוענקו הרשאות אלה, אך ניתן להעניק את ההרשאות גם למשתמשים אחרים. אם לא תציין חשבון, עליך לבצע כניסה למחשב תחת חשבון עם הרשאות אלה כדי שהפקודה תפעל. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא לספריה זו בתחילת הפקודה cscript.
  • בעת מחיקת מנהל מדפסת, עליך לכלול את הפרמטרים של הסביבה ושל הגירסה.
  • אם המידע שסיפקת כולל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").

לשם פירוט מנהלי המדפסת במחשב

תחביר

cscript prndrvr.vbs -l ‎[-s RemoteComputer]‎ ‎[-u UserName -w Password]‎

פרמטרים

‎-l
נדרש. קביעה כי ברצונך לפרט את כל מנהלי המדפסת במחשב.
‎-s RemoteComputer
ציון המחשב המרוחק שאת מנהלי המדפסת שלו ברצונך להציג. אם לא תציין מחשב, יפורטו מנהלי התקן במחשב המקומי.
‎-u UserName -w Password
ציון חשבון עם הרשאות לחיבור באמצעות השירותים של Windows Management Instrumentation ‏(WMI) למחשב שאת מנהלי המדפסת שלו ברצונך להציג. לכל החברים בקבוצה Administrators של מחשב זה הוענקו הרשאות אלה, אך ניתן להעניק את ההרשאות גם למשתמשים אחרים. אם לא תציין חשבון, עליך לבצע כניסה למחשב תחת חשבון עם הרשאות אלה כדי שהפקודה תפעל. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא לספריה זו בתחילת הפקודה cscript.
  • אם המידע שסיפקת כולל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").

לשם מחיקה מהמחשב של כל מנהלי מדפסת שאינם בשימוש

תחביר

cscript prndrvr.vbs -x ‎[-s RemoteComputer]‎ ‎[-u UserName -w Password]‎

פרמטרים

‎-x
נדרש. קביעה כי ברצונך למחוק ממחשב את כל מנהלי המדפסת שאינם בשימוש.
‎-s RemoteComputer
ציון המחשב המרוחק שממנו ברצונך למחוק מנהלי מדפסת. אם לא תציין מחשב, מנהלי מדפסת יימחקו מהמחשב המקומי.
‎-u UserName -w Password
ציון חשבון עם הרשאות לחיבור באמצעות השירותים של Windows Management Instrumentation ‏(WMI) למחשב שממנו ברצונך למחוק מנהלי מדפסת. לכל החברים בקבוצה Administrators של מחשב זה הוענקו הרשאות אלה, אך ניתן להעניק את ההרשאות גם למשתמשים אחרים. אם לא תציין חשבון, עליך לבצע כניסה למחשב תחת חשבון עם הרשאות אלה כדי שהפקודה תפעל. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא לספריה זו בתחילת הפקודה cscript.
  • אם המידע שסיפקת כולל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").


Prnjobs.vbs

השהייה, חידוש, ביטול ופירוט של משימות הדפסה. כאשר נעשה שימוש ב- prnjobs.vbs ללא פרמטרים, מוצגת עזרה של שורת פקודה עבור הפקודה prnjobs.vbs.

לשם השהייה של משימת הדפסה

תחביר

cscript prnjobs -z [-s RemoteComputer]‎ ‎-p PrinterName -j JobNumber ‎[-u UserName -w Password]‎

פרמטרים

‎-z
נדרש. קביעה כי ברצונך להשהות משימת הדפסה.
‎-s RemoteComputer
ציון, לפי שם, של המחשב המרוחק שאליו נשלחה משימת ההדפסה שברצונך להשהות. אם לא תציין מחשב, ייעשה שימוש במחשב המקומי.
‎-p PrinterName
נדרש. ציון, לפי שם, של המדפסת שתדפיס את המשימה שברצונך להשהות.
‎-j JobNumber
נדרש. ציון, לפי מספר מזהה (ID), של משימת ההדפסה שברצונך להשהות.
‎-u UserName -w Password
ציון חשבון עם הרשאות לחיבור באמצעות השירותים של Windows Management Instrumentation ‏(WMI) למחשב שאליו נשלחה משימת ההדפסה שברצונך להשהות. לכל החברים בקבוצה Administrators באותו מחשב הוענקו הרשאות אלה, אך ניתן להעניק את ההרשאות גם למשתמשים אחרים. אם לא תציין חשבון, עליך לבצע כניסה למחשב תחת חשבון עם הרשאות אלה כדי שהפקודה תפעל. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא לספריה זו בתחילת הפקודה cscript.
  • כדי להציג רשימה של משימות הדפסה ומספרי הזיהוי שלהן, השתמש בפקודה זו עם הפרמטר ‎-l.
  • אם המידע שתספק כולל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").

דוגמה

כדי להשהות משימת הדפסה שמזהה המשימה שלה הוא 27, ושנשלחה למחשב מרוחק הנקרא HRServer לשם הדפסה במדפסת הנקראת ColorPrinter, הקלד:

cscript prnjobs.vbs -z -s HRServer -p ColorPrinter -j 27

לשם חידוש משימת הדפסה

תחביר

cscript prnjobs -m [-s RemoteComputer]‎ ‎-p PrinterName -j JobNumber ‎[-u UserName -w Password]‎

פרמטרים

‎-m
נדרש. קביעה כי ברצונך לחדש משימת הדפסה.
‎-s RemoteComputer
ציון, לפי שם, של המחשב המרוחק שאליו נשלחה משימת ההדפסה שברצונך לחדש. אם לא תציין מחשב, ייעשה שימוש במחשב המקומי.
‎-p PrinterName
נדרש. ציון, לפי שם, של המדפסת שתדפיס את המשימה שברצונך לחדש.
‎-j JobNumber
נדרש. ציון, לפי מספר מזהה, של משימת ההדפסה שברצונך לחדש.
‎-u UserName -w Password
ציון חשבון עם הרשאות לחיבור באמצעות השירותים של Windows Management Instrumentation ‏(WMI) למחשב שאליו נשלחה משימת ההדפסה שברצונך לחדש. לכל החברים בקבוצה Administrators באותו מחשב הוענקו הרשאות אלה, אך ניתן להעניק את ההרשאות גם למשתמשים אחרים. אם לא תציין חשבון, עליך לבצע כניסה למחשב תחת חשבון עם הרשאות אלה כדי שהפקודה תפעל. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא לספריה זו בתחילת הפקודה cscript.
  • כדי להציג רשימה של משימות הדפסה ומספרי הזיהוי שלהן, השתמש בפקודה זו עם הפרמטר ‎-l.
  • אם המידע שתספק כולל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").

לשם ביטול משימת הדפסה

תחביר

cscript prnjobs -x [-s RemoteComputer]‎ ‎-p PrinterName -j JobNumber ‎[-u UserName -w Password]‎

פרמטרים

‎-x
נדרש. קביעה כי ברצונך לבטל משימת הדפסה.
‎-s RemoteComputer
ציון, לפי שם, של המחשב המרוחק שאליו נשלחה המשימה שברצונך לבטל. אם לא תציין מחשב, ייעשה שימוש במחשב המקומי.
‎-p PrinterName
נדרש. ציון, לפי שם, של המדפסת אשר תדפיס את המשימה שברצונך לבטל.
‎-j JobNumber
נדרש. ציון, לפי מספר מזהה, של משימת ההדפסה שברצונך לבטל.
‎-u UserName ‎-w Password
ציון חשבון עם הרשאות לחיבור באמצעות השירותים של Windows Management Instrumentation ‏(WMI) למחשב שאליו נשלחה משימת ההדפסה שברצונך לבטל. לכל החברים בקבוצה Administrators באותו מחשב הוענקו הרשאות אלה, אך ניתן להעניק את ההרשאות גם למשתמשים אחרים. אם לא תציין חשבון, עליך לבצע כניסה למחשב תחת חשבון עם הרשאות אלה כדי שהפקודה תפעל. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא לספריה זו בתחילת הפקודה cscript.
  • כדי להציג רשימה של משימות הדפסה ושל מספרי המזהים שלהן, השתמש בפקודה זו עם הפרמטר ‎-l.
  • אם המידע שתספק כולל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").

לשם פירוט משימות ההדפסה בתור הדפסה

תחביר

cscript prnjobs -l [-s RemoteComputer] [-p PrinterName‎] [-u UserName -w Password]‎

פרמטרים

‎-l
נדרש. קביעה כי ברצונך לפרט את כל משימות ההדפסה בתור הדפסה.
‎-s RemoteComputer
ציון, לפי שם, של המחשב המרוחק המארח את תור ההדפסה שברצונך להציג פירוט של המשימות הנמצאות בו. אם לא תציין מחשב, ייעשה שימוש במחשב המקומי.
‎-p PrinterName
ציון, לפי שם, של המדפסת שתור ההדפסה שלה מכיל את המשימות שברצונך להציג פירוט עבורן. אם לא תציין מדפסת, יפורטו כל המשימות בכל תורי ההדפסה.
‎-u UserName -w Password
ציון חשבון עם הרשאות לחיבור באמצעות השירותים של Windows Management Instrumentation ‏(WMI) למחשב המארח את תור ההדפסה שברצונך להציג פירוט עבור המשימות שאוחסנו בו. לכל החברים בקבוצה Administrators באותו מחשב הוענקו הרשאות אלה, אך ניתן להעניק את ההרשאות גם למשתמשים אחרים. אם לא תציין חשבון, עליך לבצע כניסה למחשב תחת חשבון עם הרשאות אלה כדי שהפקודה תפעל. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא לספריה זו בתחילת הפקודה cscript.
  • כדי להציג רשימה של משימות הדפסה ושל מספרי המזהים שלהן, השתמש בפקודה זו עם הפרמטר ‎-l.
  • אם המידע שתספק כולל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").

דוגמה

כדי לפרט את כל משימות ההדפסה הנוכחיות בתור עבור המדפסת המקומית הנקראת ColorPrinter_2, הקלד:

cscript prnjobs.vbs -l -p ColorPrinter_2


Prnmngr.vbs

פקודה זו מוסיפה, מוחקת ומפרטת מדפסות או חיבורי מדפסות, בנוסף להגדרה והצגה של מדפסת ברירת המחדל. ללא פרמטרים, הפקודה prnmngr.vbs מציגה עזרה של שורת פקודה עבור הפקודה prnmngr.vbs.

לשם הוספת מדפסת מקומית

תחביר

cscript prnmngr.vbs -a ‎-p PrinterName [-s RemoteComputer] -m DriverName -r PortName ‎[-u UserName -w Password]‎

פרמטרים

‎-a
נדרש. פרמטר זה מציין כי ברצונך להוסיף מדפסת מקומית.
‎-s RemoteComputer
פרמטר זה מציין את שם המחשב המרוחק שברצונך להוסיף אליו מדפסת מקומית. אם לא תציין מחשב, המדפסת תתווסף למחשב המקומי.
‎-p PrinterName
נדרש. פרמטר זה מציין את שם המדפסת המקומית שברצונך להוסיף.
‎-m DriverName
נדרש. פרמטר זה מציין את שם מנהל המדפסת עבור המדפסת המקומית שברצונך להוסיף. מנהלי התקנים נקראים לעתים קרובות בשם המדפסת שהם תומכים בה. עיין בתיעוד המדפסת לקבלת מידע נוסף.
‎-r PortName
נדרש. פרמטר זה מציין את היציאה שאליה מחוברת המדפסת. אם זו יציאה טורית או יציאה מקבילית, השתמש במזהה היציאה (לדוגמה, LPT1 או COM1). אם זו יציאת TCP/IP, השתמש בשם היציאה שצוין בעת הוספת היציאה. לקבלת מידע נוסף, ראה נושאים קרובים.
‎-u UserName -w Password
פרמטר זה מציין חשבון שברשותו הרשאות התחברות באמצעות שירותי Windows Management Instrumentation ‏(WMI) אל המחשב שברצונך להוסיף אליו מדפסת מקומית. כל חברי הקבוצה Administrators של אותו מחשב הם בעלי הרשאות אלה, אך ניתן להעניק את ההרשאות גם למשתמשים אחרים. אם לא תציין חשבון, עליך לבצע כניסה למחשב תחת חשבון שברשותו הרשאות אלה כדי שהפקודה תפעל. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא אל הספריה בתחילת הפקודה cscript.
  • אם המידע שסיפקת מכיל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").

דוגמה

כדי להוסיף מדפסת הנקראת ColorPrinter_2 המחוברת ליציאה LPT1 במחשב המקומי ומצריכה מנהל מדפסת הנקרא Color Printer Driver1, הקלד:

cscript prnmngr.vbs -a -p ColorPrinter_2 -m "Color Printer Driver1" -r lpt1:‎

לשם הוספת חיבור מדפסת

תחביר

cscript prnmngr.vbs -ac ‎-p PrinterName

פרמטרים

‎-ac
נדרש. פרמטר זה מציין כי ברצונך להוסיף חיבור מדפסת.
‎-p PrinterName
נדרש. פרמטר זה מציין את שם המדפסת שעבורה ברצונך להוסיף חיבור.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא אל הספריה בתחילת הפקודה cscript.
  • אם המידע שסיפקת מכיל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").

לשם מחיקת מדפסת

תחביר

cscript prnmngr.vbs -d ‎-p PrinterName ‎[-u UserName -w Password] [-s RemoteComputer]‎

פרמטרים

‎-d
נדרש. פרמטר זה מציין כי ברצונך למחוק מדפסת.
‎-p PrinterName
נדרש. פרמטר זה מציין את שם המדפסת שברצונך למחוק.
‎-u UserName -w Password
פרמטר זה מציין חשבון שברשותו הרשאות התחברות באמצעות שירותי Windows Management Instrumentation ‏(WMI) אל המחשב שממנו ברצונך למחוק מדפסת. כל חברי הקבוצה Administrators של אותו מחשב הם בעלי הרשאות אלה, אך ניתן להעניק את ההרשאות גם למשתמשים אחרים. אם לא תציין חשבון, עליך לבצע כניסה למחשב תחת חשבון שברשותו הרשאות אלה כדי שהפקודה תפעל. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎-s RemoteComputer
פרמטר זה מציין את שם המחשב המרוחק שברצונך להוסיף אליו מדפסת מקומית. אם לא תציין מחשב, המדפסת תתווסף למחשב המקומי.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא אל הספריה בתחילת הפקודה cscript.
  • אם המידע שסיפקת מכיל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").

דוגמה

כדי למחוק את המדפסת הנקראת ColorPrinter_2 מהמחשב המרוחק הנקרא HRServer, הקלד:

cscript prnmngr.vbs -d -s HRServer -p ColorPrinter_2

לשם מחיקת כל המדפסות מהמחשב

תחביר

cscript prnmngr.vbs -x [-s RemoteComputer]‎ ‎[-u UserName] [-w Password]‎

פרמטרים

‎-x
נדרש. פרמטר זה מציין כי ברצונך למחוק את כל המדפסות ממחשב.
‎-s RemoteComputer
פרמטר זה מציין את שם המחשב המרוחק שממנו ברצונך למחוק את כל המדפסות. אם לא תציין מחשב, כל המדפסות יימחקו מהמחשב המקומי.
‎-u UserName -w Password
פרמטר זה מציין חשבון שברשותו הרשאות התחברות באמצעות שירותי Windows Management Instrumentation ‏(WMI) אל המחשב שממנו ברצונך למחוק את כל המדפסות. כל חברי הקבוצה Administrators של אותו מחשב הם בעלי הרשאות אלה, אך ניתן להעניק את ההרשאות גם למשתמשים אחרים. אם לא תציין חשבון, עליך לבצע כניסה למחשב תחת חשבון שברשותו הרשאות אלה כדי שהפקודה תפעל. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא אל הספריה בתחילת הפקודה cscript.
  • אם המידע שסיפקת מכיל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").

לשם הצגת המדפסת המהווה ברירת המחדל

תחביר

cscript prnmngr.vbs -g

פרמטרים

‎-g
נדרש. פרמטר זה מציין כי ברצונך להציג את מדפסת ברירת המחדל.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא אל הספריה בתחילת הפקודה cscript.
  • אם המידע שסיפקת מכיל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").

לשם הגדרת מדפסת שתהווה ברירת מחדל

תחביר

cscript prnmngr.vbs -t -p PrinterName

פרמטרים

‎-t
נדרש. פרמטר זה מציין כי ברצונך להגדיר את המדפסת שתהווה ברירת מחדל.
‎-p PrinterName
נדרש. פרמטר זה מציין את שם המדפסת שברצונך להגדיר כמדפסת ברירת המחדל.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא אל הספריה בתחילת הפקודה cscript.
  • אם המידע שסיפקת מכיל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").

לשם הצגת פירוט של כל המדפסות עבור מחשב

תחביר

cscript prnmngr.vbs -l [-s RemoteComputer]‎ ‎[-u UserName -w Password]‎

פרמטרים

‎-l
נדרש. פרמטר זה מציין כי ברצונך להציג פירוט של כל המדפסות עבור מחשב.
‎-s RemoteComputer
פרמטר זה מציין את שם המחשב המרוחק שעבורו ברצונך להציג פירוט של המדפסות. אם לא תציין מחשב, יפורטו המדפסות שנוספו למחשב המקומי.
‎-u UserName -w Password
פרמטר זה מציין חשבון שברשותו הרשאות התחברות באמצעות שירותי Windows Management Instrumentation ‏(WMI) אל המחשב שעבורו ברצונך להציג פירוט של המדפסות. כל חברי הקבוצה Administrators של אותו מחשב הם בעלי הרשאות אלה, אך ניתן להעניק את ההרשאות גם למשתמשים אחרים. אם לא תציין חשבון, עליך לבצע כניסה למחשב תחת חשבון שברשותו הרשאות אלה כדי שהפקודה תפעל. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא אל הספריה בתחילת הפקודה cscript.
  • אם המידע שסיפקת מכיל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").


Prnport.vbs

פקודה זו יוצרת, מוחקת ומפרטת יציאות מדפסת תקניות מסוג TCP/IP, בנוסף להצגה ולשינוי של תצורת היציאה. ללא פרמטרים, prnport.vbs מציגה עזרה עבור הפקודה prnport.vbs.

לשם הוספת יציאת מדפסת תקנית מסוג TCP/IP

תחביר

cscript prnport.vbs -a -r PortName [-s RemoteComputer]‎ ‎-h IPAddress [-u UserName -w Password] [-o {raw -n PortNumber | lpr}] [-q QueueName]‎ ‎[-m{e | d}] [-i IndexName] [-y CommunityName] [-2{e | d}]‎

פרמטרים

‎-a
נדרש. פרמטר זה מציין כי ברצונך ליצור יציאת מדפסת תקנית מסוג TCP/IP.
‎-r PortName
נדרש. פרמטר זה מציין את היציאה שאליה מחוברת המדפסת.
‎-s RemoteComputer
פרמטר זה מציין את שם המחשב המרוחק שברצונך להוסיף לו את היציאה. אם לא תציין מחשב, היציאה תתווסף למחשב המקומי.
‎-h IPAddress
נדרש. פרמטר זה מציין את כתובת ה- IP שברצונך להקצות ליציאה.
‎-u UserName -w Password
פרמטר זה מציין חשבון שברשותו הרשאות התחברות באמצעות שירותי Windows Management Instrumentation ‏(WMI) אל המחשב שבו ברצונך ליצור יציאת מדפסת תקנית מסוג TCP/IP. כל חברי הקבוצה Administrators של אותו מחשב הם בעלי הרשאות אלה, אך ניתן להעניק את ההרשאות גם למשתמשים אחרים. אם לא תציין חשבון, עליך לבצע כניסה למחשב תחת חשבון שברשותו הרשאות אלה כדי שהפקודה תפעל. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎-o {raw -n PortNumber | lpr}‎
פרמטר זה מציין באיזה פרוטוקול משתמשת היציאה: TCP Raw או TCP LPR. בעת שימוש בפרוטוקול TCP Raw, הפרמטר מציין את מספר היציאה עבור יציאת מדפסת מסוג TCP Raw. כברירת מחדל, מספר יציאה זו הוא 9100. לקבלת מידע נוסף, ראה נושאים קרובים. מרבית המדפסות משתמשות בפרוטוקול TCP Raw. ברשתות UNIX, מדפסות משתמשות לעתים קרובות בפרוטוקול TCP LPR. לקבלת מידע נוסף אודות TCP Raw, ראה נושאים קרובים. לקבלת מידע נוסף אודות TCP LPR, ראה RFC 1179 באתר האינטרנט של RFC Editor.
‎-q QueueName
פרמטר זה מציין את שם התור עבור יציאה מסוג TCP Raw.
‎-m{e | d}‎
פרמטר זה מציין אם SNMP זמין. הפרמטר e הופך את SNMP לזמין. הפרמטר d הופך את SNMP ללא זמין.
‎-i IndexName
פרמטר זה מציין את אינדקס SNMP, אם SNMP זמין. לקבלת מידע נוסף, ראה RFC 1759 באתר האינטרנט של RFC Editor.
‎-y CommunityName
פרמטר זה מציין את שם הקהילה של SNMP, אם SNMP זמין. לקבלת מידע נוסף, ראה נושאים קרובים.
‎-2{e | d}‎
פרמטר זה מציין אם מאגרים כפולים (הנקראים גם Respooling) זמינים עבור יציאות TCP LPR. יש צורך במאגרים כפולים מכיוון שעל TCP LPR לכלול ספירת בתים מדויקת בקובץ הבקרה הנשלח למדפסת, אך לפרוטוקול אין אפשרות לקבל את הספירה מספק ההדפסה המקומי. לכן, כאשר קובץ נשלח לתור הדפסה מסוג TCP LPR, הוא גם נשמר כקובץ זמני בספריה system32. פרוטוקול TCP LPR קובע את גודל הקובץ הזמני ושולחת את הגודל אל השרת שבו פועל LPD. הפרמטר e הופך מאגרים כפולים לזמינים. הפרמטר d הופך מאגרים כפולים ללא זמינים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא אל הספריה בתחילת הפקודה cscript.
  • אם ברצונך לשנות את התצורה עבור יציאת המדפסת התקנית מסוג TCP/IP לאחר יצירתה, באפשרותך להשתמש בפקודה cscript prnport.vbs עם הפרמטר ‎-t.
  • אם המידע שסיפקת מכיל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").
  • XOX

לשם מחיקת יציאת מדפסת תקנית מסוג TCP/IP

תחביר

cscript prnport.vbs -d -r PortName [-s RemoteComputer]‎ ‎[-u UserName -w Password]‎

פרמטרים

‎-d
נדרש. פרמטר זה מציין כי ברצונך למחוק יציאת מדפסת תקנית מסוג TCP/IP.
‎-r PortName
נדרש. פרמטר זה מציין את יציאת המדפסת התקנית מסוג TCP/IP שברצונך למחוק.
‎-s RemoteComputer
פרמטר זה מציין את שם המחשב המרוחק שממנו יש למחוק את היציאה. אם לא תציין מחשב, היציאה תימחק מהמחשב המקומי.
‎-u UserName -w Password
פרמטר זה מציין חשבון שברשותו הרשאות התחברות באמצעות שירותי Windows Management Instrumentation ‏(WMI) אל המחשב שבו ברצונך למחוק יציאת מדפסת תקנית מסוג TCP/IP. כל חברי הקבוצה Administrators של אותו מחשב הם בעלי הרשאות אלה, אך ניתן להעניק את ההרשאות גם למשתמשים אחרים. אם לא תציין חשבון, עליך לבצע כניסה למחשב תחת חשבון שברשותו הרשאות אלה כדי שהפקודה תפעל. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא אל הספריה בתחילת הפקודה cscript.
  • אם המידע שסיפקת מכיל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").

דוגמה

כדי למחוק את יציאת המדפסת התקנית מסוג TCP/IP הנקראת IP_192.168.12.128 מהמחשב המרוחק הנקרא HRServer, הקלד:

cscript prnport.vbs -d -r IP_192.168.12.128 -s HRServer

לשם הצגת פירוט של יציאות המדפסת התקניות מסוג TCP/IP המותקנות במחשב

תחביר

cscript prnport.vbs -l [-s RemoteComputer]‎ ‎[-u UserName -w Password]‎

פרמטרים

‎-l
נדרש. פרמטר זה מציין כי ברצונך להציג פירוט של כל יציאות המדפסת התקניות מסוג TCP/IP המותקנות במחשב.
‎-s RemoteComputer
פרמטר זה מציין את שם המחשב המרוחק שעבורו ברצונך להציג פירוט של היציאות. אם לא תציין מחשב, יוצג פירוט של היציאות המותקנות במחשב המקומי.
‎-u UserName -w Password
פרמטר זה מציין חשבון שברשותו הרשאות התחברות באמצעות שירותי Windows Management Instrumentation ‏(WMI) אל המחשב שעבורו ברצונך להציג פירוט של כל יציאות המדפסת התקניות מסוג TCP/IP. כל חברי הקבוצה Administrators של אותו מחשב הם בעלי הרשאות אלה, אך ניתן להעניק את ההרשאות גם למשתמשים אחרים. אם לא תציין חשבון, עליך לבצע כניסה למחשב תחת חשבון שברשותו הרשאות אלה כדי שהפקודה תפעל. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא אל הספריה בתחילת הפקודה cscript.
  • אם המידע שסיפקת מכיל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").

דוגמה

כדי להציג פירוט של כל יציאות המדפסת התקניות מסוג TCP/IP במחשב המרוחק הנקרא HRServer, הקלד:

cscript prnport.vbs -l -s HRServer

לשם הצגת התצורה של יציאת מדפסת תקנית מסוג TCP/IP

תחביר

cscript prnport.vbs -g -r PortName [-s RemoteComputer]‎ ‎[-u UserName -w Password]‎

פרמטרים

‎-g
נדרש. פרמטר זה מציין כי ברצונך להציג את התצורה של יציאת מדפסת תקנית מסוג TCP/IP.
‎-r PortName
נדרש. פרמטר זה מציין את היציאה שברצונך להציג את תצורתה.
‎-s RemoteComputer
פרמטר זה מציין את שם המחשב המרוחק המארח את היציאה שברצונך להציג את תצורתה. אם לא תציין מחשב, יוצג מידע אודות תצורת היציאה כפי שנקבעה במחשב המקומי.
‎-u UserName -w Password
פרמטר זה מציין חשבון שברשותו הרשאות התחברות באמצעות שירותי Windows Management Instrumentation ‏(WMI) אל המחשב המארח את היציאה שברצונך להציג את תצורתה. כל חברי הקבוצה Administrators של אותו מחשב הם בעלי הרשאות אלה, אך ניתן להעניק את ההרשאות גם למשתמשים אחרים. אם לא תציין חשבון, עליך לבצע כניסה למחשב תחת חשבון שברשותו הרשאות אלה כדי שהפקודה תפעל. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא אל הספריה בתחילת הפקודה cscript.
  • אם המידע שסיפקת מכיל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").

לשם קביעת תצורה של יציאת מדפסת תקנית מסוג TCP/IP

תחביר

cscript prnport.vbs -t -r PortName [-s RemoteComputer]‎ ‎[-o {raw -n PortNumber | lpr}] [-h IPAddress] [-q QueueName]‎ ‎[-m{e | d}] [-i IndexName] [-y CommunityName] [-2{e | d}]‎ ‎[-u UserName -w Password]‎

פרמטרים

‎-t
נדרש. פרמטר זה מציין כי ברצונך לקבוע תצורה של יציאת מדפסת תקנית מסוג TCP/IP.
‎-r PortName
נדרש. פרמטר זה מציין את היציאה שאליה מחוברת המדפסת.
‎-s RemoteComputer
פרמטר זה מציין את שם המחשב המרוחק שבו ברצונך לקבוע את תצורת היציאה. אם לא תציין מחשב, תצורת היציאה תיקבע במחשב המקומי.
‎-o {raw -n PortNumber | lpr}‎
פרמטר זה מציין באיזה פרוטוקול משתמשת היציאה: TCP Raw או TCP LPR. בעת שימוש בפרוטוקול TCP Raw, הפרמטר מציין את מספר היציאה עבור יציאת מדפסת מסוג TCP Raw. כברירת מחדל, מספר יציאה זו הוא 9100. לקבלת מידע נוסף, ראה נושאים קרובים. מרבית המדפסות משתמשות בפרוטוקול TCP Raw. ברשתות UNIX, יציאות מדפסת משתמשות לעתים קרובות בפרוטוקול TCP LPR. לקבלת מידע נוסף אודות TCP Raw, ראה נושאים קרובים. לקבלת מידע נוסף אודות TCP LPR, ראה RFC 1179 באתר האינטרנט של RFC Editor.
‎-h IPAddress
פרמטר זה מציין את כתובת ה- IP של המדפסת שעבורה ברצונך לקבוע את תצורת היציאה.
‎-q QueueName
פרמטר זה מציין את שם התור עבור יציאת TCP Raw.
‎-m{e | d}‎
פרמטר זה מציין אם SNMP זמין. הפרמטר e הופך את SNMP לזמין. הפרמטר d הופך את SNMP ללא זמין.
‎-i IndexName
פרמטר זה מציין את אינדקס SNMP, אם SNMP זמין. לקבלת מידע נוסף, ראה RFC 1759 באתר האינטרנט של RFC Editor.
‎-y CommunityName
פרמטר זה מציין את שם הקהילה של SNMP, אם SNMP זמין. לקבלת מידע נוסף, ראה נושאים קרובים.
‎-2{e | d}‎
פרמטר זה מציין אם מאגרים כפולים (הנקראים גם Respooling) זמינים עבור יציאות TCP LPR. יש צורך במאגרים כפולים מכיוון שעל TCP LPR לכלול ספירת בתים מדויקת בקובץ הבקרה הנשלח למדפסת, אך לפרוטוקול אין אפשרות לקבל את הספירה מספק ההדפסה המקומי. לכן, כאשר קובץ נשלח לתור של יציאה מסוג TCP LPR, הוא נשלח גם כקובץ זמני לספריה system32. הפרוטוקול TCP LPR קובע את גודל הקובץ הזמני ושולח את הגודל אל השרת שפועל בו LPD. הפרמטר e הופך מאגרים כפולים לזמינים. הפרמטר d הופך מאגרים כפולים ללא זמינים.
‎-u UserName -w Password
פרמטר זה מציין חשבון שברשותו הרשאות התחברות באמצעות שירותי Windows Management Instrumentation ‏(WMI) אל המחשב שבו ברצונך לקבוע תצורה של יציאה. כל חברי הקבוצה Administrators של אותו מחשב הם בעלי הרשאות אלה, אך ניתן להעניק את ההרשאות גם למשתמשים אחרים. אם לא תציין חשבון, עליך לבצע כניסה למחשב תחת חשבון שברשותו הרשאות אלה כדי שהפקודה תפעל. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא אל הספריה בתחילת הפקודה cscript.
  • אם המידע שסיפקת מכיל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").
  • XOX


Prnqctl.vbs

פקודה זו מדפיסה עמוד ניסיון, משהה או מחדשת פעולה של מדפסת ומנקה את תור המדפסת. ללא פרמטרים, הפקודה prnqctl.vbs מציגה עזרה של שורת הפקודה.

לשם השהיית הדפסה

תחביר

cscript prnqctl.vbs -z [-s RemoteComputer]‎ ‎-p PrinterName ‎[-u UserName -w Password]‎

פרמטרים

‎-z
נדרש. פרמטר זה מציין כי ברצונך להשהות הדפסה.
‎-s RemoteComputer
פרמטר זה מציין את שם המחשב המרוחק שאליו מחוברת המדפסת שאת פעולתה ברצונך להשהות. אם לא תציין מחשב, תתבצע השהייה של פעולת המדפסת המחוברת למחשב המקומי.
‎-p PrinterName
נדרש. פרמטר זה מציין את שם המדפסת שאת פעולתה ברצונך להשהות.
‎-u UserName -w Password
פרמטר זה מציין חשבון שברשותו הרשאות התחברות באמצעות שירותי Windows Management Instrumentation ‏(WMI) אל המחשב המארח את המדפסת שאת פעולתה ברצונך להשהות. כל חברי הקבוצה Administrators של אותו מחשב הם בעלי הרשאות אלה, אך ניתן להעניק את ההרשאות גם למשתמשים אחרים. אם לא תציין חשבון, עליך לבצע כניסה למחשב תחת חשבון שברשותו הרשאות אלה כדי שהפקודה תפעל. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא אל הספריה בתחילת הפקודה cscript.
  • אם המידע שסיפקת מכיל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").

דוגמה

כדי להשהות את כל פעולות ההדפסה במדפסת הנקראת ColorPrinter_2, שמארח אותה מחשב מרוחק הנקרא HRServer, הקלד:

cscript prnqctl.vbs -z -s HRServer -p ColorPrinter_2

לשם חידוש הדפסה

תחביר

cscript prnqctl.vbs -m [-s RemoteComputer]‎ ‎-p PrinterName ‎[-u UserName -w Password]‎

פרמטרים

‎-m
נדרש. פרמטר זה מציין כי ברצונך לחדש הדפסה.
‎-s RemoteComputer
פרמטר זה מציין את שם המחשב המרוחק שאליו מחוברת המדפסת שאת פעולתה ברצונך לחדש. אם לא תציין מחשב, תחודש פעולת המדפסת המחוברת למחשב המקומי.
‎-p PrinterName
נדרש. פרמטר זה מציין את שם המדפסת שברצונך לחדש בה את ההדפסה.
‎-u UserName -w Password
פרמטר זה מציין חשבון שברשותו הרשאות התחברות באמצעות שירותי Windows Management Instrumentation ‏(WMI) אל המחשב המנהל את המדפסת שברצונך לחדש בה את ההדפסה. כל חברי הקבוצה Administrators של אותו מחשב הם בעלי הרשאות אלה, אך ניתן להעניק את ההרשאות גם למשתמשים אחרים. אם לא תציין חשבון, עליך לבצע כניסה למחשב תחת חשבון שברשותו הרשאות אלה כדי שהפקודה תפעל. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא אל אותה ספריה בתחילת הפקודה cscript.
  • אם המידע שסיפקת מכיל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").

דוגמה

כדי לחדש את כל פעולות ההדפסה במדפסת הנקראת ColorPrinter_2, שמארח אותה המחשב המרוחק הנקרא HRServer, הקלד:

cscript prnqctl.vbs -m -s HRServer -p ColorPrinter_2

לשם הדפסת עמוד ניסיון

תחביר

cscript prnqctl.vbs -e [-s RemoteComputer]‎ ‎-p PrinterName ‎[-u UserName -w Password]‎

פרמטרים

‎-e
נדרש. פרמטר זה מציין כי ברצונך להדפיס עמוד ניסיון.
‎-s RemoteComputer
פרמטר זה מציין את שם המחשב המרוחק שאליו מחוברת המדפסת שברצונך להדפיס בה עמוד ניסיון. אם לא תציין מחשב, ייעשה שימוש במחשב המקומי.
‎-p PrinterName
נדרש. פרמטר זה מציין את שם המדפסת שברצונך להדפיס בה עמוד ניסיון.
‎-u UserName -w Password
פרמטר זה מציין חשבון שברשותו הרשאות התחברות באמצעות שירותי Windows Management Instrumentation ‏(WMI) אל המחשב המנהל את המדפסת שברצונך להדפיס בה עמוד ניסיון. כל חברי הקבוצה Administrators של אותו מחשב הם בעלי הרשאות אלה, אך ניתן להעניק את ההרשאות גם למשתמשים אחרים. אם לא תציין חשבון, עליך לבצע כניסה למחשב תחת חשבון שברשותו הרשאות אלה כדי שהפקודה תפעל. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא אל אותה ספריה בתחילת הפקודה cscript.
  • אם המידע שסיפקת מכיל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").

לשם ביטול כל המשימות המודפסות ברקע עבור מדפסת

תחביר

cscript prnqctl.vbs -x [-s RemoteComputer] -p PrinterName ‎[-u UserName -w Password]‎

פרמטרים

‎-x
נדרש. פרמטר זה מציין כי ברצונך לבטל את כל משימות ההדפסה ברקע עבור מדפסת.
‎-s RemoteComputer
פרמטר זה מציין את שם המחשב המרוחק שאליו מחוברת המדפסת שאת כל משימותיה ברצונך לבטל. אם לא תציין מחשב, ייעשה שימוש במחשב המקומי.
‎-p PrinterName
נדרש. פרמטר זה מציין את שם המדפסת שאת כל משימות ההדפסה שלה ברצונך לבטל.
‎-u UserName -w Password
פרמטר זה מציין חשבון שברשותו הרשאות התחברות באמצעות שירותי Windows Management Instrumentation ‏(WMI) אל המחשב שבו ברצונך לבטל את כל משימות האבטחה. כל חברי הקבוצה Administrators של אותו מחשב הם בעלי הרשאות אלה, אך ניתן להעניק את ההרשאות גם למשתמשים אחרים. אם לא תציין חשבון, עליך לבצע כניסה למחשב תחת חשבון שברשותו הרשאות אלה כדי שהפקודה תפעל. לקבלת מידע נוסף אודות WMI, ראה נושאים קרובים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פקודה זו מפעילה קובץ Script הממוקם בספריה systemroot\system32. עליך להקליד פקודה זו בשורת פקודה כאשר ספריה זו היא הספריה הנוכחית. לחלופין, הקלד את הנתיב המלא לאותה ספריה בתחילת הפקודה cscript.
  • אם המידע שסיפקת מכיל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").


Prompt

פקודה זו משנה את שורת הפקודה של Cmd.exe. ללא פרמטרים, הפקודה prompt גורמת לאיפוס שורת הפקודה להגדרת ברירת המחדל: אות הכונן הנוכחי, ספריה נוכחית וסימן גדול מ- (‎>‎).

תחביר

prompt [text]‎

פרמטרים

text
ציון הטקסט או המידע שברצונך לכלול בשורת הפקודה של המערכת.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • באפשרותך להתאים אישית את שורת הפקודה כך שתציג כל טקסט שברצונך להציג, לרבות מידע כגון שם הספריה הנוכחית, שעה ותאריך או מספר הגירסה של Windows XP.
  • הטבלה שלהלן מפרטת את שילובי התווים שבאפשרותך לכלול במקום או בנוסף למחרוזת תווים אחת או יותר באפשרות שורת הפקודה text. הרשימה מכילה תיאור קצר של הטקסט או של המידע שכל שילוב תווים מוסיף לשורת הפקודה.
    תו | תיאור
    ‎$q | = (סימן שוויון)
    $$ $ (סימן דולר)
    ‎$t | שעה נוכחית
    ‎$d | תאריך נוכחי
    ‎$p | כונן ונתיב נוכחיים
    ‎$v | מספר גירסה של Windows XP
    ‎$n | כונן נוכחי
    ‎$g | < (סימן גדול מ-)
    ‎$l | > (סימן קטן מ-)
    ‎$b | (תו Pipe)
    ‎$_‎ הזנת שורה
    ‎$e | קוד Escape של ANSI (קוד 27)
    ‎$h | מחיקה (כדי למחוק תו שהוקלד לשורת הפקודה)
    ‎$a | & (אמפרסנד)
    ‎$c | ) (תו סוגריים שמאלי)
    ‎$f | ( (תו סוגריים ימני)
    ‎$s | רווח
  • כאשר הרחבות פקודה זמינות (כלומר, ברירת המחדל), הפקודה prompt תומכת בתווי העיצוב המפורטים בטבלה שלהלן.
    תו | תיאור
    ‎$+‎ אפס או יותר תווים של סימן חיבור (+) בהתאם לעומק מחסנית הספריה של pushd, תו אחד עבור כל רמה שבוצעה עליה הפעולה Push.
    ‎$m | השם המרוחק המשויך לאות של הכונן הנוכחי או המחרוזת הריקה אם הכונן הנוכחי אינו כונן רשת.
  • אם כללת את התו ‎$p בפרמטר הטקסט, מתבצעת קריאה של הדיסק לאחר הזנת כל פקודה, וזאת כדי לקבוע את הכונן ואת הנתיב הנוכחיים. פעולה זו עשויה לארוך זמן נוסף, בייחוד עבור כונני תקליטונים.

דוגמאות

הדוגמה שלהלן מגדירה את שורת הפקודה להצגה של הכונן ושל הנתיב הנוכחיים ואחריהם סימן גדול מ- (<):

prompt $p$g

הפקודה הבאה שלהלן גורמת להצגה של שורת פקודה בת שתי שורות, כאשר השעה הנוכחית מוצגת בשורה הראשונה והתאריך הנוכחי מוצג בשורה השניה.

prompt time is: $t$_date is: $d


Pushd

פקודה זו מאחסנת את שם הספריה הנוכחית לשימוש הפקודה popd לפני מעבר מן הספריה הנוכחית אל הספריה שצוינה.

תחביר

pushd [Path]‎

פרמטרים

Path
ציון הספריה שאליה יש לעבור מן הספריה הנוכחית. פקודה זו תומכת בנתיבים יחסיים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • בכל שימוש בפקודה pushd, מתבצע אחסון של ספריה בודדת לשימושך. עם זאת, באפשרותך לאחסן ספריות רבות על-ידי שימוש חוזר בפקודה pushd.

    הספריות מאוחסנות ברצף במחסנית וירטואלית. אם תשתמש בפקודה pushd פעם אחת, הספריה שמתוכה השתמשת בפקודה תמוקם בתחתית המחסנית. אם תשתמש בפקודה שוב, הספריה השניה תמוקם מעל הספריה הראשונה. התהליך חוזר על עצמו בכל שימוש בפקודה pushd.

    באפשרותך להשתמש בפקודה popd כדי להחליף את הספריה הנוכחית לספריה האחרונה שאוחסנה באמצעות הפקודה pushd. אם תשתמש בפקודה popd, הספריה שבראש המחסנית תוסר מהמחסנית ברגע שהספריה הנוכחית תשתנה לאותה ספריה. אם תשתמש בפקודה popd שוב, תתבצע הסרה של הספריה הבאה במחסנית.
  • אם הרחבות פקודה זמינות, הפקודה pushd מקבלת נתיב רשת או אות ונתיב של כונן מקומי.
  • אם ציינת נתיב רשת, הפקודה pushd מקצה זמנית את אות הכונן הראשונה שאינה נמצאת בשימוש (החל באות Z:‎) למשאב הרשת שצוין. בשלב זה הפקודה משנה את הכונן והספריה הנוכחיים לספריה שצוינה בכונן החדש שהוקצה. אם תשתמש בפקודה popd כאשר הרחבות פקודה זמינות, הפקודה popd תסיר את הקצאת אות הכונן שנוצרה באמצעות pushd.

דוגמאות

באפשרותך להשתמש בפקודה pushd ובפקודה popd בתוכנית אצווה כדי לעבור מן הספריה שהופעלה בה תוכנית האצווה לספריה אחרת, ובחזרה. דוגמת תוכנית האצווה הבאה מציגה אופן לביצוע פעולה זו:

‎@echo off
rem This batch file deletes all .txt files in a specified directory
pushd %1
del *.txt
popd
cls
echo All text files deleted in the %1 directory


Rasdial

הופך את תהליך ההתקשרות לאוטומטית עבור כל לקוח Microsoft. שימוש ב- rasdial מביא להצגת המצב הנוכחי של ההתקשרויות.

תחביר

rasdial ConnectionName [UserName [{Password|*}]] [/domain:Domain] [/phone:PhoneNumber] [/callback:CallbackNumber] [/phonebook:PhonebookPath] [/prefixsuffix]

rasdial [ConnectionName] /disconnect

פרמטרים

ConnectionName
פרמטר זה נדרש בעת התקשרות לערך של פנקס טלפונים (‎.pbk). השתמש בפרמטר זה לקביעת ערך מסוים בקובץ ‎.pbk הנוכחי, הממוקם בתיקיה systemroot\System32\Ras. אם הערך של ConnectionName מכיל רווחים או תווים מיוחדים, תחום את הטקסט במרכאות (כלומר, "Connection Name").

אם לא נבחרה האפשרות פנקס טלפונים אישי, ייעשה שימוש בקובץ Rasphone.pbk‏. אם נבחרה האפשרות פנקס טלפונים אישי, ייעשה שימוש בקובץ UserName.pbk. השם יוצג בפס הכותרת של Rasphone לאחר בחירה באפשרות Personal Phonebook/p. מספרים יצורפו במקרה של התנגשות בין שמות.

UserName [{Password|*}]‎
ציון שם המשתמש והסיסמה שבאמצעותם תתבצע ההתקשרות. אם נעשה שימוש בתו כוכבית (*), המשתמש יתבקש להזין את הסיסמה, אך התווים המוקלדים לא יוצגו.
‎/domain:Domain
ציון קבוצת המחשבים שחשבון המשתמש נמצא בה. אם לא צוין ערך, ייעשה שימוש בערך האחרון שהוזן בשדה קבוצת מחשבים בתיבת הדו-שיח התקשרות אל.
‎/phone:PhoneNumber
החלפת מספר הטלפון שצוין במספר הטלפון של הערך בקובץ Rasphone.pbk.
‎/callback:CallbackNumber
החלפת המספר שנקבע להתקשרות חזרה במספר להתקשרות חזרה של הערך בקובץ Rasphone.pbk.
‎/phonebook:PhonebookPath
קביעת הנתיב לקובץ של פנקס הטלפונים. ברירת המחדל היא systemroot\System32\Ras\UserName.pbk. באפשרותך לציין נתיב מלא אל הקובץ.
‎/prefixsuffix
החלת הגדרות החיוג של מיקום TAPI הנוכחי על מספר הטלפון. הגדרות אלה נקבעות תחת טלפוניה בלוח הבקרה. כברירת מחדל, אפשרות זו אינה מופעלת.
‎/disconnect
פרמטר זה נדרש בעת התנתקות. ניתוק הערך שצוין. באפשרותך להתנתק גם על-ידי הקלדת ‎/d.

הערות

  • התכונות הבאות של קובץ Rasphone.exe אינן נתמכות על-ידי הפקודה resdial:
    • ערכים עבורם נדרש ערך משתמש במצב מסוף בעת ביצוע רצף החיוג.
    • חיוג באמצעות מרכזיה או חיוג ידני.

דוגמאות

בדוגמה הבאה, פקודה זו מתקשרת לערך OFFICE ב- Rasphone.pbk:

rasdial office

בדוגמה הבאה, פקודה זו מתקשרת לערך OFFICE 2 ב- Rasphone.pbk ומציינת מספר להתקשרות חזרה:

rasdial "office 2" /callback:555-0100

בדוגמה הבאה, פקודה זו מתנתקת מהערך EAST OFFICE:

rasdial "EAST OFFICE" /d


Rcp

פקודה זו מעתיקה קבצים בין מחשב Windows XP לבין מחשב שפועל בו rshd, שירות המעטפת המרוחק (Daemon)‏. Windows XP ו- Windows 2000 אינן מספקות שירות rshd. ללא פרמטרים, הפקודה rcp מציגה עזרה.

תחביר

rcp ‎[{-a | -b}]‎ ‎[-h]‎ ‎[-r] [Host][.User:] [Source] [Host][.User:] [Path\Destination]‎

פרמטרים

‎-a
ציון מצב העברה של ASCII. במצב זה מומרים תווי סוף-שורה (End-Of-Line, ‏EOL) להחזרת גררה עבור UNIX ולהחזרת גררה/הזנת שורה עבור מחשבים. זה מצב ההעברה המשמש כברירת מחדל.
‎-b
ציון מצב העברה מסוג תמונה בינארית. לא מתבצעת המרה של החזרת גררה/הזנת שורה.
‎-h
העברת קבצי מקור שסומנו כמוסתרים (Hidden) אל מחשב Windows XP. ללא פרמטר זה, לא יועתקו קבצים מוסתרים.
‎-r
העתקה רקורסיבית של תוכן כל ספריות המשנה של המקור אל היעד.
Host
ציון המחשב המארח המקומי או המרוחק. אם הפרמטר Host צוין ככתובת IP או אם שם המחשב המארח מכיל נקודות (.), עליך לציין את המשתמש.
User
ציון שם המשתמש. אם לא צוין שם משתמש, נעשה שימוש בשם המשתמש המחובר כעת למערכת.
Source
ציון הקבצים שיש להעתיק.
Path\Destination
ציון הנתיב היחסי לספריית הכניסה במחשב המארח המרוחק. השתמש בתווי ה- Escape קו נטוי הפוך (\), מרכאות (") או גרשיים (‘) עבור נתיבים מרוחקים כדי להשתמש בתווים כלליים במחשב המארח המרוחק. אם צוינו קבצי מקור מרובים, היעד הוא ספריה.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • העברות מגורם חיצוני

    הפקודה rcp, פקודת קישוריות, ניתנת לשימוש גם עבור העברות מגורם חיצוני. באפשרותך להפעיל את הפקודה rcp ממחשב Windows XP כדי להעתיק קבצים בין שני מחשבים שונים שפועל בהם rshd. יישום ה- Daemon הנקרא rshd זמין במחשבי UNIX, כך שלמחשב Windows XP יש אפשרות להשתתף בהעברה מגורם חיצוני רק כמערכת המשמשת להפעלת הפקודות.

  • שימוש בפרמטר ‎-r

    על Source ועל Path\Destination להיות ספריות. עם זאת, באפשרותך להשתמש בפרמטר ‎-r ללא רקורסיות אם המקור אינו ספריה.

  • שימוש בפרמטרים Source ו- Path\Destination

    אם שם הקובץ אינו מתחיל בקו נטוי (/) עבור UNIX או בקו נטוי הפוך (\) עבור Windows XP, ההנחה היא כי שם הקובץ יחסי לספריה הנוכחית הפועלת. ב- Windows XP זו הספריה שבה הופעלה הפקודה. במערכת המרוחקת, זו ספריית הכניסה עבור המשתמש המרוחק. נקודה (.) מציינת את הספריה הנוכחית. השתמש בתווי היציאה קו נטוי הפוך (\), מרכאות (") או גרשיים (‘) בנתיבים מרוחקים כתווים כלליים במחשב המרוחק.

  • הרשאות מרוחקות

    הפקודה rcp אינה מציגה בקשות לסיסמאות. על שם המשתמש הנוכחי או שם המשתמש שצוין להתקיים במחשב המרוחק ולאפשר ביצוע מרוחק של הפקודה באמצעות rcp.

  • הקובץ ‎.rhosts

    הקובץ ‎.rhosts מציין לאילו מערכות מרוחקות או משתמשים מרוחקים תהיה אפשרות לגשת לחשבון מקומי באמצעות rsh או באמצעות rcp. יש צורך בקובץ זה (או ברכיב Hosts שווה ערך) כדי שתתאפשר גישה למערכת מרוחקת באמצעות פקודות אלה. הפקודה rsh והפקודה rcp משדרות את שם המשתמש המקומי למערכת המרוחקת. כדי לקבוע אם לאפשר גישה, המערכת המרוחקת עושה שימוש בשם זה ובכתובת IP (המפוענחת בדרך כלל לשם מחשב) של המערכת המבקשת. לא קיים אמצעי לציון סיסמה לשם גישה לחשבון באמצעות פקודות אלה.

    אם המשתמש מחובר לקבוצת מחשבים, על בקר קבוצת המחשבים הראשי להיות זמין לפענוח שם הכניסה, כיוון שזה אינו מאוחסן במטמון במחשב המקומי. מאחר ששם המשתמש נדרש כחלק מפרוטוקול rsh, הפקודה תיכשל אם אין אפשרות להשיג את השם.

    הקובץ ‎.rhosts הוא קובץ טקסט שכל שורה בו היא ערך. ערך מורכב משם המחשב המקומי, שם המשתמש המקומי והערות אודות הערך. כל ערך מופרד באמצעות טאב או באמצעות רווח. הערות מתחילות בסימן סולמית (#). לדוגמה:

    computer5marie #This computer is in room 31A

    על הקובץ ‎.rhosts להימצא בספריה הראשית של המשתמש במחשב המרוחק. לקבלת מידע נוסף אודות אופן היישום הספציפי של הקובץ ‎.rhosts במחשב מרוחק, עיין בתיעוד עבור המערכת המרוחקת.

    בנוסף, באפשרותך להוסיף את שם המחשב שלך לקובץ ‎/Etc/Hosts במחשב המרוחק. כך ניתנת למערכת המרוחקת אפשרות לאמת בקשות מרוחקות עבור המחשב שלך בעת השימוש בכלי שירות מסוג TCP/IP של Windows XP.

  • פירוט מחשבים (מארחים)

    השתמש בפרמטרים Computer.User כדי להשתמש בשם משתמש שאינו שם המשתמש הנוכחי. אם Computer.User צוין עם Source,על הקובץ ‎.rhosts במחשב המרוחק להכיל ערך עבור user כדלקמן:

    rcp host99.user7:file1 corp7.admin:file2

    על הקובץ ‎.rhosts ב- corp7 להכיל ערך עבור user7 ב- host99.

    אם שם מחשב ניתן כשם מלא של קבוצת מחשבים המכיל נקודות, יש לצרף לשם המחשב שם משתמש, כפי שתואר לעיל. כך נמנע פירוש הרכיב האחרון של שם קבוצת המחשבים כשם משתמש, לדוגמה:

    rcp domain-name1.user:user92 domain-name2.user:user7

  • עיבוד מרוחק

    עיבוד מרוחק מתבצע על-ידי הפעלת פקודה ממעטפת הכניסה של המשתמש ברוב מערכות UNIX. הפעלת הקובץ ‎.profile או הקובץ ‎.cshrc מתבצעת לפני ניתוח המבנה של שמות קבצים, וניתן להשתמש במשתני מעטפת מיוצאים (באמצעות תו Escape או מרכאות) בשמות קבצים מרוחקים.

  • העתקת קבצים

    אם תנסה להעתיק מספר קבצים לקובץ ולא לספריה, תתבצע העתקה של הקובץ האחרון בלבד. לפקודה rcp אין אפשרות להעתיק קובץ אל עצמו (על Source ו- Path/Destination להיות שונים).

    אם ביצעת כניסה למחשב של Windows XP Professional באמצעות קבוצת מחשבים שאינה קבוצת המחשבים המקומית ובקר קבוצת המחשבים הראשי אינו זמין, הפקודה תיכשל מכיוון שלפקודה rcp אין אפשרות לקבוע את שם המשתמש המקומי. הגבלה זהה חלה גם עבור rsh.

  • פקודה זו זמינה רק כאשר פרוטוקול Internet Protocol ‏(TCP/IP) הותקן כרכיב במאפיינים של מתאם רשת בחיבורי רשת.

דוגמאות

כדי להעתיק קובץ מקומי לספריית הכניסה של מחשב מרוחק, הקלד:

rcp filename remotecomputer:‎

כדי להעתיק קובץ מקומי לספריה קיימת עם שם קובץ חדש במחשב מרוחק, הקלד:

rcp filename remotecomputer:/directory/newfilename

כדי להעתיק קבצים מקומיים מרובים לספריית משנה של ספריית כניסה מרוחקת, הקלד:

rcp file1 file2 file3 remotecomputer:subdirectory/filesdirectory

כדי להעתיק ממקור מרוחק לספריה הנוכחית של המחשב המקומי, הקלד:

rcp remotecomputer:filename

כדי להעתיק קבצים מרובים ממקורות מרוחקים מרובים ליעד מרוחק עם שמות משתמש שונים, הקלד:

rcp remote1.user1:file1 remote2.user2:file2 remotedest.destuser:directory


Recover

שחזור מידע קריא מדיסק פגום.

תחביר

recover [Drive:][Path] FileName

פרמטרים

‎[Drive:][Path] FileName
ציון המיקום והשם של הקובץ שברצונך לשחזר.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • הפקודה recover קוראת סקטור אחר סקטור של קובץ ומבצעת שחזור נתונים המאוחסנים בסקטורים תקינים. נתונים שאוחסנו בסקטורים פגומים אובדים.
  • מגבלה על ‎[drive:][path]filename

    לא ניתן להשתמש בתווים כלליים (* ו- ?) בעת שימוש בפקודה recover. יש לציין קובץ.

  • הזנה מחדש של נתונים שאבדו

    מאחר שכל הנתונים בסקטורים פגומים אובדים בעת שחזור קובץ, יש לשחזר כל קובץ בנפרד. באפשרותך להשתמש בשיטה זו כדי לערוך כל קובץ ולהזין מחדש מידע חסר לאחר שחזור הקובץ.

  • שחזור סקטורים פגומים

    סקטורים פגומים שדווחו על-ידי chkdsk סומנו כ- "bad" (פגומים) כאשר הדיסק הוכן לראשונה לשימוש. סקטורים אלה אינם מהווים סכנה, והפקודה recover אינה משפיעה עליהם.

דוגמאות

כדי לשחזר את הקובץ Story.txt שבספריה ‎\Fiction בכונן D:‎, הקלד:

recover d:\fiction\story.txt


Gpupdate

ריענון של הגדרות מקומיות ומבוססות Active Directory של מדיניות קבוצתית, ובכלל זה הגדרות אבטחה. פקודה זו מחליפה את האפשרות ‎/refreshpolicy שאינה בשימוש עוד עבור הפקודה secedit.

תחביר

gpupdate [/target:{computer|user}] [/force] [/wait:value] [/logoff] [/boot]‎

פרמטרים

‎/target:{computer|user}‎
עיבוד של הגדרות Computer או של הגדרות User הנוכחיות בלבד. כברירת מחדל, מעובדות גם הגדרות המשתמש וגם הגדרות המחשב.
‎/force
התעלמות מכל מיטובי העיבוד והחלה מחדש של כל ההגדרות.
‎/wait:value
מספר השניות שבמהלכן ימתין הליך עיבוד המדיניות עד לסיום. הזמן המוקצב כברירת מחדל הוא 600 שניות. 0 פירושו "ללא המתנה"; ‎-1 פירושו "המתנה עד אין סוף".
‎/logoff
התנתקות לאחר השלמת הרענון. אפשרות זו נחוצה עבור ההרחבות בצד הלקוח של מדיניות קבוצתית שאינן פועלות במחזור רענון ברקע, אלא מופעלות כאשר המשתמש מבצע כניסה למחשב, כגון Software Installation ו- Folder Redirection. לאפשרות זו אין השפעה אם לא בוצעה קריאה להרחבות הדורשות את התנתקות המשתמש.
‎/boot
הפעלה מחדש של המערכת לאחר שהושלם הרענון. אפשרות זו דרושה להרחבות בצד הלקוח של מדיניות קבוצתית שאינן פועלות במחזור רענון ברקע, אלא מופעלות עם הפעלת המחשב, כגון Computer Software Installation. לאפשרות זו אין השפעה אם לא בוצעה קריאה להרחבות הדורשות את הפעלת המחשב מחדש.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • אם ביצעת שגיאת תחביר, מופיע סיכום תחביר שתוכנו דומה לתוכנו של נושא עזרה זה.

דוגמאות

הדוגמאות הבאות מראות כיצד באפשרותך להשתמש בפקודה gpupdate:

gpupdate

gpupdate /target:computer

gpupdate /force /wait:100

gpupdate /boot


Reg

הוספה, שינוי והצגת מידע וערכים של מפתחות משנה בפריטי רישום.

כדי לצפות בתחביר פקודה, לחץ על פקודה:

reg add

הוספת מפתח משנה או רשומה חדשים לרישום.

תחביר

reg add KeyName ‎[/v EntryName|/ve]‎ ‎[/t DataType]‎ ‎[/s separator]‎ ‎[/d value]‎ ‎[/f]‎

פרמטרים

KeyName
מציין את הנתיב המלא של מפתח המשנה. עבור מחשבים מרוחקים, כלול את שם המחשב לפני נתיב מפתח המשנה בתבנית ‎\\ComputerName\PathToSubkey. השמטה של ComputerName מביאה, כברירת מחדל, לביצוע הפעולה במחשב המקומי. התחל את הנתיב עם עץ המשנה המתאים. עצי המשנה החוקיים הם HKLM‏, HKCU‏, HKCR‏, HKU ו- HKCC.
‎/v EntryName
מציין את שם הפריט שיש להוסיף תחת מפתח המשנה שצוין.
‎/ve
מציין שלפריט שהוסף לרישום יש ערך ריק.
‎/t DataType
מציין את סוג הנתונים עבור הפריט. האפשרות DataType עשויה להיות אחת מהבאות:

REG_SZ

REG_MULTI_SZ

REG_DWORD_BIG_ENDIAN

REG_DWORD

REG_BINARY

REG_DWORD_LITTLE_ENDIAN

REG_LINK

REG_FULL_RESOURCE_DESCRIPTOR

REG_EXPAND_SZ

‎/s separator
מציין את התו המשמש להפרדת מופעים מרובים של נתונים. נמצא בשימוש כאשר צוין REG_MULTI_SZ כסוג הנתונים ויש להציג פירוט עבור יותר מפריט אחד. אם הפרמטר לא צוין, המפריד המוגדר כברירת מחדל הוא ‎\0.
‎/d value
מציין את הערך עבור פריט הרישום החדש.
‎/f
מוסיף את מפתח המשנה או את הפריט מבלי לבקש אישור.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • לא ניתן להוסיף עצי משנה באמצעות פעולה זו. גירסה זו של הפקודה Reg אינה מבקשת אישור בעת הוספת מפתח משנה.
  • הטבלה הבאה מפרטת את ערכי ההחזרה עבור הפעולה reg add.
    ערך | תיאור
    0 | הצלחה
    1 | כישלון

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה reg add:

reg add \hklm\software\myco /v data /t reg_binary /d fe340ead
reg add "hkcu\software\microsoft\winmine" /v Name3 /t reg_sz /d Anonymous
reg add "hkcu\software\microsoft\winmine" /v Time3 /t reg_dword /d 5

reg compare

השוואה בין פריטים או מפתחות משנה של רישום שצוינו.

תחביר

reg compare KeyName1 KeyName2 ‎[/v EntryName | /ve]‎ ‎{[/oa]|[/od]|[/os]|[on]}‎ ‎[/s]‎

פרמטרים

KeyName
מציין את הנתיב של מפתח המשנה. עבור מחשבים מרוחקים, כלול את שם המחשב לפני הנתיב של מפתח המשנה בתבנית ‎\\ComputerName\PathtoSubkey. השמטה של הפרמטר ComputerName מביאה, כברירת מחדל, לביצוע הפעולה במחשב המקומי. התחל את הנתיב עם עץ המשנה המתאים. עצי המשנה החוקיים הם HKLM‏, HKCU‏, HKCR‏, HKU ו- HKCC. אם צוין מחשב מרוחק, באפשרותך להשתמש רק בעצי המשנה HKLM ו-HKU.
‎/v EntryName
משווה פריט ספציפי תחת מפתח המשנה.
‎/ve
מציין שתתבצע השוואה רק עבור פריטים ללא ערך.
‎{[/oa]|[/od]|[/os]|[on]}‎
מציינים את אופן התצוגה של הבדלים ושל התאמות. ברירת המחדל היא ‎/od.
ערך | תיאור
‎/oa | מציין שיוצגו כל ההבדלים וההתאמות. כברירת מחדל, מוצגים רק ההבדלים.
‎/od | מציין שיוצגו רק ההבדלים. זו הגדרת ברירת המחדל.
‎/os | מציין שיוצגו רק ההתאמות. כברירת מחדל, מוצגים רק ההבדלים.
‎/on | מציין שלא יוצג דבר. כברירת מחדל, מוצגים רק ההבדלים.
‎/s Separator
משווה בין כל מפתחות המשנה והפריטים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • הטבלה הבאה מציגה פירוט של ערכי ההחזרה עבור הפעולה reg compare.
    ערך | תיאור
    0 | ההשוואה נעשתה בהצלחה והתוצאה זהה.
    1 | ההשוואה נכשלה.
    2 | ההשוואה הצליחה ונמצאו הבדלים.

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה reg compare:

reg compare "hkcu\software\microsoft\winmine" ‎"hkcu\software\microsoft\winmine" /od /s

reg copy

העתקת פריט רישום למיקום שצוין במחשב המקומי או המרוחק.

תחביר

reg copy KeyName1 KeyName2 ‎[/s]‎ ‎[/f]‎

פרמטרים

KeyName1
מציין את הנתיב המלא של מפתח המשנה שיש להעתיק. עבור מחשבים מרוחקים, כלול את שם המחשב לפני הנתיב של מפתח המשנה בתבנית ‎\\ComputerName\PathtoSubkey. השמטה של הפרמטר ComputerName מביאה, כברירת מחדל, לביצוע הפעולה במחשב המקומי. התחל את הנתיב עם עץ המשנה המתאים. עצי המשנה החוקיים הם HKLM‏, HKCU‏, HKCR‏, HKU ו- HKCC. אם צוין מחשב מרוחק, באפשרותך להשתמש רק בעצי המשנה HKLM ו-HKU.
KeyName2
מציין את הנתיב המלא של יעד מפתח המשנה. עבור מחשבים מרוחקים, כלול את שם המחשב לפני הנתיב של מפתח המשנה בתבנית ‎\\ComputerName\PathtoSubkey. השמטה של הפרמטר ComputerName מביאה, כברירת מחדל, לביצוע הפעולה במחשב המקומי. התחל את הנתיב עם עץ המשנה המתאים. עצי המשנה החוקיים הם HKLM‏, HKCU‏, HKCR‏, HKU ו- HKCC. אם צוין מחשב מרוחק, באפשרותך להשתמש רק בעצי המשנה HKLM ו-HKU.
‎/s
מעתיק את כל מפתחות המשנה והפריטים תחת מפתח המשנה שצוין.
‎/f
מעתיק את מפתח המשנה מבלי לבקש אישור.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • גירסה זו של הפקודה Reg אינה מבקשת אישור בעת העתקת מפתח משנה.
  • הטבלה הבאה מפרטת את ערכי ההחזרה עבור הפעולה reg copy.
    ערך | תיאור
    0 | הצלחה
    1 | כישלון

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה reg copy:

reg copy "hkcu\software\microsoft\winmine" "hkcu\software\microsoft\winminebk" /s /f
reg copy "hkcu\software\microsoft\winminebk" "hkcu\software\microsoft\winmine" /s

reg delete

מחיקה של מפתח משנה או של פריטים מהרישום.

תחביר

reg delete KeyName ‎[{/v EntryName|/ve|/va}]‎ ‎[/f]‎

פרמטרים

KeyName
מציין את הנתיב המלא של מפתח המשנה. עבור מחשבים מרוחקים, כלול את שם המחשב לפני הנתיב של מפתח המשנה בתבנית ‎\\ComputerName\PathtoSubkey. השמטה של הפרמטר ComputerName מביאה, כברירת מחדל, לביצוע הפעולה במחשב המקומי. התחל את הנתיב עם עץ המשנה המתאים. עצי המשנה החוקיים הם HKLM‏, HKCU‏, HKCR‏, HKU ו- HKCC.
‎/v EntryName
מוחק פריט ספציפי תחת מפתח המשנה. אם לא צוין פריט, יימחקו כל הפריטים ומפתחות המשנה תחת מפתח המשנה.
‎/ve
מציין שיימחקו רק פריטים ללא ערך.
‎/va
מוחק את כל הפריטים תחת מפתח המשנה שצוין. פרמטר זה אינו גורם למחיקת מפתחות משנה תחת מפתח המשנה שצוין.
‎/f
מחיקת מפתח משנה או פריט רישום קיים מבלי לבקש אישור.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • הטבלה הבאה מפרטת את ערכי ההחזרה עבור הפעולה reg delete.
    ערך | תיאור
    0 | הצלחה
    1 | כישלון

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה reg delete:

reg delete "hkcu\software\microsoft\winmine" /v Name1
reg delete "hkcu\software\microsoft\winmine" /v Time1
reg delete "hkcu\software\microsoft\winmine" /va

reg export

יצירת עותק של מפתחות המשנה, הפריטים והערכים שצוינו בקובץ כך שניתן להעבירם לשרתים אחרים.

תחביר

reg export KeyName FileName

פרמטרים

KeyName
מציין את הנתיב המלא של מפתח המשנה. הפעולה export פועלת רק במחשב המקומי. התחל את הנתיב עם עץ המשנה המתאים. עצי המשנה החוקים הם HKLM‏, HKCU‏, HKCR‏, HKU ו- HKCC.
FileName
מציין את השם והנתיב של הקובץ שברצונך לייצא. על הקובץ להיות בעל סיומת ‎.reg
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • הטבלה הבאה מפרטת את ערכי ההחזרה עבור הפעולה reg export.
    ערך | תיאור
    0 | הצלחה
    1 | כישלון

דוגמאות

הדוגמה הבאה מראה כיצד ניתן להשתמש בפקודה reg export:

reg export "hkcu\software\microsoft\winmine" c:\data\regbackups\wmbkup.reg

reg import

העתקת קובץ הכולל מפתחות משנה, פריטים וערכי רישום שיוצאו לתוך רישום המחשב המקומי.

תחביר

reg import FileName

פרמטרים

FileName
מציין את השם והנתיב של הקובץ שיועתק לתוך הרישום של המחשב המקומי. יש ליצור קובץ זה מראש באמצעות הפעולה reg export.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • הטבלה הבאה מפרטת את ערכי ההחזרה עבור הפעולה reg import.
    ערך | תיאור
    0 | הצלחה
    1 | כישלון

דוגמאות

הדוגמה הבאה מראה כיצד ניתן להשתמש בפקודה reg import:

reg import "hkcu\software\microsoft\winmine" c:\data\regbackups\wmbkup.reg

reg load

כתיבת מפתחות משנה ופריטים שנשמרו למפתח משנה אחר ברישום. הדבר נועד לשמש בקובץ זמני שניתן להשתמש בו לפתרון בעיות או לעריכת פרטי רישום.

תחביר

reg load KeyName FileName

פרמטרים

KeyName
מציין את הנתיב המלא של מפתח המשנה. עבור מחשבים מרוחקים, כלול את שם המחשב לפני הנתיב של מפתח המשנה בתבנית ‎\\ComputerName\PathtoSubkey. השמטה של הפרמטר ComputerName מביאה, כברירת מחדל, לביצוע הפעולה במחשב המקומי. התחל את הנתיב עם עץ המשנה המתאים. עצי המשנה החוקיים הם HKLM‏, HKCU‏, HKCR‏, HKU ו- HKCC.
FileName
מציין את השם והנתיב של הקובץ שייטען. על קובץ זה להיווצר באמצעות הפעולה reg save ועם סיומת ‎.hiv
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • הטבלה הבאה מפרטת את ערכי ההחזרה עבור הפקודה reg load.
    ערך | תיאור
    0 | הצלחה
    1 | כישלון

דוגמאות

הדוגמה הבאה מראה כיצד ניתן להשתמש בפקודה reg load:

reg load "hkcu\software\microsoft\winminebk2" wmbkup.hiv

reg query

החזרת רשימה של הרמה הבאה של מפתחות משנה ופריטים הממוקמים תחת מפתח משנה ברישום.

תחביר

reg query KeyName ‎[{/v EntryName|/ve}]‎ ‎[/s]‎

פרמטרים

KeyName
מציין את הנתיב המלא של מפתח המשנה. עבור מחשבים מרוחקים, כלול את שם המחשב לפני הנתיב של מפתח המשנה בתבנית ‎\\ComputerName\PathtoSubkey. השמטה של הפרמטר ComputerName מביאה, כברירת מחדל, לביצוע הפעולה במחשב המקומי. התחל את הנתיב עם עץ המשנה המתאים. עצי המשנה החוקיים הם HKLM‏, HKCU‏, HKCR‏, HKU ו- HKCC. אם צוין מחשב מרוחק, ניתן להשתמש רק בעצי המשנה HKLM ו- HKU.
‎/v EntryName
מחזיר פריט ספציפי ואת הערך שלו. פרמטר זה מחזיר רק פריטים הנמצאים בדיוק ברמה שמתחת למפתח המשנה שצוין. פריטים הממוקמים במפתחות משנה מתחת למפתח המשנה הנוכחי לא יוחזרו בחיפוש. כאשר מושמט הפרמטר EntryName, מוחזרים כל הפריטים תחת מפתח המשנה.
‎/ve
מציין שיוחזרו רק פריטים ללא ערך.
‎/s
מחזיר את כל מפתחות המשנה וכל הערכים בכל הרמות. ללא פרמטר זה, תוחזר רק הרמה הבאה של מפתחות משנה וערכים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • הטבלה הבאה מפרטת את ערכי ההחזרה עבור הפקודה reg query.
    ערך | תיאור
    0 | הצלחה
    1 | כישלון

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה reg query:

reg query "hklm\system\currentcontrolset\control\session manager" /v maxstacktracedepth

reg query "hkcu\software\microsoft\winmine" /s

reg restore

כתיבת מפתחות משנה ופריטים שנשמרו בחזרה לרישום.

תחביר

reg restore KeyName FileName

פרמטרים

KeyName
מציין את הנתיב המלא של מפתח המשנה. הפעולה restore פועלת במחשב המקומי בלבד. התחל את הנתיב עם עץ המשנה המתאים. עצי המשנה החוקיים הם HKLM‏, HKCU‏, HKCR‏, HKU ו- HKCC.
FileName
מציין את השם והנתיב של הקובץ שייכתב בחזרה לרישום. יש ליצור קובץ זה מראש באמצעות הפעולה reg save ועם סיומת ‎.hiv
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פעולה זו משמשת להחלפת פריטי רישום שנערכו. לפני עריכת פריטים, שמור את מפתח המשנה המשמש כאב באמצעות הפעולה reg save. אם העריכה נכשלת, שחזר את מפתח המשנה באמצעות פעולה זו.
  • הטבלה הבאה מפרטת את ערכי ההחזרה עבור הפקודה reg restore.
    ערך | תיאור
    0 | הצלחה
    1 | כישלון

דוגמאות

הדוגמה הבאה מראה כיצד ניתן להשתמש בפקודה reg restore:

reg restore "hkcu\software\microsoft\winmine" wmbkup.hiv

reg save

שמירת עותק של מפתחות המשנה, הפריטים והערכים של הרישום שצוינו בקובץ שצוין.

תחביר

reg save KeyName FileName

פרמטרים

KeyName
מציין את הנתיב המלא של מפתח המשנה. עבור מחשבים מרוחקים, כלול את שם המחשב לפני הנתיב של מפתח המשנה בתבנית ‎\\ComputerName\PathtoSubkey. השמטה של הפרמטר ComputerName מביאה, כברירת מחדל, לביצוע הפעולה במחשב המקומי. התחל את הנתיב עם עץ המשנה המתאים. עצי המשנה החוקיים הם HKLM‏, HKCU‏, HKCR‏, HKU ו- HKCC.
FileName
מציין את השם והנתיב של הקובץ שנוצר. אם לא צוין נתיב, נעשה שימוש בנתיב הנוכחי.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • הטבלה הבאה מפרטת את ערכי ההחזרה עבור הפקודה reg save.
    ערך | תיאור
    0 | הצלחה
    1 | כישלון

דוגמאות

הדוגמה הבאה מראה כיצד ניתן להשתמש בפקודה reg save:

reg save "hkcu\software\microsoft\winmine" wmbkup.hiv

reg unload

הסרה מהרישום של מקטע שנטען באמצעות הפעולה reg load.

תחביר

reg unload KeyName

פרמטרים

KeyName
מציין את הנתיב המלא של מפתח המשנה. עבור מחשבים מרוחקים, כלול את שם המחשב לפני הנתיב של מפתח המשנה בתבנית ‎\\ComputerName\PathtoSubkey. השמטה של הפרמטר ComputerName מביאה, כברירת מחדל, לביצוע הפעולה במחשב המקומי. התחל את הנתיב עם עץ המשנה המתאים. עצי המשנה החוקיים הם HKLM‏, HKCU‏, HKCR‏, HKU ו- HKCC.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • הטבלה הבאה מפרטת את ערכי ההחזרה עבור הפקודה reg unload.
    ערך | תיאור
    0 | הצלחה
    1 | כישלון

דוגמאות

הדוגמה הבאה מראה כיצד ניתן להשתמש בפקודה reg unload:

reg unload "hkcu\software\microsoft\winminebk2"‎

שים לב

  • עריכה לא נכונה של הרישום עשויה לגרום נזק חמור למערכת. לפני עריכת שינויים ברישום, מומלץ לגבות את כל הנתונים החשובים במחשב.

שים לב

  • אל תערוך את הרישום באופן ישיר אלא אם אין ברירה אחרת. עורך הרישום עוקף אמצעי הגנה סטנדרטיים ומאפשר הגדרות העשויות לפגוע בביצועים, לגרום נזק למערכת, ואפילו להצריך התקנה מחדש של Windows. באפשרותך לשנות בבטחה את רוב הגדרות הרישום באמצעות התוכניות בלוח הבקרה או ב- Microsoft Management Console ‏(MMC). אם עליך לערוך את הרישום ישירות, גבה אותו לפני שתעשה כן. קרא את העזרה עבור עורך הרישום לקבלת מידע נוסף.

הערות

  • השימוש בפקודה Reg משמש לשם עריכה ישירה של הרישום במחשבים מקומיים או מרוחקים. שינוים אלה עשויים להשבית את המחשבים, ולחייב התקנה מחדש של מערכת ההפעלה. במקום לערוך את הרישום ישירות, השתמש בלוח הבקרה או ב- Microsoft Management Console כדי לבצע שינויים ברישום, אם באפשרותך לעשות זאת.
  • פעולות מסוימות מאפשרות הצגה או קביעת תצורה של פריטי רישום במחשבים מקומיים או מרוחקים, ואחרות מאפשרות קביעת תצורה עבור מחשבים מקומיים בלבד. בנוסף, גישה מרחוק לרישום עשויה להגביל את הפרמטרים שניתן להשתמש בהם לביצוע פעולה. בדוק את התחביר עבור כל פעולה כדי לוודא שניתן להשתמש בה במחשבים מרוחקים וכדי לבדוק מה הם הפרמטרים שניתן להשתמש בהם במקרה זה.


Regsvr32

כלי שורת פקודה זה רושם קבצי ‎.dll כרכיבי פקודה ברישום.

תחביר

regsvr32 [/u] [/s] [/n] [/i[:cmdline]] dllname

פרמטרים

‎/u
מבטל רישום שרת.
‎/s
מציין שעל regsvr32 לפעול בצורה שקטה ולא להציג תיבות הודעה כלשהן.
‎/n
מציין שאין לבצע קריאה אל DllRegisterServer. עליך להשתמש באפשרות זו יחד עם ‎/i.
‎/i:cmdline
ביצוע קריאה אל DllInstall עם העברת [cmdline] אופציונלי. בעת שימוש עם הפרמטר ‎/u, מתבצעת קריאה אל Dll Uninstall.
dllname
מציין את שם קובץ ה- ‎.dll שיש לרשום.
‎/?‎
הצגת עזרה בשורת הפקודה.

דוגמאות

כדי לבצע רישום של קובץ ה- ‎.dll עבור Active Directory Schema, הקלד:

regsvr32 schmmgmt.dll


Rem

פקודה זו מאפשרת לכלול הערות בקובץ אצווה או בקבצי קביעת התצורה.

תחביר

rem [comment]‎

פרמטרים

comment
ציון כל מחרוזת תווים שברצונך לכלול כהערה.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • שימוש בפקודה echo לשם הצגת הערות

    הפקודה rem אינה גורמת להצגת הערות על המסך. עליך להשתמש בפקודה echo on בקובץ האצווה או בקובץ Config.nt כדי להציג הערות על המסך.

  • מגבלות על הערות בקובץ אצווה

    לא ניתן לעשות שימוש בתווי הניתוב מחדש ‎"("‎‏, ‎")"‎ או בתו Pipe (|) בהערה בקובץ אצווה.

  • שימוש ב- rem לשם הוספת מרווח אנכי

    אף-על-פי שניתן להשתמש ב- rem ללא הערה כדי להוסיף מרווח אנכי לקובץ אצווה, ניתן להשתמש גם בשורות ריקות. המערכת מתעלמת משורות ריקות בעת עיבוד של תוכנית אצווה.

דוגמאות

הדוגמה שלהלן מציגה קובץ אצווה העושה שימוש בהערות לצורך מתן הסברים וגם לצורך יצירת מרווח אנכי:

‎@echo off
rem This batch program formats and checks new disks.‎
rem It is named Checknew.bat.‎
rem
echo Insert new disk in drive B.‎
pause
format b: /v
chkdsk b:‎

אם ברצונך לכלול בקובץ Config.nt הערת הסבר לפני הפקודה prompt, הוסף לקובץ Config.nt את השורות הבאות:

rem Set prompt to indicate current directory
prompt $p$g


(Rename (ren

גרפיקה של Microsoft Windows

Rename ‏(ren)

שינוי שם של קובץ או של ערכת קבצים.

תחביר

rename [Drive:][Path] filename1 filename2

ren [Drive:][Path] filename1 filename2

פרמטרים

‎[Drive:][Path] filename1
פרמטר זה מציין את המיקום ואת השם של הקובץ או של ערכת הקבצים שאת שמם ברצונך לשנות.
filename2
פרמטר זה מציין את שם הקובץ החדש. בעת שימוש בתווים כלליים (* ו- ?), הפרמטר filename2 מציין את השמות החדשים עבור הקבצים. לא ניתן לציין כונן חדש או נתיב חדש בעת שינוי של שמות קבצים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • שינוי שמות קבצים

    באפשרותך לשנות את שמות כל הקבצים התואמים לשם הקובץ שצוין. לא ניתן להשתמש בפקודה rename כדי לשנות שמות של קבצים בכוננים אחרים כדי להעביר קבצים למיקום ספריה אחר.

  • שימוש בתווים כלליים בפקודה rename

    באפשרותך להשתמש בתווים כלליים (* ו- ?) בכל אחד משני הפרמטרים של שם קובץ. שימוש בתווים כלליים ב- filename2 יגרום לכך שהתו המיוצג על-ידי התו הכללי יהיה זהה לתו המקביל ב- filename1.

  • שינוי השם לא יפעל אם filename2 כבר קיים.

    אם תציין עבור הפרמטר filename2 שם קובץ קיים, תגרום הפקודה rename להצגת ההודעה הבאה:

    Duplicate file name or file not found

דוגמאות

נניח שברצונך לשנות את הסיומות של כל הקבצים בספריה הנוכחית שסיומת שם הקובץ שלהם היא ‎.txt; לדוגמה, אם ברצונך לשנות את סיומות שם הקובץ ‎.txt לסיומות ‎.doc, הקלד:

ren *.txt *.doc

כדי לשנות שם קובץ או שם ספריה הנקראים Chap10 ל- Part10, הקלד:

ren chap10 part10


Replace

פקודה זו גורמת להחלפת קבצים שבספריית היעד בקבצים בעלי שם זהה בספריית המקור. ניתן להשתמש בפקודה replace גם כדי להוסיף שמות קובץ ייחודיים לספריית היעד.

תחביר

replace [drive1:][path1] FileName [drive2:][path2] [/a] [/p] [/r] [/w]‎

replace [drive1:][path1] FileName [drive2:][path2] [/p] [/r] [/s] [/w] [/u]‎

פרמטרים

‎[drive1:][path1] FileName
ציון מיקום ושם של קובץ המקור או של ערכת קבצי המקור.
‎[drive2:][path2]‎
ציון המיקום של קובץ היעד. אין באפשרותך לציין שם קובץ עבור קבצים שברצונך להחליף. אם לא תציין כונן או ספריה, הפקודה replace תשתמש בכונן ובספריה הנוכחיים כיעד.
‎/a
מוסיף קבצים חדשים לספריית היעד במקום להחליף קבצים קיימים. לא ניתן להשתמש בפרמטר זה עם האפשרויות ‎/s או ‎/u.
‎/p
הצגת בקשה לאישור לפני החלפה של קובץ יעד או הוספה של קובץ מקור.
‎/r
מחליף קבצים לקריאה בלבד וכן קבצים ללא הגנה. אם לא תציין את פרמטר זה אך תנסה להחליף קובץ לקריאה בלבד, תיגרם שגיאה ופעולת ההחלפה תיפסק.
‎/w
המתנה להכנסת תקליטון לפני שהפקודה replace מתחילה בחיפוש של קבצי מקור. אם לא תציין את הבורר ‎/w, הפקודה replace מתחילה בהחלפה או בהוספה של קבצים מיד לאחר הקשת ENTER.
‎/s
מחפש בכל ספריות המשנה של ספריית היעד ומחליף קבצים תואמים. לא ניתן להשתמש בפרמטר ‎/s עם הפרמטר ‎/a. הפקודה replace אינה מבצעת חיפוש בספריות משנה שצוינו ב- path1.
‎/u
מחליף (מעדכן) רק את הקבצים בספריית היעד שנוצרו לפני הקבצים בספריית המקור. לא ניתן להשתמש בפרמטר ‎/u עם הפרמטר ‎/a.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • הודעות של Replace

    בשעה שהפקודה replace מבצעת הוספה או החלפה של קבצים, שמות הקבצים מוצגים על המסך. לאחר שהפקודה replace סיימה את פעולתה, מוצגת שורת סיכום באחת מהתבניות הבאות:

    nnn files added
    nnn files replaced

    no file added
    no file replaced

  • החלפת קבצים בתקליטונים

    אם נעשה שימוש בתקליטונים ועליך להחליף תקליטונים במהלך פעולתה של הפקודה replace, באפשרותך לציין את הפרמטר ‎/w כדי שביצוע הפקודה replace יושהה עד להחלפת התקליטונים, אם הדבר נדרש.

  • מגבלות על replace

    אין באפשרותך להשתמש בפקודה replace כדי לעדכן קבצים מוסתרים או קבצי מערכת. לקבלת מידע אודות שינוי של הגדרת קובץ כקובץ מוסתר או כקובץ מערכת, לחץ על attrib ברשימה נושאים קרובים.

  • קודי יציאה של replace

    הרשימה שלהלן מציגה את קודי היציאה ותיאור קצר של משמעותם:

    קוד יציאה | תיאור
    0 | הפקודה replace סיימה בהצלחה את פעולת ההחלפה או ההוספה של הקבצים.
    1 | הפקודה replace זיהתה גירסה שגויה של MS-DOS.
    2 | הפקודה replace נכשלה בניסיון למצוא את קבצי המקור.
    3 | הפקודה replace נכשלה בניסיון למצוא את נתיב המקור או את נתיב היעד.
    5 | למשתמש אין אפשרות גישה לקבצים שברצונך להחליף.
    8 | אין די זיכרון מערכת לביצוע הפקודה.
    11 | המשתמש הזין תחביר שגוי בשורת הפקודה.

    באפשרותך להשתמש בפרמטר errorlevel בשורת הפקודה if בתוכנית אצווה כדי לעבד קודי יציאה שהוחזרו על-ידי הפקודה replace. לקבלת דוגמה של תוכנית אצווה המעבדת קודי יציאה, לחץ על if ברשימה נושאים קרובים.

דוגמאות

נניח שמספר ספריות בכונן C מכילות גירסאות שונות של קובץ בשם Phones.cli, המכיל שמות לקוחות ומספרי טלפון. כדי להחליף את כל הקבצים האלה בגירסה העדכנית של הקובץ Phones.cli, הנמצאת בתקליטון שבכונן A, הקלד:

replace a:\phones.cli c:\ /s

כדי להוסיף מנהלי התקן חדשים של מדפסת לספריה בכונן C, הנקראת Tools וכבר מכילה מספר קבצים של מנהלי התקן מדפסת עבור מעבד תמלילים, הקלד:

replace a:*.prd c:\tools /a

פקודה זו מבצעת חיפוש אחר קבצים בעלי סיומת ‎.prd בספריה הנוכחית שבכונן A ולאחר מכן מוסיפה קבצים אלה לספריה Tools שבכונן C. מאחר שהפרמטר ‎/a כלול, הפקודה replace מוסיפה רק קבצים מכונן A שאינם קיימים בכונן C.


Rexec

הפעלת פקודות במחשבים מרוחקים שפועל בהם השירות Rexec ‏(Daemon). הפקודה rexec מאמתת את שם המשתמש במחשב המרוחק לפני הפעלת הפקודה שצוינה. Windows XP ו- Windows 2000 אינם מספקים את השירות Rexec. בשימוש ללא פרמטרים, הפקודה rexec מציגה עזרה.

תחביר

rexec [Host] [-l UserName] [-n] [Command]‎

פרמטרים

Host
מציין את השרת (המחשב) המרוחק שיש להפעיל בו את Command לפי כתובת IP או שם.
‎-l UserName
מציין את שם המשתמש במחשב המרוחק. אם הפרמטר מושמט, נעשה שימוש בשם של המשתמש המחובר כרגע.
‎-n
מנתב מחדש את הקלט של rexec להתקן NUL. דבר זה מונע הצגה של תוצאות הפקודה במחשב המקומי.
Command
קובע את הפעולה שברצונך להפעיל במחשב המרוחק.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פעולה רגילה

    הפקודה rexec מציגה בקשה לסיסמה ומבצעת במחשב המרוחק אימות של הסיסמה שהוזנה. אם האימות מושלם בהצלחה, הפקודה מבוצעת.

    הפקודה rexec מעתיקה קלט סטנדרטי לפקודה המרוחקת, פלט סטנדרטי של הפקודה Command במחשב המרוחק לפלט הסטנדרטי של אותה פקודה, ושגיאה סטנדרטית של הפקודה המרוחקת לשגיאה הסטנדרטית של אותה פקודה. לרוב, הפקודה rexec מסיימת את פעולתה כאשר מסתיים ביצוע הפקודה המרוחקת.

  • שימוש בסימני ניתוב מחדש

    כדי שיתרחש ניתוב מחדש במחשב המרוחק, תחום סימני ניתוב מחדש במרכאות (למשל, "<<"). אם אינך משתמש במרכאות, הניתוב מחדש מתרחש במחשב המקומי. לדוגמה, הפקודה שלהלן מצרפת את הקובץ המרוחק RemoteFile לקובץ המקומי LocalFile:

    rexec othercomputer cat remotefile >> localfile

    הפקודה שלהלן מצרפת את הקובץ המרוחק RemoteFile לקובץ המרוחק OtherRemoteFile:

    rexec othercomputer cat remotefile ">>" otherremotefile

  • שימוש בפקודות אינטראקטיביות

    לא ניתן להפעיל את מרבית הפקודות האינטראקטיביות. לדוגמה, לא ניתן להפעיל את vi או את emacs באמצעות הפקודה rexec. עם זאת, באפשרותך להשתמש בפקודה telnet במקום.

  • פקודה זו זמינה רק אם הותקן פרוטוקול Internet Protocol ‎(TCP/IP)‎ כרכיב במאפייני מתאם הרשת בחיבורי רשת.

דוגמאות

כדי להפעיל את הפקודה telcon במחשב המרוחק vax1 באמצעות השם admin1, הקלד את הפקודה הבאה:

rexec vax1 -l admin1 telcon


(Rmdir (rd

גרפיקה של Microsoft Windows

Rmdir ‏(rd)

הסרה (מחיקה) של ספריה.

תחביר

rmdir [Drive:]Path [/s] [/q]‎

rd [Drive:]Path [/s] [/q]‎

פרמטרים

‎[Drive:]Path
ציון שם ומיקום עבור הקובץ שברצונך למחוק.
‎/s
הסרת הספריה שצוינה והסרת כל ספריות המשנה ובכלל זה כל הקבצים. השתמש באפשרות ‎/s להסרת עץ.
‎/q
הפעלת rmdir במצב שקט. אפשרות זו מוחקת ספריות ללא בקשת אישור.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • שימוש בפקודה rmdir במסוף השחזור

    הפקודה rmdir, עם פרמטרים שונים, זמינה במסוף השחזור.

  • לא ניתן למחוק ספריה שמאוחסנים בה קבצים מוסתרים או קבצי מערכת

    אין באפשרותך למחוק ספריה המכילה קבצים שביניהם קבצים מוסתרים או קבצי מערכת. אם תנסה לעשות זאת, תוצג ההודעה הבאה:

    The directory not empty

    השתמש בפקודה dir כדי לקבל רשימה של הקבצים המוסתרים ושל קבצי המערכת ובפקודה attrib כדי להסיר את התכונות Hidden ו- System מקבצים. לקבלת מידע נוסף, ראה נושאים קרובים.

  • שימוש בקו נטוי הפוך (\) עם הפרמטר path

    אם תזין קו נטוי הפוך (\) לפני שם הספריה הראשון בפרמטר הנתיב (path), המערכת תתייחס לספריה כאל ספריית משנה של ספריית הבסיס, ללא תלות בספריה הנוכחית. אם לא תזין קו נטוי הפוך לפני שם הספריה הראשון בפרמטר path, המערכת תתייחס לספריה כאל ספריית משנה של הספריה הנוכחית.

  • מחיקת הספריה הנוכחית

    אין באפשרותך להשתמש בפקודה rmdir כדי למחוק את הספריה הנוכחית. תחילה יש לעבור לספריה אחרת (שאינה ספריית משנה של הספריה הנוכחית) ולאחר מכן להשתמש בפקודה rmdir עם ציון נתיב. אם תנסה למחוק את הספריה הנוכחית, תוצג ההודעה הבאה:

    The process cannot access the file because it is being used by another process.‎

דוגמאות

כדי למחוק ספריה ששמה ‎\User\Smith‎, תחילה ודא כי הספריה ריקה. כדי לעשות זאת, הקלד:

dir \user\smith /a

רק הסימנים "." ו- ".." אמורים להופיע.

לאחר מכן, מתוך ספריה כלשהי שאינה ‎\User\Smith‎, הקלד:

rmdir \user\smith

כדי למחוק את הספריה ‎\User ואת כל הקבצים וספריות המשנה שבתוכה, הקלד:

rmdir /s \user


Route

הצגה ושינוי של ערכים בטבלת ניתוב IP המקומית. בשימוש ללא פרמטרים, הפקודה route מציגה עזרה.

תחביר

route ‎[-f]‎ ‎[-p]‎ ‎[Command ‎[Destination]‎ ‎[mask Netmask]‎ ‎[Gateway]‎ ‎[metric Metric]]‎ ‎[if Interface]]‎

פרמטרים

‎-f
מנקה את טבלת הניתוב מכל הערכים שאינם ניתובים מארחים (ניתובים בעלי מסיכת הרשת 255.255.255.255), ניתובי רשת של לולאה חוזרת (Loopback) (ניתובים בעלי היעד 127.0.0.0 ומסיכת הרשת 255.0.0.0) או ניתובי שידור לקבוצה (ניתובים בעלי היעד 224.0.0.0 ומסיכת הרשת 240.0.0.0). אם נעשה שימוש בפרמטר זה יחד עם אחת הפקודות (כגון add‏, change או delete), הטבלה מנוקה לפני הפעלת הפקודה.
‎-p
בעת שימוש עם הפקודה add, הניתוב שצוין מוסף לרישום ומשמש להפעלת טבלת הניתוב של IP בכל פעם שמופעל פרוטוקול TCP/IP. כברירת מחדל, ניתובים שהוספו אינם נשמרים כאשר מופעל פרוטוקול TCP/IP. בשימוש עם הפקודה print, פרמטר זה מביא להצגת הרשימה של הניתובים הקבועים הרשומים. פרמטר זה אינו תקף בשאר הפקודות. ניתובים קבועים מאוחסנים במיקום הרישום.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services‎\Tcpip\Parameters\PersistentRoutes.
Command
מציין את הפקודה שיש להפעיל. הטבלה הבאה מפרטת פקודות חוקיות.
פקודה | מטרה
add | הוספת ניתוב.
change | שינוי ניתוב קיים.
delete | מחיקת ניתוב או ניתובים.
print | הדפסת ניתוב או ניתובים.
Destination
מציין את יעד הרשת עבור הניתוב. היעד עשוי להיות כתובת IP של רשת (כאשר סיביות האירוח של כתובת הרשת נקבעות ל- 0), כתובת IP עבור ניתוב מארח או 0.0.0.0 עבור הניתוב המוגדר כברירת מחדל.
mask Netmask
מציין את מסיכת הרשת (ידועה גם בשם מסיכת רשת משנה) המקושרת ליעד הרשת. מסיכת רשת המשנה עשויה להיות המסיכה המתאימה לכתובת IP של רשת, ‏255.255.255.255 עבור ניתוב מארח או 0.0.0.0 עבור הניתוב המוגדר כברירת מחדל. אם פרמטר זה מושמט, נעשה שימוש במסיכת רשת המשנה 255.255.255.25. בשל הקשר בין היעד ומסיכת רשת בהגדרת ניתובים, היעד לא יכול להיות ספציפי יותר ממסיכת רשת המשנה המתאימה. במילים אחרות, לא ניתן לקבוע סיבית ביעד כ- 1 אם הסיבית המתאימה במסיכת רשת המשנה מוגדרת כ- 0.
Gateway
מציין את ההעברה או את כתובת ה- IP של הדילוג הבא שבאמצעותן ניתן להגיע אל ערכת הכתובות המוגדרות באמצעות יעד הרשת ומסיכת רשת המשנה. עבור ניתובים של רשת משנה המצורפים מקומית, כתובת השער היא כתובת ה- IP המשויכת לממשק המצורף לרשת המשנה. עבור ניתובים מרוחקים, הזמינים דרך ניתוב אחד או יותר, כתובת השער היא כתובת IP הזמינה באופן ישיר ומשויכת לנתב שכן.
metric Metric
מציין מדד עלות במספר שלם (בין 1 ל- 9999) עבור הניתוב, המשמש בעת בחירה בין ניתובים מרובים בטבלת הניתוב, המתאימים ביותר לכתובת היעד של מנה מועברת. הניתוב בעל המדד הנמוך ביותר נבחר. המדד עשוי לשקף את מספר הדילוגים, את המהירות, האמינות או התפוקה של הנתיב, או מאפיינים ניהוליים .
if Interface
מציין את אינדקס הממשק עבור הממשק שבאמצעותו ניתן להגיע ליעד. עבור רשימה של ממשקים ואינדקסי הממשק התואמים שלהם, השתמש בתצוגת הפקודה route print. באפשרותך להשתמש בערכים דצימליים או הקסדצימליים עבור אינדקס הממשק. הקדם 0x לערכים הקסדצימליים. כאשר הפרמטר if מושמט, הממשק נקבע לפי כתובת השער.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • ערכים גדולים בעמודה metric של טבלת הניתוב נוצרים אם ניתנה ל- TCP/IP אפשרות לקבוע באופן אוטומטי את המדד עבור ניתובים בטבלת הניתוב בהתבסס על תצורת כתובת IP, מסיכת רשת משנה ושער המוגדר כברירת מחדל עבור כל ממשק LAN (רשת תקשורת מקומית). קביעה אוטומטית של מדד הממשק, המופעלת כברירת מחדל, קובעת את מהירות כל ממשק ומתאימה את מדדי הניתובים עבור כל ממשק, כך שהממשק המהיר ביותר יוצר את הניתובים בעלי המדד הנמוך ביותר. כדי להסיר את המדדים הגדולים, בטל את הקביעה האוטומטית של מדדי ממשק במאפיינים המתקדמים של פרוטוקול TCP/IP עבור כל חיבור LAN.
  • ניתן להשתמש בשמות עבור הפרמטר Destination אם קיים ערך מתאים בקובץ Networks המקומי המאוחסן בתיקיה systemroot\System32\Drivers\Etc. ניתן להשתמש בשמות עבור הפרמטר gateway כל עוד ניתן לפענח אותם לכתובות IP באמצעות טכניקות סטנדרטיות של פענוח שמות מחשבים מארחים כגון שאילתות Domain Name System ‏(DNS), שימוש בקובץ Hosts המקומי המאוחסן בתיקיה systemroot\System32\Drivers\Etc ופענוח שמות של NetBIOS.
  • אם הפקודה היא print או delete, ניתן להשמיט את הפרמטר Gateway ולהשתמש בתווים כלליים עבור היעד והשער. הערך Destination עשוי להיות ערך של תו כללי המצוין באמצעות כוכבית (*). אם היעד שצוין מכיל כוכבית (*) או סימן שאלה (?), היחס אליו הוא כאל תו כללי ורק ניתובי יעד מתאימים מודפסים או נמחקים. כוכבית מתאימה לכל מחרוזת וסימן שאלה מתאים לכל תו בודד. לדוגמה, ‎10‎.*.1‏, ‎192.168.*‎, ‏‎127.*‎ ו- ‎*224*‎ הם שימושים חוקיים בתו הכללי כוכבית.
  • שימוש בשילוב לא חוקי של יעד וערך מסיכה של רשת משנה (מסיכת רשת) מביא להצגת הודעת השגיאה "Route: bad gateway address netmask". הודעת שגיאה זו מופיעה כאשר היעד מכיל סיבית אחת או יותר שנקבעו כ- 1 במיקומי סיביות שבהם נקבעו הסיביות התואמות במסיכת רשת המשנה כ- 0. כדי לבחון מצב זה, בטא את היעד ואת מסיכת רשת המשנה באמצעות סימון בינארי. מסיכת רשת המשנה בסימון בינארי מכילה סדרה של סיביות 1 המייצגות את קטע כתובת הרשת של היעד וסדרה של סיביות 0 המייצגות את קטע כתובת המחשב המארח של היעד. בדוק האם קיימות ביעד סיביות שנקבעו כ- 1 עבור קטע היעד שהוא כתובת המחשב המארח (כפי שהוגדר באמצעות מסיכת רשת המשנה).
  • הפרמטר ‎-p נתמך בפקודה route רק ב- Windows NT 4.0‏, Windows 2000‏, Windows Millennium Edition ו- Windows XP. אין תמיכה בפרמטר זה בפקודה route ב- Windows 95 או Windows 98.
  • פקודה זו זמינה רק אם הותקן פרוטוקול ‎Internet Protocol (TCP/IP)‎ כרכיב במאפייני מתאם הרשת בחיבורי רשת.

דוגמאות

כדי להציג את כל התוכן של טבלת ניתוב IP, הקלד:

route print

כדי להציג את הניתובים בטבלת ניתוב IP המתחילים ב- ‎10.‎ הקלד:

route print 10.*‎

כדי להוסיף ניתוב המוגדר כברירת מחדל עם כתובת השער המוגדרת כברירת מחדל 192.168.12.1, הקלד:

route add 0.0.0.0 mask 0.0.0.0 192.168.12.1

כדי להוסיף ניתוב ליעד 10.41.0.0 עם מסיכת רשת המשנה 255.255.0.0 וכתובת הדילוג הבא 10.27.0.1, הקלד:

route add 10.41.0.0 mask 255.255.0.0 10.27.0.1

כדי להוסיף ניתוב קבוע ליעד 10.41.0.0 עם מסיכת רשת המשנה 255.255.0.0 וכתובת הדילוג הבא 10.27.0.1, הקלד:

route -p add 10.41.0.0 mask 255.255.0.0 10.27.0.1

כדי להוסיף ניתוב ליעד 10.41.0.0 עם מסיכת רשת המשנה 255.255.0.0, כתובת הדילוג הבא 10.27.0.1 ומדד עלות 7, הקלד:

route add 10.41.0.0 mask 255.255.0.0 10.27.0.1 metric 7

כדי להוסיף ניתוב ליעד 10.41.0.0 עם מסיכת רשת המשנה 255.255.0.0, כתובת הדילוג הבא 10.27.0.1 ותוך שימוש באינדקס הממשק 0x3, הקלד:

route add 10.41.0.0 mask 255.255.0.0 10.27.0.1 if 0x3

כדי למחוק את הניתוב ליעד 10.41.0.0 עם מסיכת רשת המשנה 255.255.0.0, הקלד:

route delete 10.41.0.0 mask 255.255.0.0

כדי למחוק את כל הניתובים בטבלת ניתוב IP המתחילים ב- ‎10.‎ הקלד:

route delete 10.*‎

כדי לשנות את כתובת הדילוג הבא של ניתוב עם היעד 10.41.0.0 ומסיכת רשת המשנה 255.255.0.0 מ- 10.27.0.1 ל- 10.27.0.25, הקלד:

route change 10.41.0.0 mask 255.255.0.0 10.27.0.25


Rsh

הפעלת פקודות במחשבים מרוחקים שפועל בהם שירות, או Daemon, ‏RSH‏. Windows XP ו- Windows 2000 אינם מספקים שירות RSH. שירות RSH הנקרא Rshsvc.exe נמצא ב- Windows 2000 Server Resource Kit. בשימוש ללא פרמטרים, הפקודה rsh מציגה עזרה.

תחביר

rsh [Host] [-l UserName] [-n] [Command]‎

פרמטרים

Host
ציון המחשב המארח המרוחק שתפעל בו הפקודה שצוינה בפרמטר Command.
‎-l UserName
ציון שם המשתמש שישמש במחשב המרוחק. אם פרמטר זה מושמט, ייעשה שימוש בשם המשתמש המחובר כרגע.
‎-n
ניתוב מחדש של פלט הפקודה rsh להתקן NUL. דבר זה מונע הצגה של תוצאות הפקודה במחשב המקומי.
Command
ציון הפקודה שיש להפעיל.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • פעולה רגילה

    הפקודה המרוחקת שצוינה בפרמטר rsh מעתיקה קלט סטנדרטי לפקודה המרוחקת Command, פלט סטנדרטי של הפקודה המרוחקת שצוינה בפרמטר Command לפלט הסטנדרטי של אותה פקודה, ואת השגיאה הסטנדרטית של הפקודה המרוחקת שצוינה בפרמטר Command לשגיאה הסטנדרטית של אותה פקודה. לרוב, פעולתה של הפקודה Rsh מסתיימת כאשר מסתיימת הפעולה של הפקודה המרוחקת.

  • שימוש בסימני ניתוב מחדש

    תחום סימני ניתוב מחדש במרכאות כדי שיתרחש ניתוב מחדש במחשב המרוחק (לדוגמה, "<<"). אם לא תעשה שימוש במרכאות, הניתוב מחדש יתרחש במחשב המקומי. לדוגמה, הפקודה שלהלן מצרפת את הקובץ המרוחק RemoteFile לקובץ המקומי LocalFile:

    rsh othercomputer cat remotefile >> localfile

    הפקודה שלהלן מצרפת את הקובץ המרוחק RemoteFile לקובץ המרוחק OtherRemoteFile:

    rsh othercomputer cat remotefile ">>" otherremotefile

  • שימוש בפקודה rsh

    בעת שימוש במחשב שפועל בו Windows XP Professional המחובר לקבוצת מחשבים, על בקר קבוצת המחשבים הראשי להיות זמין כדי לבצע אימות של שם המשתמש. אם לא יהיה זמין, הפקודה rsh תיכשל.

  • הקובץ ‎.rhosts

    לרוב, הקובץ ‎.rhosts מעניק זכויות גישה לרשת במערכות UNIX. בקובץ ‎.rhosts מפורטים שמות המחשבים בעלי הרשאת גישה למחשבים מרוחקים ושמות הכניסה המשויכים אליהם. אין צורך לספק נתוני כניסה וסיסמה עבור המחשב המרוחק בעת הפעלה של הפקודות rcp‏, rexec או rsh במערכת מרוחקת עם קובץ ‎.rhosts המוגדר כהלכה.

    הקובץ ‎.rhosts הוא קובץ טקסט שכל שורה בו היא ערך. ערך מורכב משם המחשב המקומי, שם המשתמש המקומי והערות אודות הערך. כל ערך מופרד באמצעות טאב או באמצעות רווח והערות מתחילות בסימן סולמית (#). לדוגמה:

    host7 #This computer is in room 31A

    על הקובץ ‎.rhosts להימצא בספריה הראשית של המשתמש במחשב המרוחק. לקבלת מידע נוסף אודות אופני יישום מסוימים של הקובץ ‎.rhosts במחשב מרוחק, עיין בתיעוד עבור המערכת המרוחקת.

  • הפקודה זמינה רק אם הותקן פרוטוקול Internet Protocol ‎(TCP/IP)‎ כרכיב במאפיינים של מתאם הרשת בחיבורי רשת.

דוגמאות

כדי להפעיל את הפקודה telcon במחשב המרוחק vax1 באמצעות השם admin1, הקלד:

rsh vax1 -l admin1 telcon


Rsm

ניהול משאבי מדיה באמצעות היישום אחסון נשלף. באמצעות הפקודה rsm, באפשרותך להפעיל קבצי Script של אצווה עבור יישומים שעדיין אינם תומכים בממשק תכנות היישומים (API) של היישום אחסון נשלף.

לשם הקצאת מדיה ממאגר מדיה

תחביר

rsm allocate /m media_pool_name /o{errunavail|new|next} {/l{g|f}logical_media_id | /p{g|f}partition_id}
[/ln logical_media_name]
[/ld logical_media_description]
[/pn partition_name]
[/pd partition_description]
[/t timeout]
[/b]‎

פרמטרים

‎/m media_pool_name
הקצאת מדיה ממאגר מדיה שצוין. משמעות הדבר היא שבמאגר מדיה זה תהיה קיימת מדיה שהוקצתה.
‎/o
מאפשר שימוש באחד מהפרמטרים המפורטים בטבלה הבאה.
ערך | תיאור
errunavail | מונע שליחה של בקשת מפעיל למדיה חדשה אם לא קיימת אפשרות להקצות מדיה תחת האילוצים שצוינו.
new | מקצה מחיצה שלא ניתן לשתף עם יישום אחר. ניתן להשתמש בפרמטר זה כדי לשמור צד שני של מדיה דו-צדדית.
next | מקצה את הצד הבא של מדיה שהוקצתה בעבר באמצעות הפרמטר new.
‎/l{g|f}logical_media_id
מציין באמצעות מזהה המדיה הלוגית את המדיה שיש להקצות. באפשרותך להשתמש במזהה ייחודי כללי (GUID), המחייב שימוש באפשרות שורת הפקודה lg, או בשם הידידותי, המחייב שימוש באפשרות שורת הפקודה lf. הפרמטר Logical_media_id מציין את הצד הבא להקצאה במדיה מרובת צדדים. פרמטר זה הוא אופציונלי ויש להשתמש בו בצירוף עם אפשרות שורת הפקודה ‎/o והפרמטר next. לאחר ביטול הקצאת המדיה, מזהה המדיה הלוגית הופך בלתי חוקי.
‎/p{g|f}partition_id
מציין באמצעות מזהה המחיצה את המחיצה שיש להקצות. באפשרותך להשתמש ב- GUID (עם אפשרות שורת הפקודה pg) או בשם הידידותי (עם אפשרות שורת הפקודה pf). פרמטר זה הוא אופציונלי ותוקפו נשמר גם לאחר ביטול הקצאת המדיה.
‎/ln logical_media_name
מציין באמצעות שם המדיה הלוגית את המדיה שיש להקצות.
‎/ld logical_media_description
מציין באמצעות תיאור המדיה הלוגית את המדיה שיש להקצות.
‎/pn partition_name
מציין באמצעות שם המחיצה את המחיצה שיש להקצות.
‎/pd partition_description
מציין באמצעות תיאור המחיצה את המחיצה שיש להקצות.
‎/t timeout
מציין את פרק הזמן שנקצב לשם ביצוע הפקודה, באלפיות שניה. פרק הזמן המוגדר כברירת מחדל הוא אינסוף.
‎/b
הצגה של GUID בלבד עבור פעולת ההקצאה. הוספת אפשרות זו מסייעת בעת כתיבת Script כאשר ברצונך להעביר את הפלט של פקודה אחת לפקודה אחרת עם ניתוח מינימלי של מבנה הטקסט.

‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • באפשרותך להשתמש בשמות מדיה לוגית ובשמות צדדי מדיה בפקודות אחרות, וזאת כדי לציין מדיה כפרמטר עבור הבוררים ‎/lf או ‎/pf בהתאמה. אם לא נעשה שימוש בשמות המדיה הלוגית (השמות הידידותיים) עבור הפקודה allocate, באפשרותך להשתמש במזהי GUID בלבד (ולא בשמות הידידותיים) בפקודות הבאות אם יהיה ברצונך לציין מדיה לוגית.

לשם יצירה של מאגר מדיה

תחביר

rsm createpool /m media_pool_name
/a{existing|always|new}
[/t{g|f}media_pool_type_id]
[/d]
[/r]‎

פרמטרים

/m media_pool_name
מציין את שם המדיה שיש ליצור.
‎/a
מאפשר שימוש באחד מהפרמטרים המפורטים בטבלה הבאה.
ערך | תיאור
existing | פותח את מאגר המדיה הקיים או מחזיר הודעת שגיאה אם מאגר המדיה שצוין אינו קיים.
always | פותח את מאגר המדיה הקיים או יוצר מאגר מדיה חדש אם לא נמצא המאגר שצוין.
new | יוצר מאגר מדיה חדש או מחזיר הודעת שגיאה אם המאגר שצוין כבר קיים.
‎/tg media_pool_type_id
מציין באמצעות GUID את סוג המדיה שיכיל המאגר. סוג ברירת המחדל הוא מאגר מדיה המכיל מאגרי מדיה אחרים.
‎/tf media_pool_type_id
מציין באמצעות שם ידידותי את סוג המדיה שיכיל מאגר המדיה. סוג ברירת המחדל הוא מאגר מדיה המכיל מאגרי מדיה אחרים.
‎/d
מאפשר למאגר המדיה למשוך באופן אוטומטי מדיה ממאגר המדיה החופשי. אם לא נכלל הבורר ‎/d, לא ניתנת למאגר המדיה אפשרות למשוך מדיה מהמאגר החופשי.
‎/r
מאפשר למאגר המדיה להחזיר באופן אוטומטי מדיה למאגר המדיה החופשי. אם לא נכלל הבורר ‎/r, לא ניתנת למאגר המדיה אפשרות להחזיר מדיה למאגר החופשי.

‎/?‎
הצגת עזרה בשורת הפקודה.

לשם ביטול של הקצאת מדיה

תחביר

rsm deallocate /l{g|f}logical_media_id | /p{g|f}partition_id

פרמטרים

‎/lg logical_media_id
מציין באמצעות GUID את המדיה הלוגית שאת הקצאתה יש לבטל.
‎/lf logical_media_id
מציין באמצעות שם ידידותי את המדיה הלוגית שאת הקצאתה יש לבטל.
‎/pg partition_id
מציין באמצעות GUID את צד המדיה שאת הקצאתו יש לבטל.
‎/pf partition_id
מציין באמצעות שם ידידותי את צד המדיה שאת הקצאתו יש לבטל.

‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • באפשרותך להשתמש בשם המדיה הלוגית או בשם המחיצה לציון המדיה הלוגית שאת הקצאתה יש לבטל רק אם צוין אחד מהשמות בפקודה allocate בצירוף אחד הבוררים ‎/ln או ‎/pn בהתאמה. במקרים אחרים, יש לציין במקום את מזהה המדיה הלוגית (LMID) או את מזהה המחיצה (PARTID).

לשם מחיקה של מאגר מדיה

תחביר

rsm deletepool /m media_pool_name

פרמטרים

‎/m media_pool_name
מציין את שם מאגר המדיה שיש למחוק.

‎/?‎
הצגת עזרה בשורת הפקודה.

לשם ביטול טעינה של מדיה מכונן

תחביר

rsm dismount {/l{g|f}logical_media_id | /p{g|f}partition_id
rsm dismount [/o[deferred]]}‎

פרמטרים

‎/lg logical_media_id
מציין באמצעות GUID את המדיה הלוגית שאת טעינתה יש לבטל.
‎/lf logical_media_id
מציין באמצעות שם ידידותי את המדיה הלוגית שאת טעינתה יש לבטל.
‎/pg partition_id
מציין באמצעות GUID את צד המדיה שאת טעינתו יש לבטל.
‎/pf partition_id
מציין באמצעות שם ידידותי את צד המדיה שאת טעינתו יש לבטל.
‎/o
אם נעשה שימוש ב- ‎/o בנוסף לפרמטר האופציונלי deferred, בורר אופציונלי זה מציין כי ניתן לבטל את הטעינה עבור מדיה זו, אך המדיה עדיין נשמרת בכונן. פקודות טעינה עוקבות יתבצעו באופן הרגיל. ללא בורר זה, מבוטלת טעינת המדיה מן הכונן באופן מיידי.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • באפשרותך להשתמש בשם המדיה הלוגית או בשם המחיצה לציון המדיה הלוגית שטעינתה מיועדת לביטול רק אם צוין אחד השמות עם הפקודה allocate ואחד הבוררים ‎/ln או ‎/pn בהתאמה. במקרים אחרים, יש לציין את מזהה המדיה הלוגית (LMID) או את מזהה המחיצה (PARTID).

כדי להוציא מדיה מספריה

ניתן לציין את המדיה שיש להוציא באחת משלוש דרכים:

  • באפשרותך לציין את המדיה הפיזית שיש להוציא באמצעות מזהה המדיה הפיזית (PMID) או באמצעות שם המדיה הפיזית.
  • באפשרותך להוציא את המדיה בחריץ שצוין בספריה שצוינה.
  • באפשרותך להוציא את המדיה בכונן שצוין בספריה שצוינה.

תחביר

rsm eject {/p{g|f}physical_media_id | /s{g|f}slot_id /l{g|f}library_id | /d{g|f}drive_id /l{g|f}library_id
rsm eject [/o eject_operation_id]‎
rsm eject [/a{start|stop|queue}]‎
rsm eject [/b]‎

פרמטרים

‎/pg physical_media_id
מציין באמצעות GUID את המדיה הפיזית שיש להוציא.
‎/pf physical_media_id
מציין באמצעות שם ידידותי את המדיה הפיזית שיש להוציא.
‎/sg slot_id
מציין באמצעות GUID את החריץ המחזיק את המדיה שיש להוציא.
‎/sf slot_id
מציין באמצעות שם ידידותי את החריץ המחזיק את המדיה שיש להוציא.
‎/lg library_id
מציין באמצעות GUID את הספריה המכילה את החריץ או הכונן שמהם יש להוציא את המדיה.
‎/lf library_id
מציין באמצעות שם ידידותי את הספריה המכילה את החריץ או הכונן שמהם יש להוציא את המדיה.
‎/dg drive_id
מציין באמצעות GUID את הכונן המחזיק את המדיה שיש להוציא.
‎/df drive_id
מציין באמצעות שם ידידותי את הכונן המחזיק את המדיה שיש להוציא.
‎/o eject_operation_id
משמש לציון של מזהה מסוג GUID עבור פעולת הוצאה מסוימת. הבורר האופציונלי ‎/o עשוי לשמש בצירוף הבורר ‎/a והפרמטר stop כדי לסיים פעולת הוצאה מסוימת. ניתן להשתמש בבורר זה גם בצירוף הבורר ‎/a והפרמטר start כדי להציג GUID של פעולת ההוצאה המסוימת.
‎/a
מאפשר שימוש באחד מהפרמטרים המפורטים בטבלה הבאה.
ערך | תיאור
Start | ברירת המחדל. הפעלה מיידית של פעולת ההוצאה. הוצאת המדיה מתבצעת עד סיום הזמן הקצוב, או עד להנפקה של פקודת הוצאה אחרת בצירוף אפשרות שורת הפקודה ‎/a והפרמטר stop. על פקודות הוצאה אלה לציין גם GUID באמצעות אפשרות שורת הפקודה ‎/o לפקודה. פרמטר הזמן הקצוב מצוין באובייקט הספריה (עבור כל פעולות ההוצאה) עבור הספריה. כדי לקבוע את ערך פרמטר הזמן הקצוב, עליך להשתמש ב- API של אחסון נשלף. פרמטר זה עשוי לשמש גם בצירוף הבורר ‎/o כדי להציג GUID של פעולת הוצאה מסוימת.
Stop | מסיים את פעולת ההוצאה לפני תום פרק הזמן שהוקצב. באפשרותך לציין את פעולת ההוצאה המסוימת באמצעות GUID המוצג בעת שימוש בפרמטר start בצירוף הבוררים ‎/a ו- ‎/o.
Queue | יוצר תור של מדיה המיועדת להוצאה לאחר מכן. פרמטר זה עשוי לשמש עבור ספריות בעלות יציאות הכנסה/הוצאה (IE) מרובות חריצים.
‎/b
מציג רק GUID של פעולת ההוצאה, וזאת למטרות Scripting.

‎/?‎
הצגת עזרה בשורת הפקודה.

לשם הוצאת מדיה ממחליף ATAPI

תחביר

rsm ejectatapi /n atapi_changer_number

פרמטרים

‎/n atapi_changer_number
מציין את מספר המחליף. atapi_changer_number הוא המספר שנמצא בקצה מחרוזת שם ההתקן של מחליף המדיה. לדוגמה, בשם ‎\\.\CdChanger0‏ מופיע 0 כמספר מחליף המדיה ATAPI.

‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • לפני הפעלת הפקודה, הפסק את שירות ntmssvc באופן ידני.

לשם עריכת רשימת מצאי של מדיה בספריה אוטומטית שצוינה

תחביר

rsm inventory /l{g|f}library_id /a{full|fast|default|none|stop}‎

פרמטרים

‎/lf library_id
מציין באמצעות שם ידידותי את הספריה שעבורה יש לערוך רשימת מצאי.
‎/lg library_id
מציין באמצעות GUID את הספריה שעבורה יש לערוך רשימת מצאי.
‎/a
נדרש. מציין את סוג פעולת רשימת המצאי שיש לבצע. הטבלה הבאה מפרטת פעולות מצאי חוקיות.
ערך | תיאור
Full | מבצע רשימת מצאי מלאה של המדיה בספריה. היישום אחסון נשלף טוען כל קלטת או דיסק שבספריה וקורא את המזהה המוטבע על פני המדיה.
Fast | עורך רשימת מצאי באמצעות ברקוד, אם בספריה שצוינה מותקן קורא ברקוד. אם לא הותקן קורא ברקוד, היישום אחסון נשלף בודק את חריצי האחסון וקורא את המזהה המוטבע על המדיה בחריצים שהיו ריקים.
Default | עורך רשימת מצאי באמצעות השיטה המוגדרת כברירת מחדל, כשם שצוינה בתיבת הדו-שיח מאפיינים (Properties) של הספריה.
None | אינו עורך רשימת מצאי.
Stop | מפסיק את עריכת רשימת המצאי עבור הספריה שצוינה, אם מבוצעת כזו.

‎/?‎
הצגת עזרה בשורת הפקודה.

לשם טעינת מדיה בספריה המיועדת

באפשרותך לציין את המדיה הלוגית המיועדת לטעינה באמצעות מזהה המדיה הלוגית (LMID) או באמצעות שם המדיה הלוגית.

תחביר

rsm mount {/l{g|f}logical_media_id | /p{g|f}partition_id | [‎/s{g|f}slot_id /c{g|f}changer_id}‎
rsm mount [/d{g|f}drive_id]‎
rsm mount /o{errunavail|drive|read|write|offline}‎
rsm mount [/r{normal|high|low|highest|lowest}]‎
rsm mount [/t timeout]‎

פרמטרים

‎/lf logical_media_id
מציין באמצעות שם ידידותי את המדיה הלוגית שיש לטעון.
‎/pf partition_id
מציין באמצעות שם ידידותי את צד המדיה שיש לטעון.
‎/pg partition_id
‎/lg logical_media_id
מציין באמצעות GUID את המדיה הלוגית שיש לטעון.
מציין באמצעות GUID את צד המדיה שיש לטעון.
‎/cg changer_id
מציין באמצעות GUID את המחליף המכיל את המדיה שיש לטעון. יש לצרף תמיד לפרמטר זה את הבורר ‎/sg ואת מזהה GUID של החריץ.
‎/cf changer_id
מציין באמצעות שם ידידותי את המחליף המכיל את המדיה שיש לטעון. יש לצרף תמיד לפרמטר זה את הבורר ‎/sg ואת מזהה GUID של החריץ.
‎/sg slot_id
מציין באמצעות GUID את חריץ המדיה המכיל את המדיה שיש לטעון. יש לצרף תמיד לפרמטר זה את הבורר ‎/cg ואת מזהה GUID של מחליף המדיה.
‎/sf slot_id
מציין באמצעות שם ידידותי את חריץ המדיה המכיל את המדיה שיש לטעון. יש לצרף תמיד לפרמטר זה את הבורר ‎/cg ואת מזהה GUID של מחליף המדיה.
‎/dg drive_id
מציין באמצעות GUID את הכונן המסוים שאליו יש לטעון את המדיה המתאימה. פרמטר זה הוא אופציונלי ויש לצרף אליו את הבורר ‎/o ואת הפרמטר drive.
‎/df drive_id
מציין באמצעות שם ידידותי את הכונן המסוים שאליו יש לטעון את המדיה המתאימה. פרמטר זה הוא אופציונלי ויש לצרף אליו את הבורר ‎/o ואת הפרמטר drive.
‎/o
מאפשר שימוש באחד מהפרמטרים המפורטים בטבלה הבאה.
ערך | תיאור
Errunavail | מפיק הודעת שגיאה אם המדיה או הכונן אינם זמינים.
Drive | מציין כי יש לטעון כונן מסוים. יש לצרף לפרמטר זה את הבורר ‎/d.
Read | טוען את המדיה עבור גישת קריאה.
Write | טוען את המדיה עבור גישת כתיבה. אם יעשה שימוש בפרמטר זה, מדיה שהושלמה לא תיטען.
Offline | מפיק הודעת שגיאה אם המדיה אינה מקוונת.
‎/r
מציין באופן אופציונלי את סדר הטעינה (עדיפות). ניתן לציין עדיפות טעינה גם באמצעות הפרמטרים normal (ברירת המחדל)‏, high‏, low‏, highest או lowest.
‎/t
מציין באופן אופציונלי את פרק הזמן המוקצב לביצוע הפקודה, באלפיות שניה. פרק הזמן המוגדר כברירת מחדל הוא אינסוף.

‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • בעת שימוש בפקודה Mount, באפשרותך לציין את המדיה המיועדת לטעינה באמצעות אחד הבוררים ‎/l או ‎/p או צירוף של הבוררים ‎/s ו- /c.

לשם רענון של ספריה, של מדיה פיזית, או של כל ההתקנים מסוג מסוים של מדיה

פקודה זו גורמת לביצוע תשאול יחיד של התקני היעד, כך שמסד הנתונים של היישום אחסון נשלף מכיל את המצב הנוכחי של ההתקן. פקודה זו עשויה להיות שימושית לאחר ביצוע פעולות הכנסה או הוצאה של מדיה.

תחביר

rsm refresh {/l{g|f]library_id | /p{g|f}physical_media_id ‎| /tg media_type_id}‎

פרמטרים

‎/lg library_id
מציין באמצעות GUID את הספריה שיש לרענן.
‎/lf library_id
מציין באמצעות שם ידידותי את הספריה שיש לרענן.
/pg physical_media_id
מציין באמצעות GUID את המדיה הפיזית שיש לרענן.
‎/pf physical_media_id
מציין באמצעות שם ידידותי את המדיה הפיזית שיש לרענן.
‎/tg media_type_id
מציין את סוג המדיה המיועדת לרענון. אין באפשרותך לציין אלא מזהה GUID. פרמטר זה עשוי לשמש לרענון כל התקני המדיה הנשלפת, על-ידי ציון של מזהה GUID עבור המדיה הנשלפת. באפשרותך לקבוע באיזה מזהה GUID יש להשתמש, וזאת באמצעות בפקודה view כמתואר להלן: rsm view /tmedia_type /guiddisplay.
‎/?‎
הצגת עזרה בשורת הפקודה.

לשם הצגת רשימה של אובייקטי מדיה

תחביר

rsm view /t{drive|library|changer|storageslot|iedoor|ieport|physical_media| media_pool|partition|logical_media|media_type|drive_type|librequest}‎
rsm view [/cg container_id]‎
rsm view [/guiddisplay]‎
rsm view [/b]‎

פרמטרים

‎/t {drive|library|changer|storageslot|iedoor|ieport|physical_media| media_pool|partition|logical_media|media_type|drive_type|librequest}‎
הצגת רשימה של אובייקטי מדיה מהסוג שצוין. כאשר נעשה בפקודה שימוש ללא פרמטרים, מציגה הפקודה רשימה של כל מאגרי המדיה במערכת של אחסון נשלף (אוסף של ספריות).
‎/cg container_id
מציין את מזהה GUID עבור הגורם המכיל של האובייקט. סוג הגורם המכיל תלוי בסוג האובייקט (פרמטר) שצוין עם הבורר ‎/t. אם לא צוין המזהה של הגורם המכיל, יוצגו כל המופעים של סוג האובייקט המתאים.
‎/guiddisplay
מציג GUID ושם ידידותי עבור אובייקטים.
‎/b
מציג רק GUID של האובייקט, למטרות Scripting.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • כשאין משתמשים בבוררים ‎/guid_display ו- ‎/b, מוצגים רק השמות הידידותיים של האובייקטים.

הערות

  • כאשר מצליח ביצוע פקודה, מוחזר הקוד ERROR_SUCCESS. כל הפקודות שפעולתן נכשלה מחזירות קוד שגיאה, העשוי לשמש למטרות Scripting. קוד השגיאה הוא קוד המוגדר באמצעות המערכת, או אחד מהקודים המפורטים בטבלה שלהלן:
    קוד שגיאה | תיאור
    536870913 | צוינו ארגומנטים לא חוקיים. לרוב, שגיאה זו נגרמת כתוצאה מהכנסת תו רווח אחרי בורר של ארגומנט. לדוגמה, ‎/t 50 במקום ‎/t50.
    536870914 | צוינו בוררי ארגומנט כפולים. לדוגמה, שימוש בפקודה allocate בצירוף שני בוררי ‎/m.
    536870915 | לא נמצא GUID התואם את השם הידידותי שצוין. יש לבדוק שימוש באותיות רישיות, משום ששמות ידידותיים הם תלויי רישיות.
    536870916 | צוין מספר לא מספיק של בוררי ארגומנטים. יש לבדוק האם חסר בורר חיוני.
    536870917 | צוין GUID לא חוקי. השתמש בפקודה view כדי למצוא את מזהה GUID המתאים עבור אובייקט.
    536870918 | מוחזר על-ידי הפקודה ejectatapi בלבד. יש לוודא פעולה תקינה של מחליף ATAPI.


Runas

פקודה זו מאפשרת להפעיל כלים מסוימים ותוכניות מסוימות עם הרשאות שונות מאלה שמספק שם הכניסה הנוכחי של המשתמש.

תחביר

‎runas [{/profile|/noprofile}] [/env] [/netonly] [/smartcard] [/showtrustlevels] [/trustlevel] /user:UserAccountName program‎

פרמטרים

‎/profile
מציין שיש לטעון את פרופיל המשתמש. הפרמטר ‎/profile הוא ברירת המחדל.
‎/no profile
מציין שאין לטעון את פרופיל המשתמש. פרמטר זה מאפשר טעינה מהירה יותר של היישום, אך עשוי לגרום לתקלה ביישומים מסוימים.
‎/env
ציון סביבת הרשת הנוכחית שיש להשתמש בה במקום בסביבה המקומית של המשתמש.
‎/netonly
שימוש בפרמטר זה מציין כי מידע המשתמש שצוין משמש עבור גישה מרחוק בלבד.
‎/smartcard
מציין האם האישורים יסופקו מכרטיס חכם.
‎/showtrustlevels
מפרט את אפשרויות הפרמטר ‎/trustlevel.
‎/trustlevel
מציין את רמת ההרשאה שעל היישום לפעול בה. השתמש בפרמטר ‎/showtrustlevels כדי להציג את רמות האמון הזמינות.
‎/user:UserAccountName
מציין את השם של חשבון המשתמש שישמש להפעלת התוכנית. עבור חשבון המשתמש יש לעשות שימוש בתבנית user@domain או בתבנית Domain\User.
program
מציין את התוכנית או הפקודה שיש להפעיל באמצעות החשבון שצוין בפרמטר ‎/user.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • שיטת עבודה מומלצת עבור מנהלים (Administrators) היא שימוש בחשבון בעל הרשאות מוגבלות כדי לבצע משימות שגרתיות שאינן משימות ניהול, ושימוש בחשבון בעל הרשאות רחבות יותר רק בעת ביצוע של משימות ניהול מסוימות. כדי לעשות זאת ללא התנתקות וכניסה מחדש, בצע כניסה למחשב באמצעות חשבון משתמש רגיל והשתמש בפקודה runas כדי להפעיל את הכלים הדורשים שימוש בהרשאות רחבות.
  • עבור דוגמאות לשימוש בפקודה runas, ראה נושאים קרובים.
  • השימוש בפקודה runas אינו מוגבל לחשבונות מנהל, אף-על-פי שזהו השימוש הנפוץ בה. לכל משתמש בעל מספר חשבונות יש אפשרות להשתמש בפקודה runas כדי להפעיל תוכנית, מסוף MMC או פריט לוח הבקרה באמצעות אישורים חלופיים.
  • אם ברצונך להשתמש בחשבון Administrator שבמחשב, הקלד עבור הפרמטר ‎/user:‎ אחת מהאפשרויות הבאות:

    ‎/user:AdministratorAccountName@ComputerName

    ‎/user:ComputerName\AdministratorAccountName

  • אם ברצונך להשתמש בפקודה זו כמנהל קבוצת מחשבים, הקלד אחד מהבאים:

    ‎/user:AdministratorAccountName@DomainName

    ‎/user:DomainName\AdministratorAccountName

  • הפקודה runas מאפשרת הפעלה של תוכניות (‎*.exe), של מסופי MMC שנשמרו (‎*.msc), של קיצורי דרך לתוכניות ולמסופי MMC שנשמרו ושל פריטי לוח הבקרה. באפשרותך לבצע הפעלה כמנהל גם אם ביצעת כניסה למחשב שלך כחבר בקבוצה אחרת, כגון הקבוצה Users או הקבוצה Power Users.
  • ניתן להשתמש בפקודה runas כדי להפעיל כל תוכנית, מסוף MMC או פריט של לוח הבקרה. כל עוד תספק את המידע המתאים עבור חשבון המשתמש ועבור הסיסמה, תהיה לחשבון המשתמש אפשרות לבצע כניסה למחשב, כך שהתוכנית, מסוף ה- MMC או פריט לוח הבקרה יהיו זמינים במערכת ועבור חשבון המשתמש.
  • הפקודה runas מאפשרת לנהל שרת ביער אחר (כלומר, כאשר המחשב שמופעל בו כלי כלשהו והשרת שאתה מנהל נמצאים בקבוצות מחשבים שונות).
  • ניסיון הפעלה של תוכנית, של מסוף MMC או של פריט לוח הבקרה ממיקום רשת באמצעות runas עשוי להיכשל, מאחר שהאישורים המשמשים עבור חיבור למיקום רשת משותף שונים מהאישורים המשמשים להפעלת התוכנית. ייתכן שלא תהיה לאישורי הפעלת התוכנית אפשרות גישה אל אותו מיקום רשת משותף.
  • פריטים מסוימים, כגון תיקיית המדפסות ופריטי שולחן עבודה, נפתחים באופן עקיף ולא ניתן להפעילם באמצעות הפקודה runas.
  • אם ביצוע הפקודה runas נכשל, ייתכן ששירות Secondary Logon אינו פועל או שחשבון המשתמש שהשתמשת בו אינו חוקי. כדי לבדוק את מצב השירות Secondary Logon, תחת ניהול מחשב, לחץ על שירותים ויישומים ולאחר מכן לחץ על שירותים. כדי לבדוק את חשבון המשתמש, נסה לבצע גישה לקבוצת המחשבים המתאימה באמצעות החשבון.

דוגמאות

כדי להפעיל מופע של שורת הפקודה כמנהל במחשב המקומי, הקלד:

runas /user:localmachinename\administrator cmd

כאשר מוצגת בקשה להזנת סיסמה, הקלד את סיסמת המנהל.

כדי להפעיל מופע של יישום ה- Snap-in של היישום ניהול מחשב באמצעות חשבון מנהל קבוצת מחשבים הנקרא companydomain\domainadmin, הקלד:

runas /user:companydomain\domainadmin "mmc ‎%windir%‎‎\system32\compmgmt.msc"‎

כאשר מוצגת בקשה להזנת סיסמה, הקלד את סיסמת החשבון.

כדי להפעיל מופע של פנקס רשימות באמצעות חשבון מנהל קבוצת מחשבים הנקרא user בקבוצת מחשבים הנקראת domain.microsoft.com, הקלד:

runas /user:user@domain.microsoft.com "notepad my_file.txt"‎

כאשר מוצגת בקשה להזנת סיסמה, הקלד את סיסמת החשבון.

כדי להפעיל מופע של חלון שורת הפקודה, של מסוף MMC שמור, של פריט לוח הבקרה או של תוכנית שתנהל שרת ביער אחר, הקלד:

runas /netonly /user:domain\username "command"‎

על domain\username להיות משתמש בעל הרשאות מתאימות לניהול השרת. כאשר מוצגת בקשה להזנת סיסמה, הקלד את סיסמת החשבון.


SC

קיום תקשורת עם בקר השירותים ועם שירותים מותקנים. היישום SC.exe מאחזר וקובע מידע בקרה אודות שירותים. באפשרותך להשתמש ביישום SC.exe לבדיקה ואיתור באגים בתוכניות שירות. ניתן להגדיר מאפייני שירות המאוחסנים ברישום לשם שליטה בהפעלה של יישומי שירותים בזמן האתחול וכתהליכים ברקע. ניתן להשתמש בפרמטרים של היישום SC.exe לקביעת תצורה של שירות ספציפי, לאחזור מצב נוכחי של שירות, ולהפסקה או הפעלה של שירות. באפשרותך ליצור קבצי אצווה המבצעים קריאה לפקודות שונות של היישום SC.exe כדי להפוך לאוטומטי רצף של הפעלה וכיבוי של שירותים. היישום SC.exe מספק יכולות הדומות לאלה של היישום שירותים בפריט כלי ניהול שבלוח הבקרה.

עבור תחביר הפקודה, לחץ על פקודה כלשהי של היישום sc שלהלן:

sc boot

הוראה לשמור או שלא לשמור את האתחול האחרון כתצורה תקינה אחרונה.

תחביר

sc ‎[ServerName]‎ boot ‎[{bad|OK}]‎

פרמטרים

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. על השם להיות בתבנית Universal Naming Convention, הידועה גם בשם UNC ‏(ולדוגמה, ‎"\\myserver"‎). בהפעלת היישום SC.exe באופן מקומי, התעלם מפרמטר זה.
‎[{bad|OK}]‎
מציין אם האתחול האחרון היה לא תקין או שיש לשמור אותו כתצורת האתחול התקינה האחרונה.
‎/?‎
הצגת עזרה בשורת הפקודה.

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה sc boot:

sc boot ok
sc boot bad

sc config

שינוי ערכי הרישום של השירותים ברישום ובמסד הנתונים של מנהל בקרת שירות.

תחביר

sc ‎[ServerName]‎ config ‎[ServiceName]‎ ‎[type= ‎{own|share|kernel|filesys|rec|adapt|interact type= {own|share}}]‎ ‎[start= ‎{boot|system|auto|demand|disabled}]‎ ‎[error= {normal|severe|critical|ignore}]‎ ‎[binpath= BinaryPathName]‎ ‎[group= LoadOrderGroup]‎ ‎[tag= {yes|no}]‎ ‎[depend= dependencies]‎ ‎[obj= {AccountName|ObjectName}]‎ ‎[displayname= DisplayName]‎ ‎[password= Password]‎

פרמטרים

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. על השם להיות בתבנית UNC ‏(‎"\\myserver"‎). כדי להפעיל את היישום SC.exe באופן מקומי, התעלם מפרמטר זה.
ServiceName
מציין את שם השירות שמחזירה הפעולה getkeyname.
type= {own|share|kernel|filesys|rec|adapt|interact type= {own|share}}‎
מציין את סוג השירות.
ערך | תיאור
own | השירות פועל בתהליך משלו. הוא אינו משתף קובץ הפעלה עם שירות אחר. זוהי הגדרת ברירת המחדל.
share | התהליך פועל כשירות משותף. הוא משתף קובץ הפעלה עם שירותים אחרים.
kernel | מנהל התקן.
filesys | מנהל התקן של מערכת קבצים.
rec | מנהל התקן מזהה של מערכת קבצים (מזהה מערכות קבצים הנמצאות בשימוש במחשב).
adapt | מנהל התקן של מתאם (מזהה פריטי חומרה כגון לוח מקשים, עכבר וכונן דיסקים).
interact | ניתנת לשירות אפשרות לקיים יחסי גומלין עם שולחן העבודה ולקבל קלט ממשתמשים. יש להפעיל שירותים אינטראקטיביים תחת החשבון LocalSystem. יש להשתמש בסוג זה בשילוב עם הפרמטרים type= own או type= shared (לדוגמה, type= interact type= own). שימוש בפרמטר type= interact בלבד יניב הודעת שגיאה של פרמטר לא חוקי.
start= {boot|system|auto|demand|disabled}‎
מציין את סוג ההפעלה עבור השירות.
ערך | תיאור
boot | מנהל התקן הנטען באמצעות טוען האתחול.
system | מנהל התקן המופעל במהלך אתחול הליבה.
auto | שירות המופעל באופן אוטומטי בכל פעם שהמחשב מופעל מחדש, ופועל גם אם אף משתמש אינו מבצע כניסה למחשב.
demand | יש להפעיל שירות באופן ידני. זהו ערך ברירת המחדל אם לא צוין הפרמטר start=‎.
disabled | לא ניתן להפעיל שירות. כדי להפעיל שירות שהוגדר כלא זמין, שנה את סוג ההפעלה (Start) לערך אחר.
error= {normal|severe|critical|ignore}‎
מציין את חומרת השגיאה אם הפעלת השירות נכשלת במהלך האתחול.
ערך | תיאור
normal | השגיאה נרשמת ומופיעה תיבת הודעה המודיעה למשתמש שהפעלת השירות נכשלה. האתחול ימשיך. זוהי הגדרת ברירת המחדל.
severe | השגיאה נרשמת (אם הדבר אפשרי). נעשה ניסיון להפעיל את המחשב מחדש בתצורה התקינה האחרונה. ייתכן שפעולה זו תאפשר את הפעלתו מחדש של המחשב, אך ייתכן שעדיין לא יהיה ניתן להפעיל את השירות.
critical | השגיאה נרשמת (אם הדבר אפשרי). נעשה ניסיון להפעיל את המחשב מחדש בתצורה התקינה האחרונה. אם תצורה זו נכשלת, גם האתחול נכשל ותהליך האתחול נעצר עם שגיאת Stop.
ignore | השגיאה נרשמת והאתחול ממשיך. לא נמסרת הודעה למשתמש מעבר לרישום השגיאה ביומן האירועים.
binpath= BinaryPathName
מציין נתיב לקובץ הבינארי של השירות.
group= LoadOrderGroup
מציין את שם הקבוצה שהשירות חבר בה. רשימת הקבוצות מאוחסנת ברישום במפתח המשנה HKLM\System\CurrentControlSet\Control\ServiceGroupOrder. ברירת המחדל היא Null (ערך ריק).
tag= {yes|no}‎
מציין האם להשיג TagID מהקריאה CreateService. תגים משמשים רק עבור מנהלי התקנים של Boot-Start ושל System-Start.
depend= dependencies
מציין את שמות השירותים או הקבוצות שיש להפעיל לפני שירות זה. השמות מופרדים באמצעות קו נטוי (/).
obj= {AccountName|ObjectName}‎
מציין שם חשבון שהשירות יפעל בו, או שם של אובייקט מנהל התקן של Windows שמנהל ההתקן יפעל בו. ברירת המחדל היא LocalSystem.
displayname= DisplayName
מציין שם ידידותי ובעל משמעות שניתן להשתמש בו בתוכניות ממשק משתמש כדי לסייע למשתמשים לזהות את השירות. לדוגמה, שם מפתח המשנה של שירות מסוים הוא wuauserv, שאינו מסייע למשתמש, אך שם התצוגה הוא "עדכונים אוטומטיים".
password= Password
מציין סיסמה. דבר זה נדרש אם נעשה שימוש בחשבון שאינו LocalSystem.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • ללא רווח בין הפרמטר לערך (לדוגמה, type= own, לא type=own), הפעולה תיכשל.

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה sc config:

sc config NewService binpath= "ntsd -d c:\windows\system32\NewServ.exe"‎

sc continue

שולח בקשת שליטה מסוג CONTINUE לשירות כדי לחדש שירות מושהה.

תחביר

sc ‎[ServerName]‎ continue ‎[ServiceName]‎

פרמטרים

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. על השם להיות בתבנית UNC ‏(‎"\\myserver"‎). כדי להפעיל את היישום SC.exe באופן מקומי, אל תשתמש בפרמטר זה.
ServiceName
מציין את שם השירות שמחזירה הפעולה getkeyname.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • השתמש בפעולה continue כדי לחדש שירות מושהה.

דוגמאות

הדוגמה הבאה מראה כיצד ניתן להשתמש בפקודה sc continue:

sc continue tapisrv

sc control

שליחת בקשת שליטה מסוג CONTROL B לשירות.

תחביר

sc [ServerName]‎ control ‎[ServiceName]‎ ‎[{paramchange|netbindadd|netbindremove|netbindenable|netbinddisable|UserDefinedControlB}]‎

פרמטרים

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. על השם להיות בתבנית UNC ‏(‎"\\myserver"‎). כדי להפעיל את היישום SC.exe באופן מקומי, התעלם מפרמטר זה.
ServiceName
מציין את שם השירות שמחזירה הפעולה getkeyname.
‎{paramchange|netbindadd|netbindremove|netbindenable|netbinddisable|UserDefinedControlB}‎
מציין בקשת שליטה שיש לשלוח לשירות.
‎/?‎
הצגת עזרה בשורת הפקודה.

sc create

יצירת מפתח משנה ופריטים עבור השירות ברישום ובמאגר המידע של מנהל בקרת השירות.

תחביר

sc ‎[ServerName]‎ create ‎[ServiceName]‎ ‎[type= {own|share|kernel|filesys|rec|adapt|interact type= {own|share}}]‎ ‎[start= {boot|system|auto|demand|disabled}]‎ ‎[error= {normal|severe|critical|ignore}]‎ ‎[binpath= BinaryPathName]‎ ‎[group= LoadOrderGroup]‎ ‎[tag= {yes|no}]‎ ‎[depend= dependencies]‎ ‎[obj= {AccountName|ObjectName}]‎ ‎[displayname= DisplayName]‎ ‎[password= Password]‎

פרמטרים

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. על השם להיות בתבנית UNC ‏(‎"\\myserver"‎). כדי להפעיל את היישום SC.exe באופן מקומי, התעלם מפרמטר זה.
ServiceName
מציין את שם השירות שמחזירה הפעולה getkeyname.
type= {own|share|kernel|filesys|rec|adapt|interact type= {own|share}}‎
ציון סוג השירות. ברירת המחדל היא type= own.
ערך | תיאור
own | השירות פועל בתהליך משלו. הוא אינו משתף קובץ הפעלה עם שירות אחר. זוהי הגדרת ברירת המחדל.
share | התהליך פועל כשירות משותף. הוא משתף קובץ הפעלה עם שירותים אחרים.
kernel | מנהל התקן.
filesys | מנהל התקן של מערכת קבצים.
rec | מנהל התקן מזהה מערכת קבצים (מזהה מערכות קבצים הנמצאות בשימוש במחשב).
interact | ניתנת לשירות אפשרות לקיים יחסי גומלין עם שולחן העבודה ולקבל קלט ממשתמשים. יש להפעיל שירותים אינטראקטיביים תחת החשבון LocalSystem. יש להשתמש בסוג זה בשילוב עם הפרמטרים type= own או type= shared (לדוגמה, type= interact type= own). שימוש בפרמטר type= interact בלבד יניב הודעת שגיאה של פרמטר לא חוקי.
start= ‎{boot|system|auto|demand|disabled}‎
מציין את סוג ההפעלה עבור השירות. ברירת המחדל היא start= demand.
boot | מנהל התקן הנטען באמצעות טוען האתחול.
system | מנהל התקן המופעל במהלך אתחול הליבה.
auto | שירות המופעל באופן אוטומטי בכל פעם שהמחשב מופעל מחדש ופועל גם אם אף משתמש אינו מבצע כניסה למחשב.
demand | יש להפעיל שירות באופן ידני. זהו ערך ברירת המחדל אם לא צוין הפרמטר start=‎.
disabled | לא ניתן להפעיל את השירות. כדי להפעיל שירות שהוגדר כלא זמין, שנה את סוג ההתחלה לערך אחר.
error= ‎{normal|severe|critical|ignore}‎
מציין את חומרת השגיאה אם הפעלת השירות נכשלת במהלך האתחול. ברירת המחדל היא error= normal.
normal | השגיאה נרשמת ומופיעה תיבת הודעה המודיעה למשתמש שהפעלת השירות נכשלה. האתחול ימשיך. זוהי הגדרת ברירת המחדל.
severe | השגיאה נרשמת (אם הדבר אפשרי). נעשה ניסיון להפעיל את המחשב מחדש בתצורה התקינה האחרונה. ייתכן שפעולה זו תאפשר את הפעלתו מחדש של המחשב אך ייתכן שעדיין לא יהיה ניתן להפעיל את השירות.
critical | השגיאה נרשמת (אם הדבר אפשרי). נעשה ניסיון להפעיל את המחשב מחדש בתצורה התקינה האחרונה. אם תצורה זו נכשלת, גם האתחול נכשל והתהליך נעצר עם שגיאת Stop.
ignore | השגיאה נרשמת והאתחול ממשיך. לא נמסרת הודעה למשתמש מעבר לרישום השגיאה ביומן האירועים.
binpath= BinaryPathName
מציין נתיב לקובץ הבינארי של השירות. אין ברירת מחדל עבור הפרמטר binpath=‎ ויש לספק מחרוזת זו.
group= LoadOrderGroup
מציין את שם הקבוצה שהשירות חבר בה. רשימת הקבוצות מאוחסנת ברישום במפתח המשנה HKLM\System\CurrentControlSet\Control\ServiceGroupOrder. ברירת המחדל היא Null (ערך ריק).
tag= {yes|no}‎
מציין האם להשיג TagID מהקריאה CreateService. תגים משמשים רק עבור מנהלי התקנים של Boot-Start ושל System-Start.
depend= dependencies
מציין את שמות השירותים או הקבוצות שיש להפעיל לפני שירות זה. השמות מופרדים באמצעות קו נטוי (/).
obj= {AccountName|ObjectName}‎
מציין שם חשבון שהשירות יפעל בו, או שם של אובייקט מנהל התקן של Windows שמנהל ההתקן יפעל בו.
displayname= DisplayName
מציין שם ידידותי ובעל משמעות שניתן להשתמש בו בתוכניות ממשק משתמש כדי לסייע למשתמשים לזהות את השירות.
password= Password
מציין סיסמה. דבר זה נדרש אם נעשה שימוש בחשבון שאינו LocalSystem.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • ללא רווח בין הפרמטר לערך (כלומר, type= own, לא type=own), הפעולה תיכשל.

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה sc create:

sc \\myserver create NewService binpath= c:\windows\system32\NewServ.exe
sc create NewService binpath= c:\windows\system32\NewServ.exe type= share start= auto depend= ‎"+TDI Netbios"‎

sc delete

מחיקה של מפתח משנה של שירות מהרישום. אם השירות פועל או אם תהליך אחר הוא בעל מזהה יחודי פתוח לשירות, השירות מסומן למחיקה.

תחביר

sc ‎[ServerName]‎ delete ‎[ServiceName]‎

פרמטרים

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. עליך להשתמש בתבנית UNC ‏(‎"\\myserver"‎). כדי להפעיל את היישום SC.exe באופן מקומי, התעלם מפרמטר זה.
ServiceName
מציין את שם השירות שמחזירה הפעולה getkeyname.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • השתמש ביישום הוספה או הסרה של תוכניות לשם מחיקה של DHCP‏, DNS או כל שירות מוכלל אחר של מערכת ההפעלה. היישום הוספה או הסרה של תוכניות יסיר את מפתח המשנה מהרישום עבור השירות ובנוסף יסיר את התקנת השירות וימחק קיצורי דרך אל השירות.

דוגמאות

הדוגמה הבאה מראה כיצד ניתן להשתמש בפקודה sc delete:

sc delete newserv

sc description

קביעה של מחרוזת התיאור עבור שירות.

תחביר

sc ‎[ServerName]‎ description [ServiceName] [Description]‎

פרמטרים

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. עליך להשתמש בתבנית UNC ‏(‎"\\myserver"‎). כדי להפעיל את היישום SC.exe באופן מקומי, התעלם מפרמטר זה.
ServiceName
מציין את שם השירות שמחזירה הפעולה getkeyname.
Description
מציין תיאור עבור השירות שצוין. אם לא מצוינת מחרוזת, תיאור השירות אינו משתנה. אין הגבלה על מספר התווים שניתן להזין בתיאור השירות.
‎/?‎
הצגת עזרה בשורת הפקודה.

דוגמאות

הדוגמה הבאה מראה כיצד ניתן להשתמש בפקודה sc description:

sc description newserv ‎"Runs quality of service control."‎

sc enumdepend

פירוט השירותים שלא ניתן להפעיל אלא אם פועל השירות שצוין.

תחביר

sc ‎[ServerName]‎ enumdepend ‎[ServiceName]‎ ‎[BufferSize]‎

פרמטרים

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. על השם להיות בתבנית UNC ‏(‎"\\myserver"‎). כדי להפעיל את היישום SC.exe באופן מקומי, התעלם מפרמטר זה.
ServiceName
מציין את שם השירות שמחזירה הפעולה getkeyname.
BufferSize
מציין את הגודל (בבתים) של מאגר הספירה. גודל ברירת המחדל הוא 1024 בתים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • אם המאגר אינו גדול מספיק, פלט הפקודה enumdepend יציג מידע תלות באופן חלקי בלבד, ויציין את גודל המאגר הנוסף הנדרש עבור הצגה של כל יחסי התלות. אם הפלט חתוך, הפעל את הפעולה מחדש וציין מאגר גדול יותר.

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה sc enumdepend:

sc enumdepend rpcss 5690
sc enumdepend tapisrv

sc failure

ציון הפעולה שתתבצע במקרה של כישלון השירות.

תחביר

sc ‎[ServerName]‎ failure ‎[ServiceName]‎ ‎[reset= ErrorFreePeriod]‎ ‎[reboot= BroadcastMessage]‎ ‎[command= CommandLine]‎ ‎[actions= FailureActionsAndDelayTime]‎

פרמטרים

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. על השם להיות בתבנית UNC ‏(‎"\\myserver"‎). כדי להפעיל את היישום SC.exe באופן מקומי, התעלם מפרמטר זה.
ServiceName
מציין את שם השירות שמחזירה הפעולה getkeyname.
reset= ErrorFreePeriod
מציין את משך הזמן (בשניות) ללא כשלים שלאחריו מאופס מונה הכשלים. יש להשתמש בפרמטר זה בשילוב עם הפרמטר actions=‎.
reboot= BroadcastMessage
מציין את ההודעה שתשודר במקרה של כישלון השירות.
command= CommandLine
מציין את שורת הפקודה שתופעל במקרה של כישלון השירות. לקבלת מידע נוסף אודות אופן ההפעלה של קובץ אצווה או קובץ VBS לאחר כשל, ראה הערות.
actions= FailureActionsAndDelayTime
מציין את פעולות הכשל ואת זמן ההשהיה שלהן (באלפיות שניה), מופרדים באמצעות קו נטוי (/). הפעולות הבאות חוקיות: run‏, restart ו- reboot. יש להשתמש בפרמטר זה בצירוף הפרמטר reset=‎. השתמש בצורה actions=‎ ""‎ כדי להימנע מביצוע פעולות לאחר הכישלון.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • לא כל השירותים מאפשרים שינוי של אפשרויות הכשל שלהם. חלקם פועלים כחלק של ערכת שירותים.
  • כדי להפעיל קובץ אצווה בעקבות כישלון, ציין ‎cmd.exe Drive:\FileName.bat‎ בפרמטר command=‎, כאשר Drive:\FileName.bat הוא השם והנתיב המלאים של קובץ האצווה.
  • כדי להפעיל קובץ VBS בעקבות כישלון, ציין את הערך cscript drive:\myscript.vbs בפרמטר command=‎, כאשר drive:\myscript.vbs הוא השם והנתיב המלאים של קובץ ה- Script.
  • ניתן לציין שלוש פעולות שונות בפרמטר actions=‎, שייושמו בפעם הראשונה, השניה והשלישית שבהן השירות נכשל.
  • ללא רווח בין הפרמטר לערך שלו (כלומר, type= own, לא type=own), הפעולה תיכשל.

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה sc failure:

sc failure msftpsvc reset= 30 actions= restart/5000
sc failure dfs reset= 60 command= c:\windows\services\restart_dfs.exe actions= run/5000
sc failure dfs reset= 60 actions= reboot/30000
sc failure dfs reset= 60 reboot= "The Distributed File System service has failed. Because of this, the computer will reboot in 30 seconds." actions= reboot/30000
sc failure myservice reset= 3600 reboot= ‎"MyService crashed -- rebooting machine"‎ command= "‎‎%windir%‎‎\MyServiceRecovery.exe" actions= restart/5000/run/10000/reboot/60000

sc getdisplayname

מקבל את שם התצוגה המשויך לשירות מסוים.

תחביר

sc ‎[ServerName]‎ getdisplayname ‎[ServiceName]‎ ‎[BufferSize]‎

פרמטרים

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. על השם להיות בתבנית UNC ‏(‎"\\myserver"‎). כדי להפעיל את היישום SC.exe באופן מקומי, התעלם מפרמטר זה.
ServiceName
מציין את שם השירות שמחזירה הפעולה getkeyname.
BufferSize
מציין את הגודל (בבתים) של המאגר. ברירת המחדל היא 1024 בתים.
‎/?‎
הצגת עזרה בשורת הפקודה.

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה sc getdisplayname:

sc getdisplayname clipsrv
sc getdisplayname tapisrv
sc getdisplayname sharedaccess

sc getkeyname

קבלת שם המפתח המשויך לשירות מסוים תוך שימוש בשם התצוגה כקלט.

תחביר

sc [ServerName]‎ getkeyname ‎[ServiceDisplayName]‎ ‎[BufferSize]‎

פרמטרים

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. על השם להיות בתבנית UNC ‏(‎"\\myserver"‎). כדי להפעיל את היישום SC.exe באופן מקומי, התעלם מפרמטר זה.
ServiceDisplayName
מציין את שם התצוגה של השירות.
BufferSize
מציין את הגודל (בבתים) של המאגר. ברירת המחדל היא 1024 בתים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • אם הערך עבור הפרמטר ServiceDisplayName מכיל רווחים, תחום אותו במרכאות (כלומר, "Service Display Name").

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה sc getkeyname:

sc getkeyname ‎"remote procedure call (rpc)"‎
sc getkeyname ‎"internet connection sharing"‎
sc getkeyname clipbook

sc interrogate

שולח בקשת שליטה מסוג INTERROGATE לשירות.

תחביר

sc ‎[ServerName]‎ interrogate ‎[ServiceName]‎

פרמטרים

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. על השם להיות בתבנית UNC ‏(‎"\\myserver"‎). כדי להפעיל את היישום SC.exe באופן מקומי, התעלם מפרמטר זה.
ServiceName
מציין את שם השירות שמחזירה הפעולה getkeyname.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • שליחת INTERROGATE לשירות גורמת לו לעדכן את מצבו באמצעות מנהל בקרת השירות.

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה sc interrogate:

sc interrogate sharedaccess
sc interrogate rpcss

sc lock

נעילת מסד הנתונים של מנהל בקרת השירות.

תחביר

sc [ServerName] lock

פרמטרים

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. על השם להיות בתבנית UNC ‏(‎"\\myserver"‎). כדי להפעיל את היישום SC.exe באופן מקומי, התעלם מפרמטר זה.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • נעילת מסד הנתונים של מנהל בקרת השירות מונעת משירותים לפעול. השתמש בפעולה זו אם ברצונך להבטיח ששירות לא יופעל לאחר שהופסק. דבר זה יאפשר לך לנקוט בפעולה כלשהי (מחיקת השירות, לדוגמה) ללא הפרעה.
  • השימוש בפעולה lock נועל את מסד הנתונים של מנהל בקרת השירות, ומאפשר את פתיחתו לאחר מכן על-ידי הקלדת u. כמו כן, באפשרותך לסיים את התהליך שממנו נעלת את מסד הנתונים.

דוגמאות

הדוגמה הבאה מראה כיצד ניתן להשתמש בפקודה sc lock:

sc lock

sc pause

שליחה של בקשת השליטה PAUSE לשירות.

תחביר

sc ‎[ServerName]‎ pause ‎[ServiceName]‎

פרמטרים

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. על השם להיות בתבנית UNC ‏(‎"\\myserver"‎). כדי להפעיל את היישום SC.exe באופן מקומי, התעלם מפרמטר זה.
ServiceName
מציין את שם השירות שמחזירה הפעולה getkeyname.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • השתמש בפעולה pause כדי להשהות שירות לפני סגירתו.
  • לא את כל השירותים ניתן להשהות.
  • לא כל היישומים מתנהגים אותו הדבר כאשר הם מושהים. חלקם ממשיכים לשרת לקוחות קיימים אך מסרבים לקבל לקוחות חדשים. אחרים מפסיקים לשרת לקוחות קיימים בנוסף לסירוב לשרת לקוחות חדשים.

דוגמאות

הדוגמה הבאה מראה כיצד ניתן להשתמש בפקודה sc pause:

sc pause tapisrv

sc qc

ביצוע שאילתה על מידע התצורה של שירות.

תחביר

sc ‎[ServerName]‎ qc ‎[ServiceName]‎ ‎[BufferSize]‎

פרמטרים

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. על השם להיות בתבנית UNC ‏(‎"\\myserver"‎). כדי להפעיל את היישום SC.exe באופן מקומי, התעלם מפרמטר זה.
ServiceName
מציין את שם השירות שמחזירה הפעולה getkeyname.
BufferSize
מציין את הגודל (בבתים) של המאגר. ברירת המחדל היא 1024 בתים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • הפעולה qc מציגה את המידע הבא אודות שירות: SERVICE_NAME (שם מפתח המשנה ברישום של השירות), TYPE‏, ERROR_CONTROL‏, BINARY_PATH_NAME‏, LOAD_ORDER_GROUP‏, TAG‏, DISPLAY_NAME‏, DEPENDENCIES ו- SERVICE_START_NAME.

  • לחברים בקבוצה Administrators יש אפשרות להשתמש בפעולה SC כדי למצוא את השם הבינארי של כל שירות ולגלות האם הוא משתף תהליך עם שירותים אחרים על-ידי הקלדת הטקסט הבא בשורת הפקודה:

    sc qc ServiceName

    הפעולה SC עשויה לעזור בהתאמת שירותים בצומת Services של Microsoft Management Console ‏(MMC) עם תהליכים בצג המערכת. אם השם הבינארי הוא Services.exe, הרי שהשירות משתף את תהליך בקר השירותים (Service Controller).

    היישום Services.exe מפעיל את כל השירותים. כדי לחסוך במשאבי מערכת, מספר שירותי Win32 שפותחו עבור Windows נכתבו כך שישתפו את התהליך Services.exe. שירותים אלה אינם מפורטים כתהליכים נפרדים בצג המערכת או במנהל המשימות. הדבר נכון גם לגבי היישום Svchost.exe שהוא תהליך מארח שירותים המשותף על-ידי מערכות הפעלה רבות.

    ייתכן שלא יהיה תהליך עבור כל שירות Win32 מכיוון ששירותי Win32 של צד שלישי עשויים אף הם להיות מוגדרים לשיתוף תהליכים. ניתן להשתמש בפעולה SC לקבלת מידע תצורה אודות שירותים אלה. עם זאת, אם השירות אינו משתף את התהליך שלו עם שירותים אחרים, בעת שהוא פועל יוצג תהליך עבורו בצג המערכת.

  • הפעולה SC עשויה להיות שימושית עבור מפתחי שירותים שכן היא מספקת מידע מפורט ומדויק יותר אודות שירותים מאשר היישום Services.exe הכלול ב- Windows. ניתן להשתמש ביישום Services.exe כדי לגלות האם השירות פועל, מופסק או מושהה. למרות שכלים אלה מספיקים עבור יישום העובר איתור באגים ופועל כהלכה, המידע שהם מספקים אודות שירות הנמצא בפיתוח עשוי להיות מטעה. לדוגמה, שירות הנמצא בתהליך הפעלה מוצג כפועל גם אם אינו פועל למעשה.

    הפעולה SC מיישמת קריאות לכל פונקציות בקרת השירות של ממשק תכנות היישומים (Application Programming Interface, ‏API) ב- Windows. קבע את הפרמטרים עבור פונקציות אלה על-ידי ציונם בשורת הפקודה.

    באמצעות הפעולה SC, באפשרותך לבצע שאילתה על מצב השירות ולאחזר את הערכים המאוחסנים בשדות מבנה המצב. ליישום Services.exe אין אפשרות לספק מצב מלא של שירות, אך הפעולה SC מציגה את המצב המדויק של השירות, כמו גם את מספר נקודת הביקורת ואת רמז ההמתנה האחרונים. ניתן להשתמש בנקודת הביקורת ככלי לאיתור באגים שכן היא מציינת עד לאן התקדם תהליך האתחול עד שהתוכנית הפסיקה להגיב. הפעולה SC מאפשרת לך, בנוסף, לציין שם של מחשב מרוחק כך שתוכל לבצע קריאה לפונקציות API של השירות או להציג מבני מצב של השירות במחשב מרוחק.

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה sc qc:

sc qc \\myserver newsrvice
sc qc rpcss 248

sc qdescription

הצגת מחרוזת התיאור של שירות.

תחביר

sc ‎[ServerName]‎ qdescription ‎[ServiceName]‎ ‎[BufferSize]‎

פרמטרים

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. על השם להיות בתבנית UNC ‏(‎"\\myserver"‎). כדי להפעיל את היישום SC.exe באופן מקומי, התעלם מפרמטר זה.
ServiceName
מציין את שם השירות שמחזירה הפעולה getkeyname.
BufferSize
מציין את הגודל (בבתים) של המאגר. ברירת המחדל היא 1024 בתים.
‎/?‎
הצגת עזרה בשורת הפקודה.

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה sc qdescription:

sc qdescription rpcss
sc qdescription rpcss 138

sc qfailure

הצגת הפעולות שיבוצעו אם השירות שצוין נכשל.

תחביר

sc ‎[ServerName]‎ qfailure ‎[ServiceName]‎ ‎[BufferSize]‎

פרמטרים

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. על השם להיות בתבנית UNC ‏(‎"\\myserver"‎). כדי להפעיל את היישום SC.exe באופן מקומי, התעלם מפרמטר זה.
ServiceName
מציין את שם השירות שמחזירה הפעולה getkeyname.
BufferSize
מציין את הגודל (בבתים) של המאגר. ברירת המחדל היא 1024 בתים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • הפעולה qfailure מציגה את המידע הבא אודות שירות: SERVICE_NAME (שם מפתח המשנה ברישום של השירות), RESET_PERIOD‏, REBOOT_MESSAGE‏, COMMAND_LINE ו- FAILURE_ACTIONS.

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה sc qfailure:

sc qfailure rpcss
sc qfailure rpcss 20

sc query

קבלה והצגה של מידע אודות השירות, מנהל ההתקן, סוג השירות או סוג מנהל ההתקן שצוינו.

תחביר

sc ‎[ServerName]‎ query ‎[ServiceName]‎ ‎[type= {driver|service|all}]‎ ‎[type= {own|share|interact|kernel|filesys|rec|adapt}]‎ ‎[state= {active|inactive|all}]‎ ‎[bufsize= BufferSize]‎ ‎[ri= ResumeIndex]‎ ‎[group= GroupName]‎

פרמטרים

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. על השם להיות בתבנית UNC ‏(‎"\\myserver"‎). כדי להפעיל את היישום SC.exe באופן מקומי, התעלם מפרמטר זה.
ServiceName
מציין את שם השירות שמחזירה הפעולה getkeyname. פרמטר query זה אינו משמש יחד עם פרמטרי query נוספים (מלבד הפרמטר ServerName).
type= {driver|service|all}‎
מציין את סוג הפריט שיש לספור. סוג ברירת המחדל הוא service.
ערך | תיאור
driver | מציין שיש לספור רק מנהלי התקן.
service | מציין שיש לספור רק שירותים.
all | מציין שיש לספור הן מנהלי התקן והן שירותים.
type= {own|share|interact|kernel|filesys|rec|adapt}‎
מציין את סוג השירותים או את סוג מנהלי ההתקן שיש לספור.
ערך | תיאור
own | השירות פועל בתהליך משלו. הוא אינו משתף קובץ הפעלה עם שירותים אחרים. זוהי הגדרת ברירת המחדל.
share | התהליך פועל כשירות משותף. הוא משתף קובץ הפעלה עם שירותים אחרים.
interact | ניתנת לשירות אפשרות לקיים יחסי גומלין עם שולחן העבודה ולקבל קלט ממשתמשים. יש להפעיל שירותים אינטראקטיביים תחת החשבון LocalSystem.
kernel | מנהל התקן.
filesys | מנהל התקן של מערכת קבצים.
state= {active|inactive|all}‎
מציין את מצב ההפעלה של השירות שעבורו מתבצעת ספירה. מצב ברירת המחדל הוא active.
ערך | תיאור
active | מציין את כל השירותים הפעילים.
inactive | מציין את כל השירותים שהושהו או הופסקו.
all | מציין את כל השירותים.
bufsize= BufferSize
מציין את הגודל (בבתים) של מאגר הספירה. גודל ברירת המחדל הוא 1024 בתים. הגדל את מאגר הספירה כאשר התצוגה של תוצאות השאילתה עולה על 1024 בתים.
ri= ResumeIndex
מציין את מספר האינדקס שיש להתחיל או לחדש בו את פעולת הספירה. ברירת המחדל היא 0. השתמש בפרמטר זה בצירוף הפרמטר bufsize=‎ כאשר מוחזר משאילתה מידע רב משניתן להציג במאגר המוגדר כברירת מחדל.
group= GroupName
מציין את קבוצת השירות שיש לספור. ברירת המחדל היא כל הקבוצות.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • ללא רווח בין הפרמטר והערך שלו (כלומר, type= own, לא type=own), הפעולה תיכשל.
  • הפעולה query מציגה את המידע הבא אודות שירות: SERVICE_NAME (שם מפתח המשנה ברישום של השירות), TYPE‏, STATE (ובנוסף מצבים שאינם זמינים), WIN32_EXIT_B‏, SERVICE_EXIT_B‏, CHECKPOINT ו- WAIT_HINT.
  • ניתן להשתמש בפרמטר type=‎ פעמיים במקרים מסוימים. המופע הראשון של הפרמטר type=‎ מציין האם לבצע שאילתה על שירותים, על מנהלי התקן או על שניהם. המופע השני של הפרמטר type=‎ מציין סוג של הפעולה create כדי לצמצם עוד יותר את טווח השאילתה.
  • כאשר גודל התצוגה שמפיקה הפקודה query עולה על גודל מאגר הספירה, מוצגת הודעה הדומה להודעה הבאה:

    Enum: more data, need 1822 bytes start resume at index 79

    כדי להציג את יתר המידע שנתקבל לאחר שימוש ב- query, הפעל מחדש את query והגדר את bufsize=‎ למספר הבתים ואת ri=‎ לאינדקס שצוין. לדוגמה, שאר הפלט יוצג על-ידי הקלדת הטקסט הבא בשורת הפקודה:

    sc query bufsize= 1822 ri= 79

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה sc query:

sc query
sc query messenger
sc query type= driver
sc query type= service
sc query state= all
sc query bufsize= 50
sc query ri= 14
sc query type= service type= interact
sc query type= driver group= ndis

sc queryex

קבלה והצגה של מידע מורחב אודות השירות, מנהל ההתקן, סוג השירות או סוג מנהל ההתקן שצוינו.

תחביר

sc ‎[ServerName]‎ queryex ‎[type= {driver|service|all}]‎ ‎[type= {own|share|interact|kernel|filesys|rec|adapt}]‎ ‎[state= {active|inactive|all}]‎ ‎[bufsize= BufferSize]‎ ‎[ri= ResumeIndex]‎ ‎[group= GroupName]‎

פרמטרים

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. על השם להיות בתבנית UNC ‏(‎"\\myserver"‎). כדי להפעיל את היישום SC.exe באופן מקומי, התעלם מפרמטר זה.
ServiceName
מציין את שם השירות שמחזירה הפעולה getkeyname. פרמטר queryex זה אינו משמש בשילוב עם פרמטרי queryex אחרים מלבד הפרמטר ServerName.
type= {driver|service|all}‎
מציין את סוג הפריט שיש לספור. סוג ברירת המחדל הוא service.
ערך | תיאור
driver | מציין שיש לספור רק מנהלי התקן.
service | מציין שיש לספור רק שירותים.
all | מציין שיש לספור הן מנהלי התקן והן שירותים.
type= {own|share|interact|kernel|filesys|rec|adapt}‎
מציין את סוג השירותים או את את סוג מנהלי ההתקן שיש לספור.
ערך | תיאור
own | השירות פועל בתהליך משלו. הוא אינו משתף קובץ הפעלה עם שירות אחר. זוהי הגדרת ברירת המחדל.
share | התהליך פועל כשירות משותף. הוא משתף קובץ הפעלה עם שירותים אחרים.
interact | ניתנת לשירות אפשרות לקיים יחסי גומלין עם שולחן העבודה ולקבל קלט ממשתמשים. יש להפעיל שירותים אינטראקטיביים תחת החשבון LocalSystem.
kernel | מנהל התקן.
filesys | מנהל התקן של מערכת קבצים.
state= {active|inactive|all}‎
מציין את מצב ההפעלה של השירות שיש לבצע ספירה עבורו. מצב ברירת המחדל הוא active.
ערך | תיאור
active | מציין את כל השירותים הפעילים.
inactive | מציין את כל השירותים שהושהו או הופסקו.
all | מציין את כל השירותים.
bufsize= BufferSize
מציין את הגודל (בבתים) של מאגר הספירה. גודל ברירת המחדל הוא 1024 בתים.
ri= ResumeIndex
מציין את מספר האינדקס שיש להתחיל או לחדש בו את הספירה. ברירת המחדל היא 0.
group= GroupName
מציין את קבוצת השירות שיש לספור. ברירת המחדל היא כל הקבוצות.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • ללא רווח בין הפרמטר והערך שלו (כלומר, type= own, לא type=own), הפעולה תיכשל.
  • הפעולה query מציגה את המידע הבא אודות שירות: SERVICE_NAME (שם מפתח המשנה ברישום של השירות), TYPE‏, STATE (ובנוסף מצבים שאינם זמינים), WIN32_EXIT_B‏, SERVICE_EXIT_B‏, CHECKPOINT‏, WAIT_HINT‏, PID ו- FLAGS.
  • ניתן להשתמש בפרמטר type=‎ פעמיים במקרים מסוימים. המופע הראשון של הפרמטר type=‎ מציין האם לבצע שאילתה על שירותים, על מנהלי התקן או על שניהם. המופע השני של הפרמטר type=‎ מציין סוג של הפעולה create כדי לצמצם עוד יותר את טווח השאילתה.
  • כאשר גודל התצוגה שהפיקה הפקודה query עולה על גודל מאגר הספירה, מוצגת הודעה הדומה להודעה הבאה:

    Enum: more data, need 2130 bytes start resume at index 75

    כדי להציג את שאר מידע שהתקבל מ- query, הפעל מחדש את query והגדר את bufsize=‎ למספר הבתים ואת ri=‎ לאינדקס שצוין. לדוגמה, שאר הפלט יוצג על-ידי הקלדת הטקסט הבא בשורת הפקודה:

    sc queryex bufsize= 2130 ri= 75

דוגמאות

הדוגמאות הבאות מראות כיצד ניתן להשתמש בפקודה sc queryex:

sc queryex messenger
sc queryex group= ""‎

sc querylock

ביצוע שאילתה והצגת מצב הנעילה עבור מסד הנתונים של מנהל בקרת השירות.

תחביר

sc ‎[ServerName]‎ querylock

פרמטר

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. על השם להיות בתבנית UNC ‏(‎"\\myserver"‎). כדי להפעיל את היישום SC.exe באופן מקומי, התעלם מפרמטר זה.
‎/?‎
הצגת עזרה בשורת הפקודה.

sc sdset

הגדרה של מתאר אבטחה של שירות באמצעות Service Descriptor Definition Language ‏(SDDL).

תחביר

sc ‎[ServerName]‎ sdset ServiceName ServiceSecurityDescriptor

פרמטרים

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. על השם להיות בתבנית UNC ‏(‎"\\myserver"‎). כדי להפעיל את היישום SC.exe באופן מקומי, התעלם מפרמטר זה.
ServiceName
מציין את שם השירות שמחזירה הפעולה getkeyname.
ServiceSecurityDescriptor
מציין את מתאר השירות ב- SDDL.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • לקבלת מידע נוסף אודות SDDL, ראה "Security Descriptor Definition Language" באתר MSDN Online Library.‏(http://www.microsoft.com/‎)

sc sdshow

הצגה של מתאר אבטחה של שירות באמצעות SDDL.

תחביר

sc ‎[ServerName]‎ sdshow ServiceName

פרמטרים

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. על השם להיות בתבנית UNC ‏(‎"\\myserver"‎). כדי להפעיל את היישום SC.exe באופן מקומי, התעלם מפרמטר זה.
ServiceName
מציין את שם השירות שמחזירה הפעולה getkeyname.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • לקבלת מידע נוסף אודות SDDL, ראה "Security Descriptor Definition Language" באתר MSDN Online Library.‏(http://www.microsoft.com/‎)

דוגמאות

sc sdshow rpcss

sc start

הפעלת שירות.

תחביר

sc ‎[ServerName]‎ start ServiceName ‎[ServiceArguments]‎

פרמטרים

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. על השם להיות בתבנית UNC ‏(‎"\\myserver"‎). כדי להפעיל את היישום SC.exe באופן מקומי, התעלם מפרמטר זה.
ServiceName
מציין את שם השירות שמחזירה הפעולה getkeyname.
ServiceArguments
מציין ארגומנטי שירות שיש להעביר לשירות שברצונך להפעיל.
‎/?‎
הצגת עזרה בשורת הפקודה.

דוגמאות

הדוגמה הבאה מראה כיצד ניתן להשתמש בפקודה sc start:

sc start tapisrv

sc stop

שליחה של בקשת השליטה STOP לשירות.

תחביר

sc ‎[ServerName]‎ stop ServiceName

פרמטרים

ServerName
מציין את שם השרת המרוחק שהשירות ממוקם בו. על השם להיות בתבנית UNC ‏(‎"\\myserver"‎). כדי להפעיל את היישום SC.exe באופן מקומי, התעלם מפרמטר זה.
ServiceName
מציין את שם השירות שמחזירה הפעולה getkeyname.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • לא את כל השירותים ניתן להפסיק.

דוגמאות

הדוגמה הבאה מראה כיצד ניתן להשתמש בפקודה sc stop:

sc stop tapisrv

הערות

    XOX

    נושאים קרובים


Schtasks

תזמון פקודות ותוכניות לפעולה באופן מחזורי או בזמן מסוים. הוספה והסרה של משימות מלוח הזמנים, הפעלה והפסקה של משימות לפי דרישה והצגה ושינוי של משימות מתוזמנות.

לשם הצגת תחביר הפקודה, לחץ על הפקודה:

schtasks create

יצירת משימה מתוזמנת חדשה.

תחביר

schtasks ‎/create ‎/tn TaskName ‎/tr TaskRun ‎/sc schedule ‎[/mo modifier] ‎[/d day]‎ ‎[/m month[,month...]‎ ‎[/i IdleTime]‎ ‎[/st StartTime]‎ ‎[/sd StartDate]‎ ‎[/ed EndDate]‎ ‎[/s computer [/u [domain\]user /p password]]‎ ‎[/ru {[Domain\]User | "System"} [/rp Password]]‎ ‎/?‎

פרמטרים

‎/tn TaskName
ציון שם עבור המשימה.
‎/tr TaskRun
ציון התוכנית או הפקודה המופעלות על-ידי המשימה. הקלד את שם הקובץ והנתיב המלאים של קובץ הפעלה, קובץ Script או קובץ אצווה. אם תשמיט את הנתיב, היישום SchTasks.exe יפעל בהנחה שהקובץ נמצא בספריה Systemroot\System32.
‎/sc schedule
ציון הסוג של לוח הזמנים. הערכים החוקיים הם MINUTE,‏ HOURLY,‏ DAILY,‏ WEEKLY,‏ MONTHLY,‏ ONCE,‏ ONSTART,‏ ONLOGON,‏ ONIDLE.
ערך | תיאור
MINUTE, ‏HOURLY, ‏DAILY, ‏WEEKLY, ‏MONTHLY | ציון יחידת הזמן עבור לוח הזמנים.
ONCE | המשימה מופעלת פעם אחת בתאריך ובשעה שצוינו.
ONSTART | המשימה מופעלת בכל פעם שהמחשב מופעל. באפשרותך לציין תאריך הפעלה או להפעיל את המשימה בפעם הבאה שהמערכת מופעלת.
ONLOGON | המשימה מופעלת בכל פעם שמשתמש (כל משתמש) מבצע כניסה למחשב. באפשרותך לציין תאריך או להפעיל את המשימה בפעם הבאה שהמשתמש יבצע כניסה.
ONIDLE | המשימה מופעלת בכל פעם שהמערכת נמצאת במצב לא פעיל למשך פרק זמן מסוים. באפשרותך לציין תאריך או להפעיל את המשימה בפעם הבאה שהמערכת אינה פעילה.
‎/mo modifier
ציון התדירות שבה מופעלת המשימה בתוך סוג לוח הזמנים שלה. פרמטר זה נדרש עבור לוח זמנים מסוג MONTHLY. פרמטר זה הוא חוקי אך אופציונאלי עבור לוח זמנים מהסוגים MINUTE,‏ HOURLY,‏ DAILY או WEEKLY. הערך המשמש כברירת המחדל הוא 1.
סוג לוח הזמנים | ביטוי מגביל | תיאור
MINUTE | ‎1 - 1439 | המשימה מופעלת כל n דקות.
HOURLY | ‎1 - 23 | המשימה מופעלת כל n שעות.
DAILY | ‎1 - 365 | המשימה מופעלת כל n ימים.
WEEKLY | ‎1 - 52 | המשימה מופעלת כל n שבועות.
MONTHLY | ‎1 - 12 | המשימה מופעלת כל n חודשים.
 | LASTDAY | המשימה מופעלת ביום האחרון של החודש.
 | FIRST, ‏SECOND, ‏THIRD, ‏FOURTH, ‏LAST | השתמש יחד עם הפרמטר ‎/d day כדי להפעיל משימה בשבוע וביום מסוימים. לדוגמה, ביום רביעי השלישי של החודש.
‎/d day
ציון יום בשבוע או יום בחודש. חוקי עם לוחות הזמנים WEEKLY או MONTHLY בלבד.
סוג לוח הזמנים | ערכי יום
WEEKLY | אופציונלי. הערכים החוקיים הם MON - SUN ו- * (כל יום). MON משמש כברירת מחדל.
MONTHLY | ערך של MON - SUN נדרש כאשר נעשה שימוש בביטויים המגבילים FIRST,‏ SECOND,‏ THIRD,‏ FOURTH או LAST ‏(‎/mo). ערך של 1 - 31 הוא אופציונלי וחוקי רק כאשר אין ביטוי מגביל או שקיים ביטוי מגביל מהסוג ‎1 - 12 . ברירת המחדל היא 1 (היום הראשון בחודש).
‎/m month[,month...]‎
ציון חודש בשנה. הערכים החוקיים הם JAN - DEC ו- * (כל חודש). הפרמטר ‎/m חוקי עם לוח זמנים מסוג MONTHLY בלבד. פרמטר זה נדרש כאשר נעשה שימוש בביטוי המגביל LASTDAY. במקרה אחר, הפרמטר הוא אופציונלי והערך המשמש כברירת מחדל הוא * (כל חודש).
‎/i IdleTime
ציון מספר הדקות שבהן לא יהיה המחשב פעיל לפני הפעלת המשימה. הקלד מספר שלם בטווח שבין 1 ל- 999. פרמטר זה חוקי עם לוח זמנים מסוג ONIDLE בלבד ובמצב זה הוא נדרש.
‎/st StartTime
ציון השעה ביום שבה מופעלת המשימה, לפי שעון של 24 שעות בתבנית HH:MM:SS . הערך המשמש כברירת המחדל הוא השעה המקומית הנוכחית כאשר מושלמת הפקודה. הפרמטר ‎/st חוקי עם לוחות הזמנים מהסוגים MINUTE,‏ HOURLY,‏ DAILY,‏ WEEKLY,‏ MONTHLY ו- ONCE. הפרמטר נדרש עם לוח הזמנים ONCE.
‎/sd StartDate
ציון התאריך שבו מופעלת המשימה, בתבנית של MM/DD/YYYY . הערך המשמש כברירת המחדל הוא התאריך הנוכחי. הפרמטר ‎/sd חוקי עם כל לוחות הזמנים והוא נדרש עבור לוח זמנים מסוג ONCE.
‎/ed EndDate
ציון התאריך האחרון שהמשימה מתוזמנת לפעולה בו. פרמטר זה הוא אופציונלי. הוא אינו חוקי בלוח הזמנים מהסוגים ONCE,‏ ONSTART,‏ ONLOGON או ONIDLE. כברירת מחדל, ללוחות זמנים אין תאריך סיום.
‎/s Computer
ציון השם או כתובת ה- IP של מחשב מרוחק (עם או בלי קווים נטויים הפוכים). המחשב המקומי משמש כברירת מחדל.
‎/u [domain\]user‎
הרצת הפקודה עם ההרשאות של חשבון המשתמש שצוין. כברירת מחדל, הפקודה מורצת עם הרשאות המשתמש המחובר למחשב שבו פועל SchTasks.
‎/p password
ציון הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u. פרמטר זה נדרש כאשר נעשה שימוש בפרמטר ‎/u.
‎/ru {[Domain\]User | "System"}‎
הפעלת המשימות באמצעות ההרשאה של חשבון המשתמש שצוין. כברירת מחדל, המשימה מופעלת באמצעות ההרשאות של המשתמש שביצע כניסה למחשב שבו פועל SchTasks.
ערך | תיאור
‎[Domain\]User | ציון של חשבון משתמש.
‎"System"‎ או ""‎ | ציון חשבון NT Authority\System שמערכת ההפעלה משתמשת בו.
‎/rp Password
ציון הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/ru . אם תסיר פרמטר זה בעת ציון של חשבון משתמש, הקובץ SchTasks.exe יציג בפניך בקשה להזנת הסיסמה ויסתיר את הטקסט המוקלד. לא נדרשת סיסמה למשימות המופעלות באמצעות הרשאות של חשבון NT Authority\System והיישום SchTasks.exe לא יציג בקשה להזנת סיסמה.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

    XOX
  • הקובץ SchTasks.exe אינו מוודא מיקומים של קובץ תוכנית או סיסמאות של חשבון משתמש. אם לא תזין את מיקום הקובץ הנכון או את הסיסמה הנכונה עבור חשבון המשתמש, המשימה תיווצר אך לא תפעל. בנוסף, אם הסיסמה עבור חשבון משתנה או שפג תוקפה ואינך משנה את הסיסמה שנשמרה במשימה, המשימה לא תפעל.
  • בחשבון NT Authority\System לא קיימות זכויות כניסה אינטראקטיביות. למשתמשים אין אפשרות להציג תוכניות המופעלות באמצעות הרשאות מערכת, או לקיים יחסי גומלין איתן.
  • כל משימה מפעילה תוכנית אחת בלבד. עם זאת, באפשרותך ליצור קובץ אצווה המפעיל משימות מרובות ולאחר מכן לתזמן משימה המפעילה את קובץ האצווה.
  • באפשרותך לבדוק משימה מיד לאחר יצירתה. השתמש בפעולה run כדי לבחון את פעולת המשימה ולאחר מכן בדוק אם קיימות שגיאות בקובץ SchedLgU.txt ‏(Systemroot\SchedLgU.txt).

תחביר ודוגמאות עבור כל סוג של לוח זמנים

לשם הצגת תחביר הפקודה, לחץ על פקודה:

schtasks create minute

תחביר

schtasks ‎/create ‎/tn TaskName ‎/tr TaskRun ‎/sc minute ‎[/mo {1 - 1439}]‎ ‎[/st StartTime]‎ ‎[/sd StartDate]‎ ‎[/ed EndDate]‎ ‎[/s computer [/u [domain\]user /p password]]‎ ‎[/ru {[Domain\]User | "System"} [/rp Password]]‎

דוגמה

לשם תזמון משימה לפעולה כל 20 דקות

הפקודה הבאה מתזמנת קובץ Script של אבטחה בשם Sec.vbs להפעלה כל 20 דקות. מכיוון שהפקודה אינה כוללת תאריך או שעה התחלתיים, המשימה מופעלת 20 דקות לאחר השלמת הפקודה ומופעלת שוב במחזורים של 20 דקות לאחר מכן כל עוד המערכת פועלת. שים לב לכך שקובץ המקור של Script האבטחה ממוקם במחשב מרוחק אך המשימה מתוזמנת ומתבצעת במחשב המקומי.

schtasks /create /sc minute /mo 20 /tn "Security Script" /tr \\central\data\scripts\sec.vbs

בתגובה, SchTasks.exe מציג הודעה המסבירה כי המשימה תופעל באמצעות ההרשאות של המשתמש הנוכחי, ומציג בקשה עבור הסיסמה של המשתמש הנוכחי. בעת הזנת הסיסמה, היישום SchTasks.exe מסתיר את הטקסט המוקלד.

The task will be created under current logged-in user name.
Please enter the password
************‎

לאחר מכן, SchTasks.exe יציג הודעה המציינת שהמשימה מתוזמנת:

SUCCESS: The Scheduled Task "Security Script" has successfully been created.‎

שאילתה מציגה את המשימה שתוזמנה על-ידי הפקודה:

TaskName                  Next Run Time            Status
========================= ======================== ==============
Security Script           10:50:00 AM , 4/4/2001

schtasks create hourly

תחביר

schtasks ‎/create ‎/tn TaskName ‎/tr TaskRun ‎/sc hourly ‎[/mo {1 - 365}]‎ ‎[/st StartTime]‎ ‎[/sd StartDate]‎ ‎[/ed EndDate]‎ ‎[/s computer [/u [domain\]user /p password]]‎ ‎[/ru {[Domain\]User | "System"} [/rp Password]]‎

דוגמה

לשם תזמון פקודה המופעלת כל שעה, חמש דקות לאחר תחילת השעה

הפקודה הבאה מתזמנת את התוכנית MyApp לפעול כל שעה, החל בחמש דקות לאחר חצות. מכיוון שהפרמטר ‎/mo מושמט, הפקודה עושה שימוש בערך המשמש כברירת המחדל עבור לוח הזמנים של הפעלה כל שעה, שהוא כל (1) שעה. אם פקודה זו מונפקת לאחר ‎12:05 A.M.‎, התוכנית לא תופעל עד ליום המחרת.

schtasks /create /sc hourly /st 00:05:00 /tn "My App" /tr c:\apps\myapp.exe

לשם תזמון פקודה המופעלת כל חמש שעות

הפקודה הבאה מתזמנת את התוכנית MyApp לפעול כל חמש שעות החל מהיום הראשון של מרץ 2001. נעשה שימוש בפרמטר ‎/mo כדי לציין את המרווח ובפרמטר ‎/sd כדי לציין את תאריך ההפעלה. מכיוון שהפקודה אינה מציינת שעת הפעלה, נעשה שימוש בשעה הנוכחית כשעת ההפעלה.

schtasks /create /sc hourly /mo 5 /sd 03/01/2001 /tn "My App" /tr c:\apps\myapp.exe

schtasks create daily

תחביר

schtasks ‎/create ‎/tn TaskName ‎/tr TaskRun ‎/sc daily ‎[/mo {1 - 365}]‎ ‎[/st StartTime]‎ ‎[/sd StartDate]‎ ‎[/ed EndDate]‎ ‎[/s computer [/u [domain\]user /p password]]‎ ‎[/ru {[Domain\]User | "System"} [/rp Password]]‎

דוגמה

לשם תזמון משימה המופעלת בכל יום

בדוגמה הבאה מתוזמנת התוכנית MyApp לפעול פעם ביום, כל יום, בשעה 8:00 לפני הצהריים, וכך עד ה- 31 בדצמבר, 2001. מכיוון שהפרמטר ‎/mo מושמט, נעשה שימוש במרווח של 1 כברירת מחדל להפעלת הפקודה כל יום.

schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc daily /st 08:00:00 /ed 12/31/2001

לשם תזמון משימה המופעלת אחת ליומיים

בדוגמה הבאה מתוזמנת התוכנית MyApp לפעול אחת ליומיים בשעה 1:00 בצהריים (13:00) החל ב- 31 בדצמבר, 2001. הפקודה עושה שימוש בפרמטר ‎/mo כדי לציין מרווח של יומיים (2).

schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc daily /mo 2 /st 13:00:00 /sd 12/31/2001

schtasks create weekly

תחביר

schtasks ‎/create ‎/tn TaskName ‎/tr TaskRun ‎/sc weekly ‎[/d {MON - SUN | *}]‎ ‎[/mo {1 - 52}]‎ ‎[/st StartTime]‎ ‎[/sd StartDate]‎ ‎[/ed EndDate]‎ ‎[/s computer [/u [domain\]user /p password]]‎ ‎[/ru {[Domain\]User | "System"} [/rp Password]]‎

דוגמה

לשם תזמון משימה המופעלת כל שישה שבועות

בפקודה הבאה מתוזמנת הפקודה MyApp לפעול במחשב מרוחק כל שישה שבועות. הפקודה עושה שימוש בפרמטר ‎/mo כדי לציין את המרווח. כמו כן נעשה שימוש בפרמטר ‎/s כדי לציין את המחשב המרוחק ובפרמטר ‎/ru כדי לתזמן את המשימה שיש להפעיל באמצעות ההרשאות של חשבון Administrator של המשתמש. מכיוון שהפרמטר ‎/rp מושמט, SchTasks.exe מציג בפני המשתמש בקשה להזנת הסיסמה עבור חשבון Administrator.

בנוסף, מכיוון שהפקודה מופעלת מרחוק, כל הנתיבים בפקודה, כולל הנתיב לקובץ MyApp.exe, מתייחסים לנתיבים במחשב המרוחק.

schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc weekly /mo 6 /s Server16 /ru Admin01

לשם תזמון משימה המופעלת ביום שישי, פעם בשבועיים

בפקודה הבאה מתוזמנת משימה שיש להפעיל ביום שישי, פעם בשבועיים. נעשה שימוש בפרמטר ‎/mo כדי לציין מרווח של שבועיים ובפרמטר ‎/d כדי לציין את היום בשבוע. כדי לתזמן משימה המופעלת בכל יום שישי, השמט את הפרמטר ‎/mo או קבע אותו ל- 1.

schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc weekly /mo 2 /d FRI

schtasks create monthly

תחביר

תחביר עבור לוח זמנים חודשי כללי
schtasks ‎/create ‎/tn TaskName ‎/tr TaskRun ‎/sc monthly ‎[/mo {FIRST | SECOND | THIRD | FOURTH | LAST | LASTDAY]‎ ‎[/d {MON - SUN | 1 - 31}‎] ‎[/m {JAN - DEC[,JAN - DEC...] | *}]‎ ‎[/st StartTime]‎ ‎[/sd StartDate]‎ ‎[/ed EndDate]‎ ‎[/s computer [/u [domain\]user /p password]]‎ ‎[/ru {[Domain\]User | "System"} [/rp Password]]‎
תחביר של שבוע מסוים
schtasks ‎/create ‎/tn TaskName ‎/tr TaskRun ‎/sc monthly ‎/mo {FIRST | SECOND | THIRD | FOURTH | LAST}‎ ‎/d {MON - SUN}‎ ‎[/m {JAN - DEC[,JAN - DEC...] | *}]‎ ‎[/st StartTime]‎ ‎[/sd StartDate]‎ ‎[/ed EndDate]‎ ‎[/s computer [/u [domain\]user /p password]]‎ ‎[/ru {[Domain\]User | "System"} [/rp Password]]‎
תחביר יום אחרון (LastDay)
schtasks ‎/create ‎/tn TaskName ‎/tr TaskRun ‎/sc monthly ‎/mo LASTDAY ‎/m {JAN - DEC[,JAN - DEC...] | *}‎ ‎[/st StartTime]‎ ‎[/sd StartDate]‎ ‎[/ed EndDate]‎ ‎[/s computer [/u [domain\]user /p password]]‎ ‎[/ru {[Domain\]User | "System"} [/rp Password]]‎
תחביר של תאריך מדויק
schtasks ‎/create ‎/tn TaskName ‎/tr TaskRun ‎/sc monthly ‎/d {1 - 31}‎ ‎[/m {JAN - DEC[,JAN - DEC...] | *}]‎ ‎[/st StartTime]‎ ‎[/sd StartDate]‎ ‎[/ed EndDate]‎ ‎[/s computer [/u [domain\]user /p password]]‎ ‎[/ru {[Domain\]User | "System"} [/rp Password]]‎

דוגמאות

לשם תזמון משימה עבור היום הראשון של כל חודש

בפקודה הבאה מתוזמנת התוכנית MyApp לפעול ביום הראשון של כל חודש. מכיוון שהביטוי המגביל המשמש כברירת המחדל הוא ריק (אין ביטוי מגביל), היום המשמש כברירת מחדל הוא יום 1 והחודש המשמש כברירת המחדל הוא כל חודש, לא דרושים פרמטרים נוספים לפקודה.

schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc monthly

לשם תזמון משימה עבור היום האחרון של כל חודש

בפקודה הבאה מתוזמנת התוכנית MyApp לפעול ביום האחרון של כל חודש. נעשה שימוש בפרמטר ‎/mo כדי לציין את היום האחרון של החודש ובפרמטר ‎/m עם התו הכללי כוכבית (*) כדי לציין שהתוכנית תופעל ביום האחרון של כל חודש.

schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc monthly /mo lastday /m *‎

לשם תזמון משימה המופעלת כל שלושה חודשים

בפקודה הבאה מתוזמנת התוכנית MyApp לפעול כל שלושה חודשים. נעשה שימוש בפרמטר ‎/mo כדי לציין את המרווח.

schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc monthly /mo 3

לשם תזמון משימה עבור יום ראשון השני בכל חודש

בפקודה הבאה מתוזמנת התוכנית MyApp לפעול ביום ראשון השני בכל חודש. נעשה שימוש בפרמטר ‎/mo כדי לציין את השבוע השני של החודש ובפרמטר ‎/d כדי לציין את היום.

schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc monthly /mo SECOND /d SUN

לשם תזמון משימה ליום ה- 15 של מאי ושל יוני

בפקודה הבאה מתוזמנת התוכנית MyApp לפעול ב- 15 במאי וב- 15 ביוני בשעה 3:00 אחר הצהריים (15:00). נעשה שימוש בפרמטר ‎/d כדי לציין את התאריך ובפרמטר ‎/m כדי לציין את החודשים. כמו כן נעשה שימוש בפרמטר ‎/st כדי לציין את שעת ההתחלה.

schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc monthly /d 15 /m MAY,JUN /st 15:00:00

schtasks create once

תחביר

schtasks ‎/create ‎/tn TaskName ‎/tr TaskRun ‎/sc once ‎/st StartTime ‎/sd StartDate ‎[/s computer [/u [domain\]user /p password]]‎ ‎[/ru {[Domain\]User | "System"} [/rp Password]]‎

דוגמה

לשם תזמון משימה המופעלת פעם אחת

בפקודה הבאה מתוזמנת התוכנית MyApp לפעול בחצות של ה- 1 בינואר, 2002. נעשה שימוש בפרמטר ‎/ru כדי להפעיל את המשימה באמצעות ההרשאות של חשבון Administrator של המשתמש ובפרמטר ‎/rp כדי לספק את הסיסמה עבור חשבון זה.

schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc once /st 00:00:00 /sd 01/01/2002 /ru Admin23 /rp p@ssworD1

schtasks create onstart

תחביר

schtasks ‎/create ‎/tn TaskName ‎/tr TaskRun ‎/sc onstart ‎[/sd StartDate]‎ ‎[/s computer [/u [domain\]user /p password]]‎ ‎[/ru {[Domain\]User | "System"} [/rp Password]]‎

דוגמה

לשם תזמון משימה המופעלת עם כל הפעלה של המחשב

בפקודה הבאה מתוזמנת התוכנית MyApp לפעול עם כל הפעלה של המחשב, החל ב- 15 במרץ, 2001:

schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc onstart /sd 03/15/2001

schtasks create onlogon

תחביר

schtasks ‎/create ‎/tn TaskName ‎/tr TaskRun ‎/sc onlogon ‎[/sd StartDate]‎ ‎[/s computer [/u [domain\]user /p password]]‎ ‎[/ru {[Domain\]User | "System"} [/rp Password]]‎

דוגמה

לשם תזמון משימה המופעלת כאשר משתמש מבצע כניסה למחשב מרוחק

בפקודה הבאה מתוזמן קובץ אצווה לפעול בכל פעם שמשתמש (כל משתמש) מבצע כניסה למחשב המרוחק. נעשה שימוש בפרמטר ‎/s כדי לציין את המחשב המרוחק. מכיוון שהפקודה מרוחקת, כל הנתיבים בפקודה, כולל הנתיב לקובץ האצווה, מתייחסים לנתיב במחשב המרוחק.

schtasks /create /tn "Start Web Site" /tr c:\myiis\webstart.bat /sc onlogon /s Server23

schtasks create onidle

תחביר

schtasks ‎/create ‎/tn TaskName ‎/tr TaskRun ‎/sc onidle ‎/i IdleTime ‎[/sd StartDate]‎ ‎[/s computer [/u [domain\]user /p password]]‎ ‎[/ru {[Domain\]User | "System"} [/rp Password]]‎

דוגמה

לשם תזמון משימה המופעלת כאשר המחשב בלתי פעיל

בפקודה הבאה מתוזמנת התוכנית MyApp לפעול כאשר המחשב בלתי פעיל. הפרמטר ‎/i דרוש כדי לציין שעל המחשב להישאר במצב לא פעיל למשך עשר דקות לפי הפעלת המשימה.

schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc onidle /i 10

דוגמאות נוספות

לשם הצגת הדוגמה, לחץ על שם הדוגמה:

לשם יצירת משימה המופעלת עם הרשאות מערכת

בפקודה הבאה מתוזמנת התוכנית MyApp לפעול עם הרשאות של חשבון NT Authority\System. בדוגמה זו, המשימה מתוזמנת לפעול ביום הראשון של כל חודש, אך באפשרותך להשתמש בכל סוג של לוח זמנים עבור משימה המופעלת עם הרשאות מערכת.

הפקודה עושה שימוש בפרמטר ‎/ru "System"‎ כדי לציין את הקשר האבטחה של המערכת. מכיוון שמשימות מערכת אינן עושות שימוש בסיסמה, מושמט הפרמטר ‎/rp.

schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc monthly /d 1 /ru "System"‎

בתגובה, SchTasks.exe מציג הודעת מידע והודעת הצלחה. לא מוצגת בקשה לסיסמה.

INFO: The task will be created under user name ("NT AUTHORITY\SYSTEM").‎
SUCCESS: The Scheduled task "My App" has successfully been created.‎

לשם יצירת משימה המפעילה יותר מתוכנית אחת

כל משימה מפעילה תוכנית אחת בלבד. עם זאת, באפשרותך ליצור קובץ אצווה המפעיל תוכניות מרובות ולאחר מכן לתזמן משימה לשם הפעלת קובץ האצווה. התהליך הבא מדגים את השיטה הזו:

  1. יצירת קובץ אצווה המפעיל את התוכניות שברצונך להפעיל.

    בדוגמה זו נוצר קובץ אצווה המפעיל את מציג האירועים (Eventvwr.exe) ואת צג המערכת (Perfmon.exe).

    • פתח עורך טקסט, כגון פנקס רשימות.
    • הקלד את השם ואת הנתיב המלא לקובץ ההפעלה עבור כל תוכנית. במקרה זה, הקובץ מכיל את המשפטים הבאים.

      C:\Windows\System32\Eventvwr.exe
      C:\Windows\System32\Perfmon.exe

    • שמור את הקובץ כ- MyApps.bat.
  2. השתמש ב- SchTasks.exe כדי ליצור משימה המפעילה את MyApps.bat.

    הפקודה הבאה יוצרת את המשימה Monitor, המופעלת כאשר משתמש כלשהו מבצע כניסה למחשב. נעשה שימוש בפרמטר ‎/tn כדי לקרוא למשימה בשם ובפרמטר ‎/tr כדי להפעיל את MyApps.bat. נעשה שימוש בפרמטר ‎/sc כדי לציין את סוג לוח הזמנים OnLogon ובפרמטר ‎/ru כדי לציין את חשבון Administrator.

    schtasks /create /tn Monitor /tr C:\MyApps.bat /sc onlogon /ru Reskit\Administrator

    כתוצאה מפקודה זו, כאשר משתמש נכנס למחשב, המשימה מפעילה את מציג האירועים ואת צג המערכת.

schtasks change

שינוי אחד או יותר מהמאפיינים הבאים של משימה.

  • התוכנית המופעלת על-ידי המשימה (‎/tr).
  • חשבון המשתמש שתחתיו מופעלת המשימה (‎/ru).
  • הסיסמה עבור חשבון המשתמש (‎/rp).

תחביר

schtasks ‎/change ‎/tn TaskName ‎[/s computer [/u [domain\]user /p password]]‎ ‎[/tr TaskRun]‎ ‎[/ru [Domain\]User | "System"]‎ ‎[/rp Password]‎

פרמטרים

‎/tn TaskName
זיהוי המשימה שיש לשנות. הזן את שם המשימה.
‎/s Computer
ציון השם או כתובת ה- IP של מחשב מרוחק (עם קווים נטויים הפוכים או בלעדיהם). המחשב המקומי משמש כברירת המחדל.
‎/u [domain\]user‎
הרצת הפקודה עם ההרשאות של חשבון המשתמש שצוין. כברירת מחדל, הפקודה מורצת עם ההרשאות של המשתמש המחובר למחשב שבו פועל SchTasks.
‎/p password‎
ציון הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u. פרמטר זה נדרש כאשר נעשה שימוש בפרמטר ‎/u.
‎/tr TaskRun
שינוי התוכנית המופעלת על-ידי המשימה. הזן את הנתיב המלא ואת שם הקובץ של קובץ הפעלה, קובץ Script או קובץ אצווה. אם תשמיט את הנתיב, SchTasks.exe יפעל בהנחה שהקובץ נמצא בספריה Systemroot\System32. התוכנית שצוינה מחליפה את התוכנית המקורית שהופעלה על-ידי המשימה.
‎/ru [Domain\]User | "System"‎
שינוי חשבון המשתמש עבור המשימה.
ערך | תיאור
‎[Domain\]User | ציון של חשבון משתמש.
"System" או "" | ציון של חשבון NT Authority\System המשמש את מערכת ההפעלה.

בעת שינוי חשבון המשתמש, עליך לשנות גם את סיסמת המשתמש. אם בפקודה קיים הפרמטר ‎/ru אך לא הפרמטר ‎/rp, ‏SchTasks.exe יציג בקשה לסיסמה חדשה ויסתיר את הטקסט המוקלד.

למשימות המופעלות באמצעות הרשאות של החשבון NT Authority\System לא נדרשת סיסמה, והיישום SchTasks.exe אינו מציג בקשה לסיסמה.

‎/rp Password
שינוי סיסמת החשבון עבור המשימה. הזן את הסיסמה החדשה.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

    XOX
  • הפרמטרים ‎/tn ו- ‎/s מזהים את המשימה. הפרמטרים ‎/tr,‏ ‎/ru ו- ‎/rp מציינים מאפיינים של המשימה שאותם באפשרותך לשנות.
  • על פקודה העושה שימוש בפעולה change לשנות לפחות מאפיין משימה אחד.
  • בחשבון NT Authority\System לא קיימות זכויות כניסה אינטראקטיביות. משתמשים אינם רואים תוכניות המופעלות באמצעות הרשאות מערכת, ואין באפשרותם לקיים קשרי גומלין עם תוכניות אלה.

דוגמאות

לשם שינוי התוכנית המופעלת על-ידי משימה

הפקודה הבאה משנה את התוכנית המופעלת על-ידי המשימה Virus Check מ- VirusCheck.exe ל- VirusCheck2.exe. פקודה זו עושה שימוש בפרמטר ‎/tn כדי לזהות את המשימה ובפרמטר ‎/tr כדי לציין את התוכנית החדשה עבור המשימה. (אין באפשרותך לשנות את שם המשימה.)

schtasks /change /tn "Virus Check" /tr C:\VirusCheck2.exe

בתגובה, SchTasks.exe מציג את הודעת ההצלחה הבאה:

SUCCESS: The parameter of the Scheduled Task "Virus Check" has been changed.‎

כתוצאה מפקודה זו, המשימה Virus Check מפעילה כעת את VirusCheck2.exe.

לשם שינוי הסיסמה עבור משימה מרוחקת

הפקודה הבאה משנה את הסיסמה של חשבון המשתמש עבור המשימה RemindMe במחשב המרוחק, Svr01. הפקודה עושה שימוש בפרמטר ‎/tn כדי לזהות את המשימה ובפרמטר ‎/s כדי לציין את המחשב המרוחק. נעשה שימוש בפרמטר ‎/rp כדי לציין את הסיסמה החדשה, p@ssWord3.

תהליך זה נדרש בכל פעם שמשתנה או פג תוקפה של הסיסמה עבור חשבון משתמש. אם הסיסמה שנשמרה במשימה כבר אינה חוקית, המשימה אינה מופעלת.

schtasks /change /tn RemindMe /s Svr01 /rp p@ssWord3

SchTasks.exe יציג את הודעת ההצלחה הבאה:

SUCCESS: The parameter of the Scheduled Task "RemindMe" has been changed.‎

כתוצאה מפקודה זו, המשימה RemindMe פועלת כעת תחת חשבון המשתמש המקורי שלה אך עם סיסמה חדשה.

לשם שינוי התוכנית וחשבון המשתמש עבור משימה

הפקודה הבאה משנה את התוכנית המופעלת על-ידי משימה ומשנה את חשבון המשתמש שתחתיו מופעלת המשימה. למעשה, המשימה שהמתקבלת לאחר ביצוע הפקודה עושה שימוש בלוח זמנים ישן עבור משימה חדשה. פקודה זו משנה את המשימה Notepad המפעילה את Notepad.exe כל בוקר בשעה 9:00 להפעלה של Internet Explorer במקום זאת.

הפקודה עושה שימוש בפרמטר ‎/tn כדי לזהות את המשימה. נעשה שימוש בפרמטר ‎/tr כדי לשנות את התוכנית המופעלת על-ידי המשימה ובפרמטר ‎/ru כדי לשנות את חשבון המשתמש שתחתיו מופעלת המשימה.

הפרמטר ‎/rp, המספק את הסיסמה עבור חשבון המשתמש, מושמט. עליך לספק סיסמה עבור החשבון אך באפשרותך להשתמש בפרמטר ‎/rp ולהקליד את הסיסמה בטקסט נקי, או להמתין עד שהיישום SchTasks.exe יציג בפניך בקשה לסיסמה ולאחר מכן להזין את הסיסמה. התווים שתקליד יוסתרו אוטומטית.

schtasks /change /tn Notepad /tr "c:\program files\Internet Explorer\iexplore.exe" /ru DomainX\Admin01

בתגובה, SchTasks.exe מציג בקשה לסיסמה עבור חשבון המשתמש. הטקסט המוקלד מוסתר כך שהסיסמה לא תהיה גלויה לעין.

Please enter the password for DomainX\Admin01: *********‎

שים לב שהפרמטר ‎/tn מזהה את המשימה והפרמטרים ‎/tr ו- ‎/ru משנים את מאפייני המשימה. אין באפשרותך להשתמש בפרמטר נוסף לשם זיהוי המשימה ואין באפשרותך לשנות את שם המשימה.

בתגובה, SchTasks.exe מציג את הודעת ההצלחה הבאה:

SUCCESS: The parameter of the Scheduled Task "Notepad" has been changed.‎

כתוצאה מפקודה זו, המשימה RemindMe פועלת כעת תחת חשבון המשתמש המקורי שלה אך עם סיסמה חדשה.

לשם שינוי תוכנית כך שתפעל עם חשבון המערכת

הפקודה הבאה משנה את המשימה SecurityScript כך שתפעל עם הרשאות של החשבון NT Authority\System. נעשה שימוש בפרמטר ‎/ru ""‎ כדי לציין את חשבון המערכת.

schtasks /change /tn SecurityScript /ru ""‎

בתגובה, SchTasks.exe יציג את הודעת ההצלחה הבאה:

SUCCESS: The parameter of the Scheduled Task "SecurityScript" has been changed.‎

מכיוון שלמשימות הפועלות עם הרשאות של חשבון מערכת לא נדרשת סיסמה, SchTasks.exe לא יציג בקשה לסיסמה.

schtasks run

הפעלה מיידית של משימה מתוזמנת. הפעולה run מתעלמת מלוח הזמנים, אך עושה שימוש במיקום קובץ התוכנית, בחשבון המשתמש ובסיסמה שנשמרו במשימה כדי להפעיל את המשימה באופן מיידי.

תחביר

schtasks ‎/run ‎/tn TaskName ‎[/s computer [/u [domain\]user /p password]]‎ ‎/?‎

פרמטרים

‎/tn TaskName
זיהוי המשימה. פרמטר זה הכרחי.
‎/s Computer
ציון השם או כתובת ה- IP של מחשב מרוחק (עם קווים נטויים הפוכים או בלעדיהם). המחשב המקומי משמש כברירת המחדל.
‎/u [domain\]user‎
הרצת הפקודה עם ההרשאות של חשבון המשתמש שצוין. כברירת מחדל, הפקודה מורצת עם ההרשאות של המשתמש המחובר למחשב שבו פועל SchTasks.
‎/p password‎
ציון הסיסמה של חשבון המשתמש המצוין בפרמטר ‎/u. פרמטר זה נדרש כאשר נעשה שימוש בפרמטר ‎/u.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

    XOX
  • השתמש בפעולה זו כדי לבחון את פעולת המשימות. אם משימה אינה פועלת, בדוק אם קיימות שגיאות ביומן הטרנזקציה של מתזמן המשימות, Systemroot\SchedLgU.txt.
  • הפעלת משימה אינה משפיעה על לוח הזמנים שהוגדר עבור המשימה ואינה משנה את זמן הפעולה הבא שהוגדר עבור המשימה.
  • כדי להפעיל משימה מרחוק, יש לתזמן את המשימה במחשב המרוחק. בעת הפעלתה, המשימה פועלת במחשב המרוחק בלבד. כדי לוודא שמשימה פועלת במחשב מרוחק, השתמש במנהל המשימות או ביומן הטרנזקציה של מתזמן המשימות, Systemroot\SchedLgU.txt.

דוגמאות

לשם הפעלת משימה במחשב המקומי

הפקודה הבאה מפעילה את המשימה "Security Script".

schtasks /run /tn "Security Script"‎

בתגובה, SchTasks.exe מפעיל את קובץ ה- Script המשוייך למשימה, ומציג את ההודעה הבאה:

SUCCESS: The Scheduled Task "Security Script" is running ......‎

לשם הפעלת משימה במחשב מרוחק

הפקודה הבאה מפעילה את המשימה Update במחשב המרוחק Svr01:

schtasks /run /tn Update /s Svr01

במקרה זה, SchTasks.exe מציג את הודעת השגיאה הבאה:

ERROR: Unable to run the Scheduled Task "Update".‎

כדי למצוא את מקור השגיאה, התבונן ביומן הטרנזקציה עבור משימות מתוזמנות, הממוקם בנתיב C:\Windows\SchedLgU.txt של המחשב המרוחק Svr01. במקרה זה, הערך הבא מופיע ביומן הרישום:

‎"Update.job" (update.exe) 3/26/2001 1:15:46 PM ** ERROR **‎
The attempt to log on to the account associated with the task failed, therefore, the task did not run.‎
    The specific error is:‎
    0x8007052e: Logon failure: unknown user name or bad password.‎
    Verify that the task's Run-as name and password are valid and try again.‎

ככל הנראה, השם או הסיסמה של המשתמש במשימה אינם חוקיים במערכת. הפקודה schtasks /change הבאה מעדכנת את השם והסיסמה של המשתמש עבור המשימה Update הנמצאת ב- Svr01:

schtasks /change /tn Update /s Svr01 /ru Administrator /rp PassW@rd3

לאחר השלמת הפקודה change, מתבצעת חזרה על הפקודה run. הפעם, התוכנית Update.exe פועלת, והיישום SchTasks.exe מציג את ההודעה הבאה:

SUCCESS: The Scheduled Task "Update" is running......‎

schtasks end

עצירת תוכנית שהופעלה על-ידי משימה.

תחביר

schtasks ‎/end ‎/tn TaskName ‎[/s computer [/u [domain\]user /p password]]‎ ‎/?‎

פרמטרים

‎/tn TaskName
זיהוי המשימה שהפעילה את התוכנית. פרמטר זה הכרחי.
‎/s Computer
ציון השם או כתובת ה- IP של מחשב מרוחק (עם קווים נטויים הפוכים ובלעדיהם). המחשב המקומי משמש כברירת המחדל.
‎/u [domain\]user‎
הרצת הפקודה עם ההרשאות של חשבון המשתמש שצוין. כברירת מחדל, הפקודה מורצת עם ההרשאות של המשתמש המחובר למחשב שבו פועל SchTasks.
‎/p password‎
ציון הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u. פרמטר זה נדרש כאשר נעשה שימוש בפרמטר ‎/u.
‎/?‎
הצגת עזרה.

הערות

    XOX
  • הקובץ SchTasks.exe מסיים רק את מופעי התוכנית שהופעלה על-ידי משימה מתוזמנת. כדי לעצור תהליכים אחרים, השתמש בכלי TaskKill הכלול ב- Windows XP Professional. לקבלת מידע נוסף אודות TaskKill, ראה TaskKill
    • .

דוגמאות

לשם סיום של משימה במחשב מקומי

הפקודה הבאה עוצרת את המופע של Notepad.exe שהופעל באמצעות המשימה My Notepad:

schtasks /end /tn "My Notepad"‎

בתגובה, SchTasks.exe עוצר את המופע של Notepad.exe שהופעל על-ידי המשימה ומציג את הודעת ההצלחה הבאה:

SUCCESS: The Scheduled Task "My Notepad" has been terminated successfully.‎

לשם סיום משימה במחשב מרוחק

הפקודה הבאה עוצרת את המופע של Internet Explorer שהופעל על-ידי המשימה InternetOn במחשב המרוחק Svr01:

schtasks /end /tn InternetOn /s Svr01

בתגובה, SchTasks.exe עוצר את המופע של Internet Explorer שהופעל באמצעות המשימה ומציג את הודעת ההצלחה הבאה:

SUCCESS: The Scheduled Task "InternetOn" has been terminated successfully.‎

schtasks delete

מחיקה של משימה מתוזמנת.

תחביר

schtasks ‎/delete ‎/tn {TaskName | *}‎ ‎[/f]‎ ‎[/s computer [/u [domain\]user /p password]]‎ ‎[/?]‎

פרמטרים

‎/tn {TaskName | *}‎
זיהוי המשימה שיש למחוק. פרמטר זה הכרחי.
ערך | תיאור
TaskName | מחיקת המשימה הנקובה.
* | מחיקת כל המשימות המתוזמנות במחשב.
‎/f
ביטול הודעת האישור. המשימה נמחקת ללא אזהרה.
‎/s Computer
ציון השם או כתובת ה- IP של מחשב מרוחק (עם קווים נטויים הפוכים או בלעדיהם). המחשב המקומי משמש כברירת המחדל.
‎/u [domain\]user‎
הרצת הפקודה עם ההרשאות של חשבון המשתמש שצוין. כברירת מחדל, הפקודה מורצת עם ההרשאות של המשתמש המחובר למחשב שבו פועל SchTasks.
‎/p password‎
ציון הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u. פרמטר זה נדרש כאשר נעשה שימוש בפרמטר ‎/u.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

    XOX
  • הפעולה delete מבצעת מחיקה של המשימה מלוח הזמנים. התוכנית המופעלת על-ידי המשימה אינה נמחקת ואין הפרעה לתוכניות פועלות.
  • הפקודה delete *‎ מבצעת מחיקה של כל המשימות שתוזמנו עבור המחשב, לא רק של המשימות שתוזמנו על-ידי המשתמש הנוכחי.

דוגמאות

לשם מחיקת משימה מלוח הזמנים של מחשב מרוחק

הפקודה הבאה מבצעת מחיקה של המשימה "Start Mail" מלוח הזמנים של מחשב מרוחק. נעשה שימוש בפרמטר ‎/s כדי לזהות את המחשב המרוחק.

schtasks /delete /tn "Start Mail" /s Svr16

בתגובה, SchTasks.exe מציג את הודעת האישור הבאה. לשם מחיקת המשימה, הקלד y. לשם ביטול הפקודה, הקלד n:

WARNING: Are you sure you want to remove the task "Start Mail" (Y/N )? y
SUCCESS: The Scheduled Task "Start Mail" was successfully deleted.‎

לשם מחיקת כל המשימות המתוזמנות עבור המחשב המקומי

הפקודה הבאה מבצעת מחיקה של כל המשימות מלוח הזמנים של המחשב המקומי, כולל משימות שתוזמנו על-ידי משתמשים אחרים. נעשה שימוש בפרמטר ‎/tn *‎ כדי לייצג את כל המשימות במחשב ובפרמטר ‎/f כדי למנוע הצגה של בקשת אישור.

schtasks /delete /tn * /f

בתגובה, SchTasks.exe מציג את הודעת ההצלחה הבאה, המציינת כי המשימה היחידה שתוזמנה (SecureScript) נמחקה.

SUCCESS: The Scheduled Task "SecureScript" was successfully deleted.‎

schtasks query

הצגת כל המשימות שתוזמנו לפעול במחשב, כולל אלה שתוזמנו על-ידי משתמשים אחרים.

תחביר

schtasks ‎[/query]‎ ‎[/fo {TABLE | LIST | CSV}]‎ ‎[/nh]‎ ‎[/v]‎ ‎[/s computer [/u [domain\]user /p password]]‎

פרמטרים

‎[/query]‎
שם הפעולה אופציונלי. הקלדת schtasks ללא כל פרמטרים גורמת לביצוע שאילתה.
‎/fo {TABLE | LIST | CSV}‎
ציון תבנית הפלט. TABLE (טבלה) היא התבנית המהווה ברירת המחדל.
‎/nh
השמטת כותרות עמודה מתצוגת הטבלה. פרמטר זה חוקי עם תבניות הפלט TABLE ו- CSV.
‎/v
הוספת מאפיינים מתקדמים של המשימות לתצוגה.

עבור שאילתות העושות שימוש בפרמטר ‎/v יש להשתמש בתבנית LIST או בתבנית CSV.

‎/s Computer
ציון השם או כתובת ה- IP של מחשב מרוחק (עם קווים נטויים הפוכים או בלעדיהם). המחשב המקומי משמש כברירת המחדל.
‎/u [domain\]user‎
הרצת הפקודה עם ההרשאות בחשבון המשתמש שצוין. כברירת מחדל, הפקודה מורצת עם ההרשאות של המשתמש המחובר למחשב שבו פועל SchTasks.
‎/p password‎
ציון הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u. פרמטר זה נדרש כאשר נעשה שימוש בפרמטר ‎/u.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

    XOX
  • הפעולה query מפרטת את כל המשימות המתוזמנות עבור המחשב, לא רק את המשימות שתוזמנו על-ידי המשתמש הנוכחי.

דוגמאות

לשם הצגת המשימות המתוזמנות במחשב המקומי

הפקודות הבאות מציגות את כל המשימות המתוזמנות עבור המחשב המקומי. פקודות אלה מפיקות את אותה התוצאה וניתן להחליפן זו בזו.

schtasks

schtasks /query

בתגובה, SchTasks.exe מציג את המשימות בתבנית הטבלה הפשוטה המשמשת כברירת המחדל, כפי שמוצג בטבלה הבאה:

TaskName                  Next Run Time            Status
========================= ======================== ==============
Microsoft Outlook         At logon time
SecureScript              14:42:00 PM , 2/4/2001

לשם הצגת מאפיינים מתקדמים של משימות מתוזמנות

הפקודה הבאה יוצרת בקשה לתצוגה מפורטת של המשימות במחשב המקומי. נעשה שימוש בפרמטר ‎/v כדי לבקש תצוגה מפורטת (Verbose) ובפרמטר ‎/fo LIST כדי לעצב את התצוגה כרשימה עבור קריאה נוחה. באפשרותך להשתמש בפקודה זו כדי לוודא כי משימה שיצרת אכן כוללת את תבנית החזרה שהיה ברצונך להגדיר עבורה.

schtasks /query /fo LIST /v

בתגובה, SchTasks.exe מציג רשימת מאפיינים מפורטת עבור כל המשימות. התצוגה הבאה מציגה את רשימת המשימות עבור משימה המתוזמנת לפעול ב- ‎4:00 A.M‎ ביום שישי האחרון של כל חודש:

HostName:                                  RESKIT01
TaskName:                                  SecureScript
Next Run Time:                             4:00:00 AM , 3/30/2001
Status:                                    Not yet run
Last Run Time:                             Never
Last Result:                               0
Creator:                                   user01
Schedule:                                  At 4:00 AM on the last Fri of every month, starting 3/24/2001
Task To Run:                               C:\WINDOWS\system32\notepad.exe
Start In:                                  notepad.exe
Comment:                                   N/A
Scheduled Task State:                      Enabled
Scheduled Type:                            Monthly
Modifier:                                  Last FRIDAY
Start Time:                                4:00:00 AM
Start Date:                                3/24/2001
End Date:                                  N/A
Days:                                      FRIDAY
Months:                                    JAN,FEB,MAR,APR,MAY,JUN,JUL,AUG,SEP,OCT,NOV,DEC
Run As User:                               RESKIT\user01
Delete Task If Not Rescheduled:            Enabled
Stop Task If Runs X Hours and X Mins:      72:0
Repeat: Until Time:                        Disabled
Repeat: Duration:                          Disabled
Repeat: Stop If Still Running:             Disabled
Idle: Start Time(For IDLE Scheduled Type): Disabled
Idle: Only Start If Idle for X Minutes:    Disabled
Idle: If Not Idle Retry For X Minutes:     Disabled
Idle: Stop Task If Idle State End:         Disabled
Power Mgmt: No Start On Batteries:         Disabled
Power Mgmt: Stop On Battery Mode:          Disabled

לשם רישום משימות שתוזמנו עבור מחשב מרוחק

הפקודה הבאה יוצרת בקשה לרשימה של משימות שתוזמנו עבור מחשב מרוחק, ומוסיפה את המשימות לקובץ יומן רישום המופרד באמצעות פסיקים ומאוחסן במחשב המקומי. באפשרותך להשתמש בתבנית פקודה זו כדי לאסוף ולעקוב אחר משימות שתוזמנו עבור מחשבים רבים.

הפקודה עושה שימוש בפרמטר ‎/s כדי לזהות את המחשב המרוחק, Reskit16, בפרמטר ‎/fo כדי לציין את התבנית ובפרמטר ‎/nh כדי להעלים את כותרות העמודה. סמל הצירוף ‎>>‎ מנתב מחדש את הפלט ליומן הרישום של המשימה, p0102.csv, במחשב המקומי, Svr01. מכיוון שהפקודה פועלת במחשב המרוחק, יש לציין נתיב מלא עבור המחשב המקומי.

schtasks /query /s Reskit16 /fo csv /nh >> \\svr01\data\tasklogs\p0102.csv

בתגובה, SchTasks.exe מוסיף את המשימות שתוזמנו עבור המחשב Reskit16 לקובץ p0102.csv במחשב המקומי, Svr01.

הערות

  • SchTasks.exe מבצע פעולות דומות לאלה שמבצע היישום משימות מתוזמנות שבלוח הבקרה. באפשרותך להשתמש באחד מהכלים האלה כדי ליצור, למחוק ולהציג משימות מתוזמנות, או לקבוע את תצורתן.
  • הקלדת schtasks ללא כל פרמטרים גורמת לביצוע שאילתה.
  • על המשתמש להיות חבר בקבוצת Administrators במחשב שעליו משפיעה הפקודה.
  • כדי לוודא שמשימה מתוזמנת הופעלה או כדי לגלות מדוע לא הופעלה משימה מתוזמנת, ראה את יומן הטרנזקציה של שירות מתזמן המשימות. יומן הטרנזקציה נקרא Systemroot\SchedLgU.txt. יומן רישום זה רושם נסיונות להפעלות היזומות על-ידי כל הכלים העושים שימוש בשירות, כולל היישום משימות מתוזמנות והיישום SchTasks.exe.
  • במקרים נדירים, קבצי משימה הופכים לפגומים. משימות פגומות אינן פועלות. בעת ניסיון לבצע פעולה במשימות פגומות, SchTasks.exe יציג את הודעת השגיאה הבאה:
    ERROR: The data is invalid.‎

    אין באפשרותך לשחזר משימות פגומות. כדי לשחזר את תכונות תזמון המשימה של המערכת, השתמש בקובץ SchTasks.exe או במשימות מתוזמנות כדי למחוק את המשימות מהמערכת ולתזמן אותן מחדש.

  • SchTasks.exe מחליף את At.exe, כלי שנכלל בגירסאות קודמות של Windows.


Secedit

קביעת תצורה וניתוח של אבטחת מערכת על-ידי השוואת התצורה הנוכחית לתבנית אחת לפחות.

לשם הצגת תחביר הפקודה, לחץ על פקודה:

secedit /analyze

תחביר

secedit ‎/analyze ‎/db FileName ‎[/cfg FileName]‎ ‎[/log FileName]‎ ‎[/quiet]‎

פרמטרים

‎/db FileName
נדרש. ציון הנתיב ושם הקובץ של מסד נתונים המכיל את התצורה המאוחסנת שמולה יבוצע הניתוח. אם FileName מציין מסד נתונים חדש, יש לציין גם את אפשרות שורת הפקודה ‎/cfg FileName .
‎/cfg FileName
ציון הנתיב ושם הקובץ עבור תבנית האבטחה שתיובא לתוך מסד הנתונים עבור ניתוח. אפשרות שורת הפקודה הזו חוקית רק כאשר משתמשים בה עם הפרמטר ‎/db. אם לא צוין פרמטר, הניתוח מבוצע מול תצורה כלשהי שכבר מאוחסנת במסד הנתונים.
‎/log FileName
ציון הנתיב ושם הקובץ של קובץ יומן רישום עבור התהליך. אם לא סופקו פרטים אלה, נעשה שימוש בקובץ יומן הרישום המשמש כברירת המחדל.
‎/quiet
הסתרה של פלט מסך ושל פלט יומן רישום. באפשרותך עדיין להציג תוצאות ניתוח באמצעות היישום ניתוח וקביעת תצורה של אבטחה.

secedit /configure

קביעת תצורה של אבטחת מערכת על-ידי החלת תבנית מאוחסנת.

תחביר

secedit ‎/configure ‎/db FileName ‎[/cfg FileName ]‎ ‎[/overwrite]‎[‎/areas area1 area2...]‎ ‎[/log FileName]‎ ‎[/quiet]‎

פרמטרים

‎/db FileName
נדרש. שם הקובץ של מסד נתונים המכיל את תבנית האבטחה שיש להחיל.
‎/cfg FileName
נתיב לתבנית האבטחה שתיובא לתוך מסד הנתונים ותוחל על המערכת. אפשרות שורת הפקודה הזו חוקית רק כאשר נעשה בה שימוש עם הפרמטר ‎/db. אם פרמטר זה לא צוין, תוחל התבנית שכבר מאוחסנת במסד הנתונים.
‎/overwrite
קביעה אם על תבנית האבטחה שצוינה בפרמטר ‎/cfg להחליף תבנית או תבנית מורכבת כלשהן שאוחסנו במסד הנתונים, במקום לצרף את התוצאות לתבנית המאוחסנת. אפשרות שורת הפקודה הזו חוקית רק כאשר נעשה שימוש גם בפרמטר ‎/cfg. אם פרמטר זה לא צוין, תצורף התבנית שצוינה בפרמטר ‎/cfg לתבנית המאוחסנת.
‎/areas area1 area2...‎
ציון אזורי האבטחה שיש להחיל על המערכת. אם לא צוין אזור, כל האזורים מוחלים על המערכת. יש להפריד בין אזורים באמצעות רווח.
שם האזור | תיאור
SECURITYPOLICY | מדיניות מקומית ומדיניות קבוצת מחשבים עבור המערכת, כולל פריטי מדיניות חשבון, פריטי מדיניות ביקורת וכן הלאה
GROUP_MGMT | הגדרות קבוצה מוגבלות עבור קבוצות שצוינו בתבנית האבטחה
USER_RIGHTS | זכויות כניסה של משתמש והענקת הרשאות
REGKEYS | אבטחה במפתחות רישום מקומיים
FILESTORE | אבטחה באחסון קובץ מקומי
SERVICES | אבטחה עבור כל השירותים המוגדרים
‎/log FileName
ציון שם של קובץ יומן רישום עבור התהליך. אם לא צוין שם הקובץ, נעשה שימוש בנתיב המשמש כברירת המחדל.
‎/quiet
הסתרה של פלט מסך ושל פלט יומן רישום.

secedit /export

ייצוא תבנית מאוחסנת ממסד נתונים של אבטחה לקובץ תבנית אבטחה.

תחביר

secedit ‎/export ‎[/mergedpolicy]‎ ‎[/DB FileName]‎ ‎[/CFG FileName]‎ ‎[/areas area1 area2...]‎ ‎[/log FileName]‎ ‎[/quiet]‎

פרמטרים

‎/mergedpolicy
מיזוג וייצוא הגדרות של מדיניות קבוצת מחשבים ומדיניות מקומית.
‎/db FileName
ציון של קובץ מסד הנתונים המכיל את התבנית שיש לייצא. אם לא צוין שמו של קובץ מסד הנתונים, נעשה שימוש במסד הנתונים של מדיניות המערכת.
‎/db FileName
ציון שם הקובץ שיש לשמור בו את התבנית.
‎/areas area1 area2...‎
ציון אזורי האבטחה שיש לייצא לתבנית. אם לא צוין אזור, יתבצע ייצוא של כל האזורים. יש להפריד בין אזורים באמצעות רווח.
שם האזור | תיאור
SECURITYPOLICY | ציון מדיניות מקומית ומדיניות קבוצת מחשבים עבור המערכת, כולל פריטי מדיניות חשבון, פריטי מדיניות ביקורת וכן הלאה
GROUP_MGMT | ציון הגדרות קבוצה מוגבלות עבור קבוצות שצוינו בתבנית האבטחה
USER_RIGHTS | ציון זכויות כניסה והענקת הרשאות של משתמש
REGKEYS | ציון האבטחה במפתחות רישום מקומיים
FILESTORE | ציון האבטחה עבור אחסון של קובץ מקומי
SERVICES | ציון אבטחה עבור כל השירותים שהוגדרו
‎/log FileName
ציון שם של קובץ יומן רישום עבור התהליך. אם לא צוין שם הקובץ, נעשה שימוש בנתיב המשמש כברירת המחדל.
‎/quiet
הסתרה של פלט מסך ושל פלט יומן רישום.

secedit /validate

אימות חוקיות התחביר של תבנית האבטחה שברצונך לייבא לתוך מסד נתונים לשם ניתוח או לשם החלה על מערכת.

תחביר

secedit ‎/validate FileName

פרמטר

FileName
ציון שם הקובץ של תבנית האבטחה שיצרת באמצעות תבניות אבטחה.

הערות

  • secedit /refreshpolicy הוחלף ב- gpupdate. לקבלת מידע אודות אופן הרענון של הגדרות אבטחה, ראה gpupdate.


Set

הצגה, הגדרה או הסרה של משתני סביבה. כאשר נעשה שימוש בפקודה set ללא פרמטרים, מוצגות הגדרות הסביבה הנוכחיות.

תחביר

set [[/a [expression]] [/p [variable=]] string]‎

פרמטרים

‎/a
קביעת string לביטוי מספרי העובר הערכה.
‎/p
קביעת הערך של variable לשורה של קלט.
variable
ציון המשתנה שברצונך להגדיר או לשנות.
string
ציון המחרוזת שברצונך לשייך למשתנה שצוין.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • שימוש ב- set במסוף השחזור

    הפקודה set, עם פרמטרים שונים, זמינה ממסוף השחזור.

  • שימוש בתווים מיוחדים

    התווים <,‏ >,‏ |,‏ &,‏ ^ הם תווי מעטפת פקודה מיוחדים ויש להקדים להם תו Escape (^) או לתחום אותם במרכאות כאשר נעשה בהם שימוש ב- string (כלומר, "StringContaining&Symbol"). אם תשתמש במרכאות כדי לתחום מחרוזת המכילה אחד מהתווים המיוחדים, המרכאות נקבעות כחלק מהערך של משתנה הסביבה.

  • שימוש במשתני סביבה

    השתמש במשתני סביבה כדי לפקח על אופן הפעולה של תוכניות וקבצי אצווה מסוימים וכדי לפקח על האופן שבו Windows XP ומערכת המשנה של MS-DOS מוצגים ופועלים. הפקודה set משמשת לעתים קרובות בקובץ Autoexec.nt כדי לקבוע משתני סביבה.

  • הצגת הגדרות הסביבה הנוכחיות

    בעת הקלדת הפקודה set ללא פרמטרים, מוצגות הגדרות הסביבה הנוכחיות. הגדרות אלה כוללות לרוב את משתני הסביבה COMSPEC ו- PATH, המשמשים לסיוע בחיפוש תוכניות בדיסק. שני משתני סביבה נוספים שבהם משתמש Windows XP הם PROMPT ו- DIRCMD.

  • שימוש בפרמטרים

    בעת ציון ערכים עבור משתנה ומחרוזת, ערך המשתנה שצוין מוסף לסביבה והמחרוזת משויכת למשתנה זה. אם המשתנה כבר קיים בסביבה, ערך המחרוזת החדש מחליף את ערך המחרוזת הישן.

    אם תציין עבור הפקודה set רק משתנה וסימן שוויון (ללא מחרוזת), ערך המחרוזת המשויך למשתנה ינוקה (כאילו המשתנה אינו קיים כלל).

  • שימוש ב- ‎/a

    הטבלה הבאה מפרטת את האופרטורים הזוכים לתמיכה עבור ‎/a, בסדר קדימות יורד.

    אופרטור הפעולה המבוצעת
    < > קיבוץ (Grouping)
    ‎* / % + -‎ פעולות אריתמטיות
    << >> העתקה לוגית
    & Bitwise AND
    ^ Bitwise exclusive OR
    | Bitwise OR
    ‎= *= /= %= += -= &= ^= |= <<= >>=‎ הקצאה
    , מפריד ביטויים

    אם תשתמש באופרטורים לוגיים (‎&& ||‎) או מסוג מודול (%), תחום את מחרוזת הביטוי במרכאות. מחרוזות בביטוי שאינן מספריות נחשבות לשמות משתנה סביבה שערכיהם מומרים למספרים לפני ביצוע העיבוד. אם תציין שם משתנה סביבה שאינו מוגדר בסביבה הנוכחית, מוקצה ערך של אפס, מה שמאפשר לך לבצע פעולות אריתמטיות עם ערכי משתנה סביבה מבלי להשתמש ב- % כדי לאחזר ערך.

    אם תפעיל את הפקודה set /a משורת הפקודה מחוץ לקובץ Script של פקודה, יוצג הערך הסופי של הביטוי.

    ערכים מספריים הם מספרים דצימאליים אלא אם כן מקדים אותם ‎0×‎ עבור מספרים הקסדצימאליים או 0 עבור מספרים אוקטליים. בשל כך, ‎0×12‎ זהה ל- 18 וזהה ל- 022. הרישום האוקטלי עשוי להיות מבלבל. לדוגמה, 08 ו- 09 אינם מספרים חוקיים, מכיוון ש- 8 ו- 9 אינם ספרות אוקטליות חוקיות.

  • שימוש ב- ‎/p

    אינך נדרש לכלול מחרוזת פקודה.

  • תמיכה בהרחבת משתנה סביבה שהושהה

    נוספה תמיכה בהרחבת משתנה סביבה שהושהה. כברירת מחדל תמיכה זו אינה זמינה, אך באפשרותך להפעילה או לבטלה באמצעות הפקודה cmd /v.

  • עבודה עם הרחבות פקודה

    כאשר הרחבות פקודה הופכות לזמינות (כלומר, כברירת המחדל) ובעת הפעלה של הפקודה set ללא פרמטרים, כל משתני הסביבה הנוכחיים מוצגים. אם תפעיל את set עם ערך, יוצגו המשתנים התואמים לערך זה.

  • שימוש בפקודה set בקבצי אצווה

    בעת יצירת קבצי אצווה, באפשרותך להשתמש בפקודה set כדי ליצור משתנים ולהשתמש בהם באופן זהה לשימוש במשתנים הממוספרים %0‎ עד %9‎. באפשרותך להשתמש גם במשתנים %0‎ עד %9‎ כקלט עבור הפקודה set.

  • קריאה למשתנה set מקובץ אצווה

    בעת ביצוע קריאה לערך משתנה מקובץ אצווה, יש לתחום את הערך בסימני אחוז (%). לדוגמה, אם תוכנית האצווה יוצרת משתנה סביבה ששמו BAUD, באפשרותך להשתמש במחרוזת המשויכת ל- BAUD כפרמטר בר-החלפה על-ידי הקלדה של ‎%baud%‎ בשורת הפקודה.

דוגמאות

כדי לקבוע משתנה סביבה בשם TEST^1, הקלד:

set testVar=test^^1

כדי לקבוע משתנה סביבה בשם TEST&1, הקלד:

set testVar=test^&1

הפקודה Set קובעת את ערך המשתנה כערך הבא לאחר סימן השוויון (=). אם תקליד:

set testVar="test^1"‎

תקבל את התוצאה הבאה:

testVar="test^1"‎

כדי להגדיר משתנה סביבה ששמו INCLUDE כך שהמחרוזת ‎C:\Inc‎ (הספריה ‎\Inc בכונן C) תשויך אליו, הקלד:

set include=c:\inc

לאחר מכן יהיה באפשרותך להשתמש במחרוזת ‎C:\Inc‎ בקבצי אצווה על-ידי תחימת השם INCLUDE בסימני אחוז (%). לדוגמה, באפשרותך לכלול את הפקודה הבאה בקובץ אצווה כדי שתוכל להציג את התוכן של הספריה המשויכת למשתנה הסביבה INCLUDE:

‎dir %include%‎

בעת עיבוד של פקודה זו, המחרוזת ‎C:\Inc מחליפה את ‎%include%‎.

באפשרותך להשתמש בפקודה set בתוכנית אצווה המוסיפה ספריה חדשה למשתנה הסביבה PATH. לדוגמה:

‎@echo off
rem ADDPATH.BAT adds a new directory
rem to the path environment variable.‎
set path=%1;%path%‎
set

אם הרחבות הפקודה זמינות (כלומר, ברירת המחדל) וברצונך להפעיל את הפקודה set עם ערך, יוצגו המשתנים התואמים לערך. לדוגמה, אם תקליד set p בשורת הפקודה, יתקבלו התוצאות הבאות:

Path=C:\WINNT\system32;C:\WINNT;C:\WINNT\System32\Wbem
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH
PROCESSOR_ARCHITECTURE=x86
PROCESSOR_IDENTIFIER=x86 Family 6 Model 8 Stepping 1, GenuineIntel
PROCESSOR_LEVEL=6
PROCESSOR_REVISION=0801
ProgramFiles=C:\Program Files
PROMPT=$P$G


Setlocal

הפעלת ההתאמה המקומית (לוקליזציה) של משתני סביבה בקובץ אצווה. ההתאמה המקומית נמשכת עד שנמצאת פקודה תואמת מסוג endlocal או עד לסוף קובץ האצווה.

תחביר

setlocal {enableextension | disableextensions}‎ ‎{enabledelayedexpansion | disabledelayedexpansion}‎

ארגומנטים

enableextension
הפיכת הרחבות הפקודה לזמינות עד לפקודה endlocal התואמת, ללא קשר להגדרה שלפני הפקודה setlocal.
disableextensions
הפיכת הרחבות הפקודה ללא זמינות עד לפקודה endlocal התואמת, ללא קשר להגדרה שלפני הפקודה setlocal.
enabledelayedexpansion
הפיכה של הרחבת משתנה הסביבה שהושהה לזמינה עד לפקודה endlocal התואמת, ללא קשר להגדרה שלפני הפקודה setlocal.
disabledelayedexpansion
הפיכה של הרחבת משתנה הסביבה שהושהה לבלתי זמינה עד לפקודה endlocal התואמת, ללא קשר להגדרה שלפני הפקודה setlocal.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • שימוש ב- setlocal

    בעת השימוש בפקודה setlocal מחוץ לקובץ Script או לקובץ אצווה, אין לה כל השפעה.

  • שינוי משתני סביבה

    השתמש בפקודה setlocal כדי לשנות משתני סביבה בעת הפעלה של קובץ אצווה. שינויי סביבה המבוצעים לאחר הפעלת הפקודה setlocal הם שינויים מקומיים לקובץ האצווה. היישום Cmd.exe משחזר הגדרות קודמות כאשר הוא נתקל בפקודה endlocal או מגיע לסוף קובץ האצווה.

  • באפשרותך להשתמש בפקודות setlocal או endlocal יותר מפעם אחת בתוכנית אצווה (כלומר, פקודות מקוננות).
  • בדיקה של הרחבות פקודה בקבצי אצווה

    הפקודה setlocal קובעת את המשתנה ERRORLEVEL. אם יתבצע מעבר עבור {enableextension | disableextensions} או {enabledelayedexpansion | disabledelayedexpansion}, המשתנה ERRORLEVEL ייקבע לאפס (0). בכל מקרה אחר, המשתנה ייקבע לאחד (1). באפשרותך להשתמש באופן הפעולה הזה בקבצי Script של אצווה כדי לקבוע אם ההרחבות זמינות, לדוגמה:

        verify other 2>nul
    setlocal enableextensions
    if errorlevel 1 echo Unable to enable extensions

    מכיוון ש- cmd אינו קובע את המשתנה ERRORLEVEL כאשר הרחבות פקודה אינן זמינות, הפקודה verify מאתחלת את המשתנה ERRORLEVEL לערך שאינו אפס בעת השימוש בו עם ארגומנט לא חוקי. בנוסף, אם תשתמש בפקודה setlocal עם הארגומנטים {enableextension | disableextensions} או {enabledelayedexpansion | disabledelayedexpansion} והדבר לא יקבע את ערך המשתנה ERRORLEVEL לאחד (1), הרחבות פקודה לא יהיו זמינות.

    לקבלת מידע נוסף אודות הפיכה של הרחבות פקודה לזמינות או לבלתי זמינות, ראה cmd בנושאים קרובים.

דוגמאות

באפשרותך לבצע התאמה מקומית של משתני סביבה בקובץ אצווה, כדלקמן:

  rem *******Begin Comment**************‎
  rem This program starts the superapp batch program on the network,‎
  rem directs the output to a file, and displays the file
  rem in Notepad.‎
  rem *******End Comment**************‎
      ‎@echo off
      setlocal
      path=g:\programs\superapp;%path%‎
      call superapp>c:\superapp.out
      endlocal
      start notepad c:\superapp.out


Setver

קביעת מספר הגירסה של MS-DOS שעליה מדווחת מערכת המשנה של MS-DOS לתוכנית. כאשר נעשה שימוש בפקודה setver ללא פרמטרים, מוצגת טבלת הגירסאות הנוכחית.

תחביר

setver [Drive:Path]‎ ‎[FileName n.nn]‎

setver [Drive:Path]‎ ‎[FileName ‎[/delete [/quiet]]‎

כדי להציג את טבלת הגירסאות הנוכחית, השתמש בתחביר הבא:

setver [Drive:Path]‎

פרמטרים

‎[Drive:Path]‎
ציון של מיקום הקובץ Setver.exe.
FileName
ציון השם של קובץ התוכנית (‎.exe או ‎.com) שברצונך להוסיף לטבלת הגירסאות. אין באפשרותך להשתמש בתווים כלליים (* או ?).
n.nn
קביעת הגירסה של MS-DOS (לדוגמה, 3.3 או 4.01) עליה מדווחת מערכת המשנה של MS-DOS לקובץ התוכנית שצוין.
‎/delete
מחיקת ערך טבלת הגירסאות עבור קובץ התוכנית שצוין. באפשרותך להשתמש גם ב- ‎/d.
‎/quiet
הסתרת ההודעה המוצגת בדרך כלל בעת מחיקה של ערך מטבלת הגירסאות.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • XOX
  • XOX
  • שימוש בטבלת הגירסאות

    תוכניות רבות שנוצרו עבור פעולה בגירסה קודמת של MS-DOS פועלות כהלכה ב- Windows XP. עם זאת, תוכנית עשויה שלא לפעול כהלכה אם שם התוכנית לא הוכלל בטבלת הגירסאות. הטבלה מיידעת את התוכנית על כך שהיא פועלת בגירסת ה- MS-DOS שעבורה היא תוכננה, אף על פי שלמעשה פעולתה מתבצעת במערכת המשנה של MS-DOS . על-ידי זיהוי של MS-DOS בגירסה 5.0 כגירסה קודמת, התוכנית אמורה לפעול כהלכה. עם זאת, שימוש בפקודה setver אינו פותר את הבעיה אם התוכנית אינה תואמת ל- Windows XP.

  • טעינה של טבלת הגירסאות לזכרון

    בטרם תוכל להשתמש בפקודה setver, יש לטעון את טבלת הגירסאות לזיכרון על-ידי הוספת הפקודה device בקובץ Config.nt.

  • הפעלה מחדש לאחר עדכון טבלת הגירסאות

    לאחר עדכון טבלת הגירסאות על-ידי הוספה או מחיקה של ערכים, עליך ליצור הפעלה חדשה של שורת פקודה כדי לקרוא מחדש את טבלת הגירסאות.

  • עדכון ערכים קיימים

    אם תציין שם קובץ שכבר קיים בטבלת הגירסאות, הערך החדש יחליף את הערך הקיים.

  • הכרת קודי היציאה של setver

    כדי לעבד קודי יציאה המוחזרים על-ידי setver, השתמש בפרמטר errorlevel בשורת הפקודה של if בתוכנית אצווה. לקבלת דוגמה לתוכנית אצווה המעבדת קודי יציאה באמצעות if, ראה נושאים קרובים. הטבלה הבאה מציגה ומתארת כל קוד יציאה.

    קוד יציאה | תיאור
    0 | Setver סיים את פעולתו בהצלחה.
    1 | המשתמש ציין אפשרות שורת פקודה לא חוקית.
    2 | המשתמש ציין שם קובץ לא חוקי.
    3 | אין די זיכרון מערכת לביצוע הפקודה.
    4 | המשתמש ציין תבנית לא חוקית של מספר גירסה.
    5 | ל- Setver לא היתה אפשרות למצוא בטבלת הגירסאות את הערך שצוין.
    6 | ל- Setver אין אפשרות למצוא את הקובץ Setver.exe.
    7 | המשתמש ציין כונן לא חוקי.
    8 | המשתמש ציין אפשרות שורת פקודה רבות מדי.
    9 | Setver איתר אפשרויות שורת פקודה חסרות.
    10 | Setver איתר שגיאה במהלך קריאת הקובץ Setver.exe.
    11 | הקובץ Setver.exe פגום.
    12 | הקובץ Setver.exe שצוין אינו תומך בטבלת גירסאות.
    13 | אין די שטח בטבלת הגירסאות עבור ערך חדש.
    14 | Setver איתר שגיאה במהלך כתיבה לקובץ Setver.exe.

דוגמאות

כדי להפעיל את Myprog.exe, קובץ הפועל ב- MS-DOS גירסה 3.30, צור בטבלת הגירסאות ערך המאפשר ל- Myprog.exe לזהות את מערכת המשנה של MS-DOS כגירסה 3.30 על-ידי הקלדת:

setver myprog.exe 3.30

כדי למחוק את הערך של Myprog.exe מטבלת הגירסאות, מבלי להשפיע בכל אופן אחר על הקובץ Myprog.exe, הקלד:

setver myprog.exe /delete

עבור פירוט התוכן של טבלת הגירסאות בכונן C, הקלד:

setver c:‎


Share

XOX

הערות

  • XOX


Shell

פקודה זו מציינת את השם ואת המיקום של מתרגם פקודות חלופי שברצונך כי ישמש את Windows XP עבור מערכת המשנה MS-DOS .

תחביר

shell=‎‎[[Drive:]Path]‎ FileName ‎[parameters]‎

פרמטרים

‎[[Drive:]Path] FileName
פרמטר זה מציין את המיקום ואת השם של מתרגם הפקודות.
parameters
פרמטר זה מציין כל פרמטר או אפשרות של שורת פקודה שניתן לעשות בהם שימוש עם מתרגם הפקודות שצוין.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • הגדרת ברירת מחדל

    כברירת מחדל, מערכת המשנה MS-DOS עושה שימוש בגירסה מיוחדת של Command.com הפועלת באופן מושלם עם מערכות משנה אחרות של Windows XP (לרבות שימוש ברכיבי Pipe וניתוב מחדש בין מערכות משנה); לפיכך, אין צורך בפקודה shell.

  • ציון מתרגם פקודות של 16 סיביות

    על אף שאין זה מומלץ, באפשרותך להשתמש בפקודה shell כדי לציין את מתרגם הפקודות האישי שלך הפועל בשיטה של 16 סיביות.

  • שימוש באפשרויות שורת פקודה עם מתרגם פקודות

    הפקודה shell לבדה אינה מקבלת כל אפשרות שורת פקודה, אך אם מתרגם הפקודות מקבל אפשרויות שורת פקודה, באפשרותך לכלול אותן בשורת הפקודה של shell.

דוגמאות

נניח שהקובץ Newshell.com נמצא בספריה ‎/Bin בכונן ההפעלה, וברצונך להשתמש ב- Newshell.com כמתרגם הפקודות. כדי לעשות זאת, הוסף את הפקודה שלהלן לקובץ Config.nt:

shell=\bin\newshell.com


Shift

פקודה זו משנה את המיקום של פרמטרי אצווה בקובץ אצווה.

תחביר

shift

פרמטרים

ללא

הערות

  • שימוש באפשרות שורת הפקודה shift עם הרחבות פקודה

    כאשר הרחבות פקודה זמינות (כלומר, ברירת המחדל), הפקודה shift תומכת באפשרות שורת הפקודה ‎/n, המורה לפקודה להתחיל בהעברה בארגומנט מספר n, כאשר n הוא ערך מאפס עד שמונה. לדוגמה,

    SHIFT /2

    תגרום להעברה של ‎%3 ל- ‎%2‏, ‎%4 ל- ‎%3 וכן הלאה, ותשאיר את ‎%0 ואת %1 ללא שינוי.

  • כיצד פועלת הפקודה shift

    הפקודה shift משנה את הערכים של פרמטרי האצווה ‎%0 עד ‎%9 על-ידי העתקת כל פרמטר לפרמטר שלפניו. כלומר, הערך של ‎%1 מועתק ל- ‎%0, הערך של ‎%2 מועתק ל- %1 וכן הלאה. פעולה זו יעילה עבור כתיבה של קובץ אצווה המבצע פעולה זהה על מספר כלשהו של פרמטרים.

  • עבודה עם יותר מ- 10 פרמטרי אצווה

    באפשרותך להשתמש בפקודה shift גם כדי ליצור קובץ אצווה המקבל למעלה מ- 10 פרמטרי אצווה. אם תציין יותר מ- 10 פרמטרים בשורת הפקודה, הפרמטרים שיופיעו אחרי הפרמטר העשירי (‎%9) יועברו, כל אחד בתורו, ל- ‎%9.

  • שימוש בפרמטר ‎%*‎ עם הפקודה shift

    הפקודה Shift אינה משפיעה על פרמטר האצווה ‎%*‎.

  • העברת פרמטרים למצב הקודם

    לא קיימת פקודת shift הפועלת לאחור. לאחר הפעלת הפקודה shift, אין באפשרותך לשחזר את פרמטר האצווה הראשון (‎%0) שהיה קיים לפני ההעברה.

דוגמאות

קובץ האצווה שלהלן, Mycopy.bat, מדגים כיצד להשתמש בפקודה shift עם כל מספר של פרמטרי אצווה. קובץ זה מעתיק רשימת קבצים לספריה מסוימת. פרמטרי האצווה מיוצגים באמצעות ארגומנטים של שמות קבצים וספריות.

‎@echo off
rem MYCOPY.BAT copies any number of files
rem to a directory.‎
rem The command uses the following syntax:‎
rem mycopy dir file1 file2 ...‎
set todir=%1‎
‎:getfile
shift
if "%1"=="" goto end
copy %1 %todir%‎
goto getfile
‎:end
set todir=‎
echo All done


Shutdown

פקודה זו מאפשרת כיבוי או הפעלה מחדש של מחשב מקומי או מרוחק. כאשר נעשה שימוש בפקודה shutdown ללא פרמטרים, ינותק המשתמש הנוכחי.

תחביר

shutdown [{-l|-s|-r|-a}] [-f] [-m [\\ComputerName]] [-t xx] [-c "message"] [-d[u][p]:xx:yy]‎

פרמטרים

‎-l
ניתוק המשתמש הנוכחי. זהו גם פרמטר ברירת המחדל. ‎-m ComputerName מקבל קדימות.
‎-s
כיבוי המחשב המקומי.
‎-r
ביצוע אתחול לאחר הכיבוי.
‎-a
ביטול פעולת הכיבוי. פרמטר זה מתעלם מפרמטרים אחרים, למעט ‎-l ו- ComputerName. באפשרותך להשתמש בפרמטר ‎-a במהלך פרק הזמן שהוקצב עד לכיבוי.
‎-f
אילוץ יישומים פועלים להיסגר.
‎-m [\\ComputerName]‎
ציון המחשב שברצונך לכבות.
‎-t xx
קביעת פרק זמן של xx שניות, שבסופו יכובה המחשב. ברירת המחדל היא 20 שניות.
‎-c "message"‎
ציון כי הודעה תוצג באזור Message של חלון System Shutdown. באפשרותך להשתמש ב- 127 תווים לכל היותר. עליך לתחום את ההודעה במרכאות.
‎-d [u][p]:xx:yy
ציון של קוד הסיבה לכיבוי. הטבלה שלהלן מציגה את הערכים השונים.
ערך | תיאור
u | מציין קוד משתמש.
p | מציין קוד כיבוי מתוכנן.
xx | מציין את קוד הסיבה הראשי (‎0-255).
yy | מציין את קוד הסיבה המשני (0-65536).
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • אם תציין קוד סיבה ראשי וקוד סיבה משני, ראשית עליך להגדיר את קודי הסיבה בכל מחשב שבכוונתך להשתמש עבורו בסיבה המסוימת. אם קודי הסיבה לא הוגדרו במחשב היעד, למציג האירועים לא תהיה אפשרות לרשום את טקסט הסיבה הנכון.

דוגמאות

כדי לכבות את ‎\\MyServer תוך 60 שניות, לאלץ יישומים פועלים להיסגר, להפעיל מחדש את המחשב לאחר הכיבוי, לציין קוד משתמש, לציין כי הכיבוי מתוכנן ולבצע רישום של הקוד סיבה ראשי 125 ושל קוד הסיבה המשני 1, הקלד:

shutdown -r -f -m \\MyServer -t 60 -d up:125:1


Sort

קריאת קלט, מיון נתונים וכתיבת התוצאות למסך, לקובץ או להתקן אחר.

תחביר

sort ‎[/r]‎ ‎[/+n]‎ ‎[/m kilobytes]‎ ‎[/l locale]‎ ‎[/rec characters]‎ ‎[[drive1:][path1]filename1]‎ ‎[/t [drive2:][path2]]‎ ‎[/o [drive3:][path3]filename3]‎

‎[command |] sort [/r]‎ ‎[/+n]‎ ‎[/m kilobytes]‎ ‎[/l locale]‎ ‎[/rec characters]‎ ‎[[drive1:][path1]filename1][/t [drive2:][path2]]‎ ‎[/o [drive3:][path3]filename3]‎

פרמטרים

‎/r
היפוך של סדר המיון (כלומר, מיון מ- Z ל- A ולאחר מכן מ- 9 ל- 0).
‎/+n‎
ציון של מספר המיקום של התו, n, שבו פותחת הפקודה sort כל השוואה.
‎/m kilobytes
ציון של כמות הזיכרון הראשי שישמש עבור המיון, בקילו-בתים (KB).
‎/l locale
עקיפת סדר מיון התווים שהוגדר על-ידי אזור ברירת המחדל של המערכת (כלומר, שפה ומדינה/אזור שנבחרו בעת התקנה).
‎/rec characters
ציון המספר המירבי של תווים בשורה של קובץ הקלט או ברשומה (ברירת המחדל היא 4,096 והמספר המירבי הוא ‎65,535).
‎[drive1:][path1]filename1‎
ציון הקובץ שיש למיין. אם לא צוין שם קובץ, מתבצע מיון של הקלט הסטנדרטי. ציון של קובץ הקלט מהיר יותר מניתוב מחדש של אותו קובץ כקלט סטנדרטי.
‎/t [drive2:][path2]‎
ציון הנתיב של הספריה שעליו להכיל את המאגר עבור פעולתה של הפקודה sort, אם כמות הנתונים אינה מתאימה לזיכרון הראשי. ברירת המחדל היא שימוש בספריה הזמנית של המערכת.
‎/o [drive3:][path3]filename3‎
ציון הקובץ שיאוחסן בו הקלט הממוין. אם לא צוין קובץ, נכתבים הנתונים לפלט סטנדרטי. ציון קובץ הפלט מהיר מניתוב מחדש של פלט סטנדרטי לאותו קובץ.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • שימוש באפשרות שורת הפקודה ‎/+n

    באמצעות שימוש באפשרות שורת הפקודה ‎/+n באפשרותך לציין התחלה של השוואה בשורה שאינה הראשונה. לדוגמה, ‎/+3 מציין כי על כל השוואה להתחיל בתו השלישי בכל שורה. שורות המכילות פחות מ- n תווים יאספו לפני שורות אחרות. כברירת מחדל, השוואות מתחילות בתו הראשון בכל שורה.

  • שימוש באפשרות שורת הפקודה ‎/m kilobytes

    כמות הזיכרון המינימלית שבשימוש היא תמיד ‎160 KB. אם צוין גודל הזיכרון, הגודל המדויק שצוין (אך לפחות ‎160 KB) ישמש את פעולת המיון, ללא התייחסות לכמות הזמינה של זיכרון ראשי.

    גודל הזיכרון המקסימלי המשמש כברירת מחדל, אם לא צוין גודל זיכרון, הוא 90 אחוזים מהזיכרון הראשי הזמין אם הקלט וגם הפלט הם קבצים, ו- 45 אחוזים מהזיכרון הראשי בכל מקרה אחר. לרוב, הגדרות ברירת המחדל מבטיחות את הביצועים הטובים ביותר.

  • שימוש באפשרות שורת הפקודה ‎/l locale

    כיום, החלופה היחידה של אזור ברירת המחדל היא אזור "C", שהוא מהיר יותר ממיון של שפה טבעית ומבצע מיון תווים לפי הקידוד הבינארי שלהם.

  • ציון מקור

    אלא אם ציינת את הפרמטרים command או FileName, הפקודה sort פועלת כמסנן ומקבלת קלט מהקלט התקני (כלומר, בדרך כלל מלוח המקשים, מרכיב Pipe או מקובץ).

  • שימוש בסימני ניתוב מחדש עם sort

    באפשרותך להשתמש בתו Pipe (|) כדי לנתב נתונים של פקודה אחרת דרך הפקודה sort, או כדי לנתב את פלט המיון לפקודה אחרת (לדוגמה, באפשרותך לנתב את המידע לפקודה more כדי שהמידע יוצג במסך אחד בכל פעם). ייתכן כי שימוש בסימן קטן מ- (‎<‎) או בסימן גדול מ- (‎>‎) כדי לציין את קובץ הקלט או את קובץ הפלט לא יהיה יעיל; במקום זאת, ציין את קובץ הקלט ישירות (כמוגדר בתחביר הפקודה) וציין את קובץ הפלט באמצעות הפרמטר ‎/o. פעולה זו עשויה להיות מהירה יותר באופן משמעותי, במיוחד עם קבצים גדולים.

  • אותיות רישיות מול אותיות קטנות

    הפקודה sort אינה מבחינה בין אותיות רישיות לבין אותיות קטנות.

  • מגבלות על גודל קובץ

    לפקודה sort אין כל מגבלה על גודל קובץ.

  • רצף איסוף

    תוכנית המיון עושה שימוש בטבלת רצף איסוף התואמת לקוד מדינה/אזור ולהגדרות הקידוד. תווים בעלי קוד ASCII גדול מ- 127 ממוינים על בסיס המידע שבקובץ Country.sys או בקובץ חלופי שצוין באמצעות הפקודה country בקובץ Config.nt.

  • שימוש בזיכרון

    אם המיון מתאים לגודל הזיכרון (כלומר, גודל הזיכרון המקסימלי המשמש כברירת מחדל או גודל הזיכרון שצוין באמצעות הפרמטר ‎/m), המיון מתבצע במהלך אחד. אם המיון אינו מתאים לגודל הזיכרון, הוא מתבצע בשני מהלכים, כך שנעשה שימוש בכמות זיכרון שווה עבור מהלך המיון ועבור מהלך המיזוג. כאשר מתבצעים שני מהלכים, הנתונים שמוינו באופן חלקי מאוחסנים בקובץ זמני בדיסק. אם לא קיים די זיכרון לביצוע המיון בשני מהלכים, מופקת שגיאת זמן ריצה. אם נעשה שימוש באפשרות שורת הפקודה ‎/m לציון כמות זיכרון הגדולה מהכמות הזמינה בפועל, עלולה להתרחש פגיעה בביצועים או שגיאת זמן ריצה.

דוגמאות

מיון קובץ

הפקודה שלהלן קוראת את הקובץ Expenses.txt, ממיינת אותו בסדר הפוך ומציגה אותו על המסך:

sort /r expenses.txt

מיון פלט מפקודה

כדי לחפש את הטקסט "Jones" בקובץ גדול הנקרא Maillist.txt וכדי למיין את תוצאות החיפוש, השתמש בתו Pipe (|) כדי לנתב את הפלט של הפקודה find לפקודה sort, כדלקמן:

find "Jones" maillist.txt | sort

הפקודה מפיקה רשימה ממוינת של שורות המכילות את הטקסט שצוין.

מיון קלט של לוח המקשים

כדי למיין קלט של לוח מקשים ולהציג את התוצאות על המסך בסדר אלפביתי, באפשרותך להשתמש תחילה בפקודה sort ללא פרמטרים, כדלקמן:

sort

ולאחר מכן להקליד את הטקסט שברצונך למיין, תוך הקשה על ENTER בסוף כל שורה. כאשר סיימת להקליד את הטקסט, הקש CTRL+Z ולאחר מכן הקש ENTER. הפקודה sort מציגה את הטקסט שהקלדת לאחר מיון אלפביתי.

באפשרותך גם לנתב מחדש קלט ממוין של לוח מקשים לקובץ. לקבלת מידע נוסף, לחץ על redirect ברשימה נושאים קרובים.


Stacks

תמיכה בשימוש דינאמי במחסניות נתונים לטיפול בפסיקות חומרה. כדי להשתמש במשתנה סביבה זה, מקם אותו בקובץ Config.nt.

תחביר

stacks=n,s

פרמטרים

n
ציון של מספר המחסניות. ערכים חוקיים עבור n הם 0 ומספרים בתחום שבין 8 ל- 64.
s
ציון, בבתים, של גודל כל מחסנית. ערכים חוקיים עבור s הם 0 ומספרים בתחום שבין 32 ל- 512.

הערות

  • הגדרות ברירת מחדל

    הטבלה שלהלן מציגה את הגדרות ברירת המחדל עבור הפקודה stack.

    מחשב | מחסניות (Stacks)
    IBM PC‏, IBM PC/XT‏, IBM PC-Portable | 0,0
    אחר | 9,128
  • מקרים מיוחדים של הקצאת מחסנית

    בעת קבלה של פסיקת חומרה, Windows XP מקצה מחסנית אחת מתוך מספר המחסניות שצוין. כאשר תציין 0 עבור הערכים n ו- s‏, Windows XP לא יקצה מחסניות. אם הערכים הם 0, על כל תוכנית פועלת להכיל די שטח מחסניות כדי לאחסן את מנהלי פסיקות החומרה של המחשב. מחשבים רבים פועלים כשורה ושומרים כמות זיכרון גדולה יותר עבור תוכניות כאשר הערכים n ו- s הם 0. עם זאת, אם המחשב הופך ללא יציב לאחר הגדרת הערכים ל- 0, חזור אל ערכי ברירת המחדל.

דוגמאות

כדי להקצות שמונה מחסניות של 512 בתים כל אחת לטיפול בפסיקות חומרה, הוסף את הפקודה שלהלן לקובץ Config.nt:

stacks=8,512


Start

פקודה זו פותחת חלון נפרד של שורת פקודה לשם הפעלה של תוכנית או של פקודה שצוינו. ללא פרמטרים, הפקודה start גורמת לפתיחה של חלון שורת פקודה נוסף.

תחביר

start ["title"]‎ ‎[/d Path]‎ ‎[/i]‎ ‎[/min]‎ ‎[/max]‎ ‎[{/separate | /shared}]‎ ‎[{/low | /normal | /high | /realtime | /abovenormal | belownormal}]‎ ‎[/wait]‎ ‎[/b]‎ ‎[FileName]‎ ‎[parameters]‎

פרמטרים

‎"title"‎
ציון הכותרת שתוצג בפס הכותרת של חלון שורת הפקודה.
‎/d Path
ציון של ספריית ההפעלה.
‎/i
העברה של סביבת ההפעלה של Cmd.exe לחלון שורת הפקודה החדש.
‎/min
פתיחת חלון שורת פקודה ממוזער חדש.
‎/max
פתיחת חלון שורת פקודה מוגדל חדש.
‎/separate
הפעלת תוכניות של 16 סיביות בשטח זיכרון נפרד.
‎/shared
הפעלת תוכניות של 16 סיביות בשטח זיכרון משותף.
‎/low
הפעלת יישום במחלקה עבור עדיפות בעת חוסר פעילות (Idle Priority Class).
‎/normal
הפעלת יישום במחלקת העדיפות הרגילה (Normal Priority Class).
‎/high
הפעלת יישום במחלקת העדיפות הגבוהה (High Priority Class).
‎/realtime
הפעלת יישום במחלקת העדיפות של זמן אמת (Realtime Priority Class).
‎/abovenormal
הפעלת יישום במחלקת העדיפות הגבוהה מהתקן (Abovenormal Priority Class).
‎/belownormal
הפעלת יישום במחלקת העדיפות הנמוכה מהתקן (Belownormal Priority Class).
‎/wait
הפעלת יישום והמתנה לסיום פעולתו.
‎/b
הפעלת יישום מבלי לפתוח חלון שורת פקודה חדש. לא קיימת התייחסות לטיפול באמצעות CTRL+C אלא אם היישום מאפשר עיבוד באמצעות CTRL+C. השתמש במקשים CTRL+BREAK כדי להפסיק את היישום.
FileName
ציון של הפקודה או של התוכנית שיש להפעיל.
parameters
ציון הפרמטרים שיש להעביר לפקודה או לתוכנית.

הערות

  • באפשרותך להפעיל קבצים שאינם קבצי הפעלה דרך שיוך הקובץ שלהם על-ידי הקלדת שם הקובץ כפקודה. לקבלת מידע נוסף אודות יצירת שיוכים אלה בקובץ Script של פקודה באמצעות assoc ו- ftype, ראה נושאים קרובים.
  • בעת הפעלת פקודה שה- Token הראשון שהיא מכילה הוא המחרוזת "CMD" ללא סיומת או מזהה נתיב, המחרוזת "CMD" מוחלפת בערך של המשתנה COMSPEC. פעולה זו מונעת מהמשתמשים לבחור cmd מהספריה הנוכחית.
  • בעת הפעלת יישום של ממשק משתמש גרפי (GUI) של 32 סיביות, המחרוזת cmd אינה ממתינה עד שהיישום ייסגר לפני חזרה לשורת הפקודה. אופן פעולה חדש זה לא ייצא אל הפועל אם תפעיל את היישום באמצעות קובץ Script של פקודה.
  • בעת הפעלת פקודה שעושה שימוש ב- Token ראשון שאינו מכיל סיומת, Cmd.exe עושה שימוש בערך של משתנה הסביבה PATHEXT כדי לקבוע אילו סיומות לחפש ובאיזה סדר. ערך ברירת המחדל עבור המשתנה PATHEXT הוא: ‎.COM;.EXE;.BAT;.CMD (כלומר, התחביר זהה למשתנה PATH, כאשר נקודה-פסיק מפרידה בין המרכיבים השונים).
  • אם ברצונך לבצע חיפוש אחר קובץ הפעלה אך לא נמצאה התאמה עבור כל סיומת שהיא, הפקודה start מבצעת חיפוש בשם ספריה. אם כך קורה, הפקודה start תביא להפעלת Explorer.exe באותו נתיב.

דוגמאות

כדי להפעיל את התוכנית Myapp בשורת הפקודה ולשמור על יכולת שימוש בחלון שורת הפקודה הנוכחי, הקלד:

start myapp


Subst

פקודה זו משייכת נתיב לאות כונן. ללא פרמטרים, הפקודה subst גורמת להצגת שמות הכוננים הווירטואלים שבתוקף.

תחביר

subst [drive1: [drive2:]Path]‎

subst drive1: /d

פרמטרים

drive1:‎
ציון הכונן הווירטואלי שברצונך להקצות לו נתיב.
drive2: ‎
ציון הכונן הפיזי המכיל את הנתיב שצוין (אם הוא שונה מהכונן הנוכחי).
Path
ציון הנתיב שברצונך להקצות לכונן וירטואלי.
‎/d
מחיקה של כונן וירטואלי.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • הפקודות הבאות אינן פועלות, או שאין להשתמש בהן, בכוננים שנעשה בהם שימוש בפקודה subst:
    • chkdsk
    • diskcomp
    • diskcopy
    • format
    • label
    • recover
  • יש להשתמש בפרמטר drive1 בטווח שצוין בפקודה lastdrive. אם לא כן, הפקודה subst תגרום להצגה של הודעת השגיאה הבאה:

    Invalid parameter - drive1:‎

דוגמאות

כדי ליצור כונן וירטואלי Z עבור הנתיב B:\User\Betty\Forms, הקלד:

subst z: b:\user\betty\forms

לאחר מכן, במקום להקליד את הנתיב המלא, באפשרותך להגיע לספריה זו על-ידי הקלדת אות הכונן הוירטואלי ואחריה נקודותיים, כדלקמן:

z:‎


Switches

פקודה זו כופה על לוח מקשים משופר אופן פעולה של לוח מקשים רגיל.

תחביר

switches=/k

פרמטרים

ללא

הערות

  • באפשרותך להשתמש בפקודה זו בקובץ Config.nt.
  • אם ברשותך תוכנית שאינה מתרגמת כהלכה קלט מלוח מקשים משופר, הוסף פקודה זו לקובץ Config.nt עבור לוח המקשים המשופר.
  • אם אתה משתמש בפקודה switches=/k והתקנת את מנהל ההתקן Ansi.sys, השתמש באפשרות שורת הפקודה ‎/k בשורת הפקודה device עבור Ansi.sys.

דוגמאות

אם ברצונך להשתמש בפונקציות של לוח מקשים רגיל אף על פי שברשותך לוח מקשים משופר, הוסף לקובץ Config.nt את הפקודה שלהלן:

switches=/k


בודק קבצי המערכת (sfc)

סריקה ואישור עבור הגירסאות של כל קבצי המערכת המוגנים לאחר הפעלה מחדש של המחשב.

תחביר

sfc ‎[/scannow]‎ ‎[/scanonce]‎ ‎[/scanboot]‎ ‎[/revert]‎ ‎[/purgecache]‎ ‎[/cachesize=x]‎

פרמטרים

‎/scannow
סריקה מיידית של כל קבצי המערכת המוגנים.
‎/scanonce
סריקה יחידה של כל קבצי המערכת המוגנים.
‎/scanboot
סריקת כל קבצי המערכת המוגנים בכל הפעלה מחדש של המחשב.
‎/revert
החזרת הסריקה לפעולת ברירת המחדל שלה.
‎/purgecache
ניקוי מטמון הקבצים של מערכת הגנת הקבצים של Windows וסריקה מיידית של כל קבצי המערכת המוגנים.
‎/cachesize=x
קביעת גודל מטמון הקבצים של מערכת הגנת הקבצים של Windows, במגה-בתים (MB).
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • עליך לבצע כניסה למחשב כחבר בקבוצה Administrators כדי להפעיל את הפקודה sfc.
  • אם הפקודה sfc מגלה כי התבצעה החלפה של קובץ מוגן, היא מאחזרת את הגירסה הנכונה של הקובץ מתוך התיקיה ‎%systemroot%‎‎\system32\dllcache ולאחר מכן מחליפה את הקובץ השגוי.
  • אם התיקיה ‎%systemroot%‎‎\system32\dllcache נפגמת או אם אין אפשרות להשתמש בה, השתמש ב- sfc /scannow, ‏sfc /scanonce או sfc /scanboot כדי לתקן את תוכן הספריה Dllcache.


Systeminfo

פקודה זו מציגה מידע תצורה מפורט אודות המחשב ומערכת ההפעלה שלו, לרבות תצורת מערכת ההפעלה, מידע אודות אבטחה, מזהה מוצר, ומאפייני חומרה כגון RAM, שטח דיסק וכרטיסי רשת.

תחביר

systeminfo[.exe]‎ ‎[/s Computer [/u Domain\User [/p Password]]]‎ ‎[/fo {TABLE|LIST|CSV}]‎ ‎[/nh]‎

פרמטרים

‎/s Computer
ציון שם או כתובת IP של מחשב מרוחק (אין להשתמש בקווים נטויים הפוכים). ברירת המחדל היא המחשב המקומי.
‎/u Domain\User
הפעלת הפקודה עם הרשאות החשבון של המשתמש שצוין באמצעות User או Domain\User. ברירת המחדל היא שימוש בהרשאות של המשתמש שמחובר כעת למחשב המפעיל את הפקודה.
‎/p Password
ציון הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u .
‎/fo {TABLE|LIST|CSV}‎
ציון התבנית לשימוש עבור הפלט. ערכים חוקיים הם TABLE‏, LIST ו- CSV. תבנית ברירת המחדל עבור פלט היא LIST.
‎/nh
הסתרה של כותרות העמודות בפלט. הפעולה חוקית כאשר הפרמטר ‎/fo מוגדר ל- TABLE או ל- CSV.
‎/?‎
הצגת עזרה בשורת הפקודה.

דוגמאות

הדוגמאות שלהלן מציגות את אופן השימוש בפקודה systeminfo:

systeminfo.exe /s srvmain
systeminfo.exe /s srvmain /u maindom\hiropln
systeminfo /s srvmain /u maindom\hiropln /p p@ssW23 /fo table


Taskkill

סיום משימה אחת או יותר או תהליך אחד או יותר. ניתן לסיים תהליכים באמצעות מזהה תהליך או שם תמונה.

תחביר

taskkill ‎[/s Computer] [/u Domain\User [/p Password]]]‎ ‎[/fi FilterName]‎ ‎[/pid ProcessID]|[/im ImageName]‎ ‎[/f][/t]‎

פרמטרים

‎/s Computer
ציון השם או כתובת ה- IP של מחשב מרוחק (אין להשתמש בקווים נטויים הפוך). המחשב המקומי משמש כברירת המחדל.
‎/u Domain\User
הפעלת הפקודה באמצעות הרשאות החשבון של המשתמש שצוין באמצעות User או Domain\User. ברירת המחדל היא ההרשאות של המשתמש המחובר כעת למחשב המנפיק את הפקודה.
‎/p Password
ציון הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u .
‎/fi FilterName
ציון סוגי התהליך או התהליכים שיש לכלול או לא לכלול בפעולת הסיום. הפריטים הבאים הם שמות מסננים חוקיים, אופרטורים חוקיים וערכים חוקיים.
שם | אופרטורים | ערך
Hostname | eq‏, ne | כל מחרוזת חוקית.
Status | eq‏, ne | RUNNING|NOT RESPONDING
Imagename | eq‏, ne | כל מחרוזת חוקית.
PID | eg‏, ne‏, gt‏, lt‏, ge‏, le | כל מספר חיובי שלם וחוקי.
Session | eg‏, ne‏, gt‏, lt‏, ge‏, le | כל מספר הפעלה חוקי.
CPUTime | eq‏, ne‏, gt‏, lt‏, ge‏, le | שעה חוקית בתבנית של hh:mm:ss. על הפרמטרים mm ו- ss להיות בין 0 ל- 59 ו- hh עשוי להיות כל ערך מספרי חוקי ללא סימן.
Memusage | eg‏, ne‏, gt‏, lt‏, ge‏, le | כל מספר שלם חוקי.
Username | eq‏, ne | כל שם משתמש חוקי ‎([Domain\]User)‎.
Services | eq‏, ne | כל מחרוזת חוקית.
Windowtitle | eq‏, ne | כל מחרוזת חוקית.
‎/pid ProcessID
ציון מזהה התהליך של התהליך שיש לסיימו.
‎/im ImageName
ציון שם התמונה של התהליך שיש לסיימו. השתמש בתו הכללי כוכבית (*) כדי לציין את כל שמות התמונה.
‎/f
קביעה כי יש לכפות סיום של תהליך או תהליכים. פרמטר זה אינו פועל עבור תהליכים מרוחקים; כל התהליכים המרוחקים מסתיימים באמצעות כפייה.
‎/t
ציון לסיום כל תהליכי הילדים לצד תהליך האב, המוכר בדרך כלל כ- tree kill.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • התו הכללי כוכבית (*) מתקבל רק אם צוין עם המסננים.
  • סיום של תהליכים מרוחקים ייעשה תמיד בכפייה ללא קשר לציון או לאי-ציון של הפרמטר ‎/f .
  • אם תספק שם מחשב למסנן HOSTNAME, הדבר יגרום לכיבוי המחשב וכל התהליכים ייעצרו.
  • השתמש ב- tasklist כדי למצוא מה הוא מזהה התהליך (PID) עבור התהליך שיש לסיים.
  • Taskkill הוא תחליף לכלי Kill.

דוגמאות

הדוגמאות הבאות מציגות אפשרויות לשימוש בפקודה taskkill:

taskkill /pid 1230 /pid 1241 /pid 1253
taskkill /f /fi "USERNAME eq NT AUTHORITY\SYSTEM" /im notepad.exe
taskkill /s srvmain /f /im notepad.exe
taskkill /s srvmain /u maindom\hiropln /p p@ssW23 /fi "IMAGENAME eq note*" /im *‎
taskkill /s srvmain /u maindom\hiropln /fi "USERNAME ne NT*" /im *‎
taskkill /f /fi "PID ge 1000" /im *‎


Tasklist

הצגת רשימה של יישומים ושירותים עם מזהה התהליך (PID) עבור כל המשימות הפועלות כעת במחשב מקומי או מרוחק.

תחביר

tasklist[.exe]‎ ‎[/s computer] [/u domain\user [/p password]]‎ ‎[/fo {TABLE|LIST|CSV}]‎ ‎[/nh]‎ ‎[/fi FilterName [/fi FilterName2 [ ... ]]]‎ ‎[/m [ModuleName]‎ | ‎/svc | ‎/v]‎

פרמטרים

‎/s Computer
ציון השם או כתובת ה- IP של מחשב מרוחק (אין להשתמש בקווים נטויים הפוכים). המחשב המקומי משמש כברירת המחדל.
‎/u Domain\User
הפעלת הפקודה באמצעות הרשאות החשבון של המשתמש שצוין באמצעות User או Domain\User. ברירת המחדל היא ההרשאות של המשתמש המחובר כעת למחשב המנפיק את הפקודה.
‎/p Password
ציון הסיסמה של חשבון המשתמש שצוין בפרמטר ‎/u .
‎/fo {TABLE|LIST|CSV}‎
ציון התבנית שיש להשתמש בה עבור הפלט. הערכים החוקיים הם TABLE,‏ LIST ו- CSV. התבנית המשמשת כברירת מחדל עבור פלט היא TABLE.
‎/nh
הסתרה של כותרות העמודה בפלט. הפעולה חוקית כאשר הפרמטר ‎/fo נקבע ל- TABLE או ל- CSV.
‎/fi FilterName
ציון סוג התהליך או התהליכים שיש לכלול או שלא לכלול בשאילתה. הטבלה הבאה מפרטת שמות מסננים חוקיים, אופרטורים חוקיים וערכים חוקיים.
שם | אופרטורים | ערך
Status | eq‏, ne | RUNNING|NOT RESPONDING
Imagename | eq‏, ne | כל מחרוזת חוקית.
PID | eq‏, ne‏, gt‏, lt‏, ge‏, le | כל מספר שלם חיובי וחוקי.
Session | eq‏, ne‏, gt‏, lt‏, ge‏, le | כל מספר הפעלה חוקי.
SessionName | eq‏, ne | כל מחרוזת חוקית.
CPUTime | eq‏, ne‏, gt‏, lt‏, ge‏, le | שעה חוקית בתבנית של hh:mm:ss. על הפרמטרים mm ו- ss להיות בין 0 ל- 59 והפרמטר hh עשוי להיות כל ערך מספרי חוקי ללא סימן.
Memusage | eq‏, ne‏, gt‏, lt‏, ge‏, le | כל מספר שלם חוקי.
Username | eq‏, ne | כל שם משתמש חוקי (‎[Domain\]User).
Services | eq‏, ne | כל מחרוזת חוקית.
Windowtitle | eq‏, ne | כל מחרוזת חוקית.
Modules | eq, ‏ne | כל מחרוזת חוקית.
‎/m [ModuleName]‎
ציון שיש להציג מידע מודול עבור כל תהליך. כאשר מצוין מודול, כל התהליכים העושים שימוש במודול זה מוצגים. כאשר מודול אינו מצוין, כל התהליכים עבור כל המודולים מוצגים. אינו ניתן לשימוש עם הפרמטר ‎/svc או ‎/v.
‎/svc
פירוט של כל מידע השירות עבור כל תהליך ללא חיתוך. חוקי כאשר הפרמטר ‎/fo נקבע ל- TABLE. לא ניתן לשימוש עם הפרמטר ‎/m או ‎/v.
‎/v
ציון שמידע משימה מפורט יוצג בפלט. אינו ניתן לשימוש לצד הפרמטר ‎/svc או ‎/m.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • Tasklist הוא תחליף לכלי TList.

דוגמאות

הדוגמאות הבאות מציגות אפשרויות לשימוש בפקודה tasklist:

tasklist /v /fi "PID gt 1000" /fo csv
tasklist /fi "USERNAME ne NT AUTHORITY\SYSTEM" /fi "STATUS eq running"‎
tasklist /v /fi "STATUS eq running"‎
tasklist /s srvmain /nh
tasklist /s srvmain /s srvny
tasklist /s srvmain /u maindom\hiropln /p p@ssW23 /nh


Tcmsetup

התקנה או ביטול של לקוח TAPI.

תחביר

tcmsetup [/q] [/x] /c Server1 [Server2...]‎

tcmsetup [/q] /c /d

פרמטרים

‎/q
מניעת ההצגה של תיבות הודעה.
‎/x
קביעה כי התקשרויות חזרה מונחות התקשרות ישמשו עבור רשתות בעלות עומס תעבורה כבד, שאובדן המנות בהן גבוה. כאשר פרמטר זה מושמט, יעשה שימוש בהתקשרויות חזרה ללא התקשרות.
‎/c
נדרש. ציון של הגדרת משתמש.
Server1
נדרש. ציון השם של השרת המרוחק הכולל את ספקי שירות TAPI שישמשו את הלקוח. הלקוח ישתמש בקווים ובטלפונים של ספקי השירות. על הלקוח להיות חבר בקבוצת המחשבים של השרת או בקבוצת מחשבים בעלת יחסי אמון הדדיים עם קבוצת המחשבים המכילה את השרת.
Server2...‎
ציון של שרת או שרתים נוספים שיהיו זמינים ללקוח זה. אם ברצונך לציין רשימה של שרתים, השתמש ברווח כדי להפריד בין שמות השרתים השונים.
‎/d
ניקוי של רשימת השרתים המרוחקים. פרמטר זה הופך את לקוח TAPI ללא זמין על-ידי כך שאינו מאפשר ללקוח שימוש בספקי שירות TAPI הנמצאים בשרתים המרוחקים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • כדי לאפשר ל- TAPI לפעול כראוי, עליך להפעיל את הפרמטר tcmsetup כדי לציין את השרתים המרוחקים שישמשו את לקוחות TAPI.
  • כדי שיהיה באפשרותך להפעיל פקודה זו, עליך להיות חבר בקבוצה Administrators. אם ביצעת כניסה למחשב כחבר בקבוצה אחרת, ראה שימוש בפקודה Runas להפעלת תוכנית כחבר בקבוצה Administrators.
  • כדי שתהיה למשתמש לקוח אפשרות להשתמש בטלפון או בקו בשרת TAPI, על מנהל שרת הטלפוניה להקצות את המשתמש לטלפון או לקו.
  • רשימת שרתי הטלפוניה שנוצרה באמצעות פקודה זו מחליפה כל רשימה קיימת של שרתי טלפוניה זמינים עבור הלקוח. אין באפשרותך להשתמש בפקודה זו כדי להוסיף נתונים לרשימה הקיימת.


כלי שירות ושירותים של TCP/IP

כלי השירות של TCP/IP מאפשרים התקשרויות רשת למחשבים אחרים, כגון תחנות עבודה של UNIX. כדי שניתן יהיה להשתמש בכלי השירות של TCP/IP, יש להתקין את פרוטוקול הרשת TCP/IP. לקבלת מידע אודות הפעלה של שירותי TCP/IP משורת הפקודה, ראה Net start. לקבלת מידע אודות הפסקה של שירותי TCP/IP משורת הפקודה, ראה Net stop.

לקבלת מידע נוסף, לחץ על כלי שירות או על שירות:

  • Arp
  • Nslookup
  • Finger
  • Ping
  • Ftp
  • Rcp
  • Hostname
  • Rexec
  • Ipconfig
  • Route
  • Lpq
  • Rsh
  • Lpr
  • Tftp
  • Nbtstat
  • Tracert
  • Netstat


פקודות Telnet

פקודות telnet מאפשרות לך לקיים תקשורת עם מחשב מרוחק העושה שימוש בפרוטוקול Telnet. באפשרותך להפעיל את telnet ללא פרמטרים כדי להיכנס להקשר Telnet, שניתן לזהות באמצעות שורת הפקודה של Telnet‏ (telnet>‎). מתוך שורת הפקודה של Telnet, השתמש בפקודות הבאות כדי לנהל מחשב שפועל בו לקוח Telnet.

פקודות tlntadmn מאפשרות לך לנהל מרחוק מחשב שפועל בו Telnet Server. פקודות אלה מופעלות משורת הפקודה. כאשר נעשה שימוש ב- tlntadmn ללא פרמטרים, מוצגות הגדרות של השרת המקומי.

לשם שימוש בפקודות telnet בשורת הפקודה של Telnet

לשם הפעלת לקוח Telnet וכניסה לשורת הפקודה של Telnet

תחביר

telnet [\\RemoteServer]‎

פרמטרים

‎\\RemoteServer
ציון שם השרת שברצונך להתחבר אליו.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • כאשר נעשה שימוש ב- telnet ללא פרמטרים, לקוח Telnet מופעל.
  • בעת העבודה בשורת הפקודה של Telnet, עליך להשתמש בפקודות Telnet.

לשם עצירת לקוח Telnet

תחביר

quit

פרמטרים

ללא

הערות

  • באפשרותך לקצר פקודה זו ל- q.

לשם חיבור של לקוח Telnet למחשב מרוחק

תחביר

open [\\RemoteServer] [Port]‎

פרמטרים

‎\\RemoteServer
ציון שם השרת שברצונך לנהל. אם לא תציין שרת, המערכת מניחה שכוונתך לשרת המקומי.
Port
ציון היציאה שברצונך להשתמש בה. אם לא תציין יציאה, המערכת מניחה שכוונתך ליציאה המשמשת כברירת מחדל.

הערות

  • באפשרותך לקצר פקודה זו ל- o.

דוגמאות

כדי להתחבר לשרת המרוחק Redmond באמצעות יציאה מספר 44, הקלד:
o redmond 44

לשם ניתוק של לקוח Telnet ממחשב מרוחק

תחביר

close [\\RemoteServer]‎

פרמטרים

‎\\RemoteServer
ציון שם השרת שברצונך לנהל. אם לא תציין שרת, המערכת מניחה שכוונתך לשרת המקומי.

הערות

  • באפשרותך לקצר פקודה זו ל- c.

דוגמאות

כדי להתנתק מן השרת המרוחק Redmond , הקלד:
c redmond 44

לשם קביעת אפשרויות של לקוח Telnet

תחביר

set [\\RemoteServer]‎ ‎[ntlm]‎ ‎[localecho]‎ ‎[term {ansi | vt100 | vt52 | vtnt}]‎ ‎[escape Character]‎ ‎[logfile FileName]‎ ‎[logging]‎ ‎[bsasdel]‎ ‎[crlf]‎ ‎[delasbs]‎ ‎[mode {console | stream}]‎ ‎[?]‎

פרמטרים

‎\\RemoteServer
ציון שם השרת שברצונך לנהל. אם לא תציין שרת, המערכת מניחה שכוונתך לשרת המקומי.
ntlm
הפעלה של אימות NTLM במידה שהוא זמין בשרת המרוחק.
localecho
הפעלה של הד מקומי.
term {ansi | vt100 | vt52 | vtnt}‎
קביעת המסוף לסוג שצוין.
escape Character
קביעת תו היציאה. תו היציאה עשוי להיות תו יחיד או צירוף של מקש CTRL ותו נוסף. כדי לקבוע צירוף של מקשים עבור שליטה, החזק את מקש CTRL לחוץ בעת הקלדת התו שברצונך להקצות.
logfile FileName
קביעת הקובץ שישמש עבור כניסה לפעילות Telnet. על קובץ יומן הרישום להימצא במחשב המקומי. הרישום מתחיל באופן אוטומטי בעת קביעת אפשרות זו.
logging
הפעלת הרישום. אם לא נקבע קובץ יומן רישום, תופיע הודעת שגיאה.
bsasdel
קביעה כי BACKSPACE יישלח כמחיקה.
crlf
קביעת מצב השורה החדש, דבר הגורם למקש ENTER לשלוח 0x0D,‏ 0x0A.
delasbs
קביעה כי DELETE יישלח כ- Backspace.
mode {console | stream}‎
קביעת מצב הפעולה.
?
מתן אפשרות להצגת התחביר המלא של פקודה זו.

הערות

  • כדי לבטל אפשרות שנקבעה קודם לכן, בשורת הפקודה של Telnet, הקלד:

    unset [Option]‎

  • כדי לקבוע את תו היציאה, הקלד:

    ‎–e Character

  • בגירסאות Telnet שאינן באנגלית, codeset Option זמין. Codeset Option קובע את ערכת הקודים הנוכחית לאפשרות שעשויה להיות אחת מהבאות: Shift JIS,‏ Japanese EUC,‏ JIS Kanji,‏ JIS Kanji (78)‎,‏ DEC Kanji,‏ NEC Kanji. עליך לקבוע את אותה ערכת קודים במחשב המרוחק.

לשם שליחת פקודות של לקוח Telnet

תחביר

send [\\RemoteServer]‎ ‎[ao]‎ ‎[ayt]‎ ‎[esc]‎ ‎[ip]‎ ‎[synch]‎ ‎[?]‎

פרמטרים

‎\\RemoteServer
ציון שם השרת שברצונך לנהל. אם לא תציין שרת, המערכת מניחה שכוונתך לשרת המקומי.
ao
ביטול של פקודת פלט.
ayt
שליחת פקודה מסוג "Are you there?‎".
esc
שליחת תו היציאה הנוכחי.
ip
הפסקה של פקודת התהליך.
synch
ביצוע פעולת הסינכרון של Telnet.
?
מתן אפשרות להצגת התחביר המלא עבור פקודה זו.

לשם הצגת ההגדרות הנוכחיות עבור לקוח Telnet

תחביר

display

פרמטרים

ללא

הערות

  • פקודת התצוגה מפרטת את הפרמטרים הפועלים כעת עבור לקוח Telnet. אם מתבצעת כעת הפעלת Telnet (במילים אחרות, אם אתה מחובר לשרת Telnet), באפשרותך לצאת מהפעלת Telnet כדי לשנות את הפרמטרים על-ידי הקשה על CTRL+]‎. כדי לחזור להפעלת Telnet, הקש ENTER.

לשם שימוש בפקודות tlntadmn בשורת הפקודה

לשם ניהול מחשב שפועל בו Telnet Server

תחביר

tlntadmn [\\RemoteServer] [start] [stop] [pause] [continue]‎

פרמטרים

‎\\RemoteServer
ציון שם השרת שברצונך לנהל. אם לא תציין שרת, המערכת מניחה שכוונתך לשרת המקומי.
start
הפעלת Telnet Server.
stop
כיבוי Telnet Server.
pause
הפסקת Telnet Server.
continue
חידוש ההפעלה של Telnet Server.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • באפשרותך לנהל באופן מרוחק מחשב שפועל בו Telnet Server באמצעות פקודות tlntadmn אם בשני המחשבים פועל Windows XP. אין באפשרותך להשתמש בפקודות tlntadmn כדי לנהל מרחוק מחשב שפועלים בו Windows 2000 ו- Telnet Server ממחשב שפועל בו Windows XP.

לשם ניהול של הפעלות Telnet

תחביר

tlntadmn [\\RemoteServer] [-s] [-k{SessionID | all}]‎ ‎[-m {SessionID | all} "Message"]‎

פרמטרים

‎\\RemoteServer
ציון שם השרת שברצונך לנהל. אם לא תציין שרת, המערכת מניחה שכוונתך לשרת המקומי.
‎-s
הצגת הפעלות פעילות של Telnet.
‎-k{SessionID | all}‎
סיום הפעלות. הקלד את מזהה ההפעלה (SessionID) כדי לסיים הפעלה מסוימת או הקלד all כדי לסיים את כל ההפעלות.
‎-m {SessionID | all} "Message"‎
שליחת הודעה להפעלה אחת או יותר. הקלד את מזהה ההפעלה כדי לשלוח הודעה להפעלה מסוימת או הקלד all כדי לשלוח הודעה לכל ההפעלות. הקלד את ההודעה שברצונך לשלוח בתוך מרכאות (כלומר, "הודעה").
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • באפשרותך לנהל באופן מרוחק מחשב שפועל בו Telnet Server באמצעות פקודות tlntadmn אם בשני המחשבים פועל Windows XP. אין באפשרותך להשתמש בפקודות tlntadmn כדי לנהל מרחוק מחשב שפועלים בו Windows 2000 ו- Telnet Server ממחשב שפועל בו Windows XP.

לשם קביעת אפשרויות רישום במחשב שפועל בו Telnet Server

תחביר

tlntadmn [\\RemoteServer] config [auditlocation={eventlog | file | both}]‎ ‎[audit=[{+ | -}admin][{+ | -}user][{+ | -}fail]]‎

פרמטרים

‎\\RemoteServer
ציון שם השרת שברצונך לנהל. אם לא תציין שרת, המערכת מניחה שכוונתך לשרת המקומי.
auditlocation={eventlog | file | both}‎
קביעה אם יש לשלוח מידע אירוע למציג האירועים, לקובץ או לשניהם.
audit=[{+ | -}admin][{+ | -}user][{+ | -}fail]‎
ציון האירועים שברצונך לבצע ביקורת עליהם (אירועי כניסה ניהוליים, אירועי כניסה של משתמש או נסיונות כניסה כושלים). כדי לבקר אירועים מסוג מסוים, הקלד סימן חיבור (+) לפני סוג האירוע. כדי להפסיק את ביצוע הביקורת עבור אירועים מסוג מסוים, הקלד סימן חיסור (-) לפני סוג האירוע.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • באפשרותך לנהל באופן מרוחק מחשב שפועל בו Telnet Server באמצעות פקודות tlntadmn אם בשני המחשבים פועל Windows XP. אין באפשרותך להשתמש בפקודות tlntadmn כדי לנהל מרחוק מחשב שפועלים בו Windows 2000 ו- Telnet Server ממחשב שפועל בו Windows XP.
  • אם ציינת את המיקום שאליו יש לשלוח מידע אירוע מבלי לציין עבור איזה סוג או סוגים של מידע יש לבצע ביקורת, תתבצע ביקורת רק על מידע אודות אירועי כניסה ניהוליים בלבד, ומידע זה יישלח למיקום שציינת.

דוגמאות

כדי לשלוח מידע אודות אירוע למציג האירועים, הקלד:

tlntadmn config auditlocation=eventlog

כדי לבצע ביקורת עבור אירועי כניסה ניהוליים ונסיונות כניסה שכשלו, הקלד:

tlntadmn config audit=+admin +fail

לשם קביעה של קבוצת המחשבים שתשמש כברירת המחדל במחשב שפועל בו Telnet Server

תחביר

tlntadmn [\\RemoteServer] config [dom=DomainName]‎

פרמטרים

‎\\RemoteServer
ציון שם השרת שברצונך לנהל. אם לא תציין שרת, המערכת מניחה שכוונתך לשרת המקומי.
dom=DomainName
ציון קבוצת המחשבים שברצונך להפוך לקבוצת המחשבים שתשמש כברירת המחדל.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • באפשרותך לנהל באופן מרוחק מחשב שפועל בו Telnet Server באמצעות פקודות tlntadmn אם בשני המחשבים פועל Windows XP. אין באפשרותך להשתמש בפקודות tlntadmn כדי לנהל מרחוק מחשב שפועלים בו Windows 2000 ו- Telnet Server ממחשב שפועל בו Windows XP.

דוגמאות

כדי להפוך את Redmond לקבוצת המחשבים המשמשת כברירת המחדל בשרת המקומי שלך, הקלד:

tlntadmn config dom=Redmond

לשם מיפוי המקש Alt במחשב שפועל בו Telnet Server

תחביר

tlntadmn [\\RemoteServer] config [ctrlakeymap={yes | no}]‎

פרמטרים

‎\\RemoteServer
ציון שם השרת שברצונך לנהל. אם לא תציין שרת, המערכת מניחה שכוונתך לשרת המקומי.
ctrlakeymap={yes | no}‎
קביעה אם ברצונך ש- Telnet Server יתרגם את CTRL+A כ- ALT. הקלד yes כדי למפות את מקש הקיצור. לחלופין, הקלד no כדי למנוע מיפוי.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • באפשרותך לנהל באופן מרוחק מחשב שפועל בו Telnet Server באמצעות פקודות tlntadmn אם בשני המחשבים פועל Windows XP. אין באפשרותך להשתמש בפקודות tlntadmn כדי לנהל מרחוק מחשב שפועלים בו Windows 2000 ו- Telnet Server ממחשב שפועל בו Windows XP.
  • אם לא תמפה את מקש ALT,‏ Telnet Server לא ישלח את מקש ALT ליישומים העשויים להסתמך על מקש זה.

לשם קביעת מספר ההתקשרויות המירבי במחשב שפועל בו Telnet Server

תחביר

tlntadmn [\\RemoteServer] config [maxconn=PositiveInteger]‎

פרמטרים

‎\\RemoteServer
ציון שם השרת שברצונך לנהל. אם לא תציין שרת, המערכת מניחה שכוונתך לשרת המקומי.
maxconn=PositiveInteger
קביעת מספר ההתקשרויות המירבי. עליך לציין מספר זה באמצעות מספר שלם חיובי הקטן מ- 10 מיליון.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • באפשרותך לנהל באופן מרוחק מחשב שפועל בו Telnet Server באמצעות פקודות tlntadmn אם בשני המחשבים פועל Windows XP. אין באפשרותך להשתמש בפקודות tlntadmn כדי לנהל מרחוק מחשב שפועלים בו Windows 2000 ו- Telnet Server ממחשב שפועל בו Windows XP.

לשם קביעת המספר המירבי של נסיונות כניסה כושלים במחשב שפועל בו Telnet Server

תחביר

tlntadmn [\\RemoteServer] config [maxfail=PositiveInteger]‎

פרמטרים

‎\\RemoteServer
ציון שם השרת שברצונך לנהל. אם לא תציין שרת, המערכת מניחה שכוונתך לשרת המקומי.
maxfail=PositiveInteger
ציון המספר המירבי של נסיונות כניסה כושלים המותרים למשתמש. עליך לציין מספר זה באמצעות מספר שלם חיובי הקטן מ- 100.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • באפשרותך לנהל באופן מרוחק מחשב שפועל בו Telnet Server באמצעות פקודות tlntadmn אם בשני המחשבים פועל Windows XP. אין באפשרותך להשתמש בפקודות tlntadmn כדי לנהל מרחוק מחשב שפועלים בו Windows 2000 ו- Telnet Server ממחשב שפועל בו Windows XP.

לשם קביעת המצב של פעולה במחשב שפועל בו Telnet Server

תחביר

tlntadmn [\\RemoteServer] config [mode={console | stream}]‎

פרמטרים

‎\\RemoteServer
ציון שם השרת שברצונך לנהל. אם לא תציין שרת, המערכת מניחה שכוונתך לשרת המקומי.
mode={console | stream}‎
ציון מצב הפעולה.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • באפשרותך לנהל באופן מרוחק מחשב שפועל בו Telnet Server באמצעות פקודות tlntadmn אם בשני המחשבים פועל Windows XP. אין באפשרותך להשתמש בפקודות tlntadmn כדי לנהל מרחוק מחשב שפועלים בו Windows 2000 ו- Telnet Server ממחשב שפועל בו Windows XP.

לשם קביעה של יציאת Telnet במחשב שפועל בו Telnet Server

תחביר

tlntadmn [\\RemoteServer] config [port=IntegerValue]‎

פרמטרים

‎\\RemoteServer
ציון שם השרת שברצונך לנהל. אם לא תציין שרת, המערכת מניחה שכוונתך לשרת המקומי.
port=IntegerValue
קביעה של יציאת Telnet. עליך לציין את היציאה באמצעות מספר שלם הקטן מ- 1,024.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • באפשרותך לנהל באופן מרוחק מחשב שפועל בו Telnet Server באמצעות פקודות tlntadmn אם בשני המחשבים פועל Windows XP. אין באפשרותך להשתמש בפקודות tlntadmn כדי לנהל מרחוק מחשב שפועלים בו Windows 2000 ו- Telnet Server ממחשב שפועל בו Windows XP.

לשם קביעה של שיטות האימות במחשב שפועל בו Telnet Server

תחביר

tlntadmn [\\RemoteServer] config [sec=[{+ | -}ntlm][{+ | -}passwd]]‎

פרמטרים

‎\\RemoteServer
ציון שם השרת שברצונך לנהל. אם לא תציין שרת, המערכת מניחה שכוונתך לשרת המקומי.
sec=[{+ | -}ntlm][{+ | -}passwd]‎
קביעה אם ברצונך להשתמש ב- NTLM, בסיסמה או בשניהם כדי עבור ביצוע אימות של נסיונות כניסה. כדי להשתמש בסוג מסוים של אימות, הקלד סימן חיבור (+) לפני סוג זה של אימות. כדי למנוע שימוש בסוג מסוים של אימות, הקלד סימן חיסור (-) לפני סוג זה של אימות.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • באפשרותך לנהל באופן מרוחק מחשב שפועל בו Telnet Server באמצעות פקודות tlntadmn אם בשני המחשבים פועל Windows XP. אין באפשרותך להשתמש בפקודות tlntadmn כדי לנהל מרחוק מחשב שפועלים בו Windows 2000 ו- Telnet Server ממחשב שפועל בו Windows XP.
  • NTLM הוא פרוטוקול האימות עבור טרנזקציות בין שני מחשבים כאשר במחשב אחד או בשניהם פועל Windows NT 4.0 או גירסה מוקדמת יותר. בנוסף, NTLM הוא פרוטוקול האימות עבור מחשבים שאינם משתתפים בקבוצת מחשבים, כגון שרתים עצמאיים וקבוצות עבודה.

לשם קביעת הזמן הקצוב עבור הפעלות לא פעילות במחשב שפועל בו Telnet Server

תחביר

tlntadmn [\\RemoteServer] config [timeout=hh:mm:ss]‎

פרמטרים

‎\\RemoteServer
ציון שם השרת שברצונך לנהל. אם לא תציין שרת, המערכת מניחה שכוונתך לשרת המקומי.
timeout=hh:mm:ss
קביעה של פרק הזמן הקצוב בשעות, דקות ושניות.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • באפשרותך לנהל באופן מרוחק מחשב שפועל ב Telnet Server באמצעות פקודות tlntadmn אם בשני המחשבים פועל Windows XP. אין באפשרותך להשתמש בפקודות tlntadmn כדי לנהל מרחוק מחשב שפועלים בו Windows 2000 ו- Telnet Server ממחשב שפועל בו Windows XP.

הערות

  • כדי לעבור מלקוח Telnet למצב פקודה, בשורת הפקודה של Telnet, הקש CTRL+ ]‎. כדי לעבור בחזרה ללקוח Telnet, הקש ENTER.


Tftp

העברת קבצים אל מחשב מרוחק וממנו, בדרך כלל מחשב UNIX שפועל בו השירות או ה- Daemon הנקרא Trivial File Transfer Protocol ‏(TFTP). כאשר נעשה שימוש ב- tftp ללא פרמטרים, מוצגת עזרה.

תחביר

tftp [-i] [Host] [{get | put}] [Source] [Destination]‎

פרמטרים

‎-i
ציון של מצב העברת תמונה בינארי (נקרא גם מצב Octet). במצב תמונה בינארי, הקובץ מועבר ביחידות של בית אחד. השתמש במצב זה בעת העברת קבצים בינאריים. אם ‎-i הושמט, הקובץ מועבר במצב ASCII. זהו מצב ההעברה המשמש כברירת המחדל. מצב זה ממיר את תווי סוף השורה (EOL) לתבנית ראויה עבור המחשב שצוין. השתמש במצב זה בעת העברה של קבצי טקסט. אם העברת קובץ מתבצעת בהצלחה, מוצג קצב העברת הנתונים.
Host
ציון של המחשב המקומי או של המחשב המרוחק.
put
העברת קובץ היעד (Destination) שבמחשב המקומי לקובץ המקור (Source) שבמחשב המרוחק. מכיוון שפרוטוקול ה- TFTP אינו תומך באימות משתמש, על המשתמש לבצע כניסה למחשב המרוחק ועל הקבצים להיות ניתנים לכתיבה במחשב המרוחק.
get
העברת קובץ היעד (Destination) שבמחשב המרוחק לקובץ המקור (Source) שבמחשב המקומי.
Source
ציון הקובץ המיועד להעברה.
Destination
ציון המיקום שאליו יש להעביר את הקובץ. אם לא נעשה שימוש בפרמטר Destination, ההנחה היא כי שם היעד זהה לשם המקור (Source).
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • שימוש בפרמטר get

    ציין put אם ברצונך להעביר קובץ FileTwo במחשב המקומי לקובץ FileOne במחשב מרוחק. ציין get אם ברצונך להעביר קובץ FileTwo במחשב המרוחק לקובץ FileOne במחשב המרוחק.

  • Windows XP או Windows 2000 אינם מספקים שרת TFTP למטרה כללית. Windows 2000 מספק שירות שרת של TFTP רק כדי לספק יכולות אתחול מרוחקות למחשבי לקוח של Windows XP ו- Windows 2000 .
  • פקודה זו זמינה רק אם הפרוטוקול Internet Protocol ‏(TCP/IP) מותקן כרכיב במאפיינים של מתאם רשת בחיבורי רשת.

דוגמאות

כדי להעביר את הקובץ Users.txt מהמחשב המקומי לקובץ Users19.txt במחשב מרוחק הנקרא vax1, הקלד:

tftp vax1 put users.txt users19.txt


Time

הצגה או קביעה של שעת המערכת. כאשר נעשה שימוש ב- time ללא פרמטרים, מוצגת שעת המערכת ובקשה להזנת שעה חדשה.

תחביר

time [/t] [/time]‎ ‎[hours:[minutes[:seconds[.hundredths]]][{A|P}]]‎

פרמטרים

‎/t
הצגת שעת המערכת הנוכחית, ללא בקשה להזנת שעה חדשה.
‎/time
זהה ל-‎/t.
hours
ציון השעה. ערכים חוקיים נעים בין 0 ל- 23.
minutes
ציון דקות. ערכים חוקיים נעים בין 0 ל- 59.
seconds
ציון שניות. ערכים חוקיים נעים בין 0 ל- 59.
hundredths
ציון של מאיות שניה. ערכים חוקיים נעים בין 0 ל- 99.
‎{A|P}‎
ציון A.M (לפנה"צ) או P.M (אחה"צ) עבור תבנית שעה של 12 שעות. אם תקליד זמן חוקי בתבנית של 12 שעות אך לא תקליד A או P, הפקודה time תעשה שימוש ב- A לציון A.M.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • בעת השימוש ב- time ללא פרמטרים, הקש ENTER כדי לשמור על אותה שעה.
  • שימוש בפרמטר ‎/t

    אפשרות שורת הפקודה ‎/t זמינה רק אם הרחבות פקודה הפכו לזמינות (כלומר, ברירת המחדל). לקבלת מידע נוסף אודות הפיכה של הרחבות פקודה לזמינות או ללא זמינות, ראה cmd בנושאים קרובים.

  • ציון תבנית זמן לא חוקית

    אם תציין את השעה בתבנית לא חוקית, תוצג ההודעה הבאה והמערכת תמתין להזנה של השעה בתבנית הנכונה:

    Invalid time
    Enter new time:_‎

  • שינוי תבנית השעה

    באפשרותך לשנות את תבנית time על-ידי שינוי ההגדרה ב- Date and Time בלוח הבקרה. עבור מערכת המשנה MS-DOS בלבד, שנה את ההגדרה country בקובץ Config.nt. בהתאם למדינה/אזור שתבחר, השעה תוצג בתבנית של 12 שעות או בתבנית של 24 שעות. אם תקבע את השעה בתבנית של 12 שעות, ציין P עבור שעות אחר-הצהריים.

דוגמאות

כדי לכוון את שעון המחשב לשעה ‎1:36 P.M.‎, הקלד אחת מהפקודות הבאות:

time 13:36

time 1:36P


W32tm

כלי המשמש לאבחון בעיות המתרחשות בשירות Windows Time

תחביר

‎{/config [/computer:ComputerName] [ [/update] [/manualpeerlist:ListOfComputerNames] ] [/syncfromflags:ListOfFlags] ]|/monitor|/ntte|/ntpte|/register|‎‎/resync [{:ComputerName] [/nowait]|[/rediscover}]|/tz|/unregister}‎

פרמטרים

‎/config [/computer:ComputerName] [ [/update] [/manualpeerlist:ListOfComputerNames] ] [/syncfromflags:ListOfFlags]‎
התאמה של הגדרות השעה במחשב המקומי או במחשב היעד. ניתן להגדיר מחשבים עמיתים של סנכרון שעה באמצעות הבורר ‎/manualpeerlist. שינויים בתצורה אינם משמשים את Windows Time אלא אם השירות מופעל מחדש, או שנעשה שימוש בבורר ‎/update. ניתן להשתמש ב- ‎/syncfromflags כדי לקבוע את סוגי המקורות המשמשים לסנכרון וניתן לקבוע אותם למצב MANUAL כדי להשתמש ברשימה הידנית עבור מחשב עמית או ל- DOMHIER כדי לסנכרן מבקר של קבוצת מחשבים.
‎/monitor
פיקוח על מחשב היעד או על רשימה של מחשבים.
‎/ntte
המרת שעת מערכת של NT לתבנית הניתנת לקריאה.
‎/ntpte
המרה של שעת NTP לתבנית הניתנת לקריאה.
‎/register
רישום להפעלה כשירות והוספת תצורה המשמשת כברירת מחדל לרישום.
‎/resync [{:ComputerName] [/nowait]|[/rediscover}]‎
סינכרון מחדש של השעון בהקדם האפשרי תוך התעלמות מכל סטטיסטיקת השגיאה שהצטברה. אם לא צוין מחשב, המחשב המקומי יסונכרן מחדש. הפקודה תמתין לסנכרון מחדש אלא אם כן נעשה שימוש במתג ‎/nowait. יעשה שימוש במשאבי שעה בהם נעשה שימוש כרגע אלא אם כן נעשה שימוש ב- ‎/rediscover, אשר יכפה זיהוי מחדש של משאבי רשת לפני ביצוע של סנכרון מחדש.
‎/tz
הצגת ההגדרות של אזור הזמן הנוכחי.
‎/unregister
ביטול הרישום לשירות והסרה של כל מידע התצורה מהרישום.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • כלי זה נועד לשימוש של מנהלי רשת עבור איבחון בעיות ב- Windows Time.

    לקבלת מידע נוסף, ראה net time בנושאים קרובים.

  • כדי שהשירות Windows Time יעשה שימוש בשינויים שבוצעו באמצעות W32tm, על השירות לקבל הודעה על השינויים. כדי ליידע את השירות Windows Time אודות שינויים, הקלד w32tm /config /update בשורת הפקודה.

דוגמאות

כדי להציג את ההגדרות של אזור הזמן הנוכחי, הקלד:

w32tm /tz


Title

יצירת כותרת עבור חלון שורת הפקודה.

תחביר

title [string]‎

פרמטרים

string
ציון הכותרת עבור חלון שורת הפקודה.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • כדי להשתמש בכותרת החלון עבור תוכניות אצווה, כלול את הפקודה title בתחילתה של תוכנית אצווה.
  • לאחר שנקבעה, ניתן לאפס את כותרת החלון באמצעות הפקודה title בלבד.

דוגמאות

כדי להגדיר כותרת חלון עבור תוכנית אצווה, הקלד:

rem This batch program updates the employee data:‎
cls
‎@echo off
title Updating Files
copy \\server\share\*.xls c:\users\common\*.xls
echo Files Updated.‎
title Command Prompt


Tracert

קביעת הנתיב אל יעד מסוים על-ידי שליחה של הודעות Internet Control Message Protocol ‏(ICMP) מסוג Echo Request אל היעד עם ערכי שדה של Time to Live ‏(TTL) העולים בהפרשים קבועים. הנתיב המוצג הוא רשימה של ממשקי הנתב הקרובים לנתבים בנתיב שבין מחשב מארח המשמש כמקור לבין יעד. הממשק הקרוב הוא הממשק של הנתב הקרוב ביותר למחשב המארח השולח שבנתיב. כאשר נעשה שימוש בפקודה tracert ללא פרמטרים, מוצגת עזרה.

תחביר

tracert‎[-d]‎ ‎[-h MaximumHops]‎ ‎[-j HostList]‎ ‎[-w Timeout] [TargetName]‎

פרמטרים

‎-d
פרמטר זה מונע מהפקודה tracert לבצע ניסיון לפענח כתובות IP של נתבי ביניים לשמותיהם. פעולה זו עשויה לזרז את הצגת תוצאות הפקודה tracert.
‎-h MaximumHops
פרמטר זה מציין את המספר המקסימלי של דילוגים בנתיב לשם חיפוש אחר היעד. ברירת המחדל היא 30 דילוגים.
‎-j HostList
פרמטר זה מציין כי הודעות Echo Request משתמשות באפשרות Loose Source Route בכותרת IP עם קבוצת יעדי הביניים שצוינו ב- HostList. באמצעות ניתוב מקורות חופשי, ניתן להפריד יעדי ביניים רצופים באמצעות נתב אחד או באמצעות נתבים מרובים. המספר המירבי של כתובות או שמות ברשימת המחשבים המארחים הוא 9. HostList הוא סידרה של כתובות IP (המסומנות כערך דצימאלי עם נקודות) המופרדות באמצעות רווחים.
‎-w Timeout
ציון פרק הזמן, באלפיות שניה, שבמהלכו יש להמתין לקבלה של הודעת Echo Reply או ICMP Time Exceeded המתאימה להודעת Echo Request נתונה. אם לא התקבלה הודעה במהלך פרק הזמן שהוגדר, מוצגת כוכבית (*). פרק הזמן המוגדר כברירת מחדל הוא 4000 (4 שניות).
TargetName
פרמטר זה מציין את היעד, המזוהה באמצעות כתובת IP או באמצעות שם מחשב מארח.
‎-?‎
הצגת עזרה בשורת הפקודה.

הערות

  • כלי אבחוני זה קובע את הנתיב אל יעד מסוים באמצעות שליחת הודעות ICMP Echo Request הכוללות ערכים משתנים של Time to Live ‏(TTL) אל היעד. כל נתב לאורך הנתיב נדרש לצמצם את ערך ה- TTL שבמנת IP ב- 1 לפחות לפני העברתו. בצורה יעילה, ה- TTL מהווה מונה קישורים מקסימליים. כאשר ערך TTL במנה מגיע ל- 0, הנתב אמור לשלוח בחזרה הודעת Time Exceeded של ICMP למחשב המקור. הפקודה Tracert קובעת את הנתיב על-ידי שליחה של הודעת Echo Request הראשונה עם ערך TTL של 1 והעלאת ערך ה- TTL בהפרשים קבועים של 1 בכל שידור עוקב עד שהיעד מגיב או עד שנמצא מספר הדילוגים המירבי. המספר המקסימלי של דילוגים הוא 30 כברירת מחדל וניתן לקבוע אותו באמצעות הפרמטר ‎-h. הנתיב נקבע על-ידי בדיקת הודעות ICMP Time Exceeded המוחזרות על-ידי נתבי ביניים והודעת Echo Reply המוחזרת על-ידי היעד. עם זאת, חלק מהנתבים אינם מחזירים הודעות Time Exceeded עבור מנות עם ערכי TTL שפג תוקפם ושאינם נראים לפקודה Tracert. במקרה זה, מוצגת שורה של כוכביות (*) עבור דילוג זה.
  • כדי לעקוב אחר נתיב ולספק השהיית רשת ואובדן מנות עבור כל נתב וקישור בנתיב, השתמש בפקודה pathping.
  • פקודה זו זמינה רק אם פרוטוקול ‎Internet Protocol (TCP/IP)‎ הותקן כרכיב במאפיינים של מתאם רשת בחיבורי רשת.

דוגמאות

כדי למצוא מהו הנתיב אל המחשב המארח הנקרא corp7.microsoft.com, הקלד:

tracert corp7.microsoft.com

כדי למצוא מהו הנתיב של המחשב המארח הנקרא corp7.microsoft.com ולמנוע פענוח של כל כתובת IP לשמה, הקלד:

tracert -d corp7.microsoft.com

כדי למצוא מהו הנתיב אל המחשב המארח הנקרא corp7.microsoft.com ולהשתמש בנתב המקור החופשי ‎10.12.0.1-10.29.3.1-10.1.44.1, הקלד:

tracert -j 10.12.0.1 10.29.3.1 10.1.44.1 corp7.microsoft.com


Tree

הצגה גרפית של מבנה הספריה של נתיב או של הדיסק הנמצא בכונן.

תחביר

tree [Drive:]‎‎[Path]‎ ‎[/f]‎ ‎[/a]‎

פרמטרים

Drive:‎
ציון הכונן המכיל את הדיסק שעבורו ברצונך להציג את מבנה הספריה.
Path
ציון הספריה שעבורה ברצונך להציג את מבנה הספריה.
‎/f
הצגת שמות הקבצים בכל ספריה.
‎/a
פרמטר זה מציין כי על tree להשתמש בתווי טקסט במקום בתווים גרפיים לשם הצגת הקווים המקשרים ספריות משנה.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • המבנה המוצג באמצעות הפקודה tree תלוי בפרמטרים שצוינו בשורת הפקודה. אם לא תציין כונן או נתיב, הפקודה tree תגרום להצגת מבנה העץ שראשיתו בספריה הנוכחית בכונן הנוכחי.

דוגמאות

כדי להציג את השמות של כל ספריות המשנה בדיסק הנמצא בכונן הנוכחי, הקלד:

tree \‎

כדי להציג את הקבצים הנמצאים בכל הספריות שבכונן C, מסך אחד בכל פעם, הקלד:

tree c:\ /f | more

כדי להדפיס את הרשימה שהוצגה בדוגמה לעיל, הקלד:

tree c:\ /f prn


פקודות Change של Terminal Services

לקבלת מידע נוסף אודות פקודות Change של Terminal Services, עיין בנושאים הבאים:

  • Change Logon
  • Change Port
  • Change User


Change logon

פקודה זו מאפשרת או מונעת ביצוע כניסה מתוך הפעלות לקוח, או מציגה את מצב הכניסה הנוכחי. כלי שירות זה עשוי להימצא שימושי עבור תחזוקת המערכת.

תחביר

change logon ‎{/enable|/disable|/query}‎

פרמטרים

‎/enable
פרמטר זה מאפשר ביצוע כניסות מתוך הפעלות לקוח, אך לא מתוך המסוף.
‎/disable
פרמטר זה מונע ביצוע של כניסות מהפעלות לקוח, אך מאפשר ביצוע כניסה מהמסוף. משתמשים שכבר מחוברים למערכת אינם מושפעים מכך.
‎/query
פרמטר זה מציג את מצב הכניסה הנוכחי, בין אם הוא זמין ובין אם לאו.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • רק לחברים בקבוצה Administrators יש אפשרות להשתמש בפקודה change logon.
  • ביצוע הכניסה מתאפשר שוב לאחר הפעלה מחדש של המערכת. אם התחברת לשרת המסוף מתוך הפעלה של לקוח והפכת את אפשרויות הכניסה לבלתי זמינות ולאחר מכן יצאת מהמערכת מבלי לאפשר שוב את ביצוע הכניסה, לא יהיה באפשרותך להתחבר שנית מתוך ההפעלה שלך. בצע כניסה במסוף כדי לחזור ולאפשר ביצוע כניסה מתוך הפעלות לקוח.


Change port

פקודה זו מפרטת או משנה מיפויים של יציאת COM כדי להפוך אותם לתואמים עבור יישומי MS-DOS .

תחביר

change port ‎[{portx=porty|/d portx|/query}]‎

פרמטרים

portx=porty
פרמטר זה ממפה יציאת COM שמספרה x ליציאה porty.
‎/d portx
פרמטר זה מוחק את המיפוי עבור יציאת COM שמספרה x.
‎/query
פרמטר זה מציג את מיפויי היציאות הנוכחיים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • מרבית יישומי MS-DOS תומכים רק ביציאות הטוריות COM1 עד COM4. הפקודה change port ממפה יציאה טורית למספר יציאה שונה ובכך מאפשרת ליישומים שאינם תומכים ביציאות COM בעלות מספר גבוה לבצע גישה ליציאה הטורית. לדוגמה, כדי למפות את COM12 ל- COM1 לשימוש ביישומים מבוססי MS-DOS, הקלד change port com12=com1. מיפוי מחדש פועל רק עבור ההפעלה הנוכחית ואינו נשמר אם תצא מההפעלה ותיכנס אליה שנית.
  • השתמש בפקודה change port ללא כל פרמטרים כדי להציג את יציאות COM הזמינות ואת המיפויים הנוכחיים שלהן.


Change user

שינוי ההגדרה עבור מיפוי של קבצי ‎.ini

תחביר

change user ‎{/execute | /install | /query}‎

פרמטרים

‎/execute
מאפשר מיפוי של קבצי ‎.ini לספריה הראשית. זוהי הגדרת ברירת המחדל.
‎/install
מבטל את מיפוי קבצי ‎.ini לספריה הראשית. כל קבצי ‎.ini נקראים ונכתבים בספריית המערכת. עליך לבטל מיפוי של קבצי ‎.ini בעת התקנת יישומים בשרת מסוף.
‎/query
מציג את ההגדרה הנוכחית עבור מיפוי קבצי ‎.ini.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • השתמש ב- change user /install לפני התקנת יישום כדי ליצור קבצי ‎.ini עבור יישום זה בספריית המערכת. קבצים אלה משמשים כעותקים ראשיים עבור קבצי ‎.ini ייחודיים למשתמש. לאחר התקנת היישום, השתמש ב- change user /execute כדי לחזור למיפוי סטנדרטי של קבצי ‎.ini.
  • בפעם הראשונה שאתה מפעיל את היישום, היישום מבצע חיפוש אחר קבצי ‎.ini שלו בספריה הראשית. אם הקבצים אינם נמצאים בספריה הראשית אך נמצאים בספריית המערכת, Terminal Services מעתיק את הקבצים לספריה הראשית ובכך מבטיח שלכל משתמש יהיו עותקים ייחודיים של קבצי ‎.ini של היישום. כל קובץ ‎.ini חדש נוצר בספריה הראשית.
  • רצוי שלכל משתמש יהיו עותקים ייחודיים של קבצי ‎.ini של יישום. דבר זה מונע מקרים שבהם למשתמשים שונים יהיו תצורות לא תואמות של יישומים (לדוגמה, ספריות ברירת מחדל שונות או רזולוציות מסך שונות).
  • כאשר המערכת במצב התקנה (change user /install), מתרחשים מספר דברים. כל ערכי הרישום הנוצרים מוצללים תחת HKEY_LOCAL_MACHINE‎\SOFTWARE\Microsoft\Windows NT‎\CurrentVersion\TerminalServer\Install. מפתחות המתווספים ל- HKEY_CURRENT_USER מועתקים תחת המפתח ‎\SOFTWARE ומפתחות המתווספים ל- HKEY_LOCAL_MACHINE מועתקים תחת ‎\MACHINE. אם היישום מבצע שאילתה על ספריית Windows באמצעות קריאות למערכת, כגון GetWindowsDirectory, שרת המסוף מחזיר את הספריה systemroot. אם מתבצעת הוספה של ערכי קובץ ‎.ini באמצעות קריאות למערכת, כגון WritePrivateProfileString, הם מתווספים לקבצי ‎.ini תחת הספריה systemroot.
  • כאשר המערכת חוזרת למצב הפעלה (change user /execute) והיישום מנסה לקרוא תחת HKEY_CURRENT_USER ערך רישום שאינו קיים, Terminal Services בודק האם עותק של המפתח קיים תחת המפתח ‎\TerminalServer‎\Install. אם קיים, המפתחות מועתקים למיקום המתאים תחת HKEY_CURRENT_USER. אם היישום מנסה לקרוא מקובץ ‎.ini שאינו קיים, Terminal Services מחפש אחר קובץ ‎.ini זה תחת בסיס המערכת. אם קובץ ה- ‎.ini נמצא בבסיס המערכת, הוא מועתק לספריית המשנה ‎\Windows של הספריה הראשית של המשתמש. אם היישום מבצע שאילתה על הספריה Windows, שרת המסוף מחזיר את ספריית המשנה ‎\Windows של הספריה הראשית של המשתמש.
  • בעת ביצוע כניסה למחשב, היישום Terminal Services בודק האם קבצי ‎.ini של מערכת שאוחסנו חדשים יותר מהקבצים במחשב שלך. אם גירסת המערכת חדשה יותר, קבצי ‎.ini של המשתמש מוחלפים או ממוזגים בגירסה החדשה. ביצוע הליך זה תלוי בהגדרת ‏0x40 עבור הסיבית INISYNC של קובץ ‎.ini זה, או באי-הגדרתה. הגירסה הקודמת של קובץ ה- ‎.ini נשמרת כ- Inifile.ctx. אם ערכי הרישום של המערכת תחת המפתח ‎\TerminalServer\Install חדשים יותר מהגירסה של המשתמש תחת HKEY_CURRENT_USER, גירסת המפתחות של המשתמש נמחקת והם מוחלפים במפתחות החדשים הנמצאים תחת ‎\TerminalServer\Install.


Cprofile

ניקוי הפרופילים שצוינו משטח שאינו מנוצל. במקרה שמבוטלים שיוכי קובץ ספציפיים למשתמש, גם הסרה של שיוכים אלה מהרישום. פרופילים הנמצאים כרגע בשימוש אינם עוברים שינוי.

תחביר

cprofile [/l]‎ ‎[/i]‎ ‎[/v]‎ ‎[FileList]‎

cprofile [/i]‎ ‎[/v] FileList

פרמטרים

‎/l
מנקה את כל הפרופילים המקומיים. כמו כן, באפשרותך לציין רשימה של פרופילים נוספים בפרמטר FileList.
‎/i
פעולה אינטראקטיבית עם המשתמש עבור כל פרופיל.
‎/v
מציג מידע אודות הפעולות המבצעות.
FileList
רשימה של קבצים שברצונך להסיר מהם שיוכי קבצים ספציפיים למשתמש. הפרד כל קובץ ברשימה באמצעות רווח. שמות קבצים יכולים להכיל תווים כלליים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • רק לחברים בקבוצה Administrators יש אפשרות להפעיל את cprofile.
  • שרת מסוף עושה שימוש בשיוכי קבצים כדי לקבוע באיזה יישום יש להשתמש כדי לבצע גישה לקבצים מסוגים שונים. סוגי קבצים נרשמים באמצעות סייר Windows.
  • שיוכי קבצים עבור כל משתמש מאפשרים לכל משתמש לבחור יישום אחר שישויך לסוג קובץ מסוים. לדוגמה, משתמש אחד עשוי לשייך קבצי ‎.doc ל- Microsoft Word ואחר עשוי לשייך קבצי ‎.doc לכתבן (Windows WordPad).
  • אם הופעלו שיוכי קובץ ייחודיים למשתמש, cprofile מסיר מפרופיל המשתמש רק את השטח שאינו בשימוש. אם בוטלו שיוכי קבצים ייחודיים למשתמש, cprofile מסיר גם את ערכי הרישום התואמים.


Flattemp

הפעלה או ביטול של תיקיות זמניות שטוחות.

תחביר

flattemp ‎{/query | /enable | /disable}‎

פרמטרים

‎/query
מבצע שאילתה על ההגדרה הנוכחית.
‎/enable
מפעיל תיקיות זמניות שטוחות.
‎/disable
מבטל הפעלת תיקיות זמניות שטוחות.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • לכל משתמש יש ספריה זמנית ייחודית. השתמש ב- flattemp /enable כדי לאפשר הפעלה של תיקיות זמניות שטוחות.
  • שיטת ברירת המחדל ליצירת תיקיות זמניות עבור משתמשים מרובים (בדרך כלל ההצבעה אליהן מתבצעת באמצעות משתני הסביבה TEMP ו- TMP) היא ליצור תיקיות משנה בתיקיה ‎\Temp ולהשתמש ב- logonID כשם עבור תיקיית המשנה. לדוגמה, אם משתנה הסביבה TEMP מצביע אל C:\Temp, התיקיה הזמנית המוקצית למשתמש logonID 4 היא C:\Temp\4. באמצעות flattemp, באפשרותך לבצע הצבעה ישירה לתיקיה ‎\Temp ולמנוע יצירה של תיקיות משנה. דבר זה שימושי כאשר ברצונך שהתיקיות הזמניות של משתמשים יאוחסנו בספריות ראשיות, בין אם בכונן מקומי של שרת מסוף ובין אם בכונן משותף ברשת. עליך להשתמש בפקודה זו רק כאשר לכל משתמש יש תיקיה זמנית נפרדת. לקבלת הוראות אודות שימוש בתיקיות זמניות לכל הפעלה, ראה לשם שימוש בתיקיות זמניות נפרדות עבור כל הפעלה.
  • עליך להיות בעל הרשאות ניהול (לרוב, חבר בקבוצה Administrators) כדי להפעיל את flattemp.
  • ייתכן שתיתקל בשגיאות יישום אם הספריה הזמנית של המשתמש נמצאת בכונן רשת. דבר זה מתרחש כאשר המיקום המשותף ברשת הופך לבלתי זמין ברשת לזמן מה. מכיוון שהקבצים הזמניים של היישום אינם נגישים או לא מסונכרנים, היישום מגיב כאילו הדיסק נעצר. העברת הספריה הזמנית לכונן רשת אינה מומלצת. ברירת המחדל היא אחסון ספריות זמניות בדיסק קשיח מקומי. אם בעת פעולה עם יישומים מסויימים נתקלת באופני פעולה בלתי צפויים או בשגיאות פגימה בדיסק, ייצב את הרשת או העבר את הספריות הזמניות לדיסק הקשיח המקומי.
  • המערכת מתעלמת מהגדרות flattemp אם ביטלת את השימוש בתיקיות זמניות לכל הפעלה. אפשרות זו נקבעת בתצורת שירותי מסוף.


Logoff

ניתוק משתמש מהפעלה ומחיקת ההפעלה מהשרת.

תחביר

logoff ‎[{SessionID|SessionName}]‎ ‎[/server:ServerName]‎ ‎[/v]‎

פרמטרים

SessionID
מציין את המזהה המספרי של ההפעלה עבור השרת.
SessionName
מציין את שם ההפעלה.
‎/server:ServerName
מציין את שרת המסוף המכיל את ההפעלה שאת המשתמש שלה ברצונך לנתק. אם לא צוין השרת, ייעשה שימוש בשרת שבו אתה פעיל כרגע.
‎/v
מציג מידע אודות הפעולות המבוצעות.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • תמיד באפשרותך להתנתק מהפעלה שביצעת כניסה אליה. עם זאת, עליך להיות בעל הרשאת Full Control כדי שיהיה באפשרותך לנתק משתמשים מהפעלות אחרות.
  • ניתוק משתמש מהפעלה ללא אזהרה מוקדמת עשוי לגרום לאובדן נתונים בהפעלת המשתמש. השתמש בפקודה msg כדי לשלוח למשתמש הודעה המתריאה על ניתוק ההפעלה לפני ניתוקה.
  • אם לא צוינו שם או מזהה עבור ההפעלה, תבצע הפקודה logoff ניתוק של המשתמש בהפעלה הנוכחית. אם ברצונך לציין שם הפעלה, ודא כי הפעלה זו פעילה.
  • בעת ניתוק משתמש מהפעלה, כל התהליכים של ההפעלה וההפעלה עצמה נמחקים מן השרת.
  • אין באפשרותך לנתק משתמש מהפעלת מסוף.

דוגמאות

כדי לנתק משתמש מההפעלה הנוכחית, הקלד:

logoff

כדי לנתק משתמש מהפעלה באמצעות מזהה ההפעלה, לדוגמה הפעלה 12, הקלד:

logoff 12

כדי לנתק משתמש מהפעלה באמצעות שם ההפעלה ושם השרת, לדוגמה הפעלה TERM04 בשרת WF12, הקלד:

logoff TERM04 /server:WF12


Msg

שליחת הודעה למשתמש.

תחביר

msg ‎{UserName|SessionName|SessionID|@FileName|*}‎ ‎[/server:ServerName]‎ ‎[/time:seconds]‎ ‎[/v]‎ ‎[/w]‎ ‎[message]‎

פרמטרים

UserName
שם המשתמש שברצונך שיקבל את ההודעה.
SessionName
שם ההפעלה שברצונך שתקבל את ההודעה.
SessionID
המזהה המספרי של ההפעלה שברצונך שהמשתמש שלה יקבל הודעה.
‎@FileName
מזהה קובץ המכיל רשימה של שמות משתמשים, שמות הפעלות ומזהי הפעלה שברצונך שיקבלו את ההודעה.
*
שולח את ההודעה לכל שמות המשתמשים במערכת.
‎/server:ServerName
מציין את שרת המסוף שברצונך שהפעלה או משתמש שלו יקבלו את ההודעה. אם לא צוין שרת, ‎/server יציין את השרת שאליו אתה מחובר כרגע.
‎/time:seconds
מציין את משך הזמן שבמהלכו ברצונך שההודעה הנשלחת תופיע על מסך המשתמש. לאחר שהסתיים הזמן שצוין, ההודעה נעלמת. אם לא נקבעת הגבלת זמן, ההודעה נשארת על המסך עד שהמשתמש מבחין בה ולוחץ על אישור.
‎/v
מציג מידע אודות הפעולות המבוצעות.
‎/w
ממתין לאישור קבלת ההודעה שיישלח מן המשתמש. השתמש בפרמטר זה יחד עם ‎/time:seconds כדי להימנע מהשהיה ארוכה, האפשרית במקרה שהמשתמש אינו מגיב מיד. שימוש בפרמטר זה יחד עם ‎/v שימושי אף הוא.
message
טקסט ההודעה שברצונך לשלוח. אם לא מוקלדת הודעה, תתבקש להקליד אחת או שייקרא הקלט הסטנדרטי (STDIN) עבור ההודעה. כדי לשלוח הודעה המוכלת בקובץ, הקלד את סימן קטן מ- (<) ואחריו את שם הקובץ.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • אם לא תציין שם משתמש או הפעלה, הפקודה msg תציג בפניך הודעת שגיאה. בעת ציון שם הפעלה, יש לציין הפעלה פעילה.
  • על משתמש להיות בעל הרשאת הגישה Send Message כדי לשלוח הודעה.

דוגמאות

כדי לשלוח את ההודעה Let's meet at 1PM today לכל ההפעלות עבור המשתמש MIKES, הקלד:

msg MIKES Let's meet at 1PM today

כדי לשלוח את אותה הודעה להפעלה MODEM02, הקלד:

msg modem02 Let's meet at 1PM today

כדי לשלוח את ההודעה להפעלה 12, הקלד:

msg 12 Let's meet at 1PM today

כדי לשלוח את ההודעה לכל ההפעלות הרשומות בקובץ USERLIST, הקלד:

msg @userlist Let's meet at 1PM today

כדי לשלוח את ההודעה לכל המשתמשים המחוברים, הקלד:

msg * Let's meet at 1PM today

כדי לשלוח את ההודעה לכל המשתמשים, עם זמן קצוב עבור אישור קבלה (לדוגמה, 10 שניות), הקלד:

msg * /TIME:10 Let's meet at 1PM today


Mstsc

יצירת התקשרויות לשרתי מסוף או למחשבים מרוחקים אחרים, עריכת קובץ תצורה קיים של התקשרות לשולחן עבודה מרוחק (Remote Desktop Connection, ‏‎.rdp) והמרת התקשרויות של Windows XP (התקשרויות שנוצרו באמצעות Client Connection Manager) לקבצי ‎.rdp חדשים.

תחביר

mstsc.exe {ConnectionFile|/v:server} [/console] [/f] [/w:width /h:height]‎

mstsc.exe /edit"ConnectionFile"‎

mstsc.exe /migrate

פרמטרים

ConnectionFile
מציין את שם קובץ ‎.rdp עבור ההתקשרות.
‎/v:server
מציין את המחשב המרוחק שאליו ברצונך להתחבר.
‎/console
מתחבר להפעלת המסוף של שרת Windows 2000 שצוין.
‎/f
מפעיל התקשרות לשולחן עבודה מרוחק במצב מסך מלא.
‎/w:width /h:height
מציין את גודלו של מסך שולחן העבודה המרוחק.
‎/edit
פותח את קובץ ‎.rdp שצוין עבור עריכה.
‎/migrate
המרת קבצי התקשרויות מדור קודם שנוצרו באמצעות Client Connection Manager לקבצי התקשרויות חדשים מסוג ‎.rdp

הערות

  • עליך להיות חבר בקבוצה Administrators בשרת שאליו ברצונך מתחבר כדי ליצור התקשרות למסוף מרוחק.
  • קבצי ‎.rdp מאוחסנים עבור כל משתמש כקבצים מוסתרים בספריה המסמכים שלי.


פקודות שאילתה של Terminal Services

לקבלת מידע נוסף אודות פקודות השאילתה של Terminal Services, ראה את הנושאים הבאים:

  • Query Process
  • Query Session
  • Query Termserver
  • Query User


Query process

הצגת מידע אודות תהליכים הפועלים בשרת מסוף. באפשרותך להשתמש בפקודה זו כדי לבדוק מה הן התוכניות שמשתמש ספציפי מפעיל ומי הם המשתמשים המפעילים תוכנית ספציפית.

תחביר

query process ‎[{ *|ProcessID|UserName|SessionName|/id:nn|ProgramName}]‎ ‎[/server:ServerName]‎ ‎[/system]‎

פרמטרים

*
מציג פירוט של התהליכים עבור כל ההפעלות.
ProcessID
מציין את המזהה המספרי המזהה את התהליך שעליו ברצונך לבצע שאילתה.
UserName
מציין את שם המשתמש שברצונך להציג פירוט תהליכים עבורו.
SessionName
מציין את שם ההפעלה שברצונך להציג פירוט תהליכים עבורה.
‎/id:nn
מציין את המזהה של ההפעלה שברצונך להציג פירוט תהליכים עבורה.
ProgramName
מציין את שם התוכנית שעל התהליכים שלה ברצונך לבצע שאילתה. הסיומת ‎.exe נחוצה.
‎/server:ServerName
מציין את שרת המסוף שברצונך להציג פירוט תהליכים עבורו. אם לא צוין שרת, נעשה שימוש בשרת שאליו אתה מחובר כרגע.
‎/system
מציין הצגה של המידע הנוכחי אודות תהליכי מערכת. אם אין ברצונך להציג תהליכי מערכת, אל תשתמש בפרמטר זה.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • לחברי הקבוצה Administrators יש גישה מלאה לכל הפונקציות של query process.
  • אם אינך מציין את הפרמטרים UserName‏, SessionName‏, ‎/id:SessionID‏, ProgramName או *, הפקודה query process מציגה רק את התהליכים השייכים למשתמש הנוכחי.
  • אם ברצונך לציין הפעלה, עליך לציין הפעלה פעילה. באפשרותך להשתמש בתווים כלליים כדי לזהות את התהליך.
  • הפקודה Query process מחזירה את המידע הבא:
    • המשתמש שבבעלותו התהליך
    • ההפעלה שבבעלותה התהליך
    • מזהה ההפעלה
    • שם התהליך
    • מצב התהליך
    • מזהה התהליך
  • כאשר הפקודה query process מחזירה מידע, מוצג סימן קטן מ- (<) לפני כל תהליך השייך להפעלה הנוכחית.


Query termserver

הצגת רשימה של כל שרתי המסוף ברשת.

תחביר

query termserver ‎[ServerName]‎ ‎[/domain:Domain]‎ ‎[/address]‎ ‎[/continue]‎

פרמטרים

ServerName
מציין את השם המזהה את שרת המסוף.
‎/domain:domain
מציין את קבוצת המחשבים שעליה יש לבצע שאילתה עבור שרתי מסוף. אין צורך לציין קבוצת מחשבים אם אתה מבצע שאילתה על הקבוצה שאתה עובד בה כרגע.
‎/address
מציג את הרשת ואת כתובות הצומת עבור כל שרת.
‎/continue
מונע עצירה לאחר כל הצגה של מסך מידע.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • הפקודה Query termserver מבצעת חיפוש ברשת אחר כל שרתי המסוף שחוברו, ומחזירה את המידע הבא:
    • שם השרת.
    • הרשת (וכתובת הצומת אם נעשה שימוש באפשרות ‎/address).

דוגמאות

כדי להציג מידע אודות כל שרתי המסוף ברשת, הקלד:

query termserver

כדי להציג מידע אודות שרת המסוף ששמו server3, הקלד:

query termserver server3

כדי להציג מידע אודות כל שרתי המסוף בקבוצת המחשבים SYSTEM, הקלד:

query termserver /domain:system

כדי להציג את הרשת ואת כתובת הצומת עבור שרת המסוף ששמו server3, הקלד:

query termserver server3 /address


Query session

הצגת מידע אודות הפעלות בשרת מסוף. הרשימה כוללת מידע לא רק אודות הפעלות פעילות, אלא גם אודות הפעלות אחרות שהשרת מפעיל.

תחביר

query session ‎[{SessionName|UserName|SessionID}]‎ ‎[/server:ServerName]‎ ‎[/mode]‎ ‎[/flow]‎ ‎[/connect]‎ ‎[/counter]‎

פרמטרים

SessionName
שם ההפעלה שעליה ברצונך לבצע שאילתה.
UserName
שם המשתמש שעל ההפעלות שלו ברצונך לבצע שאילתה.
SessionID
מזהה ההפעלה שעליה ברצונך לבצע שאילתה.
‎/server:ServerName
מזהה את שרת המסוף שעליו יש לבצע שאילתה. ברירת המחדל היא השרת הנוכחי.
‎/mode
מציג את הגדרות השורה הנוכחיות.
‎/flow
מציג את הגדרות בקרת הזרימה הנוכחיות.
‎/connect
מציג את הגדרות החיבור הנוכחיות.
‎/counter
מציג את מידע המונים הנוכחי, ובכלל זה המספר הכולל של הפעלות שנוצרו, נותקו וחוברו מחדש.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • באפשרותו של משתמש תמיד לבצע שאילתה על ההפעלה שבה הוא עובד ברגע נתון. כדי לבצע שאילתות על הפעלות אחרות, על המשתמש להיות בעל הרשאת הגישה ביצוע שאילתה על מידע.
  • אם אינך מציין הפעלה באמצעות הפרמטרים SessionName‏, UserName או SessionID, הפקודה query session מציגה מידע אודות כל ההפעלות הפעילות במערכת.
  • כאשר הפקודה query session מחזירה מידע, סימן קטן מ- (<) מוצג לפני ההפעלה הנוכחית.

דוגמאות

כדי להציג מידע אודות כל ההפעלות הפעילות בשרת SERVER2, הקלד:

query session /server:SERVER2

כדי להציג מידע אודות ההפעלה הפעילה MODEM02, הקלד:

query session MODEM02

דוגמה לפלט של הפקודה query session:

C:\>query session
 SESSIONNAME    USERNAME       ID STATE  TYPE   DEVICE
>console        administrator   0 active wdcon
 rdp-tcp#1      client1         1 active wdtshare
 rdp-tcp                        2 listen wdtshare
                                4 idle
                                5 idle

הסימן קטן מ- (<) מציין את ההפעלה הנוכחית. SESSIONNAME מציין את השם המוקצה להפעלה. USERNAME מציין את שם המשתמש של המשתמש המחובר להפעלה. STATE מספק מידע אודות המצב הנוכחי של ההפעלה. TYPE מציין את סוג ההפעלה. DEVICE, שאינו מופיע עבור המסוף או עבור ההפעלות המחוברות ברשת, הוא שם ההתקן המוקצה להפעלה. ההערה המופיעה אחרי מידע ההפעלה נלקחת מפרופיל ההפעלה.

כל הפעלות שבהן המצב הראשוני נקבע ל- DISABLED לא יופיעו ברשימת ההפעלות של query session עד שיופעלו.


Query user

הצגת מידע אודות הפעלות משתמש בשרת מסוף.

תחביר

query user ‎[{UserName|SessionName|SessionID}]‎ ‎[/server:ServerName]‎

פרמטרים

UserName
מציין את שם הכניסה של המשתמש שעליו ברצונך לבצע שאילתה.
SessionName
מציין את שם ההפעלה שעליה ברצונך לבצע שאילתה.
SessionID
מציין את מזהה ההפעלה שעליה ברצונך לבצע שאילתה.
‎/server:ServerName
מציין את שרת המסוף שעליו ברצונך לבצע שאילתה. אם לא יצוין שרת, נעשה שימוש בשרת המסוף הנוכחי.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • באפשרותך להשתמש בפקודה זו כדי לבדוק האם משתמש מסוים מחובר לשרת מסוף מסוים. הפקודה Query user מחזירה את המידע הבא:
    • שם המשתמש
    • שם ההפעלה בשרת המסוף
    • מזהה ההפעלה
    • מצב ההפעלה (פעילה או מנותקת)
    • זמן חוסר הפעילות (מספר הדקות מאז ההקשה האחרונה או תנועת העכבר האחרונה בהפעלה)
    • התאריך והשעה שבהם ביצע המשתמש כניסה
  • כדי להשתמש בפקודה query user, עליך להיות בעל ההרשאה Full Control או בעל הרשאת הגישה המיוחדת Query Information.
  • אם אתה משתמש בפקודה query user מבלי לציין שם משתמש, שם הפעלה או מזהה הפעלה, תוחזר רשימה של כל המשתמשים המחוברים לשרת. לחלופין, באפשרותך להשתמש בפקודה query session כדי להציג רשימה של כל ההפעלות בשרת.
  • כאשר הפקודה query user מחזירה מידע, מוצג סימן קטן מ- (<) לפני ההפעלה הנוכחית.
  • הפרמטר ‎/server נדרש רק אם אתה משתמש בפקודה query user משרת מרוחק.

דוגמאות

כדי להציג מידע אודות כל המשתמשים המחוברים למערכת, הקלד:

query user

כדי להציג מידע אודות המשתמש USER1 בשרת SERVER1, הקלד:

query user USER1 /server:SERVER1


Register

רישום תוכנית כך שמוענקים לה מאפייני הפעלה מיוחדים.

תחביר

register FileName ‎[{/system|/user}]‎ ‎[/v]‎

פרמטרים

FileName
מציין את שם הקובץ שברצונך לבצע רישום שלו.
‎/system
רושם את שם הקובץ כמשאב גלובלי של המערכת.
‎/user
רושם את שם הקובץ כמשאב גלובלי של המשתמש.
‎/v
מציג מידע נוסף.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • רק חברים בקבוצה Administrators יכולים להשתמש בפקודה register.
  • על מערכות משנה ויישומים מורכבים מסוימים להיות מופעלים בהקשר גלובלי של המערכת כדי ליצור משאבים המשותפים ליותר מהתחברות אחת.
  • נתוני רישום עבור תוכנית מזוהים רק לאחר התקנת התוכנית. אם תשתמש בפקודה register עבור תוכנית שכבר הותקנה, השינויים ייכנסו לתוקף בפעם הבאה שהתוכנית תותקן.


Reset session

פקודה זו מאפשרת איפוס (מחיקה) של הפעלה משרת המסוף.

תחביר

reset session ‎{SessionName|SessionID}‎ ‎[/server:ServerName]‎ ‎[/v]‎

פרמטרים

SessionName
שמה של ההפעלה שברצונך לאפס. כדי לבדוק מהו שם ההפעלה, השתמש בפקודה query session.
SessionID
מזהה של ההפעלה שיש לאפס.
‎/server:ServerName
מציין את שרת המסוף המכיל את ההפעלה שברצונך לאפס. אם לא יצוין שרת, נעשה שימוש בשרת המסוף הנוכחי.
‎/v
מציג מידע אודות הפעולות המבוצעות.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • תמיד יש באפשרותך לאפס הפעלות שלך, אך עליך להיות בעל הרשאת הגישה Full Control כדי לאפס הפעלות של משתמש אחר.
  • שים לב - איפוס הפעלת משתמש ללא אזהרה עשוי להביא לאובדן נתונים בהפעלה זו.
  • עליך לאפס הפעלה רק כאשר היא מתפקדת בצורה גרועה או כשנוצר הרושם שהפסיקה להגיב.
  • הפרמטר ‎/server נדרש רק אם אתה משתמש בפקודה reset session משרת מרוחק.


Shadow

פקודה זו מאפשרת שליטה מרחוק בהפעלה פעילה של משתמש אחר.

תחביר

shadow ‎{SessionName | SessionID}‎ ‎[/server:ServerName]‎ ‎[/v]‎

פרמטרים

SessionName
שמה של ההפעלה שברצונך לשלוט בה מרחוק.
SessionID
מזהה של ההפעלה שברצונך לשלוט בה מרחוק. השתמש בפקודה query user כדי להציג רשימה של ההפעלות והמזהים שלהן.
‎/server:ServerName
מציין את שרת המסוף המכיל את ההפעלה שברצונך לשלוט בה מרחוק. כברירת מחדל, נעשה שימוש בשרת המסוף הנוכחי.
‎/v
מציג מידע אודות הפעולות המבוצעות.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • באפשרותך להציג הפעלה, או לשלוט בה באופן פעיל. אם תבחר לשלוט על הפעלת משתמש באופן פעיל, יהיה באפשרותך להשתמש במקלדת ובעכבר כדי לבצע פעולות בהפעלה.
  • תמיד יש באפשרותך לשלוט מרחוק בהפעלות שלך (מלבד ההפעלה הנוכחית), אך עליך להיות בעל הרשאת הגישה שליטה מלאה כדי שיהיה באפשרותך לשלוט מרחוק בהפעלה של משתמש אחר.
  • כמו כן, באפשרותך לאתחל שליטה מרחוק באמצעות מנהל שירותי מסוף. לקבלת מידע נוסף, ראה לשם שליטה מרחוק בהפעלה.
  • לפני שפעולת השליטה או הפיקוח מתחילה, השרת מזהיר את המשתמש שההפעלה עומדת בפני שליטה מרחוק, אלא אם האזהרה מבוטלת. ייתכן שההפעלה שלך תיראה קפואה למשך כמה שניות בעודה ממתינה לתגובה מהמשתמש. כדי לקבוע תצורה של בקרה מרחוק עבור משתמשים והפעלות, השתמש בתצורת שירותי מסוף או בהרחבות של שירותי מסוף עבור משתמשים וקבוצות מקומיים ועבור משתמשים ומחשבים של Active Directory.
  • על ההפעלה לתמוך ברזולציית המסך של ההפעלה שברצונך לשלוט בה מרחוק. בכל מקרה אחר, הפעולה תיכשל.
  • לא ניתן לבצע שליטה מרחוק באמצעות הפעלת מסוף, או לשלוט מרחוק בהפעלת מסוף באמצעות הפעלה אחרת.
  • כאשר ברצונך להפסיק שליטה מרחוק (Shadowing), הקש ‎CTRL+*‎ (השתמש ב- * מהמקלדת הנומרית בלבד) או בכל מקש ישיר אחר שהגדרת. מקשים ישירים מוגדרים באמצעות מנהל שירותי מסוף.

דוגמאות

כדי לשלוט בהפעלה 93, הקלד:

shadow 93

כדי לשלוט בההפעלה ACCTG01, הקלד:

shadow ACCTG01


Tscon

חיבור להפעלה אחרת.

תחביר

tscon ‎{SessionID | SessionName}‎ ‎[/dest:SessionName]‎ ‎[/password:pw]‎ ‎[/v]‎

פרמטרים

SessionID
מזהה של ההפעלה שאליה ברצונך להתחבר. אם אתה משתמש בפרמטר האופציונלי ‎/dest:SessionName, זהו המזהה של ההפעלה שאליה ברצונך להתחבר.
SessionName
שם ההפעלה שאליה ברצונך להתחבר.
‎/dest:SessionName
ציון שמה של ההפעלה הנוכחית. הפעלה זו תתנתק כאשר תתחבר להפעלה החדשה.
‎/password:Password
סיסמת המשתמש בעל ההפעלה שאליה אתה מתחבר. הסיסמה נדרשת כאשר המשתמש המתחבר אינו בעל ההפעלה.
‎/v
מציג מידע אודות הפעולות המבוצעות.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • עליך להיות בעל הרשאת הגישה Full Control או בעל הרשאת הגישה המיוחדת Connect כדי להתחבר להפעלה אחרת.
  • הפרמטר ‎/dest:SessionName מאפשר לך לחבר את ההפעלה של משתמש אחר להפעלה אחרת.
  • אם לא תציין סיסמה בפרמטר Password כאשר ההפעלה המהווה יעד אינה שייכת למשתמש הנוכחי, הפקודה tscon תיכשל.
  • לא ניתן להתחבר להפעלת המסוף.

דוגמאות

כדי להתחבר להפעלה 12 בשרת המסוף הנוכחי ולהתנתק מההפעלה הנוכחית, הקלד:

tscon 12

כדי להתחבר להפעלה 23 בשרת המסוף הנוכחי באמצעות הסיסמה mypass ולהתנתק מההפעלה הנוכחית, הקלד:

tscon 23 /password:mypass

כדי לחבר את ההפעלה ששמה TERM03 להפעלה ששמה TERM05 ולאחר מכן לנתק את ההפעלה TERM05 אם היא מחוברת, הקלד:

tscon TERM03 /v /dest:TERM05


Tsdiscon

ניתוק הפעלה משרת מסוף.

תחביר

tsdiscon ‎[{SessionID | SessionName}]‎ ‎[/server:ServerName]‎ ‎[/v]‎

פרמטרים

SessionID
מזהה של ההפעלה שיש לנתק.
SessionName
שמה של ההפעלה שיש לנתק.
‎/server:ServerName
מציין את שרת המסוף המכיל את ההפעלה שברצונך לנתק. אם לא צוין שרת, נעשה שימוש בשרת הנוכחי.
‎/v
מציג מידע אודות הפעולות המבוצעות.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • עליך להיות בעל ההרשאה Full Control כדי לנתק משתמש אחר מהפעלה.
  • אם לא צוינו מזהה או שם הפעלה, הפקודה tsdiscon מנתקת את ההפעלה הנוכחית.
  • כל היישומים שפעלו בעת ניתוק ההפעלה פועלים באופן אוטומטי בעת חיבור מחדש להפעלה זו, ללא אובדן נתונים. השתמש בפקודה Reset session כדי להפסיק את פעולתם של היישומים בהפעלה המנותקת, אך שים לב שהדבר עשוי להתבטא באובדן נתונים בהפעלה.
  • הפרמטר ‎/server נדרש רק אם ברצונך להשתמש בפקודה tsdiscon משרת מרוחק.
  • לא ניתן לנתק את הפעלת המסוף.

דוגמאות

כדי לנתק את ההפעלה הנוכחית, הקלד:

tsdiscon

כדי לנתק את הפעלה 10, הקלד:

tsdiscon 10

כדי לנתק את ההפעלה הנקראת TERM04, הקלד:

tsdiscon TERM04


Tskill

מסיים תהליך.

תחביר

tskill ‎{ProcessID | ProcessName}‎ ‎[/server:ServerName]‎ ‎[{/id:SessionID | /a}]‎ ‎[/v]‎

פרמטרים

ProcessID
מזהה של התהליך שברצונך לסיים.
ProcessName
שמו של התהליך שברצונך לסיים. באפשרותך להשתמש בתווים כלליים כדי לציין פרמטר זה.
‎/server:ServerName
מציין את שרת המסוף המכיל את התהליך שברצונך לסיים. אם לא צוין שרת, נעשה שימוש בשרת המסוף הנוכחי.
‎/id:SessionID
מסיים את התהליך הפועל בהפעלה שצוינה.
‎/a
מסיים את התהליך הפועל בכל ההפעלות.
‎/v
מציג מידע אודות הפעולות המבוצעות.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • אלא אם אתה חבר בקבוצה Administrators, באפשרותך להשתמש בפקודה tskill כדי לסיים רק תהליכים השייכים לך. לחברים בקבוצה Administrators יש גישה מלאה לכל הפונקציות של tskill ובאפשרותם לסיים תהליכים הפועלים בהפעלות של משתמשים אחרים.
  • כאשר כל התהליכים הפועלים בהפעלה מסתיימים, ההפעלה מסתיימת אף היא.


Tsprof

העתקת מידע התצורה של המשתמש, המוצג בהרחבות של Terminal Services אל משתמשים וקבוצות מקומיים ואל Active Directory Users and Computers, ממשתמש אחד למשנהו. ניתן להשתמש בפקודה Tsprof גם כדי להגדיר את נתיב הפרופיל עבור משתמש.

תחביר

tsprof /update ‎{/domain:DomainName | /local}‎ ‎/profile:ProfilePath UserName

tsprof ‎/copy ‎{/domain:DomainName | /local}‎‎[/profile:Path]‎ SourceUser DestinationUser

tsprof /q ‎{/domain:DomainName | /local}‎ UserName

פרמטרים

UserName
מציין את שם המשתמש שעבורו ברצונך לעדכן או לבצע שאילתה על נתיב פרופיל השרת.
SourceUser
מציין את שם המשתמש שממנו ברצונך להעתיק את מידע תצורת המשתמש.
DestinationUser
מציין את שם המשתמש שאליו ברצונך להעתיק את מידע תצורת המשתמש.
‎/domain:DomainName
מציין את שם קבוצת המחשבים שעליה חלה הפעולה.
‎/local
מחיל את הפעולה על חשבונות משתמשים מקומיים בלבד.
‎/profile:ProfilePath
מציין את נתיב הפרופיל כפי שמוצג בהרחבות Terminal Services במשתמשים וקבוצות מקומיים וב- Active Directory Users and Computers.
‎/update
מעדכן את מידע נתיב הפרופיל עבור UserName בקבוצת המחשבים DomainName ל- Path.
‎/copy
מעתיק מידע תצורת משתמש מ- SourceUser ל- DestinationUser ומעדכן את מידע נתיב הפרופיל עבור DestinationUser ל- profilepath. על SourceUser ועל DestinationUser להיות מקומיים או בקבוצת המחשבים DomainName.
‎/q
מציג את נתיב הפרופיל הנוכחי של המשתמש שעבורו ברצונך לבצע שאילתה על נתיב פרופיל השרת.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • רק חברים בקבוצה Administrators יכולים להפעיל את הפקודה tsprof.


Tsshutdn

פקודה זו מאפשרת לחברים בקבוצה Administrators לבצע כיבוי או אתחול של שרת מסוף באופן מרוחק. הפקודה מאפשרת גם כיבוי פיזי של השרת אם המחשב תומך בבקרת תוכנה על אספקת חשמל.

תחביר

tsshutdn ‎[WaitTime]‎ ‎[/server:ServerName]‎ ‎[/reboot]‎ ‎[/powerdown]‎ ‎[/delay:LogOffDelay]‎ ‎[/v]‎

פרמטרים

WaitTime
לאחר דיווח למשתמשים, מציין את משך הזמן (בשניות) שיש להמתין לפני ניתוק כל המשתמשים מההפעלות שלהם. ברירת המחדל היא 60 שניות.
‎/server:ServerName
מציין את שרת המסוף שיש לכבות. אם לא יצוין שרת, יכובה שרת המסוף הנוכחי.
‎/reboot
מאתחל מחדש את שרת המסוף לאחר שהסתיימו הפעלות המשתמשים.
‎/powerdown
מנתק את שרת המסוף מהחשמל אם המחשב תומך בבקרת תוכנה על אספקת חשמל.
‎/delay:LogOffDelay
לאחר ניתוק המשתמשים מההפעלות שלהם, מציין את משך הזמן שיש להמתין לפני סיום כל התהליכים וכיבוי שרת המסוף. ברירת המחדל היא 30 שניות.
‎/v
מציג מידע אודות הפעולות המבוצעות.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • עליך להיות בעל הרשאות ניהול כדי להפעיל את הפקודה tsshutdn.
  • השימוש באפשרות כיבוי בתפריט התחלה אינו מומלץ עבור כיבוי שרת מסוף. פעולה זו אינה מדווחת למשתמשים לפני סיום ההפעלות שלהם.
  • לכל ההפעלות המחוברות מקבלות הודעה המציינת שהן עומדות בפני ניתוק. הפעלות בעלות יישומים עם קבצים פתוחים מודיעות למשתמש שעליו לשמור את הקבצים. לאחר הפעלה של פקודת הניתוק, tsshutdn ממתינה במהלך פרק הזמן שצוין (ברירת המחדל היא 30 שניות, הנקבעת באמצעות הפרמטר ‎/delay), לפני סיום כל התהליכים.
  • הפקודה Tsshutdn אינה מבצעת אתחול מחדש לשרת המסוף אלא אם צוינה האפשרות ‎/reboot.


פקודות Terminal Services

לקבלת מידע נוסף, לחץ על פקודה:

  • change logon
  • change port
  • change user
  • cprofile
  • flattemp
  • logoff
  • msg
  • mstsc
  • query process
  • query session
  • query termserver
  • query user
  • register
  • reset session
  • shadow
  • tscon
  • tsdiscon
  • tskill
  • tsprof
  • tsshutdn


Type

הצגת תוכנו של קובץ טקסט. השתמש בפקודה type כדי להציג קובץ טקסט מבלי לערוך בו שינויים.

תחביר

type [Drive:]‎‎[Path]‎ FileName

פרמטרים

‎[Drive:][Path] FileName
פרמטר זה מציין את המיקום ואת השם של הקובץ או של הקבצים שברצונך להציג. בעת ציון של מספר שמות קובץ, יש להפרידם באמצעות רווחים.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • אם אתה משתמש בכונן מסוג NTFS והפרמטר FileName מכיל רווחים, תחום את הטקסט במרכאות (כלומר, "File Name").
  • בעת הצגה של קובץ בינארי או של קובץ שנוצר באמצעות תוכנית, ייתכן שיוצגו על המסך תווים מוזרים, בככל זה תווי הזנת דפים וסימני רצף יציאה. תווים אלה מייצגים קודי בקרה המשמשים בקובץ הבינארי. ככלל, הימנע משימוש בפקודה type לצורך הצגת קבצים בינאריים.

דוגמאות

כדי להציג את התוכן של קובץ הנקרא Holiday.mar, הקלד:

type holiday.mar

כדי להציג תוכן של קובץ ארוך במסך אחד בכל פעם, הקלד:

type holiday.mar | more


Unlodctr

הסרה של שמות מונה Performance (ביצועים) ואת טקסט Explain עבור שירות או מנהל התקן מרישום המערכת.

תחביר

Unlodctr [\\ComputerName] DriverName

פרמטרים

‎[\\ComputerName] DriverName
מסיר את הגדרות השמות של מונה Performance ואת טקסט Explain עבור מנהל התקן או שירות DriverName מרישום המערכת של Windows XP. אם לא תציין את הפרמטר ComputerName, ברירת המחדל עבור ‏Windows XP היא שימוש במחשב הנוכחי.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • אם המידע שברצונך להזין מכיל רווחים, תחום את הטקסט במרכאות (לדוגמה, "Computer Name").

דוגמאות

כדי להסיר את הגדרות הרישום הנוכחיות של Performance ואת טקסט המונה של Explain עבור שירות RSVP במחשב comp1, הקלד:

unlodctr \\comp1 RSVP


Ver

הצגת מספר הגירסה של Windows XP.

תחביר

ver

פרמטרים

‎/?‎
הצגת עזרה בשורת הפקודה.


גרפיקה של Microsoft Windows

Verify

XOX

נושאים קרובים


Vol

הצגה של תווית אמצעי האחסון ושל המספר הסידורי של הדיסק, אם ישנם. מספר סידורי מוצג עבור דיסק שאותחל באמצעות MS-DOS גירסה 4.0, או גירסה מתקדמת יותר.

תחביר

vol [Drive:]‎

פרמטרים

Drive:‎
ציון הכונן המכיל את הדיסק שאת תווית אמצעי האחסון שלו ואת מספרו הסידורי ברצונך להציג.
‎/?‎
הצגת עזרה בשורת הפקודה.


Vssadmin

הצגה, בחלון הפקודה, של הגיבויים הנוכחיים מסוג עותק צל של אמצעי אחסון ושל כל הכותבים והספקים שהותקנו.

תחביר

‎Vssadmin list {shadows [/set= [shadow copy set GUID]] | writers | providers}‎

פרמטרים

‎list shadows [/set= [shadow copy set GUID]]‎
פירוט כל עותקי הצל במערכת, מקובצים לפי המזהה הייחודי הכללי (GUID) עבור ערכת עותקי הצל (קבוצה של עותקי צל שנוצרו באותו זמן).
list writers
פירוט שם, GUID, מצב ומזהה מופע עבור כל כותבי עותקי הצל שהותקנו.
list providers
פירוט שם, סוג, GUID וגירסה של כל ספקי עותקי הצל שהותקנו.
‎/?‎
הצגת עזרה בשורת הפקודה.

דוגמאות

כדי להציג את כל הספקים של עותקי הצל שהותקנו עבור אמצעי אחסון, הקלד את הפקודה הבאה:

vssadmin list providers


Winnt32

התקנה של Windows XP או שדרוג ל- Windows XP. באפשרותך להפעיל את הפקודה winnt32 בשורת הפקודה של מחשב שהותקנו בו Windows 95‏, Windows 98‏, Windows Millennium Edition‏, Windows NT‏, Windows 2000 או Windows XP.

הערה

  • אם אתה מפעיל את הפקודה winnt32 במחשב מבוסס מעבד Itanium, ניתן להפעיל את הפקודה מ- Extensible Firmware Interface ‏(EFI) או מ- Windows XP (לא ממערכת הפעלה מוקדמת יותר). כמו כן, במחשב מבוסס מעבד Itanium, הפקודות ‎/cmdcons and ‎/syspart והאפשרויות הנוגעות לביצוע שדרוגים אינן זמינות.

תחביר

winnt32 ‎[/checkupgradeonly]‎ ‎[/cmd:command_line]‎ ‎[/cmdcons]‎ ‎[/copydir:{i386|ia64}\FolderName]‎ ‎[/copysource:FolderName]‎ ‎[/debug[Level]:[FileName]]‎ ‎[/dudisable]‎ ‎[/duprepare:pathname]‎ ‎[/dushare:pathname]‎ ‎[/m:FolderName]‎ ‎[/makelocalsource]‎ ‎[/noreboot]‎ ‎[/s:SourcePath]‎ ‎[/syspart:DriveLetter]‎ ‎[/tempdrive:DriveLetter]‎ ‎[/udf:id ‎[,UDB_file]]‎ ‎[/unattend[num]:[answer_file]]‎

פרמטרים

‎/checkupgradeonly
בדיקה של המחשב עבור תאימות לשדרוג אל Windows XP.

בעת שימוש באפשרות זו עם הפרמטר ‎/unattend, לא נדרש קלט משתמש. אם לא כן, התוצאות מוצגות על המסך, ובאפשרותך לשמור אותן תחת שם הקובץ שתציין. שם הקובץ המשמש כברירת מחדל הוא Upgrade.txt בתיקיה systemroot.

‎/cmd:command_line
מורה לתוכנית ההתקנה להפעיל פקודה מסוימת לפני השלב הסופי של ההתקנה. הפעלת הפקודה תתבצע לאחר שהמחשב הופעל מחדש ולאחר שתוכנית ההתקנה אספה את מידע התצורה הדרוש, אך לפני סיום ההתקנה.
‎/cmdcons
מתקין את Recovery Console כאפשרות אתחול במחשב מתפקד מבוסס x86. ‏Recovery Console הוא ממשק שורת פקודה שניתן לבצע באמצעותו משימות כגון הפעלה והפסקה של שירותים וגישה לכונן המקומי (בכלל זה כוננים שאותחלו באמצעות NTFS). באפשרותך להשתמש באפשרות ‎/cmdcons רק לאחר שהסתיימה התקנה רגילה.
‎/copydir:{i386|ia64}\FolderName
יוצר תיקיה נוספת בתיקיה שמותקנים בה קבצי Windows XP . הפרמטר Folder_name מתייחס לתיקיה שיצרת כדי להחזיק שינוים עבור האתר שלך בלבד. לדוגמה, עבור מחשבים מבוססי x86, באפשרותך ליצור תיקיה בשם Private_drivers בתוך תיקיית המקור של i386 עבור ההתקנה ולמקם את קבצי מנהלי ההתקנים בתיקיה. לאחר מכן באפשרותך להקליד ‎/copydir:i386\Private_drivers כדי לגרום לתוכנית ההתקנה להעתיק תיקיה זו למחשב שזה עתה הסתיימה בו ההתקנה ולמקם את התיקיה ב- systemroot\Private_drivers. באפשרותך להשתמש בפרמטר ‎/copydir כדי ליצור תיקיות נוספות כרצונך.
‎/copysource:FolderName
יוצר תיקיה זמנית נוספת בתיקיה שהותקנו בה קבצי Windows XP. הפרמטר Folder_name מתייחס לתיקיה שיצרת כדי לאחסן שינויים עבור האתר שלך בלבד. לדוגמה, באפשרותך ליצור תיקיה בשם Private_drivers בתוך תיקיית המקור עבור ההתקנה שלך ולמקם את קבצי מנהלי ההתקנים בתיקיה. לאחר מכן באפשרותך להקליד ‎/copysource:Private_drivers כדי לגרום לתוכנית ההתקנה להעתיק תיקיה זו למחשב שזה עתה הסתיימה בו ההתקנה ולמקם את התיקיה ב- systemroot\Private_drivers. באפשרותך להשתמש בפרמטר ‎/copysource כדי ליצור תיקיות נוספות כרצונך. שלא כתיקיות הנוצרות באמצעות ‎/copydir, תיקיות של ‎/copysource נמחקות עם סיום ההתקנה.
‎/debug[Level]:[FileName]‎
יוצר יומן רישום של איתור באגים ברמה שצוינה, לדוגמה, ‎/debug4:Debug.log. קובץ יומן הרישום המוגדר כברירת מחדל הוא C:\systemroot\Winnt32.log ורמת איתור הבאגים המוגדרת כברירת מחדל היא 2. רמות יומן הרישום הן אלה: 0 מייצג שגיאות חמורות, 1 מייצג שגיאות, 2 מייצג אזהרות, 3 מייצג מידע ו- 4 מייצג מידע מפורט עבור איתור באגים.כל רמה כוללת את הרמות שמתחתיה.
‎/dudisable
מונע פעולה של Dynamic Update. ללא Dynamic Update, תוכנית ההפעלה פועלת רק עם קבצי ההתקנה המקוריים. אפשרות זו תמנע את הפעלת Dynamic Update אפילו אם אתה משתמש בקובץ תשובה ומציין אפשרויות Dynamic Update בקובץ זה.
‎/duprepare:pathname
מבצע הכנות להתקנה של שיתוף כך שניתן יהיה לעשות בו שימוש עם קבצי Dynamic Update שהורדת מאתר האינטרנט של Windows Update. לאחר מכן ניתן יהיה להשתמש בשיתוף זה לשם התקנת Windows XP עבור לקוחות מרובים.
‎/dushare:pathname
מציין שיתוף שאליו הורדת בעבר קבצי Dynamic Update (קבצים מעודכנים לשימוש עם תוכנית ההתקנה) מאתר האינטרנט של Windows Update, ושעליהם הרצת קודם לכן את הפקודה ‎/duprepare:pathname. כאשר פרמטר זה מופעל במחשב לקוח, הוא מציין שהתקנת הלקוח תעשה שימוש בקבצים המעודכנים בשיתוף שצוין ב- ‎pathname.
‎/m:FolderName
מציין כי תוכנית ההתקנה מעתיקה קבצי החלפה ממיקום חלופי. שימוש בפרמטר זה מורה לתוכנית ההתקנה להתחיל את החיפוש במיקום החלופי ולעשות שימוש בקבצים שבמיקום זה, אם קיימים, במקום בקבצים שבמיקום המהווה ברירת מחדל.
‎/makelocalsource
מורה לתוכנית ההתקנה להעתיק את כל קבצי המקור של ההתקנה לדיסק הקשיח המקומי. השתמש בפרמטר ‎/makelocalsource בעת התקנה מתקליטור כדי לאפשר שימוש בקבצי התקנה בשלבי התקנה מאוחרים יותר, שבהם התקליטור אינו זמין.
‎/noreboot
מורה לתוכנית ההתקנה לא להפעיל מחדש את המחשב לאחר שהושלם שלב העתקת הקבצים של תוכנית ההתקנה, כך שיהיה באפשרותך להפעיל פקודה נוספת.
‎/s:Sourcepath
מציין את מיקום המקור של קבצי Windows XP. כדי להעתיק קבצים משרתים מרובים במקביל, הקלד את האפשרות‎/s:SourcePath מספר פעמים (עד שמונה). אם אתה מקליד את האפשרות מספר פעמים, על השרת הראשון שצוין להיות זמין או שתוכנית ההתקנה תיכשל.
‎/syspart:DriveLetter
במחשב מבוסס x86, מציין כי באפשרותך להעתיק את קבצי ההפעלה של תוכנית ההתקנה לדיסק הקשיח, לסמן את הדיסק כפעיל ולאחר מכן להתקין את הדיסק במחשב אחר. בעת הפעלה של אותו מחשב, המחשב יופעל אוטומטית בשלב הבא של תוכנית ההתקנה. בפרמטר ‎/tempdrive יש להשתמש תמיד עם הפרמטר ‎/syspart. באפשרותך להשתמש בפקודה Winnt32 עם האפשרות ‎/syspart במחשב מבוסס x86 שפועל בו Windows NT 4.0‏, Windows 2000 או Windows XP. לא ניתן להשתמש בפקודה במחשב שפועלים בו Windows 95‏, Windows 98 או Windows Millennium Edition.
‎/tempdrive:DriveLetter
מורה לתוכנית ההתקנה למקם קבצים זמניים במחיצה שצוינה. בהתקנה חדשה, Windows XP יותקן אף הוא במחיצה שצוינה. בעת ביצוע שדרוג, האפשרות ‎/tempdrive משפיעה רק על מיקום הקבצים הזמניים; מערכת ההפעלה תשודרג במחיצה שממנה תפעיל את הפקודה winnt32.
‎/udf:id [,UDB_file]‎
ציון של מזהה (id) המשמש את תוכנית ההתקנה לציון האופן שקובץ מסוג Uniqueness Database ‏(UDB) עורך שינויים בקובץ תשובות (ראה הערך ‎/unattend). ‏UDB עוקף ערכים בקובץ התשובות והמזהה קובע אילו ערכים של קובץ ה- UDB יהיו בשימוש. לדוגמה, ‎/udf:RAS_user,Our_company.udb עוקף את ההגדרות שצוינו עבור המזהה RAS_user בקובץ Our_company.udb. אם לא צוינה האפשרות UDB_file, תוכנית ההתקנה תציג בפני המשתמש בקשה להכנסת תקליטון המכיל את הקובץ ‎$Unique$.udb.
‎/unattend
מבצע שדרוג הגירסה הקודמת של Windows 98‏, Windows Millennium Edition‏, Windows NT 4.0 אוWindows 2000 במצב התקנה ללא התערבות.כל הגדרות המשתמש נלקחות מההתקנה הקודמת, כך שאין צורך בפעולות משתמש במהלך פעולתה של תוכנית ההתקנה.
‎/unattend[num]:[answer_file]‎
מבצע התקנה מחדש במצב התקנה ללא השגחה. קובץ התשובות (answer_file) שצוין מספק לתוכנית ההתקנה את המפרטים המותאמים אישית שלך. Num הוא מספר השניות החולף בין סיום העתקת הקבצים באמצעות תוכנית ההתקנה לבין הפעלה מחדש של המחשב על-ידי תוכנית זו. באפשרותך להשתמש באפשרות num בכל מחשב שפועלים בו Windows 98‏, Windows Millennium Edition‏, Windows NT‏, Windows 2000 או Windows XP.

שימוש באפשרות שורת הפקודה ‎/unattend כדי להפוך את ההתקנה לאוטומטית פירושו שקראת וקיבלת את תנאי הסכם הרישיון של Microsoft עבור Windows XP. לפני שימוש באפשרות זו בעת התקנה של Windows XP בארגון שאינך חבר בו, יש לוודא כי משתמש הקצה (בין אם משתמש פרטי או ישות בודדת) קיבל לידיו את הסכם הרישיון של Microsoft עבור Windows XP, קרא אותו והסכים לתנאיו. יצרני ציוד מקורי (OEM) אינם מורשים לציין מפתח זה במחשבים הנמכרים למשתמשי הקצה.


Winnt

ביצוע התקנה של Windows XP או שדרוג ל- Windows XP. אם ברשותך חומרה התואמת ל- Windows XP, באפשרותך להפעיל את הפקודה winnt בשורת הפקודה של Windows 3.x או של MS-DOS .

תחביר

winnt ‎[/s:SourcePath]‎ ‎[/t:TempDrive]‎ ‎[/u:answer file]‎‎[/udf:ID [,UDB_file]]‎ ‎[/r:folder]‎‎[/rx:folder]‎‎[/e:command]‎‎[/a]‎

פרמטרים

‎/s:SourcePath
מציין את מיקום המקור של קבצי Windows XP. על המיקום להיות נתיב מלא בצורה x:\[Path]‎ או ‎\\server\share[‎\Path]‎.
‎/t:TempDrive
מורה לתוכנית ההתקנה למקם קבצים זמניים בכונן שצוין ולהתקין את Windows XP באותו כונן. אם לא תציין מיקום, תוכנית ההתקנה תבצע ניסיון לאתר כונן עבורך.
‎/u:‎answer file
ביצוע התקנה ללא השגחה באמצעות קובץ תשובות. קובץ התשובות מספק תשובות עבור חלק מהבקשות המוצגות במהלך ההתקנה בפני משתמש הקצה, או עבור כל אותן בקשות. אם השתמשת בפרמטר ‎/u, עליך להשתמש גם בפרמטר ‎/s.
‎/udf:ID [,UDB_file]‎
ציון של מזהה (ID) המשמש את תוכנית ההתקנה לציון האופן שבו יבצע קובץ Uniqueness Database ‏(UDB) שינויים בקובץ תשובות (ראה ‎/u). ‏UDB עוקף ערכים בקובץ התשובות והמזהה קובע באילו ערכים בקובץ UDB יש להשתמש. אם לא צוין UDB_file, תוכנית ההתקנה תציג בקשה להכנסת תקליטון המכיל את הקובץ ‎$Unique$.udb.
‎/r:‎folder
ציון תיקיה אופציונלית שיש להתקין. התיקיה נשארת בדיסק הקשיח לאחר סיום ההתקנה.
‎/rx:‎folder
ציון תיקיה אופציונלית שיש להעתיק. התיקיה נמחקת לאחר סיום ההתקנה.
‎/e:‎command
מורה לתוכנית ההתקנה להפעיל פקודה מסוימת לפני השלב הסופי של ההתקנה.
‎/a
הפיכת אפשרויות הנגישות לזמינות.
‎/?‎
הצגת עזרה בשורת הפקודה.


Xcopy

העתקה של קבצים ושל ספריות, כולל ספריות משנה.

תחביר

xcopy Source [Destination]‎ ‎[/w]‎ ‎[/p]‎ ‎[/c]‎ ‎[/v]‎ ‎[/q]‎ ‎[/f]‎ ‎[/l]‎ ‎[/g]‎ ‎[/d[:mm-dd-yyyy]]‎ ‎[/u]‎ ‎[/i]‎ ‎[/s [/e]]‎ ‎[/t]‎ ‎[/k]‎ ‎[/r]‎ ‎[/h]‎ ‎[{/a|/m}]‎ ‎[/n]‎ ‎[/o]‎ ‎[‎/x]‎ ‎[/exclude:file1[+[file2]][+[file3]]‎ ‎[{/y|/-y}]‎ ‎[/z]‎

פרמטרים

Source
נדרש. פרמטר זה מציין את המיקום ואת השמות של הקבצים שברצונך להעתיק. על פרמטר זה לכלול כונן או נתיב.
Destination
מציין את היעד של הקבצים שברצונך להעתיק. פרמטר זה עשוי לכלול אות כונן ונקודותיים, שם ספריה, שם קובץ או שילוב של שלושתם.
‎/w
הצגת ההודעה שלהלן והמתנה לתגובה לפני התחלה בפעולת ההעתקה של קבצים:

Press any key to begin copying file(s)‎

‎/p
הצגת בקשה לאישור עבור יצירה של כל קובץ יעד.
‎/c
התעלמות משגיאות.
‎/v
בדיקה של כל קובץ בעת כתיבתו לקובץ היעד כדי לוודא כי קבצי היעד זהים לקבצי המקור.
‎/q
מונע הצגה של הודעות xcopy.
‎/f
הצגה של שם קובץ המקור ושל שם קובץ היעד במהלך ההעתקה.
‎/l
מציג רשימה של הקבצים שעומדים להיות מועתקים.
‎/g
יוצר קבצי מקור מפוענחים.
‎/d[:mm-dd-yyyy]‎
העתקה של קבצי מקור ששונו בתאריך שצוין או אחריו בלבד. אם אינך כולל ערך mm-dd-yyyy, הפקודה xcopy מעתיקה את כל קבצי Source החדשים יותר מקבצי Destination הקיימים. אפשרות שורת פקודה זו מאפשרת לעדכן רק קבצים ששונו.
‎/u
מעתיק רק קבצי Source הקיימים ב- Destination.
‎/i
אם Source הוא ספריה או מכיל תווים כלליים ו- Destination אינו קיים, הפקודה xcopy מניחה ש- Destination מציין שם ספריה ויוצרת ספריה חדשה. לאחר מכן, הפקודה xcopy מעתיקה את כל הקבצים שצוינו לספריה החדשה. כברירת מחדל, xcopy מבקש ממך לציין האם Destination הוא קובץ או ספריה.
‎/s
מעתיק ספריות וספריות משנה, אלא אם כן הן ריקות. אם תשמיט את הפרמטר ‎/s, פעולת הפקודה xcopy תתבצע בספריה בודדת.
‎/e
מעתיק את כל ספריות המשנה, גם אם הן ריקות. השתמש בפרמטר ‎/e עם אפשרויות שורת הפקודה ‎/s ו- ‎/t.
‎/t
מעתיק את מבנה ספריית המשנה (העץ) בלבד, ללא קבצים. כדי להעתיק ספריות ריקות, יש לכלול את הפרמטר ‎/e.
‎/k
מעתיק קבצים תוך שמירה על התכונה קריאה בלבד (Read-Only) בקבצי היעד, אם תכונה זו קיימת בקבצי המקור. כברירת מחדל, הפקודה xcopy מסירה את התכונה קריאה בלבד.
‎/r
מעתיק קבצי קריאה בלבד (Read-Only).
‎/h
מעתיק קבצים מוסתרים (Hidden) וקבצי מערכת (System). כברירת מחדל, הפקודה xcopy אינה מעתיקה קבצים מוסתרים או קבצי מערכת.
‎/a
מעתיק רק קבצי מקור שהוגדרה עבורם התכונה ארכיון (Archive).הפרמטר ‎/a אינו גורם לשינוי התכונה ארכיון של קובץ המקור. לקבלת מידע אודות אופן קביעת התכונה ארכיון עבור קובץ באמצעות הפקודה attrib, ראה נושאים קרובים.
‎/m
מעתיק רק קבצי מקור שהוגדרה עבורם התכונה ארכיון (Archive). שלא כמו הפרמטר ‎/a, הפרמטר ‎/m מבטל את תכונת הארכיון עבור קבצי המקור שצוינו. לקבלת מידע אודות אופן קביעת התכונה ארכיון עבור קובץ באמצעות הפקודה attrib, ראה נושאים קרובים.
‎/n
יוצר עותקים באמצעות שמות קובץ או ספריה קצרים של NTFS. הפרמטר ‎/n נחוץ בעת העתקה של קבצים או של ספריות מאמצעי אחסון של NTFS לאמצעי אחסון של FAT או כאשר יש להשתמש בשיטת מתן השמות של מערכת הקבצים FAT ‏(8.3 תווים)‎ באמצעי האחסון של קובץ היעד. מערכת הקבצים של קובץ היעד עשויה להיות FAT או NTFS.
‎/o
מעתיק מידע אודות בעלות של קובץ ורשימת בקרת גישה על-פי שיקול דעת (DACL).
‎/x
מעתיק מידע אודות הגדרות ביקורת של קובץ ורשימת בקרת גישה למערכת (SACL) (מכיל את הפרמטר ‎/o).
‎/exclude:filename1[+[filename2]][+[filename3]]‎
מציין רשימה של קבצים הכוללת מחרוזות.
‎/y
מונע את הצגת הבקשה שמטרתה לוודא אם ברצונך להחליף קובץ יעד קיים.
‎/-y
מציג בקשה לאישור החלפה של קובץ יעד קיים.
‎/z
העתקה דרך רשת במצב המאפשר הפעלה מחדש.
‎/?‎
הצגת עזרה בשורת הפקודה.

הערות

  • שימוש בפרמטר ‎/v

    XOX

  • שימוש בפרמטר ‎/exclude

    ציין כל מחרוזת בשורה נפרדת בכל קובץ. אם מחרוזת כלשהי שצוינה תואמת חלק כלשהו של הנתיב המוחלט של הקובץ שיש להעתיק, קובץ זה אינו נכלל בתהליך ההעתקה. לדוגמה, אם תציין את המחרוזת "\Obj\", אתה מבטל את הכללת כל הקבצים בספריה Obj. אם תציין את המחרוזת "‎.obj", תימנע הכללת כל הקבצים בעלי הסיומת ‎.obj בפעולת ההעתקה.

  • שימוש בפרמטר ‎/z

    אם אתה מאבד את החיבור במהלך שלב ההעתקה (לדוגמה, אם השרת עובר למצב לא מקוון וקוטע את ההתקשרות), ההעתקה נמשכת לאחר יצירה מחדש של החיבור. שימוש בפרמטר ‎/z מציג גם את האחוז של פעולת ההעתקה שהושלמה עבור כל קובץ.

  • שימוש בפרמטר ‎/y במשתנה הסביבה COPYCMD

    באפשרותך להשתמש בפרמטר ‎/y במשתנה הסביבה COPYCMD. באפשרותך לעקוף הגדרה זו על-ידי שימוש בפרמטר ‎/-y בשורת הפקודה. כברירת מחדל, מופיעה בקשה להחלפה, אלא אם כן הפעלת את הפקודה copy מתוך קובץ Script של אצווה.

  • העתקת קבצים מוצפנים

    העתקת קבצים מוצפנים לאמצעי אחסון שאינו תומך ב- EFS מביאה ליצירת שגיאה. ראשית פענח את הקבצים או העתק אותם לאמצעי אחסון התומך ב- EFS.

  • צירוף קבצים

    כדי לצרף קבצים, ציין קובץ בודד כיעד אך מספר קבצים כמקור (תוך שימוש בתווים כלליים או בתבנית file1+file2+file3).

  • ערך ברירת מחדל עבור Destination

    אם תשמיט את Destination, הפקודה xcopy מעתיקה את הקבצים לספריה הנוכחית.

  • קביעה אם Destination הוא קובץ או ספריה

    אם Destination אינו מכיל תיקיה קיימת ואינו מסתיים בקו נטוי הפוך (\), מופיעה ההודעה הבאה:

    Does destination specify a file name
    or directory name on the target
    ‎(F = file, D = directory)?‎

    הקש F אם ברצונך שהקובץ או הקבצים יועתקו לקובץ. הקש D אם ברצונך שהקובץ או הקבצים יועתקו לספריה.

    באפשרותך למנוע הצגה של הודעה זו על-ידי שימוש באפשרות שורת הפקודה ‎/i, הגורמת לפקודה xcopy להניח שהיעד הוא ספריה אם המקור הוא יותר מקובץ אחד או ספריה אחת.

  • שימוש בפקודה xcopy כדי לקבוע תכונת ארכיון עבור קבצי Destination

    הפקודה xcopy יוצרת קבצים עם תכונת הארכיון (Archive), בין אם תכונה זו הוגדרה עבור קובץ המקור ובין אם לאו. לקבלת מידע נוסף אודות תכונות קובץ והפקודה Attrib, ראה נושאים קרובים.

  • השוואה בין xcopy ו- diskcopy

    אם ברשותך דיסק המכיל קבצים בספריות משנה וברצונך להעתיק אותו לדיסק בעל תבנית שונה, עליך להשתמש בפקודה xcopy במקום בפקודה diskcopy. מאחר שהפקודה diskcopy גורמת להעתקת דיסקים רצועה אחרי רצועה, על דיסק המקור ודיסק היעד להיות בתבנית זהה. לפקודה xcopy אין דרישה כזו. השתמש בפקודה xcopy, אלא אם ברצונך לקבל עותק מלא של תמונת דיסק.

  • קודי יציאה של xcopy

    כדי לעבד קודי יציאה שהוחזרו על-ידי הפקודה xcopy, השתמש בפרמטר errorlevel בשורת הפקודה if בתוכנית אצווה. לקבלת דוגמה של תוכנית אצווה המעבדת קודי יציאה באמצעות if, ראה נושאים קרובים. הטבלה הבאה מפרטת כל קוד יציאה ותיאור.

    קוד יציאה | תיאור
    0 | קבצים הועתקו ללא שגיאה.
    1 | לא נמצאו קבצים להעתקה.
    2 | המשתמש הקיש CTRL+C כדי לסיים את פעולת xcopy.
    4 | אירעה שגיאת אתחול. מחסור בזיכרון או בשטח דיסק, או שהוזן בשורת הפקודה שם כונן לא חוקי או תחביר לא חוקי.
    5 | אירעה שגיאה של כתיבה לדיסק.

דוגמאות

כדי להעתיק את כל הקבצים וספריות המשנה (כולל ספריות משנה ריקות) מכונן A לכונן B, הקלד:

xcopy a: b: /s /e

כדי לכלול קבצי מערכת (System) או קבצים מוסתרים (Hidden) כלשהם בדוגמה הקודמת, הוסף את אפשרות שורת הפקודה ‎/h, כמתואר להלן:

xcopy a: b: /s /e /h

כדי לעדכן קבצים בספריה ‎\Reports באמצעות הקבצים שבספריה ‎\Rawdata שעברו שינוי לאחר ה- 29 בדצמבר 1993, הקלד:

xcopy \rawdata \reports /d:12-29-1993

כדי לעדכן את כל הקבצים הקיימים בספריה ‎\Reports בדוגמה הקודמת, ללא תלות בתאריך, הקלד:

xcopy \rawdata \reports /u

כדי לקבל רשימה של הקבצים שהיו מועתקים באמצעות הפקודה הקודמת מבלי להעתיק קבצים אלה בפועל, הקלד:

xcopy \rawdata \reports /d:12-29-1993 /l > xcopy.out

הקובץ Xcopy.out מכיל פירוט של כל הקבצים שהיו מועתקים.

כדי להעתיק את הספריה ‎\Customer ואת כל ספריות המשנה שלה לספריה ‎\\Public\Address בכונן הרשת H:‎ תוך שמירה על התכונה קריאה בלבד (Read-Only) וקבלת בקשות לאישור יצירה של קבצים חדשים ב- H:‎, הקלד:

xcopy \customer h:\public\address /s /e /k /p

כדי להפעיל את הפקודה הקודמת, לוודא שהפקודה xcopy יוצרת את הספריה ‎\Address אם זו איננה קיימת ולמנוע את הופעת ההודעה המופיעה בעת יצירת ספריה חדשה, הוסף את אפשרות שורת הפקודה ‎/i כפי שמתואר להלן:

xcopy \customer h:\public\address /s /e /k /p /i

באפשרותך ליצור תוכנית אצווה כדי לבצע פעולות xcopy ולהשתמש בפקודת האצווה if עבור עיבוד של קוד היציאה במקרה של שגיאה. לדוגמה, תוכנית האצווה שלהלן עושה שימוש בפרמטרים ברי-החלפה עבור פרמטרי המקור ועבור פרמטרי היעד של xcopy:

@echo off
rem COPYIT.BAT transfers all files in all subdirectories of
rem the source drive or directory (%1) to the destination

rem drive or directory (%2)

xcopy %1 %2 /s /e

if errorlevel 4 goto lowmemory
if errorlevel 2 goto abort
if errorlevel 0 goto exit

:lowmemory
echo Insufficient memory to copy files or
echo invalid drive or command-line syntax.
goto exit

:abort
echo You pressed CTRL+C to end the copy operation.
goto exit

:exit

כדי להשתמש בתוכנית אצווה זו להעתקת כל הקבצים שבספריה C:\Prgmcode ובספריות המשנה שלה לכונן B, הקלד:

copyit c:\prgmcode b:‎

מתרגם הפקודה מחליף את %1 ב- C:\Prgmcode ואת %2 ב- B: ולאחר מכן משתמש בפקודה xcopy עם אפשרויות שורת הפקודה ‎/e ו- ‎/s. אם הפקודה xcopy נתקלת בשגיאה, תוכנית האצווה קוראת את קוד היציאה, עוברת לתווית שצוינה בהצהרת IF ERRORLEVEL המתאימה ולאחר מכן מציגה את ההודעה המתאימה ומבצעת יציאה מתוכנית האצווה.